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Practical Programs – Hand Book

COMPUTER APPLICATION PRACTICAL 11

Instructions: 

1. One exercise from Writer, Calc and CSS, Three exercises from HTML, and 
Four exercises from JavaScript   are     to be practiced in the practical classes.

2. Ansewer to any one question from Practical Book with internal choice 

3. Distribution of Marks 

I. Internal Assessment:            5 Marks

Record Book 5 Marks

II. External Assessment:           15 Marks

(a) Writer or Calc                            –  Procedure 

      HTML or CSS or JavaScript     –  Coding
10 Marks

(b) Execution & Output 5 Marks

Total 20 Marks
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CA1 – FORMATTING INVOICE

CA-1
Type the following Invoice in OpenOffice Writer and apply the formatting 
features as given below:

Invoice
SAIRAM MEDICAL STORES

Mobile No      : 9002416000
Mail Address  : sairam@gmail.com

P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

23rd Nov 2017

No: 70/162

M/s.  Eswari Medical Stores,
 No: 72, N.S.C. Bose Road, 
 Puduchery - 6210110

For Sriram Medical Stores

Sales Manager

Quantity (Nos) Particulars Rate Amount
20 Johnson Baby Powder 25 500
10 Nestle Milk Powder 100 1000
5 Wood Wards Gripe Water 70 350

Total
Add: GST @ 3%

Net Payable

•	 Use	formula	to	calculate	Total	and	Net	Payable

Procedure

 Step-1. OpenOffice Writer and choose Text document or File → New → Text Docu-
ment.

 Step-2. Type the text and apply the format as per the given format.
Note: Select the required text before formatting.

Text Format Method

INVOICE Center and apply red Ctrl + E and choose Red color from 
font color pallete or any method.

SAIRAM MEDICAL 
STORES

Center and apply blue Ctrl + E and Blue color from font 
color pallete or any method.
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Eswari Medical 
Stores

Bold Ctrl + B or any method.

 Step-3 Create a table using any one of the method Ctrl + F12   or   Insert → Table or 
Table → Insert → Table or Insert Table icon from toolbar. with 4 columns and 7 rows

 Step–4. Enter the data as per the given format.

 Step-5. Select first three columns in 5th Row and Right Click  →  Cell →  Merge and 
type as "Total"

 Step-6. Repeat Step-5 for 7th Row, and type as "Net payable"

 Step-7. To find the Total, Enter the following formula at Total → Amount Column as  
=<D2>+<D3>+<D4> OR = Sum (<D2:D4>)

 Step-8. To find the GST @ 3% Enter the formula as = <B> *0.03

 Step-9. To calculate Netpayable amount, Enter the formula as =<B5>+<D6>
Output

Invoice
SAIRAM MEDICAL STORES

Mobile No      : 9002416000
Mail Address  : sairam@gmail.com

P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

23rd Nov 2017

No: 70/162

M/s.  Eswari Medical Stores,
 No: 72, N.S.C. Bose Road, 
 Puduchery - 6210110

For Sriram Medical Stores

Sales Manager

Quantity (Nos) Particulars Rate Amount
20 Johnson Baby Powder 25 500
10 Nestle Milk Powder 100 1000
5 Wood Wards Gripe Water 70 350

Total 1850
Add: GST @ 3% 55.5

Net Payable 1905.5
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CA2 -  INTEREST CALCULATION

CA-2
Create statement of interest using OpenOffice Calc with the following partic-
ulars:

 Sara Ltd., sells goods. Their policy is to charge interest @ 2% p.a., for the number of 
days. From the following data, find out the amount to be collected from each customer. 
Assume 365 days in the year.

Customer Sales Date of Sale NO. of days Date of 
settlement

Tharani 25000 10/04/2017 60
Mahalakshmi 14000 28/05/2017 30
Kumar 28000 14/07/2017 45
Arulmozhi 54000 03/08/2017 90

Procedure

Step -1. Open OpenOffice Calc and choose Spreadsheet or File →  New → Spreadsheet.
Step -2. Type the Headings in cell A1 to E1 (Customer, Sales, Date of Sale, Number of days 

and Date of settlement) as per the given data.
Step -3. In cell F1 and G1 type (Interest Amt and Amount to be paid) respectively.
Step -4. In cell E2 enter the formula = C2 + D2 to arrive the date of settlement and to the 

remaining cells (E3 to E5). Use Edit → Fill → Down command
Step -5. In cell F2 enter the formula =ROUND((B2*2/100)*D2/365) to arrive the Interest 

amount to the remaining cells (F3 to F5). Use Edit → Fill → Down command
Step -6. In cell G2 enter the formula = B2 + F2 to arrive the Amount to be paid to the remaining 

cells (G3 to G5). Use Edit → Fill → Down command

Output
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CA3 – FORM DESIGN

CA-3 Write an HTML code to design a form like the one shown below. 

Coding

<html>

<head>

<title>	User	Registration	</title>

</head>

<body>

<h1 align = center> Registration Form </h1>

<form id=reg_form  method = post  action = " ">

User	Name:	<input	type	=	text		name=uname	/>	<br><br>

Password: <input type = password name=pword1 /> <br><br>

Re-type Password: <input type = password name=pword2 /> <br><br>

Gender: 

<input type = radio  name=male value="M" /> Male
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<input type = radio  name=female  value="F" /> Female

<h2 align=center> Additional Information </h2>

Optional Subject: 

<select name=subj>

 <option value = CT> Computer Technology

 <option value = Paint> Painting

 <option value = SG> Sports and Games

</select>

<br><br/>

<input type  = checkbox  name=mail />  Put me on mail list <br> <br> 

<input type = reset  value=Reset />

<input type = submit  value=Submit /> 

</form>

</body>

</html>
Output
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CA4 - HEIGHT AND WEIGHT TABLE

CA-4 Write an HTML code to display the following.

Height and Weight

Name Class Height Weight
Mani XII - G 5'0" 45
Vasu XI - H 5'4" 49
Murali XI - B 5'1" 51
Pallavai XII - D 4'5" 50

Coding

<html>

<head>

<title> Height and Weight Table </title>

<head>

<body>

<table border=10>

<caption> Height and Weight </caption>

<tr> 

<th width=40%> Name </th>

<th width=20%> Class </th>

<th width=20%> Height </th>

<th width=20%> Weight </th>

</tr>

<tr> 

<td> Mani </td>

<td> XII – G </td>

<td> 5’0” </td>

<td> 45 </td>
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</tr>

<tr> 

<td> Vasu </td>

<td> XI – H </td>

<td> 5’4” </td>

<td> 49 </td>

</tr>

<tr> 

<td> Murali </td>

<td> XI – B </td>

<td> 5’1” </td>

<td> 51 </td>

</tr>

<tr> 

<td> Pallavai </td>

<td> XII - D </td>

<td> 4’5” </td>

<td> 50 </td>

</tr>

</table>  

</body>

</html>
Output

Height and Weight

Name Class Height Weight
Mani XII - G 5'0" 45
Vasu XI - H 5'4" 49
Murali XI - B 5'1" 51
Pallavai XII - D 4'5" 50
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CA5 - NESTED LIST 

CA-5
Write an HTML code to create a webpage to display the following sets of 
lists:

1. Tamilnadu
a. Chennai
b. Madurai

•	Languages
o  Tamil
o  Malayalam
o  Telugu

2. Andhra Pradesh
a. Amaravathi
b. Vijayawada

•	Science
o   Physics
o  Chemistry
o  Zoology

3. Kerala
a. Thiruvananthapuram
b. Cochin

•	Humanities
o   History
o  Commerce
o  Economics

Coding

<html>
<head>
<title> Sets of Lists </title>
</head>
<body>
<OL>
 <LI> Tamilnadu
  <OL type=a>
   <LI> Chennai
   <LI> Madurai
  </OL>
 <LI> Andhra Pradesh
  <OL type=a>
   <LI> Amaravathi
   <LI> Vijayawada
  </OL>
 <LI> Kerala
  <OL type=a>
   <LI> Thiruvanandhapuram
   <LI> Cochin
  </OL>
</OL>
<UL>
 <LI> Languages
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	 	 <UL	type=circle>
   <LI> Tamil
   <LI> Malayalam
   <LI> Telugu
	 	 </UL>
 <LI> Science
	 	 <UL	type=circle>
   <LI> Physics
   <LI> Chemistry
   <LI> Zoology
	 	 </UL>
 <LI> Humanities
	 	 <UL	type=circle>
   <LI> History
   <LI> Commerce
   <LI> Economics
	 	 </UL>
</UL>
</body>
</html>

Output

1. Tamilnadu
a. Chennai
b. Madurai

2. Andhra Pradesh
a. Amaravathi
b. Vijayawada

3. Kerala
a. Thiruvananthapuram
b. Cochin

•	Languages
o  Tamil
o  Malayalam
o  Telugu

•	Science
o   Physics
o  Chemistry
o  Zoology

•	Humanities
o   History
o  Commerce
o  Economics
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CA6 -  FORMATTING WEBPAGE 

CA-6 Create a webpage as given description using CSS

Tamil

 Tamil is a Dravidian language predominantly spoken by the Tamil people of India 
and Sri Lanka, and by the Tamil diaspora, Sri Lankan Moors, Burghers, Douglas, and 
Chindians. Tamil is an official language of two countries: Sri Lanka and Singapore. 

	 It	has	official	status	in	the	Indian	state	of	Tamil	Nadu	and	the	Indian	Union	Territory	
of Puducherry. It is used as one of the languages of education in Malaysia, along with 
English, Malay and Mandarin. 

 Tamil is spoken by significant minorities in the four other South Indian states of 
Kerala,	Karnataka,	Andhra	Pradesh	and	Telangana	and	the	Union	Territory	of	the	Andaman	
and Nicobar Islands. It is one of the 22 scheduled languages of India.

Description:

Element Font Style Alignment Color

H1 Arial Black - Center Border 2px 
solid blue

P1 Century Bold - Red

P2 Boockman Old Style Italic - Blue

P3 Century Gothic - - Green

Note: Create two files. 1. Mystyle.css and 2. CA6.html

Coding -1

Mystyle.css

H1

{

  font-family: "Arial Black";

  text-align:center;

  border : 2px solid blue;

}
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P1

{

 font-family: "Century";

 font-style : Bold;

 color : Red;

}

P2

{

 font-family: "Bookman Old Style";

 font-style : Italic;

 color : Blue;

}

P3

{

 font-family: "Century Gothic";

 color : Green;

}

Coding -2

CA6.htm

<html>

<head>

<title> Tamil </title>

<link rel="stylesheet" type="text/css" href="mystyle.css">

</head>

<body>

<H1> Tamil </H1>

<P1>

Tamil is a Dravidian language predominantly spoken 

by the Tamil people of India and Sri Lanka, and by the 

Tamil diaspora, Sri Lankan Moors, Burghers, Douglas, 

and Chindians. Tamil is an official language of two countries: 

Sri Lanka and Singapore.
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</P1>

<br>

<P2>

It has official status in the Indian state of Tamil Nadu 

and	the	Indian	Union	Territory	of	Puducherry.	

It is used as one of the languages of education in Malaysia, 

along with English, Malay and Mandarin.

</P2>

<br>

<P3>

Tamil is spoken by significant minorities in the four other 

South Indian states of Kerala, Karnataka, Andhra Pradesh 

and	Telangana	and	the	Union	Territory	of	the	Andaman	and	

Nicobar Islands. It is one of the 22 scheduled languages of 

India.

</P3>

</body>

</html>
Output

Tamil
 Tamil is a Dravidian language predominantly sopken 
by the Tamil people of India and SriLankan Moors, Burghers, 
Douglas, and Chindians. Tamil is an official language of two 
countries: Sri Lanka and Singapore.

 It has official status in the Indian state of Tamil Nadu 
and	the	Indian	Union	Territory	of	Puducherry.	It	is	used	as	one	
of the languages of educatiooon in Malaysia, along with English, 
Malay and Mandarin.

 Tamil is spoken by significant minorities in the four 
other south Indian states of Kerala, Karnataka, Andhra Pradesh 
and	 Telangana	 and	 the	Union	 Territory	 of	 the	 andaman	 and	
Nicobar Islands. It is one of the 22 scheduled languages of India.
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CA7 - DISPLAY  TEXT

CA-7 Create a webpage using JavaScript to display the following text.

Welcome to JavaScript

State Council of Educational Research and Training (SCERT), 

Tamilnadu, Chennai.

Coding 

<html>

<head>

<title> Display text using JavaScript </title>

</head>

<body align=center>

<p> 

<script>

 document.write ("<h1 align=center>Welcome to JavaScript <br>");

 document.write ("State Council of Educational Research and Training (SCERT),<br>");

 document.write ("Tamilnadu, Chennai. </h1>");

</script>

</p>

</body>

</html>
Output

Welcome to JavaScript

State Council of Educational Research and Training (SCERT),

Tamilnadu, Chennai.
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CA8 – MULTIPLICATION TABLE

CA-8 Create a webpage using JavaScript to display multiplication table by prompting 
number of rows and columns.

Coding 

<html>
<head>
  <title>Multiplication Table</title>
  <script type="text/javascript">
    var rows = prompt("How many rows for your multiplication table?");
    var cols = prompt("How many columns for your multiplication table?");
    if(rows == "" || rows == null)
      rows = 10;
    if(cols== "" || cols== null)
      cols = 10;
    createTable(rows, cols);
    function createTable(rows, cols)
    {
      var j=1;
 var output ="<table border='1' width='500' cellspacing='0'cellpadding='5'>";
      for(i=1;i<=rows;i++)
      {
     output = output + "<tr>";
        while(j<=cols)
        {
      output = output + "<td>" + i*j + "</td>";
       j = j+1;
     }
      output = output + "</tr>";
      j = 1;
    }
    output = output + "</table>";
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    document.write(output);
    }
  </script>
</head>
<body>
</body>

</html>
Output

1 2 3 4 5 6
2 4 6 8 10 12
3 6 9 12 15 18
4 8 12 16 20 24
5 10 15 20 25 30
6 12 18 24 30 36
7 14 21 28 35 46
8 16 24 32 40 48
9 18 27 36 45 54
10 20 30 40 50 60
11 22 33 44 55 66
12 24 36 48 60 72
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CA9 - DISPLAY WEEKDAYS IN WORDS

CA-9 Create a webpage using JavaScript to display Weekday in words by getting 
input as a number using switch.

Coding 

<html>
<head>
<title> Weekday </title>
<script type="text/javascript">
var n=prompt("Enter a number between 1 and 7");
switch (n)
{
case (n="1"):
document.write("Sunday");
break;
case (n="2"):
document.write("Monday");
break;
case (n="3"):
document.write("Tuesday");
break;
case (n="4"):
document.write("Wednesday");
break;
case (n="5"):
document.write("Thursday");
break;
case (n="6"):
document.write("Friday");
break;
case (n="7"):
document.write("Saturday");
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break;
default:
document.write("Invalid Weekday");
break;
}
</script>
</head>
</html>

Output

Thursday
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CA10 - LOGIN FORM

CA-10
Create a Form using JavaScript to get username, password and address, 
validate the inputs. 

Coding 

<html>
<head>
<script type="text/javascript">
function sub()
{
if(document.getElementById("t1").value == "")
alert("Please enter your name");
else if(document.getElementById("t2").value == "")
alert("Please enter a password");
else if(document.getElementById("t2").value != document.getElementById("t3").value)
alert("Please enter correct password");
else if(document.getElementById("t4").value == "")
alert("Please enter your address");
else
alert("Form has been submitted");
}
</script>
</head>
<body>
<form>
<p align="center">
User	Name:<input	type="text"	id="t1"><br><br>
Password:<input type="text" id="t2"><br><br>
Confirm Password:<input type="text" id="t3"><br><br>
Address:<textarea rows="2" cols="25" id="t4"></textarea><br><br>
<input type="button" value="Submit" onclick="sub()">
<input type="reset" value="Clear All">
</p>
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</form>
</body>
</html>

Output
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Internal Choice For The Programs

Qno. Question Qno. Question Choice

CA1 Writer - Formatting 
Invoice  

CA6 CSS – Formatting 
Webpage

CA1 or 
CA10

CA2 Calc – Interest 
Calculation  

CA7 JavaScript – Display  
Text

CA2 or 
CA8

CA3 HTML – Form 
Design

CA8 JavaScript – 
Multiplication Table

CA3 or 
CA9

CA4 HTML – Height 
and Weight Table

CA9 JavaScript – Display 
Weekdays in Words

CA4 or 
CA6

CA5 HTML – Nested 
List

CA10 JavaScript – Login 
Form

CA5 or 
CA7
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