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1. Introduction

1.1. Overview

Noise is a serious problem that hinders
high-quality digital image processing. In
digital photography, the consumer- and
prosumer-level cameras produce images with
an easily noticeable noise component. This
component is especially strong in images
shot at high ISO rates. The noise reduces the
visual quality of digital images and resulting
printouts. Some image processing operations,
like sharpening, make quality of noisy images
even worse.

Neat Image is a filter software designed to reduce
visible noise and grain in digital photographic images.

Neat Image detects, analyzes and reduces noise.
Neat Image incorporates the most advanced image
noise reduction algorithms in the industry. The
filtration quality is also higher than that of other
methods because Neat Image takes into account noise
characteristics of particular image acquisition devices,
making the filtration more accurate. Using device
noise profiles, Neat Image adapts itself to almost any
input device – digital camera, scanner, etc.

Online examples of
Neat Image noise reduction:

https://ni.neatvideo.com/

The rich control set of the noise filter allows you to easily achieve the
desired level of noise reduction. In addition, Neat Image can make
images look sharper without degradation of image quality (which is
usually inevitable with noisy images). Smart application of sharpening
based on preceding noise analysis makes such an effect possible.

Neat Image plug-in for Photoshop (Win) is currently produced in three editions: Demo, Home and Pro.
All editions provide top-quality noise reduction and sharpening. The key differences are the following:

• Demo plug-in is a free edition of the software with limited functionality

• Home plug-in processes only 8-bit images and does not support Photoshop actions

• Pro plug-in supports 8-bit, 16-bit and 32-bit images as well as Photoshop actions and smart filters

1.2. Features
Photoshop plug-in

• To selectively apply noise reduction to layers, channels, selections (areas of interest)

• To automate your workflow using Photoshop actions including Neat Image noise reduction

• To enable noise reduction in Photoshop action-based batches

• 32-bit and 64-bit versions of Photoshop and compatible applications are supported

Noise Reduction and Smart Sharpening

• Advanced noise filters to reduce noise and grain in digital images

• Smart sharpening filter to make images look sharper without amplification of noise

• 8-bit, 16-bit and 32-bit image support to fully utilize capabilities of modern image acquisition
devices and support HDR post-processing workflows

• CUDA and OpenCL acceleration to speed up processing using computation-capable GPUs

Device Noise Profiles

• Auto Profile to build noise profiles for your camera or scanner on the fly

• Rich set of pre-built noise profiles in the online profile library

• Auto Match to select the most suitable pre-built noise profiles

Some features are only available in the Home or Pro edition. Detailed feature map (page 58) explains the
differences between Neat Image Demo, Home and Pro editions in details.
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1.3. Requirements

1.3.1. Hardware requirements

System requirements for practical use of Neat Image depend on size of input images. The more system
RAM is available the larger the images that can be handled. The processing speed is determined primarily
by the processor’s number-crunching power (clock frequency, number of cores/processors, cache size),
memory speed and availability of supported computation-capable GPUs.

Recommended system configuration to process photos produced by modern digital cameras:

• Intel i7 / i5 / Xeon / compatible; single or multi-processor

• Windows 10, 8, 7, Vista, XP; 64-bit

Optional CUDA acceleration requires:

• CUDA-capable NVIDIA GPU with compute capability 3.5 or higher;

• Recent video driver supporting CUDA 9 or newer
(you can download the latest versions of the video drivers from
https://www.nvidia.com/Download/index.aspx)

Optional OpenCL acceleration requires:

• Supported AMD video card:


 AMD Radeon HD 7790;


 AMD Radeon R7 250X, 260/265/260X;


 AMD Radeon R7 360/370;


 AMD Radeon R9 255/270/280/285/290; 250X, 270X, 280X, 290X, 295X2;


 AMD Radeon R9 380/390/390X;


 AMD Radeon R9 Fury, R9 Nano, R9 Fury X, Pro Duo;


 AMD Radeon RX 460/470/480;


 AMD Radeon RX 540/540X/550/550X/560/570/580;


 AMD Radeon RX Vega 56/64;


 AMD Radeon Vega Frontier Edition;


 AMD Radeon RX 5300M/5500/5500M;


 AMD Radeon RX 5600/5700/5600 XT/5700 XT;


 AMD Radeon Pro WX 2100/3100/4100/5100/7100/9100;


 AMD Radeon VII;


 Another AMD GPU based on one of the following chip series: Bonaire, Hawaii, Tonga,
Fiji, Ellesmere, Baffin, gfx804, gfx900, gfx901, gfx906, gfx907, gfx1010, gfx1012

• The latest version of AMD Adrenalin driver.

If you experince a problem with the latest version of the driver, please check the known issues
page for possible solutions:

https://ni.neatvideo.com/support/known-issues

You can download the latest and archive versions of AMD Driver from

https://www.amd.com/en/support
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1.3.2. 64-bit plug-in

Recommended OS:

• Windows 10 64-bit, Windows 8 64-bit, Windows 7 64-bit, Vista 64-bit, Windows XP 64-bit

The 64-bit plug-in is compatible with the following plug-in hosts:

• Adobe Photoshop 2022 / 2021 / 2020 / 2019 / CC / CS6 / CS5.x / CS4 (64-bit)

• Adobe Photoshop Elements 2022 / 2021 / 2020 / 2019 / 2018 / 15 / 14 / 13 (64-bit)

• Corel PaintShop Pro 2022 / 2021 / 2020 / 2019 / 2018 / X9 / X8 / X7 / X6 (64-bit)

• Corel PHOTO-PAINT 2021 / 2020 / 2019 / 2018 / 2017 / X8 / X7 / X6 (64-bit)

• Affinity Photo 1.5+

• Serif PhotoPlus X8 / X7 / X6 (64-bit)

• PhotoLine (64-bit)

The plug-in may be compatible with other 64-bit hosts as well.

1.3.3. 32-bit plug-in

Recommended OS:

• Windows 10, Windows 8, Windows 7, Vista, XP; 32-bit or 64-bit

The 32-bit plug-in is compatible with the following plug-in hosts:

• Adobe Photoshop CC / CS6 / CS5.x / CS4 / CS3 / CS2 / CS / 7 / 6 / 5 (32-bit)

• Adobe Photoshop Elements 14 / 13 / 12 / 11 / 10 / 9 / 8 / 7 / 6 / 5 / 4 / 3 / 2 (32-bit)

• Corel PaintShop Pro 2022 / 2021 / 2020 / 2019 / 2018 / X9 / X8 / X7 / X6 / X5 / X4 / X3 / X2 / XI
/ X / 9 / 8 / 7 (32-bit)

• Corel PHOTO-PAINT 2020 / 2019 / 2018 / 2017 / X8 / X7 / X6 / X5 / X4 / X3 / 12 (32-bit)

• Corel / Ulead PhotoImpact X3 / 12 / 11 / 10 / XL / 8 (32-bit)

• Serif PhotoPlus X8 / X7 / X6 / X5 / X3 / 12 / 11 / 10 / 9 / 8 / 7 / 6 (32-bit)

• Microsoft Digital Image Pro

• Microsoft Digital Image Suite 2006

• PhotoLine (32-bit)

The plug-in may be compatible with other 32-bit hosts as well.

1.3.4. Supported types of images

The following image types are supported:

• 8-bit / 16-bit / 32-bit per channel RGB images

• 8-bit / 16-bit / 32-bit per channel grayscale images

Color input images are supposed to be in a flavor of RGB color space, like AdobeRGB, sRGB, etc. If an
input image is in some flavor of RGB color space then Neat Image produces the output image in exactly
the same flavor of RGB color space.

The minimum size of an input image is 40x40 pixels; the maximum size is usually limited by the amount
of system RAM available.

The plug-in can work with images stored using any file format that can be opened by Photoshop: PSD,
TIFF, RAW, JPEG, etc.
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2. Key concepts

2.1. What it can do – functionality of Neat Image
Neat Image is a digital image filter. Its main function is to reduce noise in digital images.

Neat Image can work with images produced by any imaging devices – digital cameras, scanners, etc.
Neat Image can be adjusted to a particular device by means of a device noise profile, which describes the
noise characteristics of the device.

A device noise profile is built by analyzing featureless areas of an image – areas that contain no visible or
important details and show only noise. Usually, the software can find such featureless areas completely
automatically. In a difficult case, you can assist it and select a featureless area manually. Finding such
areas is very easy for human eyes but may sometimes be a bit difficult for computer software.

By analyzing those featureless areas, the Auto Profile function builds a profile which describes the
properties of the noise contained there. Using such a profile, Neat Image’s noise filter can then efficiently
reduce noise in the whole image.

When you have several such noise profiles for different device modes (for example, different ISO rates),
the Auto Match function can automatically select the profile that matches a given input image. In this
way, you can skip noise analysis and simply re-use one of profiles built earlier.

Smart Profile combines the power of Auto Profile and Auto Match by preparing two candidate profiles
and then selecting the better one for actual image processing. This helps to achieve great results with less
manual assistance.

The noise filter processes images in several spatial frequency ranges. This allows, for example, to
accurately reduce noise in one frequency range while fully preserving details that may be present in
other frequency ranges. In the same way, the filter can also selectively process the color channels.

In addition to the noise filter, there is the smart sharpening filter, which sharpens only details but not noise,
so the noise is not amplified. Combining the noise reduction and sharpening in this way saves processing
time and produces better overall results.

2.2. When it works – types of input images
Neat Image is designed to reduce noise in images produced by digital cameras and scanners, and can also
be used to process images from other sources. For Neat Image to be efficient, input images should satisfy
the following requirements:

• Noise must be uniformly distributed throughout the image, i.e., there should be no strong
surges of noise intensity in some areas of the image or significant changes of noise characteristics
across the image.

Neat Image works fine, for example, on images with high ISO noise because such noise usually
uniformly covers the whole image area. However, ‘hot’ or ‘dead’ pixels (produced by single
‘broken’ elements of image sensor) do not satisfy the uniformity condition and, therefore, are not
efficiently removed by Neat Image.

Another frequent source of noise is JPEG compression. The JPEG noise is approximately uniform
when high quality setting (low compression rate, larger file size) is used. However, low compression
quality makes noise non-uniform. Therefore, we recommend using the highest quality levels
whenever possible. Try to avoid visible artifacts (‘squares’ or ‘blocks’ introduced by JPEG
compression) in input images beginning from the early stages of image processing. If you can, use
lossless file formats such as TIFF or RAW (any file format supported by Photoshop can be used
with the Neat Image plug-in in Photoshop environment).
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3. Installing the plug-in

To automatically install Neat Image plug-in to Photoshop

1. Make sure you have started Photoshop at least once before installing the plug-in. If you have not done
that yet, start Photoshop;

2. Close Photoshop;

3. Download the EXE installer of Neat Image that matches your version of Photoshop;

• if you already purchased the product and have a current license for the Home or Pro plug-in,
please use the download instruction supplied with the license to download the corresponding
plug-in;

• if you want to try Neat Image before purchase please download the installer of the Demo
version from this page: https://ni.neatvideo.com/download

4. Double-click the downloaded EXE file to start the installer;

5. Follow the steps of the installer wizard to complete the installation process.
Make sure the installer finds the location of your version of Photoshop in the Additional tasks step
of the installation process. If necessary, manually specify the location of Photoshop’s Plug-ins folder
there.

For example, the Plug-ins folder of the 64-bit version of Photoshop CS6 is:
C:∖Program Files∖Adobe∖Adobe Photoshop CS6 (64 Bit)∖Plug-ins∖

while for the 64-bit version of Photoshop CC 2015 that is:
C:∖Program Files∖Adobe∖Adobe Photoshop CC 2015∖Plug-ins∖

If for some reason the plug-in is not automatically installed, then you can install it manually using the
guidelines below.

To manually install Neat Image plug-in to 64-bit host application:

è 64-bit Photoshop (CC / CS6 / CS5.x / CS4, 64-bit) or Photoshop Elements (14 / 13, 64-bit)

Copy the NeatImage.8bf file from the Neat Image installation folder
(typically, C:∖Program Files∖Neat Image for Photoshop∖) into the Plug-Ins1subfolder inside the
Photoshop folder.

Then re-start Photoshop (make sure you start the 64-bit version of Photoshop, as there may be two
Photoshop versions available, 32-bit and 64-bit one) and find Neat Image in the menu:
Filter > Neat Image > Reduce Noise v8.

To manually install Neat Image plug-in to 32-bit host application:

è 32-bit Photoshop or Photoshop Elements

Copy the NeatImage.8bf file from the Neat Image installation folder
(typically, C:∖Program Files∖Neat Image for Photoshop∖ in 32-bit Windows or
C:∖Program Files (x86)∖Neat Image for Photoshop∖ if you use 64-bit Windows) into Plugins
or Plug-Ins1 subfolder inside the Photoshop / Photoshop Elements folder.

Then re-start Photoshop and find Neat Image in the menu: Filter > Neat Image > Reduce Noise v8.

è Other image editors (plug-in hosts)

Please refer to the documentation of the corresponding plug-in host to find the correct way to install a
third-party Photoshop-compatible plug-in (8BF-type).
You can find the Neat Image plug-in itself (NeatImage.8bf ) in the Neat Image installation folder:
C:∖Program Files∖Neat Image for Photoshop∖
or
C:∖Program Files (x86)∖Neat Image for Photoshop∖
depending on the version of Windows (32-bit vs 64-bit).

1 If the language of Photoshop is not English, you may have to use another Plug-Ins folder, for example, ”Modules externes” in
French, ”Zusatzmodule” in German version, ”Insteekmodules” in Dutch, ”Plug-In” in Italian, etc.
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4. Filtration process overview

4.1. Overview of Neat Image filtration process

1. Prepare image

– in Photoshop, open the image to be
processed;

– use the Filter > Neat Image > Reduce
Noise v8. . . menu item to open Neat Image;

2. Prepare a device noise profile - noise analysis
necessary to filter the image

– to build a new profile click the
Auto Profile button; this will automatically
select and analyze a featureless (noise–only)
image area;
if you see that automatic selection includes
any important image details, then move the
selection to an area without details and click
the Auto Profile button again;

3. Adjust the filter settings

– switch to the Noise Filter Settings tab;

– adjust the filter settings to achieve desired
level of noise reduction:

– try to vary the setting: Noise
Reduction Amounts: Luminance
and see how the preview changes;

4. When you are happy with preview results, apply
the filter to the image: click the Apply button.
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4.2. Running Neat Image on a sample image
You can download a test-kit prepared to help you start using Neat Image plug-in via this link:
https://ni.neatvideo.com/project/resources/testkit8.zip, 2.5 MB. Please download and unzip it to a new
folder on the hard disk.

The test-kit contains a sample image: SampleImage.jpg. This is a typical photo taken with a modern
digital camera. The detailed information about the image is available in the SampleImageInfo.txt file.

Please go through the stages below to see how the image can be improved by Neat Image:

Stage I. Open the image in Photoshop and invoke Neat Image

1. Open the image (SampleImage.jpg) in Photoshop;
You will see that there is some strong noise in the image (zoom in to better see the noise). This is
typical noise produced by a digital camera. The task of Neat Image is to reduce this noise.

2. Select the Filter >Neat Image > Reduce Noise v8. . . menu in Photoshop to open Neat Image.

Stage II. Build a noise profile using Auto Profile

To reduce noise Neat Image generally needs a noise profile describing the noise properties of the image. It
is possible to build such a noise profile using the image itself.

To prepare a noise profile please do the following:

1. In the Device Noise Profile tab: ,

click (the Auto Profile button);

Auto Profile will try to automatically find and analyze a flat featureless image area that contains
only noise and no important details.

2. Visually inspect the image area selected by Auto Profile. The area should contain no visible
details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, move the selection to another area without details or
draw a new selection in such an area. Then click the Auto Profile button again.

Once processing is completed, the noise profile is ready and Neat Image can apply its noise reduction to
the image.

Stage III. Check preview

1. Switch to the Noise Filter Settings tab: ;

2. Once preview is automatically prepared, visually evaluate the results of noise reduction.

You can click the image to quickly switch between original and filtered images for comparison.
Zoom in to better see details at 100% zoom level.

3. You can also try to adjust the filter settings a bit. For example, try to vary Noise Reduction
Amounts: Luminance control and see how that affects the preview.

Stage IV. Apply the filter

1. Click in the bottom of the plug-in window and wait until the image processing is
completed. That can take a few seconds. Then the filtered image is displayed in Photoshop.

Zoom in to better see details at 100% zoom level. Notice that the noise has been significantly
reduced throughout the image while the image details have been preserved.
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You can process your own images in a similar fashion as well. Neat Image can perform similar noise
reduction on images captured or acquired by any digital camera (or scanner) working in any mode. To
be able to do that Neat Image needs a device noise profile describing the properties of noise produced by
the corresponding device. Neat Image can build such a profile on the fly using the Auto Profile function.
Also, you can find ready-made noise profiles for many cameras and scanners in the Profiles section of the
Neat Image web page (you will find more details on that later in the document).

The next sections – Filtration process details, page 12, and Device noise profiles, page 30 contain detailed
descriptions of the filtration and profiling processes. There are also examples of profiling and filtration in
the Neat Image web page: https://ni.neatvideo.com/examples
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5. Filtration process details

The Neat Image plug-in can be used in Photoshop to process one or multiple images. This section
describes the key stages of using the Neat Image plug-in to process one image. There is also a way
to automatically process many images (see the Using plug-in in actions and smart filters section, page 28).

5.1. Stage I. Invoke the plug-in in Photoshop
In Photoshop, open and select an image to be processed (it will be called “input image” hereafter) and
then invoke the Neat Image plug-in using the standard method:

è Select the Filter >Neat Image > Reduce Noise. . . menu item in Photoshop.

The Neat Image plug-in window will open and show the input image.

To scroll and pan the image

• press the middle mouse button and then drag the image using the mouse;

• press the spacebar and the left mouse button and then drag the image using the mouse.

To change zoom level

• use the mouse wheel when the mouse pointer is over the viewer;

• use the zoom control under the viewer;

• use the Ctrl-Plus, Ctrl-Minus, Ctrl-0 (zero), Ctrl-Alt-0 (zero) keyboard shortcuts.

5.2. Stage II. Prepare a device noise profile
To filter the input image, Neat Image needs to know the characteristics of noise produced by the image
acquisition device (digital camera, scanner, etc.) that the image comes from. The noise characteristics of a
device working in a certain mode constitute a device noise profile.

There are several ways to prepare a noise profile for the input image:

1. Auto Profile: to build a new profile by analyzing the input image itself
(or a specially prepared test image);

2. Auto Match: to automatically select the most suitable device noise profile from a pre-built set of
profiles (when such a set is available);

3. Smart Profile: to use both Auto Profile and Auto Match (with optional Auto Fine-Tune) to
prepare two candidate profiles and then automatically select the better of two profiles;

4. Load Profile: to manually select a suitable profile from a pre-built set of profiles
(when such a set is available).

The first option is often the easiest one provided the input image contains uniform featureless areas that
include noise but no visible or important details.1 Auto Profile will try to automatically find such image
areas and analyze them to build a noise profile. When the image does contain featureless areas, this
automatic way of preparing a noise profile is the most accurate and therefore recommended. If the input
image includes no such areas, another image with featureless areas can be used to build a profile (provided
both images come from the same source and therefore contain the noise with the same properties).

The other options are available once you already have a pre-built set of profiles. You can prepare such a
set yourself or find some profile sets built by other users of the same camera or scanner. You can find more
information about profiles and profiling in the Device noise profiles section, page 30.

Again, using Auto Profile is often the simplest and fastest way to prepare an accurate noise profile, so
below this method is described first.
1 You can see some examples of featureless image areas in the Examples section, page 52.
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Auto Profile: build a new profile using the input image

è Make sure you have switched to the Device Noise Profile tab:

è Click (the Auto Profile button) in the toolbar, or use the Profile > Auto Profile
with Regular Image menu item, or press F2.

Auto Profile function will find and select an area for main analysis. Neat Image will then automatically
analyze the noise in that area to build a new noise profile. It will then analyze the rest of the image as
well, but the most important part of the analysis is the area highlighted by the selection. Which is why
it is important to visually control that area selected by Auto Profile.

In difficult cases, Neat Image may be not able to find a large enough, uniform enough and featureless
enough area in the image. You will then notice that the area selected by Auto Profile, for example,
contains some important details, not just noise. In such cases, Neat Image also warns you that the
area is not very suitable for analysis. It may say that the selected area is not uniform in one or more
channels, or is too small, or contains clipping in one or more channels.

One way to address that is to manually move the selection (or resize, or draw a new one) to an area
that does not contain any visible details and then click the same Auto Profile button again. To find
the most suitable area, use the Assist mode of the image viewer to better see weak details that may
be present in the candidate image areas. The Assist mode emphasizes the weak details present in
Luminance (Y), Cr, Cb channels, as shown in the example below:

The top image shows the original picture where details around the sun are barely visible, while the
channels in the bottom part display the image data in such a way as to emphasize those weak details.
That helps to visually verify that the selected area contains no useful details, which is very important
for accurate noise analysis.

Alternatively, you can just ignore those warnings about possible non-uniformity, clipping or size of the
area,, but the quality of the resulting noise profile may be lower than it could in principle be with that
image. The filter will still work though.

After the profile is built, check the Quality indicator in the Device Noise Profile box. A profile built
using a large, uniform and featureless image area will show a high value there. If the profile quality is
high (for example, higher than 70%) then you can be sure that the noise profile is accurate. In this case,
consider the noise profile ready and proceed to Stage III. Adjust filter settings, page 15.

If the quality is not high or you clearly see that the area used for analysis contains some details, try to
find another uniform image area and use Auto Profile again. It is usually best to select the most noisy
area for analysis.

That may not help still, especially if the image contains only a few featureless areas. In this case,
consider building a noise profile using an alternative image or a special test image prepared with
the Calibration Target. Please see the Device noise profiles section, page 30, to learn how to use the
Calibration Target to build noise profiles. You can also try to load some pre-built profile using one of
the methods described below.
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Auto Match: select matching noise profile from a pre-built profile set

This option can only be used if you already have a pre-built set of profiles. You can prepare such a set
yourself or find some pre-built profile online.

è Click (the Auto Match button) or use the Profile > Auto Match menu item.

The Auto Match function uses the EXIF data fields of the input image to automatically select and
load the device noise profile that matches the device mode of the image. The most matching profile is
selected from profiles stored in the Profile folder. By default, this folder is in your Documents folder1:
Documents∖Neat Image v8 for Photoshop∖Profiles∖

Auto Match will look for matching profiles in that folder as well as all its subfolders (where you can
place profiles built by you or downloaded from the Internet).

After a profile is loaded by Auto Match, the degree of match between the current input image and
loaded noise profile is displayed in the Device Noise Profile box. Higher Match values mean better
match, leading to more accurate filtration.

Smart Profile: prepare two profiles and select the better one

è Use the Profile > Smart Profile menu item (or press the F5 key).

Smart Profile uses both Auto Profile and Auto Match (with Auto Fine-Tune) to prepare two candidate
profiles and then selects the better of two profiles. For Smart Profile to be fully efficient, the input
image must contain flat featureless areas with noise for Auto Profile to analyze, and also there must be
several pre-built profiles to let Auto Match find the most matching noise profile, as described above.
You can adjust settings of Smart Profile function in Preferences.

Load Profile: manually select a noise profile from a pre-built profile set

è Click (the Load Profile button) or use the Profile > Load Profile. . . menu item.
Then select a profile in the Load Device Noise Profile dialog.

or

è Click (the drop-down button) in the Device Noise Profile box to open the popup menu with all
available profiles and then select one of the available profiles.

Please note that you must either build your own profiles or download some pre-built profiles and place
them to Neat Image’s Profile folder to make this drop-down button and popup menu truly work. By
default the Profile folder is located in your Documents folder 2 :
Documents∖Neat Image v8 for Photoshop∖Profiles∖

If you build or download some pre-built profiles, place them to the above folder (unzip the downloaded
ZIP archive to that folder). Neat Image will recognize and display those profiles in the popup menu to
help you quickly load any of them when needed.

When manually selecting a profile for an input image, use the profile file names and sub-folder
structure to guide your search. See Preparing profile set for different device modes: Stage III. Structuring
profile set, page 40, for more information on profile set structuring.

Load Profile: manually select a noise profile from a generic profile set

There may be some cases the images you are working on have no featureless areas suitable for building a
noise profile, no pre-built profiles available for particular device and noise characteristics. For such cases
Neat Image has a set of generic pre-built noise profiles that can provide a solution when other options are
not available. Of course it is better to use the regular solution (Auto Profile, Auto Match, Smart Profile)
when possible, because that delivers the most accurate results.

1 You can check and adjust the location of that folder using the menu Tools > Preferences > Matching.
2 You can check and adjust the location of the Profile folder using the menu Tools > Preferences > Folders.
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è To use one of the generic profiles click (the Load Profile button). Then select a
profile from the Generic Profiles folder.
or
Click (the drop-down button) in the Device Noise Profile box to open the popup menu showing
all profiles (currently available in Neat Image’s Profile folder), click on Generic Profiles and select
one of the available profiles.

By default, Generic Profiles are located in your Documents folder:
Documents∖Neat Image v8 for Photoshop∖Profiles∖Generic Profiles∖

There are seven profiles available in the Generic Profiles folder: Generic-1 (weak noise), Generic-2
(weak noise), Generic-3 (medium noise) . . . . . . and Generic-7 (strong noise). They have been ranked
according to the noise level they have been designed to deal with. Generic-1 (weak noise) noise profile
designed to work with images that do not have much noise, while Generic-7 (strong noise) noise profile
has been created for very noisy images.

Try different generic profiles to find one that delivers the best results in preview in the Noise Filter

Settings tab:

To additionally fine-tune the manually loaded or matched profile

You may want to additionally fine-tune the profile after it has been loaded either automatically
(using Auto Match) or manually (using Load Profile). Fine-tuning the profile to the current image
usually makes the profile more accurate and better reflecting the image’s noise properties. Please note
that you do not need to fine-tune a profile if you have just built it using Auto Profile. Auto Profile
automatically applies fine-tuning so you do not need to repeat that operation. However if you load an
existing profile instead of building a new one, fine-tuning such a loaded profile can be very useful.

è Click (the Auto Fine-Tune button) or use the Profile > Auto Fine-Tune menu
item to fine-tune the profile to the current input image.

There is no need to select any area in the input image because Auto Fine-Tune automatically analyzes
the whole image.

Once you have loaded the profile that matches the input image or you have just built a new profile
specifically for the current input image, proceed to process the image in the Stages III-V below.

5.3. Stage III. Adjust filter settings
As soon as the noise profile is ready you can use the noise and sharpening filters. These filters have
several adjustable settings. The default settings usually produce good results (provided the noise profile is
accurate). You may want to additionally vary the filter settings to achieve the filtration results that look
best to your eyes.

è Switch to the Noise Filter Settings tab:

5.3.1. Use preview when adjusting filter settings

The image viewer in the Noise Filter Settings tab shows a part of the image processed by the noise and
sharpening filters. When you change any filter settings, the preview is automatically updated. You can
zoom in and out, drag, scroll and pan the image to see how the filtration affects different parts of the
image. If you manually select an area in the image then only that area will be processed for preview. That
can also be faster than processing the whole visible area, so if you work on a slower machine, try selecting
a smaller area for preview. The simplest way to do that is to double-click the image in the area of interest:
Neat Image will then add a selection around that point.

When the preview is ready (the preview area shows “Filtered”), you can click inside that preview area to
temporarily switch back to the original for comparison.
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5.3.2. Beginner and Advanced modes

Neat Image has two sets of filter controls available in Beginner mode and Advanced mode. You can
select the mode using the Tools > Beginner mode and Tools > Advanced Mode menu items or using the
dedicated Beginner mode and Advanced Mode menu in top right corner of the plug-in’s window.

The Beginner mode provides a simplified control set recommended for beginners who have just started
using Neat Image. The Advanced Mode provides the most complete control set with the maximum
control over the noise profiling and filtration processes. The Advanced Mode offers several additional
filter options and modes that help to achieve better noise reduction results.

We recommend to start with the simplified control set of the Beginner mode and later switch to the
Advanced Mode to be able to utilize Neat Image to its full potential.

Adjusting filter settings in Beginner Mode and Advanced Mode is described in two separate sub-sections
below.

For Beginner mode please follow the sub-section Stage IV (a). Beginner Mode below.

If you want to jump right to the most complete control set in Advanced Mode then please instead follow
the sub-section Stage IV (b). Advanced Mode, page 18.

5.4. Stage IV (a). Beginner Mode
Please make sure Filter Settings panel is switched to the Filter tab.

5.4.1. Beginner Mode: Adjusting filter settings

There are two main filters in Neat Image: noise reduction filter and sharpening filter. These two filters can
be used together and each of them can be used independently. You can enable, disable and adjust these
filters using the guidelines in the subsections below.

Filter

The noise filter itself has two main settings (when working
in Beginner Mode): Noise Level and Noise Reduction
Amount.

The Noise Level setting is a threshold determining which
image elements are considered noise and which elements
are considered true details. The Noise Reduction Amount
setting determines how much reduction is applied to the
elements identified as noise.

è Use the Noise Reduction Amount: Luminance control
to adjust the amount of noise reduction applied to the
noise in the luminance component of the image data.This control is the most important and most frequently adjusted setting of the noise filter. The
higher this setting, the more of the detected noise is removed in the luminance component. Be careful,
setting the noise reduction amount too high may lead to loss of fine details and/or unnaturally looking
(over-smooth, plastic-like) results. Too low amounts may be not enough to sufficiently reduce the
objectionable part of the noise. The default value of 60% usually provides a good balance between
noise removal and preserving natural (not over-processed) appearance of filtered image. Try to adjust
the setting up and down to get the results that look best to your eyes.

è Use the Noise Level control to adjust the setting (only when necessary).

Please note that if the noise profile is accurate,1 then it is not necessary to adjust this setting. However,
if the noise profile is not accurate or it was built for a different image, then the noise filter may need

1 Use the Quality indicator in the Device Noise Profile box (in the Device Noise Profile tab) to estimate the accuracy of the profile.
The indicator shows how accurate and complete is the noise analysis itself. Higher values usually lead to more accurate noise
reduction. Also pay attention to the Match indicator: it should either show a high value or there should be the (AP) sign indicating
that the profile has been built by Auto Profile using this very image. That ensures that the profile is not only accurate but it also
matches the input image.
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an adjusted estimation of the actual noise level to be able to work correctly. By adjusting the Noise
Level setting, you provide the filter with such an adjusted estimation. Use the preview to visually
guide yourself when making such adjustments. The right adjustment will leave no noise elements in
the image yet will not destroy the actual details.

It is best to gradually increase the noise level and watch the preview to find the point where most the
noise elements are already reduced and the details are still preserved. If you go beyond that point, then
some details may be lost too, so make sure you do not set the noise level unnecessarily high.

Sharpening (optional)

The sharpening filter in Neat Image increases the sharpness of image details without increasing the noise
strength.

The sharpening filter is disabled by default. You can enable it and adjust the sharpening amounts separately
for three typical scales of details: fine, medium-sized and large.

Like any sharpening method, try to balance the amount of sharpening to avoid over-sharpening.

è Use the Sharpening: Fine, Medium and Large sliders
to adjust the amount of sharpening applied to the image
details of the corresponding sizes.

It is best to start with adjusting the Fine sharpening
amount. If sharpening the fine details alone is not
sufficient to make the image look sharp, then try to increase the Medium and Large settings too.

Use preview

While adjusting the settings, use the available preview facilities to evaluate the corresponding changes in
the results of Neat Image processing:

• Click inside the preview area to temporarily switch back to the original image for comparison;

• Move the preview area from one part of the image to another to see how the Neat Image processing
affects different image content;

• Create several alternative variants of filtration, compare results and select the best variant. For
more information on using variants please see the Variants of filtration section, page 44.

5.4.2. Beginner Mode: Optimize performance settings (optional)

Before applying the filter to the image (especially if that is only one of many images in a large batch), you
may want to measure the processing speed on that image and potentially improve the speed by optimizing
the performance settings of Neat Image. This is entirely optional but in some cases, the optimization can
appreciably reduce the time of batch processing.

It is generally a good idea to optimize the performance settings when you run Neat Image on that specific
computer for the very first time, to adapt the filter to the current hardware (the CPUs and GPUs available
in that machine).

To check the current speed and to optimize the performance settings switch to the Performance tab in the
Filter Settings box.
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è To measure the filter speed click

Neat Image will run a test and will then display the
measured processing speed based on the current filter
settings (as shown in the text field in the Performance
tab).

è To optimize the performance settings click
to open the Performance tab in Neat Image Preferences.
In that tab, you can inspect the available and current CPU
and GPU settings.

Then click to open a specialized
dialog designed to measure image processing speeds
achieved with different combinations of the CPU and
GPU settings. It allows to automatically benchmark all
possible combinations of those settings and to identify

the best combination (for the current hardware and current filter settings). You can then just click

to apply the found optimal combination achieving the best performance.

Once you have completed this step, please proceed to the section Stage VIII. Apply filter, page 27.

Or if you want to switch to the Advanced Mode and adjust the filters using the most complete set of
controls please proceed to the next sub-section dedicated to the Advanced Mode.

5.5. Stage IV (b). Advanced Mode
As said in the previous sections, Neat Image has two sets of filter controls, that are available in the
Beginner mode and Advanced mode (you can select the mode using the Tools > Beginner mode and
Tools > Advanced Mode menu items).

The Beginner mode described earlier provides a simplified control set recommended for beginners who
have just started using Neat Image. The Advanced Mode provides the most complete control set with the
maximum control over the noise profiling and filtration processes. The Advanced Mode offers several
additional filter options and modes that help to achieve better noise reduction results.

It is usually best to start learning Neat Image using the simplified control set of the Beginner mode and
later switch to the Advanced Mode to be able to utilize Neat Image to its full potential.

If you want to use the Advanced mode then please follow this sub-section, otherwise skip it and proceed
to page 25 for the next stage.

As compared with the Beginner mode, the Advanced mode offers a more extensive set of filter controls.
There are also several quality modes allowing to opt for higher quality of image processing over processing
speed or the other way around.
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5.5.1. Advanced Mode: Selecting Quality Mode

Please make sure Filter Settings panel is switched to the
Filter tab.

The first setting available in the Filter tab is the Quality
Mode, which is a global setting affecting the way all or
most parts of the filter work. Quality Mode determines
whether Neat Image should generally work more accurately
(but somewhat slower) or somewhat less accurately (but
significantly faster).

By default, Quality Mode is set to High, which provides
a good balance between processing speed and the visual
quality of results. There are also Highest (slower) and
Normal (faster) modes.

è Use the Quality Mode control to select the preferred processing mode.

While adjusting the Quality Mode, observe how the preview progress indicator (the yellow bar at the
top of the preview area) is updating to get an idea of expected processing speed in each processing
mode. You may not immediately notice the difference in visual quality in preview but the speed
difference should be immediately obvious.

If the preview is updating too slowly, you do not necessarily have to decrease the Quality Mode. You
can simply zoom into the image or manually select a smaller part of the image to limit the preview to
that smaller area. Then the preview will update faster.

Preview has to update in many situations: when you change any filter settings, move the selected
area to another part of the image, zoom in or out, etc. Therefore it is important to make those updates
comfortably fast.

Once you find a comfortable way to evaluate the preview results, proceed to the next steps to adjust the
actual filters.

5.5.2. Advanced Mode: Adjusting filter settings

There are several sections in the Filter tab. Most of the sections are related to the noise reduction filter
and the last section is about sharpening. Most of the sections can be enabled or disabled individually to
achieve the desired results in different image processing situations.
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Filter

In Advanced Mode, the main noise filter has separate
settings for all (spatial) frequency1 and channel components
of the image data. There are pairs of noise level – noise
reduction amount controls for each of these components.
You have access to eight such pairs – three for channel
components (Luminance, Cr, Cb) and five for spatial
frequency components (High, Mid, Low, Very Low, Ultra
Low) of the image data.

The meaning of each noise level – noise reduction amount
pair is the following:

• the noise level control adjusts the threshold
determining which elements of the corresponding
image component are considered noise and which
elements are considered true details;

• the noise reduction amount control determines how
much reduction is applied to the elements identified
as noise in that component.

Thus, with a noise level – noise reduction amount pair of
settings you can adjust what should be considered noise in
a component of the image data and how much of that noise
should be reduced.

The noise level settings are relative and are based on the
noise levels of the current noise profile. Because the noise
level controls are relative to the measured levels of the
noise profile, the default filter settings usually produce good
results as long as the noise profile is accurate.2

Noise Reduction Amount3

Noise reduction amounts are the most frequently adjusted settings of the noise filter.

è Use the Noise Reduction Amount > Luminance; and Noise Reduction Amount > Components >
Cr, Cb; High, Mid, Low, Very Low, Ultra Low sliders.

1 See “What is frequency” question in page 55.
2 Use the Quality indicator in the Device Noise Profile box (in the Device Noise Profile tab) to estimate the accuracy of the profile.

The indicator shows how accurate and complete is the noise profile itself. Higher values usually lead to more accurate noise
reduction. Also pay attention to the Match indicator: it should either show a high value or there should be the (AP) sign indicating
that the profile has been built by Auto Profile using this very image. That ensures that the profile is not only accurate but it also
matches the input image.

3 We recommend disabling the sharpening filter when adjusting the noise filter. This can make the influence of adjustments easier to
see in preview.

27-Oct-2021 Neat Image © 1999-2021 Neat Image team, ABSoft. All rights reserved. 20



User Guide Neat Image v8 plug-in for Photoshop (Win)

You can vary the noise reduction amount for each frequency
and channel component of the image data. The higher a
certain noise reduction amount is, the more of the detected
noise is removed in the corresponding component.

Noise reduction amounts can be in the range from 0% (none
of the detected noise is removed) to 100% (all the detected
noise is removed). By default, the noise filter removes 60%
in the Luminance channel and 80% in the Cr, Cb channels
(you can always change the defaults if necessary1).

Be careful: setting the noise reduction amounts too high,
especially in the Luminance channel, may lead to loss
of fine details and/or unnaturally looking (over-smooth,
plastic-like) results. Too low amounts may be not enough to
sufficiently reduce the objectionable part of the noise. Try to
balance the noise reduction amounts (most importantly, the
amount of noise reduction in the Luminance channel) to get
the results that look best to your eyes.

As human vision is not very
sensitive to variations of
colors, strong filtration in the
chrominance channels (Cr, Cb)
does not noticeably distort image,
but efficiently reduces color noise.

Decreasing the noise reduction amounts can have a positive effect
if the image contains some natural noise. For example, when
you work with an image showing asphalt, sand, or anything else
that contains fine natural noise-like features, it may be helpful
to reduce the amounts at least for some of the components (for
example, Luminance).

Filter Tuning Assist (optional)

Filter Tuning Assist is a special tool, which facilitates
adjustment of other filter settings by helping to better
see the influence of other settings in preview. It is not
necessary to use this tool, but it may help to speed up the
adjustment process as a whole.

When you use Filter Tuning Assist, all noise reduction
amounts are temporarily increased to a higher Amount
value (the specific value of that special Amount can be
adjusted here as well). That makes it easier to see the
difference caused by adjustments in other settings such
as Noise Level, Artifact Removal, Detail Recovery and
other filter settings available in Advanced Mode and
described further in this section.

è Click Filter Tuning Assist > Begin for easier tuning
of filter settings.

The preview image may then look unnaturally plastic,
but that is just a temporary effect that will go away
once tuning is complete.

è Adjust highlighted filter settings so that no noise is visible, but details are still preserved.

è Click Filter Tuning Assist > Finish button to complete the tuning process.
Please note that some noise will return to the preview image after that. This is normal. The amount of
noise reduction can be adjusted using other filter settings if required.

1 You can adjust the filter settings and then save them as a new default preset using the menu Filter > Set As Default Preset. . .
Also see the description of the Default Filter Preset setting in Neat Image Preferences, page 47.
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Noise Level (optional)

Usually it is not necessary to change the noise level settings if the noise profile is accurate. You only
need to adjust the noise levels if you see in preview that some noise elements are not reduced by the
filter even if you increase the noise reduction amounts. Such incomplete reduction is usually caused by
an inaccurate noise profile providing inaccurate noise level estimations to the noise filter. This may be
compensated by adjusting (increasing) the noise levels in the filter settings.

è Use the Noise Level > Luminance, Cr, Cb; High, Mid,
Low, Very Low, Ultra Low sliders.

The noise filter is applied to the five frequency
components and the three channel components of the
image data. Corresponding sliders adjust the estimated
noise levels for each of these components.

The higher a certain noise level is, the more elements in
the corresponding component are considered noise. Be
careful: setting a noise level too high can lead to removal
of true details. Setting it too low can lead to incomplete
filtration: residual noise and compression artifacts can
stay in the filtered image.

As a rule, if the device noise profile has been built
properly, it is not necessary to increase the noise levels
by more than 50%. If the image contains strong surges
of noise in the high frequency range, it is recommended
to increase the high frequency noise level up to +20 to
40% and/or use the artifact filter (see below).

If the image contains strong color noise, it is
recommended to increase the Cr and Cb noise levels
to +30% or more. In some cases, it may be useful to
increase these noise levels up to +100%.

If adjusting noise levels still does not help and some noise elements remain in the filtered image, probably
the device noise profile is not good at all. Return to Stage V. Prepare a device noise profile, page 12, and
additionally fine-tune the noise profile or simply rebuild it from scratch.

Artifact Removal (optional)

Neat Image has an additional filter to remove residual
dot-like and line-like noise elements that may remain
in image even after applying Neat Image’s regular
noise filters. Such residual noise elements / artifacts
are typically created by in-camera noise reduction and
compression or by other post-processing. Neat Image’s
noise reduction can make those elements more visible
if the noise levels are under-estimated during profiling.

You can see an example of such digital artifacts in
the first picture on the right. The second picture shows the results of noise reduction with the Artifact
Removal filter enabled.

Such artifacts are usually of digital nature. They are typically of very small size yet they are different from
the regular random noise, so they require special treatment provided by the Artifact Removal filter.

You can enable and adjust this filter using the following controls in the Filter > Artifact Removal
section:
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è Use the Dots control to adjust the dot removal threshold.
Higher values lead to stronger reduction of dot-like
artifacts (less attention to details); lower values lead
to weaker reduction (more attention to details).

è Use the Lines control to adjust the line removal threshold.
Higher values lead to stronger reduction of line-like
artifacts (less attention to details); lower values lead to
weaker reduction (more attention to details).

The artifact filter additionally offers separate thresholds for three frequency components (in other words,
for three typical size scales) in the Frequencies sub-section: high, mid, low.

è Use the High, Mid and Low controls to adjust the artifact removal thresholds in the corresponding
frequency components.
Higher values lead to stronger reduction of artifacts (less attention to details); lower values lead to
weaker reduction (more attention to details).

Detail Recovery (optional)

This option allows to recover some of the fine details which might be weakened or lost due to image
editing, compression, noisiness of the original image, using a less accurate noise profile, etc. The Detail
Recovery function is particularly useful when you need to preserve and recover partially lost repeated
patterns such as brick walls, rug patterns, cloth textures, ripples, etc.

This option is available only in the Highest quality mode and it makes processing somewhat slower.

è Enable the Detail Recovery section.

è The Sensitivity setting is a threshold that determines
what should be considerered true details (as compared
with noise elements) and therefore recovered by the
filter. Positive values of Sensitivity make the filter detect
and recover more details. Negative values make it more
conservative so it recovers fewer image elements.

You can also use the High, Mid and Low controls to adjust the sensitivity for the individual frequency
components of the image.

Keep in mind that setting the Detail Recovery controls too high can lead to incomplete filtration:
residial noise and compression artifacts can stay in the filtered image. Setting these controls too
low can lead to insufficient recovery of useful details. Try to find the right balance based on visual
inspection of preview.

è Use the Amount control to set the strength of Detail Recovery. The higher the Amount setting the
stronger recovery of the detected details. Lower values produce weaker recovery effect.

Edge Smoothing (optional)

This option of the noise filter makes smoother the edges of
the objects in the image. This can be useful when edges are
significantly degraded by the noise (or by the in-camera
noise reduction and sharpening) and it is preferable to
restore them.

è Enable the Edge Smoothing section to enable this option in general.

è Use the High, Mid and Low controls to adjust the strength of edge smoothing in the corresponding
frequency components of the image. Higher values lead to stronger smoothing of edges; lower values
lead to less smoothing.
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Sharpening (optional)

The sharpening filter in Neat Image increases sharpness of the details in the image without increasing the
noise strength.

The sharpening filter is disabled by default. You can enable it and adjust the sharpening amounts separately
for three frequency components (for three typical size scales): High, Mid, Low.

è Use the Sharpening: High, Mid and Low sliders to
adjust the amount of sharpening applied to the details of
the corresponding size.

0% will not sharpen the component at all. 100% is
the normal and 250% is the maximum strength of
sharpening in each component.

It is best to start with adjusting the amount of sharpening
applied to the High frequency component. If that
sharpening alone is not sufficient, try to increase the
Mid and Low settings too.

Like any sharpening method, try to balance the amount of sharpening to avoid over-sharpening.

You can also adjust sharpening amounts separately for three channel components – Luminance and Cr /
Cb (chrominance components):

è Use the Sharpening > Channels > Luminance, Cr and Cb sliders to adjust the amount of sharpening
applied to the corresponding channel components.

You can also enable the dedicated option that prevents over-sharpening:

è Use the Sharpening > Prevent Over-Sharpening option to use a higher-quality sharpening method,
which tries to prevent over-sharpening and to avoid creating a halo around details.

Use preview

While adjusting the settings, use the available preview facilities to evaluate the corresponding changes in
the results of Neat Image filtration:

• Click inside the preview area to temporarily switch back to the original image for comparison;

• Move the preview area from one part of the image to another to see how the Neat Image processing
affects different image content;

• Use (Viewer mode button) in the viewer toolbar to switch to different viewer
modes and to inspect the individial components of the image. Examine channel and frequency
components, check the presence of noise in individual components. Identify those components that
do not get enough (or get too much) noise reduction and adjust the corresponding filter settings;

• Create several alternative variants of filtration, compare results and select the best variant. For
more information on using variants please see the Variants of filtration section, page 44.

If you enabled Filter Tuning Mode to facilitate adjustments of the filter settings, make sure you have
disabled that mode now.
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5.5.3. Advanced Mode: Optimize performance (optional)

Before applying the filter to the image (especially if that is only one of many images in a large batch), you
may want to measure the processing speed on that image and potentially improve the speed by optimizing
the performance settings of Neat Image.

It is generally a good idea to optimize the performance settings when you run Neat Image on that specific
computer for the very first time, to adapt the filter to the current hardware (the CPUs and GPUs available
in that machine).

The processing speed may also depend on the filter settings: enabling more filters makes processing
slower because Neat Image has to do more work. Also, if you significantly change the filter settings,
then the optimal performance settings (for example, the number of CPU cores and/or GPUs used for
processing) may change as well, so it may be useful to optimize those settings before starting a large batch
where many images are going to be processed using the same settings. This is entirely optional but in
some cases, the optimization can appreciably reduce the time of batch processing.

To check the current speed and to optimize the performance
settings switch to the Performance tab in the Filter Settings
box.

è To measure the filter speed click in the
bottom of the Performance tab.

Neat Image will run a test and will then display the
measured processing speed based on the current filter
settings (as shown in the text field above).

è To optimize the performance settings click
to open the Performance tab in Neat Image Preferences.
In that tab, you can inspect the available performance
options as well as the current CPU and GPU settings.

Then click to open a specialized
dialog designed to measure image processing speeds
achieved with different combinations of the CPU and
GPU settings. It allows to automatically benchmark all
possible combinations of settings and to identify the best
combination (for the current filter settings).

You can then just click to apply the found optimal combination achieving the
best performance.

5.6. Stage V. Save filter settings into a preset (optional)
This sub-section is entirely optional yet you may want to consider saving the current filter settings into a
preset on the disk to be able to re-load the same customized filter settings in another image, in the same or
another project.

To save the filter settings into a preset

è Click (the Save current filter settings as a preset. . . button) in the Filter Settings box or use
the Filter > Save Filter Preset. . . menu item.

In the Save Filter Preset As dialog box, specify the name of the file to save the preset. The filter
presets are stored in *.nfp files.

The saved filter preset includes all settings of Neat Image’s noise filter, all its specialized sub-sections and
options, as well as the sharpening settings. By re-opening a preset later on, you can reproduce exactly
the same filter settings. Together, a pair of device noise profile and filter preset can be used to accurately
reproduce the filtration results.

You can also add some text comments to your custom preset using the Preset Description dialog:

27-Oct-2021 Neat Image © 1999-2021 Neat Image team, ABSoft. All rights reserved. 25



User Guide Neat Image v8 plug-in for Photoshop (Win)

è Use to open the Preset Description dialog and add or edit the description of the preset.

The text comments are also saved into the preset on the disk when you use .

To load a previously saved filter preset

è Click (the Load filter settings from a preset. . . button) in the Filter Settings box or use the
Filter > Load Filter Preset. . . menu item. In the Load Filter Preset dialog box, locate and select the
filter preset to be loaded.

or

è Click (the drop-down button) in the Filter Settings box to open the popup menu with all available
presets and then select one of them.

There are several pre-written filter presets in your Documents folder:1

Documents∖Neat Image v8 for Photoshop∖Presets∖

Please try to load those pre-written presets to see what combinations of the filter settings and their values
can be used to solve typical tasks. The names of the groups of presets and names of presets themselves
explain those tasks. Also, when loading any of the pre-written filter presets supplied with Neat Image, the
Preset Description dialog opens automatically2 to display the description of the preset being loaded. The
description is intended to help you get a better understanding of the purpose, applicability and possible
side effects of the preset.

There are two main groups of pre-written presets: General and Advanced. The presets in the first group
can be used in both Beginner mode and Advanced Mode. The presets in the second group can only
be used when Neat Image is in Advanced Mode, so loading such a preset will switch Neat Image to
Advanced Mode (if you currently use Neat Image in Beginner Mode).

5.7. Stage VI. Adjust Action settings (optional)3

At this point in the workflow, the noise profile is ready, filter settings are adjusted and, therefore, the filter
is ready to be applied to the image. However, before applying the filter, you may want to adjust the Action
Setup settings accessible via the Action Setup button:

These settings specify which noise profile and filter preset should be used by the plug-in on startup when
you use the plug-in next time. For example, you can have Neat Image automatically build a new noise
profile using Auto Profile when you open the plug-in.

The following options are available for noise
profiles:

• Use Current Profile
Neat Image will use the currently
loaded/built profile;

• Auto Match
Neat Image will use Auto Match
to find and load the best matching
profile from the profile set on the disk;

• Auto Profile
Neat Image will use Auto Profile
to build a profile using the input image;

1 You can check and adjust the location of the Preset folder: use the menu Tools > Preferences > Folders > Preset folder.
2 You can disable displaying that dialog using the checkbox in the bottom of the Preset Description dialog (and re-enable it later in

Neat Image Preferences if necessary).
3 This subsection applies to Neat Image Pro plug-in only.
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• Smart Profile (Auto Profile and Auto Match)
Neat Image will use both Auto Profile and Auto Match to prepare two noise profiles and then will
select the better of two resulting profiles. This provides higher overall quality at expense of slightly
longer processing time. To be fully efficient, this option also needs a pre-built set of noise profiles
(for Auto Match to work). You can configure the behavior of the Smart Profile function using the
settings link.

• Auto Fine-Tune
Neat Image will additionally apply Auto Fine-Tune to adapt the loaded profile to the input image;
this option is available when you use either Use Current Profile or Auto Match (Auto Profile
applies Auto Fine-Tune automatically).

The plug-in will always use the current filter settings as the default filter preset for the next run.

5.8. Stage VII. Apply filter

To apply filter to the image

è Click (the Apply button in the bottom of the plug-in window).

Neat Image is a processor-intensive image filter,
so the processor’s speed is the most important.
On Core i7 3.8 GHz, processing a 24-megapixel
image takes about 3 seconds in Normal quality
mode and about 9 seconds in High quality mode
(Neat Image v8 plug-in for Photoshop (Win)).
On a computer of typical configuration, the
processing time is linear with respect to image
size (when measured in megapixels).

The plug-in window will be closed and filtration
will start. Processing may take some time (from
seconds to minutes, depending on the speed
of your computer’s processor and size of the
image).

Then the filtered output image is displayed
in Photoshop and you can continue your
Photoshop workflow.

After filtration, the Neat Image plug-in will also automatically save the current settings such as device
noise profile, filter preset, Action Setup settings, which will enable re-applying the plug-in (for
example, using the Ctrl+F shortcut in Photoshop) with the same settings without re-doing the stages
II-III. Also, you can open the plug-in manually and continue to work with the last used parameters.

27-Oct-2021 Neat Image © 1999-2021 Neat Image team, ABSoft. All rights reserved. 27



User Guide Neat Image v8 plug-in for Photoshop (Win)

6. Using plug-in in actions and smart filters

6.1. Configuring Neat Image in actions and smart filters
The Neat Image plug-in can be used in Photoshop actions and smart filters along with the built-in
Photoshop filters. The plug-in has two parameters when used in an action or smart filter: Profile and
Preset. The Profile parameter tells Neat Image which device noise profile should be used, the Preset
parameter specifies which filter preset should be used.

When you record an action or configure a
smart filter that includes the Neat Image
plug-in, you can select the source of noise
profile and filter preset that should be used

by the plug-in. To do that click
(the Action Setup button) in the main plug-in
window and then select the corresponding
options in the Action Setup window. You
can later return and check which options are
selected in the current action or smart filter
using that window.

è To specify how Neat Image should prepare
noise profile(s) for the input image(s)
processed by this action or smart filter,
select one of the following options in the
Device Noise Profile box:

• Use Current Profile
The plug-in will use a fixed noise profile that has been created or loaded into plug-in at the time of
action recording (configuring the smart filter) and is currently available in the Device Noise Profile
box in the main plug-in window; the plug-in will record that noise profile into the action or smart
filter and will then always use it when the action is played or smart filter is (re-)applied.

• Auto Match1

The plug-in will use Auto Match to search and load the best matching profile(s) for input image(s)
from the profile set on the disk.

• Auto Profile
The plug-in will use Auto Profile to build new noise profile(s) for the input image(s) when
the action is played or smart filter is (re-)applied. The input image(s) must contain enough flat
featureless noise-only areas suitable for noise analysis.

• Smart Profile (Auto Profile and Auto Match)
Neat Image will use both Auto Profile and Auto Match to prepare two noise profiles and then will
select the better of two resulting profiles. This provides higher overall quality at expense of slightly
longer processing time. To be fully efficient, this option also needs a pre-built set of noise profiles
(for Auto Match to work). You can configure the behavior of the Smart Profile function using the
settings link.

• Auto Fine-Tune
The plug-in will additionally apply Auto Fine-Tune to adapt the loaded profile(s) to the input
image(s), to make the profile(s) more accurate. This option is available when you select Use
Current Profile or Auto Match.

è The action or smart filter will use the filter preset created or loaded into plug-in at the time of action
recording (or configuring the smart filter). This filter preset will be recorded into the action or smart
filter and will then always be used when the action is played or smart filter is (re-)applied. When used

1 For this option to work, several noise profiles should be available on the hard drive. The profiles should be stored in the folder
specified in Preferences (you can check and modify its location using the menu Tools > Preferences > Matching > Profile
Matching). These can be profiles downloaded from the Neat Image online profile library or from other sources. You can also
use profiles built by you. The input images as well as profiles in the profile set should contain the EXIF information to make
profile-image matching possible. Most noise profiles available in the profile library in Neat Image website do contain the EXIF
data. New noise profiles built with the latest versions of Neat Image plug-in will also contain the EXIF data (from the images
used for profiling). Profiles built with older versions of Neat Image plug-in may not contain the EXIF data, so it may be useful to
re-build them using the latest version.
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in an action, the Preset parameter contains the name of that preset. The preset name is also shown in
the Filter Settings box in the main plug-in window. You can change this preset using the controls in
the Filter Settings box and then the new or modified preset will be recorded into the action or smart
filter.

When you have completed the adjustments in the Action Setup window, click the Apply button to save
the changes into the action or smart filter that you are currently recording or configuring.

6.2. Neat Image in action-based batch processing
The Neat Image plug-in for Photoshop (Win) can be used to process multiple images using Photoshop’s
action-based batching facility.

To use this kind of batching you must do the following:

1. Pick one image from the series of images that you want to process and manually apply Neat Image
filtration to this image to make sure you get the filtration results that you like. Then undo the
changes done to the image.

2. Start recording a new action in Photoshop
(if necessary consult Photoshop’s documentation to check how you can create, record and play
actions in your version of Photoshop).

3. While recording the action, repeat the step (1) and before applying the Neat Image plug-in click
the Action Setup button in Neat Image plug-in window and make sure the settings there correctly
describe the way you want Neat Image to prepare noise profile(s) and filter preset when the action
will be played. After configuring the Action Setup settings, click the Apply button in the Action
Setup window, and then click the Apply button in the main plug-in window.

4. Stop recording the action in Photoshop.
You will now have a ready for use action that includes Neat Image with configured parameters.

5. In Photoshop, go to the menu File > Automate > Batch. This will open the Batch window where
you can configure a new batch that will process your series of images.

6. In the Set / Action fields of the Batch window, select the action that you have just recorded.

7. Configure the rest of the Batch options according to the Photoshop user guide and then start the
batch processing.

Photoshop’s Batch tool will then process your images using the action that you have prepared. Neat Image
is a part of that action, so the Batch tool will apply Neat Image filtration to every image in the batch.

Since it is possible that some of the images may not be automatically processed by Neat Image (or other
filters that may be used in your action) due to some errors, use the log options to save a log of the batch
and then check which image(s) failed. If they failed because Neat Image could not process them, you can
find out why that happened by manually running the action on one of those images. Make sure you run the
action with GUI/dialog enabled to make Neat Image open its main window and display the error messages
that will explain the problem to help you resolve it. After the problem is resolved, run the batch again
using the steps 5-7 above or manually process failed images.
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7. Device noise profiles
A device noise profile (or noise profile, or simply profile) describes the properties of noise produced by
an imaging device (e.g., digital camera, scanner, etc.) working in a certain mode. Several noise profiles
corresponding to different modes of a device constitute a profile set. Neat Image can use profiles from
such a set to process images produced in any of the modes covered by the set.

You can find some pre-built noise profiles or build your own profiles for your camera or scanner. Learn
how to find, build and use device noise profiles in Neat Image in the subsections below.

7.1. Getting ready-made noise profiles
You can find some free profile sets for different cameras and scanners in:

• Profiles section of the Neat Image web page:

https://ni.neatvideo.com/download/noise-profiles

• Device noise profiles section of the Neat Image community forum:

http://www.neatimage.net/forum/viewforum.php?f=5

• Other digital imaging forums and web pages where users of Neat Image may publish their profiles.

To use a profile set from one of these sources, download the archive with profiles and unzip all profiles to
the following folder 1 and/or its sub-folder(s) in your Documents folder:
Documents∖Neat Image v8 for Photoshop∖Profiles∖

After that you can use individual profiles from this set in Neat Image to process images produced in device
modes covered by this profile set.

Please be aware that using ready-made profiles built by other people may produce less than optimal results
with your images because of possible slight differences in noise properties of cameras (scanners) as well
as due to differences in imaging processing workflows used. Therefore, we advise to use ready-made
noise profiles built by others only as a starting point to learn how to use Neat Image. To achieve the best
results consider building your own profiles using the procedures described in the subsections below.

7.2. Building a profile for a device mode (standard profiling
procedure)

In this subsection, you will find out how to build a single noise profile for an image produced in a certain
shooting mode of a camera or a scanning mode of a scanner (such a profile can also be called “a profile for
a certain mode of the device”).

Building a new noise profile generally consists of three stages:

Stage I. Building a profile;
Stage II. Documenting the profile;
Stage III. Saving the profile.

The Stage I, building a profile, can be done using a regular image (for example, the image that you want
to denoise or any other regular image) or using an image of the Calibration Target (a special test chart
facilitating profiling). These two cases are described as two alternative versions of the Stage I:

Stage I. Case of building a profile using a regular image
Stage I. Case of building a profile using the Calibration Target

You may want to follow the case of building a noise profile using a regular image if you want to build
a one-time-use noise profile to process one specific input image. In this case, the input image (or an
alternative regular image from the same series, that is produced by the same device working in the same
mode) should contain some uniform featureless areas for noise analysis.

A uniform area (with minor brightness variation in all channels of the image) may be overcast sky
(without visually distinguishable clouds), clear sky (without clouds and birds), or any other part of the
1 You can check and adjust the location of the Profile folder using the menu Tools > Preferences > Folders.
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image containing no visually perceptible details (except the noise). Neat Image needs uniform featureless
areas of around 128x128 pixels or more (up to 512x512 pixels; larger is better), the minimum is 32x32
pixels. You can see some examples of such areas in the Examples section, page 52.

If the input image does not contain such areas and you have no suitable alternative regular image that
contains such areas, you can prepare a special test image and follow the case of building a noise profile
using the Calibration Target. That is also recommended if you want to prepare a reusable noise profile for
a certain mode of your camera or scanner.

7.2.1. Stage I. Case of building a profile using a regular image

To build a noise profile using a regular image you must take 2 steps:

Step 1. Preparing a regular image for noise analysis;
Step 2. Analyzing the image noise.

Step 1. Preparing a regular image for noise analysis

To analyze noise in a regular image, you can use the input image or an alternative regular image that
was produced by the same camera (or scanner) in the same or similar shooting (scanning) mode. Using
the input image itself usually produces the most accurate noise profile that perfectly matches the noise
properties of the input image. However, if there are not enough flat featureless areas in the input image,
then you may have to use an alternative regular image.

Case of using the input image

In this case, simply open the input image in the plug-in and proceed to the step 2 below.

Case of using an alternative image

If there is no large enough uniform featureless areas in the input image, use an alternative image. The
alternative image is supposed to be produced by the same device working in the same or similar mode.
This can be just another image from the same series; the image should contain at least one large enough
uniform featureless area suitable for analysis.

Open an alternative image in Photoshop and then open this image in Neat Image plug-in for analysis
below.

Step 2. Analyzing image noise (profiling)

Analyzing noise is the main part of building a noise profile for an imaging device working in a certain
mode. The current version of Neat Image plug-in for Photoshop (Win) offers three ways of conducting
the noise analysis (profiling): automatic, semi-automatic and manual one. Using automatic profiling is
easier and therefore recommended for beginners. In difficult cases (for example if Neat Image cannot
automatically find a uniform featureless area in an analyzed image), automatic profiling may not work
well or may produce less than perfect results. You can always override automatics and use semi-automatic
or manual profiling.

è Make sure you use the Device Noise Profile tab:
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Case of automatic profiling

To analyze noise properties, Neat Image uses uniform image areas that contain noise but no visible or
important details. With automatic profiling, Neat Image tries to find one such area automatically and then
uses the found area to analyze image noise.

è Click (the Auto Profile button) in the toolbar, or use the Profile > Auto Profile
with Regular Image menu item, or press F2.

Neat Image will try to automatically find image areas suitable for analysis and will analyze them, first
the primary area (highlighted using the selection box in the viewer) and then the rest of the image. If the
primary area selected in viewer indeed contains no visible details then the resulting noise profile will be
accurate.

In difficult cases, Neat Image may be unable to find a sufficiently-large uniform featureless area in the
image. You will notice that the selected area, for example, contains some important details. In such a case,
use the semi-automatic profiling instead (see below).

If you see that the area automatically selected for analysis is indeed uniform and featureless, then the
resulting noise analysis is accurate. To be sure, check the Quality indicator in the Device Noise Profile
box. A profile built using a uniform and featureless area will usually show a high value there.

If the profile quality is high (for example, higher than 60%), then you can be sure that the noise profile is
accurate. In this case, proceed to Stage II. Documenting noise profile, page 36.

If the quality is not high, try to use the semi-automatic profiling instead (see below).

Besides the Quality indicator, Neat Image offers a few more tools to help you build accurate noise
profiles.

When you build a noise profile, the viewer is set to the Assist mode by default. That mode allows to
emphasize the weak details present in Luminance (Y), Cr, Cb channels, as shown in the image below:

The top image shows the original picture where details around the sun are barely visible, while the
channels in the bottom part display the image data in Assist mode allowing to see those weak details much
better.

That can help to verify that the selected area contains no useful details, which is very important for
accurate noise analysis. If you see that some details are present in the selected area then try to use the
semi-automatic profiling instead (see below).

Also, the Device Noise Profile box displays a histogram of the measured noise levels of the current
profile’s frequency components. (In Beginner Mode, the histogram is shown in Profile Viewer only:
menu Profile > Profile Viewer).

Normally, the histogram bars are shaded in green, which means likely-accurate measurements. Yellow or
red shadings are used to indicate likely-inaccurate measurements of the corresponding components.
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It may happen that the lowest frequencies are measured inaccurately (especially
when the analysis area is small). The analysis area may seem featureless, but may
actually contain some gradient-like details. Their presence in the analysis area
may cause the noise levels to be measured inaccurately: the noise levels may be
estimated higher than they really are. An example of such a profile with inaccurate
measurements is shown in the top picture on the right.

A more accurate profiling (perhaps using a larger analysis area) could potentially
produce a better profile. Such a better profile would show a histogram like one
shown in the lower picture on the right.

If a noise profile with inaccurately measured lowest frequencies is used to process
an image, then those inaccurate measurements may lead to loss of details in the
corresponding frequency components. If you disable processing those frequency
components (by setting the Noise Reduction Amounts of those frequency components to 0% in the Filter
> Components settings), this profile can be still used to filter the other frequency components.

Case of semi-automatic profiling

1) Find a uniform featureless image area

è Manually find and select an image area that contains no visible details.1

The area should be as large as possible (up to the maximum of 512x512 pixels). Using a large area is
preferred because that allows to more accurately measure the properties of the noise. Using smaller
areas is possible too, but the accuracy may be reduced. The absolute minimum size is 32x32 pixels.

You can resize the selection frame and check the size of the selection using the W and H indicators
in the bottom of the window. Also, Neat Image will indicate which frequency components can be
measured using the selected area. For example, Good (Low Freq) would mean that all frequency
compoments up to Low (specifically, High, Medium, and Low) can be measured using the selected
area.

Scroll, pan, zoom the image to find a uniform image area and then select this area. Use the Assist
mode of the viewer to better see the weak details and choose an area without details.

If you cannot find a large enough uniform area in the input image, consider using an alternative regular
image or use the Calibration Target as described in the section (Stage I. Case of building a profile
using the Calibration Target, page 35).

2) Analyze selected image area

è Click (the Auto Profile button).

Neat Image will automatically analyze the manually selected image area and then it will also automatically
analyze the rest of the image (it will automatically fine-tune the profile using the whole image).

The profile is now ready. Please proceed to Stage II. Documenting noise profile, page 36.

Case of manual profiling (Advanced Mode only 2)

1) Find a uniform featureless area

è Manually find and select an area that contains no visible details.

The area should be as large as possible (up to the maximum of 512x512 pixels). Using a large area is
preferred because that allows to more accurately measure the properties of the noise. Using smaller
areas is possible too, but the accuracy may be reduced. The absolute minimum size is 32x32 pixels.

1 You can find some examples of uniform featureless image areas in the Examples section, page 52.
2 You can switch using the Tools > Advanced Mode menu item.
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2) Analyze selected area

è Click (the Auto Profile button).

Neat Image will automatically analyze the manually selected area and build a noise profile.

3) Additionally manually fine-tune the profile

Fine-tuning uses additional flat featureless image areas to make the noise profile more accurate.
You can manually select and analyze several such areas one after another.

1) Find and select a uniform featureless area

è Scroll, pan, zoom the image in the viewer in the Device Noise Profile tab to find a new uniform area.

The size of an area may be from 16x16 to 512x512 pixels. Using larger areas makes fine-tuning more
accurate. The edges of the selection frame will change their thickness according to the selection size.

2) Analyze the selected area with Manual Fine-Tune

è Click (the Manual Fine-Tune button) or use the Profile > Fine-Tune Using Selected Area
menu item.

The analysis results will be shown in the noise profile
equalizer: the graphs of the equalizer will change some
of the values (see the picture on the right) each time you
add a new fine-tuning measurement. You can switch
from one channel to another in the equalizer to better
see a specific channel’s graph, or you can select to show
them all together.

The goal of manual fine-tuning is to fill the equalizer
with measured values (shown as graph-color knots) in all
points of the graphs. The previous steps (specifically, the
Auto Profile function) may have already filled some of
the values. Manual fine-tuning can further improve the
analysis by filling out the still missing or interpolated values (shown as yellow knots) and/or making
some of already measured values more precise.

3) Repeat 1-2 above with other uniform areas of different brightness

To make the device noise profile more accurate, fine-tune it using several uniform image areas. Select
areas of different brightness for best results. Try to choose and analyze uniform areas to cover all or
most elements of the equalizer in all its color channels. The more elements of profile are analyzed, the
higher is the overall quality of the profile.

4) Complete fine-tuning using Auto Complete

è Click (the Auto Complete button) or use the Profile > Auto Complete menu item to automatically
complete the fine-tuning by adjusting the unmeasured values using interpolation based on the
measured data.

At this point the profile is ready. Proceed to Stage II. Documenting noise profile, page 36.
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7.2.2. Stage I. Case of building a profile using the Calibration Target

The Calibration Target is specially designed to enable easy profiling of various imaging devices. It can be
used to build a single profile for a certain device mode or a set of profiles for different modes.

Follow the steps below to prepare a single profile using the Calibration Target.

Step 1. Preparing the Calibration Target

To use the Calibration Target, either use the menu Tools > Calibration Target and then click
(the Display target. . . button), or download the image of the Target from the Neat Image web page:
https://ni.neatvideo.com/download/calibration-target

There are two ways of using the Calibration Target: you can open it on the screen and take a shot (with a
digital or film camera, depending on your workflow) or you can print it out and shoot the hardcopy.

Shooting the Calibration Target off the screen is faster, especially with a digital camera. However, be
careful when shooting it off the screen of a CRT monitor because you may occasionally capture scan
bands. These bands may spoil a part of the shot. If you cannot avoid these bands, prepare a printed version
of the Calibration Target or shot it off an LCD monitor, which does not produce this effect. Also, try to
avoid glares when using a monitor with a glass or glossy screen.

Case of shooting the Calibration Target off the screen

è Open the Calibration Target image on the screen (menu Tools > Calibration Target and then click
the Display target. . . button). Then use the displayed Calibration Target in the Step 2 below.

Case of shooting the printed Calibration Target

è Open the Calibration Target image in an image editor and print out the image on a sheet of white matte
paper; make the image fill the whole page. Then use the printed target in the Step 2 below.

Step 2. Preparing a shot or scan of the Calibration Target

Case of digital camera

Use the displayed or printed Calibration Target to prepare a test shot for building a device noise profile for
your camera:

1. Set the camera to a certain shooting mode (ISO level, etc.) you want to build a profile for;

2. Important: set the focusing system on infinity or in macro mode to get a slightly-out-of-focus
image of the target;

3. Make sure the Calibration Target fills the whole frame and make a shot;

4. Open the resulting shot in Neat Image plug-in.

Case of flatbed scanner

Use the printed Calibration Target to prepare a test scan for building a device noise profile for your flatbed
scanner:

1. Set the scanner to a certain scanning mode (resolution, light level, etc.) you want to build a profile
for;

2. If possible set the scanner slightly out of focus (an out of focus scan is preferred for profiling); a
possible way to achieve this is to raise the page over the scanner glass a bit;

3. Scan the printed Calibration Target;

4. Open the resulting scan in Neat Image plug-in.
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Case of slide scanner

Use the displayed or printed Calibration Target to prepare a test scan for building a device noise profile for
your film scanner:

1. Set the camera to a certain shooting mode (film type, exposure, etc.) you want to build a profile for;

2. Important: set the focusing system on infinity or in macro mode to get a slightly-out-of-focus
image of the target;

3. Make sure the Calibration Target fills the whole frame and make a shot;

4. Develop the slide and put it into the scanner;

5. Set the scanner to a certain scanning mode (resolution, light level, etc.) that you want to build a
profile for and scan the slide;

6. Open the resulting scan in Neat Image plug-in.

Step 3. Analyzing image noise

Having the shot or scan of the Calibration Target, Neat Image can build a noise profile automatically:

è Use the Profile > Auto Profile with Calibration Target menu item.

After the analysis is completed, proceed to the Stage II below.

7.2.3. Stage II. Documenting noise profile

At this point of building the noise profile for your camera or
scanner, the noise analysis is done and all important noise
characteristics are gathered in the profile. You may still
want to manually document the profile if Neat Image has
not done this automatically. With most images from digital
cameras, Neat Image is able to automatically extract the
crucial information about the camera mode from the EXIF
data fields of the analyzed image and put this information to
the noise profile (you can see that in the Device Name and
Mode fields in the Device Noise Profile box.

If Neat Image has not automatically placed the required
information to the Device Name and Mode fields after
noise analysis, you can add those details manually.

è Use the Device Name and Mode fields in the Device Noise Profile box. Here, you can specify the
model of the image acquisition device and describe the device mode, which can be something like the
data in the picture above.
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About the Device name and Mode notes

It is highly recommended to specify these details to keep record of devices, device modes and
corresponding device noise profiles that you use.

The noise characteristics of any two devices can be extremely different. Even a single device in
different modes can produce significantly different noise. Therefore, it is always better to use
separate noise profiles for different devices and device modes to avoid inaccurate filtration and
artifacts. Commenting on the device name and device mode parameters helps you keep track of
them when you do manual profile matching, i.e., when you manually select a suitable profile to
process an image.

Automatic profile matching available in Neat Image uses the EXIF information from the image files
and profiles, not the Device Name and Mode fields, so filling out these fields may not be necessary
for automatic profile matching. However, filling out these fields is highly advisable both for the
clarity purposes and for the cases of EXIF-less input images where you have no other choice by to
manually select a suitable profile based on the Device Name and Mode fields.

See the Preparing profile set for different device modes section below to find out more about
camera and scanner parameters that may need to be documented in the Device Name and Mode
fields.

7.2.4. Stage III. Saving the noise profile

è Use (the Save Device Noise Profile As. . . button) in the Device Noise Profile box or use the
Profile > Save As. . . menu item.

In the Save Device Noise Profile As. . . dialog box, select the file name to save the profile to. The
default name is based on the device name and device mode when these are available from the EXIF
data fields of the analyzed image. If the EXIF data are not available then the default profile name is
based on the name of analyzed image file. Use the suggested default or change the name of the file to
store the device noise profile. Device noise profiles are saved in *.dnp files.

File naming considerations

If you are going to re-use a device noise profile later on, select a good file name explaining the
device name and mode so that you could easily recognize this profile by its file name. Alternatively,
you can use special folder structuring to keep many device noise profiles arranged according to
their device modes.

See Stage III. Structuring profile set, page 40, for additional information.

A saved noise profile includes the complete noise analysis. Therefore, by re-opening the noise profile,
you can reproduce exactly the same conditions for image processing later on. Also, you can exchange
noise profiles with other Neat Image users.

7.3. Preparing profile set for different device modes
Usually, an imaging device can work in several different modes. Therefore, there should be several
device noise profiles corresponding to different modes to enable accurate processing of arbitrary images
produced by this device. If a set of profiles covers all modes of the device then any image from this device
can be processed by using one of the profiles from the set.

This subsection explains how to prepare a reusable set of profiles for a range of modes of an imaging
device.

As an owner of a certain imaging device, for example a digital camera, you are in perfect position to
prepare a profile set for that device because you have direct access to the device hardware. Moreover,
building and using your own set of profiles makes noise reduction more accurate because such profiles
better reflect the specifics of the device as well as the workflow you use.

When building a set of profiles, please follow the guidelines below that will help you structure the profile
set in such a way as to make consequent reuse of the set easy for you. And other people if you decide
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to share your results. Please do share because in this way you will help people with the same camera or
scanner model. You can submit a set of profiles to the Neat Image team to publish the set in the profile
library by using a special form at https://ni.neatvideo.com/contacts/upload-noise-profiles or just share
them with other people directly.

7.3.1. Stage I. Selecting device parameters for profile set

To build a set of profiles for particular camera or scanner, you must identify different device parameters
that affect the noise characteristics and that you will take into account during profiling. There may be
many device parameters but not all of them influence image noise and those that do differ by the strength
of their influence. Naturally, you are only interested in those parameters that appreciably affect noise.
Different noise profiles should be prepared for different values of the most important parameters, so you
should identify those parameters in the first place.

The tables below describe the parameters that appreciably affect noise characteristics (from the most to the
less important ones) of digital cameras and scanners:

Digital camera parameters in the order of decreasing importance

ISO rate 50, 100, 200, 400, etc.; depends on
a camera

Higher ISO rate produces more noise.

Camera noise
reduction

High, Normal, Low, etc.; depends
on a camera

In-camera noise reduction can reduce levels of noise
in photos (usually at expense of some details).

Sharpness
adjustment

Low, Normal, High, etc.; depends
on a camera

Internal sharpness adjustment of a camera makes
noise more intensive. Using no internal sharpness
adjustment produces least noise.

Compression

1:1 (or Uncompressed),
1:5 (or Fine), 1:10 (or Normal),
1:20 (or Basic), etc.
or
2 bits/pixel, 4 bits/pixel, etc.
depends on a camera

Strong JPEG compression typically produces
more JPEG artifacts and destroys image elements
including noise; weaker compression preserves more
image elements including noise created by the image
sensor. It is preferable to use the lowest amount of
compression for the best results.

Resolution

1:1 (original resolution, like
4288x2848), 1:2 (downsized in
camera, e.g., 2144x1424), 2:1
(digital zoom, 2x), etc.

In-camera interpolation (both downsizing and
upsizing, e.g., that of digital zoom) changes many
characteristics of noise.

White balance
Sun, Cloudy, Incandescent,
Fluorescent, etc.;
depends on a camera

White balance adjustment changes characteristics of
noise (mainly of color noise) slightly.

Exposure 1/16s, 1.0s, 16s;

Longer exposures produce more hot-pixel noise;
also, some cameras switch on the automatic noise
reduction when exposure is longer than a certain
threshold – this may affect the noise levels.

Scanner / camera parameters in the order of decreasing importance

Film type
For example, Kodak Tmax
400, Kodak Tri-X Professional
320, Fuji Superia 200, etc.

Every film type produces a specific grain pattern, which
depends on the film material. Strength of the grain
depends on ASA/ISO rate of the film.

Scanning
resolution

For example, 300 dpi, 3200
dpi, 4000 dpi, etc.

Higher scanning resolution emphasizes film grain and
makes it more evident in scanned images.

Number of
scan passes

Single pass,
2x pass,
4x pass, etc.

Multi-pass scanning can potentially produce less grainy
images.

If two images were captured in the same or similar conditions (most of the above device mode parameters
are the same) then the noise of these two images should be very similar. If you have built a device noise
profile using one of these images, you can use this profile to filter both images with good results. If
the shooting or scanning conditions were different then the noise in two images could be significantly
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different. In this case, cross-use of one noise profile is not recommended. Instead, two different profiles
should be built and used to filter these two images.

Based on these considerations and tables above, identify the device mode parameters of your camera or
scanner that (1) are important from the noise standpoint and (2) are changed in your imaging tasks. For
example, if you never change the sharpness adjustment of your digital camera then there is no need to
build profiles for different values of the sharpness adjustment parameter. On the other hand, if you do
shoot with different ISO rates then you should build profiles for every ISO rate you use. Some parameters
are less important (for example, the White Balance or Exposure) and you may simply choose to ignore the
slight differences of the noise characteristics caused by changes of those device mode parameters.

Identify and make a list of the device mode parameters that are important for your imaging tasks. For
example, you could include two parameters of your digital camera: the ISO rate (ISO 100, 200, 400) and
JPEG compression level (HQ, SHQ). Then it is straightforward to write down all combinations of the
selected parameters:

JPEG HQ, ISO 100
JPEG HQ, ISO 200
JPEG HQ, ISO 400
JPEG SHQ, ISO 100
JPEG SHQ, ISO 200
JPEG SHQ, ISO 400

Then prepare an individual profile for each combination from this list. Please proceed to the Stage II to
build profiles for all combinations.

7.3.2. Stage II. Building individual profiles

To build individual profiles for the profile set, you can either use the standard profiling procedure described
earlier, or employ a special built-in tool – the Batch Profiler.

Using standard profiling procedure

To build individual profiles using the standard profiling procedure, follow the guidelines of the Building a
profile for a device mode (standard profiling procedure) section, page 30. Using those guidelines, build a
new profile for every combination of the device mode parameters included in your list (prepared in the
Stage I above). The resulting set of noise profiles (several *.dnp files on the disk) can then be structured as
recommended in the Stage III below.

Using Batch Profiler

The Batch Profiler is a dedicated tool that can automatically build several noise profiles using shots or
scans of the Calibration Target (please note that the Batch Profiler is not for regular images). To use this
tool, you must prepare several shots (scans) of the Calibration Target and then analyze them all at once
using the Batch Profiler.

1. Preparing set of images of the Calibration Target

To prepare shot or scan of the Calibration Target for every combination of device mode parameters, please
follow the two initial steps of Stage I. Case of building a profile using the Calibration Target:

Step 1. Preparing the Calibration Target, see page 35.

Step 2. Preparing a shot or scan of the Calibration Target, see page 35.

Do the Step 2 for every combination of device parameters in your list. Then place all resulting image
files (*.jpg, *.tiff, *.png) to a new folder (and its subfolders if necessary) on the hard drive, for example:
Documents∖Target Images∖
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2. Preparing profiles

To prepare profiles using the images of the Calibration Target:

1. Select the Tools > Batch Profiler. . . menu item to open the Batch Profiler window.

2. In the Batch Profiler window, specify the folder with images of the Calibration Target and the
folder where the Batch Profiler should save the prepared device noise profiles.

3. Click the Start button to initiate the profiling process.
When profiling is finished, new noise profiles are saved in the selected target folder.

4. Click the Close button to close the Batch Profiler window.

As the result, you have a set of noise profiles (several *.dnp files on the hard drive) that can be structured
as described below.

7.3.3. Stage III. Structuring profile set

In the Stage II, you have prepared a set of profiles on the disk. You have assigned names to these profiles
that reflect the device modes they correspond to.

For example, profiles for Olympus Stylus SH-2 could be named like the following:

Olympus SH-2
SH-2 (ISO125; JPEG Normal; SharpNormal; 3200x2400).dnp
SH-2 (ISO125; JPEG Normal; SharpNormal; 4608x3506).dnp
SH-2 (ISO125; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO125; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO200; JPEG Normal; SharpNormal; 3200x2400).dnp
SH-2 (ISO200; JPEG Normal; SharpNormal; 4608x3506).dnp
SH-2 (ISO200; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO200; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO400; JPEG Normal; SharpNormal; 3200x2400).dnp
SH-2 (ISO400; JPEG Normal; SharpNormal; 4608x3506).dnp
SH-2 (ISO400; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO400; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO800; JPEG Normal; SharpNormal; 3200x2400).dnp
SH-2 (ISO800; JPEG Normal; SharpNormal; 4608x3506).dnp
SH-2 (ISO800; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO800; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO1600; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO1600; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO3200; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO3200; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO6400; JPEG Fine; SharpNormal; 3200x2400).dnp
SH-2 (ISO6400; JPEG Fine; SharpNormal; 4608x3506).dnp
SH-2 (ISO125; TIFF; SharpNormal; 4608x3506).dnp
SH-2 (ISO200; TIFF; SharpNormal; 4608x3506).dnp
SH-2 (ISO400; TIFF; SharpNormal; 4608x3506).dnp
SH-2 (ISO800; TIFF; SharpNormal; 4608x3506).dnp
SH-2 (ISO1600; TIFF; SharpNormal; 4608x3506).dnp
SH-2 (ISO3200; TIFF; SharpNormal; 4608x3506).dnp
SH-2 (ISO6400; TIFF; SharpNormal; 4608x3506).dnp

- disk folder

SH-2
– camera name

ISO###
– ISO rate of
camera mode

JPEG Normal /
JPEG Fine / TIFF
– file format and
compression level

Sharp#####
– sharpness adjustment

####x####
– image size

When the profiles are named like this, manual selection of a suitable profile is simple. You can check the
device mode of the input image in Photoshop or Neat Image (using using button in the bottom of the
image viewer) and then select and load a profile that matches that device mode.
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There is another way to select profile for an image, based on structuring the profile set using the disk
folders. For example, the above Olympus Stylus SH-2 profile set could be structured like this:

Olympus Stylus SH-2

TIFF (uncompressed)
4608x3506
ISO 125.dnp
ISO 200.dnp
ISO 400.dnp
ISO 800.dnp
ISO 1600.dnp
ISO 3200.dnp
ISO 6400.dnp

JPEG
Fine (high quality)

3200x2400
ISO 125.dnp
ISO 200.dnp
ISO 400.dnp
ISO 800.dnp
ISO 1600.dnp
ISO 3200.dnp
ISO 6400.dnp
4608x3506
ISO 125.dnp
ISO 200.dnp
ISO 400.dnp
ISO 800.dnp
ISO 1600.dnp
ISO 3200.dnp
ISO 6400.dnp

Normal (normal quality)
3200x2400
ISO 125.dnp
ISO 200.dnp
ISO 400.dnp
ISO 800.dnp
4608x3506
ISO 125.dnp
ISO 200.dnp
ISO 400.dnp
ISO 800.dnp

- disk folder

Olympus Stylus SH-2
JPEG/TIFF,
####x####
- the names of disk subfolders
containing device noise profiles
for corresponding device modes;

ISO ###.dnp
- device noise profiles;

Note that the constant parameter (Sharpness
adjustment) is not reflected in the folder
structure. However, if there were profiles
with different values of that parameter then
an additional subfolder should be added.

Parameters that can be disregarded, such as
exposure time, are not reflected in the folder
structure too.

In this case, the folder tree stores device noise profiles in a structured way, which helps to select one
profile from the set given the device mode of the input image.

Note that the automatic profile matching provided by Neat Image does work well in both cases: you
can keep the whole set of profiles as a flat list of files in one folder, or you can structure the files into
subfolders. This choice only affects the convenience of manual selection of profiles, while automatic
profile matching can handle both cases equally well.

If the automatic profile matching is not available (for example, if the images or profiles contain no EXIF
information or the available EXIF details are incomplete) then you have to select profiles manually.
Therefore, we recommend to structure profiles according to one of the methods above to make your
manual work easier.
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7.3.4. Stage IV. Documenting profile set

Along with the text comments inside individual noise profiles and their file names, we advise to document
the whole profile set with a plain text file explaining the following points:

• Author of the profile set and profiling date

• Device name, firmware version

• Device modes that have been profiled in this set


 Device mode parameters that change within the profile set


 Device mode parameters that are constant for all profiles in the set

• Post-processing applied (after receiving an image from the imaging device and before opening it in
Neat Image)

An example of such a description is below:

Olympus Stylus SH-2 noise profiles
by John Smith, June 19, 2015

A set of profiles for Olympus Stylus SH-2 TIFF and JPEG files. The profiles were built using shots of the
Calibration Target for the following file formats and image sizes:

TIFF: 4608x3506

JPEG Fine / Normal: 3200x2400 / 4608x3506

For each file format and image size above, shots with different ISO rates (125, 200, 400, 800, 1600 3200, and
6400) were made and used to build profiles.
For Normal quality JPEG images ISO rates from 1600 to 6400 were not taken.
Default camera settings were used for Sharpness, Contrast, and Saturation. In-camera noise reduction was
switched off. The white balance was set to daylight.
No post processing was applied; the calibration target shots directly from the camera were opened in Neat Image
to build profiles.

Such kind of summary will later help you understand any set of profiles prepared by yourself and will let
other people understand your results if you decide to share your profiles.

7.4. Using noise profiles
When you have a set of profiles for your camera or scanner, you can directly use these profiles to process
images in Neat Image. Usually there is only one profile that is most suitable to process a given input
image. Therefore it is very important to select the right profile, which would provide the best match
between profile and image. Profiles in a set usually correspond to different modes of the imaging device.
To make a perfect match between a profile and image, the device mode of a profile should be the same or
very close to the device mode used to capture the image.

There are two ways to select a device noise profile that matches the input image:

• To automatically select the most suitable profile from a pre-built set of profiles using Auto Match
(see page 14 to learn how to use Auto Match);

• To manually select the most suitable profile from a pre-built profile set based on device mode
comments (see page 14 for details).

When you select and load a profile in either way, Neat Image shows the degree of match between the
profile and input image. This degree is shown by the Match indicator in the Device Noise Profile box.
The match degree is calculated on the basis of the image and profile’s metadata (such as the EXIF data
fields in images produced by digital cameras). If the profile’s device mode is exactly the same as the
device mode used to capture the image then the match is 100%. There is always a 100% match between
an image and profile built using this very image (Neat Image displays that using the note “(AP)” in the
Match indicator). If the device modes of a profile and image are very close then the match degree is close
to 100%. The more different the device modes of profile and image are, the lower the match degree is.
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Use the match degree as an indication of match accuracy. If the match degree is low then it is likely that
building a new profile (using the current input image or a shot of the Calibration Target taken in current
device mode) would produce better noise reduction results.

Obviously it is preferable to build a new noise profile for each new input image (unless the image does
not allow building a quality profile because it contains no large uniform areas for analysis), because such
a profile would perfectly match the noise of that image. Nevertheless, any noise profile can, with some
degree of accuracy, be used to process other images captured by the same device working in the same or
similar mode. This is less accurate than building a profile for each image but saves time because building
a new quality profile can take more time than re-using a pre-built one. This is especially important if one
profile is re-used many times, for example to process a series of images produced in one device mode.
Also, it may not always be possible to build an accurate profile using input image when it contains no flat
featureless areas.

When using pre-built profiles, you may also want to pay attention to the Quality indicator in the Device
Noise Profile box. A properly-built and fine-tuned profile will show a high value in that indicator. If the
profile quality is high (for example, higher than 70%) then you can be sure that the profile is accurate.

Both Quality and Match indicators should usually show high values for the noise reduction of the current
input image using the current noise profile to be accurate.
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8. Additional tools

8.1. Variants of filtration
When adjusting the Neat Image filter settings, you may want to compare different adjustments and
select one that delivers the best visual results. You can of course manually make the adjustments and
check preview after each adjustment, but it would be easier if you could prepare several variants of such
adjustments and then quickly switch between their corresponding previews. Then it would be much
simpler to visually evaluate and compare the results.

That is exactly what variants of filtration do in Neat Image. You can create up to four variants, each with
its own set of filters settings, and quickly switch between them to evaluate their previews.

Here is how you can use variants of filtration (make sure the Noise Filter Settings tab is open):

1 To create a new variant press and hold the button in the toolbar and select one of the available
choices:

a Duplicate
a new variant will be a copy of the current variant (the current filter settings);
you can then modify this new variant by adjusting the filter settings however you like, potentially
making the new variant very different than the original one;

b Default Preset
a new variant will be based on the filter settings obtained via the Default Filter Preset setting in
Neat Image Preferences;

c Select Preset >
a new variant will be based on the filter preset you select from the presets available on the disk (you
select one of them using the context menu);

d Load Preset. . .
a new variant will be based on the filter preset you select from the presets available on the disk (you
select one of them using the regular preset loading dialog).

The new variant is added to the toolbar as a new button with the corresponding name, for example

.

The new variant automatically becomes current: it receives a special shading on its button.

When you make any adjustments to the filter settings, they are applied and kept within the current
variant. So if you want to change filter settings in any other variant, then you need to select that variant
first and only then make any adjustments of the filters.

2 To select one of the existing variants (to make it current) click the corresponding variant’s button in
the toolbar (or press the corresponding number button on the keyboard: 1, 2, . . . ). This will change the
filter settings and preview to the selected variant.

If you now change any filter settings, then the changes will be applied to the current variant.

3 To compare two variants (their previews) you can simply click their buttons to select them alternatively.

There is also an easier and quicker way. If you right-click another (not the current) variant’s button
instead of doing a regular left-click, then the clicked variant is only temporarily selected and the
selection returns to the previous variant once you release the right mouse button. This can be used
to quickly switch between any two variants (the current one and an alternative one) for comparison
purposes: the preview will change from one variant to another and you can easily compare them to
decide which one is better.

4 To delete an unneeded variant use its corresponding remove button ( ).

5 When you are happy with one specific variant simply keep it current and it will then be used by
Neat Image for actual processing.
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8.2. Alternative modes of image viewer
The image viewer in Neat Image can show the working image in several alternative modes to enable
detailed examination of both channel and frequency components. Examining the components helps to
find flat featureless image areas for noise analysis. Also, that allows to visually compare the original and
filtered version of each component and to find optimum filter settings for the corresponding component
easier and faster.

è Use (Viewer mode button) in the viewer toolbar to select
the desired viewer mode.

The viewer mode will change accordingly and will display the image
components separately or as one composite image.

Examine individual channel and frequency components of the image,
check the presence of noise in individual components. Working in
the Noise Filter Settings tab, you can use the separately displayed
components to identify those components that do not receive enough
(or receive too much) noise reduction and adjust the corresponding
filter settings.

You can also adjust the brightness of the viewer to easier see image details and noise in very dark or very
bright areas of the image:

è Use (the viewer brightness controls) in the viewer toolbar to adjust and/or reset the
viewer brightness to better see the noise and details in very dark or very bright areas of the image.

Please note that this adjustment does not change the underlying image data in any way. The adjustment
only affects the image viewer, i.e., the way the image is displayed in it.

8.3. Navigator
The image viewer has an additional Navigator panel, which offers an easy way to locate and navigate to
an area of interest in a large image that does not entirely fit into the viewer, for example when you zoom
into the image to see its fine details. When using Navigator you do not need to zoom out and then again
zoom in (though such an approach to locating an area of interest can be used as well).

è Use (the Navigator button in top-left corner of the viewer), the Tools > Navigator
menu item or press F8 to open or close the Navigator panel.

è Use the mouse pointer to drag the visible area frame (the red rectangle) to the desired part of the
image within the Navigator panel. This will make the main viewer navigate to the same position in
the image.
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8.4. Profile Viewer
The Profile Viewer provides detailed information about the current noise profile.

è Use (the Profile viewer button) in the Device Noise Profile box in the Device Noise Profile tab
to open the Profile Viewer window.

The Profile Viewer provides the following details:

• Image Metadata – this box contains the metadata (such as the EXIF information) associated with
the image used to build this profile. This information is used by Auto Match to find a profile that
matches an input image.

• Main Noise Sample – this is a noise sample (a crop from the image used to build this profile).
The noise sample allows to visually evaluate the noise described by this profile. Also, you can
easily see whether any details are present in this area, which would make the profile less accurate
(only flat featureless areas without any details should be used for profiling, so the sample should
normally contain no visible details).

• Clipping – this indicator tells whether there is any clipping in the analyzed image area. Clipping
occurs when the sample contains pixels that are very close to or in fact are entirely white, entirely
black or have exactly the same color/tone. Clipping reduces the overall profile quality.

• Uniformity – these values show how uniform the noise sample is in all color channels. The
uniformity is low when any details are present in the area. Low uniformity reduces the overall
profile quality.

• Overall Profile Quality – this is an estimation of the overall quality of the noise analysis contained
in this profile. The higher this value the better this profile seems to be. A quality profile is necessary
for quality noise reduction.

• Noise Levels – these figures show the actual noise levels measured during profiling. There are the
noise level of the main sample, average noise level of the whole profile and noise levels of the
channel and frequency components. These figures are a good indication of how noisy the image
acquisition device is.

• Fine-Tuning Completeness – this indicator tells how well this profile is fine-tuned. Fine-tuning
is a part of profiling process (both automatic and manual) and the more complete and accurate
the fine-tuning the higher the overall profiling quality. If you work with Neat Image in Advanced
mode then you can see that the more equalizer values are filled in with measured data the higher
the overall profile quality is. You can improve the profile quality by additional fine-tuning.
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9. Preferences

There are several preferences that adjust the behavior of Neat Image plug-in for Photoshop (Win).

Use the Tools > Preferences. . . menu item to open the Preferences dialog box.

9.1. General preferences

Auto zoom to fit on image open

Check this option to make the image viewer automatically adjust zoom level to fit the image into the
window.

Show hints over interface controls

This option switches on/off the hints. The hints are displayed when the mouse pointer is placed over any
control in the Neat Image interface.

Color Theme

Normal brightness

Neat Image will display its interface elements using the current color theme of the OS.

Reduced brightness

Select this option to switch Neat Image to a custom color theme with reduced brightness.

Updates

Periodically check for software updates

Neat Image can automatically access the Internet to check whether an updated version of the software is
available on the webpage of Neat Image.

Unless this option is disabled, Neat Image will automatically look for updates every few days.

You can also manually run such a check using the Check Now button available there.

Neat Image will display the currently installed version of the software as well as the latest available
version of the product that can be downloaded. When a newer version is available you can use the
provided download link to visit the download area to download and install the updated version.

9.2. Defaults

Default Filter Preset

When you manually reset one or all filter settings using the reset buttons in the Noise Filter Settings
panel, the settings are reset either to the default values pre-programmed in Neat Image or to the values
provided by a user-defined filter preset.

• Program’s default settings
If this variant is selected, then Neat Image resets filter settings to its pre-programmed default
settings.

• Specified custom preset
If this variant is selected and a valid filter preset is specified, then the filter settings are reset
to the values provided by the custom preset from the disk.
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9.3. Profiling preferences

Save noise samples in profiles

Enable this option to make Neat Image save a noise sample from the analyzed image area into device
noise profile (*.dnp file). This will increase the size of the *.dnp file, but will also improve the compatibility
with the future versions of the software (Neat Image will be able to re-build the profile using the saved
noise sample).

Show warnings about selected image area

Enable this option to let Neat Image display possible warnings about the selected image area during
profiling. For example, Neat Image may warn you about clipping or non-uniformity detected in the
selected area, thus helping you select a better area for profiling.

Smart Profile

Smart Profile is one of the possible ways to prepare a noise profile for an image filtration task. Smart
Profile uses both Auto Profile and Auto Match (with Auto Fine-Tune) to prepare two candidate profiles
and then selects the better one of two profiles.

Use the settings in the Smart Profile box to configure the behavior of the Smart Profile function.

Automatically select the best profile

Use this option to let Neat Image automatically decide which noise profile to use.

Prefer profile prepared by Auto Profile

Let Neat Image preferably select the profile prepared by Auto Profile when it can find a good area for
analysis in the input image. When the area is not very good then Neat Image will use the profile prepared
by Auto Match with Auto Fine-Tune.

Prefer profile prepared by Auto Match and Auto Fine-Tune

Let Neat Image preferably select the profile prepared by Auto Match when it can find a matching profile
among the pre-built noise profiles, even when Auto Profile provides a good profile as well.

9.4. Matching preferences

9.4.1. Profile Matching

Use profile matching preferences to adjust the way Neat Image matches noise profiles to input images.

Look for noise profiles in the following folder

If you select this option then Neat Image will look for matching noise profiles in the specified folder.
If you have several sub-folders with profiles, select the topmost folder of all those subfolders to let
Neat Image search in all of them.

By default, the folder used to store profiles (see the Folders > Profile folder setting in the same Preferences
window) is used for matching. You can use any other (sub-)folder for profile matching as well.
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Matching parameter priorities

To automatically match profiles for the input image, Neat Image compares the device parameters of the
input image and candidate profiles selected from the folder specified by the above options. Different
parameters usually have to be matched with different priorities. Using Matching parameters priorities
controls, you can select the priorities of such parameters as Input device, ISO rate, Compression,
Resolution, Sharpness, Exposure:

• Match - the parameter should match exactly;
• High - it is highly important that the parameter is very close or matches exactly;
• Low - it is preferable that the parameter is close or matches exactly;
• Ignore - the parameter is not important at all.

9.5. Preview preferences

Preview

Limit preview size

This option allows to limit the maximum size of the automatic preview area (the preview area selected
by Neat Image itself when you do not select any area manually). Limiting the preview size can be useful
because updating a smaller area is faster than updating preview for the whole image. Also, preparing a
larger preview requires more memory resources, which may be a significant factor on machines with small
amounts of memory resources.

By default, this option is enabled, so if you work with a large image, then the preview is limited to a part
of the image. That limitation only affects the preview, while the final image is processed fully. You can
always adjust the limit upwards or downwards, depending on your needs.

If you disable this option completely, then there will be no limit at all and the whole image will be
processed for preview.

9.6. Performance preferences
The first group of settings in this tab selects the computing devices to be used for image processing. This
group of settings is optional, it is shown only if at least one supported GPU (graphics processing unit)
is available along with the regular CPU (central processing unit, or processor). This group includes the
following items:

Use CPU only

This option makes Neat Image perform all image processing using only CPU.

Use GPU only

This option makes Neat Image perform all image processing using only GPU when possible.

Use CPU and GPU

If you select this option then Neat Image will process images using both CPU and GPU.

Depending on individual performance of each computing device (CPU and GPU), each of the above
options may be the most efficient. You can try different settings and measure the resulting speed using the
Benchmark tool below.
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CPU

Number of used cores

This option adjusts the number of CPU cores used by Neat Image for processing. The number of used
cores can go up to the total number of cores in all CPUs in your computer (like 4 cores in Core i3 with
enabled hyperthreading, 8 cores in a desktop version of Core i7, etc.). If the computer includes two
physical CPUs then the number of cores is correspondingly higher. Ideally, using all cores should provide
the best overall performance. In some cases however, the best processing speed may be achieved if fewer
cores are used (especially on CPUs with hyperthreading). For example, using fewer than all 8 virtual cores
in a Core i7 is in some cases faster, so you may want to test different values of this setting.

GPU

In this box, you can specify which of the available computation-capable GPU devices (CUDA-capable
NVIDIA cards and/or supported OpenCL-capable AMD/ATI cards) should be used for image processing
(in addition to CPU or instead of CPU). When you have one or more GPUs, you can allow Neat Image to
use it and specify how much GPU memory may be used for Neat Image’s image processing. When you
also run other software that uses the GPU, you may want to allow Neat Image to use only a part of the
available GPU memory and leave some part of it free for the other software. When you are not sure, try
different values and see which setting gives the best overall results in terms of performance.

Check Speed

Use the Check Speed button to measure the image processing speed with the current settings specified in
the CPU and GPU boxes.

Optimize Settings

Use the Optimize Settings. . . button to open a specialized dialog designed to measure image processing
speeds achieved with different combinations of the CPU and GPU settings. It allows to automatically
benchmark all possible combinations of settings and to identify the best combination. This is the easiest
way to optimize the performance of Neat Image for specific CPU and GPU hardware.

GPU Troubleshooting

Use the GPU Troubleshooting. . . button to open a specialized dialog designed to check the GPU detection
details and if necessary disable all use of the NVIDIA CUDA and/or AMD/ATI OpenCL GPU by
Neat Image. Disabling all use of GPU by Neat Image may be useful if the GPU driver is faulty or unstable
or if using the GPU by Neat Image causes any other problems.

9.7. Folder preferences

Profile Folder

Select the folder where Neat Image must look for device noise profiles. This should be the topmost
folder of all the (sub)folders with device noise profiles. Neat Image will display all profiles (stored in
all subfolders of the specified folder) in the popup menu in the Device noise profile panel of the plug-in
window and in other parts of Neat Image.

By default, the Profile folder is located in your Documents folder:
Documents∖Neat Image v8 for Photoshop∖Profiles∖

You can select another location to store and use your Neat Image profiles if you prefer.
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Preset Folder

Select the folder where Neat Image must look for filter presets. This should be the topmost folder of all
the (sub)folders with filter presets. Neat Image will display all presets (stored in all subfolders of the
specified folder) in the popup menu in the Filter Settings panel of the plug-in window and in other parts
of Neat Image.

By default, the Preset folder is located in your Documents folder:
Documents∖Neat Image v8 for Photoshop∖Presets∖

You can select another location to store and use your Neat Image presets if you prefer.

Show preset description on load

Enable this option to make Neat Image show the description of the filter preset when you load it from the
disk. The descriptions available in some presets (for example, in presets supplied with Neat Image) is
intended to help you get a better understanding of the purpose, applicability and possible side effects of
the preset.

Folder History

Use independent load and save folders

Enable this option to make Neat Image use independent folders in its file open and save dialogs. If
disabled (the default setting), a save dialog will show the folder where the object (for example, a noise
profile) was loaded from.

Use independent folders for profiles and presets

Enable this option to make Neat Image use independent folders in its file dialogs for different types of
objects: noise profiles and filter presets. If disabled, Neat Image’s file dialogs will open the same folder
when working with different types of objects. By default, this option is enabled.
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10. Examples

10.1. Images to build a noise profile
The image below contains examples of areas that are “good” and “bad” from the standpoint of profiling.
Here, ”good” image areas are highlighted in green, these should be at least 32x32 pixels large, preferably
more than 128x128 pixels; “bad” ones are highlighted in red. If the input image you have does contain
similar “good” flat featureless noise-only areas as shown in the example then you can be sure that Auto
Profile will produce an accurate noise profile. However, if there are no such flat featureless areas in the
input image, then Auto Profile will not work well because building a profile using an area containing
details produces an inaccurate profile that will then lead to very inaccurate filtration. In such a case, you
can build a noise profile using an alternative image containing flat featureless areas or you can use a shot
of the Calibration Target taken by the same camera working in the same mode.

Additional comments regarding the “good” and “bad” areas in this example are available in the next page.
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These image areas are good to build device noise profiles, as they contain no visible details

— GOOD, because this area contains no important details

— GOOD, no important details (this area is from another image)

Examples of “bad” areas that contain visible details:

— BAD, because this area contains a detail: corner – junction of wall and
ceiling

— UNACCEPTABLE, because this area contains many details

— BAD, because this area contains some details: some gradients caused by
differences in illumination of the area

See more examples of building noise profiles on the Neat Image web page:
https://ni.neatvideo.com/support/how-to-use/device-noise-profiling
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10.2. Filtration results
Here are some examples of Neat Image performance.

Input Output

This is a small portion of a digital photo taken with a compact digital camera. The original image contains
easily visible noise. In this case, the source of noise is the camera’s image sensor (CCD) working in high
ISO mode.

Input Output

This image was also taken with a different digital camera. Along with the strong high ISO noise, there is
an image degradation caused by the JPEG compression. Even though Neat Image tries to do its best to
clean up such images, please avoid using strong JPEG compression.

See more filtration examples in the Neat Image web page: https://ni.neatvideo.com/examples
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11. Questions and answers

11.1. General questions
Q What is the difference between Neat Image Demo, Home and Pro editions of Neat Image?

A Different editions have different functional capabilities and limitations as described by the Detailed
feature map, page 58.

Q Should I uninstall Demo edition prior to installing the Home / Pro edition?

A This is not necessary. You can install the Home / Pro edition over the Demo edition. Please make sure
Neat Image is completely closed when you install the Home / Pro edition.

Q Should I uninstall the older version of Neat Image prior to installing a newer one?

A This is not necessary. You can simply install a newer version of Neat Image. It will either replace the
old one or will be available along with the old one (depending on the version).

Q I think I have found a bug. How can I submit a bug report?

A Please use the online bug report form: https://ni.neatvideo.com/support/report-bug
Please fill it out to let us know all the details necessary to reproduce the problem.

See more information about bugs in the Known issues section in Neat Image webpage
(https://ni.neatvideo.com/support/known-issues) and about bug fixes in the WhatsNew.txt file supplied
with the software (also see the history section on the web page for the most up to date information:
https://ni.neatvideo.com/features/version-history/ni8ps?os-tab=win).

11.2. Filtration-related questions
Q Why do I receive some crystal-like artifacts in the filtered image?

A The crystal-like artifacts (usually these are the residual compression artifacts or residual noise) look
like thin lines in the filtered image. They can be eliminated by increasing the (high frequency) noise
level in the filter settings or by using the dedicated Artifact Removal filter described in page 22.

Note: presence of many residual artifacts may be caused by using a poorly built, inaccurate noise
profile or a profile built for another device and/or device mode. Therefore the solution could be
re-building the noise profile.

Q Filtered image looks ‘plastic’. Why?

A The reason is that too much filtration has been applied. Let Neat Image keep some noise to produce
more natural-looking results. Adjust the noise reduction amounts; for example, set the Noise
Reduction Amount: Luminance control to 30-50%. Also, make sure the device noise profile does
match the input image processed. Using an incorrectly chosen or poorly built noise profile can either
produce plastic-looking results or leave residual artifacts (see the previous question).

Q What is frequency?

A The term (spatial) frequency is used in Neat Image to denote elements of an image (both important
details and noise/grain) of certain size.

High frequency corresponds to elements of smallest size. Medium (mid) frequency
corresponds to elements of medium size. Low, Very Low and Ultra Low frequency
correspond to elements of correspondingly larger sizes.

For reference, see the noise samples of different frequencies in the Noise Filter
Settings tab of the Neat Image window.

Q The filtration process is not very fast, is this normal?

A This is normal, because the Neat Image noise reduction algorithms are quite complex. We work on
further optimization to provide better performance.

Q How to filter only the color noise (not the luminance noise)?
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A Set the Noise Reduction Amount: Luminance control to 0%. This will disable the noise filter in the
luminance (brightness) channel.

Q What is YCrCb?

A YCrCb is the name of a family of color spaces widely used in digital imaging, television, video, etc. In
‘YCrCb’ , ‘Y’ corresponds to the luminance channel , ‘Cr’ – to the Cr chrominance channel covering
the red to blue-green color range, ‘Cb’ – to the Cb chrominance channel covering the blue to yellow
color range. Because this space separates the luminance and chrominance information, it is used for
noise reduction where different processing is required in the luminance and chrominance channels.

Q Is processing via Neat Image best done before or after any other processing (i.e. tonal/color
correction)?

A Such operations as tonal/color correction are quite conservative from the standpoint of noise, that
is they do not significantly change the noise characteristics of the image. Therefore, reducing noise
before or after makes little difference – as long as the noise profile is built and applied at the same
stage of your workflow. For example, do not use a noise profile built with an unprocessed (the color
correction is not yet applied) image to filter the same image after the color correction has been applied.

On the other hand, certain effects, like sharpening or resampling, applied to a noisy image may
considerably change its noise properties. In this sense, it is generally better to use Neat Image noise
reduction before applying such effects.
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12. Tips and tricks

12.1. Preventing banding
In some cases, the banding effect may appear when applying the noise filter to images with faint brightness
gradients. This effect is quite rare for normal images.

To avoid banding, try to reduce the noise reduction amount for the high frequency component to 50% or
lower to preserve some high frequency noise in the image.

Another option is to process the image in higher bitdepth.

12.2. Filtration of shadow areas
In some situations, it is preferable to filter only the shadow areas of images leaving bright areas intact.
You can do this by using the noise profile equalizer (available in the Device Noise Profile panel when
working in Advanced Mode) to limit or stop filtration of bright image areas.

The graph nodes in the noise profile equalizer correspond to particular ranges of brightness (individually
for each color channel) of the RGB color space. The vertical position of each node reflects the noise level
in the corresponding range of brightness. So, the lower a node is, the less filtration will eventually be
applied to image elements that belong to the corresponding range of brightness.

Therefore, to filter only shadows you can manually move all the ‘bright’ nodes down (refer to the
gradients in the bottom of the noise profile equalizer to see which brightness level they correspond
to). For example, move down all but the three ‘darkest’ nodes in each RGB channel.

Using this method, you can effectively prevent filtration of the bright image areas.

12.3. Partial filtration
Some images contain both noisy and clean areas and it may be preferable to filter only noisy areas. This
can be manually done by combining two images – original and filtered one – in an image editor. For
example, the following steps can be used:

1. Open the input image in your image editor;

2. Copy the input image in a new layer on top of the original image;

3. Apply Neat Image noise reduction to the top layer;

4. Adjust the transparency of the top layer so that noisy areas look fine;

5. Select and delete the areas of the top layer where filtration is not necessary or excessive (you may
want to use the eraser tool with adjustable transparency and shape).
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13. Information

13.1. Issues and bugs
Please report any bugs or issues you encounter while working with Neat Image. Use the online bug report
form: https://ni.neatvideo.com/support/report-bug.

Your feedback will greatly help us to improve the software and provide you with newer and better versions
of Neat Image.

13.2. Plans
The current version of Neat Image is the result of our ongoing research on noise filtration. We continue to
work on the core noise reduction algorithms to improve the quality and speed of noise reduction.

Please let us know if you have ideas that can make Neat Image better. Please participate in the discussions
taking place in the Neat Image forum: http://www.neatimage.net/forum/

Express your opinion, make suggestions and ask questions.

13.3. Detailed feature map

Features Neat Image

Demo plug-in Home plug-in Pro plug-in
Use for commercial purposes not allowed not allowed allowed

Image
processing

8 bit/channel (24-bit RGB, 8-bit Grayscale) + 1 + +

16 bit/channel (48-bit RGB, 16-bit Grayscale) – – +

32 bit/channel (96-bit RGB, 32-bit Grayscale) – – +

Workflow
Support for Photoshop actions and smart filters – – +

File formats supported all formats supported by plug-in host

Device
noise
profiles

Automatic and semi-automatic profiling +

Manual profiling of any imaging devices +

Automatic matching profiles to input images +

Noise
reduction

Channel components (Luminance, Cr, Cb) +

Frequency components (High, Mid, Low, Very low, Ultra Low) +

Smart
sharpening

Channel components (Luminance, Cr, Cb) +

Frequency components (High, Mid, Low) +

Filter presets (reusable filter settings) +

13.4. Contacts
We really appreciate your opinion of Neat Image. Please let us know what you think about the software.
Feel free to ask questions regarding Neat Image. You can contact us using the following means:

E-mails

info@neatimage.com for general inquiries about Neat Image

photoshop@neatimage.com for technical questions regarding Neat Image plug-in for Photoshop (Win)

sales@neatimage.com for inquiries regarding purchase and licensing of Neat Image

1 A limited part of the input image is processed if the image is larger than 1600x1600 pixels.
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Forum

Register in the Neat Image community forum (http://www.neatimage.net/forum/) and participate in
discussions related to the use and development of Neat Image. The discussions there cover such topics as:

• announcements of new and updated version of the software;

• questions about use of Neat Image;

• examples of using Neat Image with comments and suggestions;

• feedback from the users: suggestions of new features and improvements;

• general comments;

• backup contacts.

Web page

https://ni.neatvideo.com

13.5. Legal information

Copyright

Neat Image © 1999-2021 Neat Image team, ABSoft. All rights reserved.

License agreement

By downloading and/or in any way using the Neat Image (called “Neat Image” hereunder in this agreement)
software you indicate that you do accept this license agreement. If you are unable or unwilling to accept
this license agreement, then you may not use the Neat Image software and must return and/or destroy all
copies of Neat Image in your possession.

You may

Use the Demo edition of Neat Image free of charge for non-commercial purposes only.

Copy and distribute the Demo edition of Neat Image.

Run the Home edition of Neat Image on one (or more, up to the number specified in your license)
computer (computers) at a time only for non-commercial purposes provided you are a registered user and
you have a valid license for the Home edition of Neat Image.

Run the Pro edition of Neat Image on one (or more, up to the number specified in your license) computer
(computers) at a time for commercial and other purposes provided you are a registered user and you have
a valid license for the Pro edition of Neat Image.

You may not

Sublicense, rent, lease and sell any version of Neat Image or any portion of it including the license data
without the explicit written permission from the Neat Image team, ABSoft.

Copy, share and distribute the Home and Pro edition of Neat Image or any portion of it including the
license data without the explicit written permission from the Neat Image team, ABSoft.

Decompile, disassemble, reverse engineer, modify, clone and emulate any version of the Neat Image
software or any portion of it including the license data.

Use the Home and Pro edition of Neat Image if you are not registered user.
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Term and termination

If you are a registered user of the Home or Pro edition of Neat Image and you have purchased a license for
a specific major of Neat Image, then you may use this major version (including all minor updates of the
same major version) and edition of the software without time limitations provided you observe the terms
of this license agreement.

A license for a certain major version of Neat Image may be extended to a higher major version. By
decision of the Neat Image team, ABSoft, this extension may be automatic and free or may involve an
upgrade fee.

You may terminate this license agreement at any time by returning or destroying all copies of Neat Image
in your possession and notifying the Neat Image team.

Your rights derived from this license agreement will terminate immediately if you infringe upon the
Neat Image team, ABSoft’s copyrights or breach the terms of this agreement. Copyright infringement or
breaching this agreement may also result in criminal or civil prosecution.

Disclaimer of warranty

The authors make no warranty or representation, either express or implied, with respect to this software,
its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided “as is”,
and you, its user, assume the entire risk as to its quality and accuracy.

Distribution

The Demo edition of Neat Image may be distributed unmodified provided any charge is to cover distribution
costs only.

The Demo edition of Neat Image may be placed on magazine CDs/DVDs as long as the Neat Image team
is informed.

13.6. Registration
To become a registered user and to get a fully functional copy of Neat Image Home or Pro edition you
need to purchase a license (a single- or multi-user license). Please find the detailed information in the
Purchase section of the Neat Image web page: https://ni.neatvideo.com/purchase

After purchasing a license, you receive an e-mail from the Neat Image team with detailed download and
registration instructions. Using those you will be able to download, install and register the software on
your computer.

By becoming a registered user of Neat Image Home or Pro edition you will:

• Encourage the authors to further improve the software and make it better suited for your needs;

• Get access to all functions of Neat Image Home or Pro edition (see the Detailed feature map, page 58);

• Pro edition only: be able to use Neat Image for commercial purposes;

• Get free updates of the software (minor modifications with the same major version number, for
example, updates from the version v8.0 to any v8.x);

• Enjoy reduced upgrade prices for new major versions of Neat Image, for example when upgrading
from v7 to v8;

• Receive the primary attention of Neat Image support group;

• Receive the primary attention of Neat Image development group
(tell us what you want to see in the next update or new version).

Message from Neat Image team

By purchasing our product you are helping us to further develop and improve the software.

Become a registered user and we will make Neat Image better for YOU!
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luminance, 56
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detail recovery, 23
device noise profile, 12

batch profiler, 39
building, 30

automatic, 32
for a certain mode, 30

for different modes,
37

manual, 33
using calibration

target, 35
using regular image,

31
quality indicator, 32
ready-made, 30
viewer, 46

edge smoothing, 23
examples, 52

feature map, 58
features, 4, 58
filter, 16, 20

noise level, 16, 20
noise reduction amount,

16, 20
filter preset, 25

description, 26
load, 26
save, 25

filter settings, 16
frequency, 55

high, 22, 55
low, 55
mid, medium, 55

frequency range, 7, 53

GPU acceleration

CUDA, 5
OpenCL, 5

high ISO noise, 7, 54

image filtration job
defaults, 47

license agreement, 59

noise filter, 7, 20
noise level, 20, 22
noise reduction amount, 20

partial filtration, 57
performance settings

optimize, 17, 25
plug-in

installation, 8
installer, 8

preferences, 47
preview, 17, 24
profile matching, 14, 42

quality mode, 19

registration, 60

sharpening, 17, 24
system requirements, 5

variants of filtration, 44
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