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1. INTRODUCTION 

1.1. Overview 

This course is designed to give an introduction to National Instruments’ 
Electronics Education Platform. The NI electronics education platform is a 
unique combination of tools including NI Multisim schematic capture and SPICE 
simulation software, NI ELVIS educational design and prototyping platform, NI 
LabVIEW graphical system design software, and NI LabVIEW SignalExpress 
interactive measurement software.  

The focus of the course is on the basic elements of circuit design flow: capture, 
simulation, prototyping and test. Through the exercise, you will familiarize 
yourself with the NI Multisim environment, while you place and wire schematic 
components, simulate a completed circuit, and prototype and measure the 
resulting design with NI ELVIS and NI LabVIEW. 

1.2. Design Challenge 

The exercises in this course are presented in the form of a design challenge. 
Each of the exercises is a step of the engineering design process. The challenge 
is to design a bandpass filter using the 741 operational amplifier. 

In the exercises Multisim is used to capture the filter and investigate its 
characteristics, including gain and bandwidth, through simulation. The 3D 
environment will also be explored for prototype the circuit in a 3D 
breadboarding environment. If you have the National Instruments Educational 
Laboratory Virtual Instrumentation Suite (NI ELVIS or NI ELVIS II) workstation, 
you can prototype this circuit in the lab and measure its characteristics. Finally, 
during the last stage of the process, compare the real-life behavior of the 
circuit with the simulations created in Multisim. Figure 1 shows the design 
process by the corresponding exercise number. 
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Figure 1. Design Process 

1.3. Course Requirements 

1. NI Multisim 10.1 and above 
2. NI ELVIS II and the NI ELVISmx 4.0 driver 
3. NI LabVIEW SignalExpress 
4. NI LabVIEW 8.5.1 or later 

1.4. Electronics Education Platform with Multisim, NI ELVIS and 
LabVIEW 

The Electronics Education Platform is a complete tool-chain consisting of 
Multisim circuit capture and simulation software, industry standard National 
Instruments LabVIEW graphical systems design software, and NI ELVIS 
educational design and prototyping platform. These products work together to 
form an unparalleled platform for circuits and electronics education.  

 

 

Figure 2. The NI Electronics Education Platform 

Through the Electronics Education Platform, students first use Multisim for 
capture and simulation. They are able to place components on the 3D 
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breadboard in Multisim and then build the circuit on the NI ELVIS II 
workstation. The NI ELVISmx instruments can display actual data from the NI 
ELVIS II unit as well as simulated results from Multisim, making it easy to 
compare actual and theoretical values. Finally, LabVIEW offers even more 
capabilities for advanced analysis of the data. 

Traditional struggles that students encounter while transitioning from theory, 
to design and finally to the physical lab, can be addressed with this integration 
of Multisim and NI ELVIS. With a single click of a mouse, NI ELVIS II virtual 
instruments can be accessed inside the Multisim simulation environment. 
These same NI ELVIS instruments in Multisim can be used for displaying 
simulation data and controlling and measuring real data. Students do not need 
to learn a new tool as they move between circuit simulation and real-world 
measurements.  

Multisim 
Multisim is a powerful and intuitive software package designed with educators 
in mind. If offers students an easy-to-use environment for capture and 
simulation of circuits and electronics.  

Multisim is a powerful and intuitive software package designed to give students 
an easy-to-use platform for capturing and simulating circuits. It includes a 
professional-grade SPICE simulation engine, powerful analyses, interactive 
components and virtual instruments such as oscilloscopes and function 
generators to easily simulate circuits. 

Multisim MCU Module 
The National Instruments Multisim MCU Module adds microcontroller unit 
cosimulation capabilities to Multisim, so you can include a microcontroller, 
programmed in assembly or C code, within your SPICE-modeled circuit. 

The Multisim MCU Module works with Intel/Atmel 8051/8052 and Microchip 
PIC16F84A chips as well as a broad range of advanced peripherals such as 
external RAM and ROM, keypads, and graphical and alphanumeric LCDs. With 
the Multisim MCU Module, students can take full advantage of the Multisim 
educational platform, which makes it the ideal choice for courses such as digital 
electronics, computer architecture, MCU programming, embedded control, 
senior design, and more. 
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The former Multisim MCU Module, has now been made a standard feature in 
NI Multisim. Users now get the advanced simulation of the PIC1684(a) and 
8051/8052 feature for no additional cost. 

Ultiboard 
National Instruments Ultiboard provides intuitive PCB layout and routing. You 
can take designs from Multisim interactive SPICE-based simulation or begin 
from scratch using parts from the built-in Ultiboard database of land patterns. 
Ultiboard contains many time-saving features that can help you quickly learn 
and understand the PCB layout process. For example, using the spreadsheet 
view, you can drag and drop components into their intended locations on 
schematics. Then, by using follow-me routing or drawing traces, you can easily 
route all of their design nets. 

NI ELVIS 
The National Instruments Educational Laboratory Virtual Instrumentation Suite 
(NI ELVIS) is a design and prototyping environment based on LabVIEW for 
university science and engineering laboratories. 

NI ELVIS consists of virtual instruments based on LabVIEW, a multifunction data 
acquisition device, a custom-designed benchtop workstation and prototyping 
board. This combination provides a ready-to-use suite of instruments found in 
all educational laboratories. Because it is based on LabVIEW and provides 
complete data acquisition and prototyping capabilities, the system is ideal for 
academic coursework, from lower-division classes to advanced project-based 
curricula. Curriculum applications include electronics design, communications, 
controls, mechatronics, instrumentation, and data acquisition. 

The new NI ELVIS II features a high speed plug and play USB interface, true 
Multisim integration, an isolated digital multimeter, and a set of device 
software based on the NI-DAQmx. 

NI ELVIS II is an open architecture, enabling leaders in other areas such as 
control design, MCU/Embedded, or telecommunications to build add-on 
modules that professors can use to teach concepts. These extensions to NI 
ELVIS II and the ease-of-use of the LabVIEW software make NI ELVIS II an ideal 
multidisciplinary engineering platform. Use the NI ELVIS II to teach engineering 
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concepts in circuit design, measurements & instrumentation, control design, 
telecommunications and embedded design for different departments, including 
electrical, computer, biomedical, mechanical and aerospace engineering and 
physics. 

LabVIEW and LabVIEW SignalExpress 
National Instruments LabVIEW is an open environment designed to make 
interfacing with any measurement hardware simple. With interactive 
assistants, code generation, and connectivity to thousands of devices, LabVIEW 
makes gathering data as easy as possible. 

LabVIEW has more than 500 built-in functions designed specifically for 
extracting useful information from any set of acquired data and for analyzing 
measurements and processing signals. LabVIEW provides tools for data 
visualization, user interface design, Web publishing, report generation, data 
management, and software connectivity. 

With Multisim, you can place certain instruments, based on LabVIEW, on 
schematics to extend the functionality of the simulator. For example, Figure 
3you can configure an expression-based source that can input any formula in 
terms of time as a voltage to your circuit. 

LabVIEW SignalExpress is an interactive software for quickly acquiring, 
comparing, automating, and storing measurements. You can use LabVIEW 
SignalExpress to streamline your exploratory and automated measurement 
tasks for electronics design, validation, and test. LabVIEW SignalExpress 
introduces an innovative approach to configuring your measurements using 
intuitive drag-and-drop steps that do not require code development.  
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Figure 3. Virtual Instrument Based on LabVIEW for Use in Multisim 
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2.  SCHEMATIC CAPTURE 

2.1. The Multisim Environment 

The Multisim user interface consists of the basic elements illustrated in Chyba! 
Nenalezen zdroj odkazů.. 

 

Figure 4. The Multisim Environment 

2.1.1. Design Toolbox 
Use the Design Toolbox to manage various elements in the schematic. With the 
Visibility tab, you can choose which layers to display on the current sheet on 
the workspace. The Hierarchy tab contains a tree that shows the dependencies 
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of the files in the design that you have opened. The Project tab displays 
information about the current project. You can add files to the existing folders 
of the current project, control access to files, and archive designs. 

2.1.2. Spreadsheet View 
With the Spreadsheet view, you can conduct fast advanced viewing and editing 
of parameters including component details such as footprints, reference 
designators, attributes, and design constraints. This view also provides a global 
perspective on object properties. 

2.2. Schematic Components 

Components form the basis for any schematic. A component is any part that 
you can place onto the schematic. Multisim defines two broad categories of 
parts: real and virtual. It is important to understand the difference between 
these parts to fully use their advantages. 

Real components can be differentiated from virtual parts because real 
components have a specific value that you cannot change as well as a PCB 
footprint. 

 

Figure 5. Various Component Symbols – 7-Segment Display U1, Diode D1, Voltage Source 
V1, NAND Gate U2A, Microcontroller U3, and Transistor Q1 
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Virtual components are simulation-only components, which you can assign 
user-defined characteristics. For example, a virtual resistor can take on any 
arbitrary resistance. Virtual components can help you check calculations by 
simulating designs with precise component values. Virtual components can also 
be idealized components such as the 4-pin hex display shown in Figure 5. 

2.2.1. Component Toolbars 
With Multisim toolbars, you can quickly and easily place the most commonly 
used circuit components. There are several toolbars available. The Component 
toolbar opens the component browser and points to an entire category of 
components such as digital components, analog components, or basic passive 
components including resistors and capacitors. The Component toolbar, shown 
in Figure 6, is visible by default. 

 

Figure 6. The Parts Bin or Component Toolbar 

Multisim also provides toolbars for direct placement of components including 
resistors, capacitors, ground references, and voltage sources. The basic 
toolbars are not shown by default. You can make any toolbar visible by clicking 
on its name from the View » Toolbars menu. Figure 7 and Figure 8 illustrate 
toolbars that you can use to direct placement of components. 

 

Figure 7. Basic Component Toolbar (Direct Placement) 

 

Figure 8. Power Source Component Toolbar (Direct Placement) 

In Multisim 10.1 and above, NI ELVIS Instruments will be accessible through the 
NI ELVISmx Instruments Toolbar. These NI ELVISmx Instruments allows the user 
to place virtual instrument in the circuit window and have access to the soft 
front panel. 
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Figure 9. NI ELVISmx Instruments Toolbar 

Component Browser 
Use the Component Browser to select components for placement onto the 
schematic. To access the Component Browser, click on any icon in the 
Component toolbar or select Place/Component. Double-click on the desired 
component to place it on the schematic. The component “ghosts” the mouse 
cursor until you click the left mouse button again to place the component. 
Figure 10 illustrates the Component Browser window. 

 

Figure 10. The Component Browser 

To search this view, simply start typing the name of the desired component, 
and the browser automatically displays matching candidate parts. Optionally, 
for a more detailed search, click on the Search button. 

The Component Browser shows the current database in which the displayed 
parts are stored. Multisim organizes the parts by group and family. The 
browser also shows the symbol, a description of the component in the Function 
field, the model, and the footprint/manufacturer. 

You can use the wildcard character ‘*’ to match any set of characters. For 
example, “LM*78” matches components “LM*AD” and returns both 
“LM101AD” and “LM108AD,” among others.  
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2.3. Schematic Wiring 

Multisim provides modeless operation – the action performed by the mouse 
cursor is dependent on the cursor’s location. There is no need to select a tool 
or mode when working with Multisim. The cursor changes depending on the 
object underneath it. Figure 11 describes the different icons that the mouse 
cursor displays.  

When the cursor is over a pin or terminal of a component, you can easily wire 
that component by left-clicking. When the cursor is over an existing wire and 
near a pin or terminal, you can easily rewire the net. Alternatively, you can left-
click on the terminal to begin wiring, then left-click on the destination terminal 
to finish the wire. 

 

 

 

Figure 11. Modeless Mouse Cursors 

 

 

Figure 12. Naming Nets 

 

When you place a wire, Multisim automatically assigns it a net number. Net 
numbers increase sequentially, beginning with 1. Ground nets are always 
numbered 0 – a requirement of the underlying SPICE simulator. To change a 
net number or assign it a logical name instead, simply double-click on the wire 

Cursor Mode 

 
Place or Move 

Part 
Select Menu Item 

or Icon 

 
Place Wire 

 
Rewire / Move 

Wires 
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(Figure 12) and type in a Net name. Check the box Show, if you want the name 
of the wire to be displayed on your screen. 

2.3.1. Autowiring by Touching Pins 

Multisim also offers autoconnection of pins to wires and pins to pins. To 
automatically connect a component to existing nets or pins, simply place that 
component so that its pins are touching an existing net or pin.  

 

Figure 13. Autowiring by Touching Pins 
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2.3.2. Autoconnecting Passives 
Multisim provides the ability to place a component in-line with an existing wire 
or set of wires. To automatically split an existing wire around a component, 
simply place that component in-line with the wire (Figure 14). 

 

Figure 14. Autoconnect Passives 
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3. EXERCISE 1 – SCHEMATIC CAPTURE 

3.1. Objective 

Design and capture a band-pass filter using the 741 op-amp. This exercise has 
been designed to introduce users to the component browser. By the end of this 
exercise, you should be able to open the component browser, search and find 
components and wire a basic circuit in Multisim. 

3.2. Design 

The completed bandpass filter for capture is shown in Figure E1-1. This exercise 
teaches you how to capture this schematic. 

 

Figure E1-1. Fully Captured Bandpass Filter 

3.3. Procedure 

A. Capture 
The first step in the process is to select and place the components for the 
bandpass filter. 

1. Locate and place the 741 op-amp. 
a. Click Place » Component from the Main menu. 
b. From within the Component Browser, click Search. 
c. Enter “741” into the Component field, and click Search. 
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Multisim then runs a search and returns all the components named 741. In this 
search, you can also use an asterisk (‘*’) as a wildcard. For example, the search 
term “*741” returns the SML4741 component as well as the 741op-amp. 

d. Accept the 741 by clicking OK. Notice that the Component Browser seen 
in Figure E1-2 now displays the exact location of the 741 (Analog Group, 
OPAMP family).  
 

 

Figure E1-2. Component Browser 

e. Click OK again, and the op-amp ghosts the mouse cursor. Click anywhere 
on the schematic to finalize the placement. 

f. Click CLOSE within the Component Browser window 
g. Right-click on the 741 and choose Flip Vertically to have the negative 

input on the top.  
2. Place the passive components using the basic toolbar shown in Figure E1-3. 

To make the basic toolbar visible, click View » Toolbars » Basic. 
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Figure E1-3. Basic Component Toolbar (Direct Placement) 

a. Place the resistors R1 and R3, the capacitors C1 and C2, and the 
potentiometer R2 by clicking once on the corresponding basic toolbar 
icon and clicking again on the schematic. You can rotate components by 
90 deg by pressing Ctrl-R while the component is ghosting the mouse 
cursor. 

If you are unhappy with the location of a placed component, you can simply 
left-click and drag that component to a new location. Multisim automatically 
reroutes any connected wires. 

3. Place the VCC, VEE, and GND components using the power sources toolbar 
shown in Figure E1-4. 

 

 

Figure E1-4. Power Source Components Toolbar (Direct Placement) 

a. Select View » Toolbars » Basic to view the Power Source Components 
Toolbar 

b. Click on the VCC toolbar button and place the VCC component on the 
schematic. 
 

 
 

c. Click on the VEE toolbar button and place the VEE component on the 
schematic. 
 

 
 

d. Click on the GND toolbar button and place the GND component on the 
schematic. 
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e. Double-click on the VCC and change its value to 15 from the Value tab. 
f. Double-click on the VEE and change its value to -15 from the Value tab. 

Your schematic should look like the diagram in Figure E1-5. 

 

Figure E1-5. Power Source Components Toolbar (Direct Placement) 

3.3.1. B. Wiring 
The second step in the process is to wire the components previously placed in 
Section A. To create a wire, simply click on the source terminal and click a 
second time on the destination terminal. Multisim automatically routes a wire 
between the two terminals.  

1. Connect the input of the circuit. 
a. Double-click on a blank area of the schematic worksheet to create a 

single-ended connection.  
b. Click on the input of R1 to complete the connection. 
c. Right click on the wire and select Properties. In the Net name field type 

in input. 
 

2. Connect the output of the circuit. 
a. Double-click on a blank area of the schematic worksheet to create a 

single-ended connection.  
b. Click on the output of U1 to complete the connection. 
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c. Right click on the wire and select Properties. In the Net name field type 
in output 

3. Complete the remainder of the wiring by clicking source and destination 
terminals. The resulting circuit should match Figure E1-6. 

 

Figure E1-6. Completed Bandpass Schematic 
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4. SIMULATING CIRCUITS 

4.1. Overview 

While a good design naturally follows from quality schematics, you can make truly great designs with 
the help of simulation. Multisim provides powerful simulation capabilities and features that can 
greatly ease the process of simulating circuits. 

Simulating a design can result in fewer design iterations and less chance of errors in the prototype 
stage of product development. When you simulate a design at the front end of the design process, you 
can significantly reduce the number of design cycles. 

In addition to a world-class SPICE (Simulation Program with Integrated Circuit Emphasis) simulator, 
Multisim includes XSPICE simulation, enabling fast simulation of digital components. 

4.2. The Multisim Approach to Simulation 

Multisim simulation is built around the mature industry-standard SPICE 
simulation engine. SPICE simulation employs sophisticated and proven 
algorithms to accurately converge on a mathematical solution for a circuit’s 
operation. 

With Multisim, you gain the advantages of SPICE without needing knowledge of 
low-level simulation details. You can quickly and interactively conduct SPICE 
simulation with the click of a mouse using Multisim virtual instruments. These 
simulated benchtop instruments connect to your schematics and report 
simulation results through familiar interfaces such as an oscilloscope or 
spectrum analyzer. As you concepts and details of simulation, you can ease 
your way into much more advanced applications. 

Multisim incorporates industry-standard SPICE versions 3F5 and XSPICE at the 
core of its simulation engine, with customized enhancements to optimize 
simulation performance and improve convergence. 

4.2.1. Simulation Toolbar 
The Simulation toolbar is the simplest way to begin an interactive simulation of 
a circuit in Multisim. It contains buttons to start, stop, and pause simulation. If 
you have the Multisim MCU Module, you can also use the Simulation toolbar 
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for advanced debugging including stepping into, out of, and over, as well as 
setting breakpoints. Figure15 illustrates the Simulation toolbar. 

 

Figure 15. Simulation Toolbar 

4.3. Virtual Instruments 

Multisim provides more than 25 virtual instruments to measure the simulated 
behavior of circuits. These instruments, such as oscilloscopes, function 
generators, and multimeter, connect to circuits and operate just like their real-
world counterparts. They look similar to the benchtop instruments used in the 
lab, making it easy to transition between benchtop and virtual instruments. 
Each virtual instrument has three views associated with it. The icon identifies 
the instrument on the Instruments toolbar, while the symbol represents the 
instrument once it is placed on a circuit. Through the front panel, users can set 
parameters and view data. Using virtual instruments is the easiest way to 
examine circuit behavior and show the results of a simulation. Appendix A lists 
the many virtual instruments available.. 

Using Multisim, you also can place certain custom LabVIEW virtual instruments 
on schematics. These instruments help you customize and extend Multisim 
simulation capabilities, do not require LabVIEW installation, and are 
downloadable for free from our website, www.ni.com 

For a detailed description and tutorial on how to use any of the instruments, 
consult the Multisim help file or see Appendix B for additional resources. 

4.3.1. Instruments Toolbar  
With the Instruments toolbar, you can place the Multisim virtual instruments 
on your workspace. Several instruments are discussed in more detail in the 
following paragraphs. 
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Figure 16. Instruments Toolbar 

4.3.2. The Oscilloscope 
The default dual-channel oscilloscope in Multisim displays the magnitude and 
frequency variations of electronic signals. It can provide a graph of the strength 
of one or two signals over time, or enable comparison of one waveform to 
another. 

Toolbar Icon Schematic Symbol Instrument Front Panel 

 

 

 

 

 

 

 

 

4.3.3. The Bode Plotter 
The Bode plotter, which produces a graph of a circuit’s frequency response, is 
most useful for analyzing filter circuits. You can use the Bode plotter to 
measure a signal’s voltage gain or phase shift. When you attach the Bode 
plotter to a circuit, you can perform a spectrum analysis. 
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Toolbar Icon Schematic Symbol Instrument Front Panel 

 

 

 

 

 

 

 

 

4.3.4. Function Generator 
The function generator is a voltage source that supplies sine, triangular, or 
square waves. It provides a convenient and realistic way to supply stimulus 
signals to a circuit. You can change the waveform and control its frequency, 
amplitude, duty cycle, and DC offset. The function generator’s frequency range 
is great enough to produce conventional AC as well as audio- and radio-
frequency signals. 

Toolbar Icon Schematic Symbol Instrument Front Panel 

 

 

 

 

 

 

 

 

4.3.5. Measurement Probes 
The measurement probe is a fast and easy way to check voltage, current, and 
frequency readings at different points in the circuit. Clicking on the 
measurement probe toolbar icon, the mouse cursor turns into a probe. By 
hover over any node on the circuit while simulating allows you to view reading 
on the fly. Optionally, click on wires before or during simulation allows you to 
place multiple probes to monitor several nodes. 
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Toolbar Icon Schematic Symbol 

 

 

 

 

 

 

4.3.6. NI ELVIS II Instruments 
From the same instrument toolbar seen in Figure 16, you can also choose NI 
ELVIS II instruments from the NI ELVISmx Instruments Toolbar. 

These NI ELVISmx Instruments allows the user to place virtual instrument in the 
circuit window and have access to the soft front panel. 

Toolbar Icon Schematic Symbol Instrument Front Panel 

 

 

 

 

 

 

 

 

4.4. Analyses 

4.4.1. Overview 
Multisim offers many analyses, all of which use simulation to generate the data 
for the desired analysis. These analyses, which range from basic to extremely 
sophisticated, often require you to perform one analysis as part of another. To 

FGEN
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configure and begin an analysis, select Simulate » Analyses and choose the 
desired analysis. Figure 17 lists all available Multisim analyses. These analyses, 
including options as varied as Fourier and Monte Carlo analyses. Descriptions of 
each are in Appendix A. For each analysis, you configure the settings that tell 
Multisim exactly how to perform the desired analysis. In addition to the 
analyses provided by Multisim, you can create user-defined analyses based on 
user-entered SPICE commands. 

To prepare an analysis, configure the analysis-specific parameters, such as 
frequency range for an AC analysis. as shown in Figure 18. You also must select 
output traces here. It is especially important to name nets appropriately to 
avoid confusion when analyzing results. The results are displayed on a plot in 
the Multisim Grapher and saved for use in the Postprocessor. Some results are 
also written to an audit trail, which you can view by selecting Simulate » 
Simulation Error Log/Audit Trail. 

 

Figure 17. Available Analyses 

 

 

Figure 18. AC Analysis Options Dialog Box 
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4.5. Grapher 

The Grapher tool displays graphs and charts, allowing you to view the results of 
analyses. In addition, it can be used to view traces for virtual instruments. You 
are able to customize graphs, select various views, and import or export 
analysis results. To use the Grapher, which is featured at the end of this section 
in Exercise 2B, select View » Grapher. 
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5. EXERCISE 2A – SIMULATING CIRCUITS 

5.1. Objective 

Use interactive simulation to measure the gain, bandwidth, and center 
frequency of the bandpass filter. Interact with components while simulation is 
running to see the effects of changing feedback resistance on overall circuit 
operation. 

5.2. Design 

This exercise uses the function generator, oscilloscope, and Bode plotter to 
measure the characteristics of the bandpass filter. You can work directly with 
the completed schematic from Exercise 1 or open “Exercise 1– Bandpass Filter 
(Complete).ms10” to continue the exercise. The schematic ready for simulation 
is shown in Figure E2-1. 

 

Figure E2-1. Complete Schematic for Exercise 2A 

5.3. Procedure 

1. Place and connect the function generator. 
a. Click first on the function generator from the Instruments toolbar 

circled in Figure E2-2 and then click again on the schematic to place the 
instrument. 
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Figure E2-2. Instruments Toolbar with Function Generator Highlighted 

b. Connect the positive terminal of the function generator to the input of 
the circuit. 

c. Connect the center reference terminal to a ground terminal.  
Your schematic should look like Figure E2-3. 

 

Figure E2-3. Schematic with Function Generator 

2. Place and connect the oscilloscope. 
a. Click first on the oscilloscope from the Instruments toolbar circled in 

Figure E2-4 and then click again on the schematic to place the 
instrument. 

 

Figure E2-4. Instruments Toolbar with Oscilloscope Highlighted 

b. Connect the negative terminals of channels A and B to ground (place new 
ground components if needed).  

c. Connect the positive trace of Channel A to the input of the circuit. 
d. Connect the positive trace of Channel B to the output of the circuit. 
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Now change the color of the wire leading into the positive terminal of Channel 
B. The color of the wires connected to the terminals of this oscilloscope should 
match the color of the traces displayed on the oscilloscope’s front panel. 

e. Right-click on the red wire leading into Channel B+ and choose Segment 
Color. Pick a dark blue from the palette dialog. 

Your schematic should look like Figure E2-5. 

 

Figure E2-5. Schematic with Oscilloscope Placed 

3. Place and connect the Bode plotter. 
a. Click first on the Bode plotter from the Instruments toolbar circled in 

Figure E2-6 and then click again on the schematic to place the 
instrument. 

 

Figure E2-6. Instruments Toolbar with Bode Analyzer Highlighted 

a. Connect the negative terminals IN and OUT of the Bode plotter to a 
ground terminal. 

b. Connect the positive IN terminal to the input of the circuit. 
c. Connect the positive OUT terminal to the output of the circuit. 

Your circuit is now ready for simulation. It should resemble Figure E2-7. 
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Figure E2-7. Completed Schematic Ready for Simulation 

4. Use the function generator and oscilloscope to simulate the circuit and 
explore its transient characteristics. 
a. Start the simulation by clicking the Simulate button from the Simulation 

toolbar circled in Figure E2-8. 

 

Figure E2-8. Simulation Toolbar with Simulate Button Circled 

b. Open the function generator and oscilloscope front panels by double-
clicking on their schematic symbols. Click the Reverse button on the 
oscilloscope to turn its background color white, making it easier to see 
the results. 

c. Verify your circuit is operating as expected by configuring the function 
generator and oscilloscope as shown in Figures E2-9 and E2-10. 

 

Figure E2-9. Function Generator Configuration 

 

 

Figure E2-10. Oscilloscope Configuration 
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d. While the circuit is simulating, investigate how changing the resistance of 
R2 affects the overall gain and phase shift of the circuit. To change the 
resistance of the potentiometer, hover the mouse over the component 
and click and drag the slider. 

e. Drag the slider to 100 percent, which represents the full 1 kΩ resistance 
of the component. 

5. Using the Bode analyzer, measure the frequency characteristics of the 
circuit. 
a. Stop simulation by clicking the Stop button from the Simulation toolbar. 
b. Start the simulation to rerun the AC analysis to reflect the new value of 

100 percent for the potentiometer R2.  
c. Open the Bode analyzer front panel by double-clicking on it. Click the 

Reverse button to turn the background color white. The Bode plotter 
front panel should look similar to Figure E2-11. 

 

Figure E2-11. Bode Plotter Showing Center Frequency Measurement 

Now measure the center frequency and gain. 

d. Right-click on the cursor and choose Go To Next Y_MAX =>. This is the 
center frequency. If your center frequency is different, verify that the 
potentiometer is set to 100 percent and stop and restart the simulation.  
Expected center frequency:  223.9 Hz 
Expected overall gain:   -6.0 dB 

Measure the -3 dB points of the circuit. The -3 dB points are the frequencies at 
which the gain is 3 dB below its maximum value. In this case, the -3 dB points 
are the frequencies where the gain of the circuit is -9 dB.  
Drag the cursor on the front panel of the Bode plotter to measure the two -3 
dB points of the circuit. You can also right-click on the cursor and, depending 
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on its current location, choose Set Y_Value =>or Set Y_Value <=.Enter -9 as the 
value and select OK. 

Expected lower -3 dB point:  117 Hz 
Expected upper -3 dB point:  433 Hz 

You can save the simulation results generated in this section for comparison 
with measurements by clicking the Save button from each front panel.- 
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6. EXERCISE 2B – SPICE ANALYSES 

6.1. Objective 

Having completed interactive simulation, we are able to utilize SPICE analyses 
to measure the center frequency of the bandpass filter while learning how to 
effectively use the grapher tool to analyze simulation data. 

6.2. Design 

This exercise continues to use the same bandpass filter completed in the 
previous exercises. You can open the Exercise 2b - Bandpass Filter 
(Complete).ms10 file to continue this exercise (as seen in Figure E2-12) 

 

 

Figure E2-12. Bandpass Filter 

6.3. Procedure 

1. Select Simulate » Analyses. You will notice the various analyses that are 
available in NI Multisim. 

2. Select AC Analysis… 
The AC Analysis dialog box contains 4 tabs: 
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o Frequency Parameters 
This tab allows you to set-up the start and stop frequencies, simulation 
sweep type and the vertical scale units 

o Output 
 Sets the nodes and nets at which a simulation will be performed 

o Analysis Options 
Sets the SPICE simulation parameters such as the custom settings for 
integration, error tolerance etc… 

o Summary 
A list of the AC Analysis simulation settings chosen in the previous 3 tabs 

3. Select the Frequency Parameters tab and set the following values (as seen in 
Figure E2-13): 
Start Frequency (FSTART):  1 Hz 

Stop Frequency (FSTOP):   1 GHz 

Sweep Type:    Decade 

Number of points per decade:  100 

Vertical Scale:    Decibel 

 

Figure E2-13. AC Analysis Frequency Parameters 
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4. Select the Output tab and set up the SPICE simulation to perform an AC 
Analysis at the output of the band-pass filter (as seen in Figure E2-14) 

5. In the right-hand side of the analysis you will notice the Variables in circuit 
field. In this field you will see a list of all of nets in the design at which a 
simulated voltage value can be measured. These variables are listed with 
their names. Notice the variable V(output) which represents the voltage at 
the output of our band-pass filter.  

6. Select the V(output) variable. 

 

Figure E2-14. AC Analysis Output Tab 

7. Click on the Add button. Notice that V(ouput) is now a selected variable for 
analysis. We are ready to simulate 

8. Click on the Simulate button. 
9. The Grapher View is now open. If you see the black background and would 

like to reverse the color of the background to white, click on the reverse 
button (as seen in Figure E2-15). 
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Figure E2-15. AC Analysis of Bandpass Filter 

6.4. Using the Measurement Probe 

We will learn now about setting up some of the advanced features of the 
Multisim SPICE simulation environment as well as of using the Grapher 
interface. 

Before we return to our analysis we will discover a way in which to better 
identify a node of interest to measure in our simulation. Recall that previously 
in the analysis we selected our node of interest by using its net name, 
V(output), which in a large design, may be difficult to find.  

In this exercise we will use a measurement probe to name and identify the 
node we will eventually study. 

A measurement probe can be used both to identify a node in an analysis as well 
as provide instantaneous measurement data during an interactive simulation. 

1. In the instruments toolbar select the measurement probe (as seen in Figure 
E2-16). 

Reverse 
Button 
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Figure E2-16. Instruments toolbar with measurement probe 

2. The measurement probe will now be ghosted to your mouse. Left-click the 
measurement probe to the output of the filter (as seen in Figure E2-17). 

 

Figure E2-17. Measurement Probe at bandpass filter output 

3. Click on the (interactive) simulate button or press F5. You will notice that 
during an interactive simulation you will be able to instantaneously access 
the voltage, current and frequency information of that node through the 
measurement probe (as seen in Figure E2-18). 

 

Figure E2-18. Measurement Probe during an interactive simulation 

4. Stop the interactive simulation session. 
Notice that the current RefDes of the probe is Probe 1. This name or RefDes 
can be changed to something which means more in terms of your design or 
simulation. 

5. Double-click on your probe (Probe 1). 
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6. In the Probe Properties dialog box set the RefDes to output (as seen in 
Figure E2-19). 

7. Click on the OK button. 

 

Figure E2-19. Measurement Probe Properties 

We are now ready to return to our analyses. 

8. Select Simulate » Analyses » AC Analysis.  
9. Make sure that your frequency parameter tab is set-up as in step 3. 
10. Click on the Output tab. 
You will notice that in the Variables in Circuit, we can only see the static probe 
voltages, specifically our node output. 

11. Select V(output) and click on the Add button. 
12. Click on the Simulate button. The grapher again displays the bandpass filter 

characteristics according to an AC Analysis. 
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6.5. Working with the Grapher View 

We will now begin working with the Grapher View to make analysis easier. 

We will be using the three highlighed icons in the Grapher View menu as seen 
in Figure E2-20. 

 

 

 

Figure E2-20. Grapher View menu toolbar 

1. To show the grid on the Grapher, left-click on the magnitude plot of the AC 
Analysis and then click on the Show/Hide Grid button (Figure E2-20-1). 

2. Left-Click on the phase plot of the AC Analysis and click on the Show/Hide 
Grid button (Figure E2-20-1). The Grapher view will now look like figure E2-
21. 

 

Figure E2-21. Grapher View with grid 

3. Left-click on the magnitude plot. Now click on the Show/Hide Legend 
button (Figure E2-20-2).The AC Analysis legend for the magnitude plot will 
appear. 

1 2 3 
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4. Click on the Show/Hide Cursors button (Figure E2-20-3).The value box will 
appear, displaying the various x and y co-ordinate values as measured by 
the cursors (Figure E2-22). 

 

Figure E2-22. Grapher View with grid, legend and cursors 

5. Click on the neon-green colored cursor (Figure E2-22-1).Move the cursor left 
and right across the screen and notice the values in the AC Analysis 
measurement box change at each location. 

We can now find the center-frequency of our plot. Note that in this exercise 
our potentiometer is set at 50% and not 100% as we had seen in a previous 
lesson. So we should expect a different center frequency and gain from 
exercise 2.  

6. Right-click on the green cursor and select Go to next Y_MAX » 
7. Look at the AC Analysis cursor value and you will see that the center 

frequency, denoted as x1 equals 316.3378 Hz and the gain denoted as y1 
equals -12.0412 dB. 

It is often very useful to compare different analyses you have performed to 
better understand a design decision. For example in lesson 2 we had set our 
potentiometer to 1k Ω and in this exercise it remained at 500 Ω. Let’s take a 
look at the difference between both of these analyses by overlaying the results 
on top of each other on a single set of axes. 

1 
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8. Close the Grapher View. 
9. Open the file Exercise 2 – Bandpass Filter (Complete).ms10 (recall this is 

the file that was used in exercise 2) 
10. With Exercise 2 – Bandpass Filter (Complete).ms10 open, set the 

potentiometer (R2) to 100% of its value (1 k Ω) 
11. Double-click on the Bode Plotter instrument 
12. Set the Horizontal initial (I) frequency to 1 Hz. 
13. Click on the simulate button and view the frequency response of your filter 

in the Bode Plotter.  
14. Stop the simulation. 
15. Close the Bode Plotter instrument and select View»Grapher. 
16. In the Grapher View select the Bode Plotter-XBP1 tab (Figure E2-23) 
 

 

Figure E2-23. Grapher View graph tabs 

17. Select the magnitude plot in the Bode Plotter graph. 
18. Select Tools»Overlay Traces 
19. In the Select a Graph dialog box select Graph 1 (which is the magnitude 

plot) in the last AC Analysis that you completed. In this case (as seen in 
Figure E2-24) we select Page_2:Graph_1[Tab_Name:AC 
Analysis,Graph_Title:AC Analysis]. 

20. Click on the OK button 
 

 

Figure E2-24. Overlaying AC Analysis magnitude over Bode Plot simulation 
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Multisim will merge the magnitude plot from the Bode Plot and the magnitude 
plot from the AC Analysis onto one set of axes (as seen in Figure E2-25) 

 

Figure E2-25. Merged analysis of Bode Plot and AC Analysis 
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7. PROTOTYPING AND MEASUREMENT 

7.1. Overview 

Prototyping is the process of realizing a design in real life. With virtual 
prototyping, you can realize designs in a 3D virtual environment. Multisim 
provides a 3D prototyping breadboard, a 3D NI ELVIS and 3D NI ELVIS II 
protoboard, so you can develop your breadboard prototypes virtually before 
going to the lab. 

Breadboarding is one of the most common methods of building simple and 
advanced circuits. A breadboard is a rectangular plastic board with hundreds of 
small metal-plated holes. Many of the holes are electrically connected 
internally, so you can place components on the board but still connect other 
components to them through the use of jumper wires. 

 

Figure 19. Virtual 3D NI ELVIS Prototype 

 

Figure 20. Real NI ELVIS Prototype 

The Virtual 3D NI ELVIS is available for schematics created using the NI ELVIS 
template schematic. To create a new NI ELVIS template schematic, select File » 
New » NI ELVIS I Schematic or NI ELVIS II Schematic. The NI ELVIS template 
schematic includes all of the connections available on the NI ELVIS prototyping 
breadboard. The template schematic also provides built-in instruments to 
measure circuit behavior in simulation. 

To view the 3D prototyping environment, select Tools » Show Breadboard, and 
the NI ELVIS 3D breadboard appears. You can use the mouse to rotate the view, 
place components, and connect wires. The mouse cursor changes to reflect 
whatever operation you perform. 
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Notice that the Main toolbar changes to reflect the new breadboard view. The 
diagram and table below list the new buttons available in this view. The Main 
toolbar for the 3D view is shown in Figure 21. 

 

Figure 21. Main Toolbar in the 3D Environment 

Toolbar Button Function 
1 Change wire color 
2 Rotate breadboard 180 degrees 
3 Change breadboard settings 
4 Show current breadboard netlist 
5 Perform Design Rules and Connectivity Check 

When working with the 3D view, keep the following in mind: 

• Rotate the display – click and drag on a blank area of the breadboard 
• Place components – click and drag components from the component bin 

at the bottom 
• Connect wires – click on a source socket and then click on a destination 

socket 
To place components onto the breadboard, click and drag them from the 
component bin at the bottom of the display. Using this method, place all of the 
components in your circuit. 

Multisim automatically detects this, so consider those pins connected. By 
placing two components pins on the same bus, you can connect them 
electrically. 

Multisim helps you decide where to connect a particular wire. When you click 
on an empty hole to begin placing a wire, the 3D environment highlights all of 
the holes that should be on the same net of the wire you are placing. An 
example of the connections inside a breadboard is shown in Figure 22. 
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Figure 22. NI ELVIS II Breadboard Connections 

Once you have placed all of the components and wired all of the nets, run the 
Design Rules and Connectivity Check. Click on the DRC button from the Main 
toolbar, and Multisim lists any wiring errors. 

Additionally, all components and connections turn green on the schematic 
when they have been properly placed and wired on the 3D prototyping 
environment. You can control this feedback through the Global Preferences in 
the Options menu of the 3D environment. 

7.2. Prototyping with NI ELVIS 

NI ELVIS, is an educational design and prototype platform based on LabVIEW 
for university science and engineering laboratories, was originally 
conceptualized by Paul Dixon of the Cal State Physics Department. There are 
two components of the NI ELVIS platform, the physical hardware containing 12 
suite of instruments, and software – the idea of virtual instrumentation.  

NI ELVIS virtual instruments are created using the LabVIEW and uses DAQmx 
and NI ELVISmx support.  

This combination provides a ready-to-use suite of instruments required in most 
educational laboratories. Because the system is powered by LabVIEW, it 
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delivers the flexibility required to provide complete data acquisition and 
prototyping capabilities. The system is ideal for academic coursework ranging 
from lower-division classes to advanced project-based curricula. 

With the NI ELVIS II software suite, you have several different methods to 
perform measurements using the workstation:  

1. NI ELVISmx Instruments inside Multisim 
2. NI ELVISmx Instrument Launcher 
3. LabVIEW API 

The instrument launcher, shown in Figure 23, provides easy access to all 12 of 
the NI ELVISmx standard instruments. You can access this launcher by click 
Start»All Programs»National Instruments»NI ELVISmx»NI ELVISmx Instrument 
Launcher. By using the instrument selector, you can quickly open the 
instruments you want and use the prebuilt interfaces to control them.  

 

Figure 23. NI ELVISmx Instrument Launcher 

NI ELVIS is a important component of the Electronics Education Platform with 
Multisim and NI LabVIEW. The integration of these three parts makes NI ELVIS 
II a powerful, highly customizable measurement and experimentation platform. 
Through the Electronics Education Platform, students first use Multisim for 
capture and simulation. They are able to place components on the 3D 
breadboard in Multisim and then build the circuit on the NI ELVIS II 
workstation. The NI ELVISmx instruments can display actual data from the NI 
ELVIS II unit as well as simulated results from Multisim, making it easy to 
compare actual and theoretical values. Finally, LabVIEW offers even more 
capabilities for advanced analysis of the data. Figure 24 and Figure 25 illustrate 
the NI ELVIS II workstation and the NI ELVISmx oscilloscope front panel. 
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Figure 24. NI ELVIS and NI ELVIS II 
Workstation 

 

 

Figure 25. NI ELVIS And NI ELVISmx 
Oscilloscope Front Panel 
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8. EXERCISE 3 – 3D VIRTUAL PROTOTYPING 

8.1. Objective 

Use the 3D prototyping environment to do virtual prototyping of the designed 
band-pass filter circuit. 

8.2. Design 

Multisim has a 3D NI ELVIS and NI ELVIS II prototyping environment. First, open 
the filter circuit from the previous exercises developed using the NI ELVIS II 
template. Then switch to the 3D breadboard view and prototype the circuit 
using NI ELVIS II. 

8.3. Procedure 

1. Open “Exercise 3 – Bandpass Filter NI ELVISII.ms10.” 

The schematic that opens is the same circuit from Exercise 2, except it has been 
created using the NI ELVIS II schematic. 

2. From the Main toolbar, click the Breadboard icon to open the 3D NI ELVIS 
prototyping environment. The icon is shown in Figure E3-1, and the 3D 
environment is depicted in Figure E3-2. 

 

Figure E3-1. Breadboard Icon 

Breadbo
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Figure E3-2. 3D NI ELVIS II Prototyping Environment 

4. Place components onto the 3D breadboard by dragging them from the parts 
bin at the bottom of the display. Connect pins together with wires by 
clicking first on a source hole and then on a destination hole. Using the 
techniques described, prototype the bandpass filter circuit.  
 

5. Verify the completion of your prototype. 
a. Method 1 – Click on the DRC button from within the 3D view 

breadboard. The DRC toolbar button is labeled 5 in Figure E3-3. 
 

 

Figure E3-3. Main Toolbar in 3D Environment 

b. Method 2 – Switch from the 3D breadboard view to the schematic. All 
nodes and components should turn green to indicate that the 
prototype is complete. 

After completing the virtual protyping exercise, now the design is ready to be 
prototyped on the NI ELVIS II hardware workstation for measurement and test. 

 



 

53 
  

6. Build the physical circuit on the NI ELVIS II design and prototyping hardware 
platform. 

7. Investigate filter behavior using ELVISmx virtual instruments. 
a. Modify the earlier filter circuit by wiring in the ELVISmx Oscilloscope. 

Wire the positive terminal of Channel 0 of the oscilloscope to the AI1 + 
pin of the Analog Input Signals portion of the NI ELVIS II virtual 
schematic. 

 

Figure E3-4. ELVISmx Virtual Oscilloscope 

b. Wire the positive terminal of Channel 1 of the oscilloscope to the AI0 + 
pin of the Analog Input Signals portion of the NI ELVIS II virtual 
schematic, which is monitoring the output of the 741 op-amp. 

c. Connect a ground to the negative terminals of CH0 and CH1 of the 
oscilloscope. 

d. Double click the function generator to bring up the function generator 
soft front panel. The function generator icon is shown in Figure E3-5. 
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Figure E3-5. ELVISmx Virtual Oscilloscope 

e. The function generator soft front panel should pop up, it should look 
similar to Figure E3-6 below. Change the Frequency to 230 Hz, the 
amplitude to 1V, and make sure the function generator is generating a 
sin wave.  
 
Waveform:  Sine Wave 
Frequency:   230Hz 
Amplitude:   1Vp-p 

Functio
n 
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Figure E3-6. Function Generator Soft Front Panel 

f. Notice that under the Instrument Control portion of the soft front panel, 
the Device that is selected is “Multisim.” Multisim 10.1 allow users to 
compare simulated data of the captured schematic and compare it to 
measured data from the circuit prototyped on the the NI ELVIS II 
protoboard. 
 

g. Close the Function Generator Soft Front Panel after configuring the 
settings. 
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h. Double click the oscilloscope to bring up the oscilloscope soft front 
panel. The oscilloscope icon is shown in Figure E3-7. 

 
Figure E3-7. ELVISmx Oscilloscope Icon 

i. The soft front panel should look similar to Figure E3-8 below. The soft 
front panel parameters of the oscilloscope can be adjusted on the fly 
while the schematic is being simulated or during actual hardware testing. 
Make sure the Channel 1 is enabled by clicking the enabled check box. 
 

Oscilloscope 
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Figure E3-8. ELVISmx Oscilloscope Soft Front Panel 

j. Now, click the simulate button to simulate your circuit. The oscilloscope 
should process the schematic and output a waveform similar to the one 
shown in Figure E3-9 below. This is the simulated output of the circuit 
that you have designed within Multisim. 
 

 

Figure E3-9. ELVISmx Oscilloscope Soft Front Panel 
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k. If you have already built your actual circuit on the NI ELVIS II protoboard, 
then we can see the output of this circuit from within the scope front 
panel as well. In order to do this, stop the simulation by clicking the stop 
simulation button. 

l. Under the scope soft front panel, click the Device drop down menu and 
change the Device to NI ELVIS II. Perform the same step for the function 
generator as well. 

m. Click the Run button. Ensure that the “Simulated Data” and the “Real 
Data” checkboxes are selected.  

n. Observe the hardware output as well as the simulated output of your 
circuit overlaid on each other. This allows you to compare the output of 
your hardware implementation to your schematic design within 
Multisim. After the device is set to acquire real data from the NI ELVIS II, 
you should see output similar to the Figure E3-10 below. 

 

Figure E3-10. ELVISmx Oscilloscope Soft Front Panel 
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9. COMPARING SIMULATIONS AND MEASUREMENTS  

9.1. Overview 

Comparing simulations and measurements is the final and one of the most 
crucial steps in any design process. With comparison, you can understand the 
differences between predictions and reality. By displaying simulations on the 
same graph as measurements, you can easily catch discrepancies and begin a 
true engineering investigation of the reasons behind the differences. 

9.2. LabVIEW SignalExpress 

Using LabVIEW SignalExpress, you can interactively configure measurements 
and load simulation data. LabVIEW SignalExpress, a non-programming software 
tool based on LabVIEW, helps you achieve quick and easy measurements. By 
placing simple steps, the NI ELVISmx instruments can be used from within the 
LabVIEW SignalExpress environment. Likewise, similar steps to load simulation 
results saved from Multisim can help you easily and quickly develop highly 
useful comparisons. 
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Figure 26. LabVIEW SignalExpress Environment 

9.3. LabVIEW and NI ELVISmx 

National Instruments LabVIEW is a graphical programming environment that 
can be used to automate test and measurement functions, for the purpose of 
testing and validating designs. LabVIEW can be utilized to directly program with 
ELVISmx Virtual Instruments (VIs) or easily load .LVM or .TDM data from 
Multisim.in .LVM or .TDM format can be easily loaded into LabVIEW using 
express Virtual Instruments (VI). Users can then overlay simulation data and 
measured results to quickly and easily verify designs. 

9.3.1. What is a VI? 
LabVIEW programs are called virtual instruments, or VIs, because their 
appearance and operation imitate physical instruments, such as oscilloscopes 
and multimeters. LabVIEW contains a comprehensive set of tools for acquiring, 
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analyzing, displaying, and storing data, as well as tools to help you troubleshoot 
code you write. 

9.3.2. Parts of a VI 
The front panel window is the user interface for the VI. You create the front 
panel window with controls and indicators, which are the interactive input and 
output terminals of the VI, respectively. An example of a front panel window is 
shown in Figure 27 below. In this case, the Number of Measurements is a 
control while Delay and Temperature Graph are indicators. 

 

Figure 27. VI Front Panel 

The block diagram window is where the actual coding of your VI is done. After 
creating a front panel window, select Window » Show Block Diagram, and add 
code using graphical representations of functions to control the front panel 
objects. An example of a block diagram window is shown in Figure 28. 
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Figure 28. VI Block Diagram 

9.3.3. Placing Items in LabVIEW 
By right clicking on the front panel or block diagram, a user can view the 
controls or functions palette, respectively. The controls palette shows 
controls/indicators that can be placed on the front panel while the functions 
palette contains other VIs to be placed on the block diagram. These VIs are 
prewritten code designed to accomplish a certain function. For example, the 

Add VI, , will add two inputs and output the sum. Both palettes also contain 
a search function that narrows the allowable choices. The controls and 
functions palettes are shown below. 

  

Figure 29. LabVIEW Controls and Functions Palettes 
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9.3.4. Wiring and Dataflow 
LabVIEW follows a dataflow model for running VIs in which the data moves 
from left to right. A block diagram VI executes when it receives all required 
inputs. When a VI executes, it produces output data and passes the data to the 
next node in the dataflow path. The movement of data through the nodes 
determines the execution order of the VIs and functions on the block diagram. 

For a dataflow programming example, consider a block diagram that adds two 
numbers and then subtracts 50 from the results of the addition, as shown in 
the figure below. In this case, the block diagram executes from left to right, not 
because the objects are placed in that order, but because the Subtract function 
cannot execute until the Add function finishes executing and passes data to the 
Subtract function. 

 

Figure 30. Dataflow in LabVIEW 

When the mouse cursor changes to the following icon, , the Wiring toll is in 
operation. Use the Wiring tool to wire objects together on the block diagram. 
When the mouse hovers over the exit or entry point of a terminal or over a 
wire, the cursor automatically accesses the Wiring tool. Click the access point. 
Two access points can be attached by clicking on one access point and dragging 
the wire to another. Keep in mind that exit points can only be attached to entry 
points. 

9.3.5. Troubleshooting 
To troubleshoot LabVIEW programs, navigate to the block diagram and select 

the Highlight Execution option, . This option will allow the user to view the 
dataflow on the block diagram and view what the data value is at specified 
points. This is a very useful feature for understanding dataflow and debugging. 
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9.3.6. NI ELVISmx Instruments 
NI ELVIS II can be directly controlled from LabVIEW using the NI ELVISmx 
Express Virtual Instruments. Express VIs are designed specifically for 
completing common operations and contain customized user interfaces. These 
instruments can be found under Measurement I/O » ELVISmx in the controls 
palette. There are 10 NI ELVISmx Express VIs available for use with NI ELVIS II 
that allow the user to both analyze and generate data from LabVIEW. 

To utilize these VIs, place them on the block diagram and be sure to provide 
the necessary inputs to function. The configuration can be done in the user 
interface or by providing controls. If the user interface is configured correctly 
then inputs will not be required on the block diagram. The user has the choice 
to provide inputs for programmatic control. Both cases are shown below using 
the ELVISmx Function Generator Express VI.  

 

         

Figure 31. ELVISmx Function Generator Express VI 
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10. EXERCISE 4 – MEASUREMENT AND COMPARISONS 

10.1. Objective 

Compare previously saved simulation data with real-world measurements to 
verify bandpass filter operation. 

10.2. Design 

Because this exercise requires the NI ELVIS II workstation to be configured, it is 
recommended that the instructor leads the exercise through a demonstration. 
It is also assumed that the circuit from Exercise 3 is already prototyped on NI 
ELVISmx. 

10.3. Procedure 

A. Transient Verification 
 

1. Open the NI ELVISmx instrument launcher (Start » Programs » National 
Instruments » NI ELVISmx» NI ELVISmx Instrument Launcher). 

2. Open the NI ELVISmx Function Generator soft front panel by clicking on 
FGEN. 

3. Verify the correct NI ELVIS device is selected in the Device drop down menu. 
4. Set the input frequency to 230 Hz and the input amplitude to 1 Vp-p using 

the fields. One variation is to check the box labeled Manual Mode to enable 
manual control of the hardware. This will allow the user to use the 
adjustment knobs on the front of the NI ELVIS II workstation.  

5. Open the NI ELVISmx Oscilloscope soft front panel by clicking on Scope. 
6. Click the Run button on both the Function Generator and the Oscilloscope. 
7. Verify your circuit operates as indicated in Figure E4-1. Note the 

configuration of the NI ELVISmx Oscilloscope. 



 

66 
  

 

Figure E4-1. Transient Verification of Real-World Circuitry 

10.3.1. Frequency Verification 
Using the NI ELVISmx Bode analyzer, quickly verify the frequency response. 

1. Turn off Manual Mode if this is currently on from the FGEN soft from panel 
2. Close both the Scope and FGEN Soft Front Panels. 
3. From the NI ELVISmx Instrument Launcher, click NI ELVISmx Bode analyzer. 

Ensure the correct are made.  
AI0:  Signal 

AI1: FGEN 

4. Run the sweep from 10 Hz to 1 KHz. The results should be similar to those in 
Figure E4-2. 
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Figure E4-2. Frequency Response Verification of Real-World Circuitry 

10.3.2. Comparisons 
Using LabVIEW SignalExpress, to control NI ELVIS II to perform a Bode analysis, 
and load previously saved SPICE simulation results. 

1. Open LabVIEW SignalExpress by clicking on Start » Programs » National 
Instruments » LabVIEW SignalExpress» LabVIEW SignalExpress x.x 

2. Click on the “+Add Step”, from the menu select Load/Save Signals»Analog 
Signals»Load from SPICE. See Figure E4-3 for location of the step. 
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Figure E4-3. Add Step Menu 

3. In the step setup, from the drop down menu select Multisim as the 
Simulation file type.  

4. Click on the browse file button and locate the file “Frequency Response.txt” 
on your computer in the Import file path field. 

5. Check boxes to import data from V(Probe1) and 20*log(mag(V(Probe1))). 
6. Select XY Pair – Time from the drop down menu for Domain. 
7. From the drop down menu select Voltage:V as the Y-axis unit. 
8. From the drop down menu select Time: s as the X-axis unit. 
9. Add another step by selecting, Add Step»NI ELVISmx»Analog»Acquire» NI 

ELVIS Bode Analyzer 
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10. Using the same configuration on the Bode Analyzer in exercise 3, set the 
number of Steps as 10 

11. In the Data View tab, click on the Gain Data, located under the NI ELVISmx 
Bode Analyzer task, and drag it to the top display. 

12. Similarly, click and drag Phase Data, located under the NI ELVISmx Bode 
Analyzer task, and drag it to the bottom display.  

13. Click Run Once. LabVIEW SignalExpress then run a frequency sweep using NI 
ELVISmx and collects 10 points per decade. After the results are generated, 
they are displayed on the graphs, along with the simulation results. The 
overall result is shown in Figure E4-4. The white traces are measured data, 
and the red tracers are simulation results. 

 

 

Figure E4-4. Frequency Response Verification of Real-World Circuitry 

Note: The frequency data loaded from Multisim includes an additional, post-
processed trace that is the magnitude response in decibels. Because of this, 
you can capture the gain data from LabVIEW SignalExpress to match the 
simulation data from Multisim. This trace was created, after first performing an 
AC analysis, by using the Add Trace(s) to Plot feature of the Grapher. The 
expression used was “20*log(mag(V(Probe1))).” 
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APPENDIX A – INSTRUMENTS AND ANALYSES IN MULTISIM 

10.4. Multisim Instruments 

Instrument Description 

2-Channel Scope Displays the magnitude and frequency 
variations of electronic signals. 

4-Channel Scope See above. 

Ammeter Displays instantaneous current through a 
wire. 

Bode Plotter Produces a graph of a circuit’s frequency 
response and is most useful for analyzing 
filter circuits. 

Current Probe Converts transient current into voltages 
for display on the oscilloscope. 

Distortion 
Analyzer 

Provides distortion measurements for 
signals in the range of 20 Hz to 100 kHz, 
including audio signals. 

Frequency 
Counter 

Measures the frequency of a given signal. 

Function 
Generator 

Supplies sine, triangular, or square 
waves. 

IV Analyzer Measures the current-voltage curves of 
diodes, PNP BJTs, NPN BJTs, PMOS 
transistors, and NMOS transistors. 

Logic Analyzer Displays the levels of up to 16 digital 
signals in a circuit. It is used for fast data 
acquisition of logic states and advanced 
timing analysis to help design large 
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systems and carry out troubleshooting. 

Logic Converter Perform several transformations of a 
circuit representation or digital signal to 
generate circuitry or derive truth tables 
for digital circuits. 

Measurement 
Probe 

Connects to any node in the circuit and 
reports various metrics such as current, 
voltage, frequency, and so on. 

Multimeter Measures voltages, currents, resistances, 
or decibels. 

Network 
Analyzer 

Measures the scattering parameters (or 
S-parameters) of a circuit; commonly 
used to characterize a circuit intended to 
operate at higher frequencies.  

Spectrum 
Analyzer 

Measures signal amplitude versus 
frequency. 

Voltmeter Displays the voltage between two points 
of a circuit. 

Wattmeter Displays the power dissipated by a given 
circuit branch. 

Word Generator Sends digital words or patterns of bits 
into circuits to provide stimulus to digital 
circuits. 

Agilent Function 
Generator 

Simulated Agilent 33120A function 
generator 

Agilent 
Multimeter 

Simulated Agilent 34401A multimeter 

Agilent Scope Simulated Agilent 54662D oscilloscope 
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Tektronix Scope Simulated Tektronix TDS2024 oscilloscope 

10.5. Multisim Analyses 

Analysis Description 

AC Used to calculate the frequency response 
of linear circuits. 

Batched Performs a sequence of arbitrary analyses 
in order. 

DC Operating 
Point 

Determines the DC operating point of a 
circuit. 

DC Sweep Simulates the circuit many times, 
sweeping the DC values within a 
predetermined range. 

Distortion Analyzes signal distortion that may not be 
evident using transient analysis. Signal 
distortion is usually the result of gain 
nonlinearity or phase nonuniformity in a 
circuit. Multisim simulates harmonic 
distortion and intermodulation distortion 
for analog small-signal circuits. 

Fourier Analyzes complex periodic waveforms. It 
permits any nonsinusoidal period function 
to be resolved into sine or cosine waves 
(possibly an infinite number) and a DC 
component. 

Monte Carlo Helps you explore how changing 
component properties affects circuit 
performance. A statistical technique, 
Monte Carlo Analysis performs DC, AC, or 
transient analysis and varies the 
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component properties. 

Nested Sweep Performs temperature and parameter 
sweep analyses in a nested fashion, with 
a series of sweeps being performed, each 
is conducted within the constraints of the 
sweep before it. 

Noise Calculates the noise contribution from 
each resistor and semiconductor device at 
the specified output node. 

Noise Figure Specifies exactly how noisy a device is. 
For a transistor, noise figure (NF) is 
simply a measure of how much noise the 
transistor adds to the signal during the 
amplification process.  

Pole Zero Determines the stability of electronic 
circuits by calculating the poles and zeros 
of the circuit’s transfer function. 

Parameter 
Sweep 

Verifies the operation of a circuit by 
simulation across a range of values for a 
component parameter. 

Sensitivity Calculates the change produced in an 
output voltage or current by changing 
each parameter independently. 

Temperature 
Sweep 

Simulates the circuit several times at 
defined temperatures. 

Trace Width Calculates the minimum trace width 
needed in the circuit to handle the RMS 
current at any trace/wire. 

Transfer 
Function 

Calculates the DC small-signal transfer 
function between an input source and two 
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output nodes (for voltage) or an output 
variable (for current) in a circuit. 

Transient Computes the circuit’s response as a 
function of time. 

User Defined Allows manually loaded SPICE card or 
netlists and user-control over actual 
SPICE commands to be performed. 

Worst Case Explores the worst possible effects of 
variations in component parameters on 
the performance of a circuit. 
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