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Introduction 

Oracle Hyperion Financial Reporting (FR) is a powerful tool for designing and presenting analytic data 
graphically.  Users can design traditional financial report formats such as cash management reports, 
profit and loss statements, and balance sheets.  Users can also design nontraditional formats for 
financial or analytic data that include text and graphics. 
 
Hyperion Financial reports can be developed on a tool called Hyperion Financial Reporting Studio.  This 
is the only tool to build or edit a Hyperion Financial report.  Users are also able to view, delete and print 
FR through FR Studio.  The web client, Workspace, is used to rename, delete, view, and print the 
Hyperion Financial reports.  Users will not be able to develop or edit reports on Workspace. 
 
Below are the server names and URLs to have access to FR Studio and Workspace: 
 
FR Studio server: http://HY-DWEB01  
FR Studio is installed on the FR Studio server.  It can be installed to clients’ laptops. 
 
Workspace URL: http://HY-DWEB01/workspace/index.jsp 

Financial Reporting Components 

Financial Reporting is comprised of numerous components that can be accessed in Reporting Studio, 
Workspace, or both: 
 
Report Designer—In Reporting Studio - Enables you to create, edit, or delete report objects, reports or 
snapshot reports. 
 
Explore 
In Reporting Studio - Enables you to create, open, save, and delete folders and store report objects, 
reports, and snapshot reports. 
In Financial Reporting Workspace - Enables you to open stored files, create folders, export and import 
files, and set up e-mail links to folders, reports, and snapshot books. 
 
Book Editor—In Financial Reporting Workspace - Provides the capability of creating a book of reports, 
which can be saved as a book or a snapshot book. 
 
Scheduler—In Financial Reporting Workspace-Enables you to schedule a batch and view the status of 
batches that are scheduled for future processing. 
 
Batch Editor—In Financial Reporting Workspace-Enables you to add objects to a batch job, remove 
objects from a batch job, schedule a batch, and indicate whether or not you want the batch deleted 
after it runs. 
 
Workspace—The tasks you can perform are based on your user rights. 
 

http://hy-dsvc01/
http://hy-dweb01/workspace/index.jsp
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In Reporting Studio - If the user is a Report Designer or Global Administrator, he/she can create, edit, or 
delete report objects, reports or snapshot reports in the designer Studio workspace or work with reports 
and report objects in Studio Explore. 
In Workspace – He/she can create a book of reports, schedule batches, view batches, and edit batches. 
If the user has the viewer rights he/she can view reports and export documents to Word, Excel, and 
PowerPoint.  
 

Report Components 

The following screen-shot shows the components that you can use while designing reports in Reporting 
Studio.  Report components include report objects, such as grids and charts, headers and footers, and 
rows, columns, and cells of grids. 
 

 

Report Objects 

Report objects are basic components for designing reports in Reporting Studio. Report objects include 
text boxes, grids, images, and charts. You can use the toolbar buttons and menu commands to add 
report objects to the report. 
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Financial Reporting Tasks 

Some of the basic Financial Reporting Tasks are: 

1. Starting Reporting Studio: If the FR Studio client is installed on your laptop, find the Studio 

under Oracle EPM System > Reporting and Analysis.  Type your username and password and 

click OK. 

  

 
2. Logging on to Workspace: Use the below link to logging on to Workspace.  Workspace will let 

you rename, run, preview, and print reports as well as develop books and batches. 
 

http://HY-DWEB01/workspace/index.jsp 
 

3. Building Reports:  Reports can be built only on Hyperion Financial Reports Studio.  Login to the 
FR Studio.  Click on File > New > Report. 

http://hy-dweb01/workspace/index.jsp
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You will see a blank sheet.  Insert a Grid by clicking Insert > Grid. 
 

 
 
In the body part of the blank sheet, press and hold the left button of your mouse and drag it down. 
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You need to map the grid to a database.  If the database connection is already developed, select the 
proper one from the list and click ok. 
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If the database connection is not developed, click on New Database Connection and fill out the required 
information. 
 

 
 
Once the database connection is set up and the grid is placed on the report you can decide on moving 
dimensions in the report. 
 
Below screenshot is how the Dimension Layout looks like: 
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Move the dimensions to Columns, Rows, Pages or keep them on Point of View.  You need to have at 
least one dimension in Rows and Columns.  Pages section will let you run the same report for various 
dimension members such as the departments in Sales Departments & Departmental Reports.  
 

4. Selecting Members: Once you place the dimensions on your grid, you need to select specific 
members because FR only puts the dimension itself.  Below screen shot was taken after the 
initial report creation. 
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For training purposes, let’s analyze Assets, Liabilities, and Equity over 12 months. 
 
Double click on Account.  Remove account from the Selected part and add Assets, Liabilities, and Equity.  
Click OK. 
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Follow the same steps for Periods. 
 
TIP: It is easier to maintain the reports when not placing selections into separate rows. 
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Leave it unchecked whenever possible.  While using Text fields, you will have to check this box.  
 

5. Defining the User POV:  Once you select the members of Rows and Columns, you can define the 
User POV.  Currently you have all the dimensions except Account and Period on POV. 
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Most of the time you will have no dimensions on POV or two or three dimensions at the most.  To limit 
and lock down some of the dimensions, right-click on Left Corner of your Grid and click on Grid Point of 
View. 
 

 
 
Start with the First dimension on POV.  If you would like to lock it (run the report for the specific 
member each time), select a specific member and move to the next dimension.  If you would like users 
to have the ability to change members, then click on User Point of View.  For this exercise let’s lock all 
the dimensions except Entity and Scenario.  For the rest of the dimensions let’s lock them with following 
members: 
 
Product: Product 
Project: Project 
Years: Curr_Year 
Version: Final 
Currency: USD 
 

 
 
You will see that only Entity and Scenario are on POV after the member selection. 
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6. Customizing Grids: After selecting row, column and POV members you can customize your grid.  

Click on the right corner of your grid and the Grid Properties window will show-up on the right 
section of your report. 

 

 
 

- General: It lets you change Member Labels, Column Width, Row Height, use features like 
Autosizing, Freezing grid headers, displaying/removing Grid Point of View, and put a Page 
Break Before a specified row. 

- Suppression: You can suppress columns, rows, and the whole grid by Zero Values, Missing 
Values or Errors.   It also lets you replace #ZERO, #MISSING, and #ERROR with your 
preference. 

- Position: You can position the Grid horizontally and vertically. 
 
You can also use basic functions such as copying, pasting formulas and data values on Grids.  It is also 
possible to insert text, data, and formula rows and columns on grids.  Right click on the row or column 
and click on the function. 
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7. Previewing and Printing Reports: You can preview and print reports on FR Studio or Workspace.  
It is better to use the PDF version of the report to print and HTML version of the report to do a 
quick analysis. 
 

8. Formatting Reports: FR offers many ways to format a report.  You can format the whole grid, 
certain rows and columns or even individual cells.   Let’s say you would like to see the data in 
millions and apply this format to the whole grid.  Below steps will let you accommodate this 
requirement: 

o Right-click on the right corner of the Grid and click on Format >Cells. 
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o In the Number tab, select the Millions option under Scale Value by box. 
 

 
 

o Click Apply or OK. 
 
Other Functions in FR include setting Prefix and Suffix for positive and negative numbers, decimal places, 
alignment, font options, border and shading, replace and inherit formatting. 
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9. Using Functions: FR also offers various Functions such as the ability to dynamically update 

Report Headers and Footers.  To add a title and use a function, insert a text box to the report. 
 

 
 
Just like adding a grid, keep clicking your cursor and drag it on the footer section of your report. 
 

 
 
Click inside of the Text box and then click on Insert Function. 
 

 
 
As you will see there are many functions.  For this exercise let’s insert Report Description function. 
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Click OK and then adjust the function in the text box by moving placing it on the middle. 
 

 
 
Some of the other popular functions are: 
 

- Member Name 
- Member Alias 
- Date 
- Page 
- Page Count 
- Report Name 

 
Click on the question mark to see sample usage of the functions. 
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10. Exporting Reports to Excel: Hyperion Financial Reports can be exported to Excel from 
Workspace in two different formats: 
1. Fully-Formatted Grids and Text 
2. Query Ready Mode 

 
To do further analysis on SmartView, export the report in Query Ready Mode: 
 
Click on the link at the bottom of the report: 
 

 
 
To export the report in Fully-Formatted Grids and Text format, click on File > Export > Excel. 
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11. Developing Books:  Books let you combine several reports into one book.  The advantage of 

books is that you will not have to run each report individually each time.  To develop a book, 
login to Workspace, click on File > New > Document. 

 

 
 
Select Collect Reports into a Book and click Next. 
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Navigate to the Reports and find the reports that you would like to select.   
 

 
 
Once you are done adding reports, click Finish and save the Book. 
 

12. Creating Batches: You need to create a Batch to automatically send out reports to other users.  
To create a batch click on File > New Document and Batch Reports for Scheduling.  Click next.  
You can select a report or several reports, or a book or several books.  After you are done 
selecting reports or books, click Finish and save the batch.  I created a Batches folder under the 
Root directory.  It is a good practice to place all the batches under one folder structure.  It is also 
good to have a proper naming convention for the Batches, such as AP Capex Batch. 

 
13. Scheduling Batches: You can schedule batches and send emails automatically to users.  To 

schedule a batch, click on Navigate > Schedule > Batch Scheduler. 
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Once you are in Batch Scheduler click on File >  New Scheduled Batch. 

 

Give a name to the batch and click Next.  
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Select the Batch you would like to schedule and click Next. 
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Type your password under Financial Report Server and Database Connection Name and click OK. 
 

 
 
Select a Start Time.  It can be NOW or a future date and time. 
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There are several options to run the report in a future date. 
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Click Next when you set the Start Time and Bursting Options. 
 
Uncheck Save as Snapshot in Repository and check Export as PDF > E-mail as PDF Attachment(s).  Click 
Next. 
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Enter the email of desired Recipients for one time only to the list. 
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Click OK and then fill out the Subject and Message Body sections. 
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Next section is for admins only.  It is good to know whether a batch ran successfully or not. 
 



   

Hyperion Financial Reports Training Document  Page 28 

 

 
 
Click Finish and you will see your batch being created under Batch Scheduler. 
 

14. Additional info and tips  
a. Using Formulas: FR lets you create formulas within reports.  Basic formulas such as sum, 

subtract, percentage, variance, etc. can be built in FR.  Below screenshots will give you 
an idea how to build formulas. 
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Select the whole column and type [A]-[B] and click on green check key. 
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The title is under Custom Heading. 
 

 
 
Click on the formula cell and expand the formula options to see other formulas FR offers: 
 

 
 

b. Using Text fields: This function will help you to enter comments for variances and other 
requirements.  To insert a text column or row, select the column or row and click on 
Insert > Text 



   

Hyperion Financial Reports Training Document  Page 31 

 

 
 
To enter notes, type the notes in the Text box under Cell Properties. 
 

 
 

c. Page Setup: Page setup is important to fit width or length to a page.  It also helps you to 
orient the report into Portrait (default) or Landscape. 
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d. Range Function in member selection: Range function enables you to select a range of 
members from a dimension.  Such as selecting a range of Jan till the Current Month, 
which will only show the actualized months in the report. 
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e. Using Same member option: Instead of typing the same member name or a function, 
use the same member function when it is applicable. 
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f. Using Year-to-Date function: While selecting members from the Period dimension, you 
can use the YTD function in three ways: 

o Select a specific month (not recommended due to maintenance) 
o Select the Curr_Month substitution variable 
o Select the Current Point of View member 
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