OSPF: Open Shortest
Path First

A Routing Protocol Based on the
Link-State Algorithm

OBJECTIVES

The objective of this lab is to configure and analyze the performance of the Open Shortest
Path First (OSPF) routing protocol.

OVERVIEW

In the RIP lab, we discussed a routing protocol that is the canonical example of a routing
protocol built on the distance-vector algorithm. Each node constructs a vector containing the
distances (costs) to all other nodes and distributes that vector to its immediate neighbors. Link-
state routing is the second major class of intradomain routing protocol. The basic idea behind
link-state protocols is very simple: Every node knows how to reach its directly connected neigh-
bors, and if we make sure that the totality of this knowledge is disseminated to every node, then
every node will have enough knowledge of the network to build a complete map of the network.
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Once a given node has a complete map for the topology of the network, it is able to decide
the best route to each destination. Calculating those routes is based on a well-known algo-
rithm from graph theory—Dijkstra’s shortest-path algorithm.

OSPF introduces another layer of hierarchy into routing by allowing a domain to be partitioned
into areas. This means that a router within a domain does not necessarily need to know how to
reach every network within that domain; it may be sufficient for it to know how to get to the
right area. Thus, there is a reduction in the amount of information that must be transmitted to
and stored in each node. In addition, OSPF allows multiple routes to the same destination to
be assigned the same cost and causes traffic to be distributed evenly over those routers.

In this lab, you will set up a network that utilizes OSPF as its routing protocol. You will ana-
lyze the routing tables generated in the routers and will observe how the resulting routes are
affected by assigning areas and enabling load balancing.

PRE-LAB ACTIVITIES
[l Read Section 3.3.3 from Computer Networks: A Systems Approach, 5th Edition.

Go to www.net-seal.net and play the following animation:
o Routing
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The slip8_gtwy node
model represents an
IP-based gateway
supporting up to eight
serial line interfaces
at a selectable data
rate. The RIP or OSPF
protocols may be used
to automatically and
dynamically create the

gateway’s routing tables

and select routes in an
adaptive manner.

The PPP_DS3 link
has a data rate of
44,736 Mbps.

PROCEDURE
Create a New Project

1.
2.

3.

Start OPNET IT Guru Academic Edition - Choose New from the File menu.

Select Project and click OK - Name the project <your initials>_OSPF, and the scenario
No_Areas = Click OK.

In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty Scenario
is selected > Click Next > Select Campus from the Network Scale list > Click Next three
times - Click OK.

Create and Configure the Network

Initialize the network:

1.

The Object Palette dialog box should now be on top of your project workspace. If it is not

there, open it by clicking 3 Select the routers item from the pull-down menu on the top

of the object palette.

a. Add to the project workspace eight routers of type slip8_gtwy. To add an object from
a palette, click its icon in the object palette 2 Move your mouse to the workspace, and
click to place the object = Right-click when you are finished placing the last object.

. Select the internet_toolbox item from the pull-down menu on the top of the object

palette. Use the PPP_DS3 links to connect the routers. Rename the routers as shown >
Close the Object Palette.

RouterB RoutarC B outerE RouteG RouterH

Configure the Link Costs

We need to assign link costs to match the following figure:




Like many popular commercial routers, OPNET router models support a parameter called a
reference bandwidth to calculate the actual cost, as follows:

Cost = (Reference bandwidth) / (Link bandwidth)

where the default value of the reference bandwidth is 1,000,000 Kbps.
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For example, to assign a cost of 5 to a link, assign a bandwidth of 200,000 Kbps to that link. This
is not the actual bandwidth of the link in the sense of transmission speed, but merely a parame-
ter used to configure link costs. To assign the costs to the links of our network, do the following;

1. Select all links in your network that correspond to the links with a cost of 5 in the

preceding graph by shift-clicking on them.

2. Select the Protocols menu - IP - Routing > Configure Interface Metric Information.

Configure Interface Metric Information g

This operation will configure the specified bandwidth
and delay on all/selected link interfaces.

Bandwidth (Kbps): |2uouoo e

Delay (10 * usecs): INot Used

|7Apply the above specification to subinterfaces

Apply the above specification to:

(" All connected interfaces

(® |nterfaces across selected links ~&——

Cancel | | QK I

3. Assign 200000 to the Bandwidth (Kbps) field - Check the Interfaces across selected

links radio button, as shown = Click OK.

4. Repeat for all links with a cost of 10 but assign 100000 to the Bandwidth (Kbps) field.
5. Repeat for all links with a cost of 20 but assign 50000 to the Bandwidth (Kbps) field.

6. Save your project.

Configure the Traffic Demands

1. Select both RouterA and RouterC by shift-clicking on them.

a. Select the Protocols menu = IP > Demands >
Create Traffic Demands - Check the From
RouterA radio button as shown = Keep the color
as blue - Click Create. Now you should see a
blue dotted line representing the traffic demand
between RouterA and RouterC.

2. Select both RouterB and RouterH by shift-clicking
on them.

a. Select the Protocols menu = IP - Demands >
Create Traffic Demands > Check the From
RouterB radio button > Change the color to red >
Click OK - Click Create.

Create Traffic Demands

— Direction
(" Eull Mesh

il

@® From IRoulerA e

" From IRoulerC
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Intensity

Packetsfsec: |1DU
Bits/sec: I'IDUO
Duration (secs): |3500

Color/lll Description:|Represents IP Traffic Flows

[ Characterize Demands

Cancel
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Now you can see the lines representing the traffic demands as shown.

3. To hide these lines: Select the View menu - Select Demand Objects > Select Hide All.

Configure the Routing Protocol and Addresses

1. Select the Protocols menu = IP - Routing - Configure Routing Protocols.
2. Check the OSPF check box = Uncheck the RIP check box = Uncheck the Visualize
Routing Domains check box, as shown:

Routing Protocol Configuration u

Choose from the following routing protocols.
This operation will overwrite the existing
configuration on selected IP interfaces.

[ None [ OSPF ~=——
——>[ RIP [T1s18
[TIGRP [TEIGRP

FApply the above selection to subinterfaces

Apply the above selection to:
(® Allinterfaces (including loopback)

" Interfaces across selected links

[ Visualize Routing Domains = =&——

Cancel
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3. Click OK.

4. Select RouterA and RouterB only = Select the Protocols menu = IP - Routing = Select  Auto-Assign IP
Export Routing Table for Selected Routers - Click OK on the Status Confirm dialog box. ~ Addresses assigns

5. Select the Protocols menu > IP - Addressing > Select Auto-Assign IP Addresses. a unique IP address

6. Save your project. to connected IP
interfaces whose IP

address is currently

Configure the Simulation set to auto assigned.

Here we need to configure some of the simulation parameters: It does not change the
. » . . . value of manually set
1. Click on * and the Configure Simulation window should appear. IP addresses.

2. Set the duration to 10.0 minutes.
3. Click OK and Save your project.

Duplicate the Scenario

In the network we just created, all routers belong to one level of hierarchy (i.e., one area).
Also, we did not enforce load balancing for any routes. Two new scenarios will be created.
The first new scenario will define two new areas in addition to the backbone area. The sec-
ond one will be configured to balance the load for the traffic demands between RouterB and
RouterH.

THE AREAS SCENARIO
1. Select Duplicate Scenario from the Scenarios menu, and give it the name Areas >
Click OK.
2. Creating Area 0.0.0.1:
a. Select the three links that connect RouterA, RouterB, and RouterC by shift-clicking on
them > Select the Protocols menu > OSPF > Configure Areas - Assign the value 69
0.0.0.1 to the Area Identifier, as shown - Click OK.

OSPF Area Conﬁguration_. [

This operation will configure Area IDs on the directly
connected interfaces for the selected links:

Area Identifier: 0.0.01

Qancell | OK I

b. Right-click on RouterC - Edit Attributes > Expand the OSPF Parameters hierarchy =  Loopback interface

Expand the Loopback Interfaces hierarchy - Expand the row0 hierarchy - Assign allows a client and a
0.0.0.1 to the value of the Area ID attribute = Click OK. tserver on the Stam(?tr:lost
. ing A .0.0.2: 0 communicate wi
3. Creaing Area 0.0 each other using TCP/IP.

a. Click somewhere in the project workspace to disable the selected links, and then
repeat Step 2a for the three links that connect RouterF, RouterG, and RouterH but
assign the value 0.0.0.2 to their Area Identifier.

4. To visualize the areas we just created, select the Protocols menu - OSPF - Visualize

Areas - Click OK. The network should look like the following one with different colors

assigned to each area (you may get different colors, though).
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OPNET provides
two types of IP load
balancing:

With Destination
Based, load balancing is
done on a per-destination
basis. The route chosen
from the source router to
the destination network
is the same for all
packets.

With Packet Based,
load balancing is done
on a per-packet basis.
The route chosen from
the source router to the
destination network is
redetermined for every
individual packet.
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Note:

e The area you did not configure is the backbone area with Area Identifier = 0.0.0.0.
o The figure shows the links with a thickness of 3.

RouterB BouterC

THE BALANCED SCENARIO

1. Under the Scenarios menu, Switch to Scenario = Select No_Areas.

2. Select Duplicate Scenario from the Scenarios menu and give it the name Balanced ->
Click OK.

3. In the new scenario, select both RouterB and RouterH by shift-clicking on them.

4. Select the Protocols menu - IP > Routing > Configure Load Balancing Options >
Make sure that the option is Packet-Based and the radio button Selected Routers is
selected as shown - Click OK.

] —
B Configure Load Balancing Options RS

Load Balancing Options: I Packet-Based ll

(" All Routers (® Selected Routers

Cancel I

5. Save your project.

Run the Simulation
To run the simulation for the three scenarios simultaneously:
1. Go to the Scenarios menu = Select Manage Scenarios.

2. Click on the row of each scenario, and click the Collect Results button. This should
change the values under the Results column to <collect> as shown.
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Project Name: IEA,OSPF

# ScenariocName |Saved |Results  SimDuration  |Time Units

1 MNo_Areas saved <collect> 10 minute(s)
2 Areas saved <collect> 10 minute(s)
3 Balanced saved <collect> 10 minute(s)

Delete | E":sc:ard,:fe-su".sl :’.-\-:-i=eciF‘ezuIls| Cancel I OK I

3. Click OK to run the three simulations. Depending on the speed of your processor, this
task may take several seconds to complete.

4. After the three simulation runs complete, one for each scenario, click Close, and then
save your project.

View the Results
THE NO_AREAS SCENARIO

1. Go back to the No_Areas scenario.

2. To display the route for the traffic demand between RouterA and RouterC: Select the
Protocols menu = IP > Demands - Display Routes for Configured Demands >
Expand the hierarchies as shown and select RouterA - RouterC = Go to the Display
column and pick Yes = Click Close.

Route Report_forl_PT!afﬁt_:F' /s

RouterA
RouterC
RouterA —> RouterC

+}@ RouterB
4

Sources (Campus Network) IDisplayi Status IDeta...j

Yes, Complete

Show All Routes | Clear All Routes |
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4. Repeat Step 2 to show the route for the traffic demand between RouterB and RouterH.
The route is as shown in the following diagram. (Note: Depending on the order in which
you created the network topology, the other “equal-cost” path can be used, that is, the
RouterB-RouterA-RouterD—RouterF—RouterH path).

B

i
o
-

|'-

RouterB RouterC RouterE RouterG RouterH
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THE AREAS SCENARIO

1. Go to Areas scenario.
2. Display the route for the traffic demand between RouterA and RouterC. The route is as

shown here:

RouterB RouterC RouterE RouterG RouterH
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THE BALANCED SCENARIO

1. Go to scenario Balanced.
2. Display the route for the traffic demand between RouterB and RouterH. The route is as
shown here:

RouterB RouterC RouterE RouterG RouterH

3. Save your project.

FURTHER READINGS

OPNET OSPF Model Description: From the Protocols menu, select OSPF - Model Usage
Guide.

OSPF: IETF RFC number 2328 (www.ietf.org/rfc.html).

EXERCISES

1. Explain why, for the same pair of routers, the Areas and Balanced scenarios result in
different routes than those observed in the No_Areas scenario.

2. Using the simulation log, examine the generated routing table in RouterA for each one of
the three scenarios. Explain the values assigned to the Metric column of each route.

Hints:

e Refer to the “View Results” section in Lab 6 for information about examining the rout-
ing tables. You will need to set the global attribute IP Interface Addressing Mode to the
value Auto Addressed/Export and rerun the simulation.

e To determine the IP address information for all interfaces, you need to open the Generic
Data File that contains the IP addresses associated with the scenarios.

3. OPNET allows you to examine the link-state database that is used by each router to build
the directed graph of the network. Examine this database for RouterA in the No_Areas
scenario. Show how RouterA utilizes this database to create a map for the topology of the
network, and draw this map. (This is the map that the router will use later to create its
routing table.)

Hints:

e To export the link-state database of a router, Edit the attributes of the router, and set the
Link State Database Export parameter (one of the OSPF Parameters, under Processes)
to Once at End of Simulation.
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Note: A stub network
only carries local traffic
(i.e., packets to and from
local hosts). Even if it has
paths to more than one
other network, it does
not carry traffic for other
networks (RFC 1983).
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e You will need to set the global attribute IP Interface Addressing Mode to the value Auto
Addressed/Export. This will allow you to check the automatically assigned IP addresses
to the interfaces of the network. (Refer to the notes of Exercise 2.)

e After rerunning the simulation, you can check the link-state database by opening the
simulation log (from the Results menu). The link-state database is available in Classes >
OSPF - LSDB_Export.

4. Create another scenario as a duplicate of the No_Areas scenario. Name the new scenario
Q4_No_Areas_Failure. In this new scenario, simulate a failure of the link connecting
RouterD and RotuerE. Have this failure start after 100 s. Rerun the simulation. Show
how that link failure affects the content of the link-state database and routing table of
RouterA. (You will need to disable the global attribute OSPF Sim Efficiency. This will
allow OSPF to update the routing table if there is any change in the network.)

5. For both No_Areas and Q4_No_Areas_Failure scenarios, collect the Traffic Sent (bits/
sec) statistic (one of the Global Statistics under OSPF). Rerun the simulation for these
two scenarios and obtain the graph that compares the OSPF's Traffic Sent (bits/sec) in
both scenarios. Comment on the obtained graph.

LAB REPORT

Prepare a report that follows the guidelines explained in the Introduction Lab. The report

should include the answers to the preceding exercises as well as the graphs you generated

from the simulation scenarios. Discuss the results you obtained and compare these results
with your expectations. Mention any anomalies or unexplained behaviors.



