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Pe r i s t a l t i c  Pump

Introduction

In a peristaltic pump, rotating rollers are squeezing a flexible tube. As the pushed down 
rollers move along the tube, the fluid in the tube follows the motion. The main 
advantage of the peristaltic pump is that no seals, valves or other internal parts ever 
touch the fluid. Due to their cleanliness, peristaltic pumps have found many 
applications in the pharmaceutical, chemical, and food industries. Besides this, the 
action of a peristaltic pump is very gentle, which is important if the fluid is easily 
damaged. Peristaltic pumps are therefore used in medical applications, one of which is 
moving the blood through the body during open heart surgery. Other pumps would 
risk destroying the blood cells.

This COMSOL Multiphysics model of a peristaltic pump is a combination of structural 
mechanics, for modeling the squeezing of the tube, and fluid dynamics, for computing 
the motion of the fluid. As it is the deformations of the tube that drive the fluid, the 
fluid part of the simulation needs to be done in a deforming geometry, defined by 
COMSOL Multiphysics’ Moving Mesh application mode.

Model Definition

The model is set up in 2D axial symmetry (Figure 10-21). A vinyl tube of length 0.1 
m, inner radius 1 cm, and outer radius 1.5 cm, contains a gas of density ρ = 1 kg/m3 
and viscosity η = 3e-5 Pa-s. A time and position dependent force density is applied to 
the outer wall of the tube, in the radial direction. This force density could have been 
taken from real data from a peristaltic pump, but is for simplicity modeled as a Gaussian 
distribution along the length of the tube. The Gaussian has a width of 1 cm and is 
moving with the constant velocity 0.03 m/s in the positive z direction. The 
engagement of the roll is represented by the force density being multiplied by a 
smoothed Heaviside function, kicking in at t = 0.1 s and taking the force to its full 
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development at t = 0.5 s. Likewise, the disengagement of the roll starts at t = 1.0 s and 
ends at t = 1.4 s. The deformations of the tube are modeled during a full cycle of 1.5 s.

Figure 10-21: The geometry of the peristaltic pump in its initial shape (left) and as it is 
deforming under the pressure of the roll. The tube is rotationally symmetric with respect to 
the z axis. The color scale shows the deformation of the tube material.

D O M A I N  E Q U A T I O N S

The structural mechanics computations are done using a 2D axially symmetric 
stress-strain formulation. The material is presumed to be linear and elastic, and 
geometric nonlinearities are not considered. With the capabilities in the COMSOL 
Structural Mechanics Module, this model could be easily be extended to account for 
large deformations and/or use a more complicated material model.

The fluid flow is described by the Navier-Stokes equations:

 (10-8)

where ρ denotes the density [kg m-3], u the velocity vector [m s-1], η the viscosity [N 
s m-2], and p the pressure [Pa]. The equations are set up and solved in axial symmetry 
on a deformed mesh inside the tube.
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The motion of the deformed mesh is modeled using Winslow smoothing. For more 
information, please refer to “The Moving Mesh Application Mode” on page 303 in 
the COMSOL Multiphysics Modeling Guide.

B O U N D A R Y  C O N D I T I O N S

For the structural mechanics computations, the time and coordinate dependent load 
described above is used as the boundary condition at the outer surface of the tube. 
Whereas the top and bottom ends of the tube are constrained along both coordinate 
axes, the inner surface is free. The reaction forces from the fluid on the tube are very 
small, so this model does not take them into account. This way you can solve first for 
the structural mechanics and then for the fluid dynamics, reducing solution time and 
memory consumption.

The inner surface is free, and the top and bottom ends of the tube are constrained 
along both coordinate axes.

For the fluid simulation, the boundary condition at the inlet states that the normal 
component of the stress tensor is zero:

 (10-9)

At the outlet, a reference zero pressure is applied. At the tube wall, the fluid is assigned 
the same velocity as the tube.

Inside the wall of the tube, the moving mesh follows the deformations of the tube. The 
mesh deformations being the same as the structural deformations is also used as the 
moving mesh boundary condition where the fluid meets the tube wall. The mesh is 
fixed to a zero r displacement at the symmetry axis and a zero z displacement at the 
top and the bottom of the tube.

Results

Figure 10-22 shows three snapshots from the peristaltic pump in action, and 
Figure 10-24 shows the inner volume of the tube as a function of time. At t = 0.3 s, 
the roll has begun its engagement phase and is increasing its pressure on the tube. As 
less space is left for the gas, it is streaming out of the tube, through both the inlet and 
the outlet. At t = 0.7 s, the roll has been fully engaged for a while. As it is moving up 
the tube, so is the gas, both at the inlet and at the outlet. This is where most of the net 
flow in the direction from the inlet to the outlet is created. Finally, at t = 1.2 s, the 

n pI– η ∇u ∇u( )T
+( )+[ ]⋅ 0=
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engagement process is reversed as the roll is disengaging. Fluid is streaming into the 
tube from both ends.

Figure 10-22: Snapshots of the velocity field and the shape of the inside of the tube at t = 
0.3 s, t = 0.7 s, and t = 1.2 s. The colors represent the magnitude of the velocity, and the 
arrows its direction. 
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Figure 10-23: The inner volume (m3) of the tube as a function of time (s).

InFigure 10-24, the inlet and outlet flows are shown. The overall behavior indicated 
in the velocity snapshots is confirmed. As the roll is engaged, gas is squeezed out 
through both the inlet and the outlet. When the fully engaged roll is moving along the 
tube, gas is steadily flowing in through the inlet and out through the outlet. As the roll 
is disengaging, the gas is being sucked back into the tube. In a real peristaltic pump, 
the peaks associated with the volume changes are usually removed or kept to a 
minimum, by another roll engaging at the same time as the first roll is disengaging. 
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This way, there are hardly any volume changes, and the fluid is flowing forward all the 
time.

Figure 10-24: Inlet (blue solid line) and outlet (red dashed line) flow in m3/s as functions 
of time. Positive values indicate that the gas is flowing in through the inlet and out 
through the outlet. 
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Figure 10-25 sums up the process, plotting the accumulated net flow versus time. It is 
worth noting that although the accumulated flow during the first 0.5 s of the cycle is 
zero or negative, it is well above zero after the full cycle.

Figure 10-25: Accumulated flow (m3) through the pump versus time (s). 

Modeling in COMSOL

This model is primarily intended to demonstrate the use of the Moving Mesh (ALE) 
application mode, but it also shows some postprocessing features. Integration coupling 
variables are defined for the flow computations and for evaluating the inside volume of 
the tube. An ordinary differential equation is used for calculating the accumulated 
flow. The smooth step function in this model is flc2hs, which is a C2-continuous step 
with a given step width.

Model Library path: COMSOL_Multiphysics/Multiphysics/peristaltic_pump

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.
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2 In the Model Navigator, set the Space dimension to Axial symmetry (2D) and click the 
Multiphysics button.

3 Select COMSOL>Structural Mechanics>Axial Symmetry, Stress-Strain>Transient analysis 
in the list of application modes and click Add.

4 Select COMSOL>Deformed Mesh>Moving Mesh (ALE)>Transient analysis and click Add.

5 Click the Application Mode Properties button and set the Smoothing method to 
Winslow. 

6 Select COMSOL>Fluid Dynamics>Incompressible Navier-Stokes>Transient analysis and 
click Add.

7 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

8 Specify two rectangles according to the table below

9 Click the Zoom Extents button in the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 Open the Constants dialog box from the Options menu and enter constants 
according to the following table. The descriptions are optional.

2 In the Options menu, go to Functions and define a new function according to 
following table.

NAME WIDTH HEIGHT BASE R Z

R1 0.01 0.1 Corner 0 0

R2 5e-3 0.1 Corner 0.01 0

NAME EXPRESSION DESCRIPTION

t_on 0.3 Time when roll is engaged (s)

t_off 1.2 Time when roll is disengaged (s)

dt 0.2 Time to reach full force (s)

z0 0.03 z coordinate where roll starts (m)

v0 0.03 Vertical velocity of roll (m/s)

width 0.01 Width of Gaussian force distribution (m)

Ttot 1.5 Total time for a pump cycle (s)

Lmax 4e6 Max load (N/m^2)

NAME ARGUMENTS EXPRESSION

gauss x, sigma 1/(sigma*sqrt(2*pi))*exp(-x^2/(2*sigma^2))
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3 Go to Physics>ODE Settings and define an ordinary differential equation with the 
following settings:

4 Select Integration Coupling Variables>Boundary Variables from the Options menu and 
specify the following boundary integration variables:

5 Select Integration Coupling Variables>Subdomain Variables from the Options menu and 
specify the following subdomain integration variables:.

P H Y S I C S  S E T T I N G S — S T R E S S - S T R A I N

Subdomain Settings
1 In the Multiphysics menu, select Axial Symmetry, Stress-Strain.

2 Open the Subdomain Settings dialog box. Select subdomain 1 and clear the Active in 

this domain check box.

3 Select subdomain 2 and click Load. Select Nylon from the list of materials and click 
OK.

4 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
Open the Boundary Settings dialog box from the Physics menu and apply the following 
boundary settings.

NAME (U) EQUATION INIT(U) INIT (UT)

netflow netflowt-(inflow+outflow)/(2*Ttot) 0 0

SOURCE BOUNDARY NAME EXPRESSION INTEGRATION ORDER GLOBAL DESTINATION 

2 inflow 2*pi*r*v 4 checked

3 outflow 2*pi*r*v 4 checked

SOURCE SUBDOMAIN NAME EXPRESSION INTEGRATION ORDER GLOBAL DESTINATION 

1 Vol 2*pi*r 4 checked

BOUNDARY 4 5, 6 7

Constraint RR 0

Constraint RZ 0

Load FR -Lmax*flc2hs(t-t_on,dt)*

gauss(z-z0-v0*t,width)*flc2hs(t_off-t,dt)

Load FZ
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M E S H  G E N E R A T I O N

1 Open the Mesh Parameters dialog box from the Mesh menu.

2 On the General page, set Maximum element size to 2e-3.

3 Click Remesh and then OK.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Manager, go to the Solve For tab and select Axial Symmetry, 

Stress-Strain. Only this application mode and its solution variables uor and w should 
be selected. Click OK to close the dialog box.

2 In the Solver Parameters dialog box, select Time dependent from the Solver list. Set 
Times to 0:0.01:1.5, Relative tolerance to 0.001 and Absolute tolerance to 1e-5.

3 On the Time Stepping tab, set Time steps taken by solver to Strict.

4 Click OK and then Solve.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises stress distribution.

1 In the Plot Parameters dialog box, go to the Deform tab.

2 Select the Deformed shape plot check box and set the Scale factor to 1.

3 Use the Solution at time list on the General tab and click Apply to study the stress 
distribution and the deformation of the tube at a few points in time.

P H Y S I C S  S E T T I N G S — I N C O M P R E S S I B L E  N A V I E R - S T O K E S

Subdomain Settings
1 In the Multiphysics menu, select Incompressible Navier-Stokes.

2 Open the Subdomain Settings dialog box. Select subdomain 2and clear the Active in 

this domain check box.

3 In subdomain 1, set the Density to 1 (kg/m3) and the Dynamic viscosity to 3e-5 
(Pa-s).

4 Click OK to close the Subdomain Settings dialog box.
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Boundary Conditions
Open the Boundary Settings dialog box from the Physics menu and apply the following 
boundary settings.

P H Y S I C S  S E T T I N G S — M O V I N G  M E S H

Subdomain Settings
1 In the Multiphysics menu, select Moving Mesh (ALE).

2 Open the Subdomain Settings dialog box. Keep the default Free displacement in 
subdomain 1.

3 In subdomain 2, select Prescribed displacement. Enter uaxi_axi for dr and w for dz. 
These are the structural r and z deformations. The reason you cannot use physics 
induced displacements here is that uaxi_axi is not a solution variable in the 
Stress-Strain application mode.

4 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
Open the Boundary Settings dialog box from the Physics menu and apply the following 
boundary settings.

C O M P U T I N G  T H E  S O L U T I O N

1 In the Solver Manager, go to the Initial tab and click the Store solution button. By 
default, all solutions are selected in the Store Solution dialog box. Click OK to 
confirm the selection.

BOUNDARY 1 2 3 4

Type Axial Symmetry Neutral Outflow/Pressure Inflow/Outflow 
velocity

u0 uaxi_t_axi

v0 wt

p0 0

BOUNDARY 1 2-3 4

Type Mesh 
displacement

Mesh 
displace
ment

Mesh 
displacement

dr 0 uaxi_axi

dz 0 w
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2 Set Value of variables not solved for and linearization point to Stored solution and 
Solution at time to All. This makes the software use the solution for the deformation 
of the tube when computing the fluid flow.

3 On the Solve For tab, select all variables but uor and w. Click OK.

4 Open the Solver Parameters dialog box, go to the General tab. Set the Absolute 

tolerance to 1e-3 and the Relative tolerance to 0.01. 

5 On the Time Stepping tab, set the Error estimation strategy to Exclude algebraic.

6 Click OK and then Solve.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The plot still shows the deformations from the stress-strain computation. To see the 
velocity field, do the following:

1 In the Plot Parameters dialog box, go to the General tab and clear the Deformed shape 
check box.

2 On the Surface tab, select Velocity field (ns) among the Predefined quantities.

3 On the Arrow tab, select Velocity field (ns) among the Predefined quantities. Click the 
Color button and choose a black color.

4 Once more, you can select different times to look at on the General tab. You will see 
the deformations even though you are not making a deformation plot, because the 
mesh is deformed.

5 If you want to animate the velocity field as a function of time, go to the Animate tab 
and click Start Animation. It may take some time for your computer to render the 
animation.

6 After closing the Plot Parameters dialog box, go to Postprocessing>Domain Plot 

Parameters. 

7 Use the Expression field on the Point tab to plot, for instance, the expressions 
inflow, outflow, netflow, or Vol. Because these variables are defined with a global 
destination and do not depend on the location, the coordinates do not matter. If 
you want to show more than one curve at the same time, use the Keep current plot 
check box on the General tab.




