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1.Introduction

This course is designed for users who are familiar with Microsoft Excel and have
already used PI DataLink.

Learn how to combine the power of Pl Datalink with Excel's advanced features such
as sparklines, Pivot Tables, Pivot Charts, and dynamic arrays. Using these tools, we
will show you best practices for creating reports and examples to prepare Pl System
data and event frames for root cause analysis.

1.1 Workspace & File Locations

Each course attendee has their own client machine but will be using the same Pl Data
Archive and AF Server, PISRV1. All machines are VMs hosted in an Azure Virtual
Learning Environment (VLE).

A soft copy of this workbook is available on the desktop of your client machine. As it
contains several hyperlinks, you are encouraged to copy the workbook from your
course client machine to your laptop. (The clipboard is enabled through Remote
Desktop connections)

1.2 The Fictitious Plant Used in This Course

In this course, we will have a fictitious plant named OSlsoft Plant. This simple plant
has two production lines, where each has a combination of one mixing tank and one
storage tank. This plant could be schematically shown as:
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OSlsoft Plant

Production Area

Mixing Tank2

As shown here, each tank has different process variables such as Internal and
External Temperatures, Flow Rate, Pressure and Level whose values are continuously
collected from devices on the Plant. In the early days of Pl System, these process
variables were the only data items whose historical data could be stored in Data
Archive.

There are some other data associated with each of these tanks such as the
manufacturer, model and the installation date which are stored in the maintenance
sheets available on tables in SQL Server. Moreover, all the information related to the
material flowing in these tanks is kept in tables on the Plant’s SQL Servers.

Even though these tables are available on the SQL server, their information could not
easily be integrated with the historical data stored in Data Archive. Hence, using AF
and hierarchy becomes critical in bringing all the important data and information in one
place: the Pl System.

At the OSlsoft Plant, predictions on the level of each mixing tank is critical in running
a smooth production. This data, Level Forecast, is stored in a “Future” point on the
Data Archive and could be viewed on PI System displays or be compared to the actual
value of level in any PI Application.
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A collection of PI Points is built on Data Archive for storing the values of process
variables. There is also a hierarchy built in AF for this Plant, bringing all the important
information and data, including the process variable time series data, to one place.

=l (F Production Area
£ (§ Production Linel
e [ Mixing Tank1
: (5 Storage Tankl
= ( Production Line2
F Mixing Tank2
(5 Storage Tank2
(L}, Element Searches

(7 Elements

|== Event Frames

i Library

e Unit of Measure

84 Contacts

% Management
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Elements Mixing Tank1
5 Elements | General I Child Elements | Attributes |Pnrts I Analyses | Motification Rules | Version |
i () Data Archive

| Fter p -
&t ll’l&ll‘dame -"—‘-lh'alue 23]
= [£1 Asset Location Production Line1
&= =] AssetName Mixing Tank1
&= =1 Density 4321 gL
= =1 Diameter 5ft
B € | ¢F External Temperature 223,497 °F
= ‘ «F Average 229,7221°F

B € | <F FowRate

152.0182 US gal/min

&= =1 Height 10 ft
= =] Installation Date 3/22016 3:00:00 PM
] [=1 Manufacturer ACME
] =1 serial Number 8T493-C54
G- | 7 Internal Temperature 104,3854 °F
= ‘ &F Average 135.7157 °F
H & | F Level 4,597035 ft
] (=1 Maximum 10 ft
] =1 Minimum oft
B % | =] Target 5099405 ft
o B | ¢F Level_Forecast 4971141 ft

= [Z] Percentage Full 45.9703493118286 %
s B | g Pressure 83.58934 psi
FA | =1 Product BCS1717

B & &% RandomSeed

0.047563022490387324

= ¥ Status Emptying
s B % K ¢F Tank Status 3
= =1 Tank Volume 1468, 797 US gal




1.3 How to use this Workbook

This workbook is structured around exercises. Each exercise will begin with objectives
and background sections, then proceed through a variety of individual exercises,
directed activities, and questions. Solutions for exercises and questions are available
at the end of the overall exercise; directed activities guide you through the solution
already. For example, this is the structure for the first exercise:

4 2, EXERCISE: Create a Report using Pl DataLink
2.1 Objectives
2.2 Background
2.3 Single Value Functions in Pl Datalink
4 2.4 Multiple Value Functions in P| Datalink
24,1 Directed Activity: Element Relative Report
2.4.2 Exercise — Operational Start Up
2.4.3 Bonus: Excel Sparklines
2.5 Calculation Functions in P| Datalink
2.6 Solutions
l- 3, EXERCISE: &Analyze Downtime Events using Pivot...

To more easily browse this workbook, go to View > Show in the ribbon and check
Navigation Pane.

1.4 Useful Resources

e Pl DataLink User Guide, available
o viathe F1 key or question mark on a Pl DataLink task pane

o on LivelLibrary
o as a PDF download from the OSlsoft Customer Portal

e Pl DataLink Playbook, which contains

o Version history
o Common data gather steps for troubleshooting issues
o Architecture and data flow overview

o Links to articles addressing common issues, sorted by issue type
(installation, runtime, admin tasks, etc.)
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2. EXERCISE: Create a Report using Pl DataLink

2.1 Objectives

e Re-familiarize yourself with PI Datalink

e Create a report using the Calculated Data function.

2.2 Background

Pl DataLink is an add-in for Microsoft Excel that enables you to retrieve information
from your Pl System directly into a worksheet. Combined with the computational,
graphic, and formatting capabilities of Microsoft Excel, Pl DatalLink offers powerful
tools for gathering, monitoring, analyzing, and reporting Pl System data.

PI DataLink sorts its functions into groups:

B8 & O©R Yo = AR5 @

Current Archive | Compressed Sampled Timed | Calculated Time Explore Compare | Search Asset Properties | Update | Settings
Value Value v Data ~ Data~ Data Data~  Filtered ~ > v v Filter (&) Feedback

Single Value Multiple Yalue Calculation Events Search Properties Update Resources

e Single-value functions retrieve the value of a data item at a specific time. They
return exactly one value per data item.

e Multiple-value functions associate a Pl point or Pl AF attribute with a time
period over which there can be one or many corresponding values.

e Calculation functions compute values from PI point values, Pl AF attributes, or
performance equation evaluations during a specific time period.

o Events functions return events that meet specified criteria in a Pl AF database.
Use the Explore Events function to view and explore events in a hierarchical
format, or the Compare Events function for a flat format. These functions return
one event per row.

o The Search functions return data items that meet specified criteria.

e The Properties function returns the property value of a specified data item.
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2.3 Directed Activity: Calculation Functions in Pl Datalink

Problem Description

As a production manager, you want to create a report showing last week’s production
statistics. You want to display the following for the production from each day of the

past week:
e Total

e Average
e Maximum

You also want to do the same calculations for the entire week.

Approach

Step1: On your Pl Server, the production is the sum of the productions from the two
production lines and is stored on your AF Server as an attribute named Production
under the element of Production Area, as shown below:

Elernents Preduction Area
5 Elements | General | Child Elements | Attributes |Ports I Analyses | Version |
= Group by: Category [_| Template
ST Line 1 I -
. i (@ Miing Tank1 |F’°f“"" P 'l Mame: |Produchon |
¢ e [ Storage Tankl |y t | @) &|& Name a|yalue 3] | Description: | |
=l £ Production Line2 P
L () Mixing Tank2 | Category: <None> roperties: | <Mome> v]
i () Storage Tank2 Categories: 5
Element Seg'chesrage =n =] Asset Mame Production Area =HERLI= |||
) i Default UOM: U5 gallon per minute ] |
= | Production 1 97,61 US galfmin
. Value Type: | Single hd |
value: |5797.61 Us galjmin |
Data Reference: |F0rmula W |
Settings... |
A=, \Production Line 1\Mixing Tank 1|Flow
Rate;B=.Production Line2\Mixing Tank2 |Flow
Rate;[A+E]

Note: Use the PI Point CDT158 if you do not have access to the AF Database.
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Step 2: Spend a few minutes and fill out the following table:

Root
Path

Data
item

Start
time:

End
time:

Time
interval:

UOM

Step 3: You will use the template provided in sheet Production Summaries of the file
P1_DataLink-Exercises.xlsx. Use the values of your table in the provided template.

Important Notes:

When working with the weekly total, do not use the time interval. Only use it for the daily total
(hint).

Be sure to show the Start Time for the daily Calculations.

The percent good field is always located to the right of an aggregate calculation, so use

/1 Show percent 900d \yith the Maximum.
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2.4 Solutions

Calculation Functions (Production Summaries)

1.

22.

23.
24,
25.

26.
27.
28.

The table could be filled out as:
Root Path \\PISRV1\OSiIsoft Plant\Production Area

Data item Production

Start time: 04-Jan-2020 00:00:00

End time: 11-Jan-2020 00:00:00
Time 1d

interval:

UoOM US gal/min

Open the file PI_DatalLink-Exercises.xlIsx, then work on sheet Production Summaries.
Select cell B11.

In the PI DataLink ribbon, select the Properties function.

Select cell B5 as the root path, B6 as the data item, and UOM as the property.

Click OK.

Select cell A21.

In the Ribbon, select Calculated Data.

Make sure the Data Item radio button is selected near the top of the task pane.

. In the task pane, click in the Root path (optional) field.

. Click on cell B5.

. In the task pane, click in the Data item(s) field.

. Click on cell B6.

. In the task pane, click in the Start time field.

. Click on cell B7.

. In the task pane, click in the End time field.

. Click on cell B8.

. In the task pane, click in the Time Interval (optional) field.
. Click on cell B10.

. In the Calculation mode drop-down, select total.

. Since the UOM of the production is per min, select minute from the conversion factor drop

down.

Click OK to have 1440 entered in the Conversion Factor field for the total calculation mode
only. For all other calculation modes, leave this field at 1.

For column A only, check the show end time check box to fill the Time stamp column.
Click on the OK button.

Repeat steps 5-22 for columns C through D using the appropriate selection for Calculation
Mode (e.g., select Average in column C). When you get to column D, make sure the show
percent good check box is checked.

Select cell B32.

In the Ribbon, select Calculated Data.

In the task pane, make sure the Data Item radio button is selected.
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29.
30.
31.
32.
33.
34.
35.
36.
37.
38.

39.

40.
41.

In the task pane, click in the Root path (optional) field.

Click on cell B5.

In the task pane click in the Data item(s) field.
Click on cell B6.

In the task pane click in the Start time field.

Click on cell B7.

In the task pane click in the End time field.

Click on cell B8.

In the Calculation mode drop-down, select total.

Since the UOM of the production is per min, select minute from the conversion factor drop
down.

Click OK to have 1440 entered in the Conversion Factor field for the total calculation mode
only. For all other calculation modes, leave this field at 1.

Click on the OK button.

Repeat steps 24-38 for columns C through D using the appropriate selection for Calculation
Mode (e.g., select Average in column C). When you get to column D, check the show percent
good check box to fill the Percent Good column.
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3.Directed Activity: Analyze Downtime Events using
PivotCharts and PivotTables

3.1 Objectives

o Retrieve Event Frames in Pl DataLink
e Create a PivotTable and PivotChart from Event Frame Data
e Analyze Event Frames retrieved from Pl DataLink using PivotCharts and PivotTables

3.2 Background

PivotTables and PivotCharts are powerful tools to calculate, summarize, and analyze data that
let you see comparisons, patterns, and trends in your Pl Event Frame data. A pivot table is a data
summarization tool in Excel. It allows its users to transform columns into rows and rows into
columns and it also allows grouping by any data field.

3.3 Directed Activity: Retrieve Event Frames in Excel using Pl DataLink

Objectives
¢ Retrieve Event Frames in Pl DataLink
Problem Description

The operations manager needs a report that shows which downtime reason is most prevalent and
a comparison showing which tanks are the most problematic. He also would like to see information
about the total production loss from the tanks.

In this exercise, you will import event data into Excel. Later, you will create PivotTables and
PivotCharts to analyze the data.

Approach

Step 1: Open the Downtime Raw Data sheet and fill in the values for cells B1:B3 as:

a. Database: ‘WPISRV1\OSlsoft Plant
**Note: use the single quote ‘ to format the cell as text and not a function

b. Search Start: t-7d

c. Search End: *

Step 2: Select cell A7 as your Output Cell

Step 3: Select Compare from the Events group
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Step 4 : Make the following selections:

a. Database:
W\PISRV1\OSlsoft Plant

Database

Compare Events

Event name

b. Event name: Bl

| ‘Dowrtime Raw DatalSB51

| -

c. Search start: B2

Search start

Event template

d. Search end: B3

| ‘Dowrtime Raw Data’lSB52

| Downtime

Search end

e. Event template:

Element name

Downtime

| ‘Dowrtime Raw DatalSB53

-

f. Element name: *

Step 5: From Columns to display select Event name, Start time, End time, Duration, Event
Template, Primary element, Event Duration (min), Maximum External Temperature,
Maximum Internal Temperature, Reason Code,

Temperature Difference.

|Evert template

JPrimary element

[Temperature Difference
|Evert Duration {minutes)
IMaxdmum Extemal Temperature
IMaxdmum Intemal Temperature
JLost Production (gal)

JReason Code

| & & & & &) & =] &]

Step 6 : Click OK.
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3.4 Directed Activity: Create PivotTables and PivotCharts

Objectives

e Create a PivotTable and PivotChart from Event Frame Data

3.4.1 Comparing Downtime Events Based on Reason Code

We would like to determine which causes of events are the most frequent and costly.
To do this, we will create a PivotChart report from Event Frames generated in AF.

After completing the Event Frame search in the previous section, use the following
instructions to create the Pivot Chart and Pivot Table.

Step 1: Go to the Evaluating Tank Downtime Blank sheet, select the Insert ribbon and select
the PivotChart option. Select the columns and rows of interest from the Downtime Raw
Data tab. This will create a PivotTable and a PivotChart.

HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW PI DATALINK PI BUILDER POWERPIVOT

5 [ D hd D T g dsee B v "= |k

-
tecommended Table  Pictures Online Shapes SmartArt Screenshol g \p apps - Bing People Recommended " Ui Lctchart | pow
PivotTables Pictures  + - 7 Maps Graph Charts - k- - Vie

Tables llustrations Apps Charts T Repc
- £
B c D E

Comparing Reason Codes

Step 2: As input for the PivotTable select the .
cell range in the Downtime Raw Data S [
sheet where the CompareEvents S
function has returned the data Table/Range: |'Downtime Raw Data'ISAS7:5L5211] e
(including the header line). © Use an external data source
Then choose to place the PivotTable
and PivotChart in the Evaluating Tank

Choose the data that you want to analyze

Connection name

Choose where you want the PivotChart to be placed

Downtime Blank sheet. O New Worksheet
(®) Existing Worksheet
Location: |“Evaluating Tank Downtime Blank'!SBS4

Choose whether you want to analyze multiple tables
1:] Add this data to the Data Model

Tip: if you want to correct the source area later in
time, select all cells of your PivotTable (or choose
the Analyze ribbon), then from the Analyze
Ribbon, select Change Data Source.

OK H Cancel ‘
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Step 3:

The PivotChart field list should now be shown in your Excel worksheet and a range of
the worksheet should be designated where the pivot table will be located, as shown
below.

[ D E <
PivotChart Fields i

Comparing Reason Codes

Cheose fields to add te report: -

4 b | Material Balance Report | Downtime Raw Data | Evaluating Tan .. () 1 »

Step 4 :

Step 5:

To build a report, choose fields from the PivotTable Field List

Chart 3

To build a PivotChart, choose fields from the PivotChart Field List

erature
0 [I " Drag fields between areas below:

v FILTERS LEGEND (SERIES)

AXIS (CATEG.. | = VALUES

Defer Layout Update

Select the PivotTable, and review the PivotTable Field list. These fields come from the
column names of the Downtime Raw Data sheet.

To perform a downtime analysis for our Event Frames based on the corresponding
reason code, select the .|Reason Code line and drag into the Values area. The
applied Aggregation for the reason codes is COUNT, because these are hon-numeric
values. Select the .|Reason Code line again and drag into the Rows area:

A B c D E -
1 PivotChart Fields %
2 Comparing Reason Codes Choose s tosatorepats | =
3
4 Row Labels + Count of .[Reason Code .|Event name -
5 Electrical 13 [Start time
6 Maintenance 63 J[End time
7 Mechanical 61 [Duration
8 Scheduled Downtime 59 'E” o
9 Unknown 8 [Event template
10 Grand Total 204 [Primary element
1 [Event Duration (minutes)
12 |Lest Production (gal)
13 s [Maximum External Temperature
14 Couptol JReaconCode, |Maximum Internal Temperature
15 - -
16 Total &
17 . Drag fields between aress below:
18 60
19 FILTERS LEGEND (SERIES)
2 50
2 40
2 0 mToml
23 20
2 10 AXIS (CATEG.. | X VALUES
2 . - ‘
2 JReason Code ~ | |[ Count of Rea... >
Electrical Maintenance  Mechanical Scheduled Unknown
27 Downtime
28
29 .|Reason Code
20 -
4 v .| Material Balance Report | Downtime Raw Data | Evaluati ... (®) f v DeferLayout Update
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Step 6 : Selectthe .|Lost Production (gal) line and drag into the Values area. The aggregation
applied for these numeric values is SUM. Select the .|Temperature Difference line
and drag into the Values area. Change the aggregation type to Average.
Your PIVOT table is extended 2 additional columns, which summarize corresponding
production losses and temperature differences, based on the reason codes:

A B c D E <
1 PivotChart Fields X
2 Comparing Reason Codes Chocsefildstosddtoreport | 4 =
3
4 Row Labels ~ |Count of .|Reason Code Sum of .|Lost Production (gal) Average of .[Temperature Difference |Duratien =
5 Electrical 13 1661374903 98.30050131 [Event template
6 Maintenance 63 132026.5988 1021547057 [Primary element
; Scheduled Downt 5 61088 2151 101 2746503 v Durtion i)

chedule owntime ¥ . .
-|Lost Producti I
9] Unknown B 22368.10064 102.1978455] =4 'M " “E‘xt"’" (IQT‘” .
10 Grand Total 204 430130.7018 101.3068936 A U, A
" [Maximurn Internal Temperature
12 /| .|Reason Code
13 | |Temperature Difference
14 Count of |Reason Code Sum of .|Lost Praduction (gal) Average of .Temperature Difference
MORE TABLES... -
15 180000
16 160000
17 140000 Drag fields between areas below:
16 100000 Values
19 80000 mCount of _|Reason Code FILTERS COLUMNS
20 60000 3 Values -
24 40000
20000 m5um of _|Last Production (zal)
2 o W | _ _
2 & & & & & Average of | Temperature
éé & & & & Difference ROWS ¥ VALUES
2% & T [Reason Code ~ | || Countof J.. » |+
27 & Sum of JL.. ¥
28 Average of... ¥ |~
29 JIReason Code +
an A
4 b+ .| Material Balance Report | Downtime Raw Data Evaluating Tank Dc ... (&) . v Defer Layout Update

Tipl: if the PivotTable Fields pane was closed and you want to have it available again, select a
cell of your PivotTable. From the right-mouse button menu, select Show Field List.

Tip2: to change the aggregation that is applied to your data, select the dropdown icon on the field,
and choose Value Field Settings... to select another aggregation type.

[P I S

Move Up Value Field Settings [ > (.

Dif Source Name: .[Temperature Difference
Move to Beginning
Custom Name: Average of .|Temperature Difference
— _
Summarize Values B how Values A:
i an Move to Report Filter ¥ [ohow Vaitesis
Move to Axis Fields (Categories) Summarize value field by
. P = Choose the type of calculation that you want to use to summarize
Moveto Legend Fields (Series) data from the selected field
[sum ﬂ
Count
Hide Value Field Buttons on Chart [Average \
|
Hide Al Field Buttons on Chart m:‘
> Remove Field | Product 2
L—'o Value Flel&Seﬂzlﬂgs..‘
Sum of |T.. ¥ ¥~
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Step 7: Let's enhance our Pivot table for analysis depending on
individual tank selections.
Which  column of our data represents a tank?
Step 8: Select a cell in the Pivot Table, and select the Analyze ribbon
from the Pivot Table tools. Click on Insert Slicer, select .|Primary
Element and click on OK.
Step 9: Add a slicer for the primary element, which allows you to select
any combination of one or more tanks for our analysis.
Check various combinations (use Shift- and Ctrl-key for
selections in the slicer):
a. alltanks
b. Mixing Tankl only
c. all Mixing Tanks
Comparing Reason Codes
Row Labels ~ Count of .|Reason Code Sum of .|Lost Production (gal) Average of .|Temperature Difference
Electrical 5 8650.75694 9712631149
Maintenance 32 72533.82153 100.3266851
Mechanical 38 64062.79905 100.68335834
Scheduled Downtime 29 §3752.73341 103.9344785
Unknown 4 13864 89748 99 44203186
Grand Total 108 242865.0084 101.240019
Count of .|Reason Code Sum of .|Lost Production [gal) Average of |Temperature Difference JPrimary element b4
ggggg Mixing Tank1
;gggg = | Mixing Tank2 ]
igggg m Count of . |Reason Code Storage Tank1
;gggg Storage Tank2
'_0002 . - - - _I m 5um of _|Lost Production (gal)
.CC; (@\J’ S@ .&\.\‘ i‘j\“ Auﬁrage of .| Temperature
&F @@"‘\L @2-;5\ \Q/be & \5&— Difference
;}\)

.|Reason Code -

Insert  Insert Chany
Slicer Timeline Sou
Filter Data

Insert Slicers _

[].|Event name

[“1.5tart time

[[].IEnd time

[.|puration

[].|Event template

[+#].IPrimary element

|:| \|Event Duration [minutes)
[].JLost Production (gal)
[].IMaximum External Temperature
D.|Max\mum Internal Temperature
[].|Reason Code

D.ITemperature Difference

The PivotTable and the PivotChart will update to show you what reason code is
causing most of the downtime events. In the screenshot above, during the observed
period of time, Electrical and Unknown events were the least common sources of

downtime.
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3.5 EXERCISE : Comparing Downtime Events Based on Tank

Now that we have determined which downtime causes are most frequent, we need to determine
which tank should get our attention first.

Step 1: To create areport to compare downtime events based on tanks, we will follow a similar

procedure as above. Repeat the procedure outlined in Steps 1-4 above to create a
new PivotChart and PivotTable with the same Event Frame data.

Step 2: To perform a downtime analysis for our Event Frames based on the corresponding
tank, select the .|Lost Production (gal) line and drag into the Values area. The
applied Aggregation for the reason codes should be SUM. Select the .|Primary
element line again and drag into the Rows area

Step 3: To add an additional visual, drag the .|Reason Code to the Legend (Series) area.

Drag fields between areas below:

FILTERS LEGEND (SERIES)

J|Reason Code i

AXIS (CATEGORIES) VALUES

J|Primary element & Sumn of |Lost Preductio.. ™

Step 4 : Select the PivotChart, then go to the Design tab and choose Change Chart Type.
Choose the Area category on the left, then choose Stacked Area as the Chart Type.
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The result is a report that shows us which tank has had the most production loss, along with a
quick glimpse of which reason codes are causing the production loss.

Comparing Tanks

Sum of .|Lost Production (gal) Column Labels

Row Labels Electrical Maintenance Mechanical Scheduled D i Unk Grand Total
Mixing Tank1 1499.206707 16424.04732 1676591656 22577.51658 9769.553726 67056.24089
Mixing Tank2 5230.233884 53281.47118 47296.85249 61175.21683 4075343752 171059.1481
Storage Tank1 5380.131752  22003.86065 14484 51055 31649.42047 3041.237542 76559.16097
Storage Tank2 2582.860339  34929.89609 19476.72868 45696.06119  5461.96562 108147.5119
Grand Total 14692.43268 126639.2752 98024.03828 161098.2151 22368.10064 422822.0619

Sum of .|Lost Production [gal)
180000
160000
140000 .|[Reason Code vY
120000 m Unknown
100000 M Scheduled Downtime
m Mechanical
50000 .
H Maintenance
40000
m Electrical
20000
o
Mixing Tankl Mixing Tank2 Storage Tankl Storage Tank2
.|Primary element vY
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3.6 Analyze Downtime Events Using PivotTables and PivotCharts

Objectives

e Analyze Event Frames retrieved from Pl DataLink using PivotCharts and PivotTables

Problem Description

The operations manager needs a report that shows which downtime reason is most prevalent and
a comparison showing which tanks are the most problematic. He also would like to see information
about the total production loss from the tanks.

Now that you have imported event data into Excel and created PivotTables and PivotCharts, use
them to analyze the data.

Approach
Step 1: You will use the template provided in sheets Downtime Raw Data and Evaluating Tank
Downtime of the file PI_DataLink-Exercises.xIsx.
Step 2: Open the Evaluating Tank Downtime sheet.

Step 3: Select the PivotTable under Comparing Reason Codes, then, from the Analyze tab,
select Refresh
FIWITTABLE OO

3 BUILDER POWERPIVOT AMALYZE DESIGM

> B BE B G

Refresh Change Data  Clear Select  Move Fields, H
M Source~ - *  PivotTable & Set

Data Actions

Step 4. Select the PivotTable under Comparing Tanks, then, from the Analyze tab, select
Refresh

Step 5: Which Reason Code caused the most production loss overall?

Step 6 : Which Reason Code caused the most production loss for the Storage tanks?

Step 7 : Which Tank has caused the most production loss?
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3.7 Bonus: Making Reports More User-Friendly

Objective
o Leverage out-of-the-box Excel functionality to make your report easier to use.

Problem Description
You would like to put some finishing touches on your workbook so that it is easier for others to
use.
Approach
Step 1: Hide the sheet containing raw data.

Step 2: Configure the PivotTables to automatically refresh data when the workbook is opened.
(As a result, the PivotCharts will automatically refresh as well).

Step 3: Prevent column widths and cell formatting from adjusting on data refresh so the
PivotCharts will print consistently.
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3.8 Solutions

Analyze Downtime Events Using PivotTables and PivotCharts

1. Which Reason Code caused the most production loss overall? Use the Comparing
Tanks PivotTable. Find the reason code corresponding to the highest individual value in
the Grand Total row (H10:L10).

2. Which Reason Code caused the most production loss for the Storage tanks? Use
the Row Labels filter to choose only the storage tanks, then find the reason code
corresponding to the highest individual value in the Grand Total row.

3. Which Tank has caused the most production loss? Make sure all tanks are selected
in the filter for the Comparing Tanks PivotTable, then look at which tank has the highest
sum of .|LostProduction (gal) in the PivotChart.

Bonus

1. Right-click the Downtime Raw Data sheet and select Hide
2. Select the PivotTable, then go to Tools > Analyze > PivotTable > Options > Data > Refresh

data when opening file (Microsoft doc)

o Or VBA, although we recommend using out of the box functionality instead if
possible. Example: when source data changes via Excel Campus

3. PivotTable Tools > Analyze > PivotTable > Options > Layout & Format > check Autofit
column widths on update and Preserve cell formatting on update (Microsoft doc)
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https://support.office.com/en-us/article/refresh-pivottable-data-6d24cece-a038-468a-8176-8b6568ca9be2
https://www.excelcampus.com/vba/refresh-pivot-tables-automatically/
https://support.office.com/en-us/article/refresh-pivottable-data-6d24cece-a038-468a-8176-8b6568ca9be2

4.Directed Activity: Improve Performance of Large
Workbooks

4.1 Objectives

e Prevent Excel from recalculating when you don’t want it to

e Use Microsoft's built-in Inquire add-in to create a summary of what a large
workbook contains

e Measure how many data calls Pl DataLink makes in the background when
opening a workbook or recalculating

o Use Excel's Formula Auditing tools to see relationships between formulas

¢ Improve performance of large workbooks by substantially reducing the number
of calls Pl DataLink must make

4.2 Background

Under the hood, Pl DatalLink takes the information entered into the task pane for a
given function and creates an AF SDK call. So, the more PI DatalLink functions you
have, the more AF SDK calls must be made to retrieve data. Thus, it is important to
keep in mind how you can minimize calls when building out or modifying large
workbooks containing many hundreds of formulas (or more).

This section will teach you some best practices when troubleshooting why workbooks
containing many PI DataLink functions open or recalculate slowly. You will learn how
to minimize unnecessary recalculations (each of which could take minutes); quantify
the number of calls made by PI DatalLink to its data access layer, the AF SDK; and
finally, reduce the number of calls necessary by using cell ranges as input and/or bulk
data retrieval methods.

For more detailed information on architecture and data flow, see Pl DataLink’s
playbook in the Customer Portal. For your convenience, here is the data flow section:

Data Flow
Pl System data is retrieved by Pl DataLink into Excel in the following manner:
1. User inputs parameters via the function pane

2. Recalculation is initiated via OK/Apply or right-click > Recalculate (Resize)
Function

PI DataLink takes the input parameters and forms an AF SDK call

AF SDK handles reaching out to back-end resources (Pl Data Archive, AF
Server) and calculations

AF SDK returns values to Pl DatalLink
Pl DataLink creates output appropriate for Excel and pastes values into the
worksheet
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https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=000025475

4.3 Directed Activity: Measure AF SDK calls made in the background

Objective
e Measure how many data calls Pl DataLink makes in the background when
opening a workbook or recalculating
Problem Description

How do you quantitatively measure the background activity to recalculate the PI
DataLink functions in this workbook? Specifically, how do you log the calls Pl DataLink
makes to its data access layer, the AF SDK, to retrieve Pl System data?

Approach

Step 1: Open Excel
Step 2: Open the Task Manager (right-click the task bar, or Ctrl+Shift+Esc)
Step 3: Right-click on Microsoft Excel (32 bit) and Go to details

Step 4 : What is the process ID (PID) for the highlighted EXCEL.EXE process? Write it down.
Note: if you do not have a PID column, add it by right-clicking a column header >
Select columns.

1w Task Manager
File Options View
Processes  Perforrmance Users Det

Fay

Mame PID iy
I EXCEL.EXE 1432 R
e T [l I | =]

Step 5: Open Windows Explorer and go to %pihome64%\AF. (On the course machine, this is
equivalent to C:\Program Files\PIPC\AF)

Step 6 : Launch AFGetTrace.exe.

Step 7 ;. Configure the tracing settings: Enable Whitelist and enter Excel’s PID in the Process
IDs field

Step 8: Verify Enable PI, Enable AF, and Log Headers are all checked
Step 9 : Select Server and Data keywords
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Step 10:

Step 11
Step 12
Step 13

Step 14
Step 15
Step 16

Step 17
Step 18

Step 19
Step 20
Step 21
Step 22
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Enable Log and name your log/select log location

@D AF SDK Get Trace Utility

File Edit
General Trace Timeout Whitelist
Enable I Session Name [ ] Enable Timeout Enable Whitelist
Enable AF AFGetTrace Process IDs Thread |1Ds
Log Headers 1432
Level Keywaords
Verbose * | | Multiple ‘-‘ Mask
E“"JT [] Enable Mask

Log File Server
Enable Log [ [ ] Connection
Strace_open_currval log [] Cache
[ ] Enakle Max Size Data

[] Events

[ ] Trace

L1 AN

: Press the green, triangular Play button
: Open Performance Exercise.xIsx

:Notice the delay in opening as the workbook recalculates. Excel estimates its

recalculation progress in the bottom right:

|Calculating[EThreads]:SF‘E'-': |@Disp|ay5ettings B ]

: Save the trace

: Close the workbook while keeping Excel open (e.g. Bookl is still open)

:Go to File > Options > Formulas > Calculation Options and select Manual, then

uncheck Recalculate workbook before saving. Alternatively, in the Formulas tab,
go to Calculation > Calculation Options and select Manual. Note this second
method does not give you an option to control the save behavior.

: Change the name of your log and start a new trace

:Open Performance Exercise.xlIsx again, and notice the difference in open speed

because a recalculation was not triggered.

: Save the trace
: Change the name of your log and start a new trace
: Switch the calculation mode back to Automatic.

: Notice how any change you make to the workbook results in a lengthy recalculation.

For example, type “test” into cell N3, then delete it.



Step 23 : Review the three traces you just generated:
-when opening the workbook in the default Automatic calculation mode
-when opening the workbook in Manual calculation mode
-and when making any change to the workbook

Step 24 : Which trace is empty?

Step 25 : To determine the exact number of AF SDK calls made for a particular action, use the
AFGetTrace log and Notepad++’s Find All in Current Document functionality.

Step 26 : For example, clear the AFGettrace log output
I W R |:

Clear cutput

Step 27 : Perform an action that you saw results in AF SDK calls, such as loading the workbook
or making a change while in Automatic mode.

Step 28 : Stop the trace (red square).
Step 29 : Open the log in Notepad++

Step 30 : Highlight “End Call Sequence” and press Ctrl+F to open the Find window with those
search terms auto-filled

Step 31 : Select Find All in Current Document

Find n

Find  Replace Findin Files Mark

Find what | “] [ Foanee O
[ 1n selection Count
Find &ll in All Opened
Documents
[1Backward direction Find All in Current
[ ] Match whole word only Document
[ IMatch case Cose
Wrap around
Search Mode Transparency
(®) Mormal {® On losing focus
() Extended O, Y, Ve YD, Yl () always
() Regular expression . matches newline 1
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Step 32

Step 33

Step 34

Step 35

Step 36
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: See how many call sequences exist in the log

Find resutt - 1,000 hits

Search "End Call Seqonence" (1000 hits in 1 file)
C:\Program Files\PIPC\AF\trace open change.log (1000 hits)
Line 12: 2020-03-04 02:15:06.262 [EXCEL(1432):948]): End Ca.

: Calculate the total recalculation time by subtracting the first Begin Call Sequence

time from the last End Call Sequence time

: Calculate the average call sequence time. A relatively fast baseline is about 3-4

milliseconds per call.

: How many calls are made when opening the workbook in the default Automatic mode?

How much total time does this data access layer activity take?

: How many calls are made when making any change to the workbook? How much total

time does it take?



4.4 Directed Activity: Gather information about the workbook

Objective
e Prevent Excel from recalculating when you don’t want it to
o Use Excel's Formula Auditing tools to see relationships between formulas
e Use Microsoft's built-in Inquire add-in to create a summary of what a large
workbook contains

Problem Description

The operators for a plant your company recently acquired have been using a workbook
for a long time, designed by someone who left or retired years ago. It has been kind
of slow for a long time, but it’s finally gotten so bad they are now asking you to fix it.
You've never seen this workbook before. How do you analyze the workbook to find
out a likely root cause?

Approach
Step 1: Open Performance Exercise.xIsx

Step 2: Select the upper left cell in the block of PIAdvCalcVal functions (C2).
Step 3: Inthe Ribbon, select Formulas > Formula Auditing > Trace Precedents

Step 4 : Arrows point to the referenced cells containing the data item (B2), start time (C2), and
end time (D2):

- e =E1-1

B C D

Data Item 2/23/2020 0:0 /2020 D:DD! 2
Te — S7546399  43,92727177

Step 5: Notice each date cell in row 1 depends on the cell to the right, such as D1 referencing
E1.

Step 6 : Remove Arrows and select the right-most date cell (M1).
Step 7. Select Trace Dependents. Notice the huge number of arrows generated:

. L M -
)0 3/3#2626-0:60]—3/2020 0:00]

Clicking Trace Dependents additional times will show successive dependents,
eventually going all the way to column C. This is a visual reference of how the entire

31|Page



Step 8 :

Step 9.
Step 10
Step 11
Step 12:

Step 13
Step 14
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block of Pl DataLink calls is influenced by this one date cell with a formula of TODAY ().
We will discuss the performance impact of this function in the next exercise.

Switching gears, read Microsoft’s article for more broad coverage of their Inquire add-
in than will be presented in this course.

Go to File > Options > Add-ins > Manage: COM Add-ins and press Go...

: Check Inquire and press OK. An Inquire tab should load in the Ribbon.

Select Workbook Analysis. If prompted, do not save changes.

In the Items pane, check Summary, Workbook, and Formulas, then press Excel
Export...

: Save the analysis, then press Load Export File.
:How many formulas, number of formulas with errors, and hidden/very hidden sheets
are in this workbook?


https://support.office.com/en-us/article/what-you-can-do-with-spreadsheet-inquire-ebaf3d62-2af5-4cb1-af7d-e958cc5fad42

4.5 Improve performance by reducing the number of background calls

Objective

e Improve performance of large workbooks by reducing the number of calls PI
DataLink must make

e Learn about volatile functions in Excel recalculation

e Learn which Excel and Pl DataLink functions are volatile

Problem Description

Now that you know this workbook is making a large amount of relatively fast data calls,
how can you help performance by reducing the number of calls?

Read the Volatie and Non-Volatile Functions section of Microsoft's Excel
Recalculation article. This is also discussed in certain OSlsoft KB articles, such as
After upgrading Microsoft Office, opening complex spreadsheets using Pl DataLink is
much slower.

After reading, you should be aware of which Excel functions are volatile. The only PI
DataLink function that is volatile by default is Current Value. Why?

Insert a column into the workbook that contains the current value for each data item.
Do so in such a way that only one call sequence is made to populate the current

values.

Bonus: verify only one call sequence is made using AFGetTrace.

Approach

Step 1: Open Performance Exercise.xlsx

Step 2: Select cell M1 containing the volatile formula, TODAY()

Step 3: Type today’s date or press Ctrl+;

Step 4 : Using AFGetTrace, observe that AF SDK calls no longer occur when making an
unrelated change to the workbook, such as typing “test” in cell N3

Step 5: To recalculate the entire block of Pl DataLink formulas, go to Pl DataLink >
Resources > Settings and select Full calculate, Os Interval for the Automatic
Update. Then click the green Update button.

Step 6 : Using AFGetTrace, observe 1000 AF SDK calls are made for each recalculation cycle.

Step 7 : Click Update again to turn auto-update off.

Step 8: Select cell C2 and notice the formula references a single data item, $B2:
{=PlAdvCalcVal(Raw Data''$B2,'Raw Data'!C$1,'Raw Data'!D$1,"average (time-
weighted)","time-weighted”,0,1,0,"")}

Step 9: Right-click the cell and select Recalculate (Resize) Function (or use the task pane

> OK)
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https://docs.microsoft.com/en-us/office/client-developer/excel/excel-recalculation#volatile-and-non-volatile-functions
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=KB01907
https://customers.osisoft.com/s/knowledgearticle?knowledgeArticleUrl=KB01907

Step 10:

Step 11:

Step 12:
Step 13
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Notice how the entire row recalculated, not just that single cell, and the formula now
shows the contiguous range of data items ($B$2:$B$101) instead of the single data
item.

Repeat for each column so that there are ten formula arrays, each referencing 100
data items, instead of 1000 individual formula arrays.

Turn Update back on

Using AFGetTrace, observe the number of AF SDK calls has been reduced by an
order of magnitude. This is because these formulas now meet the conditions under
which PI DataLink is able to take advantage of bulk AF SDK calls, as documented in
the user guide’s Retrieval of large amounts of data topic.



https://livelibrary.osisoft.com/LiveLibrary/content/en/datalink-v8/GUID-6BA4CBB1-03C7-44D8-8D7F-3D0CAC9B3AC0

4.6 Solutions

Directed Activity: Measure AF SDK calls made in the background

1. Calculate the average call sequence time. Total time / # calls = time/call. So 3.8/1000
= 0.0038s, or 3.8 milliseconds.

2. How many calls are made when opening the workbook in the default Automatic
mode? Should be 1000.

3. How much total time does this data access layer activity take? Should be around 3-
4 seconds. During testing, it took 3.8s.

4. How many calls are made when making any change to the workbook? How much
total time does it take? # of calls and time should be very similar to the open, as the
functions all being volatile results in all of them recalculating on change, just like they do
on workbook open.

5. Which trace is empty? The one covering workbook open when in Manual calculation
mode should be empty.

Directed Activity: Gather information about the workbook

1. How many formulas, number of formulas with errors, and hidden/very hidden
sheets are in this workbook? Use the Inquire report you just generated. Example:

A B
1 Summary
2 | mag e o Ry ol el el il i oy B e B W E /P | World 202€
3
4 |ltem Value Rev
5 |Creation Date Monday, March 2, 2020 8:03:24 PM
6 Modified Date Wednesday, March 4, 2020 1:23:52 AM
7 |File Size (bytes) 48,088
B8 |Title
9 |Author Jeremy Roberts
10 |Linked Workbooks 0
11 |DDE Links 0
12 |Data Connections 0
13 Visible Sheets 1
14 Hidden Sheets 0
13 Very Hidden Sheets 0
16 |Formulas 1,111
17 |Array Formulas 1,000
18|| Formulas With Errors 0
19 |Formulas With Logical Values 1]

A M mrre o las TAEER Bl wrin W alm - L e Tal
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5. EXERCISE: Excel’s New Dynamic Array Functions

5.1 Objectives

e Learn about Excel’'s new dynamic array functions
e Create a report using Pl DataLink and these new Excel functions

e Brainstorm other ways these functions could prove useful to you

5.2 Background

Microsoft has recently made changes to Excel's calculation engine that enable
“dynamic arrays”, which allow you to write one formula and return many values. As of
January 17" dynamic arrays and the new functions that leverage them are available
in all Office 365 channels except Semi-Annual.

In this exercise, we will go through Microsoft’s preview of dynamic arrays. Then, we
will see a few ways these new functions could be used with Pl DataLink functions.

Note: In most cases, there are other ways to accomplish the same tasks besides these
new functions, such as VLOOKUP or INDEX(MATCH()). However, the new functions
will generally be simpler and easier to use.
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https://techcommunity.microsoft.com/t5/excel-blog/preview-of-dynamic-arrays-in-excel/ba-p/252944
https://techcommunity.microsoft.com/t5/excel-blog/preview-of-dynamic-arrays-in-excel/ba-p/252944

5.3 Learn about Excel’s new dynamic array functions

Objective

e Get hands-on experience with dynamic array formulas

Problem Description

Microsoft’'s Preview of Dynamic Arrays in Excel describes several aspects of dynamic
arrays and lists multiple dynamic array functions. Read through this article and the
articles on specific functions, such as SORT and FILTER. In addition, read the article
on the XLOOKUP function. Then follow along in the workbook.

Approach
Step 1: Open PI_DatalLink-Exercises.xIsx to the Dynamic Functions sheet.
Step 2: Sort the names in column A with a single dynamic function.

Step 3: Notice a couple of new behaviors for dynamic functions—first, when you select any
cell in the resulting array, the entire array is outlined in blue. In addition, only the top
left cell in the dynamic array is editable; all other cells in the array have greyed-out
formulas, and if you attempt to edit the cell, the formula disappears.

E | F |
Dynamic Arrays O

Mames  Sorted

Mary Alisan
Peter ICharIes )
John Jane
Simon John
Charles  [Mary

Jane Peter
Alison Simon

Step 4 : Cleanse the list of names in column D of duplicates with a single dynamic function.

Step 5: Filter the list of names in column G by the diet preferences in column H with a single
dynamic function.

Step 6 : With a single function, look up the country code for Brazil from the data in columns P
and R.

Step 7 : Bonus: Which aspects of this new functionality will work in earlier versions of Excel?
What will not work?
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https://techcommunity.microsoft.com/t5/excel-blog/preview-of-dynamic-arrays-in-excel/ba-p/252944
https://support.office.com/en-us/article/xlookup-function-b7fd680e-6d10-43e6-84f9-88eae8bf5929

5.4 Use dynamic array functions to complement Pl DataLink functions

Objective

e Use dynamic array functions with Pl DataLink functions to derive more value
out of your data

e Brainstorm other ways these functions could prove useful to you

Problem Description

You want to enhance your production summaries by sorting production days below a
certain threshold by their total production. After hearing about new dynamic functions,
you think they could be used to quickly accomplish your goals.

Approach
Step 1: Go to the Production Summaries sheet

Step 2: Use the SORT and FILTER functions to display a list of the days below 200,000
gallons of total production from the Daily Calculations table, in ascending order.

Step 3: Go to the Downtime Raw Data sheet

Step 4: In column T, use Compressed Data to retrieve values from yesterday for the tag
CDM158.
Note: you will need to enter ‘CDM158 for the data item; otherwise, it will be recognized
as a reference to the cell CDM158.

Step 5: Use the UNIQUE function to retrieve (1) the unique digital states in yesterday’s data
for CDM158 and (2) the unique reason codes in the event frame data.
Bonus: Sort the digital states and reason codes alphabetically.
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5.5 Solutions

Learn about Excel’s new dynamic array functions

1.

2
3.
4

Open PI_DataLink-Exercises.xIsx to the Dynamic Functions sheet.
In cell B5, use the SORT function and select the range of names: =SORT(A5:A11)
In cell E5, use the UNIQUE function and select the range of names: =UNIQUE(D5:D14)

Cell E9 contains a period, which prevents the dynamic array from spilling into the full cell
range it requires. This results in a #SPILL error. Delete this period, and the UNIQUE
formula will auto-populate.

In cell U4, use the XLOOKUP function with a lookup value of T4, a lookup array of
P4:P13, and a return array of R4:R13. If it's hard to keep track of the different fields,
use Formulas > Insert Function. =XLOOKUP(T4,P4:P13,R4:R13)

Bonus: It's probably wise to avoid using dynamic array functionality until your IT
department rolls out an O365 update containing dynamic arrays to you/your users.
Dynamic arrays will be converted to legacy Ctrl+Shift+Enter (CSE) formulas in older
versions of Excel and still work, but dynamic array functions will not be recognized,
resulting in #NAME? errors.

Remember that if you need to verify compatibility across multiple Office versions, you
can use File > Info > Check for Issues > Check Compatibility. For more information,
read Dynamic array formulas in non-dynamic aware Excel and Dynamic array formulas
vs. legacy CSE array formulas.

Use dynamic array functions to complement Pl DataLink functions

1.

On the Production Summaries sheet, in cells G20:120, label columns Criterion, Day,
and Production Total.

Enter 200,000 into cell G21

In cell H21, filter the Daily Calculations range containing the start time and Production
Total (gal) by the criterion: =FILTER(A21:B27,B21:B27<G21,"")

Now wrap the filtered range in a SORT to specify ascending order:
=SORT(FILTER(A21:B27,B21:B27<G21,""),2,1)
Note: This is an application of the example given in the SORT function’s documentation.

On the Downtime Raw Data sheet, in cell T7, use Compressed Data to retrieve
yesterday’s values for the tag CDM158:
{=PICompDat("cdm158","y","t",1,"","inside")}

In cell W8, use the UNIQUE function with the values from the Compressed Data
function, and use an ascending SORT for alphabetical order:
=SORT(UNIQUE(U8:U1934),,1)

Similarly, in cell Q8, use the UNIQUE function with the values in the .|Reason Code
column: =SORT(UNIQUE(L8:L36),,1)
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https://support.office.com/en-us/article/dynamic-array-formulas-in-non-dynamic-aware-excel-696e164e-306b-4282-ae9d-aa88f5502fa2?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/dynamic-array-formulas-vs-legacy-cse-array-formulas-ca421f1b-fbb2-4c99-9924-df571bd4f1b4?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/dynamic-array-formulas-vs-legacy-cse-array-formulas-ca421f1b-fbb2-4c99-9924-df571bd4f1b4?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-us/article/SORT-function-22f63bd0-ccc8-492f-953d-c20e8e44b86c

6. EXERCISE: Introduction to Pl DataLink
Documentation

6.1 Objective

e Learn about key articles in OSlsoft Technical Support’s Knowledge Base for PI
DataLink

6.2 Background

Pl DataLink has been and continues to be one of OSlIsoft’s most-used client tools.
Over the past two decades, OSlsoft Technical Support has answered well over
100,000 calls concerning Pl DatalLink. As you might expect, we have created
documentation along the way to help us efficiently answer these calls and deflect some
guestions outright as customers can find what they need in our Customer Portal
without our assistance.

This section will give you an overview of the most-used articles for Pl DataLink so that
the next time you have a question about Pl DatalLink the user guide doesn’t answer,
you will know how to find the same resources we use!

6.3 Access Pl DataLink’s user guide in context

Objective
e Access the Pl DataLink user guide in the context of your current task

¢ Understand the structure of the Pl DataLink user guide

Problem Description

Pl DataLink does not appear in the Ribbon, and you wish to search and view OSlsoft
Knowledge Base articles to help you troubleshoot.

Approach

Step1: You will use the template provided in sheet Operational Start Up of the file

Pl_DataLink-Exercises.xIsx.

Step 2: Select a cell containing a Pl DatalLink function, such as cell A11, and the task pane

will appear.
Step 3: Select any field in the Compressed Data task pane and press F1

Step 4 : Alternatively, in the top right of the task pane, click the question mark.

Step 5: This brings up the Compressed Data function topic in the local PI DataLink User

Guide, which describes each possible input for the function
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Step 6 :

Step 7:

Step 8 :

Step 9:

Navigate down a level to the Compressed Data example topic. (Each PI DataLink
function topic has an example.)

You can also use the function reference for more formula-focused help. Return to cell
A11 and view the formula.

In the user guide, navigate to the Function reference topic, select the group matching
the Ribbon group for your function, then select the exact function. For example,
Function reference > Multiple-value functions > PICompDat() for Compressed Data in
cell A1l

Go to the Downtime Raw Data sheet and view the documentation for the Compare
Events function

6.4 Directed Activity: Access the Customer Portal

Objective

e Configure your account (if necessary)

e Access the Customer Portal

Problem Description

PI DataLink does not appear in the Ribbon, and you wish to search and view OSlsoft
Knowledge Base articles to help you troubleshoot.

Approach
Step 1: Go to https://customers.osisoft.com and log in with your OSlsoft single sign-on (SSO)
account
' If you do not have an SSO account or have not been added to a site, at
™ your convenience go to https://explore.osisoft.com/myosisoft-customer-
Tip portal/how-to-get-a-login and follow the step-by-step instructions there.
Step 2: In the top search bar, search for “datalink playbook”
Step 3: Click on Playbook — Pl DataLink
Step 4 : Inthe Troubleshooting section under the Runtime list, select “Pl DataLink or PI Builder
does not appear in the Ribbon in Excel”
Step 5: Instead of using the playbook, now access the same article via direct search. Search
for your issue to find the article, filtering by the KB Articles content type if necessary.
Step 6 : Pretend two months have passed, and you vaguely remember something about an

AF tracing utility you used in a Pl World course. You think it could be useful to
troubleshoot your current situation but can’t recall exactly how to use it. Search to find
an article describing how to use the utility.
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Have an idea how to
improve our products?

OSlIsoft wants to hear
from you!

https://feedback.osisoft.com/

A
4
A
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