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Precision Drawing and Advanced Dimensioning
Learn to how to set up Canvas‘ Dimensioning tools to
create precision illustrations.

As a standard for technical illustration, Canvas is used worldwide by professional engi-
neers and designers for schematics, blueprints, and other types of drawing endeavors.
When creating complex technical illustrations, it sometimes may be necessary to work
with scaled objects. To help with this task, Canvas allows you to determine the scale and
measurement units of your technical illustrations for precision. Canvas also has a wide
array of Dimensioning tools to allow the user to create visible measurements.

In this tutorial, we‘ll show you how to go about setting up Canvas for precision drawing
and walk you through a few common Dimensioning tools.

Preparing the Document
We begin by starting Canvas
and opening a new Canvas
document. Choose File >
New.

When the New Document dia-
log box appears, choose Illus-
tration as Type of Document.
Note that from within this dia-
log box you also have the
option to select a different
document size and set the
unit of measurement for your
document. For this tutorial,
we elected to use Inches as
the unit of measurement.

After you have made your
selections, click OK.



Precision Drawing and Advanced Dimensioning (continued)

Setting your Rulers
Before we start drawing, we need to set our rulers.
To set the rulers, you first must make them visible
by choosing Layout > Display > Show Rulers. Your
Rulers will appear across the top and side of the
Canvas work area.

Next we will set the unit of measurement for the
rulers. You have the choice of using various units
of measurement. Canvas applies this unit of mea-
surement to the rulers as well as to the drawing
objects.

To set the ruler measurement, choose Layout >
Rulers. In the Rulers dialog box, open the Units
drop-down menu and select the unit of measure-
ment. For this tutorial, we have chosen Inches.

You now have to define the major divisions for
your chosen unit of measurement.

To set the ruler‘s major divisions, drag the double
arrow between the two rulers. Drag to the unit of
the top ruler that you want to be the major divi-
sion. The major division also determines the major
division of the alignment grid.



Precision Drawing and Advanced Dimensioning (continued)

Next, set the drawing scale using the text boxes
in the Scale area. In the first box, enter the base
unit measurement. Then, in the second box, enter
the scaled equivalent. In the third box, enter the
units for the scaled measurement. For our exam-
ple, we‘ve chosen a scale of 1 inch = 12 inches.

Finally, open the Minor divisions drop-down
menu and choose the number of minor divisions
to be shown on the rulers. For this tutorial,
we‘ve chosen 16.

Click OK to close the dialog box.



Precision Drawing and Advanced Dimensioning (continued)

Setting the Unit Preferences
Another important setting when
working with precision drawing is
the Unit preferences. Unit prefer-
ences let you choose the measure-
ment setting such as units, preci-
sion, and numerical format.
Settings on this tab affect the unit
displayed in the Strokes palette,
the Status bar, the measurements
in dimension objects, and the preci-
sion settings in the Type palette.

To set the Unit preferences, first
open the Preferences dialog box by
choosing File > Preferences
(Windows and Mac OS 9) or Canvas
> Preferences (OS X). When the
Preferences dialog box opens, click
on the Units tab.

Pen size units allow you to choose
inches, millimeters (mm), points, or
picas to specify how you want to
measure the pen size in the Pen tab
of the Strokes palette.

Number Format sets the precision
and numerical format for numbers
in the Status bar, Type palette,
Show Size display, and other
numerical displays. This setting
affects the measurement precision,
not the drawing precision.

Setting the Dimensioning tool
With Canvas, you can easily add formatted dimensions that conform to industry stan-
dards, such as ANSI, DIN, and JIS, to your documents by using the Dimensioning tool;
however, before we use the Dimensioning tool, you should adjust its setting.
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To change the Dimensioning tool settings, first make
sure that no object is selected. We do this by press-
ing the Esc key twice. Then, double-click on one of
the Dimensioning tools to open the Dimen-
sioning dialog box.

Within this dialog box, you have many cus-
tomizing choices.

Dimension type: Choose the type of dimen-
sion you want to configure. There are four
different dimension types from which to
choose:

Angular: use for angles.

Radial: use for radius, diameter, center.

Linear: use for horizontal, vertical, side, hor-
izontal baseline, vertical baseline, horizontal,
chain, vertical chain, and perpendicular.

Object Info: use for area or perimeter.
For this exercise, we‘ll use Linear dimension type.
In the Style area, use the checkboxes to modify the settings for arrow placement, text
position, and text framing. For our example, we want our arrows inside and the text
centered.

Next, open the Text display drop-down menu and choose the text alignment method.
We chose Horizontal.

Leading Character is used to configure the leaders for linear and radial dimension
object. Select None.

R,D symbols configure the radius and diameter symbols for radial dimension objects.
This drop-down menu only becomes active if Radial is selected as the Dimension type.

The Precision option tells Canvas to use fractions or the specified number of decimal
places in the dimension text.

Tolerance is used to specify the format of tolerance data in the dimension object.

Custom Units overrides the measurement units specified for the document rulers.
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The Dimension Standards dialog box is a feature that should be used by advanced users
only. To open this dialog box, click on the Standards button in the Dimensioning dialog
box.

The Dimension Standards
dialog box specifies the length
and position of various ele-
ments of dimension objects
based on industry standards.

Current Standards allows you
to choose from five standard
measurement systems, includ-
ing ANSI, DIN, BS-380, ISO,
and JIS.

Units lets you choose the mea-
surement units you want to use
for the settings in the Dimen-
sion Standards dialog box.

Extension allows you to set the
length of the witness lines‘ and
center lines’ extension.

Gap sets the size of the gap
between the witness lines and
the measurement points on
objects.

Length sets the length of the arrow lines and only applies when the arrows are outside
the witness lines.

Tolerance Scales adjusts the size of the tolerance text and the space between them in
percentages.
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Displaying Dimensions
Canvas can display the horizontal and vertical
dimensions of objects as you draw them as shown
in the example. To make the dimensions visible,
choose Layout > Display > Show Size.

Drawing Objects with Dimensions Displayed
Now that we‘ve finished preparing our document,
we are ready to start drawing. For the first exam-
ple, we’ll draw a basic circular object.

First, select the Oval tool and draw a 24-inch per-
fect circle by Shift-dragging the crosshair diago-
nally. To get an accurate size, refer to the object
dimensions that appear when dragging the
crosshair.

If you need help drawing the 24-inch circle, make
the circle as close to that size as possible. Then,
select it and choose Object > Object Specs. In
the Object Specs dialog box, click on the Data tab
and enter 24 in the Height and Width fields. Press
Apply.

Note: Object dimensions will also display
when using the Rectangle and Line tools.
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Adding Visible Dimensions
Using Canvas‘ Dimensioning tools, you could add measurements to your illustrations.
Canvas has several different Dimensioning tools at your disposal. The following chart
describes the various Canvas Dimensioning tools and a quick summary of their use.

Dimensioning Tools Prompts Procedures

Horizontal, Oblique, and
Vertical

Baseline and Chain
(Horizontal, Oblique, and
Vertical)

Click 1st Point,
Click 2nd Point

Click the starting point for the measure-
ment. Then, click the end point and
anchor the dimension object.

Click 1st Point,
Click Next Point

Click the starting point. Then, click the end
point for the first measurement. Anchor
the first part of the dimension object.
Then, click the next measurement point
and anchor the next part of the dimension
object. Continue until finished, then press
Enter (Mac) or Esc (Windows).

Angle

Click 1st Line,
Click 2nd Line

Click the start point for the angular mea-
surement. Then, click the end point.

Perpendicular

Click Line, Click
Point

Click the line to measure from. Then, click
a point anywhere to take a perpendicular
measurement from the line to the point.

Object Side

Click Object Side Click the side of the object to be mea-
sured.

Radius, Diameter, and
Center

Click Arc/Ellipse Click anywhere on the arc or ellipse and
then anchor the dimension object.

Area and Perimeter

Click Object Click anywhere on the object to be mea-
sured and then anchor the dimension
object.
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Next we will apply some of the different Dimensioning tools to objects created using the
techniques we learned in Step 2.

Horizontal, Oblique, and Vertical Dimensioning Tools

First, we‘ll use the 24-inch circle that we creat-
ed earlier and add a horizontal measurement
to it using the Horizontal Dimensioning tool.
The Horizontal, Oblique, and Vertical Dimen-
sioning tools function in the same manner so
the techniques used in this step could be
applied to any of those tools.

To add a horizontal measurement, first select
the Horizontal Dimensioning tool. Then, as
directed by the prompts, click on the circle.

Tip: It‘s a good idea to drag the
Dimensioning tool palette away from
the Toolbox so you have quick access
to all the Dimensioning tools.

Next, click on the end point of your object as
directed by the prompts.
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Upon clicking the end point, the measurement will
become visible; however, we still need to establish an
anchor point for it. Do this by dragging the cursor either
up or down until you are satisfied with the placement of
the measurement and then double-click to establish the
measurement‘s anchor.

The resulting measurement will look like the example.
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Next we are going to learn how to apply the Radius Dimensioning tool, a very common
measurement used in technical drawings. Also, note that the Radius, Diameter, and Cen-
ter dimensioning function in the same way.

Radius, Diameter and Center
Dimensioning Tools

First, using the 24-inch circle that we creat-
ed earlier, we will add a radial dimension. To
add the radial dimension, first select the
Radius Dimensioning tool. Then, as directed
by the prompts, click on the circle.

A radial measurement will appear originating
from the center of the circle with the measure-
ment displayed in the unit of measurement you
selected in step 1.

Next, drag the cursor out of the circle and click
to create an anchor point.

Note: Since dimension objects are not
attached to the objects they measure,
dimensions do not change when you resize

objects you have measured. However if you
group (Object > Group) a dimension and an
object, when you resize the object, the dimension
changes accordingly.

The finished radius dimension will appear like
our example.
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In this final section, will apply the Horizontal Baseline Dimensioning tool to an object.
The techniques used in this section also apply to chain dimensioning tools.

Baseline and Chain (Horizontal, Oblique, and Vertical)

Baseline and chain dimensioning tools allow the
user to make multiple measurements using the
same starting point or establish several succes-
sive measurements.

For this example, we will use the object on the
right to get a baseline measurement.

First, we start by selecting the Horizontal
Baseline Dimensioning tool. Then, click on the
starting point of your baseline measurement
as directed by the on-screen prompts.

Next, click on the end point for your first
measurement.
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Now drag the measurement away
from the object so it is easy to read.
Click the cursor once to create an
anchor point.

Your measurement will now appear
dark and solid.

Next, click on the next point you
want to measure as instructed by
the prompt.

Again drag the measurement away
from the object and click the cursor
to establish the anchor point.



Precision Drawing and Advanced Dimensioning (continued)

Your resulting horizontal baseline measurement
should look similar to the example on the right.

Using the steps learned in this exercise, anyone
could easily put together technical drawings with
precise measurements. With Canvas, you avoid
the trouble, as well as the expense, of learning
how to operate a CAD program.
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