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Product Options with eCart

Online stores sell a wide variety of products, and many of those products have options within themselve
example, you may be selling shoes, and want the customer to be able to choose the size shoe that they rt
slightly more complex example would be if you were selling T-Shirts, and needed to charge extra for thc
purchase X-Large due to the additional fabric.

This tutorial shows you how you can incorporate product options with eCart's shopping cart functionalit
including the ability to increment the price for certain options.

‘ NOTE: We have provided our Free eCommerce MySQL database to alleviate the need for
creating your own custom database tables. It is recommended you use this database to avoid
having to make modifications to the recordset provided to you in this tutorial.

What you need to start:

Dreamweaver CS3 or CS4

Dreamweaver site with eCart checkout functionality already created.

eCart 5
WebAssist Free eCommerce MySQL database (Optional)

E NOTE: This tutorial refers to the Free eCommerce MySQL database that is provided by
WebAssist. This database contains all the necessary tables and columns to complete this tutorial.
If you are not using this database, you will need to review the table and column references to
make sure they match up with your database structure.

Define your product options



Before you proceed with adding the product option functionality to eCart, you will need to populate your product catalog, and add the v
and option groups to your database.

The Free eCommerce MySQL database contains the necessary database tables for handling these product options and it is recommende
database to add product options to your online store. Using your preferred database management tool, you should populate the necessar
products and their options. Then continue with this tutorial to add this functionality to your shopping cart.

Refer to the Database Relationship Overview to learn more about how the tables are configured for product options.

In this tutorial we will be creating two types of product options:

1. Color options without a price increment.
2. Size options with a price increment for certain sizes.

1. Update your eCart Object

The first step you need to take is to update your eCart Object with the necessary columns for handling your product options.

Add New Columns

1. From the eCart Object panel, select your cart and click Edit.
2. Choose the Columns tab of your eCart object.

Create new or edit existing columns

Add a new column called color.

From the menu list, choose text for the column.
Select the unique checkbox.

Add a new column called size.

From the menu list, choose text for the column.
Select the unique checkbox.

Add a new column called sizePricelnc.

From the menu list, choose currency for the column.
Select the unique checkbox.
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Adding new Calculations

1. Choose the Calculations tab.

?‘M Object ' Iﬂ

Create new or edit existing calculations
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Add a new calculation called truePrice.

3. For the truePrice calculation, enter the following:

[Price] + [sizePricelnc]

With this new calculation, we will need to update the TotalPrice calculation.
Modify the TotalPrice calculation to look like this:

([Price] + [sizePricelnc]) * [Quantity]

SRR

Mame | Formula [Type |

TotalWeight [Weight] * [Quantity] Weight

TotalPrice ([Price] + [sizePriceInc]) * [Quantity] Currency

FullDetails [Quantity] . "', [Mame] . ' (. [ID] .7 Text

truePrice [Price] + [colorPriceInc] + [sizePricelnc] Currency
Mame: Output Type:
| TotalPrice | | Currency - |
Calculation formula; @ Add to formula

([Price] + [sizePriceInc]) * [Quantity]

6. Click ok to save your changes and close the eCart Object window.

2. Create your Shopping Cart

Now that you have made changes to your eCart Object, you will need to update the shopping cart page to contain the new columns. This
remove the Shopping Cart instance from your cart page, and insert a new one using the eCart Display Manager.

1. Open your shopping cart page.

If you don't already have one, create a new PHP page in your site called cart.php.
Place your cursor where you wish your new shopping cart display to be inserted.
From the Insert menu, choose WebAssist > eCart > Display Manager.

4. Recreate your eCart Shopping cart.

If you have never created an eCart Shopping Cart Display, see the Getting Started Guide for more inforn

3. Adding Product Options
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Now that you have updated your eCart Object and recreated your Shopping Cart Display, you can update your Add to cart behaviors
to handle the product options.

1. Open your product detail page.

This page is typically created by DataAssist that displays the details for a specific item and the Add to
Cart button for that item.

Open the Server Behaviors panel from Window > Server Behaviors.

3. From the Server Behaviors panel, choose Add > Recordset.
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SERVER BEHAVIORS
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w NOTE: When the Recordset dialog box displays, it may open in Simple Mode. For these
instructions, we will need to change this to Advanced Mode. If present, choose the
Advanced... button from the buttons on the right.

&

In the Name field, enter rsColor.

5. Highlight the following code, and press Ctrl (Cmd) + C to copy this content.

SELECT productoptions.OptionPriceincrement, productoptions.ProductOptionID, options.OptionName,
options.OptionGrouplD, optiongroups.OptionGroupName

FROM options

INNER JOIN productoptions ON options.OptionID = productoptions.ProductOptionID

INNER JOIN optiongroups ON options.OptionGrouplD = optiongroups.OptionGrouplD

WHERE optiongroups.OptionGroupName = 'color' AND productoptions.ProductID = paramltem
Place your cursor in the SQL box of the Recordset dialog and press Ctrl (Cmd) + V to paste this content.
Under the Variables section, click Add.

In the Name field of the Variables dialog, enter paramitem.

From the menu list choose Integer.

In the Value field, enter -1.

Copy and paste the following parameter in the

$row_WADAproducts['ProductID’]
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Mame: rsColor

Connection: |wadb "] Define...

S0L: | SELECT productoptions, OptionPriceincrement, productoptions, ProductOptionID, .«
options. OptionMame, upﬁuns.DpﬁmGrnupmr
FROM options INMER. JOIN productoptions ON options, OptionID =
productoptions. ProductOptionID
WHERE options, OptionGroupIlD = 1 AND productoptions.ProductlD = paramItern -

Variables: |£J EJ

Mame: paramltem

Type: Integer

Default value: -1

Run-time Value: Srow_rsProducts[Pr...

12. Click ok.
13. From the Server Behaviors panel, choose Add > Recordset to create another recordset.
When the New Recordset dialog displays, make sure you are in Advanced Mode.
14. In the Name field, enter rsSize.
15. Highlight the following code, and press Ctrl (Cmd) + C to copy this content.
SELECT productoptions.OptionPriceincrement, productoptions.ProductOptionlD, options.OptionName,
options.OptionGrouplD, optiongroups.OptionGroupName
FROM options
INNER JOIN productoptions ON options.OptionID = productoptions.ProductOptionID
INNER JOIN optiongroups ON options.OptionGrouplD = optiongroups.OptionGrouplD
WHERE optiongroups.OptionGroupName = 'size" AND productoptions.ProductID = paramltem
16. Place your cursor in the SQL box of the Recordset dialog and press Ctrl (Cmd) + V to paste this content.
17. Under the Variables section, click Add.
18. In the Name field of the Variables dialog, enter paramitem.
19. From the menu list choose Integer.
20. In the \alue field, enter -1.
21. Copy and paste the following parameter in the
$row_WADAproducts['ProductID’]



Mame:
Connection: [wadh "] Define...

S0L: SELECT productoptions, OptionPriceincrement, productoptions, ProductOptionID, .«
options. OptionMame, options. OptionGroupID
FROM options INMER. JOIN productoptions ON options, OptionID =
productoptions. ProductOptionID
WHERE options, OptionGroupIlD = 2 AND productoptions.ProductlD = paramItemn .

HEE

Variables: |£J EJ
3 Mame: paramltem
Type: Integer
Default value: -1
Run-time Value: Srow_rsProducts[Pr...
22. Click oK.

4. Create Add to Cart button

The next step is to create your Add to Cart buttons. If you already have these buttons added to this page, you can reenter the interface
to modify them. Otherwise, you can create new ones.

1. Place your cursor where you wish to insert your Add to Cart button.
If you already have an Add to Cart button on this page, you can launch the Add to Cart button interface
by double-clicking the eCart Add from Recordset option in the Server Behaviors panel.

2. From the Insert menu, choose WebAssist > eCart > Add to Cart.

3. From the General tab, choose Look up item ID from recordset.

4. Choose the DataAssist recordset, WADAProducts.
This recordset was created by DataAssist and displays all the products in the products database table. If
you are not using a DataAssist created page, you will want to create this recordset, and then reenter the
Add to Cart interface.

eCart Add To Cart Button E

Cart: |eCartl

Properties
() Add static item to cart

i@ Look up item ID from recordset

Recordset: | WADAProducts - |
ID Column: | ProductID - |

5. Choose the Bindings tab.



6. Select the Color column.
7. Select the Updatable checkbox.
8. From the menu list, choose Select List.

Price <?php echo Srow_WADAProducts... none
color <?php echo $row_rsColorLookUp[... select U
colorPricelnc «<?php echo Srow_rsColorLookUp[... none
size «?php echo Srow_rsSizelookUp[... none i

Default value:  Srow_rsColorLookUp[OptionMameT; 7= @

Updatable: as: [selectl.ist "]

9. Click OK to create this add to cart button.
We will be modifying this add to cart button to handle more information later.

5. Size Lookup Recordset

The next step is to create the recordset that handles the size price increment.

. From the Server Behaviors panel, choose Add > Recordset.
. Make sure you are in Advanced Mode.
. In the Name field, enter rsSizeLookup.
. Copy and paste the following SQL query into the SQL text field.
SELECT productoptions.OptionPriceincrement, productoptions.ProductOptionID, options.OptionName,
options.OptionGrouplD, optiongroups.OptionGroupName
FROM options
INNER JOIN productoptions
ON options.OptionID = productoptions.ProductOptionID
INNER JOIN optiongroups
ON options.OptionGrouplD = optiongroups.OptionGrouplD
WHERE optiongroups.OptionGroupName = 'size* AND productoptions.ProductOptionID =
paramOption AND productoptions.ProductID = paramltem
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10.
11.
12.
13.
14.

Mame: rsSizelookUp

SELECT productoptions. OptionPriceincrement, productoptions. ProductOptionID
pptions. OptionMame, oplions. OptionGroupID
F.OM options TNMER. JOIN productoptions ON options, OptionID =
oductoptions.ProductOptionID
WHERE options. OptionGroupID = 2 AMD

sqQL: |

« g

ctoptions, ProductOptionID =

Under the Variables section, click Add.

In the Name field of the Variables dialog, enter paramOption.

From the menu list choose Integer.

In the Value field, enter -1.

Copy and paste the following parameter in the Runtime Value field.
$ POST['eCartl 1 _size Add’]

naramO ption |

Type: [Irltegﬂ' v]
Default value: 4

Runtime value: § POST[eCart1_1_size Add]

Under the Variables section, click Add.

In the Name field of the Variables dialog, enter paramitem.
From the menu list choose Integer.

In the Value field, enter -1.

Copy and paste the following parameter in the

$ POST['eCartl_1_ID_Add]




Mame: paramltem

| e ]
Type: |Integer -

Default value: _4

Runtime value: § POST[eCart1_1_ID_Add]

w NOTE: In case your select list name differs, make sure that the name entered in the
parameter above matches the name you copied earlier.

6. Populate the Select Lists

The Color select list was automatically created for you when you created your eCart Add to Cart button. However, we are going to
manually create the Size select list since this list will include a price increment for certain options.

Size List
1. Place your cursor where you wish the size select list to display.

2. From the Insert menu, choose Form > List/Menu.
3. In the name field, enter eCart1_1_size_Add.

| PROPERTIES

Height | List Values... Class

LCart1_1_ size () List Selections || Allow multiple ¥ Dynamic...

L NOTE: This name is already being used in the recordset you created above. So, in order
to ensure this works, you will need to enter the name exactly as it is displayed.

s

Select the Size Select List you just created.
5. From the Properties Inspector, choose the Dynamic button.

MNone -

Hetaht |

E_SiIE () List Selections || Allow multiple

List Values,.., Class

Ly
Bind to Dynamic Source

Triftially selected| Select A Size

S

Click Add for static options.
7. Press tab to leave the Value field blank.



8. In the Label field, enter Select A Size.

9. From the Options from recordset field, choose rsSize.
10. From the \alue field, choose ProductOptionID.
11. From the Labels field, choose OptionName.

Menu: |"eCartl_1_size_Add®in form "eCartl - |

Static options: lE] |EJ E] lEJ

Value Label
Select A Size
Ciptions from recordset: [rsEzE v]
Values: |ProductOptionID -|
Labels: | OptionName -

Select value equal to:

12. Click ok.

Color List

Select the Color select list that was created when you added the eCart Add to Cart button.
From the Properties Inspector, choose the Dynamic button.

Click Add for static options.

Press tab to leave the Value field blank.

In the Label field, enter Select A Color.

From the Options from recordset field, choose rsColor.

From the \alue field, choose ProductOptionID.

From the Labels field, choose OptionName.
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Menu:

Static oplions:

Options from recordset;
Values;
Labels:

Select value equal to:

9. Click ok.

"eCartl 1 color_AddZ®in form "eCal - |

&5 a5

Value Label
[rsﬂdnr - ]
| ProductoptioniD -
| Optionhame v

7. Update the Add to Cart

Now that we have created and populated the lists for this product's options, we need to update the Add to Cart button.

1. From the Server Behaviors panel, double-click the eCart Add From Recordset behavior.
This will launch the Add to Cart interface for modifying the behavior.

Select the size column

ook own

Choose OptionName.

Select the Bindings tab.

Choose the value lightning bolt.
Expand the rsLookup Recordset.

H

Field: B Recordset (rsProducts) -
= @ Recordset {rsSizelooklp)

ok
i 47 OptionPriceincrement

e 27 ProductOptionID
*

s OptionGrouplD
@ Recordset {rsColorLookUp)

— -

OptionMame

m

7. Click ok.
8. Select the sizePricelnc.

9. Choose the value lightning bolt.



10. Expand the rsLookup Recordset.
11. Select OptionPricelncrement.

Dynamic Data

Field: B Recordset (rsProducts)
El 5E Recordset (rsSizelookUp)

Lo |
OptionPriceincrement :a”:EI

»

4§ ProductOptionID
-4 OptionName
“es? OptionGrouplD

@ Recordset {rsColorLookUp)
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12. Click ok.

What to do next...

Now that you have completed creating your Download Center, you may want to spend some time customizing the appearance of the
page, and adding additional Recordset bindings to display information from the orders or products tables. When you are finished
with your site, you will want to upload everything to your live server and import your database to your live MySQL database so that
your online store is on the web.
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