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PREFACE
The Agile documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology Network (OTN) Web 
site contains the latest versions of the Oracle|Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle|Agile Documentation folder available on 
your network from which you can access the Oracle|Agile documentation (PDF) files.

To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. This program can be 
downloaded from the www.adobe.com.

The Oracle Technology Network (OTN) Web site can be accessed through Help > Manuals in both the Agile Web 
Client and the Agile Java Client. If applicable, earlier versions of Oracle|Agile PLM documentation can be found on 
the www.agile.com/support.

If you need additional assistance or information, please contact support@agile.com or phone (408) 284-3900 for 
assistance.

Before calling Agile Support about a problem with an Oracle|Agile PLM manual, please have ready the full part 
number, which is located on the title page.

Readme

Any last-minute information about Oracle|Agile PLM can be found in the Readme file on the Oracle Technology 
Network (OTN) Web site.

Agile Training Aids

Go to the Agile Training Web page for more information on Agile Training offerings.
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http://www.oracle.com/technology/documentation/index.html
http://www.oracle.com/technology/documentation/index.html
http://www.adobe.com
http://www.oracle.com/technology/documentation/index.html
http://www.agile.com/support
http://www.oracle.com/technology/documentation/index.html
http://www.oracle.com/technology/documentation/index.html
http://training.agile.com


Agile PLM 9.2.1
x Product Portfolio Management User Guide



CHAPTER 1
Introduction

This chapter provides an overview of Agile Program Portfolio Management (PPM). It contains the following 
sections:
❑ Agile Program Management
❑ Program Management Objects
❑ Tracking Project Status

Agile Product Portfolio Management (PPM) gives you powerful capabilities to define, analyze, and manage all 
aspects of a project or program. 

Executives use the PPM Dashboard’s Executive and Financial tabs to view portfolio data for all programs being 
monitored, including risks to program health caused by schedule slips, lack of resources, and program cost.

Program Managers use PPM to create and manage program tasks, resources, documents, and schedules; make 
program assignments; conduct program discussions; and track program health and budget.

Program participants use the PPM Dashboard’s My Activities tab to report on the completion of program tasks, and 
their Agile Inbox to update program documents, manage any resource pools they own, manage program activities 
they own, and participate in program discussions.

Powerful filtering and summarizing tools let you find trouble spots quickly and drill down to study the details. The 
program objects of PPM provide detailed control over all aspects of program management, from high level overview 
to individual employee activities. 

Agile PPM objects and functionality are accessed using the Agile Web Client. 

Agile Program Management
The program management objects and features in Agile enable Program Managers to: 

❑ Define a program in terms of its schedules, tasks, resources, and deliverables

❑ Plan, execute, and manage multiple related program/phase/gate processes

❑ Associate product deliverables with program objects

❑ Establish templates that can be used to generate other programs

❑ View resource workloads by user and resource pool 

❑ Characterize programs according to organizational, product and program types

❑ View portfolio-level dashboards and reports
1-1
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Program Managers schedule and execute programs in Agile PPM using program objects. Each program object 
contains not only schedule information, but also the attachments, discussions and actions items, resources and roles, 
and history of all activity related to the program. 

Agile PPM provides the means to “roll up” data from child objects to higher levels by rules and relationships, to 
provide management with an executive-level view of program progress.

You can track program progress against schedules, cost, resources and quality by toggling tracking for each child 
object in your program (see “Tracking Project Status” on page 1-5). You can view project progress via the tables in 
the Agile Dashboard (see Chapter 2), or create a Gantt Chart that shows project progress visually (see Chapter 5). 

Once an activity (program) has been created, you can add the following elements to it:

❑ Programs

❑ Phases

❑ Tasks

❑ Gates

We introduce these objects in “Program Management Objects” below, and describe their use in detail in Chapter 4.

Program Management Objects 
The program management process involves management of scheduling, tasks, status, discussions, documents, 
phases/gates, and resources.

At a minimum, a typical Agile PPM program consists of: 

❑ A root-level program

❑ Multiple tasks (and other child objects) 

❑ A series of phases or other programs

Table 1-1 describes the objects that can comprise an Agile PPM program. 

Figure 1-1 shows how Agile PPM objects are employed.

Table 1-1: PPM Object Types 

Icon Object Description

Program A program is a set of related activities and gates (milestones) that is created to monitor 
and manage progress on a specific project. 

A program is the top-level object, but a program can also be a child of another 
program.

Phase A phase, sometimes called a stage, is a segment of a program. 

Phases are often used to define the activities required to create a set of deliverables. 
When phases end, program managers may hold a phase exit or gate review to examine 
the completion status of each phase element. 

Phases usually derive their dates and status information from the program elements 
that report to them.

Task A task is a segment of work that one or more resources can complete over a period of 
time. Progress or status reported in a task is rolled up to higher levels of the program.

Tasks may be embedded in programs, phases, or other tasks.
1-2 Product Portfolio Management User Guide
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Gate A gate (or milestone) is a specific point in time that denotes the completion of a set of 
related activities, such as a phase. 

Gate status is frequently controlled by deliverables. A gate’s status is closed until all its 
deliverables are complete, at which time it opens so work can go forward (“through the 
gate”). The change in the gate’s workflow status can be automatically triggered by the 
status of deliverables, so that when all deliverables reach a certain status, the gate goes 
into review or it opens. 

Deliverable An Agile PLM object whose state change can trigger a state change in the program 
element that contains it. When the deliverable changes to a predefined target workflow 
status, the event triggers a change of status in the activity to a predetermined new 
status.

Deliverables are often used to control the status of gates.

Discussion Informal conversations relating to a specific program activity, found on the program 
object’s Discussions tab.

Action Items Unplanned tasks, with owners and due dates, found on the program object’s 
Discussions tab. Action items can be attached to discussions or to the program object.

Table 1-1: PPM Object Types  (continued)

Icon Object Description
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Figure 1-1: PPM Objects in a Typical Program

Note Programs, phases, tasks and gates are fully customizable. For further information, see your site’s Agile 
administrator.

Deliverables

A deliverable is an Agile PLM object that can be linked to a Program, Phase, or Task. Product deliverables, or items, 
are generally placed under Change Control and managed in the Agile database.

Dependencies

Activities (Programs, Phases, Tasks) and Gates can be linked to each other as dependencies. Agile supports Finish-
to-Start dependencies for the sole purpose of scheduling. 

❑ If a dependency is established between two tasks, the start date of the successor is moved out 1 day past the end 
date of the predecessor. (See also “Time Buffer” on page 1-5, below.)

❑ If the predecessor's start date is moved forward in time (increased) then the successor task moves out as well. The 
duration of the successor task is held constant. 

Phase III

Phase II

Phase I

Task 3

Task 2

Task 1

DELIVERABLE

Program
Begins

Gate

DELIVERABLE

DELIVERABLE

Gate

Task 1 Task 2 Task 3

Discussion
Action Items

Program Completed

DELIVERABLE
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❑ If a predecessor’s start date is moved in (rescheduled earlier), the successor activities are also moved earlier in 
time (rescheduled earlier).

❑ If the end date of the predecessor is moved in (duration is reduced), the start date of the successor task is also 
moved in (rescheduled earlier).

Note A dependency relationship has no bearing on the workflow state of an Activity or Gate. For example, Gates 
with predecessors can still be opened even if the predecessor Activities are not complete or the prior Gates 
are not opened.

Time Buffer

A buffer can be inserted to maintain a gap between a predecessor and its successors. Either positive values or negative 
values are accepted for the buffer. For more information about adding or editing a time buffer, see “Dependencies 
Tab” on page 4-11.

Discussions and Action Items

Discussions and action items are events or activities that occur spontaneously during the course of a program. They 
are completely unplanned.

Tracking Project Status
Agile PPM enables Executives and Program Managers to track the status of each activity, and overall “health” of the 
project (on track, needs attention, and off track).

How Status Roll-Up works

A number of attributes are passed upward from child objects to parents, in a process called rolling up. 

Attributes that are rolled up include activity workflow status and health statuses.

The rolling up of values starts with leaf nodes (child objects that have no children) that are not either Complete or 
Canceled, and moves upward to parent objects. If any leaf node object is determined to be Off Track, the parent 
object is considered to be Off Track. 

Workflow statuses roll up to the parent object from the children, except in the case of setting an entire project to 
Cancelled. (For more information, see “Cancelling Programs and Their Children” on page 4-28.

Parent object fields that reflect rolled-up status of child objects, such as Days Effort or Scheduled Dates, cannot be 
edited because it is automatically rolled up from lower levels in the hierarchy. Status can only be edited at the lowest 
levels (leaf nodes).

Health Status

Health Status values are rolled up for all objects that are configured to report such status (if Rollup Health Status is set 
to Yes in that object’s General Info tab). The following status elements are rolled upward:

❑ Overall

❑ Schedule

❑ Cost

❑ Resource

❑ Quality

If any one child of a program object is Off Track, the parent program is set to Off Track. If the Quality Status of a 
child is Below Quality, the parent is set to Below Quality. 
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Note If you set Rollup Health Status to No in an object’s General Info tab, the object’s health status will not roll up to 
the parent item.

Health attribute values are maintained in administrator settings, and each value has an associated activation period 
or value. 

The activity Health Status indicators appear in the upper right of the activity window. Colors indicating stages of the 
health are:

❑ On Track (green) 

❑ Needs Attention (yellow) 

❑ Off Track (red) 

Default Health Statuses

The following table shows default schedule, cost, resource, and quality health statuses.

Table 1-2: Default health statuses

The severity level that triggers a change in health status can be customized by the Agile administrator. Schedule 
Status can be based on either a percentage overdue or a specific number of days overdue. For more information 
about health status settings, see Agile PLM Administrator Guide.

Reason fields

When you update an object’s status in its General Info tab, use the Reason field to specify a reason for the status. For 
example, if you set the Cost Status field to Off Budget, you might specify “high shipping costs” as the reason. 

Workflow Status

Agile Web Client uses a workflow stamp in the upper right of the General Info tab to indicate the workflow status of 
an activity (see Figure 1-2). The Agile administrator defines the name of each status in each workflow. 

Figure 1-2: Workflow status stamp (left) and health status indicators 

The default program workflow statuses are:

❑ Not Started

Status Values What triggers change?

Schedule On Track (green), Needs Attention 
(yellow), Off Track (red)

Health status changes from Not Started or On Track to 
Needs Attention if task is overdue between 1-5 days; Off 
Track if task is overdue more than 5 days

Cost On Budget (green), Off Budget 
(yellow), Over Budget (red)

The cost status is calculated based on the %deviation 
(Percentage property) from the original cost.

Resource Staffed (green), Understaffed 
(yellow), Not Staffed (red)

Quality Meets (green), Below (yellow), Poor 
(red)

Overall Corresponds to the most severe 
(red) setting of the four health 
statuses for any project.
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❑ In Process

❑ Complete

❑ Canceled

Your company may have its own customized workflows and status stamps, as displayed in the Workflow tab. For 
further information see page 4-18.

If a user has the appropriate privileges, they can use the Change Status button to change an activity’s status, promoting 
it to the next lifecycle state.

Important Since workflow status of parent objects is rolled up from lower levels, you can only change status on 
individual leaf node objects (objects with no children). You cannot promote an activity whose Template 
field setting is Template or Proposed. On summary objects (non-leaf node objects), workflow settings for 
entry required fields, exit required fields, and approvers and observers are ignored.

Program Costing

Program costing information is rolled up through the project structure the same way status and health are rolled up. 
By default, cost information for each field is rolled up automatically, such that a summary or parent task is a 
summation of the values of its child objects. However, there are flags (not visible by default) that can be enabled to 
let a particular summary task’s values to be calculated automatically (rolled up) or edited manually.

Program cost calculations generally occur as shown in Figure 1-3.

Figure 1-3: Rolling up program costs

Program

Phase 1

Phase 3

Phase 2

Task 1

Task 2

Total Cost = $25 + $30 + $15 = $70

Cost = $25

Cost = $20 + $10 = $30

Cost = $20

Cost = $10

Cost = $15
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CHAPTER 2
Viewing Programs

This chapter discusses the PPM Dashboard, which enables Executive and Management users to view cross-
program information on all their programs and resources, and team members to view information about 
their own activities and tasks. It contains the following sections: 
❑ The Configuration Panel
❑ The Executive Tab
❑ The Programs Tab
❑ The Resources tab
❑ Resource Pool Utilization by Program Window
❑ The My Activities tab
❑ Optional Dashboard Tabs
❑ Dashboard Management Administration Tasks
❑ PPM Reports

The PPM Dashboard enables you to view and manage information across all your programs or activities. Depending 
on your roles and privileges, you can use the Dashboard to get an executive-level view of key information for all your 
programs, and user-level information about your own activities and tasks. All users can use the Dashboard to access 
reports, viewing and printing consolidated information (see “PPM Reports” on page 2-9). 

You can make the Dashboard your default start page by going to Settings > User Profile and selecting the Preferences tab. 
Click Edit, and select the Dashboard tab you want as your Preferred Start Page. Most users open on My Activities, but 
an executive might prefer to open on the Executive tab. 

To start the Dashboard:

Select Home > Dashboard.

The Dashboard is comprised of:

❑ Tabs that enable you to select the view: Executive, Programs, Resources, Financial, My Activities, Optional Tab 1, and Optional 
Tab 2.

❑ Windows within each tab that present information relevant to that view. For example, in the My Activities tab the 
windows represent the current user’s possible program activities: My Assignments, My Documents, My Action Items, My 
Issues, Notification Requests. 

❑ The Configuration panel in the upper right, which enables you to filter data for all the Dashboard tabs and windows, 
to create a customized view.

The only information you can view in the Executive, Programs, and Financial tabs comes from root programs that you 
are privileged to read. 
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An Executive role can be established to provide read privilege to all programs. (For detailed information about roles 
and privileges, see Agile PLM Administrator Guide.) With an Executive role, you can view all root-level programs 
with matching values for the dashboard category fields that are labeled (by default) Region, Division, Program Type, 
Customer, Launch Year, Product Line, and Category 7 - 10 fields.

If you are not an Executive, and want to see information on other programs, ask your Program Manager can add 
you to the Team of that root program. 

Figure 2-1: The Dashboard

Manipulating the Dashboard Windows
The Dashboard windows are manipulated by three buttons in the upper right-hand corner, as described in Table 2-2.

In the windows that display a table, you can click column headings of most tables to change the sort order. 
Depending on your privileges, you can click on data in most tables to “drill down” to a view of the individual object. 

Figure 2-2: Buttons in Dashboard windows

Button Description

 Maximize/Restore Original Size Expands the window to full size or reduces it to the size it was previously.

 Remove Content From View Closes the window.

To reopen the window after closing it this way, select it again in the Add Content field at 
the bottom of the window, then click Add. 

-or-

Click the current tab to refresh your browser view.

 Configure On Optional dashboard tabs, launches the Configure Table wizard, which allows you to 
define a search for the window.

 Export Exports data in comma-separated value (.CSV) format for use in a spreadsheet (available 
in all tables).

Configuration Panel

Window buttons
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The Configuration Panel
The Configuration panel in the upper right lets you filter the data in the dashboard views to show just the information 
that’s most relevant to you. The notation on the Configuration panel shows which filters are currently in place.

For example, a functional manager who owns a number of resource pools might want to show certain pools for 
consideration, or only off-track activities for tasks assigned to people in his pools. An executive might set the 
dashboard to show all the programs, issues, gates, financial summaries, and resources that apply to her division and 
region, or view a subset she specifies. Once the dashboard settings are entered, the executive sees only those programs 
that are her responsibility. 

Note If a root program has a value set to “All,” then, by design, it will show up in all views no matter what value 
is selected in the configuration view for that field. “All” is interpreted as including the specific value.

Figure 2-3: The Configuration Panel.

The Executive Tab
The Executive tab provides portfolio data for the executive who needs to monitor programs and see information 
rollups by type of program. It provides a cross-section of information on programs that enables the executive to see 
the major risks in terms of schedule, resources, and costs of the programs.

Note The Executive tab contains data only if you have the Executive role, or have read access to root-level 
programs. 

Windows in the Executive tab include:

❑ Program management

❑ Resources

❑ Financial Window
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Program Management Window

The Program Management window provides a graph of all active programs the user is configured to view, showing 
their overall status (i.e., On Time, Needs Attention, Off Track). For each type of status displayed, the window shows 
the percentage of programs that have that status. 

To display the number of programs that comprise a segment, pass the mouse pointer over that segment of the chart.

To display the Programs tab with a particular segment of programs selected in all windows, click on that segment.

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed or Template, or programs that are archived or soft deleted.

Resources Window

The Resources window displays a table showing the names of available resource pools and associated data, filtered 
by the settings in the Configuration panel. 

Pool members who have no current assignments are not counted.

Resources who are not pool members are listed on a separate line labeled “No Pool.”

To view the Pool Utilization Summary report, click the Report button beside the pool name OR go to the Resources 
table and click Pool Utilization Report. 

To view the user profile of the pool owner, click their name. If you have the required privileges, you can edit 
information about the user and create a Resource Utilization report for them. 

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed or Template, or programs that are archived or soft deleted.

Financial Window

The Financial window displays a table showing cost rollups for the root programs you are configured to view.

The Programs Tab
The Programs tab displays information about all programs that you are involved in, including status, gate progress, 
and top priority issues.

Windows in the Programs tab include:

❑ Programs

❑ Gate Progress

❑ Top Priority Issues

Programs Window

The Programs window displays all programs to which you have access (subject to the filters in the Configuration panel). 
It includes the root program name, owner, status, start date and end date. 

To change the sort order, click a column heading. 

To open a program object, click its name. The icon next to the program name indicates the status of the program, 
such as On Track or Needs Attention. 
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Gate Progress Window

The Gate Progress window shows the gates for each active program, and their status; also, the number of 
deliverables/activities required and completed for each gate thus far. (The number required is derived from the 
number of deliverables listed on the Deliverable tab plus the number of dependencies to the gate.)

To open a program object, click its name.

Top Priority Issues Window

The Top Priority Issues window shows issues arranged in order of priority. If an Action Item icon  appears in 
the row, it means there is an associated Action Item. Click the icon to open the Action Item.

To view a program’s associated issues, click the program name to open its object, then open its Discussions tab. (For 
further information on the Discussions tab, see page 4-19.)

To sort issues by a different priority, or view all priorities, use the selection list.

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed or Template, or programs that are archived or soft deleted. 

The Resources tab
The Resources tab provides several views on resource utilization and issues for resource pools that you own or for 
pools that match your privileges.

To select the resource pools to be considered in this tab, use the category fields in the Configuration panel or use the 
Resource Pools field at the top of the page.

You can minimize, maximize or close tables and charts in the tab view. When a table is closed, the Add Content list 
appears. Use this list to re-open any table or chart you have closed.

Windows in the Resources tab include:

❑ Resources

❑ My Pool Members Top Priority Issues

❑ My Pool Members Off Track Activities

❑ Resource Summary

Resources Window

The Resources window shows each resource pool’s programs and status, noting items that are pending, assigned, or 
overdue. It also notes resources that are over allocated.

A pending activity or gate is one that has been delegated to a resource pool but it has not yet been assigned to a user 
in that pool. 

The number of overdue items is a count of all activities or gates that are past due, whether or not they are assigned 
to users. See also “Resource Pool Assignments Tab” on page 3-3.

To edit status for a resource pool (add or remove resources, or create a report), click its name. 

To create a Pool Utilization report, click the icon to the left of the pool name, or click the pool name and click Report. 

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed or Template, or programs that are archived or soft deleted.
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My Pool Members Top Priority Issues Window

This window shows the highest priority discussions for each Resource Pool, but you can select other priorities to 
display from the Priority list. An icon shows the program status, and an Action Items icon  appears at the right if 
there are Action Items. Click a program name to open it. Once the program object is open you can go its Discussions 
tab, and view associated issues. (For further information on the Discussions tab, see page 4-19.)

If there is a discussion thread, only the top level issue is displayed. Click the + symbol to expand the display. 

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed or Template, or programs that are archived or soft deleted.

My Pool Members Off Track Activities Window

This window displays Off Track items assigned to pool members of pools that you own, noting scheduled due date, 
actual date, and percent completed.

To view and update off-track resource pool activities, click the resource pool name.

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed, or programs that are archived or soft deleted.

Resource Pool Utilization by Program Window

This window shows a graph of the resource pool utilization by program, enabling a program manager to see where 
resources are allocated or over-allocated.

To view program name and percent utilization of resources, pass the mouse pointer over each chart segment. 

To view team data click the chart segment of interest. This opens the corresponding program object at the Team tab.

To view and change report settings, click the Show Report Options link at the top. You can specify the chart type, date 
range, programs to include, and time intervals used in the graph.

Note The data in this window does not include programs that are in the Completed or Canceled states, programs 
with a Template field setting of Proposed, or programs that are archived or soft deleted.

The Financial tab
The Financial tab shows charts of capital expense, labor cost, and fixed cost for each root program available. The 
Financial tab also shows the same table that is presented in the Financial window (see “Financial Window” on page 2-
4).

To select the programs to be considered in this tab, use the category and status fields in the Configuration panel.

You can minimize, maximize or close charts in the tab view. When a chart is closed, the Add Content list appears. Use 
this list to re-open any chart you have closed.

The My Activities tab
The My Activities tab displays activities that you own or are participating in. 

To select the activities to be considered in this tab, use the category and status fields in the Configuration panel.

You can minimize, maximize or close tables and charts in the tab view. When a table is closed, the Add Content list 
appears. Use this list to re-open any table or chart you have closed.

Windows in the My Activities tab include:

❑ My Assignments
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❑ My Documents

❑ My Action Items

❑ My Issues

❑ Notification Requests

My Assignments Window

The My Assignments window lists the programs, phases, tasks, deliverables and gates that you own. An icon indicates 
the status of each assignment. 

To change the sort order (view assignments alphabetically, sort by start or end date), click on the heading of the 
desired column. 

My Documents Window

The My Documents window lists all documents associated with your programs, with the document description, size, 
and other data. 

To open a file, click the file name. 

My Action Items Window

The My Action Items window displays all your action items, along with status and due date.

The Belongs To column and icon indicate whether the action item is associated with a discussion object or with a 
program object. Click the link in the Belongs To column to open the object.

Click the name of the action item in the Subject column to open the action item.

To see details of your issues, click the name of the program of interest, then select its Discussions tab.

My Issues Window

The My Issues window includes all discussions you have created for the selected set of programs (not just your top 
priority discussions). The data includes the program name, issue number, and issue title. 

To see details of your issues, click the name of the program of interest, then select its Discussions tab.

Notification Requests Window

The Notification Requests window displays your notifications, including the type and description, sender, and date 
received. 

To see details of your notification requests, click the name of the program of interest.

Note Agile PLM automatically sends notifications to users either when the user is required to take action or to 
notify the user that various actions have taken place. 

If an action triggers multiple notifications to the same user, the user will receive only one notification. 

For example, if the triggering action is the status promotion of a routable object, and Bob is an approver, 
and Bob is added to the Notify list when the object is promoted, Bob is now specified as a recipient of 
notifications as both an approver and as a person on the notify list.

However, Bob will receive only one notification related to this triggering action. 
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Optional Dashboard Tabs
If your Agile administrator has enabled them, you may have access to two optional dashboard tabs. Each optional 
tab includes four windows. Each window allows individual users to personalize the contents by defining an 
Advanced Search. When you display an optional dashboard tab, the search results are automatically displayed in the 
windows. 

This allows you to quickly view the PPM objects that you decide are most important to you.

Configuring an Optional Dashboard Tab Window

To configure an optional dashboard tab window:

1 If the dashboard is not already displayed, use the Home button drop-down menu and choose Dashboard.

2 Click the optional tab you want to use. 

By default, the optional dashboard tabs are named Optional Tab 1 and Optional Tab 2. Your Agile administrator may 
have defined a custom name for the optional tabs.

3 To display the Configure Table wizard:

• If the window has not been configured, a message to that effect appears in the window. Click the Configure 
button in the window or click the Configure icon  in the window title bar.

• If the window has already been configured, click the Configure icon  in the window title bar.

The Configure Table wizard appears.

4 Enter a name for the table in the Table Name field.

5 Define your search by one of the following methods.

Create a new search:

a Use the Search Criteria tab and Options tab to define an Agile Advanced Search. For more information about Agile 
advanced searches, see “Finding Agile Data with Searches” chapter in Getting Started with Agile PLM.

Use a saved search:

a To start with a saved search, check the Used Saved Search checkbox.

b Click  to open the Select Saved Search dialog. Select the search you want and click OK.

The the Search Criteria tab and Options tab are automatically completed with the saved search definition.

c If desired, you can modify the search by adding, deleting or editing the listed search criteria or by modifying 
the output fields on the Options tab. 

For more information about Agile advanced searches, see “Finding Agile Data with Searches” chapter in 
Getting Started with Agile PLM.

6 When you have finished defining your search, click OK.

Whenever you display the optional dashboard tab, Agile PLM runs the search you have defined for each window and 
displays the results in a table in the window.

Modifying or Removing a Table from an Optional Dashboard Tab

You can modify your optional dashboard table searches at any time. You can remove an optional dashboard table 
search when it is no longer needed.
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To modify an optional dashboard table search:

1 In the window you want to modify, click the Configure icon  in the window title bar.

2 Make the desired modifications to the search criteria or search options. 

For more information about Agile advanced searches, see “Finding Agile Data with Searches” chapter in Getting 
Started with Agile PLM.

3 When you are finished, click OK.

To remove an optional dashboard table search:

1 In the window in which you want to remove the table, click the Configure icon  in the window title bar.

2 In the Configure Table wizard, check the Remove Table checkbox.

3 Click OK.

Dashboard Management Administration Tasks
If your Agile administrator has given you Administrator privilege applied to Dashboard Management, you can use 
the Tools menu (Tools > Administration) to modify systemwide settings that determine which available tables to display 
on each tab and the order in which they are displayed.

Caution! Any Dashboard Management modifications you make affects every Agile PLM user. If you display a 
particular table, then every user can see that table in their dashboard. If you hide a particular table, then 
no one can see that table in their dashboard.

For full instructions, see Agile PLM Administrator Guide, “Set Table Display Order on a Dashboard Tab in Web 
Client.” 

Note In order to make Dashboard Management modifications, you must have the appropriate Administrator 
privilege. For more information, see Agile PLM Administrator Guide, “Dashboard Management.”

PPM Reports
Agile PPM includes a set of standard reports for use in analyzing program health. PPM reports are not part of the 
Dashboard itself; instead, select the PPM report you want to use in the navigation pane of the Agile PLM window.

About Agile Standard Reports

Reports allow you to display the values of your Agile programs and product records. By accessing this information 
and summarizing it in a meaningful way, reports provide insight into your business processes and can help guide 
better-informed decisions. Agile PLM provides a robust reporting platform that allows you to:

❑ Measure and monitor business performance using standard out-of-the-box reports. These standard reports 
capture the best practices in product lifecycle management business processes.

❑ Configure reports with Agile’s custom reporting to obtain the specific information you need.

❑ Use a single point of access to all relevant reports—even those developed outside of the Agile PLM application— 
through Agile’s external reporting capability.

For detailed information about using all types of Agile reports, see the “Working with Agile Reports” chapter in 
Getting Started, which includes information about:

❑ How your roles and privileges affect reports

❑ Report object tabs

❑ Creating and modifying report layouts

❑ Creating custom and external reports
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❑ Running, scheduling, saving, and deleting reports

❑ Report output window

Agile Standard Reports for PPM

This section discusses the Agile standard reports that are included as part of Agile Product Portfolio Management.

To access program reports:

1 Open the Navigation Pane, to the left of the Dashboard, and select Analytics and Reports > Program & Portfolio Reports

OR

In the main toolbar, select Tools> Reports to display the Reports navigation pane.

Note The analytics option is only available for licensed Analytics users.

2 Agile PPM standard reports are organized into subfolders under the Program and Portfolio Reports folder. Navigate 
to the report you want.

Reports that effect PPM include:

Table 2-1: Agile PPM standard reports

PPM Report Folder Report Description

End User Reports My Action Items All the open action items associated with issues and tasks that are as-
signed to you. Root Programs that are Complete or Cancelled are not 
listed.

My Activities and Utilization All your task assignments. Root programs and programs that are Com-
plete or Cancelled are not listed. 

My Discussions All open discussions owned by you with the priority selected when you 
execute the report.

My Documents All the documents for which you are the Creator or Checkout User.

User Time All the programs where the specified user has entered Actual Time.

Portfolio Reports Portfolio Cost Cost report of all the root programs to which you have access.

Portfolio Cross Program De-
pendency 

Report of all the activities that have external dependencies. Root Pro-
grams that are Complete or Cancelled are not listed in the portfolio. 

Portfolio Deliverable Gate Report of all the Gates and their dependent tasks and deliverables in 
the portfolio of root programs. Root Programs that are Complete or 
Cancelled are not listed. 

Portfolio Priority Discussions Report of all the open discussions in your portfolio of programs.

Portfolio Status Status report of all the root programs to which you have access.
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Program Reports Program Open Action Items Report of all the open action items associated with discussions and 
tasks of the selected root program. Root Programs that are Complete 
or Cancelled are not listed. 

Program Deliverable Gate Report of all the Gates and their dependent tasks and deliverables in 
the selected Root Programs. Root Programs that are Complete or Can-
celled are not listed. 

Program Documents Report of all the documents of the selected Root Program. Root Pro-
grams that are Complete or Cancelled are not listed. 

Program Off Track Activities Report of all the activities based on the selected health status within the 
selected root program. Root Programs that are Complete or Cancelled 
are not listed for selection. 

Program Schedule The schedule report of all the activities of the selected root program. 
Root Programs that are Complete or Cancelled are not listed for selec-
tion. 

Program Top Discussions Report of all open discussions with priority you select, within the root 
program you select. Root Programs that are Complete or Cancelled are 
not listed for selection. 

Program User Assignments Report of assignments of a selected user within a selected root pro-
gram.Root Programs that are Complete/ Cancelled are not listed. 

Baseline Comparison Report of comparison of the baselines for the selected program. Pro-
grams that are Complete or Cancelled are not listed for selection.

Program Actual vs. Budgeted 
Cost

Report of the Actual Cost and Budgeted Cost for the selected program. 
for the selected program. Programs that are Complete or Cancelled are 
not listed for selection.

Program Actual vs Budgeted 
Time

Report of the Actual Time and Budgeted Time for the selected pro-
gram. for the selected program. Programs that are Complete or Can-
celled are not listed for selection.

Resource Pool Reports Pool Member Report Report of all the resources of the selected resource pool.

Resource Pool Utilization Report of all your task assignments for all root programs and programs 
except those that are Complete or Cancelled. 

Resource Pool Consumption Report of the resource pool consumption during the specified time pe-
riod.

Table 2-1: Agile PPM standard reports  (continued)

PPM Report Folder Report Description
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CHAPTER 3
Participating in Programs

This chapter describes how program team members interact with PPM through Agile Inboxes. It includes 
the following sections:
❑ Notifications and Requests Inbox
❑ Workflow Routings Inbox
❑ Program Activities Inbox
❑ Action Items Inbox
❑ Resource Pools Inbox

As information passes through the Agile system, you receive news of status changes, requests and other notifications 
through email. The Agile Inbox contains notifications, actions items, and activities that require your review and 
action. In all the inboxes, you can click on a column heading to sort on that column, and click it again to reverse the 
sort order.

Notifications and Requests Inbox
Use the Type field to view only notifications or only requests, or both.

Note Using the Type field can help you respond to requests by grouping them all together. When you open a 
request, you will see fields that enable you to accept or decline.

The Accept button lets you accept requests sent to you from other users. A typical request will ask you to join a team 
or to assume ownership of a task or deliverable. Acceptance of a request updates the item with your response. An 
accepted request is removed from the Inbox.

To accept one or more requests:

Select one or more request rows and click the Accept button.

To decline a request:

1 Click the link in the Subject column. The Requests dialog appears.

2 Click the No radio button, enter the required explanation, and click Save.

Notifications do not require a response.

To delete notifications:

Select one or more notification rows and click Delete to remove them from you inbox.

Note If you select both request rows and notification rows, only the notifications rows are deleted. To remove a 
request from the Inbox you must either accept it or decline it.
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Workflow Routings Inbox
The Workflow Routings page displays a list of all objects (activities and gates) that are undergoing a change in status, and 
for which you are an approver or an observer.

For more details on workflow, see “Routing Objects with Workflows” in Getting Started with Agile PLM.

Program Activities Inbox
Items in the Program Activities list are:

❑ Activities that you own.

❑ Activities for which you are a resource, that is, for which you have a % allocation. 

The Program Activities list does not include activities and gates for which you are a team member only.

This content depends on your role in the programs and on your privileges.

Alongside the name of each activity is an icon representing the type of program element that it is associated with, 
and its status. Pause the mouse pointer over the icon to see the current workflow and health statuses.

Icons indicate deliverables, discussions, action items, and attachments. Click the icon to go to the corresponding tab 
of the program element.

The Edit button above your program activities list lets you edit the Status and % fields for the selected rows. When you 
click Edit, these fields become active so that you can make changes to them. If you are a resource for the activity, you 
can also modify the Actual Days Effort field. Use the Save or Cancel buttons when done.

Note A parent activity cannot be edited.

Action Items Inbox
The action Items inbox lists unplanned action items or tasks from all your programs. The default list shows all your 
action items. Change the time frame to show action items due within one week, two weeks, one month, two months, 
or six months. 

Use the Display Due In: drop-down list to select which action items you want to view. You can view action items due 
in the next week or up to six months. You can also choose to view all action items. The default list shows action items 
which are due in one week or are overdue. Completed and Cancelled action items are not included.

The Belongs To column and icon indicate whether the action item is associated with a discussion object or with a 
program object. Click the link in the Belongs To column to open the object.

Click the name of the action item in the Subject column to open the action item.

The Edit button above your action item list lets you edit the Status fields for the selected rows. When you click Edit, 
these field become active so that you can make changes to it. Use the Save or Cancel buttons when done.

Resource Pools Inbox
The Resource Pools inbox contains the Resource Pools for which you are the owner. This page contains the pool name, 
owner, and description of the pool. The Agile administrator, PPM program manager or resource pool administrator 
creates resource pools and assigns owners and users.

Clicking the pool name link opens the resource pool. (The ability to view or create Agile PPM objects and adding 
users as resources is determined by your privileges.)

A resource pool can be created by an Agile administrator by choosing Administration > User Groups in Agile Web Client. 
To create a resource pool, create a user group or edit an existing user group, and set the Resource Pool field to Yes.
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Resource Pool Assignments Tab

On the Assignments tab, you can view the assignments for the members of this group. You can also analyze resource 
utilization and capacity at an individual user level, at a resource pool level, and at a program level by using the 
available reports.

The Assignments field is a drop-down list where you can select the assignments (Pending, Assigned, Show All) to 
include in the display.

Click the icon in the Resource column to view the Resource Pool Utilization Report. This report provides a user’s 
utilization based on % allocation for the selected user.

To create the other reports, click the Assignment List Report button or the User Group Utilization Report button.
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CHAPTER 4
Creating and Managing Programs

This chapter discusses how Program Managers create and manage programs. It includes the following main 
sections:
❑ About Programs
❑ Creating Program-related Objects
❑ Working with Proposed Programs
❑ Configuring Program-related Objects
❑ Creating and Using Gates
❑ Concurrent Editing of Program Objects
❑ Creating a Hospitable Project Environment: The Actions Menu

About Programs
Agile Product Portfolio Management provides many tools a Program Manager can use to schedule and track a 
project program, including the means to send automatic reminders to team members when they have tasks due, 
maintain a record of project-related discussions, or let team members know when aspects of the projects have 
changed.

You can start “from scratch” by creating a new program structure in PPM, or import an existing Microsoft Project 
file. For detailed examples showing this process in action, see Appendix B.

You can also create a new program from a template by selecting Create > Programs > From Template in the main toolbar.

Setting Up a Program Structure

When creating a new program, the easiest way to build the structure is to start at the top and work down. At a 
minimum, you need:

❑ Parent program object

❑ Child activity objects

❑ Designated program “gates”

❑ Pool of resources (project team members)

You can store program specifications and requirements documents with the parent program object, to make them 
easy for program members to locate. 

The general procedure is to create the root-level program first and then create the child objects. 
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Table 4-1 shows the general workflow for creating a program structure.

Once you have the structure in place, you may want to save it as a template, to make it easier to create future 
programs; see “Using Save As to Create a Template” on page 4-26.

Note You can also create program objects working from the project Gantt Chart. For further information, see 
Chapter 5.

Creating Program-related Objects
As noted in Table 1-1 on page  1-2, you can create a number of program-related objects in Agile PPM. A program-
related object can be the parent program itself, a gate (phase), or a task.

The PLM user interface gives you four different ways to create a program-related object:

❑ Use the Create menu to define the program object “from scratch,” or from an existing template. 

❑ Open an existing program object and choose Save As.

❑ Open the project Gantt Chart and click Add Activity, as described in Chapter 5.

❑ Import an existing program from Microsoft Project, as described in Chapter 6.

Using the Create Menu

To create a new program object or template: 

1 Launch Agile Web Client. 

2 Go to the main toolbar and click the Create menu.

3 Select Programs > New. The Create Project_Activities Wizard appears. 

Or 

Select Programs > From Template, and specify the template you want to use to create the program; see “Creating a 
Program from a Template” on page 4-3 below. (See also “Using the Save As command” on page 4-3).

4 Click the Activities Type drop-down list, and select the desired activity type.

Table 4-1: Creating a Program Structure in Agile PPM

Starting “from scratch” in Agile PPM Importing an Existing Program from Microsoft Project

1.Create the root-level program object using one of 
the methods described below in “Creating Program-
related Objects.” Be sure to specify program as the 
object type.

1. Publish the program’s Microsoft Project file into Agile 
PPM, as described in this Guide’s Chapter 6. 

2. Create the first child object. Go to the Schedule tab of 
the new program object, and click Add. Create the first 
child object. All objects created from the Schedule tab 
are children of the current object. 

3. Repeat the process to create additional children, as 
needed.

4. Open each child object and create its children, as 
needed.

5. Set gates to delineate the completion of key program 
goals.

6. Map existing dependencies between program 
objects.

2. Re-set any dependencies that were not originally 
entered as “Finish to Start” dates. 
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5 Fill in the required fields, such as Name, Schedule Start Date, and Schedule End Date. Click the calendar icon on date 
fields for a drop-down calendar to assist you in finding the appropriate day. 

• To continue using the Create wizard to enter information on each tab of the program, check the Continue 
Creation in  Wizard checkbox, and click the Continue button. Follow the onscreen instructions to complete the 
wizard as described in step 6 below

• To create and display the program immediately, uncheck the Continue Creation in  Wizard checkbox and click 
Finish. The new item appears with the General Info tab showing. Fill in information on the program tabs, as 
desired.

6 On the Enter Cover Page Information page, enter the information about the program. 

• Rollup Health Status -- If you want this information rolled up to parent objects, select Yes (see “How Status 
Roll-Up works” on page 1-5).

• Template -- If you are creating a new template (not saving an existing template with a new name), select 
Template in this field.

Note You cannot change the status of objects whose Template field is Proposed or Template. (For more 
information, see also “Starting the Program” on page B-4.)

7 If you want to add an attachment to the object, click Next. Otherwise, click Finish. The General Info tab of the new 
object appears.

If you use a template, you become the owner of all activities in the plan. You then need to delegate ownership to 
various resource pool owners or team members.

Creating a Program from a Template

To create a new active or proposed program from a template:

1 Launch Agile Web Client. 

2 Go to the main toolbar and click the Create menu.

3 Select Programs > From Template. The Create Program from Template Wizard appears. 

4 On the Select Template page, select the template you want by clicking its row to highlight it. Click Next.

5 On the Details page, enter the following information:

• In the Name field, enter the new program name.

• For Schedule, click the radio button for either Start Date or End Date. Use the calendar widget to choose the date.

• Under Components, use the checkboxes to select which components to copy. 

Note The checkboxes are automatically filled in with the selections you made the last time you used the 
Create Program from Template Wizard.

• In the Template drop-down list, choose either Active or Proposed.

6 Click Finish when done. The General Info tab of the new program appears.

Using the Save As command

You can use the Save As command to duplicate an activity and all its information, including schedule, structure, 
team, dependencies, deliverables, and general information. 

To use Save As to create a new activity: 

1 Choose Actions > Save As to save the current activity under a new name. 

2 On the Enter Name and Select Components page, enter the following information:
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• In the Name field, enter the new program name.

• Under Components, use the checkboxes to select which components to copy. 

Note The checkboxes are automatically filled in with the selections you made the last time you used the 
Save As.

• In the Template drop-down list, choose Active, Proposed or Template.

3 Click Finish when done. The General Info tab of the new activity appears.

Working with Proposed Programs
A proposed program (the Template field setting is Proposed) has specific limitations and behavior differences that 
allow you to modify Proposed activity objects (programs) without sending multiple notifications or affecting certain 
rolled-up values. This discussion of proposed programs includes the following topics:

❑ What is a Proposed Program?

❑ Proposed Programs and Notifications

❑ Proposed Programs and Workflow Status

❑ Proposed Programs and Program Health Values

❑ Editing the Attributes of Proposed Programs

❑ Proposed Programs and Calculating Rolled-up Values

❑ Proposed Programs and Rescheduling

What is a Proposed Program?

When you create a program, you select a Template field setting:

❑ Template — The program does not appear on active program lists. The template is available to create new 
programs using the Create > Program > From Template command. 

❑ Active — The program appears on active program lists. You can modify the workflow status of the leaf nodes of 
the program tree. (See “Change Status Button” on page 4-30.

❑ Proposed — The program does not appear on active program lists, for example, it is not included in Dashboard 
tables. The workflow status cannot be modified.

If you have the appropriate privileges, you can edit a program and modify its Template field setting.

Proposed Programs and Notifications

Some notifications are blocked and are not sent while the program’s is Proposed. When the program is changed to 
Active, the blocked notifications are sent. 
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The following list of notifications and requests are blocked when the program is proposed:

Proposed Programs and Workflow Status

When an activity object (program) is Proposed, its workflow status (for example, Not Started, In Process, Complete, 
or Canceled), cannot be changed. 

A Template field setting of Proposed has no effect on workflow status rollup. For workflow status rollup, that is, the 
process that determines workflow status of a parent object, the workflow statuses of all the childed objects (both 
active and proposed children) are considered. Workflow status rollup behavior is same for both proposed and active 
programs.

Proposed Programs and Program Health Values

The program health status values are indicated by the Health Status indicators in upper right of the activity window: 
On Track (green) , Needs Attention (yellow) , Off Track (red) . For more information, see 
“Health Status” on page 1-5.

Proposed activities have empty values for the Schedule Status attribute and the Cost Status attribute. Therefore, the 
Health Status indicators corresponding to these two attributes (Schedule Status and Cost Status) are empty: . 

When the program Template attribute is changed to Active, the colored Health Status indicators reappear based on 
the current data. Schedule Status and Cost Status are computed values.

Editing the Attributes of Proposed Programs

Because the following types of attributes affect a program’s workflow status, these attributes cannot be edited for a 
proposed program: 

❑ Actual Dates

❑ Percent Complete

❑ Attributes that affect Rollup values

Table 4-2: Blocked notifications when program is proposed

Proposed program blocked 
notifications and requests

Notification sent when 
program changed to Active? Notes

Assignment requests for users only Yes Note: For a proposed programs, assignment 
requests are sent to the resource pool owner, if a 
pool is assigned.

For more information about assignment requests, 
see “Add Team Members”on page 4-12.

Delegate Owner request Yes For more information about delegating ownership 
of a program, see “Delegating” on page 4-26.

Reschedule notification sent upon 
adding a Dependency

Yes For more information about dependencies, see 
“Dependencies Tab” on page 4-11 and 
“Dependencies” on page 4-10.

Child activity schedule change 
notifications sent to the owner of the 
child activity

No
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Proposed Programs and Calculating Rolled-up Values

The behavior of most of the rollup values changes when the program Template attribute is changed to Proposed. 
When computing the rolled-up values for a parent object, the Proposed children objects are not considered for the 
following rollup values:

❑ Roll up of schedule dates

❑ Roll up of Actual Start date

❑ Roll up of Days Effort

❑ Roll up of Zero duration

❑ Roll up of Schedule Status and Cost Status

❑ All cost roll ups

The following rollup calculations include Proposed child objects when determining the rolled-up value of the parent 
object:

❑ Rolled-up value for percent Complete

❑ Rolled-up value for Actual End Date

❑ Rolled-up values for Estimated dates

Proposed Programs and Rescheduling

Rescheduling actions are allowed for proposed programs and activities. Rescheduling can be triggered from either 
Proposed or Active programs. 

The following sections describe the actions that can cause a Proposed activity to be rescheduled due to modifications 
of an Active activity. That is, date changes on an Active activity change the dates of a Proposed activity.

Rescheduling Active Parent Object and Child Object is Proposed

Performing Schedule tab menu Edit | Reschedule action in Web Client on Active parent will change the dates of the 
proposed child also. 

For example, if the active parent is moved forward by 5 days using the Schedule tab Edit | Reschedule action, then the 
proposed child is also moved by 5 days. 

Adding a Dependency when Predecessor is Active and Successor is Proposed 

If the Proposed successor activity's date does not match the Active predecessor activity’s date, then the Proposed 
successor’s dates are changed to accommodate the added dependency.

For example, if a Finish-Start dependency is added between an Active program ending on October 25 and a Proposed 
program starting on October 20, then the Proposed program will be rescheduled to start on October 26 to honor the 
added Finish-Start dependency. However, the new rescheduled start date of the successor Proposed program will not 
roll up to its parent, as described in “Proposed Programs and Calculating Rolled-up Values” above.

Adding a Dependency to an Active Parent that has a Proposed Child 

If adding a new dependency alters the date of the Active parent, then the Proposed child's date is also altered by the 
same number of days as the parent. The parent has been rescheduled because a predecessor has been added. For 
example, if the Active parent is moved forward by 5 days, then the Proposed child is also moved by 5 days. 

This is similar to “Rescheduling Active Parent Object and Child Object is Proposed” explained above.
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Configuring Program-related Objects
All program-related objects contain the following tabs:

General Info Tab

The General Info page tab contains Activity and Status Information. 

The Program General Info tab contains the following fields: 

Table 4-3: General Info tab fields 

Field Contains...

Schedule Contains information that enables you to quickly track program progress. Tells you the 
targeted start and finish dates as well as the duration remaining until program completion.

Estimated Contains information that enables you to track when overdue items will be delivered. 
Estimated dates for a child object are entered by the owner of the object and will roll up to 
the estimated dates of the parent object in the same manner as scheduled dates.

Actual Actual varies from schedule if you are ahead of or behind targeted program dates. 

Work Days Variance
Calendar Days Variance

Start Variance, Finish Variance, and Duration Variance are displayed for Estimated, and 
Actual dates, compared with Scheduled dates. Variances can be displayed in either Work 
Days or Calendar Days, or both Work and Calendar days.

Note: Your Agile administrator determines which information is displayed in the 
summary table on the General Info tab. 

Duration Type
Days Effort
Complete

Duration Type influences how Days Effort is determined. For more information about 
duration type and days effort, see “Duration” on page 4-8, below.

The Complete field tells you to what percent of the program is complete.

Activities Type Displays whether the activity is a program, phase, or task.

Owner The program owner. 

Delegated Owner The user who has been assigned the activity. Becomes the owner once he/she accepts the 
delegated object. If a user has been delegated ownership but has not accepted the request, 
they are listed as the Delegated Owner.

Name The name of the activity.

Description Text that describes the program. The maximum length is set by the Agile administrator.

Root Parent A link to the root parent object.

Parent A link to the parent object.

Template Indicates the type: Active, Proposed, Template. Only an Active program can undergo 
changes in workflow status. 

Audit Score The audit score for the activity. See “Audit values” on page 4-9.

Weight Weight assigned to the activity. See “Audit values” on page 4-9.

Weighted Score A calculated score based on the audit score times the weight. See “Audit values” on page 4-
9.

Status Indicates the workflow status of the program.

Rollup Health Status Indicates whether the health status rollup is selected or not.

Schedule Status Reason Describes the schedule status for the program object.

Cost Status Denotes the cost status for the activity. This value is a selected value for the leaf object and 
a rolled-up value for a parent object. 

Cost Status Reason Describes the cost status for the program object.

Resource Status Denotes the resource status for the activity. This value is a selected value for the leaf object 
and a rolled-up value for a parent object.

Resource Status Reason Describes the resource status for the program object.
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Editing a Program

To edit a program, click the Edit button. Make changes in the editable fields, and click Save to save the changes, or 
Cancel.

Some fields on the Program page will not be editable if the program has elements reporting to it.

Duration 

Objects within a program can have different duration types such as:

❑ Fixed duration—The object takes a defined period of time (for example, five days). For Fixed duration type, the 
Days Effort is calculated as the Scheduled Duration times the sum of the % allocation of all resources.

❑ Effort driven—The objects’ Days Effort is fixed, but the number of resources assigned affects the scheduled 
duration. For Effort Driven Duration Type, the Scheduled Duration is calculated as the Days Effort divided by 
the sum of % allocation of all resources.

❑ Calculated—This applies to parent objects and is set by the system. You cannot edit this duration type. 

❑ You can also create an effortless activity by selecting Fixed duration and setting zero as the Days Effort. An 
effortless activity can have any scheduled duration (such as six months), but the Days Effort is zero.

Quality Status Denotes the quality status for the activity. This value is a selected value for the leaf object 
and a rolled-up value for a parent object. 

Quality Status Reason Describes the quality status for the program object.

Lock User Name of the user who is currently using Gantt Chart or Microsoft Project to modify the 
program. When a user launches either Gantt Chart or Microsoft Project, the activity is 
automatically locked to prevent any other user from editing the program in PPM. 

Workflow Identifies the object’s assigned workflow.

Schedule Status The schedule status of the activity.

Overall Status An overall status of the activity. This value is calculated based on either selected or rolled-
up values for cost, resource, quality, and schedule. It denotes the worst of these status 
values (cost, resource, quality, and schedule).

Program Type Dashboard field. May be renamed during implementation.

Region Dashboard field. May be renamed during implementation. 

Division Dashboard field. May be renamed during implementation. 

Product Line Dashboard field. May be renamed during implementation. 

Customer Dashboard field. May be renamed during implementation. 

Launch Year Dashboard field. May be renamed during implementation. 

Global Controls whether the program is available to all executives or not. 

Schedule Editor Indicates the source of schedule editing for this program: PPM or MSP (Microsoft 
Project). This is automatically set to MSP when you launch a project into Microsoft 
Project. When set to MSP, the PPM project does not roll up dates, durations and % 
complete. This ensures that when the project is published in PPM from Microsoft Project 
the project dates are correct in PPM. 

Cost fields Monetary fields that are used in the dashboard and reports. These fields track program 
level costs.

Time Fields Data for these fields is manually entered using Edit.

Critical Indicates whether the activity is on the critical path. 

Custom fields Fields that can be configured by the administrator.

Table 4-3: General Info tab fields  (continued)

Field Contains...
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Note If a parent changes to a leaf node object (an activity with no children) then the duration type changes from 
calculated to fixed. The duration remains the same as it was when it was the parent. If the parent object 
had resources, Days Effort is calculated based on the % allocation of the Resource/Groups assigned to the 
Team tab. If there are no resources, days effort is the same as the scheduled duration. A zero duration parent 
changes to a zero-duration child node.

Audit values

The General Info tab of activities contains Audit Score and Weight fields. The objects of a program can be audited, and 
based on performance indicators, the auditor can assign an Audit Score value to each. The weight value reflects the 
importance of the individual object compared to other objects, in the context of the entire program. The Weighted 
Score field is calculated by multiplying Weight * Audit Score. 

Schedule Tab

The Schedule tab displays the activities and schedule of the current activity and its children in a hierarchical fashion. 
For a root program, it contains all the activities required to complete the program. If anything about your program 
changes after you create your schedule, you can update the activities and resources, and Agile adjusts the schedule 
for you. 

To open a program, click the link in the name field. 

You must have the appropriate privileges to work with the Schedule tab.

The Schedule tab has the following buttons:

Deleting a Program Element

To delete a program element:

1 Select the row of the object you want to remove.

2 Click the Delete button. A warning message appears asking you to confirm that you want to delete this program 
object. Choose OK in the confirmation message if you want to delete the program element from the database. 

Note Only an administrator or PPM program manager or resource pool administrator may delete a program. 
An owner may delete a phase, task, deliverable, or gate. Discussions and File Folders are not deleted from 
the system; they are removed from the program and become stand-alone objects in Agile when the activity 
is deleted.

Table 4-4: Schedule Tab buttons 

Button Description

Expand Enables you to see all child activities associated with the selected activity. 

Delete Enables you to delete the selected child object.

Edit Enables you to:

• Edit dependencies between the child tasks within the root program.
• Reschedule the current activity.
• Change display order of child activities.
• Add a team. 

Add Enables you to add new object (program, phase, task, gate) to the program schedule using the 
Add Activity wizard.

Create Baseline Enables you to create baseline (see “Creating a Baseline” on page 4-11).

Remove Baseline Enables you to remove a baseline.
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Edit Menu Options

The Edit menu on the Schedule tab opens the Dependencies, Display Order, Reschedule, and Add Team wizards. A 
checkbox in the menu indicates that you must select an item before using the menu choice. 

Dependencies

A dependency between activities means that one activity's schedule start date is driven by the predecessor's scheduled 
end date (see “Dependencies Tab” on page 4-11). 

Select at least two activities in the list of child objects, and choose Edit > Dependencies. The window that opens lets 
you create or edit dependencies between activities selected by entering the line item number. You also can establish 
and change dependencies using the Gantt Chart (see Chapter 5). 

Note Defining dependencies on a parent task is not an Agile PPM Best Practice. Dependencies should be 
modeled at the leaf-level tasks, not at the parent level. A parent and its child should not have the same 
dependency.

Editing the Display Order

You can change the order in which tasks or phases appear on the Schedule Page tab. 

To edit the sequence of the Program elements on the Schedule tab: 

1 On the Schedule tab, select Edit > Display Order. The Display Order page appears. 

2 In the boxes in the Line # column, enter a number that represents the order in which you want the corresponding 
program elements to appear on the Schedule tab.   

3 Click Save when done. 

Rescheduling a Program 

While other Schedule tab edit functions allow you to select and modify rows in the schedule table, the Edit > Reschedule 
function acts on the currently displayed object only, not the rows in the schedule table. (Edit > Reschedule is similar to 
the Move function in the Gantt Chart.)

To reschedule your Program:

1 From the Schedule tab, select Edit > Reschedule. The Reschedule page opens. 

2 Click the button beside the Move forward () days field to move the schedule date for the program element forward. 
Click the button beside the Move back () days field to move the schedule date for the program element back. Or you 
can use the Start Date or End Date fields to adjust the schedule. 

For more field and button information on this page, see “Schedule Tab” on page 4-9 

3 Click Save to reschedule the program. 

Adding to the Team

You can select single or multiple activities and add team members or resources (the default allocation is 100%). 

See also “Team Tab” on page 4-12.

To add members to a team from the Schedule tab:

1 Select one or more activities and select Edit > Add Team. 

2 Search for a name by typing the Search Name and clicking Find. Or view all available users by leaving the Search Name 
box empty and clicking Find. 

3 Select individual team members from the Available Users list, and click the arrow to move them to the Selected Users 
list. You can use Ctrl+click and Shift+click to select multiple users. 
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4 By default, the Add as Team Member Only checkbox is selected, which will add the selected users as team members 
with no % allocation.

To add the selected users as resources (with a % allocation), click the checkbox to deselect it. In the % Allocation 
field, the default allocation is 100%. You can accept the default or you can enter the desired allocation in the % 
Allocation field. 

5 Click Next. 

6 Select the appropriate roles for these users from the Available Roles list, and click the arrow to move them to the 
Selected Roles list. 

7 Check Apply to Children if you want the users roles to apply to the current object and child objects. Click Finish. 

Creating a Baseline

Baselines are used for comparing actual progress with your original plans. A baseline is essential for tracking 
progress. The original estimates it contains are permanent reference points against which you can compare the 
updated task structure, schedule and actual dates.

You create baselines only for the root program object so you can take snapshot of the schedule.

To create a baseline: 

1 From the Schedule tab of a root program, click the Create Baseline button.

2 Enter a description for the baseline, and click Save. 

Once you save a baseline, you can compare the current schedule with any baseline by selecting the baseline from the 
Version list. 

Note You can use the Baseline Comparison report to compare baselines. In the navigation pane, click Analytics 
and Reports navigation button, then navigate to Standard Reports > Program & Portfolio Reports > Program Reports > 
Baseline Comparison Report.

If you need to take snapshots of extensive program data during the planning phase, save multiple baselines. For 
example, you may want to do this at major planning milestones. 

You can remove a baseline by selecting the baseline in the Version list, and clicking the Remove Baseline button. When 
you remove a baseline, the references to the baseline for all objects in the tree are also removed.

Dependencies Tab

The Dependencies tab displays a list of all the predecessor (Dependent Upon) and successor (Required for) 
information of the program. If you have established dependencies to other activities, links to these are also shown. 
All dependencies are Finish-to-Start (FS). For more information about dependencies, see also “Dependencies” on 
page 1-4.

This tab contains the following buttons:

❑ Edit—lets you edit dependencies between the child tasks within the root program. The Edit button affects only the 
checked items on the current page. 

❑ Remove—deletes the selected object. The Remove button affects only the checked activities in the current page.

❑ Add—lets you add a dependency between the child tasks within the root program. You can add an element whose 
completion is essential to the start of the current program using the Add Dependencies wizard. Dependencies 
can be made between activities in the same program. 

To add a dependency, click Add. 

To edit or delete dependencies, select the rows you want to affect, and click Edit or Remove. 

To open an activity, click its name.
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Dependency Time Buffer

When creating or editing a dependency, you can enter a value in the Time Buffer field that represents “slack time” 
between the end of the predecessor activity and the start of the successor. 

You can also create and change dependencies from the Gantt Chart view. See “Creating a Dependency” and “Editing 
a Dependency” on page 5-5.

Team Tab

The Team tab lets you manage the team member list for the activity. The Team tab enables you to add or remove team 
members, change team members’ roles, and change their allocation. You must have the appropriate privileges to 
work with the Team tab.

Add Team Members

To add team members or a group and apply roles: 

1 Click Add. 

2 Search for a name by typing the Name(s) field and clicking Find. Or view all available users by leaving the Name(s) 
field empty and clicking Find. You can select All Groups to assign a resource pool as a placeholder if the specific 
user is not known.

3 Select individual team members from the Available Users list, and click the arrow to move them to the Selected Users 
list. You can use Ctrl+click and Shift+click to select multiple users. Click Next. 

4 Check the Add As Team Member Only box if you want the new people to be team members but not resources. Or 
uncheck the box and fill in the percent of their time that will be dedicated to this task in the % Allocation field. 

5 Assign one or more roles by selecting them from the Available Roles list on the left and clicking the arrow to move 
them to the Selected Roles list on the right. 

6 Check the Apply to Children box if you want the team members to be included for all child objects. 

7 Click Finish. 

The selected resources with the roles are displayed in the Team tab. People added as resources are also added as team 
members automatically. 

When you complete the Add action, users added as resources receive an Inbox request to accept/decline the 
assignment. Once the user accepts a request, the Resource Pool owner receives a notification that the assignment has 
been accepted.

You can click the Report button in the Add to Team Wizard: Identify Users to Add page to view one or more user’s assignments 
to decide whom to add to the assignment pool. 

Edit Team Member Attributes

To edit a team member’s resource pool, roles, and % allocation:

1 Select the rows you want to affect. Click Edit. 

2 Enter the changes you want in the Resource Pool and % Allocation fields. Click the  button in the Roles column 
to edit roles. 
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3 Click Save. 

Assigning Team Members from a Resource Pool Placeholder

If you added a resource pool to the Team tab as a placeholder, you can easily select the specific users you want to 
assign.

To assign team members from a resource pool:

1 Open the activity and click the Team tab to display it.

2 In the Name column, click the  button next to the resource pool you want. The Assign User From User Group 
wizard appears.

3 Select individual team members from the Available Users list, and click the arrow to move them to the Selected Users 
list. You can use Ctrl+click and Shift+click to select multiple users. 

4 To apply the team member assignments to children of the current activity, check Apply to Children.

5 Click Finish. 

Note The % Allocation will be divided among the selected users. If there is a fraction of a percent, the percentage 
will be rounded down to the next lowest whole number; the fractions of a percent are discarded. 

For example, if the resource pool was assigned at 100% allocation, and you select three users, each user will 
be assigned 33%. If you remove the three users and reassign the % Allocation back to the resource pool, the 
% Allocation for the pool will be 99% – the fractions of a percent are discarded. However, you can select the 
appropriate rows in the table and click Edit to adjust the percentages for the users assigned from the 
resource pool, or (if you have assigned allocation back to the resource pool) adjust the percentage for the 
resource pool. 

Table 4-5: Team tab fields 

Field Description

Click the icon to view Resource Pool Utilization Report. The Resource Pool Utilization 
report provides a user’s utilization based on the % allocation for the selected user. 

Name Name of team member or group.

Assigned From The name of the pool from which the resource is assigned. If the resource is assigned to 
multiple pools, the appropriate pool can be selected. 

Note: For best results in managing resource utilization, Agile recommends that a user be 
assigned as a member of only one resource pool. 

Roles Program-specific roles assigned to team member for this activity.

Days Effort Days effort corresponds to the total sum for the resource or group. 

Is Resource Identifies the user as a resource or just a team member with no time allocated to the activity. 
This Information is dependent on % allocation of Resource/Team Member / User Group. If 
% allocation is greater than 0, it is Yes, otherwise No. 

Rejected flag This indicates that the resource or pool has rejected the Inbox Request. 

% Allocation For both Fixed and Effort Driven duration type, this value determines utilization of a 
resource or group.

Pool Owner Name of the resource pool owner, if there is one.

Actual Hours The number of actual hours (duration) the team member has worked. 

• Reported Actual Hours are rolled up and compared to Estimated Duration and Scheduled 
Duration.

• Actual hours are also used to determine the labor cost per activity. Actual hours are 
multiplied by the resource rate to determine the current applied cost of each resource. 
These totals by resource are added up to determine the applied cost per activity, and are 
then rolled up to the top to create labor costs for all parent objects.
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In a similar manner, when you assign users from a resource pool, the Actual Hours setting is divided among 
the users and any fractions of an hour are discarded. Select the appropriate rows and click Edit to adjust the 
Actual Hours settings as needed.

Remove Team Members

Use the Team tab to remove a team member, resource, or pool from the activity. When you remove, you can choose 
one of the following options. 

Note For an effort-driven task, removing the resource and discarding the allocation changes the schedule 
duration of the task and affects roll-ups to parent activities.

❑ Delete only if resource has no percent allocation

Removes the selected resources only if the resource has no allocation. If the selected resource does have 
allocations, it will not be removed.

❑ Delete resource and re-assign percent allocation to pools (if applicable)

If the resource is assigned from a pool, the resource is removed and the resource’s allocation is reassigned to the 
pool. If the resource is not in a pool, the resource is removed and the allocation is discarded.

❑ Delete resource and discard percent allocations

The resource (whether assigned from a pool or not) is removed and the allocation is discarded.

Deliverables Tab

Deliverables are Agile objects that must be in a specified workflow status or lifecycle before the current PPM object 
can change status. The Deliverables tab can be used to organize documentation and other Agile objects related to a 
PPM program. Deliverables enable you to add any Agile PLM object to PPM objects as triggers to enable cross-
business process automation. 

For a deliverable that has not yet reached the specified target status or lifecycle when added to the Deliverables tab, 
when it moves to the specified status or lifecycle, this event can automatically trigger the PPM object to change status, 
providing all other PPM object status change criteria have been met. For example, a gate might change to Open from 
Closed when a deliverable Agile item moves to the Production lifecycle.

Whenever any object changes from one status or lifecycle (state) to another, Agile evaluates whether that event is set 
to trigger a status change in another Agile object, including PPM objects. 

When you add objects to the Deliverables tab, you select a target status or lifecycle as the specified event. Usually this 
is a target state that indicates that the deliverable is complete or approved. You may select:

❑ Deliverables that are already completed, that is, their current state matches the target state.

Objects whose current state matches the target state when added to the Deliverables tab are marked complete  
in the Affected By table. Because they will not change state to reach the target state, there is no event to be 
evaluated, and therefore they will not trigger the PPM object to change status.

Note If all the objects on the Deliverables tab are complete and the PPM status change has not been automatically 
triggered, you can change the status manually, that is, use the PPM object Change Status button to change 
the status.

❑ Deliverables that are not yet completed, that is, their current state is different than the target state. 

When objects move to the target state, they are marked complete  in the Affected By table. When all the 
deliverables are complete, the last deliverable that changes state triggers the PPM object to change status, 
providing all other PPM object status change criteria have been met.

You can select multiple deliverables, completed, not yet completed, or a mixture.

Example:
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Part of Jane’s project requires that 15 specifications be written and approved. Jane creates a task in her PPM 
program called “Create Specifications.” Each specification is an Agile item object with a document file as an 
attachment. Jane’s company uses the Agile change order to route specifications items for approval. When all 
approvers have signed off, the lifecycle of the specification object (a deliverable) changes to Production.

Jane opens the “Create Specifications” task and clicks the Deliverables tab. She uses the add by search option to 
locate the specifications she wants. She selects Production as the trigger event. Some of the specifications are 
already in Production, and others are not. When she completes the edit wizard, the Production object rows in 
the Affected By table are marked complete .

Jane has now created a complete list of associated documents on the “Create Specifications” task Deliverables tab. 
At any time during the life of her PPM program, the complete list of specifications is available for review or 
reference by any member of the program team.

Affected By Table

The Affected By table displays objects that affect the current activity’s workflow status when their workflow status 
changes. The change in the status of the object is automatically reflected on the Deliverables tab. 

Note Objects in the Affected By table may be either routable objects with workflow statuses, such as changes or 
file folders, or the objects may be non-routable objects with lifecycle phases, such as parts (items).

The fields in the Affected By table are described in the following table: 

To Add items in the Affected By table by searching for the objects:

1 Open the Activity.

2 Click the Deliverables tab.

3 Click the Add drop-down menu button and choose the  Search option.

The Add Related Content dialog box appears.

4 Search for one or more existing objects. In the Add Objects dialog box, select a search method. If you choose to 
perform a simple search, enter the value to search for and click Search. You can also define an advanced search, 
run a saved search, or select a bookmarked or recently visited object (Shortcuts). (For more information about 
searches, see Getting Started with Agile PLM.)

5 In the search results, select the objects you want by moving them into the Selected Objects list.

You can run multiple searches to find and select additional objects.

6 Check Edit rows after adding if you want to edit the Event and Result fields immediately after adding.

Note If you do not check Edit rows after adding, the objects are added to the table and you can edit the Event and 
Result fields later. 

Table 4-6: Fields in Affected By table 

Field Name Field Description

Criteria Met
The Complete icon  indicates that the object has entered the status or lifecycle specified in 
the Event field.

Number The unique identification number of the object.

Description The description about the object. 

Event The event to happen in the object in order to change the state of the program to the state 
specified in the Activity Result field. It is also referred to as the target status.

<Activity> Result <Activity> is replaced by the activity name. The status of the activity will be automatically 
changed to the status specified in this field when the last non-complete deliverable workflow 
status changes to that specified in the Event field.

Current Status The current status of the activity.
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7 Click OK.

8 If you checked Edit rows after adding, the Edit Newly Added Rows wizard appears. Select the Event and Result settings 
as required and click Save.

Event is the change of state of the Agile object that will trigger a workflow status change in the activity. 

Result is the workflow status that the activity will change to once the trigger occurs. 

Note When multiple objects are listed on the Deliverables tab, all objects must reach their Event state to 
trigger the change in the activity.

To Add items in the Affected By table by creating new objects:

1 Open the Activity.

2 Click the Deliverables tab.

3 Click the Add drop-down menu button and choose the  Create New option.

The New dialog box appears.

4 Select an object type.

5 Complete the information in the dialog as required: select a number and complete any required fields.

6 Click OK.

The object is added to the Affect By table.

7 To complete the Event and Result fields, select the object row, and click Edit.

Event is the change of state of the Agile object that will trigger a workflow status change in the activity. Result is the 
workflow status that the activity will change to once the trigger occurs. 

Note When multiple objects are listed on the Deliverables tab, all objects must reach their Event state to 
trigger the change in the activity.

Affects Table 

The Affects table displays the objects that are affected by a change in the workflow status of the current activity. 

Note Objects in the Affects table are limited to routable objects with workflow statuses, such as changes or file 
folders.

The fields in the Affects table are described in the following table:

To add objects to the Affects table by searching:

1 Open the activity.

2 Click the Deliverables tab.

Note If no Affects table is visible, click the Add to Affects Table link below the Affected By table.

Table 4-7: Fields in Affects table 

Field Name Field Description

Number The unique identification number of the object. (Lets say OBJ01)

Description The description of the object.

<Activity_NUM> Event <Activity_NUM> stands for the unique identification number of the activity. When the status of 
the activity is changed to the status specified here, the status of the object (OBJ01) will be 
automatically changed to the status specified in the Result field.

Result The status of the object (OBJ01) will be automatically changed to the status specified in this field 
when the <Activity_NUM> Event is triggered in the activity object.

Current Status The current status of the object (OBJ01).
4-16 Product Portfolio Management User Guide



Chapter 4 Creating and Managing Programs
3 Click the Add drop-down menu button and choose the  Search option.

The Add Objects dialog box appears.

4 Search for one or more existing discussions. In the Add Objects dialog box, select a search method. If you choose 
to perform a simple search, enter the value to search for and click Search. You can also define an advanced search, 
run a saved search, or select a bookmarked or recently visited item (Shortcuts). (For more information about 
searches, see Getting Started with Agile PLM.)

5 In the search results, select the objects you want by moving them into the Selected Objects list.

You can run multiple searches to find and select additional objects.

6 Check Edit rows after adding if you want to edit the Event and Result fields immediately after adding.

Note If you do not check Edit rows after adding, the objects are added to the table and you can edit the Event and 
Result fields later. 

7 Click OK.

8 If you checked Edit rows after adding, the Add Related Content Wizard appears. Select the Event and Result settings as 
required and click Save.

To add objects to the Affects table by creating a new object:

1 Open the activity.

2 Click the Deliverables tab.

Note The Affects table must be visible to add by Create New. If no Affects table is visible, click the Add to Affects 
Table link below the Affected By table.

3 Click the Add drop-down menu button and choose the  Create New option.

The New dialog box appears.

4 Select an object type.

5 Complete the information in the dialog as required: select a number and complete any required fields.

6 Click OK.

The object is added to the Affects table.

7 To complete the Event and Result fields, select the object row, and click Edit.

To edit the object information in both Affected By and Affects table:

1 Select the rows of the objects that needs to be edited.

2 Click Edit. The objects are displayed in the Edit mode in the table.

3 Make changes to the editable fields as required.

4 Click Save to save the changes.

To Remove the object information from Affected By and Affects table:

1 Select the rows of the objects you want to remove.

2 Click Remove. A confirmation message box is displayed.

3 Click OK to confirm the removal.

Links Tab

For a product deliverable, the Links tab displays a list of all objects that have a reference relationship with the current 
object. Unlike deliverables, there are no requirements or automation imposed between linked objects and the 
corresponding PPM activity. 
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❑ To add a reference relationship, click the Add button. The Add Related Content wizard opens. 

❑ To delete a reference relationship, select the rows you want to effect, and click the Remove button. 

❑ To open a reference relationship, click its number link.

The table below describes the fields in the section. 

Workflow Tab

The Workflow tab shows where the program object is in the assigned workflow and lists past signoff information. If 
you have the necessary privileges, you can add or remove approvers and observers on this tab, or you can move the 
object to another status in the workflow.

Programs, phases, and tasks roll up their statuses (see “How Status Roll-Up works” on page 1-5). Default workflows 
for programs contains the following statuses: 

❑ Default Activities Workflow

Not Started —> In Process —> Complete

❑ Default Gates Workflow

Closed —> In Review —> Open

Default workflows also include a Cancelled status. If you have the appropriate privileges, you can move the program 
object to the Cancelled status from any current workflow status. 

Note If your company uses custom workflows, your list of statuses may be different and your ability to move 
from one status to another status may controlled differently.

Rules for parent status
❑ Parent object workflows are affected when any of their child workflows start. For example, if one child activity is 

in the In Process state, then Parent status is In Process.

❑ Parent object workflows are affected when all of their child object workflows complete. For example, if all 
activities are Complete, then parent status is Complete.

❑ When custom workflows are used, the roll up is governed by the transition between the Status Type, not 
necessarily a change in the step. For example, a workflow with seven steps can roll up to a parent with three steps 
because each has only one transition between the “Pending” and “Review” type (Pending, Review, Complete, and 
Cancel are the Status Types).

For leaf-node objects, you can click the Change Status button to change their workflow status (provided you have the 
required role). 

To change the workflow status of the parent activity, open a leaf-level child activity and click the Change Status button 
to change the workflow status of the leaf-level activity.

Note You cannot use the Change Status button to change the workflow status of an activity that has children 
(subordinate activities).

For more information about workflows, see Getting Started with Agile PLM and the Agile PLM Administrator Guide. 

Table 4-8: Fields on the Links tab 

Field Description

Type An icon representing the object type. Rest the mouse pointer on the icon to see the name of 
the object. 

Number The object number or name. Click to open this object. 

Description A description of the object.
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Discussions Tab

The Discussions tab contains both discussions and action items. Users can post and reply to discussions that arise in 
the course of managing programs. High priority discussions appear on the Agile dashboard as Issues. Action items 
may be used in conjunction with discussions to ensure that the loop is always closed so that discussions do not go 
unattended. Action items can also be tracked at each activity level independent of any discussion or issue, and can 
be used to track and measure activity follow-up, meeting to-dos, and so forth.

Subscriptions are often set up by the team members to get notified as discussions are raised. This promotes a 
collaborative thread of replies and captures the decision-making and history of a program.

Discussion Table Details

The Discussion table displays important information about each discussion. An action item icon  indicates there 
are action items associated with the discussion. Click the icon or click the discussion name to open the discussion.

Adding Discussions

You can add a new discussion or reply to an existing discussion. 

To add a new discussion: 

1 Open the activity, and click the Discussions tab.

2 Click the Add drop-down menu button and choose the  Create New option.

The Add Discussion wizard appears. 

3 Select Discussion from the Type drop-down list.

4 Enter a subject for the discussion. 

5 Type the message you want to send. 

6 From the Priority drop-down list, set the discussion priority.

7 Click the Notify List field to add users who should receive notification of this discussion in their Notifications & 
Requests inboxes. Click Finish. 

To search for an existing discussion to add: 

1 Open the activity, and click the Discussions tab.

2 Click the Add drop-down menu button and choose the  Search option.

The Add Objects dialog box appears.

3 Search for one or more existing discussions. In the Add Objects dialog box, select a search method. If you choose 
to perform a simple search, enter the value to search for and click Search. You can also define an advanced search, 
run a saved search, or select a bookmarked or recently visited item (Shortcuts). (For more information about 
searches, see Getting Started with Agile PLM.)

4 In the search results, select the discussions you want by moving them into the Selected Objects list.

You can run multiple searches to find and select additional discussions.

5 Click OK.

Replying to Discussions

You or your team members or notified users can reply to the discussions. 

To reply to discussions,

1 Open the activity, and click the Discussions tab.

2 Click the discussion name to open it. 
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In the root program object, you can see which activities have discussions by looking for the symbol in the 
discussions column on the Schedule tab. 

3 On the Discussions tab, select the discussion you want to reply to.

Note You can use the Preview Message checkbox to quickly preview the message text of all the discussions in the 
Discussion table when selecting the discussion you want to reply to.

4 Click the Reply button. Enter your message and the list of people to notify, and click Save. 

To add a comment to an existing reply:

1 Open the activity, and click the Discussions tab.

2 Click the + symbol next to a discussion in the Subject column. 

The list of replies is displayed. 

3 If a reply has subordinate replies or comments, click the + symbol in the Subject column next to the reply to 
expand the list.

Each + symbol indicates that the reply has subordinate replies. Click the + symbol on each successive level until 
you have displayed the reply to which you want to add a comment.

4 Select the row to which you want to add a reply.

5 Click the Reply button. The Discussion Reply wizard appears.

6 If desired, enter a subject for the reply. Or, use the default subject provided for you.

7 Enter your message and the list of people to notify, and click Save. 

Your reply is added to the discussion thread below the reply row you selected in step 4 above.

Viewing Discussion Replies

Note You can use the Preview Message checkbox to quickly preview the message text of all the discussions in the 
Discussion table. 

To see a list of replies to a discussion: 

Click the + symbol next to a discussion in the Subject column to expand the list of replies. 

Or you can click a discussion subject to open the discussion object. Click the + symbol in Subject column of the 
Message Thread table to view all the replies related to this discussion.

Replying to Discussion from your Inbox

When a discussion appears in your Notifications and Requests Inbox, you can open the discussion object and either 
add a reply or add a comment to an existing reply,

If you are viewing a list of discussions in your Notifications & Requests inbox, you can reply as follows:

1 In your Notifications & Requests inbox, click the Regarding field (not the Subject field) of the discussion to open the 
discussion item. 

2 Select the button for the row you want to reply to. 

3 Click Reply. The Discussion Reply wizard appears. 

4 Add the reply message and the list of people to notify, and click Save.

To add a comment to an existing reply:

1 In your Notifications & Requests inbox, click the Regarding field (not the Subject field) of the discussion to open the 
discussion item. 

2 Select a row in the replies table to add a comment to that row.
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3 Or, if a reply row has subordinate replies or comments, click the + symbol in the Subject column next to the reply 
to expand the list.

Each + symbol indicates that the reply has subordinate replies. Click the + symbol on each successive level until 
you have displayed the reply to which you want to add a comment.

4 Select the button for the row to which you want to add a reply.

5 Click Reply. The Discussion Reply wizard appears. 

6 If desired, enter a subject for the reply. Or, use the default subject provided for you.

7 Add the reply message and the list of people to notify, and click Save. 

8 Click the Notify List field to add users who should receive notification of this discussion in their Notifications & 
Requests inboxes. Click Save.

Your reply is added to the discussion thread below the reply row you selected in step 4 above.

Removing Discussions

After you finish all your discussions, you can remove the discussion objects. 

To remove discussions: 

1 Open the activity, and click the Discussions tab.

2 Select the button for the discussion you want to remove.

3 Click Remove. 

Action Item Table Details

You can access action item details from the Discussions tab by clicking the name of the action item. Action Items 
appear separately below discussions in the Action Item table in the lower part of the page. 

❑ The list of action items in the table is a combined list of the action items associated with the program and the 
action items associated with the listed discussions. 

❑ The Belongs To column and icon indicate whether the action item is associated with a discussion object or with a 
program object. Click the link in the Belongs To column to open the object.

Click the name of the action item in the Subject column to open the action item.

To add an Action Item: 

1 Open the activity and click the Discussions tab

2 In the Action Item section, click the Create button. 

3 Fill in the action item information. Fields that are in boldface are required. 

4 Click Save.

The action item will appear in the Notifications & Requests inbox of the person you assigned it to.

Attachments Tab

The Attachments tab enables you to attach files and URLs that are helpful or needed for your and your team members’ 
work. If there are items on the Attachments tab, a paper clip icon appears on the tab. 

Note You must have at least edit permissions to add an attachment to a program element.

Refer to “Working with Attachments” in the Getting Started with Agile PLM for details about the Attachments tab.
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History Tab

The History tab records all actions taken, such as editing the General Info tab or changing activities or team members. 

Note If you do not have the appropriate read privileges, you cannot view the fields on the History tab. If you have 
questions about your privileges, see your Agile administrator.

Creating and Using Gates
A gate is a special PPM object representing a point in time that denotes the completion of a set of related activities, 
such as a phase or some other set of tasks. Gates usually change state based on the state change of one or more 
deliverables. A gate is a leaf node, meaning it has no children. 

The status of a gate can be Closed or Open. The default is the Closed state. A gate is closed until all its deliverables 
have been met. At that point, it becomes Open, meaning the program can now proceed through the gate. 

The Approval Items and Deliverables tabs display objects and deliverables that are required for the review and approval 
process of the Gate object. 

A gate is created as the child of another program element. To create a gate: 

1 Go to the parent activity. 

2 On the Schedule tab of the parent object, choose Add and specify Gate as the object type. The Add Activity wizard 
appears. 

3 Fill in the information for the gate.

4 Click Finish. The General Info tab of the new gate appears.

Once you have created the gate, you can go to the Approval Items tab and click Add to add activities that need to be 
monitored during a gate review. 

You also can go to the Deliverables tab and click Add to add deliverable objects, which can be used to control the status 
of the gate. 

To add deliverables to a gate: 

1 Click the Add button in the Deliverables tab

2 Use one of the search options to locate and select the objects you want to add. 

3 In the Information wizard page, fill in the fields:

• In the Event field, select the target workflow status which the deliverable must reach to trigger a status change 
in the gate.

• In the <Gate name> Result field, select the status that the gate should move to once all deliverables have reached 
their target statuses. Usually this is Open, meaning the gate should open when the deliverables have been 
completed. 

4 Click Add More if you want to add more deliverables to the gate, or click Finish. 

You also can add dependencies to a gate, as with other activities. Only the dependencies are accounted for in the 
rescheduling of the project plan.

Using the PPM Program Tree in the Navigation Pane
In Agile Web Client, the left pane, called the navigation pane, provides access to searches and Analytics and Reports. 
As you perform certain actions in Web Client, such as stepping through wizards, the navigation pane provides tools 
for navigating the process.
4-22 Product Portfolio Management User Guide



Chapter 4 Creating and Managing Programs
In Agile PPM, the navigation pane also includes navigation tools that allow you to view an entire program tree 
structure and to keep that program tree visible and accessible as you work in Web Client. For example, you may open 
and view other types of Agile objects, run searches, and view attachments, then return to the most recently viewed 
program tree view in the navigation pane.

Figure 4-1: Navigation pane controls

When you open any Agile PPM object, the root program tree for that object appears in the navigation pane, and the 
Program Tree navigation control become available. 

Concurrent Editing of Program Objects
The Agile PPM solution is designed to manage large programs with hundreds of activities and numerous team 
members. It is possible for multiple users to edit:

Table 4-9: Program tree navigation pane actions

Action or button: Description: 

 Expand All

 Collapse All

Expand All expands all levels of the program tree. 

Collapse All collapses the all levels of the program tree so that only the root parent activity is 
displayed.

You can also click + or - in the program tree to expand or collapse one level at a time.

Click an activity in the 
program tree navigation 
pane

The activity is displayed in the right pane with the most recently viewed tab in front.

For example, if you display the Discussions tab in the right pane, when you click another activity 
in the program tree navigation pane, that activity is displayed in the right pane with the 
Discussions tab in front. 

As you click through the program tree in the left pane, the same tab is always displayed in the right 
pane until you select a different tab.

 Program Tree • If the program tree is not currently displayed in the navigation pane, clicking Program Tree 
returns the navigation pane view to the most recently viewed expansion of the program tree.

• If the program tree is currently displayed in the navigation pane, clicking Program Tree collapses 
the navigation pane. 

You may perform a number of actions (including running searches, opening and viewing other 
Agile objects, opening your Inboxes) during which the Program Tree button remains visible. Click 
Program Tree at any time to return to the most recently viewed expansion of the program tree.

If the program tree is not currently displayed in the navigation pane and the Program Tree button 
is visible, you may also click the Refresh button in the main toolbar to return to the program tree 
in the navigation pane.

Note: The Program Tree button is removed if you use Show BOM Tree when viewing an Agile item 
or if you perform an action that displays wizard steps in the navigation pane. However, if you 
select and display an activity in the root program (for example, by using the Recently Viewed list), 
the most recently viewed expansion of the program tree is displayed in the navigation pane and 
the Program Tree button is visible.

Navigate to (by any 
means) a different root 
program

The navigation pane program tree is updated with the program tree of the newly selected root 
program.

Collapse Navigation Pane or Expand Navigation Pane 

Searches Folders (includes Bookmarks and Recently Visited)

Analytics and Reports

Program Tree
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❑ Multiple tasks in the same project tree structure at the same time. 

❑ The same task at the same time. 

Editing Multiple Tasks in the Same Project Tree Structure

When multiple tasks in the same project tree are edited at the same time, the edit modifications may have affects on 
objects higher in the program tree (rollup) or lower in the program tree (rolldown). 

Editing Tasks that have a Predecessor and Successor Relationship

When a parent task is rescheduled to a specific end date, that end date rolls down to the child objects. It is also 
possible to edit a child object end date, which then extends (by rollup to the parent object) the bounds of the parent 
object. As each user makes save his modifications, the necessary rollup or rolldown takes place. In this scenario it is 
possible for a user to enter a specific date on the edit page, yet see a different date upon save because of the rollup or 
rolldown caused by another user’s edits, however, the schedule is accurate.

Examples

❑ Task B (owned by Bob) is a predecessor to task A (owned by Mark). Bob and Mark are edging the schedule dates 
of their tasks at the same time, and save their edits one right after the other. If the new edited dates of the first 
saved task cause the dates of the second saved task to change, the person saving the second task is presented with 
a message explaining that the dates he entered will be changed and he can accept the change or cancel.

❑ Mary is editing a parent activity and several other users are editing several child activities at the same time. Mary 
reschedules the specific end date of the parent activity. At the same time, some of the child activities have been 
modified in such a way that the end date of the parent activity is extended. As each edited activity is saved, the 
dates for the parent or child activity are updated correctly for schedule accuracy. It is possible that a user may 
save his activity and see a different date than the one he entered on the edit page, but the schedule is accurate.

❑ New roll-up data overwrites a common parent or root activity.

Susan owns task C and Fred owns task D. Both task C and task D have a common parent, task M, thus they are 
both in the same tree structure. Both Susan and Fred are editing their tasks, modifying data that rolls up to parent 
task M (percent complete, cost, or status data). Fred saves task D and task M is rescheduled according to Fred’s 
edits. Then Susan saves task C, and task M is again rescheduled, this time according to Susan’s edits.

Multiple Users Editing the Same Task

To keep other users from editing roll-up or roll-down attributes of the object you want to edit, use the Lock feature. 
Locking an object means that only you can edit roll-up and roll-down attributes and other users who edit the object 
are “locked out.” Although they can edit attributes that do not rollup and rolldown, they cannot edit roll-up and 
roll-down attributes until you have finished your edits and you have unlocked the object.

Note When you use Launch in Microsoft Project or Gantt Chart, Agile automatically locks the project. When you update 
from Gantt Chart or Microsoft Project, Agile automatically unlocks the project.

In contrast, when you use Edit on the Cover Page, you must click the Lock button before you click Edit if you 
want to lock the object. The differences between locked editing and unlocked editing are explained below.

Lock Task Before Editing

When a user (Mary) locks the task before entering edit mode, Agile provides the following safeguards when a second 
user (Carl) edits the same task:

❑ Carl sees a message “This activity is currently locked by another user. For this reason some fields will not be 
editable.”
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❑ While in edit mode, Carl can edit only non-rollup attributes on the Cover Page, Page Two, and Page Three. Carl can 
save his edits. When Mary saves her edits, Carl’s edits may be overwritten. The most recent update of non-rollup 
attributes overwrites the others.

❑ The Name attribute on the Cover Page is an exception. Even though it is not a rollup attribute, when the task is 
locked, only the lock user may edit this attribute.

Note When you lock an object, its dependencies (both external and internal) are locked; the successors and their 
children are locked.

To lock and edit an activity object:

1 Open the object you want to edit.

2 Click the Lock button.

3 Click Edit on the Cover Page tab.

4 Make your desired edits.

5 Click Save on the Cover Page tab.

6 Click the Unlock button.

Editing a Task without Locking it First

If you do not lock a task before editing it, the same safeguards do not apply. When Joe enters edit mode for a task 
first, and Carl then enters edit mode, the following applies:

❑ The second user, Carl, does not see a warning that another user is in edit mode.

❑ Regardless of who entered edit mode first, the user who saves first will update the Agile database with his 
modified data. The second user who saves receives the following error message: “The current object has been 
modified by another user, please try again. If you want to ensure that your changes are saved, please lock the 
object prior to editing.” 

❑ If the unlocked parent object has been rescheduled to a specific end date, and any child objects have been 
modified in a manner that extends the bounds of the parent, no messages are presented, and each modification 
is saved. The appropriate roll-up or roll-down date modifications are performed. It is possible that the date 
information that a user saves might not match the date he entered (due to edits made by a different user), but the 
schedule information is correct.

❑ The exception to above behavior is when two users edit the task status (use the Change Status button) or two users 
add to the Schedule at the same time. Multiple status changes and schedule additions are accepted and saved 
when done in parallel.

Creating a Hospitable Project Environment: The Actions Menu
The Actions menu has the following commands: 

❑ Bookmark 

❑ Subscribe

❑ Save as

❑ Delete 

❑ Print

❑ Send 

❑ Sharing

❑ View workflows 
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❑ Delegate

❑ Substitute resource

❑ Change parent

❑ Change archive status

❑ Change to Cancelled

❑ Reports and Analytics

Some of the above commands, such as Bookmark and Subscribe, are useful with all Agile objects; they are described 
in the Getting Started with Agile PLM.

The commands noted in boldface, above, are discussed in the following sections.

Using Save As to Create a Template 

You can use Save As to duplicate values and other dependencies of existing objects in new objects or templates. 

To create a template:

1 Open the program you want to save as a template. Choose Actions > Save As.

2 Select the components you want to include. 

3 Select Template in the Template drop-down list. Click Finish. 

The General Info tab of the new template appears. 

Note Discussions, action items, and history are not included in the template. 

Once saved as a template, a program does not appear on active program lists. However, documents continue to be 
stored for the program on the Attachments tab. The template is available to create new programs using the Create > 
Program > From Template command. 

Delegating

When you create a program element, you are made its owner by default. The Delegate command enables you to 
change ownership of a program element.

Note An owner of a higher-level program element retains ownership of lower level items reporting to it, even 
when ownership of the lower level is delegated to another team member. 

To delegate ownership of a program, phase, task, deliverable, or gate: 

1 Open the activity you want to assign to a new owner. 

2 Choose Actions > Delegate.

3 Select a new owner from the team list.

4 If the intended new owner is not listed, add him or her to the team at this time by clicking the Add button on the 
Delegate Ownership page, then select the user in the Select Delegate list. 

A red flag icon appears beside the General Info tab link. It remains until the delegated owner has accepted the 
delegation by accepting the request sent to his Notifications & Requests inbox.

If the delegated owner has not yet accepted the delegation, you can use Actions > Delegate to choose a different user as 
the delegated owner. 

Note To cancel the delegation, use Actions | Delegate and select a new owner for the delegation, which cancels the 
current delegation.
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Substituting Resources

You can use the Actions > Substitute Resource command to substitute resources.

You can substitute an existing resource for another resource by selecting from a list of people. The current resource’s 
role is assigned to the substituted resource. 

To substitute one resource for another: 

1 Choose Actions > Substitute Resource. 

2 Select a resource to be replaced in the From Resource drop-down list. The list contains all team members including 
those of child activities. 

3 Click the To Resource field and use the  button to select the To Resource. If you want to substitute the resource 
in all the child activities, select the Apply to Children checkbox.

4 Click the Substitute button.

Changing the Parent

You can change which program a program element reports to. For example, you can change the parent of Gate A, 
so that it reports to Task A instead of Task B, or have Phase A report to Program 2 instead of Program 1. 

To change the parent of an activity: 

1 Open the activity. 

2 Select the Actions > Change Parent command. 

3 Use one of the search options to locate the new parent. 

4 Select the new parent object, and click Change. 

Table 4-10: Delegation process, results and consequences

Action or condition Results or consequences

The program is not active (the Template 
field setting on the General Info tab is not 
equal to Active).

• No delegations are sent to the delegated owners. Delegations are sent only when 
the program General Info tab Template field setting is equal to Active.

A current team member is selected as 
the new owner, but has not yet 
accepted.

• The new owner’s name appears in the Delegated Owner field on the General Info tab.
• A red flag icon appears beside the General Info tab name indicating that the 

program has been delegated, but the delegation has not been accepted.

A user who is not a current team 
member is selected as the new owner, 
but has not yet accepted.

• The new owner’s name appears in the Delegated Owner field on the General Info tab.
• A red flag icon appears beside the General Info tab name indicating that the 

program has been delegated, but the delegation has not been accepted.
• Because the delegation has not yet been accepted, the new owner does not appear 

on the Team tab.

The delegated user accepts the 
delegation in his Notifications & Requests 
inbox.

• The red flag icon beside the General Info tab name is removed.
• If the delegated owner was not a current team member, he is added as a team 

member on the Team tab.
• On the Team tab, the Agile PPM default owner role is automatically added to the 

delegated owner’s assigned roles. By default, the default owner role is the Program 
Manager role, however, your Agile administrator may set a different role. For 
more information, see the Agile PLM Administrator Guide.

The delegated user rejects the 
delegation.

• The red flag icon beside the General Info tab name is removed.
• The Delegated Owner field on the General Info tab is empty.
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Changing the reporting relationship of a program element also changes the rollup status, dates, and progress to those 
of the new parent. 

Archiving Programs

Programs are archived by changing the root-level program’s archive status.

You can change the archive status of a root-level program from the Actions menu. Archiving old data can improve 
system performance.

To change the archive status: 

1 Select a root-level object. 

2 Select Actions > Change Archive Status.

When a program is archived, it is removed from all active program lists and from the program navigation tree. All 
buttons and Actions menu choices are grayed out, except for Actions > Change Archive Status. You can select this option 
again to remove the archive status. The archived program’s data remains searchable.

Cancelling Programs and Their Children

Agile PPM allows you to cancel a program object and automatically cancel all its children by using the Actions > Change 
to Canceled menu command. (An object is canceled when its workflow status is set to Canceled.)

To cancel a program object and its children:

1 Select and open the highest-level program or activity object you wish to cancel.

• If you select the Root Parent object, the entire program tree will be canceled.

• If you select a child object, that object and all its children will be canceled.

Note You cannot use the Actions > Change to Canceled menu selection to cancel a program object that is in 
workflow status Complete.

2 In the Actions menu, choose Change to Canceled.

The Change Status wizard appears.

3 Use the Change Status wizard to specify the list of people who should be notified (click the Notify button) and 
enter a comment in the Comments field. Your comment will appear on the History tab of the current object and all 
its children.

When you are finished, click OK.

The program object and its children are canceled automatically when:

• The program Template field setting is Template or Proposed.

• The program Template field setting is Active and the program object is in workflow status Not Started.

4 If the program Template field setting is Active and: 

• The program workflow status is In Process, 

• Or, one or more of the child objects are in workflow status In Process or Complete,

Agile PLM presents a warning message and asks if you want to continue. Click Yes to continue; the program 
object and its children are cancelled automatically.

You must have the appropriate roles and privileges to cancel program objects. For more information, see the Agile 
Administrator Guide.

Note You can also cancel a leaf object (an object that has no children) by using the Change Status button to change 
the object’s workflow status to Canceled. (See “Change Status Button” on page 4-30.)
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Reports

Use the Actions > Report and Analytics command to view the Program Resource Utilization and Schedule Reports. 

Note The analytics option is available only if you have installed Analytics.

Program Resource Utilization Report

The Program Resource Utilization report provides a chart summarizing Days Effort Utilization including all the 
children of the current object. This report categorizes the Resource % Allocation by resource pools and users who 
are not members of any resource pools as No Pool. All the tasks for which resources have not been fully assigned are 
categorized as Unassigned. 

To print the report, click Print button. 

To export the report, click Export to CSV button. The report will be exported into the comma-separated value format 
(.CSV), which can be opened in Microsoft Excel.

Schedule Reports

The Actions > Report and Analytics > Schedule option opens the Schedule Reports page. Schedule reports provide a complete 
view of the schedule. Values for status and ownership can be selected to apply filters to the list of activities.

You can customize the report by selecting values in the Owner, Status, and Health fields. 

The schedule report has the following fields:

Table 4-11: Program Resource Utilization by Days Effort Report Fields 

Fields Description

Program Name of the activity type such as program or phase.

Owner The owner of the activity.

Scheduled Start/End The schedule start and end dates of the activity.

% Complete The % of the activity completed.

Status The workflow status of the activity.

Report Type Types of report; defaults to Program Utilization report. 

Chart Type Select the type of chart: Non-Graphic, Line, Area, Stacked Area, Bar, Stacked Bar, Stair.

Start/End Dates The start and end dates for duration-based assignments such as phases and tasks. 

Pools Select the resource pools assigned. By default all the existing pools are selected. But you can filter 
the data displayed in the report based by changing the selections. 

Reporting Intervals Report by day or other interval.

Scheduled End The schedule end date of the program

Status Status of the activity from where the report has been run.

Chart Type A drop-down list containing the available chart types.

End Date The scheduled end for the activity. 

Reporting Intervals A drop-down list to select the reporting intervals such as month, day, week, quarter, and year.

Table 4-12: Schedule report fields 

Field Description

Name The number of the program.

Description The schedule description.
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Click the Print button to print the report. 

For descriptions of other reports, see “PPM Reports” on page 2-9.

Change Status Button

The Change Status button lets you change the workflow status of leaf objects (objects that have no children). The status 
of parent objects cannot be changed directly, since it is changed by rolling up the status from leaf-level objects. You 
must have the appropriate privileges; by default, the Program Manager and Program Administrator roles have the 
required privileges. 

The Change Status button is only available for objects whose Template field is Active in the General Info tab. You cannot 
change status of objects whose Template field is Proposed or Template. Changing the Template field must be done at 
the parent level, and child objects are automatically moved to the Template value of the parent.

Note To cancel a program object and automatically cancel all its children, see “Cancelling Programs and Their 
Children” on page 4-28

Owner The program owner.

Schedule Contains information that enables you to quickly track Program progress. Tells you the targeted 
start and finish dates as well as the duration remaining until Program completion. The 
Complete subfield tells you to what percent the Program is complete.

Actual Actual varies from Schedule in so far as you are ahead or behind targeted Program dates. It 
tracks actual time spent on a Program. 

Table 4-12: Schedule report fields  (continued)

Field Description
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CHAPTER 5
The Gantt Chart

This chapter describes the Gantt Chart and tells how to use it to view and modify programs and activities. 
The chapter contains the following sections:
❑ Overview
❑ Activity View
❑ Resource View
❑ Display Settings
❑ Additional Information about Rescheduling Behavior

Overview
The Gantt Chart is a powerful tool for viewing and modifying program, resource and status information. It provides 
a graphical view of program schedules and progress, and tools that let you revise many of the details of activities. 

The Gantt Chart is Java-based, and requires JRE 1.4.2 (Java Runtime Environment) to be installed on your 
computer. This happens automatically the first time you click the Gantt Chart button. 

Note Certain firewalls prevent this automatic download. In this case you can download and install the JRE 1.4.2 
from www.sun.com.

Depending on your roles and privileges, you can perform a number of functions using the Gantt Chart. If you have 
questions about your assigned roles and privileges, contact your Agile administrator. See also Agile PLM 
Administrator Guide.

The Gantt Chart has a menu across the top, a toolbar, graphics, and two major panes: the field pane (on the left) and 
the graphics pane (on the right). You can change the size of the field or graphics pane by dragging the divider 
between them. 

You must create a program before you can view and modify it using the Gantt Chart. 

The Web Client Lock feature prevents changes from being made in the web client when editing in the Gantt Chart. 
For more information about the Lock feature, see “Concurrent Editing of Program Objects” on page 4-23. 

The Gantt Chart tools let you create and remove activities, create or modify dependencies, and modify other data of 
the activities such as duration. 

Important After making changes in the Gantt Chart, you must use the Gantt Chart Update button  if you want to 
save your changes to the database. Update overwrites any changes others may have made while the Gantt 
Chart was open. You must be the program owner to use Update.

To open the Gantt Chart:

Click the Gantt Chart button  on the activity page of a parent or root parent object. 
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Note When you open Gantt Chart, the object is automatically locked and remains locked until you exit 
Gantt Chart. See also “Concurrent Editing of Program Objects” on page 4-23. 

When you start the Gantt Chart, two Java JAR files are downloaded to your computer's temporary folder. Once these 
have been loaded, the Gantt Chart appears. 

Activity View
The Gantt Chart opens on the Activity View, or you can select it by clicking the Activity button at the bottom of the 
window. Both the Activity view and the Resource view contain a field pane on the left and a graphics pane on the 
right. 

The table below describes the icons in the Gantt Chart toolbar.  

Status icons appear next to the program elements:

Not Started—The program has not started. 

Table 5-1: Gantt Chart Toolbar Buttons  

Icon Name Shortcut Keys Description

Update F5 Updates Agile PPM with the additions and changes 
you’ve made in the Gantt Chart. 

Add Activity Shift-A Inserts an activity below the selected activity.

Add Gate Shift-G Inserts a gate below the selected activity.

Create Dependency Alt-C Adds a dependency.

Edit Dependency Shift-E Edits a constraint.

Remove Selected/Delete Delete Deletes the item from the Gantt Chart.

Expand All Ctrl-E Expands all program elements to the lowest-level item 
reporting to the program.

Collapse All Ctrl-Q Collapses all program elements to the highest-level 
item they report to.

Expand/Collapse Activity Ctrl-Enter Expands or collapse all program elements.

Outdent Ctrl-Left Outdents an item, so that a program element no longer 
reports to the higher-level element.

Indent Ctrl-Right Indents an item, making a program element report to 
another item.

Move Up Alt-U Moves an item up the chart within its level. Changes 
the order of the item within the same level. If program 
elements report to the item, these move along with it. 

Move Down Alt-D Moves an item down the chart within its level.  
Changes the order of the item on the Schedule tab.  If 
program elements report to the item, these move along 
with it. 

Zoom In Ctrl-Z Focuses on a smaller section of the graphics pane.

Zoom Out Ctrl-O Focuses on a larger section of graphics pane.

Zoom To Fit Ctrl-F Zooms to show the entire program in the visible area.
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Complete—The program is complete. 

Canceled—The program has been canceled. 

On Track—The program object is on schedule. 

Needs Attention—The program or child objects are 2-5 days overdue.

Off Track—The program or its child objects are more than 5 days overdue. 

Adding an Activity 

To add a program, phase, or task using the Gantt Chart:

1 Click on the row below which you want the new activity to appear. The new activity will be a child of the one 
selected.

2 Click the Add Activity icon. Enter the activity name in the Name field. 

3 Specify the subclass—program, phase or task—and the duration type. 

4 Click the Calendar button in the Start Date field. A pop up calendar appears. Choose the Start Date. 

5 Click in the Duration field, and set the duration in number of days.

The parent program will take on the same Duration as child activities.  If more than one activity exists for the 
program, the program’s duration will be calculated to accommodate the earliest start date and latest end date. 

6 The Due Date is automatically computed by adding the Duration to the Start Date (skipping Saturdays and 
Sundays).

If you need to move the new Phase up or down the Gantt Chart (thereby changing which item it reports to), use the 
Move Up or Move Down buttons on the toolbar. 

You can make an activity a child of another by clicking the Indent button. Similarly, select a child activity and click 
the Outdent button to promote it. 

Note Using Indent and Outdent to change the parent of a child activity has the same effect as using the Agile PPM 
Actions > Change Parent command. For additional information, see “Changing the Parent” on page 4-27.

Deleting Objects in the Gantt Chart and Your Assigned Agile PLM Delete Privileges

You can delete programs, phases or tasks in the Gantt Chart by using the delete function: the  Remove/Delete 
button, the menu selection Edit > Remove, or the keyboard shortcut Ctrl-Delete.

When you update Agile PPM with the changes you have made in the Gantt Chart, Agile PPM checks your assigned 
Delete privileges to ensure that you are allowed to delete programs, phases, or gates in Agile PPM. If you have deleted 
activities in the Gantt Chart that you are not allowed to delete in Agile PPM, none of your Gantt Chart changes are 
written to the Agile database, and you will see an error message telling you that you do not have the appropriate 
privileges.

Note If the update fails because you do not have the appropriate Delete privileges, you will not be able to go back 
to the original program tree in the Gantt Chart. However, you can go back to Agile PPM and start the Gantt 
Chart again.

If you are not able to delete specific types of PPM objects in Agile PPM, you will also not be able to delete them in 
the Gantt Chart and update the Agile database.

Using the Activity View’s Field Pane

The field pane (on the left) displays a list of the activities and selected fields of the activities. 
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❑ You can specify which fields to display in the Table Options dialog (Display Settings > Table > Options). For more 
information, see “Display Settings” on page 5-6.

❑ You can change field values for some items (date fields, duration, predecessor) by double-clicking directly on the 
field. When you double-click the Schedule Start, for example, a calendar appears, enabling you to choose a new 
start date. 

❑ You can change the order of the fields by dragging them to the desired position.

❑ You can change the column width by dragging the margins to the right or left. 

❑ You can change the parent-child structure. Click an activity to select it, and use the arrow buttons in the toolbar 
to move it in the program structure. 

❑ The ID column represents a work breakdown structure. It is a numerical representation of the hierarchy of a 
program. This number dynamically updates based on indent/outdent position, moving an activity up or down, 
and inserting new activities. 

You can change predecessors by clicking in the Predecessor column and entering the ID number of the predecessor 
you want, for example, 1.2. To specify a time buffer, append the number of days you want as lag time or lead 
time. For example, 1.2+3 or 1.2-3.

If the Predecessor and ID columns do not appear, use the menu selection Display Settings > Table > Options select them 
from the Available Columns list. For more information about field settings, see “Display Settings” on page 5-6.

❑ You can open the activity object in Agile by double-clicking it. No changes are made in the Web Client until you 
select Update from the Gantt Chart. Changes in the Web Client are overwritten by Gantt Chart updates. Agile 
automatically locks the program when you begin editing in Gantt Chart.

Note Remember that you must use the Gantt Chart Update feature (either click the Update  button, select 
File > Update, or press F5) to if you want to save any changes you make while using the Gantt Chart.

The Table Display Options

Selecting Display Settings > Table > Options > opens the Table Options dialog box. 

The following fields are found in the Table Options dialog box: 

Using the Activity View’s Graphics Pane 

The graphics pane in the Activity view displays graphic representations of the program elements you have created, 
and enables you to make changes using the menus and toolbar options.   

Duration-based items—programs, phases, and tasks—are represented as bar graphs in the graphic pane, enabling 
you to easily vary the start and due dates, as well as the durations, for these items.

A deliverable or gate is placed on the chart according to its scheduled end date. 

In the graphics pane you can:

❑ Create and change dependencies 

Table 5-2: Table Options fields 

Field Description

Table Categories Select which fields to show in the Field Pane from the Available Columns list, and click the 
arrow to move them to the Selected Columns list. You can use Ctrl+click and Shift+click to select 
multiple columns.

To view only the activity name, use the arrows to move all the fields to the Available Columns 
list so that the Selected Columns list is empty.

Horizontal Click the box in this field to show horizontal lines between each row in the Field Pane.

Vertical Click the box in this field to show vertical lines between each column in the Field Pane.
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❑ Drag bar ends to change start or end date plus duration, or drag the entire bar to change both start and end dates.

❑ Change the labeling on the bars using the options in the Label By menu. 

❑ If you click a bar, a four-headed arrow appears. You can drag the entire task forward or back in the time line while 
maintaining the duration. 

A duration-based item that is in progress is represented by two graphs: one graph to show the scheduled start and 
end dates, and another to show its actual start and actual end dates. The bar representing the (scheduled) Start Date 
and Due Date is located just above the bar representing the Actual Start and Actual Finish.

A duration-based item that has not yet begun is placed in the location that corresponds to its start date. One of the 
two bar graphs for duration-based items in progress is placed on the chart according to its scheduled start date, and 
the other according to its actual start date. 

Viewing Critical Path and Critical Task

You can use View > Show Critical Task or Ctrl+S to view the program’s critical path elements. Critical path helps you to 
plan all activities that directly affect the completion date of a program. Critical Path is determined by identifying all 
the activities that have slack below a pre-determined number of days. 

Critical path activities act as the basis both for preparation of a schedule and for resource planning. They help you 
to see where remedial action needs to be taken to get a program back on track. Critical path can be viewed at root, 
phase or any parent level.

To see critical tasks, use View > Show Critical Task or Ctrl+T. The critical task is the current activity on the critical path. 

Changing Duration 

The task duration can be seen in the Duration column of the field pane. 

To change the scheduled duration of an item from the graphics pane:

Click the beginning or end of the bar graph for the item so the selection boxes appear, and drag to expand it or 
reduce it. 

The Scheduled Start and Scheduled End Dates for the item in the field pane are changed accordingly. 

Creating a Dependency

You can create a dependency between items by drawing links between them on the Graphics Pane. Dependencies are 
always Finish to Start (FS). 

To create a dependency:

1 From the toolbar click the Create Dependency button. 

2 In the chart view, place the cursor on the small box at the right end (end date) of the predecessor item bar. Click 
once. 

3 Position the cursor over the start end of the successor item bar. When the small box appears, click to establish 
the dependency. 

Note You cannot establish dependencies between items that have a parent-child relationship. 

Defining dependencies on a parent task is not an Agile PPM Best Practice. Dependencies should be 
modeled at the leaf-level tasks, not at the parent level. A parent and its child should not have the same 
dependency.

Editing a Dependency

You can create a Time Buffer (also commonly referred to as slack or lag and lead time) between the completion of 
one activity and the start of a successor by editing the dependency. 
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To add a time buffer to a dependency: 

1 Click in the graphics pane on the blue line representing the dependency between two activities.

2 Click the Edit Dependency button . 

3 In the Edit Dependency dialog box that appears, enter the number of days of slack time you want, or modify the 
existing value as desired. 

You may enter a positive or negative number, for example, 3 or -3.

The value you enter appears in the Time Buffer field on the object’s Dependencies tab in PPM. 

A lag or lead time can also be entered in Predecessor column of the Gantt Chart Activity View’s field pane. See “Using 
the Activity View’s Field Pane” on page 5-3.

A lag or lead can also be entered in the Web Client on the object’s Dependencies tab. When you next open the Gantt 
Chart you need to select Edit > Reschedule to change the dependent activity's start date based on the lag or lead time. 

Resource View
Click the Resource button at the bottom to open the Resource view. This view provides a listing of all resources used 
in the activities, and their task loading. 

❑ If you rest the mouse pointer over the utilization graph in the lower part of the graphics pane, a tool tip appears 
showing you the resource name and utilization information. 

❑ You can select one or more resources in the field pane on the left and view the resource loading in the lower 
graphics window.

Display Settings
You can use the Display Settings menus to change the overall appearance of the Gantt Chart window, select the label 
on each bar of the bar graphs, customize the display grids, and select table display options. 

You can save your settings and they will be used the next time you open the Gantt Chart.

Additional Information about Rescheduling Behavior
On the Agile Support web site, you will find a detailed white paper explaining the task rescheduling behaviors in 
Agile PLM 9.2.1.1 (and later releases) with business use case examples. See:

http://support.agilesoft.com/products/plm921/white_papers/9211_task_reschedule.pdf

Table 5-3: Display Settings menu selections

Display Settings menu Description

Display Settings > Appearance Change the overall appearance of the Gantt Chart window. The choices are Metal, CDE/Motif, 
and Windows.

Display Settings > Chart > 
Grids

Customize the display grids (Vertical, Weekend, Horizontal), including grid colors and row 
colors.

Display Settings > Chart > 
Display Labels

Change the labeling for each bar of the bar graphs: Name, Start Date, End Date, Status, or 
Resource.

Display Settings > Table > 
Options

Select the columns to display in the table of the Activity View’s field pane. For more information, 
see “The Table Display Options” on page 5-4.

Display Settings > Table > 
Save Settings

Saves all the table settings including: visible columns, column order, column widths, row 
heights, table grid lines (on or off) and frame size (table and chart widths) for both the Activities 
and Resources tables. 

The saved display settings are used each time you open the Gantt Chart.
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CHAPTER 6
Working with Microsoft Project

This chapter contains information about how to use or reuse existing Microsoft Project files within Agile 
Product Portfolio Management. It includes the following sections:
❑ Before You Begin
❑ Working with Imported Microsoft Project Files (Project 2002 and 2003)
❑ Microsoft Project Troubleshooting Tips

Agile Product Portfolio Management enables you to:

❑ integrate schedule and resource information created with Microsoft Project 2002 and Microsoft Project 2003, 
with an Agile system

❑ manipulate an Agile PPM program in Microsoft Project, publishing the changes back to PPM

Note Certain complex dependency and constraint types supported in Microsoft Project are not yet supported 
in Agile PPM. For further information see “Microsoft Project Troubleshooting Tips,” at the end of this 
chapter.

If you use Microsoft Project 2002 or 2003, this chapter describes how to import your project file to Agile PPM, and 
continue managing your project from there.

For detailed information about how Agile works with Microsoft Project files, see the Agile 9 Import Export Guide.

Before You Begin
❑ Make sure all your Microsoft Project team members exist in the Agile database

❑ Note any activity dependencies that are not set up as Finish-to-Start. 

Note Non-PPM dependency types, such as Start-to-Start and Finish-to-Finish, are not supported in PPM will 
be unlinked during conversion

❑ If your work site has previously used PPM 8.5 or 9.0, uninstall the 8.5 or 9.0 macros. 

To uninstall the Agile PPM 8.5 or 9.0 macros:

1 Open Microsoft Project

2 Select Tools > Organizer > Modules.

3 Open Global.mpt and delete the Get File and XML macros.
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Working with Imported Microsoft Project Files (Project 2002 and 2003)
Note In Agile PLM 9.2.1, integration with Microsoft Project 98 and 2000 project files is not supported. If you 

have Microsoft Project 98 or 2000 project files with which you would like to work, open them in Microsoft 
Project 2002 or 2003 to automatically convert the project files to the appropriate format. For more 
information, select Help > Microsoft Project Help in the Microsoft Project menu.

1. Setting up your desktop client for use with Microsoft Project

To install the plug-in:

1 Choose Tools > Microsoft Project Synchronization Setup.

2 Agile displays a warning-security message. Click Yes.

3 Close the Setup window.

4 Do one of the following:

Open Microsoft Project. and make sure the Agile Menu appears on the menu bar.

OR

Click the Microsoft Project button from any Agile program, then select Launch in Microsoft Project. This starts Microsoft 
Project and installs the Agile menu.

Figure 6-1: Agile Menu item on the Microsoft Project menu

2. Creating a program in PPM from an existing Microsoft Projectfile

You can use an existing Microsoft Project plan with only one Level 1 task, as the basis for an Agile PPM project 
object. (All tasks must be rolled up under a single project; PPM transforms that project into the root program 
object.)

To create an Agile PPM program from an existing Microsoft Project 2002 or 2003 file:

1 Open the target file in Microsoft Project.

2 Choose Agile > Publish to PPM.

The Agile PLM Publish page appears.

Alternately, you can save the Microsoft project file as an .xml file to use the .xml file to publish the project.

To create an Agile PPM program from an existing Microsoft Project 2002 or 2003 file saved as an .xml file:

1 Open the target file in Microsoft Project.

2 In the Microsoft Project menu, select File > Save As to save the project file as an .xml file.

3 Move to the Agile Tools menu and select Tools > Microsoft Project Publish. 

4 Navigate to the Microsoft Project .xml file you want to publish.

5 Click Next.

Launching a PPM Project in Microsoft Project

Depending on your assigned privileges, you can launch a PPM project in Microsoft Project in two modes:

❑ Launch as Read Only
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When you launch a PPM project in Microsoft Project using Launch as Read Only, it allows you to view, print, or 
analyze a PPM project in Microsoft Project without altering the project data in Agile PPM. In Microsoft Project 
you can perform any edit, modification, or analysis actions you choose. You can save the Microsoft Project file 
in any local or network directory to which you have access. 

However, you cannot publish the launched-as-read-only program back into Agile PPM. When you launch as 
read-only, the PPM project is not locked, the Lock User field remains empty, and the Schedule Editor field remains 
set to PPM. (For more information about these General Info tab fields, see Table 4-3 on page  4-7.) It is therefore 
possible for a another user to modify the PPM project by using any of the available Agile PPM edit methods: edit 
in PPM, edit in Microsoft Project (Launch in Edit Mode), or edit in Gantt Chart.

The Microsoft Project file that you create when you use Launch as Read Only is not updated or affected by any 
subsequent edits or modifications made to the PPM program file.

❑ Launch in Edit Mode

When you launch a PPM project in Microsoft Project using Launch in Edit Mode, the PPM program is automatically 
locked so that no other user can modify it. Your name appears in the Lock User field, and the Schedule Editor field is 
set to Microsoft Project. (For more information about these General Info tab fields, see Table 4-3 on page  4-7.)

You are able to publish the launched-in-edit-mode program back into Agile PPM.

For more information about locking programs, see “Multiple Users Editing the Same Task” on page 4-24.

To Launch a Product Portfolio Management project into Microsoft Project:

1 On the PPM program object, choose Microsoft Project > Launch as Read Only or choose Microsoft Project > Launch in Edit 
Mode. 

Microsoft Project opens.

2 Specify that the file should be launched As a New Project.

3 Click Finish.

Microsoft Project Troubleshooting Tips
If Microsoft Project sync does not work, you may want to reinstall the Agile PPM menu. To do so, you need to 
manually remove the pre-existing Agile menu by doing the following:

To see list of active COM add-ins for Microsoft Project:

1 Click on Tools > Customize > Toolbars. The “Customize” window will pop up.

2 Go to “Commands” tab.

3 From the left list, select Tools.

4 Locate “COM Add-Ins” in the right-hand-side list.

5 Drag and drop “COM Add-Ins” from the list onto the menu-bar.

6 “Close” the customize window.

7 Click the COM Add-Ins menu just added. A list of all installed add-ins will be shown.

To manually uninstall a COM Add-In from Microsoft Project:

1 Follow steps above to see list of COM Add-Ins.

2 Select the add-in you wish to uninstall.

3 Click the Remove button to uninstall the selected add-in.

Other things that might cause difficulty with integration:

❑ Split task resource assignments
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❑ Use of actual dates vs. scheduled dates

❑ Customized calendars and working days

❑ Non-PPM dependency types such as Start-to-Start and Finish-to-Finish, and Constraint types such as Must 
Finish on are not maintained in the Agile system after you Publish from Microsoft Project. Therefore, launching 
the plan back into Microsoft Project will result in different dates then the initial Microsoft Project plan.

❑ Microsoft Project allows duration to be entered in hours. PPM uses days as the lowest unit of time. Therefore, 
accuracy issues are compounded with heavy usage of tasks that are less than one day's duration.

❑ The Agile PPM project name must be at outline level one in Microsoft Project. All Agile PPM subtasks, phases, 
and gates must be indented under level one in Microsoft Project.

Note Microsoft Project outline numbers are not imported into Agile PPM.

Deleting Objects in Microsoft Project and Your Assigned Agile PLM Delete Privileges

You can delete programs, phases or tasks in Microsoft Project by using the Microsoft Project features.

When you update Agile PPM with the changes you have made in Microsoft Project, Agile PPM checks your assigned 
Delete privileges to ensure that you are allowed to delete programs, phases, or gates in Agile PPM. If you have deleted 
activities in Microsoft Project that you are not allowed to delete in Agile PPM, none of your Microsoft Project 
changes are written to the Agile database, and you will see an error message telling you that you do not have the 
appropriate privileges.

Note If the publish to PPM fails because you do not have the appropriate Delete privileges, you will not be able 
to go back to the original program tree in Microsoft Project. However, you can go back to Agile PPM and 
launch Microsoft Project again.

If you are not able to delete specific types of PPM objects in Agile PPM, you will also not be able to delete them in 
Microsoft Project and update the Agile database.

Transferring Microsoft Project Work Values to Agile PPM as Days Effort

In Agile PPM, days effort is always calculated based on the % allocation and duration. Agile PPM requires an 
allocation to a resource or resource pool in order for days effort to be populated. To handle the publishing of tasks 
from Microsoft Project where work values are entered, your Agile administrator can set up and define a generic 
resource pool to hold the work/days effort values. If your Agile administrator has defined the generic resource pool, 
you will notice that tasks which satisfy these conditions have a generic resource pool associated to them on the Team 
tab.

For information about how to define the generic resource pool, see the chapter about Product Portfolio 
Management settings in Agile PLM Administrator Guide.
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CHAPTER 7
Program Costing

This chapter contains information about performing Program Costing tasks. It contains the following 
sections:
❑ Rollups
❑ Labor Costs
❑ Program Activities Table Changes
❑ Cost Status
❑ Costs Included in Baselines

Rollups
By default, cost information for each field will be rolled up through the project structure such that a summary or 
parent task is a summation of the values of its child objects. There are flags (not visible by default) that can be enabled 
to allow users to determine whether or not they want the parent/summary task's values to be calculated/rolled up or 
edited manually.

As you can see in the example below, if a cost is associated with the leaf node it gets added to the parent node. This 
way the total cost of the entire Program can be obtained.

Program

Phase 1

Phase 3

Phase 2

Task 1

Task 2

Total Cost = $25 + $30 + $15 = $7

Cost = $25

Cost = $20 + $10 = $30

Cost = $20

Cost = $10

Cost = $15
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In the above diagram it can be noticed that Phase 2’s cost is $30. In the case shown above, the cost represents the sum 
of the costs of its children. The provision to edit Cost at the parent node level phase 2 is possible but not shown above.

Both the ways of calculating Cost are provided. 

How Total Cost is Determined

Total Cost fields that appear on the General Info tab are calculated values and cannot be edited. Total Cost is the sum 
of the four cost types: Labor Cost, Capital Expenses, Fixed Cost and Flex Cost. 

For example, Total Actual Cost is the sum of:

Actual Labor Cost

Actual Capital Expenses

Actual Fixed Cost

Actual Flex Cost

In the same manner, Total Estimated Cost is the sum of Estimated Labor Cost, Estimated Capital Expenses, 
Estimated Fixed Cost, and Estimated Flex Cost. Total Budgeted Cost is the sum of Budgeted Labor Cost, Budgeted 
Capital Expenses, Budgeted Fixed Cost, and Budgeted Flex Cost.

Labor Costs
Actual and Budgeted Labor costs are automatically calculated. Budgeted Labor Cost uses scheduled duration, % 
allocation, and the users' resource pool rate, and man hours (8 hours per day) to calculate a labor cost per resource 
assignment. These are summed for multiple resources assigned to an activity. If an activity has a resource assigned, 
and has lower-level objects with Labor costs, then it is summed at the parent level and not replaced. Budgeted and 
Actual Labor Costs are always calculated in this way. However, Estimated Labor Cost can be editable at all levels. If 
not edited, it will be rolled up by default. Capital and Fixed Costs (Actual, Budgeted and Estimated) can be both 
rolled up as well as edited values, depending on whether the Agile administrator has enabled the Calculate/Roll-up 
flag on each cost field. 

Budgeted Labor costs for effort-driven projects are calculated using the correct days effort, for example, 2.971234. 
For readability, the days effort number is truncated in the Agile PPM display to include only the first two decimal 
places: 2.97. However, the cost values are correctly calculated using the entire number (2.971234). 

Note If a Resource is not assigned to a Resource Pool, the user’s individual Labor Rate is used.

Program Activities Table Changes
A revised Program Activities table displays all the Assignments (entries in the Team tab with a % allocation > 0) for 
the currently logged in user as well as all the leaf node activities and gates that user owns. This allows the user to enter 
actual hours, status, and % complete information. Time information is maintained in the Actual Hours attribute of 
the Team tab.

Cost Status
The cost status is calculated based on the %deviation (Percentage property) defined in the cost status node in Agile 
Administrator, under System Settings->Product Portfolio Management. For information about Agile system settings, see 
Agile PLM Administrator Guide.
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Costs Included in Baselines 
All Cost fields are part of the baseline. The cost fields are Labor Cost, Capital Expenses, Fixed Cost and Flex Cost. 
Each of these costs have Actual, Budgeted and Estimated categories. There are 12 cost fields in total. Ten Calculate 
flags are also baselined. Budgeted and Actual Labor costs do not have the calculate/roll-up flags as they are always 
calculated and rolled up.

Use the Baseline Comparison Report in the Agile Standard Reports to compare these values.
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APPENDIX A
Agile e5.1 Integration

This appendix discusses the integration of Agile with an Agile e5.1 system. The subjects discussed include:
❑ Adding Agile e5.1 Objects as Deliverables
❑ Modifying the Trigger Event and Result
❑ Updating a Program to Agile e5.1
❑ Modifying Objects in Agile e5.1
❑ Other Information

Objects in Agile e5.1 can be added to Agile PPM activities and gates as deliverables. This capability enables a change 
of state in an Agile e5.1 object to trigger a change in workflow status of an Agile object. You can also copy Agile 
programs to Agile e5.1 as new projects, duplicate deliverables into Agile e5.1, and launch the Agile e5.1 object in the 
Agile e5.1 web client directly from Agile PPM. 

Adding Agile e5.1 Objects as Deliverables
Once the Agile e5.1 connection has been established, you can add Agile e5.1 objects as deliverables to a PPM activity 
such as a program or task. 

To add Agile e5.1 objects to a PPM activity:

1 Go to the Deliverables tab of a PPM object. 

2 Click the Add button

3 In the Add Related Content wizard, use the search options under Search From Existing Agile e5.1 Entities to locate the 
objects you want. Or you can choose Create New Object to create a new Agile e5.1 object. In the search results, 
select all objects you want to add as deliverables.

4 In the Information wizard step, specify the Event and Result, if desired. 

Event is a target status in the Agile e5.1 deliverable, and Result is a resulting change of the Agile object’s workflow 
status triggered by the status change of the Agile e5.1 deliverable. The trigger of the Agile program object occurs 
when the current Agile e5.1 object status is greater than or equal to the Event status.

5 Click Add More if you want to add other Agile e5.1 objects, or click Finish. 

Modifying the Trigger Event and Result
Once the Agile e5.1 entity has been added, the status-change trigger and result can be changed by selecting the object 
on the Deliverables tab and clicking Edit. 
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To change the trigger event and result:

1 Go to the Deliverables tab of the activity.

2 Check one or more deliverables you want to modify. Click Edit.

3 For each object, select the triggering event in the Event drop-down list, and select the resulting workflow status in 
the Result drop-down list.

4 Click the Save button to save the changes in Agile PPM. 

Updating a Program to Agile e5.1
Once you have created a program in PPM, you can send the program structure, deliverables, links and roles on the 
Team tab to the Agile e5.1 system as a new Agile e5.1 project. 

 You can copy this PPM program structure into Agile e5.1 from the Agile PPM root program. A flag is set at each 
Agile object to indicate whether or not it will be updated to Agile e5.1.

Users who have access to the program in PPM are given access to the corresponding objects in Agile e5.1 through a 
role mapping that is set up by the administrator. Users must also have the necessary permissions to log into the Agile 
e5.1 web client.

To update the Agile e5.1 database with an Agile program:

1 Open the program. 

2 Verify that the Update to Agile e5.1 field on the General Info tab is set to Yes for all levels of the hierarchy that you want 
to copy into Agile e5.1 as Agile e5.1 project objects. If it is not, click the Edit button, and set the field to Yes. 

3 From the Actions menu, choose Update Program to Agile e5.1. 

4 Select the Agile e5.1 project that you want to copy the PPM program into. The new Agile e5.1 project will be 
placed within the selected project. 

5 Select options to copy the deliverables, links, and roles of team members to Agile e5.1. 

You now can view the new project in Agile e5.1. You can select the In Projects tab within the Agile e5.1 web client to 
see the higher level project that was selected.

Within Agile PPM, the root level program will now appear on the Links tab, enabling you to navigate directly to this 
project in Agile e5.1.

Modifying Objects in Agile e5.1
Agile e5.1 objects that appear on the Deliverables tab can be modified in the Agile e5.1 web client. 

Note Users must have the necessary permission to log into the Agile e5.1 web client in order to add deliverables 
and links.

To modify an Agile e5.1 object on the Deliverables tab:

Click the object name in the Deliverables table. 

You will see a page that says “Connecting to Agile e5.1.” Then the object opens in the Agile e5.1 web client, without 
the need for a separate login. If a change is made to the status of the object in Agile e5.1 to promote it to its event or 
target status, then the activity in Agile PPM will be updated upon refreshing.

For information about modifying the object, refer to the Agile e5.1 web client documentation. 

Other Information
Some other information about the integration between Agile PPM and Agile e5.1:
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❑ A new user or user group added to the Agile e5.1 system is updated to Agile PPM during a periodic resource sync 
process. These users/user groups are not available for adding as resources in PPM immediately, but they are 
available after the next periodic system resource sync. Users in Agile e5.1 that have person information, including 
first name, last name, and email, are automatically copied to the Agile PPM user list.

❑ User Groups that have an owner and department are automatically populated as Resource Pools within Agile 
PPM. The manager attribute specifies the owner of the resource pool in PPM.
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APPENDIX B
Creating Programs:

A “Real World” Example
This appendix describes how to set up a simple program in Agile PPM.
❑ 1. Creating the Root-level Program Object
❑ 2. Creating the Schedule (program-related objects)
❑ 3. Creating a Gate
❑ Starting the Program

Excalibur Designs Corporation has been contracted to create, test, and implement a prototype electric “clown car” 
-- a car that appears quite small, but hold a surprisingly large number of people.

Their program manager structures the program in Agile PPM as follows:

1. Creating the Root-level Program Object
a Launch Agile Web Client.

b From the Create menu on the main toolbar, select Programs > New. The Activity Creation wizard appears.

c Select Program as the Activity Type, and fill in the necessary details.

The program manager specifies the following:

Program object field Setting

Activities Type Program

Name RoboClown V 0.1

Schedule Start Date 03/01/2005

Schedule Duration 154 (days automatically calculated when Schedule End Date is specified)

Schedule End Date 09/30/2005

Description Design and implement prototype electric clown car.

Project milestones to include: obtain requirements, create proposal, write specifications, 
build prototype.

Delegated Owner

Activity State Proposed

Duration Type Fixed

Days Effort

Resource Pool Mechanical Eng
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d Click Continue. The Activity Creation wizard displays the project cover page.

At this point, most of the cover page is not filled in. Other sections below the Activity Information heading 
draw information from child objects of this program, and cannot be populated until information can be 
compiled and rolled up. These sections are:

Status Information — the Status is set to “Not Started”

Project Information — No information yet on Technical Feasibility, revenue Forecast, Market Opportunity, 
MNPV, or Strategic Fit. (At Excalibur Designs Corporation, the Agile administrator has defined this 
optional General Info tab section.)

e Click Finish. RoboClown is now present in the Agile database.

2. Creating the Schedule (program-related objects)
The program manager promises, in her description, that the program will contain the following project deliverables, 
each requiring a duration to complete:

❑ Obtain requirements (14 days)

❑ Create proposal (15 days)

❑ Write specifications (110 days)

❑ Build prototype (110 days)

Each deliverable becomes a phase in this program.

To add phases:

a Select RoboClown’s Schedule tab.

b Choose Add to add an activity to the schedule. PPM displays the Add Activity wizard.

c Specify Phase as the activity type, then create each phase in turn. Order the phases in such a way that the next 
phase does not start until the previous phase is completed. (Once the actual project starts this ordering may 
turn out not to be realistic, but we can adjust dates later.)

Note The program manager is the default owner of all phases. To change ownership of a phase to another 
Team Member, delegate ownership during phase creation.

Given a start date of March 1, and the expected duration of each phase, the phases are scheduled to start as follows:

Obtain Requirements: March1 - March 18

Create Proposal: March 21 - April 8

Write Specifications: April 11 - April 29

Build Prototype: May 23 - September 30

Add me as Resource [selected]

% Allocation 100

Program object field Setting
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Within three of the phases are various tasks. The Program Manager adds preliminary tasks to each phase as follows:

To add tasks to each phase:

a Open the phase object.

b Click the Schedule tab.

c Choose Add to add an activity to the schedule. PPM displays the Add Activity wizard.

d Specify Task as the activity type, then create each task in turn.

3. Creating a Gate
It is mandatory that RoboClown pass the Acceptance test before a demonstration can be schedule. There is a short 
period of time open between the end of Acceptance test and the demonstration; that period can be used to 
accommodate a “gate” for the project.

To create a gate on “Acceptance test:”

a Go to the Acceptance test task.

b Select the Schedule tab.

c Choose Add and specify Gate as the object type. The Add Activity wizard appears.

d Fill in the information for the gate.

e Click Finish. The General Info tab of the new gate appears.

Once the gate is created, the Program Manager clicks Approval Items. She adds this gate as an activity that needs to be 
monitored during a gate review.

Phase Task Dates

Create Proposal Preliminary draft Mar 21-25

Core Executive review Mar 28-29

Incorporate comments, expand Mar 30-Apr 1

Final review Apr 4-7

Produce and distribute Apr 8

Write Specifications Assign team members Apr 11-12

Preliminary draft Apr11-22

Engineering review Apr25-28

Incorporate comments, polish Apr 27-29

Build Prototype Fabrication May 2-27

Initial test (lab) May 31-Jun7

Refine design June 8-July1

Track test July 5-8

Optimization and tuning July11-Aug5

Road test Aug 8-19

Acceptance test Aug 22-Sept 22

DEMONSTRATION Sept 26
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Starting the Program
Starting a program, that is, moving it out of the Not Started status, involves two actions:

❑ On the root parent activity, the program, edit the General Info tab, and change the Template field setting from 
Proposed to Active. (You cannot change the workflow status of Proposed or Template programs.)

When the root parent activity is changed to Active, the Active setting rolls down to all children activities.

❑ To change the workflow status of the root parent (program) activity from Not Started to In Process, open a leaf-
level activity and click its Workflow tab. Change the status of the leaf activity to In Process.

The workflow status change rolls up to the root parent activity, changing the workflow status of the program to 
In Process.
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APPENDIX C
Installation Notes

This appendix provides notes for installation.
❑ Product Portfolio Management User Licenses
❑ Configuration

Product Portfolio Management User Licenses
The PPM server license is required with a predetermined number of concurrent and power user licenses. Users are 
assigned as either a concurrent or power user by the Agile administrator using the Java Client.

Once the PPM system is activated and users are designated as concurrent or power, the Agile administrator assigns 
roles that govern system-level access and functionality. For example, a user must typically be assigned a system-level 
Program Manager role to be able to Create new programs from the Create menu.

However, on specific programs, an owner of a task or program can add users to the team and assign an object-specific 
role. The potential roles that are assigned are all the roles related to the program object, not just the system-level roles 
defined for that user by the Agile administrator.

For more details on licenses, see the Agile PLM Administrator Guide.

Configuration
❑ For Japanese and Chinese OS, an Agile PPM database instance can only be configured to use UTF-8 language 

encoding. Agile PPM sets the browser’s character encoding to UTF-8, and it is not recommended to change the 
character encoding setting in the browser.

❑ The Agile PPM Gantt application requires the International JRE (Java Runtime Environment) on client systems. 
The Japanese and Chinese JRE version are not supported.
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