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Lab 08 – Working offline with i Projects 
 

Overview 
 
In this module, you learn how to use the i Projects perspective in a typical development cycle for offline 
application development. 
 
When you do i Project based development you will want to work in the i Projects perspective.  This 
perspective serves two main purposes, namely for performing IBM i offline development on Windows® 
and Linux clients and for enabling team development. 
 
Offline development allows for a disconnected mode of development where a live connection to a host is 
only required when source code updates or compiles on the IBM server are needed.  Team development is 
needed when code changes need to be shared between a team of developers and synchronization of these 
changes is needed as part of the development cycle.  Team Development with sharing source is not 
covered in this tutorial.  However there is a hands-on Lab available that shows how to use i Projects with 
Rational Team Concert for IBM i in a Team development environment. 
 
Typically, when using i Projects, you create local source physical files and members and edit them on 
your workstation.  You can also download existing members from any remote library into your project. 
Once done with the local editing, you can submit a build that will push all your changes to the associated 
library of the i Project and perform a build on the remote members.  The code pushed to this scratch 
library is only pushed there for the purpose of performing that build.  If source code management is 
needed, the i Project could be associated with any Team management tool provider preferable Rational 
Team Concert for IBM i. 
 
This Lab is divided into 2 parts:  
• The first part describes how to use i Projects in a casual way to get development work done offline.  

For example, take your work home over the weekend and then push the changes back onto the IBM i 
server on Monday morning, or maybe working on the train. 

• The second part describes how to use i Projects for your regular development. Where your developers 
will create and maintain code on their individual workstations.  The source code will only be pushed 
onto the IBM i server for compiles.  If you work in a team, you will most likely use this form of 
development in a managed team environment for example using RTCi. 

Learning objectives 
 
• Make source available for offline or disconnected development 
• Edit and verify source in disconnected mode 
• Compile a changed member 
• Create a new i Project and populate with new source physical files and members 
• Show remote objects or local objects or both 
• Submit a build for the entire i Project. 
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Skill level and prerequisites 
 
Introductory. 
 

 

Important! 
 
You should complete RDi Lab01 ‘Getting started’ before you work on this lab.  Lab01 
contains the following information and instructions: 

• Which IBM i server to connect to 
• Which User ID to use 
• How to start RDi, create a connection and connect 
• How to setup the correct library list for this lab 

 
Knowledge of basic Microsoft Windows operations such as working with the desktop, mouse operations 
such as opening folders and drag-and-drop is assumed.  It will also be helpful if you understand DDS and 
ILE RPG. 



IBM Software 

Page 6 IBM Rational Developer for i Sandbox – RDi Lab 08 – Working offline 

Conventions used in this workbook 
 
Bold font   is used to highlight user interface controls 
Mono-spaced font is used for user input text and code blocks 
Italic font   is used for variable names and glossary terms 
 
The following icons are also used to identify categories of information: 
 

Icon Purpose Explanation 

 
Important! 

This symbol calls attention to a particular step or command. 
For example, it might alert you to type a command carefully 
because it is case sensitive. 

 
Information This symbol indicates information that might not be necessary 

to complete a step, but is helpful or good to know. 

 

Trouble-
shooting 

This symbol indicates that you can fix a specific problem by 
completing the associated troubleshooting information. 

 

Client System requirements 
 
The labs require IBM Rational Developer for IBM i (RDi) to be installed on your workstation. If you do 
not yet have this, you can download it for free from http://ibm.biz/rdi_trial. As of version 9.5, RDi 
includes a built-in emulator so you will not need any additional software. If you are using a previous 
version, then any 5250 emulator will work.  The IBM i Access Client Solutions contains a best of breed 
emulator that is freely available to those who have an IBM i that is V6R1 or later. 
 

Host System requirements 
 
The easiest way to ensure you have everything you need, is to use the EM Sandbox demonstration IBM i 
server that is set up and ready to use with these lab exercises.   

 

Tip 
If this is not an instructor led class with PC's provided, you may need to install and setup the 
IBM software on your PC first. 
 
120 day Trial of Rational Developer for i can be downloaded here: 
http://ibm.biz/rdi_trial 
Page to request userid for IBM i demonstration system: 
http://ibm.biz/rdi_labs_getuserid 

The picture can't be displayed.



IBM Software 

IBM Rational Developer for i Sandbox – RDi Lab 08 – Working offline Page 7 

1 Using i Projects for working offline 
 
In this module, you will: 
• Download selected files or members to your workstation. 
• Verify downloaded source. 
• Launch the editor on a local source member in an i Project. 
• Create a new i Project for working local on your workstation. 
• Edit a local source member in i Project. 
• Work with local source members using the i Project Navigator 
• Verify changed source members locally. 
• Push a source member to the IBM i sever and compile it 

 

1.1 Making source available offline 
 
You want to edit and verify your source on a workstation, disconnected from an IBM i server, you will 
need to download the source to the workstation.  You will need to store the source in an i Project.  After a 
successful download you will be able to work offline with the source.  
 
Since you don't have an existing i Project, the easiest is to use the Make Available Offline option in the 
RSE. 
 
The Make Available Offline option downloads the selected files or members locally to their 
corresponding i Project.  The corresponding i Project that gets created uses the connection's host and 
library names of the selected source physical files in the RSE view.  If such an i Project is not found, one 
will automatically be created. 
 
To make source available offline, in the RSE view, using the connection you created before in Lab 01: 
__1.  In the library list, expand your RSELABxx library. It contains the source files that you want to 

work with offline. 
__2.  Select the source physical files QDDSSRC and QRPGLESRC as you want the members in 

these source files to be made available for offline development. You can use the Control key to 
make multiple selections. 
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__3.  Right-click and select Make Available offline on the pop-up menu. 
 

 
 
The Download to i Projects dialog opens. 

__4.  Click the Yes button to proceed. 
 

 
 
The i Projects perspective opens with your new i Project named IBM i Test 
System_RSELABxx. 
IBM i Test System being the connection name and RSELABxx the library containing the 
objects to be downloaded. 
 
 

 

Troubleshooting 
If the i Projects perspective does not open automatically, click Window > Open 
Perspective > iProjects. 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be 
displayed.
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This project IBM i Test System_RSELABxx is created for you automatically and the source 
files QDDSSRC and QRPGLESRC are added to this project. 
 

 
 
 

 

Tip: 
 If you want to add more source files later to this i Project, you can use the Make 
Available Offline option again. 

 
 

1.2 Caching reference data 
 
You need to verify that you have the latest cached reference data available before you begin to work 
offline.  You need cached external data descriptions of files used in the RPG program.  That allows, even 
offline without a connection to an IBM i system, to run verifies for programs that contain external 
described files. 
 
__1.  In the i Projects view, expand QRPGLESRC. 
__2.  Double-click PAYROLLG to open this source in the source editor. 

The picture can't be displayed.

The picture can't be 
displayed.
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__3.  Click anywhere in the editor to give it focus and click Verify on the workbench menu. 
 

 
 
This action will check your member for syntax and semantic errors and any errors will appear in 
the Error List view and it caches all information required into the local workspace for 
subsequent offline verifies. 
 

 

Tip: As you are now in i Projects perspective your Remote Systems pane is 
now to the bottom left corner of your Workbench. You can easily switch 
perspectives with Window / Open Perspective if you need to. 
 

 
Now you are ready to disconnect from the IBM i server. 
 

The picture can't be displayed.

The picture can't be 
displayed.
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__4.  From the Remote Systems view, look below the i Project Navigator pane for the RSE pane, right-
click on the connection and click Disconnect. 
 
This action disconnects the session from the IBM i server. 
 

 
 
 

 

Tip: 
You can also put an entire IBM i connection, and all the contents defined with 

that connection, into offline mode by right-clicking the connection and clicking 

Work Offline on the pop-up menu.  This method of working offline prevents the 

Remote System Explorer from attempting to connect to the IBM i server if a 

request is made for remote information.  For example, if you are verifying a local 

source file or member in an i Project, the project would attempt to connect to the 

server if the required information was not available in the cache.  This can be 

prevented by switching the connection to offline mode. 

 
You have downloaded selected files or members to your workstation, verified downloaded 
source to cache reference data, and put an IBM i connection into offline mode. 

 

1.3 Editing local source members in disconnected mode 
 
In this lesson, you learn how to edit the member PAYROLLG, save that member, and display an outline 
of that member, all disconnected from an IBM i server.  You also learn how to open a local copy of the 
DDS source member MSTDSP in the Screen Designer.  

The picture can't be displayed.

The picture can't be 
displayed.



IBM Software 

Page 12 IBM Rational Developer for i Sandbox – RDi Lab 08 – Working offline 

Editing local source members in i Projects is the same as editing remote source members in the Remote 
System Explorer.  The LPEX Editor can be launched on any local member and the same functionality is 
available, such as the Outline view, prompter and the content assist feature. 
 
There is one major difference though when editing source members using the LPEX Editor in the Remote 
System Explorer perspective as opposed to using the LPEX Editor in the i Projects perspective.  
• When a source member is opened with the editor in the Remote System Explorer perspective, it is 

locked, and it cannot be modified on the host while the local edit session is active.  Any code changes 
that you make locally will be saved to the host when the Save action is performed. 

• On the other hand, when a member is opened with the LPEX Editor in the i Projects perspective, the 
member is not locked on the host.  It can be modified by anyone with enough authority to the object.  If 
you do a Refresh on the i Project, a double-sided red arrow will indicate that the member has been 
modified on the host.  When you push changes back to the host, (something you will do when you are 
connected again), you will be warned that you will be overwriting remote changes, and you are given 
the chance to cancel the operation. 

 
To edit local source members in disconnected mode: 
In the i Project perspective: 
__1.  Open the PAYROLLG member in the LPEX editor if it is not open already. 
__2.  In the PAYROLLG editor window move the cursor to line 211 which contains EXSR 

ACDESR. 
__3.  Append an X to the EXSR op-code to make it EXSRX. 
__4.  Click File > Save from the workbench menu to save this change. 

 

 
You will fix this error later. 
 
 

The picture can't be displayed.
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Note: 
The file is updated in the local workspace on the workstation you are working on, 

it has not been updated the file on the IBM i server. 

 
Next, let’s display an outline of this ILE RPG member. 
 
The next couple of steps are not i Projects specific, they just show some of the features of 
Rational Developer, if you are already familiar with Rational Developer you might want to skip 
some of these steps. 
 
The Outline view acts as an excellent resource when you want to edit RPG and COBOL source. 
The Outline view displays a structural outline of items defined in the source that you currently 
have open in the editor.  With the editor active, you can expand the file structure in the Outline 
view, and click various elements in the view to jump to that location in the source. 
 

 
To see an Outline view of your RPG source: 

__5.  click the PAYROLLG tab in the editor 

The picture can't be 
displayed.

The picture can't be displayed.
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__6.  Expand some of the elements in the Outline view. 
The Outline view contains your source program in a tree view without the lines containing logic. 
 

 
 
Now you want to see more details of your source member. 
 

 
 

__7.  Expand Files. 
__8.  Expand the MSTDSP workstation file. 
__9.  Expand the EMPSEL record format. 
__10.  Double-click on any of the entries in the Outline view. This will position the source editor 

accordingly. 
 
You can also edit DDS members locally from the i Project Navigator. 
To open a DDS member from the i Project Navigator: 

__11.  Expand QDDSSRC, if it is not already expanded.  

The picture can't be displayed.

The picture can't be displayed.
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__12.  Right-click MSTDSP member and select Open With. 
 

 
 
As in the Remote System Explorer perspective, you now have the options to open the LPEX 
Editor or other editors. 
 
Rational Developer for i now includes special editors for DDS source it can handle display file 
source as well as printer File source.  You might want to give these a try by selecting the Open 
with Screen/Report Designer actions when right clicking on a DSPF or PRTF type member. 
 
You have edited a local source member from an i Project, viewed an outline of the local RPG 
source and opened a local DDS member for edit from the i Project Navigator. 

 

1.4 Verifying RPG source in disconnected mode 
 
In this lesson, you learn how to verify the RPG source member PAYROLLG while disconnected from an 
IBM i system.  You then learn how to fix a problem in the source and verify that the source is fixed 
correctly. 
 
While you are disconnected from an IBM i system, you can make certain that there are no semantic and 
syntactic errors in your code by invoking the Program Verifier.  The verifier checks for syntactic and 
semantic (compile) errors on your workstation, so that you can guarantee a clean compile when you are 
connected again.  The Error List view lists the errors that are found and their severity, inserts the error 
messages directly into the source and helps you to navigate between the errors. 
 
To verify source: 
__1.  Click the PAYROLLG editor tab to bring the editor in focus. 
__2.  Click Source > Verify from the workbench menu. 

 

The picture can't be displayed.
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Tip: If you are prompted to login to the IBM system, click Cancel. You can avoid 

this pop-up by right clicking on your connection in RSE (IBM i Test System) and 

selecting 'Work Offline' 

 

 
 
After a moment the verifier will display an Error List view below the Editor window. 

__3.  Use the Error List to locate the error you created earlier and fix it (remove the X you put in line 
211) ensuring you don't remove/add any spaces. 
 
 

 

Tip: Double click on the error to move focus the editor and position the cursor on 

the line in error 

 
__4.  Save the change to the source that you just made. 

 

 
 

__5.  Verify the source again. 
 
You may ignore the six Severity 0 informational messages for now. 
 
You have locally verified changed RPG source, whilst not needing to be connected to the IBM i 
system. 

 

1.5 Compiling a member 
 
In this lesson, you learn: 
• how to change the compile preferences to compile interactively 
• how to select the RPG source member PAYROLLG to remotely compile this source into the 

PAYROLLG program.  

The picture can't be 
displayed.

The picture can't be displayed.

The picture can't be 
displayed.

The picture can't be displayed.
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You will see that during compile, you are automatically connected to your IBM i system to push the 
changed source to the IBM i server and to invoke the compiler.  So now that the code has been edited 
locally and verified, you are ready to perform a single member compile on the source member in your i 
Project. 
 
To compile a single member, first change the preferences to compile interactively: 
__1.  Click Window > Preferences from the workbench menu. 
__2.  Expand i Projects. 
__3.  Select Build and Compile. 
__4.  Clear the Run compiles as batch jobs check box. 
__5.  Click OK. 

 

 
 

__6.  Expand QRPGLESRC if it is not already 
__7.  Right-click PAYROLLG. 

The picture can't be displayed.



IBM Software 

Page 18 IBM Rational Developer for i Sandbox – RDi Lab 08 – Working offline 

__8.  Select Remote Actions > Compile (RPGLE) > CRTBNDRPG on the pop-up menu. 
 

 
Now the connection will be activated and you may be prompted for a user ID and password. 
This will connect you to your IBM i system. 
Any local changes are uploaded to the same file in the associated library on the IBM i system 
from which they were loaded.  This action will then compile your member and any errors will 
appear in the Error List view. 
You could now run or debug your changed application. 
 

 

The picture can't be displayed.
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2 Working with i Projects 
 
The previous module guided you through the creation of a default i Project, which included using the 
default associated library, and the default compile commands.  As we mentioned before, working with the 
default settings is ok for casual use of i Projects when you want to work offline for a couple of hours or 
days.  If you use i Projects as the main environment for development, you will need to set it up in a way 
that works best for you.  This module goes through some of the steps needed to customize i Projects. 
 
In this module, you learn how to create a scratch library (sandbox) PROJxx for pushing local code 
changes to the remote host and for performing builds on that remote host. 
 
You then learn how to create the i Project MyProject and populate it with a new RPG source file and new 
RPG source member.  You also learn how to import remote objects such as DDS source and RPG source 
files into your existing i Project.  As well, you learn about build styles and how they are used to build 
(compile) your project. 
 
Next you learn about submitting a build for MyProject and displaying the status of this build job.  Next, 
you learn how to show the remote objects, in particular, PAYROLLG program in the view of your i 
Project, MyProject.  Further you learn how to filter this view, so you only see objects that are both local 
and remote.  You also learn how to remove the local/ remote label decorators from the view. 
 
Finally, you change PAYROLLG source again and submit another build to see how only the changed file 
is pushed to the remote host. 
 
Instead of making remote objects available offline as you did with the Make Available Offline option, 
you now create an i Project and import or add objects to that project. To import objects into an i Project 
you must be connected to an IBM i system. 
 

2.1 Creating a scratch library 
 
In this lesson, you learn how to create a scratch library PROJxx and how to push local source code 
changes to the remote IBM i server. 
 
You will need an associated library when you create an i Project. The associated library is a ″scratch″ 
library on the remote IBM i system that the project maps to.  The scratch library is used for pushing 
local code changes to the remote host and for performing builds on that remote host.  It is expected 
that this library is a ″personal″ library.  The goal is that the source in it will not be edited directly on 
the host.  It is meant to be a sandbox in which a single developer can perform tasks, like compiling 
and running the program to test code changes. 
 
To create a scratch library: 
In the Remote Systems view below the i Project Navigator (if you are in i Projects perspective): 
__1.  Expand the IBM i Test System connection, if it is not already expanded. 
__2.  Right-click Objects.  
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__3.  Select New > Library on the pop-up menu. 
 

 
 
The New Library page opens. 

__4.  In the Library field, type Projxx, xx being your team number. 
__5.  Select the Test radio button to change the type of library to Test. 
__6.  Type your own comments such as scratch library  into the Text field. 

The picture can't be displayed.
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__7.  Click Finish. 
 

 
 
This will create an empty IBM i Library. 
 

 
 
 

2.2 Creating an i Project 
 
In this lesson, you will learn how to create an i Project, MyProject, associate a scratch library PROJxx 
with that project, and select a build style for that project. 
 

The picture can't be displayed.

The picture can't be displayed.
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i Projects are projects that are dedicated for holding IBM i source members.  When a new i Project is 
created three properties need to be associated with it.  These are: 
• An IBM i Connection 
• A associated Library 
• A Build Style. 
 
To create an i Project: 
__1.  Make sure you are in the i Projects perspective 
__2.  Click File > New > IBM i Project on the workbench menu. 

 

 
 
The New i Project page opens. 
 

__3.  In the Project name field, type MyProject. 
__4.  Click Next. 

 

 
 
 

The picture can't be displayed.

The picture can't be displayed.
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__5.  Select your connection from the Connection list, for example, IBM i Test System. The property 
Connection allows for remote access to the IBM i host, and handles for example user ID and 
password authentication to the remote host. It also provides the initial environment for builds, 
including the base library list. 

__6.  In the Associated library field, type PROJXX. 
The associated library is the library on the IBM i system that your i Project maps to. 

__7.  Click Next. 
 

 
 
On the next page: 
Under Active build style: 

__8.  Select CL Program. 
The property build style determines how a given i Project is built. It determines how source 
physical files and members are pushed to the remote host, and how these members are compiled 
there. 
 

The picture can't be displayed.
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__9.  Click Finish. 
 

 
This will create an empty i Project.  This project is now your development environment instead of 
using RSE to remotely work with source you will use this Eclipse project to store and edit source 
members. 
 

 
 

 

2.3 Creating a source file and a source member in an i Project 
 
In this lesson, you learn how to create an RPG source file and an RPG source member in your i Project, 
MyProject. 
 
To create a source physical file: 

The picture can't be displayed.

The picture can't be displayed.
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__1.  Right-click your i Project. 
__2.  Click New then click IBM i Source Physical File on the pop-up menu. 

 

 
The New Source File page opens. 
 

__3.  Enter a name for your file in the File name field, for example RPGFile. 
__4.  Click Finish. 

The file is added to your project. 
 

 
You see the new file as part of your project. 
 

The picture can't be displayed.

The picture can't be displayed.
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Next add a member to the file that you just created. 
 

__5.  Right-click your IBM i source physical file RPGFile. 
__6.  Click New then click IBM i Source Member on the pop-up menu. 

 

 
The New Member page opens. 
 

__7.  Enter the name of the member in the Member name field, for example, RPGSRC. 
__8.  Enter the source type in the Source type field, for example, RPGLE. 
__9.  Click Finish. 

 

 
 
The member is added to your project and opened in the editor so you could start writing your 

The picture can't be displayed.

The picture can't be displayed.

The picture can't be displayed.
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code. 
 

 
 
Your i Project perspective should now look similar to the figure above. 

 
 

2.4 Importing members into your i Project 
 
In this lesson, you learn how to import existing DDS and RPG source files and members from library 
RSELABxx into the i Project MyProject 
 
Instead of creating new files and members, you can also import remote objects into an i Project.  You use 
the Import Remote Objects action or the Add to i Project action for this. 
 
To import remote objects: 
__1.  Right-click MyProject. 
__2.  Click Import Remote Objects on the pop-up menu. 

 

 
 
On the Import remote Objects dialog: 
 

__3.  Expand *LIBL. 
__4.  If you see a logon display, enter your user ID and password. 
__5.  If you don’t see RSELABxx in the library list, you will need to create a library filter or add this 

library to your library list in the RSE connection. To create a library filter: 
(1)  Expand Work with libraries. 
(2)  Type RSELABxx for the Library name. 
(3)  Click OK. 

The picture can't be displayed.

The picture can't be displayed.
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The library is added. 
 

 
 
 

__6.  Expand the library that contains the source files that you want to import. In this case select 
RSELABxx. 

__7.  Select the source physical files QDDSSRC and QRPGLESRC to be added to your project. 
You can use the Ctrl key to make multiple selections. 
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__8.  Click OK. 
 

 
 
The selected files are downloaded. The project now shows the copied files and they are ready for 
you to work with. 
 

 
 

The picture can't be displayed.
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The figure above shows the source files added to MyProject. 

 
 

2.5 Selecting the build style 
 
In this lesson, you learn about build styles and the IBM i Build Status view. 
 
So now that you know how to populate your i Project, you could disconnect and edit and verify the files 
on your workstation. Let’s assume that you did just that and you changed multiple members and that you 
want to build (compile) the full i Project. 
 
Associated with each i Project is a Build Style which determines how source members in that project will 
be pushed and compiled on the host.  A build style is a set of actions that provide push and build 
operations for a given i Project. 
 
There are three IBM-supplied build styles: 
*NONE 
This build style contributes no actions and is useful if you want to disable the menu items associated with 
a build style.  This style will always be available. 
 
Command 
The command build style contributes the following actions to the Remote Actions menu: 

• Push Changes — Pushes any new or changed resources found in the selected project.  An item is 
changed if it has been updated locally since the last time it was pushed, either by Push Selected or Push 
Changes.  The first time it is done, all resources are uploaded to the associated library.  Each 
subsequent upload is incremental. 

• Push Selected — This action uploads all selected resources and their children to their corresponding 
IBM i source files and members in the associated library.  It creates any resources that do not exist.  It 
will overwrite any changes that have been made on the server only if confirmed by the user.  Use this 
action to force the contents of the associated library to match the workspace. 
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• Submit Build Command — Submits the command found in this build style configuration to the 
server. 

 
CL Program 
This style uploads the COMPILE.CLLE and BIND.CLLE members from the source file that you 
designated in the style configuration for this project.  It then compiles and runs them to build this project 
on the server.  This build style contributes the following actions to the Remote Actions menu: 

• Push Changes — Pushes any new or changed items found in the selected project. An item is changed 
if it has been updated locally since the last time it was pushed, either by Push Selected or Push 
Changes.  The first time it is done, all resources are uploaded to the associated library. Each 
subsequent upload is incremental. 

• Push Selected — This action uploads all selected resources and their children to their corresponding 
IBM i source files and members in the associated library.  It creates any resources that do not exist.  It 
will overwrite any changes that have been made on the server only if confirmed by the user. Use this 
action to force the contents of the associated library to match the workspace. 

• Submit Build — Submits a job to compile the i Project on the server using the COMPILE and BIND 
programs from the source file you specify. 

 
Each i Project can have only one active build style. This can be configured through the Properties page for 
that project (right-click on the i Project and select Properties). 
 
By default, when a new i Project is created, it has the CL Program Build Style associated with it.  This 
can be changed by going to Window > Preferences > i Projects > Build and Compile. 
 
Once submitted, a build can be monitored through the Job Status View.  This view can be set to update at 
regular intervals and monitors all i Project build jobs that you have submitted.  Also compile errors can be 
retrieved from that view by right-clicking on the submitted build and selecting the Retrieve Errors action. 
 
To select a default build style for new i5/OS projects: Select Window > Preference > i Projects: 
__1.  Then select Build and Compile. 
__2.  Select the build style that you want. 
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__3.  Click OK. 
 

 
 
You have selected a default build style for your new i Projects. 

 

2.6 Submitting a build 
 
In this lesson, you learn how to compile the i Project MyProject and how to view the Build Job Status for 
that project. 
 
Besides compiling a single member, you can compile the project in full.  The actual compile behavior 
depends on the Build Style associated with the project.  The default build style for i Projects is the CL 
Program Build Style. 
 
This build style will generate a COMPILE.CLLE member in a QCLSRC file that will contain a compile 
entry for each source member in the i Project. 
 
If you want to create a *PGM, you must create a BIND.CLLE member in QCLSRC.  The member will 
usually just contain a CRTPGM command that binds the modules into a *PGM.  The BIND program will 
only run if the source member exists and COMPILE runs successfully.  

The picture can't be displayed.
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You can verify or change the configuration of a build style.  You can specify the name of the source file 
to hold the COMPILE.CLLE member and whether or not you want to automatically push changes and 
re-generate the COMPILE.CLLE member before a push. 
 

 

Tip: You must have a build style defined for your project before you can 
compile.  

 
To compile a project in full: 
__1.  Right-click the i Project and click Remote Actions > Submit Build. 

 

 
 
Now the connection that is associated with the project will be activated and you may be 
prompted for a user ID and password if you were disconnected. 
 

__2.  Enter your User ID and password. 
 
The changes are pushed to the IBM i server. 

The picture can't be displayed.

The picture can't be displayed.
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Note: If your build fails due to a timeout connecting to the remote system, then 

just submit the build again. The first time a project is being pushed all files are 

pushed to the host. Subsequent builds only push changed files. 

 

 
 
This action, with the default configuration, will perform all of the following: 

__a.  Generate the following COMPILE.CLLE member: 
 

 
 

__b.  Display a Build Job entry in the Job Status view indicating that a build has been submitted. 
 
The entry will look like this: 
 

 
You can change the Refresh Interval using the bottom arrows next to the Refresh Interval field 
shown above. 
 

__c.  Push all project changes to the host, including the newly created COMPILE.CLLE member. 
__d.  Compile COMPILE.CLLE into a program in the QTEMP library. 
__e.  Run it against the source in the PROJxx project library. 

If there were any errors during the submitted build: 
 

The picture can't be 
displayed.

The picture can't be displayed.
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__3.  After the job completes, refresh the Job Status view 
 

 
 

__4.  Right-click on the entry in the Job Status view and select Task Actions --> Retrieve Errors. 
 
This will open the Error List view and you will be able to double-click the error to open the 
corresponding member. 
 

 
 
 

2.7 Showing remote objects 
 
In this lesson, you learn how to see all the remote objects in the i5/OS project, MyProject. 
 
In particular, you see the results of the project compile (PAYROLLG program) that you just completed in 
the previous lesson.  You can refresh your i Project Navigator and look at all the remote objects. 
 
To show remote objects: 
In the i Project Navigator: 
__1.  Right click MyProject. 

The picture can't be displayed.

The picture can't be displayed.
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__2.  Click Show Remote Objects on the pop-up menu. 
 

 
 
Your i Project Navigator will now look like this: 
 

 
You can see now in the i Project Navigator: 

(1)  Local only objects (you don’t have any)  
(2)  Remote only objects ((like PAYROLLG *pgm)  
(3)  Remote and local objects (like QCLSRC) 

 
 

2.8 Filtering out remote objects 
 
In this lesson, you learn how to remove remote only objects from the i Project Navigator view.  You also 
learn how to remove the flags that identify local and remote objects in the i Project Navigator view.  
 
To filter out remote only objects: 
__1.  Go to the i Project Navigator toolbar. 

The picture can't be displayed.

The picture can't be displayed.
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__2.  Click the drop-down arrow. 
__3.  Click Show > Remote Objects on the drop-down menu, to de-select it. 
__4.  Select and de-select the Show Local/Remote Decorator to see the effect. 

 

 
This removes all objects that are remote only from the view. 
 

__5.  Expand QCLSRC, QDDSSRC, QRPGLESRC and RPGFILE. 
 

 
 
You can see Local/Remote objects only. 
Now you want to remove the Local/Remote Label Decorators from the view. 

__6.  Go to the i Project Navigator toolbar. 
__7.  Click the drop-down arrow. 

The picture can't be displayed.
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__8.  In the drop-down menu, click Show Local/Remote Decorator, to deselect it. 
 

 
Now you see your objects without the decorators that indicate whether the object is local, remote 
or both local and remote. 

 

2.9 Changing PAYROLLG and submitting another build 
 
In this lesson, you learn how to change PAYROLLG and push this changed file to the IBM i system. 
 
Now let’s change PAYROLLG again and then submit another build.  You will see that only the changed 
files are pushed to the IBM i server. 
 
To change PAYROLLG edit it and submit another build: 
__1.  Double-click PAYROLLG in QRPGLESRC. 
__2.  In the Editor add a comment line to the source. 
__3.  Save the file by clicking Ctrl+S. 

 

 
 

The picture can't be displayed.
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__4.  Right-click MyProject. 
__5.  Click Remote Actions > Submit Build on the context menu.  

 

 
 
Only the member and COMPILE.CLLE are pushed to the IBM i system. 
 

 
 
 

The picture can't be displayed.

The picture can't be displayed.
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Congratulations! 
 
You have successfully completed the RDi Working Offline lab exercises. 
 
This tutorial has shown you how to use the i Projects perspective in a typical development cycle for 
offline application development.  After providing you information about the perspective, the tutorial 
outlined the development cycle working offline with an i Project, then elaborated on each step in 
maintaining an ILE RPG project-based application. 
 
We recommend that you move on to the next lab in the sequence; or browse the list of labs on Rational 
Developer for i - Hands-On Labs at http://ibm.biz/rdi_labs to choose a lab of interest. 
 
More information, material and opportunities to discuss the product can be found at our RDi Hub:  
 
http://ibm.biz/rdi_hub 
 



IBM Software 

IBM Rational Developer for i Sandbox – RDi Lab 08 – Working offline Page 41 

 
Appendix A  Notices 

This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document in other countries. 
Consult your local IBM representative for information on the products and services currently available in 
your area. Any reference to an IBM product, program, or service is not intended to state or imply that only 
that IBM product, program, or service may be used. Any functionally equivalent product, program, or 
service that does not infringe any IBM intellectual property right may be used instead. However, it is the 
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter described in this document. 
The furnishing of this document does not grant you any license to these patents. You can send license 
inquiries, in writing, to: 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A. 
For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property 
Department in your country or send inquiries, in writing, to: 
IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan 
The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES 
CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in 
certain transactions, therefore, this statement may not apply to you. 
This information could include technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein; these changes will be incorporated in new editions of the publication. 
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for convenience only and do not in 
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of 
the materials for this IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you. 
Any performance data contained herein was determined in a controlled environment. Therefore, the 
results obtained in other operating environments may vary significantly. Some measurements may have 



IBM Software 

Page 42 IBM Rational Developer for i Sandbox – RDi Lab 08 – Working offline 

been made on development-level systems and there is no guarantee that these measurements will be the 
same on generally available systems. Furthermore, some measurements may have been estimated through 
extrapolation. Actual results may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM 
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those 
products. 
All statements regarding IBM's future direction and intent are subject to change or withdrawal without 
notice, and represent goals and objectives only. 
This information contains examples of data and reports used in daily business operations. To illustrate 
them as completely as possible, the examples include the names of individuals, companies, brands, and 
products. All of these names are fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. All references to fictitious companies or individuals are used 
for illustration purposes only. 

COPYRIGHT LICENSE: 
This information contains sample application programs in source language, which illustrate programming 
techniques on various operating platforms. You may copy, modify, and distribute these sample programs 
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing 
application programs conforming to the application programming interface for the operating platform for 
which the sample programs are written. These examples have not been thoroughly tested under all 
conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these 
programs.
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Appendix B  Trademarks and copyrights 

The following terms are trademarks of International Business Machines Corporation in the United States, 
other countries, or both: 

IBM AIX CICS ClearCase ClearQuest Cloudscape  

Cube Views DB2 developerWorks DRDA IMS IMS/ESA  

Informix Lotus Lotus Workflow MQSeries OmniFind   

Rational Redbooks Red Brick RequisitePro System i   

System z Tivoli WebSphere Workplace System p   

 
Adobe, Acrobat, Portable Document Format (PDF), and PostScript are either registered trademarks or 
trademarks of Adobe Systems Incorporated in the United States, other countries, or both. 
Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the United States, other 
countries, or both and is used under license therefrom. 
Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both. See Java Guidelines 
Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in 
the United States, other countries, or both. 
Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, Intel Xeon, 
Intel SpeedStep, Itanium, and Pentium are trademarks or registered trademarks of Intel Corporation or its 
subsidiaries in the United States and other countries. 
UNIX is a registered trademark of The Open Group in the United States and other countries. 

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both. 
ITIL is a registered trademark and a registered community trademark of the Office of Government 
Commerce, and is registered in the U.S. Patent and Trademark Office. 
IT Infrastructure Library is a registered trademark of the Central Computer and Telecommunications 
Agency which is now part of the Office of Government Commerce. 
Other company, product and service names may be trademarks or service marks of others. 
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