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Wilcom TrueSizer Pro e3

Wilcom TrueSizer Pro e3 is a universal embroidery file conversion utility offering 
full compatibility between industrial and domestic file formats, as well as full 
design scalability. It allows you to view, modify, read and convert, and output 
high quality embroidery through its easy-to-use commands and tools. It also lets 
you recolor designs and create multiple colorways for different fabrics. Based on 
the same core software as Wilcom's acclaimed professional embroidery design 
software, TrueSizer Pro provides the same unique advantages of the ‘all-in-one’ 
EMB file format.

Who is it for?
Customers may include a range of embroidery specialists, ranging from 
domestic to commercial, as well as their staff and customers. It is especially 
intended for sales and customer service staff for the purposes of recoloring 
existing designs. Wilcom TrueSizer itself is also intended for customers of 
Wilcom customers allowing them to view and manipulate EMB design files 
directly.

What does it do?
TrueSizer Pro includes all the capabilities of Wilcom TrueSizer. Both can be 
used to open, view and scale Wilcom EMB, Bernina ART, and Janome JAN 
object-based embroidery designs. They can both convert designs to many 
machine formats as well as generate production worksheets. They can also be 
used to share designs and design images. In addition to these capabilities, 
TrueSizer Pro allows you to create and save multiple colorways in EMB format. 
Designs can be visualized on garment images as well as production hoops. 
Unlike Wilcom TrueSizer, multiple designs can be opened simultaneously. 
Customer approval sheets can also be quickly generated. 
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Tip  If you want to do more with your EMB designs, you can easily upgrade. Just 
register your copy of TrueSizer Pro online and order upgrades for Wilcom’s 
professional range of embroidery design products.

The EMB advantage
Do you receive designs from digitizing centers or embroiderers? Do you send 
designs to embroiderers or production houses? If so, Wilcom EMB is the ideal 
embroidery file format for your day-to-day needs. More professional designs are 
created in EMB than any other. 
Because EMB format combines original outlines (condensed data) with the full 
original stitch data, customers will receive designs exactly as they were created 
– complete with any fine-tuning stitch edits that may be included. They can still 
resize the design from the original outlines with guaranteed rescaling. No 
confusion switching between multiple expanded and condensed files.

Product keys & activation
When a customer purchases TrueSizer Pro from the website store, they receive 
a product key (serial number) which must be entered when the product is first 
run. The installation program will automatically try to activate the product via 
internet.
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PART I

OBJECT-BASED EMBROIDERY

TrueSizer Pro can be used to open, view and scale Wilcom EMB, Bernina ART, 
and Janome JAN object-based embroidery designs. Convert designs to many 
machine formats. Customer approval sheets and production worksheets can be 
quickly generated. In addition, TrueSizer Pro lets you create and save multiple 
colorways in EMB format. Designs can be visualized on garment images as well 
as production hoops.

Basic procedures
This section describes how to open TrueSizer Pro and start using the commands 
and tools. It also explains how to open designs as well as create new ones. It 
describes how to display the grid and rulers, and measure distances on screen. 
And it also summarizes shortcut keys available in TrueSizer Pro. See Basics for 
details.

Viewing designs
This section explains the various design viewing settings, including design 
colorways. Techniques for viewing the stitching sequence are described as well 
as how to selectively view and name design color blocks. Viewing design 
information, including production worksheets, is also covered. See Viewing 
Designs for details.

Threads & colorways
This section describes how to set up multiple colorways. For each colorway you 
define, you can select colors from commercial thread charts or define your own. 
It also describes how to change backgrounds, including colors, fabrics, or 
products, as well as display elements such as unsewn and sewn stitching to suit 
different colorways. See Threads & Colorways for details.

Modifying designs
This section covers the selection and transformation of designs, including 
scaling, rotating, skewing, and mirroring. It also covers fine-tuning of designs 
with automatic start and end points and removal of small stitches. See Modifying 
Designs for details.
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Basics

Based on the same core software as Wilcom’s acclaimed professional embroidery 
design software, Wilcom TrueSizer Pro e3 provides the same unique 
advantages of the ‘all-in-one’ EMB file format. TrueSizer Pro is a universal file 
conversion tool offering full compatibility between industrial and domestic 
embroidery file formats, as well as full design scalability. It allows you to view, 
modify, read and convert, and output high quality embroidery through its 
easy-to-use commands and tools.

Opening designs

TrueSizer Pro opens a comprehensive range of both ‘outline’ and ‘stitch’ files. 
You can also open designs from proprietary embroidery disks. See Supported file 
formats. See also Reading designs from embroidery disk.

Caution  You cannot open EMB files created with a later version of the software 
to the one you are running.

To open a design
1 Click the Open icon.

Use Standard > Open to open an existing design.
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The Open dialog opens.

2 Select a folder from the Look In list.
3 If the design is not in EMB format, select a file type from the Files of Type 

list.
4 Select a design.
5 Select the Preview checkbox to preview the design (for supported file 

formats) together with design data. This includes stitch and color numbers, 
color changes, design height and width, and software version number (V6.0 
onwards).

Tip  For more information about a selected file, right-click and select 
Properties from the popup menu. See Viewing design information.

6 For file types other than EMB or ESD, click Options to change the file 
recognition options. See Supported file formats.

7 Click Open.

Note  If you open a design which is not a native EMB, you will receive the 
following warning. See File sources & EMB format for details.

Grids, rulers & guides

TrueSizer Pro provides a set of grid lines to help accurately align or size 
embroidery designs.

Displaying the grid

Preview panel

Design data

Preview on/off

Click View > Show Grid to show or hide the grid. Right-click to change the Grid 
settings.
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Use grid lines to help accurately align or size embroidery designs. Default grid 
spacing is 10 mm x 10 mm. 

To display the grid
Click the Show Grid icon or press Shift+G.
Click again to toggle off.
Right-click for settings.
You can change grid spacing, select a reference point and turn Snap to Grid 
on or off in the Options dialog. See also Setting grid display.

Tip  You can also change the color of the grid lines. See Changing display 
colors for details.

Displaying rulers & guides

Rulers are located to the top and left side of the design window. These make it 
possible to accurately position and size designs. The unit of measurement – mm 
or inches – defaults to the regional settings in the MS Windows® Control Panel. 
See also Setting measurement units.

Click View > Show Rulers and Guides to show or hide rulers and guides. Right-click 
for settings.

Drag the Ruler Zero Point to reset a new ruler zero point.
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To display rulers & guides
Click the Show Rulers & Guides icon or press Ctrl+R.

Reset the ruler zero point by clicking and dragging the box in the top left-hand 
corner to the required point in the design.
To create a guide, click on either ruler – horizontal or vertical – and 
click-and-drag it into position. Multiple guides can be created and just as 
easily removed.
For more accurate positioning of guides, double-click the yellow handle. In 
the Guide Position dialog, enter a precise distance from the zero point, and 
click OK.

To remove a guide, drag the yellow guide handle off the design window.

Tip  You can turn Snap to Grid and Snap to Guide on or off in the Options 
dialog. See also Setting grid display options.

Click-and-drag to
reset ruler zero

point

Click-and-drag to
reposition guides

Click ruler to
create new guide

Drag guide off
ruler to remove

Enter precise 
position

Select to
display grid

Select to snap
design points

to grid

Enter grid
spacing

Click to save for 
current template
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Tip  You can also change the color of grid and guidelines. See Changing 
display colors for details.

Measuring distances on-screen

Measure the distance between two points on screen using the Measure 
command. This command displays coordinates, distance and angle of the mouse 
pointer from a point corresponding to the center of a hoop in an empty design. 
View the measurements in the Status bar or in a tooltip. See also Setting 
measurement units.

Tip  For more accurate results, zoom in before you measure. The measurement 
is always the actual size, and is not affected by the zoom factor.

To measure a distance on-screen
1 Select View > Measure.
2 Click the start point.
3 Move the pointer to the end point and hold the mouse still.

The information displays in both the Status Bar and tooltip:
Length of the measured line (L=)
Angle of the line relative to the horizontal (A=)
Position coordinates of the end point (X=, Y=) – Status Bar only.

Note  Measurements are shown in millimeters or inches according to 
selection. See also Setting measurement units.

4 Press Esc to finish.

Specifying measurements on-the-fly

As an alternative to changing the overall measurement system used in 
TrueSizer Pro, you can specify units of measurement when typing values into a 
measurement control. When you include the unit of measurement, the software 
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automatically converts the entered value into the units of the control. See also 
Setting measurement units.

Say, for example, you are using the metric measurement system so your heights 
are in mm. And say you need to resize in inches. Simply specify the 
measurement in inches as shown, press Tab, and the value is automatically 
converted to metric. Press Enter to confirm. See also Scaling designs 
numerically.

Note  TrueSizer Pro supports both proper and improper fractions – e.g. ‘1 1/3’ 
as well as ‘4/3’. It does not, however, support mixed units – e.g. 1'3". Nor does 
it display values as fractions after they are entered, only during.

Supported units
Supported units include:

millimeters, mm 
inches, in
feet, ft
yards, yd 
centimeters, cm 
meters, m 

Tip  TrueSizer Pro also allows entering units in text form, both English and the 
language the software is currently running in.

Saving designs

Saving a design records its file name, location and format, and updates it with 
any changes you make. When you save a design under a new name, to a 
different location or format, you create a copy of the original. TrueSizer Pro lets 
you save designs in native EMB as well as other outline and stitch file formats. 
You can also save designs to proprietary embroidery disks. See also Supported 
file formats and Saving designs to embroidery disk.

Use Standard > Save to save the current design.
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To save a design
1 Click the Save icon or select File > Save As.

Tip  To save changes to an existing file but preserve the original, use Save 
As.

2 Select the folder where you want to save the design from the Save In list.
3 Enter a name for the design in the File Name field.
4 Select a file format from the Save as type list. See also Supported file 

formats.

Note  For backwards compatibility, you have the option of saving in previous 
EMB formats.

Caution  If a design feature is not available in the file type you select, it will 
be converted – e.g. Flexi Split stitching may be changed to plain Tatami.

5 If available, select the Save Icon checkbox to include a thumbnail image of 
the design with design file.
This icon appears in the machine control panel during stitch-out. It also 
appears in the preview panel of the Open dialog. See also Opening designs.

6 Click Save.

Tip  Files saved in EMB format are automatically compressed when saved and 
decompressed when re-opened. This reduces the storage space required, and 
makes it possible to save large files to floppy disk, or send them as email 
attachments. See also Sending designs as email attachments.
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Shortcut keys

The following shortcut keys can be used to make your TrueSizer Pro jobs faster 
to perform.

Function Shortcut

File
Exit Alt+F4
Open Ctrl+O
Print Ctrl+P
Save Ctrl+S
Edit
Deselect all X or Esc
Nudge Arrow keys
Redo Ctrl+Y
Select all Ctrl+A
Undo Ctrl+Z
View
Measure M
Pan P
Redraw R or F4
Refresh screen R
Show all 0 (zero) or F2
Show bitmaps D
Show bling Ctrl+B
Show functions Shift+F
Show grid Shift+G
Show hoop Shift+P
Show needle points · (period)
Show outlines L
Show rulers & guides Ctrl+R
Show stitches S
Show vectors Shift+D
Slow redraw Shft+R
TrueView T
Zoom 1:1 1
Zoom box B or F8
Zoom factor F
Zoom in 2X Z or F9
Zoom out 2X Shft+Z or F10
Zoom to fit 0
Zoom to hoop Alt+0
Zoom to product Ctrl+0
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Viewing Designs

TrueSizer Pro provides many viewing features to make it easier to work with 
your design. Zoom in on an area to see more detail or view the design at actual 
size. Pan the design to move it across the design window instead of scrolling, 
and quickly change between one view and the last. You can show or hide various 
design elements with the available display settings. Show or hide design 
outlines, or needle penetration points, as well as a ‘trueview’ of the stitch-ready 
design.

In TrueSizer Pro, you can preview an existing design in different colors on 
different fabrics by selecting from among any number of pre-defined ‘colorways’. 
TrueSizer Pro also provides information about designs in a variety of ways and 
formats. Approval and production reports also provide essential information, 
including design previews, size, color sequence information and any special 
instructions.

Viewing embroidery designs

TrueSizer Pro provides many viewing modes to make it easier to work with your 
design. View a design at actual size or zoom in for more details. Pan across the 
design instead of scrolling, or quickly change between one view and the last.

Tip  To make sure your design is being displayed at the correct size, you might 
need to calibrate your monitor. See Calibrating the monitor for details.

Zooming & panning designs

Zoom tools allow you to magnify your view of the design by zooming in on 
individual stitches or details, or zoom out to view more of the design.

Select Standard > Zoom Factor from the dropdown list to display the design 
at a particular scale.
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To zoom in and out
To display the whole design in the design window, select View > Zoom to 
Fit or press 0.
To zoom in on a section of a design, select View > Zoom (or press B) and 
drag a selection marquee around the zoom area.

To display a design at its actual size, select View > Zoom 1:1 or press 1.
To display stitches at a particular scale, select View > Zoom Factor. 
Alternatively, press F on the keyboard. In the Zoom Factor dialog, enter a 
scale as a percentage of the actual size, and click OK.

To display a design at twice its current size, select View > Zoom In 2X or 
press Z.
To display a design at half its current size, select View > Zoom Out 2X or 
press Shift + Z.

Drag selection marquee 
around area to zoom

Enter scale as
percentage of

actual size

Zoomed area of 
design

Click and drag to pan 
across design window
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Note  To make sure your design is being displayed at the correct size, you 
might need to calibrate your monitor. See Calibrating the monitor for details..
To pan across a design in the design window, use the scroll bars. Alternatively, 
select View > Pan or press P and use the ‘grabbing hand’ tool. Click to ‘hold’ 
the design window and drag it around.
To view a design in multiple views, select Window > Split Window. Zoom, 
pan, and adjust viewing options in each window pane as required.

Refreshing the screen

After certain operations, such as editing thread colors, you may need to refresh 
the screen for a clearer display.

Note  To view the stitching sequence, use Slow Redraw. See Viewing 
colorways for details.

To refresh the screen
Select View > Refresh Screen or press R.
The design display is refreshed.

Viewing embroidery components

TrueSizer Pro allows you to show or hide embroidery design elements. Show or 
hide design outlines, needle penetration points, machine function symbols and 
stitches themselves. Show or hide any graphical elements which may be part of 
the design.

Viewing stitches & outlines

Double-click to 
remove split bars

Use View > TrueView to change between normal view and TrueView.

Click View > Show Stitches to show or hide stitches.

Click View > Show Outlines to show or hide design outlines.
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Show or hide design elements with a variety of display settings. View designs in 
TrueView for realistic presentations.

To view outlines and stitches
Click the TrueView icon to switch between TrueView and stitch view.

In stitch view, click the Show Outlines icon to turn outlines on or off.

Note  Show Outlines will not work with ‘stitch’ files that have been read 
without stitch recognition. See also Opening stitch files.
Click the Show Stitches icon (or press S) to turn stitches on or off.

Viewing needle points & machine functions

You can show or hide design elements such as needle points and machine 
function symbols in your design.

Stitch view

TrueView ON

Outlines ON

 Outlines OFF

Click View > Show Needle Points to show or hide the needle points in a design.

Click View > Show Functions to show or hide the function symbols and any sequin 
elements in a design.

Stitches and 
outlines ON

Stitches OFF
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Note  You can display or hide design elements in any combination. None, 
however, displays while viewing in TrueView.

To view needle points and machine functions
To show or hide needle points, click the Show Needle Points icon.

To show or hide machine functions, click the Show Functions icon.

Tip  Use Show Functions to visualize any sequin elements which may be 
included in a design.

Viewing graphical components

Artwork can be included in EMB files as digitizing templates or ‘backdrops’. A 
design may include artwork, usually in the form of vector graphics, as an 
element in multi-decoration designs. TrueSizer Pro also lets you display 
background appliqué fabrics for more realistic previews. Some multi-decoration 
designs include bling elements. TrueSizer Pro lets you visualize graphical 
elements singly or in combination with other design elements.

Functions ONNeedle Points ON

Use View > Show Bitmaps to show and hide bitmap images. Right-click for settings.

Use View > Show Vectors to show and hide vector graphics. Right-click for 
settings.

Click View > Show Appliqué Fabric to toggle appliqué fabric display. 

Use View > Show Bling to toggle bling display on/off.
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To view graphical components
Click the Show Appliqué Fabric icon to toggle display of appliqué fabric 
on/off.

Tip  You can also print appliqué fabrics with the production worksheet. See 
also Setting design print options.
Click the Show Bling icon to toggle on/off display of any bling elements in a 
design.
Toggle the Show Bitmaps and/or Show Vectors icons to selectively view 
backdrops or graphic design elements.

Tip  Depending on the view options set up in the Options dialog, images 
display in full color, or dimmed. See also Setting image viewing options.
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Use Show Functions to visualize any sequin elements which may be 
included in a design.

Viewing & naming color blocks

A color block or ‘element’ corresponds to a color change in the design. It may 
be comprised of one or more same-color embroidery objects. Each block can be 
given a descriptive name for easy identification. Named color blocks are known 
as design ‘elements’.

To view color blocks
Click the Colorway Editor icon to view or edit an existing colorway.
The Colorway Editor opens with the current colorway selected.

Select a color from the colorways list.
Select an item in the element list, and click and hold the Locate button. Only 
the selected color block will appear in the design window.
To name a design element, double-click the corresponding field and key in a 
descriptive name – e.g. ‘bear nose - body’.

Use Color > Colorway Editor to view and name elements in a design.

Enter descriptive
name for selected

element

Select color

Click and hold to locate 
selected color block

Click to view current 
colorway details

2 - Text - highlights
6 - Bear nose - body
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To check the naming of all design elements, select Design > Design 
Properties > Stop Sequence. See also Viewing design elements.

Tip  Element names should make sense to a production operator as they 
appear on the production worksheet. The operator generally refers to these 
to make sure correct colors are used. See Creating design reports for details.

Viewing colorways

In TrueSizer Pro, you can define multiple colorways for the one design. This 
means you can preview or stitch out the same design in different colors to 
different fabrics.

Switching colorways

A ‘colorway’ is a color scheme or palette of thread colors. It may also include a 
background color or fabric sample. This means you can preview or stitch out the 
same design in different colors to different fabrics. In TrueSizer Pro, you can 
also print multiple colorways, icons of color blocks, and design backgrounds with 
the production worksheet. 

Text - highlights
Text - outline

Text - background

Bear head - background
Bear head - highlights

Bear head - outline
Bear nose - body

Named design
elements listed

here

Use Color > Current Colorway dropdown to select a new color scheme 
for design.

Use Color > Colorway Editor to view and modify colorway details.
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To switch colorways
Open a design with multiple colorways. See also Setting up colorways.

Select a colorway from the Colorways dropdown list.

Alternatively, click the Colorway Editor icon.
The Colorway Editor dialog opens.

Select a colorway by clicking the associated column header or anywhere 
within the column.

Tip  Change colorway background by double-clicking the BKG swatch. See 
also Setting backgrounds.

Select 
colorway

Click header to
change colorway

Click to view current 
colorway details

Double-click to 
change background
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Viewing backgrounds

TrueSizer Pro lets you set the background color, fabric, or product of the current 
colorway for more realistic previews and presentations.

To view the background
Open the design and select the desired colorway. See also Viewing colorways.

Click the split arrow next to the Background & Display Colors icon on the 
Color toolbar.
Choose a popout color menu:

The Background Color menu is available if activated in the Background 
& Display Colors dialog.

Click Colorway Editor > Background & Display Colors to change the background of 
the current colorway.

Click View > Show Background Image to display selected background image – 
fabric or product. Right-click for settings.

Click View > Show Hoop to turn hoop display on or off. Right-click for settings.

Select 
colorway

Click arrow to invoke
popup menu

Select background 
color
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The Fabric Color menu is available if activated in the Background & 
Display Colors dialog.

The Product Color menu is available if activated in the Background & 
Display Colors dialog.

Tip  To preset any of these options, click the Background & Display Colors 
icon. See Setting backgrounds for details.
Click More Colors in the popout menu to select from a greater range.
To turn off background fabric or product altogether, toggle off the Show 
Background Image icon.

Click arrow to invoke
popup menu

Select fabric 
color

Click arrow to 
invoke popup menu

Select product color
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Tip  Use the Show Hoop and Zoom to Hoop tools to display the currently 
selected hoop. See Selecting & centering hoops for details.

Simulating design stitchouts

Slow Redraw lets you view the stitching and color sequence of a design in slow 
motion. Redrawing can be started from any stitch in the design. Hide previously 
stitched parts of the design as required. With larger designs, you can choose to 
scroll automatically so that the area being stitched remains on-screen. It can be 
run in both TrueView and stitch view.

To simulating the design stitchout
1 Click Slow Redraw or select View > Slow Redraw.

The Slow Redraw dialog opens.

2 Use the slider bar to adjust the redraw speed. 
3 Select the options as required:

Use View > Slow Redraw to simulate embroidery design stitchout on screen.

Half-stitched
design

Go
Pause Stop

Back to Start

Adjust display 
optionsAdjust redraw

speed

Reverse

Set the stitch range 
to redraw section of 
the design
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Hide Before: Hide all sections of the design prior to the current cursor 
position.
Auto Scroll: With larger designs, scrolls automatically so that the area 
being stitched remains on-screen.

4 To redraw only a section of the design, specify a start point for either forward 
or backward stitching in the Stitch Range field or via the slider control.

5 Click Go.
The design is redrawn on-screen according to the stitching sequence and 
selected speed.

Viewing design information

TrueSizer Pro provides information about designs in a variety of ways and 
formats. Before even opening TrueSizer Pro or your design, you can check the 
software version number and other design information for EMB files directly from 
Windows Explorer. You can view stitching details in the Design Properties 
dialog.

Viewing design information

You can check software version number and other design information through 
the Design Properties dialog. This dialog provides stitching details as well as 
important information about the file source – Native Design, Imported Outlines, 
Processed Stitches, or Imported Stitches. See also Processing Design Files.

To view design information
1 Select Design > Design Properties.

The Design Properties > Information tab opens. This tab contains 
information about the design source as well as height and width and stitch 
count and colors. The data is extracted from the design and, except for stitch 
count, cannot be modified.

2 Click Length Calculation to revise thread usage estimate according to 
target fabric thickness. See Estimating total thread usage.

3 Select the Stop Sequence tab to view the color sequence and stitch counts 
for each design ‘element’. See also Viewing design elements.

Revise thread usage
estimate according to
target fabric thickness
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The data in this tab is extracted from the design and, except for Element, 
cannot be modified. Any additional colorways associated with the design are 
listed in the dropdown. See also Printing multiple colorways.

4 Select the Summary tab to view or enter summary information about the 
design.

5 Click a field and enter any text which will help you identify the design at a 
later date.

Note  Information from this tab is included on the Production Worksheet as 
well as the Summary tab of the Windows Properties dialog. See Viewing 
design information and Previewing reports.

6 Click OK.

Estimating total thread usage

In order to get more precise thread usage estimates, you can adjust the fabric 
thickness setting to suit the target fabric.

To estimate total thread usage
1 Select Design > Design Properties.

The Design Properties > Information tab opens.
2 Click Length Calculation.

Additional colorways

Color sequence and 
stitch counts for each 
design ‘element’

Hatice Onay

fish, tropical, water, ocean, animal

This beautiful tropical fish design is base on
an original design by Nina Feigin.

Tropical Fish
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The Length Calculation dialog opens.

3 Enter the thickness of the target fabric in millimeters.
4 Adjust the bobbin thread length according to the mixture of thread types in 

the design.
5 Click OK.

The Total Thread and Total Bobbin values are adjusted to take into account 
fabric thickness on total thread requirement.

Tip  Click Save to save the revised settings to the current template.

Viewing design elements

You can assign names to blocks of sequential, same-color embroidery objects, 
known as ‘elements’. Each color block can be given a descriptive name for easy 
identification. Element names appear on the production worksheet. See Creating 
design reports for details.

To view design elements
1 Select Design > Design Properties.

The Design Properties > Information dialog opens.
2 Select the Stop Sequence tab.

3 In the Element fields, enter names for each color block as required. To do so, 
click the field, type the name, and press Enter. See also Viewing & naming 
color blocks.

Tip  This information may be included on the Production Worksheet. See 
Customizing report information for details.

4 Click OK.

Enter target fabric 
thickness in mm

Enter bobbin thread 
length as a %

Enter element
names for each

color block
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Previewing reports

The production worksheet is the link between the designer and the embroidery 
machine operator. It contains a design preview and essential production 
information, including the size of the design, color sequence and any special 
instructions. The approval sheet is intended for the customer, not production 
staff. Its function is to display designs in TrueView with or without a product or 
fabric background. Customers can see what they are ordering and approve 
accordingly. See also Printing custom reports.

To preview a report
1 Click the Print Preview icon.

By default, a production worksheet displays in a preview window.

2 To change the information that displays, and set printing/plotting 
preferences, click Options. See Printing custom reports.

3 Adjust the view as required:
To change the orientation of the paper, click Landscape or Portrait.
To print the design, click Print.
To close the preview, click Close.

Tip  Zoom to read information or view the design preview more closely. Large 
designs may be displayed over a number of pages. See also Zooming & 
panning designs.

Click Print Preview to preview the Production Worksheet on-screen.

Design Info table

Stop Sequence 
summary table
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Chapter 1

Threads & Colorways

In TrueSizer Pro, you can choose from a selection of colors tailored to each 
design or color scheme. The particular ‘colorway’ represents the actual thread 
colors in which a design will be stitched. In fact you can define multiple color 
schemes and switch between them. 

For each colorway you define, you can select colors from commercial thread 
charts or define your own. Search for particular threads by specific code. 
Automatic thread color helps you locate thread colors based on closest match 
across one or several thread charts. You can also match thread colors from 
imported graphics – vector or bitmap.
TrueSizer Pro also lets you set the background color, fabric, or product of the 
current colorway for more realistic previews and presentations. The background 
is saved with the colorway.

Tip  You can also print multiple colorways, design backgrounds, and icons of 
color blocks in the production worksheet. See Creating design reports for details.
This section describes how to adjust colors as well as how to set up colorways, 
including matching image colors to threads. It explains how to name elements 
within color blocks as well as how to split them across multiple colorways. It also 
explains how to customize and mix your own thread colors. It describes how to 
change backgrounds, including colors, fabrics, or products, as well as the display 
of display elements such as unsewn and sewn stitching to suit different 
colorways.

Setting up colorways

TrueSizer Pro lets you define your own color schemes, or ‘colorways’, for a 
single design. Change them to preview an existing design in different colors on 
different fabrics. Colorways are saved automatically with the design when saving 
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in EMB format. Colorways cannot, however, be saved with stitch files. See also 
Viewing colorways.

Tip  Certain other settings are included as part of the colorway definition – 
background color or fabric, as well as display colors for borer symbols, unsewn 
stitches, selected objects, object outlines and the grid.

Adding colorways

When you open a design, it will contain at least one colorway called by default, 
‘Colorway 1’. You can define up to 100 colorways for any design.

To add a colorway
1 Open a design.
2 Click the Colorway Editor icon.

The Colorway Editor dialog opens.

3 Click the Create Colorway icon.

Use Color > Colorway Editor to add or edit colorways.

Use Colorway Editor > Create Colorway to create a new colorway definition for the 
design.

Use Colorway Editor > Delete Colorway to remove the selected colorway from the 
design.

Click to create
new colorway

Click to view selected 
colorway details
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The Create Colorway dialog opens.

4 Select a colorway to base on and enter a new colorway name.

Tip  By default, the Based on field contains the current colorway. If you want 
to base the new colorway on default settings, select the blank entry.

5 Click OK.
The new colorway is added.

6 Assign threads from the available chart/s to selected colors. See Assigning 
threads to colorways for details.

Note  To delete a colorway, select it and click the Delete Colorway icon.

Editing colorways

Enter new colorway name

Select colorway to base on

Green

New colorway added 
based on selected 
colorway

Use Color > Colorway Editor to add or edit colorways.

Use Colorway Editor > Rename Colorway to rename the selected colorway.

Use Colorway Editor > Delete Colorway to remove the selected colorway from the 
design.

Use Colorway Editor > Background & Display Colors (or Color toolbar) to change 
design background presets for the current colorway.

Use Colorway Editor > Edit Color to modify thread information about the color 
currently selected in the colorway.

Click Colorway Editor > Show Used Colors Only to show only those colors that are 
used by objects in the design.
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You can modify colorways by renaming or deleting them. You can add or change 
colors within colorways, or change colorway backgrounds. New colors can be 
selected from any associated thread chart.

To edit colorways
With a design open, click the Colorway Editor icon.
The Colorway Editor dialog opens.

Select the colorway you want to edit.
To edit the colorway name, click the Rename Colorway icon.

To delete a colorway, select it and click the Delete Colorway icon.
To modify a thread color, click Edit Color icon. See Editing colors for details.
To change the colorway background, click Background & Display Colors. 
See Viewing backgrounds for details.

Select colorway
to edit

Click to change 
colorway background

Rename selected
colorway

Enter new 
colorway name

Red

Russet
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Customizing backgrounds

TrueSizer Pro lets you set background color, fabric, or product backdrop for 
more realistic previews and presentations. The background is saved with the 
colorway. See also Viewing backgrounds.

Note  While you can change background colors, fabrics, and even products, this 
does not automatically affect fabric settings. Colorways and colorway editing in 
TrueSizer Pro is really intended for visualization purposes. The design file may 
not be production ready if the end use is for a fabric different to original settings.

Setting backgrounds

TrueSizer Pro lets you set the background color of the current colorway for more 
realistic previews and presentations. Choose from an assortment of swatches, 
or if you have your own, import them into your design. Almost any artwork can 
be used – photos, magazine pictures, clipart images, and even fabric samples. 
The background is saved with the colorway.

Use Color > Background & Display Colors (or Colorway Editor dialog) to change 
design background presets for the current colorway.

Click View > Show Background Image to display selected background image – 
fabric or product. Right-click for settings.
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To set the background
Open the design.

Click the Background & Display Colors or right-click the Show 
Background Image icon.
The Background & Display Colors dialog opens for the selected colorway.

Use the dropdown color menu to preset the background color for the current 
colorway. Click More Colors to select from a greater range.
To select a background fabric for the current colorway, tick Show 
Background Image and the Fabric option.

Preset background
color

Click link to select 
from greater range

Activate
background image

Choose fabric 
colorChoose desired

fabric
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Click the Fabric droplist for a swatch of fabrics to choose from.

To choose from a custom swatch, tick Custom and use the Browse button 
to locate.

Alternatively, click the Product droplist for a library of products to choose 
from. See Visualizing products for details.

Select background fabric 
and color as desired

Tick Custom to
choose your own

fabric swatch

Click Browse to locate 
custom fabric swatch
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Click OK.

Visualizing products

TrueSizer Pro lets you choose a garment or product backdrop on which to 
position your decoration. Use it to display location, size and overall appearance 
for visualization and approval purposes. The software provides a library of 
garments of common brands and styles. Choose colors for each product type, 
including multi-color garments. Even use different garments for different 
colorways within the same design. Print options allows you to print approval 
sheets and production worksheets with or without backdrops. See also Creating 
design reports.

Use Color > Background & Display Colors (or Colorway Editor dialog) to change 
design background presets for the current colorway.

Click View > Show Background Image to display selected background image – 
fabric or product. Right-click for settings.
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To visualize a product
Open the design and select the desired colorway (if available) from the Color 
droplist. See also Viewing colorways.

Click the Background & Display Colors or right-click the Show 
Background Image icon.
The Background & Display Colors dialog opens for the selected colorway.
To select a product, tick Show Background Image and Product.

Choose desired 
colorway

Select background 
product and color as 
desired
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Choose product and color from the dropdown menus. For custom product 
images, click Browse.

Scale the product as required.
Scale should be adjusted according to garment size – XS, S, M, L, XL, or XXL. 
For example, for a small size garment, scale down to approximately 70%. 
Rule of thumb: L = 100%.

Tip  Measure the garment using the Measure command. See Measuring 
distances on-screen for details.
Click OK. 
The product image is centered in the design window at the selected scale.
To toggle the product background on/off, click the Show Background 
Image icon.

If a multi-layer product image is selected, additional Product Layer 
submenus become available.

Scale product image
as required

If a multi-layer product 
image is selected, 
customize colors for each 
layer

Select product
color

Choose colors for
each layer
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Setting up colorway threads

For each colorway you define, you can select colors from commercial thread 
charts or define your own. Search for particular threads by specific code. 
Automatic color matching helps you locate threads across one or several thread 
charts. You can edit display colors and details of your threads at any stage.

Assigning threads to colorways

When a design is opened, it includes at least one colorway. This may contain 
specific thread colors or default colors, unassigned to any thread chart. The 
Colorway Editor lets you edit these colors and assign threads from preferred 
thread charts. You can also use it to set up additional colorways. See also 
Viewing & naming color blocks.

To assign threads to a colorway
1 Open a design.
2 Click the Colorway Editor icon.

Use Color > Colorway Editor to assign threads to colors in the colorway.

Use Colorway Editor > My Thread Charts to assign a thread chart/s to the design.

Use Colorway Editor > Find Thread to search for exact color codes or names in the 
current thread chart.

Use Colorway Editor > Assign Thread to assign a thread to the selected color.

Use Colorway Editor > Match All to assign automatically matched threads from the 
selected chart/s to the current colorway.

Use Colorway Editor > Show Thread Details to expand thread details for current 
thread chart.
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The Colorway Editor opens. The Isacord 40 thread chart is selected by 
default.

3 Click the My Thread Charts button.
The My Thread Charts dialog opens.

4 Select the thread chart/s to add and double-click to assign to your charts list. 
Remove any unwanted charts with the reverse arrow buttons.

5 Click OK.

Click to select
thread chart/s

Click to expand or 
contract ‘task pane’

Select thread
chart/s to use

Use arrows to assign 
or remove thread 
charts from your list
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All definitions from the selected chart/s are transferred to the Colorway 
Editor.

6 Select the colorway you want to assign threads to. See also Setting up 
colorways.

7 Sort the My Threads list as desired:
Sort the threads list by clicking a column header. Default sorting is by 
closest matching color. Color can only be sorted in descending order. Click 
Code, Name, Chart and Thickness to sort in either ascending or descending 
order.
Click the Show Thread Details button to expand thread details for 
current thread chart.

8 If unsatisfied with the automatic selection:
Enter an exact color code or name in the Find Thread field and click the 
search button.
Scroll down the color list to locate a suitable a color.

9 Click the Assign Thread button to assign your selection to the current color.

Browse color list 
manually for desired 
colors

Enter exact color code 
or name if known

Click to assign selected
thread to selected color

Select color for visual
comparison with nearest

matching thread colors

Click column header to
sort by category

Click to toggle thread 
details

Currently selected
color
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10 Repeat for all other colors. Alternatively, use the Match All tool to assign 
automatically matched threads to the selected colorway.

Note  Assigned threads are printed to the production worksheet for easy 
reference. See Creating design reports for details.

Editing colors

You can always change the code, name, chart, thickness or display color of 
existing colors by means of the Colorway Editor. These labels appear on the 
production worksheet both in the Stop sequence and Color Film printout. See 
also Creating design reports.

To edit colors
1 Click the Colorway Editor icon.

The Colorway Editor dialog opens.

2 Select a colorway. See also Setting up colorways.
3 Assign thread charts and threads as desired. See Assigning threads to 

colorways for details.

Actual thread colors 
assigned to colors

Use Color > Colorway Editor to modify threads in existing charts.

Use Colorway Editor > Edit Color to modify information about the current color 
selection in the colorway list.

Select a color 
to edit

Click to edit 
color details
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4 Double-click a color or click the Edit Color button.

5 Edit details as required:
Click Color droplist to see more colors or mix your own.
Enter code, name, and chart details for the new color. Code is the 
identification number of a thread color in a chart.
Select an appropriate thread thickness:

Tip  Lighter weight threads do not run so well in a production environment as 
the machines need to be slowed down in order to avoid thread breaks. 
However, lighter weight threads are good for very small lettering and 
fine-detail designs.

Changing display colors

In addition to background color or fabric, display colors for borer holes, unsewn 
and selected stitches, design outlines and grid are part of the colorway 

Click to select 
or mix color

Edit thread
details

Thickness Description Default

A Normal embroidery thread (approx. denier 40) 0.01
B Thicker than normal (approx. denier 30) 0.03
C Finer than normal (approx. denier 80) -0.03
D Very fine (approx. denier 100) -0.06

Use Color > Background & Display Colors (or Colorway Editor) to change design 
background presets for the current colorway.
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definition. Change them if the default display color is not visible against the 
current colorway.

To change display colors
1 Select a colorway and click the Background & Display Colors icon.

The Display dialog opens for the selected colorway.

2 Select an item from the Selection list:

3 Select a suitable color for the current colorway from the popout color menu.

Cyan outline against burgundy background Black outline against blue background

Select item to
change

Choose color

Display item Description

Selected Selected objects or stitches.
Unsewn Unsewn stitches as they appear when traveling through the design.
Object outline Object outlines as they appear when Show Outlines is activated. See 

Viewing stitches & outlines for details.
Grid Depending on the colorway, you may need to adjust grid display colors 

in order to view them against the background color. See also Grids, 
rulers & guides.

Guide Depending on the colorway, you may need to adjust guide display 
colors in order to view them against the background color. See also 
Grids, rulers & guides.
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4 Click More Colors in the dropdown menu to select or mix a new display color.

5 Click OK to close.
The display colors will be saved with the colorway. 

Tip  You can save colorways as an EMT template file for use in future designs.

Choose or mix 
color for display 
colors
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Modifying Designs

Wilcom TrueSizer Pro e3 lets you scale and transform (mirror, rotate, skew) 
both outline and stitch formats. After modification, you can choose to save your 
design to the native EMB format, or to a different format altogether. See also 
Supported file formats.

The scalability and stitching quality of a design ultimately depend on its original 
source – Native Design, Imported Outlines, Processed Stitches, or Imported 
Stitches. See also Viewing design information.

Note  Only native EMB designs contain the complete set of design information 
required for 100% perfect scaling and transformation.

Selecting designs

In order to scale, move or transform a design, you must first select it. When you 
have finished making changes, deselect the design to see the effects. 

To select a design
Select Edit > Select All or press Ctrl + A.
Eight selection handles appear around the design. These are used for 
positioning and scaling operations. See also Positioning designs and Scaling 
designs.
Click the design a second time.
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Eight rotation handles appear around the design. These are used for rotation 
and skewing operations. See also To scale a design numerically and Skewing 
designs.

To deselect a design, use one of the following methods:
Click a point outside the design.
Select Edit > Deselect All.
Press X or Esc.

Positioning designs

The simplest way to move a design is to click and drag it to a new position. See 
Scaling designs numerically.

To position a design
1 Select the design. See Selecting designs.
2 Click and drag it to a new position.

3 For more accurate positioning, press the arrow keys to ‘nudge’ the object into 
the required position.

Tip  Zoom in to make small adjustments. The distance the object moves 
depends on the current zoom factor. The greater the zoom factor, the smaller 
the distance moved.

Scaling designs

You can scale whole designs by dragging selection handles, specifying the exact 
dimensions in the Property bar, or by setting the distance between reference 
points on the design. As design is scaled, the stitch count changes to preserve 
the current stitch spacing.

First click displays 
selection handles

Second click displays 
rotation handles

Anchor
point

Skew handle

Rotation
handle

Cross Hair cursor 
centers objects
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Note  After any transformation, stitches are regenerated and the original stitch 
density preserved. Only native EMB designs contain the complete set of design 
information required for 100% perfect scaling and transformation. See 
Processing Design Files for details.

Scaling designs interactively

You can change design height and width or scale proportionally using selection 
handles. Strictly speaking, it is not possible to select objects individually in 
TrueSizer Pro. However, it is possible to select certain types of objects by hiding 
object types. For example, in a design containing embroidery, bitmaps, vectors, 
and bling:

All embroidery objects in the design can be selected by hiding bling, vectors, 
and bitmaps.
All vector objects can be selected by hiding bitmaps, bling, and embroidery 
objects.

Tip  To hide embroidery objects, TrueView, stitches, outlines, needle points, and 
functions all need to be turned off. See Viewing embroidery components for 
details.

To scale a design interactively
1 Select the design. See Selecting designs.
2 Click and drag a selection handle to resize.

To scale height and width proportionally, use a corner handle.

To change the height, use the handles at the center-top or center-bottom.

Scale proportionally Scale proportionally 
about center Shift + dragDrag

Scale vertically

Drag

Drag
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To change the width, use the handles at the center-sides.

To resize proportionally around a central anchor point, hold down Shift as 
you drag.

Tip  Use the tooltip as a guide to object scale.

Scaling designs numerically

You can scale artwork or embroidery by means of ‘properties’. With outline files 
(EMB), stitches are regenerated while preserving stitch density. An exact size 
may not be achieved due to pull compensation being added after scaling 
operations.

Caution  If you scale a stitch file by more than 5%, however, changes to stitch 
density will affect the design quality. See Processing Design Files for details.

To scale a design numerically
1 Select the design to scale.
2 In the Property Bar, either:

Enter exact height and width values.

Scale horizontally Scale horizontally

Drag

Shift + drag

Scale vertically in 
both directions

Scale horizontally in 
both directions

Shift + drag
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Enter the new height and width as a percentage of the current dimensions.

Tip  Toggle on the Lock Aspect Ratio toggle to preserve aspect ratio.
3 Press Enter to apply.

Note  After scaling, the new size is reset to 100%.

Scaling designs by reference line

You can scale a design by marking reference points and specifying the required 
length of line between them. For example, to resize a specific width, mark 
reference points across the design width.

To scale a design by reference line
1 Select the design to scale.
2 Select Transform > Transform by Reference Line Numerically. 

You are prompted to enter start and end points of the reference line. You will 
have already decided which two points will form it.

3 Click to mark reference points on the design.

Tip  Press Ctrl to constrain the angle of the axis to 15° increments. Press Enter 
twice to use the default reference line.

Enter dimensions as exact 
values or as a percentage

Lock aspect ratio toggle

Vase scaled
Width: 120% Height: 140%

Shadow scaled
Width: 140% Height: 120%

Use Transform > Transform by Reference Line Numerically to transform designs 
using a combination of reference points and numeric values.

Click to mark the 
reference points



   Modifying Designs 50

The Transform by Reference Line dialog opens.

4 Select the Resize to checkbox, and enter the required distance between the 
reference points.

5 Click OK.

Rotating designs

You can rotate designs directly on screen or by setting an exact rotation angle.

Rotating designs interactively

When you select a design, selection handles display at its extremities. When you 
click again, they change to rotation handles. See Scaling designs interactively.

Note  After any transformation, stitches are regenerated and the original stitch 
density preserved. Only native EMB designs contain the complete set of design 
information required for 100% perfect scaling and transformation. See 
Processing Design Files for details.

To rotate a design
1 Double-click the design.

Rotation handles appear at the corners and an anchor point displays at the 
design center.

Select Resize
to checkbox

Specify size

First click displays 
selection handles

Second click displays 
rotation handles

Anchor
point

Skew handle

Rotation
handle
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2 If required, drag the rotation anchor from the center to a new position.
3 Click a rotation handle, and drag it clockwise or anti-clockwise. An outline and 

cross-hairs display as you rotate.

Tip  Use the tooltip as a guide to rotation angle.

Rotating designs numerically

You can rotate selected designs in 45° increments or by entering an exact value 
using the Transform toolbar.

To rotate a design numerically
Select the design.
To rotate in 45° increments, click one of the Rotate 45 icons.

Drag a corner to rotate 
about the anchor point

Drag the anchor point Drag a corner to rotate 
about the anchor point

Click Transform > Rotate 45° CW to rotate selected objects by 45° in a clockwise 
direction.

Click Transform > Rotate 45° CCW to rotate selected objects by 45° in a 
counter-clockwise direction.

Use Transform > Rotate to rotate selected objects by an exact amount (in 
degrees).
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To rotate by an exact amount, enter the exact angle in the Rotate field and 
press Enter.

Rotating designs by reference line

The Transform by Reference Line Freely tool lets you rotate selected designs 
with the aid of reference points alone. This technique is useful to duplicate and 
rotate designs around an anchor point.

To rotate a design by reference line
1 Select the design.
2 Select Transform > Transform by Reference Line Freely.
3 Follow the instruction in the prompt line:

Click the first reference point. This becomes the anchor point for the 
rotation.
Click a second reference point. An outline attaches to the pointer.

Tip  Press Ctrl to constrain the angle of the axis to 15° increments.
Click the anchor point. The pointer then aligns itself with the second 
reference point.
Click a guide point for the required rotation position. Use the coordinates 
on the Status bar for exact alignment.

Rotating designs by reference line & angle

The Transform tool provides another method for transforming selected designs 
using a combination of reference points and numeric values. This provides a very 
accurate technique for rotating selected designs.

To rotate designs by reference line and angle
1 Select the design.
2 Decide which two points will form the reference line. This should be a 

significant line – e.g. one which must be perfectly horizontal or vertical in the 
final design.

Use Transform > Transform by Reference Line Freely to rotate selected objects 
with the aid of reference points alone.

Move the pointer

Use Transform > Transform by Reference Line Numerically to transform designs 
using a combination of reference points and numeric values.
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3 Select Transform > Transform by Reference Line Numerically.
The Transform by Reference Line dialog opens.

4 Select the Rotate to checkbox, and enter the rotation angle of the reference 
line.
For example, to rotate the image so that it aligns with the horizontal axis, 
enter a value of 0°.

Note  The Angle field accepts angles from 0 to ±180 degrees.
5 Click OK.
6 Click to mark the start and end points of the reference line.

Tip  Press Ctrl to constrain the angle of the axis to 15° increments. Press Enter 
twice to use a horizontal reference line by default.

Skewing designs

You can skew designs directly on screen or by setting an exact skew angle.

To skew a design
1 Select the design and click a second time.

Select Rotate to Enter absolute 
rotation angle in 
degrees

Select rotation angle – 
e.g. 0°

Reference line set to angle 
specified in dialog

Digitize reference line – align 
with base of object

Use Transform > Skew to skew objects by an exact amount (in degrees).
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Rotation and skew handles appear. Selection handles are diamond-shaped 
and appear at center-top and bottom.

2 Drag the skew handles left or right.
The object skews along the horizontal plane.

Tip  To skew by an exact amount, enter the exact angle in the Skew field on 
the Transform toolbar and press Enter. Alternatively, use the tooltip as a 
guide.

Mirroring designs

In TrueSizer Pro you can mirror designs horizontally or vertically by means of 
the Transform toolbar. You can also mirror around a defined axis using a 
reference line.

Flipping designs

You can mirror selected designs horizontally or vertically using the Mirror tools.

Note  After any transformation, stitches are regenerated and the original stitch 
density preserved. Only native EMB designs contain the complete set of design 
information required for 100% perfect scaling and transformation.

Click second 
time

Anchor point

Skew handle

Rotation handle

Drag skew handle left 
or right

Click Transform > Mirror Horizontally to flip objects in the horizontal plane. 

Click Transform > Mirror Vertically to flip objects in the vertical plane.
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To mirror a design
Select the design and click a Mirror icon.

Mirroring designs around an axis

Use Mirror by Reference Line to mirror designs around a defined axis using a 
reference line.

To mirror a design around an axis
1 Select the design.
2 Click the Mirror by Reference Line icon or select Edit > Mirror by 

Reference Line.

3 Click to mark the reference points of the mirror axis.
After the second click, the selected object is mirrored in the reference line.

Tip  Press Ctrl to constrain the angle of the axis to 15° increments. If you just 
want to mirror your selection around a horizontal axis, press Enter twice. 
The mirror axis defaults to zero.

Use Transform > Mirror by Reference Line to mirror objects around a defined axis 
using a reference line.

Mirrored verticallyMirrored in both axes

Starting objectMirrored horizontally

Mirrored

Starting object
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Fine-tuning designs

To improve the quality of your embroidery and make stitching easier, use the 
fine-tuning commands TrueSizer Pro provides.

Setting automatic start & end points

The Auto Start & End feature is not an object property, but it is a quality setting 
that affects the design stitchout. Before stitching, some embroidery machines 
require you to position the starting needle exactly above the first needle 
penetration point. Use Auto Start & End to connect the first and last stitches 
in the design. This makes it easy to position the needle before stitching, and 
reduces the chance of the needle hitting the side of the frame.

To set automatic start and end points
1 Right-click Auto Start & End.

The Auto Start & End dialog opens.

2 Select the Apply Auto Start & End checkbox to connect the first and last 
stitches in the design.

3 Select the Maintain Automatically checkbox to maintain the design center 
after modifying the design.

4 Select a centering method: Auto Start & End, Return to Start Point, or Digitize 
Auto Start/End Point.

Use View > Auto Start & End to toggle the Auto Start & End function on/off 
according to the current settings. Right-click to adjust settings.

Select Use Auto
Start & End

Select centering
method

Specify how to
match connecting

stitches

Specify the
connector type

Select preset end 
point

Click to enter
separate start and

end points
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5 Select to match connecting stitches on the Horizontal plane, Vertical plane 
or both in the Match On panel.

6 Select the type and length of the connecting stitches in the Connectors 
panel. Choose between Run or Jump stitch.

7 Click OK. 
Connecting stitches will be inserted as required before the first and after the 
last stitch of the design.

Removing small stitches automatically

Very small stitches can damage the fabric and cause thread or needle breakage. 
Before you stitch out a design, you can remove unwanted small stitches 
automatically.

To remove small stitches automatically
1 Select Design > Remove Small Stitches.

The Remove Small Stitches dialog opens.

2 Enter the minimum stitch length you want to keep.
3 Click OK.

All stitches shorter than the specified length will be removed from the design.

Tip  Check the Status bar for the new stitch count.

Match on bothMatch on vertical Match on horizontal

Enter minimum stitch 
length to keep

Original design Small stitches reduced
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PART II

DESIGN PROCESSING &
PRODUCTION

Design processing and encoding involve all the important, back-end operations 
of embroidery design and manufacture. This is where you actually output your 
designs to machine, disk, printer, cutter, and so on. For this, you will need an 
understanding of embroidery file types as well as different machine formats. 
Depending on your setup, you will also need an understanding of traditional 
storage media such as embroidery disks.

Printing designs
This section describes how to create production worksheets and approval 
sheets. It also explains how to send designs as email attachments, as well as 
how to output designs as images. Sending appliqué shapes to printer and cutter 
are also covered. See Printing Designs for details.

Processing design files
This section describes different file sources and native EMB format files. It also 
covers opening stitch files as well as working with CND format. It covers saving 
designs in CSD format and lists supported file formats. See Processing Design 
Files for details.

Hooping designs
This section deals with selecting and centering hoops, both manually and 
automatically. It also covers setting up and editing custom hoop lists. See 
Hooping Designs for details.
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Printing Designs

You can output embroidery designs in a variety of ways – as design files or stitch 
files. From the same EMB design file, you can also output production worksheets 
or approval sheets for machine operators or customers respectively. Designers 
frequently want to distribute their designs so that they can be seen in real colors, 
in TrueView or otherwise. In TrueSizer Pro you can save both design images and 
production worksheets to disk or email them direct. Optionally, email production 
worksheets in PDF format with the embroidery file as an attachment in a 
specified format – e.g. EMB or DST, etc.

Creating design reports

The production worksheet is the link between designer and embroidery machine 
operator. It contains a design preview as well as essential production 
information, including the design size, the color sequence and any special 
instructions. You can customize production worksheets before printing. You can 
also print multiple colorways, icons of color blocks, and backgrounds.
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Report types
In addition to production worksheets, TrueSizer Pro allows you to create a 
variety of other report types:

Note  If certain thread colors are not available on your printer, they may be 
mapped to a different color, including white. If a color is mapped to white, it will 
be invisible on the worksheet. Print the design in TrueView color, or black and 
white, or turn off color mapping. See your printer manual for more information.

Printing custom reports

Create a hard copy of your design report using a printer or plotter. Preview the 
report before printing as required. See Previewing reports for details.

To print a custom report
1 Select File > Print. 

Option Purpose

Approval sheet This report is intended for the customer, not production staff. Its 
function is to display designs in TrueView with or without a product or 
fabric background. Customers can see what they are ordering and 
approve accordingly. 

Product summary This report provides two summary tables of the design and associated 
colorways – a Colorway Summary table together with a Design 
Summary table. You can also include color blocks in the Colorway 
Summary table by selecting the Show Colors in Summary option in the 
Stop Sequence tab. See also Customizing report information.

Color film This report provides color block information so that production staff can 
see each stitch color in separate blocks according to the sequence 
they will be stitched out.

Appliqué patterns This report shows appliqué patterns – cutter information – isolated from 
the design. This tells the operator which appliqué pieces are to be 
included in design. See also Printing appliqué patterns.

Click Standard > Print to print Production Worksheets for the current design using 
the current settings.

Click Standard > Print Preview to preview the production worksheet on screen.
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The Print dialog opens.

2 Select the printer or plotter you want to use, and enter the number of copies 
of the worksheet you require.

3 To select a report type, click the Options button.
The Print Options dialog opens.

4 Select a report type in the Print panel.
Multiple reports can be batched as part of the same print run. Tick the 
checkbox next to each report type you require.

5 Select associated tabs and change default settings as required. Tabs vary with 
selected report type. Options include:

Click to preview 
worksheet

Click to
select/customize

report

Select tabs to 
customize report 
details

Select report
type

Tab Purpose

General Click to access report layout settings.
Colorways Click to access colorway settings for the current design.
Zoom Click to set the zoom factor for the design preview and physical 

printout.
Design Click to set design appearance on the printout, including 

multi-decoration components.
Info Click to further filter information included on product worksheets.
Blocks Click to select production information available on the Design 

Properties > Information tab for inclusion in the printout.
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Note  The Production Worksheet actually provides a superset of all options 
available on these tabs. See Customizing print options for details.

6 Click OK to close the Print Options dialog.
7 If you are using a plotter, click Properties, and set pen colors to correspond 

with the thread colors in the design.

Note  Refer to your plotter’s manual for information on setting up pen colors.
8 Click Preview if you want to inspect the document before sending to print.

9 Click OK to proceed.

Customizing print options

The production worksheet is the link between designer and embroidery machine 
operator. It contains a design preview as well as essential production 
information, including the design size, the color sequence and any special 
instructions. You can customize production worksheets before printing. You can 
also print multiple colorways, icons of color blocks, and backgrounds.

Stop Sequence Click to select production information available on the Design 
Properties > Stop Sequence tab for inclusion in the printout.

Tab Purpose

Design Info table

Stop sequence 
summary table

Use Standard > Print to print Production Worksheets for the current design using 
the current settings.

Use Standard > Print Preview to preview Production Worksheets and access print 
options.
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To customize print options
1 To access the Print Options dialog, select File > Print Preview.
2 Click Options.

The Print Options dialog opens.

3 Select Production Worksheet or other report type as required. See also 
Printing custom reports.
The Production Worksheet actually provides a superset of options available 
for all report types.

4 Click the General tab to access report layout settings.
Customizable options include:

5 Click the Barcode tab to access barcode settings and include or exclude 
barcode from the report as required.

Select tabs to 
customize report 
details

Select report
type

Option Purpose

Text / heading 
font

Use to access the system font dialog. Set parameters for all text and 
headings appearing in the report – e.g. Arial for print, Verdana for 
online reports.

Print in 
English

Useful when printing to plotters where the device driver does not 
support the character set you require. Deselecting the checkbox prints 
the report in the language of the operating system. 

Print design 
filename

Include the filename of the current design in the header of the product 
report.

Margins Add a margin between the edge of the page and the content of the 
report. The page size itself is set via the Print dialog. See also Printing 
custom reports.

Company Includes your company name on the report. Key in the name and/or 
attach a company logo.

Customer Key in the customer name. The name is recorded for future use. 
Access it via the dropdown list. Note that the customer name is not 
saved with the design. Reverting to factory defaults will clear customer 
names on a particular PC.
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The tab allows you to specify a standard format for the barcode – based 
design name with or without file extension – or a custom format as required.

6 Click the Colorways tab to access colorway settings for the current design.

Customizable options include:

7 Click the Zoom tab to set the zoom factor for the design preview and physical 
printout.

Customizable options include:

Set barcode format 
as required

Set colorway display 
for printout

Option Purpose

Current Prints the design in the current colorway only.
All Scales the design to fill the available space on the worksheet.
Selected Prints multiple colorways. When selected, available colorways

are selectable from the list. See Printing multiple colorways for 
details.

Set design zoom 
factor for current 
printout

Option Purpose

Zoom 1.1 Shows design at actual size.
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8 Click the Design tab to set design appearance on the printout.

Customizable options include:

9 Click the Info tab to further filter information included on product 
worksheets. See also Customizing report information.

Zoom to fit Scales design to fill available space on the printout.
Custom Sets a specific zoom factor.

Option Purpose

Set design 
appearance in 
current printout

Option Purpose

Outlines Include design outlines. See also Viewing stitches & outlines.
Needle points Include needle points. See also Viewing needle points & machine 

functions.
TrueView Print design in TrueView. When selected, the Draft Quality option 

becomes available.
Background Prints design with colored background or fabric color. 

Color behind product: Include background color behind selected 
product. 
Crop to design: Crop any background to the extends of the 
design, rather than the full page.

Extents box Places an outline around the design to delineate its full extents.
Start/end crosshair Prints a cross hair across the design indicating design start and 

end points. See also Setting automatic start & end points.
Standard Resets printing options to default values.
As Window Sets printing options as per current settings in the design window.

Set information to 
include on production 
worksheets
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Customizable options include:

10 Click the Blocks tab to select production information available on the Design 
Properties > Information tab for inclusion in the printout. See Viewing 
design information for details. See also Customizing report information.

11 Click the Stop Sequence tab to select production information available on 
the Design Properties > Stop Sequence tab for inclusion in the printout. 
See Viewing design information for details. See also Customizing report 
information.

Tip  Tick Show Colors in Summary option to include actual color samples 
in the production colorway summary table. See also Printing multiple 
colorways.

12 Click OK.

Option Purpose

Full Invokes further tabs allowing a full printout of available design 
and production information.

Short Includes only default header and footer information – usually 
used in conjunction with full size design in order to visualize on 
garment. See also Zoom tab.

Stop sequence Invokes Stop Sequence tab and includes stop sequence 
information on the worksheet. See Stop Sequence below.

None Eliminates design information altogether and suppresses display 
of default header and footer information – again, can be used in 
conjunction with full size design in order to visualize on garment. 
See also Zoom tab.

Use left side Displays the information column on the left side of the page 
(rather than the default right-hand side).

Set detailed 
production information 
for inclusion

Set stop sequence 
information for 
inclusion



Wilcom TrueSizer Pro e3 Reference Manual 67

Setting design print options

The Print Options dialog allows you to print all design files supported by 
TrueSizer Pro. 

Design components
Options for selectively showing/hiding design components can be found under 
the Design tab. These include embroidery components as well as appliqué 
fabric.

Select embroidery 
elements to display

Tick to include 
appliqué fabric
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Appliqué patterns
A specific report type exists for selectively showing/hiding appliqué patterns. 
See Printing appliqué patterns for details.

Embroidery components
To display embroidery components, select from amongst Outlines, Needle 
Points, TrueView in the Design tab.
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Design backgrounds
The Design tab also provides options to display design backgrounds – i.e. colors 
or fabrics.

Customizing report information 

You can further customize production worksheet information when the Full 
Information option is the selected. See also Customizing print options.

To customize report information
1 To access the Print Options dialog, select File > Print Preview.
2 Click Options.

The Print Options dialog opens.
3 In the Info tab, select Full.
4 Click the Info tab to further filter information included on product 

worksheets. See also Customizing report information.

5 In the Blocks tab, select the design statistics to include on the worksheet:

Further customize 
production worksheet 
information

Option Purpose

Left / right / up / 
down

Depending on where the design start/end point has been set, 
these figures indicate the distance from that point.

End X / Y The coordinates of the last stitch. See also Setting automatic 
start & end points.
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Here is a sample production worksheet with all options selected:

6 In the Stop Sequence tab, select the statistics for each color block:

Here is a sample production worksheet with all options selected:

Max / min stitch The maximum and minimum stitch lengths, and maximum jump 
stitch length in the design.

Thread chart type The name of the thread chart used in the design.
Thread usage Meterage of thread required per color.
Total bobbin Total meterage of bottom (bobbin) thread required to stitch out 

the design.

Option Purpose

Left / right / up / down

End X / Y

Max / min stitch

Thread usage
Total bobbin

Option Purpose

Stitch count Number of stitches per color.
Needle number The needle number corresponding to each color block.
Chart Name of thread chart used.
Element name User-defined name to identify each color block. See Viewing 

design elements for details.
Show colors in 
summary

Includes color samples in a colorway summary table. See also 
Printing multiple colorways.

Chart

Element name

Stitch count
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Note  The Show Colors in Summary option works in conjunction with the 
Production Summary option. This option prints color blocks in a summary 
table. See Customizing print options for details.

7 Select the Use Left Side checkbox in Info tab to include the full information 
column on the left side. 
By default, this column displays on the right of the page.

8 Click OK.

Printing multiple colorways

You can print your design in the current or multiple colorways.

To print multiple colorways
1 To access the Print Options dialog, select File > Print Preview.
2 Click Options.

The Print Options dialog opens.

3 Select Selected to print multiple colorways. 
4 Select one or more colorways from the list.

To select a range of items, hold down Shift as you select.
To select multiple items, hold down Ctrl as you select.

Alternatively, select All to print out all the colorways in the design.

Colors displayed in 
colorway summary 
table

Select Selected 

Hold down Ctrl to 
select multiple items
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5 In the Design tab, select Background if you want to include the background 
or fabric color with the colorway.

Tip  Select Crop to Design to crop the space around the design.
6 Click OK.
7 Click OK in the Print dialog or Print Now in the Print Preview dialog.

Tip  If the Production Summary option in the Print Options dialog is 
selected, a colorway summary table is printed together with design details. 
You can also print color blocks in the Colorway Summary table by selecting 
the Show Colors in Summary option in the Stop Sequence tab. See also 
Customizing report information.

Printing color film

The Color Film report option lets you print color blocks in the design as they 
appear in the Color-Object List. Consecutive objects of the same color form a 
single ‘color block’.

To print a color film
1 To access the Print Options dialog, select File > Print Preview.
2 Click Options.

Select to include
background on

worksheet

Design summary 
table

Colorway summary 
table
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The Print Options dialog opens.

3 Select the Color Film checkbox.
4 Click OK.

Separate color films are printed for selected colorways on the last page of the 
worksheet. See also Printing multiple colorways.

Sending designs as email attachments

You can attach designs to emails from the design window or via the Open dialog.

To send designs as email attachments
1 Do one of the following:

With the design open in the design window, select File > Send via Email, 
or 
Click the Open icon to display the Open dialog. Select the file to send, 
then right-click it. The popup menu appears. Select Send To > Mail 
Recipient.

Select Color
Film checkbox

Use Standard > Open to send a design as an email attachment.

Color film for 
select colorway
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Your default email system is launched and a new email created with the 
design file attached.

2 Enter mailing details and send.

Outputting designs as images

Designers frequently want to distribute their designs for viewing in real colors, 
in TrueView or otherwise, with or without fabric backgrounds. This might be for 
stock design sales purposes, for approval of digitized designs, or for 
presentation on the web or in catalogs. TrueSizer Pro lets you save both design 
images and production worksheets to disk or email them direct. See also 
Sending designs as email attachments.

To output a design as an image
1 Open the embroidery design.
2 Select File > Capture Design Bitmap.

The Capture Design Bitmap dialog opens.

Select Send To > 
Mail Recipient

Select Output 
option

Select Output 
format

Select image
selection option

Select to include
background color or

fabric
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3 Select a Selection option:

4 Select an Output option:

5 Select an output format for the screen image from the dropdown list – BMP, 
JPG, etc.

6 Select Include Background/Fabric to include the background color or 
fabric with the screen capture.

Option Purpose

Whole Design (1:1) Captures the screen image in a ratio of 1:1.
Current design 
window

Captures the screen image at the currently selected zoom factor.

Custom Lets you specify a capture area. After clicking OK, you are 
prompted to enter a ‘rectangle origin’ and ‘rectangle corner’ to 
define the area to capture.

Click to enter
rectangle origin

Click to enter
rectangle corner

Custom option – only 
specified area is captured

Option Purpose

Save to Disk Lets you save the screen capture to disk. After clicking OK, the 
Save Capture Screen dialog opens, allowing you to select a 
location, name and format for the captured design image.

Send via Email Lets you send the screen capture as email. After clicking OK, a 
new email message opens with the image attached.

Save & Send Lets you both save to hard disk and send as an email attachment.
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7 Click OK.

Printing appliqué patterns

Print a copy of appliqué patterns to use in cutting out fabric pieces. Each 
appliqué pattern piece is numbered according to the stitching sequence. One 
copy of the placement outlines is printed to show how their positions relate to 
each other. This copy is printed to fit one page. A second copy of the placement 
outlines is printed at 100% scaling, with each outline separated for use in cutting 
the fabric.

Note  Automatically create all the stitching you need for appliqué using the Auto 
Appliqué tool.

Tip  You can also extract appliqué shapes from a design to output to a cutter or 
to a separate file.

To print an appliqué pattern
1 Select File > Print Preview.
2 Click Options icon.

Image captured as 
Whole Design (1:1) with 
background fabric
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Print Options dialog opens.

3 Select Appliqué Patterns report type.
A specific report type exists for selectively showing/hiding appliqué patterns. 
This shows fabric, fabric name, and yardage. It also shows a summary on the 
first page.

4 Set General options as required. See Customizing print options for details.
5 Click OK.

Each appliqué pattern is numbered according to the stitching sequence.

6 Click Print Now.

Select appliqué
patterns report
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Processing Design Files

Embroidery designs are saved in one of two formats – ‘outline file’ format or 
‘stitch file’ format. Outline or ‘condensed’ files are high-level formats which 
contain object outlines, object properties and stitch data. When you open an 
outline file in TrueSizer Pro, corresponding stitch types, input methods and 
effects are applied. Outline files can be scaled, transformed and reshaped 
without affecting stitch density or quality. After modification, they can be saved 
to EMB format, or to a different format altogether. See also Supported file 
formats.

Stitch or ‘expanded’ files are low-level formats for direct use by embroidery 
machines. They contain only stitch coordinates and machine functions. They are 
generally created ‘on the fly’ when sending designs to machine. They can also 
be output to embroidery disk or paper tape. Stitch designs are generally not 
suited to modification because stitches are not regenerated.

Note  TrueSizer Pro also supports a number of proprietary embroidery disk 
formats. See Supported embroidery disk formats for details.

File sources & EMB format

The ‘all-in-one’ EMB file format contains a complete set of design information in 
a single file – object outlines and properties, actual stitches and machine 
functions, thread colors, a picture icon and comments. Even the original design 
bitmap image can be included in EMB format. Only native EMB files provide 
100% perfect scaling and transformation. See also The EMB advantage.

File source
While embroidery files are broadly classified as outline or stitch formats, 
TrueSizer Pro internally tags files as belonging to one of four types – Native 
Design, Imported Outlines, Processed Stitches, or Imported Stitches. 
For information about the source of a design file, refer to the Design Properties 
dialog. See Viewing design information.

File 
source Description

Native 
Design

Designs created in Wilcom professional embroidery design software (or 
equivalent).
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Note  Because EMB files can store stitches and/or design outlines, you can 
actually save stitch design files in EMB format without object outlines. However, 
TrueSizer Pro itself is not able to process and ‘recognize’ stitch files. 

Opening non-native formats
If you open a design which is not a native EMB, you will receive the following 
warning:

If you have an EMB file which is comprised of processed stitches, you will be able 
to resize this design and the software will recalculate the stitches for objects 
which were successfully ‘recognized’. The calculation will preserve the stitch 
density of the recognized objects. However, not all objects (or parts of objects) 
can be recognized. Therefore resizing will not be perfect as it would if you using 
a true native EMB file.
If you have an EMB file which is comprised only of imported stitches, or if you 
have opened a stitch file such as DST or EXP into TrueSizer Pro, the software 
will not recalculate the stitches. It is recommended that you do not scale this 
design more than ±5%. Enlarging the design too much may cause ugly gaps in 
the fills, while shrinking it too much may result in excessive stitching and thread 
breaks. See Opening stitch files for details.

Note  You can toggle on and off the non-native design warning using Help > 
Show Design Warning.

Opening stitch files

Stitch or ‘expanded’ designs are low-level formats for direct use by embroidery 
machines. They contain only stitch coordinates and machine functions. When 
you open stitch files, you can set decoding options to determine how to convert 

Imported 
Outlines

Designs read from non-EMB outline – CND or PCH – where stitches have 
been generated in TrueSizer Pro (or equivalent) from original outlines and 
stitching data.

Processed 
Stitches

Designs read from stitch files where stitches have been processed and 
regenerated with a Wilcom digitizing system such as EmbroideryStudio or 
DecoStudio.

Imported 
Stitches

Designs read from stitch files, where outlines may or may not have been 
recognized, but stitches have not been regenerated through stitch 
processing. Note, however, that if you change a stitch design – e.g. add a 
lettering object – the status changes to ‘Processed Stitches’ even though the 
imported stitches may not have been regenerated.

File 
source Description
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the design. Options vary with the type of stitch file you select. See also 
Supported file formats.

You can scale a stitch design just like a normal design. However, because the 
stitch count does not change, the density increases or decreases with the design 
size. Thus you should not scale stitch designs by more than ±5% or some areas 
may be too thickly or too thinly covered.

Note  Because EMB files can store both stitches and/or design outlines, you 
can actually save stitch files in EMB format without object outlines. In other 
words, depending on its source, an EMB file may in fact be a stitch file. See also 
File sources & EMB format.

To open stitch files
1 Access the Open or Open From Embroidery Disk dialog. See Opening 

designs or Reading designs from embroidery disk for details.

2 Select the stitch file to open. See Supported file formats for details.
The Options button is activated.

Tip  Limit the file listing by selecting a format from the Files/Designs of 
Type dropdown list – e.g. Melco (EXP).

3 Click Options.

Click to access 
stitch file options

Select design
type

Select stitch
file
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The Open Options dialog opens.

Note  Options vary with the type of stitch file you select. When opening CND 
designs, TrueSizer Pro gives you a completely different set of options. See 
Opening Melco CND outline files.

4 Select a different machine format from the Machine Type list as required.
5 Enter the number of jumps to recognize as trims.

When TrueSizer Pro encounters this number of consecutive jumps, it will 
convert them to a trim function. 

Caution  If this value is different from the original design, trim functions will 
be not be inserted correctly.

6 Use the Stop Code As options to select the output type for stop codes. Options 
may include Color Change, Stops, Custom. See also Manually reassigning 
colors to CND files.

7 Click OK and then Open.

Note  Only EMB designs contain the complete set of design information 
required for 100% perfect scaling and transformation.

Working with CND format

Melco Condensed (CND) is the native file format of the Melco embroidery 
digitizing software. CND files store only digitized outlines and stitch values. 
When you open CND designs in TrueSizer Pro, these outlines are scaled and 
stitches recalculated to preserve density.
TrueSizer Pro recognizes all Melco machine functions and stitch types, including 
Partition Lines and Complex Fill, and automatically converts them to EMB 
format. However, CND files do not contain quality features such as Pull 
Compensation or Auto Spacing, nor do they include actual stitches, thread 
colors, or design icons.
There are several versions of CND, all of which can be read by TrueSizer Pro. 
While these designs scale accurately, the number and placement of stitches may 
differ somewhat from the original design. You may notice some difference 
(±5%) in the stitch counts between original and converted files. This is because 
of differences in the software methods used to calculate stitches.
TrueSizer Pro cannot interpret certain specialty features of CND design objects 
because there is no direct equivalent. However, stock designs do not normally 
use these features and will generally convert without problem.

Select a different
machine format

Enter jumps to
recognize as trims

Select output type
for stop codes
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Tip  Before CND designs are stitched out, an EXP format file is created. The EXP 
stores the actual stitches and can be stitched directly. This file too can be opened 
in TrueSizer Pro. See Opening stitch files for details.

Opening Melco CND outline files

Melco Condensed (CND) is the native file format of the Melco embroidery 
digitizing software. CND files store only digitized outlines and stitch values. 
When you open CND designs in TrueSizer Pro, these outlines are scaled and 
stitches recalculated to preserve density.

Note  TrueSizer Pro cannot interpret certain specialty features of CND design 
objects because there is no direct equivalent. However, stock designs do not 
normally use these features and will generally convert without problem.

To open a Melco CND outline file
1 Access the Open or Open From Embroidery Disk dialog. See Opening 

designs or Reading designs from embroidery disk for details.

2 Select the CND file to open. See Supported file formats for details.
The Options button is activated.

Tip  Limit the file listing by selecting CND format from the Files/Designs of 
Type dropdown list.

3 Click Options.

Select CND
file

Click to access 
stitch file options
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The Condensed File Input Settings dialog opens.

4 In the Scale Factor panel, enter the scale at which you want to open the 
design.

5 In the Adjust panel, enter the spacing values to apply to the design as a 
percentage of the original values.
You can adjust Satin spacing, Run stitch length as well as Tatami spacing and 
length.

6 In the Auto Color Merge panel, choose whether you want to read thread 
color information from CND files.
This ensures that stitches are displayed in the correct colors when converted 
to EMB. See Color merging Melco CND files and Manually reassigning colors 
to CND files.

7 In the Effects panel, select the effects you want to apply to the design. 
These allow you to apply Auto Spacing, Stitch Shortening, Fractional Spacing 
and Fractional Spacing Offset.

8 In the Default Values panel, adjust the default values for Stitch Spacing, 
Stitch Length and Maximum Stitch Length as required.
If the CND design was created with values different to the factory settings, 
you can override them in these fields.

To save new settings as defaults, click Save.
To revert to the Melco factory settings, click Reset.

9 Click OK.
The selected design opens in the design window. You can scale the design 
directly on screen, or via the General Properties panel. You can also rotate, 
mirror and skew the design. See Modifying Designs.

Color merging Melco CND files

The Auto Color Merge feature reads thread color information for CND files from 
an associated TXT file so that stitches are displayed in the correct colors when 
they are converted to EMB. You can create this text file with a text editor such 
as MS Notepad. The text file must have the same file name as the CND file – e.g. 
Fish.TXT and Fish.CND. Both files must also reside in the same folder. For the 
Auto Color Merge function to work correctly, information in the text file must 
be entered in a certain format. 

Example text file: Fish
A typical text file might look like this:
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Fish
Uses curve effects
File: Fish
55.9mmW X 74.5mmH
ST: 6,780
Colors: 8
1. Tropical Sunset
2. Saffron
3. Pale powder Blue
4. Tropical Sunset
5. Pale powder Blue
Curve effect
6. Tropical White
7. Tropical Sunset
8. Pale powder Blue

Text file structure
All text files contain some or all of the following elements.

Reading Melco CND files with Auto Color Merge

When opening a CND file which has a TXT file associated with it, you must 
specify the thread chart used when the design was originally created in EDS (or 
other design software). The thread colors nominated in the text file will 
correspond to the selected thread chart. Alternatively, you can assign colors 

Text file 
element Mandatory Description Example

Design name This is the name of the design as it appears 
in File > Design Properties > Summary > 
Subject

Fish

Comments Lines inserted here appear under File > 
Design Properties > Summary > 
Comments.

Uses curve effects

File name This is the file name of the CND design file. 
The file extension should not be included.

File: Fish

Design size Enter the expected design size for the 
design. The actual design size is derived 
from the software.

55.9mmW X 74.5mmH

Stitch count Enter the expected stitch count for the 
design. The actual stitch count is derived 
from the software.

ST: 6,780

Number of colors States the total number of colors in the 
design.

Colors: 8

Thread name 1 Enter the first thread name. The name of 
the thread is searched against the Thread 
Chart. The thread name is shown in the File 
> Design Properties > Stop Sequence tab.

1. Tropical Sunset

Thread name 2 Enter the second thread name. 2. Saffron
Thread name 3 Enter the third thread name. 3. Pale Powder Blue
Thread name 4 Enter the fourth thread name. 4. Tropical Sunset
Thread name 5 Add any extra threads to this list. 5. Pale Powder Blue
Thread 
comments

Place comments below the relevant thread 
number

Curve effect

Thread name 6 6. Tropical White
Thread name 7 7. Tropical Sunset
Thread name 8 8. Pale Powder Blue
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manually to every Color Stop code in the file. See also Manually reassigning 
colors to CND files.

To read Melco CND files with Auto Color Merge
1 Access the Open or Open From Embroidery Disk dialog and select the CND 

file to open. See Opening Melco CND outline files for details.
2 Click Options.

The Condensed File Input Settings dialog opens.

3 Select a color merge option from the Auto Color Merge panel.
If you want to read thread color information for the selected CND file from 
an associated TXT file, select From File and follow the steps below.
If you want to assign colors manually to every Color Stop code in the file, 
select Custom and click Define Stop Sequence. See Manually 
reassigning colors to CND files for details.

4 If you are using Auto Color Merge from an associated text file, select a 
thread chart from the dropdown list.

Note  The thread colors nominated in the text file will correspond to the 
selected thread chart. If the color name does not correspond, it will default 
to black.

5 Click OK.

The design opens, the stitches appear in the correct thread colors, and the 
palette displays the selected thread chart.

Select thread
chart

Assign colors
manually

No chart selected – default colors 
assigned

Original colors correctly assigned 
from text file

One color not correctly matched – 
defaults to black
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Manually reassigning colors to CND files

When you open a CND file, a design without color code assignment uses default 
colors. You can, however, map thread colors to every Color Stop code in the file. 
This means you can color code stitch file designs which do not contain needle 
addressing information before opening the file.

Note  In order to assign colors correctly, you need to consult a Production 
Worksheet for the necessary color sequence information.

To manually reassign colors to a CND file
1 Check the existing CND file Production Worksheet.

2 Access the Open or Open From Embroidery Disk dialog and select the CND 
file to open. See Opening Melco CND outline files for details.

3 Click Options.
The Condensed File Input Settings dialog opens.

4 Select Custom and click Define Stop Sequence.

Without color code assignment With color code assignment

Thread chart for
selected file

Number of color
changes in design

(e.g. 8)

Select
Custom Select Define
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The Define Stop Sequence dialog opens. Initially the Building Stop 
Sequence grid is empty.

5 Select a thread chart and first color.

6 Click Assign Color.
The color and the description are entered at the current Stop in the Building 
Stop Sequence grid.
The selection moves to the next color in the thread chart. Two consecutive 
same colors are not allowed and Assign Color is disabled.

Note  Assigning a redundant Color function may trigger an error message. 
Use the Delete key to delete a selected entry in the stop sequence. Click 
Reset to reset all entries.

7 Click Assign Stop to enter an explicit Stop code.
Stop is entered in the Description field.

8 Use the Extra Stop Codes As panel to select the output type for extra stop 
codes. Options include Color Change, Stops, Repeat Sequence.

9 Repeat the operation as many times as indicated by the Production 
Worksheet.

10 Click OK.
The design will have the desired colors and the correct number of color 
changes.

Tip  You can convert color changes to an explicit Stop Code. You can also 
remove Color Stops by assigning the same color number to consecutive color 
blocks.

Select thread
chart

Select color

Click Assign
Color

Click Assign
Stop

Select how extra 
stops are to be 
interpreted
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Saving designs in CSD format

The CSD Save Options allow you to select between CSD Type I and Type II. 
Type II was introduced in CS 1.2B software for the POEM machine. It is also used 
by the Singer EU software for the POEM machine. Type II CSD files additionally 
store the thread color RGB values and also an icon of the design.

To save designs in CSD format
1 Select File > Save As.

The Save As dialog opens.
2 Select CSD from the Files of Type list.
3 In the File Name field, enter a name for the design.
4 Click Options.

The Save Options dialog opens.

5 Select the required CSD file type option.
6 Click OK and then Save.

Supported file formats

The table below lists the ‘outline’ and ‘stitch’ file formats supported by 
TrueSizer Pro.

Select CSD file 
type option

File Type Manufacturer Format Open Save As

10O Toyota Stitch
AMT60 Bernina ES Templates (V6.0) Outline
ART60 Bernina ES Designs (V6.0) Outline
AMT50 Bernina ES Templates (V5.0) Outline
ART50 Bernina ES Designs (V5.0) Outline
ART artista (V4.0) Outline
AMT artista Template Outline
ART42 Exploration Project Outline
ARX artista Cross Stitch Stitch
BRO Bits & Volts Stitch
CND Melco Outline
CSD Poem, Huskygram, Singer EU Stitch
DSB Barudan Stitch
DSN Nova Stitch
DST Tajima Stitch

* For reasons of compatibility, TrueSizer Pro lets you save in both current and previous 
versions of EMB including DecoStudio.
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Tip  For information about the source of a design file, refer to the Design 
Properties dialog. See Viewing design information.

DSZ ZSK Stitch
EMB * Wilcom Outline
EMT Wilcom Outline
EMX Wilcom Stitch
ESD Wilcom Stitch
EXP Melco Stitch
EXP Bernina Stitch
JAN Janome Stitch
JEF Janome, Elna, Kenmore Stitch
JMT Digitizer Template Outline
GNC Great Notions Stitch
HUS Husqvarna, Viking Stitch
INB Inbro Files Stitch
INP Wilcom condensed format Outline
KSM Pfaff Stitch
PCD Pfaff Stitch
PCH Gunold APS Outline
PCQ Pfaff Stitch
PCS Pfaff Stitch
PEC Deco, Brother, Babylock Stitch
PES Deco, Brother, Babylock Stitch
PMU Proel Stitch
PUM Proel DOS Stitch
SEW Janome, Elna, Kenmore Stitch
SHV Husqvarna/Viking Stitch
STC Gunold APS Stitch
STX Datastitch Stitch
TAP Happy Stitch
TBF Tajima Stitch
U?? Barudan Stitch
VIP Husqvarna/Viking/Pfaff Stitch
VP3 Husqvarna/Viking/Pfaff Stitch
XXX Compucon Stitch
XXX Singer Stitch
Z?? ZSK TC Stitch

File Type Manufacturer Format Open Save As

* For reasons of compatibility, TrueSizer Pro lets you save in both current and previous 
versions of EMB including DecoStudio.
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Chapter 2

Hooping Designs

Devices made from wood, plastic, or steel, hoops are used to tightly grip fabric 
and stabilizer between an inner and outer ring. Designed to hold fabric taut 
against the machine bed for embroidering, they attach to the machine’s frame. 
Fabrics must be hooped before stitching out on the machine. TrueSizer Pro 
allows you to select from a wide range of standard factory-supplied hoops.

This section deals with selecting and centering hoops, both manually and 
automatically. It also covers setting up and editing hoop lists.

Selecting & centering hoops

The Show Hoop tool allows you to toggle hoop display on or off. When 
activated, a hoop template representing the embroidery hoop you connect to 
your embroidery machine appears in the middle of the design window. The hoop 

Click View > Show Hoop to turn hoop display on or off. Right-click to change hoop 
settings.
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can either be centered automatically at the design center or at a fixed position 
– i.e. center of the design window (default) or a user-defined center point.

A range of hoop sizes is available for a wide variety of design types. From the 
hoop sizes available, select the smallest hoop which will accommodate your 
design. This will hold the fabric tight while stitching.

Note  These settings are digitizing functions only as the embroidery machine 
itself will always center the design. See also Setting automatic start & end 
points.

To select and center a hoop
1 Open your design and click the Show Hoop icon.

The current hoop is displayed. It may be too big or too small for your design.

2 Right-click the Show Hoop icon. 
The Options > Hoop dialog opens.

Choose required 
hoop
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3 Select a hoop from the droplist.

Note  Configure the hoop list via the My Hoops function to include only the 
ones you have available. See Setting up or editing a hoop list for details.

4 In the Position panel, choose how you want the hoop to be positioned.
Automatic Centering: Ensure that design is always centered in the hoop. 

Manual: Use the manual option to make sure the hoop display does not 
move from its original position. This means it won’t automatically center 
while you’re digitizing.
Manual > Set Hoop Center: Digitize a point on the design that the hoop 
will center around. See Selecting & centering hoops for details.

Tip  Always turn auto-centering back on to check that the design will fit within 
the hoop when it gets to the machine.

5 Click OK.
If you selected Set Hoop Center, click the point on the design or design 
window where you want to center the hoop.

Note  Whenever you choose a new hoop, it becomes the ‘current’ hoop until 
changed in the present or a future session.

6 Optionally, click the Zoom to Hoop icon, select View > Zoom > Zoom to 
Hoop or press Alt+0 to view the entire hoop in the design window.

Note  The production worksheet will state the selected/recommended hoop. 
See Customizing print options for details.

Design automatically
centered

Design remains in
same position
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Setting up or editing a hoop list

Configure the hoop list to include only those you currently have available for use. 
The list can be selected from a wide range of commercial brands.

To set up or edit a hoop list
1 Right-click the Show Hoop icon.

The Options > Hoop dialog opens.

Tip  This and the My Hoops dialogs will display the very first time you click 
the Show Hoop icon if there are no hoops currently set up.

2 Click the My Hoops button or select from the droplist itself.
The My Hoops dialog opens.

Tip  You can access this dialog directly via the Setup > My Hoops function.
3 Double-click or use arrow buttons to:

Add available hoops to the My Hoops list.
Remove hoops if for any reason they are redundant or unavailable.

4 Click OK.

Click View > Show Hoop to turn hoop display on or off. Right-click to change hoop 
settings.

Choose to configure 
your custom hoop list

Use the controls to add 
available hoops to your list
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Only these hoops will be available for selection. See also Selecting & centering 
hoops.



Wilcom TrueSizer Pro e3 Reference Manual 95

PART III

HARDWARE & SOFTWARE SETUP

In order to work with your particular equipment, TrueSizer Pro needs to be 
properly configured. You may also want to configure the software to your 
particular design requirements.

Using embroidery disks
This section describes the use of embroidery disks supported by TrueSizer Pro. 
If covers the formatting of embroidery disks, as well as reading and writing 
designs to them. It also deals with adjusting standard machine format settings 
to meet your machine’s specific requirements. See Using Embroidery Disks for 
details.

Changing system settings
This section describes how to change the TrueView display, grid spacing and 
positioning, and design window scrolling options. It also describes how to save 
designs automatically as you work. There is also information about how to adjust 
the pointer position display, paste position options, and other general options. 
See Changing System Settings for details.
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Using Embroidery Disks

Embroidery disks are specially formatted floppy disks used to transfer designs 
from computer to embroidery machine. You can format embroidery disks and 
save designs to them from within Wilcom TrueSizer Pro e3. The format you use 
will depend on the selected embroidery machine. You can also open designs 
from embroidery disk directly into TrueSizer Pro.

Reading designs from embroidery disk

You can open designs of other formats from specially formatted embroidery 
disks. See also Supported embroidery disk formats.

To read designs from embroidery disk
1 Insert the embroidery disk in your computer’s floppy disk drive.
2 Select File > Embroidery Disk > Open.

The Open Embroidery Disk dialog opens.

3 From the Look In list, select the floppy disk drive.
4 Select the disk format. Either:

Select the format from the Diskette Format list.
Select the Auto Detect checkbox and let TrueSizer Pro automatically 
determine the format. This generally takes longer.

5 Click OK.
The Open From Embroidery Disk dialog opens.

Select drive

Select format

Select design
type
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6 From the Designs of Type list, select a design type.
Any designs saved on disk are listed in the panel. If no designs are listed, 
make sure that the correct drive and disk format are selected.

Note  If the Options button is available, you can set recognition options for 
the design. See Processing Design Files.

7 Click Open.

Choosing floppy disks

Most embroidery machines are equipped with the same floppy disk drives as 
those used in PCs. So that you can transfer your embroidery designs, make sure 
that the floppy disk drive in your computer can read, write and format floppy 
disks that you can use with your embroidery machine.
If you want to stitch out a design, you must write it to a disk that is formatted 
for your embroidery machine. When formatting an embroidery disk on your 
computer, make sure you use the correct density of disk. For example, if your 
machine requires a Double Density (DD) disk, you must use one even if your 
computer has a High Density (HD) floppy disk drive.

Floppy disk types
Different types of floppy disk can store different amounts of data:

Caution  Use the disk type required by the embroidery machine, not the 
computer. For example, if a machine requires DD disks, you must use DD disks 
even though your computer may have an HD drive. If your machine can only 
read Single Density disks you may need to install a special floppy disk controller 
card in your computer. See Supported embroidery disk formats for more details.

Disk drives and floppy disks
Different types of floppy disk drive can read and write only certain capacity 
floppy disks:

Most computers have a High Density 1.44 Mb drive which can read both Double 
Density 720 Kb and High Density 1.44 Mb floppy disks. Most embroidery 

Capacity Density Code

360Kb Single-Sided Single-Density SS/SD
720Kb Double-Sided Double-Density DS/DD
1.44Mb Double-Sided High-Density DS/HD
2.88Mb also called Double-Sided 

High-Density
DS/HD

Computer Disk Drive SS/SD DS/DD DS/HD DS/HD

Single Density
Double Density
High Density 1.44 Mb
High Density 2.88 Mb
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machines use Double Density or High Density disks so there is usually no 
problem with transferring designs. 

Note  If your embroidery machine can only read Single Density disks, you need 
to install a special floppy disk controller card in your computer. Only a few special 
floppy disk controller cards can read Single Density disks. See also Supported 
embroidery disk formats.

Formatting embroidery disks

Embroidery disks must be formatted to suit the embroidery machine you intend 
to use or the machine will not be able to read the design. Most computers have 
a High Density 1.44 Mb drive which can read both Double Density 720 Kb and 
High Density 1.44 Mb floppy disks. Most embroidery machines use Double 
Density or High Density disks so there is usually no problem with transferring 
designs. See your embroidery machine’s manual for details of the appropriate 
disk type.

To format embroidery disks
1 Insert a 3.5" floppy disk of the correct density in your computer’s floppy disk 

drive.

Note  Use the disk type required by the embroidery machine, not the 
computer. For example, if a machine requires DD disks, you must use DD 
disks even though your computer may have an HD drive. If your machine can 
only read Single Density disks you may need to install a special floppy disk 
controller card in your computer. See Choosing floppy disks.

2 Select File > Embroidery Disk > Format.
The Format Embroidery Disk dialog opens.

3 From the Drive list, select the floppy disk drive.
4 From the Diskette Format list, select the required disk format.
5 Click OK.

A confirmation message appears.
6 Click OK to confirm.

Select floppy
disk drive

Select disk
format
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The Format dialog opens.

7 From the Capacity list, select the disk storage capacity.
8 In the Format Type panel, select the format option you require. Options may 

include Full, Quick, or Copy system files only.
9 In the Other Options panel, select the options you require. These may 

include No Label, Display Summary when Finished, and Copy system files.
10 Click Start.

A progress bar appears. You are prompted when formatting is complete.
11 Click OK to format another disk or Cancel to finish.

Note  If you have trouble with formatting a Melco embroidery disk, check if 
your floppy disk drive can read and write single density (SS/SD) floppy disks.

Saving designs to embroidery disk

Save designs to embroidery disk to stitch out on a specific machine. When you 
save to a new format, the design is converted to encode the machine functions 
and commands supported by the particular machine.

Note  Embroidery disks must be correctly formatted before you save designs to 
them. See Formatting embroidery disks.

To save designs to embroidery disk
1 Insert the embroidery disk in your computer’s floppy disk drive.
2 Select File > Embroidery Disk > Save As.

Select disk 
format

Select format 
option

Enter disk 
label
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The Save to Embroidery Disk dialog opens.

3 From the Look In list, select the floppy disk drive.
4 Select the disk format. Either:

Select the format from the Diskette Format list.
Select the Auto Detect checkbox and let TrueSizer Pro automatically 
determine the format.

Any designs already saved on disk are listed in the panel. 

Note  If the disk is not formatted, or its format is not correct, click Format. 
See Formatting embroidery disks.

5 If the File Number field is enabled, enter the file number. 
Not all machine formats require this information.

6 In the File Name field, enter a name for the design. 
7 From the Machine Format list, select the format for the design.

Some machines can read different formats. For example, some Tajima 
machines can read Barudan as well as Tajima formats. 

8 From the Design Type list, select the file type to save to embroidery disk.
Only one file type is generally available.

9 If available, select the Save Icon checkbox to include a thumbnail image of 
the design with the design file.
This icon appears in the machine control panel during stitch-out.

10 Click Save.

Caution  Wait until the light on the floppy disk drive stops flashing before 
removing the disk.

Supported embroidery disk formats

Embroidery machine manufacturers have selected different capacity disk drives 
and floppy disks to suit their requirements. The floppy disk drive in your 
embroidery machine may be different from the one in your computer. The table 

Select format
Select drive
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below lists the embroidery disk formats supported by TrueSizer Pro. See also 
Choosing floppy disks.

Note  Embroidery machine manufacturers constantly improve their models so 
use this table as a guide only. If you are in doubt as to which type of floppy disk 
to use, consult the manual for your embroidery machine.

Embroidery Disk Density Open Save As

Barudan 2HD DS/HD
Barudan FDR DS/DD
Barudan FMC DS/DD
DOS DS/HD
Happy DS/HD
Tajima DS/HD
Toyota DS/HD
ZSK DS/DD
ZSK TC DS/HD
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Changing System Settings

Different peripheral devices and system settings are set up in different ways – 
some in Windows, via the Control Panel, others within Wilcom TrueSizer Pro e3 
itself.

Calibrating the monitor

You need to calibrate your monitor so that designs at 1:1 scale appear at real 
size. Do this when you first install TrueSizer Pro or whenever you change your 
monitor.

To calibrate the monitor
1 Select Setup > Calibrate Screen.

The Calibrate Screen dialog opens.

2 Measure the height and width of the dialog box.
3 Enter the measurement in the Width and Height fields.
4 Click OK to return to the design window.

Setting up printers

Printers are added to the system through the Windows Printers panel and then 
selected for use through the Print option in the File menu.

To set up printers
1 Switch off the power to the PC and all attached equipment.
2 Set up the printer.

Use the documentation supplied with the printer to set up toner and ink 
cartridges, etc.

3 Connect the printer cable to a parallel port on the PC.
4 Switch on the power to all equipment.
5 Set up the printer through the Windows Printers panel using the Add Printer 

icon.

Measure width

Measure 
height
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The printer will have installation instructions and software. Refer to the 
printer installation instructions and the Microsoft Windows documentation.
The printer can be set up as the default printer through the Printer icon in 
the Windows Control panel. Once it is set up, it can be selected through 
TrueSizer Pro. 

6 Start TrueSizer Pro.
7 Select File > Print.

The Print dialog opens.
8 Select a printer from the Name list.

The currently selected printing device details appear below the Name list. 
The information indicates the current status, type of printer, location of the 
printer driver, and a comment.

9 Click Properties to adjust printer options.
The Printer Properties dialog opens. Refer to the documentation supplied 
with the printer for details. 

10 Click OK in the Printer Properties dialog to save changes to printer settings. 
11 Click Options to adjust Production Worksheet print options. See Customizing 

print options for details.

Setting measurement units

The first time you run TrueSizer Pro, the measurement system will default to 
whatever the operating system is using. You can use different measurement 
units within TrueSizer Pro without having to exit and change system settings. 
This is useful, for example, if you receive orders from places that use a different 
measurement system. The most common scenario is where a US customer 
orders lettering in inches – say ¾" – and the digitizing is to be done in metric. 
The digitizer can then easily enter ‘3/4"’ without having to first do any 
mathematical conversion to mm.

Accessing the feature
The measurement system may be changed via a droplist on the View toolbar:

Note  Technically, when you select ‘U.S.’, you will get the imperial measurement 
system – inches, feet, and yards.

Setting image viewing options

Use View > Design Measurement System to change measurement units within 
software without changing system settings. 

Select desired 
measurement unit

Use View > Show Bitmaps to show and hide bitmap images. Right-click to set 
image display options.

Use View > Show Vectors to show and hide vector graphics. Right-click to set 
image display options.
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You can dim bitmap image backdrops on screen to make it easier to view stitches 
when they are the same color as the image. You can also show colored vector 
graphics as outlines only. Dimming, however, only applies to bitmap images – 
you cannot dim vector graphics. Similarly, you can’t show bitmap images as 
outlines only.

To set image viewing options
1 Right-click either the Show Bitmap or Show Vectors icon.

The Options > View Graphics dialog opens.

2 To dim a bitmap image backdrop, select the Dimmed checkbox.

3 To view a colored vector graphic as outlines, select the Show Wireframe 
checkbox.

4 Click OK.

Setting grid display options

TrueSizer Pro provides a set of grid lines to help accurately align or size 
embroidery objects. The Show Rulers & Guides feature improves usability by 
allowing you to accurately position stitches and align objects in a design. By 

Dim bitmap image

Show vector outlines

Dimmed bitmap 
image

Original bitmap 
image

Vector outlines 
only

Original vector 
graphic
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default, rulers and guides are switched on. When they are switched off, guides 
are hidden but are stored in the design and will reappear when switched back on.

Note  Each design has its own set of guides and its own zero point for the rulers. 
When a design is saved, the ruler zero point and positions of the guides, if any, 
are saved with it.

Setting grid display

You can change grid spacing, select a reference point and turn Snap to Grid on 
or off in the Options dialog. By default, rulers and guides are switched on. When 
they are switched off, guides are hidden but are stored in the design and will 
reappear when switched back on.

To set the grid display
1 Right-click the Show Grid icon. 

The Options > Grid & Guide dialog opens.

2 Select the Show Grid checkbox to turn the grid on if not already activated.

Right-click View > Show Grid to set grid reference point and spacing.

Select to
display grid

Enter grid
spacing

Click to save for 
current template

Select to snap
design points

to grid
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3 Enter Grid Spacing values for horizontal and vertical grid lines.

Tip  To use these settings as defaults for the current template, click Save.
4 Select the Snap to Grid checkbox as required.

Reference points, control points or leading edges of objects snap to grid 
during digitizing, sizing, reshaping, or positioning operations. When any of 
these operations is taking place, grid lines change color temporarily to 
indicate that ‘snap to’ is active.

5 Choose a snap method in the Method list:

Tip  To temporarily disable Snap to Grid as you digitize, hold down Alt.
6 Select the Set Reference Point checkbox to align a significant point of the 

design with a grid line or grid point.
For example, you can set the grid reference point to the design center. This 
is easier and faster than moving the whole design.

7 Click OK.
If you selected Set Reference Point, mark the reference point on your 
design. The grid aligns so that horizontal and vertical grid lines intersect at 
this point.

Grid spacing: 20 mmGrid spacing: 5 mm

Snap to Grid
in X only

Snap to Grid
in X and Y

Option Purpose

In X and Y Snaps objects to the nearest horizontal and vertical grid line 
intersection.

In X Snaps objects to the nearest horizontal grid line.
In Y Snaps objects to the nearest vertical grid line.
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Setting ruler & guides display

Rulers are located to the top and left side of the design window. The unit of 
measurement – mm or inches – depends on the regional settings in the 
MS Windows® Control Panel. The ruler scale, illustrated with numbers and 
ticks, depends on the zoom setting. Guides are dotted vertical and horizontal 
lines placed across the design window to help you align objects. Rulers must be 
displayed before a guide can be created. 

To set the ruler & guides display
1 Right-click Show Grid or Show Rulers & Guides.

The Options > Grid & Guides dialog opens.

2 Select the Show Rulers & Guides checkbox if not already activated.
3 Select the Snap to Guides checkbox as required.

Reference points, control points or leading edges of objects snap to guides 
during sizing, reshaping, or positioning operations.

4 Click OK.

Tip  To temporarily disable Snap to Guides as you digitize, hold down Alt.

Right-click View > Show Rulers & Guides to set the Snap to Grid and Snap to 
Guides options.

Select to snap
design points to

guides

Select to Show 
Rulers & Guides
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PART IV

APPENDICES
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Troubleshooting

This section provides help for solving problems in Wilcom TrueSizer Pro e3. It 
includes procedures for checking your system’s requirements and settings, 
reverting to original values, and testing disks and connections. It also describes 
how to log errors, and lists causes for common error messages and problems.

Note  TrueSizer Pro creates a number of dump files that contain information on 
where the software failed, in order to quickly identify and correct any recurring 
problems. These are located by default in the C:\Program 
Files\Wilcom\TrueSizerPro_e3.0\Recover folder. A backup of currently 
open designs is stored by default in the ..\Backup folder.
For further Technical Support, please contact us through the links provided at 
the bottom of the page.

Color printing limitations

Standard color printing of designs may result in stitches being printed in colors 
other than those used in the design. Dithered colors used in your designs may 
be mapped to the primary colors provided by your printer driver. This limitation 
is dependent on the behavior of individual printer drivers. At worst this can result 
in the incomplete print out of the stitches. In this instance a color in your design 
has been mapped to white by the printer driver which is then printed as 
white-on-white.
If this problem appears, you may alternatively print the design in 3D View color 
or black and white. Turning off mapping for your printer is another way to 
overcome the problem. Refer to your printer’s user manual for details.

Deleting files with Purge Recovery

On rare occasions, a corrupted design may prevent TrueSizer Pro from starting 
up. Delete corrupt files using the Purge Recovery utility. Purge Recovery 
deletes files in the Recover and Backup folders.

To use Purge Recovery
1 Exit TrueSizer Pro.
2 On the Windows taskbar, click the Start button and select Programs > 

Wilcom TrueSizer Pro e3 > Wilcom Tools > Purge Recovery.
The Purge Recover and Backup Directories dialog opens.

Tip  To delete backup files as well, select Delete Backup files.
3 Click OK.



   Troubleshooting 110

If some files cannot be deleted, a message will display. Using Windows 
Explorer, delete these files from the C:\Program 
Files\Wilcom\TrueSizerPro_e3.0\Recover and ..\Backup folders 
manually.

Tip  If the errors persist, try reverting to factory settings. See Reverting to 
factory settings.

Reverting to factory settings

If you have made changes to the default settings in your software and you want 
to revert back to the factory settings, use the Revert utility.

To revert to factory settings
1 Exit TrueSizer Pro.
2 On the Windows taskbar, click the Start button and select Programs > 

Wilcom TrueSizer Pro e3 > Wilcom Tools > Revert.
The Revert to Factory Settings dialog opens.

3 Select the items you want restored to factory defaults.

Caution  Reverting to the original settings removes any changes you have 
made to styles, templates and hardware settings. New styles, templates and 
hardware settings are unaffected as they are saved separately.

4 Click OK.
The selected items are restored to factory settings. 

Note  There is no confirmation message.

Recommended PC specifications

Check that your PC meets the system requirements. Check CPU/RAM as well as 
hard disk space. The table below provides minimum system requirements.

Select items to be 
restored

Hardware item Minimum requirements

CPU Intel® Pentium® 4, AMD Athlon™ 64 or AMD Opteron™ or higher

* All with latest service packs installed
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Checking CPU/RAM specifications

Check your CPU and RAM specifications, and the version of Windows you are 
running to ensure they meet TrueSizer Pro requirements. See also 
Recommended PC specifications.

To check CPU/RAM specifications
1 On the Windows desktop, right-click the My Computer icon and select 

Properties.
The System Properties > General tab opens.

2 Check the Windows version, the CPU and the amount of RAM.

Checking your hard disk space

Check that your hard disk has enough space to run TrueSizer Pro effectively. 
See also Recommended PC specifications.

To check your hard disk space
1 Double-click the My Computer icon on your Windows Desktop.

The My Computer window opens.
2 Right-click the hard-disk drive icon (usually C:) and select Properties.

The Properties > General tab opens.
This tab shows the hard-disk capacity as well as any free space. This must be 
greater than 100 MB or 10% of your total hard drive space, whichever is the 
greater amount.

Operating system * • MS Windows® 8.1 (32-bit or 64-bit editions)
• MS Windows® 7 (32-bit or 64-bit editions)
• MS Windows Vista® (32-bit or 64-bit editions)

Memory Support for Highest Color (32bit) and resolution (1024 X 768) or 
higher

Monitor 15" at 1024 x 768 resolution
HDD 2 GB free space
Internet Required for product activation

Hardware item Minimum requirements

* All with latest service packs installed
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Glossary

The EMB advantage

Read and convert many popular file formats:  TrueSizer Pro lets you read 
designs of other formats so you don’t have to switch back and forth between programs. 
Read and scale Melco Condensed (CND) and APS condensed designs (PCH). Read and 
convert all popular machine stitch formats. All designs can be saved to Wilcom EMB 
format.

Resize your EMB designs:  With TrueSizer Pro you can resize native EMB designs 
maintaining all special effects and fills. TrueSizer Pro perfectly re-calculates stitches from 
original outlines.

Create multiple colorways for different fabrics:  Create and save multiple 
colorways in EMB format. Designs can be visualized on fabric swatches, garment images 
as well as production hoops.

Print out production worksheets:  Create production worksheets – color of course – 
and you don’t have to wait for faxed printouts from your supplier. All the color sequence 
information is saved in the EMB file. With TrueSizer Pro’s colorways feature, you can print 
multiple colorways, design backgrounds, and icons of color blocks with the production 
worksheet. Customer approval sheets can also be quickly generated. 

Make sales presentations and printouts:  Using TrueSizer Pro and EMB format 
designs, you can make sales presentations of your designs. Display and print designs in 
TrueView with or without background fabrics. Make sales printouts or save designs as 
bitmap files for use in other software.

Email your EMB files direct:  Send designs to customers or partners in original EMB 
format. Send by email and nothing else is required. Everything is saved in the one file – 
stitches, colors, production instructions, design outlines.

Output to embroidery disk format:  Using TrueSizer Pro, output designs to 
whatever machine disk format you require.

Guarantee quality of final stitchout:  Because EMB format combines original 
outlines (condensed data) with the full stitch data, customers will receive the design 
exactly as you created it, complete with any stitch edits you may have included. And they 
can still re-size the design from original outlines if they want to, with guaranteed 
re-scaling. No confusion switching between multiple expanded and condensed files.

FAQs

What’s different about Wilcom's ‘all-in-one’ EMB native file format?  EMB 
designs are created in Wilcom’s professional embroidery software. EMB format is like 
having CND and EXP together in the same file. All design information – outlines, stitches, 
thread colors and more – is saved in one file. This means designs can be scaled perfectly 
in TrueSizer Pro, even those with Wilcom’s modern fancy fills.

How do condensed ‘outline’ files differ from expanded ‘stitch’ files?  Stitch or 
‘expanded’ designs are low-level formats for direct use by embroidery machines. They 
contain only stitch coordinates and machine functions. These designs are generally not 
suited to modification. Because the stitch count does not change, the density increases 
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or decreases with design size. Thus you should not scale stitch designs by more than 
±5% or some areas may be too thickly or too thinly covered.

How do Wilcom EMB files differ from Melco CND?  Melco Condensed (CND) is the 
native file format of Melco embroidery digitizing software. CND files store only outlines 
and stitch values. TrueSizer Pro recognizes all Melco machine functions and stitch types, 
including Partition Lines and Complex Fill, and automatically converts them to EMB 
format. However, CND files do not contain specialty features such as Pull Compensation 
or Auto Spacing, nor do they include actual stitches, thread colors, or design icons.

Can I permanently convert my other designs to EMB?  Yes. TrueSizer Pro can 
read any of the popular embroidery machine formats, including Melco CND and EXP, 
Tajima DST, Barudan, Toyota, ZSK and Happy disks. You can then output to any expanded 
stitch format for stitching. Note, however, that TrueSizer Pro does not output to Melco 
CND.

Design window

Design window – displays designs for viewing and modification.

Backdrop:  An electronic image used as a guide for digitizing designs on screen. Two 
types are used – vector or bitmap. Insert them from various file sources, or copy and 
paste them via the MS Windows® clipboard.

Background:  Use to change the background color of the design window to match fabric 
color. Or display a background fabric for more realistic previews and presentations. The 
background is saved with the current colorway.

Capture design bitmap:  Capture designs as a bitmap image with or without 
background color or fabric.

Colors:  Show the number of colors (C) and stops (S) in whole design. See also Design 
Properties.

Colorways:  Preview a design in different colors on different fabrics by selecting from 
among pre-defined color schemes.

Design properties:  Check software version number and other design information. This 
Design Properties dialog provides stitching details as well as information about the 
file source – Native Design, Imported Outlines, Processed Stitches, or Imported Stitches.

Embroidery disk open:  Open designs of other formats from specially formatted 
embroidery disks. Save designs to embroidery disk for stitching on certain machines.

Mirror horizontally/vertically:  flips a design left or right, up or down.

Position:  Shows position of the design (X, Y) in the design window. See also General 
Properties.

Print:  Print production worksheets. These contain production information necessary for 
the machine operator to stitch the design correctly.

Print preview:  Use to preview a design and design information before printing 
worksheets or approval sheets.

Send:  Send the open design as an email attachment for approval or production 
purposes.

Show grid:  Turn grid lines on or off. Grid lines help you accurately place a design. Exact 
position coordinates are given at the bottom of the design window.

Slow redraw:  Redraw your design slowly. Slow Redraw lets you view the stitching and 
color sequence of a design at slow speed.

Small stitches:  Remove unwanted small stitches from a design automatically.
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Status bar:  Provides information about the whole design –  current stitch, design 
dimensions, number of colors (C) and stops (S), background settings. Note that the 
current stitch value changes when you drag the indicator in the Slow Redraw dialog and 
also when Slow Redraw is running.

Prompt bar:  Provides information about the currently selected tool. Also indicates 
currently selected hoop.

Stitch count:  View stitch count for whole design. See also Design Properties.

Zoom factor:  Check current zoom factor in relation to actual design size.

Zoom 1:1:  Display the design at its actual size.

TrueView:  See a 3D preview of your stitch-ready design.

File formats

10O:  Stitch Design file format native to Toyota machines.

CND:  Melco Condensed (CND) is the native file format of the Melco embroidery digitizing 
software. CND files store only digitized outlines and stitch values.

DSB:  Basically the same as the T03 tape file but with a ‘header’ in front so that it can 
be written to floppy disk – i.e. it is the floppy disk version of the T03 file.

DST:  Stitch Design file format native to Tajima machines.

DSZ:  SK Stitch Design or ‘expanded’ file format.

EMB:  EMB is the outline file format native to Wilcom software. EMB designs contain a 
complete set of design information in a single ‘all-in-one’ file – object outlines and 
properties, actual stitches and machine functions, thread colors, a picture icon and 
comments. Even the original design bitmap image can be included in EMB format. Only 
native EMB files provide 100% perfect scaling and transformation.

ESD:  Native DOS format of Wilcom DOS ES – contains stitch data, like stitch types and 
densities, which permits better processing. ESD in later versions contains lettering 
objects with outlines.

EXP:  Stitch Design or ‘expanded’ file format native to Melco machines.

KSM:  Pfaff Stitch Design or ‘expanded’ file format.

PCH:  Gunold Outline Design or ‘condensed’ file format.

PMU:  Proel Stitch Design or ‘expanded’ file format.

STC:  Gunold Stitch Design or ‘expanded’ file format.

STX:  Datastitch Stitch Design or ‘expanded’ file format.

T03:  ’Tape’ (old paper tape) version of Barudan file.

U??  Stitch Design file format native to Barudan machines.

XXX:  Compucon Stitch Design or ‘expanded’ file format in the professional market.

ZSK:  Strictly speaking, ZSK is an embroidery disk format. There are three ZSK encoding 
types – Zangs, ZSK1 and ZSK2. ZSK1 format is for older ZSK machines, generally those 
older than 1991. ZSK2 is for newer ZSK machines, those characterized by a single top 
thread trimmer. The trim is the most significant differentiating factor between the two 
types.

ZSK TC:  This format is for ZSK machines that accepts Transport Code Disks (DOS 
format disks).
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Design properties

Bobbin thread length:  This factor provides a simple mechanism for a more accurate 
bobbin thread length estimate. The default value (100%) is suitable for a design with a 
mixture of stitch types. If the design is all run stitches or all tatami, more bobbin thread 
will be used and the factor can be increased say to 125%. If the design is all satin stitch, 
the factor can be reduced to say 65%.

Color block:  A color block or ‘element’ corresponds to a color change in the design. It 
may be comprised of one or more same-color embroidery objects. These may form a 
single group – e.g. ‘ropes’ – or more – e.g. ‘ropes and birds’. Each color block, or element, 
can be given a descriptive name for easy identification. These then appear on the 
production worksheet. The operator generally uses them to ensure correct colors are 
used during production.

Design source:  While embroidery files are broadly classified as ‘outline’ (condensed) 
or ‘stitch’ (expanded), TrueSizer Pro internally tags files as belonging to one of four types 
– Native Design, Imported Outlines, Processed Stitches, or Imported Stitches.

Element name:  An ‘element’ is a block of sequential, same-color embroidery objects. 
You can enter names for them. The operator generally uses these to make sure colors are 
correct when stitching.

Imported outlines:  Designs read from non-EMB outline – CND or PCH – where 
stitches have been generated in TrueSizer Pro (or equivalent) from original outlines and 
stitching data.

Imported stitches:  Designs read from stitch files, where outlines may or may not 
have been recognized, but stitches have not been regenerated through stitch processing. 
Note, however, that if you change a stitch design – e.g. add a lettering object – the status 
changes to Processed Stitches even though the imported stitches may not have been 
regenerated.

Machine function:  Machine functions are commands for a specific embroidery 
machine. These include color changes, thread trims, jumps, machine stops, needles 
in/out, and boring begin/end. Schiffli makes a distinction between ‘logical’ and ‘physical’ 
machine functions.

Native design:  Designs created in Wilcom professional embroidery design software (or 
equivalent).

Processed stitches:  Designs read from stitch files where stitches have been 
regenerated by processing.

File recognition

Adjust:  Adjust: CND files use Melco stitch types which have their own spacing and 
length parameters. When loaded into TrueSizer Pro they are converted to native stitch 
types (Satin, Run, Tatami). The options in the Adjust panel let you adjust stitch density 
values to other than a one-to-one correspondence. For example, you might want Satin 
Spacing to be -10% with respect to the CND settings – i.e. 90%.

Color change:  Stop codes are interpreted as Next Color commands. The next color is 
selected from the default color palette.

Custom:  Lets you map thread colors to every stop code in the file. This means you can 
color code stitch file designs which do not contain needle addressing information, before 
opening the file.

Effects:  This set of options specifies which stitch effects should be active when you load 
a CND design. CND files do not contain information about these effects; setting these 
options instructs the software to apply the effects automatically to converted designs.
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Outline design:  Outline or ‘condensed’ files are high-level formats which contain 
object outlines, object properties and stitch data. When you open an outline file in 
TrueSizer Pro, corresponding stitch types, input methods and effects are applied. Outline 
files can be scaled, transformed and reshaped without affecting stitch density or quality.

Outline recognition:  When you convert a stitch file to outline format, TrueSizer Pro 
reads the data stitch-by-stitch according to the needle penetration points. The software 
then ‘recognizes’ stitch types, spacing and length values, stitch effects, and can 
determine object outlines.

Repeat sequence:  If you select fewer colors than the design requires, the selected 
colors are repeated. For example, if your design requires four colors and you’ve only 
selected two in the Building Stop Sequence list, colors 3 and 4 will be the same as original 
colors 1 and 2.

Scale factor:  This allows you to automatically scale CND designs as you load them. 
New dimensions are expressed as a ratio of the original design size. For example, to scale 
to 120% of the original, enter a scale factor of 1.2 in each field.

Stitch design:  Stitch or ‘expanded’ designs are low-level formats for direct use by 
embroidery machines. They contain only stitch coordinates and machine functions. Stitch 
designs are generally not suited to modification. Because the stitch count does not 
change, the density increases or decreases with the design size. Thus you should not 
scale stitch designs by more than ±5% or some areas may be too thickly or too thinly 
covered.

Stop code as:  If there are stops in the design, these can be read as either a Color 
Change function or as a Stop function.

Stops:  Stop codes are interpreted as Explicit Stops. The machine stops stitching.

Printing reports

Production worksheet:  The production worksheet is the link between the designer 
and the embroidery machine operator. It contains a design preview as well as essential 
production information, including the design size, the color sequence and any special 
instructions.

Approval sheet:  The approval sheet is intended for the customer, not production staff. 
Its function is to display designs in TrueView with or without a product or fabric 
background. Customers can see what they are ordering and approve accordingly. 

Information to print
The Information to Print options determine whether you want Full, Short, Only Stop 
Sequence or No Information on your worksheet. If you choose the Full option, you have 
the further option of customizing Blocks to Print and Columns in Stop Sequence.

Full information:  shows details specified in the Customize Worksheet dialog.

Short information:  shows summary information about the design. This and the 
previous option include information provided in the Summary tab of the Design Properties 
dialog.

Stop sequence:  lists all stops in the design together with the stitch number at which 
they occur, color number, and thread color name and brand.

None:  shows the design preview only.

Current colorway:  prints the design in the current colorway only.

Selected colorways:  prints multiple colorways.
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Graphics
Graphics options determine the design print options. The default (Standard) includes 
Outlines, Stitches, Connectors, and Machine Functions. When you print a design in 
TrueView, it will be printed by default in high resolution. (High resolution uses the printer 
resolution as opposed to the screen resolution.) If you select TrueView, the Draft Quality 
checkbox becomes available. Select this checkbox for quicker printing at lower resolution.

Backdrop:  An electronic image used as a guide for digitizing designs on screen. Two 
types are used – vector or bitmap. Insert them from various file sources, or copy and 
paste them via the MS Windows® clipboard.

Vector graphic:  Unlike raster images, vector graphics contain vector data. This is a 
collection of geometric shapes and lines that combine to make an image. Rather than 
pixels, such data is recorded as a set of mathematical formulas defining shapes such as 
rectangles, ellipses, curves, polygon stars, etc. These are created using vector graphics 
programs such as CorelDRAW® Graphics Suite. Vector graphics are scalable without 
distortion, and are usually much smaller than bitmap images.

Zoom options
Zoom options: these determine the zoom factor used for printing. This can be different 
from the zoom factor at which the design is currently displayed.

1.0:  Shows the design at its actual size.

Show all:  Scales the design to fill the available space on the worksheet.

Custom:  Lets you set a specific zoom factor.

General options
Print in English:  Deselecting this checkbox prints worksheets in the same language as 
the Windows operating system. This feature is useful when printing to plotters where the 
device driver does not support the character set you require.

Extents box around design:  Places an outline around the design.

Company name:  Prints a specified company name on the worksheet. Select a 
company name from the list, or enter a new one.

Customize worksheet
Blocks to print:  Left/Right/Up/Down: the margins between the edges of the design 
and the edges of the design area.

End X/Y:  Coordinates of the last stitch.

Max/min stitch:  Maximum and minimum stitch lengths in the design.

Thread chart type:  Thread chart name used in the design.

Thread usage:  Thread usage statistics by color.

Total bobbin:  Total bobbin thread length.

Columns in stop sequence:  Stitch Count: number of stitches per color.

Needle number:  Needle number corresponding to each color block.

Chart:  Name of thread chart.

Element name:  User-defined name to identify each color block.

Show colors in summary:  Includes actual color samples in the colorways summary 
table/s.
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Capture design bitmap
Selection options:  Whole Design (1:1): captures the screen image in a ratio of 1:1.
Current Design Window: captures the screen image at the currently selected zoom factor.
Custom: lets you specify a capture area. After clicking OK, you are prompted to enter a 
‘rectangle origin’ and ‘rectangle corner’ to define it.

Output options:  Save to Disk: lets you save the screen capture to hard disk. After 
clicking OK, the Save Capture Screen dialog opens, allowing you to select a location, 
name and format for the design image.
Send via Email: lets you send the screen capture as email. After clicking OK, a new email 
message opens with the image attached.
Both Save and Send: lets you both save to hard disk and send as an email attachment.

Embroidery disks

Embroidery disk:  Embroidery disks are specially formatted floppy disks used to store 
designs in stitch data format. They are primarily used to transfer designs from computer 
to embroidery machine. You can open designs from embroidery disks of various formats 
directly into TrueSizer Pro. Once a design is read, you can output it without change, 
modify it and output it in its original format, or save it as an EMB file. You can also format 
embroidery disks and save designs to them from TrueSizer Pro. The format you use will 
depend on the selected embroidery machine.

Design type:  The type of file saved to embroidery disk – usually only one type is 
available.

Format type panel:  Full: formats a blank disk or changes the disk format.
Quick: erases all data from the disk but does not reformat it.
Copy System Files only: copies system files without formatting the disk.

Other options panel:  To label the disk, deselect the No Label checkbox and enter the 
label name.
Select the Display Summary when Finished to view a summary dialog after formatting.
Select the Copy system files checkbox to copy system files to the disk. This makes the 
disk ‘bootable’ in DOS. See your Windows manual for details.

FDR:  An embroidery disk format native to Barudan machines.

FMC:  An embroidery disk format native to Barudan machines.

TFD:  An embroidery disk format native to Tajima machines.

ZSK:  ZSK1 format is for older ZSK machines, generally those older than 1991. ZSK2 is 
for newer ZSK machines, those characterized by a single top thread trimmer. The trim is 
the most significant differentiating factor between the two types.

Auto start & end

Auto start & end:  By default, connecting stitches are created from the start and end 
points to the center of the design. Select one of the nine preset end points.

Return to start point:  This option creates a connecting stitch from the end point to 
the start point.

Digitize auto start/end point:  This option creates connecting stitches from the start 
and end points to a point you define. If you select this, you are prompted to select the 
point after you click OK. Click the Separately checkbox to enter separate start and end 
points.
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Stitch spacing:  Stitch Spacing is the spacing between two consecutive needle 
penetrations on the same side of a column. The smaller the value, the greater the stitch 
density. For more open stitching, use larger values.

Tatami:  Tatami stitch is used to cover large, irregular design shapes. It is composed of 
specially arranged Run stitches. The stitches are laid in vertical rows going back and forth 
across the shape. The vertical rows can be parallel or slightly turning. The stitches are 
laid with an offset in each row to eliminate horizontal split lines and are close enough to 
give the appearance of a solid field of stitching.
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Index

A
anchor points, rotation 50
appliqué

outputting 76
printing patterns 76

Assign Thread tool 38
Auto Center 56
Auto Start and End dialog 56
automatic, color matching 38

B
backdrops, dimming 103
background

colors, changing 21
fabrics, changing 21
image, toggle on/off 35
images, changing 32
printing on production worksheets 71
products, changing 21

Background & Display Colors tool 21, 
30, 42

bitmap images
dimming 103
output designs as 74

brands, thread 42

C
Calibrate Screen dialog 102
Capture Design Bitmap dialog 74
CND

CND files, color merging 83
conversion options 82

codes, thread 42
color blocks, printing 72
Color dialog 43
color film, printing 72
color matching 38
Color Merge utility 83
Color toolbar

Background & Display Colors 30
Colorway Editor 18, 19, 30–41
Delete Colorway 30

Color-Object List
printing color film 72

colors
changing backgrounds 21
changing borer display 42
changing grid display 42
changing object outlines 42
changing stitch display 42
Colors dialog 21
display colors 42
merging Melco CND files 83
modifying colorways 30
modifying thread values 41
removing from thread charts 41
thread colors 28

Colorway Editor
Colorway Editor dialog 38, 41
Colorway Editor tool 19

Assign Thread 38
Background & Display Colors 21, 42
Current Colorway 19
Delete Colorway 29, 30
Edit Color 30, 41
Find Thread 38
Match All 38
My Thread Charts 38
New Colorway 29
Rename Colorway 30
Show Thread Details 38
Show Used Colors Only 30

colorways 28
basing on existing 29
changing display colors 42
Colorway Options dialog 71
creating 29
Current Colorway 19
default settings 30
modifying 30
multiple 28
printing 71
viewing 19

Condensed File Input Settings 
dialog 82–85

connectors
displaying 15
hiding 15

converting file formats
CND conversion options 82

converting outline designs
EMB to CSD 88

converting stitch designs
recognize Jumps as Trim 81

coordinates, length 8
CSD format, saving as 88
Customize dialog 69

D
Decoding Options dialog 86
Define Stop Sequence dialog 86
Delete Colorway tool 29–30
Design Properties dialog

Stop Sequence 26
designs

Auto Start and End 56
converting formats 78
naming elements 18
redrawing slowly 19

dialogs
Auto Start and End 56
Calibrate Screen 102
Capture Design Bitmap 74
Color 43
Colors 21
Colorway Editor 41
Colorway Options 71
Condensed File Input Settings 82–85
Create Colorway 29
Customize 69
Decoding Options 86
Define Stop Sequence 86
Design Properties > Stop 

Sequence 26
Display 21, 33–43
Display Options 33, 36
Edit Color 41
Format 98
Format Embroidery Disk 98
Guide Position 7
Hardware Setup 102
Length Calculation 25
Multi-Colorway Box 29
My Hoops 93
My Thread Charts 38
Open 73, 82
Open Embroidery Disk 96
Open From Embroidery Disk 96
Options > Grid 105
Options > Grid & Guides 107
Options > Hoop 91, 93
Options > View Drawing 104
Print 60
Print Options 63–76
Purge Recover and Backup 

Directories 109
Remove Small Stitches 57
Save to Embroidery Disk 99
Select Fabric Pattern 33
Slow Redraw 23
Stop Sequence Warning 86
Transform by Reference Line 49–52

dimming backdrops 103
display

changing display colors 42
Display dialog 21, 33–43
Display Options dialog 33, 36

distances, measuring on-screen 8
DOS disks, opening designs 96

E
Edit Color dialog 41
Edit Color tool 30
editing stitches, removing small 

stitches 57
elements, naming 18
email attachments 73
embroidery disks

formats 98
formatting 98
opening designs 96

F
fabrics

changing backgrounds 21
changing colors 21

Find Thread tool 38
Format dialog 98
Format Embroidery Disk dialog 98
functions

displaying 15
hiding 15
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G
General Properties dimensions 48
General toolbar

Show Hoop 90, 93
grid

changing display color 42
setting options 104
snap to 107

Guide Position dialog 7

H
Hardware Setup dialog 102
hardware, setting up display 

monitor 102
hiding

outlines 14
hoops

custom lists 93
selecting 90
setting centers 90

I
images

changing backgrounds 32
dimming bitmaps 103
output designs as 74

L
Length Calculation dialog 25

M
machine functions

displaying 15
hiding 15

Match All tool 38
measurement units, setting 103
measuring

distances on-screen 8
status line 8

Melco, CND files, color merging 83
Mirror

by Reference Line tool 55
Mirror Horizontally tool 54
Mirror Vertically tool 54
mirroring objects

around a specified axis 55
around X or Y axis 54
horizontally 54
vertically 54

modifying designs
moving objects 46

modifying objects
skewing

monitor, setting up 102
Multi-Colorway Box dialog 29
My Hoops dialog 93
My Thread Charts dialog 38

N
needle penetrations

displaying 15
hiding 15

new

New Colorway tool 29
Create Colorway dialog 29

O
object outlines

changing display color 42
hide/show 14

objects
moving 46
skewing 53

open
Open tool 4, 73
Open dialog 73, 82

Open Embroidery Disk dialog 96
Open From Embroidery Disk dialog 96
opening designs

from DOS disk 96
other formats 96

Options dialog
Grid 105
Grid & Guides 107
Options > Hoop 91

outlines
changing display color 42
displaying 14

P
position coordinates 8
positioning objects 46
Print

Print dialog 60
Print Options dialog 63–76

Print Preview tool 27, 62
Print tool 60, 62
printing

backgrounds 71
multiple colorways 71
Print Preview tool 60

production worksheets
color printing 60
customizing 69
printing 59, 60
printing backgrounds 71

products
changing backgrounds 21
templates, selecting 35

Property bar
scaling objects 48

Purge Recover and Backup Directories 
dialog 109

R
reassigning colors, to stitch files 86
redrawing designs 14

slowly 19
reference lines

mirroring objects 55
rotating by specified angle 52
rotating relative to 52

reference points
rotating using 52
rotating using (exact angle) 52
scaling objects with 49

Remove Small Stitches dialog 57
Rename Colorway tool 30
Rotate

Rotate tool 51
Rotate 45 degrees CCW tool 51
Rotate 45 degrees CW tool 51

rotating objects
by click-and-drag 50
on screen 50
using a reference line 52
using a reference line and angle 52

S
Save to Embroidery Disk dialog 99
Save tool 9
saving designs

CSD format 88
scaling objects

by click-and-drag 47
on screen 47
to an exact size 48
using Object Properties panel 48
using reference points 49

Select
Select Fabric Pattern dialog 33

Show
Appliqué Fabric tool 16
Background Image toggle 35
Background Image tool 32, 35
Bitmaps tool 16, 103
Bling tool 16
Functions tool 15
Grid tool 5, 105
Hoop tool 21, 90
Needle Points tool 15
Outlines tool 14
Rulers and Guides tool 6, 107
Show Vectors tool 103
Stitches tool 14
Thread Details tool 38
Used Colors Only tool 30
Vectors tool 16

skewing objects
by click-and-drag 53
Skew tool 53
with rotation handles 53

Slow Redraw
Slow Redraw tool 23
dialog 23

small stitches, removing 57
snap to grid 107
Standard toolbar

Open 4, 73
Print 60, 62
Print Preview 27, 60, 62
Save 9
Show Grid 5, 105
Zoom Factor 12

stitch files, reassigning colors 86
stitch usage, estimating total 25
stitches, changing display colors 42
system preferences, settings 102

T
templates, selecting products 35
thread charts, modifying threads 41
thread colors 28

matching 38
modifying threads 41

threads
brands 42
code 42
density 42
type 42

total stitch count, estimating 25
Transform by Reference Line

dialog 49–52
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Freely tool 52
Numerically tool 49, 52

Transform toolbar
Mirror by Reference Line 55
Mirror Horizontally 54
Mirror Vertically 54
Rotate 51
Rotate 45 degrees CCW 51
Rotate 45 degrees CW 51
Skew 53
Transform by Reference Line 

Freely 52
Transform by Reference Line 

Numerically 49, 52
transforming objects

mirroring (reference line) 55
rotating (reference line and 

angle) 52
scaling (reference points) 49

troubleshooting
reverting to factory settings 110

TrueView
tool 14
viewing designs 14

V
View Graphics, Options dialog 104
View toolbar

Auto Start and End 56
Show Appliqué Fabric 16
Show Background Image 32, 35
Show Bitmaps 16, 103
Show Bling 16
Show Functions 15
Show Hoop 21
Show Needle Points 15
Show Outlines 14
Show Rulers and Guides 6, 107
Show Stitches 14
Show Vectors 16, 103
Slow Redraw 23
TrueView 14

viewing colorways 19
viewing designs

connectors 15
functions 15
needle points 15
outlines 14
redrawing 14
redrawing slowly 19

W
worksheets, see production worksheets

Z
Zoom

Zoom Factor tool 12
Zoom to Hoop tool 21
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