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Typographic Conventions 

Type Style Description 

Example Words or characters quoted from the screen. These include field names, screen titles, 
pushbuttons labels, menu names, menu paths, and menu options. 
Textual cross-references to other documents. 

Example Emphasized words or expressions. 

EXAMPLE Technical names of system objects. These include report names, program names, 
transaction codes, table names, and key concepts of a programming language when they 
are surrounded by body text, for example, SELECT and INCLUDE. 

Example Output on the screen. This includes file and directory names and their paths, messages, 
names of variables and parameters, source text, and names of installation, upgrade and 
database tools. 

Example Exact user entry. These are words or characters that you enter in the system exactly as 
they appear in the documentation. 

<Example> Variable user entry. Angle brackets indicate that you replace these words and characters 
with appropriate entries to make entries in the system. 

EXAMPLE  Keys on the keyboard, for example, F2  or ENTER . 
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Document History 

Version Date Change 

1.0 2012-11-16 First version. 

1.1 2013-01-29 Add information about monitoring components, managing license 
allocations, assigning operational authorization to resellers, and managing 
reseller requests. 
Minor changes to extensions chapter to support more lightweight add-ons. 

1.2 2013-04-11 Add information about working with dynamic keys and troubleshooting 
problems using partner support user accounts. 

1.3 2013-05-20 Replace on-demand terminology with cloud. 

1.4 2013-10-12 Add information about working with SAP HANA and analytics services. 
Add chapter about managing security. 

1.5 2014-07-02 Provide more details about the power user 

1.6 2014-08-13 Update for SAP Business One Cloud 1.1 PL02: 
• Support Windows Server 2012 
• Enable SAP HANA tenant upgrade 
• Tenant Upgrade Simulation 
• Domain Groups Management 

1.7 2015-03-31 Update for SAP Business One Cloud 1.1 PL04 

1.8 2015-07-23 Update for SAP Business One Cloud 1.1 PL05:Support Browser Access 

1.9 2016-06-16 Update for SAP Business One Cloud 1.1 PL06: Support SAP HANA high 
availability (HA) solution 

1.10 2016-10-28 Update for SAP Business One Cloud 1.1 PL07: 
• New UAP installer 
• Linux installer for SLD and SLD Agent 
• SLD Agent task distribution 
• Google Chrome support 
• View login SBO users 

1.11 2017-01-13 Update for SAP Business One Cloud 1.1 PL08: SLQ 2016 support; UAP 
password change 

1.12 2017-09-04 Section 2 - Prerequisites: 
o SUSE Linux Enterprise Server 11 SP3/SP4, 12 SP1 supported 
o Windows Server 2016 supported  

Section 3.3 - Configuring Database Instances:  
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o CCC supports MSSQL and SAP HANA Database Server on one 
landscape 

Section 3.3.1. - Backing up Databases:  
o Updated content and added section 3.3.1.1 Backing Up SQL 

Databases and 3.3.1.2 Backing Up SAP HANA Databases 
Section 3.5 - Installing the License Server:  

o Added procedure to install the license server using the Server Tools 
installer  

Section 3.8 - Configuring Mailer:  
o Changed to "Job Service" and new sections added 

Section 4.1.2 - Installing the SLD and Cloud Control Center on Linux:  
o Updated screenshots for Linux installation of SLD and SLD Agent for 

1.1 PL09 
Section 4.4 - Installing the User Access Portal for Browser Access: 

o Edited introduction and note, updated screenshots of the B1 Cloud 
Setup Wizard for installing UAP for 1.1 PL09.  

Section 5.2 - Working with Microsoft Windows:   
o Windows Terminal Services Plugin no longer supported; rewrote 

section  
Section 6.5.5 - Registering Tenant Storage:  

o Step 3: Clarified the mount command use. 
Section 8.2.1.3 - Creating Tenants from Backups:   

o Added caution note and reference to SAP Note 2159531  
Section 9 - Managing Extensions:  

o Removed bullet on extensible fields and objects 
o Removed ELSTERLW from list 

Section 10.3 - Upgrading License Servers:  
o Added Step 4: Enter credentials in Configuration window 

Section 16.2 - Uploading Content to SAP:  
o Updated Prerequisites 

Section 16.3 - Troubleshooting Problems Using a Partner Support User 
Account 

o Updated button name and added description of new Expired In field 

1.13 2018-03-19 Section 4.4 - Installing the User Access Portal for Browser Access: 
o Updated screenshots of the B1 Cloud Setup Wizard for installing UAP 

for 1.1 PL10.  
Section 10.1 - Upgrading System Landscape Directory and Cloud Control 
Center  

o Updated screenshot of setup wizard for SLD service with new 
Database backup checkbox. 
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Version Date Change 

Section 10.5.1 - Performing Pre-Upgrade Tests and 10.5.2 Performing Tenant 
Upgrades: 

o Added the prerequisite that the source and target service unit are 
connected to the same license server  

Section 17.2.3 (new) - Setting New User Passwords:  
o Added procedure for setting new passwords for users in CCC.  

Section 17.2.3.1 (new) - Password Requirements Hint:  
o Added procedure for entering a description of password 

requirements in CCC Global Settings. 
Section 17.2.3 (new) - Database Privileges for Installing, Upgrading, and 
Using SAP Business One Cloud: 

o Roles and privileges to be granted to SAP HANA database user 
Section 17.3.3.1 (new) - Database Role PAL_ROLE for Pervasive Analytics  
Section 17.4 (new) - Database User Management:  

o Described database user and database privilege functions in CCC: 
o 17.4.1 (new) - Granting Privileges to Database Users 
o 17.4.2 (new) - Creating Database Users  

1.14 2018-06-08 Section 2 - Prerequisites: 
o SUSE Linux Enterprise Server 12 SP2 and SP3 supported. 
o SUSE Linux Enterprise Server 12 SP1, SP2, or SP3 for SAP 

Application supported.  
Section 4.1.2 - Installing the SLD and Cloud Control Center on Linux 

o Updated screenshot in Step 10 with new checkbox and added step in 
text.   

Section 6.5.4 - Registering Company Template Repositories 
o Added procedure for SAP HANA mount point 

Section 8.2.1.3 - Creating Tenants from Backups 
o Added prerequisites and updated procedure for SAP HANA service 

units 
Section 8.2.2 - Duplicating Tenants 

o Added Step 5: New Duplicate Tenant Level Database Users window 
and updated all screenshots.  

Section 9.4 - Deploying Extensions 
o Added Step 4: New Set Upgrade Time field in the extension 

deployment wizard.  
Section 11 - Managing Domain Groups 

o Removed reference to ON option in Global Settings → Domain 
Groups Management.  

Section 13.2 - Registering External Address Mapping 
o Added note that the internal URL is editable when registering 

mapping for SLD. The field value is displayed in Global Settings. 
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Section 14 - Message Service 
o Added new section on message service feature in CCC 

1.15 2018-09-17 Section 2 - Prerequisites 
o Microsoft SQL Server 2017 is supported from SAP Business One 

Cloud 1.1 PL12 (with SAP Business One 9.3 PL05) or later. 
Section 3.5 - Installing the License Server; 10.5.1 - Performing Pre-Upgrade 
Tests; 10.5.2 - Performing Tenant Upgrades 

o Added prerequisite to use one license server for Microsoft SQL and 
one for SAP HANA installed on a separate machine on the latest 
version and patch level 

Section 4.1.1. - Installing the SLD and Cloud Control Center on Windows 
o Updated screenshots for PL12. Added notes describing SLD 

installation mode window options.  
Section 6.1 - Registering Database Instances 

o In Step 2, added screenshot and note if a SAP HANA database 
instance is selected as the server type to describe the Connect Using 
SSL option. 

Section 6.3 -  Registering Presentation Servers 
o As of PL11, presentation server is selected using a dropdown list. 

Updated screenshot. 
Section 6.5.4 - Registering Company Template Repositories and 6.5.5 - 
Registering Tenant Storage: 

o Updated Step 3 - only first level shares are supported, and the mount 
point can only be created by adding a new line to the configuration 
file /etc/fstab. 

Section 8.1 - Creating Customers 
o In Step 2, added UPN Suffix field. 

Section 8.2 - Adding Domain Users to Customers 
o Updated steps related to UPN/ SAM account name in Add User and 

Confirmation window 
Section 8.3.1 - Modifying Domain User Data 

o Added new section to describe new Modify button on User 
Management tab 

Section 8.2.2 - Registering Tenants 
o Added new section to describe tenant registration wizard  
o Added note that user codes increased from 8 to 25 characters 

Section 9.4 - Deploying Extensions 
o Added prerequisites for deploying extensions based on SAP HANA 

XS  
Section 10.1 - Upgrading SLD and CCC 

o Added note and screenshot if using SAP HANA database 
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Section 11 - Managing Global Settings (previously Domain Groups 
Management) 

o 11.1 Managing Domain Groups (edited existing content) 
o 11.2 Managing System Users (new) 

Section 17.11 - Cleaning Up Audit Logs 
o Added description of new clean up audit logs function 

1.16 2019-01-18 Section 4.4.3 - Reconfigure User Access Portal Web App 
o Updated steps to reconfigure the User Access Portal web app using 

the setup wizard for SAP Business One Cloud in reconfiguration 
mode, which allows you to change the certificate for the User Access 
Portal. 

Section 6.1 - Registering Database Instances  
o In Step 2, added note with steps on how to enable secure 

communication between the SLD and SAP HANA database using the 
Secure Sockets Layer (SSL) protocol. 

Section 8.2.1.3 - Creating Tenants from Backup 
o Updated prerequisites and procedure for creating tenants from 

schema exports as the SLD Agent now supports backup/export 
functions. 

Section 8.2.4 - Exporting Tenants (new) 
o Describes new Export button on Tenants page that allows exporting 

SAP HANA schemas or backing up MS SQL tenant databases. 
Section 8.5.3 - Removing License Files (new) 

o Added procedure for removing a license file using the new Remove 
License File button. 

Section 11 - Global Settings 
o Deleted "System User Management" section.  

Section 11.1 - Managing Domain Groups 
o Impersonate option removed and replaced by On option. 

Section 11.2 - Controlling Permission to Add Domain Administrators to 
Customers (new) 

o Describes new Enable Add Domain Administrators to Customers 
option in global settings, which allows you to control permission for 
adding domain administrators to customers. 

Section 15.1 - Adding Cloud Operators 
o Added Step 6 to describe Read-Only Operator checkbox option when 

adding a new cloud operator. 
Section 18.2.4 - Managing Account for Active Directory Operations 

o Added section to describe how to set the account used to perform 
operations in the Cloud Control Center that require Active Directory 
access. 
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Version Date Change 

1.17 2019-04-26 - Removed references to SUSE Linux Enterprise Server 11 SP3 (no longer 
supported) 
Section 2 - Prerequisites 

o Windows Server 2019 supported  
Section 3.5 - Installing the License Server 

o Added note about unsafe changes to license server computer that 
can change the hardware key. 

3.8.4 - Configuring Mailer and Mail Scheduling Settings 
o Added procedure to enable Mailer for each company directly in SAP 

Business One. 
3.8.5 -Configuring Alert Service and Scheduling Settings 

o Added procedure to enable the alert service for each company 
directly in SAP Business One. 

3.8.6 - Monitoring and Controlling Deployment Status of Mailer and Job 
Service in the Cloud Control Center (new)  

o Added procedure to monitor and change the deployment status of 
Mailer service and job service in the CCC. 

Section 8.2.1.2 - Creating Tenants from Solution Packages 
o Added note about access permissions of cloud operators and 

resellers to Implementation Repositories. 
Section 8.2.1.3 - Creating Tenants from Backups 

o Added note about access permissions of cloud operators and 
resellers to Company Template Repositories.  

Section 8.3 - Adding Domain Users to Customers 
o Updated description of inactive user to indicate that other users can 

see this user as active in SAP Business One. 
Section 8.3.1 - Synchronizing Domain Users (new) 

o Added description how to synch domain users. 
Section 8.3.3 - Removing Domain Users (new) 

o Added description how to remove domain users from customers. 
Section 8.4 - Adding and Removing SAP Business One Users (renamed) 

o Added section 8.4.2 Removing SAP Business One Users to describe 
how to remove users in the CCC 

Section 9 - Managing Extensions 
o 9.6 - Controlling Reseller Access to Extensions (new) 
o Added section 9.6.1 - Managing Reseller Access to describe the 

options in the Reseller Access field, which can be used to control 
reseller access to the extension (All, None, or Custom).  

o Added section 9.6.2 - Assigning Resellers to Extensions to describe 
the process of assigning resellers to extensions using the Assign 
button on the Assigned to Reseller tab. 
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o Added section 9.6.2 - Unassigning Resellers from Extensions to 
describe the process of removing resellers from extensions using the 
Unassign or Remove All button on the Assigned to Reseller tab. 

Section 11 - Managing Global Settings 
o Added section 11.3 - Controlling Reseller Permission to Deploy 

Extensions to describe the new Enable Extension Deployment by 
Resellers option that allows operators to control if resellers can 
deploy extensions in SAP Business One Cloud. 

o Added section 11.4 - Enabling Two-Factor Authentication to describe 
how to enable 2FA for cloud operators, reseller operators, and 
customers. 

Section 15.2.6 - Assigning Storage to Resellers 
o Added note about access permissions of cloud operators and 

resellers to repositories. 

1.18 2019-08-01 Section 2 - Prerequisites 
o Support for SLES 12 SP4.  
o Support for SLES 15 SP1 and SLES 15 for SAP Application.  

Section 4.1 - Installing the SLD and Cloud Control Center  
o Added note that if you are using SAP HANA 2.0, follow procedure in 

SAP Note 2799556. 
Section 8.3.3 - Removing Domain Users 

o Added description of “Disable domain user in Active Directory” 
checkbox 

Section 6.1 - Registering Database Instances 
Divided original section into two: 

o 6.1.1 Registering Microsoft SQL Server Database Instances 
o Added note that as of SAP Business One Cloud 1.1 PL15, Windows 

Authentication is no longer available for new database instances. 
o 6.1.2 Registering SAP HANA Server Database Instances 

Described new fields in Database Instance Registration window. 
Section 8.2.1 - Creating Tenants 

o Added note that as of SAP Business One Cloud 1.1 PL15, Windows 
Authentication is no longer available. 

Section 11.1 - Controlling DI API Access to the Common Database  
o Added description of new global setting “Enable DI API to Access the 

Common Database” 
Section 11.6 - Controlling Reseller Permission to Register Tenants 

o Added description of new global setting “Enable Tenant Registration 
by Resellers” 

Section 18.2.4 Managing Account for Active Directory Operations 

https://launchpad.support.sap.com/#/notes/2799556
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o Added note that as of SAP Business One Cloud 1.1 PL15, you cannot 
use the built-in administrator account as the account for AD 
operations. 

1.19 2020-05-25 Section 2 - Prerequisites 
o Added note that SAP HANA 2.0 is supported as of SAP Business One 

Cloud 1.1 PL16 and later. 
4.1 - Installing System Landscape Directory and Cloud Control Center 

o Added note that the SLD and Active Directory controller should not 
be installed on the same machine. 

Section 4.1.1 - Installing SLD and Cloud Control Center on Windows 
o Added note that SAP Business One uses information including 

system number and hardware key from the SAP Business One 
landscape for statistical purposes. 

o Step 9: Described steps for specifying database information for 
MSSQL and SAP HANA separately. Described new fields for SAP 
HANA database.  

Section 4.1.2 - Installing SLD and Cloud Control Center on Linux 
o Step 11: Added note to describe new fields in the Database Server 

Connection window. 
o Added description of new SLD Hostname window. 

Section 4.6 - Installing the Web Client for SAP Business One (new) 
o Added descriptions of: 

Section 4.6.1 - Installing the Web Client on Windows  
Section 4.6.2 - Installing the Web Client on Linux  

7.1 - Creating Service Units  
o Added description of Tenant Limit field and updated screenshot.  
o Added Web Client and Electronic Document Service to list of 

components and procedure (Step 3). 
7.2 - Registering Software Components or Storage to Existing Service Units 

o Added Web Client and Electronic Document Service as new software 
components  

8.2.1.3 Creating Tenants from Backup 
o Added additional supported formats for export files (.tar and .tar.gz) 

8.2.2 - Registering Tenants  
o Added description of tenant limit for cloud operators and reseller 

operators  
8.3 Adding Domain Users to Customers  

o Added description how CCC identifies users created in Active 
Directory (Step 4) 

8.4.3 Importing SAP Business One Users (new) 
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o Added description of import users function on the User Management 
tab 

9 - Managing Extensions 
o Updated table of automatically registered add-ons with Datev2LW 

and EFMLW and removed automatic registration for Screen Painter 
and SBO Script. 

11.5 - Enabling the Launch Application Option in SAP Business One 
o Added description of new global setting Enable Launch Application 

Option in SAP Business One. 
11.8 - Controlling the Execution of Heavy Tasks on Presentation Servers 

o Added description of new global setting Allow Heavy Tasks to Run on 
Presentation Servers 

15.2.1 - Creating Resellers 
o Added description of Tenant Limit field in tenant creation wizard and 

updated screenshot.  
15.2.5 - Setting Tenant Limits for Resellers (new) 

o Added description and procedure for cloud operators on setting 
tenant limits for resellers  

17.3 - Troubleshooting Problems Using a Partner Support User Account 
o Support user session extended to 4 hours. 

18.2.4 - Managing Account for Active Directory Operations 
o Added description of LDAP over SSL option. 

18.4.3 - Creating Database Users 
o Added note that only cloud operators can create, edit, and delete 

database users. 

1.20 2021-01-18 o Updated menu item paths and names due to menu item 
reorganization in the Cloud Control Center.  

o Changed all "Country" field names to "Country/Region" 
3.8.1 - Installing Job Service on Windows 

o Specified that only if you are using SAP Business One 9.3 or earlier, 
you need perform step 11. 

4.7 - Installing the Integration Component for SAP Business One (new) 
o Inserted reference to Working with the Integration Framework of SAP 

Business One in Cloud Environments for instructions on 
prerequisites, installation, and configuration 

o Added note the if you are using B1i to connect to the DI API, you 
must enter the database user and database password in B1i each 
time. 

4.8 - Installing the Tenant Configurator for SAP Business One Cloud (new) 
o Added a description of the new solution and a link to the how-to 

guide. 
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6.1.2.1 - Configuring SAP HANA 2.0 in Cloud Environments to Enable Multiple 
Database Containers (new) 

o Added procedure for configuring SAP HANA 2.0 in a cloud 
environment and using multiple database containers 

6.1.2.2 - Setting Up Multiple Database Containers in SAP HANA 2.0 
Environments (new) 

o Added procedure for setting up multiple database containers in an 
existing SAP HANA 2.0 environment 

6.1.2.3 - Deleting SAP HANA Tenant Databases (new) 
o Added procedure to delete an existing tenant database in an SAP 

HANA 2.0 environment 
8.1 - Creating Customers and 15.2.1 Creating Resellers 

o Added description of new External ID field and link to global settings.  
8.4.1 - Adding SAP Business One Users; 8.5.5 - Assigning Licenses to Users 

o Added note in Step 3 that the license server is case sensitive; enter 
the user code for each SAP Business One company user in the exact 
same format for each tenant; otherwise, you will need to assign more 
than one license. 

9.7 - Managing Extension Security (new) 
o Added description of how to add and remove trusted certificates to 

enhance extensions security. 
11.4 - Enable Security Certificates for Extensions(new) 

o Added description of how to activate the new option Enable Security 
Certificates for Extensions. 

11.5 - Allow Resellers to Edit External IDs (new) 
o Added description of the new global settings option Allow Resellers 

to Edit External IDs, which allows cloud operators to control whether 
resellers can edit the External ID field. 

1.21 2021-23-04 Appendix 1 (new) 
o Added a list of the paths to installation and runtime log files for SAP 

Business One Cloud components and services 
5.2.3 - SAP Business One Microsoft 365 Integration  

o Added description of SAP Business One Microsoft 365 integration 
feature and link to how-to guide. 

6.4 - Registering Browser Access Servers 
o Added more details about the configuration of Browser Access 

servers in the Cloud Control Center. 
8.3 - Adding Domain Users to Customers 

o Added a note that the system enters domain user names in lower 
case.  
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1.22 2021-30-07 Section 2 - Prerequisites 
o Support for SLES 15 SP2  

4.3.1 - Creating Software Repositories  
o In Step 3, added a note that only the UpgradeCD folder is 

mandatory. 
7.1 - Creating Service Units 

o In Step 3, added the option to select Web Client for SAP Business 
One in Step 2 of the Service Unit Creation Wizard. 

o Removed the Browser Access Server selection from the wizard 
steps. 

8.2.1.1 - Creating Default Tenants  
o In Step 3, added a note that support users cannot be added to 

tenants. 
8.4.1 Adding SAP Business One Users  

o In Step 3, added a note that support users cannot be assigned to 
tenants. 

o In Step 3, added a note that the Assignment Reason field in the 
Assign Users window must be specified if the Operators area is active 
and a cloud operator or reseller operator is selected.  

10.1 - Upgrading the System Landscape Directory and Cloud Control Center 
o Added description of support user detection window. 

11.15 - Allow Operators to Assign Themselves as Users on Customer Tenants 
(new) 

o Described new global setting Allow Operators to Assign Themselves 
as Users on Customer Tenants. 

1.23 2022-06-05 1.2 Glossary  
o Updated description of power user authorizations 

2 - Prerequisites 
o Support for SLES 15 SP3 

3.5 - Installing the License Server  
o Updated procedure for installing the license server using the 64-bit 

SAP Business One Components Wizard. 
3.5.1 - Uninstalling the License Server on Windows (new)  

o Added procedure for uninstalling the license server on Windows 
using the SAP Business One Components Wizard. 

3.8.1 - Installing Job Service on Windows 
o Updated procedure for installing job service using the 64-bit SAP 

Business One Components Wizard. 
3.8.1.1 - Uninstalling Job Service on Windows  

o Updated procedure for uninstalling job service on Windows using the 
SAP Business One Components Wizard 
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6.4 - Registering Browser Access Servers 
o Enhanced Step 5 to describe the configuration of Browser Access 

servers in the Cloud Control Center 
7.2 - Registering Software Components to Existing Service Units 

o Listed software components that can only be registered once on a 
SU and those that can be registered multiple times.  

8.2.1 - Creating Tenants 
o Added a note to define the tenant shared folder structure 

9.4- Deploying Extensions 
o Enabled and Startup Mode field values can be found on the 

Extensions page, in the Extension Details area, on the Assigned to 
Tenant field.  
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1 Introduction 

The SAP Business One Cloud Administrator’s Guide provides a central resource for the technical implementation 
of SAP Business One in a cloud landscape. 

 Note  
For the latest information about installation and configuration issues that may not appear in this guide, 
see SAP Note 1923349. 

 
With SAP Business One Cloud, customers can access SAP Business One remotely, centrally hosted in data 
centers. Partners and customers benefit from the sharing of common resources, lower maintenance 
requirements, and ability to scale elastically as companies grow and the number of users increases. 
SAP's certified infrastructure and hosting partners provide a hosting infrastructure, typically a certified data 
center, and perform centralized management and maintenance of SAP Business One Cloud software 
components. Infrastructure partners can provide hosting services across several countries and industries. 
Resellers, also known as Value Added Resellers (VARs,) are companies that sell SAP software and provide first-
level support to their customers. Resellers market, sell, and implement customized SAP Business One Cloud 
solutions and provide ongoing support, consulting, and education services to customers. 
 
The SAP Business One Cloud Administrator’s Guide consists of the following main sections: 
• Prerequisites 

This section outlines the prerequisite steps you must complete before you can proceed with the installation 
and configuration of SAP Business One Cloud components. 

• Configuring the Server Landscape 
This section provides instructions for preparing the server landscape. In addition to SAP Business One 
components, you are required to install and configure several third-party components to provide remote 
access to SAP Business One. 

• Installing SAP Business One Cloud Components 
This section provides instructions for installing SAP Business One Cloud components, which include the 
following: 
o System Landscape Directory (SLD) 
o Cloud Control Center 
o SLD Agent Service 
o User Access Portal 

• Managing Remote Access 
This section assists you with configuring your remote access solution, for example Microsoft Remote Desktop 
Services or Citrix. 

• Registering Components Using the Cloud Control Center 
This section assists you with using the Cloud Control Center to register components in the SLD. After 
completing the registration process, you can group registered components together into service units. 

https://launchpad.support.sap.com/#/notes/1923349


 

2 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Introduction 

 

• Managing Service Units 
This section assists you with grouping registered components together into service units to provide users 
with full access to an SAP Business One installation. This section also includes information about monitoring 
components. 

• Managing Customer Components 
This section provides instructions for creating customers and provisioning tenants. The activities include the 
following: 
o Creating customers 
o Creating tenants 
o Creating company databases 
o Adding SAP Business One Users 
o Removing SAP Business One Users 
o Managing licenses 

• Managing Extensions 
This section assists you with using the Cloud Control Center to deploy, assign, and manage extensions for 
SAP Business One. 

• Upgrading SAP Business One Cloud 
This section provides instructions for upgrading an SAP Business One Cloud landscape and upgrading 
tenants to later versions of SAP Business One. 

• Managing Access 
This section assists you with using the Cloud Control Center to manage cloud operators, SLD clients, and 
resellers. Resellers are companies that market, sell, and implement customized SAP Business One Cloud 
solutions to customers. 

• Managing Global Settings  
This section assists you with performing various security and system configuration settings using the Global 
Settings window in the Cloud Control Center.  

• Managing Requests 
This section provides instructions for approving and rejecting requests for trials of SAP Business One Cloud 
from customers and requests from resellers. 

• Managing Support 
This section assists you with using the audit log (a time stamped list of all changes to System Landscape 
Directory resources) and uploading content to SAP Support. 

• Managing Security 
Explains how to implement a security policy and provides recommendations for meeting the security 
demands of the application. 

1.1 Components Overview 

This section provides a description of the important components of an SAP Business One Cloud landscape. 
Before you begin installing and configuring components, it is important to analyze the requirements of your 
business and customers to carefully plan the number and type of components required.  
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An SAP Business One Cloud landscape contains multiple physical or virtual machines. For the purposes of this 
document, it is not important whether a machine is physical or virtual. 

 Recommendation  
Use virtualization as this option offers numerous benefits, including performance improvements, easier 
manageability, and a lower total cost of ownership.  

The following figure shows the typical architecture of an SAP Business One Cloud landscape. 

 

Unlike an on-premise installation, in cloud deployments, the SAP Business One client application is not installed 
on end-user workstations. Instead, customers can access the SAP Business One application through one of the 
following approaches: 
• Use remote desktop connections to access the SAP Business One application, centrally hosted on 

presentation servers in a data center.  
SAP Business One users can enter their logon credentials on a secure Remote Desktop Web Access using a 
Web browser, which initiates a remote application instance. 

• Use a Web browser to access the SAP Business One application, centrally hosted on Browser Access servers 
in a data center. 
SAP Business One users can enter their logon credentials on a secure user access portal, which initiates an 
application instance in a Web browser.  
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Application data is stored and executed in the data center rather than locally, with only high-level graphical 
information delivered to client machines over the network. 
Central software components are shared across an entire cloud landscape. A System Landscape Directory 
(SLD) service maintains a registry of all components and how they are allocated to customers. The Cloud Control 
Center is an interface for the SLD service that operators can use to manage an SAP Business One Cloud 
landscape. You can register landscape components, add users, and create service units and tenants. 
The resources in an SAP Business One Cloud landscape are divided into service units to improve the overall 
manageability. A service unit is a collection of the software components, servers, and storage required to provide 
access to a full SAP Business One installation. All SAP Business One components in a single service unit are of the 
same version, and extensions are available to tenants of the service unit should they choose to use them. A single 
service unit can contain multiple tenants with similar requirements.  
A tenant represents a company database, storage, and licenses allocated to a customer to provide business 
functionality. A customer is an organization that has purchased a subscription to remotely access SAP Business 
One for a predefined period of time and specific number of named users, according to contractual conditions.  
Customers may have multiple tenants across different service units, with each tenant having a different 
application version or purpose, such as productive, demonstration, or testing instances. 
Customers’ data is stored in secure company databases and several files in dedicated directories, with access 
permissions granted on a per-user or per-tenant basis. SAP Business One Cloud landscapes can use either 
Microsoft SQL Server or SAP HANA as the database layer. Individual customers cannot see or access the data of 
other customers. An SAP Business One Cloud landscape requires the following shared folders for storing files: 
• Software Repository – The software repository is a shared folder accessible by all service units, containing 

SAP Business One installation packages, upgrade packages, and add-on installers. 
• Shared Folder – A folder assigned to a service unit that contains sub-folders dedicated to individual tenants, 

in which attachments, images, and document templates required to use SAP Business One are stored. 
• Implementation Repository – A global folder that stores SAP Business One solution package (.PAK) files, 

which you can use to create company databases. 
• Company Template Repository – A global folder that stores database backup files, which you can use to 

create company databases. 
• Tenant Storage – A folder assigned to a service unit that contains sub-folders dedicated to individual tenants, 

in which logs and company database backup files, used during tenant upgrades, are stored. 
• User Storage – A global folder that contains sub-folders dedicated to individual users, in which user-sensitive 

data and documents are stored. 

1.2 Glossary 

Term Description 

Analytics Service SAP Business One analytics powered by SAP HANA provides various analytical 
features, including enterprise search, real-time dashboards, Microsoft Excel interactive 
analysis, and predefined Crystal reports. 

Backup Service Enables you to export and import company schemas, as well as back up and recover 
SAP HANA database instances.  



 

SAP Business One Cloud Administrator's Guide 
Introduction 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  5 

 

Term Description 

Cloud Control Center An interface for the SLD service that cloud operators can use to manage an SAP 
Business One Cloud landscape. You can register infrastructure components, add users, 
and create service units and tenants. 

Cloud Operator An authorized Cloud Control Center user responsible for managing an SAP Business 
One Cloud landscape. Cloud Operators can belong only to a single customer, but can be 
reassigned to other customers. 

Common Database A central database containing system data, update packages, and add-ons. Multiple 
tenants in the same service unit share a single common database. 

Company Database A database that stores all business and transaction data. A single customer may 
require several company databases.  

Company Template 
Repository 

A global folder that stores database backup files, which you can use to create tenants. 

Customer A client organization that has purchased a subscription to remotely access SAP 
Business One for a pre-defined period of time and specific number of named users, 
according to contractual conditions.  

Extension An additional component for SAP Business One, developed by SAP or a third-party, to 
meet specific industry or niche business requirements. 

Implementation 
Repository 

 

Partner Support User An SAP Business One user account that is automatically created by the application 
during installation. Partners can use this account to access a customer's SAP Business 
One to troubleshoot problems for a limited amount of time. 

Power User In SAP Business One On Premise, the superuser can manage licenses, users, and add-
ons. However, in SAP Business One Cloud, the user and license management is 
centralized and managed by the cloud operator through the Cloud Control Center. 
To prevent a reseller from interfering with the centralized management, the SAP 
Business One client functionality must be restricted. Therefore, the superuser status is 
no longer available for resellers; the power user status has been introduced instead. 
When adding power users to the Cloud Control Center, if the user code does not exist in 
the company database, the new power user should have the same authorizations as 
superusers, except for the following: 
• Power users cannot manage licenses. 
• Power users cannot create new users in the SAP Business One client. 
• Power users cannot install add-ons. 
When adding power users to the Cloud Control Center that already exist in the 
company database (in other words, the user has Full Authorization for Power User in 
the Authorizations window in SAP Business One client), the Cloud Control Center 
inherits the user's current authorization.  

Presentation Server A server that provides tenants with remote access to the SAP Business One client 
application. 
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Term Description 

Presentation Server 
Farm 

A collection of presentation servers that provide remote access to the SAP Business 
One client application for a single service unit. 

Reseller A company that sells SAP software and provides first-level support to their customers. 
Resellers market, sell, and implement customized SAP Business One Cloud solutions 
and provide ongoing support, consulting, and education services to customers. 

Reseller Operator An authorized Cloud Control Center user, employed by a reseller, responsible for 
managing an SAP Business One landscape on behalf of their customers. Reseller 
Operators can have multiple assigned customers. 

Resource A service unit, customer, or license file assigned to a reseller. 

SAP Business One 
User 

A licensed SAP Business One user, who is a member of a customer that has purchased 
a subscription to remotely access SAP Business One Cloud. An SAP Business One User 
can belong only to a single customer, and cannot be reassigned to other customers. 

Service Unit A collection of the software components, servers, and storage required to provide 
access to a full SAP Business One installation. All SAP Business One components in a 
single service unit have the same version. A single service unit can contain multiple 
tenants with similar requirements. 

Shared Folder A folder assigned to a service unit that contains sub-folders dedicated to individual 
tenants, in which attachments, images, and document templates required to use SAP 
Business One are stored. 

SLD Agent Service An agent service that executes tasks on behalf of the SLD, such as performing 
database upgrades.  

SLD Client A client that can communicate with the System Landscape Directory using the SAP 
Business One Cloud API. 

Software Repository A shared folder accessible by all service units, containing SAP Business One installation 
packages, upgrade packages, and add-on installers. 

Storage A collective term for software repositories, shared folders, implementation 
repositories, and company template repositories.   

Superuser An SAP Business One User with additional permissions. In SAP Business One, 
superusers can do the following: 
• Access all windows and perform all functions 
• Limit the authorizations of users that are not superusers 

 Caution 
In a cloud environment, you can assign superuser permissions only to Cloud 
Operators. 

System Landscape 
Directory (SLD) 

A central directory of all SAP Business One components in a cloud landscape. A service 
provides information about software components and their settings, how resources are 
grouped into service units, and registered customers, tenants, and users. 

Tenant A company database, storage, and licenses allocated to a customer to provide business 
functionality. A customer may have multiple tenants across different service units, with 
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Term Description 

each tenant having a different application version or purpose, such as productive, 
demonstration, or testing instances. 

Tenant Configurator 
for SAP Business One 
Cloud 

A solution that allows you to automate the tenant configuration and creation process in 
the cloud.  

User Access Portal  A web site where users can enter their logon credentials to remotely access the SAP 
Business One application in the Browser Access mode. 

Browser Access 
Server 

A server that provides tenants with Web browser access to the SAP Business One client 
application. 

Web Client for SAP 
Business One  

A component that offers the SAP Business One core business logic and processes 
provided in the new SAP Fiori user experience. 
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2 Prerequisites 

• For information on hardware and software requirements, see the following:  
o SAP Business One Cloud Platform Support Matrix on SAP Help Portal. 
o Compatibility with the SAP Business One client application, which you can find in the patch overview note 

for the relevant version/patch in the SAP Business One Notes Knowledge Base. The central note for SAP 
Business One Cloud 1.0 (1791202 ) and central note for SAP Business One 1.1 (1923349)  list all patch 
overview notes. 

o  System Requirement Sizing Tool for SAP Business One Terminal Server and Browser Access, which you 
can search on SAPPartnerEdge.com.  

• You have configured the required number of machines, which have one of the following Windows Server 
editions installed: 
o Microsoft Windows Server 2019 Standard edition or Datacenter edition  
o Microsoft Windows Server 2008 R2 Standard edition or Enterprise edition 
o Microsoft Windows Server 2012 Essentials, Standard, or Datacenter edition 
o Microsoft Windows Server 2012 R2 Essentials, Standard, or Datacenter edition 
o Microsoft Windows Server 2016 Essentials, Standard, or Datacenter edition 
o Microsoft Windows Server Essentials, Standard, or Datacenter edition 

• If you are using Microsoft SQL Server for the database layer, you have installed one of the following on the 
landscape server and database servers:  
o Microsoft SQL Server 2019 Standard or Enterprise edition 
o Microsoft SQL Server 2017 Standard or Enterprise edition 
o Microsoft SQL Server 2016 Standard or Enterprise edition 
o Microsoft SQL Server 2014 Standard, Business Intelligence, or Enterprise edition  
o Microsoft SQL Server 2012 Standard, Business Intelligence, or Enterprise edition  
o Microsoft SQL Server 2014 Standard, Business Intelligence, or Enterprise edition  
o Microsoft SQL Server 2016 Standard or Enterprise edition  
o Microsoft SQL Server 2017 Standard or Enterprise edition 
o Microsoft SQL Server 2019 Standard or Enterprise edition 

 Note 
o Microsoft SQL Server 2012 is supported from SAP Business One Cloud 1.0 SP01 (with SAP Business One 

8.82 PL11) or later.  
o Microsoft SQL Server 2014 is supported from SAP Business One Cloud 1.1 PL06 (with SAP Business One 

9.1 PL12) or later.  
o Microsoft SQL Server 2016 is supported from SAP Business One Cloud 1.1 PL08 (with SAP Business One 

9.2 PL06) or later. 
o Microsoft SQL Server 2017 is supported from SAP Business One Cloud 1.1 PL12 (with SAP Business One 

9.3 PL05) or later. 

https://help.sap.com/
https://launchpad.support.sap.com/%23/notes/1791202
https://launchpad.support.sap.com/#/notes/1923349
https://partneredge.sap.com/
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o Microsoft SQL Server 2019 is supported from SAP Business One Cloud 1.1 PL16 (with SAP Business One 
9.3 PL13) or later. 

• If you are using SAP HANA for the database layer, you have installed one of the following: 
o SAP HANA Platform Edition 1.0 (supported as of SAP Business One 9.1 PL00, version for SAP HANA and 

SAP Business One 9.2 PL00, version for SAP HANA) 
o SAP HANA Platform Edition 2.0 (supported as of SAP Business One Cloud PL16) 
For more information about the prerequisites for SAP HANA, see SAP Business One Administrator's Guide, 
version for SAP HANA on SAP Help Portal.  

• If you are using SAP HANA for the database layer, you have installed one of the following server platforms: 
o SUSE Linux Enterprise Server 11 SP2, SP3, or SP4 (x86_64) (compatible with SAP Business One 9.x 

versions). 
o SUSE Linux Enterprise Server 12 SP1, SP2, SP3, or SP4 (x86_64) (compatible with SAP Business One 9.x 

versions). 
o SUSE Linux Enterprise Server 15 SP1, SP2, or SP3 (x86_64) (compatible with SAP Business One version 

10.0). 
• If you want to enable SAP HANA high availability solution, you must install SUSE Linux Enterprise Server 11  

SP4 for SAP Application (x86_64), SUSE Linux Enterprise Server 12 SP1, SP2, SP3, or SP4 for SAP 
Application (x86_64), or SUSE Linux Enterprise Server 15 SP1, SP2, or SP3 for SAP Application (x86_64) and 
SAP HANA. For more information about the prerequisites for SAP HANA high availability solution, see Setting 
Up SAP HANA Database High Availability for SAP Business One for Manual Failover  or  Setting Up SAP HANA 
Database High Availability for SAP Business One for Automatic Failover on SAP Help Portal. 

 Caution 
SUSE Linux Enterprise Server for SAP Application is different from SUSE Linux Enterprise server. 

• You have installed Adobe Reader on all presentation servers. 
• If you want to access the Web client for SAP Business One, be sure to use one of the following Web browsers: 

o Mozilla Firefox 
o Google Chrome 
o Apple Safari (Mac and IPad) 

2.1 Installation Checklist 

To perform a correct and complete installation and provide browser access to SAP Business One, do the 
following: 

 Configure the server landscape 
 Configure a Windows time server 
 Configure the domain controller 
 Configure database instances 
 Install certificates 
 Install the license server  
 Configure the Remote Desktop Web Access 
 Install job service 

https://help.sap.com/
http://www.help.sap.com/
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 Install SAP Business One Cloud components 
 Install the System Landscape Directory and Cloud Control Center 
 Install the SLD Agent Service 
 Create storage 
 Install the User Access Portal 

 Add optional cloud operators and optional resellers 
 Register components using the Cloud Control Center 

 Register database instances 
 Register license servers 
 Register storage 
 Register and create common databases 
 Register Browser Access servers 

 Create the required service units 
 Create customer components 

 Create customers 
 Create tenants 
 Add users 
 Assign licenses 

 Deploy and assign extensions 

 Note  
To run your extensions successfully, you must ensure that the Session ID of SAPbouiCOM.exe is the 
same as that of SAP Business One.exe. 
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If the Session IDs are not the same, you need to perform the following steps to change the identity to the 
launching user in the DCOM configuration of SAPbouiCOM.exe: 
1.    Stop the SAP Business One Browser Access Server Gatekeeper service. 
2.    In Windows Task Manager, end the SAPbouiCOM.exe process, if it exists. 
3.    Open Control Panel -> All Control Panel Items -> Administrative Tools -> Component Services, find 

SAPbouiCOM, right-click and choose Properties. 
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4.    On the Identity tab of the SAPbouiCOM Properties window, select The launching user, and choose 
the Apply button. 
5.    Start the SAP Business One Browser Access Server Gatekeeper service. 
SAPBouiCOM.exe will be started with the same session ID as SAP Business One.exe. 

 

 Note  
Since SAP Business One Browser Access is simulating the SAP Business One Windows desktop 
application, to fully display the screen elements, we recommend that you use a high resolution 
(1280×800 minimum), and maximize the Firefox window. 

 



 

SAP Business One Cloud Administrator's Guide 
Configuring the Server Landscape 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  13 

 

3 Configuring the Server Landscape 

This section provides instructions for configuring the server landscape in a cloud environment. An SAP Business 
One Cloud landscape contains multiple physical or virtual machines. For more information, see SAP Business One 
Cloud Platform Support Matrix. 
In addition to SAP Business One components, you are required to install and configure several third-party 
components to provide remote access or Web browser access to SAP Business One. 
Configuring the server landscape consists of the following main steps: 
• Configuring a Windows time server 
• Configuring the domain controller 
• Configuring database instances 
• Installing certificates 
• Installing the license server 
• Installing the remote support platform for SAP Business One 
• Configuring the presentation server farm 
• Configuring job service 

 
When configuring SAP Business One Cloud and third-party components, you can specify which TCP/IP ports to 
use. The following table lists the default ports: 

Component Port 

SLD 80 (HTTP), 443 (HTTPS) 

User Access Portal 443 (HTTPS) 

License Server for Windows (prior to SAP Business One 
9.2 PL05) 

30000 (TCP), 30001 (TCP)  

License Server for Linux (any version) and for Windows 
(SAP Business One 9.2 PL05 and later) 

40000 (TCP) 

Integration Component 8080 (HTTP), 8433 (HTTPS) 

Database Instance 1433 (TCP), 1434 (UDP) 

SAP Business One Analytics 1433 

Service Layer 50000 

App Framework 4300, 8000 

https://partneredge.sap.com/en/library/assets/products/ent_mng/sbo/about/sbo_cloud/platform_info/tr_d_sbo_cloud_psm/assetfile/Platform%20Support%20Matrix%20for%20SAP%20Business%20One%20Cloud.pdf
https://partneredge.sap.com/en/library/assets/products/ent_mng/sbo/about/sbo_cloud/platform_info/tr_d_sbo_cloud_psm/assetfile/Platform%20Support%20Matrix%20for%20SAP%20Business%20One%20Cloud.pdf
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3.1 Configuring Windows Time Server 

You must configure a Windows time server to ensure that all machines in an SAP Business One Cloud landscape 
use a common time. If the time is not synchronized across all machines, errors will occur during authentication 
processes. For more information about configuring a Windows time server, see www.microsoft.com. 

3.2 Configuring the Domain Controller 

The domain controller runs Active Directory and is responsible for the administration and security management of 
the entire network. The domain controller authenticates and authorizes domain users and resources, assigns and 
manages certificates, and enforces security policies. 

Prerequisites 

• You have installed Windows Active Directory Service. For more information, see www.microsoft.com. 
• You have configured the server role as Domain Controller. 
• You have created a new domain for the SAP Business One Cloud landscape. 

Procedure 

To configure the domain controller, do the following: 
 Configure the required domain user accounts and groups: 

 In the Active Directory Users and Computers console, create a service account named SAPServiceB1C in 
the new domain. 

 Create the required domain user accounts for all cloud operators and SAP Business One Users. 
 Create a domain group for each tenant and service unit.  

Each tenant group is a child group of its respective service unit group. 
 Add domain users to their respective tenant groups. 
 Enable personal folder roaming for all domain user accounts.  
 Use a group policy object to configure permissions.  

 Use a group policy object to configure registry key values for Hosting and SLDAddress on all machines. For 
the Hosting registry key, the type must be dword and the value 00000001. You must ensure all the required 
registry keys exist on all machines in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP\SAP Manage. 

 

http://www.microsoft.com/
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3.2.1 Configuring the Domain Controller with Multiple Domain 
Controllers 

If your setup includes more than one domain controller, you must perform additional configuration steps in order 
for all components to functional properly. These are as follows: 

o Configure the domain controller's priority and weight value: By default, the primary domain controller 
(PDC) and secondary domain controller (SDC) have the same weight and priority, so load balancing 
applies. Change the priority and weight so that PDC has the highest priority. 

3.3 Configuring Database Instances 

A database instance runs either Microsoft SQL Server or SAP HANA and includes all company databases and 
common databases for a single service unit. Note that as of SAP Business One Cloud 1.1 PL04, the Cloud Control 
Center supports both Microsoft SQL Server and SAP HANA database servers on one landscape. 

 Note  
If you use SAP HANA, the license server and mailer components run on Linux and not Microsoft Windows. 
SAP Business Cloud landscapes based on SAP HANA do not support the following: 
o Duplicating tenants 
o Creating tenants from software packages 
o Duplicating service units 

Prerequisites 

• If using Microsoft SQL Server, you have installed Microsoft SQL Server 2008 R2, 2012, 2014, 2016, 2019 
Standard or Enterprise edition on all database servers. 

• If using SAP HANA, you have installed SUSE Linux Enterprise Server 11 SP4 (x86_64), SUSE Linux Enterprise 
Server 12 SP1, SP2, SP3, or SP4 (x86_64), or SUSE Linux Enterprise Server 15 SP1, SP2, or SP3 (x86_64) and 
SAP HANA . For more information about the prerequisites for SAP HANA, see SAP Business One 
Administrator's Guide, version for SAP HANA on SAP Help Portal. 

Procedure 

To configure the required database instances using Microsoft SQL Server, do the following: 
 Change the logon account for the SQL Server service to Network Service. 
 In Microsoft SQL Server Management Studio, grant sysadmin security privileges for each partner domain 

group. 
 Enable the SQL Server Browser service: 

 In Windows, choose Start → Control Panel → Administrative Tools → Services. 
 Right-click SQL Server Browser and choose Properties. 

https://help.sap.com/
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 From the Startup type dropdown list, select Automatic. 
 Grant Microsoft SQL Server security privileges to cloud operators: 

 In Microsoft SQL Server Management Studio, add the corresponding domain groups or domain user 
accounts for cloud operators as SQL Server logins. 

 For each account, set the server roles as public and sysadmin. 
 Grant local administrator privileges to the SAPServiceB1C account for each database instance: 

 In Windows, choose Start → Control Panel → Administrative Tools → Computer Management. 
 In the Computer Management window, expand Local Users and Groups → Groups. 
 Right-click the Administrators group and choose Add to Group. 
 In the Administrator’s Properties window, add the SAPServiceB1C account. 

 
To configure the required database instances using SAP HANA, do the following: 

 Install and configure SAP HANA. For more information, see SAP Business One Administrator's Guide, version 
for SAP HANA. For information about installing SAP HANA Platform Edition 2.0, see Installing SAP HANA 2.0 
in Cloud Environments to Enable Multiple Database Containers. 

 After installing and configuring SAP HANA, ensure that you disable the SAP HANA password policy by setting 
force_first_password_change to FALSE in the SAP HANA configuration settings. 

3.3.1 Backing Up Databases 

Databases are always at risk of damage and it is vital to implement a security strategy. To keep the risk of data 
loss low, ensure that you develop a backup strategy that suits your business and the requirements of your 
customers. An important factor to consider is the volume of data that you process each day. In case of data loss, 
you are required to retrieve this data manually, back to the time of your last backup. 

 Recommendation  
Test your backup and recovery procedures thoroughly. Testing helps to ensure that you have the 
required backups to recover from various failures, and that your procedures can be executed smoothly 
and quickly if a failure occurs. 
The frequency of the backups depends on the following factors: 
o Processed data volume 
o Customer requirements 
o Number of users 

To avoid data loss, you must also regularly back up the following directories and storage: 
o Software repositories 
o Shared folders 
o Implementation repositories 
o Company Template Repositories 
o Tenant storage 
o User storage 
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3.3.1.1 Backing Up SQL Databases 

You can back up your SQL databases using SQL Server Management Studio or the backup functionality of remote 
support platform for SAP Business One. For information about backing up SQL databases, see the SAP Business 
One Administrator's Guide.  

3.3.1.2 Backing Up SAP HANA Databases 

You can back up SAP HANA databases using SAP HANA studio or the backup service component of the remote 
support platform available for SAP Business One, version for SAP HANA (available as of SAP Business One Cloud 
1.1 PL06). For more information about backup service support for SAP HANA databases in SAP Business One 
Cloud, see SAP Note 2297466. 

 Note  
The backup service component can be installed on a different machine from the SAP HANA machine and 
can be configured to back up multiple remote SAP HANA servers.  

Procedure:  

1. To configure the backup service of the remote support platform for SAP Business One, see Configuring 
Backups in the online help for the remote support platform for SAP Business One.  

 Note  
As of the remote support platform for SAP Business One version 3.2 PL02, you can perform the following 
backup service tasks for SAP HANA: 
o Export SAP HANA company schemas  
o Back up SAP HANA server instances  
o Upload an SAP HANA backup to SAP Business One  

2. To install the backup service component on an SAP HANA server, see Wizard Installation in the 
Administrator's Guide for SAP Business One, version for SAP HANA.  

 Note  
If you need to add a new SAP HANA database to the backup service, see Reconfiguring the System in 
Administrator's Guide for SAP Business One, version for SAP HANA. 

3.4 Installing Certificates 

The following certificates are required for an SAP Business One Cloud landscape: 
• Certificates for Remote Desktop Services  

https://launchpad.support.sap.com/#/notes/2297466
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Remote Desktop Services components require certificates for authentication. For more information, see 
www.microsoft.com. 

• Certificates for the System Landscape Directory  
If you select Hypertext Transfer Protocol Secure (HTTPS) as the web protocol the SLD uses for connections, 
a certificate is required for authentication. For more information, see Installing System Landscape Directory 
and Cloud Control Center. 

You can acquire the necessary certificates using either of the following methods: 
• Third-party Certificate Authority 

You can purchase certificates from a third-party global certificate authority that Microsoft Windows trusts by 
default. 

• Certificate Authority Server 
You can configure a Certificate Authority (CA) server in the SAP Business One Cloud landscape to issue 
certificates. If you choose this method, you must configure all servers in the landscape to trust the CA’s root 
certificate.  

3.5 Installing the License Server 

A license server is a central component that manages the application license mechanism. Since the license server 
is compatible with all versions of SAP Business One, multiple service units can share a single license server. 
For more information about installing and configuring a license server, see the SAP Business One Administrator’s 
Guide. 

 Note  
For the integration component and job service to function correctly in cloud environments, in the SAP 
Business One License Manager, register any common databases and ensure you select the Use Trusted 
Connection checkbox. 

To avoid accidentally changing the hardware key, do not perform the following actions on the license server 
computer: 

Windows:  
• Changing the security identifier (SID) 
• Changing the computer name  
• Changing the virtual machine identifier  

Linux: 
• Changing the virtual machine identifier  

You can check the hardware key of the license server in the Cloud Control Center. To do so, choose Central 
Components → License Servers. In the License Server Details area, on the Configuration tab, check the value in the 
Hardware Key field. 
 
The following procedure describes how to install the license server by using the SAP Business One Components 
Wizard. 
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Prerequisite 

• You have installed the SLD Agent Service. For more information about installing the SLD Agent, see section 
4.2. Installing SLD Agent Service.  

• If you are using both Microsoft SQL and SAP HANA databases, ensure that you have one license server for 
each product version (in other words, one license server for Microsoft SQL and one for SAP HANA) installed 
on a separate machine on the latest version and patch level of SAP Business One and SAP Business One, 
version for SAP HANA.  

Procedure 

[On Windows] 
 In the SAP Business One installation folder, navigate to the directory …\Packages.x64\ 

ComponentsWizard. 
 Run the install.exe file. 
 In the welcome window of the wizard, choose Next.  
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 In the Specify Installation Folder window, specify a folder in which you want to install the license server and 
choose the Next button.  

 
 In the Select Features window, select the License Manager checkbox. Ensure that the System Landscape 

Directory checkbox is deselected and choose the Next button. 
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 In the Network Address window, select the IP address, or use the hostname, of the license server for SAP 
Business One Cloud and choose Next. The hostname is automatically populated with the fully qualified 
domain name (FQDN). 

 
 In the Service Port window, specify a port number that is to be used by the license server for single single-on 

(SSO) and choose Next. The default port number is 40000.  
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 In the Specify Security Certificate window, specify a security certificate and choose Next. You can also choose 
to use a self-signed certificate. For information about obtaining a certificate, see the Administrator's Guide for 
SAP Business One. 

 
 In the Landscape Server window, enter the SLD server address and port, site user ID and password for SAP 

Business One Cloud, and then choose Next. 
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 Note  
For the site user ID and password, use credentials for a domain account that is a cloud operator with local 
administrative privileges. 

 
 In the License Server Node Type window, choose to install the license server as either a standalone node or 

high availability primary or secondary node. If you are using high availability, in the License Server Node Type 
window, enter the virtual address URL. If you chose High Availability Secondary Node, enter the address and 
port of the primary node. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 In the Review Settings window, review your settings and then choose Start to start the installation. 
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 In the Setup Progress window, when the progress bar displays 100%, choose Next to finish the installation. 
 In the Setup Process Completed window, review the installation results, and then choose Finish to exit the 

wizard. 
 

Note 
To upgrade the license server to a higher version, run the SAP Business One Component Wizard. The SAP 
Business One Component Wizard detects previous versions of the license server and performs an 
upgrade to the latest version. 

 
[On Linux] 
If you use a service unit with the SAP HANA database platform, you must install the license server (version for 
SAP HANA) on a Linux machine. For more information about installing and configuring a license server (version 
for SAP HANA), see the SAP Business One Administrator’s Guide, version for SAP HANA. 

3.5.1 Uninstalling the License Server on Windows 

The following procedure describes how to uninstall the license server on a Microsoft Windows machine. 
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Procedure 

 Navigate to the SAP Business One installation folder (C:\Program Files\SAP\SAP Business One 
SetupFiles\) and run the setup.exe file.  
Alternatively, on your workstation, in the Programs and Features window, select SAP Business One 
Components Wizard and then choose Uninstall. 

 In the welcome window of the wizard, select Uninstallation. 
 In the Select Features window, select the License Manager checkbox and choose Next. 

 
 In the Review Settings window, review your settings and then choose Start to start the uninstallation 
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3.6 Installing the Remote Support Platform for SAP Business 
One 

You can optionally install the remote support platform for SAP Business One. After installing the remote support 
platform, change the logon account for the corresponding Windows service to the SAPServiceB1C account. 

 Note 
In cloud environments, you can optionally configure the remote support platform to use the HTTPS 
protocol for connections. To do so, a certificate is required for authentication. You can use the same 
certificate as the one you use for the System Landscape Directory. For more information, see Installing 
Certificates. 

For more information about installing the remote support platform, see the Administrator’s Guide to Remote 
Support Platform and Remote Support Platform Studio for SAP Business One. 

3.7 Configuring the Presentation Server Farm 

A presentation server farm is a collection of presentation servers that provide remote access to the SAP Business 
One client application for a single service unit. The domain controller, connection broker, and gateway server 
facilitate connections to presentation servers. 
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 Note  
This section assumes that you are using Microsoft Remote Desktop Services to provide remote access to 
SAP Business One. If you are using a different remote access solution, such as Citrix, see the appropriate 
third-party documentation. 

 Caution 
Using dashboard widgets with animations may cause performance issues when accessing SAP Business 
One remotely.  

Procedure 

To configure the presentation server farm, do the following: 
 Install and configure Remote Desktop Services on the following machines: 

o Remote Desktop Web Access server – Configure the server roles as Remote Desktop Gateway and 
Remote Desktop Web Access. 

 Note  
You must configure the Web Portal Server to use a certificate for authentication. For more information, 
see Installing Certificates. 

o Connection Broker – Configure the server role as Remote Desktop Connection Broker. 
o Presentation Servers –Configure the server role as Remote Desktop Session Host. 

 On the connection broker, add the presentation servers to the Session Broker Computers group. 
 On each presentation server, configure the server to participate in connection broker load-balancing using 

the connection broker you previously configured. 
 Install the required version of the SAP Business One client application on each presentation server. The client 

application must have the same version as the other SAP Business One components in the service unit.  
Alternatively, you can use the Cloud Control Center to deploy the client application to a presentation server.  
For more information about installing the SAP Business One client application, see SAP Business One 
Administrator’s Guide. 

 Caution  
Cloud environments support only SAP Business One 8.82 PL03 and later. 

 Note  
During the installation process, you are required to enter the name of an RD Licensing Server. You must 
ensure that you enter the name of an RD Licensing Server that you configured in the RDS infrastructure. 

 Configure SAP Business One as a RemoteApp: 
 On the connection broker, add the presentation server farm as a RemoteApp source. 

 Caution 
Ensure you do not enter the name of each presentation server in the presentation server farm as a 
RemoteApp source, otherwise users see multiple instances of RemoteApp icons. 

 On each presentation server, do the following: 
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o Use the RemoteApp wizard to configure SAP Business One as a RemoteApp.  
o Specify the tenant domain groups for which you want to enable connections to SAP Business One. 

 [Optional] Configure mobile device access: 
 Use an account with power user or superuser privileges to log on to SAP Business One. 
 From the SAP Business One Main Menu, choose Administration → License → License Administration. 

Assign B1i licenses to users for whom you want to enable mobile device access. 
 From the SAP Business One Main Menu, choose Administration → Setup → General → Users. 
 In the Users – Setup window, do the following on behalf of each user for whom you want to enable mobile 

device access: 
o Select the Mobile User checkbox. 
o Specify values for the Mobile Phone and Mobile Device ID fields. 

 For more information, see Setting Up the Mobile Scenario in Integration Component in the 
…\Documentation\B1 Integration Component folder. 

 [Optional] Install Data Transfer Workbench (DTW): 
 Install DTW on each presentation server. DTW must have the same version as the other SAP Business One 

components in the service unit. 

 Caution 
Cloud environments support only Data Transfer Workbench 8.82 PL08 and later. 
For more information about installing DTW, see the SAP Business One Administrator’s Guide. 

 Configure DTW as a RemoteApp. On each presentation server, do the following: 
o Use the RemoteApp wizard to configure DTW as a RemoteApp.  
o Specify the tenant domain groups for which you want to enable connections to DTW. 

3.8 Configuring Job Service 

The job service manages the following settings on the server side:  
• Mailer settings: allows you to send documents directly from SAP Business One through e-mail.   
• Alert and scheduling settings: use this function to have SAP Business One send automatic alerts to selected 

users whenever certain events occur or to automatically run previously scheduled tasks.  

 Note  
As of SAP Business One 9.3, the scheduling function is available in addition to the alert function. The 
scheduling function allows you to have SAP Business One automatically run previously scheduled tasks.  

 Note  
Note that each service unit requires a dedicated job service instance. 
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3.8.1 Installing Job Service on Windows 

The following procedure describes how to install the job service on Windows using the SAP Business One 
Components Wizard. 

Prerequisite 

You have installed the SLD Agent Service. For more information about installing the SLD Agent, see Installing the 
SLD Agent Service.  

Procedure 

To install the job service for SAP Business One version 10.0 FP 2111 or higher, do the following: 

Note 
If you are using SAP Business One version 9.3 or SAP Business One version 10.0 FP 2108 or lower, to 
install the job service on Windows, please refer to a previous version of this administrator's guide that 
corresponds to your version and patch/feature package.  

 In the SAP Business One installation package, navigate to the directory …/Packages.x64/ 
ComponentsWizard. 

 Run the install.exe file. 
 In the welcome window of the wizard, choose Next.  
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 In the Specify Installation Folder window, specify a folder in which you want to install the job service and 
choose the Next button.  

 
 In the Select Features window, select the Job Service checkbox. Ensure that the System Landscape Directory 

checkbox is deselected and choose the Next button. 
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 In the Network Address window, select the IP address, or use the hostname, of the job service server and 
choose Next. The hostname is automatically populated with the fully qualified domain name (FQDN). 

 
 In the Service Port window, specify a port number that is to be used by the job service for single single-on 

(SSO) and choose Next. The default port number is 40000.  
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 In the Specify Security Certificate window, specify a security certificate and choose Next. You can also choose 
to use a self-signed certificate. For information about obtaining a certificate, see the Administrator's Guide for 
SAP Business One. 

 
 In the Landscape Server window, enter the SLD server address and port for SAP Business One Cloud, site 

user ID and password, and then choose Next. 

 



 

SAP Business One Cloud Administrator's Guide 
Configuring the Server Landscape 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  33 

 

 Note  
For the site user ID and password, use credentials for a domain account that is a cloud operator with local 
administrative privileges. 

 
 In the Review Settings window, review your settings and then choose Start to start the installation. 

 
 In the Setup Progress window, when the progress bar displays 100%, choose Next to finish the installation. 
 In the Setup Process Completed window, review the installation results, and then choose Finish to exit the 

wizard. 
 Navigate to C:\Program Files (x86)\SAP\SAP Business One ServerTools\Job Service\Tools\ 

and run the CloudEnablement.bat file.  
 Specify the following information: 
 Enter the hostname of the current Microsoft Windows server (or press enter to retrieve the hostname   from 

the system). 
 If the job service is on the same sever as the SLD, enter Y. If the job service is on a different sever as the 

SLD, accept the default value of N. 
 Enter the address of the SLD (for example, http://hostname:port). 
 Enter the account service username (for example, domain\SAPServiceB1C). 

Note 
This user must have the sysadmin role in the database instance being used by the common database and 
company database. 

 Enter the password for the account service user.  

http://hostname:port
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Note 
To upgrade the job service to a higher version, run the SAP Business One Component Wizard. The SAP 
Business One Component Wizard detects previous versions of job service and performs an upgrade to 
the latest version. 

3.8.1.1 Uninstalling Job Service on Windows 

The following procedure describes how to uninstall the job service on a Microsoft Windows machine. 

Procedure 

 Navigate to the SAP Business One installation folder (C:\Program Files\SAP\SAP Business One 
SetupFiles\) and run the setup.exe file.  
Alternatively, on your workstation, in the Programs and Features window, select SAP Business One 
Components Wizard and then choose Uninstall. 

 In the welcome window of the wizard, select Uninstallation. 
 In the Select Features window, select the Job Service checkbox and choose Next. 

 
 In the Review Settings window, review your settings and then choose Start to start the uninstallation 
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If you are using SAP Business One version 9.3 or earlier, to uninstall the job service on a Windows machine, 
perform the following: 
Before uninstalling the job service, you need to perform the following: 

 Navigate to C:\Program Files (x86)\SAP\SAP Business One ServerTools\Job Service\Tools 
and run the CloudUninstall.bat file.  

 Specify the following information: 
 Enter the hostname of the current Microsoft Windows Server (or press enter  to retrieve the hostname 

from the system). 
 Enter the address of the SLD (for example, http://hostname:port) 
 Enter the account service username (for example, domain\SAPServiceB1C) 
 Enter the password for the account service user.  

3.8.2 Installing Job Service on Linux 

If you use a service unit with the SAP HANA database platform, you must install the job service (version for SAP 
HANA) on a Linux machine. For more information about installing and configuring job service (version for SAP 
HANA), see the SAP Business One Administrator’s Guide, version for SAP HANA. 

 Note  
The job service depends on the existence of the Service Layer if you want to use the alert function. Make 
sure that the Service Layer exists in the same landscape and is bound with the database server where 
alert service works. 

http://hostname:port
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3.8.3 Registering Job Service to Service Units 

After you install the job service, a list of registered job services is displayed in the Cloud Control Center, which you 
can then assign to service units. For more information about assigning job services while creating service units, 
see Creating Service Units. For more information about assigning job services to existing service units, see 
Registering Software Components or Storage to Existing Service Units. 

 Note  
After assigning a job service to a service unit, it is automatically assigned to all tenants registered to the 
service unit. 

3.8.4 Configuring Mailer and Mail Scheduling Settings 

 Note 
As of SAP Business One 9.3 PL09, superusers and power users can enable Mailer for each company 
directly in SAP Business One. Additionally, cloud operators and reseller operators can monitor and 
change the deployment status of Mailer in the Cloud Control Center. For more information, see 
Monitoring and Controlling Deployment Status of Mailer and Job Service in the Cloud Control Center. 

Prerequisites 

You have installed the job service. 

Procedure 

[On Windows] 
To configure Mailer and mail schedule settings, perform the following: 

 To open the SAP Business One Service Manager window, in the Microsoft Windows task bar, double-click 
(SAP Business One Service Manager).  
Alternatively, in Windows, choose Start → All Programs → SAP Business One → Server Tools → Service 
Manager.  

 From the Service dropdown list, select Job Service - Mailer. 
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 Choose   (Play) and select the Start when operating system starts checkbox. 
 Define mail settings for the SAP Business One landscape: 

 In the SAP Business One Service Manager window, choose Settings. 
The General Settings window appears. 

 

 In the General Settings window, specify the following: 
o SMTP Server — Enter the name or IP address of your outgoing mail server. To make changes in this field 

later, you must stop the Job Service - Mailer. 
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o SMTP Port — Specify the port number for mail services.  
o Encoding — Select the language for email text. 
o HTML direction right-to-left — Select this checkbox if you are using a right-to-left language to define the 

direction of the email text. 
o Include Subject in Message Body — Select this checkbox to include the subject line in the body of the 

message. 
o Fax Settings — Select the required fax service. 
o Scheduled Report Settings - Specify the required information for configuring SBO Mailer for report 

scheduling and mailing. For more information, see Configuring Report Scheduling. 

  Caution 
After you choose the OK button in the General Settings window and return to the SAP Business One 
Service Manager window, do not choose the Connection or Database buttons. 

 To enable mailing services for companies, log on to the SAP Business One client and do the following:  
 Select the company for which you want to enable the Mailer service.  
 On the Service tab of the General Settings window (Main Menu → Administration → System Initialization → 

General Settings), select the Enable Mailer checkbox.  

Note  
As of SAP Business One 9.3, PL09, you cannot enable databases for the mailing services or modify the 
configuration in the SAP Business One Service Manager window.  

Note  
If you upgrade the SAP Business One job service from a lower version to SAP Business One 9.3 PL09, the 
original enabled databases for mailing services will be disabled. You must reset the databases for which 
you want to enable mailing services in SAP Business One client. 

 To configure a company-specific SMTP server, select the Enable Company Specific Mailer Configuration 
checkbox, and specify the required settings: 

o SMTP Server – Enter the name or IP address of your outgoing mail server.  
o SMTP Port – Specify the port number for mail services.  
o Authentication – Specify the authentication method you want to use: No Authentication, Login 

Authentication, or Plain Password, and enter the required User Name and Password.  
o Encoding – Select the language for email text.  
o Use TLS Encryption – Select this checkbox to use Transport Layer Security (TLS) encryption.  
o HTML direction right-to-left – Select this checkbox to define the direction of the email text if you are 

using a right-to-left language.  
o Include Subject in Message Body – Select this checkbox to include the subject line in the body of the 

message.  

Note  
This checkbox is not selected by default. If you don’t select this checkbox, only one SMTP server can be 
configured for the entire SAP Business One landscape from the Job Service - Mailer in the SAP Business 
One Service Manager.  
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 Set the mail processing schedules: 
 In the SAP Business One Service Manager window, from the Service dropdown list, select SBO Mailer, and 

then choose Schedule.  

 

 In the Scheduler – SBO Mailer window, select one of the following options: 
o By Intervals — Sets mail and fax processing to start regularly every x hours and y minutes. 
o On Specific Date — Defines mail and fax processing for a specific date and time. 
o Daily — Sets mail and fax processing for a fixed hour of each day. 
o Weekly — Sets mail and fax processing for a fixed hour on a fixed day of each week. 
o Monthly — Sets mail and fax processing for a fixed hour on a fixed day of each month. 

  Recommendation 
If you choose the By Intervals option, set the interval to a minimum of 5 minutes. 
 
 
 
 
 
 
 
 
 
 
 

 
 Choose OK to return to the SAP Business One Service Manager window. 
 In the SAP Business One Service Manager window, choose             (Play), and select the Start when operating 

system starts checkbox. 
 To close the SAP Business One Service Manager window, choose OK. 
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Result  

You can now proceed to define the email signature settings. To access the email signature settings, from the SAP 
Business One Main Menu, choose Administration → System Initialization → E-Mail Settings. 

 
[On Linux] 
The process of configuring job service comprises the following steps: 

 Define the mail settings 
 Assign job services to service units 
 Connect to the SMTP server 

 Note 
The job service configuration web page does not provide access to mailer e-mail signature settings.  
To access these settings, from the SAP Business One Main Menu, choose Administration → System 
Initialization → E-Mail Settings. 

Procedure 

To configure Mailer and job service (including alert service and scheduling job function), perform the following: 
 In the Cloud Control Center, from the Service Unit Components menu, choose Job Services. 
 In the Job Services window, select the job service you want to configure and click the link in the Access URL 

field to access the job service configuration web page.  

 Note 
o If you use a proxy for your Internet connection, you must add the full hostname or IP address of any 

Web server (for example, SLD) to the proxy exception list of your Web browser; in other words, do not 
use a proxy for these addresses. 

o The URL of the service is case-sensitive. 
 If you have not logged on to the SLD service, in the logon window, enter the user name  and password of the 

cloud operator and then choose Log On. 

 Note 
The site user name is case sensitive. 

 On the Mailer Settings tab, specify the following mandatory mail settings information and choose Save: 
o SMTP Server: Name or IP address of your outgoing mail server. 
o SMTP Port: Port number for the SMTP server. 

 Note 
If your SMTP server does not allow anonymous connection, specify a user name and password; 
otherwise, select the Anonymous checkbox. 

o In the Language dropdown list, select the language for email text. 
o If your SMTP server requires TLS encryption, make sure the Use TLS Encryption checkbox is selected. 
o If you are using a right-to-left language, select the Right-to-Left checkbox. 
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o To include the subject line in the body of the message, select the Include Subject in Message Body 
checkbox. 

 To connect to the SMTP server, choose Start. 
The status changes to RUNNING and the button changes to Stop. 

 Note 
To change the SMTP server, you must first stop the connection by choosing Stop. 

Result 

You can now proceed to create a mount point for your shared folder on your Linux server. For more information, 
see SAP Note 2478013.   

3.8.5 Configuring Alert Service and Scheduling Settings 

To use the alert service and scheduling job to have SAP Business One automatically notify selected users 
whenever certain system events occur or have SAP Business One automatically run previously scheduled tasks, 
you must first start the alert service for the companies on the server side. 

 Note 
As of SAP Business One 9.3 PL09, superusers and power users can enable the alert service for each 
company directly in SAP Business One. Additionally, cloud operators and reseller operators can monitor 
and change the deployment status of alert in the Cloud Control Center. 

 Note 
  If the password for the user who is running the alert service is expired, the alert will not be sent.   

Procedure 

To configure the alert service and scheduling job, perform the following: 
 In a Web browser, navigate to the following URL: 
https://<Server Address>:<Port>/job 

Alternatively, on the Services tab in the System Landscape Directory, you can click the Job Service link to 
access the settings. 

 Notes 
o If you use a proxy for your Internet connection, you must add the full hostname or IP address of any 

Web server (for example, SLD) to the proxy exception list of your Web browser; in other words, do not 
use a proxy for these addresses. 

o The URL of the service is case-sensitive. 
 If you have not logged on to the SLD service, in the logon page, enter the user name and password of the 

cloud operator and choose Log On. 

https://launchpad.support.sap.com/#/notes/2478013
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 Note 
The site user name is case sensitive. 

 On the Alert Settings tab, if you want to change the technical user used to execute the alerts, enter the user 
code for an SAP Business One user and then choose Save. 

 Note 
If you want to use a user different from the default user AlertSvc, you must ensure the user is created in 
all the companies. Otherwise, all the alert settings are ineffective for the companies missing this user. 
This technical user is used for database connection and not intended for any business transactions. You 
do not have to assign a license to this technical user and we recommend that you do not.  

 To start the alert service, choose Start. 
The status changes to RUNNING and the button changes to Stop. 

 Note 
To change the technical user or change the company selection, you must first stop the connection by 
choosing Stop. 

 To enable the alert and scheduling function for companies, log on to the SAP Business One client and do the 
following:  

 Select the company for which you want to enable the alert service. 
 On the Service tab of the General Settings window (Main Menu → Administration → System Initialization → 

General Settings), select the Enable Alert Service checkbox.  

Result 

You can now log on to each of your companies in the SAP Business One client and define the alert settings on the 
client side. For more information, see the online help. 

3.8.6 Monitoring and Controlling Deployment Status of Mailer 
and Job Service in the Cloud Control Center 

As of SAP Business One Cloud PL14, cloud operators and resellers can monitor and change the deployment 
status of Mailer service and job service (including alert service and scheduling function), directly in the Cloud 
Control Center.  
 

Prerequisites: 

• You have installed job service. 
•  You have configured the Mailer service and job service. 

 
To monitor and change the deployment status of Mailer service and job service in the Cloud Control Center, 
perform the following: 
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 In the Cloud Control Center, choose Customer Management → Tenants and select a tenant.  
 In the Tenant Details area, on the Services tab, you can check or change the deployment status of the job 

service and Mailer service. 
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4 Installing SAP Business One Cloud 

Depending on the solution you use to provide remote access to the SAP Business One application, there are 
different installation and configuration scenarios.  
The following steps are mandatory: 
• Installing the System Landscape Directory and the Cloud Control Center 
• Installing the SLD Agent Service 
• Creating the software repository 
• Creating storage 

The following steps are optional and apply only if you are using SAP Business One Browser Access: 
• Installing SAP User Access Portal 

4.1 Installing System Landscape Directory and Cloud Control 
Center 

To configure an SAP Business One Cloud landscape, you must install the following components: 
• System Landscape Directory (SLD) – Installs a service that provides information about landscape 

components and their settings and the accompanying database.  
• Cloud Control Center – Installs an interface for the SLD service that you can use to manage an SAP Business 

One Cloud landscape.  

 Note  
You can choose to install the SLD and Cloud Control Center either on Windows or on Linux. The SAP 
Business One Cloud setup wizard for Linux is available as of SAP Business One Cloud 1.1 PL07 (path: 
\Linux\install). 
You can install the Linux-based server components in GUI mode or in silent mode. For more information 
on the silent mode, see SAP Business One Administrator's Guide, version for SAP HANA. 

 Note  
The SLD and Active Directory controller should not be installed on the same machine.  

Prerequisites 

• You have installed the database server on the landscape server: 
o If using Microsoft SQL Server, you have installed Microsoft SQL Server 2008 R2, 2012, 2014 or 2016 

Standard or Enterprise edition. 
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o If using SAP HANA, you have installed SUSE Linux Enterprise Server 11 SP4 (x86_64), SUSE Linux 
Enterprise Server 12 SP1, SP2, SP3, or SP4 (x86_64), or SUSE Linux Enterprise Server 15 SP1 (x86_64) 
and SAP HANA.  

o You have installed Google Chrome (recommended) or Mozilla Firefox on the machine you want to use to 
access the SLD and Cloud Control Center. 

4.1.1 Installing the SLD and Cloud Control Center on Windows 

 Note  
For statistics (SAP Business One usage frequency) used internally by SAP only, we use information 
including system number and hardware key from your SAP Business One landscape. 

Procedure 

 Navigate to the root folder of the installation package, right-click the SLD_x64.exe file, and choose Run as 
administrator. 

 In the SAP Business One SLD Service – InstallShield Wizard window that appears, choose the Next button. 
 In the Choose Destination Location window, specify the installation destination folder. 
 In the System Landscape Directory Service Configuration window, specify the following logon credentials: 

o Domain Name – Enter the domain name. 
o User Name – Enter the user name for the domain account that has local administrative permissions and is 

the sysadmin role on the database server. 
o Password – Specify the password for the domain account. 
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 Note  
The domain administrative account you have defined to be used by the SLD service for operations that 
require Active Directory access can be later changed in the Cloud Control Center (System Configuration 
→ Account for AD Operations). 

 In the Specify SLD Hostname window, specify the hostname or IP address for SLD under which the instance 
will be registered. 

 In the Web Protocol window, select the radio button of the web protocol you want the SLD to use for 
connections. 

 Recommendation  
For security reasons, select the Hypertext Transfer Protocol Secure (HTTPS) option. If you choose this 
option, a certificate is required for authentication. For more information, see Installing Certificates. 

If you select the Hypertext Transfer Protocol Secure (HTTPS) option, enter a valid PKCS12 certificate store 
and password. 

 

 In the Cloud Control Center Site Configuration window, specify the site name, IP address, and TCP/IP port of 
the Cloud Control Center. To use the default values, select the corresponding checkboxes. 
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 In the SLD installation mode window, choose to install the System Landscape Directory in either standalone 
mode or in high availability mode. If you choose the high availability option, specify whether you want to use 
an admin or worker node.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Note 
o If you chose the Standalone Mode option, proceeding with the installation will delete any high 

availability (cluster) node entries in the existing SLD database.  
o If you choose high availability mode and the Admin Node option, proceeding with the installation will 

delete any high availability (cluster) node entries in the existing SLD database. As a result, you will 
have to reinstall all worker nodes.  
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o If you choose high availability mode and the Worker Node option, ensure that you have an admin node 
entry in the SLD database.  

 In the next window, perform the following: 
 Specify the database type (Microsoft SQL database or SAP HANA database) and information for the 

database on which you want the SLD to store data. 
o If you chose MSSQL, specify the following fields: 

o Database Server – Enter the database server. 
o Database Name – Enter the database name. 

 Note 
If the SLD database name that you specified already exists, you must confirm that you want to use 
the database. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

o If you chose HANA, specify the following fields: 
o Database Server – Specify the database server. 

 Note  
If you are deploying SAP HANA High Availability solution, in the Database Server field, enter a virtual 
IP address. 

o Instance – Enter the database instance. 
o Tenant Name: If you are using SAP HANA 1.0, ensure you leave this field empty for the connection to 

be identified by the wizard. If you are using SAP HANA 2.0, enter the container name in the Tenant 
Name field. 

 Note  
For more information about installing SAP HANA 2.0, see Installing SAP HANA 2.0 in Cloud Environments 
to Enable Multiple Database Containers. 
o Database Name – Enter the database name. 
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 Recommendation  
We recommend that you do not use the SYSTEM user account. Instead, use the database user account 
that you created as a substitute for the SYSTEM user. For more information, see Database Privileges for 
Installing, Upgrading and Using SAP Business One Cloud.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 In the Server Authentication area, select an authentication mode. 

 Note 
For SAP HANA Server, you must use the Database Server Authentication option, as the Windows 
Authentication option is not supported.  

 In the Cloud Control Center Default Account Configuration window, enter the user name of the domain 
account you want to use as the default account for accessing the Cloud Control Center. 
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 In the Ready to Install Components window, do the following: 
o To install the selected components, choose the Install button.  
o To change the settings, choose the Back button to return to the previous steps. 

 In the Complete window, choose the Finish button. 

 Recommendation  
After completing the installation process, backup the keytools.dat and SLD.KEYSTORE files located in 
<INSTALLDIR>\apache-tomcat-6.0.35\work\Catalina\localhost\sld\WEB-

INF\classes\META-INF\. 
SAP provides you with a useful command utility for updating the KEYSTORE of tomcat. After the 
completion of the installation process, the utility is installed under tomcat\bin. To update the https 
certificate in tomcat\conf\server.xml, run the command: 
updateKeystore.bat pk12keystore pk12keypass. 

4.1.2 Installing the SLD and Cloud Control Center on Linux 

 Note  
For statistics (SAP Business One usage frequency) used internally by SAP only, we use information 
including system number and hardware key from your SAP Business One landscape. 

Procedure 

 Log on to the Linux server as root. 
 In a command line terminal, navigate to the directory …/Linux where the install utility is located. 
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Start the installer from the command line by entering the following command: 
./install 

The installation process begins. 

 Note 
If you receive an error message: “Permission denied”, you must set execution permission on the installer 
utility to make it executable. To do so, run the following command:  
chmod +x install  

 In the Welcome window of the setup wizard, choose the Next button. 

 

 In the Specify Installation Folder window, specify a folder in which you want to install the Cloud components 
and choose the Next button. 

 
 
 
 
 
 
 
 
 
 
 
 

 

 In the Select Features window, select the System Landscape Directory OD checkbox and choose the Next 
button. 
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 Check the compatibility information and choose the Next button. 

 

 In the Network Address window, select an IP address or use the hostname as the network address for the 
selected components. 

 

 In the Web Protocol window, specify a Web protocol to use for SLD service installation and choose the Next 
button. 

 Recommendation  
For security reasons, select the Hypertext Transfer Protocol Secure (HTTPS) option. If you choose this 
option, a certificate is required for authentication. For more information, see Installing Certificates. 

If you select the Hypertext Transfer Protocol Secure (HTTPS) option, enter a valid PKCS12 certificate store 
and password. 
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 In the Service Port window, specify a port number, and choose the Next button.  
The default port depends on the Web protocol; it is 80 or 443. 

 

 In the SLD Hostname window, specify the hostname or IP address for the SLD under which this instance will 
be registered.  
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 In the Cloud Control Center Operator window, specify the following logon credentials: 
o Fully-Qualified Domain Name – The fully-qualified domain name must be the full name in upper case. 
o Domain Controller – Enter the domain controller IP address. 
o Operator/User Name – Enter the user name for the domain account you want to use as the default 

account for accessing the Cloud Control Center. This account should have local administrative 
permissions. The domain user name is case-sensitive. 

o Password – Specify the password for the domain account. 

 Note: 
o Ensure that the UTC time on your Linux server is the same as that on your Windows domain 

controller; otherwise, you cannot proceed with the installation. 
o Ensure that you have registered a service principal name (SPN) for this domain user. For more 

information on registering a SPN, see the SAP Business One Administrator's Guide, version for SAP 
HANA on SAP Help Portal.  

o Ensure that  
Select the checkbox to indicate that you have included the Linux machine in the specified Windows domain, 
and then choose the Next button. 

https://help.sap.com/viewer/index
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 In the Database Server Connection window, specify the database server on which you want the SLD to store 
data. 

 Note: 
If you are using SAP HANA 1.0, ensure you leave the Tenant Database field empty for the connection to be 
identified by the wizard. If you are using SAP HANA 2.0, enter the container name in the Tenant Database 
field. 

 Note  
For more information about installing SAP HANA 2.0, see Installing SAP HANA 2.0 in Cloud Environments 
to Enable Multiple Database Containers. 
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 Recommendation  
For SAP HANA DB, do not use the SYSTEM user account. Instead use the database user account that you 
created as a substitute for the SYSTEM user. For more information, see Database Privileges for Installing, 
Upgrading and Using SAP Business One Cloud. 

 In the SLD Database window, enter the name for the System Landscape Directory schema. 

 

 In the Review Settings window, review your settings carefully before proceeding to execute the installation. If 
you need to change your settings, choose the Previous button to return to relevant windows; otherwise, 
choose the Start button to start the installation. 

 

 In the Setup Progress window, when the progress bar displays 100%, proceed with one of the following 
options: 
o If all of the selected components were installed successfully, choose the Next button to finish the 

installation. 
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o If one or more components failed to be installed, choose the Roll Back button to restore the system. After 
the rollback progress is complete, in the Rollback Progress window, choose the Next button to finish the 
installation. 

 

 In the Setup Process Completed window, review the installation results showing which components were 
successfully installed and which were not. 

 

 To exit the wizard, choose the Finish button. 
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4.2 Installing the SLD Agent Service 

In addition to the SLD and Cloud Control Center, you must install the SLD Agent Service. This agent service 
executes tasks on behalf of the SLD, such as performing database upgrades. 

4.2.1 Manually Installing the SLD Agent Service 

You can manually install the SLD Agent Service on servers individually using an installer provided by SAP. 

 Note  
You must install the SLD Agent Service on each Windows or Linux machine actively in use on your 
landscape. The SAP Business One Cloud setup wizard for Linux is available as of SAP Business One Cloud 
1.1 PL07 (path: \Linux\install). 
You can install the Linux-based server components in GUI mode or in silent mode. For more information 
on the silent mode, see SAP Business One Administrator's Guide, version for SAP HANA. 

Procedure 

[On Windows] To install the SLD Agent Service, do the following: 
 Navigate to the root folder of the SAP Business One Cloud installation package. In the SLDAgentMSI_x64 

folder, right-click the SLDAgent_x64.exe file, and the choose Run as administrator. 
 In the SAP Business One SLD Agent – InstallShield Wizard window that appears, choose the Next button. 
 In the Destination Folder window, specify where to install the SLD agent. 
 In the SLD Agent Service Configuration window, specify the following logon credentials: 

o Domain Name – Specify the domain name for the SAP Business One Cloud landscape. 
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o User Name – Enter the user name of an existing domain account that is a cloud operator with local 
administrative privileges. 

o Password – Specify the password for the domain account. 

 

 In the System Landscape Directory Configuration window, enter the URL of the System Landscape Directory.  
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 In the Ready to Install Components window, do the following: 
o To install the selected components, choose the Install button.  
o To change the settings, choose the Back button to return to the previous steps. 

 In the Complete window, choose the Finish button. 
 
[On Linux] To install the SLD Agent Service, do the following: 

 Log on to the Linux server as root. 
 In a command line terminal, navigate to the directory …/Linux where the install utility is located. 

Start the installer from the command line by entering the following command: 
./install 

The installation process begins. 
 Note 

If you receive an error message: “Permission denied”, you must set execution permission on the installer 
utility to make it executable. To do so, run the following command:  
chmod +x install  

 In the Welcome window of the setup wizard, choose the Next button. 

 

 In the Specify Installation Folder window, specify a folder in which you want to install the Cloud components 
and choose the Next button. 
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 In the Select Features window, select the SLD Agent, and choose the Next button. 

 

 In the Landscape Server window, specify the following logon credentials: 
o SLD URL – Enter the URL of the System Landscape Directory. 
o Site User ID – Enter the user name of an existing domain account that is a cloud operator with local 

administrative privileges. 
o Password – Specify the password for the domain account. 
o On the Installed components for reconfiguration screen, choose Next.   
o On the Specify Security Certificate screen, specify a path to Certificate Store File and enter a Certificate 

Password; choose Next. In the Review Settings window, review your settings carefully before proceeding 
to execute the installation. If you need to change your settings, choose the Previous button to return to 
relevant windows; otherwise, choose the Start button to start the installation. 

 In the Setup Progress window, when the progress bar displays 100%, proceed with one of the following 
options: 
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o If all of the selected components were installed successfully, choose the Next button to finish the 
installation. 

o If one or more components failed to be installed, choose the Roll Back button to restore the system. After 
the rollback progress is complete, in the Rollback Progress window, choose the Next button to finish the 
installation. 

 In the Setup Process Completed window, review the installation results showing which components were 
successfully installed and which were not. 

 To exit the wizard, choose the Finish button. 

4.2.2 Automatic Installation Using a Group Policy Object 

You can automatically install the SLD Agent Service on all servers using a Group Policy Object (GPO). 

Procedure 

To install the SLD Agent Service using a GPO, do the following: 
 Navigate to the root folder of the SAP Business One Cloud installation package. In the SLDAgentMSI_x64 

folder, locate the SLDAgent_x64.msi file.  
 The SetupPrerequisites folder contains the setup prerequisites. 
 Create a transform file with the following properties: 

o SLD_AGENT_SERVICE_USER – Specify the user name of the domain user account that is the logon user 
for the SLD agent service and is a cloud operator.  

o SLD_AGENT_SERVICE_PASS – Specify the password for the domain user account. 
o SLD_URL – Specify the base URL of the SLD service. 
o SLD_AGENT_DOMAIN_NAME – Specify the domain name. 

 Recommendation  
To create the transform file, use ORCA.EXE, a database table editor for creating and editing Windows 
Installer packages and merge modules that is available in the Microsoft Windows SDK Components for 
Windows Installer Developers. For more information, see www.microsoft.com. 

 Install all setup prerequisites. 
 Install the provided MSI installation packages to the GPO. 

 Note 
To retrieve the MSI package from the vcredist_x64.exe setup prerequisite, extract the contents of the file 
and locate the vc_red.msi file. 

 Configure any advanced options and apply the transform file to SLDAgent_x64.msi. 
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4.2.3 Silent Installation of SLD Agent Service (on Windows) 

You can perform a silent installation of the SLD Agent Service on a Windows machine using one of the following 
commands: 
• Install by single .exe using Basic MSI: 

SLDAgent_x64.exe /s /v"/qn SLD_AGENT_DOMAIN_NAME=<domain name> 
SLD_URL=\"https://xx.xx.xx.xx/sld/sld0100.svc\" SLD_AGENT_SERVICE_USER=<service 
user name>  

SLD_AGENT_SERVICE_PASS=<service pass>" 

• Install using the msiexec command: 
msiexec /i SLDAgent_x64.msi /qn SLD_AGENT_DOMAIN_NAME=<domain name> 
SLD_AGENT_SERVICE_USER=<service user name> SLD_AGENT_SERVICE_PASS=<service pass>" 

SLD_URL="https://xx.xx.xx.xx/sld/sld0100.svc" 

• Uninstall: 
msiexec /x SLDAgent_x64.msi /qn  

4.3 Creating Storage 

An SAP Business One Cloud landscape requires the following shared folders for storing files: 
• Software Repositories 

A shared folder accessible by all service units, containing SAP Business One installation packages, upgrade 
packages, and add-on installers. 

• Shared Folders 
A folder assigned to a service unit that contains sub-folders dedicated to individual tenants, in which 
attachments, images, and document templates required to use SAP Business One are stored. 

• Implementation Repositories 
One or more folders shared by the entire cloud landscape that store SAP Business One solution package 
(.PAK) files, which you can use to create company databases. 

• Company Template Repositories 
One or more folders shared by the entire cloud landscape folder that stores database backup files. You can 
use the Company Template Repository to backup company databases and to create company databases 
from backup files. Company Template Repositories can be assigned to service units or reseller operators, 
depending on how you choose to control backup file access on the file system. 

• Tenant Storage 
A folder assigned to a service unit that contains sub-folders dedicated to individual tenants, in which logs and 
company database backup files, used during tenant upgrades, are stored. 

• User Storage 
A global folder that contains sub-folders dedicated to individual users, in which user-sensitive data and 
documents are stored. 

https://xx.xx.xx.xx/sld/sld0100.svc/
https://xx.xx.xx.xx/sld/sld0100.svc
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4.3.1 Creating Software Repositories 

To create a software repository, do the following: 
 Create a Windows shared folder for each major release of SAP Business One that you want to provide. 

Keep a record of the full UNC path to each folder, as you are required to enter these in the Cloud Control 
Center during the registration process. 

 For each folder, assign read, write, and execute permissions to the SAPServiceB1C account. 
 Extract the contents of the required SAP Business One upgrade packages to each folder. The following figure 

shows the directory structure. 

 

 Note  
Only the UpgradeCD folder is mandatory. For each new patch or feature package of SAP Business One, 
extract the upgrade package to this folder. Then, register the web path of the UpgradeCD parent folder to 
the Cloud Control Center as a software repository.  

 Note  
For Browser Access, make sure that you have granted domain computers the full authorization to access 
the software repository folder. To do so, perform the following steps: 

 Right-click the software repository folder and choose Properties.  
1.    On the Security tab, in the Group or user names area, choose Edit. 
2.    In the Permissions window, choose Add. 
3.    In the Select Users, Computers, Service Accounts, or Groups window, choose Object Types.  
        Ensure that the Computers checkbox is selected. 
4.    Enter Domain Computers and check names. 
5.    Make sure that the domain computers have Full control permission. 

4.3.2 Creating Shared Folders 

To create a Shared Folder for each service unit, do the following: 
 Create a Windows shared folder for each service unit. 

Keep a record of the full UNC path to each folder, as you are required to enter these in the Cloud Control 
Center during the registration process. 
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 For each sub-folder dedicated to a tenant, assign read and write permissions to the following: 
o The SAPServiceB1C account. 
o The corresponding tenant’s domain group. For more information about domain groups, see Enable DI API 

to Access the Common Database  
The Enable DI API to Access the Common Database option allows you to control whether the DI API has 
permission to access the common database, for instance when performing user queries.     
Procedure 
To activate the Enable DI API to Access the Common Database option, do the following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable DI API to Access the Common Database field, choose the On option and 

then choose Save.  

 Note 
If the Enable DI API to Access the Common Database option is set to Off, the DI API does not have 
permission to access the common database. The default value for new installations and upgrades is Off.  

o  Disable UDO Business Logic Implementation DLL 
When you create a user-defined object (UDO) in SAP Business One, you can add a business logic 
implementation (DLL). The Disable UDO Business Logic Implementation DLL option in global settings allows you to 
control if the UDO business logic implementation is enabled or not. By default, the option is On, meaning that UDO 
business logic implementation is disabled.  

Procedure 

To enable UDO business logic implementation, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings.  
 From the dropdown list in the Disable UDO Business Logic Implementation DLL field, choose the Off option 

and then choose Save.   
o Domain Groups. 

4.3.3 Creating Implementation Repositories 

To create implementation repositories, do the following: 
 Create one or more Windows shared folders. 

Keep a record of the full UNC path to each folder, as you are required to enter these in the Cloud Control 
Center during the registration process. 

 For each folder, assign read and write permissions to the SAPServiceB1C account. 

4.3.4 Creating Company Template Repositories 

To create company template repositories, do the following: 
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 Create one or more Windows shared folders. 
Keep a record of the full UNC path to each folder, as you are required to enter these in the Cloud Control 
Center during the registration process. 

 For each folder, assign the following permissions:  
Read and write permissions to the SAPServiceB1C account. 
Read permission to all database instances in the corresponding service unit. 

4.3.5 Creating Tenant Storage 

To create tenant storage, do the following: 
 Create one or more Windows shared folders. 

Keep a record of the full UNC path to each folder, as you are required to enter these in the Cloud Control 
Center during the registration process. 

 For each folder, read and write permissions to the following:  
o The SAPServiceB1C account. 
o All database instances. 

 Note  
When you create a new tenant in the Cloud Control Center, the application automatically creates a sub-
folder with the required permissions in the tenant storage dedicated to that tenant. 

4.3.6 Creating User Storage 

To create user storage, do the following: 
 Create one or more Windows shared folders. 

Keep a record of the full UNC path to each folder, as you are required to enter these in the Cloud Control 
Center during the registration process. 

 For each folder, assign read and write permissions to the SAPServiceB1C account. 

 Note 
When you create a new user in the Cloud Control Center, the application automatically creates a sub-
folder with the required permissions in the user storage dedicated to that user. 

4.4 Installing the User Access Portal for Browser Access 

The User Access Portal allows you to remotely access the SAP Business One application in Browser Access mode. 
You can install the User Access Portal (UAP) for SAP Business One Browser Access using the SAP Business One 
Cloud Setup Wizard. 
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 Note  
As of SAP Business One Cloud 1.1 PL07, the User Access Portal installer was removed from the 
installation package and replaced with the new SAP Business One Cloud Setup Wizard (path: \User 
Access Portal\install.exe). The SAP Business One Cloud Setup Wizard provides the only option to 
install the UAP for Browser Access. The SAP Business One Cloud User Access Portal for RDS and Citrix 
are no longer supported. Partners will need to customize Remote Desktop Web Access and Citrix Web 
portals by their own means. The new UAP does not require IIS. For more information about other 
functional improvements, see SAP Note 2373769. 

 Caution 
The SAP Business One Cloud Setup Wizard is installed as a new application; it does not upgrade or 
uninstall the previous version of the UAP. As both versions of UAP can coexist on the same machine, you 
may need to use a different port for the UAP when using the setup wizard . Although a previous version of 
UAP may still work with the System Landscape Directory for some time, we recommend installing the 
new UAP for Browser Access using the setup wizard. Also note that the previous version of the UAP is not 
supported. 

Prerequisites 

You have configured the SLD service. 

 Note  
When you run the installer for the first time, you are asked to set PowerShell execution policy to 
RemoteSigned. For more information on how to set the proper execution policy, see 
https://technet.microsoft.com/en-us/library/ee176961.aspx. 

Procedure 

To install the User Access Portal, do the following: 
 Navigate to the root folder of the SAP Business One Cloud installation package. In the User Access Portal 

folder, right-click the install.exe file, and choose Run as administrator. 
 In the welcome window of the SAP Business One Cloud Setup Wizard, choose the Next button. 

https://launchpad.support.sap.com/#/notes/2373769
https://technet.microsoft.com/en-us/library/ee176961.aspx
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 In the Specify Installation Folder window, specify a destination folder in which you want to install the Cloud 
components and choose the Next button. 

 

 In the Select Features window, select the User Access Portal, and choose the Next button. 



 

SAP Business One Cloud Administrator's Guide 
Installing SAP Business One Cloud 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  69 

 

 

 In the Network Address window, either accept the prepopulated hostname as the network address for the 
selected component, or manually enter the IP address.  

 Note  
This determines how the internal address of the UAP component will be registered in the SLD Cloud 
Control Center.  

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Service Port window, specify a port number that is to be used by the UAP and choose the Next button. 
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 Note  
If the default port is occupied, one of the reason may be that you have the old UAP (prior to Cloud 1.1 
PL07) running. You can either uninstall the old UAP, or consider changing its port if you decide to keep it. 
 

 In the Landscape Server window, enter the internal URL of the SLD server, and specify the site user 
credentials. Then choose the Next button. 
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  Note  
If you have configured an external SLD address in the Cloud Control Center, the UAP will be configured to 
use this external address. Otherwise, the UAP is configured to use the SLD address you entered in this 
step.  
 

 In the External URL Configuration window, enter the publicly available external access URL of the UAP service. 

 

 Note 
The URL is automatically registered in the SLD. To change the URL after installation, you can configure it 
in using the SLD external address mapping feature. For more information, see Mapping Internal and 
External URLs. 
 

 In the Specify Security Certificate window, specify a security certificate for the UAP and choose Next. 
The way you expose your services to the Internet determines which certificates you import: 
o Reverse proxy mode: Import the internal certificate. 

Note that the external certificate is for the reverse proxy server. 
o NAT/PAT mode: Import the purchased certificate for both internal and external domains. 
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 In the Review Settings window, review your settings carefully before proceeding to execute the installation. If 
you need to change your settings, choose the Back button to return to the relevant windows; otherwise, 
choose the Start button to start the installation. 

 

 In the Setup Progress window, when the progress bar displays 100%, proceed with one of the following 
options: 
o If all of the selected components installed successfully, choose the Next button to finish the installation. 
o If one or more components failed to be installed, choose the Roll Back button to restore the system. After 

the rollback progress is complete, in the Rollback Progress window, choose the Next button to finish the 
installation. 
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 In the Setup Process Completed window, review the installation results. 

 

 In the Setup Completed window, choose the Finish button. 
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 Note 
In runtime, if there are external addresses for the Browser Access Service configured in the SLD address 
mappings in the Cloud Control Center, the UAP will use these external addresses. Otherwise, UAP will use 
the addresses specified when BAS is registered (see Registering Browser Access Servers). 

 

 Note 
You can install the UAP in silent mode. To do so, enter the following command line: 
install -i silent -f <Property File Path> (for example, install.exe –i silent –f 
“C:\InstFolder\instaler.properties”) 
In the property file, separate parameter values by a comma. The format is as below: 
o Single value: Parameter=Value 
o Multiple values: Parameter=Value, Value 

The table below lists all parameters that are required or supported: 

Parameter Description 

CLOUD_UAP_PUBLIC_URL Public external access URL of the UAP service. 

INSTALLATION_FOLDER Installation folder of the Cloud components. 

SELECTED_FEATURES List of features that you want to install or upgrade. 
Separate feature names with a comma; the order of the features 
does not matter. If you do not specify a feature, all features will 
be installed. 
Value option: BODUAP - User Access Portal 

SERVICE_PORT Port number for the User Access Portal (for example, 4430). 

SITE_USER_ID Site user name that will be used to access SLD (for example, 
B1SiteUser). 
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Parameter Description 

SITE_USER_PASSWORD Password for the specified site user. 

SLD_CERTIFICATE_ACTION Certificate for HTTPS encryption. 
Value option: p12 - PKCS12 certificate 

SLD_CERTIFICATE_FILE_PATH Path to the PKCS12 certificate file. 

SLD_CERTIFICATE_PASSWORD Password for the PKCS12 certificate file. 

SLD_SERVER_ADDR SLD server address. 

SLD_SERVER_PORT SLD server port number. 

SLD_SERVER_PROTOCOL SLD communications protocol. 
Value options: 
• none: Do no use this option; for internal use only 
• http: Allowed for Cloud solutions only, not recommended 
• https: Recommended 

SLD_SERVER_TYPE System Landscape Directory type. 
Value options: 
• none: Do no use this option. 
• od: Cloud solution 

SLD_SERVICE_URL The internal URL of the SLD service (for example, 
https://10.55.179.208/sld/sld0100.svc). 

 Note 
If a component has already been installed and is up-to-date, the installer ignores the component even if 
you include it in the selected features. 

4.4.1 Access SAP Business One Browser Access via User Access 
Portal 

Prerequisite 

You have ensured that you can log on to the SAP Business One client installed on the Browser Access server. 

Procedure 

 In a Web browser, navigate to the User Access Portal for Browser Access using its URL 
(https://servertool.def.com:Port/UAP or https://UAPExternalAddress.abc.com:Port/UAP). 
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 Log on to the User Access Portal. 
One Browser Access server link is displayed for each service unit. 

 Note 
Even though more than one Browser Access service is registered with a service unit, only one Browser 
Access service link is displayed. The particular service is picked up randomly to achieve load balancing. 
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 Note 
As of SAP Business One Cloud 1.1 PL08, you can change the Windows user password via UAP. 
You can change the password before or after you log on to the UAP by clicking the Change Password link 
in the top-right corner of the UAP landing page. 

 Click one of the Browser Access server links. 
The Browser Access page is opened. 
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 Choose the company and log on. 
Now you can work with SAP Business One in your web browser. 
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4.4.2 Monitor Browser Access Processes 

As of SAP Business One 9.2 PL02, you can monitor the Browser Access processes in a Web page using this URL: 
https://dispatcherHostname:port/dispatcher/serviceMonitor/. 

 

If a process hangs for a long time, you can kill it directly. 

4.4.3 Reconfigure User Access Portal Web App 

You need to reconfigure the User Access Portal Web app in the following cases: 
• The SLD service address (internal address) has changed. 
• The configured SLD external address has changed. 
• The SLD has been reinstalled, which means the security token has changed. 
• You want to change the address of the User Access Portal server (for example, use the fully qualified domain 

name instead of a simple hostname or the IP address). 
• You want to change the certificate for the User Access Portal server. 

Prerequisites: 

• You are using SAP Business One Cloud 1.1 PL07 or higher.  
• You have installed the User Access Portal. 

Procedure: 

To reconfigure the User Access Portal web app, you can run the setup wizard for SAP Business One Cloud in 
reconfiguration mode and change the certificate for the User Access Portal. To do so, perform the following: 

 In the SAP Business One product or upgrade package, navigate to the directory …/ Program 
Files/SAP/SAP Business One Cloud Setup Files and run the setup.exe file. If you are using 
Windows Server 2008 or Windows 7, right-click the setup.exe file and choose Run as administrator.  

 In the Setup Wizard window, select the Reconfiguration option and choose Next. 
 
 

https://dispatcherHostname:port/dispatcher/serviceMonitor/
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 In the Installed components for reconfiguration window, choose Next.   
 In the Specify Security Certificate window, specify a path to the certificate store file, enter a certificate 

password, and choose Next. 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 

 In the Review Reconfigured Settings window, choose Next and wait for the reconfiguration to finish.  
 In the Reconfiguration Progress window, choose Next.  
 In the Reconfiguration Status window, choose Next.  
 In the Reconfiguration Completed window, choose Finish.  
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4.5 Enabling Analytics Services and apps for the version for SAP 
HANA 

SAP Business One analytics powered by SAP HANA provides various analytical features, including enterprise 
search, real-time dashboards, Microsoft Excel interactive analysis, and predefined Crystal reports. The 
application also includes a Web-based Administration Console for performing administrative tasks related to the 
analytical features. 

 Note 
Analytical features and apps for the version for SAP HANA are available only in SAP Business One Cloud 
environments using SAP HANA. Cloud environments that use Microsoft SQL Server do not support 
analytical features. 

Prerequisites 

You have installed SAP Business One, analytics powered by SAP HANA, initialized corresponding company 
databases in the Administration Console, and logged on to SAP Business One, version for SAP HANA again. 
For information about installing the application and initializing company databases on an SAP HANA database 
server, see SAP Business One Administrator's Guide, version for SAP HANA. 
For information about working with the analytical features in SAP Business One, see the SAP Business One Online 
Help. 

 Note 
Analytics Services and apps for the version for SAP HANA in SAP Business One Cloud is different from 
that in SAP Business One on premise. Analytics Service and apps can be installed in SAP HANA server 
only. 

 
If you want to enable Analytics Services and apps in SAP HANA high availability mode, perform the following 
steps: 

 Stop cluster resource manager. 
You must stop it one by one. 

 Stop cluster resource manager in secondary server via root: 
rcopenais stop 

 Stop cluster resource manager in primary server via root: 
rcopenais stop 

 Start primary SAP HANA instance. 
Stopping cluster resource manager leads to a stopped SAP HANA instance. You must start the SAP HANA 
instance manually. 

 Unregister the secondary SAP HANA instance. 
In the secondary SAP HANA server, execute the following command via <SID>adm: 
hdbnsutil -sr_unregister 

 Start the secondary SAP HANA instance. 
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After you have the secondary instance unregistered, start SAP HANA instance in the secondary server 
manually. 

 Install Analytics service and app Framework in both SAP HANA servers. 

 Note 
Enter localhost for SAP HANA address. 

 Stop Analytics Service and app Framework in the secondary server. 
Execute the following command via root: 
/etc/init.d/sapb1servertools stop 

 Stop SAP HANA instance in the secondary SAP HANA server. 
 Register the SAP HANA instance in the secondary server again. 

Execute the following command via <SID>adm: 
hdbnsutil -sr_register --remoteHost=<Remote Host Name> --remoteInstance=<HANA 
Instance Number> --mode=syncmem --name=<Local Host Name> 

 Start cluster resource manager. 
You must start it one by one, and the order of starting is opposite to that of stopping. 

 Start cluster resource manager in primary server via root: 
rcopenais start 

 Start cluster resource manager in secondary server via root: 
rcopenais start 

 Add resource control script. 
 Upload crm_b1.txt into SAP HANA server. 

 Execute the following command via root: 
crm resource load update crm_b1.txt 

 Unregister Analytics Service and app that are not using virtual IP address. 

4.6 Installing the Web Client for SAP Business One  

The Web Client for SAP Business One offers the SAP Business One core business logic and processes provided in 
the new SAP Fiori user experience. For more information about using the Web Client, see the Web Client for SAP 
Business One User Guide on SAP Help Portal 

4.6.1 Installing the Web Client on Windows 

Prerequisites 

The Web Client for SAP Business One depends on the existence of the Service Layer, which is preselected for 
installation when you choose to install the Web Client.  

http://www.help.sap.com/
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Procedure 

To install the Web Client on a Microsoft Windows machine, follow the procedure in the section Installing the Web 
Client in the Administrator's Guide for SAP Business One on SAP Help Portal with the following exceptions: 
• In the Select Features window, select the Web Client and choose Next.  

Note 
The Service Layer is automatically selected as it is a required component for deployment of the Web 
Client.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
• In the Landscape Server window, enter the server address and port of the System Landscape Directory 

installed in SAP Business One Cloud and choose Next.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.help.sap.com/
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• In the Database Server Specification window, specify the database information of your Microsoft SQL 
database server and choose Next.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
• In the Service Layer window, specify the following information for the Service Layer and then choose Next: 

o Install Service Layer Load Balancer and Port: Select the checkbox to install the load balancer and specify 
the port for the load balancer. 
When installing the load balancer, you need to specify the following information: 
o Port for the load balancer. The default port for the load balancer is 50000. 
o Server name or IP address of all load balancer members, as well as their ports. 

Note that the load balancer and load balancer members must use a different port for each if installed on 
the same machine. 

 Note 
The port number must be within the 0-65535 range. 

o Service Layer Load Balancer Members: Specify the server address and port for each load balancer 
member. 
If you have selected the Install Service Layer Load Balancer checkbox, you can specify load balancer 
members either on local (current) or remote (different) machines. If on the local machine, the installer will 
create a local load balancer member; if on a remote machine, the load balancer member will be added to 
the pool (cluster) of load balancer members, but you need to install the specific load balancer member on 
its own server. 
o Starting Port: The port for the first balancer member. The default starting port is 50001. 
o Node Count: The total number of the load balance members. 

 Example 
If you specify 5 load balancer members on a local machine and the starting port is 50001, the 
corresponding ports for the other 4 load members as follows: 
o 50002 

o 50003 



 

SAP Business One Cloud Administrator's Guide 
Installing SAP Business One Cloud 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  85 

 

o 50004 

o 50005 

The node count is 5. 
If you have not selected the checkbox, you cannot edit the server address, which is automatically set to 
127.0.0.1 (localhost). All specified load balancer members will be created. 

 Note 
Ipv6 addresses are not allowed. 

o Threads per Load Balancer Member: The number of threads to be run for each load balancer member. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
• In the Web Client Port window, specify a port number that is to be used by the Web Client and choose Next. 

The default port number is 443. The port number must be within the 0-65536 range. 
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Note 
After the installation, to start working with the Web Client on Windows, ensure that you set Google 
Chrome or Mozilla Firefox as your default Web browser. If your devices are Windows domain-joined, we 
recommend that the administrator centrally set the default browser using Group Policy. For more 
information, see the section Web Client in the Administrator's Guide for SAP Business One on SAP Help 
Portal. 

Note 
Due to a limitation in SAP Business One 10.0 PL00 and PL01, after you install the Web Client and 
subsequentially register the Web Client on a service unit in the Cloud Control Center (see Registering 
Software Components or Storage to Existing Service Units), you need to restart the Web Client by 
completing the steps described in SAP Note 2875511. 

4.6.2 Installing the Web Client on Linux 

The Web Client for SAP Business One depends on the existence of the Service Layer and analytical features, both 
of which can be installed during installation of the Web Client as described below. 

Procedure 

To install the Web Client on a Linux machine, follow the procedure in the section Wizard Installation in the 
Administrator's Guide for SAP Business One, version for SAP HANA on SAP Help Portal with the following 
exceptions:  
• In the Select Features window, select the Web Client, Analytical Features, and Service Layer Components. 

Ensure that the System Landscape Directory is unselected and choose Next.  
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

http://www.help.sap.com/
http://www.help.sap.com/
https://launchpad.support.sap.com/#/notes/2875511
http://www.help.sap.com/
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• In the Landscape Server window, enter the server address and port for the System Landscape Directory 
installed in SAP Business One Cloud and choose Next.  
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
• In the Service Layer window, specify the following information for the Service Layer and then choose Next: 

o Install Service Layer Load Balancer and Port: Select the checkbox to install the load balancer and specify 
the port for the load balancer. 
When installing the load balancer, you need to specify the following information: 
o Port for the load balancer. The default port for the load balancer is 50000. 
o Server name or IP address of all load balancer members, as well as their ports. 

Note that the load balancer and load balancer members must use a different port for each if installed on 
the same machine. 

 Note 
The port number must be within the 0-65535 range. 

o Service Layer Load Balancer Members: Specify the server address and port for each load balancer 
member. 
If you have selected the Install Service Layer Load Balancer checkbox, you can specify load balancer 
members either on local (current) or remote (different) machines. If on the local machine, the installer will 
create a local load balancer member; if on a remote machine, the load balancer member will be added to 
the pool (cluster) of load balancer members, but you need to install the specific load balancer member on 
its own server. 
o Starting Port: The port for the first balancer member. The default starting port is 50001. 
o Node Count: The total number of the load balance members. 

 Example 
If you specify 5 load balancer members on a local machine and the starting port is 50001, the 
corresponding ports for the other 4 load members as follows: 
o 50002 

o 50003 
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o 50004 

o 50005 

The node count is 5. 
If you have not selected the checkbox, you cannot edit the server address, which is automatically set to 
127.0.0.1 (localhost). All specified load balancer members will be created. 

 Note 
Ipv6 addresses are not allowed. 

o Threads per Load Balancer Member: The number of threads to be run for each load balancer member. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
• In the Web Client Port window, specify a port number that is to be used by the Web client and choose Next. 

The default port number is 443. The port number must be within the 0-65536 range. 
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Note 
Due to a limitation in SAP Business One 10.0 PL00 and PL01, after you install the Web Client and 
subsequentially register the Web Client on a service unit in the Cloud Control Center (see Registering 
Software Components or Storage to Existing Service Units), you need to restart the service by performing 
the following steps: 

1.  Log on to the Linux server as root. 
2.  In a command line terminal, navigate to the directory     
      …/user/sap/SAPBusinessOne/WebClient where the startup.sh script is located. 
3.  Restart the program from the command line by entering the following command: 
  sh startup.sh restart 

The restart process begins. 
 

4.7 Installing the Integration Component for SAP Business One 

The integration component for SAP Business One is an optional component that enables users to use 
dashboards, work with mobile devices, and integrate with third-party services. Each service unit requires a 
dedicated integration component instance. 
For more information about installing and configuring the integration component, see Working with the Integration 
Framework of SAP Business One in Cloud Environments on SAP Help Portal. 

 Recommendation 
Install the integration component to provide users with full SAP Business One functionality and mobile 
device access. You should install the integration component on the same server as the database instance 
that contains common databases.  

 

Note 
As a security enhancement as of SAP Business One version 10.0, when you use the integration framework 
to connect to the DI API, you must enter the database user and database password each time. This is the 
case for both B1DI (dbUser, dbPassword) and JDBC (username, password) connection details.  
For more information about database user management in SAP Business One Cloud, see the section 
Database User Management in the Administrator's Guide for SAP Business One Cloud on SAP Help Portal.  

4.8 Installing the Tenant Configurator for SAP Business One 
Cloud  

The Tenant Configurator for SAP Business One Cloud is a solution that allows you to automate the tenant 
configuration and creation process in the cloud so that you can focus on accelerating the volume of your business. 

https://help.sap.com/
https://help.sap.com/
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By using a preconfigured solution prepared in advance for your target customer groups, you can minimize the 
effort in configuring and creating tenants each time customers of the same group make a request. The solution is 
integrated into the partner’s onboarding process and is suitable for partners using business models with 
preconfigured solutions for a specific target group of customers, such as OEM agreements, packaged solutions, 
and vertical and micro-vertical solutions.  
After installing the solution on your machine, the installed Tenant Configurator for SAP Business One Cloud is 
displayed In the Cloud Control Center, on the Tenant Configurator page (Service Unit Components → Tenant 
Configurator). To access the Tenant Configurator for SAP Business One Cloud, use the link in the Service URL 
field.  

 
For more information on installing, configuring, and working with the Tenant Configurator for SAP Business One 
Cloud, see How to Work with the Tenant Configurator for SAP Business One Cloud on SAP Help Portal or in the 
TenantConfigurator folder in the root folder of the SAP Business One Cloud installation package.  
You can also find training sessions on the Tenant Configurator for SAP Business One Cloud at the following link: 
https://businessone.litmos.com/self-signup/ (you must enter registration code 2104111). 
 

https://help.sap.com/
https://businessone.litmos.com/self-signup/
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5 Managing Remote Access 

You can use a variety of remote access solutions to provide remote access to SAP Business One, for example 
Microsoft Remote Desktop Services (RDS) or Citrix. 
A typical Microsoft RDS landscape includes the following components:  
• User Access Portal – A web server that hosts a customized landing page where registered SAP Business One 

Users can enter their logon credentials to remotely access the SAP Business One client application. 
• Remote Desktop Gateway – Creates secure, encrypted connections across firewalls and network address 

translators. The remote desktop gateway enables users to connect to remote machines in the network from 
any location, without the need for a virtual private network (VPN) connection. 

• Connection Broker – Responsible for connecting users to virtual desktops on presentation servers with 
sufficient available capacity. 

• RD Licensing Server – Manages RDS client access licenses that are required for remote connections. 

5.1 Customizing the User Access Portal 

The user access portal (UAP) is a landing page on which users can enter their logon credentials to remotely 
access the SAP Business One application. For more information, see Installing the User Access Portal. 
UAP is a simple HTML page. Administrators are free to modify the visual aspects according to their company's 
visual needs. For example, they can add URLs or specify company logos, texts, and so on. 
For more information about customizing the user access portal, see www.microsoft.com. 

5.2 Working with Microsoft Office 

SAP Business One enables users to export reports and documents to Microsoft Excel and Microsoft Word. You 
can enable users to work with Microsoft Office using a number of methods, including those listed below.  

Note 
As of SAP Business One 1 Cloud 1.1, the SAP Business One Cloud Terminal Service Plugin (B1ODTS) is no 
longer supported.  

5.2.1 Disk Sharing 

For more information about mapping client drives, see Client Drive Mapping. 
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5.2.2 Local Drive Mapping  

You can use local drive mapping to enable users to access documents on the cloud side, for example using one of 
the following methods: 

 Virtual storage through WebDAV  
 Automatic mapping of user storage 

5.2.2.1 Setting Up Virtual Storage Using WebDAV 

Prerequisites 

• You have installed Microsoft Internet Information Services (IIS) on the machine on which the user storage is 
located. For more information about installing and configuring IIS, see www.microsoft.com. 

• You have enabled WebDAV for IIS. 
• You have enabled Digest Authentication for IIS. 

Procedure 

To enable users to access their personal subfolders in the user storage using the WebDAV protocol, perform the 
following: 

 In Windows, choose Start → Administrative Tools → Server Manager. 
 In the Console Tree, expand Roles → Web Server (IIS) → Internet Information Services (IIS) Manager. 
 In the Connections pane, expand the Sites node in the tree, right click Default Web Site, and then select Add 

Virtual Directory from the context menu. 
 In the Add Virtual Directory window, specify the following: 

o Alias – Enter UserStorage. 
o Physical path – Enter the full UNC path to the Windows shared folder that you have configured as user 

storage. 

 

http://www.microsoft.com/
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 To close the window, choose the OK button. 
 Configure the WebDAV authoring rules: 

 In the Connections pane, expand Sites → Default Web Site → User Storage. 
 In the IIS area, double-click WebDAV Authoring Rules. 
 In the Actions pane, choose Add Authoring Rule. 
 In the Add Authoring Rule window, do the following: 

o In the Allow access to area, select the All Content radio button. 
o In the Allow access to this content to area, select the All users radio button, 
o In the Permissions area, select the Read, Source, and Write checkboxes. 

5.2.2.2 Setting Up Automatic Mapping of User Storage 

Prerequisites 

You have created user storage. For more information, see Creating User Storage 

Procedure 

To enable the automatic mapping of user storage to the Z drive on presentation servers when users log on to SAP 
Business One Cloud, use a group policy object to configure the following logon script for each domain user: 

net use Z: \\<StorageServer>\UserStorage\%USERNAME% 

5.2.3 SAP Business One Microsoft 365 Integration 

With the SAP Business One Microsoft 365 integration feature, you  can use Microsoft Office Word and Excel, 
Outlook, storage space, and other components in the cloud. The SAP Business One Microsoft 365 integration 
feature is available as of SAP Busines One Cloud 1.1 PL17. To use SAP Business One Microsoft 365 integration in 
SAP Business One Cloud, make sure you have registered the job service component in your service unit.  
For more information, see How to Work with SAP Business One Microsoft 365 Integration on SAP Help Portal. 

5.3 Supporting Local Printing 

Both Microsoft RDS and Citrix support redirecting print jobs to client machines, and can provision locally attached 
and network printers.  
For more information about printing, see the corresponding documentation for your remote access solution. 

httphttps://help.sap.com/
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5.4 Client Drive Mapping 

Both Microsoft RDS and Citrix support mapping client drives, which enables users to access their locally stored 
files during remote sessions to, for example, attach files in SAP Business One. 
For information about mapping client drives, see the corresponding documentation for your remote access 
solution. 
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6 Registering Components Using the Cloud 
Control Center 

This section describes how to use the Cloud Control Center to register the components you previously configured 
in the System Landscape Directory (SLD). Once components are registered, you can use the Cloud Control 
Center to group components into service units to provide tenants with access to SAP Business One. 
To access the Cloud Control Center, in a web browser, enter the machine name or IP address of the landscape 
server on which you have installed the SAP Business One Cloud components.  

 Example  
https://landscapeservername/ 

 

In the Cloud Control Center, you can register the following components: 
• License servers 
• Database instances 
• Storage (see Registering Storage) 
• Presentation servers 
• Web Client for SAP Business One 
• Browser Access Servers 
• Integration framework for SAP Business One  
• Job service 
• Analytics services 
• App frameworks 
• Service Layers 
• Mobile services 
• Electronic Documents Services  

When registering these components, you can register multiple components of the same type in the corresponding 
window one after the other. After completing the registration process, you can create common databases. 
Alternatively, if you have already created a common database, you can register existing databases.  

 Caution  
In order to register components in the Cloud Control Center, you must first configure the server 
landscape. For more information, see Configuring the Server Landscape. 

https://landscapeservername/
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6.1 Registering Database Instances 

6.1.1 Registering Microsoft SQL Server Database Instances 

 In the Cloud Control Center, choose Service Unit Components → Database Instances, and then choose the 
Register button.  
The Database Instance Registration window appears. 

 

 In the Database Instance Registration window, specify the following: 
o Server Type – From the dropdown list, select the MSSQL option to register a Microsoft SQL Server 

database instance.  
o Name – Enter the database instance you want to register or select a database instance from the 

dropdown list. 
o Authentication Type – From the dropdown list, select the type of authentication used for connections 

between the SAP Business One client and the tenant's company database. For a Microsoft SQL Server 
database instance, select the authentication method used by the database. If you choose SBO Managed 
Authentication, specify the user name and password to authenticate the database.  

 Note  
As of SAP Business One Cloud 1.1 PL15, Windows Authentication is no longer available as an 
authentication type option when registering new database instances. By default, SBO Managed 
Authentication is displayed in the Authentication Type field. Existing database instances with Windows 
Authentication will not be changed after upgrading. If you choose to change the authentication type of an 
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existing database instance to SBO Managed Authentication (Service Unit Components → Database 
Instances → Database Instance Details → Configuration → Edit button → Authentication Type field), note 
that this is an irreversible change.  

o Description – Enter an optional description for this database instance. 
 To verify the database instance exists and is available, choose the Test Connection button. 
 To complete the registration process, choose the Register button. 

6.1.2 Registering SAP HANA Server Database Instances 

 In the Cloud Control Center, choose Service Unit Components → Database Instances, and then choose the 
Register button.  
The Database Instance Registration window appears. 

 In the Database Instance Registration window, specify the following: 
o Server Type – From the dropdown list, select the SAP HANA Database option to register an SAP HANA 

database instance.  
o Server Name – Enter the database instance you want to register or select a database instance from the 

dropdown list. 
o Instance Number – Enter database instance number (for example: 00). 
o Database Container Mode – Specify the database container mode by selecting the Single Container or 

Multiple Container radio button.  

Note 
To use multiple database containers, before proceeding with these steps, you need to follow the 
procedure specified in Installing SAP HANA 2.0 in a Cloud Environment to Enable Multiple Database 
Containers or Setting Up Multiple Database Containers in an Existing SAP HANA 2.0 Environment.   

o Tenant Database Name – If you chose Multiple Container as the database container mode, enter the 
tenant database name. 



 

98 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Registering Components Using the Cloud Control Center 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
o Authentication Type – From the dropdown list, select the type of authentication used for connections 

between the SAP Business One client and the tenant's company database. When using SBO Managed 
Authentication, specify the user name and password to authenticate the database.  

 Note  
For the server authentication, note that you must use the SBO Managed Authentication option, as the 
Windows Authentication option is not supported. 

o Connect Using SSL – You may choose to enable secure communication between the SLD and SAP HANA 
database using the Secure Sockets Layer (SSL) protocol. To do so, perform the following: 
1.    Navigate to a SSL keystore file in a local user directory in which the Cloud Control Center is installed. 

For more information about keystore, see SAP HANA Administration Guide at 
http://help.sap.com/hana_platform.  

             2.    Transfer the file to your Linux machine. 
3.    Convert the format of the keystore file from binary data into base64 encoding.  

You can use the following Linux server command (or a third-party tool) to convert the keystore file:  
base64 -w 0 .keystore >"<file-of-base64>"                     

 For example: base64 -w 0 .keystore >keystore.txt 
4.   Transfer the base64 keystore.txt file to the Windows machine on which the Cloud Control  

Center is installed.  
5.    Open the base64 keystore.txt file and copy the string. 
6.    In the Cloud Control Center, in the Database Instance Registration window, select the Connect Using 

SSL checkbox. 
              7.    In the SSL Key Store field, paste the string you copied from the keystore file. 

http://help.sap.com/hana_platform
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Note  
After enabling the connection using SSL, you can specify only the hostname of the database server or the 
FQDN (fully qualified domain hostname) with the port of the SAP HANA machine (for example, 
hanab1.b1c.local:30015) in the Name field rather than the IP address. 

o Description – Enter an optional description for this database instance. 
 To verify the database instance exists and is available, choose the Test Connection button. 
 To complete the registration process, choose the Register button. 

6.1.2.1 Configuring SAP HANA 2.0 in Cloud Environments to 
Enable Multiple Database Containers  

This section describes how to configure SAP HANA Platform Edition 2.0 in your cloud environment to enable you 
to work with multiple database containers.  

Note  
You need to complete this procedure before registering the multiple container database in the Cloud 
Control Center.  

Note  
The SAP HANA system database is used to manage tenant databases and the default tenant database is 
used to install SAP Business One.   
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Prerequisites 

• You have installed an SAP HANA Platform Edition 2.0 server. For more information, see the SAP HANA 
installation guides on SAP Help Portal at https://help.sap.com/hana_platform. 

• You have installed the SAP HANA client on a Linux server. For more information, see the SAP HANA Client 
Installation and Update Guide on SAP Help Portal. 

Procedure 

As a result of the of SAP HANA 2.0 installation, two databases are created: a system database (for example, 
SYSTEMDB@NBD(SYSTEM)) and a default tenant database (for example, DEV@NDB(SYSTEM)). You need to 
connect to the system database and default tenant database in SAP HANA studio and then register the default 
tenant database in the Cloud Control Center. To do so, perform the following: 

 Log on to the SAP HANA studio. 
 To connect to the system database, in the Systems list, right-click a blank space and choose Add System… 
 In the Specify System window,  in the Mode field, select Multiple containers and System database. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Description field, enter a description for the system (for example, SYSTEMDB) and then choose Next. 
The description will be displayed in the list of systems in the Systems panel.  

https://help.sap.com/
https://help.sap.com/hana_platform
https://help.sap.com/
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 In the Connection Properties window, choose Authentication by database user, enter your user name and 
password, and choose Finish.  
As a result, you can see the new system database in the Systems list.  

 To check that the two databases were successfully created, right-click the system database, choose Open an 
SQL Console, and run the following SQL statement: 
SELECT * FROM "SYS_DATABASES"."M_SERVICES"; 

 To connect to the default tenant database in SAP HANA studio, perform the following: 
 In the Systems list, right-click a blank space and choose New System.  
 In the Specify System window, in the Mode field, select Multiple containers and Tenant database. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Name field, enter a name for the tenant  (for example, NDB) and then choose Next. 
 In the Cloud Control Center, register the tenant database as a database instance and set up the service unit. 

For more information, see Registering SAP HANA Server Database Instances.  

6.1.2.2 Setting Up Multiple Database Containers in SAP HANA 
2.0 Environments 

This section describes how to set up multiple database containers in an existing SAP HANA 2.0 environment. 



 

102 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Registering Components Using the Cloud Control Center 

 

Procedure 

To create a new tenant database in an existing SAP HANA 2.0 environment, perform the following steps:  
 Log on to the SAP HANA studio. 
 Connect to the SYSTEM database (see Steps 1-5 in Installing SAP HANA 2.0 in Cloud Environments to Enable 

Multiple Database Containers).  
 To create a new tenant, right-click the system database, choose Open an SQL Console, and run the following 

SQL statement: 
--with script server 

create database <database name> ADD 'scriptserver' system user password <system 
user password>; 

 To check that the tenant database was successfully created, right-click the system database, choose Open an 
SQL Console, and run the following SQL statement: 
SELECT * FROM "SYS_DATABASES"."M_SERVICES"; 

 To connect to the new tenant database in SAP HANA studio, perform the following: 
 In the Systems list, right-click a blank space and choose New System.  
 In the Specify System window, in the Mode field, select Multiple containers. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Name field, enter a name for the tenant database  and then choose Next. 
 In the Cloud Control Center, register the tenant database as a database instance and set up the service unit. 

For more information, see Registering SAP HANA Server Database Instances.  



 

SAP Business One Cloud Administrator's Guide 
Registering Components Using the Cloud Control Center 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  103 

 

Result 

In the Cloud Control Center, choose Service Unit Components → Database Instances. You will see that for one SAP 
HANA database instance, there are two tenant databases.  
For additional SQL statements related to managing tenant databases, see the SAP HANA SQL Reference Guide for 
SAP HANA Platform on SAP Help Portal.  

6.1.2.3 Deleting SAP HANA Tenant Databases  

Procedure 

To delete an existing tenant database in an SAP HANA 2.0 environment, perform the following: 
 Log on to the SAP HANA studio. 
 Right-click the system database, choose Open an SQL Console, and run the following SQL statement: 
--Stop Manage Tenant database； 

alter system stop database <tenant database name>; 

-- drop Tenant (Stop it first) 

drop database <tenant database name>; 

 To check that the tenant database is deleted, run the following SQL statement: 
SELECT * FROM "SYS_DATABASES"."M_SERVICES" 

6.2 Registering License Servers 

Prerequisites 

The license manager is running. For more information about the license manager, see the SAP Business One 
Administrator’s Guide. 

Procedure 

To register an SAP Business One License Server, do the following: 
 In the Cloud Control Center, choose Central Components → License Servers, and then choose the Register 

button.  
The License Server Registration window appears. 

https://help.sap.com/
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 In the License Server Registration window, specify the following: 
o Server – Enter the full UNC path or IP address of the license server. 
o Port – Enter the port number that you previously configured this license server to use. 

 Note  
The port number is set by default to 30000.  

o Description – Enter an optional description for this license server. 
 To verify the license server exists and is available, choose the Test Connection button. 
 To complete the registration process, choose the Register button. 

6.3 Registering Presentation Servers 

 Note  
In this procedure, SLD checks whether the SLD Agent is installed and is available. Nothing will be installed 
on the machine. 

To register a presentation server, do the following: 
 In the Cloud Control Center, choose Service Unit Components → Presentation Servers, and then choose the 

Register button.  
The Presentation Server Registration window appears. 
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 In the Presentation Server Registration window, specify the following:  
o Name – Enter the host name of this presentation server. 
o Type – Specify whether the server uses Microsoft Remote Desktop Services or Citrix to provide remote 

access to SAP Business One. If you are unsure, select Unknown from the dropdown list. 
o Server – Select the relevant presentation server from the dropdown list. 

 Note  
Ensure that the version of the SLD Agent you have installed on all machines is the same as that of the 
Cloud Control Center. 

o Description – Enter an optional description for this presentation server. 
 To complete the registration process, choose the Register button. 

6.4 Registering Browser Access Servers 

 Note  
In this procedure, SDL checks whether the SLD Agent is installed and is available. Nothing will be installed 
on the machine. 

Procedure 

To register a Browser Access server, do the following: 
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 In the Cloud Control Center, choose Service Unit Components  → Browser Access Servers, and then choose 
the Register button.  

 The Browser Access Server Registration window appears. 

 

 In the Browser Access Server Registration window, specify the following:  
o Name – Enter a name for the Browser Access server. 
o Server and Port – Enter the machine name and the port number of the Browser Access server where the 

Browser Access Server Gatekeeper service will listen. This server must have SLD Agent installed. Make 
sure that the port is not used by other applications. 

o Certificate file and Certificate password – Specify a certificate file and password for the Browser Access 
Server Gatekeeper for HTTPS. If these are not provided, a self-signed certificate will be generated 
automatically. 

o Description – Enter an optional description for the Browser Access server. 
 To complete the registration process, choose the Register button. 
 To set the configuration details of the Browser Access servers, in the Browser Access Server Details area, on 

the Configuration tab, specify the following fields: 
o Maximum Processes [required] – Specify the maximum number of SAP Business One client processes 

that the Browser Access server can host. 
o Idle Processes  [required] – Specify the number of standby SAP Business One client processes. When a 

new SAP Business One user attempts to log on, an idle process is ready for use. The value can be equal or 
greater than 0 but no greater than the value for initial processes.  

o Description [optional] – Enter a description for the Browser Access server.   
o Service URL – If necessary, edit the URL used to access the Browser Access service. 

For example, you may want to use the IP address instead of the hostname. Or the hostname, IP address, 
or port has changed, and you must update the service URL to reflect the changes. 
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o Initial Processes  [required] – Specify the initial number of SAP Business One client processes that the 
Browser Access service hosts. The value can be equal or greater than 0 but no greater than the value for 
maximum processes.  

o Session Timeout [required] – Specify the number of minutes (more than 0) after which a session will time 
out.  

Example:  
Specify the following: 
o Maximum Processes: 100 
o Initial Processes: 20 
o Idle Processes: 2 

Twenty SAP Business One client processes are constantly running on the Browser Access server and 
allow 20 SAP Business One users to access the SAP Business One client in a Web browser at the same 
time. 
When the 19th SAP Business One user logs on, one more SAP Business One process is started to ensure 
that two idle processes are always running in the background. 
If more SAP Business One users attempt to access the SAP Business One client in a Web browser, more 
idle processes are started. However, a maximum of 100 users are allowed for concurrent access. 

 To save the changes, choose OK. 
 To apply the changes immediately, on the Browser Access server, restart the SAP Business One Browser 

Access Server Gatekeeper service. 

6.5 Registering Storage 

You can register software repositories, shared folders, implementation repositories, company template 
repositories, tenant storage, and user storage. 

6.5.1 Registering Software Repositories 

To register a software repository, do the following: 
 In the Cloud Control Center, choose Central Components → Storage, and then select the Software 

Repositories tab.  
 Choose the Register button. 

The Software Repository Registration window appears. 
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 In the Upgrade Package Path field, enter the full path to a folder corresponding to a major release of SAP 
Business One. For more information, see Creating Software Repositories. 

 Note 
SAP provides you with a useful command utility for updating the KEYSTORE of tomcat. After the 
completion of the installation process, the utility is installed under tomcat\bin. To update the https 
certificate in tomcat\conf\server.xml, run the command:  
updateKeystore.bat pk12keystore pk12keypass. 

 To complete the registration process, choose the Register button. 

6.5.2 Registering Shared Folders 

To register a shared folder, do the following: 
 In the Cloud Control Center, choose Central Components → Storage, and then select the Shared Folders tab.  
 Choose the Register button. 

The Shared Folder Registration window appears. 



 

SAP Business One Cloud Administrator's Guide 
Registering Components Using the Cloud Control Center 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  109 

 

 

 In the Shared Folder Registration window, specify the following: 
o Path – Enter the full UNC path to the shared folder that you want to register. 
o Description – Enter an optional description for this shared folder. 

 To complete the registration process, choose the Register button. 

6.5.3 Registering Implementation Repositories 

To register an Implementation Repository, do the following: 
 In the Cloud Control Center, choose Central Components → Storage, and then select the Implementation 

Repositories tab.  
 Choose the Register button. 

The Implementation Repository Registration window appears. 
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 In the Implementation Repository Registration window, specify the following: 
o Path – Enter the full UNC path to the repository that you want to register. 
o Description – Enter an optional description for this shared folder. 

 To complete the registration process, choose the Register button. 

6.5.4 Registering Company Template Repositories 

To register a Company Template Repository, do the following: 
 In the Cloud Control Center, choose Central Components → Storage, and then select the Company Template 

Repositories tab.  
 Choose the Register button. 

The Company Template Repository Registration window appears. 
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 In the Company Template Repository Registration window, specify the following: 
o Path – Enter the UNC path to the repository that you want to register. Note that only first level shares are 

supported (for example, \\server_hostname\Storage\) and that the terminal backslash is required 
(\).   

o Description – Enter an optional description for this shared folder. 
o Mount Point – Enter the SAP HANA server mount point directory that is mapped to the Company 

Template Repository.  

Note 
The mount point can be created by adding a new line to the configuration file /etc/fstab . To do so, 
perform the following: 
1.  Create the credentials file: /root/.cifs and enter the following lines: 
username=sapserviceb1c 

password=**password** 

2.  Add a new line to the configuration file /etc/fstab, for example: 
//server_hostname/Storage/mnt/CompanyTemplateRepo cifs 
credentials=/root/.cifs,domain=,uid=adm,forceuid,sec=ntlmssp 0 0 

3. Either run the command: mount -a or restart your system. 
The \\server_hostname\Storage is the Company Template Repository path and 
/mnt/CompanyTemplateRepo is the mount point. 

Note 
If you are using SAP HANA high availability mode, you need to mount the same point and same folder for 
both SAP HANA servers. 

 To complete the registration process, choose the Register button. 
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6.5.5 Registering Tenant Storage 

To register tenant storage, do the following: 
 In the Cloud Control Center, choose Central Components → Storage, and then select the Tenant Storage tab.  
 Choose the Register button. 

The Tenant Storage Registration window appears. 

  

 In the Tenant Storage Registration window, specify the following: 
o Path – Enter the full UNC path to the repository that you want to register. 
o Description – Enter an optional description for this tenant storage. 
o Mount Point – Enter the SAP HANA server mount point directory that is mapped to the tenant storage 

path.  

 Note 
The mount point can be created either by using a command or by adding a new line to the configuration 
file /etc/fstab. In either case, first create a folder for the mount point, for example: 
/mnt/tenantstorage. 
o To create the mount point temporarily using a command, enter, for example: mount -t cifs -o 

domain=<domain 
name>,username=sapserviceb1c,pass=**password**,uid=<sid>adm,forceuid 
'//server_hostname/SharedFolder/tenantstorage' /mnt/tenantstorage.  

o To create a permanent mount by adding a new line to the configuration file /etc/fstab 
(recommended), do the following: 

1.   Create the credentials file: /root/.cifs and enter the following lines: 
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  username=sapserviceb1c 
  password=**password** 

2.  Add a new line to the configuration file /etc/fstab, for example: 
//server_hostname/SharedFolder/tenantstorage /mnt/tenantstorage cifs 
credentials=/root/.cifs,domain=<domain 
name>,uid=<sid>adm,forceuid,sec=ntlmssp 0 0 

3.  Either run the command: mount -a or restart your system. 
In both examples, the //server_hostname/SharedFolder/tenantstorage is the tenant storage 
path and /mnt/tenantstorage is the mount point. 

 Note 
If you are using SAP HANA high availability mode, you need to mount the same point and same folder for 
both SAP HANA servers. 

 To complete the registration, choose the Register button. 

6.5.6 Registering User Storage 

To register user storage, do the following: 
 In the Cloud Control Center, choose Central Components → Storage, and then select the User Storage tab.  
 Choose the Register button. 

The User Storage Registration window appears. 

 

 In the User Storage Registration window, specify the following: 



 

114 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Registering Components Using the Cloud Control Center 

 

o Path – Enter the full UNC path to the repository that you want to register. 
o URI – Enter a URI to enable users to access their dedicated storage using WebDAV or FTP protocols. 
o Description – Enter an optional description for this user storage. 

 To complete the registration, choose the Register button. 

6.6 Registering and Creating Common Databases 

A common database is a central database containing system data, client application update packages, and add-
on installers. Multiple tenants in the same service unit share a single common database. You can create new 
common databases in the Cloud Control Center or register existing common databases. 

6.6.1 Registering Common Databases 

Prerequisites 

You have created a common database. 

Procedure 

To register a common database, do the following: 
 In the Cloud Control Center, choose Service Unit Components→ Common Databases, and then choose the 

Register button.  
The Common Database Registration window appears. 
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 In the Common Database Registration window, specify the following: 
o Database Instance – Select the corresponding database instance from the dropdown list. 
o Description – Enter an optional description for this server instance. 

 Note  
The name is set by default to SBO-COMMON.  

 To complete the registration process, choose the Register button. 
 Repeat the previous steps to register additional common databases. 
 Choose the Close button. 

6.6.2 Creating Common Databases 

Prerequisites 

You have registered the corresponding database instance for the common database that you want to create. For 
more information, see Registering Database Instances. 

Procedure 

To create a common database, do the following: 
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 In the Cloud Control Center, choose Service Unit Components→ Common Databases, and then choose the 
Create button.  
The Common Database Creation window appears. 

 

 In the Common Database Creation window, specify the following: 
o Database Instance – Select the corresponding database instance from the dropdown list. 
o Version – Select the corresponding version of SAP Business One from the dropdown list. 
o Description – Enter an optional description for this server instance. 

 Note  
The name is set by default to SBO-COMMON.  

 To complete the creation process, choose the Create button. 
 Repeat the previous steps to create additional common databases. 
 Choose the Close button. 
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7 Managing Service Units 

After registering infrastructure components in the SLD, you can group registered components together into 
service units. Depending on your requirements, you can create trial, staging, productive, demo, and testing 
service units.  
A service unit is a collection of the software components, servers, and storage required to provide access to a full 
SAP Business One installation. All SAP Business One components in a single service unit have the same version 
and add-ons. A single service unit can contain multiple tenants with similar requirements. 

7.1 Creating Service Units 

To provide users with access to a full installation of SAP Business One, you must first create a new service unit. 
After creating a service unit, you can create tenants in the service unit. 
As a cloud operator, you can control the maximum number of tenants that can be created on the service unit. The 
tenant limit can be set while creating the service unit using the Service Unit Creation Wizard (Basic Settings) and 
changed at any time in Central Components → Service Units → Service Unit Details area → Configuration tab.  

Prerequisites 

You have configured the following components and registered them in the SLD using the Cloud Control Center: 
• Database Instance 
• Software Repository 
• License Server 
• Presentation Server 
• Shared Folder 
• Tenant Storage 
• (Optional) Integration Component  
• (Optional) Job Service 
• (Optional) Analytics Service 
• (Optional) Implementation Repository 
• (Optional) Company Template Repository 
• (Optional) Service Layer 
• (Optional) Mobile Services  
• (Optional) Web Clients for SAP Business One  
• Electronic Document Service  

For more information, see Registering Components Using the Cloud Control Center. 
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Procedure 

To create a service unit, do the following: 
 In the Cloud Control Center, choose Central Components → Service Units, and then choose the New button to 

run the Service Unit Creation Wizard. 
 In the Basic Settings window, specify the following: 

o Service Unit Name – Enter a unique name of up to 128 characters for this service unit. 
o Database Type - Select the database type of the SAP Business One that you want to run. 
o Version – From the dropdown list, select the version of SAP Business One that you want to run. 
o Purpose – From the dropdown list, select the type of service unit you want to create. The following table 

provides an overview of the possible types. 

Purpose Description 

Staging You can use this service unit as an intermediary during tenant upgrades 
to minimize the impact on system resources. 

Trial Customers can evaluate a dedicated SAP Business One implementation 
for a limited period. 

Productive Customers can use this service unit to access SAP Business One and 
perform business operations. 

Demo Potential customers can use this service unit to try SAP Business One 
before purchasing subscriptions. 

Testing Cloud operators can use this service unit to test new functionality and 
software versions before customer deployment. 

 
o Description – Enter an optional description for this service unit. 
o Tenant Limit – Enter a positive integer to set the maximum number of tenants allowed on the service unit. 

The default value is 0, which indicates no limit. You can change the tenant limit at any time in Central 
Components → Service Units → Service Unit Details area → Configuration tab.  
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 In the Infrastructure Components window, specify the following: 
o License Server – From the dropdown list, select a license server that is compatible with the service unit. 
o Database Instance – From the dropdown list, select an available database instance.  
o Common Database – Specify the available common database. 
o Shared Folder – From the dropdown list, select a location to store attachments, images, and document 

templates. 
o Tenant Storage – From the dropdown list, select a location to store logs and company database backup 

files used during tenant upgrades. 
o Integration Component – From the dropdown list, select a B1i instance. 
o Job Service – From the dropdown list, select a job service. 
o Implementation Repository – From the dropdown list, select a location to store solution packages. 
o Analytics Service – From the dropdown list, select an analytics service to provide various analytical 

features to users, including enterprise search, real-time dashboards, Microsoft Excel interactive analysis, 
and predefined Crystal reports.  

 Note 
Analytical features are available only in SAP Business One Cloud environments using SAP HANA. Cloud 
environments that use Microsoft SQL Server do not support analytics services. 

o App Framework 
o Service Layer – From the dropdown list, select a Service Layer to provide Web access to SAP Business 

One services and objects. 
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Note 
o If you want to specify Web Client for SAP Business One or mobile service, you must also select the 

Service Layer.  
o Web Client for SAP Business One - From the dropdown list, select an available Web Client for SAP 

Business One environment.  
o Mobile Service – From the dropdown list, select a mobile service.  
o Company Template Repository – From the dropdown list, select a location to store backup files containing 

template company databases. 

 Note 
If you select a database instance that already contains a common database, the system automatically 
populates the Common Database field. If you select a database instance that does not yet contain a 
common database, the wizard creates a new common database for the selected database instance. 

o Electronic Document Service - From the dropdown list, select an available Electronic Document Service.  
 

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Presentation Servers window, select one or more presentation servers to assign to the service unit. 

 Note 
The wizard automatically deploys the SAP Business One client and SAP Business One Client Agent to the 
selected presentation servers, according to the service unit version that you previously specified. To 
correctly configure the SAP Business One Client Agent, the wizard prompts you to enter the credentials 
of a domain account that is a cloud operator with local administrative privileges on the selected 
presentation servers. 
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If you are using Microsoft RDS, you must configure SAP Business One as a RemoteApp. On each 
presentation server, do the following: 
o Use the RemoteApp wizard to configure SAP Business One as a RemoteApp.  
o Specify the tenant domain groups for which you want to enable connections to SAP Business One. 

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 In the Review window, review the settings you have made:  
o To create the service unit, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the creation process.  
To complete the process, choose the Finish button. 

7.2 Registering Software Components to Existing Service Units 

After creating a service unit, you can still register new software components to it at a later stage.  
The following software components can only be registered once to a particular service unit: 

o Analytics service 
o App frameworks 
o Service Layer 
o Mobile service 
o Electronic Documents Service 
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o Integration framework for SAP Business One  
o Job service 

 

Note 
For the integration framework for SAP Business One and job service, you can register a new component 
to replace the previous one. 
 
The exceptions are the following software components, which can be registered to a service unit more 
than once:  
o Presentation servers 
o Web Client for SAP Business One 
o Browser Access Servers 

Procedure 

 In the Cloud Control Center, choose Central Components → Service Units, and select an existing service 
unit. 

 In the Service Unit Details area, on the Software Components tab, choose the Register button.  
 In the Select Software Component window, select the component you want to register, and then choose the 

Register button. 
o For registering an additional presentation server, the application automatically deploys the SAP Business 

One client with the same version as the selected service unit. 
o When registering a Browser Access server, the Register button will trigger installation or re-installation (if 

an old version component already exists) of the component. However, the Un-Register button will not 
uninstall components. 

 Note 
If you register a server both as a presentation server and a Browser Access server, you must register the 
presentation server and Browser Access server on the same service unit. 
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7.3 Registering Storage to Existing Service Units 

After creating a service unit, you can still register storage to it at a later stage.  

Procedure 

 In the Cloud Control Center, choose Central Components → Service Units, and select an existing service unit. 
 In the Service Unit Details area, on the Storage tab, choose the Register button.  
 In the Select Storage window, select the type of storage you want to register, and then choose the Register 

button. 
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7.4 Duplicating Service Units 

To streamline the process of creating multiple service units for the same customer, you can use the service unit 
duplication wizard to duplicate an existing service unit. The target service unit has the same version as or higher 
version than the source target unit that contains the tenant you want to duplicate. You can add different users and 
assign different extensions to the duplicated tenant. 

Prerequisites 

You have created a source service unit. For more information, see Creating Service Units.  

Procedure 

To duplicate a service unit, do the following: 
 In the Cloud Control Center, choose Central Components → Service Units, select the source service unit that 

you want to duplicate, and then choose the Duplicate button to run the service unit duplication wizard. 
 In the Basic Settings window, specify the following settings for the target service unit: 

o Service Unit Name – Enter a unique name of up to 128 characters for this service unit. 
o Version – From the dropdown list, select the version of SAP Business One that you want to run. 
o Purpose – From the dropdown list, select the type of service unit you want to create. The following table 

provides an overview of the possible types. 

Purpose Description 

Staging You can use this service unit as an intermediary during tenant upgrades to 
minimize the impact on system resources. 

Trial Customers can evaluate a dedicated SAP Business One implementation for a 
limited period. 

Productive Customers can use this service unit to access SAP Business One and perform 
business operations. 

Demo Potential customers can use this service unit to try SAP Business One before 
purchasing subscriptions. 

Testing Cloud operators can use this service unit to test new functionality and software 
versions before customer deployment. 

 
o Description – Enter an optional description for this service unit. 

 In the Infrastructure Components window, specify the following: 

 Note 
The application automatically specifies the license server according to that of the source service unit. 

o Database Instance – From the dropdown list, select an available database instance.  
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o Shared Folder – From the dropdown list, select a location to store attachments, images, and document 
templates. 

o Tenant Storage – From the dropdown list, select a location to store logs and company database backup 
files used during tenant upgrades. 

o Integration Component – From the dropdown list, select a B1i instance. 
o Implementation Repository – From the dropdown list, select a location to store solution packages. 
o Company Template Repository – From the dropdown list, select a location to store backup files containing 

template company databases. 
 In the Presentation Servers window, select one or more presentation servers to assign to the target service 

unit. 

 Note 
The wizard automatically deploys the SAP Business One client to the selected presentation servers, 
according to the target service unit version that you previously specified. 
If the SAP Business One client is already installed on a presentation server, the wizard installs a new 
client, according to the specified target service unit version. However, there may extensions installed on 
the presentation server that are no longer required. Ensure you manually remove any redundant 
extensions. 

 In the Browser Access Servers window, select one or more Browser Access servers to assign to the service 
unit. 
The wizard automatically deploys the SAP Business One client, SAP Business One Client Agent, and Browser 
Access Server Gatekeeper to the selected Browser Access servers, according to the service unit version that 
you previously specified. 

 The Extensions window displays a list of the extensions deployed to the source service unit. Select the 
extensions that you also want to deploy to the target service unit. 

 Note 
The wizard automatically selects all the extensions that are compatible with the target service unit. You 
may deploy incompatible extensions; however, users may encounter errors when working with these 
extensions. 

 In the Review window, review the settings you have made:  
o To create the service unit, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the creation process.  
To complete the process, choose the Finish button. 

7.5 Monitoring Components 

In the Cloud Control Center, you can monitor the status of service units and their components, as well as 
monitoring the status of the SLD and SLD Agents.  
You can monitor the status of components by selecting the corresponding item under the Central Components 
section in the main menu of the Cloud Control Center. You can also view limited monitoring information on the 
Home page of the Cloud Control Center. 
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To view detailed monitoring information for the components of a service unit, in the Cloud Control Center, choose 
Central Components → Service Units, select the service for which you want to view monitoring information, and 
then select the Monitoring tab in the Service Unit Details area. 
The following table provides an overview of the different monitoring statuses for each component in a cloud 
landscape. 
 

Component  Available  Warning  Service 
Error 

 Service 
Not 
Reachable 

 Machine 
Not 
Reachable 

 
Unknown 

SLD Available 
and working 
correctly 

N/A Cannot 
connect to 
SLD database 

N/A N/A Cannot 
determine 
status 

SLD Agent Available 
and working 
correctly 

N/A N/A SLD Agent 
service not 
reachable via 
notification 
channel 

Machine 
running SLD 
Agent is not 
reachable 

Cannot 
determine 
status 

License 
Server 

Available 
and working 
correctly 

Offline or 
under 
maintenance, 
or no license 
files found 

N/A Cannot 
connect to 
license server 
service 

Machine 
running 
license 
server is not 
reachable 

Cannot 
determine 
status 

Database 
Instance 

Available 
and working 
correctly 

Offline N/A Cannot 
connect to 
database 
instance 

Machine 
running 
database 
instance is 
not 
reachable 

Cannot 
determine 
status 

Common 
Database 

Available 
and working 
correctly 

Offline Cannot 
retrieve 
version 
information 

Cannot 
connect to 
database 
instance, 
common 
database 
does not 
exist, or an 
error 
occurred 
while 
connecting 

Machine 
running 
common 
database is 
not 
reachable 

Cannot 
determine 
status 

Mailer Available 
and working 
correctly 

Offline, or 
SMTP server 
not 
configured, or 
logon 
credentials for 

Cannot 
connect to 
SMTP server 
or an error 
occurred 

Mailer service 
not reachable 
using 
notification 
channel 

Machine 
running 
mailer 
service is not 
reachable 

Cannot 
determine 
status 
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Component  Available  Warning  Service 
Error 

 Service 
Not 
Reachable 

 Machine 
Not 
Reachable 

 
Unknown 

SMTP server 
are incorrect 

during logon 
authentication 

Integration 
Component 

Available 
and working 
correctly 

Offline or 
version 
information is 
not registered 

Integration 
component is 
not available. 

Integration 
component is 
not reachable 

Machine 
running 
integration 
component 
is not 
reachable 

Cannot 
determine 
status 

Storage Available 
and working 
correctly 

N/A N/A Storage path 
does not 
exist 

N/A Cannot 
determine 
status 

Presentation 
Server 

Available 
and working 
correctly 

Offline or 
under 
maintenance 

Cannot 
connect to 
RDS or Citrix 
services 

SLD Agent of 
presentation 
server is not 
reachable 

Machine 
running 
presentation 
server is not 
reachable 

Cannot 
determine 
status 

Service Unit All 
components 
are available 
and working 
correctly 

Offline or one 
or more 
components 
have warnings 

One or more 
components 
report errors 

One or more 
components 
are not 
reachable 

One or more 
machines 
running 
components 
are not 
reachable 

Cannot 
determine 
status 
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8 Managing Customer Components 

After creating productive service units, you can perform the following tasks to provide customers with remote 
access to SAP Business One:  
• Create customers 
• Create tenants 
• Create company databases 
• Add SAP Business One Users to a tenant 
• Assign and manage licenses 

8.1 Creating Customers 

A customer is a client organization that has purchased a subscription to remotely access SAP Business One for a 
pre-defined period of time and specific number of named users, according to contractual conditions. 

Prerequisite 

You have obtained a valid SAP Business One license file. For more information, see Importing License Files.  

Procedure 

To create a customer, do the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then choose the New button 

to run the customer creation wizard.  
 In the Customer Profile window, specify the following: 

o Customer Name [required] – Enter the name of the customer or select an existing customer from the 
dropdown list. 

o Contact Person – Enter the name of the customer's contact person. 
o Phone – Enter the telephone number of the customer's contact person. 
o E-Mail – Enter the e-mail address of the customer's contact person. 
o Employee Count – Enter the number of employees in the customer’s organization. 
o Country/Region – Enter the country or region in which the customer is located. 
o Location – Enter the address of the customer. 
o Industry – Enter the industry in which the customer operates. 
o Description – Enter an optional description for this customer. 
o UPN Suffix – Specify the User Principal Name (UPN) suffix.   
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 Note 
If a UPN suffix is already assigned to the user's UPN, you cannot change the UPN suffix. 
Several customers can use the same suffix; however, you can set only one suffix for each customer.  

o External ID – Enter an external reference ID to help associate the customer with other SAP systems.  

Note 
By default, reseller operators do not have permission to edit the External ID field. If you want to allow 
resellers to edit external IDs, see Allow Resellers to Edit the External IDs. 

 
 In the License Import window, do one of the following: 

o Select a valid license file from the list. 
o Select the Trial checkbox. 

 Alternatively, to import a new license file, do the following: 
 Choose the Browse button.  
 In the File Upload window, locate the license file you want to use and choose the Open button. 
 Choose the Import button to import the license file. 
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 In the Add System Users window, choose the Add button to add Microsoft Windows domain user accounts to 
the customer.  
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 In the Add User window, perform the following: 
o  If a domain user account exists for the user, enter the domain user name, and then choose the Check 

Name button to verify that the domain user name you entered exists. The SAM Account Name and User 
Principal Name fields are displayed automatically. 

o To create a new domain user, see Adding Domain Users to Customers (Step 4). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 In the Add Tenants window, select the tenants you want to assign to the customer. To create a new tenant, 

choose the New button. For more information about creating tenants, see Creating Tenants. 
o To register the customer, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 
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 The Progress/Finish window displays an overview of the main results of the customer creation process.  
To complete the process, choose the Finish button. 

8.2 Managing Tenants 

A tenant is a company database, storage, and licenses allocated to a customer to provide business functionality. A 
customer may have multiple tenants across different service units, with each tenant having a different application 
version or purpose, such as trial, productive, demonstration, or testing instances. 
Multiple tenants may share a single service unit, with tenants’ data and configuration partitioned across multiple 
company databases and file repositories. 

8.2.1 Creating Tenants 

 You can create tenants by completing the steps in the tenant creation wizard.  

 Note 
Cloud operators can set the maximum number of tenants allowed on each service unit. Resellers must 
ensure that the cumulative number of their customer's tenants does not exceed the tenant limit. For more 
information, see Creating Service Units. 
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 Note 
The tenant shared folder structure consists of <Shared folder path>\<Database Name>\<B1 default 
structure>. The <B1 default structure> consists of the following subfolders: Attachments, WordDocs, 
ExclDocs, Bitmaps, and so on. 

Prerequisites 

• You have created a customer. For more information, see Creating Customers. 
• You have created a service unit with the version of SAP Business One that the customer wants to run in this 

tenant. For more information, see Creating Service Units. 

Procedure 

To create a tenant, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the New button to 

run the tenant creation wizard. 
 In the Tenant Creation Wizard window, select one of the following options: 

o New – Creates a new default tenant. For more information, see Creating Default Tenants. 
o From Package – Creates a tenant from an existing solution package. For more information, see Creating 

Tenants from Solution Packages. 

 Caution  
Creating tenants from solution packages is not supported in SAP Business One Cloud landscapes that 
use SAP HANA. 

o From Backup – Creates a tenant from an existing backup file. For more information, see Creating Tenants 
from Backups. 
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8.2.1.1 Creating Default Tenants 

If you select the New radio button in the Tenant Creation Wizard window, you create a default tenant that does not 
contain any business or transaction data. You must configure all required settings, including local settings, 
language, and chart of accounts. 

Procedure 

To create a default tenant, after completing steps 1 and 2 in Creating Tenants, do the following: 
 In the Select Customer window, select the customer to which you want to assign the tenant. 
 In the Select Service Unit window, select the service unit in which you want to create a tenant. 
 In the Tenant Information window, specify the following: 

Field Description 

Tenant Name Enter the name of the tenant. This name appears: 
• At the top of the SAP Business One Main Menu 
• In reports and on printed documents 

Database Name Enter a name for the company database that stores all business and 
transaction data. 

Purpose Select one of the following options: 
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Field Description 

• Trial – Customers can evaluate a dedicated SAP Business One 
implementation for a limited period. 

• Productive – Customers can use this database to store company 
information and perform business operations. 

• Demo – Potential customers can use this database to try SAP Business 
One before purchasing subscriptions. 

• Testing – Cloud operators can use this database to test new functionality 
and software versions before customer deployment. 

Trial Period This field is visible only when you select Trial as the tenant purpose. Enter the 
number of days for which the trial period is valid. The maximum allowed value 
is 93 days. 

Authentication Type From the dropdown list, select the type of authentication used for connections 
between the SAP Business One client and the tenant's company database. The 
available options are: 
• Windows Authentication – Each SAP Business One User is granted access 

to the database. An additional read-only domain account is created for 
some database operations. 

• SBO Managed Authentication – The client connects to the database using 
SQL Server Authentication. SAP Business One Users do not connect 
directly to the database, but receive access credentials from the SLD. Two 
domain accounts are created for database access: a read-only account 
and a read write account. This option is recommended. 

 Note 
For service units running SAP Business One 882.072 and earlier, you 
can select only Windows Authentication. 

 Note  
As of SAP Business One Cloud 1.1 PL15, Windows Authentication is no 
longer available when creating new tenants; you must use SBO 
Managed Authentication. Existing tenant registrations with Windows 
Authentication will not be changed after upgrading. If you choose to 
change the authentication type of an existing tenant to SBO Managed 
Authentication (Customer Management → Tenants → Tenant Details 
→ Configuration → Edit button → Authentication Type field), note that 
this is an irreversible change.  

Contact Person Enter the name of a contact person for this tenant. 

Phone Enter the telephone number of the contact person. 

E-Mail Enter the e-mail address of the contact person. 

Local Settings From the dropdown list, select the required country/region. 
Your selection determines accounting related parameters, such as tax 
definitions, tax reports, available chart of accounts templates, and availability 
of country-specific features. 
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Field Description 

Chart of Accounts From the dropdown list, select the required chart of accounts template. 
The available options are derived from the country/region selected in the 
Localization field. These options represent common chart of accounts 
structures in the selected country. 

Base Language From the dropdown list, select the language you want to use for displaying 
default values, such as document series, payment terms, and property 
descriptions. 

 Note 
This option does not define the default display language of the SAP 
Business One user interface. You can configure this option in the SAP 
Business One client after installation. 

Description Enter an optional description for this tenant. 

 
 In the Posting Periods window, specify the following: 

Field Description 

Period Code Specify a code of up to 20 characters for the posting period. 

Period Name Specify a name of up to 20 characters for the posting period. 

Sub Periods This setting determines the number of additional posting periods that SAP 
Business One creates automatically. Select one of the following options: 
• Year – Choose this option to manage a single period during a fiscal year. 

SAP Business One will not create additional posting periods automatically 
when you choose this option. 

• Quarters – Choose this option to manage four posting periods during a 
fiscal year. When you choose Quarters, the number 4 is entered 
automatically in the No. of Periods field and SAP Business One creates four 
new posting periods respectively. 

• Months – Choose this option to manage twelve posting periods during a 
fiscal year. When you choose Months, the number 12 is entered 
automatically in the No. of Periods field and SAP Business One creates 12 
new posting periods respectively. 

• Days – When you choose this option, the No. of Periods field becomes 
active. Enter the number of required posting periods. SAP Business One 
will then create the respective periods. For example, if you need to manage 
one posting period per week, enter 52 in the No. of Periods field. SAP 
Business One creates fifty-two periods; one for each week. 

When you select an entry that consists of more than one posting period, the 
value entered in the Period Code field is used as the base code for creating the 
codes of the additional posting periods. For example, if 2006 is entered as the 
Period Code and the value Quarters is selected in the Sub-Periods field, the 
codes of the four new posting periods would be 2006-1, 2006-2, and so on. 
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Field Description 

Number of Periods Displays the number of posting periods according to the option selected in the 
Sub-Periods field. This field is active only when Days is chosen in the Sub-
Periods field. 

Period Posting Date Specify the posting date range for the new period.  

 
 In the Users & Licenses window, choose the Assign button to optionally add SAP Business One Users to the 

tenant. After adding a user, select the license you want to assign to this user from the list. 
For more information about adding users, see Adding, Removing, and Importing SAP Business One Users.  

 Recommendation  
You should add at least one SAP Business One User with power user or superuser permissions to the 
tenant. After you complete the tenant creation process, this user can remotely access the SAP Business 
One client application and configure settings. 

Note 
Support users cannot be assigned to a tenant. SAP Business One Support user accounts are 
automatically created in SAP Business One (on premise) for support activities and their usage is not 
allowed in SAP Business One Cloud. 

o To register the tenant, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the tenant creation process.  
To complete the process, choose the Finish button. 

8.2.1.2 Creating Tenants from Solution Packages 

A solution package is a preconfigured industry-specific solution containing SAP Business One core configurations 
such as user-defined tables (UDTs) and user-defined fields (UDFs), print layouts, and so on. You can create 
solution packages using the Solution Packager for SAP Business One. 
For more information about working with solution packages, see Solution Packager online help. 

 Caution  
Creating tenants from solution packages is not supported in SAP Business One Cloud landscapes that 
use SAP HANA. 

Prerequisites 

• The required solution package exists in an Implementation Repository. For more information, see Creating 
Implementation Repositories. 

• The service unit in which you want to create a new tenant is version 8.82 PL06 or later. 
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Procedure 

To create a new company database from a solution package, after completing steps 1 and 2 in Creating Tenants, 
do the following: 

 In the Select Customer window, select the customer to which you want to assign the tenant. 
 In the Select Service Unit window, select the service unit in which you want to create a tenant. 
 In the Select Solution Package window, select the solution package (.PAK) file you want to use to create a 

tenant. 

 Caution  
You can only create tenants with versions equal to or later than the SAP Business One version you used to 
create the solution package. For example, if you create a solution package using SAP Business One 8.82 
PL06, you can create a tenant that can be used only with SAP Business One 8.82 PL06 or later. 

 Note  
For cloud operators, the wizard displays a list of the solution packages available in the Implementation 
Repositories that are registered to the service unit. For reseller operators, the wizard displays a list of the 
solution packages available in the Implementation Repositories that are assigned to the specific reseller. 

 In the Package Information window, verify the solution package information is correct. 
 In the Tenant Information window, specify the following: 

Field Description 

Tenant Name Enter the name of the tenant. This name appears: 
• At the top of the SAP Business One Main Menu 
• In reports and on printed documents 

Database Name Enter a name for the company database that stores all business and 
transaction data. 

Purpose Select one of the following options: 
• Trial – Customers can evaluate a dedicated SAP Business One 

implementation for a limited period. 
• Productive – Customers can use this database to store company 

information and perform business operations. 
• Demo – Potential customers can use this database to try SAP Business 

One before purchasing subscriptions. 
• Testing – Cloud operators can use this database to test new functionality 

and software versions before customer deployment. 

Trial Period This field is visible only when you select Trial as the tenant purpose. Enter the 
number of days for which the trial period is valid. The maximum allowed value 
is 93 days. 

Authentication Type From the dropdown list, select the type of authentication used for connections 
between the SAP Business One client and the tenant's company database. The 
available options are: 
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Field Description 

• Windows Authentication – Each SAP Business One User is granted access 
to the database. An additional read-only domain account is created for 
some database operations. 

• SBO Managed Authentication – The client connects to the database using 
SQL Server Authentication. SAP Business One Users do not connect 
directly to the database, but receive access credentials from the SLD. Two 
domain accounts are created for database access: a read-only account 
and a read write account. This option is recommended. 

 Note 
For service units running SAP Business One 882.072 and earlier, you 
can select only Windows Authentication. 

 Note  
As of SAP Business One Cloud 1.1 PL15, Windows Authentication is no 
longer available; you must use SBO Managed Authentication. Existing 
tenant registrations with Windows Authentication will not be changed 
after upgrading. If you choose to change the authentication type of an 
existing tenant to SBO Managed Authentication (Customer 
Management → Tenants → Tenant Details → Configuration → Edit 
button → Authentication Type field), note that this is an irreversible 
change. 

Contact Person Enter the name of a contact person for this tenant. 

Phone Enter the telephone number of the contact person. 

E-Mail Enter the e-mail address of the contact person. 

Local Settings From the dropdown list, select the required country/region. 
Your selection determines accounting related parameters, such as tax 
definitions, tax reports, available chart of accounts templates, and availability 
of country-specific features. 

Base Language From the dropdown list, select the language you want to use for displaying 
default values, such as document series, payment terms, and property 
descriptions. 

 Note 
This option does not define the default display language of the SAP 
Business One user interface. You can configure this option in the SAP 
Business One client after installation. 

Description Enter an optional description for this tenant. 

 
 From the dropdown list in the Chart of Accounts window, select one of the following options: 

o Pre-Defined – Configures the chart of accounts according to the exact chart of accounts structure in the 
solution package. 
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o User-Defined – Users can configure the chart of accounts in the SAP Business One client application after 
the provisioning process is complete.  

o Default – Configures a default chart of accounts structure according to the local settings of the solution 
package. 

 In the Posting Periods window, specify the following: 

Field Description 

Period Code Specify a code of up to 20 characters for the posting period. 

Period Name Specify a name of up to 20 characters for the posting period. 

Sub Periods This setting determines the number of additional posting periods that SAP 
Business One creates automatically. Select one of the following options: 
• Year – Choose this option to manage a single period during a fiscal year. 

SAP Business One will not create additional posting periods automatically 
when you choose this option. 

• Quarters – Choose this option to manage four posting periods during a 
fiscal year. When you choose Quarters, the number 4 is entered 
automatically in the No. of Periods field and SAP Business One creates four 
new posting periods respectively. 

• Months – Choose this option to manage twelve posting periods during a 
fiscal year. When you choose Months, the number 12 is entered 
automatically in the No. of Periods field and SAP Business One creates 12 
new posting periods respectively. 

• Days – When you choose this option, the No. of Periods field becomes 
active. Enter the number of required posting periods. SAP Business One 
will then create the respective periods. For example, if you need to manage 
one posting period per week, enter 52 in the No. of Periods field. SAP 
Business One creates fifty-two periods; one for each week. 

When you select an entry that consists of more than one posting period, the 
value entered in the Period Code field is used as the base code for creating the 
codes of the additional posting periods. For example, if 2006 is entered as the 
Period Code and the value Quarters is selected in the Sub-Periods field, the 
codes of the four new posting periods would be 2006-1, 2006-2, and so on. 

Number of Periods Displays the number of posting periods according to the option selected in the 
Sub-Periods field. This field is active only when Days is chosen in the Sub-
Periods field. 

Period Posting Date Specify the posting date range for the new period.  

 
 In the Users & Licenses window, choose the Assign button to optionally add SAP Business One Users to the 

tenant. After adding a user, select the license you want to assign to this user from the list. 
For more information about adding users, see Adding, Removing, and Importing SAP Business One Users.  

 Recommendation 
You should add at least one SAP Business One User with power user or superuser permissions to the 
tenant. After you complete the tenant creation process, this user can remotely access the SAP Business 
One client application and configure settings. 
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o To register the tenant, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the tenant creation process.  
To complete the process, choose the Finish button. 

8.2.1.3 Creating Tenants from Backups 

If you are using a Microsoft SQL Server, you can create new tenants from the backup files of existing tenants.  
If you are using an SAP HANA instance, you can create new tenants from export files of existing tenant schemas. 
The new tenant contains all the settings and business and transaction data of the original tenant. You are required 
to specify only the name and purpose of the new company database. 

Prerequisites 

For service units based on a Microsoft SQL Server, ensure the following:  
• The required database backup file exists in a Company Template Repository. For more information, see 

Creating Company Template Repositories. 
For service units based on an SAP HANA instance, ensure the following 
• You have installed the SLD Agent on the SUSE Linux Enterprise server hosting the relevant SAP HANA 

database instance. For more information, see SAP Note 2714103. 
Alternatively, you have installed the backup service on your Linux machine and configured it to control the 
particular SAP HANA instance. (Note that this does not apply for the SAP-hosted option). For more 
information, see Installing Linux-Based Server Components in the SAP Business One Administrator's Guide, 
version for SAP HANA. 

 Note 
To check the backup service assigned to your database instances, in the Cloud Control Center, choose 
Service Unit Components → Backup Services.  Note that if the backup service does not support the 
schema import, the Version field will be empty. 

• You have exported the schema and packaged it as a single file (.zip, .tar, or .tar.gz).   
For more information about exporting schemas, see SAP Note 2134959. 

• In the Cloud Control Center, you have performed the following: 
 Defined a Company Template Repository to be used as the import location. For more information, see 

Creating Company Template Repositories. 
 Registered the Company Template Repository to one of the following:  
o To the service unit, which allows the cloud operator to import databases under the cloud operator 

account. 
o To a reseller, which allows the reseller to import databases under the reseller operator account. 
For more information, see Registering Company Template Repositories. 

 Copied the zipped schema export files to the relevant Company Template Repository from which they are 
to be imported. 

https://launchpad.support.sap.com/#/notes/2714103
https://launchpad.support.sap.com/#/notes/2134959
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Procedure 

To create a new tenant from a backup file, after completing steps 1 and 2 in Creating Tenants, do the following: 
 In the Select Customer window, select the customer to which you want to assign the tenant. 
 In the Select Service Unit window, select the service unit in which you want to create a tenant. 
 In the Select Backup window, select the backup file you want to use to create a tenant. 

 Note  
For cloud operators, the wizard displays a list of backup files available in the Company Template 
Repositories that are registered to the service unit. For reseller operators, the wizard displays a list of the 
backup files available in the Company Template Repositories that are assigned to the specific reseller. 

 In the Tenant Information window, specify the following: 

Field Description 

Tenant Name Enter the name of the tenant. This name appears: 
• At the top of the SAP Business One Main Menu 
• In reports and on printed documents 

Database Name Enter a name for the company database that stores all business and 
transaction data. 

Purpose Select one of the following options: 
• Trial – Customers can evaluate a dedicated SAP Business One 

implementation for a limited period. 
• Productive – Customers can use this database to store company 

information and perform business operations. 
• Demo – Potential customers can use this database to try SAP Business 

One before purchasing subscriptions. 
• Testing – Cloud operators can use this database to test new functionality 

and software versions before customer deployment. 

Trial Period This field is visible only when you select Trial as the tenant purpose. Enter the 
number of days for which the trial period is valid. The maximum allowed value 
is 93 days. 

Authentication Type From the dropdown list, select the type of authentication used for connections 
between the SAP Business One client and the tenant's company database. The 
available options are: 
• Windows Authentication – Each SAP Business One User is granted access 

to the database. An additional read-only domain account is created for 
some database operations. 

• SBO Managed Authentication – The client connects to the database using 
SQL Server Authentication. SAP Business One Users do not connect 
directly to the database, but receive access credentials from the SLD. Two 
domain accounts are created for database access: a read-only account 
and a read write account. This option is recommended. 
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Field Description 

 Note 
For service units running SAP Business One 882.072 and earlier, you 
can select only Windows Authentication. 

 Note  
As of SAP Business One Cloud 1.1 PL15, Windows Authentication is no 
longer available; you must use SBO Managed Authentication. Existing 
tenant registrations with Windows Authentication will not be changed 
after upgrading. If you choose to change the authentication type of an 
existing tenant to SBO Managed Authentication (Customer 
Management → Tenants → Tenant Details → Configuration → Edit 
button → Authentication Type field), note that this is an irreversible 
change. 

Contact Person Enter the name of a contact person for this tenant. 

Phone Enter the telephone number of the contact person. 

E-Mail Enter the e-mail address of the contact person. 

Description Enter an optional description for this tenant. 

 
 In the Users & Licenses window, choose the Assign button to optionally add SAP Business One Users to the 

tenant. After adding a user, select the license you want to assign to this user from the list. 
For more information about adding users, see Adding, Removing, and Importing SAP Business One Users.  

 Recommendation  
You should add at least one SAP Business One User with power user or superuser permissions to the 
tenant. After you complete the tenant creation process, this user can remotely access the SAP Business 
One client application and configure settings. 

o To register the tenant, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the tenant creation process.  
To complete the process, choose the Finish button. 

8.2.2 Registering Tenants 

The tenant registration wizard allows you to register a new tenant based on an existing company database on an 
existing service unit.  
As a cloud operator, you can control the number of tenants that a reseller can register on each service unit. For 
more information, see Setting Tenant Limits for Resellers.  
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As a reseller operator, the Number of Tenants field (Central Components → Service Units) displays the number of 
tenants you have registered on each service unit, and the Tenant Limit field (System Configuration → My Details → 
Basic Information tab), displays the maximum number of tenants you can register on each service unit. 
 
To register a tenant, perform the following: 

 In the Cloud Control Center, choose Customer Management → Tenants, and then select the Register button 
to run the tenant registration wizard. 

 In the Select Customer window, select the customer for whom you want to create the tenant. 
 In the Select Service Unit window, select the service unit on which you want to register the tenant. 
 In the Tenant Information window, specify the following information: 

o Database Name – Select the relevant database. 
o Tenant Name – Specify a new name for the tenant.  
o Tenant Version – Displays the tenant version (non-editable). 
o Upgrade – Displays the upgrade required to be performed (non-editable). 

Note:  
If the tenant version is lower than the version of the service unit, a company database upgrade will be 
performed during the tenant registration process.  

 In the Users & Licenses window, choose the Assign button to optionally assign SAP Business One Users to the 
tenant. After adding a user, select the license you want to assign to this user from the list. 
For more information about adding users, see Adding, Removing, and Importing SAP Business One Users.  

 Recommendation 
You should add at least one SAP Business One User with power user or superuser permissions to the 
tenant. After you complete the tenant registration process, this user can remotely access the SAP 
Business One client application and configure settings. 

 Note 
As of SAP Business One Cloud 1.1 PL11, user codes have been increased from 8 to 25 characters. This 
means that existing user codes that may have previously been truncated are now shown in full. To ensure 
old user code values are retained, either manually change the user code in the User Code field, or use the 
import users function, which displays the user codes directly from the database.   

 The Review window displays an overview of the main results of the tenant registration process.  
o To register the tenant, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 In the Process/Finish window, to complete the process, choose the Finish button. 

8.2.3 Duplicating Tenants 

To streamline the process of creating multiple tenants for the same customer, you can use the tenant duplication 
wizard to duplicate an existing tenant to a target service unit. The target service unit has the same version as or 
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higher version than the source target unit that contains the tenant you want to duplicate. You can add different 
users and assign different extensions to the duplicated tenant. 

Prerequisite 

You have created a source tenant. For more information, see Creating Tenants. 

Procedure 

To duplicate a tenant, do the following: 
 Choose Customer Management → Tenants, and then choose the Duplicate button to run the tenant 

duplication wizard. 
 In the Select Target Service Unit window, select the service unit in which you want to create the duplicated 

tenant. The target service unit must: 
o Have the same license server as the source service unit that contains the tenant that you want to 

duplicate. 
o Run the same as or a later version of SAP Business One than the source service unit. 

 

 Note 
If you select a target service unit running a later version of SAP Business One than the source service unit, 
the wizard will automatically upgrade the duplicated tenant, and the Tenant Duplication Method window 
appears. In the Tenant Duplication Method window, specify whether to upgrade the tenant using the 
target service unit or a staging service unit. For more information, see Upgrading Tenants.  
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 In the Tenant Information window, enter the following: 
o Tenant Name – Enter the name of the tenant. This name appears: 

o At the top of the SAP Business One Main Menu 
o In reports and on printed documents 

o Database Name – Enter a name for the company database that stores all business and transaction data. 

 Note 
The application automatically specifies the customer and service unit names, and the purpose of the 
tenant, according to those of the source tenant.  

 

 In the Add Tenant Users window, do the following: 
o To optionally add SAP Business One Users to the duplicated tenant, choose the Assign button. After 

adding a user, select the license you want to assign to this user from the list. For more information about 
adding users, see Adding, Removing, and Importing SAP Business One Users. 

o To change the system user for an SAP Business One User already added to the tenant without changing 
the SAP Business One user code, choose the Change System User button. 
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 In the Duplicate Database Users window, select the corresponding checkbox for the database users that you 
want to add to the duplicated tenant. 
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 In the Extension window, select the corresponding checkboxes for the add-ons that you want to assign to the 
duplicated tenant. If one or more selected add-ons are not already deployed to the target service unit, the 
wizard automatically deploys them. 

 

o To duplicate the tenant, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Duplicate Tenant window displays an overview of the main results of the tenant duplication process.  
To complete the process, choose the Finish button. 

8.2.4 Exporting Tenants 

As of SAP Business One Cloud 1.1 PL13, you can export SAP HANA schemas and backup Microsoft SQL tenant 
databases directly from the Cloud Control Center.  

Prerequisite 

• You have registered a Company Template Repository.  
• You have registered the Company Template Repository to the service unit.  
• For reseller operators, the Company Template Repository has been registered to the relevant reseller. 
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Procedure 

To export a tenant, do the following: 
 Choose Customer Management → Tenants. 
 Choose the Export button. 

 Note 
To export a tenant registered to a SAP HANA service unit, you must ensure that the SLD Agent is installed 
on the Linux machine hosting the database server instance of the given service unit. 

8.2.5 Working with Dynamic Keys 

To ensure that customer's data is secure, the SAP Business One company databases of tenants are encrypted 
using dynamic keys. When you create a new tenant in a cloud environment, the company database of the tenant is 
automatically encrypted using a dynamic key generated by the SLD service. You can generate a new dynamic key 
for a tenant at any time. 

 Caution 
To ensure that you can decrypt databases in the future and provide customers with access to their data, 
it is important to export a file containing all your dynamic keys on a regular basis. For more information, 
see Exporting Dynamic Keys. 

8.2.5.1 Generating Dynamic Keys 

Procedure 

To generate a new dynamic key for a tenant, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant for which 

you want to generate a new dynamic key. 
 On the Configuration tab in the Tenant Details area, choose the Generate Dynamic Key button. 

If you successfully generate a new dynamic key, the application displays a confirmation message. 
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 Recommendation 
To back up the dynamic key and ensure that you can decrypt the database in the future, export a file 
containing all your dynamic keys. For more information, see Exporting Dynamic Keys. 

8.2.5.2 Exporting Dynamic Keys 

To back up your dynamic keys and ensure that you can decrypt databases in the future, you can export a file 
containing all your dynamic keys. This file is encrypted using TDEA and a specified password. 

Procedure 

To export a file containing all your dynamic keys, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants. 
 To open the Dynamic Key Management window, click the  icon. 
 In the Dynamic Key Management window, choose the Export Dynamic Keys button. 

 

 In the Dynamic Key Export window, enter a password to encrypt the file that contains your dynamic keys, and 
then choose the Export button. 

 Caution 
There are no restrictions on the length or characters that you can use when specifying a password to 
encrypt the dynamic key file. However, it is recommended that you choose a strong password, which 
consists of eight or more characters and a combination of letters, numbers, and special characters.  
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Your browser saves a CFG file containing your dynamic keys. 

8.2.5.3 Importing Dynamic Keys 

To decrypt databases that you previously encrypted, you can import a file that contains your dynamic keys. 

Procedure 

To import a file containing all your dynamic keys, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants. 
 To open the Dynamic Key Management window, click the  icon. 
 In the Dynamic Key Management window, choose the Import Dynamic Keys button. 

 

 In the Dynamic Key Import window, specify the location of the most recent file that contains your dynamic 
keys, enter the password that you previously used to encrypt the file, and then choose the Import button. 
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8.2.6 Viewing the Logged-on SAP Business One Users 

You can view the SAP Business One users who are currently logged on to the company. 

Procedure 

To view the logged on SAP Business One users, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants. 
 Choose a tenant. 
 On the Login SBO Users tab, view the user, the login time and the duration (in minutes). 

8.3 Adding Domain Users to Customers 

To provide access to SAP Business One, you first must add Microsoft Windows domain accounts to customers for 
all SAP Business One Users that you want to create. 

Procedure 

To add domain users to customers, do the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then select the customer to 

which you want to add a domain user. 
 On the User Management tab in the Customer Details area, choose the Add button.  

The Add User window appears. 

 



 

SAP Business One Cloud Administrator's Guide 
Managing Customer Components 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  153 

 

 

 

 

 

 

 

 
 

 

 

 

 Enter a valid domain user name for the user you want to add.  

Note 
We recommend that you enter the domain user name in lower case. If you enter upper case letters, the 
system adds the domain user name into the Active Directory as you have entered it, but it will be changed 
to lower case in the Cloud Control Center.  

 To verify that the domain user name you entered exists, choose the Check Names button.  

Note 
The Cloud Control Center can find users created in the Active Directly in the following cases: 
o The UPN assigned to the user in the Active Directory is same as that assigned to the corresponding 

customer in the Cloud Control Center. 
o The user has the same UPN in the Active Directory as the default UPN set in the Active Directory. 
o The user has no UPN assigned in the Active Directory. 

 If the domain user name does not exist, the Confirmation window appears.  
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To create a new domain user, in the Confirmation window, do the following: 
o User Principle Name – Enter the User Principle Name (UPN) [optional]. Next, from the dropdown list, 

choose either the AD DNS (Active Directory Domain Name Service) or UPN suffix (if defined for the 
selected customer). By default, the UPN suffix is displayed.  

o System User Name – Displays the system user name. However, if you entered a User Principal Name, this 
value is displayed in the System User Name field.  

o Password – Enter a valid initial password for the user. 
o Confirm Password –Confirm the password you entered in the previous step and choose the Yes button. 

 In the Add User window, after the user is found in the active directory, or after you have successfully added a 
new domain user, both the SAM Account Name (Security Accounts Manager) and User Principal Name values 
are displayed.  
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 From the Status dropdown list, select one of the following statuses for the user: 
o Active – The user can log on to SAP Business One and has full access to all functionality. 
o Inactive – The user cannot log on to SAP Business One, but other users can see this user as active in SAP 

Business One. You can set a user’s status to active later. 
 Choose the Add button. 

8.3.1 Synchronizing Domain Users 

To synchronize domain user data with the active directory, perform the following:  
 In the Cloud Control Center, choose Customer Management → Customers, and then select the customer for 

which you want to synchronize domain users. 
 On the User Management tab in the Customer Details area, choose the Synchronize All button.  

8.3.2 Modifying Domain User Data 

To modify the User Principal Name (UPN) or status of a user, perform the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then select the customer for 

which you want to modify a user. 
 On the User Management tab in the Customer Details area, choose the Modify button.  

The Add User window appears. 
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 If you want to change the UPN of the user, in the User Principal Name field, enter a new UPN name. 
 If you want to change the UPN suffix of the user, in dropdown box in the User Principal Name field, select 

another option for the suffix (if available).  
 If you want to change the status of the user, from the Status dropdown list, select a new status for the user. 

8.3.3 Removing Domain Users 

To remove domain users from customers, do the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then select the customer to 

which you want to remove a domain user. 
 On the User Management tab in the Customer Details area, choose the Remove button.  
 In the Confirmation window, if you want to also disable the domain user in the Active Directory, select the 

Disable the user in Active Directory checkbox. 
 Choose the OK button.  

8.4 Adding, Removing, and Importing SAP Business One Users 

To provide access to SAP Business One, you must add SAP Business One Users to a tenant and assign a valid 
license. You can add a single user to multiple tenants but only one customer.  
After adding SAP Business One Users, in the SAP Business One client application, you can assign power user 
permissions as required.  

 Note 
Cloud operators and reseller operators can receive superuser privileges when opening a partner support 
user (PSU) connection. 

In SAP Business One (on premise), the superuser can manage licenses, users, and add-ons. However, in SAP 
Business One Cloud, the user and license management is centralized and managed by the cloud operator through 
the Cloud Control Center. To prevent a reseller from interfering with the centralized management, the SAP 
Business One client functionality must be restricted. Therefore, the superuser status is no longer available for 
resellers; the power user status has been introduced instead. 
Power users should have the same authorizations as superusers, except for the following: 
• Power users cannot manage licenses. 
• Power users cannot create new users in the SAP Business One client. 
• Power users cannot install add-ons. 

 Note  
Only superusers can add and delete users and assign power user permissions in the SAP Business One 
application. In an SAP Business One Cloud environment, you cannot assign superuser permissions in the 
SAP Business One client application. To assign superuser permissions, use the Cloud Control Center. 
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8.4.1 Adding SAP Business One Users 

Prerequisites 

• You have created a customer. For more information, see Creating Customers. 
• You have created a tenant. For more information, see Creating Tenants. 
• You have configured Microsoft Windows domain user accounts for the users that you want to add.  
• You have added the system users to a customer. 

Procedure 

To add SAP Business One Users, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant to which 

you want to add users. 
 On the User Management tab in the Tenant Details area, choose the Add button.  

The Assign Users window appears. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Assign Users window, select the corresponding checkboxes for the system users that you want to 
assign to the tenant. Selecting the first checkbox assigns normal user permission to the user. To select all 
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system users at once, select the checkbox in the left corner of the header row.  To assign additional 
permissions to the user, see the Superuser and Power User field descriptions below. 

Note 
Support users are displayed as blocked technical users and cannot be assigned to a tenant.  

 
For each user, specify the following:  
o User Code – Enter the SAP Business One user code that will be bound to the Windows domain user. This 

is a unique code of up to 25 characters with which a user logs on to the SAP Business One client 
application. 

 Note  
The user code is case sensitive and, once saved, cannot be changed. Make sure you enter the user code 
for each SAP Business One company user in the exact same format for each tenant. For example, if you 
use "Administrator" in tenant A but "administrator" in tenant B, you need to assign two different licenses 
to this user. 

 Note 
As of SAP Business One Cloud 1.1 PL11, user codes have been increased from 8 to 25 characters. This 
means that existing user codes that may have previously been truncated are now shown in full. To ensure 
old user code values are retained, either manually change the user code in the User Code field, or use the 
import users function, which displays the user codes directly from the database.   

o Superuser – Select this checkbox to assign superuser permissions to the user. In SAP Business One, 
superusers can do the following: 
o Access all windows and perform all functions 
o Limit the authorizations of users that are not superusers 

 Caution 
You can only assign superuser permissions to cloud operators, to allow them to configure SAP Business 
One company databases on behalf of customers. This checkbox is inactive for reseller operators as 
reseller operators are not authorized to assign superuser permission.  

 Note  
If you select the Superuser checkbox, the Power User checkbox is automatically selected and non-
editable.  

o Power User – Select this checkbox to assign power user permissions to the user. 
In SAP Business One on-premise, the superuser can manage licenses, users, and add-ons. However, in 
SAP Business One Cloud, the user and license management is centralized and managed by the cloud 
operator through the Cloud Control Center. To prevent a reseller from interfering with the centralized 
management, the SAP Business One client functionality must be restricted. Therefore, the superuser 
status is no longer available for resellers; the power user status has been introduced instead. 
Power users should have the same authorizations as superusers, except for the following: 
o Power users cannot manage licenses. 
o Power users cannot create new users in the SAP Business One client. 
o Power users cannot install add-ons. 
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o Status – A green status indicates that the user is active in the Cloud Control Center;  a red status 
indicates that the user is inactive in the Cloud Control Center.  

 Note  
If the Allow Operators to Assign Themselves as Users on Customer Tenants global setting is set to ON, the 
Operators area is active. If you select a cloud operator or reseller operator, in the Assignment Reason 
field, you must specify the reason for the assignment before proceeding with the wizard. 

 Choose the Save button. 

 Note  
After adding an SAP Business One User, you must assign a valid license in order for the user to access 
SAP Business One. For more information about assigning licenses, see Assigning Licenses.  

 Repeat the previous steps to add additional users. 
 Choose the Close button. 

Result 

After defining the user type and user code for the system user in the Cloud Control Center, a corresponding user 
is created in the SAP Business One application with the corresponding settings. On the User Management tab 
(Customer Management → Tenants → Tenant Details area →  User Management), you can view the details for the 
added user.  
 
 
 
 
 
 
 

8.4.2 Removing SAP Business One Users 

To remove an SAP Business One User, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant to which 

you want to remove a user. 
 On the User Management tab in the Tenant Details area, select the user you want to remove, and choose the 

Remove button.  
 In the Confirmation window, choose the Yes button. 
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Result 

After removing the user binding to the tenant in the Cloud Control Center, the user is marked as removed in SAP 
Business One and no longer appears in user lists.  

8.4.3 Importing SAP Business One Users 

You can import SAP Business One users that have been created on a tenant from an on-premise SAP Business 
One database backup file into the Cloud Control Center. The import users functionality allows you to perform the 
following: 
• View a list of SAP Business One users that already exist on the tenant 
• Automatically map system users to SAP Business One users, in the case that such assignment already exists 

in another tenant of the same customer 
• Assign or unassign an SAP Business One user to (or from) a system user. 

Procedure 

To use the import users functionality, perform the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant to which 

you want to import a user.  
 On the User Management tab in the Tenant Details area, choose the Import Users button. 

The Import Users from Tenant window is displayed. The Status field indicates which users are available to 
import, which already exist,  and which are blocked technical users. 

 Click the corresponding row for the user you would like to import. 
 From the dropdown list in the System User field, select a system user or create a new system user by 

choosing the Create New option.  
 If relevant, select the Superuser or Power User checkboxes to apply superuser or power user privileges to the 

user.  
 Choose the Save button. 

Result 

The user is imported into the Cloud Control Center. On the User Management tab (Customer Management → 
Tenants → Tenant Details area →  User Management), you can view the details of the imported user or perform 
additional operations. 
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8.5 Managing Licenses 

SAP Business One is based on a named user licensing model, in which each license is granted to a specific user 
name. A named user is an employee of a customer, a subsidiary, or a third party business, who is authorized to 
access, directly or indirectly, the licensed SAP Business One software. 
To provide access to the SAP Business One application, in the Cloud Control Center, you are required to install 
license files generated by SAP on request, which contain the licenses that you have purchased plus other relevant 
information. You can also install license files during the customer creation process. All license information is 
maintained by a license server. 
A license file can contain more than one purchased license for SAP Business One. Multiple customers and tenants 
can share a single license file, but a single customer or tenant may be assigned to only one license file. However, 
SAP recommends that you use one license file per customer where possible. Each license within the license file is 
assigned to a named SAP Business One User or cloud operator. 
For more information about licenses, see the SAP Business One License Guide. 

8.5.1 Importing License Files 

After registering a license server, you can import a valid license file to the license server. 

Procedure 

To import a new license file to a license server, do the following: 
 In the Cloud Control Center, choose Customer Management → License Files. 
 Choose the Import License File button. 

The Import License File window appears, displaying a list of license files you have already imported. 
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 Choose the Browse button and select the license file you want to import. 
 To import the selected file, choose the Import button. 

 Note 
If the installation number of the selected license file is the same as that of an existing license file, a 
warning window appears. To import the selected license file and overwrite the existing data with the data 
in the selected file, choose the OK button. 
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The application automatically assigns license modules from the selected license file, according to the license 
module assignments in the existing file. However, if the selected license file contains fewer available license 
modules than the number assigned in the existing file, the application automatically unassigns some license 
modules from users.  

8.5.2 Viewing Imported License Files 

In the Cloud Control Center, you can view detailed information about imported license files, including the license 
types, expiration dates, and available number of licenses. 

Procedure 

To view detailed information about a license file, do the following: 
 In the Cloud Control Center, choose Customer Management → License Files, and then select the license file 

for which you want to view information. 
 Choose the View License File button. 

The License File window appears. 
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 Note 
You can view the hardware key of the license file in the License File Details area, on the Configuration tab.  

8.5.3 Changing License Files 

You can change the installation number of a license file that is already assigned to a customer. 

 Note 
After changing the license file, the application maintains common license module assignments. However, 
you may need to manually reassign license modules to some users. 

Procedure 

To change a license file for a customer, do the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then select the customer for 

which you want to change the license file. 
 On the Configuration tab in the Customer Details area, choose the Change License File button. 
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 In the Change License File window, select the license file you want to use, and then choose the Save button. 

 

 Note 
You can select only valid license files with the same localization as the original license file that you are 
replacing, or license files with a worldwide localization. 

8.5.4 Removing License Files  

As of SAP Business One 9.3 PL08, you can remove license files in the Cloud Control Center. Removing a license 
file removes the binding between the license file and any customers, tenants, and resellers which have been 
assigned the license file.    

Procedure 

To remove a license file, do the following: 
 In the Cloud Control Center, choose Customer Management → License Files. 
 Choose the Remove License File button. 
 In the Confirmation window, choose Yes.  
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8.5.5 Managing License Allocations 

Although SAP recommends you use one license file per customer where possible, in certain scenarios it may be 
necessary for multiple customers to share a single license file, which can contain more than one purchased 
license for SAP Business One. You can allocate a specific number of licenses from a shared license file to 
individual customers. 

 Note 
License allocation is managed by hosting partners. Resellers can only view license information for the 
licenses that are assigned to their customers. 
For more information about assigning licenses to resellers, see Assigning License Files to Resellers. 

Procedure 

To allocate licenses to a customer, do the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then select the customer for 

which you want to manage the license allocation. 

 Note 
You cannot modify the license allocation for trial customers.  

 In the Customer Details area, select the License Allocation Management tab, and then select the license type 
for which you want to adjust the allocation. 

 In the License Allocation column, click the (Edit) icon, and then enter the number of licenses that you 
want to allocate to the customer.  
o If you enter 0, then the customer cannot use the license module. 
o If you set the value as Dynamic, then the application automatically calculates the number of available 

licenses, which changes dynamically according to how many licenses are allocated or consumed by other 
customers that share the same license file. 

 Click the Save icon. 

8.5.6 Assigning Licenses to Users 

After adding an SAP Business One User, you must assign a valid license in order for the user to access SAP 
Business One. 

Procedure 

To assign a license to an SAP Business One User, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant containing 

the user to whom you want to assign a license.  
 On the User Management tab in the Tenant Details area, choose the Assign License button. 
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The Assign License window appears. 

 

 In the Assign License window, select the user to whom you want to assign a license. 

Note 
When you assign a license to an SAP Business One company user, the name of the company user is case 
sensitive. This means, for example, that you need to assign two different licenses if you have "user2" on 
one tenant and "User2" on another tenant. 

 Select the checkbox that corresponds to the type of license you want to assign. The Available column displays 
the number of remaining licenses available. 

 Repeat the previous steps to assign licenses to additional users. 
 Choose the Finish button. 
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9 Managing Extensions 

Extensions for SAP Business One Cloud are additional components that meet specific industry or niche business 
requirements. SAP Business One Cloud includes several default add-ons provided by SAP and provides support 
for the lifecycle management of the following types of third-party extensions: 
• SAP Business One Script 

A lightweight, JavaScript-based extension system that you can use to quickly adapt SAP Business One to 
business-specific processes in cloud environments.  
Unlike traditional SAP Business One add-ons, these extensions are "sandboxed", with managed access to 
system functionality. SAP Business One Script enables you to quickly and cheaply develop solutions that 
address last-mile extensibility, without the need for certification. In addition, users can modify scripts on-the-
fly according to immediate business requirements. 
For more information, see Working with SAP Business One Script. 

• Add-ons enabled for lightweight deployment 
Add-ons for which the lifecycle management is fully automated in cloud environments, without the need for 
any manual installations or configuration on the server. These add-ons have access to the full functionality of 
SAP Business One. You can completely configure add-ons enabled for lightweight deployment using the 
Cloud Control Center.  Depending on requirements, the types of add-ons enabled for lightweight deployment 
are as follows: 
o Fully compliant add-on certified by SAP 

Typically developed by software solution providers (SSPs) to address broad industry needs. These add-
ons are certified by SAP to ensure that they run reliably and securely in cloud environments, and are 
marketed and sold to a wide audience. 

o Fully compliant add-on not certified by SAP 
Typically developed by value-added resellers (VARs) to meet the specific business requirements of a few 
individual customers. Although these add-ons still meet the requirements for lightweight deployment, 
they do not receive certification by SAP since they are not marketed and sold to a wide audience. 

• Compatible add-ons 
Add-ons for which the lifecycle management is not fully automated in cloud environments, with the need for 
manual installations or configuration on the server. These add-ons have access to the full functionality of SAP 
Business One. You can partially configure these add-ons using the Cloud Control Center.   

 
The following table provides an overview of the default SAP add-ons, which are registered automatically. 

Add-On Type Compatibility 

PaymentLW Add-on for lightweight 
deployment 

SAP Business One 8.82 PL11 and later  

Datev2LW Add-on for lightweight 
deployment 

SAP Business One 9.2 PL10 and later  
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Add-On Type Compatibility 

EFMLW (Electronic File 
Manager:Format 
Definition) 

Add-on for lightweight 
deployment 

SAP Business One 9.3 PL06 and later 

Screen Painter Compatible add-on SAP Business One 8.82 PL08 to SAP Business 
One 9.3 PL14 

SBO Script Compatible add-on SAP Business One 8.82 PL09 to SAP Business 
One 9.3 PL14 

 
Extracting the contents of an SAP Business One upgrade package to a software repository makes SAP add-ons 
available for deployment and assignment from the Cloud Control Center. 

 Note 
To run add-ons, SAP Business One Users require an SAP Add-Ons license, which is included in the 
Professional User license. 

 Note 
As of SAP Business One 9.1 PL03 and SAP Business One 9.0 PL14, the ELSTER add-on is no longer 
included in the SAP Business One upgrade or installation packages. 

9.1 Enabling Add-Ons for Lightweight Deployment 

The lifecycle management of add-ons enabled for lightweight deployment is fully automated in cloud 
environments, without the need for any manual installations or configuration on the server. Add-ons that are 
enabled for lightweight deployment do not have dedicated installers. Instead, the required files are located within 
a single folder or ZIP archive, and installation is performed by the application. 
When enabling add-ons for lightweight deployment, you can specify support for multiple versions of an add-on. In 
this case, you can deploy multiple different versions of the same add-on to a single presentation server. 
Add-ons enabled for lightweight deployment must contain the following components in a folder or ZIP archive: 
• Application executable 
• Add-on registration data (ARD) file 
• COM-based DLLs 
• Other required files or sub-folders  

 
Add-on registration data (ARD) files contain the following add-on registration data in Extensible Markup Language 
(XML) format: 
• Basic Information – Specifies the name and contact information of the SAP partner that creates the add-on, 

and the name, version, and basic properties of the add-on. 
• SBO Compatibility – Specifies the versions of SAP Business One with which the add-on is compatible. 
• Configuration – Specifies landscape, deployment, and assignment values for the add-on, and information 

required for installation and uninstallation. 
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You can use the Extension Package tool to package the add-ons enabled for lightweight deployment into a ZIP 
archive. The tool is located at …\SAP\SAP Business One 
SDK\Tools\ExtensionPackage\ExtensionPackage.exe. 
For more information, see How to Package and Deploy SAP Business One Extensions for Lightweight Deployment. 
 
Add-ons enabled for lightweight deployment can store data in the following locations: 
• Company databases and user-defined tables (UDTs) 
• Dedicated add-on folders in the tenant storage using the GetExtensionSharedFolderPath or 

GetExtensionSharedFolderPathEx functions of UI API 
• User storage using the GetUserStorage function of UI API 
• SAP Business One Users' roaming profile folders (not recommended) 
• Web services using HTTP/HTTPS 

For more information about working with UI API, see the Online Help for the SAP Business One Software 
Development Kit (SDK). 

9.2 Configuring Extension Repositories 

The extension repository stores extension files. After you create an extension repository, the application 
automatically creates two sub-folders named Incoming and Repository. The Repository folder stores 
synchronized extensions that you can deploy to service units and assign to tenants. The Incoming folder 
provides a location for add-on providers to upload third-party extensions that you can then synchronize. 

 Recommendation  
Allow add-on providers to upload third-party extensions using FTP or WebDAV protocols, or both, and 
implement automatic virus and malware scanning. 

Procedure 

To configure the extension repository, do the following: 
 Create a Windows shared folder. 

Keep a record of the full UNC path to the folder, as you are required to enter this in the Cloud Control Center 
during the registration process. 

 Assign read and write permissions to the SAPServiceB1C account. 
 In the Cloud Control Center, choose Central Components → Extensions. 
 To open the Extension Configuration window, click the  (Extension Configuration) icon. 
 In the Path field, enter the full UNC path to the extension repository. 
 To configure the application to automatically synchronize add-ons according to a specified schedule, select 

the Enabled Scheduled Synchronization checkbox. 
Specify a start time and interval between synchronizations. 

 To prevent operators from deploying and running extensions that are incompatible with the relevant service 
units, select the Enable Extension Compatibility Check checkbox. This option is recommended. 
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 To complete the process, choose the Set button. 
 The application creates two sub-folders named Incoming and Repository in the specified extension 

repository. To allow add-on providers to upload extensions, do the following: 
o In the Incoming folder, manually create sub-folder for each add-on provider that you want to allow to 

upload third-party extensions. 
o Grant the appropriate permissions to each add-on provider. 

 Caution  
Add-on providers must upload extensions to only their dedicated folders using FTP or WebDAV protocols. 
Add-on providers must place an extension in a folder or ZIP archive dedicated to that specific extension. 
For example, the structure of the Incoming folder is as follows: 

• Incoming 

o Add-On_Provider_1 

o Add-On_1 

o Add-On_2.zip 

o Add-On_Provider_2 

o Add-On_1.zip 

o Add-On_2 

o Add-On_3.zip 
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9.3 Synchronizing Extensions 

To allow users to run third-party add-ons uploaded by add-on providers to the Incoming folder, you first must 
synchronize the extension. Synchronization copies add-ons from the Incoming folder to the Repository folder of 
the extension repository. 

Procedure 

To synchronize add-ons, do the following: 
 In the Cloud Control Center, choose Central Components → Extensions. 
 To synchronize all add-ons, choose the Synchronize All button. 

9.3.1 Viewing Synchronization History 

In the Cloud Control Center, you can view reports of all manual and automatic synchronizations.  

Procedure 

To view the synchronization history, do the following: 
 In the Cloud Control Center, choose Central Components → Extensions. 
 To open the Synchronization History window, click the  (Synchronization History Report) icon. 

9.3.2 Troubleshooting Synchronization Errors 

If the application fails to copy add-ons from an add-on provider’s sub-folder in the Incoming folder to the 
Repository folder during the synchronization process, the application moves the add-on to a sub-folder named 
Failed.  
To help you troubleshoot synchronization errors, the application creates a Logs folder for each add-on provider in 
their respective sub-folders in the Incoming folder, in which you can access log files. 

9.4 Deploying Extensions 

After synchronizing an extension, you can deploy the extension to a service unit. You can deploy a single 
extension to multiple service units. 
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 Note 
After creating a service unit, the application automatically deploys add-ons provided by SAP to the 
service unit; you are not required to manually deploy them.  

 Recommendation 
If you need to redeploy all extensions on a particular service unit, you can easily find the required 
extension configuration settings (Enabled and Startup Mode field values for each tenant) on the 
Extensions page, in the Extension Details area, on the Assigned to Tenant tab. The table displayed on the 
Assigned to Tenant tab allows you to view the extension configurations for all relevant tenants for each 
extension type. You can also export a CSV file of the table data. For more information, see SAP 
Note 3134898. 

Prerequisites 

• You have synchronized the add-ons you want to deploy. For more information, see Synchronizing Extensions. 
• You have created a service unit. For more information, see Creating Service Units. 
• You have set the logon account of the SAP Business One Client Agent service to a cloud operator account 

with local administrator privileges. For more information, see SAP Note 1764311. 
• If you are deploying an extension based on SAP HANA XS, you have performed the following: 

o Ensured that the SAP HANA database client is installed on the SLD service machine. 
o On the SLD service machine, you have specified the value of the PATH environment variable as the SAP 

HANA database client path.  

Procedure 

To deploy an extension, do the following: 
 In the Cloud Control Center, choose Central Components → Service Units, and then select the service unit to 

which you want to deploy an extension. 
 In the Service Unit Details area, select the Extensions tab. 

To run the extension deployment wizard, choose the Deploy button. 
 In the Select Extensions window, select the extensions you want to deploy to the service unit. 

https://launchpad.support.sap.com/#/notes/3134898
http://service.sap.com/sap/bc/bsp/spn/smb_searchnotes/display2.htm?note_langu=E&note_numm=1764311
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o To configure the properties of an extension, click the corresponding hyperlink in the Properties column. 
o To deploy the extensions, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 Note 
If you have selected an extension with a higher version, an extension upgrade will be required. You can set 
the amount of time before users need to exit the extension before the upgrade begins. In the Set Upgrade 
Time window, in the Number of Minutes field, specify the number of minutes after the system notifies you 
that an upgrade is required that you want the extension upgrade to be performed.  
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 Recommendation  
We recommend that you specify at least a 5-minute period to allow users sufficient time to exit the 
extension before the upgrade begins.  This allows you to provide sufficient time for users to exit the 
extension before the upgrade begins. 

 The Progress/Finish window displays an overview of the main results of the extension deployment process.  
To complete the process, choose the Finish button. 

 Note 
After completing the deployment process, the application automatically installs any add-ons that are 
enabled for lightweight deployment on the presentation servers that are registered to the service unit.  
To view detailed information about the installation status, in the Service Unit Details area, ensure you have 
selected the Extensions tab, and then click the Details link in the Installation Status column to open the 
Extension Installation Status window. If an installation fails, you can manually start the installation again 
by clicking the retry icon in this window.  

9.5 Assigning Extensions 

After deploying an extension to a service unit, you can assign the extension to tenants. After assigning an add-on 
to a tenant, users of that tenant can run the add-on in SAP Business One. 
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Prerequisites 

• You have created a tenant. For more information, see Creating Tenants. 
• You have deployed the add-ons to the service unit containing the tenant to which you want to assign the add-

ons. For more information, see Deploying Extensions. 

Procedure 

To assign an extension, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant to which 

you want to assign an extension. 
 In the Tenant Details area, select the Extensions tab. 

To run the extension assignment wizard, choose the Assign button. 
 In the Select Extensions window, select the extensions you want to assign to the tenant. 

 

o To configure the properties of an extension, click the corresponding hyperlink in the Properties column. 
o To assign the extensions, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the extension assignment process.  
To complete the process, choose the Finish button. 

 Note 
After completing the assignment process, to begin the associated installation process, use an 
administrator account to log on to relevant presentation servers, right-click SAP Business One.exe 
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and choose Run as administrator, and then log on to the SAP Business One client using an account with 
superuser permissions. 
Add-ons enabled for lightweight deployment are installed automatically; however, you must manually 
install compatible add-ons using the associated installers. 
After all installations are complete, you can log off the presentation servers. Customers can now log on to 
SAP Business One and use their assigned extensions. 

9.6 Controlling Reseller Access to Extensions  

As a cloud operator, for each extension on a service unit, you can control whether reseller operators have 
permission to access the extension. If you choose to allow reseller operators to access an extension, you can 
either allow all resellers access or specify which resellers can assess the particular extension. 

Note 
To globally manage whether reseller operators can deploy extensions, see Controlling Reseller 
Permission to Deploy Extensions. 

9.6.1 Managing Reseller Access to Extensions  

Prerequisites 

• You have synchronized the relevant extensions. For more information, see Synchronizing Extensions. 
• You have created resellers. For more information, see Creating Resellers.  

Procedure 

To control whether reseller operators can access extensions, perform the following: 
 In the Cloud Control Center, choose Central Components → Extensions. 
 Select the extension to which you want to set reseller access for, and from the dropdown list in the Reseller 

Access field, select one of the following options: 
o  All– All resellers can access the extension.  
o None (default) – No resellers can access the extension.  

Note 
If the All or None option is selected in the Reseller Access field, note that the access type is displayed next 
to the buttons on the Assigned to Reseller tab (for example, Effective Access: All). In this case, if a 
custom list of resellers is displayed, it is not applied. 

o  
o  
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o Custom – Only specific resellers that you assign to the extension and are displayed on the Assigned to 

Reseller tab in the Extension Details section can access the extension. For more information, see 
Assigning Resellers to Extensions. 

9.6.2 Assigning Resellers to Extensions 

Prerequisites 

In Central Components → Extensions, in the Reseller Access field, the Custom option is selected for the relevant 
extension.  

Procedure 

To assign specific resellers to an extension, perform the following: 
 In the Cloud Control Center, choose Central Components → Extensions. 
 Select the extension to which you want to assign resellers to. 
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 In the Extension Details area, on the Assigned to Reseller tab, choose the Assign button. 

 
 In the Assign Resellers to Extension window, select the checkbox next to the resellers you want to assign to 

the extension.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Choose the Assign button.  

Result 

The custom list of resellers assigned to the extension is displayed on the Assigned to Reseller tab.  
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Note 
If the All or None option is selected in the Reseller Access field, note that the custom list may be displayed 
but is not applied. The All or None access type is simply displayed next to the buttons on the Assigned to 
Reseller tab (for example, Effective Access: None).  

9.6.3 Unassigning Resellers from Extensions 

Prerequisites 

In Central Components → Extensions, on the Assigned to Reseller tab, you have assigned specific resellers to an 
extension.  

Procedure 

 To remove specific resellers assigned to an extension, perform the following: 
 In the Cloud Control Center, choose Central Components → Extensions. 
 Select the extension to which you want to unassign resellers from. 
 In the Extension Details area, on the Assigned to Reseller tab, select the resellers you want to remove.  
 Choose the Unassign button. 
 In the confirmation window, choose Yes.  

Note 
If you want to remove all resellers assigned to an extension, on the Assigned to Reseller tab, choose the 
Remove All button.  
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9.7 Managing Extension Security 

As of SAP Business One 10.0 FP 2011, you can enhance the security of extensions by issuing trusted certificates 
to your extensions in the Cloud Control Center. If this option is enabled, SAP Business One will check if the 
certificate for each add-on is trusted in the SLD to ensure that the connection is secure. The supported 
certificates are base64-encoded, standard x.509 certificates, with the filename extension .crt or .cer. The 
certificate can be issued by a third-party certification authority (CA) or a local enterprise CA. Add-ons provided 
by SAP use an SAP certificate that is automatically imported and cannot be removed. 

9.7.1 Adding Extension Certificates 

Procedure 

To add a trusted certificate to an extension, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable Security Certificates for Extensions field, choose the On option. 
 Choose Central Components → Extensions. 
 On the Extensions page, select the extension for which you want to add a certificate. 
 On the Certificates tab, choose the Import Certificate File button.  
 In the Import Certificate File window, perform the following: 

 In the Certificate File field, choose the Browse button and choose the relevant certificate.  
 In the Description field, you can enter a description of the certificate (optional). 
 Choose the Import button. 

9.7.2 Removing Extension Certificates 

Procedure 

To remove a trusted certificate from an extension, perform the following: 
 In the Cloud Control Center, choose Central Components → Extensions. 
 On the Extensions page, select the extension for which you want to remove a certificate.  
 On the Certificates tab, select the certificate you would like to remove. 
 Choose the Remove Certificate File button.  
 In the Remove Certificate File window, choose the Browse button and choose the relevant certificate. 
 In the confirmation window, confirm whether or not you want to remove the selected certificate.  
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Note 
You cannot remove default SAP certificates.  

9.8 Upgrading Extensions 

When new versions of extensions are available, you can upgrade extensions deployed to service units individually. 
Note that all tenants in the same service unit must run the same version of an extension, unless it is an add-on 
enabled for lightweight deployment with multiple version support. In this scenario, you can deploy multiple 
versions of the same add-on to a single service unit. 

Procedure 

To upgrade an extension, do the following: 
 Unassign the extension from all tenants in the same service unit: 

 In the Cloud Control Center, choose Customer Management → Tenants, and then select a tenant from 
which you want to unassign the extension. 

 In the Tenant Details area, select the Extensions tab. 
 Select the extension that you want to upgrade, and then choose the Unassign button. 
 Repeat the previous steps for all tenants in the service unit. 

 Undeploy the extension from the service unit: 
 In the Cloud Control Center, choose Central Components → Service Units, and then select the service unit 

from which you want to undeploy the extension. 
 In the Service Unit Details area, select the Extensions tab. 
 Select the extension that you want to upgrade, and then choose the Undeploy button. 

 Note 
After completing the undeployment process, to begin the associated uninstallation process, use an 
administrator account to log on to relevant presentation servers, right-click SAP Business One.exe, 
and then choose Run as administrator. Log on to the SAP Business One client using an account with 
superuser permissions. 
Add-ons enabled for lightweight deployment are uninstalled automatically; however, you must manually 
uninstall compatible add-ons using the associated uninstallers. 

 Deploy the new version of the extension to the service unit. For more information, see Deploying Extensions. 
 Assign the new version of the extension to all tenants in the service unit. For more information, see Assigning 

Extensions. 

 Note 
After completing the assignment process, to begin the associated installation process, use an 
administrator account to log on to relevant presentation servers, right-click SAP Business One.exe, 
and then choose Run as administrator. Log on to the SAP Business One client using an account with 
superuser permissions. 
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Add-ons enabled for lightweight deployment are installed automatically; however, you must manually 
install compatible add-ons using the associated installers. 
After all installations are complete, you can log off the presentation servers. Customers can now log on to 
SAP Business One and use their assigned extensions. 
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10 Upgrading SAP Business One Cloud 

This section assists you with the following: 
• Upgrading SAP Business One Cloud components  
• To upgrade SAP Business One Cloud to later versions, you must upgrade the SLD, Cloud Control Center, and 

SLD Agent Service. Depending on the supported releases, this does not typically affect customers. 
• Upgrading customers to later versions of SAP Business One 
• To upgrade a customer's SAP Business One application and enable them to run it successfully, you must do 

the following: 
 Register a new software repository with the version of SAP Business One to which you want to upgrade 
 Upgrade the license server using the Cloud Control Center 
 Create a target service unit with the version of SAP Business One to which you want to upgrade 
 Upgrade tenants using the tenant upgrade wizard in the Cloud Control Center 
 Manually upgrade other SAP Business One components 

10.1 Upgrading System Landscape Directory and Cloud Control 
Center 

Only SAP Business One Cloud 1.0 SP02 is supported for direct upgrade to SAP Business One Cloud 1.1. To 
upgrade an SAP Business One Cloud version that is lower than 1.0 SP02 to version 1.1, first upgrade your current 
version to 1.0 SP02, and then perform the upgrade to version 1.1. 

 Recommendation  
Before upgrading, backup the SLD database or create a restore point or snapshot for the SLD server, in 
case any errors occur during the upgrade. 

Procedure 

To upgrade the SLD and Cloud Control Center, do the following: 
 Navigate to the root folder of the SAP Business One Cloud 1.1 installation package, right-click the 

SLD_x64.exe file, and choose Run as administrator. 
 The SAP Business One SLD Service - InstallShield Wizard appears, indicating that the wizard will upgrade the 

SLD and Cloud Control Center. 
To continue, choose the Yes button. 

 In the welcome window, choose Next to start the installation of SAP Business One SLD Service.  
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 In the Confirmation of Software Compatibility Information window, confirm that you have read the information 
in SAP Note 1756002 -  Verified Combinations of SAP Business One Cloud and SAP Business One. 

 In the System Landscape Directory Database Backup window, specify a location where you want to back up 
the SLD database. 

 

 

 

 

 

 

 
 
 
 
 
 

 Note 
If you want to skip the database backup, deselect the Backup database checkbox, choose the Next 
button, and confirm the warning message.  

https://authn.hana.ondemand.com/saml2/sp/mds
https://i7p.wdf.sap.corp/sap/support/notes/1756002
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 Note 
If you are using an SAP HANA database, the location you specify to back up the database schema and 
data must exist on the SAP HANA server and have write permission.  

 If the wizard detects one or more tenants containing user mappings to a Support user for SAP Business One, 
a window is displayed in which you can agree to remove the user mappings. Support user accounts are 
automatically created in SAP Business One (on premise) for support activities and their usage is not allowed 
in SAP Business One Cloud. If you provide your consent, the upgrade will remove all existing user mappings to 
support users. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Specify SLD hostname window, specify the hostname or IP address for the System Landscape 
Directory under which you want the instance to be registered.  
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 In the Ready to Install Components window, do the following: 
o To upgrade the components, choose the Next button. 

 Note 
If the SLD Service is running, the wizard prompts you to stop the service before performing the upgrade.  

o To change the settings, choose the Back button to return to the previous steps. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 The Setup Status window displays the progress of the installation.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Complete window, choose the Finish button. 



 

188 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Upgrading SAP Business One Cloud 

 

 Note 
If the SLD Service is running, manually restart the SAP Business One Client Agent on each presentation 
server.  
 
 
 
 
 
 
 
 
 
 
 

10.2 Upgrading SLD Agent Service 

After upgrading the SLD and Cloud Control Center, you must upgrade the SLD Agent Service. You can upgrade 
the SLD Agent Service using the installer provided by SAP or a group policy object. The upgrade steps are the 
same as those in the installation procedure. 
For more information, see Installing the SLD Agent Service. 

10.3 Upgrading License Servers 

 Caution  
Upgrading license servers is not supported in SAP Business One Cloud landscapes that use SAP HANA. 

 Caution 
When upgrading a license server, ensure that installation path remains the same. 

Prerequisites 

• You have registered a license server. For more information, see Registering License Servers. 
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• You have installed the SLD Agent service on the machine on which the license server is located. 
• You have registered one or more software repositories with a later version of SAP Business One. For more 

information, see Registering Software Repositories. 

Procedure  

To upgrade a license server, do the following: 
 In the Cloud Control Center, choose Central Components → License Servers, and then select the server that 

you want to upgrade. 

 Caution 
Automatic upgrade of license servers from version 8.82 to 9.0 is not supported. You must manually 
perform the upgrade procedure. After upgrading license servers from version 8.82 to 9.0, ensure that you 
change the logon account of the license service to a service account, such as SAPServiceB1C. 

 On the Configuration tab of the License Server Details area, choose the Upgrade button and confirm any 
warning messages that the application displays. 
The Software Repository Selection window appears. 

 Recommendation  
Before upgrading, create a restore point or snapshot, in case any errors occur during the upgrade. 

 

 In the Software Repository Selection window, select the software repository with the version to which you 
want to upgrade. 
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 In the Configuration window, enter the credentials of the cloud operator account with administrative rights on 
the selected license server machine. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

10.4 Upgrading Service Units 

You cannot upgrade an existing service unit to run a later version of SAP Business One. Instead, you must create a 
new service unit with the SAP Business One version that you want to run, or duplicate an existing service unit to a 
later version, and then use the new service unit as a target service unit during the tenant upgrade process. For 
more information about upgrading tenants using target service units, see Performing Tenant Upgrades. 
If you create a new service unit running a later version of SAP Business One, you must also do the following: 
• Deploy the required extensions to the new service unit. 
• Unregister the presentation servers from the original service unit and register them to the new service unit. 
• [Optional] Manually install a new integration component and mailer for the new service unit. 
• Manually configure the remote access solution, for example Microsoft RDS or Citrix. 

For more information about creating service units, see Creating Service Units. 
 
If you use the service unit duplication wizard to duplicate an existing service unit to a later version, the wizard can 
automatically deploy the required extensions and move the presentation servers to the new service unit. In this 
scenario, you must also do the following: 
• [Optional] Manually install a new integration component and mailer for the new service unit. 
• Manually configure the remote access solution, for example Microsoft RDS or Citrix. 

For more information about duplicating existing service units, see Duplicating Service Units. 
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10.5 Upgrading Tenants 

You can upgrade tenants to provide users with access to later versions of SAP Business One as new patches, 
minor versions, and major versions are released by SAP. 

 Note 
SAP HANA tenant upgrade is supported in SAP Business One Cloud 1.1 PL02. To perform the upgrade on 
SAP HANA, all SAP HANA servers must have mounted tenant storage at the mount point location. For 
more information, see Registering Tenant Storage. 

10.5.1 Performing Pre-Upgrade Tests 

Before you can upgrade a tenant, you must perform a pre-upgrade test to ensure the tenant is ready and reduce 
the possibility of the upgrade process failing. The wizard performs a series of version-specific verification checks 
on selected databases to see if they are ready for upgrade. The existing installation and data are not changed.  

Prerequisites 

• You have created a tenant. For more information, see Creating Tenants. 
• You have created a software repository with the version of SAP Business One to which you want to upgrade 

the tenant. For more information, see Creating Software Repositories. 
• You have ensured that the source service unit and target service unit are connected to the same license 

server. 
• If you are using both Microsoft SQL and SAP HANA databases, ensure that you have one license server for 

each product version (in other words, one license server for Microsoft SQL and one for SAP HANA) installed 
on a separate machine on the latest version and patch level of SAP Business One and SAP Business One, 
version for SAP HANA.  

Procedure 

To perform pre-upgrade tests on tenants, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then choose the Pre-Upgrade 

Test button to run the tenant pre-upgrade test wizard. 
 In the Select Tenants window, select the service unit from the dropdown list that contains the tenants you 

want to test. 
 Select one or more tenants to test. 



 

192 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Upgrading SAP Business One Cloud 

 

 

 In the Target Software Repository window, select the software repository with the version of SAP Business 
One to which you want to upgrade the tenants. 

 If the required software repository is not in the list, choose the New button to register a software repository. 
For more information, see Registering Software Repositories. 
o To test the tenants, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 
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 The Pre-Upgrade window displays the results of the test(s). 

 

 To view detailed information about a test, click the hyperlink in the Results column. 
The Pre-Upgrade Result window appears. 
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 To view information about individual checks, possible solutions to errors, and recommendations for dealing 
with warnings, in the SAP Note column, click the links to the corresponding notes. 
After you have reviewed all checks, choose the Done button to return to the Pre-Upgrade Test Progress 
window.  

 To complete the process, choose the Finish button. 

 Note 
The pre-upgrade test results are valid for three days. Within this period, you can perform tenant upgrade 
without having to pre-upgrade tests again. After three days, or if you make any changes to the company 
configuration, the pre-upgrade test results become invalid. 

10.5.2 Performing Tenant Upgrades 

After performing pre-upgrade tests, you can upgrade tenants to later versions of SAP Business One. To upgrade a 
tenant, you select a target service unit running the version of SAP Business One to which you want to upgrade the 
tenant. The application moves the tenant to the new service unit, and then upgrades the company database of the 
tenant. You can perform tenant upgrades in the target service unit or, alternatively, use a staging service unit as 
an intermediary. 

 Recommendation  
Upgrading tenants is a resource-intensive process. Since a single service unit can contain multiple 
tenants, use a staging service unit to minimize the impact on other tenants. 
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Prerequisites 

• You have created a tenant. For more information, see Creating Tenants. 
• You have created a service unit with the later version of SAP Business One to which you want to upgrade the 

tenant. For more information, see Creating Service Units. 
• You have ensured that the source service unit and target service unit are connected to the same license 

server. 
• If you are using both Microsoft SQL and SAP HANA databases, ensure that you have one license server for 

each product version (in other words, one license server for Microsoft SQL and one for SAP HANA) installed 
on a separate machine on the latest version and patch level of SAP Business One and SAP Business One, 
version for SAP HANA.  

Procedure 

To upgrade tenants, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then choose the Upgrade button 

to run the tenant upgrade wizard. 
 In the Tenant Upgrade wizard, from the Upgrade Type radio button, choose Upgrade. 
 In the Select Tenants window, select the service unit from the dropdown list that contains the tenants you 

want to upgrade. 
 Select one or more tenants to upgrade. 

 Note  
If one or more of the selected tenants have active connections, you should manually disconnect all 
applications. Otherwise, the application displays a warning, which requires you to automatically 
disconnect all applications from the selected tenants before you can continue. 
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 In the Target Service Unit window, select the service unit running the version of SAP Business One to which 
you want to upgrade the tenants. 
If the required service unit is not in the list, choose the New button to create a new service unit. For more 
information, see Creating Service Units. 
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 Note  
If the target service unit already contains company databases with the same names as the company 
databases of the tenants that you want to upgrade, the Change Database Name window appears. To 
continue, you must change the names of these company databases in the selected tenants. 

 In the Pre-Upgrade Test window, you must perform pre-upgrade tests on tenants for which any of the 
following conditions are true: 
o You have not previously performed a pre-upgrade test. 
o You previously performed a pre-upgrade test, but it was not within the previous three days. 
o You previously performed a pre-upgrade test, but one or more errors occurred during the test. 
To perform the necessary pre-upgrade tests, select the tenants you want to test, and then choose the Begin 
Test button. 

 

 If any warnings occur when performing the pre-upgrade tests, to open the Pre-Upgrade Test Results window, 
click the corresponding hyperlink in the Result column, and do either of the following: 
o To ignore a warning, select the corresponding checkbox in the Confirm column. 
o To fix an issue, click the corresponding hyperlink in the SAP Note column and follow the 

recommendations. After fixing the issue, select the checkbox in the Confirm column. 
 After you have confirmed all warnings, choose the Confirm button to return to the Pre-Upgrade Test window. 

To continue, choose the Next button. 
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 In the Staging Service Unit window, specify whether to perform the upgrades in the target service unit or use a 
staging service unit as an intermediary. 

 Recommendation  
Upgrading tenants is a resource-intensive process. Since a single service unit can contain multiple 
tenants, use a staging service unit to minimize the impact on other tenants. 

 If you select the Use Staging Service Unit to Perform Upgrade checkbox, select the service unit running the 
version of SAP Business One to which you want to upgrade the tenants, to use as an intermediary for 
performing the upgrades. 
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o To upgrade the tenants, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 The Progress/Finish window displays an overview of the main results of the tenant upgrade process.  
To complete the process, choose the Finish button. 

 Note 
If you upgrade a presentation server from SAP Business One 8.82 to version 9.0, after the completing the 
upgrade process, ensure that you remove version 8.82 as a RemoteApp and then use the RemoteApp 
wizard to configure SAP Business One 9.0 (32-bit) as a RemoteApp. 

10.5.3 Performing Tenant Upgrade Simulation 

You can use the tenant upgrade simulation function after the installation of (or upgrade to) SAP Business One 
Cloud 1.1 PL02. The upgrade simulation follows the whole upgrade process; however, it does not prevent the end 
user from still using the old tenant. If the upgrade fails, the operator stores the upgrade logs and tenant backup 
for further analysis. 
To perform the tenant upgrade simulation, do the following: 

 In the Cloud Control Center, choose Customer Management → Tenants, and then choose the Upgrade button 
to run the Tenant Upgrade wizard. 

 In the Tenant Upgrade wizard, from the Upgrade Type radio button, choose Upgrade Simulation. 
 In the Select Tenants window, from the dropdown list, select the service unit that contains the tenants on 

which you want to perform the upgrade simulation. 
 Select one or more tenants to perform the upgrade simulation. 
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 In the Target Service Unit window, select the service unit running the version of SAP Business One on which 
you want to perform the upgrade simulation. 
If the required service unit is not in the list, choose the New button to create a new service unit. For more 
information, see Creating Service Units. 
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o To perform the upgrade simulation, choose the Next button.  
o To change the settings, choose the Back button to return to the previous steps. 

 Note 
The pre-upgrade test is run with upgrade simulation; all detected warnings are confirmed. 

 The Progress/Finish window displays an overview of the main results of the upgrade simulation process.  
To complete the process, choose the Finish button. 

 

 Note 
To view the Upgrade Simulation in the Cloud Control Center, choose Central Components → Service 
Units, and then select the service unit in which you want to view the upgrade simulation. In the Service 
Unit Details area, select the Upgrade Simulation tab. The contents of the Upgrade Simulation tab include: 
o Tenant data: Tenant Name, Tenant Database Name, Source Version, Target Version. 
o Upgrade data: simulation Start Time, simulation End Time, Duration, Last Result (OK, Failed, Not 

Run). In case of fail, the description and the link to the log folder appear. 

10.5.4 Upgrading Extensions 

For information about upgrading extensions for SAP Business One, see Upgrading Extensions. 
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10.6 Upgrading SAP Business One Components 

For information about upgrading SAP Business One components, see SAP Business One Administrator's Guide.  
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11 Managing Global Settings  

The Global Settings window in the Cloud Control Center allows you to perform various security and system 
configuration settings.  

11.1 Enable DI API to Access the Common Database  

The Enable DI API to Access the Common Database option allows you to control whether the DI API has 
permission to access the common database, for instance when performing user queries.     

Procedure 

To activate the Enable DI API to Access the Common Database option, do the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable DI API to Access the Common Database field, choose the On option and 

then choose Save.  
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 Note 
If the Enable DI API to Access the Common Database option is set to Off, the DI API does not have 
permission to access the common database. The default value for new installations and upgrades is Off.  

11.2  Disable UDO Business Logic Implementation DLL 

When you create a user-defined object (UDO) in SAP Business One, you can add a business logic 
implementation (DLL). The Disable UDO Business Logic Implementation DLL option in global settings allows you to 
control if the UDO business logic implementation is enabled or not. By default, the option is On, meaning that UDO 
business logic implementation is disabled.  

Procedure 

To enable UDO business logic implementation, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings.  
 From the dropdown list in the Disable UDO Business Logic Implementation DLL field, choose the Off option 

and then choose Save.   

11.3 Domain Groups Management 

You can use the management function of the domain groups after the installation of (or upgrade to) SAP Business 
One Cloud 1.1 PL02. Alternatively, you can also generate domain groups when you create, duplicate, or upgrade 
tenants or service units. 

Activating the Domain Groups Management Function  

Procedure 

To activate the domain groups management function, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings.  
 From the dropdown list in the Domain Groups Management field, choose the On option and then choose Save.   

 Note 
Choosing the On option turns on the domain groups management function, which requires that the 
operator's account is a domain administrator or a user who has rights to create domain groups and users 
(defined in System Configuration → Account for AD Operations). 
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 Note 
After selecting a value and clicking the Save icon, you need to log off and log on to ensure the refresh of 
the browser session. 

Generating Domain Groups  

Procedure 

To generate domain groups on a service unit, perform the following 
 In the Cloud Control Center, choose Central Components → Service Units, and then select the service unit in 

which you want to generate domain groups.  
 In the Service Unit Details area, on the Configuration tab, choose the Generate Domain Groups button. 

 Note 
The Generate Domain Groups button is enabled only if the Domain Group Management value is set to 
Impersonate. You must be a domain administrator or a user with rights to create groups and users to 
activate the domain group management function. 

Result 

o The domain group for the service unit, and the domain group for each tenant on the service unit, are 
created in the domain controller. 

o The accounts of the system users added to the tenants are updated in the domain controller such that 
they become members of the newly generated domain groups. 

o System users will automatically have file system permissions to the tenant-related shared folder because 
of their membership to domain groups.  

The domain group value is displayed in the following windows: 
o  Central Components → Service Units → Configuration tab → Domain Group field.   
o Customer Management → Tenants → Configuration tab → Domain Group field.   
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11.4 Enable Add Domain Administrators to Customers 

The Enable Add Domain Administrator to Customers option in global settings allows cloud operators to control 
permission to add a domain administrator to a customer. This can otherwise be a security issue as users who can 
add domain administrators to customers are able to change other user's passwords.  

Procedure 

To activate the Enable Add Domain Administrator to Customers option, which gives cloud operators and reseller 
operators permission to add domain administrators to customers, do the following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable Add Domain Administrator to Customers field, choose the On option and 

then choose Save.  

 Note 
If the Enable Add Domain Administrator to Customers option is set to Off, cloud operators and reseller 
operators do not have permission to add domain administrators to customers. The default value for new 
installations and upgrades is Off.  

11.5 Enable Security Certificates for Extensions 

The Enable Security Certificates for Extensions option allows you to enhance the security mechanism for 
extensions by allowing you to issue trusted certificates to your extensions. If the Enable Security Certificates for 
Extensions option is enabled, SAP Business One will check if the certificate for each add-on is trusted in the SLD to 
ensure that the connection is secure.  

Procedure  

To activate the Enable Security Certificates for Extensions option, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable Security Certificates for Extensions field, choose the On option and then 

choose Save. 
 
For more information about adding trusted certificates in the Cloud Control Center, see Managing Extension 
Security. 

11.6 Allow Resellers to Edit External IDs 

The External ID field allows you to enter an external reference ID to help associate customers and resellers with 
other SAP systems. The External ID field can be viewed in Customer Management →  Customers and System 
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Configuration → Resellers and edited on the Configuration tab in the Customer Details area or Reseller Details 
area. The External ID field is also displayed in the wizard when creating customers or resellers. 
Cloud operators can use the Allow Resellers to Edit External IDs option in global settings to control whether or not 
resellers can edit the External ID field. By default, resellers do not have permission to edit the External ID field (in 
other words, the default value is Off).  

Procedure 

To give permission to resellers to edit the External ID field, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Allow Resellers to Edit External IDs field, choose the On option and then choose 

Save. 

11.7 Enable Extension Deployment by Resellers  

The Enable Extension Deployment by Resellers option in global settings allows cloud operators to control if 
resellers can deploy extensions in SAP Business One Cloud. 

Prerequisites  

•  You are logged on to the Cloud Control Center as a cloud operator.  
•  Resellers have the requirements to deploy extensions. 

Procedure 

To activate the Enable Extension Deployment by Resellers option, which allows resellers to deploy extensions, 
perform the following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable Extension Deployment by Resellers field, choose the On option and then 

choose Save. 

 Note 
If the Enable Extension Deployment by Resellers option is set to Off, resellers can view the extensions 
assigned to their service units (Central Components → Service Units → Service Units Details area → 
Extensions) but cannot deploy or undeploy extensions. The default value for new installations and 
upgrades is Off.  
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11.8 Enable Launch Application Option in SAP Business One 

The Launch Application option in SAP Business One (File → Launch Application) allows users to launch different 
applications directly from SAP Business One. In the Cloud Control Center, you can control whether the Launch 
Application option is available in SAP Business One Cloud using the Enable Launch Application Option in SAP 
Business One option in global settings. The default value for the Enable Launch Application Option in SAP Business 
One option is Off.  

Procedure 

To activate the Enable Launch Application Option in SAP Business One option, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable Launch Application Option in SAP Business One field, choose the On 

option and then choose Save. 

11.9 Reseller E-mail is Mandatory 

The Reseller E-Mail is Mandatory option allows you to set whether the Email field is mandatory for reseller 
operators. By default, the Reseller E-Mail is Mandatory option is set to On, which means that the Email field is 
required when creating resellers. You can edit the Email field on the Configuration tab in the Reseller Details area.  

 Note 
 Multiple email addresses can be used if separated by a comma.  

Procedure 

To activate the Reseller E-Mail is Mandatory option, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Reseller E-Mail is Mandatory field, choose the On option and then choose Save. 

11.10 Enable Security Code Authentication (Two-Factor) 

Two-factor authentication is a method of confirming a user's claimed identity by utilizing a combination of two 
different components. In SAP Business One Cloud, the first authentication factor is User ID and Password, and the 
second authentication factor is the Secret Key. 
 
You can enable two-factor authentication for cloud operators, reseller operators, and customer type domain 
users. 
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Note 
If you are using SAP Business One client and DI API add-ons in a cloud solution, some features may 
require you to input the domain user and password for authentication. To ensure this feature works well, 
ensure your service unit (SAP Business One client and DIAPI) is 9.2 PL05 or a later version. 

Note 
As of SAP Business One Cloud 1.1 PL14, in addition to cloud operators, reseller operators can also enable 
the two-factor authentication feature for customer users. 

Prerequisites  

• On your device, you have downloaded and installed the SAP Authenticator app, a mobile app provided by SAP 
SE, which supports iOS and Android.  

• You have configured a Windows time server and ensured that all machines in the Cloud landscape use a 
common time.  

• You are logged on as a cloud operator user. 

11.10.1 Enabling Two-Factor Authentication for Cloud Operators 
and Resellers 

Procedure 

To enable the two-factor authentication feature for cloud operators and reseller operators, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
 In the Global Settings window, set the Enable Security Code Authentication field to On and then choose Save. 
 To enable two-factor authentication for cloud operators, in the main menu of the Cloud Control Center, 

choose System Configuration → Operators. 
 In the Operators window, select an operator and choose the Enable 2FA button.  

Note:  
o To enable two-factor authentication for all cloud operators, in the Operators window, choose the 

Enable 2Fa For All Users button. 

 
 To enable two-factor authentication for resellers, in the main menu of the Cloud Control Center, choose 

System Configuration → Resellers. 
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 In the Resellers window, select a reseller. In the Reseller Details area, on the Reseller Operator Management 
tab, choose the Enable 2FA button.  

Note:  
o To enable two-factor authentication for all reseller operators, in the Resellers window, in the Reseller 

Details area, choose the Enable 2Fa For All Users button. 

 
 In the main menu of Cloud Control Center, choose Secret Key Management. 
 In the Secret Key window, choose the Generate New button.  

 
 
 
 
 
 
 
 
 
 
 
 
 

 Open the SAP Authenticator app on your device and choose Add account. 
Scan the QR code that is generated in the Secret Key window and choose Done. 
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The account is added to your app, and the Current Passcode is generated automatically by the SAP 
Authenticator app.  

 Log off from the Cloud Control Center.  
 You can now log on to the Cloud Control Center or log on to the Browser Access mode of SAP Business One 

using two-factor authentication. 
In the logon window, you are required to enter the SecureCode. 
Enter the Current Passcode from the app. The current passcode can be used for up to 5 minutes. 

Note:  
 Once you have enabled two-factor authentication and generated the security code, the SecureCode in 
the log on window is mandatory. 

 If you want to reset the two-factor authentication key, perform the following: 
o  To reset the two-factor authentication key for a cloud operator, in the Operators window, select the 

relevant operator and choose Reset 2FA Key. 
o To reset the two-factor authentication key for a reseller operator, in the Resellers window, on the 

Reseller Operator Management tab in the Reseller Details area, select the relevant reseller and choose 
the Reset 2FA Key button. 

 If you want to disable two-factor authentication, perform the following  
o To disable two-factor authentication for a cloud operator, in the Operators window, select the 

relevant operator and choose the Disable 2FA button. 
o To disable two-factor authentication for a reseller operator, in the Resellers window, on the Reseller 

Operator Management tab in the Reseller Details area, select the relevant reseller and choose the 
Disable 2FA button. 

11.10.2 Enabling Two-Factor Authentication for Customers 

Procedure 

To enable the two-factor authentication feature for customers, perform the following steps: 
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 In the Cloud Control Center, choose System Configuration → Global Settings. 
 In the Global Settings window, set the Enable Security Code Authentication field to On and then choose Save. 
 In the main menu of Cloud Control Center, choose Customer Management → Customers and select a 

customer that is registered to a tenant.  
 In the Customer Details area, on the User Management tab, select the relevant user and choose the Enable 

2FA button.  

 

Note:  
o To enable two-factor authentication for all users of a customer, in the Customers window, select the 

relevant customer, and on the User Management tab in the Customer Details area, choose the Enable 
2FA For All Users button. 

 Log off from the Cloud Control Center and log on with the customer domain user. 
 In the logon window, after you enter the user name and password, the Secret Key window appears. Choose 

the Generate New button.  
 
 
 
 
 
 
 
 
 
 
 
 

 Open the SAP Authenticator app on your device and choose Add account. 
Scan the QR code that is generated in the Secret Key window and choose Done. 
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The account is added to your app, and the Current Passcode is generated automatically by the SAP 
Authenticator app.  

Note:  
 Once you have enabled two-factor authentication and generated the security code, the SecureCode in 
the log on window is mandatory. 

 You can now log on to the Browser Access mode of SAP Business One using two-factor authentication. 
In the logon window, you are required to enter the SecureCode. 
Enter the Current Passcode from the app. The current passcode can be used for up to 5 minutes.  

Note:  
If a customer that has two-factor authentication enabled wants to log on to some DI add-ons via the 
domain user, the add-ons must support security code logon. In SAP Business One SDK DI API, a new 
property, SecurityCode, is exposed in the Company object. You can adjust your DI add-on code to enable 
the two-factor authentication feature. 

 If you want to reset the two-factor authentication key for a user, in the Customers window, on the User 
Management tab in the Customer Details area, select the relevant user of the customer and choose the Reset 
2FA Key button. 

 If you want to disable two-factor authentication for a user, in the Customers window, on the User 
Management tab in the Customer Details area, select the relevant user for the customer and choose the 
Disable 2FA button. 

11.10.3 Disabling Two-Factor Authentication 

Procedure 

To disable two-factor authentication, perform the following: 
 In the Cloud Control Center, choose System Configuration → Global Settings. 
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 In the Global Settings window, set the Enable Security Code Authentication field to Off and then choose Save. 

11.11 Machine Status Query Interval (X-minutes) 

You can set the frequency with which the SLD retrieves information about memory utilization and CPU utilization 
on your logical machines. By default, the system checks the memory and CPU utilization in 5-minute intervals. 
You can view the memory utilization and CPU utilization in Central Components → Logical Machines.  

Procedure 

To change the machine status query interval to a value other than the default value (5-minutes),  perform the 
following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 In the Machine Status Query Interval (X-minutes) field, choose Edit icon. 
 Enter a value (integer > 0) and choose Save. 

11.12 Password Requirements Hint 

For more information, see Password Requirements Hint. 

11.13 Enable Tenant Registration by Resellers  

The Enable Tenant Registration by Resellers option in global settings allows cloud operators to control if resellers 
can register tenants in SAP Business One Cloud. 

Prerequisites  

•  You are logged on to the Cloud Control Center as a cloud operator.  
•  Resellers have the requirements to register tenants. 

Procedure 

To activate the Enable Tenant Registration by Resellers option, which allows resellers to register tenants, perform 
the following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Enable Tenant Registration by Resellers field, choose the On option and then 

choose Save. 
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 Note 
The default value for the Enable Tenant Registration by Resellers option for new installations and 
upgrades is Off, which means that resellers do not have permission to register tenants (Customer 
Management → Tenants).  

11.14 Allow Heavy Tasks to Run on Presentation Servers 

When performing resource heavy tasks, such as creating, upgrading, or duplicating a tenant, the SLD may 
distribute the task to an SLD Agent on a presentation server, which can degrade the user experience of any users 
working on the presentation server. The Allow Heavy Tasks to Run on Presentation Servers option allows you to 
control whether such tasks can be performed on presentation servers. By default, the Allow Heavy Tasks to Run 
on Presentation Servers options is set to On.  

Procedure  

To deactivate the Allow Heavy Tasks to Run on Presentation Servers option (in other words, to not allow heavy 
tasks to run on presentation servers), perform the following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Allow Heavy Tasks to Run on Presentation Servers field, choose the Off option 

and then choose Save. 

11.15 Allow Operators to Assign Themselves as Users on 
Customer's Tenants  

By default, cloud operators and reseller operator cannot be assigned as a user on a customer's tenant. If an 
operator needs to access the customer's tenant as a user for troubleshooting purposes, the partner support user 
(PSU) connection can be used. If, however, a cloud operator or reseller operator needs to be assigned to a 
customer's tenant for some other reason, you may deactivate this global setting (in other words, the Allow 
Operators to Assign Themselves as Users on Customer Tenants option is switched to ON).  

Procedure  

To activate the Allow Operators to Assign Themselves as Users on Customer Tenants option (in other words, to 
allow cloud operators and reseller operators to assign themselves as users on customers' tenants), perform the 
following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 From the dropdown list in the Allow Operators to Assign Themselves as Users on Customer Tenants field, 

choose the ON option and then choose Save. 

Note 
If the Allow Operators to Assign Themselves as Users on Customer's Tenants global setting is set to ON, 
you need to provide a reason for the assignment in the Assign Users window when creating tenants, 
registering, tenants, or duplicating tenants.  



 

216 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All 
rights reserved. 

SAP Business One Cloud Administrator's Guide 
Managing SLD Agent Task Distribution 

 

12 Managing SLD Agent Task Distribution 

As of SAP Business One Cloud 1.1 PL06, operators can select which Task Executors are selected for respective 
tasks. For example, if you want to create SBO-Common or upgrade tenants, before PL06, these operations are 
executed by any available Task Executor (SLD Agent). As of PL06, operators can define Affinity Groups and 
assign selected computers to respective Affinity Groups. Thus, operations on a Database Server that is in a 
certain Affinity Group will be served by the Task Executor of the same Affinity Group. 

Procedure 

 In the Cloud Control Center, choose System Configuration → Affinity Groups. 
 Add an affinity group. 

 

 Go to the Logical Machines window (Central Components → Logical Machines), select the machine that hosts 
your Database Server instance. 
To verify which components are installed on a selected machine, check the Software Component tab in the 
Logical Machine Details area. 

 To assign the affinity group to a selected machine, press the Edit button on the Configuration tab and select a 
value from the Affinity Group selection box. Choose Save. 

 Go to the Service Units window (Central Components → Service Units), verify that the Affinity Group setting 
for the Database Server instance is also displayed on the Configuration tab in the Service Unit Details area. 

 Repeat steps 3-4 for machines that host SLD Agents. 
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13 Mapping Internal and External URLs 

You can use the external address mapping function after the installation of (or upgrade to) SAP Business One 
Cloud 1.1 PL05. Some components can have public addresses configured here. These addresses are used for 
accessing components from public Internet. 

13.1 Preparing External Addresses 

To expose your SAP Business One services to the Internet (external networks), you must prepare external 
addresses for relevant components. 

 Note 
The Service Layer is for internal component calls only and you do not need to expose it to the Internet. 

Please note the following: 
• The external address and the internal address of each component must be different; otherwise, the external 

networks cannot be distinguished from the internal network, which makes browser access not possible. 
• Only one set of external addresses is supported. Communication through the DNS alias of an external 

address will lead to error. 
• While the User Access Portal is installed later, we recommend that you prepare an address for it in advance at 

the same time as other components. It will save you some configuration efforts. 

Reverse Proxy Mode 

If you intend to handle client requests using a reverse proxy, we recommend that you use different domain names 
for internal and external domains. For example, the internal domain is abc.corp and the external domain is 
def.com.  
Prepare the external addresses as follows: 
• Prepare one external address for both the System Landscape Directory and the User Access Portal. 

In addition, the internal and external ports must use the same number for the User Access Portal. 
• One external address for each service unit, which will be shared by the Browser Access service, the analytics 

service, the integration framework within the service unit, and the mobile service if you are using SAP 
Business One Sales app. 

• The internal address of each component must match the common name of the certificate for the internal 
domain; the external address of each component must match the common name of the purchased certificate 
for the external domain. 

 Example 
The internal URLs of the components are as follows: 
o System Landscape Directory: https://SLDInternalAddress.abc.corp:Port 
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o Browser Access service: https://BASInternalAddress.abc.corp:Port/dispatcher 
o Analytics service: https://B1AInternalAddress.abc.corp:Port/Enablement  
o Integration framework: https://B1iInternalAddress.abc.corp:Port/B1iXcellerator 
o Mobile Service: https://MobileServiceInternalAddress.abc.corp:Port/mobileservice 

The external URLs are as follows: 
o System Landscape Directory: https://servertool.def.com:Port 
o UAP: https://servertool.def.com:Port/BrowserAccess 
o Browser Access service: https://su01.def.com:Port/dispatcher  
o Analytics service: https://su01.def.com:Port/Enablement  
o Integration framework: https://su01.def.com:Port/B1iXcellerator 
o Mobile Service: https://MobileServiceExternalAddress.def.com:Port/mobileservice 

NAT/PAT 

If you intend to handle client requests using NAT/PAT, we recommend that you use the same domain name 
across internal and external networks. For example, both the internal and external domains are abc.com. 
Prepare the external addresses as follows: 
• Prepare one external address (hostname or IP address) for each of these components: 

o System Landscape Directory (SLD) 
o Browser Access service 
o [SAP Business One, version for SAP HANA only] Analytics service 
o User Access Portal (UAP) 
o Integration framework (if you use the SAP Business One mobile solution) 
o Mobile service (if you are using SAP Business One Sales app) 

• The combination of external address and port must be different for these components. In other words, if two 
components have the same external address, the ports they listen on must be different; and vice versa. 

• The internal address and external address of each component must match the common name of the 
certificate purchased for both the internal and external domains. 

 Example 
The internal URLs of the components are as follows: 
o System Landscape Directory: https://SLDInternalAddress.abc.com:Port 
o Browser Access service: https://BASInternalAddress.abc.com:Port/dispatcher 
o Analytics service: https://B1AInternalAddress.abc.com:Port/Enablement  
o Integration framework: https://B1iInternalAddress.abc.com:Port/B1iXcellerator 
o Mobile Service: https://MobileServiceInternalAddress.abc.com:Port/mobileservice 

The external URLs are as follows: 
o System Landscape Directory: https://SLDExternalAddress.abc.com:Port 
o User Access Portal: https://UAPExternalAddress.abc.com:Port/BrowserAccess 
o Browser Access service: https://BASExternalAddress.abc.com:Port/dispatcher  
o Analytics service: https://B1AExternalAddress.abc.com:Port/Enablement  

https://B1iInternalAddress.abc.com:Port/B1iXcellerator
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o Integration framework: https://B1iExternalAddress.abc.com:Port/B1iXcellerator 
o Mobile Service: https://MobileServiceExternalAddress.def.com:Port/mobileservice 

13.2 Registering External Address Mapping 

In the Cloud Control Center, you must register the mapping between the external address of each of the following 
components and its internal address: 
• System Landscape Directory (SLD) 
• Browser Access service 
• [SAP Business One, version for SAP HANA only] Analytics service 
• Mobile service (if you are using SAP Business One Sales app) 
• User Access Portal 

Note that you do not need to register the mapping for the integration framework. 

Procedure 

To map an external address to an internal address, do the following: 
 In the Cloud Control Center, choose System Configuration → External Address Mapping. 
 Choose the Register button. 
 In the External Address Mapping Registration window, select a component type. 
 Specify the component. 

The Internal URL field is filled automatically.  

 Note 
If you are registering the mapping for the System Landscape Directory, the internal URL is editable. Either 
accept the prefilled internal URL or specify a new one.  
The internal URL is then displayed in the System Landscape Directory Internal Address field in the Global 
Settings window. You can check the internal URL in the global settings, and modify it at any point in the 
External Address Mapping Registration window.  

 Specify the external URL. 
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 Choose Register. 
 To apply the changes, restart the relevant service. 

For example, if you have registered the external address mapping for a Browser Access server, you must 
restart the SAP Business One Browser Access Server Gatekeeper service.  
Note that the restart of SAP Business One Browser Access Server Gatekeeper service may take from 5 to 10 
minutes. 
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14 Message Service 

The message service feature allows you to use an external message service (RabbitMQ, a popular open source 
message broker) to receive notifications for noteworthy events performed in the Cloud Control Center. You will 
receive a notification for events such as CUD (create, update, and delete) behaviors related to service units, 
tenants, customers, resellers, SAP Business One components, user binding, trial requests, and so on.  

Prerequisites 

• You have installed and set up RabbitMQ in your environment. For more details, see 
https://www.rabbitmq.com/admin-guide.html. 

Procedure 

To configure the message service in the Cloud Control Center, perform the following: 
 In the Cloud Control Center, choose Central Components → Message Service.  
 To create a new message service, choose the New button.   
 In the Create New Message Service window, specify the following information: 

o Host Name 
o Port 
o Virtual Host 
o User Name 
o Password 
o Read-Only User 
o Read-Only User Password 

https://www.rabbitmq.com/admin-guide.html
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 Choose the Create button.  

Result 

The message service is listed on the Configuration tab in the Message Service Details area.  
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15 Managing Access 

This section assists you with using the Cloud Control Center to manage access for cloud operators, SLD clients, 
and resellers. 

15.1 Adding Cloud Operators 

To provide access to the Cloud Control Center, you must add a cloud operator account for each user. After adding 
a Cloud Operator, you can add an SAP Business One User account with superuser permissions for this user.  
For more information about adding user accounts, see Adding, Removing, and Importing SAP Business One Users. 

Procedure 

To add a Cloud Operator, do the following: 
 In the Cloud Control Center, choose System Configuration → Operators, and then choose the New button.  

The Add Operator window appears. 

 

 Enter a valid domain user name for the user you want to add.  
 To verify that the domain user name you entered exists, choose the Check Names button. 
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 If the domain user name does not exist, the Confirmation window appears.  
To create a new domain user, do the following: 

 Enter a valid initial password for the user. 
 Confirm the password you entered in the previous step and choose the Yes button. 
 The Authorization Required window appears. 
 Enter the logon credentials of an account that has permission to create domain users. For more 

information, see Configuring the Domain Controller. 
 Choose the Add button to return to the Add Operator window. 

 From the Status dropdown list, select a status for this user. The following table gives an overview of the 
possible values. 
o Active – The cloud operator can log on to the Cloud Control Center and has full access to all functionality. 
o Inactive – The cloud operator cannot log on to the Cloud Control Center. You can set a user’s status to 

Active later. 
 If you want to restrict the authorization of the operator to read-only permission, select the Read-Only 

Operator checkbox.  

Note 
The read-only cloud operator can log on and view the data stored in the Cloud Control Center, but does 
not have create, edit, or delete permission.  

 Choose the Add button. 

15.1.1 Adding Read-Only Cloud Operators 

When adding a new operator, you may choose to restrict the authorization to read only permission. The read-only 
operator cannot create, edit, or delete entities in the Cloud Control Center.  
 
 in the Cloud Control Center,  

15.2 Managing Resellers 

Resellers, also known as Value Added Resellers (VARs,) are companies that sell SAP software and provide first-
level support to their customers. Resellers market, sell, and implement customized SAP Business One Cloud 
solutions and provide ongoing support, consulting, and education services to customers. 
You can provide certified resellers with limited access to the Cloud Control Center to enable them to manage their 
customers. Resellers can do the following: 
• Create, edit, and delete customers 
• Add users to and remove users from customers and tenants, and change the status of users 
• Create, edit, duplicate, and delete tenants 
• Assign extensions to tenants 
• Import license files 
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• View information about assigned service units 

15.2.1 Creating Resellers 

Procedure 

To create a reseller, do the following: 
 In the Cloud Control Center, choose System Configuration → Resellers, and then choose the New button to 

run the reseller creation wizard. 
 In the Reseller Profile window, specify the following: 

o Reseller Name – Enter the name of the reseller. 
o Contact Person – Enter the name of the reseller's contact person. 
o Phone – Enter the telephone number of the reseller's contact person. 
o E-Mail – Enter the e-mail address of the reseller's contact person. 
o Employee Count – Enter the number of employees in the reseller’s organization. 
o Country/Region – Enter the country or region in which the reseller is located. 
o Location – Enter the address of the reseller. 
o Description – Enter an optional description for this reseller. 
o Tenant Limit – Enter a positive integer to set the maximum number of tenants allowed by the reseller on 

each service unit. The default value is 0, which indicates no limit. You can change the tenant limit for the 
reseller at any time in System Configuration → Resellers → Configuration tab.  

o External ID – Enter an external reference ID to help associate the reseller with other SAP systems.  

Note 
By default, reseller operators do not have permission to edit the External ID field. If you want to allow 
resellers to edit external IDs, see Allow Resellers to Edit the External IDs. 
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 In the Select Service Unit window, select one or more service units to assign to the reseller. The reseller can 

use the Cloud Control Center to view information about the selected service units and assign tenants to them. 

 

 In the Authorization window, select the operations that you want to authorize the reseller to perform. For the 
operations that you do not select, the reseller must send a request to a cloud operator for approval. 
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 Note 
You can modify the operational authorizations for the reseller later. For more information, see Assigning 
Operational Authorization to Resellers.  

 

 In the Add Reseller Operator window, choose the Add button to optionally add reseller operators to the 
reseller.  
For more information about adding reseller operators, see Adding Reseller Operators. 
o To create the reseller, choose the Finish button.  
o To change the settings, choose the Back button to return to the previous steps. 
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15.2.2 Adding Reseller Operators 

To provide a reseller with access to the Cloud Control Center, you must add a Reseller Operator account for each 
user. After adding a Reseller Operator, you can add an SAP Business One User account with power user 
permissions for this user.  
For more information about adding user accounts, see Adding, Removing, and Importing SAP Business One Users. 

Procedure 

 In the Cloud Control Center, choose System Configuration → Resellers. 
 On the Reseller Operator Management tab of the Reseller Details area, choose the Add button. 

The Add Reseller Operator window appears. 
 Enter a valid domain user name for the user you want to add.  
 To verify that the domain user name you entered exists, choose the Check Names button. 
 If the domain user name does not exist, the Confirmation window appears.  

To create a new domain user, do the following: 
 Enter a valid initial password for the user. 
 Confirm the password you entered in the previous step and choose the Yes button. 
 The Authorization Required window appears. 
 Enter the logon credentials of an account that can create domain users. For more information, see 

Configuring the Domain Controller. 
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 Choose the Add button to return to the Add Reseller Operator window. 
 From the Status dropdown list, select a status for this user. The following table gives an overview of the 

possible values. 
o Active – The reseller operator can log on to the Cloud Control Center and has access to the service units, 

customers, tenants, and licenses assigned to them. 
o Inactive – The reseller operator cannot log on to the Cloud Control Center. You can set a user’s status to 

Active later. 
 Choose the Add button. 

15.2.3 Assigning Service Units to Resellers 

To enable resellers to provision tenants for their customers, you must assign service units to resellers, in which 
they can create tenants.  

Prerequisites 

• You have created a reseller. For more information, see Creating Resellers. 
• You have created a service unit. For more information see Creating Service Units. 

Procedure 

To assign a service unit to a reseller, do the following: 
 In the Cloud Control Center, choose System Configuration → Resellers, and then select the reseller to which 

you want to assign a service unit. 
 On the Service Units tab of the Reseller Details area, choose the Assign button. 

The Assign Service Units to Reseller window appears. 
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 Select one or more service units to assign to the reseller. 
 Choose the Assign button. 

15.2.4 Assigning Customers to Resellers 

Although resellers can use the Cloud Control Center to create, edit, and delete customers, you can also assign 
existing customers to a specific reseller. 

 Caution 
When you unassign a customer from a reseller, the application automatically unassigns all licenses owned 
by the reseller from the customer.  Consequently, the customer can no longer access SAP Business One 
Cloud. 

Prerequisites 

• You have created a reseller. For more information, see Creating Resellers. 
• You have created a customer. For more information see Creating Customers. 

Procedure 

To assign a customer to a reseller, do the following: 



 

SAP Business One Cloud Administrator's Guide 
Managing Access 

INTERNAL: SAP PARTNERS 
© 2022 SAP SE or an SAP affiliate company. All rights reserved.  231 

 

 In the Cloud Control Center, choose System Configuration → Resellers, and then select the reseller to which 
you want to assign a customer. 

 On the Customers tab of the Reseller Details area, choose the Assign button. 
The Assign Customers to Reseller window appears. 

 

 Select one or more customers to assign to the reseller. 
 Choose the Assign button. 

15.2.5 Setting Tenant Limits for Resellers 

As a cloud operator, you can set the maximum number of tenants that a reseller can register on each service unit.  
 
To set a tenant limit for a reseller, perform the following; 

 In the Cloud Control Center, choose System Configuration → Resellers, and then select the reseller for which 
you want to set a tenant limit. 

 In the reseller details area, choose the Configuration tab. 
 In the Tenant Limit field, enter a positive integer to set the maximum number of tenants allowed on each 

service unit for the reseller (the default value is 0, which indicates no limit). 
 
In System Configuration → Resellers, the Number of Tenants field displays the number of tenants registered to the 
reseller and the Tenant Limit field displays the maximum number of tenants currently set for the reseller. 
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15.2.6 Assigning License Files to Resellers 

You can assign license files to resellers, which they can then assign to their customers to provide access to SAP 
Business One. 

 Note 
In situations where customers share license files, the hosting partner is responsible for managing 
licenses.  

Prerequisites 

• You have created a reseller. For more information, see Creating Resellers. 
• You have imported a license file. For more information see Importing License Files. 

Procedure 

To assign a license file to a reseller, do the following: 
 In the Cloud Control Center, choose System Configuration → Resellers, and then select the reseller to which 

you want to assign a license file. 
 On the License Files tab of the Reseller Details area, choose the Assign button. 

The Assign License Files to Reseller window appears. 
 Select one or more license files to assign to the reseller. 
 Choose the Assign button. 

15.2.7 Assigning Storage to Resellers 

You can assign Implementation Repositories and Company Template Repositories to resellers, which enables 
resellers to use their own solution packages and company templates. Multiple resellers cannot share the same 
Implementation Repository or Company Template Repository. 
When a reseller operator provisions a tenant, they can use solution packages or backup files in the repositories 
assigned to the reseller by cloud operators. However, when a cloud operator provisions a tenant, they can use 
solution packages and company templates only in the repositories assigned to the service unit, regardless of any 
storage assigned to resellers. 

 Note 
Cloud operators cannot access the solution packages or backup files of reseller operators assigned to 
their resellers.   
Resellers can only access the solution packages and backup files in the Implementation Repositories and 
Company Template Repositories assigned to them. 

Resellers can upload their own solution packages and company templates using FTP or WebDAV protocols. 
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Prerequisites 

• You have created a reseller. For more information, see Creating Resellers. 
• You have created an Implementation Repository and/or Company Template Repository. For more 

information, see Creating Storage. 

Procedure 

 In the Cloud Control Center, choose System Configuration → Resellers, and then select the reseller to which 
you want to assign storage. 

 On the Storage tab of the Reseller Details area, choose the Assign button. 
The Assign Storage to Reseller window appears. 

 Select the corresponding radio button for the type of storage you want to assign, and then select the 
repository from the dropdown list. 

 Choose the Assign button. 

15.2.8 Assigning Operational Authorization to Resellers 

By default, when a reseller uses the Cloud Control Center to perform an operation, such as creating a new tenant, 
a request is sent to a cloud operator, who must first approve the request before the system executes the 
operation. However, you can authorize certain resellers to perform some operations without requiring approval 
from cloud operators.  
In the Cloud Control Center, you can authorize resellers to perform one or more of the following operations: 
• Tenant creation 
• Tenant upgrades 
• Customer creation 

Prerequisite 

You have created a reseller. For more information, see Creating Resellers. 

Procedure 

To authorize a reseller to perform operations without requiring approval from cloud operators, do the following: 
 In the Cloud Control Center, choose System Configuration → Resellers, and then select the reseller to which 

you want to assign operational authorization. 
 On the Authorization tab of the Reseller Details area, choose the Assign button. 

The Assign Authorization to Reseller window appears. 
 Select the corresponding checkboxes for the operations that you want to authorize the reseller to perform. 
 Choose the Save button. 
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15.3 Adding SLD Clients 

An SLD Client is a client that can communicate with the system landscape directory using the SAP Business One 
Cloud SLD service application programming interface (API). The SLD service API is a collection of 
Representational State Transfer (REST) Web service APIs that enable partners and customers to extend the 
functionality of SAP Business One Cloud to create industry specific functionality, develop missing functionality, 
and interface with third-party tools. 
For a client to communicate with the SLD, you must first register the client using the Cloud Control Center. Each 
client is assigned a unique identifier that you must specify in the HTTP request header when calling the Web 
service API. 
For more information about using the SLD service API, see SAP Business One Cloud System Landscape Directory 
Service API. 

Procedure 

To register an SLD Client, do the following: 
 In the Cloud Control Center, choose System Configuration → SLD Clients, and then choose the Register 

button. 
The SLD Client Registration window appears. 

 

 In the Name field, enter the name of the client that you want to register. 
 If you already have an identifier for the client from SAP, enter it in the Identifier field. The SLD confirms 

whether the identifier is valid. Otherwise, choose the Generate button to create a new identifier for the client. 
 In the Description field, enter an optional description for the client. 
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 To complete the registration process, choose the Register button. 
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16 Managing Requests 

This section provides instructions for approving and rejecting requests for trials of SAP Business One Cloud from 
customers and requests from resellers. 

16.1 Managing Trial Requests 

For customers that are interested in learning more about SAP Business One Cloud, you can offer a fully functional 
license-free trial. During the trial period, customers can access a simple SAP Business One implementation, for a 
limited time and number of users. 
Customers can request a trial of SAP Business One Cloud using the User Access Portal. After a customer enters 
the required information, the Cloud Control Center displays a trial request with the customer’s information.  
For more information about configuring the User Access Portal, see Installing the User Access Portal. 

16.1.1 Approving Trial Requests 

Prerequisites 

• You have created a service unit with the version of SAP Business One that the customer wants to run. For 
more information, see Creating Service Units. 

• You have created a Shared Folder. For more information, see Creating Shared Folders. 

Procedure 

To approve a trial request, do the following: 
 In the Cloud Control Center, choose Customer Management → Trial Requests, and then select the request 

you want to approve.  
 Choose the Approve button to run the customer creation wizard. 
 Complete the required steps in the customer creation wizard. For more information, see Creating Customers. 

 Note  
When creating customers from a trial request, the following restrictions exist: 

o You can add a maximum of two users 
o You can create only a trial tenant 
o You cannot assign licenses 

 Log on to the SAP Business One client application and configure the settings on behalf of the user. 
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 On the Configuration tab in the Trial Request Details area, choose the Release button. 

 Note 
You can extend the trial period on the Configuration tab in the Tenant Details area for the corresponding 
tenant. To view the details for a tenant, choose Customer Management → Tenants, and then select the 
tenant from the list. 

16.1.2 Rejecting Trial Requests 

To reject a trial request, do the following: 
 In the Cloud Control Center, choose Customer Management → Trial Requests, and then select the request 

you want to reject.  
 Choose the Reject button. 
 In the Confirmation window, enter a reason for the rejection. 
 To complete the process, choose the Confirm button. 

16.2 Managing Reseller Requests 

When a reseller uses the Cloud Control Center to perform an operation, such as creating a new tenant, a request 
is sent to a cloud operator, who must first approve the request before the system executes the operation.  

 Note 
You can authorize certain resellers to perform some operations without requiring approval from cloud 
operators. For more information, see Assigning Operational Authorization to Resellers. 

16.2.1 Approving Reseller Requests 

To approve a reseller request, do the following: 
 In the Cloud Control Center, choose Customer Management → Reseller Requests, and then select the request 

you want to approve. 
 Choose the Review button. 

The Reseller Request Details window appears. 
 Choose the Approve button, 
 In the Approve window, enter a reason for the approval. 
 To complete the process, choose the OK button, 
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16.2.2 Rejecting Reseller Requests 

To reject a reseller request, do the following: 
 In the Cloud Control Center, choose Customer Management → Reseller Requests, and then select the request 

you want to reject. 
 Choose the Review button. 

The Reseller Request Details window appears. 
 Choose the Reject button, 
 In the Reject window, enter a reason for the rejection. 
 To complete the process, choose the OK button, 
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17 Managing Support 

This section assists you with using the audit log (a time stamped list of all changes to System Landscape 
Directory resources) and uploading content to SAP Support. 

17.1 Working with Audit Logs 

The audit log records a time stamped list of all changes to system landscape directory resources, including the 
user that made the change and the request. The audit log records changes made using the Cloud Control Center 
as well as SLD clients via the System Landscape Directory Service API. 
To access the audit log, in the Cloud Control Center, choose System Configuration → Audit Logs. 
 
The Audit Logs area provides an overview of all changes to SLD resources, and displays the following information 
for each change: 
• Sequence Number – Indicates the order in which the changes to SLD resources occurred. 
• Request – The request sent to the SLD Service API. The request is either an SLD function or an SLD entity. 
• Resource – The SLD resource that was changed and the operation that was performed. 
• User Name – That name of the Cloud Operate or Reseller Operator who made the change. 
• Changed On – The date and time at which the SLD resource was changed. 

 
You can use the controls and the top of the Audit Logs area to filter the entries displayed in the audit log. For 
example, you can filter by specific users, requests, resources, and time periods.  
 
To view detailed information about the properties that were changed for a specific resource, select the row for the 
corresponding request in the audit log. The Audit Log Details area displays the following information: 
• Property – This column lists all the changed and unchanged properties for the selected resource. For more 

information about the available properties for different resources, see SAP Business One Cloud System 
Landscape Directory Service API. 

• Previous Value – The value of the property before the change occurred. 
• New Value – The updated value of the property after the changed occurred. 

17.1.1 Cleaning Up Audit Logs 

Failing to delete audit log records can cause the SLD database to become relatively large, which may result in 
errors during upgrade of the SLD. As of SAP Business One Cloud 1.1 PL12, the clean up audit log function allows 
you to clean up your audit logs. 
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Procedure 

To clean up audit log records of changes to system landscape directory resources, perform the following: 
 In the Cloud Control Center, choose System Configuration → Audit Logs. 
 Choose the Clean Up button.  
 In the Clean Up Audit Log window, in the To Date field, select the date to up to which you want to delete your 

audit logs. 
 Choose the Clean Up button, and then choose Yes in the Confirmation window.  

17.2 Uploading Content to SAP 

The Cloud Control Center provides an interface for working with content upload tasks in the remote support 
platform for SAP Business One, which enables you to upload company databases to SAP Support. Cloud 
operators can upload any company database to SAP Support; however, reseller operators can only upload the 
company databases of their assigned customers. 

Prerequisites 

• You have installed the latest version and patch level of the remote support platform for SAP Business One in 
your cloud landscape. 

• You have configured the remote support platform access to the System Landscape Directory, and the remote 
support platform user for the SLD is a cloud operator. 

• You have enabled and correctly configured the SAP Channel in the remote support platform. 
• You have configured a network folder in which to store database backups in the remote support platform. 

For more information about working with the remote support platform, see the Online Help for the remote support 
platform for SAP Business One. 

Procedure 

To use the Cloud Control Center to upload company databases to SAP Support, do the following: 
 Obtain a content upload request from SAP Support, which includes an encryption key. 
 In the Cloud Control Center, choose Support Management → Content Upload. 
 To run the content upload wizard, choose the New Content Upload button. 
 In the Import Request window, enter the path to the content upload request file you received from SAP along 

with the corresponding encryption key. 
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 In the Choose Database window, select the company database that you want to upload to SAP Support. 

 

 The Summary window displays an overview of the content upload settings. 
o To begin uploading content, choose the Finish button. 
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o To change the settings, choose the Back button to return to the previous steps. 

Result 

The content upload request is imported to the agent of the remote support platform. You can monitor the upload 
progress in the Cloud Control Center or the remote support platform console. 

17.3 Troubleshooting Problems Using a Partner Support User 
Account 

When you register a tenant to a service unit, the application automatically creates two partner support user 
accounts with user codes _PSU_1 and _PSU_2. These accounts can be used to open a partner support user (PSU) 
connection to log on to the tenant and troubleshoot problems. A support user session can last for a maximum of 4 
hours. 

 Note 
Customers may disable access to SAP Business One for partner support user accounts in the 
application's help menu or by locking the accounts.  

Procedure 

To use a partner support user account to access a customer's SAP Business One tenants, do the following: 
 In the Cloud Control Center, choose Customer Management → Tenants, and then select the tenant to which 

you want to connect. 
 In the Tenant Details area, on the Configuration tab, choose the Open PSU Connection button, and then open 

the generated RDP file. 
SAP Business One launches and automatically logs you on using an available partner support user account. 

 Note 
If you are using Citrix instead of Microsoft RDS, do not open the generated RDP file. Instead, log on using 
the Remote Desktop Web Access. 

 In the Support User Logon Reason window, select a reason for using the partner support user account from 
the dropdown list or enter a reason in the text area, and then choose the Login button. 
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You have a maximum of 4 hours to troubleshoot the problem. You can view the time remaining in your session in 
the Expires In field (Tenants → User Management). The application will display a timeout warning 10 minutes 
before your session expires. 
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18 Managing Security 

Your security requirements are not limited to SAP Business One Cloud, but apply to your entire system 
landscape. Therefore, we recommend establishing a security policy that addresses the security issues of the 
entire company. This section offers several recommendations to help you meet the security demands of SAP 
Business One Cloud. 
Your security policy should cover the following aspects: 
• Technical Landscape – Provides an overview of the technical components and communication paths that 

SAP Business One Cloud uses. 
• User Management and Authentication – Provides system access to only legitimate users and prevents 

identity impersonation. 
• Database Authentication – Introduces a strong password definition mechanism to restrict unauthorized 

database access. 
• Data Storage Security – Avoid the risk of data loss by developing a comprehensive backup strategy. 

Once you have established your security policy, we recommend that you dedicate sufficient time and allocate 
ample resources to implement it and maintain the level of security that you require.  

 Note 
For more information about the security considerations of SAP HANA, see the SAP HANA documentation 
on SAP Help Portal at http://help.sap.com/hana_appliance. 
For more information about the security of Microsoft SQL Server, see the Microsoft SQL Server Security 
Center at www.microsoft.com. 

18.1 Technical Landscape 

In SAP Business One Cloud, the System Landscape Directory servers as the security server, which saves 
database credentials in the SLD database. 
Database credentials are obtained by supplying a Kerberos token to the SLD and validated against the Central 
Directory Server. Upon successful authentication, connections to common and company databases are 
established using database credentials supplied from the SLD server.  
The following figure provides an overview of the security workflow for SAP Business One Cloud. 

http://help.sap.com/hana_appliance
http://www.microsoft.com/
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18.2 User Management and Authentication 

This section provides an overview of how SAP Business One Cloud supports an integrated approach to user 
administration and authentication. 

18.2.1 User Management 

For information about managing access for the different user types in SAP Business One Cloud, see Message 
Service. 
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18.2.2 Password Policy 

As standard practice, SAP Business One Cloud authenticates users based on their operating system 
authentication.  The password policy of the underlying operating system should be strong enough to protect the 
entire landscape. 
The suggested password policy is as follows: 
• Minimum eight characters 
• Maximum 25 characters 
• Minimum one digit 
• Minimum one lower case character 
• Minimum one upper case character 
• Cannot be the same as the five previous passwords 
• Expires after 60 days 
• Locks after five consequent failed validations 
• Unlocks one hour after the last failed logon attempt 

18.2.3 Resetting Domain User's Passwords 

You can reset passwords for existing domain users in the Cloud Control Center.  

Prerequisites 

• As a reseller operator, you have the required authorization on the active directory to maintain passwords for 
your customer's system users.  

• As a cloud operator, you have the required authorization on the active directory to maintain passwords for 
system users and reseller operators. 

Procedure 

To set a password for a customer user, do the following: 
 In the Cloud Control Center, choose Customer Management → Customers, and then select the relevant 

customer.  
 On the User Management tab in the Customer Details area, choose the user for whom you want to set the new 

password, and choose Reset Password. 
 In the Set Password window, enter and confirm the new password for the selected user.  

Note  
Alternatively, cloud operators can set passwords for resellers by choosing System Configuration → 
Operators and System Configuration → Resellers → Reseller Operator Management.  
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18.2.3.1 Password Requirements Hint  

To help operators meet the password policy set up on the domain controller, the optional Password Requirements 
Hint field in System Configuration → Global Settings allows you to provide a description of the password policy. 
The field text is displayed each time a new password is being set for a domain user.  

Procedure 

To create a password requirements hint to be displayed each time a new password is being set for a domain user, 
do the following: 

 In the Cloud Control Center, choose System Configuration → Global Settings. 
 In the Password Requirements Hint field, enter the text to be displayed when a new password is being set, and 

then click the Save icon. 

Result 

The text in the Password Requirements Hint field will be automatically displayed in the Set Password window. 

Note 
If any of the rules that comprise the password policy change, you need to update the text in the Password 
Requirements Hint field. 

18.2.4 Managing Account for Active Directory Operations 

As a cloud operator, you can set the account used to perform operations in the Cloud Control Center that require 
Active Directory access. To do so, you must provide the domain administrative account credentials during 
installation or upgrade of the SLD service. You can modify the specified account for Active Directory operations at 
any time in the Cloud Control Center.  

Note 
As of SAP Business One Cloud 1.1 PL15, you cannot use the built-in administrator account as the account 
for AD operations. To change the built-in Administrator account to another domain administrator 
account, see SAP Note 2815684. 

Prerequisites 

• You have created a domain account for Active Directory operations to perform domain information 
management in the Cloud Control Center.  

• During installation or upgrade of the SLD service, you have entered the domain administrative account 
credentials. 

https://launchpad.support.sap.com/#/notes/2815684
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Procedure 

To set or modify the account for Active Directory operations in the Cloud Control Center, perform the following: 
 In the Cloud Control Center, choose System Configuration → Account of AD Operations.  

Note 
Only one domain account for Active Directory operations is permitted in the Cloud Control Center. 

 Choose the Edit button. 
 In the Set Domain Account for AD Operations window, enter the required domain administrative account 

credentials: 
o Domain Controller – Enter the domain controller IP address. 
o Domain Name – Enter the domain name for the SAP Business One Cloud landscape. 
o Domain User Name – Enter the domain user name for the domain user.  

Note 
The domain user name must be the same as the logon name. 

o Password – Enter the password for the domain user.  
o Confirm Password – Confirm the password you entered for the domain user.  
o LDAP over SSL – You can make LDAP transmission confidential and secure by selecting the LDAP over 

SSL checkbox to enable LDAPS. Data that is sent between the LDAP client and LDAP server is encrypted. 
To configure LDAPS, you need to install a valid certificate on the domain controller. For more information, 
see SAP Note 2868733.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://launchpad.support.sap.com/#/notes/2868733
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 To use the stored domain controller address and admin credentials to perform domain manipulation, 
in System Configuration → Global Setting, in the Domain Group Management field, choose the ON option.  

 Note 
In System Configuration → Global Settings, the System User Management field is no longer displayed. 

18.3 Database Authentication 

The default database administrator user SYSTEM has full authorization. Therefore, you must assign a strong 
password for the SYSTEM account. This ensures that a blank or weak SYSTEM user password is not exposed. 
Alternatively, you can create another superuser account with the same authorization as the SYSTEM user. 

 Recommendation 
For security reasons, we recommend that you change the SYSTEM logon password immediately after 
installing the SAP HANA database server. Alternatively, a safer option is to create another database user 
account as a substitute for the SYSTEM user 

 Note 
If you change the password of the database user account (for example, SYSTEM) used to install the 
System Landscape Directory, you must reinstall the SLD. 

18.3.1 Changing the SYSTEM Logon Password 

A strong password is the first step to securing your system. A password that can be easily guessed or 
compromised using a simple dictionary attack makes system vulnerable. A strong password has the following 
characteristics: 
• Contains alphabetic, numeric, and special characters 
• Is at least seven characters in length 
• Is at least seven characters in length 
• Is NOT a common word or name 
• Does NOT contain a name or user name 
• Is significantly different from previous passwords 

Procedure 

To change the password for the SYSTEM logon, in the SAP HANA studio, do the following: 
 Log on to the SAP HANA Studio as a database administrator. 
 In the SAP HANA Systems list, navigate to the database instance for which you want to change the password 

for the SYSTEM user. 
 Choose Security → Users → SYSTEM and double click SYSTEM.  
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The <instance name> - SYSTEM tab appears the right. 
 Enter and confirm the password. 
 In the upper right toolbar, click the Deploy button to save the new password. 

18.3.2 Creating a Superuser Account 

Procedure 

To create a superuser account for maintaining administrative tasks, in the SAP HANA studio, do the following: 
 Log on to the SAP HANA studio as a database administrator. 
 In the SAP HANA Systems list, navigate to the database instance for which you want to create a superuser 

account. 
 Choose Security → Users, right click User, and choose New User.  

The <instance name> - New User tab appears on the right. 
 On the <instance name> - New User tab, do the following: 

o In the User Name field, enter the name of the new user. 
o Select the Password checkbox, and then specify and confirm the password for the new user. 
o In the Session client field, do not enter anything. 
o On the System Privilege tab in the lower area, choose the plus button. In the Select System Privilege 

window, add all system privileges. 
o In the System Privilege pane on the left, select each privilege, and then select the Grantable to other users 

and roles checkbox in the Details pane on the right. 
 In the upper right toolbar, click the Deploy button to save the new user 

 Note 
When the new user first logs on to the SAP HANA studio, they must change the password. 

18.3.3 Database Privileges for Installing, Upgrading, and Using 
SAP Business One Cloud  

To install, upgrade, and use SAP Business One Cloud, you must grant the following database privileges to the 
corresponding SAP HANA database user:  
• Roles:  

o PUBLIC  

o CONTENT_ADMIN  

o AFLPM_CREATOR_ERASER_EXECUTE (grantable)  
• System privileges:  

o CREATE SCHEMA (grantable)  
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o USER ADMIN (grantable)  
o ROLE ADMIN (grantable)  
o CATALOG READ (grantable)  
o IMPORT  

o EXPORT  

o INIFILE ADMIN  

o LOG ADMIN  

This is needed if this database user is used to run the migration wizard to migrate your company 
databases from the Microsoft SQL Server to the SAP HANA server.  

• SQL object privileges:  
o SYSTEM schema: CREATE ANY, SELECT  
o  _SYS_REPO schema: SELECT, EXECUTE, DELETE (all grantable)  

The SBOCOMMON schema is created during the installation of SAP Business One Server, and the COMMON schema is 
created during the installation of the analytics platform. If you use different SAP HANA users for installing 
different components, you must pay special attention to grant the following object privileges as appropriate:  
•  SBOCOMMON schema: SELECT, INSERT, DELETE, UPDATE, EXECUTE, CREATE ANY, DROP (all 

grantable)  
• COMMON schema: SELECT, INSERT, DELETE, UPDATE, EXECUTE (all grantable)  

 

Grant Roles and Privileges to Database Users  

To grant roles or privileges to a database user, follow the steps below:  
 In the SAP HANA studio, connect to your system as a superuser (for example, SYSTEM).  
 In the Administration Console, under the Security folder of your system, under Users, double-click the 

database user.  
The details of the database user are displayed on the right.  

 In the right panel, add required roles or privileges.  
 To apply the changes, click the Deploy button or press F8 .    

18.3.3.1 Database Role PAL_ROLE for Pervasive Analytics  

A database role PAL_ROLE is created during the upgrade/installation process of the app framework. All database 
privileges necessary for using pervasive analytics are assigned to this role on the condition that you have installed 
the AFLs properly (for more information, see the Host Machine Prerequisites section in SAP Business One 
Administrator's Guide, version for SAP HANA); AFLs being missing do not prevent the setup program from 
creating PAL_ROLE, but you will have to manually assign database privileges after the upgrade/installation (see 
the troubleshooting section below).  
During the upgrade/installation process or when you change the database user for server connection in the 
System Landscape Directory, PAL_ROLE is automatically assigned to the database user.  
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Note  
If you change the database user for server connection in the System Landscape Directory, PAL_ROLE is 
not automatically unassigned from the previously used database user. Similarly, if you change the 
security option for your company schema (for example, from using a specified database user for each 
SAP Business One user to using the admin user for all), PAL_ROLE is not automatically unassigned from 
the database users self-generated for the old option.  
You need to release the PAL_ROLE assignments manually.  

Troubleshooting Missing Database Privileges for PAL_ROLE  

If required database privileges are not granted to PAL_ROLE (for example, because you install the AFLs after you 
install or upgrade the app framework) or PAL_ROLE is not properly assigned to the relevant database user or the 
required database privileges are not granted to non-SYSTEM users, you will have difficulty using pervasive 
analytics. To solve this issue, follow the troubleshooting instructions below.  

Step 1: Ensure PAL_ROLE has all necessary database privileges  

 In the SAP HANA studio, connect to your SAP HANA database instance as the database user that was used to 
upgrade the app framework.  

 In the Security folder, under Roles, double-click the role PAL_ROLE.  
The details about the role are displayed in the right panel.  

 Check if PAL_ROLE has the following database privileges:  
o Granted roles:  

o AFL__SYS_AFL_AFLPAL_EXECUTE  

o AFL__SYS_AFL_AFLPAL_EXECUTE_WITH_GRANT_OPTION  

o AFLPM_CREATOR_ERASER_EXECUTE  

o Object privileges:  
o SYSTEM.afl_wrapper_generator: EXECUTE  
o SYSTEM.afl_wrapper_eraser: EXECUTE  

 If any database privileges are missing, grant the privileges to PAL_ROLE.  

Step 2: Ensure PAL_ROLE is assigned to the database user being used for server connection  

 Log on to the System Landscape Directory, edit your server, and check the database user name.  
This database user is being used for server connection. 

 In the SAP HANA studio, connect to your SAP HANA database instance as the database user that was used to 
upgrade the app framework.  

 In the Security folder, under Users, double-click the name of the database user being used for server 
connection.  
The details about this database user are displayed in the right panel.  

 If the granted roles do not include PAL_ROLE, then grant PAL_ROLE (grantable) to the database user.  
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Note  
If you intend to switch to a database user other than SYSTEM after installing SAP Business One Cloud with 
the SYSTEM user, you should also grant the following object privileges to the non-SYSTEM user before 
Step 1 and Step 2:  
o SYSTEM.afl_wrapper_generator: EXECUTE  
o SYSTEM.afl_wrapper_eraser: EXECUTE  

18.3.4 Stored Procedures 

You must not rename or remove any of the stored procedures in the SAP HANA database; otherwise, errors could 
occur when running SAP Business One Cloud. 

18.4 Database User Management  

As of SAP Business One Cloud 1.1 PL10, the database users and privilege function in the Cloud Control Center 
allows cloud operators and reseller operators to manage SAP Business One analytics, Crystal reports, and stored 
procedures in SAP Business One, version for SAP HANA. 

18.4.1 Granting Privileges to Database Users 

Before creating database users, ensure that you have all privilege types that you may need to grant to database 
users. The following three user privileges have been predefined in the system (System Configuration → Database 
Privileges):  

o Stored Procedures: Grants the database user privileges to create, modify, and delete stored procedures. 
o Crystal Reports: Grants the database user privileges to use SAP Crystal Reports, version for the SAP 

Business One application. 
o Analytics (SAP HANA only): Grants the database user design-time privileges to SAP Business One 

analytics. 
Additionally. you  may define one or more customized privileges using the DB privilege creation wizard. For more 
information, see Defining Customized Database Privileges.  

Note:  
o When you create or duplicate a tenant, the database privileges are automatically granted to all 

database users on the tenant’s company database. 
o When deleting a tenant, service unit, customer, or reseller, the related database user is also deleted.   
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18.4.1.1 Defining Customized Database Privileges 

Prerequisites 

• You have checked that your privilege content can be successfully executed in the database. 

Procedure 

To add a customized database privilege, perform the following: 
 In the Cloud Control Center, choose System Configuration → Database Privileges, and then choose the New 

button. 
 In the Database Privilege Information window, perform the following: 

o Database Privilege Name– Enter a unique name for the database user.  
o Grant SP Name – Enter a name for the stored procedure.  
o Revoke SP Name – Enter a name for the revoke stored procedure. 
o Description (optional) – Enter a description of the stored procedure.  

 In the Add DB Privilege Content window, choose the Add button, and in the next window, perform the 
following: 

 Select whether the database type for the privilege content is a SAP HANA database or a Microsoft SQL 
database. 

 In the Grant SP Content box, enter the stored procedure for the grant permission. 

 Example  
CREATE PROCEDURE ExampleDBUser_StoredProcedures_GrantPrivilege( 
            in db_name varchar(250), 

            in db_username varchar(250) 

) 

LANGUAGE SQLSCRIPT 

AS 

sqlstr nvarchar(1024); 

BEGIN 

            sqlstr := 'GRANT ALTER, CREATE ANY, DEBUG, DELETE, DROP, EXECUTE on 
SCHEMA ' || :db_name || ' TO ' || :db_username || ' WITH GRANT OPTION'; 

            EXEC sqlstr; 

END; 

 

 In the Revoke SP Content box, enter the stored procedure for the revoke permission.  

 Example  
CREATE PROCEDURE ExampleDBUser_StoredProcedures_RevokePrivilege( 

            in db_name varchar(250), 
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            in db_username varchar(250) 

) 

LANGUAGE SQLSCRIPT 

AS 

sqlstr nvarchar(1024); 

dbuser_count INT;  

BEGIN 

            SELECT COUNT(*) INTO dbuser_count FROM PUBLIC.USERS WHERE USER_NAME 
= :db_username; 

            IF :dbuser_count > 0 THEN 

                        sqlstr := 'REVOKE ALTER, CREATE ANY, DEBUG, DELETE, 
DROP, EXECUTE on SCHEMA ' || :db_name || ' FROM ' || :db_username; 

                        EXEC sqlstr; 

            END IF; 

END; 

 
 Choose the Add button to add the stored data to the Add DB Privilege Content table.   

Note: 
You can repeat Step 3 to add additional database privilege content for the database type.  

 In the Review window, check the database privilege data you have entered, and then choose the Finish button.  

18.4.1.2 Regranting Privileges to Database Users 

After upgrading to a higher SAP Business One version (Cloud 1.1 PL11 or higher), you can regrant privileges to 
existing database users.  

Prerequisites 

• You have created a database user. For more information, see Creating Database Users. 

Procedure 

To regrant privileges to database users on all related tenants, perform the following: 
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 In the Cloud Control Center, choose System Configuration → Database Users, and then select the relevant 
database user.  

 
 Choose the Regrant Privilege button.  
 In the Confirmation window, choose Yes. 

Result 

In the Database User Details area in the Database Users window, on the Tenant Management tab, the Grant 
Privilege Status field indicates whether the privileges were successfully granted to the relevant tenant. 

18.4.2 Creating Database Users  

You can create database users at the tenant level (permissions are granted on the selected tenant), customer 
level (permissions are granted on the tenants associated with the selected customer and service unit), and 
reseller level (permissions are granted on the tenants associated with the selected reseller and service unit).  

Note: 
Only cloud operators can create, edit, and delete database users. Reseller operators have read-only 
permission for the database users assigned to them.  

Procedure 

To create a database user, perform the following: 
 In the Cloud Control Center, choose System Configuration → Database Users, and then choose the New 

button. 
 In the welcome window of the database user creation wizard, in the Create Options area, select one of the 

following options: 
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o Tenant – Create a database user with tenant privileges (proceed to Step 5). 
o Customer – Create a database user with customer privileges (proceed to Step 3) 
o Reseller – Create a database user with reseller privileges (proceed to Step 4). 

 In the Select Customer window, select the customer to whom you want to assign the database user (proceed 
to Step 5). 

 In the Select Reseller window, select the reseller to whom you want to assign the database user. 
 In the Select Service Unit window, select the relevant service unit on which you want to select a tenant.  
 In the Select Tenant window, select the tenant on which you want to assign the database user.  
 In the Database User Profile window, perform the following: 

o Database User Name – Enter a unique name for the database user.  
o Password – Enter a password for the database user. 

Note:  
The password must be a minimum of 8 characters, and should include at least one lowercase, uppercase, 
and numerical digit or other character.   

o Confirm Password – Confirm the password you entered for the database user. 
o Description (optional) – Enter a description of the database user.  

 In the Select Privilege Type window, choose one or more privilege type for the database user.  

Note:  
You may choose from among the predefined database privilege types and your custom privilege types. 
For more information, see Granting Privileges to Database Users.  

18.5 Data Security 

Databases are always at risk of damage.  To keep the risk of data loss low, ensure that you develop a backup 
strategy that suits your business and the requirements of your customers. An important factor to consider is the 
volume of data that you process each day. In case of data loss, you are required to retrieve this data manually, 
back to the time of your last backup.  
Test your backup and recovery procedures thoroughly. Testing helps to ensure that you have the required 
backups to recover from various failures, and that your procedures can be executed smoothly and quickly if a 
failure occurs. 
The frequency of the backups depends on the following factors: 
• Processed data volume 
• Customer requirements 
• Number of users 

To avoid data loss, you must also back up regularly the following directories and storage: 
• Software repositories 
• Shared folders 
• Company template repositories 
• Tenant storage 
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Appendix 1 

List of Log File Locations for SAP Business One Cloud Components 

The following tables list the paths to installation and runtime log files for SAP Business One Cloud components 
and services (according to your operating system). 
For information about log file locations for SAP Business One components and services, see the corresponding 
Appendix in the SAP Business One Administrator's Guide or SAP Business One Administrator's Guide, version for 
SAP HANA on SAP Help Portal.  
 

  Table 1: Windows 

Component  Installation Log Path Runtime Log Path 

Cloud 
Control 
Center 

System 
Landscape 
Directory (SLD) 

%USERPROFILE%\SAP Business One 
SLD Service\setup.log 

${user.home}/AppData/Local/SAP/S
AP Business One/Log/SLD 
 

User Access 
Portal 

%PROGRAMDATA%\SAP\SAP 
Business One\Log\SAP Business 
One\<Windows 
user>\BODWinInstaller_CurrentRun.lo
g 

%PROGRAMFILES%\SAP\SAP 
Business One User Access 
Portal\tomcat\logs\dispatcherService.
log 

SLD Agent %USERPROFILE%\SLDAgent-
setup.log 

${user.home}/AppData/Local/SAP/S
AP Business One/Log/SLDAgent 

 

  Table 2: Linux 

Component  Installation Log Path Runtime Log Path 

Cloud 
Control 
Center 

System 
Landscape 
Directory 
(SLD) 

/var/log/SAPBusinessOne /var/log/SAPBusinessOne/CloudSLD 

User Access 
Portal 

 %PROGRAMFILES%\SAP\SAP Business 
One User Access 
Portal\tomcat\logs\dispatcherService.log 

SLD Agent /var/log/SAPBusinessOne ${user.home}/AppData/Local/SAP/SAP 
Business One/Log/SLDAgent 

https://help.sap.com/
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