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Introduction  
This solution guide is a companion to the “SAP BusinessObjects Business Intelligence Workbook 1:                

The Sports Warehouse”.  For more information about the activities refer to Workbook 1. 

To get the most out of this Solution Guide, it is strongly recommended that you do your best to 

complete the activities in the workbook without referring to this Solution Guide whenever possible.  The 

prerequisites and recommended tutorials referred to in the Workbook activities should provide you with 

the knowledge required to successfully complete the activities.   

If you get stuck completing any of the activities, follow the step by step solutions in this guide.  

However, simply clicking through the step by step solutions found here will generally be inadequate to 

learn how to build effective business intelligence solutions.  If you need the step by step solutions to 

complete any activity, try to complete the activity in the workbook again without referring to the 

detailed solution steps.   

Instructions to install the required software are provided in the “SAP BusinessObjects B1 4.x Installation 

Job Aid”.   

 

  

http://sdn.sap.com/irj/scn/index?rid=/library/uuid/40c992c6-3f4c-2f10-c1bc-d5a93bd08075
http://sdn.sap.com/irj/scn/index?rid=/library/uuid/40c992c6-3f4c-2f10-c1bc-d5a93bd08075
http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/a004fe72-ca4a-2f10-a49d-a0703ed1d8e8
http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/a004fe72-ca4a-2f10-a49d-a0703ed1d8e8
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Solution 1: Create the Sports_Warehouse Database 

 
1. Download and extract the following workbook resources. 

a. Sports:  

http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/4026d3cc-ca4a-2f10-fa85-

ecc740f6a085  

b. Spreadsheets:  

http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/00f8b958-cb4a-2f10-a2b3-

e18c0ef13574  

 

2. Open SQL Server Management Studio (Start > All Programs > Microsoft SQL Server 2008 > SQL 

Server Management Studio. 

3. Login as shown in the dialog below. 

 

 
 

Note: You may need to switch server types to view the (local) server name. 

 

4. Right click Databases in the Object Explorer and choose New Database… 

http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/4026d3cc-ca4a-2f10-fa85-ecc740f6a085
http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/4026d3cc-ca4a-2f10-fa85-ecc740f6a085
http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/00f8b958-cb4a-2f10-a2b3-e18c0ef13574
http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/00f8b958-cb4a-2f10-a2b3-e18c0ef13574
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5. Type Sports_Warehouse in the Database Name field. 

 
 

6. Change the Initial Size to 10 MB. 

7. Click OK. 

8. Navigate to the Sports_Warehouse Database. 

 
 

9. Right click Sports_Warehouse and choose Tasks > Import Data… 

10. Click Next. 

11. Choose Flat File Source as the data source. 

12. Click Browse… 

13. Navigate to Sample_Databases\Sports_Warehouse\. 

14. Choose CSV Files (*.csv). 

15. Select the Dim_Category. 
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16. Check the Column names in the first data row checkbox. 

 
 

17. Click Advanced on the left. 

18. Change the Category_ID data type to single-byte signed integer. 

19. Click Next. 

20. Click Next. 

 
 

21. Click Next. 

22. Click Next. 
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23. Click Finish. 

24. Click Close. 

 
 

25. Repeat these steps to import the Dim_Customer and Dim_Product. 

 

Don’t forget to check the Column names in the first data row option and to change the 

Customer_ID, Product_ID data type. 
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26. Repeat these steps to import the Dim_Fact table.  

a. To modify the data types in the fact table: 

i.  Click Advanced on the left of the dialog. 

ii. Click each column name (Date, Year, Year_Quarter, etc) and click the Suggest 

Types… button. 
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iii. Click Next . 

iv. Click Next. 

v. Review the Data Mappings. 

 
 

vi. Click Next. 

vii. Click Next. 

viii. Click Finish. 
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27. Right click the Sports_Warehouse Database Diagrams folder and choose New Database 

Diagram. 

 
 

 

28. Click Yes. 

 
 

29. Select all four tables and click Add. 
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30. Click Close. 

31. Set the primary keys for Dim_Category, Dim_Customer, and Dim_Product tables. 

a. In the Dim_Category table, right-click Category_ID and set it to primary key.  

b. Do the same for Customer_ID and Product_ID. 

 

32. Create relationships between each of the dimension tables and the fact tables. 

a. Click and drag the table title bars to rearrange the tables. 

b. Click and drag the primary keys to the fact tables. 

 

Your completed diagram should look like the image below. 

 
33. Save your relationship diagram.   

 

Note if you get an error message saving the table: Click Tools > Options, select Designers and 

uncheck the Prevent saving changes that require table re-creation option.  Then try to save your 

diagram again. 

 

Solution 2: Create a Sports Data Source Name 
1. Open Windows Explorer and navigate to C:\Windows\SysWOW64\. 

2. Double-click odbcad32. 

3. Click the System DSN tab. 
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4. Click Add… 

 
 

5. Select SQL Server Native Client 10.0. 

 
 

6. Click Finish. 
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7. Type the name Sports and select the SAPDEMO server and click Next>. 

 
 

8. Click Next. 
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9. Check Change the default database to option and select Sports_Warehouse. 

 
 

10. Click Next. 

11. Click Finish. 

12. Click Test Data Source. 

13. Click OK, OK, OK. 

14. Click Start > Control Panel. 

15. Click Administrative Tools. 

16. Double-click Data Sources (ODBC) and repeat steps 3 – 13 to create another DNS named Sports. 

 

Solution 3 – Create a Crystal Report using the Standard Report Creation 

Wizard 
1. Open Crystal Reports 2011 (Start > All Programs > Crystal Reports 2011 > Crystal Reports 2011) 

2. Click File > New > Standard Report… 

3. Expand Create New Connection. 
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4. Expand ODBC (RDO).   

5. If you do not see the ODBC (RDO) dialog, double-click Make New Connection. 

6. Click Sports. 

 
 

7. Click Next. 

8. Type the password Welcome1. 

9. Click Finish. 

10. Expand Sports > Sports_Warehouse > dbo > Tables. 
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11. Double-click Dim_Category, Dim_Fact, Dim_Product. 

 
 

12. Click Next. 

13. Click Next. 

14. Add the Product_Name, Date, and Gross_Sales fields. 

 
 

15. Click Next. 

16. Add Category to group the records by category. 
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17. Click Next. 

18. Click Next. 

19. Click Next. 

20. Click Bar Chart. 

 
 

21. Click Next. 

22. Add Year Quarter to the Filter Fields. 

23. Set the filter is equal to 2010 – Q4. 

 
 

24. Click Next. 
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25. Click Corporate (Blue). 

 
 

26. Click Finish. 

 

The first page of your report should look like this. 

 
 

27. Click the Show Next Page button. 

 
 

The second page of your report should look like this.
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28. Click Golf in the Groups pane on the left. 

 

You should see the data for the Golf category. 

 

 
 

29. Click Show Previous Page. 

 

Notice the total is calculated at the end of each section. 

 
 

30. Right click one of the dates and choose Format Field... 

 
 



Step by Step Activity Solutions  Page 21 

 SAP BusinessObjects Business Intelligence Workbook 1 Solution Guide 

31. Scroll down and select the 1-Mar-1999 format and click OK. 

 
 

32. Click the Align Right button. 

 
 

33. Right click one of the Gross Sales values and choose Format Field... 
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34. Select the Display Currency Symbol option and click OK. 

 
 

35. Click the Design tab. 

36. Move and resize the Category and Product Name columns so that the full product names can be 

displayed. 

37. Right click the Product_Name header and choose Edit Text. 

38. Click inside the header and replace the _ with a space. 

39. Align the Date and Gross Sales titles to the right. 

40. Click Preview 

 

Your report should now look like the image. 

 
 

41. Save your report as Product Gross Sales Q4 2010.
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Solution 4 – Create a Crystal Report in Design View 
1. Open Crystal Reports 2011. 

2. Click New Report. 

3. Use the existing Sports database connection and add the Customers, Facts, and Products tables. 

 
 

4. Click Next. 

5. Double-click the join between Dim_Fact and Dim_Customer. 

 
 

6. Click Enforce Both and click OK. 
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7. Double-click the join between Dim_Fact and Dim_Product. 

8. Choose Enforce Both and click OK. 

9. Click Finish. 

10. Click the Design Tab. 

11. Click and drag to resize the Page Header section of the report. 

 
This allows space for both the Print Date and the Column Headers for each Field. 

 

12. Click View Field Explorer. 

13. Click the + buttons to expand the Database Fields tree. 

 
 

14. Click and drag to add the Customer_Name, Product_Name, Date, and Net_Sales fields to the 

Details section of the report.   
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15. Move and resize the fields to match the image. 

 

 

16. Click the Preview tab. 

17. Right click a Date value and choose Format Field… 

 

If Format Field… is not enabled in the pop-up menu, you may need to click the Stop button on 

the record navigation toolbar. 

 
 

18. Choose the format March 01, 1999 and click OK. 

19. Click one of the Net Sales values to select it. 

20. Resize the column to ensure it is large enough to display the largest values. 

21. Click the Design tab. 

22. Click the Select Expert button and choose Record. 
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23. Select Year_Quarter and click OK. 

 
 

24. Select is equal to. 

25. Choose 2010 – Q4 and click OK. 

 
 

26. Click the Preview tab. 

27. Click Refresh Data. 

28. Use the navigation buttons to review the data. 

 
 

29. Click the Design tab. 

30. Click Select Expert and choose Record. 

31. Click New…  
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32. Click Dim_Product.Product_Name and click OK. 

 
 

33. Choose is like. 

34. Type *Golf* and click OK. 

 
 

35. Click the Preview Tab. 

36. Click Use Saved Data and click OK. 

 
 

Your report should display the data shown here. 
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37. Click Record Sort Expert. 

 
 

38. Add Customer_Name, Date, and Product_Name as Sort fields. 

 
 

The records should be sorted alphabetically by customer, then by date, and finally by product 

name. 
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39. Save the File > Save As… 

 

40. Click Enterprise. 

 
 

41. Type the password Welcome1 and click OK. 

 
 

42. Click Administrator. 

43. Type the file name Golf Equipment Net Sales. 
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44. Click Save. 

 

45. Open the BI launch pad and log in as Administrator. 

46. Click the Documents tab. 

 
 

47. Double-click the Golf Equipment Net Sales Crystal report. 

 

48. The report will open and display the data saved with the report. 
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Solution 5 – Group and Summarize Records in a Crystal Report 
1. Create a new report in Crystal Reports 2011. 

2. Use the Sports connection and add the Customers, Facts, and Products tables and click Next. 

 
 

3. Configure the table joins to enforce joins and click Finish. 

4. Click the Design tab. 

5. Add the Customer_Name, Product_Name, Date and Gross_Sales columns to the report. 

 
 

6. Click the Select Expert and choose Record. 

 
 

7. Click New… 
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8. Choose Dim_Fact.Date is between and select the dates 12/1/2010 and 12/27/2010. 

 
 

9. Click OK. 

10. Click the Preview tab. 

11. Click the Group Expert button. 

 
 

12. Double-click the Customer_Name field and click OK. 

13. The records are now grouped by customer name. 

 
 

14. Right-click a date value and format the date. 

15. Click the Design tab. 

16. Click the Customer_Name field in the Details section of the report and press the Delete key. 
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17. Click the Preview tab.   

 
 

Now the customer name is only listed once for each group. 

 

18. Click the Save button and save the report to the Administrator user folder with the file name 

Product sales by customer. 

 
 

19. Click a Gross_Sales value. 

20. Click Insert Summary. 
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21. Check the Add to all group levels option. 

 
 

Note that you can change the Calculation type.  The available calculations depend on the data 

type of the column that is being summarized.   

 
 

22. Click OK. 

 

23. Click the Design tab. 

 

Note the position of the new summary fields in the group footer and report footer. 
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Summaries are typically used to display calculated values including averages and totals such as 

average sale, or total costs.  Depending on the data type, different summary calculations are 

available including minimum, maximum, and statistical values such as median, mode, standard 

deviation, correlation, covariance and more. 

 

24. Click the Preview tab. 

 

A subtotal is added below each customer group.  A grand total is added to the end of the report. 

 

 

 

Solution 6 – Create a Crystal Report with Parameters 
1. Create a new report in Crystal Reports 2011. 

2. Use the Sports connection and add the Customers and Facts tables. 

3. Configure the joins to enforce relationships. 

4. Use the Field Explorer to add the Customer_Name, Date, Sales_Count, and Gross_Sales fields to 

the report.  

 

Note you can use CTRL + click to select multiple fields and drag them to the report. 
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5. In the Field Explorer right-click Parameter Fields and choose New… 

 

6. Type Customer Name in the name field. 

7. Choose Customer_Name in the Value Field. 

8. Click the Actions button under the Value Field and choose Append all database values. 

 

This pastes all of the Customer Names into a static list of options. 

 
 

9. In the Value Options section scroll down and change the Allow custom values option to False. 

 
 

The “allow custom values” option would allow report consumers to type any value as a 

customer name. 

 

10. Click OK. 
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11. Click the Select Expert and choose Record. 

 
 

12. Click Customer_Name and click OK. 

 
 

13. Choose the is equal to operator. 

 
 

14. Choose {?Customer Name}  

a. Or Click the Formula Editor… button. 

b. Double-click the Customer Name Parameter in the Report Fields list. 
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c. Modify the expression to match the example below. 

 
 

d. Click Save and Close. 

 

15. Click OK. 

 
 

16. Click the Preview tab. 

17. Select a customer and click OK. 

 
 

The report should show records for the customer which you selected. 
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18. Click the Refresh button. 

 
 

19. Choose Prompt for new parameter values. 

 
 

20. Select a different customer and click OK. 

 

21. Click the Design tab. 

22. Double-click the Customer Name parameter in the Field Explorer. 

23. In the value options dialog, change the Allow multiple values option to true. 

 
 

24. Click the Preview tab. 

25. Click the Refresh button. 

26. Choose two or more cities and click OK. 

 

Navigate in the report to see that only records for the selected customers are displayed in the 

report. 

 

27. Click the Design tab. 

28. Use the Field Explorer to add the Year_Quarter field to the Page Header section of the report. 

29. Add another parameter to allow report consumers to select the Year and Quarter using the 

Year_Quarter field. 
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30. User the Record Selector to add another filter. 

 
 

31. Add a text box to the report header (Click Insert > Text Object). 

32. Add a title that reads “Customer Gross Sales in ” followed by the Year and Quarter parameter 

value. 

33. Format the text as a title by modifying font properties. 

34. Format the date values, and group the records by customer. 

35. Delete the customer name field from the detail section of the report. 

36. Add Gross Sales subtotals. 

37. Sort the records by date. 

 

Your completed report should look like the image below. 
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Solution 7 – Create a Dashboard from a Spreadsheet 
1. Open Dashboard Design  

(Click Start > All Programs > Dashboard Design > Dashboard Design). 

2. Click the New button. 

3. Double-click the Home tab in the Excel spreadsheet to minimize the ribbon. 

 
Note you can restore the ribbon by double-clicking Home again. 

 

4. Click the import Spreadsheet button. 

 
 

5. Navigate to Products Crosstab.xlsx  spreadsheet. 

6. Click Open. 

7. The spreadsheet should now include data beginning in row 6. 

 
 

8. Select the range A6:Q7 and copy. 

9. Click in cell A1 and paste. 
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10. Add a radio button control to the canvas.  The Radio Button control is in Components under 

Selectors. 

 
 

11. Click the component and type Category in the Title field. 

 

Note:  You can show or hide the properties pane on the right side of the screen by clicking View 

> Properties.  The Properties dialog allows you to view and modify properties for the component 

currently selected on the canvas. 

  

12. Click the down-arrow button to the right of the Labels field and choose spreadsheet. 

 
 

13. Select the range A7:A11 and click OK. 

 

The radio button options should now list the categories. 
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14. Click the Insertion type list and choose Row. 

 

Insertion Type Description 

Position 
 

When a series is selected, the position of the value within the series is entered in 
the target cell. For example, if the series contains three cells, when the first one is 
selected, a 1 is entered in the destination cell. When the second is selected, a 2 is 
entered and for the final one, a 3 is entered. 
 

Value When a selection is made, the value in the source cell for that selection is entered in 
the destination cell. 
For Bubble, OHLC, XY, Candlestick, and Tree Map charts, the value is based on the 
specified value set. For example, for a Tree Map chart, you might use the values for 
size or for color intensity. 

Row When a selection is made, the row of source data values corresponding to the 
selection is entered in the target row. 
 

Column When a selection is made, the column of source data values corresponding to the 
selection is entered in the destination column. 
 

Range When a selection is made, a value of 1 is entered in the cell in the range 
representing that selection and a value of 0 is entered in the other cells of the 
target 
 

 

15. Click the button to the right of the Source Data field. 

16. Select the range A7:Q11 and click OK. 

17. Click the down-arrow to the right of the Destination field and choose Spreadsheet. 
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18. Select the range A2: Q2 and click OK. 

 
 

The destination is the location in the spreadsheet where the selected data is transferred.  The 

destination range must be blank and large enough to store all the cells in the source range. 

 

19. Click the Behavior tab. 

20. Choose Label in the Selected Item Type list. 

21. Choose Label 1 in the Selected Item Item list. 
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22. Add a column chart to the canvas. 

 
 

23. Click the column chart and configure the titles. 

 
 

 

24. Click the button to the right of By Range. 

25. Select the range A1:Q2. 
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26. Click the Behavior tab. 

27. Check the Ignore Blank Cells In Series and In Values options. 

 
 

28. Click the Preview Button. 

 

29. Test each category option. 

 

By default, the blank cells are not ignored.   Therefore products from many categories are 

displayed in the chart with empty bars. 
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You can remove these blank columns by sorting the data. 

 

30. Check the Enable Sorting By Data option. 

 
 

31. Click the Preview button. 

 

The column graph should now only show columns for cities in the selected country. 

 

 
 

32. Click the Preview button again. 

33. Check the Enable Run-Time Tools option. 
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34. Click the Preview button again.   

 

Move your mouse over the  button in the top left corner of the graph.  Experiment with 

the different options. 

 

 

Solution 8 – Create a Dashboard with a Single Value Input Control 
1. Open Dashboard Designer and create a new dashboard. 

2. Click QuickViews > Show Spreadsheet Only. 

 
 

3. Enter the table of data into the spreadsheet. 

Growth Rate 
    

 
Minimum -50% 

   

 
Maximum 250% 

   

 
Forecast 12% 

   

          2009 2010 2011 2012* 

  Q1 2,660,699.50 3,326,172.20 3,742,988.90 4,192,147.57 

  Q2 2,279,003.00 2,840,650.80 4,006,717.50 4,487,523.60 

  Q3 1,367,840.70 2,879,303.00 3,953,395.30 4,427,802.74 

  Q4 1,788,580.40 3,186,120.00 3,356,041.10 3,758,766.03 

 

4. Click QuickViews > Show My Workspace. 

 

5. Add a Column Chart to the canvas. 
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6. Configure the chart titles and set the data range as required. 

 
 

7. Click the Appearance tab. 

8. Scroll down and select the Enable Hide/Show Chart Series at Run-Time. 

9. Click the Preview button and experiment with the check boxes in the legend. 
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10. Click Preview again. 

11. Add a horizontal slider under the chart. 

12. Resize the slider to slightly less than the width of the chart. 

13. Set the Data and Scale values. 
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14. Click the Behavior tab. 

15. Set the Increment to .01. 

16. Change the Limits to Adjustable. 

17. Ensure that the Enable Interaction option is selected. 
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18. Delete the 2012 Sales Revenue values and enter the formula =E7*(1+$C$4). 

 
 

19. Paste the formula into F8:F10. 

 

20. Click the Preview button. 

 

Note that this data can be displayed by rows or by columns, which will switch the years and 

quarters in the legend and x-axis. 
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Solution 9 – Filter Data by Chart Selection 
1. Open Dashboard Design and create a new dashboard. 

2. Open Products Crosstab.xlsx from the Workbook Resources.  

 

Note:  This data was generated by creating a crosstab based on the Sports universe with a Year 

filter. 

 

3. Calculate annual totals for each category in column N. 

 
 

4. Add a Pie Chart control to the canvas. 

5. Configure the titles and data range.   

 

 
 

6. Remove the legend. (Deselect Enable Legend on the Appearance / Layout tab). 
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1. Configure the properties on the Insertion tab to insert the row of data that corresponds to the 

pie selection in row 2. 

 
 

2. Add a Line Chart to the canvas. 
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3. Configure the Line Chart to display the Gross Sales for the selected pie section (in row 2). 

 
 

4. Click Preview and test the dashboard by selecting different sections of the pie chart. 
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5. Click the Themes button and apply a theme. 

 
 

6. Resize the canvas as required. 

 

 

 

Solution 10 – Create a Sports_Warehouse Universe 

Part 1 - Create a Sports_Warehouse Connection 

1. Open the information design tool  

(Click Start > All Programs > SAP BusinessObjects Enterprise XI 4.0 > SAP BusinessObjects Client 

Tools > Information Design Tool). 

2. Click File > New > Project… 
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3. Type Sports_Warehouse and click Finish. 

 
 

4. Right click the Sports project and choose New > Relational Connection… 

5. Type Sports_Warehouse and click Next. 
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6. Select the Microsoft > SQL Server > ODBC driver and click Next. 

 
 

7. Choose the Sports data source name and click Test Connection. 
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8. Click Next>. 

 
 

9. Click Next> 

10. Click Next 

11. Click Finish. 

12. Expand the Sports_Warehouse project to see the new connection.
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Part 2 - Create a Sports_Warehouse Data Foundation 

1. Click File > New Data Foundation… 

2. Type Sports_Warehouse and click Next>. 

3. Click Next>. 

4. Select the Sports_Warehouse data source and click Finish. 

 
 

5. Click the Insert button and choose Insert Tables… 

 
 

6. Expand the Sports_Warehouse connection and select the following tables: 

a. Dim_Category 

b. Dim_Customer 

c. Dim_Fact 



Step by Step Activity Solutions  Page 61 

 SAP BusinessObjects Business Intelligence Workbook 1 Solution Guide 

d. Dim_Product 

 
 

7. Click Finish.   

 

Note that you can select the Detect keys and Detect joins options to create keys and joins 

automatically.  Join detection examines the tables and data for primary and foreign keys. 

However, automatic key and join detection may not always produce the results that you 

intend.  For example, joins the join type may not meet your needs and sometimes more 

joins will be created that you want.   

 

You can also create keys by right-clicking a column and choosing Primary Key.   

 

8. Set the Primary keys for each dimension table. 

9. Create equi-joins between the dimension and fact tables. 

10. Set the foreign keys for the fact table. 

 

Your data foundation should look like this. 
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11. Click Save. 

 

Part 3– Create a Sports_Warehouse Business Layer 

1. Right-click the Sports project and choose New > Business Layer. 

2. Select Relational Data Source and click Next>. 

3. Type Sports_Warehouse and click Next. 

4. Click the … button. 

5. Select the Sports_Warehouse.dfx and click OK. 
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6. Click Finish. 

 
 

7. The following folders and business objects are created automatically for you. 
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8. Delete the Category Id, Customer Id, and Product Id from the Dim Fact folder.    

These objects are not required, and will only confuse end users of the universe. 

 

9. Convert Sales Count, Net Sales, and Gross Sales into Measures.   

Select all three objects, right-click and choose Turn into measure(s). 

 

10. Select all three measures, right click and choose Change aggregation function > Sum. 

 
Note that the Aggregation Function is currently only used by Web Intelligence.  The best practice 

is to use an aggregation function in the SQL definition select statement.   The SQL definition 

select statement is used by queries in all of the client tools, not just Web Intelligence.  The steps 

with a simple example are completed in another activity later in this workbook. 

 

11. Click Sales Count, and change the name to Quantity. 

12. Change the name of the Year Quarter dimension to Quarter.   

13. Change the SQL definition select statement to: 

 

Right(Dim_Fact.Year_Quarter,2) 
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This function extracts the last 2 characters from the field (for example Q1 or Q2). 

 

14. Right-click the Sports_Warehouse universe, and click New > Folder

 
 

15. Name the folder Figures, and add the description “This folder contains the numbers and values 

that can be summarized in a report.” 

 

16. Drag the three measures into the Figures folder. 

 

17. Remove the word Dim from each of the folder names. 

 

18. Rename the “Fact” folder “Time”. 

 

Part 4– Publish the Universe 

1. Right-click the connection and choose Publish Connection to a Repository. 

2. Enter these credentials and click Next. 

System Name:  SAPDEMO:6400 

User Name:  Administrator 
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Password: Welcome1 

 
 

3. Click Finish. 

 
 

4. Click Yes. 
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5. Click Close. 

6. Double-click the data foundation (Sports_Warehouse.dfx). 

7. Click Change Connection. 

 

 

8. Select the new secured connection (Sports_Warehouse.cns) and click OK. 

 
 

9. Click File > Save All… 
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10. Right click the business layer (Sports_Warehouse.blx) and choose Publish > To a Repository… 

 
 

11. Click the Check all link. 
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12. Click Check Integrity. 

 
13. Click Next> . 

 

14. Click Finish. 

15. Click Close. 

 

Part 5– Test the universe 

1. Open the BI launch pad (Start > All Programs > SAP BusinessObjects Enterprise XI 4.0 > SAP 

BusinessObjects Client Tools >SAP BusinessObjects Enterprise Java BI launch pad. 

2. Login as Administrator with the password Welcome1. 

3. Click Interactive Analysis (Web Intelligence). 

4. Click New. 
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5. Select Universe and click OK. 

 
 

6. Select Sports_Warehouse.unx and click Select.

 
 

7. Add the following objects to the Query Results pane: 

a. Category 
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b. Year 

c. Product Name 

d. Gross Sales 

 

 

 

8. Click Run Query. 

 

Note:  You may see an error message if you have not created a DSN for both 32-bit and 64-bit 

database connectivity.  Ensure that you create two DSNs with the same name.
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9. Check “Don’t notify me again.” and click OK. 

 

You should see a report similar to the image below. 

 
 

10. Click the Data Button on the toolbar. 

 
 

11. Click Edit 

 
 

12. Add the Net Sales measure. 

 
 

13. Click Run Query. 

14. Click Design 
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15. Drag the Net Sales measure to the right of the Gross Sales column in the table. 

16. Resize the columns. 

 
 

17. Right Click the new Net Sales column and choose Insert > Insert column on right.  

 

 
 

18. Click in the new column and then click the Create Variable button. 

 

 
 

19. Type Discount in the name field. 

20. Choose Measure in the qualification list. 
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21. Enter the formula = [Gross Sales] – [Net Sales]. 

 
 

22. Click OK. 

23. Click and drag the new Discount variable to the right of the Gross Sales Column. 

 

 

24. Delete the Product Name and Discount columns from the report.  You can right click and choose 

Delete, or drag the column headings out of the report. 

 

You should see the following results. 
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Solution 11 - Create Additional Universe Objects 
1. Open the information design tool  

2. Double click the Sports.blx business layer. 

3. Expand all of the folders to view each object. 

4. Right click the Time folder and choose New > Dimension. 

5. Type “Month” in the Name field. 

6. In the Select text box enter the formula: 
DATENAME(month, Dim_Fact.Date). 

 

 

7. Right-click the Month object and choose New > Attribute. 

8. Type “Month number” in the Name field. 

9. Change the Data type to numeric. 
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10. In the business layer, right-click the Figures folder and choose New > Measure. 

 
 

11. Type the name Discount. 

12. Type “Gross Sales – Net Sales” in the description. 

 
 

13. Click the SQL assistant… button to the right of the Select text box. 

 

14. Expand the Dim_Fact table. 

 
 

15. Double click Gross_Sales. 

16. Click in the SQL Expression box and type “-”. 



Step by Step Activity Solutions  Page 77 

 SAP BusinessObjects Business Intelligence Workbook 1 Solution Guide 

17. Double click Net_Sales. 

 
 

This formula calculates the discount (Gross Sales – Net Sales). 

 

18. Click OK. 

 

19. Double click the Year object and change the SQL definition select statement to 
CAST(Dim_Fact.Year as VarChar(4)) 

20. Change the data type of the Year object to String.  

 

Your universe should now contain the following objects. 

 
 

21. Click File > Save All… 

22. Publish the business layer.  (Right-click Sports.blx and choose Publish > To a repository…    

Review Solution 10 Part 4 for more information). 

 

23. Log into the BI launch pad.   

24. Create a New Web Intelligence document using the Sports universe. 
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25. Add Category, Gross Sales, Net Sales, and the new Discount measure. 

 
 

26. Click Run Query. 

 

Your report should return these values. 

 
 

Solution 12– Optimize Performance with Index Awareness 
1. Open the information design tool and open the Sports.blx business layer. 

2. Add index awareness to the Category, Customer name, and Product name dimensions. 

a. Click Category. 

b. Click the Keys tab. 

c. Click Add Key. 

d. Click Select in the new row. 

e. Click … 

 
f. Expand Dim_Category. 

g. Double-click Category_ID. 

h. Repeat steps a – f for the Customer name and Product name dimensions. 
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3. Save and publish the universe. 

Solution 13 – Testing the Universe in Web Intelligence. 
1. Log into the BI launch pad 

2. Open Web Intelligence (Interactive Analysis) from My Applications. 

 

 
 

3. Click Universe. 
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4. Double-click Sports.unx 

 
 

5. Open the folders and double-click Category, Year, and Gross Sales. 

6. Drag the Year dimension to the Query Filters.   
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7. Modify the filter:  Year Equal to 2010. 

 
 

8. Click Run Query in the top right corner. 

9. Double-click the right border of the Gross Sales column to resize it. 

 
 

 

10. Click New. 



Step by Step Activity Solutions  Page 82 

 SAP BusinessObjects Business Intelligence Workbook 1 Solution Guide 

11. Click No. 

 
 

12. Double-click Universe. 

13. Double-click Sports.unx. 

14. Open the folders and double-click Customer Name, Year, and Gross Sales objects 

15. Drag the Year dimension to the Query Filters.   

16. Modify the filter:  Year Equal to 2010. 

 
 

17. Click Run Query. 

18. Click Analysis. 

19.  Click anywhere in the Gross Sales column. 
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20. Click Ranking. 

 
 

21. Change the Top value to 5. 

 
 

22. Click OK. 

23. Double-click the right border of the Customer Name column to resize it. 

 
 

24. Click New. 
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25. Click No. 

 
 

26. Double-click Universe. 

27. Double-click Sports.unx. 

28. Open the folders and double-click Product Name, Customer Name , and Quantity. 

29. Add a year equal to 2010 filter. 

 
 

30. Click Run Query. 

31. Resize the columns as required. 

32. Click Edit. 

 
33. Drag Product Name to the Query Filters pane. 
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34. Click the down-arrow button to the right of the filter and choose Prompt. 

 
 

35. Click Run query. 

36. Type golf and click the Search button. 
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37. Select all three golf products and click the add  button. 

 
 

38. Click OK. 

 

39. Resize the columns as required. 

 
 

40. Click Analysis. 

 
 

41. Click anywhere in the Product Name column. 
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42. Click the Break button. 

 
 

The document is now broken into three tables, one for each product.  Scroll down the report to 

view the Clone Golf Clubs table. 

 

43. Click Undo. 

 
 

44. Scroll up to the top of the table. 

 

45. Click and drag a cell from the Product Name column above the table. 

 

 
 

The report is no2 broken into sections, with one table for each section.  Each section includes a 

header with the Product Name above the table. 

 

44. Click Undo. 
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Answer the following questions. 

1. In Q4, 2010 which category had the highest Net Sales? 

 
 

 
 

2. Who were the top 5 customers in Gross Sales for 2010? 
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3. Which customers purchased Golf Clubs?  Which type did they buy and how many? 
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Solution 14 – Creating a Dashboard 

Part 1– Create a Dashboard 

In this activity you will use a universe query as your dashboard’s data source.  Follow the steps to see 

how the Dashboard Design query builder retrieves data from the universe. 

1. Open Dashboard Design. 

(Click Start > All Programs > Dashboard Design > Dashboard Design). 

 

2. Click No. 
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3. Click New. 

 
 

4. Click Add Query… 

 
 

5. Type the password Welcome1 and click OK. 
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6. Click the Sports.unx universe and click Next. 

 
 

7. Add Year, Category, Quantity, Net Sales, Gross Sales, and Discount. 
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8. Add the filter Year Equal to 2010 and click Next. 
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9. Click Next. 

 
Note that the Dashboard Design Query Builder does not aggregate the fact records.  In Web 

Intelligence, this query would return a single row for each Category and Year, and display the 

total value for each measure. 

 

10. Click Cancel. 

 

Part 2 – Modify the Measure Objects 

In this activity you will add the SQL Sum function to the measures in the Sports universe.  This will 

ensure that values can be grouped and aggregated in Dashboard Design queries.  Without the Sum 

function, the Query Builder in Dashboard Design does not group records and sum values. 

1. Open the Information Design Tool. 

2. Open the Sports.blx business layer. 

3. Click the Quantity measure. 

4. Change the SQL definition Select: statement to 

 

SUM (Dim_Fact.Sales_Count) 
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5. Modify the remaining measure to use the SUM() function. 

 
SUM(Dim_Fact.Net_Sales) 

SUM(Dim_Fact.Gross_Sales) 

SUM(Dim_Fact.Gross_Sales-Dim_Fact.Net_Sales) 

 

6. Click File > Save All… 

 

7. Right click Sports.blx and choose Publish > To a Repository… 

 

 

Part 3 – Create a Dashboard Column Chart 

In this activity you will use a universe query as your dashboard’s data source. 

1. Open Dashboard Design.  

2. Click No. 
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3. Click New. 

 
 

4. Click Add Query… 

 
 

5. Type the password Welcome1 and click OK. 
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6. Click the Sports.unx universe and click Next. 

 
 

7. Add Year, Category, Quantity, Net Sales, Gross Sales, and Discount. 

8. Add the filter Year Equal to 2010 and click Next. 
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9. Click Next. 

 
Note that the Dashboard Design Query Builder now aggregates the fact records correctly.  This 

query can be used to create a variety of visualizations. 

 

10. Click Next. 

 
 

11. Click OK. 
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12. Drag a Column Chart onto the Canvas. 

 
 

13. Enter the titles shown below. 

 
 

14. Scroll down and click By Series. 

 
 

15. Click the + button to add a new series. 

16. Type the name Net Sales. 
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17. Click the menu button beside the Values(Y) field and click Query Data. 

 
 

18. Click Net Sales. 

19. Click OK. 

20. Click + to add another series. 

21. Type the name Gross Sales. 

22. Click the menu button beside the Values(Y) field and click Query Data. 

23. Click Gross Sales and click OK. 

24. Click the menu button beside the Category Labels (X) field and click Query Data. 

25. Click Category and click OK. 

26. Resize the graph. 

27. Click the Fit Canvas to Component button. 

 

 
 

28. Click the Preview button. 
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Your dashboard should look like the following image: 

 
 

29. Click the Preview button again. 

30. Click Save. 

31. Type the name Sales by Category 2010. 

 

 

Part 4 – Save the Dashboard to the BI Platform 

1. Click File > Save to Platform. 

2. Type your login credentials. 

3. Enter a suitable name and location for the Dashboard. 

 
 

4. Click Save. 

5. Login to the BI launch pad. 

6. Click the Documents tab. 
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7. Navigate to the folder where you saved the Dashboard. 

 
 

8. Double click the dashboard to view it. 

 
 

Because SAP BusinessObjects Dashboards publishes to the Adobe flash format, your dashboards 

are subject to the Adobe security restrictions.  To access data across domains you must create a 

cross domain policy file. 

 

9. Copy and Paste the following into a text editor. 

 
< ? x m l  v e r s i o n = " 1 . 0 " ? >  

< ! D O C T Y P E  c r o s s - d o m a i n - p o l i c y  S Y S T E M  

" h t t p : / / w w w . m a c r o m e d i a . c o m / x m l / d t d s / c r o s s - d o m a i n - p o l i c y . d t d  " >  

< c r o s s - d o m a i n - p o l i c y >  

< a l l o w - h t t p - r e q u e s t - h e a d e r s - f r o m  d o m a i n = " * "  h e a d e r s = " * "  

s e c u r e = " f a l s e "  / >  

< a l l o w - a c c e s s - f r o m  d o m a i n = " * "  s e c u r e = " f a l s e "  / >  

< / c r o s s - d o m a i n - p o l i c y >  

 

10. Save the file as crossdomain.xml in  

 

 

For more information see 7.1.2.1 To create a cross-domain policy file in the user guide. 

11.  
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12.  

 

13.  
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Solution 15 – Create an Interactive Dashboard 
 

Part 1 – Create a Universe Query 

1. Open SAP BusinessObjects Dashboards. 

2. Click File > New > New. 

3. Click Add Query. 

4. Select the Sports.unx universe. 

5. Create a query including Category, Year, Net Sales, Gross Sales, and Discount 

6. Drag the Year dimension to the Filters pane. 

 
 

7. Select Prompt. 

8. Check Set default value(s)  

 
 

9. Click the … button 

10. Choose 2010 as the default value. 

 
11. Click OK. 

12. Click OK. 

13. Drag Quarter to the Filters pane. 
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14. Choose Prompt and set the default value to Q4. 

 

 
 

15. Click Next. 
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16. Click Run. 

 
 

17. Click Next. 

 
 

18. Click OK. 

Part 2 – Add Query Prompts 

1. Click the Universe Connectivity tab. 

2. Drag a Query Prompt Selector control onto the canvas.  You will find the Query Prompt Selector 

under Components in Universe Connectivity.
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3. Click the Source Prompt drop down list and choose Enter Year: (Equal). 

 
 

4. Click cell A1 in the Spreadsheet and type Year. 

5. Click the Insert Selected Items: button. 

 
 

6. Click cell B1 and click OK. 

7. Scroll down and select Refresh When Selection Changes. 
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8. Drag another Query Prompt Selector component onto the canvas. 

9. Select Enter Quarter: (Equal) in the Source Prompt drop down list. 

 
 

10. Repeat steps 4 to 7 to configure the Query Prompt Selector. 

11. Click cell A3 and type Subtitle. 

12. Click cell B3 and enter the formula  

 

=B1 & “ – “ & B2. 

 

This formula will create a subtitle based on the selection in the Query Prompt Selectors.  For 

example “2010 – Q4”. 

Part 3 – Add a Tab Control 

1. Click Containers. 

2. Scroll down. 

3. Drag a Tab Set onto the canvas. 

 
 

4. Click the Tab 1 and click the + button. 
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5. Type Net Sales and click OK. 

 
 

6. Click the + button. 

7. Type Gross Sales and click OK. 

8. Click the + button again and add a Discount tab. 

9. Click Tab 1. 

10. Click the – button. 

 

Part 4 – Add a Net Sales Pie Chart 

 

1. Click the Net Sales tab. 
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2. Drag a Pie Chart into the Net Sales tab. 

 
 

3. Click the Pie Chart. 

4. Change the chart title to Net Sales. 

5. Click the down-arrow to the right of the Subtitle field. 

6. Click cell B3 and click OK. 
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7. Click the down-arrow on the button to the right of the data Values field. 

 
 

8. Click Query Data. 

9. Click Net Sales and click OK. 

 
 

10. Click the down-arrow to the right of the Labels field. 
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11. Click Query Data. 

12. Click Category and click OK. 

13. Click Preview. 

14. Type the password Welcome1 if required. 

15. Test the Query Prompt Selectors by choosing different year and quarter values. 

16. Click Preview to return to design mode. 

 

Part 5 – Add a Gross Sales Pie Chart 

1. Right-click the Net Sales Pie Chart and choose Copy. 

2. Click the Gross Sales tab. 

3. Click inside the Gross Sales control to select it. 

 
 

 

4. Right-click in the Gross Sales control and choose Paste. 

5. Repeat the steps from the previous activity to configure the chart to display Gross Sales. 

6. Click Preview. 

7. Test the Query Prompt Selector controls and switch between the tabs.   

 

Notice that changing the prompt values updates both pie charts. 

 

8. Click Preview to return to design mode. 
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Part 6 – Create a Discount Column Chart 

1. Click the Discount Tab. 

2. Drag a Column chart into the Discount tab control. 

3. Enter title values. 

 
 

4. Click the By Series option. 

5. Click the + button. 

6. Type Category in the Name field. 

7. Add the Discount measure in the Values(Y) field. 
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8. Add the Category Dimension in the Category Labels(x) field. 

 
 

9. Click Preview. 

 

10. Test the dashboard. 

 

11. Click Preview to return to design mode. 

 

 

Part 7 – Format the Canvas and Apply a Theme 

1. Resign the Query Prompt Selectors. 

2. Use the Alignment toolbar buttons to position the controls. 
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3. Click the Fit Canvas to Components button. 

 
 

4. Click the Increase Canvas button to add a border. 

 
 

5. Click Format > Theme. 

 

6. Select a Theme and click OK. 

 
 

7. Click Preview and test the Dashboard. 

 

Solution 16 - Create a Crystal Report using Crystal Reports for Enterprise 
1. Log into the BI Launch pad. 

2. Click Crystal Reports for Enterprise in My Applications. 
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3. Click Open to launch the Crystal Reports for Enterprise application. 

 
 

4. Click Sports.unx and click Next. 

 
 

5. Add Category, Quantity, and Gross Sales to the Results Objects pane. 

6. Add a Year filter which prompts the report consumer to select a year. 
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7. Click Finish. 

 
 

8. Select the year 2010 and click OK. 

 

 

9. Your report should look like the image below. 
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Solution 17 – Create a Crystal Report with a Crosstab 
1. Log into the BI Launch pad. 

2. Click Crystal Reports for Enterprise in My Applications. 

 
 

3. Click Open to launch the Crystal Reports for Enterprise application. 

 
 

4. Click Sports.unx and click Next. 
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5. Add Category, Year, Quarter, and Gross Sales to the Results Objects pane. 

 
 

6. Click Finish. 

7. Click any value in the year column to select it. 

8. Click and drag the Year smart guideline and drag it over the Category smart guideline.   

 
 

This will switch the order of the Year and Category columns in the report. 
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9. Right-click any value in the year column and choose Group on Year… 

 
 

10. Click any value in the Year column and press the Delete key. 

 

11. Click Structure. 

 
 

12. Click Cross-tab. 
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13. Click the Column drop-down and choose Year. 

 
 

14. Click the + to the right of the Column field. 

 
 

15. Choose Quarter in the second column drop-down. 

 

16. Change the total to Sum of Net Sales and click Insert. 
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17. Click in the Group Footer section of the report to place the Crosstab. 

 
 

18. Click Page. 

19. Click and drag to move the crosstab so that it will fit on a single page. 

 
 

Notice that a gridline appears as you drag the crosstab to the left. 

 

20. Click and drag the Group Footer selector to make the group footer larger. 
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21. Click and drag the Crosstab to add white space around it. 

 
 

22. Click Save and save the report in My Favorites as Net Sales Summary. 
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Solution 18 – Create a Simple Alert 
1. Log into the BI Launch pad. 

2. Click Crystal Reports for Enterprise in My Applications. 

 
 

3. Click Open to launch the Crystal Reports for Enterprise application. 

 
 

4. Click Sports.unx and click Next. 

 
 

5. Add Year, Month, Month Number, Category, and Gross Sales to the Results Objects pane. 

 

6. Right-click a year value and choose Group on Year… 
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7. Right-click a Month number and choose Sort on Month number > Ascending. 

8. Right-click a Month number and choose Group on Month number… 

9. Right-click a Month number and choose Delete. 

10. Right-click a Gross Sales value and choose Total Gross Sales… 

 
 

11. Click Insert. 

12. Right-click any Total Gross Sales value and choose Conditional Formatting… 

13. Click Add Condition. 

14. Change the condition to: 

 Sum of Gross Sales Less Than or Equal to 15,000,000 

 

 

15. Change the following properties: 

Font Color (White) 

Font Style (Bold) 

Background Color (Red) 
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16. Click OK. 

17. Click Save and type the name Monthly Gross Sales. 

18. Click Data > Alerts… 

19. Click New.  

 
 

20. Type the name Missed Monthly Sales Target. 

 

21. Click the Condition (fx). 

 

22.  Double-click Group Footer 2 (Month number). 
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23. Type < 15000000.

 

 

24. Click Save and Close 
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25. Type “At least one monthly sales target has been missed”.  

 
 

26. Click OK. 

27. Click Save. 

28. Click Refresh. 
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29. Click Triggered Alerts. 

 
 

30. Click Missed Monthly Sales Target. 

 
 

Notice that the report is filtered to display only data for months where the Total Gross Sales are 

less than 15 million. 
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31. Click Deselect All. 

 
 

With the alert deselected, the report should display data for all months. 

 

Note that you can optionally include a Pop-up alert when the report is opened. 

 

Solution 19 – Subscribe to an Alert 
1. Log into the BI Platform. 

2. Click Documents. 

 

Notice that the icon for the Monthly Gross Sales report is different from any of the other Crystal 

Reports.  The orange circle with an exclamation point indicates that this report includes an alert. 
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3. Right-click Monthly Gross Sales and choose Subscribe. 

 
 

4. Select Missed Monthly Sales Target (1). 

 
 

5. Click Destinations. 

6. Select My Alerts. 

 
 

7. Click Save and Close. 
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8. Click Subscribed Alerts. 

 
 

9. Click My Favorites. 

10. Right-click Monthly Gross Sales and choose Schedule. 

11. Click Recurrence. 

 
 

12. Click Schedule in the bottom left corner. 

 

 

Once the report has run, a date will be added to the Last Run column.   
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13. Click My Alerts. 

 
 

14. Right-click Missed Monthly Sales Target (1) and choose Alert Details. 

 
 

15. Click OK. 

16. Click Favorites 

17. Double-click the Monthly Gross Sales report to open it. 
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Solution 20 – Create an Information Space 
1. Open the BI launch pad. 

2. Click Explorer in My Applications. 

 
 

3. Click Manage Spaces 

 

 

4. Expand Universes 

 
 

5. Click Sports.unx 
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6. Click New. 

 

 

7. Type Sports in the Name field. 

 

 

8. Click the Objects tab. 
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9. Add the objects and measures shown below. 

 
 

10. Click Validate 

 

11. Click OK. 

 

12. Click OK. 

 

13. Click the Build Index button. 
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Solution 21– Explore the Sports Information Space 
1. Login to the BI launch pad 

2. Click Explorer in My Applications 

3. Click the Sports information space 

4. Click 2010 

5. Click Q4 2010 

6. Click the Net Sales (SUM) measure. 

 
 

7. Click the percentage button and choose a Pie graph. 

 
 

 
 

8. Click Bookmark. 
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9. Click the x to delete the 2010 Q4 filter. 

 
 

10. Click the displaying list and check Gross Sales. 

 
 

11. Click Comparison and choose a column graph. 
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12. Click Category and choose Year Quarter. 

 
 

13. Click the right side of the Year Quarter column in the data table and choose A to Z. 

 
 

Your visualization should now look like the image. 
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Solution 22 –Explore a Microsoft Excel Spreadsheet 
1. Open the BI Launch pad. 

2. Open Explorer 

 
3. Click the Browse… button to the right of the Select a File textbox in the bottom of the Explorer 

window. 

 
 

4. Navigate to the C:\_Kits\Sample_Databases folder. 

5. Click the eFashionStoreSales spreadsheet and click Open. 

6. Click Preview and Configure 

 
 

7. Change the Year, Month, and Week data types to Label – because these values would not be 

totaled.   
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8. Click OK. 

You can explore the spreadsheet dataset the same way you explore an Information Space. 

 

 
 

For example, you can drill into the data to visualize the performance of stores in Texas in a 

specific year and quarter. 
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Solution 23 –Create an Information Space Based on a Spreadsheet 
1. Open the BI launch pad. 

2. Click the Documents tab. 

3. Right-click the right hand pane and choose New > Local Document. 

 
 

4. Click Folders in the bottom left of the screen. 

5. Click Browse… and select C:\_Kits\Sample_Databases\eFashionStoreSales.xlsx 

 

 

6. Click Add. 
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7. Right-click the eFashionStoreSales spreadsheet and choose Organize > Cut. 

 
 

8. Click Folders in the bottom left corner of the screen. 

9. Double click Public Folders 

10. Right-click and choose New > Folder. 

 
 

11. Type the name Spreadsheets and click OK. 

12. Double-click the Spreadsheets folder. 
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13. Right-click and choose Organize > Paste. 

 
 

14. Click the Home tab. 

15. Open Explorer from My Applications. 

16. Click Manage Spaces. 

17. Navigate to Excel Spreadsheets > Public Folders > Spreadsheets > eFashionStoreSales. 

 
 

18. Click the New button to create a new Information Space. 
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19. Type the name eFashion Store Sales. 

 
 

20. Click the Configure Excel File  tab. 

21. Change the data type of Year, Month, and Week to Label. 

 
 

22. Click OK. 
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23. Click the Index Now button on the right. 

 
 

24. Click the Home tab. 

25. Click Refresh list on the top right. 

 
 

The new Information Space will appear in the list. 

 
 

Solution 24 – Create a Web Intelligence Document 
1. Log into the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Click New… 
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4. Click Universe. 

 
 

5. Double-click Sports.unix 

 
 

6. Open the folders and double-click Category, Product Name, Date, and Gross Sales. 
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7. Drag the Year dimension to the Query Filters.   

8. Modify the filter:  Year Equal to 2010. 

 
 

9. Click Run Query in the top right corner. 

10. Click and drag the Product Name column border to resize the column. 

 
 

11. Click Save. 
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12. Type the file Name Product Gross Sales By Category. 

 
 

13. Click Save. 
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Solution 25 – Create a Web Intelligence Document using Web 

Intelligence Desktop 
1. Click Start > All Programs > SAP BusinessObjects Enterprise  XI 4.0 > SAP BusinessObjects 

Enterprise Client Tools >  Interactive Analysis Desktop or Web Intelligence Rich Client). 

2. Enter the login credentials including the password Welcome1 and click Log On. 

 
 

3.  Select the Sports.unx universe. 

4. Add Customer Name, Product Name, Date, and Gross Sales. 
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5. Add the filter Year Equal to 2010. 

 
 

6. Click Run query. 

7. Resize the Customer Name and Product Name columns. 

8. Click Save. 

9. Type the file name Product Gross Sales by Customer. 

10. Click the down-arrow beside the Save button and choose Publish to… 
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11. Click Save. 

 
 

Note that you can publish Web Intelligence documents to public folders to share with multiple 

users. 

 

You can also use Save As… to save a Web Intelligence document as a PDF or spreadsheet. 

 

12. Close the Interactive Analysis Desktop client. 

 

Solution 26 – Insert breaks, totals and subtotals  
1. Open the BI launch pad. 

2. Click Documents. 

3. Double-click Product Gross Sales by Category. 
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4. Click the Don’t notify me again option and click OK. 

 
 

5. Click Design in the top right corner. 

 
 

6. Click a cell in the Category column to select it. 

7. Click Break. 

 
 

8. Scroll down to view the footer row to each category. 
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9. Click in the Category column to select it. 

10. Click Set as Section. 

 
Each section has a title with the category name.

 
 

11. Scroll down to the bottom of the Bikes table. 

12. Right click the cell in the bottom right corner of the table. 

 
 

13. Double click the right hand border of the new cell to resize the column. 
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14. Click the Navigation Map button to the left of the report. 

 
 

15. Expand Report 1 and click a category name to navigate to that section of the report. 

 
 

16. Click Save. 

 

 



Step by Step Activity Solutions  Page 156 

 SAP BusinessObjects Business Intelligence Workbook 1 Solution Guide 
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Solution 27 – Sorting and Ranking 
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Create a new Web Intelligence document using the Sports universe. 

4. Add the Year, Category, Product Name, and Net Sales objects. 

 

 

5. Click Run Query. 

 

By default the records are sorted from left to right to the order they are presented in the 

document.  In this example the records are sorted first by year, and then by category.  Within 

each category the records are sorted alphabetically by product name. 

 
 

Click and drag the year column header to the right of the Product Name column header. 

 
 

Changing the order of the columns can change the order in which the records are sorted.   
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Now the same records are sorted first by Category, and then alphabetically by product name.  

Within each product name, the records are sorted by Year. 

 
 

6. Click the Analysis tab. 

 
 

7. Click in the Net Sales column. 

8. Click the Sort button. 

 
 

9. The records are now sorted in ascending order (lowest to highest) by Net Sales. 

 
 

Note you should format the Net Sales as currency, and it will be easier to view the sorted values. 
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10. Click the down-arrow to the right of the Sort button and choose Remove All Sorts. 

 
 

The records will be resorted in the default order. 

 

 

11. Click the down-arrow to the right of the Sort button and choose Manage Sorts. 

12. Click Add. 
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13. Click Product Name and click OK. 

 
 

14. Click Add and choose Net Sales. 
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15. Click OK. 

 
 

The records are now sorted alphabetically by product name and in ascending order by Net Sales.  

Note that the Crochet Cycling Gloves sold more in 2010 than in 2009.  Net sales of most 

products increased, but sales of Crochet Cycling Gloves decreased. 

 

16. Click in the Net Sales column.  

17. Click the down-arrow to the right of Sort and choose Descending. 

 

Records are still sorted alphabetically by product name, but are now sorted in from highest to 

lowest Net Sales. 

 

Solution 28 – Modify a Web Intelligence Query and Document 
1. Open the BI launch pad. 

2. Open Web Intelligence (Interactive Analysis) from My Applications. 

3. Click Open. 

 
 

4. Click Product Gross Sales by Category.   

This is the document you created in the first Web Intelligence activity. 
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5. Click Open. 

6. Click Design. 

 

 

7. Click the Data Access tab. 

8. Click Edit. 
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9. Add the Quantity, Net Sales, and Discount measures. 

 

 

10. Click Run Query. 

Note that the existing table in the document does not change; however, the new measures are 

listed on the left panel under Available Objects. 

 

 

You can add objects to an existing table, by dragging and dropping them to the left or right of 

any existing column. 
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Or you can drag and drop objects to a new location to create a completely new table using the 

selected objects. 

 
 

11. Add a table to the right of the existing table that displays net Quantity, Net Sales, and Gross 

Sales for each product. 
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12. Use the Report Map to find a new table with the new data for each Category. 

 

 

13. Save the report. 

 

Solution 29 – Filter the Data in a Web Intelligence Document  
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Create a new Web Intelligence document using the Sports universe. 

4. Add the Customer Name, Category, Product Name, Gross Sales and Net Sales to the report. 

5. Add the filter Year is equal to 2010. 

6. Add the filter Quarter is equal to Q4. 

 
 

Note that the “And” keyword in the Query Filters pane means that only records where both the 

Year and Quarter criteria have been met will be returned to the report. 

 

7. Click Run Query 
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8. Double-click the title.  Erase the formula and type “Product Sales”. 

 

9. Resize the columns to best display the data. 

 
 

10. Click the Input Control button on the left sidebar . 

 
 

11. Click New. 
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12. Click Category and click Next. 

 
 

13. Click Radio buttons and click Next. 
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14. Click Next. 

 
 

15. Click Finish. 

 

16. Click Golf. 

 
 

Notice that only sales of Golf products are displayed in the report. 

 

17. Click New. 

18. Click Product Name and click Next. 
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19. Click Check boxes and click Next. 

 
 

20. Click Finish. 

21. Filter the report by experimenting with both the Category and Product name input controls. 

22. Click New. 

23. Click Customer Name and click Next. 

24. Click List box and click Next. 
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25. Click the Reset button. 

 
 

26. Use CTRL+click to select two or more customers and click OK. 

 
 

27. Click the Data Access tab. 

 
 

28. Click Edit. 
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29. Modify the query filters to prompt for the Year and Quarter. 

 
30. Click Run Query. 

31. Select Q1, 2009 

32. Save the document as Product Sales. 

 

Solution 30 – Add a Chart to a Web Intelligence Document  
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Create a new Web Intelligence document using the Sports universe. 

4. Add the Category, Year, Quarter, Gross Sales and Net Sales to the report. 

5. Run the query. 

6. Resize the columns as required. 

7. Right-click Year and choose Set as Section. 

8. Right-click Quarter and choose Set as Section. 

9. Click the border of the top table to select it. 

10. Right-click and choose Copy. 

11. Right-click to the right of the table and choose Paste. 

 

Your report should now include a duplicate table for each section. 
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12. Right-click the table on the right and choose Turn Into > Pie. 

13. Right-click the Pie chart and choose Format Chart… 

14. Click the Data Values tab on the left. 

15. Select the Show Data Labels Option. 

16. Choose Label and Percent in the Data Type list. 

 
 

17. Click the Title Tab. 

18. Select the Visible option. 

19. Type the title Net Sales. 

20. Click the Legend tab. 

21. Deselect the Visible option. 
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22. Click OK. 

 
 

23. Click the Report Map button and navigate the report using the tree. 

 
 

24. Save the report as Sales by Category. 

 

Solution 31 – Drill into a Web Intelligence Document using Default 

Navigation Paths 
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Create a new Web Intelligence document using the Sports universe. 

4. Add Category ID, Date, Gross Sales and Net Sales to the report. 

5. Click Run Query. 

6. Click Analysis. 
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7. Click Drill. 

 
 

Because Category Id and Date are both included in a navigation path, the values in these 

columns are now hyperlinks.  Users can click the hyperlinks to “drill” into the data following the 

navigation path.   

 

8. Click a value in the Category Id column. 

 
 

The report now shows the name for the selected category (Category Id=1).  Category is the 

second object in the Category navigation path, and includes the category name. 

 

9. Click the first date in the Date column (1/5/09). 

 
 

The report now shows the total Net Sales and Gross Sales for the year 2009.  Year is the second 

object in the Fact Navigation path. 

 

10. Click 2009. 
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Solution 32 – Create a Custom Navigation Path in the Universe 
1. Open the information design tool. 

2. Open the Sports project and double-click the Sports.blx business layer. 

3. Click the Navigation Paths tab. 

 
 

4. Click Custom. 

5. Click the Insert Navigation Path button. 

 
 

6. Type the name Products. 

 

7. Click Add… 
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8. Click Category and click OK. 

 
 

9. Click Add… 

10. Click Product Name and click OK. 

11. Click Add… 

12. Click Customer Name and click OK. 

 

13. Click the Insert Navigation Path button. 

 
 

14. Type the name Time. 

15. Add Year, Quarter, Month, and then Date. 

 

16. Click file and choose Save All… 

17. Right click Sports.unx and choose Publish > To a Repository… 
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Solution 33 – Creating Drillable Web Intelligence Documents  
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Create a new Web Intelligence document using the Sports universe. 

4. Add the Category, Year, Gross Sales and Net Sales to the report. 

5. Run the query. 

6. Resize the columns as required. 

 
 

7. Click Reading. 

 
 

8. Click the Drill button. 

 
 

The data in the table is converted into hyperlinks.  
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9. Click Bikes. 

 

The data is filtered. Only Bike sales are displayed in the table. 

 

10. Click Design. 

 
 

11. Resize the product name column so that the complete names are displayed. 

 
 

12. Click 2010. 

 

Only bike sales from 2010 are displayed. 

 
 

13. Click Q4. 

 

The filters applied to the table are displayed in the toolbar above the document. 
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Users can drill across the data by selecting different values in the toolbar.  For example, try 

changing the category filter from Bikes to Golf.  Try changing the Quarter filter to a different 

quarter. 

 

 
 

Users can also drill up to a higher level by clicking the drill up  buttons in the column 

headers.  For example you could drill up from Month to Quarter. 

 

14. Click the Design. 

 

15. Click Edit. 
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16. Click Scope of Analysis panel 

 
 

17. Click the Scope level list in the bottom right corner of the Query Panel and choose three levels. 
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Solution 34 – Create a Web Intelligence Document with a Crosstab. 
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Create a new Web Intelligence document using the Sports universe. 

4. Add the Category, Year, Quarter, and Gross Sales to the report. 

5. Run the query. 

 
 

6. Right-click anywhere in the table and choose Turn Into > Crosstab. 
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7. The table in converted into a crosstab, which displays the Gross Sales for each quarter. 

 
 

8. Click and drag the category column heading to the left of the quarter heading. 

 
 

9. Right-click one of the category headings and choose Set as Section 

 
 

10. Change the report title to Gross Sales. 

11. Save the report as Gross Sales Crosstab. 
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Solution 35 – Add another query to a Web Intelligence Document. 
1. Open the BI launch pad. 

2. Open Web Intelligence from My Applications. 

3. Open the Gross Sales Crosstab document that you created in the previous activity. 

4. Click Design in the top right corner. 

 
 

5. Click Data Access. 

6. Click Edit. 

 
 

7. Click Add Query. 

 
 

8. Double-click Sports.unx. 

9. Add Customer Name, Year, Quarter, and Gross Sales. 

10. Click Run Queries. 
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11. Click OK. 

 
 

12. Click the Report 2. 
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13. Resize the Customer Name column. 

 
 

14. Right-click the Report 1 tab and choose Rename.  Chang e the name to Gross Sales by Category. 

15. Right-click the Report 2 tab and choose Rename.  Change the name to Gross Sales by Customer. 

 
 

16. Save the document. 
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Troubleshooting 

Logon denied: Your system does not allow the use of this application 

 

This error occurs when the license keys for the BI platform have expired.  Log into the Central 

Management Console and update the license keys. 

Error: Server SAPDEMO:6400 not found or server may be down (FWM 

01003) null 

 

This error occurs when the server is no longer running.  To restart the servers open the Central 

Configuration Manager (Start > All Programs > SAP BusinessObjects Enterprise XI 4.0  > SAP 

BusinessObjects Enterprise > Central Configuration Manager) and restart the Server Intelligence Agent 

(SAP Demo) 
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