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Installation Guide 
Thank you for purchasing ServiceCEO® and welcome to the Insight Direct family! 

The following sections are designed to walk you through the installation process. Our 
customers have found that following these steps is the most successful way to install the 
program. 

It will take you about 30 minutes to install ServiceCEO. 

Requirements for Installing ServiceCEO 
If you are going to use ServiceCEO on multiple computers connected together on a 
network, only one of these computers needs to install SQL.  To determine which version 
of SQL you should install, see the Should I Install ServiceCEO with the MSDE or the 
Full Version of SQL Server? section below. 

Please disable any virus protection software you have running before installing 
ServiceCEO. Running such software during installation may interfere with the 
installation process. 

System Requirements 
Any computer running the application should have or use: 

• The Windows XP or 2003 operating systems. We recommend using Windows XP 
for optimal performance. 

• Pentium 2 GHz with at least 512 MB of RAM. 

 

Tip: 
For more on our computer recommendations, please see the System 
Requirements page of our website, located at 
http://www.insightdirect.com/products_system.html. 
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Should I Install ServiceCEO with the MSDE or the Full Version 
of SQL Server? 

ServiceCEO ships with a managed version of Microsoft® Desktop Engine called MSDE. 
Most users install this server, which automates many of the complex configuration and 
maintenance tasks involved in managing a database. However, the MSDE does have 
some performance limitations: 

• Maximum database size of two gigabytes (GB)  

• Uses up to two processors  

• Limited to eight concurrent executing operations per instance  

• 32,767 concurrent connections  

• 32,767 databases per instance  

• 16 instances per server  

• Only uses up to two GB of Random Access Memory (RAM) 

• The Workload Governor. Whenever the MSDE exceeds eight concurrently 
executing operations, MSDE invokes the workload governor. Invoking the 
governor delays query execution which, in turn, usually creates more concurrent 
queries, resulting in very long running queries.  

The end result of these limitations is that if you have more then five regular users of 
ServiceCEO, you could experience a dramatic decrease in performance if you continue to 
use the MSDE. Using the full version of SQL Server™ 2000 to host one or more 
ServiceCEO databases will prevent this performance degradation, including: 

1. No size limit is enforced on your databases. With SQL 2000 Server, your 
database size is limited primarily by your hardware.  

2. No limit on the number concurrent executing operations per instance exists. Users 
of SQL 2000 Server purchase a base license (typically the SQL Server Standard 
Edition with 10 Client Access Licenses (CALs)) and purchase additional CALs as 
they need them.  

3. Use of multiple processor machines. SQL Server 2000 supports up to 32 Central 
Processing Units (CPUs) and 64 GB of RAM.   

Note that when using SQL Server 2000, the ServiceCEO backup and restore tools may 
not function properly. You will need to use regular SQL Server tools like Enterprise 
Manager and Query Analyzer to backup and restore your database. For details, please 
read your SQL documentation. 
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Next Topic: 
     - To install ServiceCEO with the MSDE, read the Installing ServiceCEO with MSDE 
topic. 
   - To install ServiceCEO with SQL Server 2000, read the Installing ServiceCEO with 
the full SQL Server topic. 

Installing ServiceCEO with MSDE 
The SQL Desktop Engine should be located on either the server or, if you do not have a 
server, the computer with the most current Microsoft® Operating System. 

 

Note: 
If you do not have the ServiceCEO CD, but have instead the ServiceCEO Full 
Installer, double-click the install file and go to step three. 

To install ServiceCEO: 

1. Insert the ServiceCEO CD into your computer. A welcome page appears. 

 

2. Click Install ServiceCEO. The Welcome to the InstallShield Wizard for 
ServiceCEO page appears. 
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3. Click Next. The License Agreement page appears. 

 

4. Read the entire license agreement by scrolling down. 

5. If you accept the conditions described in the license agreement, click the I accept 
the terms of the license agreement option button. If not, you will not be able to 
install ServiceCEO. 

6. Click Next. The Choose Destination Location page appears. 
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To make any changes to the system Domain Server Name (DSN) configuration for 
ServiceCEO and the MSDE, you will need to be logged into the computer as the 
Windows Administrator. 

 

Tip: 
ServiceCEO's default installation location is C:\Program Files\ServiceCEO. If 
you want to change the installation location, click Change.... The Choose Folder 
dialog box will appear. Navigate to and select the folder on your computer where 
you want to install ServiceCEO. Click OK to change the location. The new 
location will appear on the Choose Destination Location page. 

 

Caution: 
If, for whatever reason, you need to run the ServiceCEO installer again or 
upgrade the program at any point, be sure you select the same directory that you 
selected on the Choose Destination Location page. If another directory is 
selected, you will install ServiceCEO into two separate directories, and the 
program may not run as expected. 

7. Click Next. The Select Components page appears. 
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There are three check boxes you can select on this page: 

• ServiceCEO Client Software. Select this check box to install the ServiceCEO 
software on this computer. 

• QuickBooks Integration. Select this component to install QBFC3, the 
QuickBooks Integration Pack that will integrate ServiceCEO with the U.S. 
version of QuickBooks. 

 

Caution: 
If you are using the Canadian version of QuickBooks, DO NOT select the 
QuickBooks Integration check box. Selecting this check box will generate errors 
when you use QuickBooks with ServiceCEO. To get the Canadian version of 
QuickBooks to integrate with ServiceCEO, you will need to install one of Intuit's 
Service Packs. Run this file after the ServiceCEO installation has completely 
finished. For more information, see the Integrating QuickBooks section. 

• Local Database Engine. Select this component if you are installing a 
ServiceCEO database on this computer. The installer will load the Microsoft® 
Desktop Engine onto this computer. The MSDE is required for single-system 
installations, but, in a networked installation, should only be installed on the 
computer hosting the database. Thus, if you will be running ServiceCEO on one 
computer but accessing (via a network) a ServiceCEO database located on 
another computer, deselect this check box. 

 

Caution: 
If you already have a full version of SQL Server installed, or if you would like to 
install SQL Server on a drive other than your C:\ drive, do not select the Local 
Database Engine check box. When installation is complete, follow the steps 
detailed in the Installing ServiceCEO with the full SQL Server section. 
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8. By default, all of the check boxes are selected on the Select Components page. If 
necessary, deselect the appropriate check boxes. 

9. Click Next. The Ready to Install the Program page appears. 

 

10. Click Install. The program starts to install. The installation progress displays on 
the Setup Status page. 

 
When the installation finishes, the Installation Completed page appears. 
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11. Select the appropriate option button. If you select the Yes option button, your 
computer will automatically reboot after you close the InstallShield Wizard. If 
you select the No option button, you will have to reboot your computer yourself 
before the application will be installed. 

12. Click Finish. The InstallShield Wizard will close. If you selected Yes in step 11, 
your computer will reboot. 

 

Note: 
You will have to reboot your computer before continuing. 

If you are not installing a ServiceCEO database, the installation is complete. If you are 
installing a ServiceCEO database, continue to the Setting up a Database section. 

Setting up a Database 

 

Note: 
If you will be accessing a ServiceCEO database over a network, you do not need 
to set up a database on this computer. Click Cancel now. 
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Installing the SQL Server Desktop Engine 
Once your computer has rebooted, the ServiceCEO Database Setup Wizard will start 
automatically. 

 

Tip: 
If, for any reason, you need to exit this wizard before the database is setup, you 
can reopen it by selecting Start > Programs > ServiceCEO > Local Database 
Engine Configuration. 

 

1. Click Next. The second page of the ServiceCEO Database Setup Wizard appears. 
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2. After reading the text on this page, click Next. The third page of the ServiceCEO 
Database Setup Wizard appears. 

 

 

Note: 
When the SQL Server Desktop Engine is installed, the computer hosting the 
ServiceCEO database (the Server computer) will display an icon in the taskbar: 

. This means that the SQL Desktop Engine is running on the computer. Since 
ServiceCEO will not operate correctly unless the Desktop Engine is running on 
the server computer, you should keep the SQL Desktop Engine open at all times.

3. After reading the text on this page, click Next. The fourth page of the 
ServiceCEO Database Setup Wizard appears. 
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4. Click Next. Microsoft SQL Server Desktop Engine will start to install. When 
complete, the System Restart Required dialog box appears. 

 

5. Click Yes. Your computer will reboot. 

 

Caution: 
If you click No in the System Restart Required dialog box, you will need to 
reboot your computer before the Microsoft SQL Server Desktop Engine is 
completely installed. 

Creating the Database 
When your computer restarts, the ServiceCEO Database Setup Wizard will automatically 
start running. As it configures the database, you will see a progress page: 

 
After several processes have run, the Load Database dialog box appears: 
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1. Select the check box of the database you want to load. 

 

Tip: 
Since ServiceCEO is so configurable, we highly recommend that you start by 
loading the Demo Database so that you can learn how to use and learn 
ServiceCEO in a safe environment. The Demo Database contains sample data - 
multiple customer records, jobs, schedules, employees, etc. - that, when loaded, 
enables you to work with and use all of ServiceCEO's functionality without 
worrying about making mistakes on your real business data. It gives you the 
opportunity to create customers, schedule jobs, complete work, and see how the 
master lists and options affect ServiceCEO without worrying about corrupting 
your live data. In short, the Demo Database will help you learn how to configure 
your own database in order to best serve your unique business. 

2. Click OK. A warning dialog box may appear. 

 

 

Caution: 
If the ServiceCEO CD is not in the computer when you click OK, you will 
receive an error. Please make sure that the ServiceCEO CD is still in your 
computer before you attempt to load the demo database. 
If you do not have the ServiceCEO CD, click Cancel and download the Demo 
Database from the Insight Direct member center: 
http://www.insightdirect.com/login.html   
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3. If necessary, click Yes. The database will load. When complete, the last page of 
the ServiceCEO Database Setup Wizard appears. 

 

4. Click Finish. The Setup Wizard will close. 

Your application is now ready to run! 

Installing ServiceCEO with the full version of SQL 
Server 
If you have a full version of SQL Server™ installed, you can configure ServiceCEO to 
use it rather then the MSDE. If you are using the MSDE, you can skip this topic. For an 
explanation of the difference, read the Installing ServiceCEO Overview topic. 

Prerequisites:  

1. A complete version of any edition of SQL Server 2000, updated to at least Service 
Pack 3 (SP3) with a collation set to "SQL_Latin1_General_CP1_CI_AS" (For 
more information on collation, point your browser to: 
http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/instsql/in_collation_19ym.asp. You can also search for "Authentication to SQL 
Server and Windows" from Microsoft's website.) 

2. Experience using SQL Server management tools, especially Enterprise Manager.  

To install a ServiceCEO database that will work with SQL Server 2000, please follow the 
following steps.  

1. Run ServiceCEO.exe. This file is located on the ServiceCEO Installation CD. The 
ServiceCEO InstallShield Wizard appears to walk you through the process. The 
steps for this process are located in the Installing ServiceCEO with MSDE topic. 
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2. On the Select Components page of the InstallShield Wizard, do NOT select the 
Local Database Engine check box.  

3. When the installation is complete, reboot your computer as prompted.  

4.  Using Enterprise Manager, create a new database on the computer. Name the 
database "ServiceCEO" (This is the internal name of ServiceCEO).  

5. Create a new user on your server. ServiceCEO is designed to log into the server 
using SQL Authentication, not Windows Authentication. You may need to 
configure your server to allow this type of authentication: 

o Name the user "insight" 
o Set the user's default database to "ServiceCEO". ServiceCEO will use this 

account to access the database.  
6. Configure the "insight" user so that the user has the proper security permissions 

for accessing the "ServiceCEO" database.  

7. Load a database. Backups created by the ServiceCEO backup/restore utility end in 
an SCB extension. A SCB file is a regular SQL Server backup that is zipped with 
the password "dunkies" (inspired by someone's choice of caffeine for the day). 
You can use WinZip or another compression utility to extract the raw SQL 
backup and restore it into your "ServiceCEO" database using Enterprise Manager.  

 

Tip: 
If you do not have a file compression tool, please download WinRAR from the 
Support Utilities section of http://www.insightdirect.com/support.html.  

8. If you want to load a blank database onto your server, you may download a 
backup of the blank database from: 
http://ws2.insightdirect.com/download/blank.SCB. Your ServiceCEO CD may 
also contain other SCB files with demo data, if you would prefer to load those.  

9. Download this file: http://ws2.insightdirect.com/download/setpassword.zip  

10. Extract the setpassword.zip file to the desktop of the server.  

11. Double-click the SetPassword.exe file. The Database Password Setup dialog box 
appears.  

12. Verify that the database name to which you’re connecting is “ServiceCEO”.  

13. When prompted, type your personal “sa” username/password combination.  

14. Click Finish.  

15. Log in to your server as an administrator (sa) using Query Analyzer.  



Installation Guide 

15 

16. Change to the "ServiceCEO" database and run the command "EXEC 
up_UpdateInsightUser".  

17. Test your configuration. Verify that the system DSN named "InsightDirect" 
points to your server. For detailed instructions, see the Network Configuration 
Overview section.  

You can now run and login to ServiceCEO in the normal manner. 

Configuring your Network 

Network Configuration Overview 
You can connect multiple ServiceCEO users to the same database via a network. There 
are two different types of networks: 

• Local Network. A Local Area Network (LAN) consists of computers that are in 
the same physical location. For example, if you have seven computers in the same 
office building all working off of the same database, you are running a LAN. 

• External Network. A Wide Area Network (WAN) consists of multiple 
computers in separate physical locations connected via the Internet. Examples of 
WANs include:  

o Connecting to the ServiceCEO database located in your office from a 
computer at home. 

o An employee based in Boise, Idaho logging onto a ServiceCEO database 
located in St. Louis. 

 
Regardless of the type of network you are running, you need to configure all client 
computers running ServiceCEO so that they are pointing at the server computer (the 
computer hosting the ServiceCEO database). To do this, you must connect each user's 
computer (the "client" computers) to the computer that is hosting the ServiceCEO 
database (the computer acting as the "server").  
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Caution: 
Please note that there are significant security risks associated with opening your 
network and/or ServiceCEO database to the Internet. This document does NOT 
cover setting up security for your server (e.g., file and directory security, server 
maintenance, etc.). This document assumes you understand the general 
networking process, and is only meant to help you configure your ServiceCEO 
network. For a brief overview on some networking issues, point your browser to 
http://www.cites.uiuc.edu/security/network-overview.html. 
If you are unsure of how to proceed, please contact your local network 
professional. They will be able to ensure that access is properly setup and your 
systems are not at risk. 

 

Note: 
ServiceCEO uses an ODBC connection to communicate with the MSDE server. 
In most broadband configurations, response time should be roughly the same 
between: a) Running the ServiceCEO client on a remote workstation, and b) 
using Microsoft® Remote Desktop Connection to connect to a workstation 
which is on the same LAN as the server.  
When large amounts of data are requested (“give me a list of 1000 customers”) 
from the ServiceCEO database, the Remote Desktop Connection (b) is expected 
to outperform (a), since the client software will have a faster connection to the 
server to retrieve the data.  
When smaller amounts of data are requested (‘give me 1 customer record”), 
running the client remotely (a) is expected to outperform slightly (b), since only 
the data has to be retrieved, whereas Remote Desktop would have to transmit all 
of the screen changes as well (the Customer Details window appearing, etc.).  
In cases where connectivity is less-than-ideal, the Remote Desktop configuration 
(b) is often preferable since it is more tolerant of dropped connections/packets 
than native ODBC (a). For more information, open Remote Desktop Connection 
by selecting Start > All Programs > Accessories > Communications > 
Remote Desktop Connection and press F1. 

In order to connect client computers to the ServiceCEO database, you will need to 
determine either the server's computer name or IP address. 

• Internal Network: You can use either the server's network name or IP address. 
To determine the server's computer name, double-click your mouse on the SQL 
icon ( ) on your system tray (located next to the clock). The SQL Server Service 
Manager dialog box appears, displaying the name of the database. If you do not 
want to use the computer name, you can use the server's IP Address. 

• External Network: If you are connecting to the ServiceCEO database via the 
internet, you will need to know the server's IP Address. 
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Tip: 
If you are running your network through a router, you will need to configure 
your router to enable remote access to ServiceCEO. For complete details, please 
read the Router Configuration for Remote Access document, located at 
http://www.insightdirect.com/docs/router_config/.  

To determine the IP Address of a computer: 

 

Tip: 
If you are connected to the internet, point your browser to 
http://www.insightdirect.com/support.html - your IP Address will be displayed in 
the Connection Information section located on the left side of the page.  

1. Select Start > Run. A Run dialog box appears. 

2. Type "Command" or "cmd" in the Open field. 

3. Press Enter. A "dos" or command prompt window appears. 

4. At the prompt, type "ipconfig". Note that this is short for IP Configuration. 

5. Press Enter. The computer's configuration information appears. 

 

6. The computer's IP address is on the IP Address line. Please note that the address 
in the graphic is only an example. 

Connecting ServiceCEO to Another Database 
In order to connect your client computers to the computer acting as the ServiceCEO 
server, you must configure the Open Database Connectivity (ODBC) options on every 
client computer to "point" the client at the ServiceCEO server computer. 

Note that server computers will not need to configure ODBC settings since MSDE will 
automatically configure it for you. 
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Tip: 
You can view a training video that covers this topic in the Insight Direct Member 
Center. To view this training video, login to the member center in the usual 
manner, click the Watch Pre-Recorded Training Classes link, and then view 
the Connecting Multiple Computers to ServiceCEO (Client/Host) video. 

To connect your application to a database on a network: 

 

Note: 
These steps are valid for versions of Windows 95 through Windows XP. 
However, while there may be minor variations between the versions (i.e., icons 
may be located in a different location), the basic steps are the same. 

1. On a client computer, select Start > Settings > Control Panel. The Control Panel 
appears. 

 

2. Double-click the Administrative Tools icon. The Administrative Tools window 
appears. 
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3. Double-click the Data Sources (ODBC) icon. The ODBC Data Source 
Administrator dialog box appears. 

 

Tip: 
In some operating systems, the Data Sources (ODBC) icon may be located in 
the Control Panel. In addition, in some versions of Windows 98, this icon may be 
named "32-bit Data Sources". 

 

4. Click the System DSN tab. The System DSN tab of the ODBC Data Source 
Administrator dialog box appears. 
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5. Click the name "InsightDirect". The name will be highlighted. 

6. Click Configure. The Microsoft SQL Server DSN Configuration dialog box 
appears. 

For local Networked Connections: For Remote Access via an Internet Connection 

7. Select the name of the computer which is hosting 
the database from the Which SQL Server do you 
want to connect to? drop-down list. 

7. Select or type the IP Address of the computer/ 
server that is hosting your database from the Which 
SQL Server do you want to connect to? drop-
down list. 
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Tip: 
If you do not know the name of the server computer, simply double-click your 
mouse on the SQL icon  ( ) on the system tray (located next to the clock) on 
the computer hosting the database. The SQL Server Service Manager dialog box 
appears, displaying the name of the database. Type this name into the Which 
SQL Server do you want to connect to? drop-down list. 

8. Click Next. The second page of the Microsoft SQL Server DSN Configuration 
dialog box appears. 

 

9. Verify that the Connect to SQL Server... check box is deselected. 

10. Click Next. The third page of the Microsoft SQL Server DSN Configuration 
dialog box appears. 
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11. Depending on what version of ServiceCEO you are running (and have run in the 
past), the Change the default database to: value will be different.  

o If you are running ServiceCEO 5.4 or previous, or have ever run 
ServiceCEO 5.4, type  into this field.  

o If you are running ServiceCEO 5.5 or higher and have never run anything 
previous to ServiceCEO 5.5, type ServiceCEO into this field. 

 

Tip: 
If the first database name you tried doesn't work, please try the other database 
name. For example, if you tried typing ServiceCEO but was not able to connect, 
try typing . 

11. Click Next. The fourth page of the Microsoft SQL Server DSN Configuration 
dialog box appears. 

 

13. Click Finish. The ODBC Microsoft SQL Server Setup dialog box appears. 
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14. Click OK. 

 

Caution: 
Do not click the Test Data source... button. 

15. Open ServiceCEO. 

If, when opening ServiceCEO, you receive an error message stating "Database Error - 
Connection could not be established", some of your settings are incorrect. For 
troubleshooting information, please read the next topic, Troubleshooting a Network 
Configuration. 

Troubleshooting a Network Configuration 
If, after following the steps detailed in the Connecting ServiceCEO to Another Database 
section, you are still unable to connect to the database server, there may be a general 
networking issue between the two computers. For example, a defective network cable or 
a firewall may be blocking your access. To help determine what the problem, run the 
following two tests: 

Test #1 - Basic Network Connectivity (the "ping" test) 

1. Select Start > Run. A Run dialog box appears. 

2. Type cmd or command in the Open field. 

3. Click OK. A DOS window appears. 
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4. Type ping SERVER at the command prompt, replacing "SERVER" with the 
name or IP address of your server. 

5. Press Enter.  

If you see a series of "Reply from..." messages, this indicates that network traffic is 
successfully moving between your client and your server. This test has succeeded and 
you can continue to test #2. 

If you receive a "Could not find host" message, you may have entered a server name 
which is not recognized on the local computer. Repeat test 1's step 4 but replace the 
server's computer name with its IP address. If pinging the IP address succeeds, change 
your DSN to use the IP address (step 7 in the Connecting ServiceCEO to Another 
Database section).  

Test #2 - Advanced Network Connectivity (the "telnet" test) 

1. Select Start > Run. A Run dialog box appears. 

2. Type cmd or command in the Open field. 

3. Click OK. A DOS window appears. 

4. Type telnet SERVER 1433 at the command prompt, replacing "SERVER" with 
the name or IP address of your server. 

5. Press Enter. 

If your DOS window goes blank and the cursor resets to the top left corner, this test has 
succeeded and you can close the DOS window by clicking the X in the top right corner. 
Your server appears to be running and no network obstructions are preventing your client 
from connecting. If you continue to experience connection issues when using 
ServiceCEO, please contact Technical Support. 

If you see either a Could not open connection to the host message or a Connection failed 
message, something preventing the client from connecting to the server port on the 
server. To fix this, verify that SQL is running and that the server can see itself. 

Verify SQL is Running 
To verify if the SQL Engine is running on your server, look in your system tray 
(generally located in the lower right corner of your computer's task bar, next to the 
clock). If it is running, you will see the MSDE icon:   
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If you do not see the SQL engine running in your system tray, please follow these steps.  

1. Select Start > Programs > Startup > Service Manager. The SQL Server icon 
will appear in your system tray.  

If the SQL icon does not have a green triangle, double-click on the SQL icon. This will 
open the SQL Server Startup Manager window.  

 
Press the green "play" button in this window to start SQL Server.  

 

Note: 
If the green "play" button is not active in the SQL Server Startup Manager 
window, you may need to click Refresh Services first. 

Can the Server Connect to Itself? 
On the Server computer, follow these steps: 

1. Select Start > Run. A Run dialog box appears. 

2. Type cmd or command in the Open field. 

3. Click OK. A DOS window appears. 

4. Type telnet SERVER 1433 at the command prompt, replacing "SERVER" with 
the name or IP address of your server. 

5. Press Enter. 

If your DOS window goes blank and the cursor resets to the top left corner, this test has 
succeeded - the server can connect to itself. 
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Filtering Software 
The next troubleshooting step is to verify that nothing is filtering traffic on the server's 
port 1433. Port 1433 is the default port used by SQL. Since ServiceCEO communicates 
using the SQL language, all incoming requests for ServiceCEO data will be in the SQL 
language as well. Thus, if something is filtering the traffic that arrives at port 1433 (i.e., 
all SQL requests), all incoming ServiceCEO requests will not reach their proper 
destination. 

Software that may be filtering network traffic include: 

• Software or hardware firewall software 

• Anti-virus applications 

If any software product is filtering traffic to port 1433, you should either turn off this 
software or disable the port 1433 filtering. Unfortunately, since every program is unique, 
we cannot tell you how to disable the filtering software. We recommend you read your 
user documentation for the product you suspect is filtering or blocking port 1433. 

Once you have disabled any filtering software, please run the tests above to verify your 
connection is working. 

Internet Provider 
Your internet provider, for any number of reasons, may block port 1433. If this is the 
case, the connection will not work. You will need to contact your internet provider to 
determine if this is the case and, if so, provide a solution for you. 

Windows XP Firewall 
If your server or client computer is running Windows® XP®, you will need to either 
disable the Windows Firewall or provide an exception for port 1433.  

 

Caution: 
Please note that there are significant security risks associated with opening your 
network and/or ServiceCEO database to the Internet. This document does NOT 
cover setting up security for your server (e.g., file and directory security, server 
maintenance, etc.). If you are unsure of how to proceed, please contact your local 
network professional. They will be able to ensure that access is properly setup 
and your systems are not at risk. 

1. Open Windows Explorer. A shortcut is to right-click the Start menu and select 
Explore from the pop-up menu. 

2. Right-click My Network Places and select Properties from the pop-up menu. 
The Network Connections dialog box appears. 

3. Right-click Local Area Connection and select Properties from the pop-up 
menu. The Local Area Connection Properties dialog box appears. 
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4. Click the Advanced tab. For more information on disabling the Windows 
Firewall or creating an exception for port 1433, please see your Windows 
documentation. 

Still Can't Connect?  
If you continue to experience connection issues contact Insight Direct's Technical 
Support Department. Be sure to tell the results of both the ping test and the telnet test to 
the Technical Support Representative. 

Managing your Database 

Toggling Between Databases 
To switch between two databases, you need to perform the following two steps: 

• Backup the current database 

• Restore another database 

 

Caution: 
Restoring a database automatically overwrites the current database. Make sure 
that you have backed up your current database before you restore another 
database, or your will lose your current data. 

An example of when you might want to switch between two databases is during database 
configuration. We recommend that you use the demo database to test out configuration 
options for your business before you toggle back to your live database for your actual 
configuration. 

 

Caution: 
Make sure that all users have exited ServiceCEO before you do perform any 
database management activities. 

Installing a New Database 
To install a new, blank database: 

1. Select Start > Programs > ServiceCEO > Local Database Engine 
Configuration. The ServiceCEO Database Setup Wizard appears. As it 
configures your database, you will see a progress page. 
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After several processes have run, the Load Database dialog box appears. 

 

2. Select the Blank Database check box. 

 

Tip: 
If you are new to ServiceCEO, we highly recommend that you start by loading 
the Demo database. See the Creating your Database section for more. 

3. Click OK. A warning dialog box appears. 
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Caution: 
If you have not yet backed up your current database, do so now. See the 
Backing up the Database section for details. Once you click Yes in this dialog 
box, your current database will be deleted. 

4. Click Yes. The database will load. When complete, the last page of the 
ServiceCEO Database Setup Wizard appears. 

 

5. Click the Launch ServiceCEO on Exit check box to start ServiceCEO when you 
exit the Setup Wizard. 

6. Click Finish. The Setup Wizard will close. The blank database is loaded into 
ServiceCEO and is ready for configuration! See the  Configuration Overview 
section of the Implementation Manual to start. 
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Backing up the Database 
Since ServiceCEO contains so much valuable data, it is wise to periodically backup the 
database to protect yourself from data loss in the event of system failure, theft of 
computer equipment, or other unforeseen accidents.  To protect you from any significant 
data loss, ServiceCEO lets you backup your entire database. 

 

Tip: 
You should regularly backup your database in order to minimize the possibility 
of losing any data. We also recommend that you keep this backup file for at least 
six months, just in case you need it. 

Backing up a database saves your data in a backup file with a .scb extension. This file 
type stands for ServiceCEO Backup. Note that only .scb files can be used as a 
ServiceCEO database. 

 

Caution: 
We do not recommend that you back up your database directly to an external or 
removable source (i.e., CD-ROM, Zip file, etc.). Doing so may result in data 
corruption. If you want to put your database backup files on an 
external/removable source, back up the database to a location on your local 
computer (such as your desktop) and, after the backup is complete, copy the 
backup .scb file to the external/removable source. 

 

Caution: 
Your computer may recognize the ServiceCEO backup file as a .zip file, not a 
.scb file. If this occurs, do not be alarmed - your computer has just confused two 
different types of file compression. Simply change the extension of the file back 
to .scb to fix the problem. To rename the file extension, right-click the file, select 
Rename from the pop-up list, and change ".zip" to ".scb". 
Note that this solution will only work if you can see your file extensions. If you 
cannot see file extensions, you must first instruct your operating system to turn 
them on. To do this, open Windows Explorer. Select Tools > Folder Options. 
Click the View tab. Deselect the Hide extensions for known file types check 
box - it should now have no visible check mark. Click OK to display your file 
extensions. 

To back up your database: 

1. Verify that all ServiceCEO applications are shut down. 

2. On the computer hosting your ServiceCEO database, select Start > Programs > 
ServiceCEO > Backup or Restore Database. The ServiceCEO Local Database 
Utility dialog box appears. 
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3. Verify that the Backup current database option button is selected. 

4. Click Next. The second page of the ServiceCEO Local Database Utility dialog 
box appears. 

 

 

Tip: 
ServiceCEO's default backup location is C:\Program 
Files\ServiceCEO\backup\. If you want to change the installation location, 
click Browse. The Browse for Folder dialog box appears. Navigate to and select 
the folder on your computer where you want to your backup file to be located. 
Click OK to change the location. The new location will appear on the second 
page of the ServiceCEO Local Database Utility dialog box. 
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5. Click Next. The backup process begins. A status box appears as the ServiceCEO 
Local Database Utility backups the current database. When completed, the 
Success dialog box appears. 

 

 

Note: 
Your backup file will automatically be named with the date on which the 
backup is being run. For example, if you ran a backup on November 10th, 2003, 
the backup file would be named 11102003.scb. 

6. Click OK. The second page of the ServiceCEO Local Database Utility dialog box 
appears with a success notice. 

 

7. Click Finish. The ServiceCEO Local Database Utility dialog box closes. Your 
database is now backed up. 

To learn how to schedule automatic backups, please search for the "Scheduling 
Automatic ServiceCEO Database Backups" solution in the Insight Direct Member 
Center. 
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Restoring a Database 
At any point, you can load a saved database into your current application.  

To restore a database: 

1. Select Start > Programs > ServiceCEO > Backup or Restore Database. The 
ServiceCEO Local Database Utility appears. 

 

2. Select the Restore database from backup option button.  

 

Caution: 
Restoring a database will automatically overwrite and erase the current 
database. Make sure that you have backed up your current database before you 
continue. See the Backing up the Database section for details. 

3. Click Next. The second page of the ServiceCEO Local Database Utility appears. 
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Tip: 
By default, ServiceCEO saves its backup files in the C:\Program 
Files\ServiceCEO\backup\ folder. 

4. Click Browse to locate the database you want to restore. The Browse for Folder 
dialog box appears. 

 

Caution: 
Only files with a .scb extension can be used as ServiceCEO databases. This file 
type stands for ServiceCEO Backup. 

5. Navigate to and select the folder on your computer where the backup file is 
located. 

 

Note: 
ServiceCEO backup file names consist of the date on which the backup is being 
run. For example, if you ran a backup on November 10th, 2003, the backup file 
would be named 11102003.scb. 

6. Click OK to change the location. The new location will appear on the second 
page of the ServiceCEO Local Database Utility dialog box. 
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Caution: 
Your computer may recognize the ServiceCEO backup file as a .zip file, not a 
.scb file. If this occurs, do not be alarmed - your computer has just confused two 
different types of file compression. Simply change the extension of the file back 
to .scb to fix the problem. To rename the file extension, right-click the file, select 
Rename from the pop-up list, and change ".zip" to ".scb". 
Note that this solution will only work if you can see your file extensions. If you 
cannot see file extensions, you must first instruct your operating system to turn 
them on. To do this, open Windows Explorer. Select Tools > Folder Options. 
Click the View tab. Deselect the Hide extensions for known file types check 
box - it should now have no visible check mark. Click OK to display your file 
extensions. 

7. Click Next. A status box appears as the ServiceCEO Local Database Utility 
restores the selected database. When completed, the Success dialog box appears. 

 

8. Click OK. The second page of the ServiceCEO Local Database Utility dialog box 
appears with a success notice. 

 

9. Click Finish. The database is now restored. 



Installation Guide 

36 

Upgrading ServiceCEO 
Upgrading ServiceCEO is an easy process. Basically, you just need to download the 
installer file, run it, and then reboot your computer. However, note that if you are running 
ServiceCEO on multiple computers, you will need to run the installer on all computers 
running ServiceCEO. If you do not, and multiple users attempt to log into ServiceCEO 
using different versions of the software, errors will result. 

1. Point your browser to the Insight Direct Support page at 
http://www.insightdirect.com/support.html.  

2. Click the orange Log into Member Center button. The Member Center Login 
page appears.  

3. Type your e-mail address into the E-mail Address field.  

4. Type your password address into the Password field.  

 

Tip: 
If you do not have a password, or have forgotten or misplaced your current 
password, click Click Here. The Forgotten Your Username or Password page 
appears. Fill in the fields with the appropriate information and click Send. 
Insight Direct will e-mail you a password for the Member Center. 

5. Click Login. The Welcome to the Insight Direct Member Center page appears.  

6. Click the Download and Install ServiceCEO Upgrades link. The Upgrade 
Installer page appears.  

You can download either the full or upgrade installer of ServiceCEO. 

• Download the ServiceCEO full installer if you need to install it from scratch. 
• Download the ServiceCEO upgrade installer if you have already installed 

ServiceCEO and want to update it to the most recent version. 

7. To download the upgrade, click the appropriate Download File button. A File 
Download dialog box appears.  

8. Click Save. A Save As dialog box appears.  

9. Navigate to your desktop and click Save. The upgrade file will be downloaded to 
your desktop. 

 

Tip: 
Rather then downloading the installer from the Internet for every computer, you 
may want to save the upgrade installer in a common folder on your internal 
network. Everyone running ServiceCEO can then copy the installer from the 
network to their computer for installation. 
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10. Double-click on the upgrade file. The InstallShield Wizard dialog box appears.  

 

Caution: 
Make sure all users are logged out of ServiceCEO before upgrading. Errors may 
result if an instance of ServiceCEO is open during the upgrade process. 

11. Click Next. The License Agreement page appears.  

12. Read the entire license agreement by scrolling down.  

13. Click the I accept the terms of the license agreement option button.  

14. Click Next. The Choose Destination Location page appears.  

15. Verify that the directory path here is C:\Program Files\ServiceCEO. If it is not, 
click Change, navigate to C:\Program Files\ServiceCEO, and click OK. 

 

Caution: 
If, for whatever reason, you need to run the ServiceCEO installer again or 
upgrade the program at any point, be sure you select the same directory that you 
selected on the Choose Destination Location page. If another directory is 
selected, you will install ServiceCEO into two separate directories, and the 
program may not run as expected. 

16. Click Next. The Ready to Install the Program page appears.  

17. Click Install. The program starts to install. The installation progress displays on 
the Setup Status page.  

18. When the installation finishes, the Installation Completed page appears.  

19. Select the appropriate option button. If you select the Yes option button, your 
computer will automatically reboot after you close the InstallShield Wizard. If 
you select the No option button, you will have to reboot your computer yourself 
before the application will be installed.  

20. Click Finish. The InstallShield Wizard will close. Note that you will have to 
reboot your computer before the upgrade process is completed. 

21. Login to ServiceCEO. A dialog box appears, informing you that you need to 
upgrade your database. If you are running SQL 2000, you will be prompted to 
enter your SA password. 

22. Click Yes. The Database Validator appears and automatically starts running. The 
Database Validator is a tool that runs a number of tests on your database 
BEFORE it is upgraded to ensure that there is no data corruption before the 
upgrade occurs. 
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Note: 
The Database Validator will not run if you are not running .NET 1.1. If you are 
not currently running .NET, you can download the installer from Microsoft. See 
http://www.insightdirect.com/dotnet/ for details. 

23. When complete, one of several actions will be performed, depending on the 
number and severity of errors that the Database Validator finds: 

o No Errors. The Database Validator automatically closes and the database 
upgrade begins. 

o Minor Errors. The Database Validator displays a yellow caution sign and 
informs you that some minor errors were found in your database. While 
you can upgrade the database with these errors without any major 
problems, we recommend you contact Technical Support to resolve these 
issues at your earliest convenience. Click Upgrade to start upgrading your 
database. 

o Critical Errors. The Database Validator displays a red warning sign and 
informs you that some critical errors were found in your database. We 
highly recommend that you stop the upgrade process by clicking Don't 
Upgrade, and contact Technical Support to resolve these issues before 
upgrading your database. 

• Other steps you can perform in the Database Validator are: 

o Details. This button expands the Database Validator screen so that you 
can see the individual test that failed. 

o Help. This button displays the Database Validator help, where you can 
read an explanation of the Database Validator tests and what they mean to 
your data. 

24. If the Database Validator finds no errors, or if you click Upgrade, your database 
will be upgraded to the new version of ServiceCEO. For some upgrades, this may 
take some time. Although it may look like ServiceCEO is unresponsive, the truth 
is that database scripts are running in the background designed to make your 
database compatible with the new version of ServiceCEO. Please be patient while 
the upgrade process runs. 
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Note: 
If any users are logged into ServiceCEO when the database upgrade begins, the 
Show Connected Users dialog box appears. Since no users can be logged into the 
program when the database is being upgraded, select every user and click 
Disconnect. See the Show Connected Users section of the User's Guide for 
details. 

25. When the database upgrade is completed, the ServiceCEO login page will appear. 
Log in to the program in the normal manner. 

 

Tip: 
To see the version of your software, select Help > About. The About 
ServiceCEO dialog box appears. The version number is displayed on the Client 
Software Version line.  

For a full description of the new features in the upgrade, please read the Release Notes, 
located at http://www.insightdirect.com/support.html. 
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Glossary 
.NET: "Dot Net" is a Microsoft® operating system platform that is designed to hide the 

boundaries between applications and the Internet. In other words, .NET will 
enable you to seamlessly connect to many different computers and services that 
will exchange and combine objects and data, instead of interacting with an 
application or a single Web site. Microsoft envisions this new technology as 
revolutionary, enabling Internet users to integrate fax, e-mail and phone services, 
centralize data storage and synchronize all of a users computing devices to be 
automatically updated. They envision that software will be rented as a hosted 
service over the Internet, users will have access to their information on the 
Internet from any device, anytime, anywhere. .NET depends on four Internet 
standards: HTTP, XML, SOAP, and UDDI. 

A 
Activation Code: The code needed to activate your application. 

C 
Client Computer: Any computer running ServiceCEO that is not hosting the 

ServiceCEO database. All client computers must connect, via a network, to the 
server in order to see the ServiceCEO database. 

D 
DSN: Short for Data Source Name. A DSN connects to a database through an ODBC 

driver. The DSN contains database name, directory, database driver, UserID, 
password, and other information. Once you create a DSN for a particular 
database, you can use the DSN to retrieve information from that database. 

I 
IP Address: A numeric identifier given to each computer on a network (such as the 

Internet) that enables the transfer of data from one computer to another. IP 
addresses are displayed as four numbers separated by periods; for example, 
7.155.23.211 is a valid IP address. 

L 
LAN: Short for Local Area Network. A computer network that spans a relatively small 

area. Most LANs connect workstations and personal computers. 

M 
MSDE: Microsoft® Desktop Engine 
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O 
ODBC: Short for Open DataBase Connectivity. ODBC is a standard database access 

method developed by Microsoft®. ODBC enables access to any data from any 
application, regardless of which database management system (DBMS) is 
handling the data. 

Q 
QuickBooks: QuickBooks® is a popular accounting software program with which 

ServiceCEO can integrate, updating QuickBooks' general ledger when financial 
actions are performed within the application (i.e., jobs are closed, deposits are 
made, etc). 

S 
Server Computer: The computer hosting the ServiceCEO database. As opposed to a 

"client" computer, which is a user computer connecting to the ServiceCEO 
database on the server computer. 

ServiceCEO Enterprise: ServiceCEO Enterprise is an expanded version of ServiceCEO 
with enhanced functionality designed to help you to manage an organization with 
multiple locations. The main difference between ServiceCEO and ServiceCEO 
Enterprise is the company structure - ServiceCEO Enterprise has a hierarchical 
organization model, starting at the top with the Organization, and then moving 
down into Regions, Branches, and Zones. Each organization can have an 
unlimited number of regions or branches. 

W 
WAN: Short for Wide Area Network. A computer network, typically connected through 

the Internet, that spans a relatively large geographical area.  
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