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COURSE

LAYOUT 

OVERVIEW
The goal of this course is to improve your efficiency in 
CET Designer and to act as a bridge between the 
Beginner CET Designer course and the Advanced 
CET Designer course. 

There will be optional topics to review at the end of 
each day from the Setting up CET Designer workshop 
and the Beginner CET Designer course. New content 
will also be introduced in preparation for the 
Advanced CET Designer course. 

This Live Participant Guide can be used to follow 
along during class and take notes on. During the live 
portion of training we will be using the free Fika
extension that is available on the Marketplace.
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TRAINING 

AT A GLANCE
• Contents:

• Course Information 

• MyConfigura

• Extensions

• Control Panel

• Views and Navigation

• Keyboard Shortcuts 

• Pin Tabs

• Component Tab Configurator 

• Work Modes

• Custom Toolbox

• Styles

• Reusable Files

• Template/Seed Drawings
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My Configura
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DETAILS:
• Portal to manage licenses & accounts

• Communicate & receive information from Configura

• Save & share information with others in secure Briefcases

• Access MyConfigura account

• Online:

• Configura.com – clicking MyConfigura

• my.configura.com

• In CET Designer:

• Pull down on name – access dashboard or account

• Briefcase Icon next to name

WHY - The portal that is used for the program CET Designer

STEPS:
1. Marketplace – manage licenses & account

2. Briefcases – save & share information

3. Dashboard & Account section

4. Downloads – download program, documentation & reference guides

5. Support – video tutorials, system recommendations & chat support 

6. Academy – free webinars, self-paced training & scheduled training

7. Forum – CET Designer Q & A

NOTES:



MyConfigura
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1. Post profile photo in “My Account” in MyConfigura

2. Download the CET Designer Reference Guide

EXERCISE
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Extensions & Updating
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DETAILS:
Free Extensions
• Characters – Make your drawings more realistic with human models

• Background download

• Plants & Flowers - Decorate your drawing with different potted plants and flowers

• Office/Kitchen Accessories - Decorate your drawing with accessories such as 

electronics, stationery, presentation boards etc.

• Material Pack - Gives you additional materials to place on walls, floors, accessories 

etc. Directly added to Material explorer

• Edit Graphics - Let´s you create special objects in CET Designer by manipulating 

standard symbols and change the graphical appearance

• SketchUp - CET Designer support the import of SketchUp objects and this 

extension gives you access to a huge library of objects of all sorts

• Catalogue Browser - Enables you to browse through online Catalogues from 

different manufacturers and place their products in your drawing in CET Designer

Updating CET Designer

• Help Pull- Down Menu / Check for Updates

• Background Download and installation

• Show Updates/Details

• Release Schedule

WHY – Learning about the free extensions available on the Marketplace and 

how to update your CET Desinger

STEPS:
Free Extensions
1. Navigate to Marketplace and install extensions

2. Updating CET Designer

Updating CET Designer

1. Help pull down – check for updates

2. Restart with update when downloads and installation complete

NOTES:



Extensions
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Updating
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1. Visit the Marketplace to download any extensions you would like

2. Update CET Designer once download/installation is finished

EXERCISE
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Control Panel
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DETAILS:
• File Pull-Down Menu/ Control Panel

• Includes default settings for currency, dimensions & program setup

• General 

• Preview Prices – show pricing or not

• F5 – to refresh

• Enable multiple drawings – open multiple drawings

• Region

• Set Defaults- Launguage, Currency, Distance Unit, Date format & Time format

• Views

• Use view focus point – pink dot 3D view (left click to move)

• Keep dialogs on same screen – open dialogs default to main screen

• Graphics – contact support if needed

• Recommended graphics cards can be found on our system recommendations 

page - http://www.configura.com/cet/support/systemrequirements/

• Turn off- Enable higher 3D-detail in realtime, Enable smooth textures & Enable 

realtime lights for faster work speeds

• Security 

• Auto backup – recovers unsaved drawings

• Auto-save – saves automatically

WHY – Adjusting & understanding the settings for CET Designer

STEPS:
1. Control Panel – file pull down

2. General – work modes & general section

3. Region – Language, Currency & Distance unit

4. Views – 3D views, Miscellaneous & 2D/3D Background

5. Graphics 

6. Security – Auto backup & Auto-save\

NOTES:



Control Panel

12



1. Verify these settings are to your liking in the Control Panel:

• Enable Multiple Drawings – on/off

• Distance Unit

• Angle Step

• View Focus Point – on/off

EXERCISE
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Views and Navigation
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DETAILS:
• Navigation in 2D view/3D View

• Scroll wheel to zoom

• Hold scroll wheel to pan

• 3D View – Hold right mouse button to pan

• Split screen mode – default 

• Change view - icons in upper right corner of 2D view

• New View – Separate window of 2D View or 3D view 

• Component Tabs – tab to right hand of program

• View Modes – Specific views in 2D & 3D

• Calculations – shows product in your drawing & pricing

• Refresh – to populate if blank

• Paper Space  – Create installation documents & presentation materials

• Photo lab – Create high quality realistic renderings of drawings

• Linked to current drawing

WHY – Learning the different areas within CET Designer & how to navigate

STEPS:
1. 2D view & 2D toolbar 

2. 3D view & 3D toolbar

3. New View – Views drop down ‘New 2D View’ or ‘New 3D View’

4. View modes – toggle between different views in drawing

5. Components Area – contains extensions you have access available

6. Top area – Additional tools in pull down, help, support and marketplace

7. Calculations – clicking on pricing icon upper right corner 

8. Paper Space – Paper & pen icon in upper right hand corner of 2D view

9. Photo Lab – 3D toolbar icon, tools pull down or 3D component tab

NOTES:



Views and Navigation 
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Keyboard Shortcuts
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DETAILS:
• Default keyboard shortcuts are assigned to some commands

• Create own shortcuts with keystrokes

• Select command & type in desired key or combination of keystroke & choose 

assign

• Once keyboard shortcut is assign can use that keyboard shortcut in any drawings 

moving forward

• Cannot assign the same keyboard shortcut to multiple commands

• Can assign more than one keyboard shortcut to a command if not already in use

WHY – Important keyboard commands to speed up workflow in CET Designer

STEPS:
1. Keyboard Shortcut – File pull down

2. Assign a keyboard shortcut – click action, click a key or multiple keys & hit assign

3. Remove keyboard shortcut – click on current keyboard shortcut & hit remove button

NOTES:
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Keyboard Shortcuts
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1. Add a keyboard shortcut for Part Tagging as Ex - “Shift + P” or “T”

2. Change another keyboard shortcut of your liking

EXERCISE
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DAILY 

GOALS

• Pin Tabs

• Component Tab Configurator 

• Work Modes

• Custom Toolbox

• Styles

• Reusable Files

• Template/Seed Drawings

DAY TWO
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Pin Tabs
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WHY – Learn how to pin your favorite component tabs show they show at the top NOTES:

DETAILS:
• Hover over extension – left-click on pin

• Will bring extension to the top

• Pin as many extension as you want – will default one under the other

• Permanent – will stay until you unpin

• Left-click on pin again to unpin

STEPS:
1. Hover over extension

2. Left-click on pin

3. Will move tab up to top



Pin Tabs
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Component Tab Configurator
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WHY – Learn how to create your own component tab configurations to just show the 

components you want to show
NOTES:

DETAILS:
• Located at the top of the component tabs

• Default component tab configurations available in drop down in blue

• Create your own – Component Tab Configurator

• Need to copy over selected Configurations

• Uncheck component tabs wish to turn off/check which to turn on

• Select component tabs & choose show details to see 

additional component tabs for extension to turn on/off

• Block down arrow – rename, remove or show created configurations in CET 

Designer folder

• File location: CET Documents>Preferences>toolbox

• Save as .cmtbx

• To share would have to copy and past this file in same location on 

computer

• Quick Buttons – colorful buttons at the top of the component tabs

• Assign commonly used component tab configurations in Component Tab 

Configurator by clicking Quick Buttons icon

• Choose which configurations for each color

STEPS:
1. Choose existing component tab configuration

2. If new – open Component Tab Configurator

3. Select default component tab configuration and choose ‘copy’

4. Uncheck or check component tabs – or select and choose ‘show all’ to see 

additional component tabs for extension to turn on/off

5. Assign quick buttons – choose commonly used component tab 

configurations for each color



Component Tab Configurator
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Work Modes
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WHY – Learn how to change your work mode in CET Designer for demos, 

specifications and create your own!
NOTES:

DETAILS:
• Located at the top of CET Designer next to ‘Marketplace’ button or in Control Panel 

in General Tab

• Default Work Modes:

• Design (Show All) – automatically placed in when download the program 

and shows everything

• Demo (no edit) – only shows tools necessary for demoing in front of a 

customer

• Easy Design – simplified buttons for simple designs

• Make Movie – For creating movies/fly thrus

• Specification – tools for specifying 

• Edit Work Modes – create your own work mode or edit an existing one

• Opens Work mode editor

• Choose work mode or copy over view mode to create own

• Work mode editor

• Visibility – CET Designer buttons/tools to turn on & off

• Tabs – keep component tabs, hide all tabs, use a specific component tab 

configuration or use custom tabs (pick and choose tabs to show)

• Keyboard shortcuts – turn on & off specific keyboard shortcuts

• Normal: default

• Black down arrow – allows renaming, resting or deleting work modes

• Show in folder – shows location of saved work mode

• CET Documents > WorkModes

• Saves as reusable file - .cmwrk

• Import work mode – bring in saved work mode

STEPS:
1. Choose existing work mode from top of CET Designer or Edit Work Mode

2. Work mode editor – choose existing work mode and copy

3. Choose visibility options, tabs, and keyboard shortcuts

4. Share work mode or import new work mode



Work Modes
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1. Set a work mode of your choice

2. Create a component tab configuration of your choice

3. Set as a quick button 

EXERCISE
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Custom Toolbox
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WHY – Learn how to create a free floating custom toolbox of commonly used product NOTES:

DETAILS:
• Located in the tools pull down or ‘C’ on keyboard for keyboard shortcut

• Create a new tab – paper icon

• Rename tab – right-click ‘rename’ or double click on tab (make sure to hit 

enter after type in new name) 

• Click on arrow in section name within tab to send to custom toolbox

• When sending a new section will be placed in the custom toolbox 

with tab selected

• Remove a section – left-click and hold for edit mode and click red x icon that 

appears (or right-click and switch into ‘edit mode’) 

• Switch back to ‘normal mode’ – right-click

• Collapse or expand all – right-click or by clicking on black down arrow

• Save as a reuseable file - .cmftb

• Assign commonly used component tab configurations in Component Tab 

Configurator by clicking Quick Buttons icon

• Choose which configurations for each color

STEPS:
1. Tools pull down or ‘C’ on keyboard

2. Left-click on paper icon to create new tab

3. Right-click – rename or double click on tab to change name and hit enter

4. Navigate to tab and click on arrow to send to tab selected in custom toolbox

5. Save custom toolbox as reusable file – file, save as



Custom Toolbox
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1. Create a toolbox of your choice

2. Save as a reuseable file

EXERCISE
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Styles
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WHY – Learn how to change text, lines, dimensions, dimensions text, dimension line, 

area, area text and hatch styles in CET Designer
NOTES:

DETAILS:
• Located in the tools tab 

• Available Styles:

• Text, Lines, Dimensions, Dimension Text, Dimension Line, Area, Area Text & 

Hatching

• Click on blue globe icon next to style to make changes

• Choose component group

• Edit default style or click blue + to create own ( - icon will remove style 

selected)

• Make changes in properties section

• Must save globally to be available in new drawings – blue save icon

• Saves to CET Documents > Styles folder

• Saves as .cmstl

• Must copy & paste in this location on computer if wish to share

• Reset style back to default settings

• Can choose new style in drop down in Styles section or in green property box drop 

down when item selected

STEPS:
1. Open Tools Tab

2. Click on blue globe icon next to specific Style

3. Click on blue + to create a new style or edit default style

4. Save globally

5. Choose style in drop down on tools tab or from green property box when item 

selected

6. Share .cmstl file type with others

7. Paste .cmstl file – CET Documents>Styles folder



Styles
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1. Place a couple items in your drawing

2. Add a special dimension style with a red font for construction documents

3. Change the line style to red to match the font

4. Dimension an area within your drawing using the new dimension style

EXERCISE
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Reusable Files
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DETAILS:
• Reusable Files – files meant to be saved & re-used

• Organization is key

• Recommend saving folder locations on network location

• Examples of reusable files:

• Paper Space – papers (.cmppr)

• Photo Lab – rendering preset (.cmpreset)

• Favorites – commonly used product or objects can be saved (.cmfav)

• Scheme Libraries

WHY – Understand shared files or saved files within CET Designer to speed up 

your workflow

STEPS:

1. See next page for flow chart on the different reusable files available

NOTES:



Reusable Files
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Template Files/Seed Drawings

36

DETAILS:
• Examples of what to add:

• Styles – i.e. construction dimensions, electrical dimensions & installation text

• Titleblocks – load in papers with titleblocks created (.cmppr)

• Custom Categories – i.e. revision cloud & electrical dimensions

• Schemes – load in saved schemes

• Save As to avoid overriding template file

• Examine after every main release – re-save over file to update

WHY – Learn how to create template files or seed drawings to start all new 

projects with to avoid re-doing work

STEPS:
1. File – Save blank drawing as template file or seed drawing

2. Create and save styles

3. Create custom categories

4. Load in saved papers with titleblocks

5. Load in saved schemes

6. Save As – when starting new project

NOTES:



Template Files/Seed Drawings – Saving & 
Styles
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Template Files/Seed Drawings – Custom Categories
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Template Files/Seed Drawings -
Titleblocks
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Template Files/Seed Drawings - Schemes
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1. Save your drawing that you’ve been building up as a template file:

1. Add any additional reusable files needed

2. Make sure customizations to CET Designer are in place 

2. Start new projects from your template file!

EXERCISE
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GLOSSARY

• Keyboard Shortcuts – Keystrokes to use a command without clicking on that 
tool. Located in the File pull-down 

• Clean Start – Restart CET Designer to refresh the program. Located in CET 
Install Helper - search “CET” or “Clean” in the Windows start menu.

• Control Panel – Adjust settings for the program. Located in the File pull-down

• Component Tabs – String of icons determined by extensions installed. An 
extension is comprised of one or multiple component tabs. Located on the left-
hand side of CET Designer 

• 2D View – Plan view of drawing that shows layout in 2D. Managed at the top 
portion in split screen view, full view, or New View

• 3D View – View that shows layout in the 3D. Can be seen at the bottom portion in 
split screen view, full view, or New View

• Split Screen View – Show both 2D and 3D views simultaneously. Control in the 
upper right-hand corner of current view

• New View – Open 2D or 3D view in a separate window. Right click & select New 
View

• PGC – Parametric Graphical Configuration. Technology behind specification and 
rules-based software, allowing the symbols to be ‘smart’ symbols

• Catalogue Browser/Explorer – Library containing all catalogue symbols that 
may also be available in an extension 

• Favorites – A reusable file (.cmfav) of 2D or 3D objects that can be inserted in 
future drawings. Right-click to create or insert favorite

• Part Tagging – Tag areas or individual products to group, sort, or filter in 
Calculations or apply Schemes. Located in the Tools pull-down 

• Material Explorer – Library of materials (.gm) that can be painted on floors, walls, 
SketchUp models, accessories, and more. Located in the 3D Component Tab

• Material Lab – Customize materials from the Material Explorer or import saved 
material (.jpeg, .png, or .gm). Located within the Material Explorer
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GLOSSARY

• Categorization – Use Categories to modify visibility in drawing or Paper View. 
Edit Category item is on in Categorization dialog. Located in Tools pull-down

• View Modes – Combination of Categories set by manufacturer determining what 

is visible in drawing or Paper View. View Modes along bottom of drawing view are 
based on the extension opened. Located at bottom of drawing view or Visibility 
dialog for Viewports

• Filter – Temporarily hide visible categories in drawing view or Viewport. Located 
in the Tools pull-down or Visibility dialog for Viewports

• Calculations – List of product with pricing and other information for ordering 
purposes & generating quotes

• Article Views – Tabs that show different quote layouts. Main Article View lists all 
product and cannot be filtered. Located in Calculations

• Paper View – Create installation documents for clients or for installation purposes

• Viewport – Show 2D or 3D view on paper. Located under the Drawing views 
section of Tools (paper) Component Tab in Paper View

• Visibility Settings – Customize view in selected viewport with a predefined View 
Mode, Custom View Mode, or Filter. Located in green property box for 2D or 3D 
Viewport

• Custom View Modes – Create own View Modes showing the specific categories 
you want to see. Located within the Visibility Settings dialog box

• Print Reports – Print Paper Views and Article Views to printer or PDF. Located in 
the File pull-down 

• Photo Lab – Create photo realistic renderings. Access from the 3D toolbar, 3D 
Component Tab or the Tools pull-down 

• Photograph Setup – Settings on the left-hand side of Photo Lab that can be 
chosen before a rendering has started 

• Post Processing – Settings on the right-hand side of Photo Lab that can be 

applied after a rendering is complete

• Render Tasks Dialog – Shows progress and preview of a rendering. 
Automatically pops up when a rendering has started in Photo Lab
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IMPORTANT

KEYBOARD

SHORTCUTS

• F1 – CET Designer Online Help

• S – Toggle between select single object & select all objects in a group 

on the 2D and 3D toolbar

• A – Copy and automatically have copied item on end of cursor to paste

• Alt + G – Gather open dialogs (opens all CET Designer dialogs on the 

same screen CET Designer)

• F5 – Refresh

• Shift – Holding down shift will override snapping

• Ctrl + N – Open up new drawing

• Ctrl + O – Open drawing

• V – New View

• Ctrl + A – Select all

• Ctrl + Z – Undo

• Ctrl + Y – Redo

• Ctrl + R - Remover

• Ctrl + left mouse – Rectangular select

• Ctrl + scroll wheel – Lasso select

• Ctrl + Alt + F – Graphical Snapping

• G – Group

• Ctl + G – Ungroup

• R – Position

• F – Insert favorite

• Alt + M – Material Explorer

• F2 – Photo Lab

• Ctl + P – Print reports

• F9 - Calculations
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