
StitchGraph User Guide V1.8 

Thanks for buying StitchGraph: the easy way to create stitch layouts for hardanger and 
other complex embroidery stitch types.


StitchGraph is intended to allow you to create clear illustrations of how to stitch particular 
stitch types, showing colors, labelling, direction of stitching, and if need be stitches that go 
behind cloth.


The output can be sent to a printer, a picture file (PNG), or a PDF file, to allow you a lot of 
flexibility in how you use the result.


�1



Table of Contents:


Starting the program. 4 
The Main Window Layout. 5 
Setting Default Properties 6 
Properties and What They Affect. 7 
Adding Stitches and Other Objects 8 
Cut Ends 8 

Adding Needles 9 
Images 9 
Cut Out Sections 9 
Moving and Resizing Objects. 10 
Selecting Several Objects 10 
Grouping Objects 10 
Deleting Objects 10 
Duplicating Objects 11 
Spacing Objects 11 
Arranging Objects 11 
Reversing Objects 11 
Mirror Function 11 
Aligning Objects 11 
Cycling through the Objects 12 
Outlining 12 
Zooming in and out 12 
Undo 12 
Copy 12 
Paste 13 

�2



Opening a saved Chart 13 
Starting a New Chart 13 
Deleting a saved Chart 13 
Printing a Chart 14 
Exporting a Chart to PNG (an image) 14 
Exporting a Chart to PDF  14 
The View menu 15 
FEEDBACK / YOUR QUERIES 16

�3



Starting the program. 
After installation, you should have an icon for the program on your desktop/start menu 
(Windows), or in your Launchpad area/ Applications folder (Mac)


Double click the icon to start the application.


Mac and Windows versions of the application are almost identical, apart from menus, 
where mac menus appear at the top of the desktop screen, and Windows menus appear as 
part of the document windows.


When the program opens for the very first time, you will be asked to activate it. (This will 
require your computer to be connected to the internet and not blocking emails by a firewall)


Enter your name, your email address, and the 17 digit serial number you were issued with. 
The serial number is unique to you, and you are allowed to install the software on two 
machines (for instance a desktop and a laptop) for your purchase fee.


(If you need to install it more times, please contact us to arrange a modest site licence fee.)


Once registered, you will be taken to the design screen, and the registration window will not 
re-appear next time you use the application.
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The Main Window Layout. 
StitchGraph has a simple screen layout, made up of 3 key areas.


The program begins , like most applications, with a  blank chart.


The main area is a grid, over which you will place your stitch diagram.


Along the top is a toolbar holding buttons for inserting stitches, and other common tasks.


And on the left is the Inspector pane, where you can change the properties of a stitch, such 
as the inner and outer colors, the labels, arrow color and direction, etc.


At the bottom left hand corner (from version 1.8 onwards) is a slider that can be used to 
quickly change the zoom size.
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Setting Default Properties 
The stitches that you add to the design will normally be white in color, with a black outline.


However, if you plan to work with pale blue or yellow stitches for a while, its a good idea to 
tell the application that this is your preference.


To set the default colors for new stitches, click on the grid once. 


This will make the Inspector pane on the left hand edge show the current default values for 
new stitches.


To set the Fill or Outline color for new stitches, click the color box next to either of these 
items in the Appearance section. (Other default properties can be amended here too.)


A color selector will be displayed. (Mac selector shown here)


We recommend using one of the ‘fixed lists’ of colors , 
such as the crayons or the web-safe colors, because then 
it is easier to find and re-use the same color at a later time 
for stitches you add later that should be the same color.  
Both Windows and Mac color selectors have a thin row of 
favourite colors running along the bottom of the dialog, 
where you can drag your favourite colors for easy access 
later.


Click a color to choose it, then click OK
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Properties and What They Affect. 
There are several types of things that can be added to your chart, and the default properties  
do not affect them all. Some have properties that can’t be set as default values. Click on a 
stitch on the toolbar to add one to the design, and it will appear in the middle of the 
window. Click on the stitch itself to select it. When you select an item in this way, the 
Inspector pane on the left will change to show the properties of that type of item, and you 
can amend those in the same way as the defaults. Here is a list of the properties you can 
amend. (Not all properties are available for all objects)


Section Item Notes

Appearance Fill Inside color of stitches and boxes

Outline Border color of stitches and boxes

Behind Cloth

Thickness A value between 0.3 and 1.5 .. the line can be thicker or 
thinner than ‘the standard’ of 1.0

Lock Shape/Offset When you have placed a stitch exactly where you need 
it, you can lock the size, shape, and position relative to 
the grid. Once locked, it can be moved but it will snap 
into position when released. IMPORTANT: this operates 
on individual stitches. If you select a group holding 
different types of locked stitches and move them 
about, they individually snap into place, and may shift 
with respect to each other, causing the group to change. 

Arrows Direction

Color The color of the arrow.

Labels Placed

Label A or B The text which appears at each end of the stitch, or if 
the object is a text object, Label A is the text.

Font You can use any font installed on your system.

Color Color of the letters.

If ticked, this object appears behind the grid.!

Inside or outside. If inside, then the labels will appear 
within the border of the stitch. If outside, then they will 
appear in circles offset from the ends.  

!

Can be no arrows, A to B, or B to A  
The arrow indicates the direction of a straight stitch

! .
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Adding Stitches and Other Objects 
There are 4 types of stitch that can be added to a chart, plus cut ends, needle parts (eyes 
and points), text, boxes, and ovals.


Using these primitives, you should be able to illustrate most types of stitches 


To add a stitch, simply click on the toolbar for the stitch type you need. (Cut ends require a 
little extra work.. see below)


These items are added with a single click, and can be moved or resized once in place:





TEXT: To change text, click on the text and amend it in the Inspector pane, or double click 
the text and enter the words directly.





Cut Ends 
Adding a cut end requires 
you to shape a curve. The 
curve will be formed by 
following a series of points 
on a grid. When the dialog 
appears, click a few times 
and see how the curve 
flows to follow your clicks. 
When you are happy with 
the shape, click insert. 
Click Reset to start again if 
need be.
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Adding Needles 

To add a needle, you need to select a matching eye and a 
point from the needles button on the toolbar.  You can place 
the eye and the point as far from each other as you 
wish.Once added, they can be resized and moved like any 
other object.





To use a needle in conjunction with a cut end, it is 
important that the cut end is set to be IN FRONT of 
the needle ( to make it appear as if the thread passes 
through the eye)


Images 

You can insert an image into the chart using this icon:


Double click the placeholder to browse for a file:


..And your image will be inserted. (images are saved with the charts)


Cut Out Sections 
Some hardanger techniques require you to cut a hole in the cloth.


You can simulate a cut section by adding a 
rectangle, and setting the border and fill 
colors to match the hole color of the cloth 
you are using. This diagram shows how, 
step by step. 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Moving and Resizing Objects. 
When you click on a toolbar button, a stitch is added to the design. It will usually not be in 
the right place, and it will not be the right size.


Click on the object to select it. Selected objects show 4 small red circles at the corners of 
their ‘effective area’.


These 4 small circles are grab points, and can be used to resize objects. Just click on one 
of them, and drag the point to a new location, to resize the object.


Also while the object is selected, you can click anywhere within region bounded by the red 
dots, and drag the object to a new spot using the mouse. Locked objects will snap to 
place.


Selecting Several Objects 
After selecting an object, if you hold down SHIFT and click on another, you will select them 
both.  You can now drag them both around using the mouse, but resizing only affects one 

at a time.


You can use the toolbar button ‘Select All’ to select all the objects on screen 
at once.


Grouping Objects 
If you select several objects, you can use the toolbar button Group to make the objects part 
of a group.   


In practice this means that when you click on any one of the objects 
of a group, they are all selected. You can drag the whole group around 
at once.


Ungroup clears the grouping and makes them all individual items again.


Deleting Objects 

You can delete objects by selecting them, then pressing BackSpace on the 
keyboard, or using the Delete button on the toolbar. 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Duplicating Objects 
When one or more objects are selected, you can use the Edit/ Repeat Horizontally or 


Edit/ Repeat Horizontally  to duplicate the objects exactly one grid space to the right or 
down. The numbers are the number of copies you get.


So to get a square of 9 stitches, select one, and repeat it horizontally 8 times.


Then select all 8 and repeat vertically 8 times.


Spacing Objects 
If you have some items of the same type close to each other and they are not strictly one 
gap apart, you can select them and use the Edit/Space horizontally (or vertically ) menu 
item and they will be placed one space apart.


Arranging Objects 
Objects can lie on top of other objects.


Normally, the most recently added objects appear on top of older ones.


This order can be changed using the Arrange button on the toolbar: you can bring an object 
to the fore or send it to the back of the ‘stack’ of objects.


(Note that this is not how you send an object behind the grid: you do that by ticking the 
‘Behind Cloth’ property in the Inspector while the object is selected.) 

Reversing Objects 
/ and \ lines can be converted to the opposite direction using the ‘reverse’ icon on the 
toolbar.    Using this option, a selection of stitches  like this ///||   would become  \\\|| 


Mirror Function 
The Mirror icon on the toolbar allows you to duplicate a selection of stitches, but reversed. 
Using this button, a selection of stitches like  ///||    would become  ///||  ||\\\


Aligning Objects 
It is common to want to have objects neatly lined up left, right, top etc. Different types of 
object line up in different ways.


You can get them to line up if you select them , and choose one of the alignment options 
from the menus.
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Here, you can make objects align on one edge.


You can also make the sizes match widths or heights.


(This option will only affect the height of vertical lines, 
and only the width of horizontal lines)


Cycling through the Objects 
If the design is full of stitches, it can be difficult to click 
on the exact object you want. You can cycle between 
objects , selecting one at a time in order until the correct 

one is selected, using the Cycle button on the toolbar.


Outlining 
When using the software for Plastic Canvas designs, it is common to want to show the 

boundaries of the plastic.


To do this, we have added ‘Outline’ 
mode.  Click on this toolbar icon and 
it will change color to show that it 

has been selected. Then, using the left mouse 
button, click or move the mouse over the grid 
lines. Where you click the mouse, the grid line 
will turn black.  To remove the outline, use the 
Right mouse button , or CTRL-click on a mac 
or device with a trackpad.


Zooming in and out 
You can change the zoom size in the View menu, under Zoom. While the grid has the 
‘focus’ (clicked on it recently), you can press + or - on the keyboard to achieve the same 
thing. Or you can use the slider control at the bottom left corner.


Undo 
StitchGraph supports many levels of undo.  You can undo repeatedly by using the CTRL-Z 
(windows) or cmd-Z (Mac) buttons.


If you use the Edit menu, you will see that the Undo menu item also shows how many undo 
items are ‘in the queue’. (When the undo items reaches zero, there will be no more undo 
actions allowed.)


Copy 
When you have selected one or more items, you can copy them to the clipboard. Ctrl-C 
(Windows) or cmd-C (Mac) will copy selected items to the clipboard.


StitchGraph maintains a list of recently copied items too, (up to 10 copies)
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Paste 
To Paste, use Ctrl-V (Windows) or cmd-V (Mac). This will paste the most recently copied 
items into the current chart. This also allows you to copy from one chart and paste into 
another.


You may also paste from the Clipboard history.. choose any of the listed items in the 
clipboard history in the Edit menu.Saving a Chart


StitchGraph charts have .SGRAF extensions (like text files are .TXT)


If you create a chart , you can save it for later using the Save As.. menu item in the file 
menu. It will open a save dialog ready to save in the Documents folder.


You can save elsewhere, but we recommend the Documents folder as this is normally 
backed up automatically by backup utilities if you run one.


Once a chart has been saved, the File / Save menu item allows you to save again without 
needing a save dialog.


(A saved chart is added to the list of Recent Files)


Opening a saved Chart 
StitchGraph charts have .SGRAF extensions (like text files are .TXT)


If you double click on such a file, it should open the StitchGraph application automatically.


If you have the application open, you can browse for an existing saved chart using the File/
Open menu item.


If the file you want to open is a ‘recent files’ file, you can open it with a single click from the 
File/Open Recent menu item.


Starting a New Chart 
Simply click File/New in the menus.


Deleting a saved Chart 
If you have saved your charts in Documents, they will be easy to find.


Use Finder (Mac) to look in the Documents folder, or Windows Explorer (Windows) to look in 
your ‘My Documents’ folder.


Find the unwanted chart, and drag it to the trashcan, or right click and choose ‘move to 
trash’ or ‘delete’.
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Printing a Chart 
To print a chart, use the File / Print option.


The whole chart will be printed on a page on the default printer.


(You can switch printers and page size using the Print Setup menu item.)


The design will have a blank area around it. The border is based on how far from the top 
and left of the grid the first stitches are. The right and bottom margins will be the same size 
as the top and left margins. Unused design area is not exported.


Exporting a Chart to PNG (an image) 
To export as PNG, click the File / Export to PNG option.


You will be asked for a file name. The name must end with .PNG


PNG is a high quality ‘lossless’ image format.


The size of the picture is driven by the zoom size on screen. Smaller zoom size, lower 
quality output.


Exporting a Chart to PDF  
To export as PDF, click the File / Export to PDF option.


You will be asked for a file name. The name must end with .PDF


The PDF export uses the highest quality output. When the PDF is printed, it should be set 
to ‘fit to page’  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The View menu 
The background grid can have a variety of styles and colors. These are set in the View 
menu.


By default ( and on versions earlier than 1.8), the background is a plain grid, where you can 
change the foreground and background color using the View menu, ‘Coth’ sub menu.


When using the ‘Plain’ style, you can use Fore Color and Back Color to change the grid 
colors directly.


The ‘Grid Width’ option lets you change the width of the lines.


New to Version 1.8 is the ability to use simulated cloth as a background.


When you do this , the cloth respects the color choices, but the thickness of the lines 
cannot be changed.


Note that on the closer textured cloths, there is less ‘hole’ showing, which means that any 
stitches placed ‘behind the grid’ will be harder to see. (You may need to bring them forward 
in order to place or resize them, for example)
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FEEDBACK / YOUR QUERIES 
We are always pleased to hear of your experiences, and about any problems.


Both help us improve the app for you, us, and everyone else.


To report a problem, ask a question , or just get in touch, drop an email to 


support@ursasoftware.com


Thanks!


Jeff & Deb Tullin. Ursa Software.
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