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Agenda

• Basics of Digital Music and Video

• Audio & Video File Formats and Standards

• Building Your Music Collection

• Cleaning up and editing recorded music

• iTunes Tutorial
– Ripping Music CDs

– Organizing Your Music Library

– Burning Music CDs

– Downloading Music to Your Hand-held

– Internet Radio

• Streaming Media Services

• Video Editing Tools

• Useful Web Links for More Information
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Basics of Digital Music

• Music is represented as a stream of numbers.
– Measurements of recorded electrical voltage level at an instant.

– Use 16 bits (2 bytes) per measurement (sample).

– For stereo, two streams – one for each channel (left / right).

– Standard audio CD sample rate is 44,100 times per second.

– Can later convert the stream of numbers back to voltages.

• Number stream may be saved in various ways
– On an audio CD.

– In a music file on a PC hard disk (.WAV, .MP3 or .AAC)

– Music files may be compressed in various ways or left uncompressed.

• Let’s look at a MP3 file with GoldWave Music Editor
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Basics of Digital Video

• A digital video is represented as a stream of frames.
– Each frame is an image with up to 2 million pixels (HD) or 8 million pixels (UHD).

– Video displays 30 or 60 frames per second (like a really fast slide show).

– Sound track is also included as 2 to 8 channels of audio.

• To achieve manageable file sizes, video is compressed.
– Mpeg Level 2 is video compression – about 55 to 1.

– Possible because from one frame to the next, there is very little change.

• Video, sound and other content can all be stored in a single 
“container file”
– .MOV, .AVI, .MP4, H.264 and others

• Video can also be stored as a structured set of files on
a Video DVD or Blu-ray disc.
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Audio File Formats (1)

• Microsoft WAVE  (.WAV)

– 44,100 samples/sec, stereo, 16-bit samples each channel.

– Each 16-bit value can range from -32768 to + 32767.

– Uncompressed, consumes about 10.6 MBytes per minute of sound

(44,100 * 2 * 2 * 60).

– Audio CD Quality (same specs).

• Motion Picture Experts Group 1 - Audio Layer 3 (.MP3)

– Compressed, size varies based on sample rate.

– .MP3 is “lossy” – removes very high and low frequencies.

– 128 Kbits/sec (near CD quality), 64 Kbits/sec (FM quality).

– At 128 Kbits/sec, uses about 1 MB per minute of sound (10% of .WAV).

– Little point in going higher than 256 Kbits/sec for MP3.
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Audio File Formats (2)

• Microsoft Windows Media Audio (.WMA)
– Compressed, size varies based on sample rate.

– Supports Digital Rights Management standards.

– MS claims files about half the size of .MP3 files.

(Our experiments didn’t confirm that).

• Apple Advanced Code (.AAC)
– Compressed, size varies based on sample rate.

– Supports Digital Rights Management standards.

– Proprietary to Apple.

• Other Formats:
– Ogg-Vorbis (.ogg), Free-Lossless (.FLAC)

• More Information
– http://ekei.com/audio

http://ekei.com/audio
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Vidio File Formats

• http://imagenevp.com/top-10-video-formats/

• Mpeg 1 & Mpeg 2

• H.264

• Motion Picture Experts Group (.MP4)

• Quicktime (.MOV)

• Microsoft (.WMV and .AVI)

• FLV (Adobe Flash)

http://imagenevp.com/top-10-video-formats/
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Building Your Own Music Library

• Convert your music CD collection to music files.
– Use iTunes or any of the many other popular CD “rippers”.

• Buy “used” CDs (save about 50%) to rip.

• Borrow music CDs to rip?
– From friends, public library.

• Buy digital music on-line.
– $.99 per song, $9.99 per “album” sometimes less)

– Most stores now sell “unlocked” MP3 files.

– Amazon.com and iTunes.com are now the biggest.

• Record Internet streaming audio
– Use a tool like Total Recorder

• Convert your old analog audio tapes and LPs to music files.
– Need a “line-in” recording tool (e.g. Spin It Again or GoldWave).

– After recording, need to separate and “clean-up” the recorded sound.
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CD Rippers

• Ripping (Definition)

– Copying contents of an Audio CD to your hard disk.

– Digital audio data is converted to: .WAV, .MP3., .WMA or .AAC

– Often audio album, artist and track information looked up

in an Internet CD Database (CDDB).

– Legal, fair personal use of copyrighted material you own.

• Many CD rippers available (shareware, freeware, jukeboxes).

– iTunes is very easy to use for ripping.

– Easy – Place CD in your CD drive and “rip away”.

– Ripped files can go in any folder – usually “My Music”.
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Demo - Ripping An Audio CD

• We’ll use iTunes, but Media Player, WinAmp, Roxio or 

Nero can also rip audio CDs.

• First - Get Your Settings Right (Only need to do this once):

– Click Edit > Preferences. Then click “Import Settings”.

– Choose Import using MP3 encoder in the drop down.

– For setting, click “Custom”. In the popup dialog, choose “256 kbps”.

– Click OK as needed to get back to the main preferences screen.

– Click the Advanced tab.

– For “iTunes Media Folder Location”, click Browse and choose the 

folder on your hard drive where you want ripped songs to go.

– Click OK as needed to exit the Preferences dialog.

• Insert the audio CD to be ripped.

• iTunes will ask if you want to import. Click “Yes”
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Converting Audio Tapes and LPs
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Digital Music Editors

• GoldWave (Shareware)
– Does line-in recording

– Full-featured music editor

• Audacity (Open Source)
– Does line-in recording

– Full-featured music editor

• Roxio Creator Suite - Music Editor

• Nero Suite - Wave Editor
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What Are Jukebox Programs?

• Most support a Music Library to organize your music.
Can “import” files and folders into the library.

• Most support ripping to MP3 files from Audio CDs.

• All can play CDs and music files back through your sound 
card.

• Can usually convert between some file formats.

• Can often burn new audio or MP3 music CDs with a 
custom mix of your favorite tracks.

• Most now support on-line music radio streams.

• Most now support on-line music stores for downloads.
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Popular Free Juke Box Programs

• Microsoft Windows Media Player

• Itunes

• WinAmp (oldie, but still a goodie)

• VideoLan VLC (audio and video player)

• All of the above are FREE!
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Organizing Your Music Library

• Physical Placement of your music files.
– Folder and file hierarchy important.

– Best is Artist > Album > Song name.

– Default is your personal “My Music” or “Music” folder.

– If have two hard drives, consider placing on the non-boot drive.

• Use a Jukebox program to index your files into a Library.

• Set up Descriptive “tags” in music files
– Artist name, song name, album name, genre, date

– Tedious work.  But, once done, these are recognized by all players 
and jukebox programs.

• Adjust physical file names based on tags.
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Adding Files to Library / Editing Tags

• We’ll use iTunes, but Media Player, WinAmp also work.

• Demo – Add Files to an iTunes Library / Edit Tags

– File > Add Folder to Library

– Browse to the Top-level folder containing the Files and Folders you 

wish to add.

– Click “Select Folder”.

– iTunes will scan and index the collection and build the library, 

indexed by Genre, Artist, Album and Song Title.

• Demo – Edit the tag information for a set of MP3 files.

– Click the “Songs” button (or you can select a playlist)

– Select one or a set of files by clicking, shift clicking, right clicking.

– Right click on the file or set and then select “Get Info”.

– Click the Info tab in the dialog that appears.

– Make changes as needed and then click OK to save the changes.
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Music CD Burning Programs

• Most Jukebox Programs (see previous).

• Roxio - Easy CD Creator or Easy Media Creator

– Good, easy to use, handles all media types.

• Ahead Software – Nero (CD & DVD)

– Good, easy to use , handles all media types..

• Ashampoo Burning Studio

– Free version available
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CD Burning Tips

• Use good quality media. Clean it before inserting!

• Use media rated to desired speed (e.g. 40X).

• Burners should have full access to the CPU and HD.

• Enable “Burn Proof” buffer mode if available.

• Shut down background programs, especially those that 

access the Internet. For example:

– Web browsers.

– E-mail client (Outlook, Windows Mail or AOL).

– Stock tickers, indexers, power managers.

– Screen savers.
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Demo - Burning MP3 CDs

• Can use iTunes, Media Player, WinAmp, Roxio or Nero.

• Demo – creating and burning an iTunes Play List

– File > New Play List.

– Drag and drop songs from the Library to the Play List (about 200).

– Keep track of total playing time (< 650 minutes)

– Drag songs in the play list into preferred order or turn on shuffle.

– Edit > Preferences > Advanced (check your settings).

– Click the “Burn Disc” item on the File menu.

– Set the CD burning parameters for “MP3 CD”.

– iTunes will check the collection and then begin the burn.
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Demo – Downloading MP3s

• Can use iTunes to download to iPhone, iPod, iPad
– http://ipod.about.com/od/ipad/qt/download-music-to-ipad.htm

– http://www.aimersoft.com/tutorial/transfer-itunes-music-video-on-ipad.html

• Demo – Downloading an iTunes Play List
– Plug in your i-Thing to a USB port with iTunes running.

– Select or create a Play List (see previous slide).

– Adjust settings for the Device (see web tutorial above).

– Tell iTunes to synch just the selected Play List.

• Can use Windows Explorer to download to an Android 

Hand-held.
– Plug in your Android device to a USB port.

– Windows will “mount” it with a drive letter.

– Copy music files from your hard drive’s “Music” folders to folders on your 

Android device.

– Or copy music files to a micro-SD card and plug it in to your device.

http://ipod.about.com/od/ipad/qt/download-music-to-ipad.htm
http://www.aimersoft.com/tutorial/transfer-itunes-music-video-on-ipad.html
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Streaming Media Services

• http://www.Pandora.com

• http://www.amazon.com (Amazon Prime)

• http://us.napster.com (formerly Rhapsody)

• http://www.Netflix.com

• http://www.youtube.com

• http://www.hulu.com

• Shoutcast (Internet Radio stations)

– Available via iTunes & other Jukebox programs

• Music channels on Cox, DirecTV & Dish

http://www.pandora.com/
http://www.rhapsody.com/
http://us.napster.com/
http://www.netflix.com/
http://www.youtube.com/
http://www.hulu.com/
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Free Video Editing Tools

• DVDShrink 3.2.0.15

– Removes copy protection from a video DVD
– http://www.softpedia.com/get/CD-DVD-Tools/CD-DVD-Rip-Other-Tools/DVD-Shrink.shtml

• HandBrake

– Converts a region free DVD or .ISO to a .MP4

– http://handbrake.fr

• Windows Live Movie Maker 2012

– http://windows.microsoft.com/en-us/windows/get-movie-maker-

download

http://www.softpedia.com/get/CD-DVD-Tools/CD-DVD-Rip-Other-Tools/DVD-Shrink.shtml
http://handbrake.fr/
http://windows.microsoft.com/en-us/windows/get-movie-maker-download
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Where To Find Music & Videos

• http://www.emusic.com/

• http://www.amazon.com

• http://www.walmart.com

• http://www.itunes.com

• http://www.freekaraoke.com/

• http://www.freemidi.com/

• http://www.secondspin.com

• https://play.google.com/store/music?hl=en

http://www.emusic.com/
http://www.amazon.com/
http://www.walmart.com/
http://www.itunes.com/
http://www.freekaraoke.com/
http://www.freemidi.com/
http://www.secondspin.com/
https://play.google.com/store/music?hl=en
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Other Useful Web Links

• http://www.howstuffworks.com/cd.htm

• http://audacity.sourceforge.net/

• http://download.cnet.com/windows/

• http://www.roxio.com

• http://www.nero.com/eng/index.html

• http://www.itunes.com

• http://www.videolan.org

• https://winamp.en.softonic.com/download

• http://www.microsoft.com

• http://www.ashampoo.com

• http://www.acoustica.com/spinitagain/

http://www.howstuffworks.com/cd.htm
http://audacity.sourceforge.net/
http://download.cnet.com/windows/
http://www.roxio.com/
http://www.nero.com/eng/index.html
http://www.itunes.com/
http://www.videolan.org/
https://winamp.en.softonic.com/download
http://www.microsoft.com/
http://www.ashampoo.com/
http://www.acoustica.com/spinitagain/

