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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
LabVIEW System Identification

System identification is a technique of building mathematical models of 
a dynamic system based on a set of measured stimulus and response data 
samples. You can use the models to simulate the system or to design a 
model-based controller for the system. System identification is 
fundamental for communication and control engineering, and it also plays 
important roles in many other areas, such as meteorology and economics. 
This manual describes how you can apply the LabVIEW System 
Identification Toolkit to your system identification needs.

LabVIEW System Identification Toolkit Overview
The LabVIEW System Identification Toolkit provides an interactive tool 
for identifying discrete-time multi-input and multi-output linear systems. 
You can think of single-input and single-output as a special case of 
multi-input and multi-output. This toolkit encompasses the entire 
identification process from raw data analysis to validation of identified 
models. You can identify large multivariable models of high-order systems 
from large amounts of data. With National Instruments hardware and the 
LabVIEW Real-Time Module, you can readily build a system for real-time 
system identification applications.

The LabVIEW System Identification Toolkit provides VIs encompassing 
the entire identification process, which includes the following:

• Data preprocess

• Parametric estimation

• Nonparametric estimation

• Recursive model estimation

• Model validation

• Model presentation

• Model conversion

• Model management

• Utility
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System Requirements
• Windows 2000/NT/XP

• LabVIEW 7.1 Full or Professional Development System

• NI-DAQ 7.1 or later if the application requires NI hardware

Note Refer to the LabVIEW Release Notes for LabVIEW system requirements.

Tip System Identification is a memory-intensive task. Increasing the amount of RAM can 
significantly increase system performance.

Installation
Complete the following steps to install the LabVIEW System Identification 
Toolkit.

Note Some virus detection programs might interfere with installing the LabVIEW System 
Identification Toolkit. Disable any automatic virus detection programs before you install. 
After installation, check the hard disk for viruses and enable any virus detection programs 
you disabled.

1. On Windows 2000/NT/XP, log in as an administrator or as a user with 
administrator privileges.

2. If it is not already installed, install LabVIEW 7.1.

3. Install the LabVIEW System Identification Toolkit. If the LabVIEW 
System Identification Toolkit installation program does not run 
automatically, you can run the installer by running x:/setup.exe, 
where x is the CD-ROM drive on the computer.

The Basic Concepts of System Identification
System identification is an iterative process that includes acquiring, 
formatting, processing, and identifying raw data from a real-world system 
based on a mathematical model you select. You then determine if the 
resulting model fits the observed system behavior. If the results are 
unsatisfactory, you revise the parameters and iterate through the process. 
Figure 1-1 shows a typical system identification flowchart.
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Figure 1-1.  System Identification Application Flowchart

System identification applications include data acquisition and 
preprocessing, model estimation, and validation and verification.

Real-world systems seldom have one model that perfectly fits all of the 
observed behaviors because system identification involves many variables, 
such as sampling frequency, type of mathematical model, model order, and 
so on. You usually have a number of models you can use. Each of the 
models describe the system behavior only to some extent.

You might have multiple applicable algorithms available for the same 
model. For example, the LabVIEW System Identification Toolkit includes 
four different adaptive schemes for recursive system identification and five 
different algorithms for AR model estimation. The algorithms you select 
depend on the model structure, stochastic assumptions, and numerical 
properties of the algorithm. 

You can use system identification in a wide range of applications, including 
chemical engineering, mechanical engineering, biology, physiology, 
meteorology, and economics. You must have a good understanding of the 
system under test, such as a motor, to devise an applicable control strategy. 
Designers use a system model of the relationship between the fuel flow and 
the shaft speed of turbojet engine to optimize the efficiency and operational 
stability of the jet engine. Biology and physiology researchers use system 
identification techniques to make progress in areas such as eye pupil 
response and heart rate control. Meteorologists and economists build 
mathematical models based on historical data for use in forecasting.

CharacterizationCharacterization

CharacterizationModeling

CharacterizationCharacterizationCharacterizationSelect ModelCharacterizationCharacterizationCharacterizationData CharacterizationCharacterizationApplicationsVerification/
Validation
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Data Acquisition and Preprocessing
The first step in system identification is collecting two sets of input-output 
data samples. You use one set of samples to estimate the mathematical 
model of the system. You use the second set of samples to verify the 
resulting model. If the resulting model does not meet the predefined 
specifications, such as prediction error, modify the settings and iterate the 
processing.

To verify the behavior of a system in a real-world environment, you can 
intentionally inject perturbations into the input data. For example, you can 
study the characteristics of an electric motor by varying the input voltage 
and observing how the motor responds. However, experimentation might 
be prohibited in many cases. For example, it might not be practical to 
introduce arbitrary perturbations to the input of a chemical plant because of 
safety concerns.

For the best results, you might need to preprocess the raw data samples you 
acquire, such as removing the trend, reducing random noise, and so on.

Refer to the LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help, for information about the Data Preprocess VIs.

Model Estimation
The next step in system identification is computing the mathematical model 
of the unknown system. The LabVIEW System Identification Toolkit 
models the system as linear, which must be in a state-space or polynomial 
form. The two most common techniques for estimating linear 
time-invariant systems are the nonparametric method and the parametric 
method. 

Nonparametric Model Estimation
A nonparametric method does not require the same amount of information 
as the parametric method, which requires the model type and model order. 
The nonparametric method is simple and efficient, but it is often less 
accurate than the parametric method. Nonparametric estimation uses the 
impulse response and frequency response methods to estimate the system.

Refer to the LabVIEW Help, available by selecting Help»VI, Function, 
& How-To Help, for information about the Nonparametric Model 
Estimation VIs.
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Parametric Model Estimation
Parametric estimation requires the model type and model order, which 
typically comes from some detailed knowledge of the system you are 
attempting to model. Parametric estimation is more involved and less 
efficient than nonparametric estimation, but it can yield more accurate 
results if you properly select the model type and model order. Prior 
knowledge of the real system is very useful when selecting the correct 
model type and the right order of the model. There are few systems in the 
real world that you can completely formulate using a linear mathematical 
model, so you usually need to try various models and model orders to 
obtain the best estimation. Refer to Chapter 2, System Identification 
Case Study, for information about adjusting the order of the model.

The LabVIEW System Identification Toolkit supports the following model 
types for parametric estimation:

• AR

• ARX

• ARMAX

• Output-Error (OE)

• Box-Jenkins (BJ)

• General Linear (GL)

• State-Space (SS)

You can represent linear discrete-time systems in state-space or polynomial 
forms. All of the above models are polynomial in form except the 
state-space model. From an input and output point of view, the model class 
that you choose is irrelevant because you can convert a polynomial model 
to a state-space form and a state-space form to a polynomial model. Refer 
to the LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help, for information about the Model Conversion VIs.

From a results point of view, the model class that you choose is important 
because the results from a direct model and the results from a converted 
model are usually different. For example, the results from a polynomial 
model and the results from a state-space model that you convert to a 
polynomial model are usually different because of different parameter 
settings and different estimation approaches.

The state-space model is preferred for multiple input or multiple output 
systems because it is suitable for complex model structures, particularly 
when a state-space system is in canonical form. There is a one-to-one 
mapping between the model parameters and the input-output behavior 
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within a model set when the state-space system is in canonical form. Input 
and output data samples can uniquely identify parameters.

Refer to the LabVIEW Help, available by selecting Help»VI, Function, 
& How-To Help, for information about the Parametric Model 
Estimation VIs.

Recursive Model Estimation
System characteristics can evolve over time and cause the previous 
estimated characteristics to be invalid. In this case, you need to use 
real-time system identification or online system identification. The 
LabVIEW System Identification Toolkit includes the Recursive Model 
Estimation VIs, which allow you to work with time-varying systems to 
achieve real-time system identification. 

Refer to the LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help, for information about the Recursive Model Estimation VIs.

Validation and Verification
The final step in system identification is validating the results. You have 
two ways to validate the resulting models. You can apply Bode, Nyquist, 
and pole-zero plots and examine the dynamic characteristics of the 
estimated model. You also can compare the estimated model against the 
actual system. For example, you can apply part of the acquired input data 
samples to the estimated model. Compare the difference between the 
response signal and the corresponding output samples to determine if the 
estimated system models the actual system with acceptable accuracy. 
Reestimate the model if the accuracy is unsatisfactory.

Refer to the LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help, for information about the Model Presentation VIs and the 
Model Validation VIs.
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2
System Identification 
Case Study

This case study compares various order estimation techniques and the ARX 
model and state-space model estimation methods for data sets from a 
flexible robot arm. The data was adopted from version 7.0 of the Xmath 
Interactive System Identification Module, Part 2, which was originally 
collected by Hendrik Van Brussel and Jan Swevers of the Laboratory of 
Production Manufacture and Automation at Katholieke Universiteit 
Leuven.

The input data is the reaction torque of the structure on the ground, which 
is a multi sinewave with 200 frequency points equally spaced over the 
frequency band from 0.122 Hz to 24.4 Hz.

The output data is the acceleration of the flexible arm that contains 
information about the flexible resonance and anti-resonance modes.

Each set contains 4,096 samples at a sampling rate of 500 Hz.

The VIs for this case study are located in examples\system 
identification\SICaseStudy1.llb. As you read the discussion in 
this chapter, open the VIs in SICaseStudy1.llb as you encounter them 
in the text and run them to better evaluate the resulting plots and the System 
Identification VIs used on the block diagram.

Refer to the LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help, for information about specific System Identification VIs in 
this case study.

Data Preprocessing
The Flexible Arm Data Set VI in Figure 2-1 shows the time waveform of 
torque, which is the measured input sample, and acceleration, which is the 
measured output sample. There is no obvious nominal, trend, or outlier 
values in the input or output time waveforms.
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Figure 2-1.  Flexible Arm Data Set in the Time Domain

The Non-Parametric FRF VI in Figure 2-2 shows the frequency response 
of the measured output signal. There are at least three resonances and 
two anti-resonances in the frequency domain. One resonance is at 
approximately 42 Hz. Noise or the system’s non-linear behavior cause the 
peak at approximately 42 Hz because the frequency of the input data is 
between 0.122 Hz and 24.4 Hz.

Figure 2-2.  Flexible Arm Data Set in the Frequency Domain



Chapter 2 System Identification Case Study

© National Instruments Corporation 2-3 System Identification Toolkit User Manual

The corresponding block diagram in Figure 2-3 uses the SI Estimate 
Frequency Response VI to compute the frequency response of the 
measured output signal. The window length input parameter is 4096 and 
specifies the length of the window used in the frequency computation.

Figure 2-3.  Block Diagram for Computing Frequency Response

You can apply a lowpass filter to the raw data sample before performing 
system identification to eliminate high frequency noise. According to 
sampling theory, you can perform downsampling to reduce the number of 
samples and the computation complexity when you reduce the frequency 
bandwidth to 25 Hz.

The Non-Parametric FRF with Prefiltering and Down Sampling VI in 
Figure 2-4 shows the frequency response after downsampling.

Figure 2-4.  Frequency Response after Downsampling
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The corresponding block diagram in Figure 2-5 adds the SI Lowpass Filter 
VI and the SI Down Sampling VI to eliminate the fake resonance at 
approximately 42 Hz and substantially reduce the number of samples 
to process.

The SI Lowpass Filter VI applies a lowpass filter before downsampling 
to avoid non-realistic behavior. Set the cutoff frequency input parameter 
to 25 so the effective frequency bandwidth is one-tenth of the original 
sampling frequency. The downsampling ratio can be as high as 10. The 
SI Down Sampling VI reduces the sampling rate using a decimation factor 
of 10. The lowpass filter and downsampling avoids the high frequency 
disturbance and makes the process faster and more efficient.

The window length input parameter of the SI Estimate Frequency 
Response VI in Figure 2-5 is 400 instead of 4096 as Figure 2-3 shows 
because the data set is downsampled by a factor of 10. The number of 
samples is one-tenth of the raw data.

Figure 2-5.  Block Diagram for Downsampling 
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Order Estimation
One of the biggest challenges in model estimation is selecting the correct 
order. The LabVIEW System Identification Toolkit supports three different 
criteria to estimate the orders.

• FPE—Akaike’s final prediction error criterion

• AIC—Akaike’s information theoretic criterion

• MDL—Minimum description length criterion

Sometimes the results you obtain with these three criteria might be 
inconsistent. You can use a pole-zero plot for further investigation and 
to verify the results.

The Estimate Orders of ARX Model VI in Figure 2-6 shows a prediction 
error plot. The y-axis is the prediction error and the x-axis is the model 
dimension. For an ARX model, the model dimension is equal to 
A order + B order. The three different color bars on the chart represent 
the FPE, AIC, and MDL criteria. The lowest prediction error usually 
corresponds to the optimal order. Figure 2-6 uses the AIC criterion so 
the prediction error corresponds to the following optimal orders:

• A order equals 9

• B order equals 10

• delay equals 0

Figure 2-6.  Prediction Error Plot for an ARX Model



Chapter 2 System Identification Case Study

System Identification Toolkit User Manual 2-6 ni.com

The corresponding block diagram in Figure 2-7 uses the SI Estimate Orders 
of System Model VI for order estimation. The optimal orders output 
parameter contains the A order and B order. The SI Split Signal VI 
partitions the preprocessing data samples into a portion for model 
estimation and a portion for model validation. The 1st portion input 
parameter is 66, which means 66% of the data samples are used for 
estimation and the remainder of the data samples are used for validation. 
The SI Estimate Orders of System Model VI generates the prediction 
error plot.

Figure 2-7.  Block Diagram for Order Estimation for an ARX Model

The Pole-Zero Cancellation VI in Figure 2-8 shows a pole-zero plot with 
three close pole-zero pairs. You can use a pole-zero plot to determine 
redundancy. If a pole and a zero overlap, the pole and zero cancel out each 
other, which indicates that the estimated optimal order is too high.

Due to numerical error, it is unlikely that a zero and a pole perfectly 
overlap. You can use the confidence region to justify whether the pole and 
the zero cancel out each other.
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Figure 2-8.  Pole-Zero Plot for an ARX Model

Figure 2-9.  Block Diagram of a Pole-Zero Plot for an ARX Model

The Pole-Zero Cancellation VI in Figure 2-10 shows a pole-zero plot with 
one pole outside the unit circle. This pole-zero plot uses the MDL criterion 
so the prediction error corresponds to the following optimal orders:

• A order equals 6

• B order equals 6

• delay equals 0
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Compare Figure 2-10, which uses the MDL criterion and Figure 2-8, 
which uses the AIC criterion. The three close pairs in Figure 2-8 have 
disappeared. This implies that the MDL criterion fits better than the 
AIC criterion in this particular example.

Figure 2-10.  Pole-Zero Plot for an MDL Model

In addition to examining redundancy, you also can use the pole-zero plot 
for other purposes. For example, Figure 2-8 and Figure 2-10 show poles 
outside the unit circle. This implies that the ARX system based on the AIC 
or MDL criteria might be unstable. One way to stabilize the system is to 
change the order. In addition to the FPE, AIC, and MDL criteria, you can 
set user-defined orders in the SI Estimate Orders of System Model VI.

Figure 2-11 shows a pole-zero plot with user-defined orders. This pole-zero 
plot uses the following optimal orders:

• A order equals 4

• B order equals 5

• delay equals 0

Compare Figure 2-11 with Figure 2-8 and Figure 2-10. The poles outside 
the unit circle in Figure 2-8 and Figure 2-10 have disappeared.
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Figure 2-11.  Pole-Zero Plot with User-Defined Order

The corresponding block diagram in Figure 2-12 uses a user-defined model 
dimension of 9 instead of the AIC model dimension of –2 used in 
Figure 2-9.

Figure 2-12.  Block Diagram for Pole-Zero Plot with User-Defined Order
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ARX Model Estimation and Verification
The Simulation & Prediction with ARX Model VI in Figure 2-13 shows 
simulation and prediction to verify an ARX model.

Figure 2-13.  Simulation and Prediction for an ARX Model

The corresponding block diagram in Figure 2-14 uses the SI Model 
Simulation VI to simulate the system model and the SI Model Prediction 
VI to perform prediction of the system model.
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Figure 2-14.  Block Diagram for Model Simulation and Prediction for an ARX Model

In addition to simulation and prediction, you also can apply a residual 
analysis to verify the system model. Residual analysis tests whether the 
prediction error correlates to the stimulus signal. Prediction errors are 
usually uncorrelated with all stimulus signals in an open-loop system. 
For a closed-loop system, prediction errors usually are uncorrelated with 
past stimulus signals.

The Residual Analysis VI in Figure 2-15 shows ideal results, where both 
auto-correlation and cross-correlation are inside the confidence region 
except those in the vicinity of τ = 0. Insufficient system order can cause 
a correlation between the stimulus and the residue. Figure 2-15 uses the 
following optimal orders:

• A order equals 4

• B order equals 5

• delay equals 0
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Figure 2-15.  Residual Analysis for A order = 4, B order = 5, and delay = 0

The Residual Analysis VI in Figure 2-16 shows the auto-correlation and 
cross-correlation residual analysis for the following orders:

• A order equals 2

• B order equals 2

• delay equals 0

The auto-correlation and cross-correlation indicates the residue is not white 
noise and correlates with the stimulus signal.



Chapter 2 System Identification Case Study

© National Instruments Corporation 2-13 System Identification Toolkit User Manual

Figure 2-16.  Residual Analysis for A order = 2, B order = 2, and delay = 0

The corresponding block diagram in Figure 2-17 uses the SI Model 
Residual Analysis VI to compute and analyze the prediction error.

Figure 2-17.  Block Diagram of Residual Analysis for A order = 2, B order = 2, 
and delay = 0
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State-Space Model Estimation
Order estimation is always a challenge with the ARX model. In the 
state-space model, order estimation is usually equal to the number of 
significant singular values.

The Estimate Orders of State-Space Model VI in Figure 2-18 shows a 
singular value plot with four leading singular values. This is the number 
of states.

Figure 2-18.  Singular Value Plot for State-Space Model

The corresponding block diagram in Figure 2-19 uses the SI Estimate 
Orders of System Model VI to estimate the number of states.
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Figure 2-19.  Block Diagram for Estimating the Number of States

The Simulation & Prediction with State-Space Model VI in Figure 2-20 
shows simulation and prediction plots for a state-space model to verify the 
quality of a system. Compare the state-space model in Figure 2-20 to the 
ARX model in Figure 2-13. The state-space model has less simulation and 
prediction errors.

Figure 2-20.  Simulation and Prediction for a State-Space Model
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The corresponding block diagram in Figure 2-21 shows a complete 
state-space model estimation and validation block diagram.

Figure 2-21.  Block Diagram of Estimation and Validation for a State-Space Model
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Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit the award-winning National Instruments Web site for 
software drivers and updates, a searchable KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, thousands 
of example programs, tutorials, application notes, instrument 
drivers, and so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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