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1 Templates

Templates are descriptions of forms and tables that can be included in Tekla Structures.
Templates are either graphical or textual. Graphical templates can be included in drawings as
tables, text blocks, and drawing headers. Textual templates can be used as reports. The
contents of the template fields are filled in by Tekla Structures at run time.

Tekla Structures includes a large number of standard templates you can use. Use Template
Editor to modify existing templates, or create new ones to suit your needs. Graphical
template definitions have the file name extension .tpl. Textual template definitions have
the file name extension .rpt.

For more information on using templates, see the Template Editor Help.

To access Help, open Template Editor and click Help --> Contents .

Creating a template on page 3

Reports on page 23

Templates on page 3

Example

See also
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1.1 Creating a template

To create a template:

1. Click Drawings & Reports > Template Editor.

2. In Template Editor, click File > New.

3. Select the template type and click OK. A new empty template is created.

4. Add new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

c. Repeat steps a–b for each new row.

5. Add value fields to get the required data from your Tekla Structures database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an attribute for the
value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

6. Save the template.

a. Click File --> Save as...

b. Browse to the template folder ..\environment\<your_environment>
\template.

c. In the File name field, enter a name for the template.

d. Click OK.

Templates on page 3

Creating a template in HTML format on page 4

Creating a template for nested assemblies on page 6

Creating a template for bending schedules or pull-outs on page 10

Adding images in a template on page 12

See also
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Creating a template in HTML format
Templates in HTML format give you more possibilities for different layout, fonts, and images.
Templates that generate output in HTML format are graphical and have the file name
extension *.html.rpt.

To create a template in HTML format:

1. Click Drawings & Reports > Template Editor.

2. In Template Editor, click File > New.

3. Select Graphical template and click OK.

4. Add new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

c. Repeat steps a–b for each new row.

5. Add value fields to get the required data from your Tekla Structures database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an attribute for the
value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

6. Add a header for each value field.

a. Click Insert --> Component --> Header...

b. Click Insert --> Text...

c. Enter a heading for the template, and then click OK.

d. Click a point to define the location of the heading in the header row.

e. Repeat steps a–d to create headings for all the value fields.

7. Save the template.

a. Click File --> Save as...

b. Browse to the template folder ..\environment\<your_environment>
\template.

c. In the File name field, enter a name for the template. 

Include the extension *.html.rpt in the file name. For example,
Part_list.html.rpt.

d. Click OK.
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If you add images in your HTML template, the images should be located in ..\Program
Files\Tekla Structures\<version>\nt\TplEd\bitmaps folder,
otherwise they are not shown in the HTML output.

Header that contains text fields

Row that contains two value fields

Templates on page 3

Adding images in a template on page 12

Creating a template for nested assemblies
This example shows how to produce a template that displays the hierarchical structure of
nested assemblies. You will create a nested assembly structure in a textual template similar
to the one in the following picture:

To create a nested assembly structure in a textual template:

Example

See also
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1. Click Drawings & Reports > Template Editor.

2. In Template Editor, click File > New.

3. Select Textual template and click OK.

4. Add four new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row, and then click OK. 

For the first and third row, select the ASSEMBLY content type, and for the second
and fourth row, select the PART content type.

c. Repeat steps a–b for each new row.

5. Use the arrow buttons under Sorting and drawing order to create a nested assembly
structure for the template.

a. Move the second and third row down one level.

b. Move the fourth row down two levels. 

The structure should now look like this:

6. Add value fields to get the required data from your Tekla Structures database. 

In this example, the added value fields are assembly or part position, number, and weight.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an attribute for the
value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

7. Modify the layout of the template. For example:
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a. Move objects to display the nested assembly structure in the printed report. To do
this, select the object you want to move and drag it to the desired position.

b. Align objects. To do this, select all the objects you want to align, right-click and
select the appropriate option from the pop-up menu, for example Align --> Right .

c. Add a header and a footer. To do this, click Insert --> Component --> Page header
and Page footer. Add the required information to the header and footer.

8. Save the template.

Below is an example textual template and a report that has been created using the template:Example
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You can create graphical templates for nested assemblies in the same manner as textual
templates. The difference between graphical and textual templates is that in a graphical
template you can display project and company information and graphics, such as table
outlines, pictures, or symbols.

Templates on page 3See also
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Creating a template for bending schedules or pull-outs
You can use Template Editor to create bending schedules or pull-outs on reinforcement bars
and bent meshes, and control the type of information that is shown in the bending schedules.

To create a bending schedule:

1. Click Drawings & Reports > Template Editor.

2. Click File --> New... .

3. Select Graphical template and click OK.

4. Click Insert --> Component --> Row to add a new row.

5. Select REBAR or MESH as the content type for the row.

6. Add value fields to get the required data from your Tekla Structures database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an attribute for the
value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

7. Insert a graphical field to your REBAR or MESH content type row.

a. Click Insert --> Graphical Field...

b. Click and drag with the mouse to draw a frame.

8. Double-click the graphical field to open the Graphical Field Properties dialog box.

9. Click Free attributes... and go to the User tab.

10. Add the required bending diagram attributes.

11. Save the template.

Bending schedule attributes on page 11

Example

See also
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Bending schedule attributes
The following table lists the attributes and values that can be used for bending schedules in
templates.

Attribute Default value Available values
FontName romsim Available template fonts

FontSize 2.0 Available font sizes

FontColor 1 (black) 1 = black

2 = red

3 = bright green

4 = blue

5 = cyan

6 = yellow

7 = magenta

8 = brown

9 = green

10 = dark blue

11 = forest green

12 = orange

13 = gray

RotationAxis 2 0 = by view

1 = by global Z

2 = by local axis

Exaggeration 1 0 = no

1 = yes

EndMark 1 1 = straight

2 = half arrow

3 = full arrow

Dimensions 1 0 = no

1 = yes

BendingRadius 0 0 = no

1 = yes

BendingAngle 1 0 = no

1 = yes
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Attribute Default value Available values
ImageWidth Width of the graphical field

multiplied by 4.
Number of pixels

ImageHeight Height of the graphical
field multiplied by 4.

Number of pixels

Creating a template for bending schedules or pull-outs on page 10

Adding images in a template
You can add images in graphical templates. For example, you might want to include a
company logo in your drawings. Tekla Structures supports the following image formats in
graphical templates: .bmp, .jpg, .jpeg, .tif, .tiff and .png.

To add an image in a template:

1. Open an existing graphical template in Template Editor.

2. Add a new row in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

3. Click Insert > Picture to open the Select Picture File dialog box. 

If a local symbols folder exists, the contents of that folder is shown by default. You can
browse the contents of common\symbols folder by selecting that folder. If a local
symbols folder does not exist, Tekla Structures displays the contents of the common
\symbols folder.

4. Select an image from the list and click OK.

5. Click and drag with the mouse to draw a frame for the image.

• Do not add really large images, as they update very slowly.

• The image may look different in the image editor than in the printout or in
the exported DWG file.

• When you export the drawing to DWG, Tekla Structures copies the images in
the same folder as the DWG file. If the image for some reason is not in the
same folder, only the name of the image is displayed together with an empty
frame instead of the image in the DWG.

• If environments have local symbols, the local symbol folder is also included in
the search path with the common\symbols folder. If the local symbols
folder contains files with the same name as common\symbols folder, then
the local symbol file is used.

See also
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• When you open the drawing that contains images inserted in the template,
Tekla Structures first looks for the images in the model folder and then in the
\symbols folder in the current environment.

• You can define a folder where Tekla Structures always looks for images using
the advanced option DXK_SYMBOLPATH. You can also define a firm folder
for your images.

Below are some examples of the Select Picture File dialog box showing folder structure in
different environments.

In the following example, the Tekla logo has been added in a template.

Example
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1.2 Content types
When you create a new row in the template, you must select a content type for the row. The
content type determines which template attributes you can use in that row.

The available content types are:

Content type Description
ASSEMBLY Use to create lists of assemblies and single parts. Includes all

assemblies containing the selected parts and bolts.

BOLT Use to create screw and bolt lists. Includes all bolts connected to
selected parts.

CAST_UNIT Use to create lists of cast units.

CHAMFER Use to create lists of the length of the chamfers.

COMMENT Use to create empty rows or rows that only have textual data or
lines anywhere on a template.

CONNECTION Use to create lists of connections.

DRAWING Use to create drawing lists without revision history information.
Use for reports and included drawings.

HISTORY Use to retrieve history information of the model. You can use this
content type with PART, REBAR, CONNECTION and DRAWING
rows.

The following template attributes can be used with this content
type:

• TYPE: the type of the historical action, for example update or
numbering.

• USER: the user who made the change.

See also
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Content type Description
• TIME: the time the change was made.

• COMMENT: the comment which was entered upon clicking
Save.

• REVISION_CODE: the revision code which was entered upon
clicking Save.

HOLE Use to create lists of holes.

LOAD Use to create lists of loads.

LOADGROUP Use to create lists of load groups.

MESH Use to create lists of meshes.

NUT Use to create lists of nuts. Contains all nuts for bolts associated
with the selected parts.

PART Use to create lists of parts.

REBAR Use to create lists of reinforcing bars.

REFERENCE_MODEL Use to list the reference models.

REFERENCE_OBJECT Use to list the reference model objects in a reference model.

Only reference model objects that have user-defined attributes are
displayed in reports.

REVISION Use to create lists of revision marks.

SIMILAR_ASSEMBLY Use to create lists of similar parts.

To use this content type, you need to have an empty (hidden in
output) ASSEMBLY, PART or CAST_UNIT row in the row
hierarchy above the row with SIMILAR_* content type:

You cannot have any rows below SIMILAR_* row content type
in the row hierarchy.

Note: Used in drawings to collect similar object information from
the model. All the other attribute information is collected from
visible drawing objects.

SIMILAR_CAST_UNIT
SIMILAR_PART

SINGLE_REBAR Use to create lists of individual bars in reinforcing bar groups.

For example, use it to the get the lengths of the individual bars in
tapered reinforcing bar groups.

SINGLE_STRAND Use to create lists of individual prestressed strands.

STRAND Use to create lists of prestressed strands.
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Content type Description
STUD Use to create lists of studs.

SURFACING Use to create lists of surfacings.

SUMMARY Use to summarize the contents of the row(s) that are above 
SUMMARY in the hierarchy.

For example, use PART - SUMMARY hierarchy to summarize the
contents of the PART rows.

TASK Use to create lists of tasks.

WASHER Use to create lists of washers. Contains all washers for all bolts
associated with the selected parts.

WELD Use to create lists of welds.

Template attribute files on page 16

1.3 Template attribute files
Template attributes represent object properties. You can use template attributes in value
fields, formulas, and row rules to get the required data from your Tekla Structures database.

When you output the template, Tekla Structures replaces the attribute with the actual value
of the corresponding object property. For example, if you include the attribute WEIGHT in a
report template, Tekla Structures displays the weight of the model object in the report.

Template attributes are defined in the following files:

File name Description
contentattributes.lst This is a container file listing all the files that

contain the actual attribute definitions. The files are
added with INCLUDE sentences. The order of the

See also
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File name Description
files included in contentattributes.lst
defines the reading order of the files.

This file is overwritten in the installation when you
install a newer version of Tekla Structures. Ensure
that you make a copy of this file before updating.

Generally, there is no need to modify
contentattributes.lst. Do not modify it if
you are not an administrator.

contentattributes_global.lst This file contains attributes that are hard-coded into
the program. Do not edit this file.

contentattributes_userdefine
d.lst

This file contains user-defined attributes, the same
as in the objects.inp file.

This file is overwritten in the installation when you
install a newer version of Tekla Structures. To use
your own attributes in templates and reports, create
a copy of this file and add the necessary attributes
to that file.

By default, these files are located in ..\Program Files\Tekla Structures
\<version>\nt\TplEd\settings, but the location may be different in your
environment.

The search order for the contentattributes.lst file is the following:

1. Model folder

2. Project folder defined by XS_PROJECT
3. Firm folder defined by XS_FIRM
4. Folder defined by XS_TPLED_INI
5. Folder defined by XS_TPLED_DIRECTORY/settings

User-defined template attributes on page 17

User-defined template attributes
User-defined template attributes are defined in the
contentattributes_userdefined.lst file. By default, this file includes most of
the user-defined attributes that are visible in the part properties dialog boxes. To use your
own attributes in templates and reports, you should make a copy of the file, rename it
appropriately, and add the necessary attributes to that file.

See also
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The contentattributes_userdefined.lst file is divided into two sections:

• A list of attribute names and the default settings:

• A list of attributes assigned to content types:

The content type of the row in Template Editor

The attribute hierarchy in Template Editor

Customizable comments, such as the tab name in the user-defined
attributes dialog box

The name of the user-defined attribute, the same as in the
objects.inp file

Adding user-defined template attributes on page 19See also
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Adding comments to user-defined template attributes on page 20

Adding hierarchy to user-defined template attributes on page 21

Adding user-defined template attributes
This example shows how to add your own user-defined attributes to the attribute tree in
Template Editor.

Before you start, add the user-defined attribute to the objects.inp file. For example, you
might add an attribute named MY_ATTRIBUTE to the user-defined properties for drawings.

To add user-defined attributes to the attribute tree:

1. Open the contentattributes_userdefined.lst file in a text editor.

2. Save the file with an appropriate name, for example
MY_contentattributes_userdefined.lst, in the same folder.

3. Add MY_ATTRIBUTE to the list of attribute names and, define the settings as follows: 

4. Add MY_ATTRIBUTE to the list of attributes assigned to content types. 

Select the content type according to which object the attribute is associated to in the
objects.inp file. In this example, the content type is DRAWING. Add the attribute in
the format USERDEFINED.<ATTRIBUTE_NAME>.

5. Save the changes.

6. Open the contentattributes.lst file.

7. Add the following line in the file: 

[INCLUDE MY_contentattributes_userdefined.lst]
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8. Save the changes. 

The attribute is shown in the attribute tree in Template Editor, under DRAWING >
USERDEFINED:

User-defined template attributes on page 17

Adding comments to user-defined template attributes
You can add your own comments to the Template Editor attribute tree.

To add a comment:

1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not modify the
original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Add your comment inside quotation marks, after the attribute name. 

For example:

4. Save the changes. 

See also
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The comment you added is displayed in the attribute tree in Template Editor:

User-defined template attributes on page 17

Adding hierarchy to user-defined template attributes
You can add your own hierarchy to the Template Editor attribute tree.

To add hierarchy:

1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not modify the
original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Define the hierarchy in square brackets, between USERDEFINED. and the attribute
name. 

For example:

Notice the full stops after the brackets, and between the hierarchies.

4. Save the changes. 

See also
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The new hierarchy is shown in the attribute tree:

User-defined attributes are case sensitive. Ensure that you enter the attribute name using
the correct case for all characters.

User-defined template attributes on page 17See also
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2 Reports

You can create reports of the information included in models. These could be lists of
drawings, bolts, and parts, for example. Tekla Structures creates reports directly from the
model, so the information is always accurate. Reports can contain information about selected
parts or the entire model.

Tekla Structures includes a large number of standard report templates. Use Template Editor
to modify the existing report templates, or create new ones to suit your needs. The report
templates are located in the folder ..\ProgramData\Tekla Structures
\<version>\environments\<environment>\system. Report templates have
the file name extension .rpt.

Creating a report on page 23

Templates on page 3

Example

See also
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2.1 Creating a report
When you create a report, you can include the information related to an entire model or only
the selected objects. Tekla Structures automatically selects the related assemblies and other
objects.

To create a report:

1. Open the model.

2. If needed, number the model.

3. Click Drawings & Reports --> Create Report... .

4. Select a report template from the list.

5. If needed, enter the report titles you want to use under Titles in reports.

6. If needed, enter a new name for the report file in the Name box.

7. If needed, set the report options on the Options tab.

8. Unless you want to create a report of the entire model, select the objects you want to
include in the report.

9. Do one of the following: 

• To run a report on the entire model, click Create from all.

• To run a report on the selected model objects, click Create from selected.

You can create reports without numbering the model objects. This is useful when you need
to produce draft reports from large multi-user models. Tekla Structures still warns you if
numbering is not up to date.

Reports on page 23

Report settings on page 28

Creating a report of selected drawings on page 24

Creating a report of nested assemblies on page 25

Creating a report of selected drawings

Before you start, create drawings of the parts you want to include in the report.

To create a report of selected drawings:

1. Open the model.

2. Click Drawings & Reports --> Drawing List...

3. In the Drawing List dialog box, select the drawings you want to include in the report. 

See also
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To select multiple drawings, hold down Ctrl and then click the drawings you
want to select.

4. Click Drawings & Reports --> Create Report... .

5. Select a drawing report template from the list. 

For example, drawing_list or drawing_issue_rev.

6. If needed, enter the report titles you want to use under Titles in reports.

7. If needed, enter a new name for the report file in the Name box.

8. If needed, set the report options on the Options tab.

9. Click Create from selected. 

Tekla Structures automatically selects all the parts in the selected drawings and includes
them in the report.

Report settings on page 28

Creating a report of nested assemblies
You can produce a list of assemblies, or a report of the parts included in the assemblies. If
the report template has a nested assembly structure, Tekla Structures displays the assembly
hierarchy in the report when you view or print it.

To create a report of nested assemblies:

1. Open the model.

2. Select the assemblies you want to include in the report.

3. Click Drawings & Reports --> Create Report... .

4. Select an assembly report template from the list. 

• Assembly_list: creates a list of the assemblies

• Assembly_part_list: creates a report of the parts included in the assemblies

5. If needed, enter the report titles you want to use under Titles in reports.

6. If needed, enter a new name for the report file in the Name box.

7. If needed, set the report options on the Options tab.

8. Click Create from selected.

Report settings on page 28

See also

See also
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2.2 Viewing a report

To view a report you have already created:

1. Click Drawings & Reports --> Create Report... .

2. Click Browse... to locate the report file you want to view.

3. Click Show to view the report.

Defining how reports are displayed on page 26

Defining how reports are displayed
You can define how reports are displayed. For example, you can have Tekla Structures open
all HTML reports in a web browser. By default, all reports are displayed in a new dialog box
within the Tekla Structures window.

To define how reports are displayed:

1. Define which program is used to open a specific type of report file. 

To do this in Windows 7 or Windows Vista, click Control Panel --> Default
Programs --> Associate a file type or protocol with a program .

2. In Tekla Structures, click Drawings & Reports --> Create Report... and go to the
Options tab.

3. In the Show report list, select With associated viewer.

4. Click Save in the Report dialog box.

Viewing a report on page 26

Adding tabs to reports
You can associate Tekla Structures to open reports of a certain type in Microsoft Excel. When
you open such reports in Microsoft Excel, the report template rows might not be divided
correctly into cells. To correct this, you can add tabs between the cells.

To add tabs to a report:

1. Open an existing report template.

2. Add \t between the text and value fields. For example: 

See also

See also
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3. Save the report. 

The output in Microsoft Excel:

The output in a text editor:
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Alternatively, you can use a comma or semicolon as a delimiter between the text fields.
However, the default delimeter may vary between users, and the output might not be
readable in all text editors.

Viewing a report on page 26

2.3 Printing a report

To print a report:

1. Do one of the following: 

• Click Drawings & Reports --> Create Report... and then click Print...

• Click File --> Print --> Print Reports...

2. Use the Browse... button to display the Select file... dialog box, where you can indicate
the folder and file name of the report. 

By default, Tekla Structures uses the Report files (*.xsr) filter to show Tekla Structures
reports only.

3. If needed, modify the print settings. 

• To change the report font, click Select...

• To set printer-specific options such as paper size and orientation, click Printer
setup...

4. Click Print.

Reports on page 23

2.4 Report settings
Use the Report dialog box to view and modify the report settings.

Option Description
Titles in reports Optional report titles.

You can enter up to three report titles. All the titles are not used
in every standard report. Title1, for example, is used to show
phase information in the Assembly_list report.

Browse... Use to change the folder where the report will be stored. By
default, reports are stored in the current model folder.

See also

See also
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Option Description
Show report Defines how Tekla Structures displays reports.

On dialog displays the report in a new window.

With associated viewer displays the report in the associated
program. For example, you can have Tekla Structures open all
HTML reports in a web browser.

Show created report Defines whether or not the report is automatically shown on the
screen after it has been created.

Reports on page 23See also
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3 Tips for templates and reports

This section provides useful hints and tips that help you use templates and reports more
efficiently.

Click the links below to find out more:

• Selecting objects included in reports on page 30

• Useful shortcuts in viewing logs and reports on page 31

• Using text type attribute in calculations on page 31

• Changing value field content if using imperial units on page 32

• Defining customized date format on page 32

• Assembly or cast unit drawing sheet number on page 33

3.1 Selecting objects included in reports
You can select objects, which are included in reports, by using their GUIDs (globally unique
identifiers).

To select objects included in reports:

1. Create a template that is used for creating the report.

a. Click Drawings & Reports --> Template Editor...

b. In Template Editor, click File --> New .

c. Select Textual template and click OK.

d. Add a row for the GUID. 

• Click Insert --> Component --> Row .

Select a content type for the row and clicking OK.

• Click Insert --> Text and enter the text guid:, Guid: or GUID:. Click OK.

This enables the selecting of objects in the model.
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• Click Insert --> Value Field . Click a point to define the location of the field
within the row. The Select Attribute dialog box appears prompting you to select
an attribute for the value field.

Select the attribute GUID and click OK.

e. Add the required amount of other rows in the template.

f. Click File --> Save As... . 

Enter a name for the template and browse the folder ..\environment
\<your_environment>\template . Use the file name extension .rpt.

2. Create a report based on the report template you saved.

a. Click Drawings & Reports --> Create Report...

b. Select the report template you created from the list.

c. Click Create from all. 

Tekla Structures displays the report.

3. Click a row that contains an GUID number in the report. 

Tekla Structures selects the corresponding object in the active model view.

Creating a template on page 3

Creating a report on page 23

3.2 Useful shortcuts in viewing logs and reports
Use the following shortcuts when viewing items in log files and reports:

To Do this
Zoom to the selected objects 1. Hold down Z.

2. Click a row that contains an ID number.

Tekla Structures zooms to the corresponding objects in
the active model view.

Fit the work area to include only the
selected objects

1. Hold down F.

2. Click a row that contains an ID number.

Tekla Structures zooms to the corresponding objects in
the active model view.

Viewing a report on page 26

See also

See also
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3.3 Using text type attribute in calculations

Change text to numeric format

double(GetValue("ASSEMBLY_TOP_LEVEL"))
Change into correct format for calculation (double=decimals)

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)
Add all above into calculation formula

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)+15000
Another example of the same for part elevation

(double(GetValue("TOP_LEVEL"))-
(double(GetValue("BOTTOM_LEVEL"))))*1000

3.4 Changing value field content if using imperial units

Advanced option to check if imperial units are in use

GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1
Translated string call for multi lingual text

GetValue("TranslatedText("albl_Diameter_")")
Formating of units

format(GetValue("DIAMETER"),"Length","inch-frac", 1/16)
format(GetValue("DIAMETER"),"Length","mm", 1)
Combine all above in rule

if GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1 then
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16) + "
Inches"
else
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","mm", 1)+" mm"
endif
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3.5 Defining customized date format

Use mid function to find year, month and day.

mid("","","") string, offset, n
year

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
month

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
days

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
Combine all above in rule

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")

3.6 Assembly or cast unit drawing sheet number

Use match function to find "-" character

match(GetValue("NAME_BASE"),"*-*")
Use of mid function to return only characters after "-"

mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
Combine all above in rule

if (match(GetValue("NAME_BASE"),"*-*"))
then mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
else ""
endif
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4 Disclaimer

© 2015 Tekla Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced Software. Use of the
Software, and use of this Software Manual are governed by a License Agreement. Among
other provisions, the License Agreement sets certain warranties for the Software and this
Manual, disclaims other warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software. All
information set forth in this manual is provided with the warranty set forth in the License
Agreement. Please refer to the License Agreement for important obligations and applicable
limitations and restrictions on your rights. Tekla does not guarantee that the text is free of
technical inaccuracies or typographical errors. Tekla reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by international treaties.
Unauthorized reproduction, display, modification, or distribution of this Manual, or any
portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the
full extent permitted by law.

Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tedds, Solve, Fastrak and Orion are either
registered trademarks or trademarks of Tekla Corporation in the European Union, the United
States, and/or other countries. More about Tekla trademarks: http://www.tekla.com/tekla-
trademarks. Trimble is a registered trademark or trademark of Trimble Navigation Limited in
the European Union, in the United States and/or other countries. More about Trimble
trademarks: http://www.trimble.com/trademarks.aspx. Other product and company names
mentioned in this Manual are or may be trademarks of their respective owners. By referring
to a third-party product or brand, Tekla does not intend to suggest an affiliation with or
endorsement by such third party and disclaims any such affiliation or endorsement, except
where otherwise expressly stated.

Portions of this software:

D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.

EPM toolkit © 1995-2004 EPM Technology a.s., Oslo, Norway. All rights reserved.

Open CASCADE Technology © 2001-2014 Open CASCADE SA. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

Teigha © 2003-2014 Open Design Alliance. All rights reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.
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FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved.

This product contains proprietary and confidential technology, information and creative
works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication,
distribution, display, modification, or transmission of such technology in whole or in part in
any form or by any means without the prior express written permission of Flexera Software
LLC is strictly prohibited. Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or rights under any
Flexera Software LLC intellectual property rights, whether by estoppel, implication, or
otherwise.

To see the third party licenses, go to Tekla Structures, click Help --> About and click the
Third party licenses button.

The elements of the software described in this Manual are protected by several patents and
possibly pending patent applications in the European Union and/or other countries. For more
information go to page http://www.tekla.com/tekla-patents.
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