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The Definitive Guide to Network Troubleshooting 
 

These instructions will help you connect your client computer(s) when the connection to the 

server computer is lost. These instructions assume that the software on your server computer is 

currently installed and functioning properly. 
 

Check Server Connection 
 

1. Obtain the correct server name by opening the program on a computer that is working 

(either another client or the server itself). While Inside the program go to the File drop-

down menu at the top-left, and then select Database Controls. This window will display the 

correct Server Name near the bottom. Record this information so that you may use it to 

configure your client computer(s)
1
. 

 

 
 

2. Go to the client computer that is not working and try opening the program.    
 

• If you get a message stating that the SQL Server could not be found click on the 

Continue without Connecting button. This should bring you to a screen that says No 

Database Open. Go to the File drop-down menu at the top-left and select Database 

Controls. Then click the Select Server button at the bottom. 

• If you get a window indicating that the program is attempting to establish a connection 

with the database that stays on your screen for more than a few moments, click the 

Cancel button once it becomes available. This will bring you to the Select Server screen. 

• If the program opens but appears to be using a different database than the server 

computer, go to the File drop-down menu at the top-left and select Database Controls. 

Then click on the Select Server button at the bottom. 
 

 

 

 

 

 

 

1: You will encounter problems if your client computer(s) and your server computer share the 

same computer name(s), i.e. DESKTOP-WORK and DESKTOP-WORK. If this is the case, one or 

more of the computer names will have to be changed through your computer’s properties 

before a connection between the client and server computers can be established. 
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3. On this screen, select the This computer is a client option. Type in the name of the server 

computer you found from Step 1 in the text box labeled The server is. Click the Connect 

button (or OK if you have a version of the software prior to version 7). 
 

 
 

At this point if everything is configured correctly, you will be asked to enter in your database 

password if you originally entered one. If not the client computer will be reconnected with the 

server computer and your database will be opened. If you instead receive an error message 

saying SQL Server was not found or is not functioning properly, then this would most likely be 

caused by one of two reasons: 
 

1. There is a firewall enabled on the server computer that is blocking the client computer from 

connecting. 
 

2. Your business’s network is not functioning properly. 
 

You can click OK on this message, but do not close out of the Select Server screen for now. 
 

Firewall Troubleshooting 
 

Go to the server computer and verify that all firewalls are turned off. This includes, but is not 

limited to, the Windows Firewall that comes installed on Windows XP, Windows Vista, 

Windows 7, and Windows 8 computers.  You should also check to see if there is a firewall built 

into your antivirus software on the server computer, such as Norton AntiVirus or McAfee 

AntiVirus. Disable the firewall in these programs also.  Since there are many different antivirus 

programs, we cannot provide these instructions.  However, to disable the Windows Firewall, 

perform the following steps: 
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For Windows XP – Windows 7 Computers 
1. On your server computer go to the Windows Start button (bottom, left corner of your 

Desktop) and click on Control Panel.   
 

2. Open Security Center.   
 

3. Open Windows Firewall. 
 

4. If you’re running Windows Vista or Windows 7, click on Turn Windows Firewall on or off. 
 

5. Toggle the Windows Firewall to be off. 

 

For Windows 8 Computers 

1. Click on the Windows button on your keyboard, which will bring you to the Windows 8 

home screen.  

2. From there, type Windows Firewall and click on the Settings option under the search bar. 

3. Open Windows Firewall 

4. Click on Turn Windows Firewall on or off 

5. Toggle the Windows Firewall to be off 
 

With the Firewall turned off
2
, try connecting again from the client computer by clicking the 

Connect button from the Select Server screen.  If it is still unsuccessful, or if Windows Firewall 

was already turned off, browse through the programs on the server computer to see if there 

exists another firewall installed on your computer from an antivirus program. 
 

Network Troubleshooting 
 

Aside from a firewall issue, the other most likely reason that the client cannot connect to the 

server is that the client cannot see the server computer over the network. The most common 

symptom of this is that the client or the server computer no longer has access to the Internet. 

However, if the Internet is working on both computers then there may be another problem 

with the network configuration that prevents the two computers from communicating directly. 

To be certain that there is a network configuration problem, perform the following steps: 
 

1. From the client computer you can ping the server computer. A ping test will let you know if 

one computer can contact another computer through a network. 
 

2. On your client computer, go to Windows Start > All Programs > Accessories > Command 

Prompt. Or for Windows 8, click the Windows button on the keyboard then type cmd to 

search for command prompt.  From there, open Command Prompt 
 

3. Type in ping [server computer’s name], where [server computer’s name] is replaced by the 

server’s actual name. The server name is the name from Step 1 on Page 1 of this document.   
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2: If you don’t want disable a firewall entirely for safety purposes, then you can set up firewall 

exceptions for Microsoft SQL Server instead of turning the firewall completely off by following 

the instructions in our document Using Windows Firewall in Network Environment located at: 

http://www.daysmart.com/downloads/archive/docs/Windows_Firewall_Exceptions.pdf 

However, because it is generally a lot faster you should consider turning the firewall entirely off 

first just to verify that this is the actual problem. If you disable the firewall and find your client 

can connect, then you can always go back to the server and enable the firewall again to set up 

the firewall exceptions. 
 

For example, if you found the server name from Step 1 on Page 1 to be THOMAS\CMJ, then the 

server computer’s name is THOMAS. In this case you would type ping THOMAS, and then hit 

the Enter key on your keyboard. 
 

A successful ping will give you a response similar to this: 
 

 
 

An unsuccessful ping will give you a response similar to this: 
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Or this… 
 

 
 

If you were able to successfully ping the server computer from the client, then it is most likely 

not a network issue. You may want to go back into looking through your system for a firewall, 

or continue on to the next section, Other Suspects. 
 

If you were not able to ping the server, then you are experiencing a network problem. Below 

are a few basic troubleshooting measures to try out if you cannot ping the server: 
 

1. Restart both the client and server computers. 
 



 

Page 6 of 9 

 

30475 S Wixom Road 

Suite 100 

Wixom MI, 48393 

800.423.8100 

 

 

2. Verify that both the server computer and the client computer are connected to the network 

router. You should verify that all cables are connected snugly on the back of the 

computer(s) and the router. 
 

3. If one (or both) of the computers is connected to the router wirelessly, be sure that the 

computer has a strong signal. 
 

4. Reset your router (using a reset button or by unplugging it for a few minutes and plugging it 

back in) and reconnect the computers in the network. 
 

If you performed the above steps and still cannot connect to the server computer from your 

client computer, and you are certain that both computers are connected to the router, i.e. they 

both have Internet access, then you can try to configure the settings in the software to connect 

using the server computer’s IP address
3
 instead of the server name. 

 

 

 

 

 

3: Connecting to your server computer using the IP address is NOT recommended if your 

computer is assigned an IP address dynamically. 

Connecting Your Server Using an IP Address 
 

When a computer is assigned an IP address dynamically, the computer is assigned a new IP 

address each time it connects to a network. In other words, your client computer(s) will lose 

connection to the server computer again every time they connect to the network. If you are not 

sure if your IP address is assigned dynamically or statically, do not use this method, as a 

dynamic IP address is the most common method for assigning an IP address on a PC computer, 

especially if you are using a wireless router or your network was set up automatically. 
 

Perform the following steps if your server has a static IP address, or if you would like to connect 

to the server by the IP address as a temporary solution: 
 

1. Go to the server computer and bring up the command prompt by going to Windows Start > 

All Programs > Accessories > Command Prompt. Or for Windows 8, click the Windows 

button on the keyboard then type cmd to search for command prompt.  From there, open 

Command Prompt. In the Command Prompt type ipconfig. You will see some information 

about your computer’s network. 
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Note: If you have Windows XP then look for the number labeled IP Address. In Windows Vista, 

Windows 7, and Windows 8 this number is renamed to IPv4 Address (there is a lot more 

information shown that can be ignored). 
 

2. Go back to the client computer and then go to the Select Server screen. 
 

3. Replace the server name with the IP Address you obtained in Step 1 on this page. Click the 

Connect button (or OK depending on the version you are running).   
 

 
 

If this is unsuccessful, try to ping the IP address from the client the same way you pinged the 

server name.   
 

• If it cannot ping the IP address, then your two computers are most likely not on the 

same network. Check all connections and verify that both are connected to the same 
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router, or contact your business’s network administrator to have them set the network 

up properly. 

• If the client can ping the server’s IP address but still not connect through the Select 

Server screen, check for firewalls on the client computer and try to establish a 

connection. 
 

Again, connecting by the IP address should only be viewed as a temporary solution unless your 

server has a static IP address. If you can connect by the IP address but not the computer’s 

name, this is a DNS issue within Windows. If this is the case you can either configure your server 

to have a static IP address or set up a new Local Area Network (LAN) in your Windows operating 

system. The steps to do either of these should be provided by the documentation that came 

with your router. 
 

Other Suspects 
 

Roughly 99% of all client connectivity issues result from server-side firewalls or network 

problems. You should not attempt any of the below until you have exhausted all of the 

possibilities described above, including contacting your network administrator if you have one 

available. 
 

If there are no server-side firewalls and you are able to ping the server computer using the 

server’s name or IP address, then here are a few other potential problems that could cause a 

client computer to be unable to connect to the server computer. 
 

1. Client-side outbound firewalls: Certain antivirus packages have built-in outbound firewalls.  

The Windows Firewall discussed earlier is exclusively an inbound firewall, so this does not 

need to be disabled on the clients. If your antivirus software does have an outbound 

firewall, you can disable it entirely or set up the firewall exceptions the same way you 

would for an inbound firewall. 
 

2. SQL Server Browser is disabled: SQL Server Browser is a component of SQL Server 2008 

Express that is installed on your server computer. To check if it is disabled on your server 

computer go to Windows Start > All Programs > Microsoft SQL Server 2008 > Configuration 

Tools > SQL Server Configuration Manager. For Windows 8, click the Windows button on 

the keyboard then type SQL Server Configuration Manager and open the program. Click on 

SQL Server 2008 Services. In this screen you will see SQL Server Browser. Make sure that its 

state is Running and its start mode is Automatic. 
 

3. TCP/IP is disabled for the SQL Server instance: To check if it is disabled on your server 

computer go to Windows Start > All Programs > Microsoft SQL Server 2008 > Configuration 

Tools > SQL Server Configuration Manager. For Windows 8, click the Windows button on 

the keyboard then type SQL Server Configuration Manager and open the program. Expand 

SQL Server 2008 Network Configuration and select the Protocol for [instance name], i.e. 
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CMJ. Make sure TCP/IP says Enabled. If it does not, right-click on it and select Start. Then go 

back to SQL Server 2008 Services and right-click on the SQL instance and select Restart. 
 

 
 

4. Miscellaneous SQL Server 2008 problems: Certain errors with SQL Server 2008 will cause 

clients to be unable to connect. If this is the case, all client computers will be unable to 

connect. As a last resort and if you are absolutely sure that you have a backup of your 

database, then you can uninstall and reinstall SQL Server 2008 on your server computer. If 

you do this you will need to restore your backup onto the server computer once the new 

SQL installation is complete to retrieve all of your data. 
 

5. SQL Server Browser cannot start: Very rarely SQL Server Browser cannot start after 

reinstalling, or a computer cannot accept inbound connections. If this happens you can 

make a different computer in your network the server computer and reconfigure each of 

your clients and your previous server to connect to the new server. For instructions see:  

 

http://downloads.daysmart.com/Docs/DocumentLibrary/SwitchingAClientAndServer.pdf 

 


