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Summary 
 
   The electromagnetic field simulation software package CST 
MICROWAVE STUDIO (MWS) was used to compute the 
cold-test parameters—frequency-phase dispersion, on-axis 
impedance, and attenuation—for a traveling-wave tube (TWT) 
slow-wave circuit.  The results were compared to experimental 
data, as well as to results from MAFIA, another  
three-dimensional simulation code from CST currently used at 
the NASA Glenn Research Center (GRC).  The strong 
agreement between cold-test parameters simulated with MWS 
and those measured experimentally demonstrates the potential 
of this code to reduce the time and cost of TWT development. 
 
Introduction 
 
   CST MICROWAVE STUDIO (MWS) is electromagnetic 
field simulation software for the analysis and design of 
components such as antennas, filters, transmission lines, 
couplers, and resonators.  To suit a variety of applications, the 
software contains four different simulation techniques: a 
Transient Solver, a Frequency Domain Solver, an Eigenmode 
Solver, and a Modal Analysis Solver.  The simulations 
described in this report use the Eigenmode Solver.  MWS has 
a user-friendly, Windows-based interface, making it simple to 
model three-dimensional (3D) structures.  The code includes 
the option of user defined or automatic meshing and features a 
Perfect Boundary Approximation (PBA) method.  This 

method allows mesh cells to be partially filled for a more 
accurate representation of shapes that do not conform to the 
Cartesian (x,y,z) or cylindrical (r,θ,z) coordinate systems, 
compared to MAFIA (solution of MAxwell’s equations by the 
Finite Integration Algorithm) (refs. 1 and 2), which represents  
shapes with only rectangular or triangular mesh cells.  MWS 
features optimizer and parameter sweep tools.  In addition, 
procedures can be automated with Visual Basic for 
Applications (VBA) macros (ref. 3). 
   In this report, the accuracy and efficiency of MWS for 
simulating cold-test parameters is established for a ferruled 
coupled-cavity traveling-wave tube (TWT) circuit.  In 
addition, compared to measured data, the MWS simulations 
are shown to be more accurate and more computationally 
efficient than previously calculated MAFIA results. 
 
CST MICROWAVE STUDIO 
 
   A screenshot of the MWS Windows-based graphical user 
interface is shown in Figure 1.  When first using MWS, the 
Quick Start Guide from the Help menu is useful.  It lists the 
steps involved in using a particular solver.   
 
Initialization 
 
   The first step for eigenmode analysis is to define units of 
length, frequency, and time in the Units window under the 
Solve menu.  Note, a unit of length should be selected such 
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that all critical parameters of the structure are greater than one.  
The background material must also be entered under the Solve 
menu.  If the structure is entirely encased in metal, the 
background material can be set to PEC (Perfect Electrical 
Conductor).  Next, the frequency range of interest must be 
defined.  Lastly, variables for the structure dimensions can be 
entered in the Parameters box under the Edit menu.  If a 
variable is assigned to each dimension and only the variables 
are used to define the structure, the circuit can be changed by 
simply editing the values of the variables in the Parameter 
List. 
 

 
Figure 1.—MWS user interface. 

 
Modeling the Structure 
 
The first step in modeling a structure is to define the materials 
it consists of.  Under the Objects → New Layer menu, the user 
can define the name, type, material properties, and color of 
new layers.  The next step in defining the structure is to 
construct its geometry using the 3D shape tools under the 
Object menu. Some useful tools are the brick, cylinder, sphere, 
cone, and extrude.  Coordinates can be entered graphically 
using the mouse or numerically using the Tab or Esc keys.  
Again, it is very useful to define the shapes in terms of 
parameters for easy editing. 
   Once an object has been defined, it can be transformed 
under the Objects → Transform Shape menu.  The transform 
operations available are: translate, scale, rotate, and mirror.  A 
very useful transformation is to check the multiple objects 
option while translating an object.  This effectively copies and 
pastes the object, eliminating the need to define repetitive 
parts of the geometry. 
   In MWS, a complex shape can be created by combining 
simple shapes.  If overlapping shapes are defined, MWS will 
prompt the user for a Boolean operation to combine them.  
The Boolean operations available for combining shapes are 
addition, subtraction, intersection, and insertion.  The user 
may select none, but this is only recommended if one of the 

shapes is PEC or if the two shapes touch, but do not overlap 
(refs. 3 and 4). 
   While defining the structure, changing the view can be very 
helpful to check the model.  The user may zoom in and out 
with the dynamic zoom or zoom in on a particular section with 
the box zoom.  Pressing the space bar will return the view to 
the best fit of the structure.  The structure can be turned with 
the free rotate and planar rotate tools.  The user can also take 
advantage of the cutting plane tool to view a cutaway version 
of the model.  Additionally, by selecting layers from the 
Navigation Tree, the structure can be viewed one layer at a 
time. 
   One of the most useful features of MWS is the History List, 
which is found under the Edit menu.  This list shows all 
previous operations in chronological order.  From the list, any 
operation can be added, hidden, deleted, or edited.   
 
Mesher 
 
   MWS uses the Finite Integration Method with the Perfect 
Boundary Approximation for spatial discretization.  The mesh 
is produced by an automatic mesh generator, which ensures a 
good compromise between accuracy and simulation time.  
Through the Mesh Properties dialog box, the user can enter 
values for the number of mesh lines per wavelength, the lower 
mesh limit, the ratio limit, and the adaptation limit.  In 
addition, this dialog box lists the number of mesh lines in the 
x, y, and z directions and the total number of mesh cells.  Note, 
the Parameter and History lists cannot be edited and macros 
cannot be run while in the Mesh View. 
   MWS also gives users the option to create a manual mesh.  
This is done by entering new fixpoints at all the boundaries of 
the structure.  Intermediate fixpoints can then be inserted in 
between existing fixpoints.  Once the user has defined a 
manual mesh, any changes made to the geometry of the 
structure will result in an error.  Therefore, if the user intends 
to vary the parameters of a structure, automatic meshing 
should be used. 
 
Eigenmode Solver 
 
   A major disadvantage of MWS, compared to MAFIA, is that 
the current version (3.4) does not have the ability to simulate 
periodic boundary conditions which allow the user to simulate 
a single circuit period and set an arbitrary phase advance in the 
longitudinal direction.  Using MWS, the user must model 
several periods and truncate the longitudinal boundaries with 
electric (E) or magnetic (M) walls to force a discrete phase 
advance (ref. 5).  An electric wall is a boundary that simulates 
a perfect conductor.  This forces the electric field to be 
perpendicular to the wall.  At a magnetic wall boundary the 
magnetic field is forced to be perpendicular to the wall.  These 
boundary conditions can be input from the Solve menu. 
   Symmetry planes are another useful tool that can be 
activated from this dialog box.  Symmetries can be set in the 
yz, xz, or xy planes and can either be magnetic or electric.  For 
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each symmetry plane used, the simulation time is reduced by a 
factor of two. 
   The Eigenmode Solver parameters can be set from the Solve 
menu.  These parameters include the number of modes 
desired, accuracy, frequency estimate, and the number of 
iterations.  Unlike MAFIA, setting a larger number of modes 
than desired does not increase precision in MWS.  Changing 
the accuracy, frequency estimate, or the number of iterations 
may improve results, but at the cost of increased simulation 
time.  Generally, these parameters can be left at their default 
settings.  However, if improved accuracy is needed, ref. 3 
suggests setting the frequency estimate to approximately  
1.2 times the highest expected frequency.  Once all the 
parameters are set, the solver can be started. 
 
Post Processing 
 
   MWS allows the user to view the electric and magnetic 
fields of the calculated modes through the 2D/3D  
Results → Modes folder in the Navigation Tree.  The cutting 
plane tool is very useful for getting a better view of the fields.  
The Plot Properties dialog box can be accessed under  
Results → Vector Plot or by right clicking with the mouse on 
the Drawing Plane.  Here the plot type, phase, and number of 
objects plotted can be edited.   
   Under the Results menu, the user can access a simulation 
summary by selecting View Logfiles → Solver Logfile.  This 
file contains units, a mesh summary, boundary conditions, 
modal frequency results, and the solver time associated with 
the simulation.  The modal frequency results are used to create 
the dispersion curve, as will be discussed later.  Another 
useful item located in the Results menu is the Loss and Q 
Calculation tool.  Here the user can enter values for the 
conductivity and permeability of each layer that was set to 
PEC during the solver run (the conductivity or tangent delta 
for the dielectric layers have to be set before the solver run) 
and then calculate the power loss and Q factor of the circuit.  
The power loss is used to calculate the attenuation. 
   MWS contains a VBA editor and debugger; therefore, the 
majority of post-processing can be done very efficiently with 
user-defined macros.  The user can take advantage of standard 
VBA language elements as well as the CST MWS language 
specific extensions.  Particularly useful commands are 
GetFieldVector and GetTotalLoss, which are used for the 
automation of the impedance and attenuation calculations, 
respectively. 
   The ability to export data and images is included in MWS.  
To export bitmap images, select BMP under the File → Export 
menu; or for immediate use, select Edit → Copy View to 
Clipboard.  To export the field data, there are several different 
methods available.  The user can select the field of interest 
from the 2D/3D Results → Modes folder in the Navigation 
Tree and then export the data by selecting Plot Data (ASCII) 
under the File → Export menu.  Note, the amount of data 
exported by this method is proportional to the number of 
arrows selected in the Plot Properties dialog box.  If the user is 

only interested in analyzing the fields in one dimension of the 
circuit, the VBA code macro.910 – 1D Plot of 2D/3D Data 
Fields, can be executed to do this.  Users can acquire this and 
several other useful macros from CST.  Please note that these 
macros are supplied in addition to the standard MWS package; 
therefore technical support is limited. 
Analysis 
 
   Following the dispersion simulation procedure described in 
ref. 5, the frequency-phase dispersion characteristics were 
obtained by modeling two- and three- cavity configurations of 
the structure.  The different eigenmodes were forced by 
axially truncating the different cavity configurations with 
electric and magnetic boundaries, which corresponds to 
simulating standing waves with an integral number of half-
wavelengths (phase shifts of π) in the length of the circuit.  
The cavity configurations and boundary conditions required to 
obtain several resonant frequencies are shown in Table 1.  The 
on-axis interaction impedance for the nth RF space harmonic 
and the attenuation per cavity were obtained using the 
procedures outlined in ref. 5. 
 

TABLE 1.—BOUNDARY CONDITIONS FOR 
RESONANCE AT VARIOUS PHASE  

SHIFTS PER CAVITY 

Cavities Boundary 
conditionsa 

Phase shift per cavityb, 
β1L, deg 

2 M,E 225,315 (315,225) 
3 M,E 210,270,330 (330,270,210) 
3 E,E 240,300,360 (300,240) 

aElectric wall, E; magnetic wall, M. 
bSlot-mode phase shifts are in parentheses. 
 
 

Results 
 
Dispersion Simulations 
 
   The ferruled coupled-cavity circuit [ref. 6] has coupling slots 
which are rotated 180° at alternating cavity partition walls.  
Ferrules, hollow posts surrounding the beam hole, concentrate 
the RF electric field in the beam region to increase the on-axis 
interaction impedance of the cavity.  The ferruled coupled-
cavity circuit was created using cylinder and brick shapes.  
The structure is fully encased in metal, so the background 
material was set to PEC.  The metal layer which includes the 
circuit elements was also set to PEC and the air layer was 
defined as normal with permittivity (ε) = 1 and permeability 
(µ) = 1.  The primary motivation for simulating the ferruled 
coupled-cavity circuit was to compare MWS’s performance to 
that of MAFIA.  In doing so, the validity of MWS’s model 
could be verified.  Therefore, manual meshing was used in this 
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circuit to create a grid with a cell resolution of 53 by 53 in the 
transverse (xy) plane and of 29 cells per cavity in the 
longitudinal (z) plane.  This is the exact mesh used in the 
MAFIA simulations.  The lines of the mesh were spaced as 
equally as possible with grid boundaries matching major 
geometrical features such as the beam hole and ferrules.  The 
boundary conditions were set according to Table 1. 
   The resonant frequencies computed with MWS and MAFIA 
are compared with fitted experimental data (ref. 7) normalized 
to the center frequency of operation for the cavity and slot 

modes in Table 2 and in Figure 2.  Compared with the 
experimental data, the MWS results are consistently lower by 
an average of 0.43 percent for the cavity mode and an average 
of 0.09 percent for the slot mode.  In comparison, for the same 
grid resolution, the MAFIA results are consistently lower than 
the experimental results by an average of 0.86 percent for the 
cavity mode and of 0.92 percent for the slot mode.  Therefore, 
the MWS simulations show better agreement with measured 
data, particularly at higher frequencies. 

 

TABLE 2.—RESONANT FREQUENCY PERCENT ERROR FOR  
THE FERRULED COUPLED-CAVITY CIRCUIT 

Phase shift  
per cavity,  
β1L, deg 

MAFIA cavity 
mode frequency 

 difference,  
|∆f|, percent 

MWS cavity 
mode frequency  

difference,  
|∆f|, percent 

MAFIA slot 
mode frequency 

 difference,  
|∆f|, percent 

MWS slot    
mode frequency 

difference,     
|∆f|, percent 

210 
225 
240 
270 
300 
315 
330 
360 

0.94 
0.95 
0.95 
0.88 
0.80 
0.78 
0.73 
0.81 

0.41 
0.42 
0.43 
0.37 
0.35 
0.38 
0.40 
0.65 

0.97 
0.96 
0.98 
0.96 
0.84 
0.84 
0.91 

- 

0.11 
0.12 
0.16 
0.13 
0.03 
0.06 
0.05 

- 
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Figure 2.—Normalized experimental data, MWS and MAFIA simulations of dispersion  

for cavity and slot modes of the ferruled coupled-cavity circuit. 
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Impedance Simulations 
 
  Table 3 and Figure 3 compare the on-axis interaction 
impedances normalized to that at the operating frequency 
calculated with MWS and MAFIA with those measured 
experimentally (ref. 7).  The MWS results match the 
experimental results well, having an average absolute 
difference of 3.39 percent between 210° and 315°.  They show  

slightly better agreement than the MAFIA results, which have 
an average absolute difference from the experimental data of 
3.77 percent between 210° and 315°.  Note that both MWS 
and MAFIA had poor results for a phase shift of 330° per 
cavity.  This may be due to some error in determining the 
group velocity where the dispersion curve starts to flatten or it 
may be due to experimental error. 
  

 

TABLE 3.—ON-AXIS INTERACTION IMPEDANCE PERCENT ERROR  
FOR THE FERRULED COUPLED-CAVITY CIRCUIT 

Phase 
shift 

per cavity, 
β1L, deg 

MAFIA 
impedance 
difference, 

|∆K1|, percent 

MWS 
impedance 
difference, 

|∆K1|, percent 
210 
225 
240 
270 
300 
315 
330 

3.77 
7.22 
5.45 
1.98 
0.71 
3.47 

18.24 

0.50 
5.77 
5.87 
2.93 
0.38 
4.86 

17.69 
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Figure 3.—Normalized experimental data, MWS and MAFIA simulations of on-axis  
interaction impedance for the ferruled coupled-cavity circuit. 
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Attenuation Calculations 
 
   The attenuation of the ferruled coupled-cavity circuit was 
calculated according to the procedure outlined in ref. 5.  Note 
that the value of conductivity that matches the experimental 
data is lower than the theoretical conductivity since actual 
 

 circuit losses are greater than theoretically predicted values 
due to machining, oxidation, and surface irregularities (ref. 8).  
Table 4 and Figure 4 compare MWS and MAFIA simulated 
results with the experimentally estimated results normalized to 
the value at the center frequency of operation. 
 
 
 
 
 
 

TABLE 4.—ATTENUATION PERCENT ERROR FOR THE FERRULED  
COUPLED-CAVITY CIRCUIT OVER THE CIRCUIT BANDWIDTH 

Normalized frequency,
f, GHz 

MAFIA 
attenuation 
difference, 

|∆α|, percent 

MWS 
attenuation 
difference, 

|∆α|, percent 
0.96 (lower band edge)
1.00 (center frequency)
1.04 (upper band edge)

4.52 
0.59 
6.01 

2.47 
1.77 
5.58 
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Figure 4. —Estimated experimental data and MWS and MAFIA simulations of attenuation  
for the ferruled coupled-cavity circuit over the bandwidth of operation. 
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Conclusions 
  
   A ferruled coupled-cavity TWT circuit was simulated in 
MWS.  Methods for calculating frequency-phase dispersion, 
on-axis interaction impedance, and circuit attenuation in MWS 
were developed.  The results of these methods proved to be 
more accurate and less time-consuming than MAFIA 
simulations.  For the dispersion calculations, excellent 
agreement with experimental results was obtained; the ferruled 
coupled-cavity circuit model resulted in an average absolute 
frequency difference of 0.26 percent.  Using MAFIA, an 
average absolute frequency difference of 0.89 percent was 
achieved.  The on-axis interaction impedance and attenuation  
also  showed  good  agreement.   For  the  ferruled coupled-
cavity circuit, MWS on-axis interaction impedance results had 
an average absolute difference of 3.39 percent between 210° 
and 315° while MAFIA had an average absolute difference of 
3.77 percent.  The MWS attenuation results had an average 
absolute difference of 3.27 percent while the MAFIA 
attenuation results had an average absolute difference of  
3.71 percent.  In general, the time required for MWS 
simulations on a 1.4 GHz dual processor PC was a factor of 
four times smaller than the time required for MAFIA 
simulations on a Sun Ultra 80 workstation.  These results 
demonstrate the accuracy of MWS simulations and their 
capability to reduce expensive and time-consuming 
experimental cold-test procedures in the design process for 
TWT slow-wave circuits.   
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