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Topic 4: Data Visualization, Excel Dashboards and Data Storytelling (Excel Charts,
Pivot Charts, Excel Dashboards & Interactivity — using Form Controls, Dashboards

collaboration & Publishing)

Excel Charts

A simple chart in Excel can say more than a sheet full of numbers. As you'll see, creating charts is very
easy.

Create a Chart
To create a line chart, execute the following steps.

1. Select the range A1:D7.

A B C D E

1 |Month | Bears Dolphins Whales

2 |lan 8 150 80

3 |Feb 54 77 34

4 |Mar 93 32 100

5 |Apr 116 11 76

6 |May 137 il 93

7 |Jun 184 1 ?2.

g

2. On the Insert tab, in the Charts group, click the Line symbol.
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3. Click Line with Markers.

7 [

Line with Markers

Use this chart type to:
» Show trends over time (years,
manths, and days) or categories,

2-D Line

21

5

Use it when:
» The order of categories is
important.
2-D Area » There are few data points.
3-D Area

alalia

E Mare Line Charts...
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Note: enter a title by clicking on Chart Title. For example, Wildlife Population.

Change Chart Type



You can easily change to a different type of chart at any time.

1. Select the chart.

2. On the Design tab, in the Type group, click Change Chart Type.
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Switch Row/ Select Change% Maove
Colurmn Data Chart Type Chart

Data Type Location

3. On the left side, click Column.
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Change Chart Type
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4. Click OK.
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Result:
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Switch Row/Column

If you want to display the animals (instead of the months) on the horizontal axis, execute the following
steps.

1. Select the chart.
2. On the Design tab, in the Data group, click Switch Row/Column.
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Column  Data Chart Type Chart
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Result:
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Legend Position
To move the legend to the right side of the chart, execute the following steps.
1. Select the chart.

2. Click the + button on the right side of the chart, click the arrow next to Legend and click Right.
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200
180
160
140
120
100

& 3

g
3
i
3
&

Axes

Aocis Titles
Chart Title
Data Labkels
Data Table
Error Bars
Gridlines

Legend

ORIEOOOEROE

Trendline

Bears

Data Labels

Right [

Top
Left
Bottom

Mare Options...

Wildlife Population

Dolphins

In@7uest

Research & Consulting

<1\ [+

m lan
B Feb
m Mar
W Apr
u May

N Jun

Whales

You can use data labels to focus your readers' attention on a single data series or data point.
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1. Select the chart.

2. Click a green bar to select the Jun data series.
3. Hold down CTRL and use your arrow keys to select the population of Dolphins in June (tiny green bar).

4. Click the + button on the right side of the chart and click the check box next to Data Labels.

. Chart Elements

Axes
& [] Axis Titles

Chart Title
? Data Labels P
Data Table
I:' Errar Bars
Gridlines
Legend

|:| Trendline
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A pivot chart is the visual representation of a pivot table in Excel. Pivot charts and pivot tables are
connected with each other.

Pivot Charts

Below you can find a two-dimensional pivot table. Go back to Pivot Tables to learn how to create this pivot
table.

A B . D E F G H I ]

1 |Category (All) -

2

3 |Sum of Amount Column| -

4 |Row Labels |~ Apple Banana Beans Broccoli Carrots Mango Orange Grand Total
5 |Australia 20634 52721 14433 17933 8106 91386 a8680 131713
6 |Canada 24867 33775 12407 3767 19929 94745
7 |France 80133 36094 60 5341 9104 7338 2256 141056
8 |Germany 9082 39686 29905 37197 21636 8YVS 8887 155168
9 |Mew Zealand 10332 40050 43390 12010 Bo7a2
10 |United Kingdom 17534 42908 5100 38438 41815 5600 21744 173137
11 |United States 28615 95061 7163 26715 56284 22363 30932 267133
12 | Grand Total 191257 340295 57281 142439 136945 57070 104438 1029734
13

Insert Pivot Chart
To insert a pivot chart, execute the following steps.
1. Click any cell inside the pivot table.

2. On the Analyze tab, in the Tools group, click PivotChart.

i O == ||[ig % e =

Fields, ltems, PrvotChart Recommended Field +/- Field
8 Sets - PivotTahles List Buttons Headers
Calculations Tools Show

The Insert Chart dialog box appears.
3. Click OK.

Below you can find the pivot chart. This pivot chart will amaze and impress your boss.
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Category =
Sum of Amount

100000
90000
80000 Product ~
70000 W Apple
ggggg m Banana
40000 M Beans
50000 Broccol
20000
10000 I I | I ‘ I I I | I‘ m Carrots

SO | {710 O T
m Mango

Australia Canada France Germany New United United
Zealand Kingdom States

Country =

Note: any changes you make to the pivot chart are immediately reflected in the pivot table and vice versa.
Filter Pivot Chart
To filter this pivot chart, execute the following steps.

1. Use the standard filters (triangles next to Product and Country). For example, use the Country filter to
only show the total amount of each product exported to the United States.

Category =
Sum of Amount

100000
90000 Product
80000
70000 W Apple
60000 m Banana
=0000 M Beans
40000
20000 Broccol
20000 W Carrots
10000

0 [ ] m Mango
United States

Country T

2. Remove the Country filter.

3. Because we added the Category field to the Filters area, we can filter this pivot chart (and pivot table)
by Category. For example, use the Category filter to only show the vegetables exported to each country.
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Category =T
Sum of Amount
60000

50000

40000

Product =
30000 m Beans
20000 m Broccol
10000 I I mCarrots
o | (| « ol 1

Australia Canada France Germany Mew United United
Zesland Kingdom States

Country =

Change Pivot Chart Type
You can change to a different type of pivot chart at any time.
1. Select the chart.

2. On the Design tab, in the Type group, click Change Chart Type.

& Bl B

Switch Row/ Select Changeb Mawve
Column Data Chart Type Chart

Data Type Location

3. Choose Pie.
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Change Chart Type

All Charts

";’ Recent
T Templates
|_I[|_ Column
@ Line

E Bar
WA Area

|22 XV (Scatter)
IQ Map

[iﬁi Stock
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@ Sunburst
[‘ Histogram
8§  Box & Whisker
M Waterfall
= Funnel

Ok

| | Cancel

4. Click OK.

Result:
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Category =T

Sum of Amount

Beans

Country -
m Australia

W Canada

France
Germany

m New Zealand
Product

Note: pie charts always use one data series (in this case, Beans). To get a pivot chart of a country, swap
the data over the axis. First, select the chart. Next, on the Design tab, in the Data group, click Switch
Row/Column.

Excel Dashboards & Interactivity — using Form Controls

Dashboards track KPls, metrics, and other data points in one visual, central place. They give you a high-
level view of work, helping you make quick decisions and keeping everyone up to date. A dashboard’s
visual nature simplifies complex data and provides an at-a-glance view of current status or performance
in real time.

Dashboards are made up of tables, charts, gauges, and numbers. They can be used in any industry, for
almost any purpose. For example, you could make a project dashboard, financial dashboard, marketing
dashboard, and more.

1. How to Bring Data into Excel

Before creating dashboards in Excel, you need to import the data into Excel. You can copy and paste the
data, or if you use CommcCare, you can create an Excel Connection to your export. But, the best way is to
use ODBC (or Live Data Connector). ODBC can connect your apps to Excel, passing real-time data from
your app to Excel. As data is updated in your app, your Excel dashboard will also be updated to reflect the
latest information. This is a perfect option if you track and store data in another place, and prefer creating
a dashboard in Excel. Data can be imported two different ways: in a flat file or a pivot table.

2. Set Up Your Excel Dashboard File
e Once you have added your data, you need to structure your workbook.
e Open a new Excel Workbook and create two to three sheets (tabs).
e You could have one sheet for your dashboard and one sheet for the raw data (so you can hide
the raw data). This will keep your Excel workbook organized. In this example, we’ll have two



@Research & Consulting

tabs.

Dashboard Raw Data

3. Create a Table with Raw Data
In the Raw Data sheet, import or copy and paste your data. Make sure the information is in a tabular
format. This means that each item or data point lives in one cell.

In this example, we’re adding columns for Project Name, Timeline, Number of Team Members, Budget,
Risks, Open Tasks, and Pending Actions.

A B C D £ F 4 H ) K L M N
PROJECT DATA

Project Name StartDate | EndDate | Duration ol Tean Project Budget| Actual Budget | Remainder | Risk: High Ris:k: Risk: Low | Issues | Revisions PE",d g

) Members Hedium Actions
3 Project A 05/0516 070116 i 1l 91,000,000 9660,000 §20000 1 0 4 2 0 4
4 Project B 051016 08/1016 % 5 $900.000‘ $920.UUU‘ 5200000 2 3 5 1 2 3
5 Project C 0610/16 03017 264 10 $BEU.000‘ 5850,000 00000 3 4 3 2 1 2
6 ProjectD 06/2216 06/0416 4 5 M.UUU.UUU‘ 9998050 bR 8 1 1 0 0
7 ProjectE (71416 1101116 Al 10 $294.00E]‘ 5280000 §140000 8 f 4 0 3 1
8 ProjectF (71416 Mi2A7 190 5 $123.400‘ $125.000‘ -$1.50[]‘ 5 0 0 2 0 2
9 Project G 08/0116 1001116 i1 1l $250.5[][]‘ $246.[][]U‘ M.SUU‘ f 4 0 1 2 ]
10 Projct H 08/14/16 0813016 16 5 $127.20E]‘ WE.UUU‘ $1.20E]‘ 1 3 3 0 1 4
11 Project| 08/01/16 1210116 100 10 $80.000‘ WQ.QUU‘ o0 2 4 1 3 2
12 Project J 100146 11114116 45 5 $77.UUU‘ WT.UUU‘ 0 4 4 5 2 0 0
13 Project K 1001146 1201116 i 10 $55.00E]‘ $55.E]E]U‘ 03 f 4 ] ? 0
14 Projeet L 10146 1201116 k) 5 %550.000‘ $551.000‘ S1000 2 3 f 0 1 1
15 Project M 11046 1210116 k) 1l $45.U[][]‘ W.UUU‘ $3.UUU‘ 1 1 1 1 0 2
16 Project N 120116 nn i 5 $32.50E]‘ $33.E]E]U‘ -$50E]‘ 5 0 2 2 1 ]
17 55,404,500‘ 55,272,!50‘ $131,ﬁ5[|‘ 5 ] 4 18 16 n

If needed, you can use a formula to automatically add all the values in a column. We will do this for
our Budget, Risks, Open, and Pending Actions columns. Click on an empty cell at the bottom of the
column, and type =SUM(. After the open parenthesis, click the first cell in the column and drag your
mouse down to the last cell. Then, add a close parenthesis to your formula. Repeat as necessary.
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Project Budget | Actual Budget
$1,EIEIEI,UDEI. 5880.000
5900000 $920,000
5860000 5850000
51,000,000 $998.050
5294000 5280000
123,400 5125000
$250.500 $246.000
127,200 $126,000
580,000 579,900
77,000 77,000
565000 565,000
3550000 $551.000
45,000 542000
532500 $33.000
=SUM(F3:F16) $5,272,950
5UM(number], [number?], ...)

4. Analyze the Data

Before building the dashboard, take some time to look at your data and figure out what you want to
highlight. Do you need to display all the information? What kind of story are you trying to communicate?
Do you need to add or remove any data?

Once you have an idea of your dashboard’s purpose, think about the different tools you can use. Options
include:

Excel formulas like SUMIF, OFFSET, COUNT, VLOOKUP, GETPIVOTDATA and others
Pivot tables

Excel tables

Data validation

Auto-shapes

Named ranges

Conditional formatting

Charts
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Excel dashboard widgets
Macros

Don’t worry, you don’t need to know how to use every single one of these Excel tools. With some basic
knowledge of charts and pivot tables, you can make a beautiful Excel dashboard.

5. Build the Dashboard

Add a Gantt Chart
We'll add a Gantt chart to visually show your project timeline.

e Go to your Dashboard sheet and click Insert.

e Inthe Charts section, click the bar chart icon and select the second option.
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You’ll now have to link this bar chart to the Project Name, Start Date, and Duration columns in your Raw
Data sheet.
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Create and Format Charts

In your Dashboard sheet, click Insert and select the kind of chart you’d like to make. For this first
example, we'll create a column chart.

Right-click on the chart and click Select Data.
e C(Click Add in Legend Entries (Series).

e Inthe Series name field, click the title of the column you want to add on the Raw Data sheet. Hit
enter.

e Inthe Series values field, select all the data in that corresponding column. Hit enter and then
click Ok.

You’ll notice that your X-axis is not correctly labeled. To fix this, click Edit in the Horizontal (Category)
Axis Labels and in the Raw Data Sheet, select what you’d like to display on the X-axis.
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“Select Data Source

Chart data range: | ='Raw Data'|5452:54516, Raw Data'|SES2:SES16

EF
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3
4
5 i
Hidden and Empty Cells ok || canc

e Toadd a title to your chart, select your chart and click the Design tab.

e Click Add Chart Element > Chart Title > Above Chart.
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e Type your title in the text field on the chart.

e Repeat this process for any other charts you want to create.

Resource Allocation
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Insert PivotTables
A pivot table allows you to extract and highlight the most important information from a large data set.
Here’s how to insert a pivot table:

e Go to your Dashboard sheet and on the Insert tab, click the PivotTable button.

FILE HOME INSERT

J | i
PivotTable|Recommended Table

PivotTables
Tables
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In the Table/Range field, click the icon at the end and aselect your whole data table from your
Raw Data sheet.

e Click Ok.

e A pop-up box will appear.

Create PivotTable @

Choose the data that you want to analyze
@ Select atable or range

Table/Range:  'Raw Data'!SAS$2:5N518| 2.5
) Use an external data source

Connection name
Choose where you want the PivoiTable report to be placed
@ Mew Worksheet
() Existing Worksheet

Location: 55

Choose whether you want to analyze multiple tables
|:| Add this data to the Data Model

e The PivotTable Field List will appear on the right side of your screen.

e Select which subsets of data you would like to include in your pivot table by clicking the boxes.



PivotTable Fields v X

Choose fields to add to report: L * g
[] Project Name [a]
[] start Date
[ ] End Date
[ ] Duration

[] # of Team Members
[ ] Project Budget

[] Actual Budget

[] Remainder B
[] Risk: High

[] Risk: Medium

[ ] Risk: Low -

Drag fields between areas below:

T FILTERS Il COLUMMNS

ROWS = VALUES

[ ] Defer Layout Update

If you’d like to include another pivot table in your dashboard, repeat steps 1-3.
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Project Name n Sum of High Risk Sum of Medium Risk Sum of Low Risk
Project A

[y
e

Project B
Project C
Project D
Project E
Project F
Project G
ProjectH
Project |

Project )

Project K
Project L
Project M
Project N
Grand Total 52

| fpo o [ | |~ |en jun |eo |wn e |k
B =] | [ (L0 | | | O[O | = s |

tQHWG\PMWPQG‘IEﬂ#WQ

I
=4}

Dashboards collaboration & Publishing

You can save an Excel dashboard to a static web page, save the Excel sheet as a PDF and upload it to your
company Intranet, or add the file to Dropbox or another cloud storage tool and share the link.

If you don’t need the Excel dashboard to live on the web, you can send it via email.



