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Objectives 
 
You will create the geometry for Mill-Lesson-4, and then generate a toolpath to machine the part 
on a CNC vertical milling machine. This lesson covers the following topics: 
 
 Create a 2-dimensional drawing by: 

Creating rectangles. 
Creating arcs. 
 
 Establish Stock Setup settings: 

Stock size. 
Material for the part. 
Feed calculation. 
 
 Generate a 2-dimensional milling toolpath 

consisting of: 
Contour toolpath. 
Drill toolpath. 
 
 Inspect the toolpath using Mastercam’s Verify and Backplot by: 

Launching the Verify function to machine the part on the screen. 
Using Backplot to identify the correctness of the toolpaths. 
Generating the NC- code. 
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 MILL-LESSON-4 DRAWING 
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TOOL LIST 
 Two cutters will be used to create this part.   
 The .125” diameter two flute center cutting flat end mill will be used to drill the four .125” 

diameter holes. 
 The .5” diameter two flute flat end mill will be used to machine the contour. 
 
   

MILL-LESSON-4 - THE PROCESS 

 
Geometry Creation 
TASK 1:  Set the environment 
TASK 2:  Create a rectangle 3” x 3” – the center is at X0 Y0 
TASK 3:  Create the inside entities 
TASK 4:  Create the four .125” fillet radii 
TASK 5:  Save the drawing 
 
Toolpath Creation 
TASK 6:  Define the rough stock using stock setup 
TASK 7:  Drill the 4 x .125” diameter holes 
TASK 8:  Machine the contour 
TASK 9:  Backplot the toolpath 
TASK 10:  Modify the contour toolpath to add roughing cuts and a finish 

pass 
TASK 11:  Verify the toolpath 
TASK 12:  Save the updated Mastercam file 
TASK 13:   Post and create the CNC code file Sam
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Geometry Creation 
TASK 1:  
SETTING THE ENVIRONMENT 
Before starting the geometry creation you should set up the grid, toolbars and machine type as 
outlined in the Setting the environment section at the beginning of this text: 

1. Set up the Grid.  This will help identify the location of the origin. 
2. Load the Workspace – SETTINGS>Load Workspace>2D Toolpaths to machine a 2D part. 

3. Set the machine type to a Haas Vertical Spindle CNC machine. 
 

TASK 2: 
CREATE A RECTANGLE 3” X 3” – THE CENTRE IS AT X0 Y0. 
 This task explains how to create the 3” square.  These four lines could be created in many 

different ways, this is just one option. 
 
1. Select from the pull down menu CREATE>Rectangle… 

 

Rectangle 

Use this function to create a rectangle using two points. To draw 
a rectangle, click to set the base point that anchors the rectangle, 
drag the rectangle outward, then click to set the second corner.  
 
You can also enter X, Y, and Z positions in the AutoCursor ribbon 
bar to position the two points on the rectangle. The rectangle can 
be drawn outward from a center point, and can be drawn as a 
surface. Width and height are lockable so that you can create 
multiple rectangles using set dimensions.  
 
The rectangle remains a live entity until you click the Apply button 
or start another rectangle. 

 
2. The Create Rectangle ribbon bar appears and you are prompted to Select position of first 

corner. 

 
 
3. On the ribbon bar click in the space  for Width and enter a value of 3.0, hit the tab key and 

you will be moved over to the Height section. 

 
 
4. In the Height section enter a value of 3.0 and then hit Enter. 
5. Now select the Anchor to Center option - this option is shown above.   To activate the 

Anchor to Center option the icon is pressed down as shown above. 

 

Anchor to center: Sets the base point of the rectangle to the center point, and draws the 
rectangle outward from the center.  

6. Move the cursor to the center of the Grid and snap to the Origin for the base point.  

7. Click on the OK icon  to complete this feature.  

8. Select the Screen Fit icon found at the top of the screen to fit the part to the screen . 
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TASK 3: 
CREATE THE INSIDE ENTITIES 
 In this task you will create the four inside lines. These lines form a 2.5” square. 
 You will use Create Rectangle again to construct these four inside lines.   

 
1. Select from the pull down menu CREATE>Rectangle… 

 
 
2. The Create Rectangle ribbon bar appears and you are prompted to “Select position of 

base point”. 

 
 
3. On the ribbon bar click in the space  for Width and enter a value of 2.5, hit the tab key and 

you will be moved over to the Height section. 

 
 
4. In the Height section enter a value of 2.5 and then hit Enter. 
5. Select the Anchor to Center option - this option is shown above.   To activate the Anchor 

to Center option the icon is pressed down as shown above. 

6. Move the cursor to the center of the Grid and snap to the origin for the base point. 

7. Click on the OK icon  to complete this feature. 
8. Your part geometry should look as below: 3.0” and 2.5” square. 
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TASK 4: 
CREATE THE FOUR .125” FILLET RADII 
 In this task you will create the four .125 fillet radii on the corners of the 2.5” square you have 

just created. 
 
1. Select CREATE>Fillet>Entities… 

 

Fillet 

Use this ribbon bar to apply fillets to existing 
entities. Before selecting the entities to fillet, 
choose the fillet style (normal, inverse, circle, 
clearance), and enter the desired radius value. 
Then choose the first and second entities. 
Mastercam's auto-preview feature displays a 
temporary fillet at the selected location. 
You can also choose to trim to the fillet or to 
leave the selected lines untrimmed.  
Trimming is the default, so for no trimming, 
select the No Trim button. 

 
2. On the Fillet ribbon bar enter .125 for the radius.  Ensure the Style of radius is set to 

Normal and the trim button is depressed to turn the trim on. 

 
 
3. When prompted to “Select an entity”, select Line 1 and 2 as shown below.  The fillet radius 

appears at the corner of line 1 and 2.   
4. To complete the remaining three fillet radii, select: 
5. Line 2 and 3. 
6. Line 3 and 4. 
7. And finally line 4 and 1. 

Before

 

After 

 
  

8. Click on the OK icon  to complete this feature. 
9. Your completed part geometry should look like the figure on the right above. 
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TASK 5: 
SAVE THE DRAWING 
 
1. Select File. 
2. Select Save As... 
3. In the “File name” box, type “MILL-LESSON-4”. 
4. Save to an appropriate location. 
5. Select the Save button to save the file and complete this function 

 

 
 

File Save As 

Mastercam lets you read (import) a variety of CAD file types into the Mastercam database.  
 
You can also write (export) Mastercam files to a variety of different file formats. See your 
Mastercam Reseller for more information on the options available for your Mastercam 
configuration. 
 
Below is an example of the various Save as type file options. 
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Toolpath Creation 
TASK 6: 
DEFINING THE ROUGH STOCK USING STOCK SETUP 
1. For a better view of the part use the toolbar at the top of the screen to change the graphics 

view to Isometric 

     
 

2. Now select the Fit to screen icon  
3. Select the plus in front of Properties to expand the Machine Group Properties.  Alt-O will 

Show/hide Toolpaths Manager pane. 

 
  
4. You may need to extend the toolpaths manager window, if so click on the right hand pane, 

hold the mouse button down and drag to the right. 

 
 
5. Select Stock setup in the Toolpath manager window. 

 

Sam
ple 

not fo
r 

Dist
rib

utio
n



Mastercam Training Guide 

Mill-Lesson-4-9 

6. Change the parameters to match the Stock Setup screenshot below: 

 

Stock Setup 
Stock Origin 

The stock origin is the X-Y-Z coordinate 
position of the point indicated by the cross in 
the picture of the stock model.  
 
Use it so Mastercam knows where your stock 
model is located relative to your part and 
coordinate system. 
 
You can either type in the X-Y-Z coordinates 
directly in the fields, or choose the Select 
button to return to the graphics window and 
select a position. 
 
Display 

Choose this option to display the stock model 
in the graphics window. 
 
Fit screen 

Choose this option so that the stock boundary 
lines are included when you use the Fit to 
Screen function. 

 
 
7. Select the Tool Settings tab and change the parameters to match the Tool Settings 

screenshot below.  To change the Material type follow the next set of instructions. 

 

Program # 

The post processor will use this field if your 
machine tool requires a number for a 
program name.  
 
Sequence # 

Enter the starting sequence number and the 
increment in the proper fields.  
 
The default values and specific format for 
these fields is determined by the NC Output 
section of the control definition. 
 
In the code file below note the block numbers 
are sequenced in increments of 1, N9 N10 

etc. 
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8. To change the Material type to Aluminium 6061 pick the Select button at the bottom of the 

Tool Settings page. 

 
 
9. Select Mill - library at the Material List dialog box open the Source drop down list. 

 
 

10. From the Default Materials list select ALUMINIUM inch -6061 and then select .   

 
 

11. Select the OK button  again to complete this Stock Setup function. 
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 Your screen will look similar to the screenshot below: 
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TASK 7: 
DRILL THE 4 X .125” DIAMETER HOLES 
 In this task you will drill the four .125” diameter holes through the part with a centre cutting 

two flute end mill that is .125 “ diameter. 
 As the four holes will be drilled at the centre of the .125” fillet radii you need to create points 

at the centre of these arcs, when creating the drilling toolpath you can snap to the centre of 
the arcs. 

 
1. Change the graphics view to a Top View by using the toolbar at the top of the screen.  

 
 
2. From the menu bar select TOOLPATHS>Drill… 

 
 
3. When prompted to “Enter new NC name” Input Mill-Lesson-4 as shown below and then 

select the OK button . 

 
 

4. Now you are prompted to: 
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5. The Drill Point Selection dialog box appears: 

 
 

6. Your screen will look similar to the screenshot below: 
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 As you need to drill the four holes at the centre of the four fillet radii all you need to do now 
is snap to the centre of the fillet radius. 

   
7. Move the mouse and position the cursor over the center of the top left hand fillet radius, 

you will notice a circle appears as you move closer to the center of the radius, this is a visual 
cue. 

8. This circle demotes you are snapping the centre of this arc.  Use the left button of your 
mouse to pick this center point. 

 
 

9. Using the method outlined above continue on and pick the remaining three center points, in 
this order: 

10. Lower left. 
11. Lower right. 
12. Upper right. 
 
13. Your screen should look like the screenshot below after selecting the four center points: 

 
 

14. Select the OK button  in the Drill Point Selection dialog box. 

Sam
ple 

not fo
r 

Dist
rib

utio
n



Mastercam Training Guide 

Mill-Lesson-4-15 

 After selecting the OK button, you are confronted with the Drill Toolpath Type page.  The 
first task here will be to select a .125” diameter end mill. 

 
15. Ensure the Toolpath Type is set to Drill as shown below and then select Tool from the list 

on the left. 

 
 
16. Click on the Select library tool button in the lower left corner. 
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17. On the right hand side of the Tool Selection dialog box remove the green check mark from 
the Filter Active to review all the tools. 

 
 
18. Use the slider bar on the right of this dialog box to scroll down and locate a .125” diameter 

flat end mill. 
19. Select the .125” diameter flat end mill by picking anywhere along the .125 end mill row, as 

shown below: 

 
 
20. To resize a column in the Tool Selection dialog box, click on the divider between the 

columns with your left mouse button, as shown below, hold the left mouse button down and 
move to the right or left. 

 
 

21. Select the OK button  to complete the selection of this tool. 

 

Tool Selection dialog box 
Use this dialog box to select tools from a tool library and add them to the current machine 
group. This means that they can be selected and used in a toolpath. Double-click on a tool to 
select it, use it in the current operation, and close this dialog box. 
 
To see tools from a different library, select the new library from the drop-list. Click on the folder 
button to see libraries from different folders. 
 
You can also filter the tool list by a number of different criteria to make it easier to find the right 
tool. Select Filter active to apply a tool filter, or click the Filter button to edit the selection criteria.  
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22. Make changes to the Tool parameter page as shown below: 

 
 
23. Select Cut Parameters from the list on the left and make changes to this page as shown 

below.  The Cycle should be set to Drill/Counterbore. 

 
 

Drill/Counterbore:  

Recommended for drilling holes with depths of less than three times the tool diameter 
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24. Select Linking Parameters from the list on the left and make changes to this page as 
shown below.  Input the depth of -0.28 and the other values as shown below.  Note all the 
values are set to Absolute. 

 
 
25. Select the plus sign to the left of Linking Parameters to expand the list and click on Tip 

Comp. 

 
 
26. Ensure Tip Comp is not activated as shown below.  The Tip Comp box is empty.  The red 

circular icon denotes this option is disabled.  
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27. Select Coolant from the list on the left.  Open up the drop down menu for Flood and set it to 
On. 

 
 

28.   Select the OK button  to complete this function. 
29. Your part should look like the screenshot below: 
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TASK 8: 
MACHINE THE CONTOUR. 
 In this task you machine the contour with a .5” diameter 2 flute end mill. 
 Initially you will machine the contour in one cut at a depth of -.125” and then later in this 

Lesson add roughing and finishing cuts using Depth of Cuts and Multi Passes. 
 
1. From the menu bar select TOOLPATHS>Contour… 

 

Contour toolpaths remove material along a path defined by a 

chain of curves. Contour toolpaths only follow a chain; they do 
not clean out an enclosed area. 
You can select an unlimited number of chains for each toolpath. 
You can create either 2D or 3D contour toolpaths. 

 
 
2. On the screen you will now see the Chaining dialog box with Chain set and in the graphics 

screen a prompt to “Select Contour chain 1”.  Select the top horizontal line as shown 

below: 

    
 

Chaining dialog box 

Use this dialog box to select chains of entities for generating surfaces, solids, or toolpaths, or for 
performing certain Analyze, Xform, or other operations.  
A chain of entities consists of one or more entities linked together in order and direction. 
 
The chaining dialog box operates in two modes: Wireframe (default) and Solids. Two buttons at 
the top let you switch between modes; however, if either solid or wireframe geometry is not 
present, its button is unavailable. 
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3. After selecting the top horizontal line your graphics screen should looks like the screenshot 
below, with the green arrow pointing to the right, clockwise direction.   

 The material for this part is aluminium so to attain a good finish when contouring climb 
milling should be employed. 

 
 
4. If the arrow is not pointing to the right select the arrow  from the Chaining dialog box shown 

below to reverse the direction:  

 
 

5. After the contour has been successfully chained select the OK button  at the bottom of 
the Chaining dialog box. 
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6. Ensure the Toolpath Type is set to Contour as shown below and then select Tool from the 

list on the left. 

 
 
7. Click on the Select library tool button in the lower left corner. 
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8. Use the slider bar on the right of this dialog box to scroll down and locate a .5” diameter flat 
end mill.  Select the .5” diameter flat end mill by picking anywhere along the .5 end mill row, 

as shown below: 

 
 

9. Select the OK button  to complete the selection of this tool. 
10. Make changes to the Tool page as shown below: 

 
 

Rapid retract 

Select this option to retract from the part at the rapid rate set at the machine tool.  
If you do not select this option, Mastercam will use the programmed Retract rate set in this 
dialog box. 
 
SFM (inch), CS (metric) 

Displays the cutting speed in surface feet per minute or surface meters per minute. 
 
FPT 
Displays the amount of feed per tooth, based on the number of flutes in the tool definition. 
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11. Select Cut Parameters from the list on the left and make changes to this page if required. 

 
 
12. Select Lead In/Out from the list on the left and make changes to this page. 
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13. Select Linking Parameters.  Input the depth of -0.125 and the other values as shown 
below.  Note all the values are set to Absolute. 

 
 
14. Select Coolant from the list on the left.  Open up the drop down menu for Flood and set it to 

On.   

 

15. Select the OK button  to complete this function 
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TASK 9: 
BACKPLOT THE TOOLPATH 
 In this task you will use Mastercam’s Backplot function to view the path the tools take to cut 

this part.  
 Backplot will enable you to review the cutting motions and identify any problem areas when 

cutting the part.  
 When the toolpaths are being Backplotted Mastercam displays tool path information on the 

right of the screen.  Information such as the current tool position in X, Y, and Z coordinates. 
 For more information on Backplot see the Tips and Techniques section on the 

multimedia DVD supplied with this text.   

 

1. To pick all the operations to Backplot pick the Select All icon  circled below: 

 
 
 Another method to Select all the operations is by clicking on the Toolpath Group-1 in the 

Toolpaths Manager as shown by the arrow above. 
 
2. The next step is to select the Backplot selected operations icon shown below: 

 
 
3. Maximize the Backplot/Verify window if required.   
4. Select the Home Tab if required. 

 
 
5. Activate the options shown below in the Visibility section of the Home tab. 
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6. At the top of the screen select the View tab, the Isometric icon and then select Fit. 

 
 
7. Click on the Backplot tab at the top left of the screen. 

 
 
8. Activate the Both option in the Toolpath section of the Backplot tab. 

 
 
9. In the lower right corner of the screen now set the run Speed to slow by moving the slider 

bar pointer over to the left as shown below. 

 
 
10. Now select the Play Simulation button to review the toolpaths. 

 
 
11. After reviewing the Backplot of the two toolpaths using a .5 spot drill and .25 drill select the 

Close button  in the top right hand corner to exit Backplot. 
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TASK 10: 
MODIFY THE CONTOUR TOOLPATH TO ADD ROUGHING CUTS AND 
A FINISH PASS 
 In this task you will use Mastercam’s Multi Passes and Depth of cuts to perform a 

roughing and finishing operation for the contour toolpath. 
 Multi Passes will let the tool approach the part geometry at the cutting depth in steps 

instead of cutting right to the part geometry. 
 Depth of cuts can be used to set the number of depth cuts, you can enter a maximum 

rough step and Mastercam divides the total depth into equal steps. Or you can enter the 
exact number of finish steps and the size of each finish step. Mastercam never creates 
unequal rough depth cuts. 

 For more information on Multi Passes and Depth of cuts see the Tips and Techniques 

section on the multimedia DVD supplied with this text.  
 
1. In the Toolpaths Manager select Parameters from the contour toolpath as shown below: 
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2. Select Depth Cuts from the list on the left and make changes to this page as shown below: 

 
 

About the Depth cuts dialog box 
Max rough step:  
Sets the maximum amount of material removed in the Z axis with each rough cut. 
# Finish cuts:  

Sets the number of finish cuts for the contour toolpath. This number multiplied by the finish step 
value equals the total amount of stock cut by the finish passes. Setting the number of finish cuts 
to 0 creates no finish cuts.  
Finish step:  

Sets the amount of material removed in the Z axis with each finish cut. This number multiplied 
by the number of finish passes equals the total amount of stock cut by the finish passes. 
Keep Tool Down: 

Determines if the tool should retract between multi passes. 
Depth cut order: 
By pocket/contour 

Performs all depth cuts in a contour or region before moving to the next contour or region. 
By depth 

Creates depth cuts at the same level in every contour or region and then descends to the next 
depth cut level.  
  
In this example you will perform: 

Each depth of cut will not exceed .0625”, therefore as your final depth is -.125” you will perform 
only two rough cuts. The first at -0.0625 and the second rough cut at -.125 
Only one finish pass at the final depth 
The finish pass will only take place at the final depth, this final cut will machine the .030” from 
the contour that you set up using Multi Passes 
In between passes the tool will be kept down. 
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3.  Select Multi Passes from the list on the left and make changes to this page as shown 

below: 

 
 

About the Multi Passes dialog box 
Roughing passes: 
Number: Enter the number of cutting passes you want Mastercam to create. 
Spacing: Enter the amount of stock to remove with each cut. 

 
Finishing passes: 
Number: Enter the number of cutting passes you want Mastercam to create. 
Spacing: Enter the amount of stock to remove with each cut. 

 
Machine finish Passes at: 
Final Depth: Performs a single finish pass at the final depth. 
Keep Tool Down: Determines whatever the tool should retract between multi passes. 

 
In this example you will perform: 
No roughing cuts in the XY pane. 
Only one finish pass at the final depth. 
While cutting at the various depths you will stay .030” away from the contour. 
The finish pass will take place at the final depth. 
In between passes the tool will be kept down. 
 

 

4. After reviewing the values input in the Multi Passes dialog box select the OK button  

to exit. 
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5. Select the Regenerate all dirty operations icon  to remove the red X from the 

contouring operation you have just edited.  You need to update the toolpath with the new 
parameters you have just input. 

 
 

Dirty toolpath 

This happens if you have changed certain parameters of the underlying geometry, or in this 
example you have updated the contour toolpaths to use Depth of cuts and multi passes. 
 
Toolpaths can be regenerated by clicking the Regenerate button at the top of the Toolpaths 
Manager circled above. 
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TASK 11:   
VERIFY THE TOOLPATH 
 Mastercam's Verify utility allows you to use solid models to simulate the machining of a part. 

The model created by the verification represents the surface finish, and shows collisions, if 
any exist.  

 This allows you to identify and correct program errors before they reach the shop floor. 
 Backplot and Verify are very similar. The differences between these two functions are that 

Backplot offers basic simulation options.   Whereas Verify offers material removal, collision 
checking and precision control. 

 For more information on Verify see the Tips and Techniques section on the 
multimedia DVD supplied with this text 

 
1. In the Toolpaths Manager pick all the operations to verify by picking the Select All icon 

. 
2. Select the Verify selected operations icon shown below: 

 
 
3. Maximize the Backplot/Verify window if required. 
4. Activate the Both option in the Toolpath section of the Verify tab. 
5. Now select the Home Tab. 

 
 
6. Activate the options shown below in the Visibility section of the Home tab. Initial Stock not 

activated. 

 

Visibility 

Click on the individual functions to cycle 
through the three states:  
On, Translucent, or Off. 

 

 
7. Activate the Color Loop. 

 

Color Loop 

Changes the color of the toolpath or cut stock 
by operation or by tool change.   
Choose File, Options to set the colors. 

 
8. At the top of the screen select the View tab, the Isometric icon and then select Fit. 
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9. In the lower right corner of the screen now set the run Speed to slow by moving the slider 

bar pointer over to the left as shown below. 

 
 
10. Now select the Play Simulation button to review the toolpaths. 

 
 

11. Select the Close button  in the top right hand corner to exit Verify. 
 
The verified toolpaths are shown below: 

 
 
TASK 12:  
SAVE THE UPDATED MASTERCAM FILE 
 

1. Select the save icon from the toolbar . 
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TASK 13:  
POST AND CREATE THE CNC CODE FILE 
 
Please Note: 
Users of the Mastercam Home Learning Edition (HLE) will not be able to Post and Create the 

CNC code file. 

 

1. Ensure all the operations are selected by picking the Select All icon  from the 
Toolpaths manager. 

 
 
2. Select the Post selected operations icon G1 from the Toolpaths manager. 
 Please Note: If you cannot see G1 click on the right pane of the Toolpaths manager window 

and expand the window to the right. 

 
 
3. In the Post processing window, make the necessary changes as shown below: 

 

About NC Processing 
NC file: Select this option to save the NC file. 

The file name and extension are stored in the 
machine group properties for the selected 
operation.  
 
If you are posting operations from different 
machine groups or Mastercam files, or batch 
processing, Mastercam will create several files 
according to the settings for each machine 
group. 
 
Edit: When checked, automatically launches 

the default text editor with the file displayed so 
that you can review or modify it. 

 

4. Select the OK button  to continue. 
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5. Ensure the same name as your Mastercam part file name is displayed in the NC File name 

field as shown below: 

 

6. Select the Save button. 

7. The CNC code file opens up in the default editor. 

 
 

8. Select the close button  in the top right corner to exit the CNC editor. 
9. This completes Mill-Lesson-4. 
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