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Introduction

Inevitably, the first time you sit down in front of any new computing tool, the question arises: "Now what
do I do?" Well, if that's how you felt the first time you looked at the 1010data Insights Platform Trillion-Row
Spreadsheet interface, you've come to the right place. After all, you're dealing with data. A lot of data. And
you can see all of it. Most people have never had that experience. Count yourself lucky. With this Trillion-
Row Spreadsheet Getting Started Guide, you'll learn all the basics that will help you understand how the
Insights Platform works and why it's different from other database solutions.

This guide is a collection of tutorials that will help you quickly come up to speed with the core functionality
of the Trillion-Row Spreadsheet. As such, the Getting Started Guide is not comprehensive. For additional
information not covered in this guide, refer to the 1010data Insights Platform User's Guide available from
the 1010data Documentation Center.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html
http://www2.1010data.com/documentationcenter/beta/
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Explore the Trillion-Row Spreadsheet

The Trillion-Row Spreadsheet is a browser-based interface that allows you to visually interact with your
data. Explore the Trillion-Row Spreadsheet to learn how to use some of the most common user interface
elements.

The 1010data Insights Platform gives you several options for interacting with the system and analyzing
your data. However, when you first get started, you are likely going to spend most of your time in the
Trillion-Row Spreadsheet (TRS). The TRS is a browser-based interface that works similarly to many
spreadsheet applications, such as Microsoft Excel. The interface uses many elements with which you may
already be familiar, such as folders, navigation icons, and menus.

Throughout this tutorial, the Sales Item Detail table (pub.demo.retail.item) is used to introduce you
to the major elements in the TRS.

To explore the Trillion-Row Spreadsheet:

1. In your Internet browser address bar, enter https://www2.1010data.com/prime-latest/ and
press Enter.
Your browser displays the 1010data Insights Platform login page.

2. Enter your Insights Platform Username and Password, then click Login.

Logging in may take several minutes.

Note:  If you cannot remember your password, you can reset it. Click Forgot your password?
and follow the instructions on the Password Reset page.

Your browser displays the Insights Platform workspace.

http://www2.1010data.com/prime-latest/
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Each time you open a new workspace, the menu bar and Dashboard are displayed on the canvas. The
menu allows you to open a TRS window and start exploring ad hoc analysis in the Insights Platform.

3. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

A. Analysis pane

The analysis pane occupies the left side of the TRS window. This pane is used to perform an
analysis on your data.
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B. Results pane

The results pane is displayed on the right side of the TRS window. This pane displays the results
of your analysis in spreadsheet format. In addition, this pane also displays charts created in the
Visualize tab.

C. Tab bar

The Tab bar contains the options used to perform an analysis and other actions on your data.

D. Folders and tables

The folders and tables visible to you are displayed in the Analyze tab in the analysis pane. Within
this tab, you can open tables, which are organized in folders.

A table is the permanent, unchanging version of the data that is saved on the server. When you
open a table in the spreadsheet interface and perform an action or query, it becomes a worksheet.
A worksheet is a working copy of the table. In worksheets, you can work with and manipulate your
data.

E. Search

The search field in the Analyze tab allows you to search for tables, folders, and other objects.

F. Hide/Show

To hide the analysis pane, click the Hide ( ) icon on the right side of the pane. This is helpful

when you need more space to view your data in the results pane. Click the Show ( ) icon to
reveal the analysis pane when it is hidden.

4. In the Analyze tab, locate the Published Data folder and click the Expand ( ) icon to the left.
The Published Data folder opens, revealing additional folders.

Note:  You can also double-click a folder to open it.

5. Double-click the Demo folder and then double-click the Retail folder.
The Retail folder opens, revealing the tables contained in the folder.

In the image above, the red box outlines the Demo folder and its contents. The Retail folder is open
and in it is a table titled Sales Item Detail.

6. Click the Sales Item Detail table.
TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.
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This is the basic view of a table in TRS. After a table is opened, the Analyze tab displays the analysis
timeline. Use the timeline to move backward or forward through the steps of your analysis. The path to
the table in which you are currently working is displayed in step 1 of the timeline.

Note:  As you work through the tutorials in this guide, you may need to resize the TRS window
to see the full table.

Next to the Analyze tab are additional tabs which are used to interact with your data. The table below
provides a description of each tab and its available options.

Table 1: Tab menu

Tabs Tab description

Analyze In a new TRS window, this tab displays options for opening common Insight
Platform items such as tables and queries.

After a table is open, the Analyze tab displays the analysis timeline which
provides quick access to perform operations like summaries, tabulations, and
cross tabulations.

View Use this tab to select from among the various ways to view and interact with the
data resulting from your analysis.

Visualize Options for creating charts based on your data analysis are available from this tab.

Develop This tab allows you to save your query and provides options to further develop
your analysis. For example, you can clone the TRS window and explore different
scenarios without losing your original query.

Export You can save the results of your analysis in a variety of file types, such as CSV
and Microsoft Excel, from this tab.

7. In the heading of the Cost column, click the drop-down arrow ( ) and select Sort Down.

When you place the cursor on a column header, the sorting drop-down arrow appears.
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TRS sorts the table in descending order based on the Cost column and adds the sort operation to step
2 in the analysis timeline.

After you perform an operation in either the table or in the timeline, the operation is listed in the timeline.

At this point, the table becomes a worksheet because an action was performed on the table.

Note:  Sorting is very system-resource intensive. As a best practice, do not sort your table or
worksheet until the data is narrowed down to a manageable size. Instead of sorting, first perform
a tabulation or select a narrow range of rows.
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Scroll bars, similar to the ones outlined in red in the image above, appear on the right side of the
worksheet if the screen cannot accommodate all of the rows and on the bottom of the worksheet if
the screen cannot accommodate all of the columns. The scroll bar in the results pane allows you to
navigate through the data in your worksheet.

Note:  If a scroll bar is not displayed in your worksheet, all available data is already displayed;
no additional rows of data exist.

For the purposes of this tutorial, a very small data set was created to illustrate the concepts in this topic.
In this case, you can scroll through the data in just a few seconds. However, your tables may contain
billions of rows. As you work with the TRS, keep in mind that scrolling may not be the most effective
way to get to a particular section of data. For that, a better method is to perform a row selection, which
is covered in Select rows on page 15.

8. In the Analyze tab, click New operation in step 3 at the bottom of the timeline.
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The New operation step allows you to add an additional operation to the timeline.

TRS displays the New operation panel.

Now that you have another step in which to perform an operation, you can arrange the columns in the
worksheet.

9. Click Arrange.
TRS displays the Arrange columns panel.
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The Columns section shows the columns that are currently visible in your worksheet, in the order
they are displayed left to right. The Hidden section shows any additional columns contained in your
worksheet that are not currently displayed. Using this panel, you can rearrange and hide columns in
your worksheet.

10.Move the Date column so that it is displayed first.

a) In the Columns section, drag Date so that it is displayed before Transaction ID as shown in the
image below.

b) Click the Submit operation ( ) icon.

The Date column moves to the first column in the worksheet.
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Next, hide the Cost column in the worksheet. While you could do this by performing another arrange
operation on a new line, you will instead edit the existing Arrange columns operation in step 3 of the
timeline.

11.Edit the Arrange columns operation to also hide the Cost column.

a) In the Analyze tab, click the Arrange columns operation in step 3.

TRS displays the Arrange columns panel.
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b) Drag Cost to the Hidden section.

c) Click the Submit operation ( ) icon.

TRS updates the Arrange columns operation and hides the Cost column in the worksheet.
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12.When you are finished with this tutorial, close the TRS window.

Take a little time to familiarize yourself with the basic menus and options in the Trillion-Row Spreadsheet.
Make sure you are comfortable opening a table, and do not be afraid to customize the table by rearranging
columns so that they are in an order that is useful to you. This will make the next few tutorials much easier,
and allow you to focus on the new material presented in them. Before you know it, you will be performing
custom analyses on your own data.

For more information about the TRS interface, see Trillion-Row Spreadsheet in the 1010data Insights
Platform User's Guide.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html?q=TRS/TRS.html
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Select rows

Selecting rows is one of the most basic tasks in the 1010data Insights Platform. Use row selection to
isolate data that is important to your analysis and create more efficient queries.

Often, the first step to answering an analytical question is to narrow down the data you are working with so
you see only the pieces of information that are relevant to your analysis. While there are many ways to do
this, the most basic is a row selection.

The purpose of row selection is to reduce a large collection of general data to a smaller collection of data
specific to the question being asked. For example, a question might be "Which store in our chain had the
highest sales in December?" Another could be "What were the highest and lowest sales figures for a single
transaction?" In both cases, you start with all of your data to answer a question that only requires a subset
of that data.

When you work with very large data sets like those typically found in the Insights Platform, the order in
which you perform your operations on the data makes a difference in how fast the system can complete
those operations. If you make the largest selection that eliminates the most data first, then the subsequent
operations you perform finish faster because the platform does not need to work with as much information.
As a best practice, if your data contains columns with date- or time-related information, that is generally
the best place to start. However, the largest selection may be something based on something else entirely
depending on your data and the analysis you want to perform.

This tutorial explains how to perform a series of row selections in the Trillion-Row Spreadsheet (TRS) to
reduce the amount of information in the Sales Item Detail data set.

To select rows:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

2. Open the Sales Item Detail table (pub.demo.retail.item).

The name of the Sales Item Detail table is pub.demo.retail.item. The location of the table
is reflected in the name. In this case, the table is located in the following folder: Published Data >
Demo > Retail.

TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.
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The table contains 35 rows of data, of which only a limited number display in the image below.

For the purposes of this tutorial, a smaller data set was created so you can see the changes being
made to the data. Even though performing real analyses require much larger data sets, all the principles
in this tutorial apply.

3. In the New operation panel, click Select.
TRS displays the Simple Comparisons options in the Select rows panel.
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4. Clear the Simple Comparisons option.
TRS displays the expression field.

When selecting rows in the Insights Platform, you should always make the selection that eliminates the
largest amount of data first. This almost always means your first selection should be a date range. To do
this, enter an expressing that uses the between function to limit the data from May 15, 2012 through May
17, 2012. An expression is a calculation, similar to a formula in Excel, you create to help you analyze your
data.

5. In the expression field, enter the following: between(date;
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If you click outside the expression field before entering a valid expression, you'll notice that the
expression field becomes outlined in red. This indicates that the expression is not valid as entered. In
this case, it is not valid because it is not yet complete.

Now that the between function for the date column is entered, you will specify the beginning and ending
dates. Dates are entered in the YYYYMMDD format.

Note:  A row selection specified using the between function is inclusive, meaning rows with the
values entered in the corresponding fields are included in the results.

6. In the expression field, after between(date;, enter the following: 20120515;20120517)

The expression field should contain the following: between(date;20120515;20120517)

Notice that the expression field is now outlined in green. This indicates that the completed expression is
valid.

7. Press Enter.
TRS displays the results of your selection.

Congratulations, you just performed your first row selection in the Insights Portal! As you can see in the
image above, the amount of data in the table is reduced by more than half. Also, notice in the analysis
timeline, the row selection you just performed displays in step 2 of the timeline.

What if you want to further limit your data to a particular store? To do this, create another row selection and
enter additional comparison criteria. In this case, you can enter a store number to limit the data to the rows
that identify a specific store.

8. In the New operation panel, click Select.
TRS displays the Simple Comparisons options in the Select rows panel.
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9. In the Select rows panel, do the following:

a) From the first drop-down list, select Store.
b) From the second drop-down list, select the equal sign (=) character.
c) In the last field, enter 2.

10.Do one of the following:

• Press Enter.
• Click anywhere in the panel, outside of the field.

These selections, outlined in red above, indicate that you want to see only rows for store 2. If the
second comparison option, the not equal to (≠) character, is selected, all of the stores in the worksheet
except store 2 are displayed.

If you want to include more than one value (more than a single store in the example above), add

additional criteria by clicking the Add Value ( ) icon and then enter the additional values.

The example above displays results for both store 1 and store 3. Searching for multiple values is useful
when working with information like product numbers.
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Now that all of the information you need for your results is entered, you can perform the selection.

11.Click the Submit operation ( ) icon.
TRS displays the results of your selection.

In just a few minutes, you narrowed the data down from 35 rows to 5. That is less than one-seventh of
the original data. Also, notice that the timeline indicates the selections you already performed (outlined
in red below). This can help prevent duplicating effort when making additional selections.

You can also quickly perform a basic row selection directly from the worksheet by right-clicking any cell
and choosing an option that appears in the pop-up menu.

12.Right-click the cell in the first row of the Date column and point to Select rows.
TRS displays a menu of selection options.
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By right-clicking a cell in the worksheet, you can choose from several row selection options that pertain to
that cell. Take a look at the available options when you right-click an Account cell.

13.Right-click the cell in the first row of the Account column and point to Select rows.
TRS displays a menu of selection options.

As you can see, when you right-click a cell in the Account column, the options are related to Account
and not Date. If you need to perform a simple selection, this is a great way to quickly select rows.

14.When you are finished with this tutorial, close the TRS window.

Row selection is an incredibly powerful tool you can use when working with your data. Using this simple
operation, you can eliminate unnecessary data and focus on what's pertinent. Feel free to make up a few
row selections of your own and try them out on any of the tables in the Published > Demo folder. It will
make a big difference as you learn how to work with the TRS, and ultimately, make your analyses faster
and more accurate.

For more information about selecting rows, see Selecting Rows in the 1010data Insights Platform User's
Guide.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html?q=TRS/Select/SelectingRows.html
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Create a computed column

A computed column is one of the most useful analytical tools in the 1010data Insights Platform. Use a
computed column to add a column of information to a worksheet typically using the information from one or
more existing columns.

Computed columns are columns you create yourself in many cases using information that is already in the
table with which you are working. For example, suppose you have a table that contains all the sales data
for a chain of stores. This table might have one column called Sales, which is the purchase price paid by
the customer. It might have another column called Cost, which is the cost of the item to the retailer. With
a computed column, it is easy to create a third column called Margin that contains the difference between
the sale price and the cost.

In this tutorial, you will use the Sales Item Detail table in the Trillion-Row Spreadsheet (TRS) to find the
margin using a computed column.

To create a computed column:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

2. Open the Sales Item Detail table (pub.demo.retail.item) by completing the following:

a) In the Analyze tab, enter pub.demo.retail.item in the Search field.

In this example, you were given the table name (pub.demo.retail.item). If you did not know the
name, you could perform a search by entering the table title (Sales Item Detail) instead.

b) Press Enter.
TRS displays the results of your search.
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c) Click Sales Item Detail.

TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.

In this tutorial, the Sales and Cost columns, outlined in red above, are used to create the Margin
computed column.

3. In the New operation panel, click Compute.
TRS displays the Computed column panel.
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4. Complete the following fields:

Name Enter margin.

This is the name the Insights Platform uses to interact with the column. It is
also used when writing more advanced expressions and queries. The column
name may only contain alphanumeric characters or underscores and must
begin with an alphabetic character (e.g., percent_total_sales). It may not
contain any spaces or other special characters.

This is a required field.

Label Enter Margin.

This is the column heading that displays by default at the top of a column in the
user interface. The column label may contain any combination of uppercase
and lowercase letters, numbers, spaces, and special characters. If you want
to have a multi-line column label, use the backtick character (`) to separate the
lines (e.g., "Percentage`Total Sales (%)").

While not required, this field is recommended.

Next, you will enter an expression to find the margin. An expression is a calculation you create to help you
analyze your data. In this case, you want to subtract the value in the Cost column from the value in the
Sales column.

5. In the expression field, enter the following: sales-cost

Next you will define the format of the computed column. You can configure items such as the display
format, column width, and the number of decimal places to display.

6. Click the More Options switch.
TRS displays the formatting options.

7. Complete the following:

Display Format Select Number: 1,234,567.89.
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This drop-down list instructs the Insights Platform how to display the new
number in the computed column. For example, as a date, a number, as text,
and so forth.

Column Width Select 5.

This option determines how many place values to hold in the column. In other
words, the width of the column by the number of characters.

Decimal Places Select 2.

This option sets how many numbers are displayed after the decimal point.

In this tutorial, dollar amounts are used. Therefore, two decimal places are
usually the appropriate setting. However, you may find that there are situations
where you need more or none at all.

8. Click the Submit operation ( ) icon.
TRS creates the Margin computed column.

9. When you are finished with this tutorial, close the TRS window.

You just created a new column in the worksheet with a very small amount of effort. The values in each
row are calculated by the equation you entered as the expression, and you can now easily see the margin
for every item sold in the entire worksheet. Of course, computed columns are much more powerful than
merely subtracting or adding one column from another. With a little practice, you will be able to build
columns based on more complicated equations, such as standard deviations and cumulative frequency
distributions.

To learn more about computed columns and value expressions, see Computed Columns in the 1010data
Insights Platform User's Guide.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html?q=TRS/Compute/ComputedColumns.html
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Perform a tabulation

A tabulation groups rows of data together based on the values in one or more columns and performs
calculations on data in each of those groups. The summarization results are provided in a small, easy-to-
read table.

A tabulation is a great place to start when you want to get a feel for what all those rows of data in your
table really mean. Tabulations allow you to calculate various metrics, such as the sum, average, or highest
value of a particular column, grouping those calculations based on common values in one or more other
columns. For instance, in a table containing weather data, you could calculate the highest temperature
during the year for every unique combination of ZIP Code and month in the table.

In this tutorial, you will perform a tabulation on the Sales Item Detail table in the Trillion-Row Spreadsheet
(TRS) to find the total amount of sales for each of three stores in a chain. You will then perform a separate
tabulation to calculate the total sales amount and number of items sold in each transaction. Finally, you will
export the tabulation to a Microsoft Excel workbook file.

To perform a tabulation:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

2. Open the Sales Item Detail table (pub.demo.retail.item).
TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.
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3. In the New operation panel, click Tabulate.
TRS displays the Tabulation panel.

The Tabulation panel allows you to create a basic tabulation.

4. Remove the default cnt (count) tabulation function by clicking the Remove ( ) icon.
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Next, choose the column by which you want to group the information. In other words, specify how you want
to subtotal the data. When performing a tabulation, a helpful question to ask yourself is "What values do
I want to use to group the records?" Since you want to find the total amount of sales for each store, you
should group the information by the Store column. Grouping is a way of pooling all the records for a single
entity or value (in this case, a store) into a single entry in the table.

5. Drag the Store column from the Worksheet Columns section to the Row Breaks section.

This groups your tabulation by store.

Now that the data grouping is set, choose the data you want to summarize. Since you want to find the total
amount of sales, you should summarize the Sales column.

6. Drag the Sales column from the Worksheet Columns section to the lower area of the Column Breaks
section.

This selection chooses the column of data you want to summarize.
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TRS adds the sum of Sales summarization and returns the Sales column to the Worksheet Columns
section.

The summarization is a combination of the selected column and the default tabulation function for that
column's data type. In this case, sum is the default tabulation function for Sales. This means the sum of
Sales summarization will calculate the total amount in the Sales column.

The next step of a tabulation is to select the tabulation function you want to perform on the column. This is
done by clicking the summarization (in this case, sum of Sales) and choosing a tabulation function from
the menu.
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However, since the default tabulation function happens to be exactly what you are looking for, you do not
need to make this selection.

At this point, your tabulation should look like the following image.

Starting from the right and working left, the tabulation panel indicates that the resultant worksheet will
contain a single column (Sales) and each row in that column will list the total sales amount (sum of Sales)
grouped by Store.

By default, columns in the resultant worksheet are named t0, t1, t2, and so on. You can give the
tabulated columns more meaningful names within the More Options view of the Tabulation panel. In
addition, you can define the format of the tabulation.

7. Click the More Options switch.
TRS displays the formatting options.
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Select sum of Sales in the Tabulation Column drop-down. This indicates that the name and
formatting options you define apply to the sum of Sales tabulated column.

8. Complete the following fields:

Tabulation Label Enter Sum of Sales Tabulation

Result Name Enter sumsales.

This is the column name. Remember, column names must begin with
an alphabetic character, may only contain alphanumeric characters or
underscores, and may not contain any spaces or other special characters.

Result Heading Enter Sum of`Sales.

This is the column label. For easier readability, column labels may contain any
combination of uppercase and lowercase letters, numbers, spaces, and special
characters. The backtick ( ` ) special character is used to break the column
label text line into multiple lines. In this case, "Sum of" will be on the first line of
the column label and "Sales" will be on the second line.

Display Format Select Currency: $1,234.56.

Since your totals will be dollar amounts, this option is selected. When currency
is selected, TRS adds the dollar sign and uses two decimal places for each
tabulated sales value.

Column Width Select Default.

Decimal Places Select Default.

Because you selected currency above, TRS will automatically use two decimal
places.
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Now that you have selected the data you want to group by, the data you want to summarize, and the
formatting options, generate the tabulation.

9. Click the Submit operation ( ) icon.
TRS displays the results of your tabulation.

Note:  In the image above, the column heading (Sum of Sales) is at the top of the column. If
you prefer, you can change this to show the column name instead. For details, see Edit your
data preferences in the 1010data Insights Platform User's Guide.

Notice that there is a row of data, with values in orange, at the top of the worksheet. This row shows
the totals for each column of summarized data. The three fictional stores generated $59.85 in sales
with store 1 generating $23.19, store 2 generating $16.31, and store 3 generating $20.35. While this
tabulation might not seem very useful for a chain of three stores, it becomes much more useful when
summarizing chains with hundreds, or even thousands, of stores.

Now, you will take a look at a slightly more complex example of a tabulation.

Instead of looking at the total sales per store, you will determine the sales totals for each transaction in
the Sales Item Detail table. However, you also want to know at which store any given transaction took
place, and also the total number of items in each transaction. The objective is to have a summary table
that shows you the transaction ID, store, sum of sales, and total units for each transaction. To accomplish
this, you will edit the existing tabulation operation in the timeline.

10.In the Analyze tab, click the Tabulation operation in step 2 of the timeline.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html?q=UserProfile/SettingsDataPreferences.html
http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html?q=UserProfile/SettingsDataPreferences.html
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TRS displays the Tabulation panel.

Just as before, start by selecting a column to group your data. In this case, you want to see the total sales
figures for each transaction. You also want to know which store recorded each of the transactions in the
table, so you should also group by store.

11.Drag the Transaction column from the Worksheet Columns section to the Row Breaks section
placing it above the Store column.

This selection first groups the tabulation by transaction and then divides the tabulated results into
subgroups by store. The result of the calculation for each transaction will be displayed on a separate
row in the new worksheet.
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Note:  The order by which you choose to group the data is important because it can affect the
results of the tabulation.

Now that you have grouped your data, first by transaction, then by store, you can choose the data you
want to summarize. In this example, you are still summarizing sales, so you can leave the sum of Sales
summarization and simply add the summarization of units.

12.Drag the Units column from the Worksheet Columns section to the lower area of the Column Breaks
section placing it below the sum of Sales summarization.

This selection is chosen because you want to determine the number of units.

TRS adds the sum of Units summarization and returns the Units column to the Worksheet Columns
section.

Since the default tabulation function (sum) is what you want, once again you do not need to select a
tabulation function from the menu.

The tabulation panel indicates that the resultant worksheet will contain two columns, Sales and Units. The
rows in each column will list the total sales amount (sum of Sales) and total number of items sold (sum of
Units) grouped first by Transaction and then subgrouped by Store.

Next, as before, give the new tabulated column a more meaningful name and define the formatting.

13.Click the More Options switch.
TRS displays the formatting options.
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14.In the Summary section, click sum of Units.

This selection is chosen because this time you want to define the name and formatting options for the
sum of Units tabulated column.

TRS displays the formatting options for the sum of Units tabulated column.

15.Complete the following fields:

Tabulation Label Sum of Sales Tabulation

Result Name Enter totunits.

Result Heading Enter Total Units.

Display Format Select Default.

Column Width Select Default.

Decimal Places Select Default.
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Now that you have selected the data you want to group by and the data you want to summarize, generate
the tabulation.

16.Click the Submit operation ( ) icon.
TRS displays the results of your tabulation.

Notice that in the new summary, the total sales figure in the row at the top of the Sum of Sales column
remains the same. However, instead of the total sales by store, TRS displays the total sales figure for
each transaction and the store at which the transaction took place. In addition, the tabulation includes
the total number of units sold in every transaction to provide a little more insight into volume. This
provides you with an extra layer of detail or granularity in your results. Yet, the new table is still much
easier to read and understand than the original Sales Item Detail table.

The final step in this tutorial is to download your results in a Microsoft Excel workbook file.

17.In the analysis pane, click the Export tab.

TRS displays the export options.
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18.Click Microsoft Excel.

19.Click the Export button.
TRS saves the tabulation to your computer as download.xlsx.

Note:  Depending on the browser you are using, you may be prompted to open or save the file.
If you are prompted, save the file.

20.When you are finished with this tutorial, close the TRS window.

After you are comfortable with them, tabulations are a very fast and powerful way to get a sense of what
information your data contains and how it can be leveraged to make decisions. So with that in mind, good
luck and keep practicing.
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Linking

Linking provides a simple yet powerful way of combining the data from two tables. Use linking to join tables
or worksheets into a single, bigger table with columns from both.

When you work a lot with data, you will often find yourself in a position where you want to use two separate
tables, which contain different but related data, to answer a question. The 1010data Insights Platform
has a highly effective feature that allows you join the information from related data tables together in a
straightforward manner. It is called linking, and it is one of the things the Insights Platform does best.

The Sales Item Detail table you have been working with in the previous tutorials of this guide contains
information about every transaction for your fictitious retail chain. However, what if you wanted to know
which department each item in those transactions came from? That information is found in the Product
Master table. Similarly, what if you wanted to know more about the store in which that transaction took
place? That information is found in the Store Master table. If you could combine those tables with your
Sales Item Detail table and match up the data, you would be able to learn exactly what those details are.

In the linking tutorials in this guide, you will start with the Sales Item Detail table.

This table contains a lot of useful information about every transaction in your fictional retail point of sale
(POS) system. The Item SKU column provides a reference to the exact product that was purchased.
Within this table, you can see the date, store, and sales price of every item that was sold, as well as in
which transaction it took place. However, based on the information in this table, you do not know any
details about the items other than a SKU code. Fortunately, you have access to a Product Master table
that gives a description of these items.
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Note:  It is not necessary to open the Product Master table to link it in. Linking in a table can be
done without opening the foreign table. It is shown here to illustrate the relationship between the
tables in the link operation.

The Product Master table shown above contains specific information about all the product SKUs that are
also in the Sales Item Detail table. Here you can see descriptions for each product, its category, and the
department of the fictitious retail chain in which it is sold. But what if you wanted to look at this information
as it relates to your sales data? The answer is to link the two tables together at a common data point. In
this instance, both tables contain item SKU data. In this tutorial, you will use the SKU column in both tables
to link them together.

Note:  If you have an SQL background, you can think of linking tables as equivalent to a join in
SQL.

For more information about linking, see Linking tables and worksheets in the 1010data Insights Platform
User's Guide.

Link in a table
You can link in another 1010data Insights Platform table to the current table or worksheet.

In this tutorial, you will link the Product Master table into the Sales Item Detail table using the Trillion-Row
Spreadsheet (TRS). The combination of these two tables provides you with both the product and sales
information within one worksheet for items sold within your fictitious retail chain.

To link in a table:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/TRS/Link/LinkingTablesWorksheets.html


Trillion-Row Spreadsheet Getting Started Guide | Linking | 40

2. Open the Sales Item Detail table (pub.demo.retail.item).
TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.

3. In the New operation panel, click Link.
TRS displays the object browser in the Link tables panel.
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You will use the table browser to select the foreign table (Product Master) that you want to link into the
current table (Sales Item Detail).

4. In the Suffix field at the bottom of the table browser, enter _pm.

While not required, this field is highly recommended as it differentiates the column names from the two
tables you are linking. By adding the _pm suffix to the columns from the Product Master table, it will be
clear in the final worksheet which columns came from the Sales Item Detail table and which came from
the Product Master table.

5. Browse for and select the Product Master table (pub.demo.retail.prod).
TRS displays the link column options in the Link tables panel.

In the Link tables panel, you select at least one column in the base table (Sales Item Detail) that matches
a column in the foreign table (Product Master). For example, an item in the Sales Item Detail table that
has a value of 366 in the Item SKU column matches with the first row in the Product Master table that has
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a value of 366 in the SKU column. These columns provide a common data point where the two tables can
be linked. While you can link two tables with more than one column at the same time, this tutorial focuses
on linking a single column.

Columns in the Link tables panel are color coded so that you can quickly determine its data type.

Table 2: Column data type by color

Color Data Type

Red Integer

The integer data type (int) is used to represent whole numbers that can be stored
within 32-bits.

Purple Big integer

The big integer data type (bigint) is used to represent whole numbers that are
outside the range of the integer data type and can be stored within 64 bits.

(Available as of version 11.25)

Blue Decimal

The decimal data type (dec) is used to represent 32-bit floating point values.

Yellow Text

The text data type (text) is used to represent values that contain uppercase and
lowercase letters, numbers, spaces, and symbols.

Note:  When linking two tables, make sure that the columns from each table have the same data
type. An error will occur if you attempt to link a column of one data type in a table to a column of a
different data type in the other.

6. In the After linking drop-down list, select Keep all rows.

This option is selected because you want to link in all rows from the foreign table.

7. Drag the Item SKU column from the Sales Item Detail section to the blank section directly to the right.

This is the column from the Sales Item Detail table you currently have open.

Note:  It is important to point out that the columns in each section use the column headings from
the table, not the column names. You can view the column names instead by marking the Show
with column name checkbox.
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Next, select a column in the foreign table you are linking in that corresponds to the one you just selected in
the table you currently have open.

8. Drag the SKU column from the Product Master section to the blank section directly to the left.

This is the column in the Product Master table you are linking in. Again, this is the heading of the
column, not the name.

9. Click the Submit operation ( ) icon.
TRS links the Product Master table into the Sales Item Detail table and displays the columns from the
two tables combined.

With the columns combined, not only can you see that an item with the SKU 3B7 was purchased
on 5/15/12 at store 1, but you can also see its corresponding item description (PEPSI 20 OZ) and
department (SNACKS).

10.When you are finished with this tutorial, close the TRS window.

In this tutorial, you linked the Product Master table, which had not been changed in any way, into the
Sales Item Detail table. However, what if you had done some work to the Product Master table, thus
making it a worksheet? In this case, you would need to link in a worksheet. For instructions, see Link in a
worksheet on page 44.
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Link in a worksheet
Linking in a worksheet allows you to perform various actions on a table and then link the results into an
existing table or worksheet.

What if you wanted to modify the Product Master table and link those results into the Sales Item Detail
table? You might do this because you only want to link in additional information for a subset of the data.
For example, in this tutorial you only want to link in the additional product information for items in the
snacks department. You can accomplish this in the 1010data Insights Platform Trillion-Row Spreadsheet
(TRS) by selecting the rows corresponding to that department in the Product Master table and then using
the Link operation to add the data to the Sales Item Detail table. In this example, you are working with
only 35 rows of data. However, for tables with billions of rows, linking in only the additional information you
need is more efficient and can result in quicker processing.

To link in a worksheet:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

2. Open the Sales Item Detail table (pub.demo.retail.item).
TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.
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3. In the New operation panel, click Link.
TRS displays the object browser in the Link tables panel.

4. In the Suffix field at the bottom of the table browser, enter _pm.

5. Click Link to worksheet.
The Insights Platform opens a new TRS window used to select the worksheet you want to link into the
Sales Item Detail table.
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6. In the Analyze tab of the new TRS window, browse for and select the Product Master table
(pub.demo.retail.prod).
TRS displays the New operation panel in the analysis pane on the left and the Product Master table in
the results pane on the right.

7. In the Department column of the Product Master table, right-click any of the instances of the value 22
and choose Select rows > Where Department has the value 22 from the menu.
TRS performs the row selection and adds the select operation to step 2 in the analysis timeline.
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Because the original Product Master table has been modified by the row selection, it is now considered a
worksheet. The worksheet has four rows.

This worksheet can now be linked into your Sales Item Detail table in its current form.

8. In the new TRS window, click the Minimize ( ) icon to return to the original TRS window containing
the Sales Item Detail table.
TRS displays the link column options for the Sales Item Detail table in the Link tables panel.

Just like when you linked in the original Product Master table in Link in a table on page 39, link once
more on the SKU columns.

9. In the After linking drop-down list, select Keep all rows.

This option is chosen because you want to link in the four selected rows from the foreign worksheet
(Product Master) and retain the rows in the base table (Sales Item Detail) that do not have a matching
department.

10.Drag the Item SKU column from the Sales Item Detail section to the blank section directly to the right.

11.Drag the SKU column from the Product Master section to the blank section directly to the left.

12.Click the Submit operation ( ) icon.
TRS links the Product Master worksheet into the Sales Item Detail table.
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The result is a new worksheet that has information from the Product Master worksheet only for those
item SKUs that fall under department 22. However, the other rows in the Sales Item Detail table
remain, and the columns from the Product Master worksheet are left blank for items not in department
22. This is useful if you want to look at additional information about one subset of rows in a table or
worksheet but still maintain the original level of detail for the other rows.

As an alternative, what if you want to simply eliminate the rows in the Sales Item Detail table that are
not applicable to the selection in the foreign worksheet (Product Master)? In that situation, you only
need to change one setting. The beauty of the analysis timeline is that you can make that change very
easily to obtain those results.

The process to link and select rows is nearly identical to the process of simply linking to another table
or worksheet. The only difference is the results produced. Instead of applying the information from the
foreign worksheet to the entire base table or worksheet, the Include matching rows linking option
retains only those rows in the base table that correspond to the selection in the foreign table.

For instance, what if in the exercise you just completed above, you only wanted to see SKUs in the
base worksheet that are in department 22? Since department information does not exist in the base
table, you cannot make that selection. You could first link in the Product Master as the foreign table
and then perform a row selection. However, that requires first linking in more rows than you need, which
is less efficient. The best solution is to first select the rows in the Product Master table, then perform a
link and select to eliminate the rows in the base table that cannot be linked.

With this in mind, go back and edit the link operation in the timeline to perform a link and select.

13.In the Analyze tab, click the Link to table pub.demo.retail.prod operation in step 2 of the timeline.
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TRS displays the link column options for the Sales Item Detail worksheet in the Link tables panel.

14.In the After linking drop-down list, select Include matching rows.

This option is chosen because you want to link in the four selected rows from the foreign worksheet
(Product Master) and eliminate the rows in the base table (Sales Item Detail) that do not match.

15.Click the Submit operation ( ) icon.
TRS displays the results of your selection.
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The result is a new worksheet with only the rows from the Sales Item Detail table that have SKUs in
department 22, reflecting the selection from the Product Master worksheet. Only rows left in the Sales
Item Detail worksheet are those that apply to the initial selection you made in the Product Master
worksheet. This method allows you to use links more efficiently and effectively in your analyses.

16.When you are finished with this tutorial, close both TRS windows.

In this tutorial, you learned how to link in a worksheet. In the first part of the exercise, only the rows that
applied to the selection in the foreign worksheet had the columns linked from the foreign worksheet. In
the second exercise, the rows that were not applicable to the selection in the foreign worksheet were
eliminated.

The linking tutorials are intended to introduce you to the topic of linking, but it is a complex topic with
many variations, which makes it very powerful. Finding ways to combine data sets and provide them with
context is what the Insights Platform is all about. After reviewing these tutorials, take some time to explore
tables and see if they have places where they can be joined by columns with similar information. This will
help you understand how your data is interrelated, and start you down the path of deeper, more insightful
analysis.
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Cross tabulations

A cross tabulation allows you to summarize the values in a column based on the values in two or more
other columns and display the result as a matrix.

In the tutorials in this section, you will learn how to perform a cross tabulation. After you have performed a
cross tabulation, you will learn how to create a computed column from your cross tabulation.

A cross tabulation can help you gain granularity from a summary without losing the highest level of data
summarization. For example, in addition to finding the total amount of sales for each store in your chain,
you can also obtain the sales figures for the individual departments within each store and how they
compare to the total.

To illustrate this concept, shown below is the Sales by Store summary from Perform a tabulation on page
26.

This result was reached simply by adding up the total sales for each store and assigning the total for each
result to a single row in the table. Another way to think about this is that you created a "bucket" for each
store and placed the amount of each transaction in the bucket of the store where the transaction took
place. What if you want to know which departments contributed to the sales of each store?

The best way to get this information, without losing sales totals for each store, is to perform a cross
tabulation. Effectively, a cross tabulation groups on a second metric and summarizes it, placing the data
into one column for each unique value in the group. Each row will contain sales figures for each store, and
a new set of columns will be created to show the sales totals for each department.

Perform a cross tabulation
A cross tabulation provides extra granularity from a summary without losing the highest level of data
summarization.

In this tutorial, you will learn how to perform a cross tabulation in the 1010data Insights Platform Trillion-
Row Spreadsheet (TRS) to determine the sales amount by store. The sales totals for each store will be
broken out by department so you can see how much each department contributed to the total sales.

To perform a cross tabulation:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.
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2. Open the Sales Item Detail table (pub.demo.retail.item).
TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.

To get the department information for your cross tabulation, you need to link in the Product Master table.
This is identical to the process used in Link in a table on page 39.

3. In the New operation panel, click Link.
TRS displays the table browser in the Link tables panel.

4. In the Suffix field at the bottom of the table browser, enter _pm.

5. Browse for and select the Product Master table (pub.demo.retail.prod).
TRS displays the link column options in the Link tables panel.

6. In the After linking drop-down, select Keep all rows.

7. Link in the table by the SKU columns.

a) Drag the Item SKU column from the Sales Item Detail section to the blank section directly to the
right.
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b) Drag the SKU column from the Product Master section to the blank section directly to the left.

8. Click the Submit operation ( ) icon.
TRS links the Product Master table into the Sales Item Detail table and displays the results of the link.

9. In the New operation panel, click Tabulate.
TRS displays the Tabulation panel.

10.Select the Show with column name checkbox.

The Show with column name checkbox displays the column names instead of the column labels.
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Notice the _pm suffix that you specified is added to the end of the certain column names. This indicates
that a column is a linked column from the Product Master table.

11.Clear the Show with column name checkbox.

12.Remove the default cnt (count) tabulation function by clicking the Remove ( ) icon.

13.Drag the Store column from the Worksheet Columns section to the Row Breaks section.

This selection creates a row for each store in the cross tabulation.

14.Drag the Department Description column from the Worksheet Columns section to the upper area of
the Column Breaks section.

This selection creates a column for each department in the cross tabulation. The Department
Description will be parsed for its individual values and then summarized. In this case, a column for
each department that had sales will be created.
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Next, you need to select the actual summary type. The summary applies to both the row grouping and the
column grouping. In this case, you are calculating total sales by department for each store.

15.Drag the Sales column from the Worksheet Columns section to the lower area of the Column Breaks
section.

This selection chooses the column of data you want to act on. In this instance, you want to calculate the
total sales.
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TRS adds the sum of Sales summarization and returns the Sales column to the Worksheet Columns
section.

The summarization is a combination of the selected column and the default tabulation function for that
column's data type. In this case, sum is the default tabulation function for Sales. This means the sum
of Sales summarization will calculate the total amount in the Sales column.

The next step of a cross tabulation is to select the tabulation function you want to perform on the
column. This is done by clicking the summarization (in this case, sum of Sales) and choosing a
tabulation function from the menu. However, since the default tabulation function happens to be exactly
what you are looking for, you do not need to make this selection.

Notice that the selections you made in the Tabulation panel represent how your worksheet will display
your analysis. In this example, your worksheet will contain stores as rows and department descriptions
as columns. The intersection between the two will list the sales total for the store by department.

Next, define the format of the tabulation.

16.Click the More Options switch.
TRS displays the formatting options.
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Select sum of Sales in the Tabulation Column drop-down. This indicates that the name and
formatting options you define apply to the sum of Sales tabulated column.

17.Complete the following fields:

Tabulation Label Enter Department Sales By Store

Display Format Select Currency: $1,234.56.

Column Width Select Default.

Decimal Places Select Default.

18.Click the Submit operation ( ) icon.
TRS displays the results of your cross tabulation.
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As you can see above, the totals for all the stores are still available in the first column outlined in red.
However, you can also see how much each department contributed to those totals. For instance, the
snacks department accounted for $24.30 of the $59.85 in total sales across all the stores in our fictional
retail chain.

Further granularity shows that in store 1, $12.30 was from the snacks department.

19.When you are finished with this tutorial, close the TRS window.

Cross tabulations are a great way to get further insight into the numbers of regular tabulations. You can
keep your totals, but see the story behind the numbers by breaking them down into their constituent parts.
Next time you are not sure about why a summary looks the way it does, rely on a cross tabulation to better
understand your data and your business.

Create a computed column from a cross-tabulated column
After you have a completed a cross tabulation, you can work with the resultant columns of the new
worksheet the same as you would with any other 1010data Insights Platform table. This makes it easy to
create new metrics based on your summaries.

In this tutorial, you will use the Trillion-Row Spreadsheet to perform a simple day-over-day calculation by
first creating a cross tabulation and then creating a computed column.

In your analysis, you want to see the sales of one date compared to the sales of a different date for all
three of your fictional stores. For this example, the dates are consecutive.

To create a computed column from a cross-tabulated column:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

2. Open the Sales Item Detail table (pub.demo.retail.item).
TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table
in the results pane on the right.
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Next, perform a row selection to limit the data to the two days in which you are interested.

3. In the New operation panel, click Select.
TRS displays the Simple Comparisons options in the Select rows panel.

4. Clear the Simple Comparisons checkbox.
TRS displays the expression field.

5. In the expression field, enter the following: between(date;20120517;20120518)

6. Press Enter.
TRS displays the results of your selection.
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Next, you will create your cross tabulation. This will give you the totals for both the stores overall, and
the totals for each of the two dates you selected.

7. In the New operation panel, click Tabulate.
TRS displays the Tabulation panel.

8. Remove the default cnt (count) tabulation function by clicking the Remove ( ) icon.

9. Drag the Store column from the Worksheet Columns section to the Row Breaks section.

This selection creates a row for each store in the cross tabulation.

10.In the Store column within the Row Breaks section, click the Sort Up ( ) icon.
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This selection sorts the cross tabulation results in ascending order by store number.

11.Drag the Date column from the Worksheet Columns section to the upper area of the Column Breaks
section.

This selection creates a column for each date for which the store had sales.

12.Drag the Sales column from the Worksheet Columns section to the lower area of the Column Breaks
section.

This selection chooses the column of data you want to act on. In this instance, you want to calculate the
total sales.

TRS adds the sum of Sales tabulation function and returns the Sales column to the Worksheet
Columns section.

The next step of a cross tabulation is to select the tabulation function you want to perform on the column.
In this case, you want to summarize the data in the sales column. The summary applies to both the row
grouping and the column grouping. In other words, you are calculating total sales by date for each store.
This is done by clicking the summarization (sum of Sales) and choosing a tabulation function from the
menu. However, since the default tabulation function happens to be exactly what you are looking for, you
do not need to make this selection.

Next, define the format of the tabulation.

13.Click the More Options switch.
TRS displays the formatting options.

14.Complete the following fields:

Tabulation Label Enter Sales by Store for 5/17 and 5/18

Display Format Select Currency: $1,234.56.

Column Width Select Default.

Decimal Places Select Default.
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15.Click the Submit operation ( ) icon.
TRS displays the results of your cross tabulation.

Since you eliminated all the dates except the two you are interested in, you can now create a computed
column that shows the difference in sales from one day to the next.

16.In the New operation panel, click Compute.
TRS displays the Computed column panel.

17.Complete the following fields:



Trillion-Row Spreadsheet Getting Started Guide | Cross tabulations | 63

Name Enter dod.

This is a required field.

Label Enter Day-Over-Day.

By default, resultant columns in cross tabulations are named m0, m1, m2, and so on.

In this case, to calculate the day-over-day sales, simply subtract the values in the column with the less
recent date (m0) from the values in the column with the more recent date (m1).

18.In the expression field, enter the following: m1-m0

Next, define the format of the computed column.

19.Click the More Options switch.
TRS displays the formatting options.

20.Complete the following fields:

Display Format Select Currency: $1,234.56.

Column Width Select Default.

Decimal Places Select Default.

21.Click the Submit operation ( ) icon.
TRS creates the Day-Over-Day computed column.

From the results, it is clear that the sales for store 2 plummeted on the last day.

22.When you are finished with this tutorial, close the TRS window.

Cross tabulations are a great way to get further insight into the numbers of regular tabulations. You can
keep your totals but see the story behind the numbers by breaking them down into their constituent parts.
Next time you're not sure about why a summary looks the way it does, rely on cross tabulations to better
understand your data and your business.
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Charts

The 1010data Insights Platform provides a way for you to generate high-quality charts from your data.

It can sometimes be easier to find trends and see differences more easily in a chart. For example, it may
be quicker and easier to find the day of sales with the highest profit margin from a chart than from a table
of numbers listing the same information. Charting can help you make sense of large amounts of data that
might otherwise be too overwhelming to comprehend.

The tutorial in this section demonstrates how to create a bar chart that shows total sales and profits for all
stores combined for the fiscal month of May. In addition, you will learn how to customize and download a
chart.

For more information about charting, see Visualize in the 1010data Insights Platform User's Guide.

Create a bar chart
You can create a bar chart to show comparisons among categories in your data. You can also customize
display settings and save a chart from the Trillion-Row Spreadsheet (TRS) to your computer as a PNG or
PDF file.

The first step to creating a chart in the platform is to prepare your data. For this tutorial, this step has
already been done so you can focus on creating the chart itself. The sample data provided compares
the total sales, cost, and profit for stores in a fictitious retail chain. Use this data to create a bar chart
comparing the total profit, sales, and cost of all stores combined for each day in the fiscal month of May.
After you have created your chart, you will then change display preferences like colors and labels. A chart
created in the 1010data Insights Platform TRS can be downloaded as a PNG or PDF file for a variety
of uses. For example, you can share the chart with someone who does not have access to the Insights
Platform, or you could use the chart as an image within a report or presentation. This tutorial explains how
to download a chart as a PDF file.

To create a bar chart:

1. From the menu bar, select Tools > Trillion-Row Spreadsheet.
The Insights Platform displays the TRS window.

2. Open the Bar Chart Sample Data Quick Query (pub.doc.retail.barchartex).
TRS displays the Bar Chart Sample Data tabulation.

http://www2.1010data.com/documentationcenter/beta/1010dataUsersGuideV10/index_frames.html?q=TRS/Visualize/Visualize.html
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3. In the analysis pane, click the Visualize tab.
TRS displays the Visualize options.

4. Create a bar chart showing the total sales and profit by day.

a) In the drop-down list below the Update, Reset, and More Options buttons, select Bar.
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b) From the column list section to the left of the buttons, drag Date into the Labels section.

c) From the column list section, drag Cost, Sales, and Profit, one at a time and in that order, into the
Bars section.

Note:  The order in which the columns are arranged in this section, from top to bottom,
determines the order in which the columns appear in the chart, from left to right.

d) Click Update.

TRS displays a bar chart of your data.
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TRS provides a number of customizable settings that control the way a chart is displayed, including the
size of the chart, background color, appearance of the title and the axes, and placement of the legend. You
can also add titles and labels.

5. Add a title to your chart.

a) Click More Options.
TRS displays the customization settings.

b) In the customization settings, click Title.
TRS displays the Title customization settings.
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c) In the Title text field, enter Cost, Sales, and Profit by Date.
d) Press Enter.

TRS adds the title to your chart.

6. Add a text label to the y-axis.

a) In the customization settings, click Axes.
TRS displays the Axes customization settings.



Trillion-Row Spreadsheet Getting Started Guide | Charts | 69

b) At the top of the Axes section, click the Y-AXIS tab.
c) In the Y-label field, enter Dollars.

d) Press Enter.

TRS adds the new text label to the y-axis of your chart.

You can change the colors of the bars in the chart to suit your tastes. In the example above, it might make
more sense to change Sales to blue and Profit to green.

7. Change the color of the bars in your chart.
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a) In the customization settings, click Data Series.
TRS displays the Data Series customization settings.

b) Next to the Colors field, click Add.
TRS displays the Hexadecimal field and Color Preview box below the Colors field.

c) Click either the Hexadecimal field or the Color Preview box.
TRS displays the color palette.
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d) In the Theme Colors section, click the red box ( ) in the top row.
TRS enters the hexadecimal code for the selected red color in the Colors field and changes all of
the bars in the table to that color.

Note:  Since there is only one hexadecimal value entered in the Colors field, all of the bars
are set to the same red color.

To change the bar color for the remaining two columns, repeat the process two more times. Each
added color changes the bar color of the next column in the chart. Hexadecimal values in the Colors
field, from left to right, change the color of the chart object from right to left.

e) Next to the Colors field, click Add.
TRS displays the Hexadecimal field and Color Preview box containing the hexadecimal code and
color for the first column.

f) Click either the Hexadecimal field or the Color Preview box and then click the blue box ( ) in the
top row of the color palette.
TRS adds the hexadecimal code for the selected blue color to the Colors field and changes the
Sales bars to blue.

g) Next to the Colors field, click Add.
TRS displays the Hexadecimal field and Color Preview box containing the hexadecimal code and
color for the second column.

h) Click either the Hexadecimal field or the Color Preview box and then click the green box ( ) in the
top row of the color palette.
TRS adds the hexadecimal code for the selected green color to the Colors field and changes the
Profit bars to green.
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Finally, download your chart as a PDF file.

8. Right-click anywhere on the chart and select Download As > PDF from the menu.

TRS saves the chart to your computer as download.pdf.

Note:  Depending on the browser you are using, you may be prompted to open or save the PDF
file. If you are prompted, save the file.

9. When you are finished with this tutorial, close the TRS window.
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In this tutorial, you learned how to create, edit, and download a simple bar chart from your data. While the
data for this tutorial was small and easy to understand, the data you work with each day will undoubtedly
be much more complex. Using the charting options provided in TRS can help you gain insight to your
data in ways that would be quite difficult to see otherwise. Feel free to explore and play with the other
customization settings. This will help you learn what else is available so that you can fully customize your
charts.
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