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C H A P T E R  1  

Welcome to Trimble Business Center -  
Heavy Construction Edition 

Trimble® Business Center - Heavy Construction Edition is office software designed to 
help construction contractors prepare construction data for use within Trimble site 
positioning systems (SPS) that employ SCS900 and SCS900 Tablet Edition site 
controller software (SCS). For those new to Trimble Business Center, we recommend 
reading these topics first: Get Familiar with the Interface, the Project Explorer (on page 
7), the Selection Explorer (on page 8), the Plan View (on page 25), and Prepare Data for 
Site Positioning Systems (on page 370). 

Features: 

 Import and export of site and design data in multiple file types 

 Graphical views of project data, including plan, profile, 3D, and cross-section 

 Hierarchical tree view of project data and list view of selected objects 

 Surface modeling and volume calculations 

 Alignment creation 

 Reports and quality assurance tools 

 Site Positioning System management: 

 Management of Trimble SPS operations on the job site 

 Preparation of site and design data for field crews carrying out SPS operations 

 Creation and monitoring of work orders for field crews using SCS900 

 Graphic view of the site and design data associated with a work order, as it will 
be displayed to field crews by SCS900 

 Import of field measurement data resulting from SPS operations 

Note: These core features provide the foundation for advanced functionality in the 
form of future, add-on modules. 
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Related topics 

 About Trimble Business Center Command 
 Products Command 
 Register This Software (on page 3) 
 Start Page Command 
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C H A P T E R  2  

Get Started 

Register This Software 
Register this software so you can receive product upgrades, support, and 
warranty-related services. 

Note: The Product Registration dialog appears in English only. The following steps guide 
you through the dialog in your installed language. 

To register:  

1. Select Help > About. The About dialog displays. 

2. Click Register. The Product Registration dialog displays, showing these notes: 

Please register your new software with the MyTrimble system. The MyTrimble 
system provides access to the latest product information from, and helps track your 
company's products and warranty information. 

Enter your email address. Each MyTrimble account has an associated email 
address. If your company has an existing MyTrimble account, enter that email 
address. 

If your company does not have an existing MyTrimble account, then you will 
create an account in the next step. 

Note: We value your privacy. We will not sell, rent, or share this information with 
third party marketing firms or other manufacturers or products. For further details, 
please click on the link to see our Privacy Statement. 

3. Type your email address in the box, and click Next. These notes appear: 

To create an account, enter your contact details below. All fields are required. If 
your company already has an account, click Back to return to the previous screen 
and enter the email address for that account. 
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Note: These contact details may be used for the delivery of product upgrades or 
enhancements, and warranty-related services. Refer to our Privacy Statement for 
additional details. 

4. Type the following in the boxes: (all are required) 

 First name 

 Last name 

 Company name 

 Address 

 City 

 State/Province 

 Postal code 

 Country 

 Phone number 

5. Click Next. This note appears: 

If you have a dongle attached to your computer, its serial number has been read 
and entered below. If you software did not come with a dongle, refer to the sticker 
on the software box for your serial number. These boxes should be automatically 
filled: 

 Serial number 

 Product name 

 Part number 

 Ship date 

Note: Your software product may not require a dongle or other license. 

6. If the boxes are empty, type the serial number for your software in the Serial 
Number box, and click Product Lookup. Otherwise, skip to step 9. 

Note: If you receive this warning: Serial Number Not Found! Please make sure you 
have entered the serial code correctly, click Reenter Serial Number, and correct the 
serial number. 

7. If you have a company-specific reference number for software, you can type it in 
the Reference Number box. 

8. Click Submit. This note appears: 

Thank you for registering! Your software has been successfully registered! Your 
password has been sent to your email. Please check your email to find the details 
on how to access your MyTrimble account. 
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This note may also appear: Our system found that you have other products that are 
not yet registered. Please choose below which product you want to register and 
click Register. 

9. Check boxes for any other products you want to register, and click Register. 
Otherwise, click Not this time. 

Note: To login to your MyTrimble account, please visit our web site's Register page. 

Retaining User Settings When Upgrading 
As you use the program, many of your settings and other customizations are saved as 
files in an application data folder. These settings, which remain constant regardless of 
which project is open, include: 
Application settings These program-wide settings include startup 

preferences, default file locations, and display 
properties. Application settings are primarily found 
in the Options dialog. 

Custom Import and Export Format 
Definitions 

These include changes  
to how file formats are defined in the Import 
Format Editor and  
Export Format Editor. 

Project Templates These include project settings, coordinate systems, 
view filters, selection sets, and data that you have 
saved as project templates. 

Internet Download Configurations These include new data provider groups and 
Internet sites that you have added to the Internet 
Download command.  

Baseline Processing and Network 
Adjustment Styles 

These include combinations of project settings that 
you have defined as templates for baseline 
processing and network adjustment. 

When you upgrade from your current version of the program to a newer version, the 
installation program searches for previous files containing these settings and 
customizations. If any are found, the Copy Settings dialog appears.  

To retain previous settings and customizations:  

1. In the Copy column, uncheck the box for each old file that you do not want to 
retain in the upgrade. 

2. Check the box for each old file that you do want to use to overwrite the new file. 

3. Click Copy Selected Files. The previous settings and customizations that you 
selected are copied to the new installation. 
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Note: Any files that conflict with the files in the new installation are marked with a red 
flag and are not selected by default. 
Note: It is always a good idea to confirm your project and application settings in the 
new installation to make sure that any new options in the current version are set to the 
defaults you want. 
Note: Customized menus and toolbars cannot be saved when you upgrade. 

 

Get Familiar with the Interface 
This software comes with an integrated user interface, including: 
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Interface elements 

Menu (see "Customize the 
Menu" on page 16) 

Gives you comprehensive access to all available commands. 

Toolbar (see "Customize 
the Toolbar" on page 18) 

Gives you quick access to the most commonly used commands 
and views using icons. 

Data views (on page 16) Allows multiple views of data in the plan view (on page 25), 
3D view (on page 28), profile view (on page 26), cross-section 
view (on page 26), and surface slicer view (on page 27). The 
data view area can be set up as a tabbed interface or a multiple 
window interface. Navigation and selection can be controlled 
both graphically and by commands. 

Status bar (on page 10) Includes status information, current units, an error flag 
(indicating computation errors), an indicator that the project 
should be computed again, the number of currently selected 
objects, and a coordinate display. 

Project Explorer (on page 
7) 

Shows a tree view of project data that includes sections for the 
objects and imported files, enabling you to easily select any 
object. 

Selection Explorer (on 
page 8) 

Shows the currently selected objects, as well as saved sets of 
objects known as 'selection sets'. 

View Filter Manager (on 
page 9) 

Lets you specify what data types and layers are visible and 
selectable in graphic views. 

Command Pane (on page 
13) 

Provides a consistent place to work through most commands.   

Properties Pane (on page 
14) 

Displays the properties associated with the currently selected 
object(s), enabling them to be edited. 

Flags Pane (on page 14) Lists objects with import or computation errors. 

 
 

Project Explorer 
The Project Explorer displays your project data organized in a tree structure. 

To display and pin the Project Explorer:  

1. Do one of the following: 

 Click the  icon on the toolbar. 



Trimble® Business Center 
Heavy Construction Edition User Guide 8 

 Get Started

 Select View > Project Explorer. 

 Press [F9] on the keyboard.  

The Project Explorer displays, docked on the left side of the application window, or 
where you positioned it last.  

2. If desired, pin the explorer open by clicking the  icon at the top.  If the pane is 
unpinned, the pane can "slide" to the side and out of view. To show it again, click 
the Project Explorer tab. 

Using the Project Explorer 

 To expand nodes, click the  icon. To collapse nodes, click the  icon. 

 To select a node or a data object, click it. 

 To display the properties for an object, double-click it. The Properties pane 
displays. 

 To access common commands for an object, right-click for a context menu. 

Related Topics 

 Select from the Project Explorer (on page 48) 
 Pane and Data View Positioning (on page 31) 
 Properties Pane (on page 14) 

 

Selection Explorer 
The Selection Explorer is a pane that lists the selection sets in your project in the top 
section and lists the objects in the active set in the bottom section.  

 When you click on a selection set, all the objects in the set are selected in the 
project.   

 When you select one or more objects in the list of objects, those objects are selected 
in the project.    

 When <Selection Snapshot> is active, objects selected in the graphics area are listed.  

Using selection sets makes accessing and selecting groups of commonly-used objects 
faster and more consistent. 

To display and pin the Selection Explorer:  

1. Do one of the following: 

 Select View > Selection Explorer. 

 Select Select > Selection Set > Selection Explorer. 

 Click the  icon on the toolbar. 
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 Right-click in a graphic view and select Selection Explorer from the context 
menu. 

The Selection Explorer displays, docked on the left side of the application window, 
or where you positioned it last. 

2. If desired, pin the explorer open by clicking the  icon at the top. If the pane is 
unpinned, the pane can "slide" to the side and out of view. To show it again, click 
the Selection Explorer tab. 

Related topics 

 Understanding Selection Sets (on page 54) 
 Create and Use Selection Sets (on page 57) 
 Modify Selection Sets (on page 58) 
 Pane and Data View Positioning (on page 31) 

 

View Filter Manager 
The View Filter Manager is a pane in which you can select data types and layers to 
specify what is visible in the current graphic view, helping you reduce and simplify 
what you see. As you make changes in the manager, the view updates to reflect them. 

View filters are saved sets of criteria that control what data and layers are displayed in 
the views. View filters can be defined separately for each type of view so that only the 
data that is important for the current phase of your work is displayed. When you 
change to a different view, the current and available view filters may change as well, 
because view filters are saved with views. The view filters for each view in your project 
can be accessed from the view filter list on the toolbar. 

To display and pin the View Filter Manager:  

1. Do one of the following: 

 Select View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays, docked on the left side of the application window, 
or where you positioned it last.  

Note: If the Project Explorer or Selection Explorer are also active, they may share the 
same pane, and be accessible as tabs at the bottom of the pane. 

2. If desired, pin the manager open by clicking the  icon at the top. If the pane is 
unpinned, it can "slide" to the side and out of view. To show it again, click the View 
Filter Manager tab on the left edge of the application window. 
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Using the View Filter Manager 

 When you check and uncheck boxes for data types and layers in the View Filter 
Manager, the current view changes in response. 

 Arrange the order of the data type groups in the tree by right-clicking on a group 
and selecting Move Up or Move Down from the context menu. 

 To set the selectability of data types and layers, click the  icon on the pane's 
toolbar to display the Advanced View Filter Settings dialog. 

Related topics 

 Create a View Filter (on page 73) 
 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 Pane and Data View Positioning (on page 31) 

 

Status Bar 
The status bar, located at the bottom of the application window, displays several useful 
pieces of information: 

 



Trimble® Business Center 
Heavy Construction Edition User Guide 11 

 Get Started

Status line Displays information about the current command. 

Snap button Click this to display the Snap mode dialog, in 
which you can set running snap modes. 

Units button Displays the current distance units. Click this to 
display the Units section of the Project Settings 
dialog. 

Flag Pane button Appears if errors have been detected in the project. 
Click this to display the Flags pane. Flagged items 
have associated messages or errors. 

Compute Project button Appears if changes made to the data require that 
final coordinates for points be recalculated. Click 
this to start the Compute Project command. 

Number of selected objects Displays the number of objects that are currently 
selected. 

Plan view dimensions icon Appears when the cursor is not in the data view 
area. 

Plan view dimensions 

or 

Coordinates display 

Displays the XY dimensions of the current view, 
when the cursor is not in the view area. 

Displays the true northing and easting coordinate of 
the current cursor location, when the cursor is 
within view area. 

Display Coordinate Pane checkbox Check this to display the Coordinates pane, which 
shows the current northing, easting, latitude, and 
longitude of the cursor. 

Related Topics 

 Running Snap Modes (see "Set Running Snap Modes" on page 89) 
 Change Project Units (see "Unit Settings" on page 151) 
 Flags Pane (on page 14) 
 Coordinates Pane (see "Coordinates Scroll" on page 15) 

 

Device Pane 
The Device pane enables you to directly access Microsoft® Windows® CE-based field 
devices or the data synchronization area (also known as the root sync folder in the 
Office Synchronizer utility), which contains the files maintained by Office 
Synchronizer. 

To display the Device pane: 

Do one of the following: 

 Click the  icon on the toolbar. 
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 Select View > Device Pane. 

 Press [F10] on the keyboard. 

The Devices pane displays, docked on the left side of the application window, or 
where you positioned it last. 

To connect to a f ield device: 

1. Connect the field device to the computer using a USB or serial connection. 

2. If the device asks if you want it to be connected, click Yes. The Device pane 
displays, showing a list of files on the device. 

 
3. As needed, upload (see "Upload Files (via Direct Connection)" on page 221) or 

download (see "Download Files (via Direct Connection)" on page 221) files via this 
direct connection. 

To connect to f ield data in the data synchronization area: 

In Office copy mode, the Device pane points to a folder on your office computer that 
contains the data previously synchronized from the field device, using the Office 
Synchronizer utility (see "Office Synchronizer" on page 219). 

 

1. To verify that data in the synchronization area is selected, click the  icon, and 
verify that Office Copy is checked in the drop-down list. The contents of the 
synchronizer root folder display. 

2. As needed, upload files (see "Upload Files (via data synchronization)" on page 224), 
upload tasks (see "Upload Tasks (via data synchronization)" on page 225), or 
download files (see "Download Files (via data synchronization)" on page 223) from 
the data synchronization area. 
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Related topics 

 Office Synchronizer (on page 219) 
 Pane and Data View Positioning (on page 31) 
 Prepare to Connect a Field Device (on page 217) 

 

Synchronizing Data for SCS 

In preparing and managing site data, design data, and work orders for site controller 
software (SCS), you do not need to use the Device pane to synchronize with the data 
synchronization area. The synchronization happens automatically when you resolve 
conflicts and finish SCS commands. 

Command Pane 
The Command pane gives you access to the All Commands list, a comprehensive list from 
which you can execute most commands. The Command pane also provides a place for 
you to work through many commands. 

To display the Command pane: 

 Select View > Command Pane.  

 Press [F12]. 

The Command pane displays docked on the right side of the application window, or 
where you positioned it last. 

To run a command from the Command pane: 

Do one of the following: 

 Enter a command in the Command box (command line).  

 Double-click a command in the Recent Commands list. 

 Click a command in the All Commands list. 

When a command is active in the Command pane, these options are available on the 
pane's toolbar. 

Options 

 Click this to display a list of the commands that are currently on the stack. 

 
In the default command pane, click this to display the last/current command on 
the stack. 

In any other command pane, click this to display the default command pane. 

Related Topics 

 Pane and Data View Positioning (on page 31) 
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Properties Pane 
The Properties pane shows properties for selected objects, enabling you to edit certain 
values. If you select a single object, the properties for that object are displayed. If you 
select multiple objects, the properties common to all of them are displayed. You can 
edit the common properties, or select a subset of the selected objects using the 
drop-down list near the top of the pane. 

To view the properties of another object in the Properties pane, click the object within 
any data view or pane. If the Properties pane is displayed, selecting any object will 
show its properties. 

Note: The toolbar icons and context menu items available in the Properties pane 
depend on the types of objects you have selected. The Properties pane also enables you 
to use COGO controls and snap commands within certain property boxes. 
Note: An icon for the type of object you have selected appears at the top of the 
Properties pane. If a flag icon appears instead of the object icon, there are import or 
computation errors associated with one or more of the selected objects. Open the Flags 
Pane (on page 14) for details. 

To display the Properties pane: 

 Click the  icon on the toolbar. 

 Select Edit > Properties. 

 Double-click an object in the Project Explorer. 

 Right-click an object in a view, spreadsheet, or the Project Explorer and select 
Properties. 

 Press [F11]. 

The Properties pane displays, docked on the right side of the application window, 
or where you positioned it last.  

Related Topics 

 View and Edit an Object's Properties (on page 64) 
 Pane and Data View Positioning (on page 31) 

 

Flags Pane 
The Flags pane shows import or computation errors. You can select individual or 
multiple objects from the Flags pane if the objects have been flagged with errors. If 
there are no objects in the Flags pane, no objects have been identified as having errors. 
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To display the Flags pane: 

 Click the  icon on the toolbar or the status bar if flags are present. 

 Select View > Flags Pane. 

The Flags pane displays at the bottom of the application window, or where you 
positioned it last.  

To highlight points using the Flags pane: 

 In the Flags pane, select a point to view. The selected point(s) highlight in any 
graphic views and spreadsheets you have open. 

Tip: [Ctrl] + click to select multiple objects, or [Shift] + click to select a range in 
the Flags pane. 

Related Topics 

 Compute Project Command 
 Pane and Data View Positioning (on page 31) 
 Select from the Flags Pane (on page 48) 
 Status Bar (on page 10) 

 

Coordinates Scroll 
The Coordinates scroll displays values, such as northing, easting, latitude, longitude, 
elevation, and offset, based on the position of the cursor in a graphic view. The values 
shown depend on what type of view the cursor is in. 

To display the Coordinates scroll :  

 Click the checkbox at the right end of the status bar. 

 Select View > Coordinates Scroll. 

The Coordinates scroll displays.  

To use the Coordinates scroll :  

1. Display the scroll and right-click in it for options. 

2. Select any type of value to show or hide when using the scroll. 

Note: Although all of the possible values can be selected in the context menu, only 
certain values will display for each type of graphic view. For example, elevation 
and offset values will display in profile and cross-section views, but not in the plan 
view. The coordinates scroll cannot be used in the 3D view. 

3. Move the cursor into a 2D view. The values at the cursor's position are displayed in 
the scroll. 
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Related Topics 

 Coordinate System Manager (on page 173) 
 Change the Coordinate System (on page 149) 
 Define a New Coordinate System (on page 149) 
 Restore the Original Coordinate System File (on page 150) 
 Pane and Data View Positioning (on page 31) 

 

Data Views 
You can view your project data in a variety of graphical, tabular, and chronological 
formats, such as: 

 Plan view (on page 25) 

 Profile view (on page 26) 

 3D view (on page 28) 

 Points spreadsheet (on page 29) 
 

Customize the Menu 
You can customize the menus by: 

 Rearranging menu commands 

 Adding a command to a menu 

 Deleting a command from a menu 

 Saving a layout 

Adding external tools to the Tools  menu To rearrange menu 
commands: 

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Commands tab. 

3. Click Rearrange Commands. 

4. In the Rearrange Commands dialog, select Menu Bar option and then select a menu 
from the drop-down list. 

5. In the Commands area, highlight the menu command that you want to move. 

6. To move the menu item, do one of the following: 

 Click Move Up to move the item up the menu list. 

 Click Move Down to move the item down the menu list. 

 Click Close to exit, or click Reset to return to the default setting. 
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To add a command to a menu: 

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Commands tab. 

3. Click Rearrange Commands. 

4. In the Rearrange Commands dialog, select Menu Bar and then select a menu from 
the drop-down list. 

5. Click Add. 

6. In the Add Command dialog, select a category and then the command that you want 
to add to the menu selected in the Rearrange Commands dialog. 

7. Click OK.   

8. Do one of the following: 

 Click Close to exit. 

 Click Move Up or Move Down to move the command if you want it in a 
different position. 

 Click Reset to remove the added command and return to the default setting. 

To delete a command from a menu: 

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Commands tab. 

3. Click Rearrange Commands. 

4. In the Rearrange Commands dialog, select Menu Bar and then select a menu from 
the drop-down list. 

5. In the Commands area, highlight the menu command that you want to delete. 

6. Click Delete. 

7. Click Close to exit, or click Reset to return to the default setting. 

To save a custom layout:  

After customizing a menu using one of the procedures above, save it so that the new 
layout appears each time you open the software. 

1. Click the Save/Load tab. 

2. Click New and give your layout a name and click OK. Your layout now appears in 
the Saved Layouts window. 

To add a new tool to the menu: 

1. Select Tools > External Tools Manager. The External Tools Manager displays. 
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2. Click Add. [New Tool] appears in the Menu Contents list. 

3. Type a name for the tool in the Title box. 

4. Next to the Command box, click the [browse] icon to browse for a tool file. For 
example, if you want to add the executable for the calculator, browse to 
C:\WINDOWS\system32\calc.exe. 

5. If needed, click Move Up or Move Down to change the position of the new item in 
the menu. 

6. Click OK. The tool appears in the tools menu. 

To delete a tool from the menu: 

1. In the External Tools dialog, highlight the tool to delete. 

2. Click Delete. 

3. Click OK. 

Related topics 

 Customize the Toolbar (on page 18) 
 Customize the Keyboard (on page 20) 
 External Tools Manager (on page 464) 

 

Customize the Toolbar 
You can customize the toolbars by: 

 Selecting toolbars to display 

 Creating a new toolbar 

 Adding a command to a toolbar 

 Rearranging toolbar commands 

 Deleting a command from a toolbar 

Note: Click Reset to return to the default setting. 

To select toolbars to display:  

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Toolbars tab. 

3. In the Toolbars list, select or clear the required toolbar(s). 

4. Click Close. 
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To create a new toolbar:  

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Toolbars tab. 

3. Click New. 

4. Assign a name to the toolbar, for example Tools. 

5. Select a location from the drop-down list. 

6. Click OK. The toolbar appears in the project toolbar. 

To add a command to a toolbar:  

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Commands tab. 

3. Click Rearrange Commands. 

4. In the Rearrange Commands dialog, select the Toolbar option, then select a toolbar 
from the drop-down list. 

5. Click Add. 

6. In the Add Command dialog, select a category then the command that you want to 
add to the toolbar selected in the Rearrange Commands dialog. 

7. Click OK.   

8. Do one of the following: 

 Click Close to exit. 

 Click Move Up or Move Down to move the command if you want it in a 
different position. 

To rearrange toolbar commands: 

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Commands tab. 

3. Click Rearrange Commands. 

4. In the Rearrange Commands dialog, select the Toolbar option, then select a toolbar 
from the drop-down list. 

5. In the Commands area, highlight the toolbar command that you want to move. 

6. To move the toolbar item, do one of the following: 

 Click Move Up to move the item up the toolbar list. 

 Click Move Down to move the item down the toolbar list. 

 Drag and drop items. 
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7. Click Close to exit. 

To delete a command from a toolbar:  

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Commands tab. 

3. Click Rearrange Commands. 

4. In the Rearrange Commands dialog, select the Toolbar option, then select a toolbar 
from the drop-down list. 

5. In the Commands area, highlight the toolbar command that you want to delete. 

6. Click Delete. 

7. Click Close to exit. 

Related topics 

 Customize the Menu (on page 16) 
 Customize the Keyboard (on page 20) 

 

Customize the Keyboard 

To customize the keyboard: 

1. Select Tools > Customize. The Customize dialog displays. 

2. Click Keyboard. 

3. In the Customize Keyboard dialog: 

 To specify a command, select a category and a command. 

 To specify a shortcut, select a shortcut from the drop- down list. 

 To assign the shortcut to the command, click Assign. 

 To remove the shortcut from the command, click Remove. 

 To reset all shortcuts, click Reset All. 

4. Click Close. 

Related topics 

 Customize the Toolbar (on page 18) 
 Customize the Menu (on page 16) 
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Customization Options and Tools 
Customization allows you to configure and save a specific layout for your menus, 
toolbars, display settings and keyboard shortcuts. When more than one person uses the 
same computer, each user can create their own layout. 

Note: In the Options dialog, if you set the Window display mode to Multiple window views, 
the last position of your windows is restored when you reopen a project. The 
restoration of window positions is not affected by customization. See Pane and Data 
View Positioning (on page 31). 

To customize tools:  

1. Select Tools > Customize. The Customize dialog displays. 

2. Click the Options tab. In this tab you can: 

 Personalize menus and toolbars 

 Select display options 

3. Click the Custom Tools tab. In this tab, you can: 

 Create a new custom command and add its icon to a toolbar 

 Delete a custom command 

 Customize the keyboard 

Tip: If you customize, save it so that it is available the next time you use the office 
software. 

4. Click the Save/Load tab. In this tab, you can: 

 Save a new layout or load a different custom layout 

 Customize the keyboard 

5.  When you have made the desired changes, click Close. 

Related topics 

 Customize the Toolbar (on page 18) 
 Customize the Menu (on page 16) 
 Customize the Keyboard (on page 20)  

 

Troubleshoot a Toolbar or Menu Problem 
Before calling Support, use any applicable solutions to known issues below. 
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Symptom Possible Cause Solution 

Toolbars are not in 
the same language as 
the installation. 

The program was run in one 
language, and then reinstalled 
in a different language. 

Reset the toolbars to the reinstalled 
language by loading the default 
layout. 

Select Tools > Customize. In the 
Customize dialog, click Save/Load. 
In Default Layout, select Default 
Layout and click Load. Click OK in 
the New layout dialog. 

Some text in the 
user interface (the 
units on the Status 
bar for instance) is 
in a different 
language. 

This only occurs 
when opening 
project files that 
were created in a 
different language. 

The user interface text is 
being stored in the project 
file. 

There is no solution at this time. 
Newly created projects will not have 
the problem, but it will remain in 
the original project file. 

 
 

Find Help Topics 
Use this help system to find the information you need on the concepts, procedures, and 
options used in the software. 
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To display the help system: 

 Select Help > Search to find topics by entering a keyword. 

 Select Help > Contents to browse through topics and glossary items in a table of 
contents. 

 Select Help > Index to find topics and glossary items alphabetically. 

 Press [F1]. 

To display context-sensitive help on a specif ic command: 

 Press [F1] while in the specific command or dialog. 

 Right-click on a command in the Command pane's All Commands list, and select 
Help from the context menu. 

To print a help topic:  

 Click the  icon. 

 Right-click on a topic in the Help window, and select Print from the context menu. 
Then select Print > Print the selected topic from the context menu. 

 To print a topic and all of its associated subtopics, select the topic, and select Print 
from the context menu. Then select Print > Print the selected heading and all 
subtopics from the context menu. 

Related topics 

 Help Options (on page 23) 
 

Help Options 
Use these options to find information and answers on the concepts, procedures, and 
options covered in the help system. They are available in the help dialog. 



Trimble® Business Center 
Heavy Construction Edition User Guide 24 

 Get Started

Tabs 

Contents Click this tab to show all of the help topics in a tree structure. 
Click a chapter or topic to view it. 

Search Type a keyword in the search box. Then, click List Topics to 
search for any occurrence of the word in the help topics. Select 
a topic in the search results, and click Display to open it. The 
word you search on is highlighted in each help topic. See the 
Search highlight on/off option below. 

1. The Find Setup wizard may appear. If it does, select the 
Minimize database size option and click Next. Then click 
Finish. 

2. In the Type the word(s) you wish to find box, enter the 
word or phrase that you want to find. 

3. If necessary, in the Select matching word(s) to narrow the 
search box, enter a word to narrow the search. 

In the Choose topic to display box, select a topic. It will be 
displayed in the right side of the Help window. 

Menu options 

Hide/show tabs Click this to hide the Contents and Search tabs. 

Back Click this to view the previous topic. 

Print Click this to display the Print Topics dialog. Select an option to 
either print just the selected topic, or the heading and all 
subtopics. 

Stop Click this to end a search function. 

Refresh Click this to reset the display of the current page. 

Internet options Click this to display the Internet Options dialog, where you 
can set security, privacy, content, connections, programs, and 
other settings for the Internet. 

Search highlight on/off Click this to enable/disable the highlighting of each instance 
of the keyword in searched topics. 

Related topics 

 Find Help Topics (on page 22) 
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C H A P T E R  3  

View, Navigate, and Select 

Graphic Views 

Plan View 

The plan view is the default view for your project data. It displays a graphical view 
from above, as in a map display. Multiple plan views can be opened at the same time. 
The data that is visible in graphics views is controlled by the view filter (see "Filter a 
View" on page 76). 

 
Within the plan view you can: 
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 Pan and zoom to explore the data. 

 Select objects to view their properties or start a command.  

Related topics 

 2D View Navigation (on page 35) 
 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Tabbed View Arrangement (on page 34) 

 

Profile View 

Use the profile view to check the geometry of a vertical alignment. The profile view 
displays a vertical, graphic view of a single, specific alignment. When the alignment 
that the view is based on is modified or deleted, the view updates accordingly. 

 
The bold vertical line at 120 denotes a station equation. 

Related topics 

 2D View Navigation (on page 35) 
 Create an Alignment (see "Understanding Alignments" on page 286) 
 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Tabbed View Arrangement (on page 34) 

 

Cross-Section View 

Use the cross-section view to check surface cross-section geometry along a single, 
specific alignment anywhere it coincides with a single, specific surface. The 
cross-section view is a vertical, graphic view that changes depending on where you are 
along the alignment. When the alignment or surface that the view is based on is 
modified or deleted, the view updates accordingly. Multiple cross-section views can be 
open concurrently. 
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Red tic marks denote where the cross-section crosses points or breaklines. Bold vertical 
lines (not shown) denote station equations. At some view magnifications, the slope 
value is shown for each segment of the cross-section. 

Related topics 

 Create and View a Cross-Section (see "Create and View a Surface Cross-Section" on 
page 326) 

 2D View Navigation (on page 35) 
 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Tabbed View Arrangement (on page 34) 

 

Surface Slicer View 

Use the surface slicer view to check any surface by slicing vertically through it to 
create a 'quick profile'.  Multiple surface slicer views can be open at a time, and you can 
view multiple surfaces in the view concurrently. 

 
Red tic marks denote where the surface slice crosses points or breaklines. At some view 
magnifications, the slope value is shown for each segment of the profile. 

Related topics 

 View a Slice of a Surface (on page 327) 
 Create and View a Cross-Section (see "Create and View a Surface Cross-Section" on 

page 326) 
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 2D View Navigation (on page 35) 
 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Tabbed View Arrangement (on page 34) 

 

3D View 

Use the 3D view to visualize your project data from pre-defined viewpoints, or by 
rotating the view. You can set a point around which the view rotates, and exaggerate 
the vertical scale to see changes in topography more easily using the 3D View Settings 
(on page 38). You can also select objects in the 3D view using the standard graphic 
selection methods (on page 43). 

 
The 3D view includes a compass triad with north, east, and Z axes to help you stay 
oriented in the view. 

The performance of the 3D view may vary based on your system settings. If you have 
trouble, try these fixes: 

1. Right-click on your desktop and select Properties from the context menu. The 
Display Properties dialog displays. Click the Settings tab. Select a different/higher 
setting in the Color quality list. Click OK. 

2. Right-click on your desktop and select Properties from the context menu. The 
Display Properties dialog displays. Click the Settings tab. Click Advanced. The Plug 
and Play dialog displays. Click the Troubleshoot tab, and move the Hardware 
Acceleration slider to/near Full. Click OK, and OK again. 

Tip: To reduce clutter in the 3D view, you can hide 2D objects or objects with a zero 
elevation. This can be set in Project Settings by selecting Project > Project Settings. 
Then click View and 3D View in the left pane to access the settings. 
Note: Microsoft® DirectX® does not work over Microsoft® NetMeeting®. The 3D view 
uses DirectX® and will show a blank view when attempting to use it across either 
communication tool. 
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Related topics 

 3D View Navigation (on page 37) 
 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from the 3D View (on page 45) 
 Tabbed View Arrangement (on page 34) 

 

Spreadsheets and Other Views 

Points Spreadsheet 

The points spreadsheet view lists the survey points in the current project, enabling you 
to easily edit the data. The plan view and the Properties pane reflect all changes made to 
data in the point spreadsheet view. 

Using the spreadsheet 

 To select a point, click in the left column for that row. 

 
 To display more detail on a point in the Properties pane, select the point and press 

[F11], or right-click and select Properties. 

 To edit a point's ID, coordinate, elevation, or feature code, select it by clicking on 
the cell. You can also tab from cell to cell and simply type over the value in the cell. 

 To sort points based on a criteria, click on a column heading. Up  or down   
icons appear on the selected column heading, indicating the current sort order 
(ascending or descending). 

 To filter the point data, click on the  icon at the top of the column and select an 
option from the drop-down menu.  

Note: If the filter for a column is active, the icon  appears blue. 
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 To copy data to a text editor, such as Microsoft® Notepad, select data, and copy and 
paste by using the right-click menu or by pressing [Ctrl] + C to copy and [Ctrl] + V 
to paste. You can select all data by pressing [Ctrl] + A. 

 To change the order of columns across the spreadsheet, click and drag the column 
heading to a new location. 

Related topics 

 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from Spreadsheet Views (on page 46) 
 Tabbed View Arrangement (on page 34) 
 Create a Point (on page 270) 

 

Alignment Editor 

The Alignment Editor enables you to edit the horizontal, vertical, and stationing values 
of existing alignments. The graphic views reflect all changes made to alignments in the 
editor. 

 

Related topics 

 Edit an Alignment (on page 290) 
 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Tabbed View Arrangement (on page 34) 
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Report View 

The Report View displays when you run certain reports. Along with the content of the 
report, the view includes a toolbar located along the top of the tab that allows you to: 

 Navigate to a specific page in the report 

 View and change the print setup information 

 View the print layout and print the report 

 Export the report to a spreadsheet or PDF document 

 Select a magnification to view the report 

 Search for text in the report 

Related topics 

 Tabbed View Arrangement (on page 34) 
 

Pane and Data View Positioning 
Control when and where panes and views display by pinning, floating, and docking 
them. Unpin panes to allow them to slide out of view when they are not being used. 
Pin panes to keep them open. Float views to move them around the screen for the best 
arrangement. Dock views to attach them to an edge of the application window. 

To pin and unpin (AutoHide) panes:  

 To pin an open pane, click the  icon at the top of the pane. 

 To unpin a pane, click on the  icon. If the pane is unpinned, the pane can "slide" 
to the side and out of view. To display the pane again, hover the cursor over the 
vertical tab.  

To f loat and dock panes and views: 

By default, most panes display docked, that is, locked to one side of the application 
window. 

 To float a docked pane, right-click on its titlebar and select Floating from the 
context menu. You can also click on the titlebar and drag the pane to float it. 

 To float a spreadsheet, editor, or other view, right-click beneath the titlebar and 
select Float View. The floated view can even be dragged to an adjacent monitor if 
you are running dual monitors. 

Note: Graphic views, such as the plan, 3D, and profile view, cannot be floated. 
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 To dock a floating pane, right-click on its titlebar and deselect Floating. You can 
also click on its title bar and drag it to a docked position along any edge of the 
application window. 

Note: The docking location is determined by the position of the cursor when it 
intersects the edge of the application window. 

 To dock a floating spreadsheet, editor, or view, right-click on the body of the view 
(not on its titlebar) and select Unfloat View. 

Related topics 

 Data View Display Formats (on page 32) 
 

Data View Display Formats 
You can control how data views are displayed, by arranging them as one or two groups 
of tabbed views, or as one or more tiled or cascaded views. Using multiple views let you 
easily view different parts of your project concurrently, and from different 
perspectives 

To change the data view format:  

1. Select Tools > Options. The Options dialog displays. 

2. Select a display format in the Display with box.  

Note: There are Window menu options for more tabbed view options. 
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Data display options 

Tabbed views (SDI) Displays one view in the view area at a time, with tabs 
at the top to access additional views. 

To change views, click a tab. 
Multiple views (MDI) Displays one or more views at a time 

 To change views, click on the title bar of the view 
you want; the active title label is dark blue. 

 To tile or cascade the views, select Window > 
(option). 

This image displays the multiple data views displayed in a tabbed format. 
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This image displays the multiple data views in an MDI format.  

 

Related topics 

 Pane and Data View Positioning (on page 31) 
 Startup and Display Options (on page 139) 
 Tabbed View Arrangement (on page 34) 

 

Tabbed View Arrangement 
When you are working with tabbed views, you can display the views in two or more 
groups (windows), arranged either horizontally or vertically. The command is active 
under these conditions: 
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 Data view display is set to tabbed view (SDI) format in Options. 

 At least 2 views (tabs) are present. 

To display tabbed views in multiple groups: 

 Select Window > New Horizontal Tab Group. 

 Select Window > New Vertical Tab Group. 

 Click the  icon on the toolbar. 

 Click the  icon on the toolbar. 

 The tabbed views are divided and arranged accordingly. 

You can also move tabs from one group to the other group of tabs. It is only active in 
data view under these conditions: 

 Data view display is set to tabbed view (SDI) format in Options. 

 At least 3 views (tabs) are present (for example, 2 plan views and a point 
spreadsheet view). 

 The 3 views are separated into 2 groups. 

To move a tabbed view to the next or previous group: 

 Click the tab to move, and then select Window > Move to Next Tab Group. The 
tabbed view moves to the next group of tabbed views. 

 Click the tab to move, and then select Window > Move to Previous Tab Group. 
The tabbed view moves to the next group of tabbed views. 

Related topics 

 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Startup and Display Options (on page 139) 

 

2D View Navigation 
Use these options and keyboard combinations to change what is displayed in the plan 
and alignment profile views. 

To pan the view: 

Use this to shift a different area of the screen to the center of the view. 
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 Click and drag the mouse wheel (or middle mouse button). 

 Click the  icon on the toolbar, or select View > Pan. Click and drag from one 
point to another point in the plan view. 

Tip: When using a laptop without a mouse, click the  (left mouse pan) on the 
toolbar. You can also press and hold both the left-click and right-click buttons while 
moving the cursor. 

To zoom in:  

Use this to display a smaller area of the plan view, in more detail. 

 Click the  icon on the toolbar. 

 Click in a view, and roll the mouse wheel forward. 

 Select View > Zoom > Zoom In. 

To zoom out:  

Use this to display a larger area of the plan view, in less detail. 

 Click the  icon on the toolbar. 

 Click in a view, and roll the mouse wheel backwards. 

 Select View > Zoom > Zoom Out. 

To zoom into a certain area: 

Use this to display the data within a box you draw in the view. 

 Press [Ctrl] + [Alt], and click and drag around an area. 

 Click the  icon on the toolbar, or select View > Zoom > Zoom. Click and drag 
around the area you want to display in the view. 

To zoom to the extents of your data: 

Use this to zoom to the limits of your visible data. 
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 Click the  icon on the toolbar. 

 Double-click the mouse wheel (or middle mouse button). 

 Select View > Zoom > Zoom Extents. 

To center a selected point in the plan view: 

 Select one or more points in the Project Explorer or the plan view. Right-click, and 
select Center from the context menu. 

 Select one or more points in the Project Explorer or the plan view, and select View > 
Center. 

 Select View > Center. The Center command pane displays. Pick a point in the plan 
view, or type a point ID in the Point box. 

Related topics 

 3D View Navigation (on page 37) 
 Plan View (on page 25) 
 Mouse Modes (on page 42) 

 

3D View Navigation 
Use these keyboard and mouse combinations to change your viewpoint in the 3D view. 
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3D view 

Pan Click the mouse wheel (or middle mouse button) and drag. 

Zoom in/out  Roll the mouse wheel. 

Zoom extents Double-click the mouse wheel (or middle mouse button). 

Note: Zooming extents restores the vertical exaggeration back to 
its original value. 

Vertical scale Press [Ctrl] + [Shift], and roll the mouse wheel to exaggerate 
differences between elevations used in a surface.  

The exaggeration value displays in the Scale box of the 3D View 
Settings command pane. To restore the original vertical 
exaggeration, type 1 in the box. 

Rotate horizontal Press [Ctrl], and roll the mouse wheel to turn the view around 
the X axis.  

The value displays in the Elevation box of the 3D View Settings 
command pane. 

Rotate vertical Press [Shift], and roll the mouse wheel to turn the view around 
the Z axis. 

The value displays in the Azimuth box of the 3D View Settings 
command pane. 

Free rotation Press [Ctrl], and click and drag the mouse wheel to rotate the 
view freely in any direction. 

Related topics 

 2D View Navigation (on page 35) 
 3D View (on page 28) 
 3D View Settings (on page 38) 
 Mouse Modes (on page 42) 

 

3D View Settings 
Use these settings to change your viewpoint, and the vertical scale in the 3D view. The 
compass triad in the bottom, left corner of the view shows the current orientation. By 
default, the 3D view rotates around the center of the view, which is usually the center 
of the bounding volume of the data in your project. 

Tip: To reduce clutter in the 3D view, you can hide 2D objects or objects with a zero 
elevation. This can be changed in Project Settings by selecting Project > Project 
Settings. Then click View and 3D View in the left pane to access the settings.  
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To access pre-defined 3D views and settings: 

 Select View > 3D View Settings. The 3D View Settings command pane displays. 

Options 

Preset views Click an arrow icon to switch to one of nine predefined, 
orthographic or isometric views.  

The view names refer to the direction the view is facing. 
Rotation Use these values to rotate the viewpoint. Entering zero in both 

boxes makes the view equivalent to the plan view. 
Elevation Drag the vertical slider, or type a value in the box, to rotate the 

view on the X axis. 
Azimuth Drag the horizontal slider, or type a value in the box, to rotate the 

view on the Z axis. 
Vertical scale 

Scale Drag the horizontal slider, or type a value in the box, to increase 
the difference between elevations. The scale is the factor by 
which all elevations in the project are multiplied. 

Min 

Max 

Set the minimum and maximum exaggeration values in the boxes 
at either end of the slider. 

To change the point around which the view rotates: 

1. Select View > 3D View Settings. The 3D View Settings command pane displays. 

2. Click Top in the Preset Views group. 

3. Pan the point around which you want to rotate into the center of the view. 

4. Press [Ctrl] and roll the mouse wheel until the view is perpendicular to the plan 
view. 

Tip: You can watch the compass triad to determine when the view is perpendicular. 

5. Pan the point around which you want to rotate into the center of the view again. 

6. Check the new rotation point by pressing [Ctrl], and clicking and dragging the 
mouse wheel to rotate the view. 

Related topics 

 2D View Navigation (on page 35) 
 3D View (on page 28) 
 3D View Navigation (on page 37) 
 Mouse Modes (on page 42) 
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Keyboard Navigation 
Use the keyboard to navigate the application and perform tasks if it is easier for you 
than using a mouse. 

Shortcut keys 

[F1] Displays the Help window. 

[F2] Toggles grid cells in spreadsheets and dialogs between editable and uneditable. 

When a cell is editable, the arrow keys move the insertion point within the 
cell. When a cell is uneditable, the arrow keys move the focus from cell to cell. 

[F4] Computes the current project. 

[F5] Switches the left mouse button to select mode. 

[F6] Switches the left mouse button to rotate mode. 

Note: This mode only works in 3D views. If you select this mode in 3D view, it 
reverts to the Select mode when in plan view. 

[F7] Switches the left mouse button to pan mode. 

[F8] Switches the left mouse button to zoom mode. 

 
[F9] 

Displays or hides the Project Explorer. 
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[F10] Displays or hides the Device pane. 

[F11] Displays the Properties pane. 

[F12] Displays or the Command pane. 

Note: [F11] and [F12] toggle between the Command and Properties panes. 

 

Other keys 

[Enter] For commands with an OK button, this initiates the 
command. 

[Esc] When the command pane has focus, this clears the most 
recent command from the stack. 

In the Properties pane, this cancels an edit, reverting the 
property to its original value. 

[Tab] Accepts the current value, and advances to the next 
control or button. 

[Shift] + [Tab] Accepts the current value, and moves to the previous 
control or button. 

[Space] Accepts the highlighted button.  
Opens advanced dialogs when you have tabbed into 
certain controls: 

 Color list - Opens the Color dialog. 

 Layer list - Opens the New Layer dialog. 

 Line Style list - Opens the Line Style Manager. 

 Select box - Opens the Advanced Select command 
pane. 

[Ctrl] + [Tab] Lets you select any of the active views, panes, or 
commands. 

[Ctrl] + [Shift] + [Tab] Lets you select any of the active views, panes, or 
commands. 

[Ctrl] + [ ] or [ ] Navigates within groups. 

Press [Ctrl] + [ ] to move up to the previous folder in 
Project Settings (and similar lists). 

[Ctrl] +[] or [ ] Expands or contracts groups in the Project Explorer and 
the Properties pane.  

[Shift] + [F10] 

 

Displays the context menu when you are in a control 
(box). 

[Ctrl] + [D] Deletes selected objects from a project. 

Related topics 

 2D View Navigation (on page 35) 
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 3D View Navigation (on page 37) 
 Mouse Modes (on page 42) 

 

Mouse Modes 
Activate different modes to control what the left-mouse button does in graphic views. 
These modes are essential when you are using a laptop, or a mouse with no 
wheel/center button. They are available on the mouse toolbar. 

Options 

 
Click this to pick objects when you click or click and drag the left mouse button. 
You can also press [F5] to switch to the select mouse mode. 

 
Click this to rotate the view when you click and drag the left mouse button. You 
can also press [F6] to switch to the rotate mouse mode. 

Note: This mode only works in 3D views. If you select this mode in 3D view, it 
reverts to the select mode when in plan view 

 
Click this to move the view in a planar way when you click and drag the left 
mouse button. You can also press [F7] to switch to the pan mouse mode. 

 
Click this to zoom in or out when you click and drag the left mouse button. You 
can also press [F8] to switch to the zoom mouse mode. 

Related topics 

 2D View Navigation (on page 35) 
 3D View Navigation (on page 37) 
 Graphic Selection Methods (on page 43) 

 

Data Selection 
Select objects by picking them in graphic views or spreadsheets, selecting menu 
options, or using keyboard combinations. Objects that you select highlight in graphic 
views, spreadsheets, and the Project Explorer, depending on which you have open. The 
number of objects selected appears on the status bar at the bottom of the application 
window. 

Note: To set the visibility and selectability of objects, create a new view filter in the 
View Filter Manager (see "Filter a View" on page 76). 

Related topics 

 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Select from the 3D View (on page 45) 
 Select from Spreadsheet Views (on page 46) 
 Select from the Project Explorer (on page 48) 
 Selection Methods and Options (on page 43) 
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Selection Methods and Options 

Use these options to choose a selection method. They are available in the Select menu 
and through the Options button, which is available in various commands. Objects set to 
visible and selectable in the current view filter can be selected. 

Note: The number of objects currently selected displays on the status bar at the bottom 
of the window. 

Options 

Select All Use this to select all of the visible and selectable objects 
(as set in the current view filter) in the views and 
spreadsheets. 

You can also press [Ctrl] + [A] to select all objects. 

Invert Selection Use this to deselect the currently selected objects, and 
select the currently unselected objects visible in the 
view.   

Select Points Use this to select points with specific properties. 

Select Duplicate Point 
Identifiers 

Use this to select points with the same point IDs, often 
prior to merging duplicate points. 

Select Observations Use this to select survey observations with specific 
properties. 

Select Unprocessed Sessions Use this to select all sessions for which baselines have 
not been processed. 

Select by Elevation Range (on 
page 52) 

Use this to select data within, or outside of, a specific 
elevation range. 

Select by Layer (on page 53) Use this to select data by its layer. 

Advanced Select (see "Select 
Using Advanced Criteria" on 
page 53) 

Use this to select data from the entire data set using a 
custom set of criteria. 

Related topics 

 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Select from the 3D View (on page 45) 
 Select from Spreadsheet Views (on page 46) 
 Select from the Project Explorer (on page 48) 
 View Filter Manager Command 

 

Graphic Selection Methods 

Select objects by clicking and dragging in graphic views in these ways: 
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Options  

Windowing Click and drag a box from left to right. All of the objects entirely 
within the box are selected. 

Crossing Click and drag a box from right to left. All of the objects within the 
box and crossed by the box are selected. 

In graphic views, there are also two context menu options that you can access by 
right-clicking when you have data selected. 

Options  

Previous selection Select this to clear the current selection and reselect select the objects 
last selected. 

Clear selection Select this to deselect all objects. 

The appearance of the cursor will change in graphic views, depending on the control 
you are using. When you are using a COGO control, the name of the control will also 
appear on the status bar. The status line's tooltip lists ways in which you can use the 
control. 

Cursor types 

     

Pick any point. 

  

Pick any point or applicable object (arc, line, segment, point). 

  

Pick any applicable object. 

 

No anchor point has been defined. 

 

  

The pick function is unavailable, or the object you are trying to 
pick is invalid. Often, you can click a blank space in the Project 
Explorer to refresh the pick cursor for the graphic views. 

Related topics 

 Select from the 2D Views (see "Select from 2D Views" on page 44) 
 Select from the 3D View (on page 45) 
 Selection Methods and Options (on page 43) 

 

Select from 2D Views 

Select objects in the plan and profile views using these standard methods, or graphic 
selection methods. 
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To select al l  objects:  

 Select Select > Select All. 

 Press [Ctrl] + [A]. 

To select individual objects:  

 Move the cursor over an object in the view and click. If there is more than one 
object within the pick aperture, a list of objects from which you can select appears. 
Select the object you need. 

 Click the name of the object in the Project Explorer. 

To select a group of points or observations: 

 [Ctrl] + click - to add an object to the selection set 

 [Shift] + [Ctrl] + click - to remove an object from the selection set 

 Click and drag (from left to right) - to select objects within the window. 

 Click and drag (from right to left) - to select all objects within or crossed by the 
window. 

To undo a selection: 

 Right-click and select Clear Selection from the context menu - the last object 
selected with be removed from the selection.   

 Click any blank space in a graphic view. This deselects everything. 

To clear the selection: 

 Right-click the selected point or group of points and select Clear Selection. 

 Click in an empty area of a graphic view. 

Related topics 

 2D View Navigation (on page 35) 
 Graphic Selection Methods (on page 43) 
 Filter a View (on page 76) 

 

Select from the 3D View 

Select objects in 3D views using these standard methods, or graphic selection methods. 
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To select al l  objects:  

 Select Select > Select All. 

 Press [Ctrl] + [A]. 

To select individual objects:  

 Move the cursor over an object in the view and click. If there is more than one 
object within the pick aperture, a list of objects from which you can select appears. 
Select the object you need in the list. 

 Click the name of the object in the Project Explorer. 

To select a group of points or observations: 

 [Ctrl] + click - to add an object to the selection set. 

 Click and drag (from left to right) - to select objects within the window. 

 Click and drag (from right to left) - to select all objects within or crossed by the 
window. 

 [Shift] + [Ctrl] + click - to remove an object from the selection set. 

To undo a selection: 

 Right-click and select Clear Selection from the context menu. The last object 
selected is removed from the selection set. 

 Click any blank space in a graphic view. 

To clear a selection: 

 Right-click the selected point or group of points and select Clear Selection. 

 Click in an empty area of a graphic view. 

Related topics 

 3D View (on page 28) 
 3D View Navigation (on page 37) 
 3D View Settings (on page 38) 
 Graphic Selection Methods (on page 43) 

 

Select from Spreadsheet Views 

To select individual or multiple points or vectors in a spreadsheet (see "Points 
Spreadsheet" on page 29) view, use the mouse. Selected objects also highlight in 
graphic views, and the Project Explorer. The number of selected points or vectors 
appears on the status bar at the bottom of the application window. Edits in a 
spreadsheet cell are reflected in the Properties Pane after you exit from the cell. 
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To select a single point or vector:  

 Click the gray box on the left of the row: 

 

Note: When you edit northing, easting, and elevation values in a point spreadsheet 
view, the quality of the point is upgraded to Control. 

To select multiple points or vectors:  

 To select a series of rows, click the first row in the series, press [Shift], and click the 
last row in the series.  All rows in-between are selected. 

 To select multiple, separate rows, press [Ctrl] + click on each individual row to add 
to the selection. 

 To select all rows, right-click anywhere in the spreadsheet and select Select All 
from the context menu. 

Note: To edit the feature code for multiple points, use the Properties pane.  

To undo a selection: 

 Click any cell. 

 Right-click and select Undo Selection from the context menu - the last object 
selected with be removed from the selection set.   

To delete a selected row: 

 Right-click the selected row and select Delete from the context menu. 

Related topics 

 Point Spreadsheet (see "Points Spreadsheet" on page 29) 
 Select Observations 
 Select Points (on page 49) 
 Select Unprocessed Sessions 
 Vector Spreadsheet 
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Select from the Flags Pane 

Select one or more objects from the Flags pane if the objects have been flagged with 
import or computation errors. If there are no objects in the Flags pane, no objects have 
been identified as having errors. 

Tip: The number of objects selected appears on the status bar at the bottom of the 
application window. 

To display the Flags pane: 

 Select View > Flags Pane. 

 Click the  icon (appears in the toolbar and on the status bar) 

Note: Press [F11] or click the  icon to display the Properties pane. Within the 
properties dialog, you can edit the errors. Click on a data object in the Flags pane to 
display its properties. 

To select f lagged objects:  

 To select an individual object, click on the left edge of the row. 

 To select multiple objects, do one of the following: 

 Click the first row of the series, hold [Shift], and click the ending row of the 
series. 

 Hold [Ctrl] and click individual rows to add these rows to the selection. 

The selected points now appear highlighted in the plan view.  

Related topics 

 Compute Project Command 
 Flags Pane (on page 14) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Select from the Project Explorer 

The Project Explorer displays your project data organized in a tree structure. The 
number of objects selected appears on the status bar at the bottom of the application 
window. 

To select objects:  

 To select an individual object, click on the object. 

 To select multiple objects, do one of the following: 

 Click the first object, hold [Shift], and click the ending object of the series. 
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 Hold [Ctrl] and click individual objects to add these objects to the selection. 

The selected points appear highlighted in the graphic and spreadsheet views. 

Related topics 

 Project Explorer (on page 7) 
 Properties Pane (on page 14) 

 

Select Points 

Select individual, multiple, ranges, or sets of points based on specific criteria. 

To select points:  

1. Do one of the following: 

 Select Select > Select Points. 

 Click the  icon on the toolbar. 

 Click Options next to a select box in a command, and select Select Points from 
the drop-down list. 

The Select Points command pane displays. Each tab (General, GPS, and Occupation) 
shows a subset of possible selection criteria. 

1. Set the selection criteria you wish to use to select points. You can set multiple 
criteria and check more than one box in each group.  

 To add points selected to the current selection, check the Add to current 
selection box. 

 To preview the selection in an open graphic view, Project Explorer, or points 
spreadsheet, click Apply. All points meeting all of the criteria are selected.  

2. Refine the criteria if needed, and click OK to make the selection and close the 
dialog. The number of selected points appears on the status bar. 
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Options 

General tab 

Point ID To select a single point, enter the point ID. 

To select a range of points, enter the ID of the first point in 
the range followed by three dots (...) and the ID of the last 
point in the range. For example, you would enter 1...5 to 
select points 1, 2, 3, 4, and 5. 

To select two or more non-contiguous points, enter the ID of 
each point separated by a comma. For example, you would 
enter 1, 3, 6 to select points 1, 3, and 6. 

Note that you can enter multiple ranges by separating each 
range with a comma. For example, you could enter 1...5, 
101...105. 

Note: Alpha characters used in point IDs are not case 
sensitive. 

Feature code Enter the abbreviation you have given to a feature associated 
with the points you want to select. 

Observed from Enter the name of a point from which the points you want to 
select were observed. 

Layer Select the layer that the points you want to select reside on. 

Coordinate quality 
(horizontal, elevation, 
height) 

Fixed in adjustment - Check this box to select control quality 
points that were designated as 'fixed' during the last network 
adjustment. 

Adjusted - Check this box to select points with final 
coordinates resulting from the last network adjustment. 

Control - Check this box to select NGS surveyed coordinates 
of the highest quality. 

Survey - Check this box to select surveyed coordinates of the 
second highest quality. 

Mapping - Check this box to select coordinates of the low to 
average quality. 

Unknown - Check this box to select coordinates of the lowest 
or unverified quality. 

GPS tab - Points observed via GPS vectors 

Horizontal/ 
vertical precision 

Select operators, and enter precisions in the format shown in 
the Properties pane for vectors in your project. 
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Solution type Code - Check this box to select points with autonomous 
positions. 

Fixed - Check this box to select coordinates for which the 
baseline processor was able to resolve the integer ambiguity 
with enough confidence to select one set of integers over 
another during baseline processing. 

Float - Check this box to select coordinates for which the 
baseline processor was unable to resolve the integer 
ambiguity search with enough confidence to select one set of 
integers over another. 

Field method Continuous - Check this box to select points observed during 
a continuous trajectory. 

Event - Check this box to select points observed in a 
Real-Time Kinematic (RTK) GPS mode in which the 
resulting vectors include an 'event' marker. 

Observed control - Check this box to select control points 
observed in an RTK GPS mode. 

Rapid - Check this box to select points observed in an RTK 
GPS mode was collected at a fast data rate, such as every 
second. 

Static or fast static - Check this box to select points observed 
in a PPK GPS mode collecting up to 20 minutes or several 
hours (respectively) of raw data, and then postprocessing to 
achieve sub-centimeter precisions. 

Stop and go - Check this box to select points observed in 
short PPK or RTK Stop and Go occupations, while 
maintaining lock, and then postprocessing to achieve 
centimeter precisions. 

Topo - Check this box to select points observed in a GPS 
survey mode defined as topographic. 

Occupation tab 

Antenna heights between Enter antenna height parameters in the format shown in the 
Properties pane for points in your project. 

Add to current selection Check this to add the results of current selection to any 
previously selected data. 

Related topics 

 Select Observations 
 Select Unprocessed Sessions 
 Selection Methods and Options (on page 43) 
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Select Duplicate Points 

Select all of the points with duplicate IDs in your project if you need to review or 
merge them into single points. Merge duplicate points if you know that they are the 
same physical point, and you do not need them to be separate points. 

To select points with duplicate IDs:  

1. Select Select > Select Duplicates. The Select Duplicate Points command pane 
displays. 

2. If you do not want to set a distance tolerance between the points selected, uncheck 
Within the following distance. 

3. Otherwise, click two points in a graphic view, or type a distance in the box. Points 
within the distance will be selected as duplicates, depending on what you set in the 
next group. 

4. Select an option to ignore point IDs, or include them only if they are identical or 
different. 

5. Click Apply if you want to see and refine the selection, or click OK to use the 
current selection criteria. All points meeting all of the criteria are selected. The 
number of selected points appears on the status bar. 

Related topics 

 Merge Duplicate Points (on page 278) 
 Selection Methods and Options (on page 43) 

 

Select by Elevation Range 

Use an elevation range to select data, such as a set of surveyed points, that lies between 
high and low points in your project. You can also select objects, such as surfaces, that 
cross the elevation range you specify. 

To select data using an elevation range: 

1. Select Select > Select by Elevation Range. The Select by Elevation Range command 
pane displays. 

2. Click in the Max elevation box, and pick a point in a graphic view to use its 
elevation, or type an elevation in the box. 

3. Click in the Min elevation box, and pick a point in a graphic view, or type an 
elevation in the box. 

4. Specify whether to include only data that falls completely within the range, or data 
that falls within or crosses the range. 

5. If you want to add consecutive selections to your selection set, leave Add to current 
selection checked. 
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6. Click Apply if you want to see and refine the selection, or click OK to use the 
current selection criteria. All data meeting all of the criteria are selected. The 
number of selected points appears on the status bar. 

Note: Check the Project Explorer to easily see what you have selected. 

Related topics 

 Selection Methods and Options (on page 43) 
 

Select By Layer 

Select data that resides on specific layers in your project. 

To select data by its layer:  

1. Select Select > Select by Layer. The Select by Layer command pane displays. 

2. Simply check or uncheck the boxes next to any layer names in the list. The graphic 
views and Project Explorer update in real-time to show the selected data. 

3. Click Close. 

Related topics 

 Create and Edit a Layer (on page 68) 
 Selection Methods and Options (on page 43) 

 

Select Using Advanced Criteria 

Select objects by specifying a type of data (baseline, coordinate, point, etc.) and a 
specific property of that data. If needed, continue to build or modify your selection by 
specifying additional data types and their properties. 

To select data using specif ic criteria:  

1. Select Select > Advanced Select. The Advanced Select dialog displays, showing 
your current selection in the Current Status group. 

2. In the Apply This Selection To group, specify whether to select from the currently 
selected objects or from all data, and whether to replace or add to the current 
selection. 

3. Designate the kind of objects you want to select in the Data type list. 

4. To narrow your selection by specifying a property, click Data with the following 
property and select a property in the list. Otherwise, click Apply to preview the 
results, or OK to make the selection and close the Advanced Select dialog. 

5. If you are specifying a property of the data, select a mathematical operator in the 
That is box. Then type or select a value in the This value box. 
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Note: If you are entering a duration in the This value box, it must be in the time 
format used used by your computer's operating system, which is likely HH:MM:SS 
(Hours:Minutes:Seconds). 

6. To select the inverse of the criteria you specify, check the Invert selected objects 
box. This deselects all objects that would have been selected and selects all of the 
previously unselected objects. 

7. Click Apply to preview the results, or OK to make the selection and close the 
Advanced Select dialog. 

Related topics 

 Selection Methods and Options (on page 43) 
 

Selection Explorer and Selection Sets 

Understanding Selection Sets 

If you need to select the same objects over and over, it can be frustrating to manually 
do it and it is easy to make mistakes. Instead, use the Selection Explorer to create, 
modify, and reuse selection sets.   

Selection sets can be created and modified in a variety of ways, including Boolean 
operations using two or more sets.  

Action Selection Explorer 
Command 

Result ing Sets 

Project with data  

 

 

 

 

 

 

Group project data 
into selection sets.  

  Save as... 

 Red(3) 

 Yellow(5)  

 Blue(5) 
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Add currently 
selected objects to a 
selection set. 

 

 

 Add Current Selection 

current selection(2)  

+ Red(3)  

--> Red (5)  

Note: Don't forget to Save as. 

 

 

Subtract currently 
selected objects from a 
selection set. 

 Subtract Current 
Selection 

Blue(5) – current selection (1) 

--> Blue (4)  

Note: Don't forget to Save as. 

 

 

 

Add objects to a more 
than one selection set. 

 

Pick current selection(1)  

Add To Red(4), Yellow(5)  

-->  Red(5), Yellow(6) 

 

 

 

 

Subtract a selection 
set from another 
selection set. 

Select Blue(5)  

Subtract From  Yellow(6) 

--> Yellow(4)  

Note: Only the two objects 
that Blue and Yellow have in 
common are subtracted from 
Yellow.  

 

 

Create a new set from 
two or more selection 
sets. 

Select Yellow(6), Blue(5) 

Save as Green(8) 

 

Note: Use [Ctrl] or [Shift] to 
multi-select selection sets 
from the Selection Explorer 
list.  
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Create a selection set 
of only the common 
objects from two or 
more sets. 

Select Yellow(6), Blue(5) 
Save Common Items as 
Green(8) 

 
 

 

Selection Explorer 

The Selection Explorer is a pane that lists the selection sets in your project in the top 
section and lists the objects in the active set in the bottom section.  

 When you click on a selection set, all the objects in the set are selected in the 
project.   

 When you select one or more objects in the list of objects, those objects are selected 
in the project.    

 When <Selection Snapshot> is active, objects selected in the graphics area are listed.  

Using selection sets makes accessing and selecting groups of commonly-used objects 
faster and more consistent. 

To display and pin the Selection Explorer:  

1. Do one of the following: 

 Select View > Selection Explorer. 

 Select Select > Selection Set > Selection Explorer. 

 Click the  icon on the toolbar. 

 Right-click in a graphic view and select Selection Explorer from the context 
menu. 

The Selection Explorer displays, docked on the left side of the application window, 
or where you positioned it last. 

2. If desired, pin the explorer open by clicking the  icon at the top. If the pane is 
unpinned, the pane can "slide" to the side and out of view. To show it again, click 
the Selection Explorer tab. 

Related topics 

 Understanding Selection Sets (on page 54) 
 Create and Use Selection Sets (on page 57) 
 Modify Selection Sets (on page 58) 
 Pane and Data View Positioning (on page 31) 
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Create and Use Selection Sets 

Use the Selection Explorer to create, modify, and reuse selection sets for easier selection 
and editing. Using selection sets makes accessing and selecting groups of 
commonly-used objects faster and more consistent.  

The Selection Explorer contains two lists: the Selection Sets list at the top of the pane, 
and the object list at the bottom of the pane. The object list shows the objects that are 
contained in the selected selection set(s).  

Note: The selection sets you create, and those created from some types of imported 
files, also appear in the View Filter Manager (on page 9). They can be used as a 
starting point in creating view filters. 

To create a temporary l ist  of the currently selected objects: 

1. Open the Selection Explorer. 

2. Click <Selection Snapshot> on the list of selection sets. 

3. Select objects that you want to list in a graphic view, spreadsheet view, or the 
Project Explorer.  This list of objects displays in the object list of the Selection 
Explorer.   

Note: If the list does not update automatically, click the  (Refresh) icon in the 
Selection Explorer.  

To create a selection set (with the Selection Explorer open):  

1. Select objects that you want to include in the set in a graphic view, spreadsheet 
view, or the Project Explorer. 

2. Click the  icon on the Selection Explorer's toolbar. The Save As dialog displays. 

3. Type a name for the selection set, and click OK. The name of the new set appears in 
the Selection Sets list. 

To create a selection set (from the menu):  

1. Select objects that you want to include in the set in a graphic view, spreadsheet 
view, or the Project Explorer. 

2. Select Select > Selection Set > Save As. The Save As dialog displays. 

3. Type a name for the selection set, and click OK. 

Note: When you open the Selection Explorer, the selection set displays in the 
Selection Sets list.  
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To select al l  objects in a selection set:  

1. Open the Selection Explorer. 

2. Select one or more sets in the Selection sets list. All of the objects in the sets are 
selected in your project.  

Note: Use [Ctrl]-click and [Shift]-click to multi-select in the Selection Sets list.  

3. Deselect, modify, and use the objects as needed. 

To copy a selection set:  

1. Open the Selection Explorer. 

2. Select the selection set to copy in the Selection sets list. 

3. Click the  icon on the Selection Explorer's toolbar. The Save As dialog displays. 

4. Type a new name for the selection set, and click OK. 

To remove a selection set (from the menu):  

1. Select Select > Selection Set > Remove. The Remove dialog displays. 

2. Select one or more sets to remove in the list, and click OK. 

Note: Remove does not delete the objects in the selection set from your project. If 
you delete objects from your project, they are also removed from any selection sets 
they were in. 
Note: <Selection Snapshot> is a default selection set that cannot be removed. 

To remove a selection set (with the Selection Explorer open):  

1. Select one or more sets to remove in the Selection Sets list 

2. Click the  icon. The selection set disappears from the list. 

Related topics 

 Selection Explorer Options (on page 60) 
 Understanding Selection Sets (on page 54) 
 View Filter Manager (on page 9) 

 

Modify Selection Sets 

To add objects to an existing selection set (from the Selection 
Explorer) :  

1. Open the Selection Explorer and select the selection set from the Selection Sets list. 

2. Select the objects to add. 

3. Click  icon on the Selection Explorer. The objects appear in the list below. 
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4. (optional) Click  to save the updated selection set.  

To subtract objects to an existing selection set (from the Selection 
Explorer) :  

1. Open the Selection Explorer and select a selection set from the Selection Sets list. 

2. Select the objects to subtract. 

3. Click  (or right-click and select Subtract Current Selection from the context 
menu). The objects are subracted from the set.  

4. (optional) Click  to save the updated selection set.   

To add objects to an existing selection set (from the menu):  

1. Select objects that you want to add to a set. 

2. Select Select > Selection Set > Add To. The Add To dialog displays. 

3. Select the set to edit in the list and click OK. The objects are added to the set. 

To subtract objects from an existing selection set (from the menu):  

1. Select objects that you want to remove from a set.  

2. Select Select > Selection Set > Subtract From. The Subtract From dialog displays. 

1. Select the set to edit in the list and click OK. The objects are removed from the set. 

To edit  multiple selection sets at once: 

1. Open the Selection Explorer. 

2. Select one or more sets  in the Selection sets list. All of the objects in the sets are 
selected in your project.  

Note: Use [Ctrl]-click and [Shift]-click to multi-select in the Selection Sets list.  

3. Select objects that you want to add; then right-click and select Add Current 
Selection. 

4. Select objects that you want to remove in the objects list; then right-click and 
select Subtract Current Selection. 

To combine multiple selection sets:  

1. Open the Selection Explorer. 

2. Select each of the selection sets that you want to combine in the Selection Sets list. 

Note: Use [Ctrl]-click and [Shift]-click to multi-select in the list.  

3. Click the  icon on the Selection Explorer's toolbar. The Save As dialog displays. 
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4. Type a name for the new selection set, and click OK. The name of the combined set 
appears in the Selection Explorer. 

Note: Objects that were in more than one set are not duplicated in the new 
combined set. 

Related topics 

 Selection Explorer Options (on page 60) 
 Understanding Selection Sets (on page 54) 

 

Selection Explorer Options 

Use these Selection Explorer options to create, edit, and use selection sets.  



Trimble® Business Center 
Heavy Construction Edition User Guide 61 

 View, Navigate, and Select

Options Context 
menu 

 

 
(save the 
selection list as) 

Save as The icon and the context menu option work in 
slightly different ways: 

Click the icon to display the Save Selection List As 
dialog, where you can save all of the objects in the 
Selection List as a new selection set, regardless of 
whether they are selected or not. 

Select the context menu option to display the Save 
As dialog, where you can save just the objects that 
are selected in the Selection List as a new selection 
set. 

Use Save As to copy and combine selection sets as 
well. You can also enter an existing set name to 
overwrite that set with the current selection. 

 
Refresh Click this to refresh the Selection Explorer's list of 

currently selected objects after you have selected 
or deselected objects in another view, spreadsheet, 
or the Project Explorer. 

 Properties  Click this to display the Properties pane, where 
you can view and edit the properties common to 
all the objects in the current selection set. 

Tip: Using the <Selection Snapshot>, you can 
select all of the objects you need to modify and 
then view and edit properties for each one without 
losing the others in the list. 

 Remove Click this to remove the selected selection sets. 

Note: This does not delete the members of the 
selection set from your project. 

 Add Current 
Selection 

Click this to add newly selected objects to the 
current selection set. 

 Subtract Current 
Selection 

Click this to subtract newly selected objects from 
the current selection set. 
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Selection sets  This column lists the <Selection Snapshot> 
(always present), selection sets automatically 
generated by some types of imported files, and 
selection sets you have created. 

Note: Selection sets also appear in the View Filter 
Manager (on page 9). They can be used as a 
starting point in creating view filters. 
Note: Selection sets can contain objects that have 
no visible display, such as coordinates. In the 
Selection Explorer, all selection sets are available. 
In the View Filter Manager, however, only 
selection sets that contain at least one visible 
object are available. 

  Objects  This column shows the number of objects that are 
members of the selection set. 

Selection List  This list shows the members of the currently 
selected set. 

     Click this to sort the set by selection status, either 
'selected' or 'unselected'. 

This column also denotes the last object selected 
with the  icon, and displays the icon for each 
member's object type. 

  Name  Click this column heading to sort the members of 
the set by object name. 

Unnamed objects are shown with '?' for the name, 
but they can be partially distinguished by the 
object type icon in the next column. 

  Type  Click this column heading to sort the objects in a 
set by their object type. 
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Additional 
options (context 
menu) 

 Right-click on any selection set or object to access 
these options. Options vary, depending on what is 
selected. 

Save Common Objects As - Select this to display 
the Save As dialog, where you can create a new 
selection set containing all of the objects that were 
in each of the selected sets. 

Lock/Unlock Selection Sets - Select these to 
prevent or allow changes to the selected sets.  

Note: Locked selection sets can only be changed by 
deleting objects from the project. 

Select all - Select this to select every object in the 
selected selection set. 

Select This Type - Select this to select all the 
objects in the set whose type (such as 'point') 
matches the selected object. 

Invert - Select this to switch the selection state in 
the object list. This deselects the currently selected 
objects in the set, and selects the currently 
unselected objects. 

Add To - Select this to display the Add To dialog, 
where you can select one or more sets to which 
you want to add the selected objects. If you add 
objects are already exist in the set, they are not 
duplicated. 

Subtract From - Select this to display the Subtract 
From dialog, where you can select one or more sets 
from which you want to subtract the selected 
objects. 

Delete - Select this to remove the selected object 
from the current selection set. 

Rename - Select this to put the selection set name 
into edit mode in the Selection Sets list. 

Related topics 

 Create and Use Selection Sets (on page 57) 
 Understanding Selection Sets (on page 54) 
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View and Edit an Object's Properties 
Review and edit the properties for selected objects to ensure they have the correct 
attributes. If you select a single object, the properties for that object are displayed. If 
you select multiple objects, the properties common to all of them are displayed. You 
can edit the common properties, or select a subset of the selected objects using the 
drop-down list near the top of the pane. 

To view the properties of another object in the Properties pane, click the object within 
any data view or pane. If the Properties pane is displayed, selecting any object will 
show its properties. 

Note: The toolbar icons and context menu items available in the Properties pane 
depend on the types of objects you have selected. The Properties pane also enables you 
to use COGO controls and snap commands within certain property boxes. 

To edit properties: 

 Click in a property box, highlight the value to edit, and type a new value, or (if 
applicable) select a new value from the list. 

Note: You can enter a value in units different from the project units; it will be 
converted to the project units. For example, if an elevation is displayed in meters 
and you enter a value as "10 ft", it will convert to "3.048" (meters). 
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 Press [Esc] to cancel an edit; the property will revert to its original value. 

 Press [Tab] to accept an edit and move to the next property box. 

 Press [Shift] + [Tab] to accept an edit and move to the previous property box. 

 Press [Enter] to accept an edit and close the Properties pane. 

Sections 

 Click this on the pane's toolbar to select any associated point, 
coordinate, baseline, vector, or trajectory when survey data is 
selected. 

Sub-selection 
list 

This displays all of the selected objects by type. If you have 
selected multiple objects, you can accept the default selection of 
All, or click the drop-down arrow to narrow the selection to a 
specific type of object. 

Properties This displays groups of properties. Click a property label to see 
additional information, or click in a property box to edit the 
value, when available. 

Note: If you are in a COGO control (see "Understanding COGO 
Controls" on page 86) in the grid, you can pick a point(s) or 
object(s) in the view, or right-click for snap options. 

(information box) This displays a description of the selected property. 

Related Topics 

 Properties Pane (on page 14) 
 Pane and Data View Positioning (on page 31) 

 

Delete an Object 
Remove objects that you no longer need from the project database. 

To select and then delete data: 

1. Select the data to delete in a graphic view, spreadsheet, or the Project Explorer. 

The number of objects selected appears in the status bar. 

2. Do one of the following: 

 Select Edit > Delete. 

 Press [Ctrl] + [D]. 

 Right-click and select Delete from the context menu. 
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The selected objects are removed from graphic views, spreadsheets, and the Project 
Explorer. The Delete command pane does not display.  

To start Delete and then select the data: 

1. Select Edit > Delete. The Delete command pane displays. 

2. Select data using one of the following: 

 Click Options, and select an option from the menu. 

 Pick objects in a graphic view, spreadsheet, or the Project Explorer. 

The number of objects selected appears in the status bar. 

3. Click OK. The selected objects are removed from graphic views, spreadsheets, and 
the Project Explorer. 

To restore deleted data:  

 Select Edit > Undo Delete immediately after using the Delete command. 

Related topics 

 Filter a View (on page 76) 
 Undo and Redo Commands 
 Selection Methods and Options (on page 43) 

 

Edit an Object 
When you need to edit an object, the program will open the editor appropriate to the 
object's type. 

To edit an object:  

 Right-click an object, and select Edit from the context menu. 

 Select Edit > Edit. 

 Click the  icon on the toolbar, or on the Properties pane toolbar. 

Depending upon whether you have an object selected or not, either the Edit 
command pane displays (prompting you to select an object) or the editor 
appropriate to the selected object displays. 

Related topics 

 Edit an Alignment (on page 290) 
 Edit a Linestring's Horizontal Segments (on page 301) 
 Edit a Surface by Adding and Removing Members (on page 328) 
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Undo or Redo an Action 
Any action that affects the project database, such as creating an object, can be redone 
or undone. Commands that don't affect the database, such as opening a file, cannot be 
redone or undone. 

To undo an action: 

Use the Undo command to revert to the state prior to the last action. 

 Select Edit > Undo command. 

 Press [Ctrl] + Z. 

 Click the  icon on the toolbar. 

Multiple actions can be undone one at a time. The most-recently performed action is 
undone first. Once you close the project or the software, no actions can be undone. 

To redo an action: 

Use the Redo command to reverse the Undo command. 

 Select Edit > Redo command. 

 Click the  icon on the toolbar. 

Once you close the project or the software, no actions can be redone. 

Note: Viewing actions, such as zoom, pan, and rotate, do not appear in the Undo / Redo 
list. 

Manage the Data in Your Views 

Understanding Layers and View Filters 

Layers enable you to separate different types of data, and group related types of data, in 
the same way that transparent overlays in drawings used to. 

View filters let you set the visibility of each data type and layer to control what is 
displayed in graphic views, helping you reduce and simplify what you see. View filters 
can be customized for each kind of view so that only the useful types of data are shown 
in each view. 

With view filters, you can also set the selectability of data types and layers. For 
example, if you have a layer containing just background reference data that you will 
always need to see, but never need to use, simply make it unselectable. 
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Layers and view filters serve unique purposes, but work powerfully in conjunction 
with each other. Once you have set up layers and view filters, you can save them in 
project templates, making them ready to use each time you start a new project. 

Related topics 

 Create and Edit a Layer (on page 68) 
 Create a View Filter (on page 73) 
 Layer Options (on page 71) 
 View Filter Manager (on page 9) 

 

Create and Edit a Layer 

Use layers to keep your data organized by type. You can create and delete individual 
layers, purge all empty layers, and select objects by choosing their layer. Layer 
properties allow you to change layer colors and line styles to help you distinguish more 
easily between data on different layers. 

Note: Layers can only be imported or exported as part of CAD (.dxf, .dwg, and .dgn) 
files. 

To create a new layer:   

1. Do one of the following: 

 Select Project > Layer Options.  

 Click the  icon on the toolbar. 

The Layer Options command pane displays. 

2. Click the  icon on the command pane's toolbar. The New Layer dialog displays. 

3. Type a unique name in the Layer name box to indicate what type of data the layer 
will contain. 

4. Select layer display options in the Color, and Line style lists.  

Note: If you have a separate line styles file, you can import it using the line styles 
list. 
Note: If the scale of your lines is small in a graphic view, some line styles display as 
solid lines to improve performance. 

5. Click OK. The new layer appears in the pane's Layers list. 

To edit  properties of  a layer:  

1. Starting after step 1 above, select a layer in the Layers list. The layer's properties 
appear in the Layer Properties group. 

2. Click in a box and edit the property or select a new property. The edits are 
reflected in graphic views immediately. 
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To delete one or all  empty layers:  

1. Select one or more empty layers in the Layers list. 

2. Click the  icon on the pane's toolbar. The layer is deleted. 

3. To delete all empty layers, click the  icon on the pane's toolbar.  

Note: Empty layers are those that have no objects assigned to them. If there are no 
empty layers selected or in your project, the icons are unavailable. 

To select the objects that reside on a layer:  

1. Select one or more layers in the Layers list. 

2. Click the  icon on the pane's toolbar. The objects on the selected layers 
highlight in graphic and spreadsheet views and in the Project Explorer. 

To change the layer on which objects reside: 

1. Select the objects for which you want to change the layer. 

2. Select Edit > Properties. The Properties pane displays. 

3. If needed, select a subset of the objects in the data type list at the top of the pane. 

Note: To change the layer, all of the selected objects must have Layer as a property. 
Generally, survey data and survey points do not have a layer property. 

4. Click in the Layer box and select the new layer. 

5. Click Close. 

To set the visibil ity or selectabil ity of objects by layer:  

1. Do one of the following: 

 Select View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays. 

2. Click the tab at the top of the view for which you want to edit the layers. 

3. Select an unlocked view filter in the  list at the top of the pane. 

Note: This sets the visibility and selectability of the layers only for the view filter 
you have selected. 
Note: To unlock a locked view filter, you can modify or copy it. See Create and Edit 
a View Filter (see "Create a View Filter" on page 73). 
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4. Click the  icon on the pane's toolbar. The Advanced View Filter Settings dialog 
displays. 

5. Scroll down and click the  icon next to Layers to expand the group. 

6. Check and uncheck boxes in the Visible and Selectable columns as needed. 

7. Click OK. 

Related topics 

 Layer Options (on page 71) 
 Isolate or Exclude a Layer (on page 70) 
 Create and Edit a View Filter (see "Create a View Filter" on page 73) 
 Filter a View (on page 76) 

 

Isolate or Exclude a Layer 

Turn individual layers on or off to better understand what data is on each layer in your 
project, and to help you create view filters using just the relevant layers. 

To isolate individual layers:  

1. Do one of the following: 

 Select the View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays. 

2. Click the tab at the top of the view in which you want to isolate the layer. 

3. Select a view filter in the  list at the top of the pane. If you want to create a new 
view filter from an unlocked view filter, click the  icon to make a copy so you do 
not modify the original view filter. 

4. If desired, click the  icon on the pane's toolbar to turn on the Auto Zoom (to the 
extents of the visible data) mode.  

5. Click the  icon on the pane's toolbar to turn on the Isolate Layers mode. The 
groups in the View Filter Manager collapse so that only the Layers group shows. 

6. Click the name of each layer to see the data that resides on it in the graphic view. 
Only objects on the selected layer are visible. 

7. If you are creating a view filter and want it to show the selected layer, make sure its 
box is checked. If you do not want to include the layer in the view filter, uncheck 
the box. 
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Tip: You may find it faster to use the keyboard to isolate layers. Click a layer name, 
and then use the up and down arrow keys to move through the list. Press the 
spacebar to check and uncheck the boxes that control the layer visibility. 

8. Once you are done, click the  and  icons again to return to normal mode. The 
new view filter shows only the data on the layers for which the boxes are checked. 

To hide (exclude) layers by selecting objects:  

1. Starting after step 4 above, select one or more objects (in the graphic view) of the 
types you want to hide or that reside on the layers you want to hide. 

2. Click the  icon on the View Filter Manager's toolbar. The layers that the objects 
were assigned to are hidden. 

3. Click the  icon again to return to normal mode. 

Tip: This method will not hide unlayered data types, such as survey data. If you are 
primarily interested in CAD data, you may want to hide raw data types before 
using this method. 

Related topics 

 Create and Edit a Layer (on page 68) 
 Layer Options (on page 71) 
 Create and Edit a View Filter (see "Create a View Filter" on page 73) 
 Filter a View (on page 76) 
 View Filter Manager (on page 9) 

 

Layer Options 

Use these options to create and delete layers, select objects by choosing their layers, 
and edit layer properties. They are available in the Layer Options command pane. 
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Options 

 Click this to open the New Layer dialog, where you can create a new 
layer. 

 Click this to delete one or more empty layers that you have selected in 
the Layers list. 

Empty layers are those that have no objects assigned to them. You 
cannot delete layers that have objects assigned to them. 

 
Click this to delete all empty layers from the Layers list and your 
project. 

 
Click this to select all of the objects on the layers you have selected.  

Layers This lists all of the layers in your project, enabling you to select one or 
more layers or the objects on them. 

Layer properties This shows the attributes of the selected layer. Click in the box for any 
property to edit it. 

Related topics 

 Create and Edit a Layer (on page 68) 
 Isolate or Exclude a Layer (on page 70) 

 

View Filter Manager 

The View Filter Manager is a pane in which you can select data types and layers to 
specify what is visible in the current graphic view, helping you reduce and simplify 
what you see. As you make changes in the manager, the view updates to reflect them. 

View filters are saved sets of criteria that control what data and layers are displayed in 
the views. View filters can be defined separately for each type of view so that only the 
data that is important for the current phase of your work is displayed. When you 
change to a different view, the current and available view filters may change as well, 
because view filters are saved with views. The view filters for each view in your project 
can be accessed from the view filter list on the toolbar. 

To display and pin the View Filter Manager:  

1. Do one of the following: 

 Select View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays, docked on the left side of the application window, 
or where you positioned it last.  

Note: If the Project Explorer or Selection Explorer are also active, they may share the 
same pane, and be accessible as tabs at the bottom of the pane. 
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2. If desired, pin the manager open by clicking the  icon at the top. If the pane is 
unpinned, it can "slide" to the side and out of view. To show it again, click the View 
Filter Manager tab on the left edge of the application window. 

Using the View Filter Manager 

 When you check and uncheck boxes for data types and layers in the View Filter 
Manager, the current view changes in response. 

 Arrange the order of the data type groups in the tree by right-clicking on a group 
and selecting Move Up or Move Down from the context menu. 

 To set the selectability of data types and layers, click the  icon on the pane's 
toolbar to display the Advanced View Filter Settings dialog. 

Related topics 

 Create a View Filter (on page 73) 
 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 Pane and Data View Positioning (on page 31) 

 

Create a View Filter 

Use the View Filter Manager to select data types and layers to specify what is visible in 
graphic views, helping you reduce and simplify what you see. As you make changes in 
the manager, the current view updates to reflect them. You can create, copy, and 
delete view filters in the manager. View filters allow you to select data types and layers 
to control what is visible in graphic views, helping you reduce and simplify what you 
see. In creating a view filter, you set criteria for what to show in views.  

To create a view fi lter:  

1. Do one of the following: 

 Select the View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays. 

2. Click the tab at the top of the view for which you want to create the view filter. 

3. In the  list, select a locked view filter that is close to the one you are trying to 
create; a copy of the original view filter is created as you make changes. If you are 
concerned about accidentally changing your existing view filters, and have most of 
them locked, use this method. 

Or 
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Select an unlocked view filter that is close to the one you are trying to create and 
click the  icon on the pane's toolbar. A copy of the view filter is created.  If you do 
not want to be bothered with locking/unlocking view filters, and have most of 
them unlocked, use this method. 

Note: There is one pre-defined view filter (All) which cannot be deleted. 
Tip: If you have project templates, you may want to create and add custom view 
filters to them. 

4. If desired, narrow the view filter by selecting a selection set in the  list (for more 
on selection sets, see Create and Use Selection Sets (on page 57)). 

5. If necessary, click the  and  icons to expand and collapse groups. 

6. Check and uncheck boxes to show and hide different data types and layers as you 
watch the changes in the graphic view. All of the changes you make are 
automatically saved to the current view filter for the current view. 

7. For additional display style options, click the tabs at the bottom of the pane and 
change the settings as needed. 

Note: The display styles tabs are only available for unlocked view filters, and 
generally only affect raw data, such as survey data. 

To create a view fi lter using advanced settings: 

1. Starting after selecting an unlocked view filter in step 3 above, click the  icon on 
the pane's toolbar. The Advanced View Filter Settings dialog displays. 

2. Use the process described in steps 4 - 6 above to create a view filter. Additional 
options (such as Include newly created layers, Locked, Show display styles, and 
Selectable) are also available. See Advanced View Filter Options (on page 81) for 
details. 

Note: Since you are working in a dialog, you will not see the graphic view update as 
you make changes to the view filter.  For projects with a lot of data, this is more 
efficient because the screen does not have to refresh between changes. You can, 
however, click Apply at the bottom of the dialog to manually refresh the graphic 
view at any time. 

3. Click OK. The new view filter is associated with the current graphic view; other 
views have the option of using the new view filter as well. 
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To copy a view fi lter:  

 Select a view filter in the  list, and click the  icon on the pane's toolbar. The 
copy of the view filter appears in the list. The original view filter's name is 
appended with " - Copy" in the new view filter's name. The copy is unlocked and is 
associated with the current graphic view. 

Note: The Copy, Delete, and other commands can also be accessed by clicking in the 
view filter list and selecting from the context menu. 

To delete a view fi lter:  

 Select a view filter in the  list, and click the  icon on the pane's toolbar. The 
view filter disappears from the list, and the current graphic view becomes 
associated with the default view filter.  If the default view filter does not exist, the 
view is associated with the original default view filter named All. 

Note: The All view filter cannot be deleted. 

Related topics 

 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 View Filter Manager Options (on page 79) 
 Create and Edit a Layer (on page 68) 

 

Edit a View Filter 

Use the View Filter Manager to edit, copy, and rename existing view filters. View filters 
can be customized for each view so that you see only the types of data you need for 
your current task. 

To unlock/lock a view fi lter:  

1. Do one of the following: 

 Select the View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays. 

2. Click the tab of the view associated with the view filter you want to unlock. 

3. Select the view filter in the  list. 

4. Click the  icon on the pane's toolbar. The Advanced View Filter Settings dialog 
displays. 

5. Check or uncheck the Locked box, and click OK. 
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Note: If you modify a locked view filter, an unlocked copy is automatically made. If 
you copy a locked view filter, the copy is unlocked. 

To edit  a view fi lter:  

1. Starting after step 3 above, click the  and  icons to expand and collapse groups 
if necessary. 

2. Check and uncheck boxes to show and hide different data types and layers as you 
watch the changes in the graphic view. All of the changes you make are 
automatically saved to the current view filter for the current view.  

3. For additional display style options, click the tabs at the bottom of the pane and 
change the settings as needed. For advanced options, click the  icon on the 
pane's toolbar. 

To rename a view fi lter:  

1. Select an unlocked view filter in the list and click the  icon on the pane's toolbar. 
Alternately, you can click in the view filter list and select Rename View Filter from 
the context menu. 

2. Type a new name for the view filter in the New name box, and click OK. 

Related topics 

 Create and Edit a Layer (on page 68) 
 Filter a View (on page 76) 
 Troubleshoot a Layer or View Filter  Problem (see "Troubleshoot a Layer or View 

Filter Problem" on page 83) 
 Layers and View Filters (see "Manage the Data in Your Views" on page 67) 

 
 

Filter a View 

Use view filters to reduce and simplify what you see in graphic views. The software 
comes with one pre-defined, default view filter that shows all of the visible data in 
your project. Use this view filter, named All, as the staring point, and adapt it to create a 
set of basic view filters to fit your needs. Then, you can modify those view filters to 
build more subtle and complex ones. 

Filter a view to inspect your project data:  (simple) 

1. Click the tab of the graphic view you want to filter. 

2. Click in the view filter list on the toolbar, and select the view filter that meets your 
needs for the current view. Depending on the data in your project, the view 
changes. 
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The view filter list on the toolbar looks like this:  

Note: The view filter list shows all of the view filters that have been created in the 
View Filter Manager.  If no additional view filters have been created for the project, 
only the default All view filter is available.  
Note: The All view filter cannot be deleted. 

3. Select other view filters in the list to try other view filters. If the view filter you 
need has not been created yet, and you want to modify the existing view filter, use 
the procedure below. 

Filter a view to inspect your project data: 

1. Click the tab of the graphic view you want to filter. 

2. Do one of the following: 

 Select the View > View Filter Manager. 

 Click the  icon on the toolbar. 

The View Filter Manager displays. 

3. Select a view filter in the  view filter list at the top of the pane. 

4. If you selected an unlocked view filter, and want to preserve the original, click the 
 icon on the pane's toolbar to create a copy. 

5. If desired, narrow the view filter by choosing a selection set in the  list. 

Note: Selection sets are automatically created for many types of imported files. For 
more information on selection sets, see Create and Use Selection Sets (on page 57). 

6. If necessary, click the  and  icons to expand and collapse the groups. 

7. Check and uncheck boxes to show and hide different data types and layers as you 
watch the changes in the graphic view. 

8. For additional display style options, click the tabs at the bottom of the pane and 
change the settings as needed. Continue to experiment by making different 
combinations of data visible. This will help you understand what is in your project. 

9. If an unneeded view filter was created, click the  icon on the pane's toolbar to 
delete it. If you do not delete the view filter, it will be available in the view filter 
list on the toolbar. 

Filter a view to see only one type of data: 

1. Starting after step 4 above, click the  and  icons to expand and collapse the 
groups if necessary. 
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2. Right-click the name of a data type you want to view, and select View Only This from 
the context menu. All of the other boxes in the group are automatically unchecked 
so that only the selected object type is visible.  

Or 

3. Right-click on the tree view and select Hide All from the context menu. All of the 
boxes in the group are automatically unchecked.   

4. Check the box for the one object type you want to see.   

Note: When using View Only This or Hide All, the check boxes in other groups are not 
affected. If you want to see only one data type from all groups, uncheck the boxes 
next to the other group names before selecting View Only This or Hide All. 

Note: There are two things that affect whether an object is visible in the graphic 
views: whether the box for the object type is checked, and whether the box for the 
layer that the object resides on is checked. If an object does not display as expected, 
make sure both boxes are checked. Generally, this only applies to Points and CAD 
Blocks, Lines, and Text (only available in the Advanced View Filter Settings dialog. 

Filter a view to see only one layer:  

 See Isolate or Exclude a Layer (on page 70). 

Filter a view to see only objects in a selection set:  

Selection sets are automatically generated by some types of imported files. You can also 
define them using selected objects in the Selection Explorer (on page 8). Use selection 
sets to narrow the data included in a view filter. 

Note: Selection sets can contain objects that have no visible display, such as 
coordinates. In the Selection Explorer, all selection sets are available. In the View Filter 
Manager, however, only selection sets that contain at least one visible object are 
available. 

1. Select the All view filter in the  list. 

2. Select the selection set in the  list. Only data that is in the selection set is visible. 

Filter a view to see everything but one data type or layer:  

1. Select the All view filter in the View Filter Manager. Alternately, you can also check 
the box for each group or right-click in each group and select View All from the 
context menu to see all of the data.  

2. Uncheck the box for just the data type or layer you want to hide.  

Related topics 

 Create and Edit a View Filter (see "Create a View Filter" on page 73) 
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 Create and Edit a Layer (on page 68) 
 Troubleshoot a Layer or View Filter  Problem (see "Troubleshoot a Layer or View 

Filter Problem" on page 83) 
 

View Filter Manager Options 

Use these options to select data types and layers to control what is visible in graphic 
views, helping you reduce and simplify what you see. View filters can be customized 
for each kind of view so that only the useful types of data are shown for each view. 
They are available in the View Filter Manager. 
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Options 

 Click this to make a copy of the currently selected view filter. The 
original view filter's name is appended with "- Copy" in the new view 
filter's name. 

 Click this to rename the currently selected view filter. Then type a 
unique name for the view filter in the New name box, and click OK. 

 Click this to delete the currently selected view filter. The view filter 
disappears from the list, and the current graphic view becomes 
associated with the default view filter.  If the default view filter does 
not exist, the view is associated with the view filter named All. 

Only unlocked view filters can be deleted. 

 Click this to put the View Filter Manager into Auto Zoom mode in 
which the current graphic view automatically zoom to the extents of 
the data that is visible in the current view filter. 

 Click this to put the View Filter Manager into Isolate Layers mode. All 
of the groups collapse except for the Layers group. Select a single layer 
to see only the data on that layer. 

 Pick objects in the graphic view, and click this to hide the layers on 
which the selected objects reside. 

 Click this to open the Advanced View Filter Settings dialog, where 
you can set additional view filter and layer settings, as well as the 
standard settings found in the View Filter Manager. 

  
(view filter list) 

Select a view filter to apply it to the current view. Then you can edit it 
or copy it.  
This list matches the view filter list found on the toolbar. 

  
(selection set list) 

Select from selection sets automatically generated by imported files or 
selection sets you have defined to narrow the data included in the 
selected view filter. 

Note: Selection sets can contain objects that have no visible display, 
such as coordinates. In the Selection Explorer, all selection sets are 
available. In the View Filter Manager, however, only selection sets 
that contain at least one visible object are available. 

(object and 
layer tree) 

Click the  icon to expand a group, and check and uncheck boxes in 
the group to control the visibility of different types of objects and 
layers in the graphic view. 

Tab groups Click these tabs near the bottom of the pane to set additional display 
style options. They only appear when you select an unlocked view 
filter, and they are part of the view filter criteria.  
For details, and to hide the tabs, see Advanced View Filter Options (on 
page 81). 

Context menu options 
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View all/ 
Hide all 

Within a group, use this option to check/uncheck all of the boxes, 
thereby displaying or hiding all of those object types or layers in the 
graphic view. 

View only this Within a group, use this option to check the selected object type or 
layer, and uncheck everything else in the group. 

Note: If no data is visible after you select View Only This, make sure 
that the box for the layer the data is on is also checked. 

Move up/ 
Move down 

On a group, use this option to move the group up or down in the tree 
so that your most frequently used groups are at the top. The order is 
saved with your project, and is the same for all view filters. 

Invert Within a group, use this option to check all of the boxes that are 
unchecked and uncheck all of the boxes that are checked. 

Layer options Within the Layers group, use this option to open the Layer Options 
(on page 71) command pane. 

Related topics 

 Create a View Filter (on page 73) 
 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 Troubleshoot a Layer or View Filter  Problem (see "Troubleshoot a Layer or View 

Filter Problem" on page 83) 
 Advanced View Filter Options (on page 81) 

 

Advanced View Filter Options 

Use these options to manage view filters, including controlling selectability and how 
new objects are handled. Most of the View Filter Manager options are also available. 
They are available in the Advanced View Filter Settings dialog. 
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Options 

Filter name If necessary, rename the selected view filter in this box. 

  
(selection set list) 

Select from selection sets automatically generated by 
imported files or selection sets you have defined to 
narrow the data included in the selected view filter. 

Note: Selection sets can contain objects that have no 
visible display, such as coordinates. In the Selection 
Explorer, all selection sets are available. In the View Filter 
Manager, however, only selection sets that contain at 
least one visible object are available. 

Include newly created layers Check/uncheck this box to include/exclude object types 
and layers that are added to the project after the view 
filter was defined. 

Locked Check/uncheck this box to make the view filter 
uneditable/editable. 

Show display styles Check/uncheck this box to show/hide the display styles 
tabs in the View Filter Manager. 

Show CAD display options Check/uncheck this box to show/hide the CAD data 
group (CAD block, line, text) in the View Filter Manager. 

Visible / Selectable  
(in the groups) 

Check/uncheck the boxes to control what is visible and 
selectable in graphic views. 
In addition to the standard data types and layers available 
in the View Filter Manager, there is a group for CAD 
blocks, lines, and text.   

Apply 
(button) 

Click this to apply your changes and refresh the current 
graphic view. 

Point tab options 

Show point labels Check and uncheck this box to show and hide the label 
text of the point ID for points. 

Show disconnected points Check and uncheck this box to show and hide points that 
are not connected to baselines or vectors. 

Observations tab options 

 Click this tab for survey-related view filter options. 

GNSS tab options 

 Click this tab for survey-related view filter options. 
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Context menu options 

View all/ 
Hide all 

Within a group, select this to check/uncheck all of the 
boxes, displaying of hiding all of those object types or 
layers in the graphic view. 

View only this Within a group, select this to check the selected object 
type or layer, and uncheck everything else in the group. 

Note: If no data is visible after you select View Only This, 
make sure that the box for the layer the data is on is also 
checked. 

Move up/ 
Move down 

On a group, select this to move the group up or down in 
the tree so that your most frequently used groups are at 
the top.  
The order is saved with your project, and is the same for 
all view filters. 

Layer options Within the Layers group, select this to open the Layer 
Options (on page 71) command pane. 

Related topics 

 Create a View Filter (on page 73) 
 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 Troubleshoot a Layer or View Filter  Problem (see "Troubleshoot a Layer or View 

Filter Problem" on page 83) 
 View Filter Options (see "View Filter Manager Options" on page 79) 

 

Troubleshoot a Layer or View Filter Problem 

Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

The graphic view 
redraws slowly 
when you make 
changes to view 
filters. 

Your project 
contains a lot of data, 
and your computer's 
graphics memory is 
running at capacity. 

Click the  icon on the View Filter 
Manager's toolbar to open the Advanced View 
Filter Settings dialog. When you make 
changes to view filters in this dialog, the 
graphic view does not automatically redraw. 
You can click Apply at any time to have the 
view redraw. 

or 

Select Project > Project Settings. Click 
View and then View Filters in the left pane, 
and select a default view filter other than All 
so that graphic views refresh more quickly. 
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The points on a 
layer are not visible, 
even though you 
have the layer's box 
checked in the View 
Filter Manager to 
make it visible. 

The Point box in the 
Raw Data group is 
not checked. 

Make sure that the boxes for both the points 
and the layer that the points are on are 
checked, making them visible in the view.  

Some of the 
selection sets you 
created do not 
appear in the View 
Filter Manager's 
selection sets list. 

The missing 
selection sets that do 
not contain any 
visible objects. 

None. Selection sets can contain objects that 
have no visible display, such as coordinates. In 
the Selection Explorer, all selection sets are 
available. In the View Filter Manager, 
however, only selection sets that contain at 
least one visible object are available. 

Related topics 

 Create a View Filter (on page 73) 
 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 View Filter Options (see "View Filter Manager Options" on page 79) 
 Advanced View Filter Options (on page 81) 

 

Troubleshoot a View or Selection Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

The graphic view 
redraws slowly 
when you make 
changes to view 
filters, or when you 
change the size of 
panes. 

Your project contains a 
lot of data, and your 
computer's graphics 
memory is running at 
capacity. 

Click the  icon on the View Filter 
Manager's toolbar to open the Advanced 
Settings dialog. When you make changes 
to view filters in this dialog, the graphic 
view does not automatically redraw. You 
can click Apply at any time to have the 
view redraw. 

or 

Select Project > Project Settings. 
Click View and then View Filters in the left 
pane, and select a default view filter other 
than All so that graphic views refresh more 
quickly. 

The 3D view is 
replaced by a red X 
and this message: 

"The system has run 
out of graphics 
memory. Close any 
unnecessary 

The system has run out 
of graphics memory.  
(no screen saver 
interruption) 

 

1. Close any unneeded programs that are 
running,     especially ones that are 
graphics intensive. 

2. Close all 3D views, including those with 
a red X. 

3. Reopen the minimum number of 3D 
views you need. 



Trimble® Business Center 
Heavy Construction Edition User Guide 85 

 View, Navigate, and Select

windows and retry." Long-term: Consider upgrading your 
graphics card. 

 

The 3D view is 
replaced by a red X 
and this message: 

"The system has run 
out of graphics 
memory. Close any 
unnecessary 
windows and retry." 

The screen saver came 
on and interrupted 
Microsoft® DirectX. 

 Close the 3D view and reopen it. 

 Close and reopen the program and the 
project. 

 Update to the latest version of DirectX. 

Some of the 
selection sets I 
created do not 
appear in the View 
Filter Manager's 
selection sets list. 

The missing selection 
sets that do not contain 
any visible objects. 

None. Selection sets can contain objects 
that have no visible display, such as 
coordinates. In the Selection Explorer, all 
selection sets are available. In the View 
Filter Manager, however, only selection 
sets that contain at least one visible object 
are available. 

Your graphic views 
are pixilated or 
contain artifacts 
when you pan or 
rotate them. 

You are not using the 
optimal advanced 
display setting. 

Select Tools > Options. In the Options 
dialog, click Startup and Display in the left 
pane, and then click Advanced. Check the 
Override automatic detection box, and 
select the appropriate option for your 
operating system. 

Your mouse 
movements are 
delayed or track 
intermittently, even 
though you are 
using an advanced 
display setting (see 
above). 

Your graphics card is 
integrated into the 
motherboard, or is not 
sufficient for advanced 
display settings. 

Select Tools > Options. In the Options 
dialog, click Startup and Display in the left 
pane, and then click Advanced. Check the 
Override automatic detection box, and try 
each of these graphics display packages (in 
order, restarting the program between 
each): 

1. DirectX 

2. OpenGL 

3. GDI 

Your system suffers 
from generally poor 
graphics 
performance. 

Two system settings are 
not set to optimize the 
graphics display. 

Try the solution directly above first. If it 
does not improve your graphics 
performance, right-click on your Windows 
desktop, and select Properties from the 
context menu. In the Display Properties 
dialog, click the Settings tab, and select 
Medium (16 bit) in the Color quality list. 
Second, click the Advanced button in the 
same dialog. In the Plug and Play dialog, 
click the Troubleshoot tab, and set 
Hardware acceleration to Full. 
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Calculate and Enter Values 
This software incorporates interactive, graphical tools that you can use to calculate and 
enter values. 

They include: 

 COGO controls (see "Understanding COGO Controls" on page 86)  

 Running snap modes (see "Set Running Snap Modes" on page 89)  

 Snap commands (see "Use Snap Commands" on page 91)  

Use these tools to calculate and enter angles, bearings, coordinates, distances, 
elevations, and offsets in your project. After you have imported survey, map, or 
engineering data, start at a known point or object, and use these functions to create 
other points and lines in your project. 

COGO and snap tools are powerful because they enable you to enter data in consistent 
ways for a variety of commands.  

Understanding COGO Controls 
COGO controls are the boxes in various commands that help you calculate angles, 
bearings, coordinates, distances, elevations, and offsets in your project. They enable 
you to enter data in a variety of ways, including: 

 Typing values and point IDs in the box 

 Picking points in graphic views 

 Right-clicking in graphic views and selecting additional snap and COGO options 
from the context menu 

COGO controls give you this flexibility so that you have many ways in which you can 
enter data within a single command, rather than forcing you to work through multiple 
commands. 

Since COGO controls are used in many commands, once you understand how to use 
them, you will be able to apply your knowledge all to the commands that use them. 

COGO cursors 

Depending on the type of control you are in, the appearance of the cursor changes in 
graphic views. The name of the control also appears on the status bar, and the status 
line's tooltip tells how use the control. 
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Cursor types 

     

Pick any point. 

  

Pick any point or applicable object (arc, line, segment, point). 

  

Pick any applicable object. 

 

No anchor point has been defined. 

 

 

No anchor point has been defined. 

  

The pick function is unavailable, or the object you are trying to pick is 
invalid. Often, you can click a blank space in the Project Explorer or a 
command pane to refresh the cursor for the graphic views. 

Related topics 

 COGO Expressions, Units, and Entry Formats (on page 87) 
 Set the Pick Aperture (on page 88) 
 Snaps Modes and Commands (on page 89) 

 

COGO Expressions, Units, and Entry Formats 

Mathematical expressions 

You can enter numbers in many of the COGO controls. When a COGO control 
supports numeric entry, you can use basic mathematic expressions by including the 
operators as shown. The value is calculated when you leave the control. 
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Operator Example 

Addition 10+10 

Subtraction 10-2 

Multiplication 10*8 

Division 8/4 

Power 10^2 

Simple expressions 

(for distance, bearing, and coordinate 
controls) 

5*(6+8) 

052>054 (for distance or bearing between points) 

Exponential notation 

(for distance and coordinate controls) 

1.01E+6 

 

Separated formats 

(for distance and coordinate controls) 

1,000,000 = 1000000  

1.000.000 = 1000000 

Units and data entry formats 

The units, and entry and display formats, for data can be found and set in the Units (see 
"Unit Settings" on page 151) section of the Project Settings dialog. 

The current distance units, which are also used for the gridlines, display on the status 
bar. Distances that you enter are in these units. You can, however, enter other units in 
COGO controls by including a character for the type of unit. For example, if your 
project units are set to International foot, you can enter 3m in a COGO control to specify 
3 meters. The unit you enter will be converted to the project units. 

Entering point IDs 

If you enter a point ID for a single value, such as an elevation, type quotation marks 
around the point ID to distinguish it as the elevation of the point, not just an elevation 
value. For example, to use the elevation for point 1001, type "1001" in the control. In 
coordinate controls where you are entering a pair of coordinates, typing the point ID 
without quotes will suffice. The coordinates of the point are used. 

Related topics 

 Change Project Units (on page 152) 
 Unit Settings (on page 151) 

 

Set the Pick Aperture 
The pick aperture is the box appearing on certain cursors. It shows the area in which 
applicable objects can be picked. 
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To set the size of  the pick aperture: 

1. Select Tools > Options. The Options dialog displays. 

2. Click Startup and Display. 

3. Specify a value in the Pick aperture box. 

4. Click OK. 

Related topics 

 Startup and Display Options (on page 139) 
 

Snaps Modes and Commands 
Snaps use geometric calculations to help you specify and select coordinates and points 
more easily and accurately. Snaps can either use existing geometry or values that you 
enter during the command. There are two types of snap functions: 

Snaps 

Running snap modes These modes are similar to the snap commands, except that 
(when enabled) they are always active. The running snap 
modes establish the order of precedence for the point snap 
modes. They can be temporarily overridden by using a specific 
snap command.  

Note: Running snaps are available only for point (coordinate) 
snaps. There are no running snaps for angle, bearing, distance, 
offset, elevation, or station controls. 

Snap commands These commands enable you to enter angles, bearings, 
coordinates, distances, elevations, and offsets to calculate 
coordinates in your project. You can also select (or enter) 
applicable objects, such as breaklines, alignments, surfaces, 
and point IDs in snap commands. 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 Running Snap Mode Options (on page 90) 
 Set Running Snap Modes (on page 89) 
 Use Snap Commands (on page 91) 

 

Set Running Snap Modes 

Running snaps are frequently-used snaps that are constantly enabled ("running"), so 
that you do not have to initiate a specific snap command each time you need one. You 
can, however, specify which of the five running snap modes you want to be active at 
any time.  
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Note: If multiple snap modes are active, and you pick a point in a graphic view that 
satisfies multiple snaps, the snap closest to the center of the pick aperture prevails. 

When a snap is active, the cursor's appearance indicates the type of snap. For instance, 
when you are in a snap mode that lets you pick an object, the cursor displays with a 
pick aperture (box). If you are in free snap, the cursor displays with cross hairs. See 
COGO Controls (see "Understanding COGO Controls" on page 86) for more 
information. 

There is no visual feedback in graphic views when you snap to a point, but the 
coordinate of the point is entered into the control in which you are working.  

To set running snap modes: 

1. Do one of the following: 

 Click Snap on the status bar. 

 Select Project > Snap Mode.  

The Snap mode dialog displays. 

2. Check (or uncheck) boxes next to any of the modes you want to enable (or disable). 

Note: You need to have at least one snap mode enabled. Otherwise, you will not be 
able to pick anything in the graphic views. 

3. Click OK to close the dialog. 

Note: Running snap modes are superseded by snap commands. 

Related Topics 

 Running Snap Mode Options (on page 90) 
 

Running Snap Mode Options 

Use these options to set which frequently-used snaps are constantly enabled, so that 
you do not have to initiate a specific command each time you need a snap. They are 
available in the Snap Mode dialog. 
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Options 

Point If a point object is inside the pick aperture, the coordinate of the point 
will be used. 

End point If the end point of a line or arc segment is inside the pick aperture, the 
coordinate of the end point of will be used. 

Insertion point If any part of a text or block object is inside the pick aperture, the 
insertion point of the object will be used. 

This running snap mode is disabled by default. 
Surface vertex If a surface vertex is inside the pick aperture, the coordinate of the 

vertex will be used. 
Free The coordinate at the intersection of the cross hairs will be used.  This 

mode will be used if none of the other modes are satisfied or selected.   

If no other modes are active, the Free mode is active by default. 

Related topics 

 Set Running Snap Modes (on page 89) 
 

Use Snap Commands 

Snap commands use geometric calculations to help you specify coordinates more easily 
and accurately. Snaps can either calculate a snap point using existing geometry, or use 
parameters that you enter during a command. Snap commands, as opposed to running 
snaps, are single-instance snaps that you initiate each time you need one. They apply to 
the current command only.   

There is no visual feedback in graphic views when you calculate (snap) to a point, but 
the coordinate of the point is entered into the control in which you are working.  

To use a snap command: 

1. When you are in a COGO control (see "Understanding COGO Controls" on page 
86), move your cursor into a graphic view and right-click. A context menu displays 
snap command options, depending on the control you are using. 

2. Select one of the snap commands. The snap's command pane displays. 

3. Specify parameters for the snap. 

4. Click OK to return to the original COGO control. 

Note: Snap commands supersede running snap modes. 
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Stacked commands 

To help you calculate a certain value, you can "stack" multiple snap commands. This 
means that you can access one snap command from within another until you have 
several snap commands stacked upon one another in the command pane. To practice, 
work through the tutorial. 

Related Topics 

 Set Running Snap Modes (on page 89) 
 Snaps Modes and Commands (on page 89) 

 

Enter an Angle 
Use the Angle control to enter an angle by specifying a bearing in relation to the 
default bearing. The default bearing (and zero angle) is east. Positive angles are 
measured counter-clockwise from 0 to <360 degrees. "Angle" appears on the status bar 
when the command is active. 

Angle controls are used in these snap commands: 

 Bearing + Angle Snap (on page 96) 

Angle controls give you access to these snap commands on the context menu: 

 Deflection Angle Snap (on page 92) 

 Three Point Snap (on page 93) 

To specify an angle: 

 Pick an anchor point in a graphic view. With the cursor "rubber-banding" from the 
default bearing, pick another point to specify the angle. 

 Type a value in the Angle box, using one of the standard entry formats. Check and 
set the entry format in Project Settings by selecting Project > Project Settings > 
Units > Angular. 

 Right-click in a graphic view, select a snap command from the context menu, and 
specify the necessary parameters. 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Deflection Angle Snap 

Use this command to calculate an angle between two bearings. 

Deflection Angle Snap can be used in these controls: 
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 Angle (see "Enter an Angle" on page 92) 

 

To use a Deflection Angle Snap: 

1. While in an angle control, right-click in a graphic view, and select Deflection Angle 
Snap from the context menu. The Deflection Angle Snap command pane displays. 

2. Pick two points or a line in the view, or type a value in the Bearing 1 box. 

3. Pick two more points or another line in the view, or type a value in the Bearing 2 
box. The angle between the bearings is recorded, and the command pane returns to 
the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Three Point Snap 

Use this command to calculate an angle based on three points picked in sequence. 

Three Point Snap can be accessed from these control context menus: 
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 Angle (see "Enter an Angle" on page 92) 

 

To use a Three Point Snap: 

1. While in an angle control, right-click in a graphic view, and select Three Point Snap 
from the context menu. The Three Point Snap command pane displays. 

2. Select an angle type (Acute or Obtuse) in the Options list.  

3. Pick a point, or type a coordinate or Point ID in the Start point box. 

4. Pick a second point, or type a coordinate or Point ID in the Pivot point box. 

5. Pick a third point, or type a coordinate or Point ID in the End point box to specify 
the angle. 

6. The angle between the three points is recorded, and the command pane returns to 
the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Enter a Bearing 
Use the Bearing control to specify an azimuthal bearing. The default bearing (and zero 
angle) is north. Positive bearings are measured clockwise. "Bearing" appears on the 
status bar when the command is active. 

Bearing control is used in these snap commands: 
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 Bearing Bearing Snap (on page 99) 

 Bearing Distance Snap (on page 100)  

 Bearing + Angle Snap (on page 96) 

Bearing control gives you access to these snap commands on the context menu: 

 Bearing + Angle Snap (on page 96) 

 Point to Point Bearing Snap (on page 97) 

To specify a bearing: 

 Pick an anchor point in a graphic view. With the cursor "rubber-banding" from the 
default bearing, pick another point to specify the bearing. 

 Pick a line segment in a graphic view. The bearing of the segment is used. Each line 
segment has two bearings, so pick a point on the line segment close to the end to 
which you want to the bearing to travel. If you pick an arc segment, the bearing 
tangent to the segment at that point will be computed. If you pick a text object, the 
bearing at which the text object is located is used. This allows you to use the 
bearing control to align text objects with other text objects.  

 Type a value in the Bearing box, using one of the standard entry formats. Check and 
set the entry format in Project Settings by selecting Project > Project Settings > 
Units > Azimuth. 

 Type a point ID to point ID notation (e.g. 1>2) in the Bearing box, to recall the 
bearing between the points. 

 Right-click in a graphic view, select a snap command from the context menu, and 
specify the necessary parameters. 

Horizontal Angle Modes 

You can also enter bearings using a prefix or suffix code for the angle mode. For 
example, for a 90 degree, 15 minute, and 2 second angle from the north azimuth, type: 
NA901502 or 901502NA. 

The codes below are supported. 

Code Descript ion 

NA North Azimuth 

 
SA 

South Azimuth 

AR Angle Right 

AL Angle Left  

 
DR 

Deflection Right 
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DL 

Deflection Left 

NE Northeast 

SE Southeast 

SW Southwest 

 
NW 

Northwest 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Bearing + Angle Snap 

Use this command to calculate a bearing by adding an angle to a given bearing. 

Bearing + Angle Snap can be used in these controls: 

 Bearing (see "Enter a Bearing" on page 94) 

 

To use a Bearing Plus Angle Snap: 

1. While in a bearing control, right-click in a graphic view, and select Bearing + Angle 
Snap from the context menu. The Bearing + Angle Snap command pane displays. 

2. Pick two points in the view, or type a value in the Bearing box. 

3. Pick two more points, or type a value in the Angle box. The bearing is recorded, and 
the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
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 Snaps Modes and Commands (on page 89) 
 

Point to Point Bearing Snap 

Use this command to compute the bearing from one point to another point. 

Point to Point Bearing Snap can be used in these controls: 

 Bearing (see "Enter a Bearing" on page 94) 

To use a Point to Point Bearing Snap: 

1. While in a bearing control, right-click in a graphic view, and select Point to Point 
Snap from the context menu. The Point to Point Snap command pane displays. 

2. Pick a point in the view, or type a coordinate or Point ID in the Reference point 1 
box. 

3. Pick a point, or type a coordinate or Point ID in the Reference point 2 box. The 
bearing is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Enter a Coordinate 
Use the Coordinate control to specify X, Y, and Z, or latitude, longitude, and elevation 
coordinates of a point. If a Z or elevation coordinate is entered in the coordinate 
control, and there is also an elevation control for the same point, the value will be 
placed in the elevation control. "Coordinate" appears on the status bar when the 
command is active.  
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To specify a coordinate: 

 Pick a point in a graphic view. If no running snap modes are enabled, the default 
operation does not specify a Z coordinate. If running snaps are enabled, the cursor 
will potentially snap to a location and use its Z value based on the snap mode. 

 Type a point ID in the coordinate box using any of the standard entry formats. If 
there are multiple points with the same ID, then the one with the best quality is 
used. Check and set the entry format in the Project Settings by selecting Project > 
Project Settings > Units > Coordinate.  

Note: If you enter a point ID for a single value, such as an elevation, type quotation 
marks around the point ID to distinguish it as the elevation of the point, not just an 
elevation value. For example, to use the elevation for point 1001, type "1001" in 
the control. In coordinate controls where you are entering a pair of coordinates, 
typing the point ID without quotes will suffice. The coordinates of the point are 
used. 

 Type two or three numbers separated by a space or comma to specify a coordinate 
pair or triplet, in the format N, E, (Z). The separator is user-definable in the Project 
Settings. Typically, spaces or commas are used to specify coordinate pairs or 
triplets. 

Examples:   27,42, (1) 

                  27 42 1 

                  27,42 

                  27 42 

In the plan view, these normally represent N, E, (Z). In the profile view these normally 
represent station and elevation. The control honors the ordering of the X and Y values 
as specified for the current view.  

Although you will usually be entering grid based coordinates, you can also enter 
latitude and longitude coordinates in the format Latitude, Longitude, (Z). To do this, a 
coordinate system must be defined for the project. Do not use spaces to separate the 
coordinates because spaces are used to separate the angle components.  

Examples:   N40°35’18.12345”, E120°23”12.32145”, 1000 

                  N40 35 18.12345, E120 23 12.32145, 1000 

                  N40 35 18.12345, E120 23 12.32145 
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To specify a relative coordinate:  

 Type an @ before a value to specify a relative distance from a previous point (when 
the cursor has an anchor point). The @ symbol must be used before each relative 
coordinate, but you can enter both relative and absolute coordinates in the same 
control. The relative distance separator is user-definable in the Project Settings, but 
typically, @ is used as shown. 

Examples:   @27,@42 

                  @27 @42 

In any view with a vertical exaggeration you can substitute a grade (G) for the 
elevation when setting a point relative to a previous point. This can be used in 
conjunction with a relative (@S) station value. Valid entries for grade are: (%, or P) for 
percent of grade and (:, or R) for ratio grade, e.g. 2:1.  

Examples:   @500,2% 

                  @500 2P 

In any view with a vertical exaggeration, you can substitute a Maximum (M) depth for 
the station and grade (G) for the elevation when setting a point relative to a previous 
point. The maximum depth will be the change in depth (elevation) from the previous 
point. Valid entries for grade are: (%, or P) for per cent of grade and (:, or R) for ratio 
grade, e.g. 2:1. This type of entry is typically used in defining templates used with 
roads.  

Examples:   5,2% 

                  5 2% 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Bearing Bearing Snap 

Use this command to calculate the intersection of two bearings defined by a first point 
and second point. No elevation (Z value) is set using this option. This snap is helpful in 
calculating the coordinates of a location that cannot be occupied, such as the center of a 
tree. 

Bearing Bearing Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Bearing Bearing Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Bearing 
Bearing Snap from the context menu. The Bearing-Bearing Snap command pane 
displays. 

2. Pick a point in the view, or type a coordinate or point ID in the Reference point 1 
box. 

3. Pick a second point, or type a value in the Bearing 1 box. 

4. Pick a point, or type a coordinate or point ID in the Reference point 2 box. 

5. Pick a second point, or type a value in the Bearing 2 box, to specify the bearing. The 
coordinate is calculated at the intersection of Bearing 1 and Bearing 2, and the 
command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Bearing Distance Snap 

Use this command to calculate a point based on a beginning point, a bearing, and a 
distance. The zero (0) bearing is north, and bearings are measured clockwise. No 
elevation (Z value) is set using this option. 

Bearing Distance Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Bearing Distance Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Bearing 
Distance Snap from the context menu. The Bearing Distance Snap command pane 
displays. 

2. Pick a point in the view, or type a coordinate or point ID in the Reference point box. 

3. Pick a second point, or type a value in the Bearing box. 

4. Pick a third point, or type a value in the Distance box. The coordinate is recorded, 
and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Center of Arc Snap 

Use this snap command to calculate the center point of an arc (or parabolic curve 
segment or spiral curve segment) when you select the arc. The elevation of the arc is 
used as the Z value. 

Center of Arc Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Center of Arc Snap: 

1. Right-click in a graphic view, and select Center of Arc Snap from the context menu. 
The Center of Arc Snap command pane displays. 

2. In the view, pick an arc. The coordinate is recorded, and the command pane 
returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Center of Gravity Snap 

Use this command to calculate a point based on the area within a closed line. If the line 
segment picked has an elevation, the Z value of the segment is used. 

Center of Gravity Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 
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To use a Center of Gravity Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Center of 
Gravity Snap from the context menu. The Center of Gravity Snap command pane 
displays. 

2. Pick a segment of a closed line in the view. The coordinate at the center of the area 
is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Distance Distance Snap 

Use this command to calculate a point based on radial distances from two reference 
points, selecting one of the two points where the resulting arcs intersect. 

Distance Distance Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use a Distance Distance Snap: 

1. While in a coordinate control, right-click in a graphics view, and select Distance 
Distance Snap from the context menu. The Distance Distance command pane 
displays. 

2. Pick a point in the view, or type a coordinate or point ID in the Center point 1 box. 

3. Pick a second point, or type a value in the Distance 1 box. 

4. Pick a point, or type a coordinate or point ID in the Center point 2 box. 

5. Pick a second point, or type a value in the Distance 2 box. 

6. Select one of the intersecting points by picking a side in the view, or by selecting 
an option in the Side list. The coordinate is recorded, and the command pane 
returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Delta X Delta Y Snap 

Use this command to calculate a point using a relative X and Y distance from a 
reference point. The elevation of the origin point is used as the Z value.  

DxDy Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a DxDy Snap: 

1. While in a coordinate control, right-click in a graphic view, and select DxDy Snap 
from the context menu. The DxDy Snap command pane displays. 

2. Pick a point in the view, or type a coordinate or point ID in the Reference point  
box. 

3. Pick a second point, or type a distance from the reference point in the Easting 
Distance box.  

4. Pick a third point, or type a distance from the reference point in the Northing 
Distance box. The coordinate is recorded, and the command pane returns to the 
previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

End Snap 

Use this command to calculate the point at the end of a line segment closest to where 
you pick on the line segment. The elevation of the end point is used. 

End Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use an End Snap: 

1. While in a coordinate control, right-click in a graphic view and select End Snap 
from the context menu. The End Snap command pane displays. 

2. Pick a line segment near the end to which you want to snap. The coordinate at the 
end of the line segment is recorded, and the command pane returns to the previous 
command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Factor of Line Snap 

Use this command to calculate a point at a factored distance along a line. You can enter 
any multiplication factor greater than zero (for example, 0.5 = 50% from the end of the 
line). If the line has a slope, the Z value is interpolated. 

Factor of Line Snap can be used in these commands: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Factor of Line Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Factor > 
Factor of Line Snap from the context menu. The Factor of Line Snap command pane 
displays. 

2. Pick a line near the end from which you want to factor the distance. The line is 
recorded in the Line box.  

3. Type a factor in the Multiplication Factor box.  

4. Click OK. The coordinate is recorded, and the command pane returns to the 
previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Factor of Segment Snap 

Use this command to calculate a point at a factored distance along a line segment. You 
can enter any multiplication factor greater than zero (for example, 0.5 = 50% from the 
end of the line). Zero (0) snaps to the end of the line closest to where you pick, and 1 
snaps to the furthest end of the line. If the line has a slope, the Z value is interpolated. 

Factor of Segment Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Factor of Segment Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Factor > 
Factor of Segment Snap from the context menu. The Factor of Segment Snap 
command pane displays. 

2. Pick a line segment near the end from which you want to factor the distance. The 
segment is recorded in the Segment box.  

3. Type a factor in the Multiplication Factor box.  

4. Click OK. The coordinate is calculated, and the command pane returns to the 
previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Free Snap 

Use this command to use the coordinates of any point picked in a view. No elevation is 
set using this option. 

Free Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Free Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Free Snap 
from the context menu. The Free Snap command pane displays. 

2. Pick a point, or type a coordinate or point ID in the Free Point box. The command 
pane returns to the previous command. 

Note: Free Snap is one of the default running snap modes, so unless you have it 
disabled in the Snap Mode dialog, you don't need to explicitly select Free Snap from 
the context menu. Use this option when you have multiple running snaps active 
and you don't want to snap to a point, end point, etc. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Intersection of Lines Snap 

Use this command to calculate the intersection (or projected intersection) of two lines.  
If there are several possible intersections, the intersection closest to where the lines 
were picked is used. No elevation is set using this option. 

Intersection of Lines Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use an Intersection of Lines Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Intersection 
> Intersection of Lines Snap from the context menu. The Intersection of Lines Snap 
command pane displays. 

2. Pick a line in the view. The line is recorded in the Line 1 box. 
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3. Pick another line. The line is recorded in the Line 2 box. The coordinate is 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Intersection of Offset Segments Snap 

Use this command to calculate the intersection of offsets from two selected line or arc 
segments. From the end of the segment closest to where it was picked, looking to the 
other end, positive offsets are to the right and negative offsets are to the left of the 
segment. 

Intersection of Offset Segments Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use an Intersection of Offset Segments Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Intersection 
> Intersection of Offset Segments Snap from the context menu. The Intersection of 
Offset Segments Snap command pane displays. 

2. Pick a line or arc segment in the view. The segment is recorded in the Line segment 
1 box.  

3. Pick a point offset from the line, or type a value in the Offset 1 box. For the offsets, 
you can enter a negative or positive offset distance from the line. 

4. Pick a second line or arc segment. The segment is recorded in the Line segment 2 
box.  

5. Pick a point offset from the second line, or type a value in the Offset 2 box. You can 
enter a negative or positive offset distance from the line. The coordinate is 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Intersection of Offset Lines Snap 

Use this command to calculate the intersection of offsets from two lines or arcs. The 
offsets are projected from the entire lines or arcs, rather than just line or arc segments. 
From the end of the line closest to where it was picked, looking to the other end, 
positive offsets are to the right and negative offsets are to the left of the line. 
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You can also calculate the intersection of offsets from two horizontal alignments 
(HALs). 

Intersection of Offset Lines Snap is used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use an Intersection of Offset Lines Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Intersection 
> Intersection of Offset Lines Snap from the context menu. The Intersection of Offset 
Segments Snap command pane displays. 

2. Pick a line in the view. The line is recorded in the Line 1 box.  

3. Pick a point offset from the line, or type a value in the Offset 1 box. For the offsets, 
you can enter a negative or positive offset distance from the line. 

4. Pick a second line. The line is recorded in the Line 2 box.  

5. Pick a point offset from the second line, or type a value in the Offset 2 box. The 
coordinate is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Intersection of Segments Snap 

Use this command to calculate the projected intersection of two line or arc segments. If 
there are several possible intersections, the intersection closest to where the lines were 
picked is used. 

Intersection of Segments Snap can be used in these commands: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use an Intersection of Segments Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Intersection 
> Intersection of Segments Snap from the context menu. The Intersection of Segments 
Snap command pane displays. 

2. Pick a line segment in the view. The segment is recorded in the Line segment 1 box. 

3. In the view, pick another line segment. The segment is recorded in the Line 
segment 2 box. The coordinate is recorded, and the command pane returns to the 
previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Middle of Point to Point Snap 

Use this command to calculate the midpoint between two points. 

Middle of Point to Point Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use a Middle of  Point to Point Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Middle of 
Point to Point Snap from the context menu. The Middle of Point to Point Snap 
command pane displays. 

2. Pick a point in the view, or type a coordinate or point ID in the From point box. 
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3. Pick a point, or type a coordinate or point ID in the To point box. The midpoint 
between the two selected points is recorded, and the command pane returns to the 
previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Middle of Segment Snap 

Use this command to calculate the middle point of a line or arc segment. If the line 
segment has a slope, the Z value is interpolated from the segment. 

Middle of Segment Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Middle of Segment Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Middle of  
Segment Snap from the context menu. The Middle of Segment Snap command pane 
displays. 

2. Pick a line segment in the view. The coordinate is recorded, and the command 
pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 
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Nearest to Line Snap 

Use this command to calculate the closest point on a line within the pick aperture to 
the point you pick. If the point is on a line with a slope, the elevation value is 
interpolated. 

Nearest to Line Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Nearest to Line Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Nearest to 
Line Snap from the context menu. The Nearest to Line Snap command pane displays. 

2. Pick a line in the view. The coordinates on the line nearest to your pick location 
are recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Offset Line Snap 

Use this snap command to calculate a point based on an offset from a station along the 
entire length of a line or an arc. Station zero is the end of the line closest to where it 
was picked. From station zero, looking down the line, positive offsets are to the right 
and negative offsets are to the left of the line. If the line has a sloping elevation, the Z 
value is interpolated from the station used. 

Note: You can use this option to select a specific position along an arc by making the 
offset distance zero. 
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Offset Line Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use an Offset Line Snap: 

1. While in a coordinate control, right-click in a graphics view, and select Offset > 
Offset Line Snap from the context menu. The Offset Line Snap command pane 
displays. 

2. Pick a line in the view. The line is recorded in the Line box.  

3. Pick a point, or type a value in the Station box.  

4. Pick a point, or type a value in the Offset box. You can enter a negative or positive 
offset distance from the line. The coordinate is recorded, and the command pane 
returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Offset Segment Snap 

Use this command to calculate a point based on an offset from a station along a line or 
arc segment. Station zero is the end of the line closest to where it was picked. From 
station zero, looking down the line, positive offsets are to the right and negative offsets 
are to the left of the segment. 

Offset Segment Snap can be used in these controls: 

Coordinate (see "Enter a Coordinate" on page 97) 

To use an Offset Segment Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Offset > 
Offset Segment Snap from the context menu. The Offset Segment Snap command 
pane displays. 

2. Pick a line or arc segment in the view. The segment is recorded in the Line segment 
box. 

3. Pick a point, or type a value in the Station box. You can enter a negative or positive 
offset distance from the segment. 

4. Type a value in the Offset box. The coordinate is calculated, and the command pane 
returns to the previous command. 

Tip: You can use this option to select a specific position along an arc by making the 
offset distance zero (0). 



Trimble® Business Center 
Heavy Construction Edition User Guide 115 

 Calculate and Enter Values

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Perpendicular to Segment Snap 

Use this command to calculate a perpendicular intersection from a point to a line 
segment or arc segment. If the line segment has an elevation, the Z value will be 
interpolated from the segment. 

Perpendicular to Segment Snap can be used in these controls: 

 Coordinate (see "Enter a Coordinate" on page 97) 

To use a Perpendicular to a Segment Snap: 

1. While in a coordinate control, right-click in a graphic view, and select 
Perpendicular > Perpendicular to Segment Snap from the context menu. The 
Perpendicular to Segment Snap command pane displays. 

2. Pick a line segment in the view. The line is recorded in the Line segment box. 

3. Pick a point or type a coordinate in the Reference point box. The coordinate is 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Perpendicular to Line Snap 

Use this command to calculate a perpendicular intersection from a point to a line or 
arc. The entire length of the line or arc is used in the calculation. You can also calculate 
a perpendicular intersection of a point to a horizontal alignment (HAL). 

Perpendicular to Line Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Perpendicular to Line Snap: 

1. While in a coordinate control, right-click in a graphic view, and select 
Perpendicular > Perpendicular to Line Snap from the context menu. The Perpendicular 
to Line Snap command pane displays. 

2. Pick a line or a HAL in the view. The line or HAL is recorded in the Line box. 

3. Pick a point, or type a coordinate in the Reference point box. The coordinate is 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Point of Intersection Snap 

Use this command to calculate the point of intersection (PI) of a selected arc, spiral, or 
parabola. No elevation is set using this option. 

Point of Intersection Snap can be used in these commands: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Point of Intersection Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Point of 
Intersection Snap from the context menu. The Point of Intersection Snap command 
pane displays. 

2. Pick a spiral, arc, or parabola in the view. The intersection coordinates are 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Point Snap 

Use this command to specify the coordinates of a point ID. The elevation of the point is 
used as the Z value. 

Point Snap can be used in these controls: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Point Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Point Snap 
from the context menu. The Point Snap command pane displays. 

2. Pick a point in the view, or type a point name in the Point ID box. The coordinates 
are recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Tangent Snap 

Use this command to calculate a point on an arc tangent to a previous point. No 
elevation is set using this option. 

Tangent Snap can be used in these commands: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use a Tangent Snap: 

1. While in a coordinate control, right-click in a graphic view, and select Tangent 
Snap from the context menu. The Tangent Snap command pane displays. 

2. Pick a point, or type a coordinate or point ID in the Reference Point box.  

3. Pick an arc. The coordinates on the arc tangent to the reference point are recorded, 
and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

XY Snap 

Use this command to calculate a point based on the easting (Y-coordinate) of the first 
point you pick, and then to the northing (X-coordinate) of the second point you pick. If 
the second point has an elevation, it will be used for the Z value. 

XY Snap can be used in these commands: 
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 Coordinate (see "Enter a Coordinate" on page 97) 

 

To use an XY Snap: 

1. While in a coordinate control, right-click in a graphic view, and select XY Snap 
from the context menu. The XY Snap command pane displays. 

2. Pick a point, or type a coordinate or point ID in the Easting of point box. 

3. Pick a point, or type a coordinate or point ID in the Northing of point box.  The 
coordinate is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Enter a Distance 
Use the Distance control to specify a distance. Typically, this is a horizontal distance. 
When calculating 3D points, the horizontal distance can also be a slope distance (SD) 
and you will be alerted as such. "Distance" appears in the status bar when this control is 
active. 

Distance control is used in these commands: 

 Bearing Distance Snap (on page 100) 

 Distance Distance Snap (on page 103) 

 DxDy Snap (see "Delta X Delta Y Snap" on page 103) 

 Distance + Distance Snap (see "Distance + Distance Snap (distance)" on page 121) 

 Factor of Distance Snap (see "Factor of Distance Snap (distance)" on page 122) 

Distance control gives you access to these commands on the context menu: 
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 Distance + Distance Snap (see "Distance + Distance Snap (distance)" on page 121) 

 Factor of Distance Snap (see "Factor of Distance Snap (distance)" on page 122) 

 Point to Point Snap (see "Point to Point Snap (distance)" on page 123) 

 Radius of Arc Snap (see "Radius of Arc Snap (distance)" on page 124) 

To specify a distance: 

 Pick a point in a graphic view. With the cursor "rubber-banding", pick another 
point to specify the distance. 

 Pick a line or line segment; the length of the segment will be used as the distance. 

 Type a value in the Distance box to specify the horizontal distance or slope distance 
(SD), using any of the standard entry formats. Check and set the entry format in 
the Project Settings by selecting Project > Project Settings > Units > Distance. 

Note:   When specifying a distance and slope from a point in the profile view, the 
distance is always horizontal. 

 Type a point ID to point ID (e.g. 1>2), to recall the distance between two points. 

 Type a distance using mathematical operators or an  expression to calculate the 
distance. The valid operators are + - * / and () for expressions. 

 Right-click in a graphic view, select a snap command from the context menu, and 
specify the necessary parameters. 

Note:  In commands where the direction is not determined, the cursor will "rubber 
band" as a circle. The center point is the anchor point , and the circle is drawn through 
the second point. 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Distance + Distance Snap (distance) 

Use this command to calculate a distance by adding two distances. Either distance can 
be negative. 

Distance + Distance Snap can be used in these controls: 
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 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Distance + Distance Snap: 

1. While in a distance or offset control, right-click in a graphic view, and select 
Distance + Distance Snap from the context menu. The Distance + Distance Snap 
command pane displays. 

2. Pick two points or a line segment, or type a value in the Distance 1 box. 

3. Pick two more points or a line segment, or type a value in the Distance 2 box. The 
distance is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Factor of Distance Snap (distance) 

Use this command to calculate a distance by applying a multiplication factor to a 
distance. 

Factor of Distance Snap can be used in these controls: 
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 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Distance Factor Snap: 

1. While in a distance or offset control, right-click in a graphic view, and select Factor 
of Distance Snap from the context menu. The Factor of Distance Snap command pane 
displays. 

2. Pick two points, or a line segment in the view, or type a value in the Distance box. 

3. Type a factor value greater than zero (>0) in the Multiplication Factor box. For 
example, type 2 for 200% of the distance. 

4. Click OK. The distance is recorded, and the command pane returns to the previous 
command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Point to Point Snap (distance) 

Use this command to calculate the distance between two points. 

Point to Point Snap can be used in these controls: 
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 Bearing (see "Enter a Bearing" on page 94) 

 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Point to Point Snap: 

1. While in a distance control, right-click in a graphic view, and select Point to Point 
Snap from the context menu. The Point to Point Snap command pane displays. 

2. Pick a point in the view, or type a coordinate or point ID in the From point box. 

3. Pick a point, or type a coordinate or point ID in the To point box. The distance is 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Radius of Arc Snap (distance) 

Use this command to calculate a distance based on the radius of an arc. 

Radius of Arc Snap can be used in these controls: 
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 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Radius of Arc Snap: 

1. While in a distance or offset control, right-click in a graphic view, and select 
Radius of Arc Snap from the context menu. The Radius of Arc Snap command pane 
displays. 

2. Pick an arc in the view. The arc's radius is recorded, and the command pane 
returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Enter an Elevation 
Use the Elevation control to specify an elevation. You can snap to any 3d object to 
specify the elevation. "Elevation" appears in the status bar when the control is active. 

Elevation control gives you access to these commands on the context menu: 
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 Elevation Undefined Snap (see "Undefined Snap" on page 126) 

 From Surface Snap (on page 126) 

To specify an elevation: 

 Pick an object in a graphic view to use its elevation. If you pick a line, the elevation 
will be interpolated along the slope of the line, based on the position you pick. 

 Type a value or a point ID in the Elevation box. 

 Right-click in a graphic view, select a snap command from the context menu, and 
specify the necessary parameters. 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Undefined Snap 

Use this command to specify that the elevation is undefined. Use it when no elevation 
is required. 

Undefined Snap can be used in these controls: 

 Elevation (see "Enter an Elevation" on page 125) 

To use an Undefined Snap: 

1. While in an elevation control, right-click in a graphic view, and select Undefined 
Snap from the context menu. The Elevation box is filled with a ? to show that the 
elevation is valid as undefined. 

2. Click OK, if necessary. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

From Surface Snap 

Use this command to calculate the elevation of a point on a 3D surface. The elevation 
of the X,Y position on the surface will be used as the Z value. 

From Surface Snap can be used in these controls: 
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 Elevation (see "Enter an Elevation" on page 125) 

To use a From Surface Snap: 

1. While in an elevation control, right-click in a graphics view, and select Point to 
Point Snap from the context menu. The Point to Point Snap command pane displays. 

2. Pick a surface in the view, or select one from the Surface list. 

1. Pick a point on the selected surface, or type a coordinate in the Point box. The 
elevation at that point on the surface is recorded, and the command pane returns to 
the previous command, if necessary. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

At Point Snap 

Use this command to specify an elevation using the elevation of a named point . 

At Point Snap can be used in these controls: 

 Elevation (see "Enter an Elevation" on page 125) 

 

To use an At Point Snap: 

1. While in an elevation control, right-click in a graphic view, and select At Point Snap 
from the context menu. The At Point Snap command pane displays.  

2. Pick a named point in the view, or type a point ID in the Point box. The elevation of 
the point is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
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 Snaps Modes and Commands (on page 89) 
 

Along Line Snap 

Use this command to specify an elevation using the elevation at a location along a 3D 
line. 

 
Along Line Snap can be used in this control: 

 Elevation (see "Enter an Elevation" on page 125) 

To use an Along Line Snap: 

1. While in an elevation control, right-click in a graphic view, and select Along Line 
Snap from the context menu. The Along Line Snap command pane displays. 

2. Pick a 3D line in the view. A "rubber-band" line appears between your cursor and 
the line. 

3. Using the rubber-band line, pick a point along the line, or type a distance from the 
beginning point of the line (in station format) in the Distance Along box. The 
elevation at that location is recorded, and the command pane returns to the 
previous command, if necessary. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Enter an Offset 
Use the Offset control to specify an offset from a given line. "Offset" appears on the 
status bar when the control is active. 

Offset control is used in these commands: 
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 Offset Line Snap (on page 113) 

 Offset Segment Snap (on page 114) 

Offset control gives you access to these commands on the context menu: 

 Distance + Distance Snap (see "Distance + Distance Snap (distance)" on page 121) 

 Distance Snap (on page 130) 

 Factor of Distance Snap (see "Factor of Distance Snap (distance)" on page 122) 

 Point ID Snap (see "Offset at Point Snap" on page 132) 

 Point to Point Snap (see "Point to Point Snap (distance)" on page 123) 

 Radius of Arc Snap (see "Radius of Arc Snap (distance)" on page 124) 

To specify an offset: 

 Pick a point in a graphic view to define the coordinate through which the offset 
will pass. The control uses the perpendicular distance from the line to the specified 
position to calculate the offset distance. 

 Type a distance value in the Offset box. From the end of the line closest to where it 
was picked, looking to the other end, positive offsets are to the right and negative 
offsets are to the left of the line. 

 Right-click in a graphic view, select a snap command from the context menu, and 
specify the necessary parameters. The At Point Snap command gives you the ability 
to use any of the point snap modes to specify the offset distance from a specific 
point to the line. 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Distance + Distance Snap (offset) 

Use this command to calculate an offset by adding two distances. Either distance can be 
negative. 

Distance + Distance Snap can be used in these controls: 
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 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Distance Plus Distance Snap: 

1. While in a distance or offset control, right-click in a graphic view, and select 
Distance + Distance Snap from the context menu. The Distance + Distance Snap 
command pane displays. 

2. Pick two points or a line segment, or type a value in the Distance 1 box. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

1. Pick two more points or a line segment, or type a value in the Distance 2 box. The 
total distance is recorded, and the command pane returns to the previous 
command. 

 

Distance Snap 

Use this command to calculate an offset based on the distance between two points, or 
based on the length of a line segment.. 

Distance Snap can be used in these controls: 

 Offset (see "Enter an Offset" on page 128) 

To use a Distance Snap: 

1. While in an offset control, right-click in a graphic view, and select Distance Snap 
from the context menu. The Distance Snap command pane displays. 
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2. Pick two points or a line segment in the view, or type a value in the Distance box. 
The distance or length of the line segment is recorded. 

3. Click OK. The command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Factor of Distance Snap (offset) 

Use this command to calculate an offset by applying a multiplication factor to a 
distance. 

Factor of Distance Snap can be used in these controls: 

 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Factor of Distance Snap: 

1. While in a distance or offset control, right-click in a graphic view, and select Factor 
of Distance Snap from the context menu. The Factor of Distance Snap command pane 
displays. 

2. Pick two points or a line segment in the view, or type a value in the Distance box. 

3. Type a factor value greater than zero (>0) in the Multiplication Factor box. For 
example, type 2 for 200% of the distance. 

4. Click OK. The offset distance is recorded, and the command pane returns to the 
previous command. 
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Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Offset at Point Snap 

Use this command to specify an offset from a line by picking a point at a distance away 
from the line. 

Offset at Point Snap is used in these controls: 

 Offset (see "Enter an Offset" on page 128) 

To use an Offset at Point Snap: 

1. While in an offset control, right-click in a graphic view, and select Offset at Point 
Snap from the context menu. The Offset at Point command pane displays. 

2. Pick a point in the view, or type a point ID or coordinate in the Point box using one 
of the standard formats. The command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Point to Point Snap (offset) 

Use this command to compute the offset between one point and another point. 

Point to Point Snap can be used in these controls: 

 Offset (see "Enter an Offset" on page 128) 

To use a Point to Point Snap: 

1. While in an offset control, right-click in a graphic view, and select Point to Point 
Snap from the context menu. The Point to Point Snap command pane displays. 

2. Pick a point in the view, or type a coordinate or Point ID in the From point box. 

3. Pick a point, or type a coordinate in the To point 2 box. The offset distance is 
recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 
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Radius of Arc Snap (offset) 

Use this command to calculate an offset based on the radius of an arc. 

Radius of Arc Snap can be used in these controls: 

 Distance (see "Enter a Distance" on page 120) 

 Offset (see "Enter an Offset" on page 128) 

 

To use a Radius of Arc Snap: 

1. While in a control, right-click in a graphic view, and select Radius of Arc Snap from 
the context menu. The Radius of Arc Snap command pane displays. 

2. Pick an arc in the view. The arc's radius is recorded, and the command pane 
returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Enter a Station 
Use the Station control to specify a station on a selected alignment. The station is 
calculated from the specified point to a perpendicular point on the alignment. "Station" 
appears on the status bar when the control is active. 

Station control is used in these commands: 

 Offset Line Snap (on page 113) 

 Offset Segment Snap (on page 114) 

Station control gives you access to this command on the context menu: 
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 Station at Point Snap (on page 134) 

 Station From Line Snap (on page 135) 

To specify a station: 

 Pick a point along an alignment in a graphic view. 

Note: When the station control is active the cursor will "rubber-band" from a 
horizontal alignment (HAL). 

 Type a value in the Station box, using any of the standard entry formats. Check and 
set the entry format in the Project Settings by selecting Project > Project Settings 
> Units > Station. 

If you have defined an alignment and station equations, you can enter the station 
and segment. If there is more than one roadway that uses the alignment, only the 
first one found is used. An alignment with two station equations has three 
segments: one before the first equation, one between the two equations and one 
after the second equation. To define the station and segment enter 
"(station):(segment)" e.g., 14000:3. If no segment is specified, the first segment 
containing the specified station will be used. You can also specify an absolute 
distance along an alignment, regardless of station equations or beginning station, 
by typing zero (0) for the segment number, e.g., 14000:0. 

 Right-click in a graphic view, select a snap command from the context menu, and 
specify the necessary parameters. 

Related topics 

 COGO Controls (see "Understanding COGO Controls" on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Station at Point Snap 

Use this command to calculate a station based on a point. You must pick the point in a 
profile view. 

Station at Point Snap is used in these controls: 

 Station (see "Enter a Station" on page 133) 

To use a Station at Point Snap: 

1. While in a station control, right-click in a graphic view, and select Station at Point 
Snap from the context menu. The Station at Point Snap command pane displays. 

2. Pick a point in a profile view, or type a coordinate or point ID in the Point box. The 
coordinate or point ID is recorded, and the command pane returns to the previous 
command. 
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Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Station from Line Snap 

Use this command to calculate a station value from a point perpendicular to an 
alignment or line. 

Station from Line Snap is used in these controls: 

 Station (see "Enter a Station" on page 133) 

To use a Station from Line Snap: 

1. While in a station control, right-click in a graphic view, and select Station from Line 
Snap from the context menu. The Station from Line Snap command pane displays. 

2. Pick a line in a graphic view.  

3. Pick a point along the line, or type a value in the Station box, to specify a station. 
The station is recorded, and the command pane returns to the previous command. 

Related topics 

 Understanding COGO Controls (on page 86) 
 COGO Expressions, Units, and Entry Formats (on page 87) 
 Snaps Modes and Commands (on page 89) 

 

Measure Values Between Points 
Calculate and report values between points in your project.  

 In the plan view, the command measures bearing and distance.  

 In the profile view, it measures the delta station, slope, and slope distance.  

 In the cross-section and surface slicer views, it measures delta offset, slope, and 
slope distance. 

To measure values between two points:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Tools > Measure.  

The Measure command pane displays. 

2. Pick the first point in a graphic view or type a point ID or coordinate (in the format 
X,Y) in the From box. 
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Note: You can also right-click in the view to access COGO controls (see 
"Understanding COGO Controls" on page 86) and snaps (see "Snaps Modes and 
Commands" on page 89) when picking points. 

3. Pick another point or type a point ID or coordinate in the To box. The measured 
values appear in the Results group. 

4. To measure other values, continue picking From and To points.  

Note: You can change to a different graphic view between measurements. 

5. Click Close. 

Related topics 

 Measure Options (on page 136) 
 Calculate the Inverse Between Points (on page 230) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Measure Options 
Use these options to calculate and report the bearing, distance, slope, slope distance, 
delta offset, and delta station between any two points, depending on which graphic 
view you use. They are available in the Measure command pane. 

Options 

From/To Pick points in graphic views, or type point IDs or coordinates (in the 
format X,Y) in the boxes, and click Measure or press [Enter]. 

Results This shows the values between the selected points: 

Slope - In the cross-section view, the slope is relative to the centerline.  
In the surface slicer view, the slope is relative to the first point of the line.

Offset - In the cross-section view, the offset is relative to the centerline. 
In the surface slicer view, the offset is relative to the first point of the 
line. 

Measure When you type in To and From points, this acts as the [Enter] key, 
calculating the Results. 

Related topics 

 Measure Values Between Points (on page 135) 
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Measure Angles 
Measure the angle between three selected locations and/or named points (points with 
IDs). 

 

To measure an angle:  

1. Select Survey > Measure Angle. The Measure Angle command pane displays. 

2. Verify the correct measurement type is selected in the Options box. 

3. Click in the Start point box and select the point or location in Plan view. The point 
or coordinate you selected is displayed in the Start point box and the cursor moves 
to the Pivot point box. 

4. Select the pivot point or location in Plan view. The point or coordinate you selected 
is displayed in the Pivot point box and the cursor moves to the End point box. 

5. Select the end point or location in Plan view. The point or coordinate you selected 
is displayed in the End point box and the measure angle is displayed in the Result 
box. 

You can continue to select different points or locations for the end point to display 
additional angles in the Result box.  

Note: As an alternative to selecting points and/or locations in the Plan View, you can 
type point IDs or coordinates directly in the point boxes. 

You can click the Reset icon located at the top of the pane to clear all 
measurements and results. 

You can click the Clear button located beneath the Result box to remove all angles 
displayed in the Result box. 
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Related topics 

 Measure Angle Options (on page 138) 
 

 

Measure Angle Options 
Use these options to measure the angle between three selected locations and/or named 
points (points with IDs). They are available in the Measure Angle command pane. 

Options 

Start point Click in the box and then select the start point in Plan View, or type the 
point ID or coordinate in the box. 

Pivot point If you selected the start point by selecting it in Plan View, the cursor 
automatically moves to this box. If you typed the point ID or coordinate 
in the Start point box, click in this box. 

Select the pivot point in Plan View, or type the point ID or coordinate in 
the box. 

End point If you selected the pivot point by selecting it in Plan View, the cursor 
automatically moves to this box. If you typed the point ID or coordinate 
in the Pivot point box, click in this box. 

Select the end point in Plan View, or type the point ID or coordinate in 
the box. 

The measured angle is displayed in the Result box. 

You can continue to select different points or locations for the end point 
to display additional angles in the Result box.  

Options Select the appropriate measurement method.  

Result Displays the measured angle. 

 

Related topics 

 Measure Angles (on page 137) 
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C H A P T E R  4  

Set Up Projects 

Choose Application Options 
Use the Options dialog to set program-wide options, such as startup preferences, default 
file locations, Internet download parameters, and display properties. 

Related topics 

 Choose Local Site Settings (on page 159) 
 Choose Project Settings (on page 147) 

 

Startup and Display Options 

Set startup and display options to control whether a project or start page automatically 
open when you start the program, and to specify program-wide preferences for the 
graphical user interface. 

To access these settings: 

1. Select Tools > Options. The Options dialog displays. 

2. Click Startup and Display in the left pane. 

These options are available: 
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Startup options 

Starting state 

 

No project - Select this to have no projects and no start page 
open when the software starts. 

Last project - Select this to open only the most recent project 
when the software starts. 

Open project command - Select this to initiate the Open Project 
command, which enables you to select any project to open, 
when the software starts. 

Display start page - Select this to display only the start page 
when the software starts. 

The start page is a view that lists features of the software and 
links to tours, tutorials, release notes, and other documentation 
to help you get started. By default, the start page appears when 
you launch the software, and closes when you start or open a 
project. 

Start page Type a path or click the  button to navigate to an alternate 
HTML page to use as the start page, which will display when 
you have Display start page selected in the Starting State box 
(see above). 

Recently-used file list Enter the number of recent project files to list at the bottom of 
the File menu, allowing you quick access to these projects. 

Graphics window options 

Display data tips Check this box to display more detailed information when you 
hover over objects in a graphic view. 

Note: This may conflict with the data list that appears when you 
graphically select an area with multiple objects. 

Background color Click an option to set the color of the background used in the 
graphics view. 

Pick aperture Enter a size (in pixels per side) for the box displayed on various 
cursors. This is the box within which an object can be picked.  

Examples of cursors with pick apertures: 

             

Application display options 
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Window display mode Tabbed views (SDI) - Select this to display each created data 
view (for example, a plan view or point spreadsheet) as a tabbed 
pane, enabling you to access each by clicking a tab, and allowing 
views to be split. In addition, data listings can be "floated", 
meaning that they can be displayed as undocked, movable 
windows. 

Multiple window views (MDI) - Select this to display each 
created data view in a separate window, allowing windows to be 
tiled or cascaded.  

Related Topics 

 Choose Application Options (on page 139) 
 File Location Options (on page 142) 
 Internet Download Options 

 

Advanced Display Options 

Use these options to control what graphics display package the program uses. In certain 
situations, choosing to use a different display package can improve graphics 
performance when you are exploring rich data sets in the Plan View (on page 25) and 3D 
View (on page 28). 

Note: Generally, you only need to override your graphics display package if you are 
accessing (via Remote Desktop or Microsoft® NetMeeting®) this program on your 
computer from a remote computer that uses a different graphics package. 

To access these settings: 

1. Select Tools > Options. The Options dialog displays. 

2. Click Startup and Display in the left pane. 

3. Click Advanced in the Graphics Window Options group. 

These options are available: 
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Advanced display options 

Graphics display 
package 

Override automatic detection - Check this box if you want to 
manually select a graphics display package other than the one 
detected on your computer. Then, select from the options 
below. 

DirectX - Select this if you are using Microsoft DirectX® 9.0c 
(Runtime version 4.09.0000.0904) distributed on June 2007 or 
later on Windows® XP Service Pack 2 or Windows Vista.  
The driver should run properly with any Direct3D 9.0 
compliant graphics hardware with the latest vendor-supplied 
drivers.  

Note for users running Vista: Although Vista comes 
pre-installed with DirectX 9, the driver uses the 
d3dx9_<version_number>.dll which does not come preinstalled 
with the operating system. Please make sure that this .dll is 
installed before trying to use the DirectX 9 driver.  

OpenGL - Select this if you are using OpenGL v1.1 or later on 
any Windows platform.  
The driver should run properly with any OpenGL 1.1 compliant 
graphics hardware. 

GDI - Select this if you are using Windows GDI on any 
Windows platform.  
The driver should run correctly on any GDI compatible device. 

Related Topics 

 Startup and Display Options (on page 139) 
 Choose Application Options (on page 139) 

 
 

File Location Options 

This command displays the Options dialog, which shows file management preferences. 

To access these settings: 

1. Select Tools > Options.  The Options dialog displays. 

2. Click File Locations in the left pane. 

These options are available: 
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Project Management 

Project management folder Select or browse for the folder to use as a default for 
saved project files. 

Use project subfolders Enable to have the program create project folders and 
subfolders, and organize your files in them. 

If you disable Use project subfolders, the root folder 
remains the default file location for projects, 
imported, and exported data until you change the 
path. 

Export folder Specify the folder to use as a default for exported files. 

Download and import folder Specify the folder to use as an archive for files that are 
downloaded and imported from field devices or the 
Internet.   

Note: When the Office Synchronizer application is 
used to transfer data between the computer and a 
field device, the Office Sync root folder is used. 

Copy imported files to import 
folder 

Enable to have imported files duplicated in the 
import folder you specify. 

This option is automatically enabled when Use 
project subfolders is enabled, but can also be set if 
you are not using the project subfolders option.  

This option can be enabled from the Import 
command pane as well. 

Tip: Disable Copy Imported files to import folder 
when you are simply reviewing data or importing 
large files that you do not want to save in your Import 
folder. 

Templates 

Template folder Specify the folder to use as the default file location for 
all projects that are saved as template projects. 
Projects stored in this folder appear in the list of 
templates when you create a new project. 

Data 

Synchronizer root folder Specify the data synchronization area (also known as 
the System root sync folder). This folder is used by 
Office Synchronizer to store data transferred 
between the computer and field devices 

Related Topics 

 Choose Application Options (on page 139) 
 Internet Download Options 
 Results of Default Folder Locations (on page 145) 
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 Startup and Display Options (on page 139) 
 Set Default Folder Locations 

 

Change the Template Folder 

The template folder contains all templates shipped with the office software and any 
templates you have created. 

Note: If you change the template folder, the existing templates remain in the original 
folder location. To move the templates, use Windows® Explorer. 

To change the template folder:  

1. Select Tools > Options. The Options dialog displays. 

2. Select File Locations. 

3. In the Template group, type a path for the location to which you want to save 
templates, or click the  icon to browse folders. 

4. In the Browse for Folder dialog, select the folder in which to store templates and 
then click OK. 

Note: Select Make New Folder to create a new template folder. 

5. Click OK. 

When you create a new template, it will automatically be saved to the folder you 
selected. 

Related topics 

 File Location Options (on page 142) 
 Set Default Folder Locations 

 

Set Default File Locations 

Projects can contain a variety of files, including imported raw data files, a project file 
with edited data, and exported data files. One way to manage projects more easily and 
logically is to specify where each file is saved by default. In the Options dialog, Use 
project subfolders is enabled by default. This option creates project folders and 
subfolders, and organizes your project files in them. 

1. When you install this software, a new folder named Trimble Business Center is 
created. The default path for the folder depends on your operating system:  

 In Windows® XP or earlier:   C:\Documents and Settings\(username)\My 
Documents\Trimble Business Center\. 

 In Windows VistaTM:   C:\Users\(user name)\Documents\Trimble Business Center\. 
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2. When you create a new project, and import or export data, a new folder called 
Unnamed is created in the Trimble Business Center folder. If you create a project, but 
do not import or export data, the folder is not created. 

3. If you save the current project, the Unnamed folder is renamed to the project name, 
and the project file is created at the same level. 

Warning: If you do not save the current project, the Unnamed folder and subfolders 
will be discarded when you close the project. 

4. As you create and save additional projects, they and their subfolders are also saved 
at the same level, so you can easily find and open them. 

To disable Use project sub-folders 

The Use project subfolders option is a project setting. You can change it from project to 
project, but once you create a new project, the mode can't be changed for that project. 
The project will use the same mode, regardless of the options setting. Therefore, if you 
do not want to use project subfolders, you must disable the option before creating a 
project. 

1. Select Tools > Options. The Options dialog appears.  

2. Click File Locations in the left pane. 

3. Uncheck Use project subfolders in the Project Management group box. The Export 
folder box, Download and import folder box, and Copy Imported files to import folder 
option become editable. 

4. Click OK. 

Note: When you enable Use project subfolders, the Copy Imported files to import folder 
option is enabled also, but you can also set it independently if you are not using 
project subfolders. 

Tip: You can manually create additional subfolders based on how your data is 
organized. For instance, if you have multiple field crews collecting data on multiple 
days, you may want to create subfolders based on those crews or days. 

Related Topics 

 File Location Options (on page 142) 
 Results of Default Folder Locations (on page 145) 

 

Results of Default Folder Locations 

Results of file operations when Use project subfolders is enabled: 
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Operation Result  

New Project A new project file is created, and a new subfolder called 
Unnamed is created when data files are copied. If the project 
is not saved, this subfolder is deleted. 

Save Project If the project is saved for the first time, the Unnamed 
subfolder will be renamed to the name of the project file. If 
the subfolder is empty, it is deleted. 

Save Project As The project file is saved with the new name. If the project has 
associated data, the project subfolder is copied and saved 
with the new name.  

Download file Downloaded data is saved in the project's import subfolder. 

Export file Exported data is saved in the project's export subfolder. 

Import file 

 

Imported data is saved in the project's import subfolder. 

Related Topics 

 File Location Options (on page 142) 
 Set Default Folder Locations 

 

SCS File Location Options 

HEAVY CONSTRUCTION  

Use this option to specify the location of the report template named SCS900 
Reporting Utility.xls or SCS Report Utility.xls, which is installed 
with the SCS900's Report Utility. This template is used when you view the results of a 
work order. The default path is C:\Program Files\Trimble\. 

To access this setting: 

1. Select Tools > Options. The Options dialog displays. 

2. Click SCS and then File Locations in the left pane. 
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Options 

Work order report template Type the path to the SCS Report Utility file in the 
box, or click  to browse for the path. 

Related Topics 

 Choose Application Options (on page 139) 
 Results of Default Folder Locations (on page 145) 
 Startup and Display Options (on page 139) 
 Set Default Folder Locations 

 

Choose Project Settings 
Use the Project Settings dialog to set various parameters for your projects, including 
settings for coordinate systems, units, computations, and views. For a description of 
any setting, click the name of the setting. The description appears in the information 
box at the bottom of the dialog. For explanations of terms, see the Glossary. 

Tip: Save time and effort, and make your projects more consistent, by choosing project 
settings and then saving the project as a template from which to begin other projects. 
You can also save baseline processing and network adjustment settings as "styles", 
which are similar to templates. Share templates and styles with co-workers to ensure 
consistency across your company. 

To choose project settings:  

1. Do one of the following: 

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog appears.   

2. Click a section to view the settings. When you click in a property, a descriptions 
displays in the info box at the bottom of the dialog. 

3. Edit the settings as needed, and click OK.  

Note: Settings with gray text are read-only; settings with black text can be edited. 

Related topics 

 Choose Application Options (on page 139) 
 Create a Project Template (on page 163) 
 Local Site Settings (see "Choose Local Site Settings" on page 159) 

 

General Information Settings 

Use general information settings to: 
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 Review the project's file properties 

 Add a reference number and description of the project 

 Add your company's contact information 

Add the names of the f ield and office staff  associated with the project 
To access the settings: 

1. Do one of the following: 

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog displays.   

2. Click General Information in the left pane. 

Related topics 

 Choose Project Settings (on page 147) 
 

Coordinate System Settings 

Use coordinate system settings to: 

 Review the current coordinate system and datum transformation 

Note: To select or create a different coordinate system, click Change at the bottom 
of the dialog. 

 Change the geoid model and specify its quality 

 Review the local site location and coordinates 

 Check the network adjustment transformation parameters 

 Review projection, vertical datum, and site calibration details 

See the shift grid name and fi lename To access the settings: 

1. Do one of the following: 

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog displays.   

2. Click Coordinate System in the left pane. 

Related topics 

 Change the Coordinate System (on page 149) 
 Choose Project Settings (on page 147)  
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Change the Coordinate System 

Choose the appropriate coordinate system and geoid model for your project by 
selecting one that you have used recently. Up to ten of the most recently used systems 
are stored. 

To select an existing coordinate system: 

1. Do one of the following: 

 Select Project > Change Coordinate System. 

 Select Project > Project Settings > Coordinate System, and click Change.  

The Select Coordinate System dialog displays. 

Note: The Select Coordinate System dialog is part of the Coordinate System Manager, 
a separate application. When only the dialog is open, pressing [F1] does not open 
online help. To view help for the Coordinate System Manager, click Tools > 
Coordinate System Manager to open the application. Then press [F1] for help. 

2. Select Recently Used System. 

3. Click  or , or press [PageUp] or [PageDown], to view the 
available coordinate systems.  

4. When the coordinate system that you want is displayed, click Finish. The 
coordinate system project settings are updated, and your project is recomputed 
using the new coordinate system. 

Caution: To avoid problems or unexpected results in your project, do not change the 
coordinate system after you import data. 

Related topics 

 Coordinate System Manager 
 Coordinate System Settings (on page 148) 
 Define a New Coordinate System (on page 149) 

 

Define a New Coordinate System 

Define parameters for a new coordinate system if the one you need doesn't appear in 
the list of recently used systems. 

To define a new coordinate system: 

1. Do one of the following: 

 Select Project > Change Coordinate System. 

 Select Project > Project Settings > Coordinate System, and click Change.  

The Select Coordinate System dialog displays. 
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2. Select New System, and click Next. 

3. To define a default project based on Transverse Mercator parameters: 

 Click Default Projection, and click Next. 

 Enter the Transverse Mercator parameters that are requested, and click Next. 

4. To define a projection based on a coordinate system group and zone: 

 Click Coordinate System and Zone, and click Next. 

 Select the coordinate system group from the list on the left, and select the zone 
from the list on the right and click Next. 

5. Select the geoid model you want to use and click Finish. Your project is 
recomputed using the new coordinate system. 

Related topics 

 Coordinate System Manager 
 Coordinate System Settings (on page 148) 
 Change the Coordinate System (on page 149) 
 Define a Projection (on page 176) 

 

Restore the Original Coordinate System File 

If you have previously installed Trimble® Geomatics OfficeTM (TGO), you may have an 
existing current.csd file which stores recently-used or custom coordinate 
systems. During the installation of the software, any existing current.csd file is 
renamed current.csd.date.xx-xx-xx.  

To restore the Current.csd fi le:  

1. Open Windows® Explorer and browse to one of these locations, depending on your 
operating system: 

  In Windows XP or earlier:  C:\Documents and Settings\All Users\Application 
Data\Trimble\GeoData unless you have previously installed TGO. If you have 
installed TGO and then this software, the path is C:\Program Files\Common 
Files\Trimble\GeoData. 

Note: Due to network security, you may not be able to edit this path unless you 
have administrative rights. 

 In Windows VistaTM:  C:\ProgramData\Trimble\GeoData\ or C:\Program 
Files\Common Files\Trimble\GeoData\. 

2. Rename current.csd to current-TBCC.csd. 

3. Rename the current.csd.date.xx-xx-xx to current.csd. 
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Related topics 

 Change the Coordinate System (on page 149) 
 

Unit Settings 

Use unit settings to review and change project units and unit display formats for: 

 Coordinates 

 Distances 

 Angles and vertical angles 

 Azimuths 

 Pressure 

 Temperature 

 GPS time (specifically, not GNSS time) 

 Stationing 

Area and volumes To access the settings: 

1. Do one of the following: 

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog displays.   

2. Click Units in the left pane. 

Entering units 

When you edit unit format settings, you are changing how the units display in views, 
spreadsheets, and commands. You can, however, enter units in any of the valid display 
formats that you see in the format settings. These are converted to the display format 
for the unit. 

Converting units 

If your project units are set to one type, such as International foot, you can still enter 
other types of units by including a character for the type. For example, you can enter 
3m to specify 3 meters. The unit you enter is converted to the project units. 

Caution: If you change the units of your project, it will be recomputed when you click 
OK. It is recommended that you exit Project Settings immediately after changing units, 
before changing other project settings. 
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Related topics 

 Change Project Units (on page 152) 
 Choose Project Settings (on page 147) 

 

Change Project Units 

Edit unit settings to control what units are used, and how they display in views, 
spreadsheets, and commands. Regardless of which unit display format you choose, you 
can enter units in any of the available formats that you see. 

Note: If your project units are set to one type, such as International foot, you can still 
enter other types of units by including a character for the type. For example, you can 
enter 3m to specify 3 meters. The unit you enter is converted to the project units. 
Note: You can also enter feet and inches by typing the two numbers with a space in 
between. For example, type 4_8 for 4 feet, 8 inches. 

To change the project units:  

1. Select Project > Project Settings. The Project Settings dialog displays. 

2. Click Units, and then click the type of units you want to change in the left pane. 

Note: To change project units from feet to meters, click Distance and then select 
Meters in the Display box. 

3. Select the box for which you want to change the units or format. 

4. Make the desired changes. 

5. To save and apply the changes, click OK. 

Caution: If you change the units of your project, it will be recomputed when you 
click OK. It is recommended that you exit Project Settings immediately after 
changing units, before changing other project settings. 

Related topics 

 COGO Expressions, Units, and Entry Formats (on page 87) 
 Unit Settings (on page 151) 

 

View Settings 

Settings are available for the various types of graphic, spreadsheet, and other views in 
which your project data is displayed. Use view settings to: 



Trimble® Business Center 
Heavy Construction Edition User Guide 153 

 Set Up Projects

 Specify whether to include 2D data in the 3D view 

 Choose the input method for horizontal and vertical alignment segments 

 Control graphic view display characteristics, such as plot scales and vertical 
exaggeration 

Control annotation text, and gridline intervals, colors and line styles in views Note: 

You can also click the  icon on the toolbar to turn gridlines on and off. 

 Show and hide individual columns for data on spreadsheet views 

 Set the default view filter used when you open new graphic views 

Note: If you delete a view filter that you have set as the default, the Default View 
Filter will revert to the All view filter, which cannot be deleted. 
Tip: If your project has a lot of data, you may want to select a default view filter 
other than All so that graphic views refresh more quickly. 

To access the settings: 

1. Do one of the following: 

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog displays.   

2. Click View in the left pane. 

3. Click any of the view types to display and edit individual settings. 

Related topics 

 Choose Project Settings (on page 147) 
 

Change the Gridline Display 

Display gridlines in the plan view to understand a project's scale and location. 

To display or hide gridlines:  

 Click the  icon on the toolbar. 

To change gridline properties:  

1. Select Project > Project Settings. The Project Setting dialog displays. 

2. Click the View folder. 

3. Expand Plan View, and click Grid Line Definition. 

4. Click in the boxes and edit the properties as needed. 
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5. Click OK. 

 

Example with grid lines On. 
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Example with gridlines Off (same data, same scale). 

 

Related topics 

 View Settings (on page 152) 
 

Toggle Line Marking 

Display or hide markers and labels for horizontal and vertical values along linestrings 
in 2D views to make viewing, understanding, and editing them easier. Markers are 
symbols that distinguish between horizontal segment end points, vertical control 
points and the overall line's end points. Labels are annotations that indicate the 
elevation of vertical control points. 

To show or hide l ine markings: 

 Click the  icon on the toolbar. 

 Select View > Toggle Line Marking. 

To set which l ine markings are shown: 

1. Do one of the following:  

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog displays. 
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2. Click View in the left pane, and click Display Options. 

3. Edit individual settings in the Marking section. 

Related topics 

 Change the Gridline Display (on page 153) 
 View Settings (on page 152) 

 

 
 

Computational Settings 

Use computational settings to: 

 Review and set horizontal and vertical tolerances for computed survey data, 
including points of varying quality, and meaned GPS vectors. 

Note: If computation results on data fall outside these tolerances, the data is flagged 
in the Project Explorer and graphic views, and a message appears in the Flags pane. 

 Select a level of confidence for displayed error values. 

 Specify the horizontal and vertical tolerances to enforce when creating surface 
breaklines from 3D alignments. 

 Set the maximum edge length and angle defaults for creating surface triangles. 

To access the settings: 

1. Do one of the following: 

 Select Project > Project Settings. 

 Click the  icon on the toolbar. 

The Project Settings dialog displays. 

2. Click Computational Settings in the left pane. 

Related topics 

 Choose Project Settings (on page 147) 
 Project Computations (on page 157) 
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Project Computations 

The Compute Project command enables you to compute your project after you make 
changes to the data. The computation applies the changes made to all affected 
observations and determines the coordinates for points in the chronological sequence a 
surveyor would typically expect. If conflicting data is available for the computation of a 
coordinate, the software gives preference to higher quality data over lower quality 
data.  

Note: When you import data into a project, change project settings, or change the 
coordinate system, the project is automatically computed for you. 

Related topics 

 Compute Project Command 
 

Run a Project Computation Report 

Generate a computation report to see a summary of the errors and warnings that 
occurred during the last computation of your project data. 

To run a Project Computation Report:  

 Select Reports > Project Computation Report. The Project Computation Report 
displays in your default Web browser. 

To customize the report:   

1. Select Reports > Report Options. The Report Options command pane displays.  

2. Select Project Computation Report in the list.  

3. Expand sections and specify output settings in the Settings group as needed.  

4. Click Apply if you want to customize additional reports, or OK to close the 
command pane. 

Related topics 

 Project Computations (on page 157) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Feature Code Processing Settings 

Use feature processing settings to configure how feature codes are processed. 

To specify feature processing settings: 

1. Do one of the following: 

 Select Project > Project Settings.  

 Click the  icon on the toolbar. 
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The Project Settings dialog displays.  

2. Select Feature Code Processing in the left pane. 

3. Click each section and set the options as shown in the following table. 

4. Click OK. 

Options 

General 

Process feature codes 
on import 

Prompt - Select this option if you want to be prompted on 
whether or not to process feature codes during data import. If you 
select to process feature codes during import and a feature 
definition (.fxl) file has not been specified in the project settings, 
you will be prompted to specify it at the time of import.  

Yes - Select this option if you want feature codes to be 
automatically processed during data import without prompting 
you. If a feature definition (.fxl) file has not been specified in the 
project settings, you will be prompted to specify it at the time of 
import. 

No - Select this option if you never want feature codes to be 
processed during data import. 

Decimal precision Specify the number of decimals to display with a numeric attribute 
(real number) when no feature definition (.fxl) file is specified. 

Processing 

Feature definition file Specify the feature definition (.fxl) file you want to use to process 
feature codes in the project. This is required if you want to process 
feature codes. 

 

Related topics 

 Choose Project Settings (on page 147) 
 Understanding Feature Data (on page 359) 
 Workflow for Feature Data (on page 361) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 
 Process Feature Codes (on page 367) 

 

Abbreviation Settings 

Use abbreviation settings to control notations for horizontal and vertical alignment 
classifications in the Alignment Geometry Report. 

To access the settings: 

1. Do one of the following: 

 Select Project > Project Settings. 
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 Click the  icon on the toolbar. 

The Project Settings dialog displays. 

2. Click Abbreviations in the left pane. 

Related topics 

 Choose Project Settings (on page 147) 
 

 

Choose Local Site Settings 
Enter local site settings to create a ground coordinate system to accommodate elevation 
differences between your site and the ellipsoid. The scale factor can be calculated for 
you. 

You should define local site settings for the project location at the start of the project 
because this information is used in calculations. The application uses: 

   The project latitude to calculate the earth's radius 

   The project latitude and longitude to define the grid scale factor 

  The project height as the default elevation and to calculate the 
elevation factor To specify local site settings: 

1. Select Project > Local Site Settings. The Local Site Settings command pane 
displays. 

2. Select a coordinate system to display in the Coordinate type list. Any changes take 
effect immediately.  

If you select Grid: 

1.   Click in the Northing box. 

2.   Pick a point in a graphic view, right-click for options, or type coordinates in 
the Northing and Easting boxes to specify the location for the local site. 

3.   Pick a point in a graphic view, right-click for options, or type a value in the 
Elevation box. 

If you select Local or Global: 

1.   Click in the Latitude box. 

2.   Pick a point in a graphic view, right-click for options, or type coordinates in 
the Latitude and Longitude boxes to specify the location for the local site. 

3.   Pick a point in a graphic view, right-click for options, or type a value in the 
Height box. 
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3. Type a value in the Ground scale factor box, or check Compute ground scale factor 
from project location to have the value computed. 

4. To close the dialog, click OK. 

To view the local site settings: 

1. Select Project > Project Settings. The Project Setting dialog displays. 

2. Select Coordinate System and then Local Site. The read-only Local Site settings 
display. 

Related topics 

 Coordinate System Settings (on page 148) 
 Calibrate a Site (on page 184) 

 

Local Site Setting Options 

Use these options to define the current project's local site. They are available in the 
Local Site Settings command pane. 
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Options 

Project location 

Coordinate type Grid - Select this to enter planar northing, easting, 
elevation, and height values in a grid system. 

Local - Select this to enter ellipsoidal latitude, 
longitude, height, and elevation values on a local 
datum. 

Global - Select this to enter global ellipsoidal 
longitude, height, and elevation values on a global 
datum. 

Ground coordinates 

Ground scale factor Type a factor by which to convert grid distances to 
ground distances. 

Compute ground scale factor from 
project location 

Check this to have the ground scale factor calculated 
for you. The value will be a product of the grid factor 
(determined from the horizontal project location) 
and the height scale factor (determined from the 
vertical project location). 

Note: When Compute ground scale factor is 
checked, the Ground scale factor box is unavailable. 

Coordinate Display 

False Northing offset 

False Easting offset/ 

Type a value for the distance to offset from the 
northing and easting values. 

For example, if you enter: 

 False northing offset:  
 -6,540,000 

 Then a northing of 6,542,111 becomes: 
2,111 

Related topics 

 Calibrate a Site (on page 184) 
 Choose Local Site Settings (on page 159) 

 

Create a New Project 
You can create a new project using the default template, or you can select a new 
template from which to create a project. 
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To create a new project using the default template: 

 Click the  icon. This is the quickest way to create a new project. 

To create a new project by choosing a template: 

1. Do one of the following: 

 Select File > New Project. 

 Press [Ctrl] + N. 

2. In the New Project dialog, select a template.   

3. Click OK. 

To create a new project upon starting the application: 

1. Select Tools > Options. The Options dialog displays.  

2. Select General > Startup and Display.  

3. Select Open new default project in the Starting state list. 

4. Click OK. Each time you start this software, a new project will be started using the 
default template. 

Note: Creating a new project closes any project that is currently open. 

Related topics 

 Choose Application Options (on page 139) 
 Choose Project Settings (on page 147) 
 Change the Default Template (on page 164) 
 Startup and Display Options (on page 139) 

 

Use a Project Template 
Several default templates are provided so you can start projects with consistent 
distance units. It is even more efficient, however, to create your own templates. In 
your own templates, you can save additional project settings, including: 
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 Company, user, and file information, such as field and office operators, contact 
numbers, and addresses 

 Coordinate system information, such as a datum transformation and geoid model 

 Units settings, such as coordinate formatting 

 View settings, such as a plot scale and grid line definition 

 View filters and selection sets 

 Computational settings, such as horizontal and vertical tolerances 

When you start projects using your own templates, any settings you specified are 
included, saving you time and effort, and making your projects more consistent. You 
can even share templates with co-workers to ensure consistency across your company. 

Related topics 

 Create a Project Template (on page 163) 
 

Create a Project Template 

When you save a project as a template, all project settings and data are saved in the new 
template file, and the new name is added to the template list. 

Warning: Saving data that requires computation in project templates is not 
recommended; the data may not recompute properly. 
Note: It is a good idea to create a template for each set of coordinate system/project 
units you commonly use. 

To create a project template using an existing project:  

1. Open, or create, a project that you want to save as a template. 

2. Review and modify project settings as needed. 

3. Create layers and view filters that you want to be available in future projects. 

4. Remove any unnecessary data from the project. 

5. Select File > Save Project as Template. The Save Project as Template dialog 
displays. 

6. In the Name field, type a name for the template. 

7. If you want this template to be used when you create a project by clicking the  
icon, check the Save project as default template box. 

8. Click OK. The template is saved in the template folder. When select File > New 
Project, the template appears among the other templates. 
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To delete a project template: 

1. Select File > Save Project as Template. The Save Project as Template dialog 
displays. 

2. Click in the left column for template you want to delete. 

3. Click Delete. A confirmation message displays. 

Note: You cannot delete the template that is set as the default. If you wan to delete 
the default template, set another as the default. 

4. Click Yes. 

5. Click OK. 

Related topics 

 Change the Default Template (on page 164) 
 Change the Template Folder (on page 144) 
 Define a New Coordinate System (on page 149) 
 Create a View Filter (on page 73) 
 Save a Project (on page 165) 
 Save Project As Command 

 

Change the Default Template 

When you create a new project by clicking the  icon on the toolbar, the default 
template is used. 

To change the default template: 

1. Select File > Save Project as Template. 

2. Select the template you want to use as a default. 

3. Click Set as default. 

4. Click OK. 

Related topics 

 Create a Project Template (on page 163) 
 Change Template Folder (see "Change the Template Folder" on page 144) 

 

Open an Existing Project 
Use these commands to quickly open a recent project, or browse to another previous 
project. 

1. Do one of the following: 

 Select File > Open Project. 
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 Click the  icon on the toolbar. 

 Press [Ctrl] + O. 

The Open File dialog displays, showing a list of available projects in the folder last 
opened. 

2. Select a project from the list, or browse to locate a project in a different folder. 

3. Click Open. 

To open a recent project:  

 Select File, and then select a project from the list of recent projects (at the bottom 
of the File menu). The project opens. 

Note: Opening a project closes any project that is currently open. 

Related topics 

 Create a New Project (on page 161) 
 Startup and Display Options (on page 139) 

 

Save a Project 
You can save a project, rename a project/save a project to a different path or filename. 

To save a project:  

1. Do one of the following: 

 Select File > Save. 

 Press [Ctrl] + S. 

 Click the  icon on the toolbar. 

2. Select the folder where you want to save the file, and assign a file name.   

3. Click Save. 

To rename an existing project:  

1. Select File > Save As. The Save As dialog displays. 

2. Select the folder in which you want to save the file in the Save in box. 

3. Type a name in the File name box. 

4. Click Save. 

Note: You cannot overwrite an existing project by naming a project the same name as 
an existing project. 



Trimble® Business Center 
Heavy Construction Edition User Guide 166 

 Set Up Projects

Related topics 

 Archive a Project (on page 166) 
 Create a Project Template (on page 163) 
 Close All Windows Command 
 Close Project Command 

 

Archive a Project 
Use this command to save a project (.vce) file and its associated subfolder in a 
compressed (.zip) file of the same name. This enables you to quickly compile all parts of 
a project into a smaller file that is suitable for sending to a colleague or archiving. 

Note: File archiving only works if you have Use project subfolders checked in the File 
Locations section of the Options dialog. 

To archive a project: 

1. Make sure the project you want to archive is closed.  

2. Select File > Archive Project. The Archive a Project dialog displays. 

3. Select the file you want to archive in the Save in box. 

4. Click Save. The .zip file appears, next to the project file and subfolder. 

Related topics 

 Save a Project (on page 165) 
 Set Default Folder Locations 

 

Print a View or Report 
You can print a graphic view to any Windows-supported printing device. You can also 
print a report using your default Web browser's print command. 

To select a printer:  

1. Select File > Page Setup.   

2. In the Page Setup dialog, set the paper size, orientation, and margins. 

3. Click Printer. The second Page Setup dialog appears. 

4. In the Name list, select the printer you require. 

5. Click OK in both dialogs. 

Note: You can also select a printer within the Print command. 
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To preview a print job: 

1. Click the view you want to print to make it active. 

2. Do one of the following: 

 Select File > Print Preview. 

 Click the  icon. 

The Print preview dialog opens. 

3. In the Print preview dialog, you can: 

 View the plan view of your project 

 Zoom to view less or more detail 

 Select the page layout 

 Click the  icon to print, or Close. 

Note:  You cannot cancel a print job if you use this option. 

To print:  

1. Do one of the following: 

 Select File > Print 

 Press  Ctrl + P 

 Click the  icon. 

2. Select the printer, page range and number of copies to print. 

3. Click OK. 

Related topics 

 Page Setup Command 
 Print Preview Command 

 

Troubleshoot a Project Problem 
Before calling Support, use any applicable solutions to known issues below. 



Trimble® Business Center 
Heavy Construction Edition User Guide 168 

 Set Up Projects

Symptom Possible Cause Solution 

You cannot reopen a 
.vce project file. 

The project file is locked, possibly due to a 
crash or an improper program shutdown. 

Improper shutdown includes when: 

 A project is open and the power to 
the computer is interrupted. 

 A project is open and the process is 
ended from Windows® Task Manager. 

Delete the lock (project 
name,lk) from the file 
project folder.  
The project will lose all 
changes made since the 
last save. 

 

 
 

Troubleshoot a Program Freeze 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

Program freezes 
when selecting 
many objects. 

The Properties pane is open. 
When you select many objects 
with the Properties pane open, it 
looks for the properties common 
to all of the objects, slowing the 
program down and making it 
look frozen. 

Close the program. If you have 
trouble reopening the project, 
check the directory where the 
.vce file is stored. If there is a lock 
(*,lk) file with the same name as 
the project, delete it and reopen 
the project. Close the Properties 
pane before reselecting the 
objects. 

Program doesn't 
respond in the 
expected way; 
nothing seems to 
work. 

The mouse may be set to a mode 
other than Select. 

Check your mouse mode on the 
Mouse toolbar. If needed, reset it 
to Select. 
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The program 
freezes. 

Toolbars are corrupted. Consider contacting Technical 
Support. 

Otherwise, remove the 
application data folder located at 
C:\Documents and 
Settings\<user 
name>\Application 
Data\Trimble\Trimble Business 
Center\<version> 

Note: If you do not see the 
Application Data folder at the 
path listed above, it may be 
hidden. To show hidden folders, 
in Windows® Explorer, select 
Tools > Folder Options. Click 
the View tab and select Show 
hidden files and folders in 
Advanced Settings. Then click 
OK. 

The program 
appears to freeze 
when you float a 
pane or try to open 
a dialog. 

If you are running the program 
on a secondary monitor, and you 
float a pane or use a command 
that launches a dialog, the pane 
or dialog might appear out of 
either monitor’s visible range. It 
will be located off of the primary 
monitor, in the space opposite 
the secondary monitor, causing 
Trimble Business Center to 
appear ‘frozen’. 

To reach the dialog or pane, 
right-click the application’s name 
on the Windows Taskbar and 
select Move. Then, press the 
appropriate arrow key to move 
the dialog into your primary’s 
monitor’s visible range. 

Program appears to 
freeze when you 
are trying to e-mail 
SCS files. 

If you are running the program 
on a secondary monitor, and you 
attempt to e-mail SCS files using 
the Compress/E-mail SCS Files 
command, your e-mail program 
may open a dialog confirming the 
operation out of either monitor’s 
visible range. The dialog will be 
located off of the primary 
monitor, in the space opposite 
the secondary monitor, causing 
the program to appear ‘frozen’. 

To reach the dialog and confirm 
the e-mail operation, right-click 
the e-mail application’s name on 
the Windows Taskbar and select 
Move. Then, press the appropriate 
arrow key to move the dialog into 
your primary’s monitor’s visible 
range. 
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C H A P T E R  5  

Set Up Geodetic Reference Data 

Understanding Geodetic Reference Data 
This software uses a coordinate system to transform measurements on a curved surface 
(the earth) to a flat surface (a map or plan). For example, a coordinate system is used to 
calculate grid coordinates for a point measured using GPS (GPS measurements are 
made on the WGS-84 ellipsoid). 

A coordinate system can consist of the following elements: 

 A datum transformation (between the WGS-84 ellipsoid and the local ellipsoid) 

 A projection 

 A geoid model 

 A GPS site calibration (consisting of an horizontal adjustment and a vertical 
adjustment) 

You must select a coordinate system for every project. If you do not have a system, or 
do not know which system to select, use the default projection. 

Note: Make sure that the points in a project are within a reasonable distance from the 
projection origin according to the properties of the projection used. 

Coordinate system database 

The coordinate system database is stored as a file called Current.csd. It contains all of the 
coordinate system information. The office software supplies an extensive set of 
published coordinate systems from around the world. To define or edit coordinate 
systems, zones, sites, datum transformations, ellipsoids, and geoid models, use the 
Coordinate System Manager (on page 173). 

Related topics 

 Change the Coordinate System (on page 149) 
 Coordinate System Manager 
 Define a New Coordinate System (on page 149) 
 Restore the Original Coordinate System File (on page 150) 
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Define the Coordinate System 

Change the Coordinate System 

Choose the appropriate coordinate system and geoid model for your project by 
selecting one that you have used recently. Up to ten of the most recently used systems 
are stored. 

To select an existing coordinate system: 

1. Do one of the following: 

 Select Project > Change Coordinate System. 

 Select Project > Project Settings > Coordinate System, and click Change.  

The Select Coordinate System dialog displays. 

Note: The Select Coordinate System dialog is part of the Coordinate System Manager, 
a separate application. When only the dialog is open, pressing [F1] does not open 
online help. To view help for the Coordinate System Manager, click Tools > 
Coordinate System Manager to open the application. Then press [F1] for help. 

2. Select Recently Used System. 

3. Click  or , or press [PageUp] or [PageDown], to view the 
available coordinate systems.  

4. When the coordinate system that you want is displayed, click Finish. The 
coordinate system project settings are updated, and your project is recomputed 
using the new coordinate system. 

Caution: To avoid problems or unexpected results in your project, do not change the 
coordinate system after you import data. 

Related topics 

 Coordinate System Manager 
 Coordinate System Settings (on page 148) 
 Define a New Coordinate System (on page 149) 

 

Define a New Coordinate System 

Define parameters for a new coordinate system if the one you need doesn't appear in 
the list of recently used systems. 

To define a new coordinate system: 

1. Do one of the following: 
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 Select Project > Change Coordinate System. 

 Select Project > Project Settings > Coordinate System, and click Change.  

The Select Coordinate System dialog displays. 

2. Select New System, and click Next. 

3. To define a default project based on Transverse Mercator parameters: 

 Click Default Projection, and click Next. 

 Enter the Transverse Mercator parameters that are requested, and click Next. 

4. To define a projection based on a coordinate system group and zone: 

 Click Coordinate System and Zone, and click Next. 

 Select the coordinate system group from the list on the left, and select the zone 
from the list on the right and click Next. 

5. Select the geoid model you want to use and click Finish. Your project is 
recomputed using the new coordinate system. 

Related topics 

 Coordinate System Manager 
 Coordinate System Settings (on page 148) 
 Change the Coordinate System (on page 149) 
 Define a Projection (on page 176) 

 

Restore the Original Coordinate System File 

If you have previously installed Trimble® Geomatics OfficeTM (TGO), you may have an 
existing current.csd file which stores recently-used or custom coordinate 
systems. During the installation of the software, any existing current.csd file is 
renamed current.csd.date.xx-xx-xx.  

To restore the Current.csd fi le:  

1. Open Windows® Explorer and browse to one of these locations, depending on your 
operating system: 

  In Windows XP or earlier:  C:\Documents and Settings\All Users\Application 
Data\Trimble\GeoData unless you have previously installed TGO. If you have 
installed TGO and then this software, the path is C:\Program Files\Common 
Files\Trimble\GeoData. 

Note: Due to network security, you may not be able to edit this path unless you 
have administrative rights. 

 In Windows VistaTM:  C:\ProgramData\Trimble\GeoData\ or C:\Program 
Files\Common Files\Trimble\GeoData\. 
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2. Rename current.csd to current-TBCC.csd. 

3. Rename the current.csd.date.xx-xx-xx to current.csd. 

Related topics 

 Change the Coordinate System (on page 149) 
 

Troubleshoot a Coordinate System Problem 

Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

You cannot 
create or edit 
coordinate 
systems, or save 
sites. 

You are running as a 
Limited User 
(non-administrator). 
Limited users do not 
have “write” 
permissions for the 
current.csd file, 
which means that you 
cannot create or edit 
coordinate systems, or 
save sites. 

You must be granted “write” permissions for 
the current.csd file by an administrator. The 
location of that file depends on your operating 
system: 

 In Windows® XP or earlier: C:\Documents 
and Settings\All Users\Application 
Data\Trimble\GeoData or C:\Program 
Files\Common Files\Trimble\GeoData. 

 In Windows VistaTM: 
C:\ProgramData\Trimble\GeoData or 
C:\Program Files\Common 
Files\Trimble\GeoData. 

Note: This may be a non-issue if other Trimble 
software has been previously installed, and 
access rights have been resolved. 
Note: If you do not see the Application Data 
folder at the path listed above, it may be 
hidden. To show hidden folders, in Windows® 
Explorer, select Tools > Folder Options. 
Click the View tab and select Show hidden files 
and folders in Advanced Settings. Then click 
OK. 

 
 

Coordinate System Manager 

The Coordinate System Manager is a standalone utility that gives you access to your 
coordinate system database (Current.csd). Use the manager to create coordinate 
systems, or to determine which coordinate systems, geoid models, and sites are 
available for use in your project. 



Trimble® Business Center 
Heavy Construction Edition User Guide 174 

 Set Up Geodetic Reference Data

To open the Coordinate System Manager:  

 Select Tools > Coordinate System Manager. 

Note: The Coordinate System Manager has its own help system. Open the utility and 
select Help > Help Topics, or press [F1] within the software. 

Related topics 

 Change the Coordinate System (on page 149) 
 Coordinate Systems (see "Understanding Geodetic Reference Data" on page 170) 
 Define a New Coordinate System (on page 149) 
 Restore the Original Coordinate System File (on page 150) 

 

Scale-Only Projection 

The software allows you to import survey data using a scale-only projection. Because 
the software cannot calculate global or local coordinates from grid positions in a 
scale-only projection, certain functionality is affected. Note the following when 
working with scale-only projection data: 

 You can specify a scale factor for the scale-only projection when you import the 
data, and after import in the Coordinate System section of the Project Settings dialog. 

 The Create Point and Add Coordinate commands allow to enter a grid point or 
coordinate in scale only.  

 The Local Site Settings and Site Calibration commands are disabled. 

 When using the Inverse command, only grid and ground distances are available.  

 The Point List report includes only grid data. 

When working with coordinate system data and scale-only projection data in the same 
project, note the following: 

 When you import scale-only projection data into a project that already contains 
coordinate system data, the scale-only projection data is converted to the existing 
coordinate system. 

 When you import coordinate system data into a project that contains scale-only 
projection data, the scale-only projection data is converted to the existing 
coordinate system. 

 

Use a Datum 

Create a Datum Grid File 

If you have chosen a coordinate system for your project that uses a datum, and the 
datum hasn't been defined yet, you must create it before uploading to a field device. 
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To do this, find a coordinate system with the appropriate datum to use. If you know of 
a coordinate system that uses the datum you need, you can select it to combine its .dgf 
files into a single .cdg file suitable for uploading. 

Note: When you download or import data into a project, the datum used by the 
imported data must correspond with the datum defined for the project's coordinate 
system. 

To create a datum grid:  

1. Select Project > Project Settings. The Project Settings dialog displays.   

2. Click Coordinate System and then Datum Transformation in the left pane. 

3. Review the parameters. You can only create a datum grid file if the Latitude Grid File 
and Longitude Grid File boxes are shown, and .dgf files are listed in them. If there 
are, click OK, and proceed to step 9. 

4. If there aren't .dgf files shown, click Change at the bottom of the dialog. The Select 
Coordinate System dialog displays. 

5. Select Recently Used System. 

6. Click  or , or press [PgUp] or [PgDn], to view the available 
coordinate systems.  

7. When you find a coordinate system that uses the datum you need, click Finish. The 
Project Settings dialog updates. 

8. Confirm that .dgf files are shown in the Latitude Grid File and Longitude Grid File 
boxes. These files will be combined into a datum grid file (.cdg) file that you can 
save and upload to a field device. 

9. Click OK to close the Project Settings dialog. 

10. Do one of the following: 

 Select Project > Datum Gridding. 

 In the Device pane, with a device connected, click Tasks and select Upload 
datum grid (.dgf) file.  

The Datum Gridding command pane displays. The .dgf files appear in the Project 
Datum Grid group. 

11. Click Create at the bottom of the command pane. The Save As dialog displays. 

12. Accept the default file name, and click Save. The datum grid file appears in the 
Datum Grid Files (.cdg) list. Now it can be uploaded to a field device. 

Related topics 

 Upload a Datum Grid (see "Upload a Datum Grid File" on page 227) 
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Datum Grid Options 

Use these options to select a datum file to upload to a field device. They are available in 
the Datum Gridding command pane. 

Note: Click the lower group header to switch between the current project's datum and 
a stored datum grid file. 

Options 

Folder  Select, or navigate to, the folder in which the datum grid 
files (.cdg) are installed. 

Datum grid files (.cdg) This displays the names of the available datum grid files. 

Description This shows the regions covered by the datums. 

Size This displays the file sizes. Files larger than 1 MB may 
take a while to upload. 

Project/Selected datum grid If you have a datum grid file selected in the list, this 
displays details on it. 

If you do not have a datum grid file selected, this displays 
details on the datum used in your current project's 
coordinate system. 

Upload Click this to transfer the datum grid file to the connected 
field device. 

Create Click this to save a new datum grid file. 

Use project datum 

(via the context menu) 

Check this before uploading it you want to upload a 
temporary copy of the current project's datum, instead of 
selecting one of the permanently stored datum grid files 
in the list. 

Upload to Device is also available from the context menu. 

Related topics 

 Create a Datum Grid File (on page 174) 
 Upload a Datum Grid (see "Upload a Datum Grid File" on page 227) 

 

Define a Projection 
Use a false origin to define a projection when you import raw GNSS data for which you 
did not previously specify the projection. 

To define a projection: 

1. Import and check-in your raw GNSS data. If there is not associated projection, the 
Projection Definition dialog displays. 

2. If needed, type grid coordinates in the Northing and Easting boxes to base the origin 
on the best known grid coordinates. 
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3. Click OK. The new coordinates become the projection's origin. 

Related topics 

 Check-In Raw GNSS Data 
 Local Site Setting Options (on page 160) 

 

Use a Geoid 

Geoid Options 

Use these options to select a geoid file to upload to a field device. They are available in 
the Geoid Sub-Gridding command pane. 

Options 

 Click this to display the Select Coordinate System dialog, 
where you can choose a recently-used coordinate system, or 
define a new one to use in your project. 

Folder Select, or navigate to, the folder in which the geoid grid files 
(.ggf) are installed. 

File (.ggf files) This displays the names of the available geoid grid files. If any 
geoid sub-grid files have been defined, they display beneath 
the name of the complete geoid grid file. 

Description This shows the regions covered by the geoids. 

Size This displays the file sizes. Files larger than 1 MB may take a 
while to upload. 

Upload Click this to transfer the geoid grid file to the connected field 
device. 

Note: This is only available if you have a field device 
connected and accessed the command through the Tasks 
button. 

Create sub-grid Click this to define a sub-area of the geoid file to save upload 
time and field device memory. 

Related topics 

 Define a Geoid Subgrid (see "Define a Geoid Sub-Grid" on page 177) 
 Upload a Geoid File to a Field Device (see "Upload a Geoid File" on page 228) 

 

Define a Geoid Sub-Grid 

If the geoid file you want to use for data collection is too large, define a subsection of 
the area to use before uploading to a field device. This saves upload time and field 
device memory.  
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Note: When you download or import data into a project, the geoid sub-grid used by the 
imported data must correspond with the geoid defined for the project's coordinate 
system. 

To create a geoid sub-grid:  

1. Do one of the following: 

 Select Project > Geoid Sub-Gridding.  

 In the Device pane, with a device connected, click Tasks and select Upload geoid 
(ggf) file.  

The Geoid Sub-Gridding command pane displays. 

2. If needed, select the folder containing the installed geoid files in the Folder (.ggf) 
list, or click the  icon and navigate to the folder. 

Note: The default location for .ggf files depends on your operating system: 
In Windows® XP or earlier:  C:\Documents and Settings\All Users\Application 
Data\Trimble\GeoData unless you have previously installed Trimble® Geomatics 
OfficeTM (TGO). If you have installed TGO and then this software, the path is 
C:\Program Files\Common Files\Trimble\GeoData. 
In Windows VistaTM:   C:\ProgramData\Trimble\GeoData\ or C:\Program 
Files\Common Files\Trimble\GeoData\. 

3. Select a geoid file in the Geoid File (.ggf) list. 

4. Right-click and select Create sub-grid from the context menu. The Create Geoid Grid 
File dialog displays. The whole globe is visible, and the geoid is centered. In the 
Geoid File Properties group, the size of the whole geoid appears in the Size box. 

5. In the Suffix to Append box, type text to attach to the end of the original geoid file 
name to define the sub-grid. The complete file name appears as you type the suffix. 
For example, if you will be collecting data in Baja, Mexico, add Baja as the suffix to 
the geoid Mexico97.ggf to create the file Mexico97Baja.ggf.  

6. If needed, uncheck borders or rivers in the Globe Properties group to simplify the 
display. 

7. Click the  icon to zoom in to the extents of the geoid. For explanations of the 
other viewing tools, see Geoid Sub-grid Options. 

8. Click the  icon, and window around the portion of the geoid that you need to 
create a sub-geoid. The size of the geoid sub-grid appears in the Size box. 

Note: You cannot adjust the sub-grid window that you draw, but you can redraw it 
multiple times. 

9. Click Save. The Save Geoid Grid File As dialog displays. 
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10. Click Save again. The geoid sub-grid file appears in the geoid list just below the 
original geoid file. 

Related topics 

 Geoid Subgrid Options (see "Geoid Sub-Grid Options" on page 179) 
 Upload a Geoid File to a Field Device (see "Upload a Geoid File" on page 228) 

 

Geoid Sub-Grid Options 

Before uploading to a field device, use these options to define a sub-area of a larger 
geoid file to save upload time and field device memory. They are available in the Create 
Geoid Grid File dialog. 
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Options 

Geoid file properties 

Geoid This displays the name of the geoid on which the sub-grid 
will be based. 

File name This displays the geoid's file name. 

Suffix to append Type text to attach to the end of the original geoid file name 
to identify the sub-grid. 

Size (KB) Shows the original geoid size until you draw the sub-grid. 
Then it shows the geoid sub-grid's size. 

Sub-grid properties 

First latitude 

First longitude 

These display the coordinates of the first corner of the 
window you pick when drawing a sub-grid. 

Second latitude 

Second longitude 

These display the coordinates of the opposite corner of the 
window you pick when drawing a sub-grid. 

Globe properties 

Cursor latitude 

Cursor longitude 

These display the coordinates of the current cursor 
location. If the cursor is not over the globe, they display the 
point at which the cursor left the globe. 

US state borders Uncheck this to hide state boundaries in the United States. 

National borders Uncheck this to hide boundaries of nations. 

Major rivers Uncheck this to hide major waterways. 

 
Click this to activate the selection tool. Then click and drag 
to draw a window within the current geoid to define the 
opposite corners of a geoid sub-grid. 

Any portion of the sub-grid that you draw outside of the 
geoid boundary is ignored. 

Note: To erase a sub-grid, click anywhere off of the globe. 

Tip: After you window to create a sub-grid, you can click 
within the sub-grid to zoom in. 
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Click this to activate the pan tool. Then click and drag on 
the globe to move to different locations. 

 
Click this to zoom in to the extents of the geoid. Then click 
it again to zoom in by an increment (x2), or pick a point on 
the globe to center it and zoom in on that point. 

 
Click this to activate the zoom out tool. Then click it again 
to zoom out by an increment (x2), or pick a point on the 
globe to center it and zoom out from that point. 

 
Click this to zoom to the extents of the globe, and center 
the current geoid. 

Related topics 

 Define a Geoid Subgrid (see "Define a Geoid Sub-Grid" on page 177) 
 

Calibrate a Site 

Understanding Site Calibration 

The site calibration process establishes the relationship between WGS-84 data 
collected by GNSS receivers and local control positions (expressed as a local map grid 
with elevations above sea level). This relationship is defined by a series of 
mathematical transformations. Site calibration enables you to pair up GNSS and local 
control points to be used in the calibration. (GNSS coordinates must be derived from 
GNSS points and observations, and grid points must be derived from grid points and 
terrestrial observations). This software then computes and applies the mathematical 
transformations using least squares. 

The mathematical transformations that are applied in order to convert WGS-84 
positions to grid coordinates are: 
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1. A datum transformation to convert the WGS-84 latitude, longitude, and ellipsoidal 
height coordinates to latitude, longitude, and ellipsoidal height coordinates relative 
to the ellipsoid of the local map grid. 

2. A map projection to convert the local ellipsoid latitude and longitude coordinates 
into local map grid northing and easting coordinates (the height value is not altered 
in this process). 

3. A geoid model to WGS-84 height to get approximate elevation above sea level. 

4. A horizontal adjustment of the transformed grid coordinates to best fit local 
control data. This adjustment allows for any local variations in the projection 
system that cannot be accommodated in the overall datum transformation. 

5. A height adjustment to convert the heights above the local ellipsoid or elevations 
derived from the geoid to local control elevations above sea level. 

The horizontal and vertical adjustment are stored as part of the coordinate system 
definition for the project. All GNSS points in the database are updated using the 
calibration parameters, resulting in more accurate local grid coordinate values.  

You can save the new coordinate system definition (which includes the calibration 
parameters) as a site for use in future projects in the same area. 

If you save a calibration as a site with the intention of using the site in another project, 
make sure that the project area is fully enclosed by the points used in the calibration. 
For example, in the following diagram, it is valid to use the site definition for project B, 
but not for project C. 

  
1. Project C area 2. Project B area 

3. Points used in calibrating Project A 

If you use the Here key in Trimble® Survey ControllerTM to start a Real Time Kinematic 
(RTK) base, and transfer the Survey Controller (.dc) file to this software, the base 
position, and therefore all rover points from the base, are of unknown quality (for all 
components, horizontal, height, and elevation). 
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Note: After performing a site calibration, if you apply local site settings, the calibration 
you have defined will become invalid and be removed. An error message warns you 
that continuing will remove the site calibration. 

Using Geoid Models 
If the coordinate system for the project defines the use of a geoid model for point 
elevation determination, then elevations are determined directly off the WGS-84 
heights by interpolation on the geoid model grid. However, it is still possible to apply a 
height adjustment on top of the elevations produced by a geoid model to allow for 
small local variations that a large scale geoid model cannot take into account. 
Elevations determined from a vertical calibration are given a survey quality. 

Rules for ensuring a useful calibration 
 WGS-84 coordinates must be relatively correct. 

 It is possible to generate autonomous GNSS points. However, you should not use more 
than one autonomous WGS-84 point in a calibration, for example make sure that only 
a single base station has been set up using the Here key in Trimble Survey Controller. 
Other base stations should be set up on positions measured by a GNSS vector in terms 
of the autonomous base station. This defines the relationship between them and allows 
you to perform a calibration with points used from either base station correctly. This is 
described below: 

The following figure shows no relationship between the base stations: 

 
Points from Base 1 and Base 2 should not be used for calibration. 

In the following figure, a relationship is defined between the base stations by 
occupying the second base station using the first base station: 
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Points from Base 1 and Base 2 can be used for a calibration. 

 The best possible WGS-84 coordinates should be used for the initial base station in 
a survey. 

The precision of GNSS vectors (real-time or postprocessed) is affected by the accuracy 
of the base coordinate. An error of up to one part per million (1 ppm) can be 
introduced for each ten meters of error in the base coordinates. For example, if your 
primary WGS-84 reference point has an error of one hundred meters and your baseline 
is two kilometers long, you may have an unnecessary extra error of two centimeters in 
your GNSS vectors. 

Related topics 

 Calibrate a Site (on page 184) 
 

Calibrate a Site 

Calibrate sites to minimize residuals between WGS-84 RTK data you collect and local 
control coordinates. For a calibration, associate GNSS points with grid points at the 
same positions. These point pairs are used to compute and apply mathematic 
transformations (using least squares) to find the transformation that gives the 
adjustment parameters that best fit the control grid coordinates when applied to GNSS 
positions. 

Calibrate a site if you: 

 Did not calibrate in the field 

 Need a report of quality control records 

 Want to transfer a calibration to Trimble® Survey ControllerTM 

Need to add extra points to a calibration in Trimble Survey Controller Horizontal 
calibrations consist of three parameters: 
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 Translation (move) 

 Rotation (turn) 

 Scale (shrink or stretch) 

Vertical calibrations consist of two parameters: 

 Lift (raise or lower) 

 Tilt (change the northing and easting incline of the geoid or local plane) 

Site calibration creates a set of local site settings. When a site calibration is complete, 
the site settings are used in the computation of all other imported GNSS data. 

To calibrate a site:  

1. Import or add your grid points using the Add Point command. 

2. Import your GNSS data. 

3. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Survey > GNSS Site Calibration. 

The Site Calibration Calculation command pane displays. 

4. Click the Calibration Settings tab. 

5. To compute a horizontal shift consisting of translations in the north/south and 
east/west directions, a rotation around a defined origin and a scale factor, leave the 
Horizontal Calibration box checked. 

6. Check the Set scale factor to 1 box if you want to maintain the scale of your 
horizontal distances. 

7. To compute a vertical shift at a defined origin, leave the Vertical Calibration box 
checked. 

8. Select Vertical Shift + Incline Plane in the list if you need to include inclinations in 
the north and east directions in the vertical calibration. 

9. Click the  icon to display the Project Settings dialog, where you can define a 
geoid model, if needed. 

10. Click the Point List tab to select the calibration point pairs that will be used in the 
calibration computations. 

11. Click in the GNSS Point box. 

12. Pick a GNSS point in a graphic view, right-click for options, or type a point ID in 
the box.  
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Note: The point you select must have global coordinates. Points with local 
coordinates cannot be selected as GNSS points. Point coordinates must be 
computed from global coordinates. 
Note: Click  to expand a group if you want to view coordinate information on the 
selected point. 

13. Click in the Grid Point box. 

14. Pick a grid point (at the same location as the GNSS point) in a graphic view, 
right-click for options, or type a point ID in the box. 

15. Select an option in the Type list to specify how the pair of points is to be calibrated. 
The calibration type you select must be valid for the points. For example, if the grid 
point does not have an elevation, you cannot set the type to Horizontal and vertical. 

16. Repeat steps 11 - 15 to add additional pairs of points, if needed. 

Note: There is no limit to the number of pairs that may be defined to compute a 
calibration. Adding a more pairs will not always improve the calibration results, 
but it will provide additional checks on the validity of the computed parameters. 
At minimum, you need three pairs of points for a horizontal calibration, and four 
pairs of points for a vertical calibration with an incline shift. 

17. Click Compute to compute the GNSS calibration parameters. The Results tab 
appears, summarizing the transformation and listing the horizontal and vertical 
residuals for each pair of points. The narrow image indicates the vertical 
magnitude and direction of the shift, and the square image indicates the horizontal. 

18. Click Save As Site if you want to make the calibrated site available to use as a 
coordinate system. The Save Coordinate System as Site command pane displays. 
Type a name for the site and click OK. 

19. Click Assign. The calibration is recomputed to update all of the GNSS points, and 
the coordinate system details are updated with the calibration parameters. 

Note: Sites can be recalibrated at any time. 

To remove a site calibration: 

 Select Survey > Remove Site Calibration. The calibration is removed, and the 
project is recomputed. 

Related topics 

 Choose Local Site Settings (on page 159) 
 Site Calibration Options (on page 187) 
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Site Calibration Options 

Use these options to establish a relationship between the WGS-84 RTK data you 
collected and local control coordinates. They are available in the Site Calibration 
Calculation command pane. 

Options 

 
Click this to display the GNSS Calibration Report, showing details of 
the calibration computation, all the computed parameters, and a 
listing of the computed control point coordinates compared with 
their known positions and individual residual values. 

 Click this to display the Site Calibration section of the Project 
Settings. 

 Click this to display the Local Site Settings command pane, where 
you can define the local site's coordinate type, scale factor, and 
offsets. 

 Click this to display the Add Point command pane, where you can 
create a new office-entered point. 
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Calibration settings 

Horizontal 
calibration 

Check this to compute a horizontal shift consisting of translations in 
the north/south and east/west directions, a rotation around a defined 
origin and a scale factor. 

The transformation parameters are computed using least squares 
methods to find the transformation that gives the adjustment 
parameters that, when applied to the GNSS positions, best fit the 
control grid coordinates. 

The horizontal adjustment reduces any residual error between the 
control coordinates and the grid coordinates calculated from the 
GPS positions. 

Set scale factor to 1 Check this to prevent your horizontal distances from being scaled. 

Tip: It is wise to first compute a horizontal adjustment without the 
scale factor set to one to check the computed scale factor. If the 
computed scale factor is not close to one, it could indicate a problem 
in the selected calibration point pairs. 

Vertical calibration Check this to perform an inclined plane adjustment consisting of a 
vertical shift at a defined origin and inclinations in the north and 
east directions.  

The parameters for this adjustment are computed using least squares 
methods to find an adjustment plane that best fits the elevations 
derived from the GNSS heights with the control point elevations. 
This requires three three-dimensional calibration point pairs. With a 
single three-dimensional calibration point pair, only the vertical 
shift parameter can be computed. If there are two three-dimensional 
calibration point pairs available the system defines a correction 
plane that exactly fits these pairs. 

If the project uses a geoid model, then the vertical adjustment is 
computed and applied on top of the geoid model corrections. 

Geoid model This shows the name of the geoid model that is part of the coordinate 
system definition.  

To change the geoid model (see "Change the Coordinate System" on 
page 149), click the  icon to display the Project Settings dialog.  

 Vertical shift - Select this to simply compute a vertical shift at a 
defined origin. 

Incline plane - Select this to include inclinations in the north and 
east directions in the vertical shift. 

Compute Click this to compute the GNSS calibration parameters after you 
have changed the calibration settings. Results are summarized in the 
Computation Summary on the Calibration Settings tab. 
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Save as site Click this to display the Save as Site dialog, in which you can save 
the current calibration and coordinate system details in the 
coordinate system database as a site definition. 

You can use this site definition as the coordinate system definition 
for future projects. 

Computation 
summary 

This shows a summary of the last calibration computation.  

Use it to confirm that the computed calibration is valid without 
having to look at the detailed computation report. 

Point list 

GNSS point 

 

Click in the box. Then pick a GNSS point in a graphic view, 
right-click for options, or type a point ID that you want to calibrate 
with the grid point in the next box. 

Note: The point you select must have global coordinates. Points with 
local coordinates cannot be selected as GNSS points. Point 
coordinates must be computed from global coordinates. 

Grid point Click in the box. Then pick a grid point in a graphic view, right-click 
for options, or type a point ID that you want to calibrate with the 
GNSS point in the previous box. 

Note: Click  if you want to view coordinate information on the 
selected point. 

Type Horizontal and vertical - Select this when the point pair is suitable 
for determining both horizontal and vertical adjustments. 

Horizontal - Select this when the point pair is suitable only for 
determining a horizontal adjustment (the elevation value for the grid 
point is not reliable). 

Vertical - Select this when the point pair is suitable only for 
determining a vertical adjustment (the northing and easting values 
for the grid point are not reliable). 

Ignored - Select this when the point pair is not to be used in the 
computation of any transformation parameters.  

This option is useful if you have a problem in your calibration 
computation and are trying to locate a suspect calibration point pair. 
You can use this to remove a calibration point pair temporarily from 
the computation to see if the results are improved. 

Results 
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(summary) Horizontal scale factor - This displays the computed scale factor for 
the horizontal adjustment. If you check the Set scale factor to 1 
box, this displays “1”.  

Use this to confirm that the computed scale factor is close to 1. If it is 
not, there may be a problem with one or more of the calibration 
point pairs. 
Horizontal rotation  

Maximum slope of inclined plane - This shows the maximum 
inclination for the computed height adjustment, based on the 
computed slope north and slope east values. 
Vertical shift at origin  

Residuals Maximum horizontal residual - This shows the highest horizontal 
difference between paired points. 

Maximum vertical residual - This shows the highest vertical 
difference between paired points. 

The residuals for each pair of points are represented by the images 
shown below. 

 

These images indicate the relative magnitude of the vertical shift. 
Investigate and resolve the reported point pairs with the longest 
arrows first. 

 

These images indicate the relative magnitude and direction of the 
horizontal shift. 

Investigate and resolve the reported point pairs with the longest 
arrows and directions that do not match the other residuals first. 

Assign Click this to recompute so that all GNSS points are updated using the 
calibration parameters.  

The coordinate system details are also updated. 

Related topics 

 Calibrate a Site (on page 184) 
 

Save a Calibrated Site as a Coordinate System 

After you perform a site calibration, you can name and save the site so it is available to 
use as a coordinate system. 

To save a site as a coordinate system: 

 Click Save As Site at the bottom of the Site Calibration command pane. 

The Save Coordinate System as Site command pane displays.  

Related topics 

 Calibrate a Site (on page 184) 
 Change the Coordinate System (on page 149) 
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 Define a New Coordinate System (on page 149) 
 

 

Separate Global and Grid/Local Coordinate Points for Site Calibration 

SURVEY  

If you import GNSS data and optical data into your project and one or more coordinates 
in the GNSS data have the same point ID as one or more coordinates in the optical data, 
points will be created under the Points node that includes both global and grid/local 
coordinates. In this case, a site calibration cannot be performed using these points. You 
must first rename the coordinate point IDs in the imported optical data file. Then, you 
must disable any remaining grid and/or local coordinates listed beneath points defined 
by global coordinates. 

To separate global and grid/local coordinate points for site 
calibration: 

1. In the Project Explorer, change the point ID for each coordinate included in the 
optical data that has the same ID as a point included in the GNSS data:  

a. Beneath the optical data file node, right-click the coordinate whose point 
ID you want to change, and select Properties from the context menu. The 
Properties pane displays. 

b. In the Properties pane, enter a new point ID for the observation in the Point 
ID field and press [Enter]. 

For example, if the original point ID is "a", you might enter a new point ID of 
"a_grid". 

The new point is created for the coordinate beneath the Points node in the 
Project Explorer. 

c. Repeat these steps for each coordinate point ID you want to rename.  

2. Select Survey > Site Calibration. 

If there are no grid and/or local coordinates listed beneath points defined by global 
coordinates, the Site Calibration pane displays. You are now ready to calibrate the 
site (see "Calibrate a Site" on page 184). 

If there are grid and/or local coordinates listed beneath points defined by global 
coordinates, a message displays identifying the points. You should disable the grid 
and/or local coordinates for these points before performing the site calibration. 
Proceed with the next step in this procedure. 

3. In the Project Explorer, disable any grid and/or local coordinates listed beneath 
points defined by global coordinates: 
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a. Beneath the the Points node, click the  icon to expand the point you want 
to view. 

b. Right-click the grid or local coordinate you want to disable, and select 
Properties from the context menu. The Properties pane displays. 

c. In the Properties pane, select "Disabled" in the Status list. 

d. Repeat these steps for each coordinate you want to disable.  

4. When you are done, do either of the following to compute the project: 

 Select Project > Compute Project.  

 Click the  icon on the status bar. 

You are now ready to calibrate the site (see "Calibrate a Site" on page 184). 

Related topics 

 Understanding Site Calibration (on page 181) 
 Calibrate a Site (on page 184) 

 

Run a Site Calibration Report 

After you calibrate a site, generate a Site Calibration Report to see details on the local site 
settings, horizontal and vertical calibration parameters, and residual differences 
between GNSS and grid points in your project. 

To run a Site Calibration Report:  

 Select Reports > Site Calibration Report. 

The Site Calibration Report displays in your default Web browser. 

To modify the report:   

 Select Reports > Report Options. Select Site Calibration Report in the command 
pane, and click OK. 

In the Settings group at the bottom of the command pane, you can specify the 
header and footer data to display.   

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
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C H A P T E R  6  

Import Data 

Import Data 
After you browse for a folder within the Import command, the files in that folder are 
analyzed to match a file type with an importer. The analyzer looks for identifying 
information within the file, the format of the file, and the file extension to assign an 
importer to the file.  If an ASCII file is marked as "unknown", you may need to create a 
custom importer for that file. 

To import data:  

1. Open an existing or new project. 

2. Do one of the following: 

 Select File > Import. 

 Click the  icon on the toolbar.  

The Import dialog displays.  

3. Select a folder in the Import Folder list, or click the  icon to browse for a folder. 
The default is the folder that you last imported from. The files contained in the 
selected folder appear in the Select File area. The file names and file types are listed. 
File type is the name of the importer that is used to read the file. 

4. Select the file(s) that you want to import in the Select File group.  

Note: The order in which you import data can affect the computation results. 
Note: If you need to set a custom importer, right-click on a file to set the file type. 

5. Click Import. The data displays in graphic views and in the Project Explorer. 

Tip: You can also double-click, or drag and drop (see "Drag and Drop to Import" on 
page 194), files to import them.  

6. To view an Import Summary (see "Run an Import Report" on page 215) report, 
select Reports > Import Summary. 
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Note: To view the file, click the  icon. This will open the file in Notepad or 
another text editor program. 

Note: To display only those files that the converter recognizes, click the  icon on 
the pane's toolbar. The icon functions as a toggle switch. 
Note: To change the file type, right-click the file, and select an option from the Set File 
Type list. The options that are offered are based on internal scanning of the file. The file 
extension is also used as a clue. 
Note: To import more than one file, use [Ctrl] + click or [Shift] + click. 
Note: To change the file type, right-click, select Set File Type, and select one of the 
options in the drop-down list. The options that are offered are based on internal 
scanning of the file. The file extension is also used as a clue. 

Related topics 

 Drag and Drop to Import (on page 194) 
 Import Data (on page 193) 
 Import Data Formats 
 Import Data in a Custom Format (on page 209) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Drag and Drop to Import 
You can import data by dragging files from your desktop, Windows® Explorer, or the 
Import command pane's file list, into a data view. 

To drag and drop a f i le into a project:  

1. Open a project. 

2. Do one of the following: 

 Locate the files that you want to import on your desktop or in Windows® 

Explorer. 

 Open the Import command pane and browse to the folder that contains the 
file(s) to import. 

3. Click and drag the file(s) onto a data view. 

Caution: The software allows you to set import properties when importing certain 
types of files. These properties are displayed in the Import command pane when you 
select File > Import and select the file type. If you choose to import one of these types of 
files using the drag-and-drop method rather than the Import command pane, you will 
not be able to see the default import properties or change them. 

Related topics 

 Import Data (on page 193) 
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Importable Data Formats 

HEAVY CONSTRUCTION  

The Import command and data synchronization functions for sites, designs and work 
orders enable you to bring the following types of data into your project. See 
file-specific topics for details. 

Fi le format Data types 

.cal Calibration files 

.crd, .mos GENIO (see "Import GENIO Files" on page 198) alignment files 

.csv, .pts ASCII point files 

.dc Trimble data collector (see "Import Data Collector Files (.dc)" 
on page 196) files 

.dgn MicroStation (see "Import MicroStation Files (.dgn)" on page 
204) design files 

.dxf, .dwg CAD files 

.ini site settings files 

.reb, .* REB (see "Import REB Files (.reb)" on page 206) roadway 
and/or surface files 

.ttm Trimble terrain model (see "Import Trimble Surface Files 
(.ttm)" on page 207) surface files 

.txt SCS work order report and record files 

.xml LandXML (see "Import LandXML Files (.xml)" on page 200) 
files 

.yxz Wirth YXZ (see "Import Wirth YXZ Files (.yxz)" on page 207) 
files 

Related topics 

 Import Data (on page 193) 
 Import Data in a Custom Format (on page 209) 

 

Import ASCII Files 
ASCII files give you the flexibility to import data from a variety of sources, or even to 
create a file using a text editor. When you import an ASCII file, the Import Format Editor 
may display, prompting you to create a custom importer to accommodate the file. You 
can also access the editor any time by clicking the  icon on the Import command 
pane toolbar.   

Note: You can import Nikon NEH files (.asc) from Field Surveyor. 
Tip: ASCII point files (.pts) can be imported as a surface. 
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Related topics 

 Import Data (on page 193) 
 Import Data in a Custom Format (on page 209) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Import Data Collector Files (.dc) 
Import data collector files from a variety of field devices, including: 

 Trimble® Survey ControllerTM (up to version 10t; for files that have been converted) 

 Trimble® Digital FieldbookTM (v2,v3, and v5) 

Related topics 

 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Import CAD Files (.dxf/.dwg) 
CAD .dwg and .dxf files are drawing files used in architecture, civil engineering, 
design, and mapping industries. At the bottom of the import pane, you can specify 
settings that affect the imported data. 
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Importable properties and objects:  

 3D Face (as a CAD 3D Face) 

 3D Polyline (as a CAD 3D Poly Line) 

 Arc (as a CAD Arc) 

 Attribute (as a CAD Attribute Definition) 

 Attribute Reference (as a CAD Attribute Reference) 

 Block Reference (as a CAD Block Reference) 

 Circle (as a CAD Circle) 

 Coordinate (as a Coordinate) 

 Ellipse (as a CAD Ellipse) 

 Hatch (as a CAD Hatch) 

 Leader (as a CAD Leader) 

 Lightweight polyline (as a CAD Lightweight Polyline) 

 Line (as a CAD Line) 

 M Line (as a CAD Multi-line) 

 M Text (as a CAD Multi-line Text) 

 Point (as a CAD Point) 

 Point (as a Point) 

 Polyline (as a CAD PolyLine) 

 Ray (as a CAD Ray) 

 Shape (as a CAD Shape) 

 Solid (as a CAD Solid) 

 Spline (as a CAD Spline) 

 Text (as a CAD Text) 

 Trace (as a CAD Trace) 

 Xline (as a CAD XLine) 

Non-importable properties and objects:  

 3D solid 

 Dim 3 Point Angular (importer) 

 Dim Aligned (importer) 

 Dim Angular (importer) 
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 Dim Diametric (importer) 

 Dimension (importer) 

 Dim Ordinate (importer) 

 Dim Radial (importer) 

 Dim Rotated (importer) 

 Polyface mesh 

 Polygon mesh 

 Raster image 

 Region 

 Tolerance 

Related topics 

 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Import GENIO Files 
Import GENIO data to create alignments. There are three types of GENIO strings that 
contain varying amounts of data and can be used in different ways. 
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Fi le Type 

GENIO 3D string  X, Y, and Z coordinates 

 2D lines  

These can be used as reference data for manually creating 
horizontal alignments, but they do not import as alignments, 
and cannot be converted into alignments. 

GENIO 6D string  X, Y, and Z coordinates 

 2D lines 

 Station data 

 Instantaneous tangencies and radii 

These can be converted into alignments with horizontal and 
vertical components after import. 

GENIO 12D string 

 

 X, Y, and Z coordinates 

 3D lines 

 Station data 

 Tangencies and radii with additional parameters 

These import as alignments with horizontal and vertical 
components. 

Related topics 

 Create an Alignment from a GENIO String (on page 297) 
 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 
 Workflow for Importing Alignments (see "Workflow for Using Imported 

Alignments" on page 287) 
 

Import GNSS Job Files (.job) 
Import GNSS files from the following field devices: 

 TDS Survey ProTM (Survey Pro Jobs) 

Note: You can also import .raw (raw data files) from TDS Survey Pro. 

 Spectra Precision® Field Surveyor 

 Trimble® Survey ManagerTM 

 Trimble® Digital FieldbookTM (v2,v3, and v5) 

 Trimble® Survey ControllerTM (versions 11 and later) 

To force a kinematic occupation to process as static:  

1. When importing a GNSS data file, select the file in the Import command pane Files 
list. 
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2. Select Yes in the Force Static box in the Settings group. The selected occupation is 
converted to static data, as indicated in the Project Explorer. 

Related topics 

 Force Continuous Command 
 Force Static Command 
 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 
 Run a Job File Report 

 

Import LandXML Files (.xml) 
LandXML is an open XML file format. The format was principally created by and for 
the survey, civil engineering, and transportation industries. LandXML format supports 
points, surfaces, and alignments when imported. This software supports version 1.0 of 
the LandXML standard. 

When you import a LandXML file, the data is previewed for conflicts. If there are no 
conflicts, the file is imported and the data appears in the graphic views. If conflicts are 
found, the LandXML Import Conflicts (see "Resolve LandXML Conflicts" on page 202) 
dialog displays, enabling you to resolve the conflicts. The import process continues 
afterwards. If there are errors after the import process, a warning flag appears on the 
status bar. 

When you import LandXML files, the points, alignments, and surfaces are handled in 
these ways: 
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LandXML Import Results  

Points LandXML files can contain any number of points (referred to as COGO 
points in the LandXML format). When points are imported: 

 They become points, with associated coordinates, and can be 
edited. These points can be referenced by a surface. 

 They are placed on a layer named after the "points" section of the 
file. (If a layer does not exist, it is created.) 

 Their point IDs are based on the "name" fields in the file. 

 Their feature codes are based on the "desc" fields in the file. 

Alignments LandXML files can contain any number of alignments. The required 
component of an alignment object is a geometric definition of the 
horizontal alignment.  

Required attributes are name, alignment length, and beginning station 
value.  

Optional attributes are station equations, profile, and cross-section 
components.  

When alignments are imported: 

 They are placed on new layers if the "alignment" sections of the 
file have unique names. 

 Their names are based on the "name" fields in the file. 

 Their geometric definitions are used to create alignments, with 
the geometry defining the horizontal component of the 
alignment. Horizontal alignment geometry can consist of lines, 
arcs, and spirals. 

 If the "name" attribute exists in the geometric definition, it is used 
to name the horizontal alignment.  

 The starting station value from the alignment object is used to 
station the horizontal alignment. 

The alignment may also contain one or more vertical alignments 
(profiles). If a vertical alignment exists: 

 It is used to create a representation of the vertical alignment in the 
profile view. 

 The "name" attribute is used to name the vertical alignment. 

If the alignment contains stored cross-sections: 

 The stored cross-sections appear in both the plan view and the 
cross-section view. 

 A surface is automatically created using the cross-section station 
values, offsets, and elevations upon import. The surface is named 
using the file name. 
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Surfaces LandXML files can contain any number of surfaces. 

A surface can be defined in the file in either (or both) of two ways: 

 Source Data - Includes the points, point lists, boundaries, 
breaklines, and contours used to create the surface. This data 
imports as objects that are separate from the surface, meaning that 
you can add or remove them from the surface, or edit their 
properties. 

 Definition - Includes 3D points and triangles defining the surface. 
This data imports as an integral part of the surface. This method 
can support holes and islands in surfaces. 

Related topics 

 Resolve LandXML Conflicts (on page 202) 
 Results of Importing LandXML Files 

 

Resolve LandXML Conflicts 

During the LandXML import process, if any objects in the file are ambiguous, the 
LandXML Import Conflict dialog displays. LandXML objects that do not conform to the 
import format will be reported as conflicts or discarded if: 

 The file is corrupted. 

 A surface is only defined by a watershed. 

 A surface contains one or many point files. 

 A surface has both Source data and Definition data description. 

 An alignment profile contains a gap. 

 An alignment profile contains a spiral that is not a clothoid. 

 The components of an alignment profile are not in the proper order. 

To resolve conflicts in LandXML objects: 

1. Select a conflict in the List of conflicts. Options for resolving the conflict appear in 
the Selected conflict area. The description and options in this depend on the 
selected conflict. 

2. Click an option for resolving the conflict. 

3. Click Resolve this conflict. A check mark appears in the Status column next to the 
conflict, indicating that the conflict is resolved. The next conflict in the list is 
automatically selected. 

4. Repeat the steps above until all of the conflicts are resolved.  
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5. Click Import to finish the import process. When the file finishes importing, the 
LandXML objects appear in the project explorer as points, surfaces, or alignments. 
Discarded objects and the reasons for the discard are listed as Errors in the Import 
Summary. 

Notes: You can change the resolution for solved conflicts any time before 
importing. 

Related topics 

 Import LandXML Files (.xml) (on page 200) 
 LandXML Conflict Resolution Options (on page 203) 

 

LandXML Conflict Resolution Options 

Use these options to resolve ambiguities in the import of LandXML files. They are 
available in the LandXML Import Conflicts dialog. There are two general types of 
LandXML conflicts. 
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Columns 

Status  Resolved conflict 

 Unresolved conflict 
# Shows the conflict number in the list 

Description Displays the type of object and the reason for the conflict 

Resolution Options 

Conflict type Triangle-based definition - Select this when you only want to 
import the triangles defining the surface. This data becomes the 
surface and cannot be edited.  

Select this only when you do not need to edit the data, and want a 
smaller file size and faster speed. This option also handles holes 
and islands in the data. 

Point/Breakline-based source data - Select this to import the 
points, point lists, boundaries, breaklines, and contours used to 
create the surface. This data defines the surface, but remains 
separate from it, enabling you to edit the data to modify the 
surface. 

If you are unsure, select this option to retain the ability to edit the 
data. 

Conflict type Use a new name - Select if you want to save the original imported 
object, and import an identical one with a new name. Type a new 
name in the box. 

Overwrite existing surface - Select if you want to discard the 
existing surface of the same name, and replace it with this one. 

Caution: If you overwrite the existing surface, all related observed 
objects are deleted, even they are not from a LandXML import. 

Related topics 

 Resolve LandXML Conflicts (on page 202) 
 

Import MicroStation Files (.dgn) 
MicroStation .dgn files are design files used in civil engineering, design, mapping, and 
architecture industries. At the bottom of the import pane, you can add a prefix to the 
layer (level) names, and specify whether to create a selection set comprised of the 
imported data. 
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Importable properties and objects:  

 Arc (as an open CAD Ellipse or a CAD Arc (when minor and major axes are equal)) 

 B-spline (as a CAD Spline if header denotes a spline (includes non-uniform and 
rational B-spline)) 

 Cell (as individual CAD Lines and other CAD objects) 

 Color (maps to default colors and bylayer for bylevel) 

 Complex chain (as separate CAD Lines, 3D Polylines, Arcs, and Splines) 

 Complex shape (as separate CAD Lines, 3D Polylines, Arcs, and Splines) 

 Curve (as a CAD Spline) 

 Ellipse (as a CAD Ellipse or a CAD Circle (when minor and major axes are equal)) 

 Level (as a layer) 

 Line (as a CAD Line) 

 Line string (as a CAD 3D Polyline) 

 Line style (maps to one of the eight pre-defined line styles and to bylayer; all others 
map to solid) 

 Multiline (as a CAD Multi-line) 

 Point string (as CAD Points (if detached) or a CAD 3D Polyline (if contiguous)) 

 Shape (as a CAD 3D Polyline) 

 Shared cell and cell reference (as a CAD Block and CAD Block Reference) 

 Tag (as CAD Text) 

 Text (as CAD Text) 

 Text node (as separate CAD Text objects) 

Non-importable properties and objects:  

 3D surface 

 3D solid 

 B-spline (if header denotes a surface) 

 Boundary 

 Cone 

 Conic 

 Dimension 

 External reference files 
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 Meshes 

 Raster data 

 Raster header 

Related topics 

 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Import REB Files (.reb) 
Import REB files to use as road model data, including alignments and surfaces, and/or 
surface data. REB data is separated into different files for these types of data: horizontal 
alignment, vertical alignment, cross-sections, points/coordinates, surface triangles, and 
breaklines.  

You can select one or more REB files to import at the same time. Since different types 
of REB data are stored in separate files, if any data is dependent upon another type of 
data, both files must be imported at the same time. For example, you cannot add a 
vertical alignment file without concurrently adding the horizontal alignment file it is 
dependent upon.  

Although REB files often use the .reb extension, they also use numeric extensions, such 
as: *.021, *.040, *.066, *.66, *. D21, *.D30, *.D40, *.D45, *.D49, *.D58, and *.D66.  REB 
extensions indicate the type of data the files contain:  

 . D21 and .021 - vertical alignment data 

 .D30 - point/coordinate data (GAEB) 

 .D40 and .040 - horizontal alignment data 

 .D45 - point/coordinate data 

 .D49 - breakline data (GAEB) 

 .D58 - surface triangle data (GAEB) 

 .D66 and .66 - cross-section data 

Note: Cross-sections from REB data are converted into breaklines when they are 
imported. 
Note: You can also import Wirth YXZ cross-section data in conjunction with an REB 
alignment file to create a road model. 
Note: REB is a data specification most-commonly used in Germany. 

Related topics 

 Import Data (on page 193) 
 Import Wirth YXZ Files (.yxz) (on page 207) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 
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Import Trimble Surface Files (.ttm) 
Import triangulated terrain models to visualize surfaces and compute volumes between 
surfaces.  

Note: You can also import ASCII point files (.pts) as surfaces using a custom format 
created in the Import Format Editor (see "Import Data in a Custom Format" on page 
209). 

Related topics 

 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 
 Workflow for Using Imported Surfaces (on page 321) 

 

Import Wirth YXZ Files (.yxz) 
Import cross-section data in a Wirth YXZ (.yxz) file to create a surface. 

Related topics 

 Import Data (on page 193) 
 Run an Import Summary Report (see "Run an Import Report" on page 215) 

 

Import DiNi Digital Level Files (.dat) 

SURVEY  

DiNi digital level .dat (M5) files contain level data recorded in the field using a Trimble 
DiNi Digital level. 

To import DiNi Digital  level  .dat f i les:  

1. Do one of the following: 

 Click the    icon on the toolbar. 

 Select File > Import.  

The Import command pane displays. 

2. Do one of the following: 

 Select a folder in the Import Folder list. 

 Click the  icon to browse for a folder.  

The default is the folder that you last imported from. The files contained in the 
selected folder appear in the Select File(s) area. The file names and file types are 
listed.  
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3. Select the DiNi digital level .dat file(s) you want to import. 

1. In the Settings section at the bottom of the Import command pane, change the 
Automatically Numbered Points properties if necessary.  

These properties help the software identify which points were auto-numbered by 
the DiNi level and which point IDs were entered by the user. Auto-numbered 
points typically are not points of interest and should not be created as points in the 
project. 

 Starting Point - Specifies the first point ID number of the range of point ID 
numbers in the file you want to specify as automatically numbered points that 
should not be created in the project.  

 Maximum Points - Specifies the maximum number of points in the file you want 
to be included in the range.  

 Increment - Specifies the increment to be used when identifying point numbers 
in the range. 

 Ending Point - Specifies the calculated ending point for the point range based on 
the other specified properties. 

2. When you are done, click Import. The Level Editor dialog displays. In this dialog, 
you can see which level points were entered by the user (points of interest) and 
will be created in the project, and which points were automatically numbered by 
the DiNi and will not be created in the project. If necessary, you can make changes 
by checking or unchecking any point to include or not include it in the project. For 
instructions, see View and Edit Level Data (on page 255). 

Note: If you import a text file with "Unknown" or "Mapping" coordinate quality into a 
project that already contains level point data, duplicate points will be created for points 
in the text file (lightweight points (see "Understanding Point Types" on page 269)) and 
points already in the project (normal points (see "Understanding Point Types" on page 
269)) that have the same ID (that is, points will not merge as expected). To avoid this 
problem, import the text file first to create the lightweight points in the project, then 
import the level point data. The lightweight points from the text file will merge with 
the normal points from the other point data to create normal non-duplicated points. 
For more information, see Understanding Point Types (on page 269). 

Related topics 

 Import Data (on page 193) 
 View and Edit Level Data (on page 255) 

 

Use Terramodel (.pro) Data 
To use data from Terramodel (.pro) files in this software, the data must be exported 
from Terramodel in formats that can be imported: 
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 Export CAD linework and point blocks in CAD (.dxf) format 

Export surfaces and alignments in LandXML (.xml) format Note: Roading data 
cannot be exported to a LandXML file. 

Alternately, you can launch SCS Data Manager (on page 376) from within this software 
and use it to add a Terramodel (.pro) file to an SCS design outside of this program. 

Import Data in a Custom Format 
Use the Import Format Editor to define a custom format for importing an ASCII file with 
a specifically defined format. The converters created with this editor are used within 
the Import command to import ASCII files with a non-standard format. 

You can create a converter to import any of the following: 

 Delimited files containing ASCII data that is separated by a specific character (e.g. 
.csv files) 

 Fixed-width files containing ASCII data that is in pre-defined columns 

 Files with ASCII data that is defined by a string of text 

 Files with ASCII data that can be defined by a regular expression (see "Reference: 
Regular Expressions" on page 214) 

To import a custom format:  

1. Do one of the following: 

 Select File > Import Format Editor. 

 In the Import dialog, click the  icon. 

The Import Format Editor opens and displays the Select Definition (see "Definition 
Options" on page 210) dialog.  

Note: If you try to import an ASCII format that is not recognized by any importers, 
the Import Format Editor may display automatically. 

2. Select a custom format in the definition list. 

3. Click Next and select options in the Description and Search Type (see "Definition 
Options" on page 210) dialog. 

4. Click Next and select options in the General Properties (see "General Properties 
Options" on page 212) dialog. 

5. Click Next and select options in the Fields (see "Fields Options" on page 213) 
dialog. 

6. Click Finish to create the importer file. 
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Tip: For each format type, you can select to show or not show the Import Format Editor 
automatically, every time you import an ASCII non-standard file. Set this option in the 
Select general properties (see "General Properties Options" on page 212) dialog of the 
editor. When checked, the Test section displays the actual contents of the file and a 
sample of how it will be parsed using the selected format. For details, see Fields 
Options (on page 213). 

To test a custom format importer:  

1. Select a custom format in the definition list. 

2. Click Test in any of the four Import Format Editor dialogs. The dialog expands. 

3. Click Read File and select the number of lines you want the importer to read. If you 
select View File, it will open in a text editor. 

4. Click the  icon and navigate to the type of file you want to import, and click 
Open. The importer will read the file and highlight any values that it is unable to 
convert. 

Note: The file must have the same file extension as the importer you chose. 

5. Select a different importer or edit the file to accommodate the reported errors. 

Related topics 

 Definition Options (on page 210) 
 Description and Search Type Options (on page 211) 
 General Properties Options (on page 212) 
 Fields Options (on page 213) 
 Import Data Formats 
 Reference: Regular Expressions (on page 214) 

 

Definition Options 

Use these options to create new format definitions. These buttons appear to the right of 
the list of definitions on the first dialog of the Import Format Editor. 
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Options 

New Click this to enter a new definition name in the list. A unique name is 
required; a descriptive name is recommended. Click any other definition 
row to finish.  

Copy After you click on description (listing on left), click Copy to enter a 
definition name. A unique name is required; a descriptive name is 
recommended. Click OK to return. 

Rename Select the name of one of the custom formats you have created, and click 
this to edit the name. 

Delete After you click on a description (listing on left), click this to remove the 
definition from the list. 

Note: To remove a description as an import option, you can click the Enable checkbox 
until no green check appears. If you would do not want to display these disabled 
descriptions, enable Only show enabled definitions at the bottom left of the dialog box.  

Related topics 

 Description and Search Type Options (on page 211) 
 General Properties Options (on page 212) 
 Fields Options (on page 213) 
 Import Data in a Custom Format (on page 209) 
 Reference: Regular Expressions (on page 214) 

 

Description and Search Type Options 

Use these options to define the type of custom importer you want to create, and add a 
description. They are available in the second dialog of the Import Format Editor. 

Options 

Description Enter a descriptive string to describe this importer (optional). 

Type Select the option that describes the file you want to import:  

Delimited - this file contains data that is separated by a specific 
character. 

Fixed Width - this file contains data that is in pre-defined columns. 

Search for Text - this file contains data marked on either side by a text 
string. 

Regular Expression - this file contains data that can be identified with 
a regular expression (see "Reference: Regular Expressions" on page 
214). 

Related topics 

 Definition Options (on page 210) 
 General Properties Options (on page 212) 
 Fields Options (on page 213) 
 Import Data in a Custom Format (on page 209) 
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 Reference: Regular Expressions (on page 214) 
 

General Properties Options 

Use these options to define how you want the file delimited and saved, and the data 
stored. They are available in the third dialog of the Import Format Editor. 

Options 

Delimiter Select the character that separates the fields from drop-down 
list. If you select <other>, you must specify the required 
character.   
This can be one of the following: _ ) ( * & ^ % $ # @ ! ~ `   

Store points as Surface - creates a surface model from the points; no 
individual points are stored in the project. 

Points - creates individual points in the project.  
Default file extension 
(recommended) 

Enter the default extension for the import format. The import 
analyzer uses this extension to help it decide what conversion 
options to offer the user in the context menu.  This field is 
optional.  If left blank, a default extension of ".txt" is assumed. 

Show editor on import Check to automatically open the Import Format Editor when 
importing a non- standard ASCII file. 

Text qualifier Enter a special character to identify the beginning and ending 
of the string, for example ". 

Skip number of header 
lines 

Enter the number of lines to skip at the beginning of the file 
before reading the data to import. 

Start undefined ID 
numbering 

Enter a number to use as the starting ID when 
auto-generating IDs for unidentified points during import. 

If no number is entered, this software will not assign a 
number to unidentified points during import.  

Undefined elevation Enter a character or value to indicate that an elevation has not 
been assigned. 

Coordinate quality Select a coordinate quality to assign to the imported 
data.  Control quality data is fixed, mapping and survey 
quality data is weighted, and unknown quality data is not used 
during the computation of the project.  

Tip: For large point files, select unknown 
quality; the program will perform faster.
Note: If you want to be able to edit the 
point quality within the software, select 
control or survey quality on import.  

Related topics 

 Definition Options (on page 210) 
 Description and Search Type Options (on page 211) 
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 Fields Options (on page 213) 
 Import Data in a Custom Format (on page 209) 
 Reference: Regular Expressions (on page 214) 

 

Fields Options 

Use these options to define the fields that you want to import, and their field order, and 
units. The options vary slightly based on the type of converter you are creating. They 
are available in the fourth dialog of the Import Format Editor. 

Options 

Fields Click Fields to display a drop-down list of data 
properties.  Select one and a tag appears as a field in the row 
of data. Continue to select all the fields that you want to 
import. 

Note: If you select the properties out of order, you can click 
and drag them into the proper order. 

Units 

Apply to all 

To select the distance units for all data, select the units and 
enable the Apply to all check box.  You can also disable the 
Apply to all check box, and select a unit for each exported 
field.  

For Fixed Width (only) Click on each field, and enter a Start and End value or a 
Start and Width value - the third value will be filled in 
automatically. 

For Search for Text (only) Click on each field, and enter text values to search for the 
Start and End the field. 

Note: Spaces will not be visible in the Start and End fields, 
but you can see them in the Preview area. 

For Regular expression 
(only) 

Click Next to display the dialog box for entering a regular 
expression (see "Reference: Regular Expressions" on page 
214). 

Test 

Enter file name 

Read file 

Click Test to open the testing display area.  To test the 
current format on a specific file: 

4. Browse for the file. 

5. Click Read file to view the results. 

You can continue to modify the format setting and Read 
file the results until you are satisfied. 

Related topics 

 Definition Options (on page 210) 
 Description and Search Type Options (on page 211) 
 General Properties Options (on page 212) 
 Import Data in a Custom Format (on page 209) 
 Reference: Regular Expressions (on page 214) 
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Reference: Regular Expressions 

A regular expression is a formula composed of characters and operators that represent a 
specific pattern. This formula is used to locate text strings that match this pattern. 

A simple example is searching your computer for a list of all the files that have the .txt 
extension. To do this, you use the substitution formula *.txt where * represents any 
alphanumeric characters A-Z or 0-9. Similarly, regular expressions allow you to create 
a formula that represents the text pattern to search for. 

Regular expressions can be simple or very complex. For example, you can write 
expressions to search for a: 

 specific sequence of characters 

 specific format such as (999)999-9999 to find phone numbers 

 special characters such as spaces or tabs 

 repeated words (or any text string) 

 one text string always followed by another text string 

By using operators in your expression, you can find text that matches a pattern or text 
that does NOT match the pattern. 

For a quick tutorial on regular expressions, visit: 

http://www.codeproject.com/dotnet/RegexTutorial.asp 
http://www.codeproject.com/dotnet/RegexTutorial.asp 

Syntax 

The syntax for writing regular expressions is comprised of several subsets, including: 

 Substitutions - characters and operators used in replacement patterns 

 Character Classes - used to match Unicode, white- space characters, non-word 
characters, etc. 

 Regular Expression Options - for modifying how a pattern is matched 

 Character Escapes - used to indicate that a special character is to be matched 

 Quantifiers - used to specify the number of matches to find 

Grouping Constructs - used to match groups and sub- groups of text strings Syntax details 
are located at: 

http://en.wikipedia.org/wiki/Regular_expression 
http://en.wikipedia.org/wiki/Regular_expression 

Related topics 

 Definition Options (on page 210) 
 Description and Search Type Options (on page 211) 

http://www.codeproject.com/dotnet/RegexTutorial.asp
http://www.codeproject.com/dotnet/RegexTutorial.asp
http://en.wikipedia.org/wiki/Regular_expression
http://en.wikipedia.org/wiki/Regular_expression
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 General Properties Options (on page 212) 
 Fields Options (on page 213) 
 Import Data in a Custom Format (on page 209) 

 

Run an Import Report 
Generate an Import Report to see a project summary, details on imported files, and any 
associated errors or warning messages. 

To run an Import Report:  

 Select Reports > Import Report. 

 Select Reports > Report Options. Select Import Report in the command pane, and 
click OK. 

The Import Report displays in your default Web browser. 

Tip: Click a file name in the report to jump to the creation and import dates and times. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Troubleshoot an Import Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

LandXML data imports 
in the wrong location or 
configuration. 

Project units are not set 
correctly. 

Check the units shown on the 
status bar. If they are not correct, 
undo the import. Then, click the 
units name to open the Project 
Settings dialog. Change to the 
correct type of units, and 
reimport the file. 

A LandXML file will not 
import. The program's 
importer says it is a 
LandXML file, but when 
you try to import it, a 
message says the file is 
invalid. 

The file is valid XML, but 
not valid LandXML. 

Open the file in your default Web 
browser. If it is corrupt, you will 
get an error message. If you do not 
get a message, it may be valid 
XML, but not valid LandXML, in 
which case the file needs to be 
recreated in a valid LandXML 
format. 

Custom point data (.csv) 
imports at the wrong 
location. 

1. Your project units are not 
set correctly. 

2. The wrong custom 
import definition was 
selected; the northing and 

1. Make sure that your project 
units are set correctly. 

2. Check the custom import 
definition you used to import the 
points. If you accidentally 



Trimble® Business Center 
Heavy Construction Edition User Guide 216 

 Import Data

easting order are reversed. selected the definition with the 
northing and easting reversed, 
undo the import and reimport 
with the correct definition. 

Duplicate points were 
created for points in an 
imported text file and 
points already in the 
project that have the 
same ID (that is, points 
were not merged as 
expected). 

If you import a text file with 
"Unknown" or “Mapping” 
coordinate quality into a 
project that already 
contains point data, 
duplicate points will be 
created for points in the text 
file (lightweight points (see 
"Understanding Point 
Types" on page 269)) and 
points already in the project 
(normal points (see 
"Understanding Point 
Types" on page 269)) that 
have the same ID.  

Import the text file into the 
project first to create the 
lightweight points, then import 
the other point data. The 
lightweight points from the text 
file will merge with the normal 
points from the other point data 
to create normal non-duplicated 
points. 
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Transfer/Synchronize Data 

Prepare to Connect a Field Device 
Transfer and synchronize data between field devices and your computer using one of 
two methods: Direct connection via the Device pane, or Office Synchronizer via the 
data synchronization area. 

Options 

Device pane (on page 11) Use this and a direct connection to update files 
directly on the field device and to import data 
directly from the field device. 

Office Synchronizer and the data 
synchronization area (see "Office 
Synchronizer" on page 219) 

Use these to manually or automatically synchronize 
data between a field device and your 
computer. Using the data synchronization area 
allows you to prepare field data and create export 
files without physical connection to the field device. 
The upload process is a separate automated step.  

To prepare for using a direct connection: 

1. If necessary, install Microsoft® ActiveSync® software.  If this wasn't done during 
installation, then do so now. (Enter ActiveSync as a search topic on the 
http://www.microsoft.com/downloads http://www.microsoft.com/downloads 
site.) 

Note: For Microsoft Vista users, ActiveSync technology is not required. The 
communication functionality needed is included with Vista. 

2. Start this software. 

3. Connect the field device to the computer using a USB connection or a serial 
connection. 

4. If the device asks if you want to be connected, click Yes. The Device pane appears, 
listing the files on the field device. 

http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
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Note: When a field device is in direct connection mode, the Office Copy mode is not 
available. 

To prepare for data synchronization: 

1. If necessary, install Microsoft® ActiveSync® software.  If this wasn't done during 
installation, then do so now. (Enter ActiveSync as a search topic on the 
http://www.microsoft.com/downloads http://www.microsoft.com/downloads 
site.) 

2. If necessary, install Office Synchronizer. If this wasn't done during installation, 
then install it from this software's installation CD. 

3. Run Office Synchronizer, and select Tools > Synchronizer Options. Verify the 
following options: 

 Sync options tab > Sync Mode = Manually 

 Display tab > Check Set ActiveSync to work in "Guest Only" mode 

4. Connect the field device to the computer using a USB connection or a serial 
connection.  When you connect a device for the first time, enter the following 
data: 

 Device name - a unique name to be associated with the device 

 Field crew information (optional) 

 System root folder location - a folder on the computer or network location 
accessible to the computer.  This folder will store the synchronized data. This 
data is stored on the field device.   

Related topics 

 Upload Files (via Direct Connect) (see "Upload Files (via Direct Connection)" on 
page 221) 

 Download Files (via Direct Connect) (see "Download Files (via Direct Connection)" 
on page 221) 

 Upload Files (via data synchronization) (on page 224) 
 Download Files (via data synchronization) (on page 223) 

 

Synchronizing Data for SCS 

In preparing and managing site data, design data, and work orders for site controller 
software (SCS), you do not need to use the Device pane to synchronize with the data 
synchronization area. The synchronization happens automatically when you resolve 
conflicts and finish SCS commands. 

http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
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Office Synchronizer 
Office Synchronizer is a separate utility that transfers data files between your 
computer and your CE-based field device/site controller, and verifies that the data in 
both locations is the same, or synchronized. 

Data synchronization area 

The data synchronization area (also known as the synchronizer root folder) is the 
folder structure that stores synchronized field data on your computer or computer 
network. This folder is used by the Office Synchronizer utility, any field devices that 
have been synchronized with the Office Synchronizer, and this software. Files to be 
uploaded to field devices and files downloaded from field devices are located in the 
folder. 

If necessary, you can enter, change, or verify the location of the data synchronization 
area by selecting Tools > Options and clicking General and File Locations. Check the 
Synchronizer root folder path. 

Related topics 

 Export Data Formats 
 File Location Options (on page 142) 
 Import Data Formats 
 Prepare to Connect a Field Device (on page 217) 

 

Device Pane 
The Device pane enables you to directly access Microsoft® Windows® CE-based field 
devices or the data synchronization area (also known as the root sync folder in the 
Office Synchronizer utility), which contains the files maintained by Office 
Synchronizer. 

To display the Device pane: 

Do one of the following: 

 Click the  icon on the toolbar. 

 Select View > Device Pane. 

 Press [F10] on the keyboard. 

The Devices pane displays, docked on the left side of the application window, or 
where you positioned it last. 

To connect to a f ield device: 

1. Connect the field device to the computer using a USB or serial connection. 
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2. If the device asks if you want it to be connected, click Yes. The Device pane 
displays, showing a list of files on the device. 

 
3. As needed, upload (see "Upload Files (via Direct Connection)" on page 221) or 

download (see "Download Files (via Direct Connection)" on page 221) files via this 
direct connection. 

To connect to f ield data in the data synchronization area: 

In Office copy mode, the Device pane points to a folder on your office computer that 
contains the data previously synchronized from the field device, using the Office 
Synchronizer utility (see "Office Synchronizer" on page 219). 

 

1. To verify that data in the synchronization area is selected, click the  icon, and 
verify that Office Copy is checked in the drop-down list. The contents of the 
synchronizer root folder display. 

2. As needed, upload files (see "Upload Files (via data synchronization)" on page 224), 
upload tasks (see "Upload Tasks (via data synchronization)" on page 225), or 
download files (see "Download Files (via data synchronization)" on page 223) from 
the data synchronization area. 

Related topics 

 Office Synchronizer (on page 219) 
 Pane and Data View Positioning (on page 31) 
 Prepare to Connect a Field Device (on page 217) 
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Direct Connection 

Download Files (via Direct Connection) 

Download files to copy them from a connected field device to your office computer. 

To download a f i le and import it  into a project:  

1. Open a project, or start a new project. 

2. Connect the field device to the computer using a USB connection or a serial 
connection. 

3. If the device asks if you want it to be connected, click Yes. The Device pane 
displays, listing the files on the field device. 

4. Select one or more files to download from the device. 

5. Do one of the following to import into the project: 

 Click the  icon on the toolbar. 

 Click and drag the selected file(s) into the plan view of the project. 

Related topics 

 Import Data Formats 
 Prepare to Connect a Field Device (on page 217) 
 Upload Files (via Direct Connection) (on page 221) 

 

Upload Files (via Direct Connection) 

Upload files to copy them from your office computer to a connected field device. 

To upload a f i le:  

1. Open the project from which you want to export data. 

2. If the field device is not connected: 

 Connect the field device to the computer using a USB connection or a serial 
connection. 

 If the device asks if you want it to be connected, click Yes. The Device pane 
appears within this office software, and lists the files currently on this field 
device. 

3. Click the  icon on the Device pane toolbar. The Export pane displays, listing 
compatible formats in the File Format list. 

4. Select the format to export. 

5. If data has not been selected, select it, or click Options for selection options.  
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Note: You can also select the data to export prior to clicking the   icon. 

6. Verify the default file name is correct, or enter a different name for the exported 
file in the File Name box. 

7. Select any file specific settings in the Settings group. 

8. Click OK. The exported file is converted to the appropriate format and uploaded to 
the field device. The file list in the Device pane updates, showing the new file 
name. 

Related topics 

 Export Data Formats 
 Select from Plan View (see "Select from 2D Views" on page 44) 
 Select via Command (see "Selection Methods and Options" on page 43) 
 Prepare to Connect a Field Device (on page 217) 
 Download Files (via Direct Connection) (on page 221) 

 

Upload Tasks (via Direct Connection) 

Upload files to field devices using the Task list on the Device pane toolbar. You can 
upload to: 

 Trimble® Survey ControllerTM 

Trimble® Digital FieldbookTM These file types can be uploaded: 

 Feature code library (.fxl) files (converted to .fal files for Survey Controller 
versions prior to 11.3) 

 Data dictionary (.ddf) files (converted to .fal files for Survey Controller versions 
prior to 11.3) 

 Antenna (.ini) files 

 Geoid (.ggf) files (including sub-grids) 

 Datum grid files (.dgf) 

To upload a f i le:  

1. Connect the field device to the computer using a USB connection or a serial 
connection. 

2. If the device asks if you want it to be connected, click Yes. The Device pane displays 
in this software. 
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3. Select the device to which you want to export the file in the Device list. If there is 
only one device available, this is not necessary. 
 

 
  

4. Click Tasks, and select the file type from the list. The Open dialog displays for .fxl, 
.ddf, and .ini files. For .dgf files, the Select Datum Grid Files for Upload dialog 
displays, and for .ggf files, the Geoid Sub-Gridding command pane displays.  

5. Browse to the file you wish to upload, and click OK, or click Upload in the Geoid 
Sub-Gridding command pane. 

6. Click the   icon on the Device pane toolbar to see the exported file list. 

Related topics 

 Prepare to Connect a Field Device (on page 217) 
 Download Files (via Direct Connection) (on page 221) 
 Upload Files (via Direct Connection) (on page 221) 

 

Data Synchronization 

Synchronizing Data for SCS 

In preparing and managing site data, design data, and work orders for site controller 
software (SCS), you do not need to use the Device pane to synchronize with the data 
synchronization area. The synchronization happens automatically when you resolve 
conflicts and finish SCS commands. 

Download Files (via data synchronization) 

Before you download files, use Office Synchronizer (on page 219) to synchronize the 
field device from which you are importing a file. 

Downloading a file creates an export file, and copies it to the data synchronization area 
for synchronizing. 

To download a f i le and import it  into a project:  

1. Open the project into which you want to download the file, or start a new project. 

2. Open the Device pane by doing one of the following: 

 Select View > Device Pane. 
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 Click the  icon. 

 Press [F10]. 

The Device pane displays. 

Note: If a field device is directly connected, you will not be able to continue. 
Disconnect the device and start over. 

3. Click the  icon, and verify that Office Copy is checked in the drop-down list. The 
contents of the data synchronization area display. 

4. Select the device from which to import the files. 
 

 
  

5. Select the files to import and do one of the following to import into the project: 

 Click the  icon. 

 Click and drag the selected file(s) to the plan view of the project. 

Related topics 

 Import Data Formats 
 Prepare to Connect a Field Device (on page 217) 
 Upload files (via data synchronization) (on page 224) 

 

Upload Files (via data synchronization) 

Upload files to copy them from your office computer to the data synchronization area. 
The synchronizer root folder is created when you synchronize field devices using the 
Office Synchronizer utility (see "Office Synchronizer" on page 219). 

Note: To view or change the location of your data synchronization area, select Tools > 
Options > File locations. 

To upload a f i le:  

1. Open the project from which you want to export data. 

2. Open the Device pane by doing one of the following: 

 Select View > Device Pane. 

 Click the  icon on the toolbar. 



Trimble® Business Center 
Heavy Construction Edition User Guide 225 

 Transfer/Synchronize Data

 Press [F10]. 

The Device pane displays. 

3. Click the  icon and verify that Office Copy is checked in the drop-down list. 

4. Select the device to which you want to export the file. 
 

 
  

5. Select the data to export. 

6. Click the  icon on the Device pane toolbar. The Export pane opens and displays a 
list of possible formats. 

7. Select the file format to export. If data has not been selected, select it. 

8. Verify the default file name is correct, or enter a different file name for the 
exported file. 

9. Verify the settings options. 

10. Click OK, and then close the Export pane to view the Device pane underneath. 

11. Click the  icon on the Device pane toolbar to see the exported file list. 

Note: Before taking the field device out to the field, the Office Synchronizer must 
synchronize the field device to which you are exporting a file. 

Related topics 

 Prepare to Connect a Field Device (on page 217) 
 Download files (via data synchronization) (on page 223) 
 Export Data Formats 

 

Upload Tasks (via data synchronization) 

Upload files to field devices using the Task list on the Device pane toolbar. You can 
upload to: 

 Trimble® Survey ControllerTM 

 Trimble® Digital FieldbookTM 

Note: To activate the Tasks drop-down list, you must first synchronize (see "Office 
Synchronizer" on page 219) your field device. 
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These file types can be uploaded: 

 Feature code library (.fxl) files (converted to .fal files for Survey Controller 
versions prior to 11.3) 

 Data dictionary (.ddf) files (converted to .fal files for Survey Controller versions 
prior to 11.3) 

 Antenna (.ini) files 

 Geoid (.ggf) files (including sub-grids) 

 Datum grid files (.dgf) 

To upload a f i le:  

1. Open the Device pane by doing one of the following: 

 Select View > Device Pane. 

 Click the  icon on the toolbar. 

 Press [F10]. 

The Device pane displays. 

2. Click the  icon, and verify that Office Copy is checked in the drop-down list. The 
contents of the folder display. 

3. Select the device to which you want to export the file. 
 

 
  

4. Click Tasks, and select the file type from the list.  

 For .fxl, .ddf, and .ini files, the Open dialog displays. 

 For .dgf files, the Select Datum Grid Files for Upload dialog displays. 

 For .ggf files, the Geoid Sub-Gridding command pane displays.  

5. Browse to the file you wish to upload, and click OK, or click Upload in the Geoid 
Sub-Gridding command pane. 

6. Click the  icon on the Device pane toolbar to see the exported file list. The new 
file will be copied to the field device the next time you synchronize. 
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Related topics 

 Prepare to Connect a Field Device (on page 217) 
 Upload files (via data synchronization) (on page 224) 

 

Upload Geodetic Reference Data 

Upload a Datum Grid File 

Select a datum grid file (.dgf) based on the datum used in the project coordinate system, 
and upload it to a field device. 

To upload a datum grid f i le:  

1. Connect the field device to which you want to upload a geoid. The Device pane 
displays. 

2. On the pane's toolbar, click Tasks, and select Upload datum (.dgf) file. The Datum 
Gridding command pane displays. 

3. If needed, select the folder containing the installed datum files in the Folder list, or 
click the  icon and navigate to the folder. 

Note: The default location for .dgf files depends on your operating system: 
 In Windows® XP or earlier:  C:\Documents and Settings\All Users\Application 
Data\Trimble\GeoData unless you have previously installed Trimble® Geomatics 
OfficeTM (TGO). If you have installed TGO and then this software, the path is 
C:\Program Files\Common Files\Trimble\GeoData. 
In Windows VistaTM:   C:\ProgramData\Trimble\GeoData\ or C:\Program 
Files\Common Files\Trimble\GeoData\. 

4. Select a datum grid file in the Datum Grid Files (.cdg) list, if the datum you need isn't 
in the list, create a datum grid file (on page 174). 

5. Click Upload. The datum file appears in the Other Files folder of the Device pane's 
tree. 

Note: If you use the datum associated with your project's coordinate system, but do not 
create a datum grid file, it will not be saved in the list of datum grid files available the 
next time you upload. If it is a datum you will need again, create a datum grid file that 
will be saved. 

Related topics 

 Create a Datum Grid File (on page 174) 
 Datum Grid Options (on page 176) 
 Upload Tasks (via Direct Connection) (on page 222) 
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Upload a Geoid File 

Select a geoid grid file (.ggf) based on the geoid used in the project coordinate system, 
and upload it to a field device. 

1. Connect the field device to which you want to upload. The Device pane displays. 

2. On the pane's toolbar, click Tasks, and select Upload geoid (ggf) file. The Geoid 
Sub-Gridding command pane displays. 

3. If needed, select the folder containing the installed geoid files in the Folder list, or 
click the  icon and navigate to a folder containing .ggf files. 

4. Select a geoid file in the Geoid File list. 

5. Click Upload. The geoid file appears in the Other Files folder of the Device pane's 
tree. 

Note: If the geoid grid file is larger than 1 MB, a confirmation message displays, 
asking if you really want to upload it. Consider defining a sub-grid (see "Define a 
Geoid Sub-Grid" on page 177) of the geoid to make the file smaller. 

Related topics 

 Geoid Options (on page 177) 
 Define a Geoid Subgrid (see "Define a Geoid Sub-Grid" on page 177) 
 Upload Tasks (via Direct Connection) (on page 222) 

 

Troubleshoot a Data Transfer/Synchronization Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

Active Sync 4.5 will not 
run. 

You are running as a 
limited user. Active Sync 
4.5 is not compatible 
with limited user 
accounts. 

Change you permissions to the 
administrator level, or download and 
use Active Sync 4.0. 
Start > Control Panel > User 
Accounts > User Accounts. In 
the User Accounts dialog, select your 
user name in the list and click 
Properties. In the Properties dialog, 
click the Group Membership tab. 
Select Other, and Administrators in 
the list. Click OK twice to close the 
dialogs. 
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Work with GNSS Data 

Planning Utility 
Use the Planning utility to plan and schedule a GPS project based on good and bad 
satellite coverage information. 

To access the uti l ity:  

 Select Tools > Planning. 

Note: The Planning software has its own help system. Open the utility and select Help > 
Index from the Planning menu or press [F1] within the software. 

Check GNSS Data 

Run a Point List Report 

Generate a Point List to see a simple summary of the coordinates for each point in your 
project. 

To run a Point List report:  

 Select Reports > Point List.  

The Point List displays in your default Web browser. 
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To modify the report:   

 Select Reports > Report Options. Select Point List in the command pane, and click 
OK. 

 In the Settings group at the bottom of the command pane, you can specify the type 
of coordinates (grid, local, or global), and the type of data to display.  The data 
options include quality control information such as scale factors and convergence 
angle.  

Tip: Click a point ID in the report to select the point in graphic views and the Project 
Explorer.  

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Run a Point Derivation Report 

Generate a Point Derivation Report to see details on the survey data used to calculate the 
final coordinates of points in your project. 

To run a Point Derivation Report:  

 Select Reports > Point Derivation Report. 

 Select Reports > Report Options. Select Point Derivation Report in the command 
pane, and click OK. 

The Point Derivation Report displays in your default Web browser. 

Tip: Click a point ID or coordinate in the report to select the point in graphic views and 
the Project Explorer. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Calculate the Inverse Between Points 

Calculate and report inverse values between any two points in your project, such as: 

 Grid distance 

 Change in elevation 

Geodetic azimuth To calculate the inverse between two points: 

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Survey > Inverse.  

The Inverse command pane displays. 
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2. Select Sequential to calculate values from point to point in series (as if drawing a 
multi-segment line), or Radial to calculate values from one point to multiple other 
points (as if drawing a fan).  

Note: You can switch between Sequential and Radial after picking any pair of 
points. 

3. Pick the first point in a graphic view, or type a point ID in the From box. 

Note: You can also right-click in the view to access COGO controls (see 
"Understanding COGO Controls" on page 86) and snaps (see "Snaps Modes and 
Commands" on page 89) when picking points.  

4. Pick another point, or type a point ID in the To box. The point IDs appear in the 
Reported Points group, and the inverse values appear in the Details group. 

Note: If Free appears in the Reported Points list, no point with a point ID was within 
the pick aperture. To prevent picking where there are no points, click the  icon 
on the Inverse command pane's toolbar. In the Snap Mode dialog, uncheck Free, and 
click OK. 

5. To calculate additional inverses, continue picking To points. 

6. To review the details for any inverse, click in the first column of the Reported 
Points list. 

7. To change inverse report options, click the  icon to display the Report Options 
command pane. When you are done, click OK to return to the Inverse command. 

8. To generate the Inverse Results report, click the  icon at the top of the Reported 
Points group. The Inverse Results report displays in your default web browser.  

Note: If no coordinate system is defined, the Select Coordinate System dialog 
displays. Define a coordinate system and run the report again. 

9. Click Close. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 Inverse Options (on page 231) 
 Measure Values Between Points (on page 135) 

 

Inverse Options 

Use these options to calculate and report the azimuth, distance, and other relationships 
between any two points. They are available in the Inverse command pane. 
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Options 

 Click this on the Inverse command pane's toolbar to display the 
Snap Mode dialog, where you can enable and disable running 
snap modes. 

Inverse 

From/To Pick points in graphic views, or type point IDs in the boxes and 
click Apply or press [Enter]. 

Note: If Free appears in the Reported Points list, no point with a 
point ID was within the pick aperture. To prevent picking where 
there are no points, click the  icon on the Inverse command 
pane's toolbar. In the Snap Mode dialog, uncheck Free, and click 
OK. 

 Sequential – Data is collected in a line, and you want to verify 
distances around the traverse.   

 For example, you will need to click on: 

A to B, B to C, C to D, D to E, and E to A. 

Radial – Data is collected in a ray, and you want to check distance 
from the base station.  

 For example, you will need to click on:      A to B, A to C, A to 
D, and A to E. 

Reported points 

 Click this to display the Inverse Results report in your default 
web browser. 

 Click this to display the Report Options command pan, in which 
you can specify heading, footer, and format settings for the 
Inverse Report. 

From point ID/ 

To point ID 

Click in the first column of any row to list details for the inverse 
of the points. 

Details This shows the azimuths, changes in elevation and height, and 
three distances of the selected inverse: 

 Grid 

 Ellipsoidal 

 Ground 
Apply This acts as the [Enter] key, when specifying points, moving the 

focus between From, To, and Reported Points. 

Related topics 

 Calculate the Inverse Between Points (on page 230) 
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Work with Total Station Data 

SURVEY  
 

Understanding Total Station Data 

SURVEY  

Survey data acquired in the field using a total station and contained in a data file can be 
imported into the software and integrated, as necessary, with other data collected as 
part of a survey project (for example, GNSS or leveling data).  

Total station data is displayed in the following areas of the software:  

 Project Explorer   

Imported data is displayed in expandable nodes displayed beneath the Import Files 
node. Data used to define points is displayed in expandable nodes displayed 
beneath the Points node. You can expand and collapse nodes as necessary to view 
information. For more information, see View Total Station Data in Project 
Explorer (on page 240). 

 Properties pane  

Click any node in the Project Explorer to display its properties in the Properties pane. 
You can edit certain properties in the pane. 

 Mean Angle Residuals dialog  

Right-click any mean angle node in the Project Explorer and select Mean Angle 
Residuals to view residuals for the mean angle and, if you want, disable any 
outlying observations. For more information, see View and Edit Mean Angle Residuals 
(on page 248). 

 Mean Angle Report 

Select Reports > Mean Angle Report to view details of how each mean angle was 
computed. For more information, see Run a Mean Angle Report (on page 249). 



Trimble® Business Center 
Heavy Construction Edition User Guide 234 

 Work with Total Station Data

 Graphical and spreadsheet views 

View point information in any of the available graphic or spreadsheet views. 

The type of total station data displayed in the software depends on the station setup 
type (see "Total Station Setup Types" on page 234) and measurement types (see "Total 
Station Measurement Types" on page 236) used for the survey.  

Related topics 

 Total Station Setup Types (on page 234) 
 Total Station Measurement Types (on page 236) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 

 

Total Station Setup Types 

SURVEY  

The software supports any of the following types of station setups in the imported total 
station data file. The different station setups support specific geometrics of known 
points for orientation. 
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Station setup type Descript ion 

single backsight The coordinate for the occupied point must be keyed 
in, previously measured, or filled in at a later time.  

The coordinate for the backsight or the azimuth to the 
backsight must be keyed in or previously measured.  

All horizontal angles are measured relative to the 
backsight. 

station setup plus (multiple 
backsight) 

The coordinate for the occupied point must be keyed 
in, previously measured, or filled in at a later time.  

The coordinates for the backsights or the azimuths to 
the backsights must be keyed in or previously 
measured.  

All horizontal angles are measured relative to the first 
backsight.  

This setup has redundant information so it is easy to 
detect errors in the backsight coordinates, azimuths, 
or instrument setup. 

standard resection This setup type requires at least two backsight points.  

The coordinates for the backsights or the azimuths to 
the backsights must be keyed in or previously 
measured.  

All angles are measured relative to the first backsight. 

This setup can have redundant information so it is 
easy to detect errors in the backsight coordinates, 
azimuths, or instrument setup. 

Helmert resection This setup type is a variation of a standard resection 
setup type. Instead of using least squares to find the 
best fit of known points and observed data, a Helmert 
coordinate transformation is used. 

refline This setup type requires two points on a line, or one 
point and the azimuth of the line.  

The coordinate for the first point on the line must be 
keyed in, previously measured, or filled in at a later 
time.  

The azimuth to the second point or the coordinate for 
the second point must be keyed in or previously 
measured. 



Trimble® Business Center 
Heavy Construction Edition User Guide 236 

 Work with Total Station Data

 

Related topics 

 Understanding Total Station Data (on page 233) 
 Total Station Measurement Types (on page 236) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 

 

Total Station Measurement Types 

SURVEY  

The software supports any of the following types of measurements in the imported 
total station data file. 
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Measurement type Descript ion 

distance offset The surveyor measures to a convenient point near the 
object and enters Left/Right, Up/Down and In/Out 
position offsets so the object position can be calculated 
from the measured point.  

You can edit the three offset values and direction after 
importing the data. 

horizontal angle offset The surveyor measures to the side of the object, then 
he turns a horizontal angle to the center. The offset is a 
combination of the slope readings taken to a prism and 
the horizontal angle after aiming the instrument to the 
center of the measured object.  

Because these are measured values, you cannot edit 
them after importing the data. 

vertical angle offset The surveyor measures to a point above or below the 
object, then he turns a vertical angle to the center. The 
offset is a combination of the slope readings taken to a 
prism and the vertical angle after aiming the 
instrument to the center of the measured object.  

Because these are measured values, you cannot edit 
them after importing the data. 

angle offset The surveyor measures to a point to the side of the 
object and above/below the object, then he turns a 
horizontal and vertical angle to the center. The offset is 
a combination of the slope readings taken to a prism 
and the angles after aiming the instrument to the 
center of the measured object.  

Because these are measured values, you cannot edit 
them after importing the data. 

circular object The surveyor measures to a point directly in front of a 
circular object, then he turns an angle to either edge. 
The center and radius are calculated from these two 
measurements.  

Because these are measured values, you cannot edit 
them after importing the data. 

dual prism offset The surveyor measures to prism A and then to prism B. 
The position of the rod point is calculated from these 
measurements and from the B-C distance (the distance 
from the rod point to the nearest prism) the surveyor 
keys in.  
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You can edit the B-C distance and prism constants after 
importing the data. 

 

Related topics 

 Understanding Total Station Data (on page 233) 
 Total Station Setup Types (on page 234) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 

 

Workflow for Total Station Data 

SURVEY  

Use the following steps as a guideline for working with total station data you have 
imported into a project: 

1. Import (see "Import Data" on page 193) the total station data file into your project.  

The data is displayed as nodes (see "View Total Station Data in Project Explorer" on 
page 240) located beneath the Imported Files node and the Points node in the Project 
Explorer. 

2. Click Reports > Import Report to view information about the import and any 
related messages. The Import Summary report displays in a browser window. 

3. Run a Survey Report to view complete information about imported total station data 
contained in a .job or .jxl file. For instructions, see Run a Job File Report. Be sure to 
select the Survey Report style sheet for the report. 

4. In Project Explorer, click the new imported data file node, which is located beneath 
the Imported Files node, and verify job information in the Properties pane. (See 
View Total Station Data in Project Explorer (on page 240).) 
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5. If necessary, fill in any coordinates from standard references. 

6. Review the chronology and correctness of the imported data in the Project Explorer. 

Expand the nodes under the Imported Files node and review in chronological order 
(top to bottom) to ensure data was gathered correctly and good survey practices 
were followed.  

7. As necessary, view information in the Project Explorer and in the Properties pane to 
verify information is correct. 

In the Properties pane, you can edit data entered manually in the field. But, you 
cannot edit measurements made by the device. If you find an error that cannot be 
corrected because the Properties pane field is read-only, the field crew must 
re-survey that portion of the project. You can delete the old station nodes that 
contain errors and import the file that contains the re-surveyed stations. If 
necessary, you can delete any redundant information. 

Tip: If a coordinate or azimuth appears to be missing, look for it earlier in the file. It 
could have been keyed in as part of an earlier setup or it may have been determined 
from a resection. Coordinates determined as part of a traverse appear later in the 
file because they can only be determined after the traverse is complete. 
Tip: To determine the angle between two observations, expand the nodes under the 
station from which the first observation is made. Click on that observation to view 
the horizontal angle to the first backsight. Then, click on the station setup node to 
view the orientation angle of the first backsight. Add these two numbers to 
determine the orientation angle of the first observation. Repeat this procedure for 
the second observation and subtract the two orientation numbers. 

8. In Project Explorer, right-click any mean angle node and select Mean Angle Residuals 
from the context menu to display the Mean Angle Residuals dialog. 

Use this dialog to view and edit mean angle residuals (on page 248). 

9. Select Reports > Mean Angle Report to view details (see "Run a Mean Angle 
Report" on page 249) of how each mean angle was computed. 

10. Select Reports > Point Derivation Report to see how multiple observed 
measurements to the same point are being used by the software to compute the 
resultant coordinate, and how the measurements compare to each other.  

Tip: When viewing the Point Derivation Report, you are especially looking for 
unacceptably high residuals. 

After total station data is imported into your project, you can view it in the graphical 
and spreadsheet views.  

Related topics 

 Understanding Total Station Data (on page 233) 
 View Total Station Data in Project Explorer (on page 240) 
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 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 

C H A P T E R  

View Total Station Data in Project Explorer 

SURVEY  

Total station data is displayed as individual nodes under two top-level nodes in Project 
Explorer: 

 Imported Files node  

This top-level node includes one or more data file nodes, each specifying a file 
containing GNSS, total station, and/or level field data that has been imported into 
the project. Individual total station nodes display beneath the file node(s) for 
imported total station data.  Total station nodes are typically listed in the same 
chronological sequence as data was gathered in the field. For more information, see 
Total Station Nodes Sequence in Project Explorer (on page 246).  

 Points node  

This top-level node includes a node for each point in the project. Individual total 
station nodes are displayed as appropriate beneath the points to which they 
pertain. 

You can double-click any node to display its properties in the Properties pane. You can 
right-click any node to display a context menu that includes other options, depending 
on the node type. 

For a description of how total station nodes are displayed in the Project Explorer, see the 
following topics: 

 View Imported Total Station Data in Project Explorer (on page 241) 

 View Total Station Data Associated with a Point in Project Explorer (on page 244) 

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 Total Station Nodes Sequence in Project Explorer (on page 246) 
 Total Station Data Errors (on page 247) 
 View and Edit Mean Angle Residuals (on page 248) 
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 Run a Mean Angle Report (on page 249) 
 

View Imported Total Station Data in Project Explorer 

SURVEY  

Each imported total station data file displays as an expandable node located beneath 
the Imported Files node in Project Explorer (select View > Project Explorer). 

The types of nodes displayed beneath the data file node depend on the station setup 
type and measurement types contained in the file. 

The sequence of nodes (top to bottom) displayed beneath the imported data file node 
reflects the chronological order in which data was gathered in the field. For more 
information, see Total Station Nodes Sequence in Project Explorer (on page 246). 

The following table shows the possible node types and their relative position beneath 
the Imported Files node in Project Explorer. 

Note: The following table is not intended to represent a single data file. 

Node type example Descript ion 

 Imported Files  This is the Imported Files node. 

 Test.jxl This is the imported data file node.  

The icon represents the source of the 
data. It is followed by the name of the 
file. 

  100 (S1) 
This is a station node.  

The icon represents the survey 
instrument type. It is followed by the 
point ID and an "S" number in 
parenthesis that uniquely identifies the 
station.  

  Used last station setup This is a note node.  

The icon is followed by the first few 
words of the note. 

   Single Backsight (99) 
This is the station setup node.  

The icon is followed by the setup type 
(in this example, "single backsight") and 
the associated backsight point ID(s) in 
parenthesis.  

Nodes displayed beneath this one are 
typically coordinate and azimuth 
nodes, which show data that was keyed 
in during station setup. 
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    100 This is a coordinate node.  

The icon is followed by a coordinate 
point ID.  

This node is typically displayed 
beneath a station setup node. 

This is a coordinate node from a 
benchmark. The icon is followed by a 
coordinate point ID. 

Note: To preserve the integrity of raw 
field data, you cannot edit coordinate 
properties for an imported coordinate 
displayed beneath the Imported Files 
node. However, you can edit 
coordinates displayed beneath the 
Points node.  

    100-99 (A1) This is an azimuth node.  

The icon is followed by the occupation 
point ID, a dash, and the the observed 
point ID. This is followed by an "A" 
number in parenthesis that uniquely 
identifies the azimuth.  

This node is typically displayed 
beneath a station setup node. 

   Backbearing 99 (R1) 
This is a backbearing node.  

The icon and name are followed by the 
point ID of the first backsight point. 
This is followed by an "R" number in 
parenthesis that uniquely identifies the 
backbearing.  

Nodes displayed beneath this one are 
typically related observation nodes. 

    100-200 (T41) 

    100-200 (T42) 

These are face 1 and face 2 total station 
observation nodes.  

The icon is followed by the occupation 
point ID, a dash, and the the observed 
point ID. This is followed by a "T" 
number in parenthesis that uniquely 
identifies the observation. 

    100-99 (T52) 

    100-99 (T53) 

These are face 1 and face 2 backsight 
observation nodes.  

The icon is followed by the occupation 
point ID, a dash, and the the observed 
point ID. This is followed by a "T" 
number in parenthesis that uniquely 
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identifies the observation. 

    201-202 (T54) 
This is a dual prism observation node.  

The icon is followed by the occupation 
point ID, a dash, and the observed point 
ID. This is followed by a "T" number in 
parenthesis that uniquely identifies the 
observation. 

    220-221 (T22) 

    110-111 (T5) 

    198-199 (T28) 

These are distance, angle, and circle 
offset nodes.  

The icon is followed by the occupation 
point ID, a dash, and the observed point 
ID. This is followed by a "T" number in 
parenthesis that uniquely identifies the 
observation. 

    99-100-200 (M3) 
This is a mean angle node. It represents 
the combining and averaging of 
redundant observations to the same 
point.  

The icon is followed by the backsight 
point ID, a dash, the occupation point 
ID, another dash, and the observed 
point ID. This is followed by an "M" 
number in parenthesis that uniquely 
identifies the mean angle. 

For more information on viewing and 
working with mean angles, see View 
and Edit Mean Angle Residuals (on 
page 248) and Run a Mean Angle 
Report (on page 249). 

   Rounds 
This is a rounds node. The icon is 
followed by the word "Rounds".  

Displayed beneath it are two or more 
sets of observations, which are 
represented by set nodes. 

    Set 1 
This is a set node. It is nested under a 
rounds node.  

The icon is followed by the word "Set" 
and a number that identifies the set.  

Displayed beneath it are nodes 
representing observations made during 
the set. 
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Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View Total Station Data Associated with a Point in Project Explorer (on page 244) 
 Total Station Nodes Sequence in Project Explorer (on page 246) 
 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 

 

View Total Station Data Associated with a Point in Project Explorer 

SURVEY  

Individual point nodes are displayed beneath the Points node in Project Explorer.  

Beneath each point node, all total station, GNSS, and/or level data used to define the 
point are displayed as individual nodes. For total station data, this includes observation, 
mean angle, coordinate, and azimuth nodes.  

Note: Station, station setup, backbearing, round, and set nodes, which are displayed 
beneath the  Imported Files node, are not displayed under the Points node in Project 
Explorer. 

The following table shows the possible node types and their relative nested position 
beneath the Points node in Project Explorer. 

Node type example Descript ion 

 Points  This is the points node. 

 100 This is an individual point node. The icon 
is followed by the point ID. 

Observations to and from the point are 
listed as observation nodes beneath it. See 
the Point Derivation Report (Reports > 
Point Derivation Report) to see how 
observations were used to establish the 
point. 

If a point ID is displayed in red, there is a 
computational error associated with the 
point. For instructions on viewing 
computational error messages, see Select 
from the Flags Pane (on page 48). For a 
description of total station errors that can 
cause a red point ID, see Total Station Data 
Errors (on page 247). 

  Grid (Single Backsight.jxl) This is a coordinate node.  

The icon is followed by the coordinate 
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type and the source of the coordinate in 
parenthesis. 

  100-99 (A1) This is an azimuth node.  

The icon is followed by the occupation 
point ID, a dash, and the observed point 
ID. This is followed by an "A" number in 
parenthesis that uniquely identifies the 
azimuth.  

  99-100-200 (M3) 
This is a mean angle node. It represents 
the combining and averaging of redundant 
observations to the same point.  

The icon is followed by the backsight 
point ID, a dash, the occupation point ID, 
another dash, and the the observed point 
ID. This is followed by an "M" number in 
parenthesis that uniquely identifies the 
mean angle. 

For more information on viewing and 
working with mean angles, see View and 
Edit Mean Angle Residuals (on page 248) 
and Run a Mean Angle Report (on page 
249). 

  100-200 (T41) 
This is a face 1 observation node.  

The icon is followed by the occupation 
point ID, a dash, and the observed point 
ID. This is followed by a "T" number in 
parenthesis that uniquely identifies the 
observation. 

  100-99 (T52) 
This is a face 1 backsight observation 
node.  

The icon is followed by the occupation 
point ID, a dash, and the observed point 
ID. This is followed by a "T" number in 
parenthesis that uniquely identifies the 
observation. 

  201-202 (T54) 
This is a dual prism observation node.  

The icon is followed by the occupation 
point ID, a dash, and the observed point 
ID. This is followed by a "T" number in 
parenthesis that uniquely identifies the 
observation. 

  220-221 (T22) 

  110-111 (T5) 

These are distance, angle, and circle offset 
nodes.  

The icon is followed by the occupation 
point ID, a dash, and the the observed 
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  198-199 (T28) 
point ID. This is followed by a "T" number 
in parenthesis that uniquely identifies the 
observation. 

 

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View Imported Total Station Data in Project Explorer (on page 241) 
 Total Station Data Errors (on page 247) 
 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 

 

Total Station Nodes Sequence in Project Explorer 

SURVEY  

The sequence of nodes (top to bottom) nested beneath the imported data file node in 
the Project Explorer reflects the chronological order in which data was gathered. For 
example, the station setup node is above observations nodes because this is the 
sequence of events in the field.  

Mean angle nodes are beneath rounds and backbearing nodes because observations 
must occur before calculations.  

Even a backbearing node follows this rule, although it may appear not to. Consider a 
station setup plus in which observations to the backsight points are made to establish 
the orientation. It may seem as though the observations are collected first and then a 
backbearing is determined from them. But, what actually happens is very much like a 
surveyor setting the horizontal plate of a theodolite before making observations. This 
fixes or establishes the horizontal circle reading until the next time he changes it. Each 
plate change coincides with a backbearing node.  

Performing a new setup is also like changing the plate because the instrument may not 
be put back exactly the same as a previous setup. Survey Controller will reset the 
horizontal circle reading to a user value under certain circumstances. This, of course, 
means a new backbearing node.  

In a single backsight setup, this occurs whenever a face 1 observation to the backsight 
is made. In other setup types, different rules apply.  

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
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 View Imported Total Station Data in Project Explorer (on page 241) 
 

Total Station Data Errors 

SURVEY  

If a point ID is displayed in red in the Project Explorer, there is a computational error 
associated with the point. For instructions on viewing computational error messages, 
see Select from the Flags Pane (on page 48).  

The following total station-related computational errors can occur: 

Error message Descript ion 

Setup failed to compute An undefined problem caused all setup 
computations to fail. No further information 
is possible. 

Using check observation to backsight as 
fallback 

This error occurs when there is only one 
check observation available to the backsight 
and it is being used to define the backsight. 
(Typically, the software does not use check 
observations for any real computations.) 

Azimuth to backsight missing or not 
computable 

This error occurs when the backsight 
azimuth is not present or some coordinates 
defining the azimuth are disabled. 

Some backsight observations are missing or 
disabled 

This error occurs when some or all 
backsight observations are either disabled or 
not present. 

Resection computation not possible This error occurs when numerical problems 
occurred in the resection mathematics. 

 

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View and Edit Mean Angle Residuals (on page 248) 
 Run a Mean Angle Report (on page 249) 
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View and Edit Mean Angle Residuals 

SURVEY  

A mean angle represents the combining and averaging of redundant observations to 
the same point. You can view residuals for any mean angle and, if you want, disable 
any outlying observations.  

Note: For mean angle residuals, all angles are normalized to the range of 0 to 360 
degrees expressed in project units. All distances are displayed in project units. 
Note: If you delete a mean angle from your project (that is, right-click the mean angle 
node in the Project Explorer and click Delete), all observations associated with the mean 
angle are also deleted. 

To view and edit residuals for a mean angle:  

1. To display the Mean Angle Residuals dialog, do either of the following: 

 Right-click the mean angle node icon  in Project Explorer and select Mean 
Angle Residuals from the context menu. 

 Select the mean angle node icon  in Project Explorer and select Survey > 
Mean Angle Residuals. 

2. In the Mean Angle Residuals dialog, review the read-only data displayed in the 
various boxes in the top half of the dialog. 

3. In the table, review the observations used to compute the mean angle and their 
residual values. 

4. If necessary, uncheck the box in the Enabled column for any observation that you 
do not want used in the computation of the mean angle. 

If an unchecked observation has an opposite face observation in the same set, the 
opposite face observation should also be unchecked to ensure maximum accuracy.  

As you enable or disable observations, the means and residuals are re-calculated so 
you can immediately see the effects of the change. However, these changes are 
temporary and do not apply to the project until you click OK. 

5. Optionally, click Report to view the Mean Angle Report (see "Run a Mean Angle 
Report" on page 249). 

6. When you are done, click OK. 
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Note: Mean angles are computed differently in the software than in Survey Controller. 
In the software, turned angles are displayed with their standard errors. In the Survey 
Controller, they are displayed with residual and standard errors of backsight and 
foresight circle readings. This is not a problem, except that it makes comparisons of the 
two values impossible. 

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 Run a Mean Angle Report (on page 249) 

 

Run a Mean Angle Report 

SURVEY  

Run a Mean Angle Report to view details of how each mean angle was computed. 

To run a Mean Angle Report:  

 Select Reports > Mean Angle Report. 

 Right-click a mean angle node icon  in Project Explorer and select Mean 
Angle Report from the context menu. 

 Click the Report button in the Mean Angle Residuals dialog. 

The Mean Angle Report displays in your default Web browser. 

Note: In the Mean Angle Report, all angles are normalized to the range of 0 to 360 
degrees expressed in project units. All distances are displayed in project units. 

The Mean Angle Report includes a separate table for each mean angle in the project. At 
the top of each table, the point ID, station ID, and backsight ID are displayed. Beneath 
that, the table includes a row of information for each enabled observation used to 
compute the mean angle. Information includes observed readings and residual values 
for the horizontal angle, vertical angle, and slope distance. The last row in the table 
displays the computed horizontal angle, vertical angle, and slope distance for the mean 
angle point. 

Tip: Click any point in the report to select it in the Project Explorer and graphical and 
spreadsheet views, and display its properties in the Properties pane. 

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 



Trimble® Business Center 
Heavy Construction Edition User Guide 250 

 Work with Total Station Data

 View Total Station Data in Project Explorer (on page 240) 
 View and Edit Mean Angle Residuals (on page 248) 
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C H A P T E R  1 0  

Work with Level Data 

SURVEY  
 

Understanding Level Data 

SURVEY  

Level data acquired in the field using a Trimble DiNi level and contained in a data file 
can be imported into the software and integrated, as necessary, with other data 
collected as part of a survey project (for example, GNSS or total station data). During 
and after import, you can edit the level data as necessary. 

The following diagram shows four segments in a typical level run.  

Key to diagram:  

  identifies a control point (point of interest). 

 1  identifies a benchmark control point. 

 2  identifies a control point used for a foresight for the preceding segment 
and a backsight for the following segment. 

 3  identifies an intermediate control point. 

 4 identifies a turning point that is used as a foresight for the preceding segment 
and a backsight for the following segment. 
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 5  identifies a control point that is used as a foresight for the preceding 
segment. This could also be a benchmark. 

 
Level data is displayed in the following areas of the software:  

 Project Explorer  

Imported data is displayed in expandable nodes nested beneath the Import Files 
node. Point data is displayed in expandable nodes located beneath the Points node. 
You can expand and collapse nodes as necessary to view information. (See View 
Level Data in Project Explorer (on page 260).) 

 Properties pane 

Click any node in the Project Explorer to display its properties in the Properties pane. 
You can edit certain properties in the pane. 

 Level Editor dialog 

Right-click the level data file node in the Project Explorer pane and select Level 
Editor from the context menu to view and edit level data in the Level Editor (see 
"View and Edit Level Data" on page 255) dialog. 

 Graphical and spreadsheet views 

Points computed from level data are displayed in graphic (if they include x and y 
coordinates) and spreadsheet views. 

Related topics 

 Workflow for Total Station Data (on page 238) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 
 Adjust Level Runs (on page 265) 

 

Workflow for Level Data 

SURVEY  

Use the following steps as a guideline for working with level data: 

1. Import (see "Import DiNi Digital Level Files (.dat)" on page 207) the level data file 
into your project.  
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2. Review the imported level data in the Level Editor (see "View and Edit Level Data" 
on page 255) dialog, which displays automatically immediately following import, 
and make changes as necessary. For example, you can determine which points you 
want to create for the project, and enable or disable observations.  

Tip: You can also display the Level Editor dialog any time after import by 
right-clicking the level data file node in the Project Explorer pane and selecting Level 
Editor from the context menu. 

3. Review the Import Summary report to identify any errors, warnings, or messages 
associated with the import that require corrective action. 

4. Review the chronology and correctness of the imported data in the Project Explorer. 

Expand the nodes under the Imported Files node and review in chronological order 
(top to bottom) to ensure data was gathered correctly and good survey practices 
were followed. (See View Level Data in Project Explorer (on page 260).) 

If necessary, edit leveling data properties in the Properties pane.  

If you find an error that cannot be corrected because the Properties pane field is 
read-only, the field crew must re-survey that portion of the project. You can delete 
the old station nodes that contain errors and import the file that contains the 
re-surveyed stations. If necessary, you can delete any redundant information. 

After level data is imported into your project, you can view the points computed from 
it in the graphic (if the points include x and y coordinates) and spreadsheet views.  

Related topics 

 Understanding Level Data (on page 251) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 
 Adjust Level Runs (on page 265) 

 

Import DiNi Digital Level Files (.dat) 

SURVEY  

DiNi digital level .dat (M5) files contain level data recorded in the field using a Trimble 
DiNi Digital level. 

To import DiNi Digital  level  .dat f i les:  

1. Do one of the following: 

 Click the    icon on the toolbar. 

 Select File > Import.  
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The Import command pane displays. 

2. Do one of the following: 

 Select a folder in the Import Folder list. 

 Click the  icon to browse for a folder.  

The default is the folder that you last imported from. The files contained in the 
selected folder appear in the Select File(s) area. The file names and file types are 
listed.  

3. Select the DiNi digital level .dat file(s) you want to import. 

1. In the Settings section at the bottom of the Import command pane, change the 
Automatically Numbered Points properties if necessary.  

These properties help the software identify which points were auto-numbered by 
the DiNi level and which point IDs were entered by the user. Auto-numbered 
points typically are not points of interest and should not be created as points in the 
project. 

 Starting Point - Specifies the first point ID number of the range of point ID 
numbers in the file you want to specify as automatically numbered points that 
should not be created in the project.  

 Maximum Points - Specifies the maximum number of points in the file you want 
to be included in the range.  

 Increment - Specifies the increment to be used when identifying point numbers 
in the range. 

 Ending Point - Specifies the calculated ending point for the point range based on 
the other specified properties. 

2. When you are done, click Import. The Level Editor dialog displays. In this dialog, 
you can see which level points were entered by the user (points of interest) and 
will be created in the project, and which points were automatically numbered by 
the DiNi and will not be created in the project. If necessary, you can make changes 
by checking or unchecking any point to include or not include it in the project. For 
instructions, see View and Edit Level Data (on page 255). 

Note: If you import a text file with "Unknown" or "Mapping" coordinate quality into a 
project that already contains level point data, duplicate points will be created for points 
in the text file (lightweight points (see "Understanding Point Types" on page 269)) and 
points already in the project (normal points (see "Understanding Point Types" on page 
269)) that have the same ID (that is, points will not merge as expected). To avoid this 
problem, import the text file first to create the lightweight points in the project, then 
import the level point data. The lightweight points from the text file will merge with 
the normal points from the other point data to create normal non-duplicated points. 
For more information, see Understanding Point Types (on page 269). 
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Related topics 

 Import Data (on page 193) 
 View and Edit Level Data (on page 255) 

 

View and Edit Level Data 

SURVEY  

The Level Editor dialog is displayed automatically immediately after you import level 
data. You can also display it any time after import by right-clicking the level data file in 
the Project Explorer pane and selecting Level Editor from the context menu. The Level 
Editor dialog enables you to do the following: 

 View all level readings from the field, and select any reading to be "enabled" (used 
for computation of level adjustment) or "disabled" (not used for computation of 
level adjustment). 

 Select which points to import. 

 Select to use raw or adjusted elevations in the project. 

 View the sums of backsight distances and foresight distances. 

 View the total misclosure and individual residuals for benchmarks and 
coordinates. 

 View the elevation type for each point (benchmark, computed, or coordinate), 
including the start and end points, and change the elevation type as necessary. 

 Manually enter benchmark heights and qualities. 

 Assign an elevation coordinate already in the project that specifies height and 
quality that cannot be changed. 

 Adjust level runs to spread any misclosure proportionately throughout all the 
measurements 

 Merge level runs. 

 Specify whether or not to allow a network adjustment to the level data after import 
(that is, specify whether level data is imported as observations or coordinates). 

 

Before you get started: 

Import level data into the project as described in Import DiNi Digital Level Files (.dat) 
(on page 207). 



Trimble® Business Center 
Heavy Construction Edition User Guide 256 

 Work with Level Data

To get started: 

1. When you import a level data file (see "Import DiNi Digital Level Files (.dat)" on 
page 207), the Level Editor dialog automatically displays. Otherwise, you can display 
it at any time by doing either of the following: 

 Right-click the imported level data file in the Project Explorer and select Level 
Editor from the context menu. 

 Click Survey > Level Editor and select the imported level data file in the 
Select Leveling Files dialog. 

The Level Editor dialog displays a tab for each level run in the data file, allowing you 
to view and/or edit each run individually. 

2. If more than one Run tab is displayed, select the tab whose run you want to view or 
edit. 

At the top of the tab, you can view the sum of backsight distances and foresight 
distances and the total misclosure to identify issues that might require corrective 
action. 

To select options: 

1. At the top of the tab, select one of the following options: 

 Select Use Adjusted Elevations to use elevations in the project that have been 
adjusted for misclosure. When you select this option, the Correction column is 
displayed in the table instead of the Misclosure column. The Correction column 
shows the correction used for the computation of the elevation for each point 
based on the misclosure value associated with that point. 

 Select Use Raw Elevations to use elevations that have not been adjusted. When 
you select this option, the Misclosure column is displayed in the table instead of 
the Correction column. The Misclosure column shows the misclosure value for 
each benchmark or coordinate in the run. 

2. If necessary, change the name of the run in the Run Name box. 

3. In the Columns box in the lower left section of the dialog, select the columns you 
want to display in the table. 

4. In the Creation Options box in the lower section of the dialog, select one of the 
following options: 

 Allow Network Adjustment – Select this option if you want all elevations of 
interest imported as delta elevations and, therefore, adjusted as part of a 
network adjustment. 

 Prevent Further Adjustment – Select this option if you want all elevations of 
interest imported as control coordinates and, therefore, not adjusted as part of a 
network adjustment. 
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To work with data in the table:  

Each station point in the run is displayed in a table, along with the following 
information about the point (assuming all Columns boxes are checked in the lower left 
are of the dialog): 

 The point ID 

 Backsight, foresight, and/or intermediate rod readings associated with the point 

 The change in elevation for the point based on the rod reading 

 The raw elevation of the point based on the rod reading 

 If the Use Adjusted Elevation box is checked, the correction required for the 
computation of the elevation for the point based on the associated misclosure value 

 If the Use Raw Elevations box is checked, the misclosure value for each benchmark 
or coordinate in the run 

 The adjusted elevation 

 The type of elevation used for the point: benchmark, coordinate, or computed 

 The distance from the instrument to the level rod for each reading 

 If applicable, a description entered for a reading associated with the point  

1. Ensure the boxes in the Create column are checked appropriately. 

 Points you want imported into the project (for example, control points) should 
be checked.  

 Points you do not want imported into the project (for example, turning points) 
should not be checked. 

See the following diagram for an example of control points (1, 2, 3, and 5) and a 
turning point (4).  

  
2. If necessary, edit any point IDs in the Point ID column. 

If the  icon displays following a point ID, the point ID is common to multiple 
runs. This can occur when the surveyor intentionally references the same point in 
multiple runs, in which case, no correction is required. It can also occur 
unintentionally when point IDs are automatically assigned in the level device for 
each run. In this case, you might need to rename one or more of the duplicate point 
IDs with unique point IDs, as necessary.  
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3. Ensure the enable/disable boxes in the BS (backsight), IS (intermediate), and FS 
(foresight) columns are checked appropriately. 

 Readings you want included in the computation of a level adjustment should 
be checked (enabled). 

 Readings you do not want included in the computation of a level adjustment 
should not be checked (disabled). 

Note: Readings that were aborted in the field are imported as disabled (not 
checked). 
Note: For each point, there must always be at least one backsight reading and one 
foresight or intermediate reading. Therefore, you can disable a reading for a point 
only if the point includes additional readings of the same observation type. For 
example, if a point includes two backsight readings, you can disable one of them, 
but not both.  

4. If necessary, in the Elevation Type column change the type of elevation used for any 
point: 

 Benchmark – Select this option to specify that the elevation for the point be a 
manually entered benchmark elevation. Any point in the run can be 
designated as a benchmark. 

 Coordinate – Select this option to specify that the elevation for the point be a 
coordinate already assigned to the point in the project. A coordinate can be 
assigned to a point only if there is a corresponding point already in the project 
with a coordinate elevation. 

 Computed – Select this option to specify that the elevation for the point be 
computed based on rod readings, benchmark and coordinate elevations entered 
for the run, and any adjustments performed on the run.  

5. If necessary, for any points assigned a Benchmark elevation type, do the following: 

a. Enter or change the value in the Elevation Type column. 

b. Click the Quality icon and select the appropriate quality option. 

6. If necessary, enter or change any descriptions in the Description column. 
 

To adjust one or more of the level runs contained in the import f i le:  

When a level run is adjusted, any misclosures are distributed proportionately 
throughout all the measurements in the run. 
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Note: When multiple intermediate (IS) observations exist for the same point ID in a 
level run, the software includes the intermediate readings in the level adjustment (the 
IS boxes will be checked in the Level Editor dialog), just as it is done during a network 
adjustment. If you do not want these intermediate readings to be included in the level 
adjustment, either uncheck the IS boxes or rename the associated point IDs so they are 
not the same. 

1. Click Adjust Runs. The Adjust Runs dialog displays. 

2. In the Adjust Runs dialog, select the runs you want to adjust. 

These runs will all be adjusted simultaneously as one network. When runs have 
points in common, the recommended procedure is to adjust them together. 

3. Click OK. 
 

To merge level runs contained in the import f i le:  

You can merge two level runs into one run if the last point ID in the first run selected 
for the merge matches the first point ID in the second run selected for the merge. For 
example, if the first run selected ends on point "1", the second run selected must start 
on point "1". This is helpful if two or more level runs were accidentally specified in the 
field for what should have been a single run (for example, one of the runs does not 
include a benchmark point). If necessary, you can merge another existing run with the 
newly created merged run using the same guidelines, and repeat as necessary. 

1. Click Merge Runs. The Merge Runs dialog displays. 

2. In the New Run Name box, enter the name for the new run. 

You can enter the name of one of the runs you are merging, or you can enter a new 
name. 

3. In the Start With list, select the run whose observations you want to use for the first 
part of the new run. 

4. In the Add This list, select the run whose observations you want to use for the 
second part of the new run. 

5. Click OK. The Merge Runs dialog closes and the newly created run tab replaces the 
two merged run tabs in the Level Editor dialog. 

If necessary, you can now merge another existing run with the newly created 
merged run using the same guidelines and instructions. 

To complete viewing and editing: 

1. Repeat the preceding procedures as appropriate for each run you want to view 
and/or edit. 

2. When you are done working in the Level Editor dialog, click OK.  
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If the Level Editor dialog was displayed as part of a data file import, the import 
process completes and an Import Summary report displays, showing details of the 
import. Be sure to review any messages, warnings, or errors contained in the report 
to determine if any corrective action is required. 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View Level Data in Project Explorer (on page 260) 

 

View Level Data in Project Explorer 

SURVEY  

Level data is displayed as individual nodes under two top-level nodes in Project 
Explorer: 

 Imported Files node  

This top-level node includes one or more data file nodes, each specifying a file 
containing GNSS, total station, and/or level field data that has been imported into 
the project. Individual level nodes display beneath the file node(s) for imported 
level data. Level nodes are typically listed in the same chronological sequence as 
data was gathered in the field.  

 Points node  

This top-level node includes a node for each point in the project. Individual level 
nodes are displayed as appropriate beneath the points to which they pertain. 

You can double-click any node to display its properties in the Properties pane. You can 
right-click any node to display a context menu that includes other options, depending 
on the node type. 

For a description of how leveling nodes are displayed in the Project Explorer, see one of 
the following topics: 

 View Imported Level Data in Project Explorer (on page 261) 

 View Level Data Associated with a Point in Project Explorer (on page 263) 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
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View Imported Level Data in Project Explorer 

SURVEY  

Each imported level data file displays as an expandable node located beneath the 
Imported Files node in Project Explorer (select View > Project Explorer). The way level data 
is displayed beneath the level data file node depends on whether the Allow Network 
Adjustment or Prevent Further Adjustment option was selected in the Level Editor dialog 
(see View and Edit Level Data (on page 255)). 

For the following examples, assume the file being imported is named "test.dat" and 
contains one level run. The run began on BM1 and ended on BM2. In addition to the 
benchmarks, the surveyor specified three control points: 1, 2, and 100. The survey 
went in the direction of 1 toward 2 with 100 as an IS point between 1 and 2. 

Example 1: Allow Network Adjustment option selected in Level Editor dialog 

This option should have been selected if you want all elevations of interest to be left as 
delta elevation observations and, therefore, adjusted as part of a network adjustment. 
The data would display in Project Explorer as follows: 

Node type example Descript ion 

 Imported Files This is the Imported Files node. 

 Test.dat This is the imported leveling data file.  

The icon is followed by the name of the file. 

  BM1 This is a coordinate node from a benchmark.  

The icon is followed by a coordinate point ID. 

Note: To preserve the integrity of raw field data, 
you cannot edit coordinate properties for an 
imported coordinate. 

  BM2 This is a coordinate node from a benchmark. 

  BM1-BM2 (H1) This is a run node.  

The icon is followed by the run's first coordinate 
point ID, a dash, and the last coordinate point ID. 
This is followed by an "H" number in parenthesis 
that identifies the run.  

Observation nodes are nested beneath it in 
chronological order. The data file can include 
multiple run nodes. 

   BM1-1 (E1)  This is a delta elevation observation node, which 
represents the change of elevation between two 
control points.  

The icon is followed by the backsight point ID, a 
dash, and the foresight or intermediate point ID. 
This is followed by an "E" number in parenthesis 
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that identifies the observation. 

   1-100 (E2) This is a delta elevation observation node. 

   1-2 (E3) This is a delta elevation observation node. 

   2-BM2 (E4) This is a delta elevation observation node. 

 

Example 2: Prevent Further Adjustment option selected in Level Editor dialog 

This option should have been selected if you want all elevations of interest to be 
converted from delta elevation observations into coordinates and, therefore, not 
adjusted as part of a network adjustment. The data would display in Project Explorer as 
follows: 

Node type example Descript ion 

 Imported Files This is the Imported Files node. 

 Test.dat This is the imported leveling data file.  

The icon is followed by the name of the file. 

  BM1 This is a coordinate node from a benchmark.  

The icon is followed by a coordinate point ID. 

Note: To preserve the integrity of raw field data, you 
cannot edit coordinate properties for an imported 
coordinate. 

  BM2 This is a coordinate node from a benchmark. 

  BM1-BM2 (H1) This is a run node.  

The icon is followed by the run's first coordinate point 
ID, a dash, and the last coordinate point ID. This is 
followed by an "H" number in parenthesis that 
identifies the run.  

Observation nodes are nested beneath it in 
chronological order. The data file can include multiple 
run nodes. 

   1 This is a coordinate node from an adjustment.  

The icon is followed by the point ID. 

   100 This is a coordinate node from an adjustment. 

   2 This is a coordinate node from an adjustment. 

 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 
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 View Level Data Associated with Point in Project Explorer (see "View Level Data 
Associated with a Point in Project Explorer" on page 263) 

 

View Level Data Associated with a Point in Project Explorer 

SURVEY  

The way imported level data is displayed beneath points in the Points node depends on 
whether the Allow Network Adjustment or Prevent Further Adjustment option was selected 
in the Level Editor dialog (see View and Edit Level Data (on page 255)). 

Example 1: Allow Network Adjustment option selected in Level Editor dialog 

This option should have been selected if you want all elevations of interest to be left as 
delta elevation observations and, therefore, adjusted as part of a network adjustment. 
The data would display in Project Explorer as follows: 

Node type example Descript ion 

 Points This is the Points node.  

All point nodes are located beneath it. 

 1 This is an individual point node.  

The icon is followed by the point ID.  

Observation nodes associated with the point are nested 
beneath it.  

If a point ID is displayed in red, there is a 
computational error associated with the point. For 
instructions on viewing computational error messages, 
see Select from the Flags Pane (on page 48). For a 
description of level errors that can cause a red point ID, 
see Level Data Errors (on page 264). 

  BM1-1 (E1) This is a delta elevation observation node, which 
represents the change of elevation between two 
control points associated with point 1.  

The icon is followed by the backsight point ID, a dash, 
and the foresight or intermediate point ID. This is 
followed by an "E" number in parenthesis that 
identifies the observation. 

  1-100 (E2) This is a delta elevation observation node. 

  1-2 (E3) This is a delta elevation observation node. 

 

Example 2: Prevent Further Adjustment option selected in Level Editor dialog 
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This option should have been selected if you want all elevations of interest to be 
converted from delta elevation observations into coordinates and, therefore, not 
adjusted as part of a network adjustment. The data would display in Project Explorer as 
follows: 

Node type example Descript ion 

 Points This is the Points node.  

All point nodes are nested beneath it. 

 1 This is an individual point node.  

The icon is followed by the point ID. Observation 
nodes associated with the point are nested beneath it.  

If a point ID is displayed in red, there is a 
computational error associated with the point. For 
instructions on viewing computational error messages, 
see Select from the Flags Pane (on page 48). For a 
description of level errors that can cause a red point 
ID, see Level Errors (see "Level Data Errors" on page 
264). 

  1 This is a coordinate node from an adjustment.  

The icon is followed by the point ID. 

 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 
 View Imported Level Data in Project Explorer (on page 261) 

 

Level Data Errors 

SURVEY  

If a point ID is displayed in red in the Project Explorer, there is a computational error 
associated with the point. For instructions on viewing computational error messages, 
see Select from the Flags Pane (on page 48).  

The following level-related computational errors can occur: 

Error message Descript ion 

Misclosure out of tolerance This error occurs when there is enough 
redundancy in the leveling run to determine 
that the elevations computed in the run are 
out of tolerance. The usual reason for this is a 
misclosure that exceeds a limit. 
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Some delta elevation observations are 
missing or disabled 

This error occurs when the elevation for a 
point cannot be determined because there is 
no path back to a benchmark. The usual 
reason is that an observation has been 
disabled or deleted. 

 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 

 

Adjust Level Runs 

SURVEY  

A level run can be adjusted during or after import to spread any misclosure 
proportionately throughout all the measurements in the run. You use the Level Editor 
dialog to adjust level runs.  

Note: When multiple intermediate (IS) observations exist for the same point name in a 
level run, the software will include the intermediate readings in the level adjustment 
(the IS boxes will be checked in the Level Editor dialog). If you do not want these 
intermediate readings to be included in the level adjustment, either uncheck the IS 
boxes or rename the associated point IDs so they are not the same. 

To adjust level  runs: 

1. When you import a level data file, the Level Editor dialog automatically displays. 
Otherwise, you can display it at any time by doing either of the following: 

 Right-click the imported level data file in the Project Explorer and select Level 
Editor from the context menu. 

 Click Survey > Level Editor and select the imported level data file in the 
Select Leveling Files dialog. 

The Level Editor dialog displays a tab for each run in the data file, allowing you to 
view and/or edit each run individually. 

2. Click Adjust Runs. The Adjust Runs dialog displays. 

3. In the Adjust Runs dialog, select the runs you want to adjust. 

These runs will all be adjusted simultaneously as one network. When runs have 
points in common, the recommended procedure is to adjust them together. 
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4. Click OK. 

Note: Performing an adjustment replaces any previously adjusted elevations, such 
as those from the instrument. 

You can view the adjusted results in the Level Editor dialog by selecting the Use 
Adjusted Elevations option in the upper left area of the tab. 

5. When you are done working in the Level Editor dialog, click OK.  

For additional instructions on using the Level Editor dialog, see View and Edit Level 
Data (on page 255). 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 

 

Merge Level Runs 

SURVEY  

You can merge two level runs into one run if the last point ID in the first run selected 
for the merge matches the first point ID in the second run selected for the merge. For 
example, if the first run selected ends on point "1", the second run selected must start 
on point "1". This is helpful if two or more level runs were accidentally specified in the 
field for what should have been a single run (for example, one of the runs does not 
include a benchmark point). If necessary, you can merge another existing run with the 
newly created merged run using the same guidelines, and repeat as necessary. 

Note: If a level data file you are importing includes a run that does not include a 
benchmark, see this note (see "Note on Level Runs Without Benchmarks" on page 
267). 

To merge level runs contained in the import f i le:  

1. When you import a level data file, the Level Editor dialog automatically displays. 
Otherwise, you can display it at any time by doing either of the following: 

 Right-click the imported level data file in the Project Explorer and select Level 
Editor from the context menu. 

 Click Survey > Level Editor and select the imported level data file in the 
Select Leveling Files dialog. 

The Level Editor dialog displays a tab for each run in the data file, allowing you to 
view and/or edit each run individually. 
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2. Click Merge Runs. The Merge Runs dialog displays. 

3. In the New Run Name box, enter the name for the new run. 

You can enter the name of one of the runs you are merging, or you can enter a new 
name. 

4. In the Start With list, select the run whose observations you want to use for the first 
part of the new run. 

5. In the Add This list, select the run whose observations you want to use for the 
second part of the new run. 

6. Click OK. The Merge Runs dialog closes and the newly created run tab replaces the 
two merged run tabs in the Level Editor dialog. 

If necessary, you can now merge another existing run with the newly created 
merged run using the same procedure. 

7. When you are done working in the Level Editor dialog, click OK.  

For additional instructions on using the Level Editor dialog, see View and Edit Level 
Data (on page 255). 

Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 

 

 
 

Note on Level Runs Without Benchmarks 

SURVEY  

If a level data file you are importing includes a level run that does not include a 
benchmark, the software will attempt to use a computed value for the first point in that 
run. It does this by locating the most recent point ID in a preceding run that matches 
the first point ID in the run that is missing a benchmark. If it finds a matching point ID, 
it copies the elevation from that point to the first point ID in the run that is missing a 
benchmark as a computed elevation.  

For example, if the first  point ID in the run that is missing a benchmark is 100, and the 
most recent previous instance of a point ID of 100 is found at the end of the preceding 
run, the elevation for point 100 in the preceding run is copied to the elevation for point 
100 in the run that is missing a benchmark as a "Computed" value. In this case, you may 
not need to merge the runs. 
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Related topics 

 Understanding Level Data (on page 251) 
 Workflow for Level Data (on page 252) 
 View and Edit Level Data (on page 255) 
 View Level Data in Project Explorer (on page 260) 
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C H A P T E R  1 1  

Work with Point Data 

Understanding Point Types 
The software supports two basic types of points: 

 Normal points are created when you import into your project any type of point 
data other than coordinate point data contained in a text file (for example, .csv) 
with "Unknown" or "Mapping" quality. You can also create normal points 
manually using the Point > Create Point command.  

A normal point includes one or more coordinate and/or observation nodes nested 
beneath it in Project Explorer that are used to compute the coordinate for the point. 
You can edit values for coordinate nodes, or change the coordinate quality level, in 
the Properties pane. These changes are reflected in the non-editable coordinates 
displayed for the point in the Properties pane. 

 Lightweight points are created only when you import a text file (for example, .csv) 
containing coordinate point data with "Unknown" or "Mapping" quality (for 
example, topographic points).  

A lightweight point does not include coordinate nodes nested beneath it in Project 
Explorer. A non-editable coordinate is displayed for the point in the Properties pane. 

Note the following concerning lightweight points: 

 You can add an editable coordinate to a lightweight point by right-clicking the 
point in Project Explorer and selecting Add Coordinate. This changes the 
lightweight point to a normal point. 

 If you import a text file with "Unknown" or "Mapping" coordinate quality into 
a project that already contains point data, duplicate points will be created for 
points in the text file (lightweight points) and points already in the project 
(normal points) that have the same ID (that is, points will not merge as 
expected). To avoid this problem, import the text file first to create the 
lightweight points in the project, then import the other point data. The 
lightweight  points from the text file will merge with the normal points from 
the other point data to create normal non-duplicated points. 
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Related topics 

 Create and Edit Points and Coordinates (see "Add and Edit Points and Coordinates" 
on page 270) 

 

Add and Edit Points and Coordinates 

Create a Point 

Create a point in your project when you need to include one for control or stakeout 
that was not observed in the field or otherwise recorded and imported in a points file. 
When you create a point, in addition to the new point object, a coordinate object 
named 'Office entered' is created and appears in the Project Explorer. Each point can 
only have one office entered coordinate. 

To create a point:  

1. Do one of the following: 

 Select Point > Create Point.  

 Click the  icon.  

The Create Point command pane displays. 

2. Type a name for the point in the Point ID box. Point IDs are not case sensitive. 

3. Type a code in the Feature Code box, if you need to use the point in feature code 
processing. 

4. Select the type of point you want to create in the Coordinate type list (see Point 
Options (on page 271) for details). 

5. Pick a location in the plan view, or type a coordinate in the Northing and Easting (or 
Latitude and Longitude) boxes, or right-click for coordinate geometry (COGO) (see 
"Understanding COGO Controls" on page 86) options. 

Tip: Once you have specified northing and easting values, you can click in the 
Easting box and pick a new point in the graphics window to change the easting 
value, while retaining the northing. 

6. Click the  icon and select a planar quality for the coordinate. Qualities are used 
to determine the best point to use when multiple observations have been made at 
the same location. 

7. Pick an object in a view to use its elevation at the location you pick, or type a value 
in the Elevation box, or right-click for options. 

Note: Elevation is measured from sea level. 

8. Click the  icon and select an elevation quality. 
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9. If needed, pick an object in a view, or type a value in the Height box, or right-click 
for options. Grid, local, and global coordinates appear at the bottom of the pane so 
you can check your new point's location in the other types. 

Note: Height is measured from the geoid. 

10. Click the  icon and select a height quality. 

11. Select the appropriate point status from the Status list. The status determines 
whether and how the point is used during the computation process. 

12. Click OK, or click Apply to continue creating additional points. The point and an 
office-entered coordinate appear in the Project Explorer, as shown.  

 

Note: Only office-entered coordinates can be edited. If you try to edit imported 
coordinates, an office-entered coordinate object with the new location is created. 

Related topics 

 Add a Coordinate to a Point (on page 272) 
 Understanding COGO Controls (on page 86) 
 Point Options (on page 271) 

 

Point Options 

Use these options to define a new point. They are available in the Add Point command 
pane when you are adding a new point to a project. 
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Options 

Point ID Type a unique identifier for the point. 

Feature code Type a code to use in feature code processing. 

Coordinate type Grid - Select this to enter northing, easting, elevation, and 
height values. 

Local - Select this to enter latitude, longitude, height, and 
elevation values. 

Global - Select this to enter global longitude, height, and 
elevation values. 

 
Planar quality 

Click this and select a quality for the horizontal coordinate. 

 Control - Select this for NGS surveyed coordinates of the 
highest quality. 

 Survey - Select this for surveyed coordinates of the 
second highest quality. 

 Mapping - Select this for coordinates of the low to 
average quality. 

 Unknown - Select this for coordinates of the lowest or 
unverified quality. 

 
Ellipsoidal quality 

Click this and select a quality for the vertical coordinate. 

See the quality descriptions above. 

Status Enabled - Select this to include the point in project 
calculations. 

Disabled - Select this to exclude the point in project 
calculations. 

Enabled as Check - Select this to exclude the point in 
project calculations, but to include it in sideshot calculations. 

Related topics 

 Create a Point (on page 270) 
 Add a Coordinate to a Point (on page 272) 

 

Add a Coordinate to a Point 

Add a coordinate to a point when you need to include a position for control or stakeout 
that was not observed in the field or otherwise recorded and imported in a points file. 
When you add a coordinate to a point, a coordinate object named 'Office entered' is 
created under the point object. 
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Note: Only add a coordinate when you are sure that you want to use this coordinate 
instead of an observed coordinate. During the computation of the project, added 
coordinates are used in preference to observations of the same quality. This ensures 
that a designed point is used in preference to a staked point. 

To add a coordinate to a point:  

1. Do one of the following: 

 Pick the point in a graphic view or select it in the Project Explorer, right-click 
and select Add Coordinate from the context menu. 

 When a point is selected, and the Properties pane is open, click the  icon on 
the pane's toolbar. 

The Add Coordinate command pane displays. 

2. Select the type of coordinate you want to add in the Coordinate Type list (see 
Coordinate Options (on page 274) for details). 

Note: You can only enter one grid, local, and global coordinate for each point. If 

you already have each type, the  icon is unavailable. 

3. Pick a location in the plan view, or type a coordinate in the Northing and Easting (or 
Latitude and Longitude) boxes, or right-click for coordinate geometry (COGO) (see 
"Understanding COGO Controls" on page 86) options. 

Tip: Once you have specified northing and easting values, you can click in the 
Easting box and pick a new point in the graphics window to change the easting 
value, while retaining the northing. 

4. Click the  icon and select a planar quality for the coordinate. Qualities are used 
to determine the best coordinate to use when multiple coordinates exist for the 
same point. 

5. Pick an object in a view to use its elevation at the location you pick, or type a 
coordinate in the Elevation box, or right-click for options. Grid, local, and global 
coordinates appear at the bottom of the pane so you can cross check your new 
coordinate's location. 

6. Click the  icon and select an elevation quality. 
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7. Select the appropriate coordinate status from the drop-down Status list. The status 
determines whether and how the coordinate is used during the computation 
process. 

8. Click OK. When you open the point in the Project Explorer, it displays the original 
observation data and the office-entered coordinate, as shown. 

 

9. If the  icon appears on the status bar, click it to recompute and update the 
coordinates in the project. 

Note: You can only edit point coordinates that you added in this software, not those 
which were observed and imported. If you try to edit an imported point, a coordinate 
object named 'office-entered' is created. 
Note: You can edit the coordinates for imported CAD points in the Properties pane, but 
CAD points are not used in computations. 

Related topics 

 Create a Point (on page 270) 
 Compute Project Command 
 Coordinate Options (on page 274) 
 Project Explorer (on page 7) 
 Properties Pane (on page 14) 

 

Coordinate Options 

Use these options to define a coordinate that you are adding to a point. They are 
available in the Add Coordinate command pane. 
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Options 

Coordinate type Grid - Select this to enter northing, easting, elevation, and 
height values. 

Local - Select this to enter latitude, longitude, height, and 
elevation values. 

Global - Select this to enter global longitude, height, and 
elevation values. 

 
(Planar quality) 

Click this and select a quality for the horizontal coordinate. 

 Control - Select this for NGS surveyed coordinates of 
the highest quality. 

 Survey - Select this for surveyed coordinates of the 
second highest quality. 

 Mapping - Select this for coordinates of the low to 
average quality. 

 Unknown - Select this for coordinates of the lowest or 
unverified quality. 

 
(Ellipsoidal quality) 

Click this and select a quality for the vertical coordinate. 

See the quality descriptions above. 

Status Enabled - Select this to include the coordinate in project 
calculations. 

Disabled - Select this to exclude the coordinate in project 
calculations. 

Enabled as Check - Select this to exclude the coordinate in 
project calculations, but to include it in sideshot 
calculations. 

Related topics 

 Add a Coordinate to a Point (on page 272) 
 

Point Coordinate Options 

Use these options to edit point coordinates when the point is a member of a surface. 
The surface that references the edited member updates accordingly. These options are 
found in the Properties pane for a point coordinate. 
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Member type Propert ies that affect surfaces 

Coordinate Northing - Edit this to move a surface vertex north or south. 

Easting - Edit this to move a surface vertex east or west. 

Elevation - Edit to move a surface vertex up or down, relative to 
sea-level. 

Latitude - Edit this to move a surface vertex north or south. 

Longitude - Edit this to move a surface vertex east or west. 

Height - Edit this to move a surface vertex up or down. 
Session Height (point) - Edit this to move a surface vertex up or down. 

Related topics 

 Edit a Surface by Changing a Point Coordinate (on page 329) 
 Edit a Surface by Adding and Removing Members (on page 328) 

 

Rename Points 

Rename points to ensure all the points in your project are unique. For example, if two 
rovers are set to automatic point numbering and contain identical points, use the 
Rename Points command to renumber one set of points. Points to be renamed can be 
selected before the command starts or within the command.  

You can rename your points: 

 Sequentially from a specific value 

 By adding a prefix 

 By adding a suffix 

By adding a constant To rename points:  

1. Select Point > Rename Points. The Rename Points dialog displays. 

2. In the Method group, select a renaming option (see descriptions below). 

3. If you do not want to generate a report, uncheck Report. 

4. Select the points to rename. 

5. To preview the results, click Preview to see the results of the settings before the 

command is run. Additional preview options are selectable using the  icon. 

6. Click OK to rename the points. To automatically generate and display a report, 
check Report. When renaming completes, the Renamed Point list displays. 
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Options 

Rename from Select this if you want to rename points using a specific starting 
number. Type the starting number in the box. 

To use this method, the point ID you enter must end in a 
number. For example, if you type GPS100 and select three 
points, they will be renamed GPS100, GPS101, and GPS102. 

Add prefix Select this if you want to insert a constant character(s) at the 
beginning of the point ID for the points you select. 

Add suffix Select this if you want to insert a constant character(s) at the end 
of the point ID for the points you select. 

Add constant Select this if you want to enter a value to increase each point ID 
by. For example, if you type 2, point ID GPS101 becomes 
GPS103. 

Report Check this to generate the Renamed Point List report when you 
finish the command. 

Related topics 

 Run a Renamed Point List (on page 277) 
 Merge Duplicate Points (on page 278) 
 Merge Points (on page 279) 
 Select Duplicate Points (on page 52) 
 Select from 2D Views (on page 44) 

 

Run a Renamed Point List 

Generate a Renamed Point List to see a simple summary of the original and new names 
of points that you have renamed in your project. 

1. Select Reports > Report Options. The Report Options command pane displays. 

2. Select Renamed Point List in the Reports list. 

3. Edit options in the Settings group as needed. 

4. Click the  icon on the pane's toolbar. The Renamed Point List displays in your 
default web browser. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
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Edit the Point ID for a Station Setup and/or Backsight 

SURVEY  

When checking data in your project, you might find that the point ID for a station 
setup and/or backsight has been incorrectly labeled in the field. For example, the Plan 
view looks incorrect or a red flag indicates a point out of tolerance.  

To change the point ID for a station setup and/or backsight:  

1. To change the point ID for a station setup: 

a. In the Imported Files node in the Project Explorer, click to display properties 
in the Properties pane for the station setup whose point ID you want to 
change. 

b. In the Point ID box in the Properties pane, type the correct ID for the station 
setup. 

If the corrected ID is for a station you set up on previously or to a control point, 
no new point is created in the Points node (the station point is shared). 
Otherwise, a duplicate point is created in the Points node (local points are not 
shared). In this case, merge them as described in Merge Points (on page 279). 

2. To change the point ID for a backsight: 

a. In the Imported Files node in the Project Explorer, click to display properties 
for the observation to the backsight whose point ID you want to change. 

b. In the Point ID box in the Properties pane, type the correct ID for the 
backsight observation. The software updates the backsight with the new 
point ID. 

If the corrected observation is to a station you set up on previously or to a 
control point, no new point is created in the Points node (the station point is 
shared). Otherwise, a duplicate point is created in the Points node (local points 
are not shared). In this case, merge them as described in Merge Points (on page 
279). 

3. Verify your corrections. 
 

Merge Duplicate Points 

If you have multiple points with the same Point ID, you can merge them into a single 
point. 

Note: This command can be run with the Select Duplicate Points command. 

1. Select Select > Select Duplicate Points, with a distance tolerance and with Point 
IDs identical selected. 
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2. Select Point > Merge Duplicate Points. A list of the IDs with duplicate points 
appears. 

3. Click OK. 

Caution: Two points with the same ID but significantly different data may be the result 
of an error. Merging them may produce unexpected results. 

Related topics 

 Merge Points (on page 279) 
 Rename Points (on page 276) 
 Select Duplicate Point IDs 
 Select from the 2D Views (see "Select from 2D Views" on page 44) 

 

Merge Points 

Use this command to create a single point from two or more points that share the same 
location data. 

To merge points (one set of  points):  

1.  Select the points you want to merge together.  Use the Select Duplicate Points 
command or select from the plan view or a spreadsheet view. 

2. Select Point > Merge Points.  If you have not selected points to merge yet, do it 
now. The points IDs and distance from the first listed point are displayed in the 
Selected point area. 

3. Click on the points to merge.  A green check displays. 

4. (optional) Enter a point ID for the merged point. The default is the first listed 
point. 

5. Click OK.     

To merge points (multiple sets of points):  

1. Select the points that may be merged together.  Use the Select Duplicate Points 
command to select all points that are within a defined distance from one another. 

2. Select Point > Merge Points.  The points IDs and distance from the first listed 
point are displayed in the Selected point area.  If you have not selected points to 
merge yet, do it now. The points IDs and distance from the first listed point are 
displayed in the Selected point area. 

3. Click on the points to merge.  A green check displays. 

4. (optional) Enter a point ID for the merged point. The default is the first listed 
point. 

5. Click Apply.  The checked points are merged together and removed from the list.   
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6. Repeat steps 1-5 until all points are merged.  Click OK when you want to exit the 
command.  

7. Click  if it appears on the status bar to recompute the project. 

Related commands 

 Select Duplicate Points 
 Merge Duplicate Points (on page 278) 
 Rename Points (on page 276) 
 Select from the 2D Views (see "Select from 2D Views" on page 44) 

 

Calculate the Inverse Between Points 
Calculate and report inverse values between any two points in your project, such as: 

 Grid distance 

 Change in elevation 

Geodetic azimuth To calculate the inverse between two points: 

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Survey > Inverse.  

The Inverse command pane displays. 

2. Select Sequential to calculate values from point to point in series (as if drawing a 
multi-segment line), or Radial to calculate values from one point to multiple other 
points (as if drawing a fan).  

Note: You can switch between Sequential and Radial after picking any pair of 
points. 

3. Pick the first point in a graphic view, or type a point ID in the From box. 

Note: You can also right-click in the view to access COGO controls (see 
"Understanding COGO Controls" on page 86) and snaps (see "Snaps Modes and 
Commands" on page 89) when picking points.  

4. Pick another point, or type a point ID in the To box. The point IDs appear in the 
Reported Points group, and the inverse values appear in the Details group. 

Note: If Free appears in the Reported Points list, no point with a point ID was within 
the pick aperture. To prevent picking where there are no points, click the  icon 
on the Inverse command pane's toolbar. In the Snap Mode dialog, uncheck Free, and 
click OK. 

5. To calculate additional inverses, continue picking To points. 
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6. To review the details for any inverse, click in the first column of the Reported 
Points list. 

7. To change inverse report options, click the  icon to display the Report Options 
command pane. When you are done, click OK to return to the Inverse command. 

8. To generate the Inverse Results report, click the  icon at the top of the Reported 
Points group. The Inverse Results report displays in your default web browser.  

Note: If no coordinate system is defined, the Select Coordinate System dialog 
displays. Define a coordinate system and run the report again. 

9. Click Close. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 Inverse Options (on page 231) 
 Measure Values Between Points (on page 135) 

 

Inverse Options 
Use these options to calculate and report the azimuth, distance, and other relationships 
between any two points. They are available in the Inverse command pane. 
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Options 

 Click this on the Inverse command pane's toolbar to display the 
Snap Mode dialog, where you can enable and disable running 
snap modes. 

Inverse 

From/To Pick points in graphic views, or type point IDs in the boxes and 
click Apply or press [Enter]. 

Note: If Free appears in the Reported Points list, no point with a 
point ID was within the pick aperture. To prevent picking where 
there are no points, click the  icon on the Inverse command 
pane's toolbar. In the Snap Mode dialog, uncheck Free, and click 
OK. 

 Sequential – Data is collected in a line, and you want to verify 
distances around the traverse.   

 For example, you will need to click on: 

A to B, B to C, C to D, D to E, and E to A. 

Radial – Data is collected in a ray, and you want to check distance 
from the base station.  

 For example, you will need to click on:      A to B, A to C, A to 
D, and A to E. 

Reported points 

 Click this to display the Inverse Results report in your default 
web browser. 

 Click this to display the Report Options command pan, in which 
you can specify heading, footer, and format settings for the 
Inverse Report. 

From point ID/ 

To point ID 

Click in the first column of any row to list details for the inverse 
of the points. 

Details This shows the azimuths, changes in elevation and height, and 
three distances of the selected inverse: 

 Grid 

 Ellipsoidal 

 Ground 
Apply This acts as the [Enter] key, when specifying points, moving the 

focus between From, To, and Reported Points. 

Related topics 

 Calculate the Inverse Between Points (on page 230) 
 

Measure Values Between Points 
Calculate and report values between points in your project.  
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 In the plan view, the command measures bearing and distance.  

 In the profile view, it measures the delta station, slope, and slope distance.  

 In the cross-section and surface slicer views, it measures delta offset, slope, and 
slope distance. 

To measure values between two points:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Tools > Measure.  

The Measure command pane displays. 

2. Pick the first point in a graphic view or type a point ID or coordinate (in the format 
X,Y) in the From box. 

Note: You can also right-click in the view to access COGO controls (see 
"Understanding COGO Controls" on page 86) and snaps (see "Snaps Modes and 
Commands" on page 89) when picking points. 

3. Pick another point or type a point ID or coordinate in the To box. The measured 
values appear in the Results group. 

4. To measure other values, continue picking From and To points.  

Note: You can change to a different graphic view between measurements. 

5. Click Close. 

Related topics 

 Measure Options (on page 136) 
 Calculate the Inverse Between Points (on page 230) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Measure Options 
Use these options to calculate and report the bearing, distance, slope, slope distance, 
delta offset, and delta station between any two points, depending on which graphic 
view you use. They are available in the Measure command pane. 
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Options 

From/To Pick points in graphic views, or type point IDs or coordinates (in the 
format X,Y) in the boxes, and click Measure or press [Enter]. 

Results This shows the values between the selected points: 

Slope - In the cross-section view, the slope is relative to the centerline.  
In the surface slicer view, the slope is relative to the first point of the line.

Offset - In the cross-section view, the offset is relative to the centerline. 
In the surface slicer view, the offset is relative to the first point of the 
line. 

Measure When you type in To and From points, this acts as the [Enter] key, 
calculating the Results. 

Related topics 

 Measure Values Between Points (on page 135) 
 

Points Spreadsheet 
The points spreadsheet view lists the survey points in the current project, enabling you 
to easily edit the data. The plan view and the Properties pane reflect all changes made to 
data in the point spreadsheet view. 

Using the spreadsheet 

 To select a point, click in the left column for that row. 

 
 To display more detail on a point in the Properties pane, select the point and press 

[F11], or right-click and select Properties. 

 To edit a point's ID, coordinate, elevation, or feature code, select it by clicking on 
the cell. You can also tab from cell to cell and simply type over the value in the cell. 

 To sort points based on a criteria, click on a column heading. Up  or down   
icons appear on the selected column heading, indicating the current sort order 
(ascending or descending). 

 To filter the point data, click on the  icon at the top of the column and select an 
option from the drop-down menu.  

Note: If the filter for a column is active, the icon  appears blue. 
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 To copy data to a text editor, such as Microsoft® Notepad, select data, and copy and 
paste by using the right-click menu or by pressing [Ctrl] + C to copy and [Ctrl] + V 
to paste. You can select all data by pressing [Ctrl] + A. 

 To change the order of columns across the spreadsheet, click and drag the column 
heading to a new location. 

Related topics 

 Data View Display Formats (on page 32) 
 Pane and Data View Positioning (on page 31) 
 Select from Spreadsheet Views (on page 46) 
 Tabbed View Arrangement (on page 34) 
 Create a Point (on page 270) 

 

Troubleshoot an Import Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

Duplicate points were 
created for points in an 
imported text file and 
points already in the 
project that have the 
same ID (that is, points 
were not merged as 
expected). 

If you import a text file with 
"Unknown" or “Mapping” 
coordinate quality into a 
project that already contains 
point data, duplicate points 
will be created for points in 
the text file (lightweight 
points (see "Understanding 
Point Types" on page 269)) 
and points already in the 
project (normal points (see 
"Understanding Point Types" 
on page 269)) that have the 
same ID.  

Import the text file into the 
project first to create the 
lightweight points, then import 
the other point data. The 
lightweight points from the text 
file will merge with the normal 
points from the other point data 
to create normal non-duplicated 
points. 
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C H A P T E R  1 2  

Work with Line Data 

Create and Edit an Alignment 

Understanding Alignments 

An alignment defines a linear feature, such as a road centerline. Alignments consist of 
horizontal geometry (a path in a horizontal plane) and optional vertical geometry (a 
path in a vertical plane). Alignments can also include station equations. 

 
You can import existing alignments from LandXML or GENIO string files, or create 
them by specifying their horizontal and vertical components, or converting them from 
vertices, lines, and polylines in your project.  

You can create horizontal alignments using lines/tangents, arcs, and clothoid spirals. 
You can create vertical alignments with lines (constant slope), arcs, and parabolas. 
Each vertical alignment is associated with a horizontal alignment, and there can be 
multiple vertical alignments for each horizontal alignment. The values you can enter 
depend on the alignment settings for the project.  

Usually, the goal in creating an alignment is to create a digital file of the design that 
you can upload to a field device for staking. 
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Related topics 

 Create an Alignment (on page 288) 
 Workflow for Creating Alignments (on page 287) 
 Workflow for Using Imported Alignments (on page 287) 

 

Workflow for Using Imported Alignments 

Save the effort of manually creating alignments by importing alignments created in 
other design applications. Alignments can be imported in GENIO or LandXML file 
formats. 

The general workflow for using imported alignments is: 

1. Import the file containing the alignment. The alignment appears as a single object 
in the Project Explorer. 

2. Check the alignment to make sure it accurately reflects the design, and make edits 
as necessary. 

 Open the Alignment Editor and verify that coordinates, bearings, lengths, 
stations, and other values match the original paper or digital plan. 

 Open a new horizontal tab group and arrange your views to that you can see 
the Alignment Editor and the appropriate graphic view (either plan or profile) 
concurrently. 

 Edit horizontal, vertical, and station values as needed. 

 Open the Properties pane, and edit the alignment's properties, such as the 
name, appearance, and layer, as needed. 

Related Topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Import LandXML Files (.xml) (on page 200) 
 Import GENIO Files (on page 198) 

 

Workflow for Creating Alignments 

Create alignments by manually entering values from digital or paper plans. Here is the 
general workflow: 

1. Use the Create Alignment command to create a new, blank alignment, and open it in 
the Alignment Editor. 

2. Open a new horizontal tab group and arrange your views so that you can see the 
alignment spreadsheet and the appropriate graphic view (either plan or profile) 
concurrently. 

3. Enter horizontal values from the paper or digital plans, or using the imported data 
as a reference. If necessary, enter vertical and station values as well.  
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4. Open the Properties pane, and edit the alignment's appearance properties, as 
needed. 

5. Export the alignment to another application or upload it to a field device. You can 
export alignments as .dxf/.dwg, GENIO, or LandXML files. 

Note: You can export an alignment to SCS software as a .dxf/.dwg foreground or 
background map (loses stationing and spirals), or you can export it to Terramodel 
as a 3D LandXML file, which you can then upload to SCS software. 
Note: If you export an alignment as a .dwg and then import it into another 
application as a .dxf/.dwg, any vertical alignments in the file may not appear. 

Related Topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Create an Alignment from a GENIO String (on page 297) 

 

Create an Alignment 

Build alignments by entering values to define horizontal line, arc, and spiral segments. 
If needed, define station equations and vertical segments as well. 

You can also create alignments by picking points in graphic views, but for precise 
values it is more likely that you will enter them using the keyboard. 

To create an alignment:  

1. Do one of the following: 

 Select Line > Create Alignment. 

 Click the  icon on the toolbar. 

The Create Alignment command pane displays. 

2. In the Name box, type an identifier for the new alignment. 

3. In the Layer list, select the layer on which you want the alignment to reside. 

4. Click OK. The Alignment Editor displays. 

5. Click the  icon. The Project Settings dialog for alignments displays. 

6. Change any setting formats to match the formats used in the design. 

7. Click OK. 

8. Referring to your design, type coordinate values in the North and East cells of the 
POB row. If you have station information, type it in the Station box. 
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Note: You can also pick a point, or right-click for snap options, in the graphic views 
to specify values. 
Note: You can right-click in the active cell to access Undo, Cut, Copy, and Paste 
commands, or right-click at the beginning of a row to access Insert Row, Delete Row, 
Copy, Editor Settings, and Float View commands. 

9. Press [Tab] or [Enter] to proceed to the next row.  

10. Select a segment type in the Type list. The type you select determines which values 
you can enter in the other cells of the row. 

11. Enter values for the available cells, based on the design. 

12. Repeat the previous steps until you have created segments for the entire horizontal 
component of the alignment. 

Note: Check the alignment in the graphic views as you enter values.  

13. If the alignment has station equation information, click the Station Equation tab.  

Note: Depending on how your data is arranged, you may want to enter station 
equations in between creating horizontal segments. 

14. Click Create Stations to make the cells available. 

15. Type values in the Back and Ahead cells. 

16. If the alignment has a vertical component, click the Vertical tab. 

17. Click Create Profile to make the cells available. 

18. Type coordinates in the Station and Elevation cells of the POB row. 

19. Press [Tab] to proceed to the next row.  

20. Select a segment type in the Type list, and enter values in the available cells. 

Note: In the vertical alignment, you are defining the PVI type, and entering PVI 
stations and elevations. 

21. Press [Enter]. The alignment appears in the Project Explorer. 

Related topics 

 View Settings (on page 152) 
 

Use Valid Segment Order 

When you are adding, inserting, deleting, or editing horizontal alignment segments, 
there are valid and invalid ways in which segment types can be connected. For 
instance, a combining spiral must be preceded and followed by an arc; it cannot 
connect to any other segment type. Some typical, and valid, sequences of segment 
types include: 
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 Residential streets:  Line > Arc > Line > 

 High speed-streets and ramps:  Line > Spiral in > Arc > Spiral out > Line 

 Unusual high-speed ramps: Line > Spiral in > Arc > Combining spiral > Arc > Spiral 
out > Line 

Valid Segment Connections  

                       To 

From 

POB Line Arc Spiral 
in 

Spiral 
out 

Combining 
spiral 

POB — OK OK OK OK — 

Line — OK OK OK OK — 

Arc — OK OK OK OK OK 

Spiral in — OK OK — OK — 

Spiral out — OK OK OK — — 

Combining spiral — — OK — — — 

Note: Tangency is assumed when a line transitions into an arc or a spiral. 

Related topics 

 Alignment Editor (on page 30) 
 Create an Alignment (see "Understanding Alignments" on page 286) 
 Edit an Alignment (on page 290) 
 Horizontal Alignment Options (on page 291) 

 

Edit an Alignment 

You can edit an alignment's segment type and values, and you can also insert new 
segments into an alignment.  

At the top of the Alignment Editor, there is a list of alignments in your project. Click the 
 icon and the arrow to open the list. Once you have selected the alignment you want 

to edit, click the  icon to lock the list again. This will prevent you from editing the 
wrong alignment. 

To edit  an alignment:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Line > Alignment Editor. 

 Pick an alignment in a graphic view, right-click and select Alignment Editor 
from the context menu. 

 Select an alignment in the Project Explorer, right-click and select Alignment 
Editor from the context menu. 
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The Alignment Editor displays. 

Note: You can only edit one alignment at a time. If you have multiple alignments 
selected, only the active alignment (indicated in bold in the Project Explorer) 
appears in the Alignment Editor. 

2. Select Window > New Horizontal Tab Group. A second pane opens so that the 
alignment spreadsheet and graphic views are visible concurrently. You may need 
to right click on a view tab and select Move to Next Tab Group from the context 
menu. 

3. In the alignment spreadsheet, click the tab on which you want to edit data. 

4. To edit values, click in a cell and specify a new value. The alignment updates in the 
graphic views as you make changes. 

Note: If the spreadsheet requests values in different formats than those used in 
your plan, click Settings to access the Project Settings dialog, where you can change 
the display format and entry methods. 

5. To change a segment type, click a cell in the Type column and select a new type 
from the list. 

6. To insert or delete a segment, right-click at the beginning of a row. 

7. Press [Enter] to save your changes. 

Related topics 

 Alignment Editor (on page 30) 
 Create an Alignment (see "Understanding Alignments" on page 286) 
 Edit an Alignment's Properties (on page 295) 

 

Horizontal Alignment Options 

Use these options to define each segment of a horizontal alignment. They are available 
on the Horizontal tab of the Alignment Editor.  

Entry formats are defined in Project Settings, which can be accessed by clicking 
Settings in the Alignment Editor, or by right-clicking the last row in the spreadsheet and 
selecting Editor Settings from the context menu. Depending on the entry format that is 
set, some of the options below may not be required. 
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Options 

Type 

 

POB (Point of Beginning) - Denotes the starting point for the 
alignment. 

Define the station, and northing and easting coordinates. 

Line - Select this to enter a straight segment. 

Define the azimuth or bearing, and length. 

Arc - Select this to enter a curved segment with a constant 
radius. 

Define the azimuth or bearing, radius, side from POB, and 
length/delta/station. 

Spiral In - Select this to enter a transitional segment (clothoid 
spiral) with a decreasing radius. Generally, use this to connect 
a line with an arc. 

Define the azimuth or bearing, radius, side from POB, and 
length/station/A parameter. 

Spiral Out - Select this to enter a transitional segment 
(clothoid spiral) with an increasing radius. Generally, use this 
to connect an arc with a line. 

Define the azimuth or bearing, radius, side from POB, and 
length/station or A parameter. 

Combining Spiral - Select this to spiral between two arcs with 
different radii. 

Define the azimuth or bearing, side from the POB, radius 1, 
radius 2, and length/station/A parameter. 

Azimuth  

(North or South) 

or  

Bearing 

Specify a bearing or an azimuth value at the beginning of the 
segment, or accept the default of Tangent, which is the bearing 
from the previous segment. 

For lines, this is the bearing of the entire segment. For arcs and 
spirals, it is the tangent bearing into the segment. 

Radius Specify a radius value for an arc. 

Left / Right Select the direction an arc should curve, left of right in the 
direction from the POB. 

Length Specify the length or distance of the segment. 

For arcs, and spirals, it is the actual length, not a chord length 
Delta Specify the central angle of the arc. 

A Param Specify the standard factor used as a roadway design criteria in 
establishing the required length of the spiral. 

The A parameter reflects the rate of change of the radius, in 
relation to the distance along the spiral. 

Station Specify the station value at the end of the POB segment. For 
other segment types, this displays the station. 
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North Specify the northing coordinate at the end of the POB 
segment. For other segment types, this displays the northing 
coordinate. 

Note: The order of the north and east are dictated by the 
format set in Project Settings. 

East Specify the easting coordinate at the end of the POB segment. 
For other segment types, this displays the easting coordinate. 

Related topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Horizontal Alignment Options (on page 291) 
 Vertical Alignment Options (on page 293) 

 

Vertical Alignment Options 

Use these options to define each segment of a vertical alignment. They are available on 
the Vertical tab of the Alignment Editor. The entry formats are defined in Project Settings, 
which can be accessed by clicking the  icon in the alignment spreadsheet. 
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Options 

PI Type POB (Point of Beginning) - Denotes the starting point for the 
alignment. 

Define the station and elevation. 

Grade Break - Select this for PVIs that do not have a curve. 
Typically, this is used for small changes in grade, or for the end of 
the vertical alignment. 

Define the station and elevation. 

Symmetrical vertical curve - Select this to create a vertical curve 
when the curves on either side of the point of intersection (PI) 
are of equal length. 

Define the station, elevation, and curve length/K factor. 

Asymmetrical vertical curve - Select this to create a vertical curve 
when the curves on either side of the point of intersection (PI) 
are of unequal length. 

Define the station, elevation, and approach and departure curve 
lengths. 

Vertical Arc - Select this to enter a vertical curve with a constant 
radius. 

Define the station, elevation, and radius/length. 
Station Type a station value, or pick it in the profile view. 

Elevation Type an elevation value for the station, or pick it in the profile 
view. 

Curve Length Type a length for the vertical curve, or pick two points in the 
profile view to use the distance between them as the length.  

Radius Type a radius value for the arc. 

K Factor This displays the calculated ratio of change on the vertical curve. 

Approach Curve Length For asymmetric curves, type a value for the  curve before the PVI. 
(from PVC to PVI) 

Departure Curve 
Length 

For asymmetric curves, type a value for the  curve after the PVI. 
(from PVI to PVT) 

Note: You can use the same station value for two consecutive PVIs (not just 0+00). This 
allows a vertical rise or fall in the alignment. 

For example, if you need to model channel (drainage) flow-lines where you have a 
vertical drop, you can add the same station at different elevations.  

Station  Elevation 

2+25.00  125.00 

2+25.00  120.00 
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This will draw the profile to elevation 125 when coming from the downstation, and 
elevation 120 when coming towards the upstation. The order of the entries in the 
editor determines the order in which they are used. 

Related topics 

 Alignment Profile View (see "Profile View" on page 26) 
 Alignment Stationing Options (on page 295) 
 Create an Alignment (see "Understanding Alignments" on page 286) 
 Create a Profile of a Surface (see "Create and View a Surface Profile" on page 325) 
 Horizontal Alignment Options (on page 291) 

 

Alignment Stationing Options 

Use these options to define an alignment's station values, generally when you add or 
remove curves. They are available on the Stationing tab of the Alignment Editor. 

Options 

Station Equations 

Back Type a station back value. 

Ahead Type a station ahead value. 

Station Zones 

Zone Denotes the section from one station to the next. The zone number 
also appears after the colon in the Start Station and End Station 
values. 

Start Station Shows the station at which the zone begins. The first station segment's 
value is derived from the Horizontal tab's POB station. 

End Station Shows the station at which the zone ends. 

Progression Indicates whether the station value increases or decreases after the 
station equation. 

Related topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Horizontal Alignment Options (on page 291) 
 Vertical Alignment Options (on page 293) 

 

Edit an Alignment's Properties 

Change alignment names, display properties, and layers in the Properties pane. 

To edit  an alignment's properties:  

1. Do one of the following: 

 Pick the alignment in a graphic view, right-click, and select Properties from the 
context menu. 
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 Double-click the alignment in the Project Explorer, or right-click it and select 
Properties from the context menu.  

The Properties pane displays. 

2. Click in an available box, and make changes as necessary. 

Note: If the scale of your alignment is small in a graphic view, some linestyles 
display as solid lines to improve performance. 

3. Click Close. The alignment updates based on the changes. 

Related topics 

 Alignment Editor (on page 30) 
 Edit an Alignment (on page 290) 

 

Alignment Properties 

Use these options to change alignment names, display properties, and layers. They are 
available in the Properties pane when an alignment is selected. 
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Options 

Linestyle Select an appearance for the line in graphic views. 

Note: If the scale of your line is small in a graphic view, 
some linestyles display as solid lines to improve 
performance. 

Color Select a display color for graphic views. 

Visible True - Select this to display the alignment in graphic views.

False - Select this to hide the alignment in graphic views. 

Layer Select the layer on which you want the alignment to reside. 

Reference Location Northing Displays the north coordinate used in the alignment's POB. 

Reference Location Easting Displays the east coordinate used in the alignment's POB. 

Reference Station Display the station used in the alignment's POB. 

Related topics 

 Edit an Alignment's Properties (on page 295) 
 

Create an Alignment from a GENIO String 

GENIO strings are sets of 3D points connected to form linear features, such as street 
centerlines or curb lines. There are three types of GENIO strings that can be imported 
into Trimble® Business Center.  Each type can be used in a different way. 
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GENIO str ing 

3D Import these, and use them with other data to form a surface. 

They do not import as alignments, and cannot be converted into alignments. 

6D Import these, and convert them into alignments using the steps below. 

12D Import these. They are automatically converted into alignments that appear in 
graphic views and the Project Explorer. 

To create an alignment from a 6D string: 

1. Import a GENIO 6D string. 

2. In a graphic view, pick the string. 

3. Select Line > Create Alignment From a GENIO 6D String.  

The alignment is created. It appears in graphic views (coincident with the original 
string) and in the Project Explorer. 

Note: After you convert a GENIO 6D string into an alignment, check the results 
thoroughly. 

Related topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Import GENIO Files (on page 198) 

 

Run an Alignment Geometry Report 

Generate an Alignment Geometry Report to see a simple summary or detailed listing of 
the geometry of an alignment in your project. You can choose to report on just the 
horizontal component or both the horizontal and vertical components of alignments. If 
you have specified station equations, they will be reported as well. 

To run an Alignment Geometry Report:  

1. Select Reports > Alignment Geometry Report. The Alignment Geometry Report 
command pane displays. 

2. Select an alignment in the Alignment list. 

3. Click OK. The Alignment Geometry Report displays in your default Web browser. 

To customize the report:   

1. Do one of the following: 

 Click the  icon on the Alignment Geometry Report command pane's toolbar. 

 Select Reports > Report Options.  
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The Report Options command pane displays. 

2. Select Alignment Geometry Report in the list. 

3. Expand sections and specify output settings in the Settings group as needed. 

4. Click Apply if you want to customize additional reports, or OK to close the 
command pane. 

Tip: You can also change the abbreviations used for horizontal and vertical 
alignment classifications in the Alignment Geometry Report. Select Project > 
Project Settings, and click Abbreviations in the left pane. Edit any of the 
abbreviations in the right column and click OK. Rerun the report to see your 
changes. 

Related topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Alignment Editor 

The Alignment Editor enables you to edit the horizontal, vertical, and stationing values 
of existing alignments. The graphic views reflect all changes made to alignments in the 
editor. 

 

Related topics 

 Edit an Alignment (on page 290) 
 Data View Display Formats (on page 32) 
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 Pane and Data View Positioning (on page 31) 
 Tabbed View Arrangement (on page 34) 

 

Create and Edit a Linestring 

Create a Linestring 

Create linestrings (versatile single or multi-segmented linear or curvilinear objects) to 
represent 2D or 3D linear objects. 3D lines can be defined and queried entirely from 
within the Plan View (on page 25), and they provide a unique and versatile way of 
establishing the line's elevation or its vertical alignment. You can create linestrings in 
this software, or you can convert imported lines, such as CAD polylines, into 
linestrings as you edit them. In creating a linestring, you specify the location of each 
point along the line, and how the connections (segments) between them are formed. 

 

To create a l inestring: 

1. Do one of the following: 

 Select Line > Create Linestring. 

 Click the  icon. 

The Create Linestring command pane displays. 

2. In the Name box, type an identifier for the linestring as you want it to appear in the 
Selection Explorer and graphic views. You can also use the name to select the 
linestring in the Advanced Select command. 

3. Select the layer on which you want the linestring to reside in the Layer list, or 
select <<New layer>> to create a new layer for the linestring. 

4. Click OK. The Edit Linestring command pane displays. Continue to create the 
linestring using either of the options below. 

To enter the f irst point by specifying a coordinate: 

This option starts the linestring with the coordinate of any location (point) you pick, so 
that the linestring's geometry remains fixed at that point until you edit its coordinate.   

1. In the Start Point group's Type list, select Coordinate. 
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2. Click in the Coordinate box, and pick a location in a graphic view, type a 
coordinate, or right-click for COGO coordinate options (see "Enter a Coordinate" 
on page 97). 

3. Enter the elevation for the starting point in the Elevation box, or right-click for 
COGO elevation options (see "Enter an Elevation" on page 125). 

4. Click Save or press [Enter]. The first point of the linestring is saved and you are 
prompted to add the second point, designating how the segment between them is 
formed. 

5. Add the second point and the segment between them using the operations in Edit a 
Linestring's Horizontal Segments (on page 301). 

To enter the f irst point by specifying a point ID: 

This option starts the linestring with a named point (point with a point ID) so that the 
linestring's geometry always reflects the location of the point. If you edit the point, the 
linestring updates in response. 

1. In the Start Point group's Type list, select Point ID. 

2. Click in the Point ID box, and pick a named point in a graphic view or type a point 
ID. The elevation of the point you specified is automatically used. 

3. Click Save or press [Enter]. The first point of the linestring is saved and you are 
prompted to add the second point, designating how the segment between them is 
formed. 

4. Add the second point and the segment between them using the operations in Edit a 
Linestring's Horizontal Components (see "Edit a Linestring's Horizontal Segments" on 
page 301). 

Related topics 

 Edit a Linestring's Horizontal Segments (on page 301) 
 

Edit a Linestring's Horizontal Segments 

The linestring editing command provides one familiar tool with which you can edit a 
large array of imported CAD lines of many types, such as polylines, arcs, and splines, 
automatically converting them in the process to linestrings, and enriching them as 
needed with geometric attributes not otherwise supported by the source objects.  

Edit linestrings by redefining their points and the connections (segments) between the 
points, as well as by adding, inserting, and deleting segments. 

To define vertical points of intersection (independent of the segment end points) at 
specific distances along the linestring, add vertical control points using the operations 
in Edit a Linestring's Vertical Control Points (on page 309). 
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The current segment, end point, and direction of the linestring are 
indicated during editing. An X indicates the linestring's start point. 

To access these options: 

If you have just created a linestring, skip to one of the operations below. Otherwise, 
select a line or linestring and do one of the following: 

 Select Line > Edit Linestring. 

 Click the  icon on the toolbar, or on the Properties pane toolbar when a 
linestring is selected. 

 Right-click, and select Edit from the context menu. 

The Edit Linestring command pane displays. Click the Horizontal tab. 

To view and select each horizontal segment in sequence: 

 Click the back and forward arrows on either side of the Current segment list, or 
move your cursor along the linestring in a graphic view and click to select the 
segment. 

To add a straight segment:  

1. In the Segment group's Type box, select Straight. 

2. Follow the steps in To specify a segment's end (or start) point below. 

3. Click Save or press [Enter]. The segment is saved and you are prompted to specify 
the end point for the next segment. 

To add a curved segment:  

1. In the Segment group's Type list, select Arc or 3 Point Arc. 

 Arc - Select this to create a curved segment between two points. Then, specify 
the radius of the arc, whether it curves left or right from the previous segment, 
and whether to use the larger arc (> 180 °) or smaller arc (> 180 °) that is created 
between the points. 
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 3 Point Arc - Select this to create a curved segment from the preceding 
endpoint, passing through a specified intermediate point, to a specified 
segment endpoint. 

2. Follow the steps in To specify a segment's end (or start) point to specify the end point 
of the curved segment. 

To add a straight segment at a deflection angle from the preceding 
segment:  

1. In the Segment group's Type list, select Deflection. 

2. For the Direction, select the perpendicular left (-90 °), perpendicular right (90 °), 
straight ahead (0 °) deflection angle option, or select Specified angle to enter a 
specific deflection angle. 

Note: Positive deflection angles are measured clockwise from the direction of the 
previous segment. 

3. Pick a point in the graphic view to specify the length, or type a value in the Length 
box. 

4. Type an elevation for the end point in the Elevation box, and click Save or press 
[Enter]. 

To specify a segment's end (or start)  point:  

1. In the End Point (or Start Point) group's Type list, select Coordinate or Point ID. 

2. Depending on the type you selected, click in either the Coordinate box or the Point 
ID box. 

3. For a coordinate, pick a location in a graphic view, type a coordinate, or right-click 
for COGO coordinate options (see "Enter a Coordinate" on page 97). Then enter the 
elevation for the starting point in the Elevation box, or right-click for COGO 
elevation options (see "Enter an Elevation" on page 125). 

4. For a point ID, pick a named point (point with an ID) in a graphic view or type a 
point ID. The elevation of the point you specified (if defined) is automatically used 
to establish a vertical point of intersection on the line at that point. 

5. Click Save. 

To edit a segment:  

1. Select the segment by picking it in the plan view, selecting it in the Current segment 
list, or clicking   and selecting it in the Browse Horizontal Segments list. 

2. Modify any of the options for the segment, and click Save. 
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To remove a segment:  

1. Select the segment by picking it in the plan view, selecting it in the Current segment 
list, or clicking   and selecting it in the Browse Horizontal Segments list. 

2. Click the  icon. The segment and its end point are removed, and the adjoining 
segments' end points are joined. 

Note: To delete a segment without joining the adjoining segments, use the Delete 
Line Segment (see "Delete a Line Segment" on page 316) command. 

To insert a segment before the current segment:  

1. Select the segment before which you want to insert a new segment by picking it in 
the plan view, selecting it in the Current segment list, or clicking   and selecting 
it in the Browse Horizontal Segments list. 

2. Click the  icon. 

3. Follow the steps in To specify a segment's end (or start) point above to specify the 
new segment's end point, which becomes the new location of the start point for the 
segment you selected. The new segment is inserted before the selected segment. 

To insert a new first segment:  

1. Select the linestrings 'start' coordinate or point by picking it in the plan view or 
selecting it in the Current segment list. 

2. Click the  icon. 

3. Follow the steps in To specify a segment's end (or start) point above to specify the 
start point for the new, first segment in the linestring. 

To add a segment onto the end: 

1. Select the last segment by picking it in the plan view or selecting it in the Current 
segment list. 

2. Click the  icon. 

3. Follow the steps in one of the To add a * segment  operations above. 

To view and select a segment in a l ist:  

1. Click the  icon. The Browse Horizontal Segments dialog displays. 

2. Select the segment you need, and click OK. 
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To reverse the segment order/switch the l inestring's start and end 
points:  

 Click the  icon on the pane's toolbar. You can confirm the order by moving your 
cursor along the linestring in the graphic view. The direction of the linestring is 
shown in the plan view an arrow on the selected segment. 

To convert two consecutive straight segments to a 3 point arc 
segment:  

1. Select the segment whose end point will become the 'point on curve' by picking it 
in the plan view, selecting it in the Current segment list, or clicking   and 
selecting it in the Browse Horizontal Segments list. 

2. Click the  icon. The selected segment and the one following it are converted to 
a 3 point arc.  

Note: Since you must select the first of two segments to be used in the 3 point arc, a 
linestring's final segment cannot be selected for this function. 

To convert a 3 point arc segment to two straight segments:  

1. Select the segment that is currently defined as a 3 point arc by picking it in the plan 
view, selecting it in the Current segment list, or clicking   and selecting it in the 
Browse Horizontal Segments list. 

2. Click the  icon. The selected segment is converted into two straight segments, 
joined at the previous 'point on curve' of the 3 point arc. 

Related topics 

 Create a Linestring (on page 300) 
 Edit a Linestring's Vertical Control Points (on page 309) 
 Horizontal Linestring Segment Options (on page 305) 

 

Horizontal Linestring Segment Options 

Use these options to create and edit horizontal linestring segments. They are available 
on the Horizontal tab of the Edit Linestring command pane. Linestring properties can be 
edited in the Properties pane (on page 14). 
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Options 

 Click this to display the properties of the selected linestring in the 
Properties pane. 

  Click this to start the Create Linestring (see "Create a Linestring" on 
page 300) command. 

 Click this to reverse the order of the linestring's segments and the 
start and end points. 

 Click this to start the Set Line Elevation (see "Set a Line Elevation" on 
page 317) command. 

 Click this to start the Break Line (see "Break a Line" on page 314) 
command. 

 Click this to start the Join Lines (on page 315) command. 

Horizontal tab 

Current segment This shows the number, segment type, and end point type of the 
currently selected horizontal segment of the linestring. Click the back 
or forward arrow on either side of the listed segment (or scroll the 
mouse wheel) to select the previous or next segment. 

A segment is defined by the location of its end point, the elevation of 
the point (if defined), and the type of connection to the previous 
segment's end point (or the linestring's starting point). 

 Click this to display the Browse Horizontal Segments dialog, a list in 
which you can view and select from all of the horizontal alignment 
segments in the linestring. 

 Click this to insert a new segment before the selected segment or start 
point. 

 Click this to add a new segment onto the end of the linestring. 

 Click this to remove the selected segment. 

The segment and its end point are removed, and the adjoining 
segments' end points are joined. 

 or  When displayed, click the icon to toggle between two states, 
depending on the current segment type. 

Click  to convert a selected 3 point arc segment into two straight 
segments, converting the specified point on curve into a new 
segment's end point.  

Click  to convert the selected segment and next segment into a 3 
point arc, converting the end point of the first segment into the arc's 
point on curve. 

Start point This group appears only when you are specifying the beginning 
location of a linestring. Use the Straight Segment Options below. 

Segment type Select an option for how the current segment end point will be joined 
to the previous segment end point or the line's start point. 
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Straight - Select this to create a straight segment between the points. 

Arc - Select this to create a curved segment defined by a radius 
between the points. 

3 Point Arc - Select this to create a curved segment defined by a point 
on curve and an end point. 

Deflection - Select this to add a straight segment at a deflection angle 
from the preceding segment. 
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Straight segment/End point options 

End point type Coordinate - Select this to end the segment by specifying a fixed 
coordinate location. 

Point ID - Select this to end the segment by specifying a named point 
using a point ID. The linestring segment will be dynamically attached 
to that point object. 

Coordinate Pick a point in a graphic view, type a coordinate, or right-click for 
more options 

Elevation Optionally, type an elevation for the end point of the segment. If you 
do, it establishes a vertical point of intersection on the line at the 
segment's end point. 

Point ID Pick a named point in a graphic view or type a point ID. 

Arc segment options 

Radius Type a value for the radius of the arc. 

Left/right Select whether the arc should curve right or left, in relation to the 
direction of the previous segment. 

Large/Small Select whether to use the larger arc (> 180 °) or smaller arc (< 180 °) 
that is created between the points. 

3 Point arc segment options 

Coordinate Select this to use any coordinate as the intermediate point ('point on 
curve') of the arc. 

Point on curve Pick a point in a graphic view, type a coordinate, or right-click for 
more options to specify a point trough which the arc must pass. 

Elevation Optionally, type an elevation for the point on curve of the arc. If you 
do, it establishes a vertical point of intersection on the line at the 
segment's end point. 

Point ID Select this to use a named point as the intermediate point. Then, pick 
a named point in a graphic view or type a point ID in the box. 

Deflection segment options 

Direction Select the perpendicular left (-90 °), perpendicular right (90 °), 
straight ahead (0 °) deflection angle option, or select Specified angle 
to enter a specific deflection angle. 

Note: Positive deflection angles are measured clockwise from the 
direction of the previous segment. 

Length Type a value in the box or pick a point in the graphic view to specify 
the length of the segment. 

Elevation Optionally, type an elevation for the end point of the segment. If you 
do, it establishes a vertical point of intersection on the line at the 
segment's end point. 

Save Click this to save the current segment.  

You are prompted to specify the end point for the next segment. 
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Related topics 

 Edit a Linestring's Horizontal Segments (on page 301) 
 Edit a Linestring's Vertical Control Points (on page 309) 
 Vertical Linestring Options (on page 310) 

 

Edit a Linestring's Vertical Control Points 

If you need to define vertical points of intersection (VPIs) on a linestring that are 
located other than at the horizontal segment end points or the line's start point, add 
vertical control points along the linestring. A vertical control point is defined by its 
distance along the linestring, the elevation of the vertical point of intersection, and an 
indication as to whether a symmetrical parabolic vertical curve is involved at that VPI 
and if so, its length. Vertical points of intersection defined in this manner have no 
effect on the linestring's horizontal alignment.  

Note: If a horizontal segment's end point and a vertical control point coincide, the 
elevation of the vertical control point overrides the elevation that may be assigned to 
the end point or to the point object to which it may be attached. 

To access these options: 

Select a line or linestring and do one of the following: 

 Select Line > Edit Linestring.  

 Click the  icon on the toolbar, or on the Properties pane toolbar when a 
linestring is selected. 

 Right-click, and select Edit from the context menu. 

The Edit Linestring command pane displays. Click the Vertical tab. 

To add a vertical  control point with no vertical  curve:  

1. Click the  icon. 

2. In the Curve group's Type box, select No curve. 

3. Type a distance from the linestring's start point in the Distance along box, or pick a 
point along the linestring in the graphic view. 

4. Type an elevation for the vertical control point in the Elevation box. 

5. Click Save or press [Enter]. The vertical control point is added with simple, 
straight transitions from and to the point using the straight segments created by the 
point. 

To add a vertical  control point with a parabolic curve:  

1. Click the  icon. 
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2. In the Curve group's Type box, select Parabolic. 

3. In the Length box, type a length for the parabolic vertical curve to be applied at the 
vertical control point. 

4. Type a distance from the start point in the Distance along box, or pick a point along 
the linestring in the graphics view. 

5. Type an elevation for the vertical control point in the Elevation box, and click Save 
or press [Enter]. The vertical control point is added with a parabolic curve. 

To view and select a vertical control point in a l ist :  

1. Click the  icon. The Browse Vertical Information dialog displays. 

2. Select the point you need, and click OK. 

To step through each vertical  control  point in sequence: 

 Click the back and forward arrows on either side of the Current vertical control point 
list. 

To edit  a vertical  control point:  

1. Select the point by selecting it in the Current VPI list or clicking   and selecting it 
in the Browse Vertical Information list. 

2. Modify any of the points options, and click Save. 

To delete a vertical  control  point:  

1. Select the point by selecting it in the Current VPI list or clicking   and selecting it 
in the Browse Vertical Information list. 

2. Click the  icon. The point is removed, eliminating the affect of the vertical 
control point on the linestring's vertical alignment. 

Related topics 

 Edit a Linestring's Horizontal Segments (on page 301) 
 Vertical Linestring Control Point Options (see "Vertical Linestring Options" on 

page 310) 
 

Vertical Linestring Options 

Use these options to create and edit vertical control points along a linestring. They are 
available on the Vertical tab of the Edit Linestring command pane. Linestring properties 
can be edited in the Properties pane (on page 14). 
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Vert ical  tab options 

Current VPI This shows the distance along the linestring and curve type of 
the currently selected vertical control point on the linestring. 
Click the back or forward arrow on either side of the listed 
point to select the previous or next point. 

A vertical control point is defined by its distance along the 
linestring, the elevation of the point, and how the linestring's 
geometry vertically transitions at the point.  

Note: The locations of vertical control points are independent of 
the locations and elevations of horizontal segment end points; 
when you move horizontal segments, vertical control points 
remain at the distance along the line at which they were 
defined. If a horizontal segment's end point and a vertical 
control point coincide, the elevation of the vertical control 
point overrides the elevation of the end point. 

 Click this to display the Browse Vertical Information dialog, a 
list in which you can view and select from all of the vertical 
control points in the linestring. 

 Click this to add a new a vertical control point. 

 Click this to remove the selected vertical control point. 

Curve type Select an option for how the linestring's geometry vertically 
transitions at the vertical control point. 

No curve - Select this to simply transition at the vertical control 
point using the two straight segments created by the point. 

Parabolic - Select this to transition more smoothly by rounding 
off the two straight segments created by the point using a 
parabolic curve. 

No curve type 

Distance along Type a distance from the linestring's start point, or pick a point 
along the linestring in the graphic view. 

Elevation Type an elevation for the vertical control point. 

Parabolic curve type 

Length Type a length for the parabolic curve that transitions the two 
straight segments into the vertical control point. 

The parabolic curve is tangent to both incoming and outgoing 
segments. 

Save Click this to save the current vertical control point. 

You are prompted to specify the location of the next vertical 
control point. 

Related topics 

 Edit a Linestring's Horizontal Segments (on page 301) 
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 Edit a Linestring's Vertical Components (see "Edit a Linestring's Vertical Control 
Points" on page 309) 

 Horizontal Linestring Options (see "Horizontal Linestring Segment Options" on 
page 305) 

 

Create and Edit a Simple Breakline 
Simple breaklines are simplified linestrings that help to define the shape of a surface as 
do other 3D line types that act as breaklines, by controlling how triangles in the surface 
mesh are formed. Triangles forming a surface never cross a breakline. Use breaklines of 
any type to more accurately reflect where surface topography changes. 

Create a simple breakline is to add linestring segments between points where surface 
triangles converge (vertices), but you can also add simple breakline segments freely 
between any two locations on or near the surface. The addition, deletion or any edit to 
a 3D line serving as a surface breakline will cause the entire surface to be reformed. 
Unlike more complex linestrings, simple breaklines do not use vertical control points; 
you can enter elevations for each new vertex or derive elevations from existing 
vertices. 

To create a simple breakline: 

1. Do one of the following: 

 Select Surface > Create Breakline. 

 Click the  icon on the toolbar. 

The Create Breakline command pane displays. 

2. In the Name box, type an identifier for the linestring as you want it to appear in the 
Selection Explorer and in graphic views when you select from multiple objects. You 
can also use the name to select the linestring in the Advanced Select command. 

3. Select a layer on which to create the linestring in the Layer list, or select <<New 
layer>> to create a new layer for the linestring. 

4. Select an option for how smoothly the surface is rendered at this particular 
linestring in the Surface sharpness list. 

5. Select the surface to which the linestring will be assigned as a member in the Add to 
surface list. 

6. Click OK. The Edit Linestring command pane displays with reduced options 
appropriate for creating a simple breakline. 

7. In the Start Point group's Type list, select Coordinate to start the linestring at any 
location, or select Point ID to attach the linestring to a named point. 
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8. Click in either the Coordinate box or Point ID box (depending on what you chose for 
the starting point type), and use one of these ways to specify each point along the 
linestring: 

 In a graphic view, pick a vertex on the surface, or pick a named point (which 
may be a member of the surface and therefore one of its vertices) 

 Pick any location on or near the surface in the graphic view, and then type an 
elevation in the Elevation box. Then, click Save or press [Enter]. 

 Type a coordinate, press [Tab], and type an elevation in the Elevation box. Click 
Save or press [Enter]. 

The first point of the simple breakline is saved and you are prompted to add the 
second point and specify how the segment between them is formed. 

Note: To use the elevation from a point you pick anywhere on a surface, right-click 
and select From Surface Snap from the context menu. You are prompted to pick the 
point in the From Surface Snap command pane. Then, click Save or press [Enter]. 
Note: To avoid picking points off of the surface (with no elevation), uncheck the 
Free snap in the Snap Mode (see "Snaps Modes and Commands" on page 89) dialog 
when you create a simple breakline or linestring. If you are prompted for an 
elevation, you may have missed the vertex point you were trying to pick. 
Note: You can also draw a 'freehand' breakline without using any existing data. In 
fact, you do not even need to have a surface to create a breakline. 

9. Keep adding segments to the linestring using one of the methods in step 8. 

10. Click Close. The simple breakline appears on the surface in graphic views, but does 
not appear in the Project Explorer. 

Note: Once created, linestrings can be graphically selected and added to other 
surfaces. 
Tip: To view changes to your surface more clearly as you work, open a 3D view and 
move it to a new tab group next to your plan view so you can see both views 
concurrently. 

To edit  a simple breakline:  

 Use the operations in Edit a Linestring's Horizontal Segments (on page 301). 

Related topics 

 Edit a Linestring's Horizontal Segments (on page 301) 
 Create a Linestring (on page 300) 
 Understanding Breaklines (on page 330) 
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Breakline Options 
Use these options and those listed in Horizontal Linestring Options to create a breakline. 
They are available in the Create Breakline and Edit Linestring command panes. After 
creating a breakline, these properties and others can be edited in the Properties pane.  

Options 

Name Type an identifier for the breakline.  

This name will appear in the Selection Explorer and in graphic views 
when you select from multiple objects. In addition, you can use the 
name to select the breakline using the Advanced Select command. 

Layer Select the layer on which you want the breakline to reside, or select 
<<New layer>> to create a new layer for the breakline. 

Segregating data onto logical layers makes it easier to filter your 
graphic views and select related data. 

Surface 
sharpness 

Select an option for how smoothly surface colors graduate at 
breaklines. 

Soft - Select this to have shading gradually change at the breakline, 
giving the visual appearance of a soft edge. 

Sharp - Select this to have shading abruptly change at the breakline, 
giving the visual appearance of a sharp edge. 

Add to surface Select the surface that you want the breakline to modify. 

Related topics 

 Create and Edit a Breakline (see "Create and Edit a Simple Breakline" on page 312) 
 Edit a Surface by Creating a Breakline (on page 334) 

 

Break a Line 
Break a line to split it into two separate linestrings at the point you specify. The 
linestrings remain coincidental at the break point, but must be edited separately 
thereafter. 

Note: This command and others used on lines, such as Join, Edit, and Delete Line 
Segment, convert the lines into linestrings. Linestrings are generic lines which offer 
more editable properties than the original lines. For more information on linestrings, 
see Understanding Linestrings. 

To break a l ine:  

1. Do one of the following: 

 Select Line > Break Line. 

 Click the  icon on the toolbar. 

The Break Line command pane displays. 
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2. Pick a line in a graphic view. The line is converted into a linestring which is 
recorded in the Line box, and a "rubber-band" line appears between your cursor 
and the linestring. 

3. Using the rubber-band line, pick a location along the linestring at which to break 
it, or distance from the beginning point of the line in the Location box and click 
Break. The linestring is broken at the point you specified. 

4. To break another line, click in the Line box, or click Close to end the command. 

Related topics 

 Join Lines (on page 315) 
 Create a Linestring (on page 300) 
 Edit a Linestring's Horizontal Segments (on page 301) 

 

Join Lines 
Join two or more contiguous lines into individual linestrings using manual and 
automated methods. When lines are joined, they are converted into linestrings, 
thereby increasing their versatility. The resulting linestring's direction and properties 
are determined by the first (base) line that you choose. 

There are two ways lines join: 

 By making their end points coincident if they are within 0.0001 m of each other 

 By drawing a straight segment between the nearest end points if they are further 
than 0.0001 m apart 

Note: End points with different elevations cannot be joined. 
Note: This command works on 2D data in the plan view; end points with an elevation 
of 0 (zero) are converted to 2D end points. 

To join two l ines manually:  

1. Do one of the following: 

 Select Line > Join Lines. 

 Click the  icon on the toolbar. 

The Join Lines command pane displays. 

2. Select the Two lines option. 

3. Pick a line in a graphic view. The line's name is recorded in the Base line box. 

4. Pick the line you want to join to the base line. The line's name is recorded in the 
Line to join box. The lines are joined and converted into a single linestring. 

5. To join additional pairs of lines, continue to pick lines to connect to the current 
base line. 
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6. Continue to join additional lines, or click Close. 

To join one l ine to many consecutive l ines:  

1. After step 1 above, select the One line to selection option. 

2. Pick a line in a graphic view. The line's name is recorded in the Base line box. 

3. Pick a set of lines to join to the base line, or click Options and choose a selection 
option. The number of lines selected is recorded in the Lines to join box. 

4. Press [Enter] or click Join. The command searches from the base line to each 
consecutive line, joining them until it reaches a break in the lines or a branch to 
multiple lines where it stops. The number of lines that were successfully joined to 
the base line is reported at the bottom of the pane. 

Note: Lines that are not within the 0.0001 m tolerance of each other cannot be 
joined using this method. 

To join all  consecutive l ines: 

1. After step 1 in the first procedure, select the All selected lines option. 

2. Pick a set of lines to join in a graphic view, or click Options and choose a selection 
option. The number of lines selected is recorded in the Lines to join box. 

3. Press [Enter] or click Join. The command searches from each selected line to each 
consecutive line, joining them until it reaches a break in the lines or a branch to 
multiple lines where it stops. The number of lines that were successfully joined to 
the base line is reported at the bottom of the pane. 

Note: Lines that are not within the 0.0001 m tolerance of each other cannot be 
joined using this method. 

Related topics 

 Break a Line (on page 314) 
 

Delete a Line Segment 
Delete a segment from a multi-segmented line or linestring to form one or two 
linestrings, depending on whether you delete an interior or an end segment. If a line 
consists of only one segment, the entire line will be deleted. 

Note: This command can be especially helpful in fixing crossing breaklines in a surface. 

To delete a segment:  

1. Do one of the following: 

 Select Line > Delete Line Segment. 



Trimble® Business Center 
Heavy Construction Edition User Guide 317 

 Work with Line Data

 Click the  icon on the toolbar. 

The Delete Line Segment command pane displays. 

2. Pick a line or linestring in a graphic view. The name is recorded in the Line box, 
and a "rubber-band" line appears between your cursor and the line. 

3. Using the rubber-band line, move along the line and pick the segment you want to 
delete. The segment disappears. 

Tip: You can also roll the mouse wheel to scroll through the line's segments. 

4. Continue picking linestrings and then segments to delete, or click Close. 

Related topics 

 Create a Linestring (on page 300) 
 Edit a Linestring's Horizontal Segments (on page 301) 

 

Set a Line Elevation 
Apply a single, constant elevation to a 2D line to make it a 3D linestring. You can also 
specify a vertical offset from the elevation that you enter and a surface to which the 
linestring will be added. 

Note: You cannot set a line elevation on a line that already has elevations. To modify 
the existing elevations, add vertical control points using the Edit Linestring command. 
Tip: The Set Line Elevation command is especially efficient when you have annotations 
that contain elevations next to your lines. You can simply pick each object and 
annotation consecutively. 
Tip: If you need to apply the same elevation to multiple consecutive linestrings, you 
may want to join them into a single linestring first using the Join command. 

To set a constant elevation on a l inestring: 

1. Do one of the following: 

 Select Line > Set Line Elevation. 

 Click the  icon on the toolbar. 

The Set Line Elevation command pane displays. 

2. To apply a standard vertical offset to each elevation you enter, type a value in the 
Vertical offset box. 

Note: This can be especially helpful when elevation values are specified by clicking 
on a text object, and when the resulting value is to be above or below the elevation 
reflected on that text. This commonly occurs in setting building pad elevations 
where the finished floor elevation is labeled, and the top of pad is to be beneath 
that by a specified slab thickness.  
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3. To make each line you pick a member (see "Edit a Surface by Adding and 
Removing Members" on page 328) of a specific surface, select the surface in the Add 
to Surface list. 

4. Pick a line in a graphic view. Any CAD line is converted to a linestring. 

5. Pick another object, such as an elevation annotation or contour line, that has an 
elevation you want to use, or type a value in the Elevation box. The elevation is 
applied to the entire linestring after adding the specified vertical offset. 

6. Repeat steps 4 and 5 to add elevations to additional objects as needed. 

7. Click Close. 

Related topics 

 Join Lines (on page 315) 
 Edit a Linestring's Horizontal Segments (on page 301) 

 

Explore an Object 
Explore objects, such as lines and alignments, by viewing geometric values calculated 
at specific locations based on the position of the cursor on the object in a graphic view. 
Certain values are displayed dynamically at the cursor as you move it along the object. 
Additional values are displayed statically in the command pane when you click in the 
view to specify a fixed location. 

To explore an object:  

1. Do one of the following: 

 Select Tools > Explore Object.  

 Click the  icon on the toolbar. 

The Explore Object command pane displays. 

2. Pick an object in a graphic view. The object is recorded in the Object box and values 
appear to the right of the cursor. 

3. Move the cursor to see values at various locations along the object. 

4. Click a location to report additional values in the command pane. 

5. Click Close. 

Related Topics 

 Explore an Object (on page 318) 
 Coordinates Scroll Command 
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Explode a Block 
After you import CAD data, explode any blocks that contain objects that you want to 
move, modify, or delete individually. Exploding breaks apart group objects that contain 
multiple individual objects (and sometimes additional nested blocks). 

To explode a block using options: 

1. Select Edit > Explode Blocks. The Explode Blocks command pane displays. 

2. Select a block object in the Project Explorer, Selection Explorer, or a graphic view, or 
click Options and select an option in the list.  

1. Uncheck the Delete blocks after exploding box if you want to retain the original 
block, as well as its individual component objects, after exploding it. 

Note: It is unlikely that you will need or want to retain the original block. 

2. Check the Remove block definitions box if you want to delete the hidden definition 
of the original block that you deleted by checking the Delete blocks after exploding 
box. 

Note: This box is unavailable if you do not delete the exploded blocks. Block 
definitions cannot be removed if your project still contains blocks that reference 
them. 

3. Click Apply if you want to explode additional blocks, or OK to close the command 
pane. 

To explode a block automatically:  

1. Select a block in a graphic view or in the Selection Explorer. 

2. Do one of the following: 

 Click the  icon on the toolbar. 

 Right-click and select Explode Blocks from the context menu. 

The selected block is exploded using the options defined in the Explode Blocks 
command pane. 

Related topics 

 Import CAD Files (.dwg/.dxf) 
 Import MicroStation Files (.dgn) (on page 204) 
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C H A P T E R  1 3  

Work with Surface Data 

Create and Edit a Surface 

Understanding Surfaces 

A surface is a 3D digital representation of topography, formed by a mesh of contiguous 
triangles, which is known as a triangulated irregular network (TIN). The triangles are 
connected at their vertices, which are defined by points with horizontal positions (X 
and Y values) and elevations (Z values). You can either import surfaces, or create them 
using existing data in your project. 

 

Use surfaces to:  

 Visualize and analyze the topography at different phases in your project: 

 Existing/as built terrain 

 Work in progress terrain 

 Finished earth 

 Proposed terrain (design) 
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 Compare one phase to another to generate volume reports for cut and fill 
earthwork operations. 

 Represent stockpiles and depressions 

 Create contour maps from topographic surveys. 

 Upload a surface to a field device to check grades, or for accurate staking of an 
alignment or daylight boundary. 

Related topics 

 Create a Surface (on page 323) 
 Workflow for Using Imported Surfaces (on page 321) 
 Workflow for Created Surfaces (see "Workflow for Creating Surfaces" on page 322) 

 

Workflow for Using Imported Surfaces 

You may receive surface files in .ttm or .xml format from colleagues, clients, or field 
crews using field software. You can also create surfaces from point data when you 
import using the Import Format Editor. The general workflow for using imported 
surfaces is: 

1. Import the file containing the surface. The surface is created as a single object, and 
appears in the Project Explorer. 

2. Check the surface for quality to make sure it accurately reflects the project 
topography. 

 View the surface in plan view with contours. 

 Orbit and view the surface in 3D view. 

 Use the coordinate scroll to check the elevation at specific locations. 

3. Edit surface properties, such as the classification, color, and other display 
characteristics. 

4. Compute volumes by comparing the surface to another surface.  

5. Upload the surface to a field device for staking, or export it to another application. 

Related Topics 

 Import LandXML Files (.xml) (on page 200) 
 Import Terrain Model Files (.ttm) (see "Import Trimble Surface Files (.ttm)" on 

page 207) 
 Check Imported Surfaces (on page 321) 

 

Check Imported Surfaces 

You can import surfaces existing in Trimble DTMs (.ttm), LandXML files (.xml), or 
ASCII point files. Once you do, check the surface for quality and accuracy. 
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To check an imported surface: 

1. Add contours to visualize the topography of the surface. 

2. Spot check elevations. Pick a point in a graphic view to find the elevation of the 
surface at that location. The coordinate scroll also shows the elevation of the 
current cursor location. 

3. In the 3D view, orbit around the surface and zoom in to see it everything looks 
valid. If it helps, change the vertical exaggeration.   

4. Pick the surface and view its properties in the Properties pane. 

 
Example of a surface with a point at an invalid elevation. 

Related Topics 

 Import LandXML Files (see "Import LandXML Files (.xml)" on page 200) 
 Import TTM Files (see "Import Trimble Surface Files (.ttm)" on page 207) 
 Create Surface Contours at Intervals (on page 343) 
 Edit a Surface by Changing Its Properties (on page 338) 
 3D View Navigation (on page 37) 

 

Workflow for Creating Surfaces 

You can create surfaces from data in your project. Here is the general workflow: 

1. Import the data from which you want to create a surface. Objects that can be used 
to create surfaces include: 

 Points 

 Feature coded points 

 CAD data 

2. Check and prepare the data. 

 Delete unneeded objects. 

 Organize data onto layers. 

 Add elevations to 2D CAD data. 
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3. Create a surface. 

 Select objects by layer, by elevation, or by picking them in a graphic view. 

4. Check the surface for quality to make sure it accurately reflects the project 
topography. 

 View the surface in plan view with contours. 

 View the surface in 3D view. 

 Use the coordinate scroll to check the elevation at specific locations. 

5. Edit the surface. 

 Add or remove members that form the surface. 

 Edit properties, such as elevations, of surface members. 

 Add breaklines to the surface. 

 Edit triangles at the surface's edge. 

6. Compute volumes by comparing the surface to another surface. 

Related Topics 

Prepare Layered Data for a Surface 

 Add and Edit Elevations on a 2D Line 
 Create a Surface (see "Understanding Surfaces" on page 320) 
 Create Surface Contours (see "Create a Surface Boundary and Contours" on page 

339) 
 

Create a Surface 

Certain types of objects in your data can be used to define a surface, including: 

 Points 

 Arcs, lines with elevation data, and polylines 

 Alignments 

 Sessions and vectors 

When you create a surface, you select a set of these objects. These selected objects are 
called "members" of the surface. Members do not become part of the surface, they 
simply define it. The surface is created as a separate object. To change a surface, you 
add, remove, or edit the positions of members in the set. As a result, the surface object 
updates to reflect the changes. 
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Note: Before creating a surface, set the default Maximum Edge Length and the Maximum 
Edge Angle of surfaces in Project Settings. Select Project > Project Settings. Then click 
Computational Settings and Surface in the Project Settings dialog. Setting these can reduce 
the amount of trimming needed on the surface edge. 
Tip: You can import points as a surface in the Import Format Editor (see "Import Data 
in a Custom Format" on page 209). 

To create a surface: 

1. Do one of the following: 

 Select Surface > Create Surface. 

 Click the  icon on the toolbar.  

The Create Surface command pane displays. 

2. Type a name in the Name box. 

3. Select a type in the Surface Classification list. This classification will be used to 
compare the surface to another surface with a different classification to calculate 
volumes for the Earthwork Report. 

4. In a graphic view, pick objects to include as member of the surface, or click Options 
and select an option in the list.  

Note: If you have organized your project into layers, select ByLayer. 

5. Click OK. The surface appears in the graphic views and the Project Explorer.  

Tip: To view surfaces more clearly, use a 3D view, and set your view filter to 
Surfaces. 

6. Check the surface for quality to make sure it accurately reflects the project 
topography. 

 View the surface in a plan view with contours. 

 View the surface in 3D view. 

 Use the coordinate scroll to check the elevation at specific locations. 

Related topics 

 Prepare Layered Data for a Surface 
 Surface Options (on page 324) 
 Workflow for Creating Surfaces (on page 322) 

 

Surface Options 

Use these options to identify the state of a surface in the construction process. They are 
available in the Create Surface command pane. 
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Options 

Surface Classification Unclassified - Select this when none of the classifications apply, or 
when you do not need to compare the surface to another 
classification of surface. 

Original - Select this when the surface represents the current state 
of the site's topography, i.e. the existing terrain. 

Work-in-progress - Select this when the surface represents a state 
in between the other, more defined, states. 

Finished earth - Select when the surface represents the 
“top-of-dirt” of the finished design.  This is usually the finished 
product for dirt-moving contractors. 

Design - Select this when the surface represents the proposed 
surface of a project, typically running across the top of pavement, 
building pads, concrete sidewalks etc.   

In most cases, this is the surface defined by the contours and spot 
elevations on plans from the engineer.   

As-built - Select this when the surface represents the completed 
project.  

Often this state is used to verify to an owner or regulatory agency 
that the site construction conforms to the plans. 

Stockpile - Select this when the surface represents a storage area 
for earthwork material. 

Depression - Select this when the surface represents a hole where 
material has been removed. 

Related topics 

 Create a Surface (see "Understanding Surfaces" on page 320) 
 

Create and View a Surface Profile 

Create a surface profile to review the elevation of a surface along a vertical alignment. 
To do this, you must have a surface and an alignment that coincide. If you simply want 
to see a surface profile without relation to an alignment, use the Surface Slicer View (see 
"View a Slice of a Surface" on page 327). 
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To create a surface profi le:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Surface > Create Surface Profile. 

The Create Profile of Surface command pane displays. 

2. Select a surface in the Surface list. 

3. Select an alignment in the Alignment list. 

4. Click OK. The profile of the surface displays with the alignment in the profile view. 

To view a surface cross-section along an alignment:  

1. In the Project Explorer, select the alignment that coincides with the surface. 

2. Right-click and select New Profile View from the context menu. The profile view of 
the alignment displays. 

Related topics 

 Profile View (on page 26) 
 Create an Alignment (see "Understanding Alignments" on page 286) 
 Create a Surface (see "Understanding Surfaces" on page 320) 
 View a Slice of a Surface (on page 327) 

 

Create and View a Surface Cross-Section 

Create a surface cross-section to check geometry along a single, specific alignment 
anywhere it coincides with a single, specific surface. To do this, the surface and 
alignment must be coincident. The view changes depending on where you are along 
the alignment. When the alignment or surface that the view is based on is modified or 
deleted, the view updates accordingly. Multiple cross-section views can be open 
concurrently. 
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To create a surface cross-section:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Surface > Create Surface Cross-Section. 

The Create Surface Cross-Section command pane displays. 

2. Select a surface in the Surface list. 

3. Select the coincident alignment in the Alignment list. 

4. Click OK. 

To view a surface cross-section along an alignment:  

1. In the Project Explorer, select the alignment that coincides with the surface. 

2. Right-click and select New Cross-Section View from the context menu. A 
cross-section view displays. 

3. Click and drag the slider at the bottom of the view to see the cross-sections along 
the alignment. 

or 

Type a station value in the box to the left of the slider to see the cross-section at a 
specific station. After you click in the station box, you can also move the cursor 
into the plan view and click anywhere along the alignment to specify the station. 

Note: The cross-section view maintains the same scale as you move the station 
slider. Red tick marks denote where the cross-section crosses points or breaklines. 
Bold vertical lines denote station equations. At certain view magnifications, slope 
values appear above segments. To hide cross-section slope values, right-click the 
cross-section, and select Properties from the context menu. In the Properties pane, 
select Hide in the Label slope list. 

Related topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Create a Surface (see "Understanding Surfaces" on page 320) 
 Profile View (on page 26) 
 View a Slice of a Surface (on page 327) 

 

View a Slice of a Surface 

Use the surface slicer view to check any surface cross-section by slicing vertically 
through the surface. You need to have the plan view and the surface slicer view open 
concurrently. Multiple surface slicer views can be open at a time, and you can view 
multiple surfaces in the view concurrently. 
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Note: If you use a command while viewing a surface slice, the focus will be in the 
Command pane. To return focus to the surface slicer view, click in the view's From or To 
box. 

To view a surface sl ice:  

1. Do one of the following: 

 Select Surface > Surface Slicer View. 

 Click the  icon on the toolbar.  

The surface slicer view displays. 

2. Click in the From box and pick a starting point for the slice in the plan view, or type 
a coordinate (in the format X,Y) or point ID in the box. 

3. Pick an ending point for the slice, or type a coordinate or point ID in the To box. 

Tip: After picking the From point, you can also move the cursor across the surface to 
view the cross-section slice dynamically, without picking a To point. The surface 
slicer view automatically scales to fill the view as you move the cursor.  
Note: Red tic marks denote where the slice crosses points or breaklines. At certain 
view magnifications, slope values appear above segments. To hide cross-section 
slope values, right-click the cross-section, and select Properties from the context 
menu. In the Properties pane, select Hide in the Label slope list. 
Note: You can also right-click in the view to access COGO controls and snaps 
when picking points. 

4. To add additional surfaces to the view, click Surfaces. The Select Surfaces dialog 
displays. 

5. Check boxes for the surfaces to include in the surface slicer view, and click OK. 

Related topics 

 Create and View a Cross-Section (see "Create and View a Surface Cross-Section" on 
page 326) 

 

Edit a Surface by Adding and Removing Members 

Members are not part of a surface; they are simply used to define the surface. Edit a 
surface by adding to, and removing from, the set of members. As a result, the surface 
updates to reflect the changes. 

You may want to prepare your data by organizing members by layer before using this 
command. 

Warning: If you add objects on or beyond the outer edge of a surface, the surface is 
recalculated and all prior edge trimming is lost. Similarly, if you remove objects from a 
surface edge, all prior trimming is lost. 
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To add and remove surface members:  

1. Do one of the following: 

 Select Surface > Add/Remove Surface Members. 

 Click the  icon on the toolbar. 

 Select a surface in the Project Explorer, right-click, and select Add/Remove 
Surface Members. 

The Add/Remove Surface Members command pane displays. 

2. Select a surface to edit in the Surface list, unless you have already selected one. 

3. In a graphic view, pick objects to add to the set of surface members, or click 
Options and choose a selection method in the context menu. You can also select 
objects in the Project Explorer. 

Tip: Sometimes it is difficult to pick surface members without picking the surface 
itself. Here are some ways to make it easier: 
Use the View Filter to control the visibility and selectability of surfaces and their 
members. To view surfaces more clearly, use a 3D view, and set your view filter to 
Surfaces. If more than one object is in the pick aperture when you pick, a list of the 
possible selections appears. Refine your pick by selecting from the list. Use 
windowing and crossing (see "Graphic Selection Methods" on page 43) selection 
methods to pick only what you need. 

4. Click Add to update the surface based on the selected objects. The surface changes 
in the 3D view. 

5. In a graphics view, pick surface members to remove, or click Options and choose a 
selection method in the context menu.  

6. Click Remove to update the surface based on the selected objects. 

7. Click Close. 

Related topics 

 Edit a Surface by Creating a Breakline (on page 334) 
 Edit a Surface by Changing a Point Coordinate (on page 329) 
 Edit a Surface by Changing Its Properties (on page 338) 
 Edit a Surface by Trimming Edge Triangles (on page 336) 
 Prepare Layered Data for a Surface 

 

Edit a Surface by Changing a Point Coordinate 

Make your surface more accurate by editing inaccurate coordinate heights in the 
Properties pane. 
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To edit surface member properties: 

1. Do one of the following: 

 Pick the point(s) in a graphic view, or select it in the Project Explorer. 

2. Click the  icon next to the point in the Project Explorer to expand it, and select the 
coordinate. 

3. Double-click the coordinate, or right-click it and select Properties from the context 
menu. The Properties pane displays. 

4. Edit any of the values in the Coordinates group as needed. 

5. Click Close. The surface updates accordingly. 

Related topics 

 Edit a Surface by Adding and Removing Members (on page 328) 
 Point Coordinate Options (on page 275) 

 

Point Coordinate Options 

Use these options to edit point coordinates when the point is a member of a surface. 
The surface that references the edited member updates accordingly. These options are 
found in the Properties pane for a point coordinate. 

Member type Propert ies that affect surfaces 

Coordinate Northing - Edit this to move a surface vertex north or south. 

Easting - Edit this to move a surface vertex east or west. 

Elevation - Edit to move a surface vertex up or down, relative to 
sea-level. 

Latitude - Edit this to move a surface vertex north or south. 

Longitude - Edit this to move a surface vertex east or west. 

Height - Edit this to move a surface vertex up or down. 
Session Height (point) - Edit this to move a surface vertex up or down. 

Related topics 

 Edit a Surface by Changing a Point Coordinate (on page 329) 
 Edit a Surface by Adding and Removing Members (on page 328) 

 

Understanding Breaklines 

Breaklines are lines that help to define the shape of surfaces by controlling how 
triangles in the surface mesh are formed; triangles forming a surface never cross a 
breakline. Use breaklines to make surfaces more accurate. For example, if a square area 
on your surface is formed by two triangles using the wrong opposing points, you can 
switch the direction of the diagonal to reform the two triangles. This might be done to 
get drainage to work as the site designer intended, or simply to ‘smooth’ the surface. 
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The simplest way to create a breakline is to add it between points where surface 
triangles converge (vertices). You can also create breaklines by picking locations on the 
surface that are not vertices. The surface triangles are redrawn, creating vertices at the 
points you picked. 

You might add a breakline to a surface to represent: 

 A stream bed 

 A curb line 

A linear feature that was not recorded in the field Here is an example of how adding a 
breakline (in yellow) can change a surface: 

  
In addition to the breaklines that you actively create, other breaklines are 
automatically created in surfaces when you import or select linear objects to create a 
surface. Any linear object, such as a polyline or an alignment, that you use in the 
creation of a surface will be represented as a breakline in the surface. If you modify the 
linear object, the breakline will update in response. 

Note: When you use an alignment in the creation of a surface, you can constrain 
the resulting breaklines horizontal and vertical distance from the alignment by 
setting tolerances in the Project Settings. Select Project > Project Settings. Then 
click Computational Settings and Surface in the left pane. 

Related topics 

 Edit a Surface by Creating a Breakline (on page 334) 
 

 

Create and Edit a Simple Breakline 

Simple breaklines are simplified linestrings that help to define the shape of a surface as 
do other 3D line types that act as breaklines, by controlling how triangles in the surface 
mesh are formed. Triangles forming a surface never cross a breakline. Use breaklines of 
any type to more accurately reflect where surface topography changes. 



Trimble® Business Center 
Heavy Construction Edition User Guide 332 

 Work with Surface Data

Create a simple breakline is to add linestring segments between points where surface 
triangles converge (vertices), but you can also add simple breakline segments freely 
between any two locations on or near the surface. The addition, deletion or any edit to 
a 3D line serving as a surface breakline will cause the entire surface to be reformed. 
Unlike more complex linestrings, simple breaklines do not use vertical control points; 
you can enter elevations for each new vertex or derive elevations from existing 
vertices. 

To create a simple breakline: 

1. Do one of the following: 

 Select Surface > Create Breakline. 

 Click the  icon on the toolbar. 

The Create Breakline command pane displays. 

2. In the Name box, type an identifier for the linestring as you want it to appear in the 
Selection Explorer and in graphic views when you select from multiple objects. You 
can also use the name to select the linestring in the Advanced Select command. 

3. Select a layer on which to create the linestring in the Layer list, or select <<New 
layer>> to create a new layer for the linestring. 

4. Select an option for how smoothly the surface is rendered at this particular 
linestring in the Surface sharpness list. 

5. Select the surface to which the linestring will be assigned as a member in the Add to 
surface list. 

6. Click OK. The Edit Linestring command pane displays with reduced options 
appropriate for creating a simple breakline. 

7. In the Start Point group's Type list, select Coordinate to start the linestring at any 
location, or select Point ID to attach the linestring to a named point. 

8. Click in either the Coordinate box or Point ID box (depending on what you chose for 
the starting point type), and use one of these ways to specify each point along the 
linestring: 

 In a graphic view, pick a vertex on the surface, or pick a named point (which 
may be a member of the surface and therefore one of its vertices) 

 Pick any location on or near the surface in the graphic view, and then type an 
elevation in the Elevation box. Then, click Save or press [Enter]. 

 Type a coordinate, press [Tab], and type an elevation in the Elevation box. Click 
Save or press [Enter]. 

The first point of the simple breakline is saved and you are prompted to add the 
second point and specify how the segment between them is formed. 
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Note: To use the elevation from a point you pick anywhere on a surface, right-click 
and select From Surface Snap from the context menu. You are prompted to pick the 
point in the From Surface Snap command pane. Then, click Save or press [Enter]. 
Note: To avoid picking points off of the surface (with no elevation), uncheck the 
Free snap in the Snap Mode (see "Snaps Modes and Commands" on page 89) dialog 
when you create a simple breakline or linestring. If you are prompted for an 
elevation, you may have missed the vertex point you were trying to pick. 
Note: You can also draw a 'freehand' breakline without using any existing data. In 
fact, you do not even need to have a surface to create a breakline. 

9. Keep adding segments to the linestring using one of the methods in step 8. 

10. Click Close. The simple breakline appears on the surface in graphic views, but does 
not appear in the Project Explorer. 

Note: Once created, linestrings can be graphically selected and added to other 
surfaces. 
Tip: To view changes to your surface more clearly as you work, open a 3D view and 
move it to a new tab group next to your plan view so you can see both views 
concurrently. 

To edit  a simple breakline:  

 Use the operations in Edit a Linestring's Horizontal Segments (on page 301). 

Related topics 

 Edit a Linestring's Horizontal Segments (on page 301) 
 Create a Linestring (on page 300) 
 Understanding Breaklines (on page 330) 

 

Breakline Options 

Use these options and those listed in Horizontal Linestring Options to create a breakline. 
They are available in the Create Breakline and Edit Linestring command panes. After 
creating a breakline, these properties and others can be edited in the Properties pane.  
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Options 

Name Type an identifier for the breakline.  

This name will appear in the Selection Explorer and in graphic views 
when you select from multiple objects. In addition, you can use the 
name to select the breakline using the Advanced Select command. 

Layer Select the layer on which you want the breakline to reside, or select 
<<New layer>> to create a new layer for the breakline. 

Segregating data onto logical layers makes it easier to filter your 
graphic views and select related data. 

Surface 
sharpness 

Select an option for how smoothly surface colors graduate at 
breaklines. 

Soft - Select this to have shading gradually change at the breakline, 
giving the visual appearance of a soft edge. 

Sharp - Select this to have shading abruptly change at the breakline, 
giving the visual appearance of a sharp edge. 

Add to surface Select the surface that you want the breakline to modify. 

Related topics 

 Create and Edit a Breakline (see "Create and Edit a Simple Breakline" on page 312) 
 Edit a Surface by Creating a Breakline (on page 334) 

 

Edit a Surface by Creating a Breakline 

3D lines of several types can be designated as members of a surface. They serve to 
influence the shape of that surface by acting in the classic manner as breaklines. These 
lines can exhibit complex curvilinear geometry and still serve a breaklines, by 
employing the breakline approximation parameters as defined in the computational 
settings for a surface in the Project Settings (see "Choose Project Settings" on page 147) 
dialog.  

One of the types of lines that can serve as a member of a surface, thereby acting as a 
breakline, is the linestring. Like alignments, linestrings can exhibit rather complex 
curvilinear geometries. But they can also exist as simple strings of straight line 
segments, connecting 3D coordinate locations, as in the case of the more classic 
breaklines associated with typical TIN models. A linestring of that nature is referred to 
here as a simple breakline; a specific command has been devised to allow you to create 
a linestring of that nature and assign it as a member of a surface at the same time, while 
defining its surface sharpness. In using the Create Simple Breakline command, you will 
in fact be creating a linestring object, though through a simpler user interface and one 
that supports the line's association with a surface as a part of its creation.  

The easiest way to create a simple breakline is to add segments between surface 
vertices (the points where surface triangles converge), but you can also add linestring 
segments freely between any two locations on or near the surface. Any geometric edit 
to a breakline of any kind will cause the entire surface to be reformed. 
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To create a simple breakline: 

1. Do one of the following: 

 Select Surface > Create Breakline. 

 Click the  icon on the toolbar. 

The Create Breakline command pane displays. 

2. In the Name box, type an identifier for the linestring as you want it to appear in the 
Selection Explorer and in graphic views when you select from multiple objects. You 
can also use the name to select the linestring in the Advanced Select command. 

3. Select a layer on which to create the linestring in the Layer list, or select <<New 
layer>> to create a new layer for the linestring. 

4. Select an option for how smoothly the surface is rendered at the linestring in the 
Surface sharpness list. 

5. Select the surface to which the linestring will be assigned as a member in the Add to 
surface list. 

6. Click OK. The Edit Linestring command pane displays with reduced options 
appropriate for creating a simple breakline 

7. In the Start Point group's Type list, select Coordinate to start the breakline using any 
location, or select Point ID to start the breakline using a named point. 

8. Click in either the Coordinate box or Point ID box (depending on what you chose for 
the starting point type), and use one of these ways to specify each point along the 
breakline: 

 In a graphic view, pick a vertex on the surface, or pick a named point (may also 
be a vertex) 

 Pick any location on or near the surface in the graphic view, and then type an 
elevation in the Elevation box. Then, click Save or press [Enter]. 

 Type a coordinate, press [Tab], and type an elevation in the Elevation box or 
right-click for COGO elevation options (see "Enter an Elevation" on page 125). 
Click Save or press [Enter].  

The first point of the linestring is saved and you are prompted to add the second 
point and specify how the segment between them is formed. 
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Note: To use the elevation from a point you pick anywhere on a surface, right-click 
and select From Surface Snap from the context menu. You are prompted to pick the 
point in the From Surface Snap command pane. Then, click Save or press [Enter]. 
Note: To avoid picking points off of the surface (with no elevation), uncheck the 
Free snap in the Snap Mode (see "Snaps Modes and Commands" on page 89) dialog 
when you create a breakline. If you are prompted for an elevation, you may have 
missed the vertex point you were trying to pick. 
Note: You can also draw a 'freehand' breakline without using any existing data 
using method below. In fact, you don't even need to have a surface to create a 
breakline. 

9. Keep adding segments to the breakline using one of the methods in step 8. 

10. Click Close. The breakline appears on the surface in graphic views, but does not 
appear in the Project Explorer. 

Note: Once created, breaklines can be graphically selected and added to other 
surfaces. 
Note: To see the properties of a breakline (in the Properties pane) you have actively 
created, select the breakline in a graphic view. 
Tip: To view changes to your surface more clearly as you work, open a 3D view and 
move it to a new tab group next to your plan view so you can see both views 
concurrently. 

To edit  a simple breakline:  

 Use the operations in Edit a Linestring's Horizontal Components (see "Edit a 
Linestring's Horizontal Segments" on page 301). 

Related topics 

 Edit a Surface by Adding and Removing Members (on page 328) 
 Edit a Surface by Changing Its Properties (on page 338) 
 Edit a Surface by Changing a Point Coordinate (on page 329) 
 Edit a Surface by Trimming Edge Triangles (on page 336) 

 

Edit a Surface by Trimming Edge Triangles 

Clean-up the edges of surfaces in your project so that you can accurately calculate 
volumes when comparing surfaces. 
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Note: Before trimming the triangles at a surface's edge, adjust the Maximum edge length 
and the Maximum edge angle of the surface in the Properties pane. Setting these can 
reduce the amount of trimming needed on the surface edge. In general, trim the edge 
triangles of a surface after you have made all other surface edits. 
Warning: If the program is forced to recompute the edge of a surface, then all edge 
trimming edits will be lost. 
Things that would cause this are: 
 - Changing the Maximum edge length of the surface in the Properties pane. 
 - Changing the Maximum edge angle of the surface in the Properties pane. 
 - Adding a new surface member outside of the edge of the surface. 
 - Removing surface members that lie on the edge of the surface. 

To trim a tr iangle:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Surface > Trim Surface Edge. 

 Right-click the surface in a graphic view, or the Project Explorer and select Trim 
Surface Edge from the context menu.  

The Trim Surface Edge command pane displays. 

2. Select a surface to trim in the Surface to Trim list. 

3. In a graphic view, pick a point to start the trim line or right click for options, or 
type a coordinate in the Outside location box. 

4. In the view, pick a point to end the trim line or right click for options, or type a 
coordinate in the Inside location box. 

5. Click Apply to keep trimming, or Close. Any triangle edges occurring outside of the 
outermost breakline are trimmed, removing the related triangle from the surface. 

Tip: Trimming stops when a breakline on the surface is encountered. To trim 
deeper into the surface, remove the breakline using the Edit Surface command. 
Conversely, you can add breaklines to a surface to prevent trimming an edge 
beyond a certain point. 
Note: Trimming maintains a valid surface based on the members used to form the 
surface. Because any point on the surface will always be connected to a triangle, 
the order in which you trim edge triangles can result in different formations. If you 
find that you cannot trim a certain triangle, you may need to remove the member 
on which it is based. 
Warning: If you add objects on or beyond the outer edge of a surface, the surface is 
recalculated and all prior edge trimming is lost. Similarly, if you remove objects 
from a surface edge, all prior trimming is lost. 
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Related topics 

 Edit a Surface by Adding and Removing Members (on page 328) 
 Edit a Surface by Creating a Breakline (on page 334) 
 Edit a Surface by Changing Its Properties (on page 338) 
 Edit a Surface by Changing a Point Coordinate (on page 329) 
 Surface Properties (on page 338) 

 

Edit a Surface by Changing Its Properties 

Edit a surface object by controlling its triangle distance and angle values, as well as 
display properties in the Properties pane. 

To edit surface properties: 

1. Do one of the following: 

 Pick the surface in a graphics view, right-click, and select Properties from the 
context menu. 

 Double-click the surface in the Project Explorer, or right-click it and select 
Properties from the context menu.  

The Properties pane displays. 

2. Click in an available property box, and make changes as necessary. 

3. Click Close. 

Related topics 

 Edit a Surface by Adding and Removing Members (on page 328) 
 Edit a Surface by Creating a Breakline (on page 334) 
 Edit a Surface by Changing Its Properties (on page 338) 
 Edit a Surface by Changing a Point Coordinate (on page 329) 
 Edit a Surface by Trimming Edge Triangles (on page 336) 
 Surface Properties (on page 338) 

 

Surface Properties 

Use these options to change a surface's edge prior to trimming. They are available in 
the Properties pane when a surface is selected. In addition, you can set display 
properties for how a surface appears in graphic views. 
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Options 

Max Edge Distance Type a value for the maximum length that one side of a triangle can 
be if it lies on the edge of the surface. 

Basically, this value defines how the longest distance that points 
can be connected on a surface edge. 

Max Internal Angle Type a value for the maximum angle that a surface triangle can use.

Practically, this value limits the amount of long, but very narrow 
triangles that can form on the edge of a surface.  

Related topics 

 Edit a Surface by Changing Its Properties (on page 338) 
 Edit a Surface by Trimming Edge Triangles (on page 336) 

 

Run a Surface Report 

Run a surface report to see surface measurements and limits, as well as the number of 
triangles, vertices, and other items in a surface in your project. 

To generate a surface report:  

1. Do one of the following: 

 Select Reports > Surface Information Report. 

 Click the  icon. 

 The Surface Information Report command pane displays. 

2. Select the surface you want to generate a report for in the Surface list.  

3. Click OK. The report displays in your default Web browser. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Create a Surface Boundary and Contours 

 



Trimble® Business Center 
Heavy Construction Edition User Guide 340 

 Work with Surface Data

A boundary is a line that delineates a portion of a surface. Boundaries can be polygonal 
or defined by specifying an offset from an alignment. 

Contours are lines that show the topography of a surface at a constant elevation. 
Contour objects are separate from the surface objects to which they are attached, but 
they are nested under surfaces in the Project Explorer. You can associate multiple 
contour objects with a single surface object. When a surface is changed, the contours 
on the surface update to reflect any changes in elevation. 

Related topics 

 Create a Surface Boundary (see "Create a Boundary" on page 340) 
 Create a Surface Contour at an Elevation (on page 344) 
 Create Surface Contours at Intervals (on page 343) 

 

Create a Boundary 

Create a boundary to delineate a portion of a surface. This is useful if you do not want 
to send an entire surface to field software; it enables you to include a smaller surface 
model with your design data. 

Note: Boundaries cannot be used to create or modify a surface. 

To create a boundary by drawing a polygon: 

1. Do one of the following: 

 Select Line > Create Boundary. 

 Click the  icon on the toolbar. 

The Create Boundary command pane displays. 

2. Type an identifier for the boundary in the Name box. 

3. Select the layer on which you want to boundary to reside in the Layer box. 

Note: If the layer does not exist in your project yet, you can create it by selecting 
<New> in the box. 

4. Select Polygon in the Creation Method group to define the boundary by drawing a 
polyline around an area. 

5. Click in the Point box and pick a starting point for the polygonal boundary in the 
plan view, or type a coordinate or point ID in the box and click Apply. 

6. Pick another point, or type a coordinate or point ID in the Additional Point box to 
draw the first line of the boundary. A "rubber-band" line appears, showing you 
how the boundary will be closed when you click Close. 

7. Continue specifying points until you have completed the boundary. 

8. To begin another boundary, click in the Name box, and repeat steps 2 - 7. 
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9. Click Close. The boundary appears in the view and the Project Explorer. 

To create a boundary offset from an alignment:  

1. Follow steps 1 - 3 above. 

2. Select Alignment corridor in the Creation Method group to define the boundary by 
specifying an offset around a selected alignment. 

3. Select an alignment to create a corridor around in the Alignment box. 

4. Click in the Left offset box and pick a point in the view, or type a distance in the 
box to specify the left boundary of the corridor parallel to the alignment. 

Note: Since the alignment itself denotes a zero offset, typically the left offset value 
will be a negative number, unless you want to create a corridor on only one side of 
the alignment, such as for a sidewalk. 

5. Pick a point in the view, or type a distance in the Right offset box to specify the 
right boundary of the corridor parallel to the alignment. 

6. To create the boundary only between specific stations along the alignment, check 
the Limit by station box. 

7. Click in the Begin station box and pick a point along the alignment, or type a value 
in the box. 

8. Pick a point along the alignment, or type a value in the End station box. 

9. Click OK. The boundary appears in the view and the Project Explorer. 

Related topics 

 Boundary Options (on page 341) 
 Add and Edit a Design Model (on page 398) 

 

Boundary Options 

Use these options to specify a subset of a surface by creating a boundary. They are 
available in the Create Boundary command pane. 
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Options 

Name Type a unique name for the boundary. 

Layer Select the layer on which you want to boundary to reside. 

You can also select <New> to create a new layer for the 
boundary. 

Creation method Polygon - Select this to define the boundary by drawing a 
polyline around an area. 

Alignment corridor - Select this to define the boundary by 
specifying an offset from a selected alignment. 

Polygon options 

Point Pick a point in the view, or type a coordinate or point ID in the 
box to draw the first line of the boundary. 

Additional point Pick a point in the view, or type a coordinate or point ID in the 
box to draw additional lines along the boundary. 

Open polygons will be closed when you click in the Name box 
to begin a new boundary, or when you close the command. 

Alignment corridor options 

Alignment Select the alignment around which to create the boundary 
corridor. 

Left offset /  
Right offset 

Pick points in the view, or type distances in the boxes to specify 
the left and right boundaries of the corridor parallel to the 
alignment. 

Note: Since the alignment itself denotes a zero offset, typically 
the left offset value will be a negative number, unless you want 
to create a corridor on only one side of the alignment, such as 
for a sidewalk. 

Limit by station Check this box to create the boundary only between specific 
stations along the alignment. 
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Begin station /  
End station 

Pick points along the alignment, or type values in the boxes to 
specify the first and last stations in the corridor. 

Related topics 

 Create a Boundary (on page 340) 
 

Create Surface Contours at Intervals 

Add contour lines to a surface at regular elevation intervals to help visualize the 
topography. 

 

To create contours at intervals:  

1. Pick the surface you want to add contours to in the graphics view, or select it in the 
Project Explorer. 

2. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Surface > Create Contours. 

 Select a surface in the project explorer, right-click, and select Create Contours 
from the context menu.  

The Create Contours command pane displays. 

3. Confirm the surface to which you want to add contours in the Surface box. 

4. Type a name for the contour object in the Name box. 

5. Type a value for the vertical distance between contours in the Contour interval box. 
The Estimated contours value updates in the Surface Information group below. 
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6. Type a value for the spacing of index contours in the Index frequency box. Index 
contours are the major contours, while the other contours are the minor contours. 

7. Select a layer on which to place the contour object in the Layer box. 

8. Select a display color for the contours in the Contour color box. 

9. Select a display color for the index contours in the Index color box. 

10. Click OK. The contours appear on the surface in graphic views, and under the 
surface in the Project Explorer. 

To edit  contours:  

1. Do one of the following: 

 Double-click the contour object in the Project Explorer, or right-click it and 
select Properties from the context menu. 

 Pick a contour line in a graphic view, right-click, and select Properties from the 
context menu. 

The Properties pane displays. 

2. Edit any available properties as needed. 

3. Click Close. 

Related topics 

 Create a Surface Contour at an Elevation (on page 344) 
 Surface Contour Options (see "Contour Options" on page 347) 

 

Create a Surface Contour at an Elevation 

Add a single contour to mark a specific elevation and help visualize its topography. For 
example, you might want to create a contour line to indicate a flood plain or a cut/fill 
line. 

 



Trimble® Business Center 
Heavy Construction Edition User Guide 345 

 Work with Surface Data

To create a contour at an elevation: 

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Surface > Create Contour at Elevation. 

 Pick a surface in a graphic view, or select it in the Project Explorer, right-click 
and select Create Contour at Elevation from the context menu. 

The Create Contours at Elevation command pane displays. 

2. If necessary, select the surface to which you want to add a contour in the Surface 
box. 

3. Type a name for the contour in the Name box. 

4. In the view, pick a point, or right-click for options, or type an elevation in the 
Elevation box. The elevation should be between the Minimum elevation and 
Maximum elevation displayed in the Surface Information group. 

5. Select a layer on which to place the contour in the Layer box. 

6. Select a display color for the contour in the Contour color box. 

7. Click OK. The contour appears on the surface in the graphics view, and under the 
surface in the Project Explorer. 

Related topics 

 Create Surface Contours at Intervals (on page 343) 
 Surface Contour Options (see "Contour Options" on page 347) 
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Create a Surface Cut/Fil l  Grid 

Create a grid of values labeling the elevation differences between two surfaces. The 
measurements are color-coded to indicate where earth needs to be cut or filled. You 
can also create a grid of values labeling the absolute elevations of a single surface. The 
resulting grid is a single object that will dynamically update in response to edits to the 
related surfaces. The order in which you specify the surfaces, or their classifications (as 
defined when they are created, and available in the surface properties) will determine 
the Initial and Final surfaces. 

 

To create a cut/fi l l  grid:  

1. Do one of the following: 

 Select Surface > Create Surface Cut/Fill Grid. 

 Click the  icon on the toolbar. 

The Create Surface Cut/Fill Grid command pane displays. 

2. To compare two surfaces, select Cut/Fill. To show the elevations of a single surface, 
select Elevation and a surface, and skip to step 5. 

3. Select a surface in the Initial surface list. You can select a surface with any 
classification, but the initial surface should reflect the state of topography before 
the surface you select as the final surface. 

4. Select a surface in the Final surface box. Again, you can select a surface with any 
classification, but the final surface should reflect the state of topography after the 
surface you selected as the initial surface. 

5. Select the layer on which you want the grid to reside in the Layer box, or select 
<<New layer>> to create a new layer for the grid. 

6. Select a style that controls the text font, font style, justification, and size for the 
grid annotations in the Text style box, or select <<New style>> to define a new text 
style. 

7. In the Grid spacing box, type a value for the uniform interval at which the grid lines 
or tick marks for the measurements will be spaced. 
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8. Select an option for how the location of each measurement will be denoted in the 
Grid style box. 

9. Select the number of decimals to use in the measurement in the Decimal precision 
list. 

10. Click OK. The cut/fill grid is created and appears in graphic views and the Project 
Explorer. Additional properties, such as the grid's origin point and rotation, and cut, 
fill, and zero colors, can be set in the Properties pane. 

Related topics 

 Surface Cut/Fill Grid Options (on page 348) 
 Create Surface Contours at Intervals (on page 343) 

 

Contour Options 

Use these options to define contour lines and their spacing. They are available in the 
Create Contours and Create Contour at Elevation command panes. 
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Options 

Surface Select the surface to which you want to add the contours. 

Name Type an identifier for the contour object. Duplicate names 
are allowed. 

Elevation Type a value, or pick a point in a graphic view, to specify 
the elevation. 

Contour interval Type a value, or pick two points in a graphic view, for the 
distance between each contour line. Distance is measured 
vertically in project units. This setting affects the 
Estimated contours in the read-only Surface Information 
group. 

Index contour frequency Type a value for the frequency of major to minor contour 
lines. Entering 5 means that every fifth line will be an 
index contour line. 

Layer Select the layer on which the contour object will be placed, 
or select <New layer> to open the New Layer dialog, in 
which you can create another layer. 

Contour color Select a color for the minor contour lines, or select to have 
contours derive their colors by layer. 

Index contour color Select a color for the major contour lines, or select to have 
contours derive their colors by layer. 

Maximum elevation This displays the elevation at the highest point on the 
selected surface. 

Minimum elevation This displays the elevation at the lowest point on the 
selected surface. 

Estimated number of 
contours 

This displays the number of contour lines that will appear 
on the surface. 

Related topics 

 Create a Surface Contour at an Elevation (on page 344) 
 Create Surface Contours at Intervals (on page 343) 

 

Surface Cut/Fil l  Grid Options 

Use these options to create cut/fill grids and elevation grids for surfaces. They are 
available in the Create Cut/Fill Grid command pane. These properties and others can be 
edited in the Properties pane. 
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Options 

Grid type Cut/Fill - Select this to create a grid of values labeling the elevation 
differences between two surfaces for cut/fill operations. 

Elevation - Select this to create a grid of values labeling the absolute 
elevations of a single surface. 

Initial surface Select the surface that reflects the state of topography before the 
surface you select as the final surface below. 

Final surface Select the surface that reflects the state of topography after the 
surface you select as the initial surface above. 

Surface For an elevation grid, select the surface for which you want to see 
absolute elevations. 

Layer Select the layer on which you want the grid to reside. 

Text style Select a style that controls the text font, font style, justification, and 
size for the grid annotations. 

Grid spacing Type a value for the uniform interval at which the grid lines or tick 
marks for the measurements will be spaced. 

Grid style Select an option for how the location of each measurement will be 
denoted. 

Decimal precision Select the number of decimals to use in the measurement. 

Related topics 

 Create a Surface Cut/Fill Grid (on page 346) 
 

Add Surface Materials 

Understanding Earthwork Volume Calculations 

In the Earthwork Report, surface to surface (and surface to elevation) volumes are 
calculated by computing the isopach between the surfaces (or between the elevation 
and surface) using the prismoidal method. First, each point is projected onto the other 
surface. Then, the corresponding elevation is interpolated, and the elevation difference 
is stored with the generated isopach point. The breaklines of both surfaces are used to 
generate isopach breaklines in a similar manner. Additional points are inserted into the 
isopach breaklines where they cross the surface triangles.  

A Triangulated Irregular Network (TIN) is generated to represent the surface created 
by the isopach points and breaklines. The isopach represents the thickness, or 
difference in elevation, between the two surfaces. The software generates the surface 
triangles for the isopach by linking the isopach points, while honoring all breaklines 
and points common to both surfaces. 
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The triangulated isopach is used to determine the volumes by breaking the data for 
each triangle into the appropriate number of truncated vertical prisms. If the three 
points of a triangle all have positive or all have negative elevations (all fill or all cut) 
then a single triangular prism is present, as shown in case 1.   

Case 1: All Excavation 

  
If the isopach triangle has both positive and negative elevations (cut and fill), then the 
triangle is broken into additional triangular prisms such that each prism represents 
only cut or fill, as shown in case 2. 

Case 2: Partial Excavation and Partial Fill  

 
The volume of each prism is equal to the average height (i.e. isopach elevation) times 
the planimetric area. The total fill volume for the isopach is the sum of all positive 
prismoidal volumes. The total cut volume is the sum of all negative prismoidal 
volumes. 

This method is considered more accurate than cross-section average end area or grid 
methods. The differences obtained between methods depend on the size of the grid or 
interval of cross-sections and the irregularity of the surfaces. Smooth surfaces may 
show differences of less than 1%. Some test cases have shown differences of as much as 
10% when the cross-section interval is 15 meters (49.21 feet) and the terrain is rough. 
Mathematically, as the size of the grid or cross-section interval decreases to a very 
small value, the volumes of these methods agree with volumes computed from the 
isopach triangles. 
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Note: The accuracy of volume calculations is dependent on the accuracy of the data 
that is used and the surface that is created. If breaklines are not properly used to form a 
valid surface, good point data can produce bad volumes. If an insufficient number of 
points are used to describe a surface, then irregularities from the recorded data to the 
actual ground will produce volumes differing from field conditions. 
Note: Duplicate points are re-layered to layer '0' during the linking process. Duplicate 
points are often created when computing the isopach surface, especially if a boundary 
line is used. In order to conserve memory, these points should be erased as required. 

Related topics 

 Define Materials for Earthwork Reports (on page 351) 
 Run an Earthwork Report (on page 353) 

 

Define Materials for Earthwork Reports 

Define materials that you want to use in earthworks volume calculations and reports. 
You can enter two of three values for the shrinkage, haul bulkage, or haul compaction 
of materials to calculate the third value. 

To create a material :  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Surface > Define Materials. 

The Materials dialog displays. 

2. Click the option for the value that you want to calculate in the Calculate group. The 
value you select is unavailable in the calculation table. 

3. Click the option for the format in which you want to view calculations in the 
Display as group. 

4. Type the name of a material you want to add in the Material column. 

5. Type percentages or factors in the Shrinkage, Haul Bulkage, and/or Haul Compaction 
boxes, as required. 

6. Press [Tab] to add another material, if needed. 

7. Click OK. 

Related topics 

 Calculate Volumes Using the Earthwork Report (see "Run an Earthwork Report" 
on page 353) 

 Materials Options (on page 352) 
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Materials Options 

Use these options to define materials to use in earthworks volume calculations and 
reports. They are available in the Define Materials dialog. For an example, see below the 
table. 

Options 

Calculate Shrinkage - Select to calculate the shrink or swell from cut or the 
natural bed to fill. 

 = (haul bulkage x haul compaction) 

Haul Bulkage - Select this to calculate the swell from the natural 
bed to the loose condition. 

 = (shrinkage / haul compaction) 

Haul compaction - Select this to calculate the shrink to 
compacted in place condition from the loose condition. 

 = (shrinkage / haul bulkage) 
Display as Factor - Select this to view the calculation as the number by 

which the volume is multiplied or divided. 

Percentage - Select this to view the calculation as a percentage 
(proportion multiplied by 100). 

Note: To understand the relationship between factor and 
percentage in relation to shrinkage and haul bulkage, experiment 
by entering various numbers. For example: 

 Shrinkage or haul compaction of 25% = a multiplication 
factor of 0.75 

whereas 

 Haul bulkage of 25% = multiplication factor of 1.25 

Material  Type a descriptive name for the material to cut or fill. 

Shrinkage % Type the percent, or factor by which, the material will shrink 
when it is cut and then used as fill. 

Haul  
bulkage % 

Type the percent that, or factor by which, the material will swell 
when it is cut and hauled in loose condition. 

Haul  
compaction % 

Type the percent that, or factor by which, the material will 
shrink when it is cut and hauled in loose condition. 

When entering values for material shrinkage, bulkage, and compaction, consult a 
standard soils engineering reference. As an example, an industry manual might show 
these values: 
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Material  Swell   Shrink ( in negative %) 

Earth (loam)  
– dry 

35%  12% 

Earth (loam)  
– wet (mud) 

0%  20% 

According to the sample reference, if you dig wet earth out of the ground, and pile it, 
or load it on a truck, it won't expand (0%). It will remain the same volume as it was in 
the ground. If you dig dry, compacted dirt out of the ground, and pile it, or load it on a 
truck, its volume will expand about 35%. 

If you dig wet earth out of the ground, use it as fill on the site, and compact it, it should 
shrink by 20%. The water will be squeezed out as it's compacted. If you take dry earth 
and do the same, the difference between its volume will be about 12% less. 

Related topics 

 Calculate Volumes Using the Earthwork Report (see "Run an Earthwork Report" 
on page 353) 

 Define Materials for Earthwork Reports (on page 351) 
 

Run an Earthwork Report 

Use the Earthwork Report to calculate volumes based on a single surface, or the 
comparison of two surfaces. 

To generate a volume report:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Reports > Earthwork Report.  

The Earthwork Report command pane displays. 

2. Select the option for the type of surface report you want to generate in the Report 
type group. Options in the steps below will vary based on the report type you 
select. 

3. Select the surface you want to report on, or the first surface to compare, in the 
Surface list. The classification for the surface displays below the box. 

4. Select the second surface to compare in the Final list, if applicable. 

5. Pick a point in a graphic view, right-click for options, or type a value in the 
Elevation box, if applicable. 

6. Pick lines to define the perimeter in the Boundary box, or click Options for more 
selection methods. 
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7. To account for materials in the calculations, check Use in calculation in the Materials 
group. 

Note: Before using this option, you need to have defined surface materials in the 
Define Materials dialog. 

8. Select the material at the site in the Native list. 

9. Select the material that will be brought to the site in the Borrow list. 

10. Select a type in the Volume Breakdown group, specifying a value by picking in the 
graphics window or typing a value, if necessary. 

11. Click OK. The report displays in your default Internet browser. 

Related topics 

 Define Materials for Earthwork Reports (on page 351) 
 Earthwork Report Options (on page 354) 
 Understanding Earthwork Volume Calculations (on page 349) 

 

Earthwork Report Options 

Use these options to configure what your earthwork report shows. They are available 
on the Earthwork Report command pane. The  icon on the command pane's toolbar 
gives you quick access to the Define Materials dialog, where you can define materials to 
use in earthwork report calculations. 
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Options 

Report Type Stockpile/Depression - Select to generate a comparison of the 
volume formed by comparing one surface to a temporary surface 
formed by the edge points of the surface  

A Stockpile/Depression Report uses only one material in the 
report. 

Surface to Surface - Select to generate a comparison between 
two surfaces 

Surface to Elevation - Select to generate a comparison of the 
volume formed by comparing one surface to a flat plane defined 
by the user giving its elevation 

Note: You can set the name for the difference between surfaces in 
the Computational Settings > Surface section of the Project 
Settings dialog. 

Select surface 

Surface/initial Select the surface on which you want to report. If you are 
comparing a surface to another surface or elevation, select the 
surface from the earlier phase of construction. 

Final If you are comparing a surface to another surface, select the 
surface from the later phase of construction. 

Elevation Pick a point in a graphic view, or type a value for the elevation to 
be compared to the specified surface. 

Boundary Select the perimeter of the volume you want to use in 
computations. 

Materials 

Use in calculation Check this to open the Native and Borrow boxes, if you are using 
materials in calculations. 

Native Select the material being excavated from the site, and often being 
reused as fill material on the site. 

Borrow Select the material that is being brought in from off-site to be 
used as fill material on the site.  Borrow material can be the same 
as native material. 
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Volume breakdown Volume totals only - Select this to report only the total difference 
between volumes. 

By depth increment - Select this to report the volumes in 
increments. Pick two points in a graphic view, or type a value to 
specify the depth of the increment. 

By elevation interval - Select this  to report volume differences 
between specific elevations. Pick two points in a graphic view, or 
type a value to specify the distance between elevations. 

Index elevation - Pick a point in a graphic view, or type a value to 
specify the elevation. 

Related topics 

 Calculate Volumes Using the Earthwork Report (see "Run an Earthwork Report" 
on page 353) 

 Define Materials for Earthwork Reports (on page 351) 
 

Shrink 3D Faces 
If you use a mesh of 3D faces to create a surface, any vertices that exist at the same 
horizontal location, but which have different elevations, will create vertical 3D faces in 
the resulting surface. You will know that you need to 'shrink 3D faces' when you see 
flags at surface vertices and messages in the Flags pane stating that "The vertex has been 
ignored. It is directly above another vertex." 

To fix this, 'shrink the 3D faces' to form closed, triangular breaklines slightly inset (.06 
mm) from each selected face. These breaklines can then be used to create a surface that 
closely approximates the original mesh of 3D faces. 

This can be helpful in forming a valid surface from data incorporating vertical faces or 
when coincidental 3D face vertices that have differing elevations at the same location. 

Note: This command is primarily used to fix data from applications that allow points 
with different elevations at the same horizontal location. 
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Initially, the surface is formed 
using vertical 3D faces with 
coincidental vertices, resulting in 
two elevations at these vertices. 
This data is not valid for forming 
a surface. 

 

The non-vertical 3D faces are 
shrunk to create triangular 
breaklines (shown in black) with 
offset vertices which can be used 
to form the surface. 

 

Using the new breaklines, the 
surface is properly formed with a 
single elevation at each vertex. 
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To 'shrink 3D faces'  for a surface: 

Follow these steps immediately after you receive one or more flagged messages that a 
vertex is directly above another vertex in a surface. If you cannot undo the surface 
creation because you have performed other commands in the interim, you will need to 
delete the surface and start with step 2 below. 

1. Select Edit > Undo Create Surface. The surface disappears. 

2. If the command pane is not already displayed, select View > Command Pane, or 
press F12. The Command Pane displays. 

3. Click Shrink 3D Faces in the All Commands list, or type shrink3dfaces on the 
Command line at the top of the pane and press [Enter]. The Shrink 3D Faces 
command pane displays. 

4. In the Plan View, pick the 3D faces that you want to use to form a surface 

5. Select the layer on which you want the new breaklines to reside in the Layer for 
breaklines box. 

Note: You will select the data on this layer to use when you create the surface.  If 
necessary, create a new layer by selecting <<New layer>>. 

6. Click OK. The breaklines are created within each selected triangular, 3D face. 

To create a surface from the newly created breaklines:  

1. Select the View > View Filter Manager. The View Filter Manager displays. 

2. If necessary, click the  icon to collapse each group except Layers. 

3. Uncheck the box for each group to hide the data. 

4. In the Layers group, right-click the name of layer you created the 3D face 
breaklines on, and select View Only This from the context menu. All of the other 
layers in the group are unchecked so that only the breaklines are visible.  

5. Select all of the breaklines in the graphic view, and select Surface > Create Surface. 

6. Follow the instructions for creating a surface (see "Create a Surface" on page 323). 

Related topics 

 Edit a Surface by Trimming Edge Triangles (on page 336) 
 Edit a Surface by Adding and Removing Members (on page 328) 
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C H A P T E R  1 4  

Work with Feature Data 

Understanding Feature Data 
Features represent objects that surveyors might encounter as they collect survey data. 
Examples include trees, fences, gates, signs, utility poles, and buildings. After import 
and processing, the software can display symbols and line work that represent the real 
world objects. Features can be exported to other systems (for example, CAD packages) 
as necessary. 

There are two basic types of features: 

 A point feature is used to identify a single feature, such as tree or utility pole. 

 A line feature is made up of two or more points that define a line, such as a fence or 
path.  

A feature is identified in the software by a feature code string that is made up of one or 
more parts. 

A feature code string for a point feature is made up of one or two parts:  

 An alphanumeric code identifying the point feature itself (for example, "TREE") 

 Optionally, a brief description of the point feature (for example, "West of house") 

A feature code string for a line feature is made up of one to four parts: 
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 An alphanumeric code identifying the line feature itself (for example, "FENCE") 

 Optionally, an alphanumeric instance identifier that is used for each point that 
makes up a single line (for example, "FENCE1" might define one fence; "FENCE2" 
might define a different fence) 

 Optionally, an alphanumeric line control code that identifies the start or end of a 
line (for example, "START" might be used to identify the start of a fence) 

 Optionally, a brief description of the line feature (for example, "Barbwire") 

Note: If you delete a point used in a line feature, the position for the point is still used 
to define the line. 
 
Note: You can  split (see "Split Line Features" on page 365) line features in the software.  

To make the feature code strings easier to read in the Properties pane and Point 
Spreadsheet, automatic formatting is used to differentiate the parts: 

 The code itself is underlined (for example, "FENCE"). 

 The instance number and line control code are normal text. 

 The brief description is in italics (for example "Barbwire"). 

So, a complete line feature code string might look like this: "FENCE1 START Barbwire" 

Each feature code can also include one or more attributes that provide additional 
information about the feature. For example, a utility pole feature might have these 
attributes: utility type and owner, pole height, material, and condition. 

Feature code types and attributes are defined and managed in the Feature Definition 
Manager software, which outputs a feature definition (.fxl) file that can be loaded on a 
field device. In the field, the surveyor can select from the feature library contained in 
the .fxl file the appropriate feature code to assign, add a brief description, and enter 
values for any attributes defined for the code. This same .fxl file is then used by the 
software for feature processing (see Feature Code Processing Settings (on page 157)) 
after the feature codes have been imported.  

Note: If a surveyor manually enters a feature code not represented in an .fxl file, or the 
.fxl file used on the field device is not specified for the project, the feature code string 
will display in the software, but it will be ignored during feature code processing and 
reported in the Feature Code Processing Report. 

Feature codes are displayed in the Properties pane when points to which they are 
assigned are selected. You can edit or delete feature codes as necessary, or add 
additional codes. You can also merge multiple line features into a single line feature or 
split a single line feature into multiple line features. 

Related topics 

 Workflow for Feature Data (on page 361) 
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 Feature Code Processing Settings (on page 157) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 
 Process Feature Codes (on page 367) 

 

Workflow for Feature Data 
To work with features data, it is recommended that you use the following steps: 

1. Specify the appropriate feature definition (.fxl) file and other feature project 
settings in the Project Settings (see "Feature Code Processing Settings" on page 157) 
dialog. 

2. Import (see "Import Data" on page 193) the data file containing features data into 
your project. 

Note: The Edit Point > Description field used in Survey Pro and Field Surveyor 2.0 
(not Field Surveyor 1.x) contains the feature code imported into the software and 
displayed in the Feature code field. 

3. If feature codes were processed on data import, review the resulting Feature Code 
Processing Report to determine if all codes were processed correctly. 

Note: You use the Project Settings (see "Feature Code Processing Settings" on page 
157) dialog to specify whether or not to process feature codes on data import. 

4. Review the Plan View and Point Spreadsheet to ensure the survey was correctly 
performed and feature codes were correctly entered. 

Note: If feature codes are not displayed in the Plan View, select View > View Filter 
Manager and ensure the Show feature code option is selected in the View Filter 
Manager pane. 

5. If appropriate, click Surface > Create Surface to ensure features are correctly 
included in the surface computation. 

6. If necessary, make changes to any feature codes as described in Enter, Edit, and 
Delete Feature Code Strings (on page 363). 

7. If necessary, split (see "Split Line Features" on page 365) any line feature into two 
line features by selecting the segment between the two points you want to 
separate. 

8. If you made any changes to the feature codes in step 6, re-process the feature codes 
as described in Process Feature Codes (on page 367). 

9. Review the resulting Feature Code Processing Report to determine if all codes were 
processed correctly. 

Related topics 

 Understanding Feature Data (on page 359) 
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 Feature Code Processing Settings (on page 157) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 
 Rules for Merging Feature Attributes (on page 365) 
 Process Feature Codes (on page 367) 

 

Feature Code Processing Settings 
Use feature processing settings to configure how feature codes are processed. 

To specify feature processing settings: 

1. Do one of the following: 

 Select Project > Project Settings.  

 Click the  icon on the toolbar. 

The Project Settings dialog displays.  

2. Select Feature Code Processing in the left pane. 

3. Click each section and set the options as shown in the following table. 

4. Click OK. 

Options 

General 

Process feature codes 
on import 

Prompt - Select this option if you want to be prompted on 
whether or not to process feature codes during data import. If you 
select to process feature codes during import and a feature 
definition (.fxl) file has not been specified in the project settings, 
you will be prompted to specify it at the time of import.  

Yes - Select this option if you want feature codes to be 
automatically processed during data import without prompting 
you. If a feature definition (.fxl) file has not been specified in the 
project settings, you will be prompted to specify it at the time of 
import. 

No - Select this option if you never want feature codes to be 
processed during data import. 

Decimal precision Specify the number of decimals to display with a numeric attribute 
(real number) when no feature definition (.fxl) file is specified. 

Processing 

Feature definition file Specify the feature definition (.fxl) file you want to use to process 
feature codes in the project. This is required if you want to process 
feature codes. 

 

Related topics 

 Choose Project Settings (on page 147) 
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 Understanding Feature Data (on page 359) 
 Workflow for Feature Data (on page 361) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 
 Process Feature Codes (on page 367) 

 

Enter, Edit, and Delete Feature Code Strings 
If a feature code string has been assigned to a point, it is displayed in the Properties pane 
when the point is selected.  

Note: Feature codes are also visible and editable in the Point Spreadsheet and Occupation 
Spreadsheet. They can be viewed, but are not editable in the Plan View. 

You can edit or delete feature code strings as necessary. You can also assign additional 
code strings. 

To enter, edit ,  or  delete a feature code string: 

1. Display in the Properties pane the point with which you want to work. 

If a feature code string has been assigned to the point you selected, it is displayed in 
the Feature Code box. 

If you select multiple points, the value in the Feature Code box is *Varies*, 
indicating that different codes may be assigned to the selected points. Any changes 
you make to the code affect all of the selected points. 

Note: The Edit Point > Description field used in Survey Pro and Field Surveyor 2.0 
(not Field Surveyor 1.x) contains the feature code imported into the software and 
displayed in the Feature code field.  

2. Click the  icon in the Feature code box. The Feature Code Editor dialog displays. 

Note: If you know the feature code string you want to assign to the point, you can 
manually enter it directly in the Feature code box without opening the Feature Code 
Editor dialog. However, if you need to enter attribute values, you must enter them 
in the Feature Code Editor dialog. In addition, you can manually delete a feature 
code string from the Feature code box.  

3. To delete a feature code string assigned to the point, delete it from the Feature code 
box. 

4. To assign or edit a feature code string for a point when a feature definition (.fxl) file 
has not been specified for the project, type the new string, or edit the existing 
string, in the Feature code box. 

You can add additional feature code strings to the point as necessary.  

5. To assign or edit a feature code string for a point when a feature definition (.fxl) file 
has been specified for the project, do the following: 



Trimble® Business Center 
Heavy Construction Edition User Guide 364 

 Work with Feature Data

a. If necessary, delete any of the existing code string from the Feature code 
box 

b. Select a feature code (for example, "FENCE") from the Codes list and click 
Add Code. The feature code is displayed in the Feature code box. 

c. If the feature code represents a line feature, type the alphanumeric 
instance of the line feature immediately before or after the code (no spaces) 
in the Feature code box (for example, "FENCE1"). 

d. If a line feature requires a control code (for example, "START"), select it in 
the Codes list and click Add Code. The control code is displayed in the 
Feature code box. 

e. If appropriate, enter a brief description of the feature in the Feature code 
box at the end of the string (for example, "Barbwire"). 

When you change focus from the Feature code box, the feature code string is 
reformatted as follows: 

- The feature code is underlined. 

- The instance for a line feature, if entered, appears in regular text. 

- The control code for a line feature, if entered, appears in regular text. 

- The description, if entered, appears in italics. 

For example, if the feature code is for the line feature "FENCE", the instance is 
"1", the control code is "START", and the description is "barbwire", the string 
would appear as "FENCE1 START Barbwire". 

f. If the feature code supports attribute values, ensure the feature code is 
selected in the Details list, then select attribute values for the code in the 
Attribute list. 

If a feature code is changed from the raw data, any attributes associated with 
the original feature code are merged with the new feature code per specific 
rules. For more information, see Rules for Merging Feature Attributes (on page 
365). 

6. To add more feature codes to the point, repeats step 4 or 5 as necessary. 

Regardless of the order in which you add additional feature codes, the codes are 
automatically arranged in alphabetical order in the Feature code box (with the 
exception of line feature codes).  

7. Click OK. 

After you have completed all feature code changes, you must reprocess the feature 
codes (see "Process Feature Codes" on page 367). 

Related topics 

 Understanding Feature Data (on page 359) 
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 Workflow for Feature Data (on page 361) 
 Feature Code Processing Settings (on page 157) 
 Rules for Merging Feature Attributes (on page 365) 
 Process Feature Codes (on page 367) 

 

Rules for Merging Feature Attributes 
If a feature code is changed from the imported data, the attributes of the imported data 
feature code and the attributes that are the same for the imported and new feature code 
are copied to the new feature code. For example, if the feature code is changed from 
"FENCE" to "MH", the raw attributes of "FENCE" and the attributes that are the same 
for "FENCE" and "MH" are copied to "MH". 

In the case of multiple feature codes being assigned to a point, the order of the codes 
before and after editing determine where the attributes in the raw feature code are 
merged. For example: 

 If "FENCE TREE" is changed to "MH TREE", the imported attributes of "FENCE" 
and attributes that are the same for "FENCE" and "MH" are copied to "MH".  

 If "FENCE TREE" is changed to "MH", the attributes of "FENCE" merge to"MH".  

 If "FENCE POST TREE" changes to "MH VALVE", the attributes of 'FENCE" merge 
into "MH" and the attributes of "POST" merge to "VALVE".  

When attributes are merged to the new feature code and the definition does not 
recognize it, the attributes become unknown attributes. You can delete these unknown 
attributes in the Feature Code Editor (see "Enter, Edit, and Delete Feature Code Strings" 
on page 363) dialog.  

Related topics 

 Understanding Feature Data (on page 359) 
 Workflow for Feature Data (on page 361) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 

 

Split Line Features 
You can split a single line feature into two line features by selecting the segment 
between the two points you want to separate, as shown in the following diagram 
(example 1). Note that you cannot select a beginning or ending line segment for the 
split (example 2). 

Key to example diagrams:  

 Green points  represent the first line feature selected for the split. 

 Maroon points  represent the new line feature created after the split.  

 1 shows the line feature segment selected for the split. 
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Example 1: 

 
Example 2: 

 

Note: Before performing this procedure, ensure that features codes have been 
processed (see "Process Feature Codes" on page 367).  

To split  a l ine feature: 

1. Do one of the following: 

 Select Survey > Feature Coding > Split Line Feature.  

 Click the  icon on the toolbar. 

The Split Line Feature pane displays. 

2. Click in the Select box. 

3. In the Plan View, select the segment between the two line feature points you want 
to separate. The segment is removed. 

You cannot select a beginning or ending line segment for the split (see example 2). 

4. If necessary, select additional line features in the Plan View to split them.  

5. When you are done, click Close in the Split Line Feature pane. 

Related topics 

 Understanding Features Data (see "Understanding Feature Data" on page 359) 
 Workflow for Features Data (see "Workflow for Feature Data" on page 361) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 
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Process Feature Codes 
You must process features codes to display features correctly in graphic views or to 
export. You can process feature codes during data import (depending on your Feature 
Code Processing settings (on page 157)), or you can process or reprocess them after 
import. For example, you might have processed feature codes during data import but 
you have since made changes to the codes in the software and need to reprocess them. 
Or, you might have added points to the project that include features you want to 
process. 

To process feature codes: 

1. Do one of the following: 

 Select Survey > Feature Coding > Process Feature Codes.  

 Click the  icon on the toolbar. 

The Process Feature Codes pane displays listing one or more point sources from 
which you can select to process feature codes. A point source is either an imported 
file or a Keyed in Block (points manually added to the project). If you select multiple 
sources, they are processed separately.  

2. In the Select point source(s) to process list, check the box for each source containing 
points you want to process. 

3. Optionally, do either of the following: 

 Click the  icon to display the Report Options (on page 438) pane. This allows 
you to select report options for the Feature Code Processing Report before 
generating the report. 

 Click the  icon to display the Project Settings dialog to change Feature Code 
Processing settings (on page 157). 

Note: This button is enabled only when an imported file is selected as a point 
source in the list. 

4. Click Process to process feature codes in the selected source(s). 

If no feature definition (.fxl) file is specified in the project, you will be prompted to 
specify it at this time.  

If you have previously processed the features codes in the project, reprocessing will 
delete the previous results and replace them with new results.  

5. After processing, review the Feature Code Processing Report, which provides a 
summary of the process.  

The report displays on the Feature Code Processing Report tab. Use the tool bar 
located above the report to navigate, print, or save the report. 
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Related topics 

 Understanding Feature Data (on page 359) 
 Workflow for Feature Data (on page 361) 
 Feature Code Processing Settings (on page 157) 
 Enter, Edit, and Delete Feature Code Strings (on page 363) 

 

Export Geodatabase Files (.xml) 
Export feature data contained in your project to a geodatabase XML file from which 
the data can be imported into an Environmental Systems Research Institute, Inc. 
(ESRI) geographic information system (GIS). 

Click the GIS tab in the Export command pane to access the Geodatabase XML exporter.  

Note: The geodatabase XML format represents ESRI's most current open mechanism 
for information interchange between geodatabases and other external systems and is a 
replacement for the earlier shapefile (.shp) spatial data format.  

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 

Feature Definition Manager Utility 
The Feature Definition Manager is a standalone utility that gives you the ability to create 
and manage feature libraries (.fxl files) for feature code processing and GIS attribute 
data collection. A feature library is a collection of features with codes and attributes 
that describe them, as well as line control codes that modify how the features relate. 

The Feature Definition Manager comes with a default library of features with predefined 
attributes. This library provides a good starting point for feature coding. As you create 
new features and edit existing ones, the library will become suited to the specific needs 
of your projects.  

Feature coding in the editor enables you to: 

 Make detailed data collection in the field more efficient and consistent by 
controlling how features and attributes can be captured. Setting parameters for 
what you can and must enter ensures data integrity and completeness. 

 Add symbols and annotations to feature-coded field data so that the information 
can be presented in a more visual format. 

 Connect points to define line features, such as pavement or building edges, or the 
centerlines of ditches or fences. Line control codes give you the power to add new 
points automatically, and add lines, curves, and arcs between points. 

If you are working with surfaces, coded features also let you: 
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 Define the breaklines of a surface. 

 Control how surfaces are formed by specifying which points should be used, and 
which lines should act as breaklines. Surfaces can be modified by moving points to 
specific layers based on their feature codes.  

Note: The Feature Definition Manager has its own help system. While in the Feature 
Definition Manager, select Help > Contents, or press [F1]. 

Related topics 

 Understanding Feature Data (on page 359) 
 Workflow for Feature Data (on page 361) 
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Prepare Data for Site Positioning Systems 

HEAVY CONSTRUCTION  

C H A P T E R  

Prepare Data for Site Positioning Systems 

HEAVY CONSTRUCTION  

Trimble® Business Center - Heavy Construction Edition and Trimble Site Controller 
Software (SCS) are components within Trimble's site positioning systems (SPS). In 
Trimble Business Center, you can prepare site data, design data, and work orders for 
site controllers with SCS. Using these controllers, you can measure material volumes, 
monitor grades and laid material thickness, and perform other site-related tasks, such 
as point, line, roadway, and surface stakeout. For more information, see Understanding 
SPS and SCS (on page 372). 

Office Synchronizer software manages the exchange of site data, design data, work 
orders, and work order results between your computer and site controllers. This 
exchange process is known as 'synchronization'. Data, work orders, and results that 
need to be synchronized are stored in a file structure on your hard drive, the location 
of which is defined in the Synchronizer root folder box in the Options dialog. For more 
information, see Understanding Sites, Designs, Work Orders, and Synchronization (on 
page 373) 

Note: For simplicity, the synchronizer root folder's file structure is referred to as the 
'data synchronization area' throughout this documentation. . 
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The default path for the data synchronization area depends on your operating system: 

 In Windows® XP or earlier:   C:\Documents and Settings\(user name)\My 
Documents\Trimble Sync 

 In Windows VistaTM:   C:\Trimble Synchronizer Data 

You may, however, have placed your data synchronization area in a different location 
or named it differently. 

Note: The data synchronization area is meant for data exchange only. You should not 
directly modify its structure or contents, but manage all your construction project files 
in a separate location. 

Following is the general workflow for preparing data for SPS in this software. 

Workflow for preparing data for Trimble site positioning systems: 

1. Create or import (see "Import Data" on page 193) the relevant roadway, surface, 
CAD, point, and other construction data into your project. 

2. Create a site (see "Workflow for Creating a Site" on page 377) or add an external 
site (see "Workflow for Using an External Site" on page 378), and add the site data. 

3. Create one or more designs (see "Create a Design" on page 393), or add one or more 
external designs (see "Add an External Design" on page 394), and add design data 
related to the site. 

Note: The site and its related designs are created as objects within your project. 

4. Create one or more work orders (see "Create a Work Order" on page 409) to be 
loaded onto site controllers, instructing your field crews what tasks need to be 
performed on site. 

Note: Work orders are accessible from your project, but they are not truly objects 
within it. Work orders reside in the synchronization area and on the controllers to 
which they are assigned. 

5. Graphically view (see "View a Work Order's Data Graphically" on page 416) the 
data associated with each work order. 

6. Synchronize controllers running SCS, such as SCS900, sending your site data, 
design data, and work orders to the controller used by the designated construction 
crew, and retrieving data resulting from their prior operations. 

7. While crews are actively using the controllers to complete work orders in the field, 
prepare new data and instructions for them. When the crews next synchronize 
their controllers, the additional information or revisions that you have prepared 
are automatically updated on their controllers, and any new data from the field is 
automatically updated on your computer. 
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8. Import the completed work orders and results (see "Import Work Order Results" 
on page 422) back into your project. 

9. Check the data by running alignment (see "Run an Alignment Geometry Report" 
on page 298), surface (see "Run a Surface Report" on page 339), and work order (see 
"Run a Work Order Report or Summary" on page 423) reports. 

10. Compress and email (see "Compress and E-mail SCS Files" on page 421) site data, 
design data, and work orders to colleagues or site controllers. 

Related topics 

 Manage a Site and Site Data (on page 377) 
 Manage Designs and Design Data (on page 393) 
 Manage Work Orders and Results (on page 406) 

 

Understanding SPS and SCS 

HEAVY CONSTRUCTION  

Trimble® site positioning systems (SPS) are comprehensive construction positioning 
solutions comprised of: 

 positioning hardware (GPS base, rover, and radios or total station) 

 site controllers (typically hand held or tablet computers) 

 site controller software (SCS) 

In general, SPS provides non-surveyors the ability to perform construction 
measurement and stakeout tasks associated with site preparation, heavy/highway 
construction, mining, and landfill operations, etc.. The overall system, comprised of 
the above components, allows contractors to track, report, validate, and control site 
measurement and positioning workflows from receipt of initial designs to project 
completion. 

SPS also gives site foremen, supervisors, grade checkers, and site engineers the tools 
they need to help run machines on site, reducing downtime, and resolving issues as 
they arise, without office assistance. 

Using SPS, contractors employ GPS antennas, GPS receivers, total stations, and hand 
held site controllers developed specifically for heavy/highway construction 
applications for measurement and stakeout activities on the job site. 

SCS is software that runs on a site controller, which is typically a hand held device. 
Contractors can use software, such as SCS900, to complete a full range of construction 
tasks, including: 
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 Performing initial site measurement and verification of original ground levels  

 Measuring site features  

 Checking finished grade and laid material thickness  

 Collecting topographic site data and computing material stockpile volumes  

 Staking out points, lines, alignments, planes, surfaces, complex roadways, side 
slopes, and catch points 

 Performing as-built site measurements  

SCS helps contractors efficiently control and quantify site operations so they do not 
need to rely on a contract surveyor for their site measurement and stakeout 
requirements.  

Understanding Sites, Designs, Work Orders, and Synchronization 

HEAVY CONSTRUCTION  

Before preparing data for Trimble® site positioning systems (SPS) within this software, 
it will be helpful to familiarize yourself with the concepts below. For additional 
information, see Understanding SPS and SCS (on page 372). 

Project 

Work in Trimble Business Center is structured in projects, which are analogous to 
'construction projects' in the real world, i.e. the work performed in fulfilling a 
construction contract. The data associated with a project is stored within a project file 
(*.vce).  

Site 

A site is an object in your project that contains site settings and site-specific data, such 
as a site calibration, the related control points, and a background map. A project's site 
represents what is commonly referred to as the 'job site', i.e., the property or physical 
location at which the improvements associated with a construction project will be 
made. In creating a site, you designate which portions of the data in your project need 
to be made available to field crews in the background map, and therefore sent to the 
site controllers that you expect to be employed on that site. The background map can 
be used by crews in the field to identify specific areas where construction work is to be 
done at the job site, and other area to be avoided. 

Note: It is important to give each site a unique name. See the Project and site naming 
section in Edit a Site's Name and Settings (on page 383). 
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Each project can contain only one site. A site can reside in your project without being 
assigned to any controllers. If you choose to assign a site to one or more controllers, 
you must designate the path to the data synchronization area in advance. When you 
assign a site to one or more controllers, its settings and data are automatically copied to 
appropriate locations within the folder structure of the data synchronization area (the 
folder structure located beneath the synchronizer root folder), in the forms in which 
they will be used on the designated controllers in the field. 

Each instance of the site, as it resides on every controller's representation within the 
data synchronization area, is associated with the project file within which it is defined. 

External Site 

External sites are those that exist in the data synchronization area, but not in your 
current project. You can add an external site to your project to make its site data and 
related designs and design data available within the project. Then you can edit the 
site's settings or data. 

When you add an external site to your project, its related designs are created as objects 
within the project and appear in the Project Explorer. If you add an external site that 
resides on multiple controllers to your project, all of the designs for the site on the 
various controllers appear in the Project Explorer. 

Design 

A design is an object in your project that contains design data, such as a surface model, 
stakeout points, and a foreground map representing features of the design. In creating a 
design, you designate which portions of the data in your project need to be available to 
field crews in regard to the subject matter of that design, and therefore sent to 
designated site controllers. Design data is used by crews in the field to stakeout or 
check designed features, alignments, and surfaces. 

After creating a site or adding an external site, one or more designs can be created in or 
added to the site. These designs reside in the association with single site that resides in 
the project. Designs can be assigned to any of the controllers to which the site has been 
previously assigned.  

External Design 

External designs are those that exist in the data synchronization area, but not your 
current project. You can add external designs to make their design data part of your 
project. Then you can edit the design data. 
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Work order 

A work order contains instructions for a field crew about the tasks they need to 
perform at a site, as well as tolerances and other site controller settings associated with 
those tasks. A work order that requires design data in order to be carried out, will 
contain a reference to the applicable design. Work orders are used to direct and track 
the progress of construction improvements at the job site. 

Multiple work orders can be created in association with a site. Even though they 
appear in the Project Explorer, work orders, unlike a site and designs, are not actually 
objects within your project. They simply reside in the data synchronization area and 
on the site controller to which they are assigned. A work order can be created without 
being assigned to a particular construction crew's site controller. It can later be 
assigned to one and only one site controller. Each of those work orders appears in the 
Project Explorer beneath the site listing. 

Site Controller 

A site controller is a field device, also known simply as a 'controller', that runs site 
controller software (SCS) within a Trimble site positioning system (SPS). Site 
controllers used by construction crews are typically hand held computers. The site 
controller software can also be operated on a tablet or notebook computer in the field. 
Those devices may commonly be used by construction supervisors, foremen, etc., who 
may operate them from within a truck cab, as they drive the site. Site data, design data, 
and work orders are transferred back and forth between office computers and site 
controllers. After using a controller to collect data in the field, the measurements are 
transferred from the controller to an office computer. 

Data Synchronization Area/Synchronizer Root Folder 

Synchronization is the process of making files on a site controller match the files in the 
data synchronization area (the folder structure located beneath the synchronizer root 
folder) used by Trimble Business Center - Heavy Construction Edition, and SCS Data 
Manager. To be in a state of synchronization, a file with the same 
creation/modification date must appear on both the controller and in the 
synchronization area. Files are synchronized so that office staff using this software and 
field crews using the SCS are always using the same (or most current) data. 

The data synchronization area is a folder structure (installed by the Office 
Synchronizer program on the office computer's hard drive) that contains site settings 
and data, design data, and work orders in a file structure that the Trimble Site 
Controller Software can use. Office Synchronizer uses the data synchronization area to 
exchange files between the office software and the site controller software so that they 
are synchronized. 
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Note: The data synchronization area is meant for data exchange only. You should not 
directly modify its structure or contents, but manage all your construction project files 
in a separate location. 

Conflict and Conflict Resolution 

A conflict is triggered by a difference between the site or design data in your project 
and data for the same site or design in the data synchronization area. In addition, a 
conflict could arise from a difference between data for the same site or design on 
multiple controllers, or the introduction of new data on a controller.  

A conflict is indicated by an active Resolve button with an  icon in the command 
pane. The icon is a reminder that you need to resolve the inconsistency by choosing 
which data to use in both your project and on site controllers. Depending on your 
choice, either your project data or the data in the data synchronization area is updated, 
thereby resynchronizing them. 

SCS Data Manager 

HEAVY CONSTRUCTION  

The SCS Data Manager is a program that lets you create sites, organize site and design 
data, write work orders, and assign the data and work orders to controllers in 
preparation for Trimble® site controller software (SCS). 

SCS enables you to measure material volumes, monitor grades and laid material 
thickness, and perform other site-related tasks, such as roadway point, line, and surface 
stakeout. 

Note: Most of the SCS Data Manager's functions have been embedded in the SCS Site 
Manager in this software.  

To open the SCS Data Manager:  

Do one of the following: 

 Select SCS > SCS Data Manager. 

 Click the  icon on the toolbar. 

Related topics 

 Manage a Site and Site Data (on page 377) 
 Workflow for Creating a Site (on page 377) 
 Workflow for Using an External Site (on page 378) 
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Manage a Site and Site Data 

HEAVY CONSTRUCTION  

Use the SCS Site Manager to create a site to be used by a Trimble® site positioning 
system. Then, prepare site data, and assign the data to the specific site controllers to be 
used on the job site. Use the SCS Design Manager to prepare designs, and use the Work 
Order Editor to create work orders. 

For additional information, see Understanding Sites, Designs, Work Orders, and 
Synchronization (on page 373). 

Related topics 

 Workflow for Creating a Site (on page 377) 
 Workflow for Using an External Site (on page 378) 
 Create a Site (on page 379) 
 Manage Designs and Design Data (on page 393) 
 Manage Work Orders and Results (on page 406) 

 

Workflow for Creating a Site 

HEAVY CONSTRUCTION  

Prepare site data for field crews. Then, assign the site and its data to specific site 
controllers so that when the crews synchronize their controllers, the correct data goes 
to the designated controllers. Here is the general workflow: 

1. Open or create a project within which to manage the data associated with a 
construction project and its job site. 

2. Import (see "Import Data" on page 193) any CAD or survey data that you want field 
crews to access at the site or from which you will derive design data. 

3. Create a site (on page 379) in the SCS Site Manager, and (optionally) assign it to one 
or more specific site controllers.  
The site, which will contain specific site-level project data associated with the use 
of a Trimble site positioning system, will be created in your project. As that site is 
subsequently assigned to a particular controller, an external folder and its data will 
be created within the data synchronization area, ready to be placed on that 
controller the next time it is synchronized. 

Note: Each project can contain only one site. 

4. Review settings for the site. 

5. Select and add control points (see "Add or Remove Control Points" on page 386) 
from your project data to the control point file included in the site data, as needed. 
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6. Select and add objects (see "Add or Remove Background Map Objects" on page 387) 
in your project data to the background map. The site, site data, and settings are 
written to the data synchronization area so they can be transferred to assigned 
controllers when those devices are synchronized. 

Note: To synchronize a controller using the Office Synchronizer utility, see Office 
Synchronizer (on page 219) and Prepare to Connect a Field Device (on page 217). 

Related topics 

 Create a Site (on page 379) 
 Workflow for Using an External Site (on page 378) 

 

Workflow for Using an External Site 

HEAVY CONSTRUCTION  

If you have already created an external site (that resides in within the data 
synchronization area) using SCS Data Manager, Terramodel, or some other means, you 
can use that site data within a project as a site within this software. Then, you can edit 
the site data by adding points and objects from your project data, if needed. Here is the 
general workflow: 

1. Open or create a project within which to manage the site. 

2. Add the external site (see "Add an External Site" on page 380) using the SCS Site 
Manager. This makes the site part of your current project. 

Note: Each project can contain only one site. 

3. Select and add control points (see "Add or Remove Control Points" on page 386) in 
your project data to the control points included in your site data, if needed. 

4. Select and add objects (see "Add or Remove Background Map Objects" on page 387) 
in your project data to the background map included in your site data, if desired. 

5. Resolve any conflicts (see "Resolve a Conflict in Site Settings" on page 388) 
between site settings and site data in your project and those in the data 
synchronization area. 

6. Check the controller assignment, and assign the site (see "Reassign a Site to 
Controllers" on page 388) to other controllers as needed. The site, site data, and 
settings are written to the synchronization area so the assigned controllers will be 
updated when they are synchronized. 

Note: To synchronize a controller using the Office Synchronizer utility, see Office 
Synchronizer (on page 219) and Prepare to Connect a Field Device (on page 217). 
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Related topics 

 Add an External Site (on page 380) 
 Workflow for Creating a Site (on page 377) 

 

Create a Site 

HEAVY CONSTRUCTION  

If your project does not already contain a site, create one so you can assign site data to 
one or more controllers for use in the field. When you create a site, it is stored in the 
current project, and appears in the Project Explorer, indicated by the  icon. A site is 
essentially a container in which you can designate portions of project data related to 
the site to be available to field crews employing a Trimble site positioning system.  

Note: Each project can contain only one site. 

To create a site:  

1. Do one of the following: 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager displays. 

2. Select Create new site, and type a unique name in the New site name box (See the 
Project and site naming section in Edit a Site's Name and Settings (on page 383)). 

3. Check the box for each controller that you want to assign the site to in the 
Controllers group. 

Note: You can create a site without assigning any controllers, but the site and site 
data cannot be saved to, or used on, controllers until you do so. The site and site 
data are saved in your project until controllers are assigned in the future. 

4. Click OK. The SCS Site Manager command pane displays, and the site appears in the 
Project Explorer. Start at step 3 in Edit a Site's Name and Settings (on page 383). 

Note: Settings for new sites are inherited from Project Settings. If these settings are 
not recognized by the assigned controllers, the Unsupported Project Settings dialog 
displays. You must resolve unsupported site settings (see "Resolve a Conflict in Site 
Settings" on page 388) before creating a site. 

To delete a site:  

1. Select the site in the Project Explorer. 
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2. Press [Ctrl] + [D]. The site is removed from the project and disappears from the 
Project Explorer.  

Note: If you delete a site in this software, it is removed from the project, but not 
from the data synchronization area. If you delete a site from the data 
synchronization area using SCS Data Manager or Windows® Explorer, it remains in 
the project, but assignments to any controllers are lost. 

Related topics 

 Add an External Site (on page 380) 
 Edit a Site's Name and Settings (on page 383) 
 Site Options (on page 381) 
 Workflow for Creating a Site (on page 377) 

 

Add an External Site 

HEAVY CONSTRUCTION  

External sites are those that exist in the data synchronization area, but not in your 
current project. Add external sites to make their site data and associated designs and 
design data part of your project. Adding an external site makes it, and its designs and 
work orders, appear in the Project Explorer. Then you can edit the site's settings or data. 

Note: Each project can only contain one site. 

To add an external site:  

1. Do one of the following: 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager displays. 

2. Select Add external site, and select a site in the External site list. 

Note: The External site list shows all of the sites found in the data synchronization 
area on your hard drive. 

3. Click OK. The SCS Site Manager command pane displays, and the site appears in the 
Project Explorer. See Edit a Site's Name and Settings (on page 383). 

Related topics 

 Create a Site (on page 379) 
 Edit a Site's Name and Settings (on page 383) 
 Site Options (on page 381) 
 Workflow for Creating a Site (on page 377) 
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Site Options 

HEAVY CONSTRUCTION  

Use these options to edit a site's name and settings, and to add and edit site data, such as 
a calibration file, control points, and a background map. In addition, you can change 
the site controllers to which the site is assigned. The options are available in the SCS 
Site Manager command pane. 
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Options 

 Click this to launch the SCS Data Manager (on page 376). 

Site settings Rename - Click this to display the Rename Site dialog, where 
you can change the site name.  

Note: Before you rename a site, read the Project and site 
naming section in Edit a Site's Name and Settings (on page 
383). 

Units - Click this to display the Site Units dialog where you can 
review project and controller-based settings for the site. To 
change any of the settings, click Project Settings. 

Resolve - If there are settings conflicts, click this to display the 
conflict resolution (see "Resolve a Conflict in Site Settings" on 
page 388) dialog. The  icon indicates that there is a conflict. 

Site calibration This shows either the date that an imported site calibration (.dc) 
was created or the date a site calibration was performed in this 
software. 

Resolve - If there are conflicts, click this to display the conflict 
resolution (see "Resolve a Conflict in Site Calibrations" on page 
390) dialog. 

Control points Select - Click this to select/highlight the control points 
currently included in the site data. 

 - Click this to display the Add/Remove Control Points 
dialog, in which you can change the control points included in 
the site data. 

Resolve - If there is a conflict with the control points, click this 
to display the conflict resolution (see "Resolve a Conflict in 
Control Points" on page 391) dialog. 

Background maps Select - Click this to select/highlight the map objects currently 
included in the site data. 

 - Click this to display the Add/Remove Background 
Map Objects dialog, in which you can change the background 
map objects included in the site data. 

Resolve - If there is a conflict with the background map, click 
this to display the conflict resolution (see "Resolve a Conflict in 
Background Maps" on page 392) dialog. 

Controllers Reassign - Click this to display the Reassign Site dialog, in 
which you can change the controllers to which the site is 
assigned. 

Related topics 

 Edit a Site's Name and Settings (on page 383) 
 Edit Site Data (on page 384) 
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 Reassign a Site to Controllers (on page 388) 
 Workflow for Creating a Site (on page 377) 
 Workflow for Using an External Site (on page 378) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Edit a Site's Name and Settings 

HEAVY CONSTRUCTION  

Review and change a site's name and units in preparation for use on controllers in the 
field. These are the common settings found in Trimble's site controller software (SCS) 
and Trimble Business Center - Heavy Construction Edition projects: Distance units, 
angular units, station format, and coordinate order. 

Project and site naming 

You should give each of your project files a unique name so they uniquely pertain to a 
particular construction project and reliably avoid confusion with other projects. In 
addition, you must name each site uniquely because site controllers identify the project 
and its site by the site name alone; the project name is not available on the site 
controller. If two construction projects contain sites of the same name, and if those 
sites are each assigned to a number of controllers, there is no way for the user of the site 
controller in the field to determine which project the site data pertains to, other than 
through his familiarity with the data. In general, the name of a project and its site 
should be the same. If that is not feasible, try to derive a site name shortened from the 
project name. Shortening the site name may be warranted in light of the small screen 
size available on some site controllers.  

To edit  a site's name and settings: 

If you have just created or added a site, the SCS Site Manager command pane is 
displayed. Otherwise, do one of the following: 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager command pane displays. 

1. To change the site name, click Rename in the Site Settings group. The Rename Site 
dialog displays. 

2. Type a unique name in the New site name box, and click OK. 

3. Click Units to review the settings for the site. The Site Units dialog displays. 
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Note: Trimble Business Center supports a number of units of measure that are not 
supported by SCS. When using this software with SCS900, the units must be 
compatible. 
Note: Changing a site's name or settings can cause it to become out of sync with the 
data synchronization area. A desynchronized site is indicated by an  icon in the 
Project Explorer. To resolve conflicts after you edit a site, click each Resolve button 
that is available. 

To change the site calibration, control points, or background map objects included in 
your site data, see Edit Site Data (on page 384). 

To change any of the controllers the site is assigned to, click Reassign in the Controllers 
group. 

1. Click Close. The site name and settings are saved to the data synchronization area. 

Related topics 

 Reassign a Site to Controllers (on page 388) 
 Site Options (on page 381) 
 Resolve a Conflict in Site Settings (on page 388) 
 Resolve a Conflict in Site Calibrations (on page 390) 
 Resolve a Conflict in Control Points (on page 391) 
 Resolve a Conflict in Background Maps (on page 392) 

 

Edit Site Data 

HEAVY CONSTRUCTION  

Review and edit your site data so it can be used on controllers at the job site. Prior to 
editing the site data, make sure that you have imported any point and CAD data that 
you want to make available to construction crews on site so you can add additional 
points and objects to the site data as needed. If you want to include a site calibration in 
your site data, perform the calibration in your project or import a .dc calibration file. 

To edit  site data:  

If you have just created or added a site, the SCS Site Manager command pane is 
displayed. Otherwise, do one of the following: 

 Right-click the site in the Project Explorer, and select SCS Site Manager. 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager command pane displays. 
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1. If you have imported or performed a site calibration in your project, it is 
automatically added to the site data, as indicated by the Last update file date in the 
Site Calibration group (see Include a Site Calibration (on page 385)). 

To highlight the control points that are included in the site data in graphic views, click 
Select in the Control Points group. 

To change the control points that are included in the site data, click  (see Add or 
Remove Control Points (on page 386)). The Add/Remove Control Points dialog displays. 

To highlight the background map objects that are included in the site data, click Select 
in the Background Map group. 

To change the background map objects that are included in the site data, click  
(see Add or Remove SCS Background Map Objects (see "Add or Remove Background 
Map Objects" on page 387)). The Add/Remove Background Map Objects dialog displays. 

Note: Changing a site's data can cause it to become unsynchronized with the data 
synchronization area, creating conflicts. A desynchronized site is indicated by the 

 icon in the Project Explorer. To resolve conflicts after you edit a site, click each 
Resolve button that is available. 

1. Click Close. The site data is saved to the data synchronization area. 

Related topics 

 Site Options (on page 381) 
 Resolve a Conflict in Site Settings (on page 388) 
 Resolve a Conflict in Site Calibrations (on page 390) 
 Resolve a Conflict in Control Points (on page 391) 
 Resolve a Conflict in Background Maps (on page 392) 

 

Include a Site Calibration 

HEAVY CONSTRUCTION  

To include a site calibration in your site data, simply perform a site calibration (see 
"Calibrate a Site" on page 184) in your project or import a .dc calibration file (see 
"Import Data Collector Files (.dc)" on page 196). Either method automatically adds a 
.dc file to your site data in the data synchronization area. The presence of a site 
calibration is indicated by the date in the Site Manager's Site Calibration group. If you 
add a site that you created and calibrated in SCS to your project, that calibration will 
also be reflected in the Site Calibration group. 
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Even if you do not perform or import a site calibration, the coordinate system and any 
datum, geoid, projection, and shift grid information that you specify in the Coordinate 
System Settings (on page 148) section of the Project Settings are automatically saved in 
the data synchronization area so they will be available when you open your site in SCS. 
If you calibrate your site or make other coordinate system changes in SCS, you will be 
prompted to resolve the site calibration conflict (see "Resolve a Conflict in Site 
Calibrations" on page 390) once you synchronize and reopen the site in this software. 

Add or Remove Control Points 

HEAVY CONSTRUCTION  

Add control points to your site data to make them available on designated controllers. 
Control points are used by crews in the field to establish the positional accuracy of a 
site survey. 

Note: You cannot add or remove control points if there is a conflict in site units. See 
Resolve a Conflict in Site Settings (on page 388). 

To add/remove site control  points:  

If you have just created or added a site, the SCS Site Manager command pane is 
displayed. Otherwise, do one of the following: 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager command pane displays. 

1. Click  in the Control Points group. The Add/Remove Control Points command 
pane displays. 

2. To add additional control points to the file, pick them in a graphic view, or click 
Options for selection options. 

3. Click Add. The selected control points are added to the control point file. 

4. To remove excess control points, pick them or click Options. 

5. Click Remove. The points are removed from the site data. 

6. Click OK. The control points are saved as a .csv file in the data synchronization 
area. 

Note: If you are also using Omnistar© control points, they will reside with the site 
data in a file called reference.csv in the data synchronization area. This will not 
cause a conflict with your control points file. 



Trimble® Business Center 
Heavy Construction Edition User Guide 387 

 Prepare Data for Site Positioning Systems

7. To check the control points included in the site data, click Select in the SCS Site 
Manager. 

Related topics 

 Edit a Site Name and Settings (see "Edit a Site's Name and Settings" on page 383) 
 Resolve a Conflict in Control Points (on page 391) 

 

Add or Remove Background Map Objects 

HEAVY CONSTRUCTION  

Add a background map to your site data to make it available on designated controllers. 
Background maps are referenced by crews in the field to determine the location of 
features and boundaries at a site. 

Note: You cannot add or remove background map objects if there is a conflict in site 
units. See Resolve a Conflict in Site Settings (on page 388). 

To add/remove background map objects: 

If you have just created or added a site, the SCS Site Manager command pane is 
displayed. Otherwise, do one of the following: 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager command pane displays. 

1. Click  in the Background Map group. The Add/Remove Background Map 
Objects dialog displays. 

2. To add additional objects to the map, pick them in a graphic view, or click Options 
for selection options. 

3. Click Add. The selected objects are added to the background map. 

4. To remove excess objects, pick them or click Options. 

5. Click Remove. The objects are removed from the map. 

6. Click OK. The background map is saved as a .dxf file in the data synchronization 
area. 

7. To check the objects included in the background map, click Select in the SCS Site 
Manager. 

Related topics 

 Edit a Site's Name and Settings (on page 383) 
 Resolve a Conflict in Background Maps (on page 392) 
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Reassign a Site to Controllers 

HEAVY CONSTRUCTION  

Assign your site to specific controllers so they can be accessed by the designated crews 
in the field. 

To change a site's assigned controllers: 

1. Do one of the following: 

 Select SCS > SCS Site Manager. 

 Click the  icon on the toolbar. 

The SCS Site Manager command pane displays. 

2. Click Reassign in the Controllers group. The Reassign Site dialog displays.  

3. Check boxes for any controllers to which you want to assign the site. To remove 
the site from any controllers, uncheck the box. 

Warning: If you unassign a site from a controller, all data and work orders 
associated with the site are removed from the controller as well. 

4. Click OK.  

Related topics 

 Edit a Site's Name and Settings (on page 383) 
 Site Options (on page 381) 

 

Resolve a Conflict in Site Settings 

HEAVY CONSTRUCTION  

Change unsupported project settings so that they can be recognized by assigned 
controllers. Unsupported settings are those that are valid in this software, but not in 
site controller software (SCS). For example, the angular unit "Mils" is unsupported in 
SCS, so it must be changed to a value that can be recognized. 

Resolve conflicts between site-related settings in your project, and those on assigned 
controllers by changing and resynchronizing the settings. Conflicting settings are those 
that are valid in, but inconsistent between, this software and SCS. A conflict is 
indicated by the active Resolve button with the  icon in the SCS Site Manager. 

Causes of a site settings conflict include differences in distance or angular units, station 
format, or coordinate order. 
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Note: If there is a conflict in site units, you cannot edit or resolve conflicts in control 
points or background maps. 
Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve unsupported project settings: 

1. If applicable, click Resolve in the SCS Site Manager. The Unsupported Project Settings 
dialog displays. 

2. Review the settings that are unsupported, and click Project Settings. The Project 
Settings dialog displays. 

3. Change the unsupported settings to values that are supported in SCS, and click OK. 
If you selected a supported setting that is in conflict with the settings on the 
assigned controllers, the Resolve Site Units Conflict dialog displays (see the next 
section). Otherwise, the conflict is resolved. 

To resolve a conflict in site settings:  

1. Click Resolve in the SCS Site Manager. The Resolve Site Units Conflict dialog displays. 

2. Review the settings that are in conflict. 

3. To use the units from your Project Settings, click OK. The site settings are updated 
in the data synchronization area, and the conflict is resolved. Otherwise, to use the 
settings on your controllers, click Project Settings. The Project Settings dialog 
displays. 

Warning: Resolving a conflict by selecting the project-based units overwrites the 
units on the assigned controllers when they are synchronized. 

4. Edit the settings in your project that that are in conflict with those on the 
controllers so they match, and click OK. The conflict is resolved. 

Related topics 

 Create a Site (on page 379) 
 Add an External Site (on page 380) 
 Edit a Site's Name and Settings (on page 383) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
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Resolve a Conflict in Site Calibrations 

HEAVY CONSTRUCTION  

Resolve inconsistencies between a site calibration you have included in your site data 
and calibrations for the same site on assigned controllers by choosing which calibration 
to use for all. A conflict is indicated by the active Resolve button with the  icon in 
the SCS Site Manager command pane. 

Causes of a site calibration conflict include differences in site calibration names or 
dates. In addition, any differences between the coordinate system, datum, geoid, 
projection, or shift grid you specified in your project and those on assigned controllers 
will need to be resolved. 

Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve a site calibration conflict:  

1. Click Resolve in the SCS Site Manager. 

2. Click Yes if asked if you want to resolve conflicts. The Resolve Site Calibration 
Conflict dialog displays, showing any calibration in your project and all .dc 
calibration files for the site on the assigned controllers. 

3. Select either a project-based or controller-based calibration (or coordinate system 
file) in the list. 

Warning: Resolving a conflict by selecting the project-based calibration overwrites 
the calibration on assigned controllers when they are synchronized. 

4. Click OK. The conflict is resolved. 

Related topics 

 Edit a Site's Name and Settings (on page 383) 
 Site Options (on page 381) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
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Resolve a Conflict in Control Points 

HEAVY CONSTRUCTION  

Resolve inconsistencies between control points you have included in your site data and 
control points for the same site on assigned controllers by choosing which points to use 
for all. A conflict is indicated by the active Resolve button with the  icon in the SCS 
Site Manager command pane.  

Causes of a control point conflict include differences in coordinates, feature codes, 
point file names or dates, or the points they contain. 

Note: You cannot resolve a conflict in control points if there is a conflict in site units. 
Note: Certain characters are invalid in control point IDs: 
/ \ : * ? < > | ; , ~ ‘ ` “ $ [ ] { } ^ ( ) 
Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve a multiple control  point f i le conflict:  

1. Click Resolve in the SCS Site Manager. 

2. Click Yes if asked if you want to resolve conflicts. The Resolve Control Points File 
Conflict dialog displays, showing the files that exist on a single controller. 

3. Select a control point file in the list, and click OK. All other control point files are 
removed, and the conflict is resolved. 

4. If there are multiple control point files on another controller, repeat the process 
and click OK. If you selected a control point file that is in conflict with others on 
assigned controllers, the Resolve Control Points Conflict dialog displays (see the next 
section). Otherwise, the conflict is resolved. 

To resolve a control  point conflict:  

1. Click Resolve in the SCS Site Manager. 

2. Click Yes if asked if you want to resolve conflicts. The Resolve Control Points Conflict 
dialog displays, showing the control points in your project and on assigned 
controllers that are in conflict. 

3. Check one box for the control point you want to retain in each set of conflicting 
points. 

4. Click OK. The conflict is resolved. 
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Warning: Resolving a conflict by selecting the project-based control points overwrites 
the control points on assigned controllers when they are synchronized. 

Related topics 

 Add or Remove Control Points (on page 386) 
 Edit a Site's Name and Settings (on page 383) 
 Site Options (on page 381) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Resolve a Conflict in Background Maps 

HEAVY CONSTRUCTION  

Resolve inconsistencies between a background map you have included in your site data 
and background maps for the same site on assigned controllers by choosing which file 
to use for all. A conflict is indicated by the active Resolve button with the  icon in 
the SCS Site Manager command pane.  

Causes of a background map conflict include differences in background map file 
names, dates, or the objects they contain. 

Note: You cannot resolve a conflict in background maps if there is a conflict in site 
units. 
Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve a background map confl ict:  

1. Click Resolve in the SCS Site Manager. 

2. Click Yes if asked if you want to resolve conflicts by using the project-based map. 
Otherwise, click No. The Resolve Background Map Conflict dialog displays, showing 
background maps in your project and on assigned controllers that are in conflict. 

3. Select a background map file in the list, and click OK. The conflict is resolved. 

Warning: Resolving a conflict by selecting the project-based background map 
overwrites the background map on assigned controllers when they are 
synchronized. 

Related topics 

 Add or Remove Background Map Objects (on page 387) 
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 Edit an Site's Name and Settings (see "Edit a Site's Name and Settings" on page 383) 
 Site Options (on page 381) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Manage Designs and Design Data 

HEAVY CONSTRUCTION  

After creating or adding a site to your project, use the SCS Design Manager to create 
designs, add design data, and assign the design data to specific controllers with site 
controller software. Then, use the Work Order Editor to create work instructions for 
your field crews. 

For additional information, see Understanding Sites, Designs, Work Orders, and 
Synchronization (on page 373). 

Related topics 

 Create a Design (on page 393) 
 Manage a Site and Site Data (on page 377) 
 Manage Work Orders and Results (on page 406) 

 

Create a Design 

HEAVY CONSTRUCTION  

Create designs and add design data, such as a surface model, stakeout points, and 
foreground map objects, so that they can be sent to specific controllers to be used on 
the job site. Multiple designs can be associated with a site. 

Designs that you add or create become objects within your project. A design is 
essentially a container in which you can designate portions of project data as design 
data related to the site, making it available to field crews using site controller software.  

To create a design: 

1. Do one of the following: 

 Select SCS > Create SCS Design. 

 Click the  icon on the toolbar. 

The Create SCS Design command pane displays. 

2. Type a unique name in the Design name box. 

3. Check the box for each controller you want to assign the design to in the Controllers 
group. 
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Note: You can create a design without assigning it to any controllers, but the design 
cannot be saved to, or used on, controllers until you do so. The design and design 
data are saved in your project until the design is assigned to specific controllers. 

4. Click OK. The SCS Design Manager command pane displays, and the design appears 
in the Project Explorer. See Edit Design Data (on page 395). 

To delete a design: 

1. Select the design in the Project Explorer. 

2. Do one of the following: 

 Right-click and select Delete from the context menu. 

 Press [Ctrl] + [D]. 

Note: If you delete a design that is assigned to controllers, it becomes an external 
design, is moved into External Designs in the Project Explorer, and remains in the 
data synchronization area. If you delete a design that is not assigned to any 
controllers, it is removed from your project and the data synchronization area, and 
disappears from the Project Explorer. 
If you delete a design using SCS Data Manager or Windows® Explorer, it remains in 
your project, but assignments to any controllers are lost. 

Related topics 

 Design Options (on page 396) 
 Edit Design Data (on page 395) 
 Add an External Design (on page 394) 

 

Add an External Design 

HEAVY CONSTRUCTION  

Add external designs to your site to make them part of your project so you can edit 
their design data. External designs are those that exist in the data synchronization area, 
but not your current project. 

To add an external design: 

1. Do one of the following: 

 Right-click an external design in the Project Explorer, and select Add SCS 
External Design from the context menu. The design is added to your site and 
project, and moves from External Designs to Designs in the Project Explorer (step 
2 in not needed). 

or 
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 Select SCS > Add SCS External Design. 

 Click the  icon on toolbar. 

The Add SCS External Design dialog displays. 

2. Select an external design in the list and click OK. The design is added to your site 
and project, and moves from External Designs to Designs in the Project Explorer. 

Note: If an external design includes a Terramodel .pro file, it cannot be added to 
your site. Terramodel files are not supported. 

To delete an external design: 

1. Right-click an external design in the Project Explorer, and select Reassign SCS 
External Design from the context menu. The Reassign SCS External Design dialog 
displays. 

2. Uncheck the box for each controller. 

3. Click OK. A confirmation message displays. 

4. Click Yes. The design is removed from the Project Explorer and the data 
synchronization area. 

Related topics 

 Create a Design (on page 393) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Edit Design Data 

HEAVY CONSTRUCTION  

Review and edit your design data so it can be used on controllers at the job site. Prior to 
editing the data, make sure that you have imported any point and CAD data that you 
want to make available to construction crews on site. Then you can add additional 
points and objects to the site data as needed. If you want to use a road or surface model 
in your design, import any surface and alignment data that you need. 

To edit  site data:  

1. If you have just created a design, the SCS Design Manager command pane is 
displayed. Otherwise, do one of the following: 

 Right-click a design in the Project Explorer, and select SCS Design Manager from 
the context menu. 

 Select SCS > SCS Design Manager. 
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 Click the  icon on the toolbar. 

The Select Design dialog displays. Select the design you want to edit, and click OK. 
The SCS Design Manager command pane displays. 

2. To add a surface model to your design, click Edit in the Model group The Edit SCS 
Design Model dialog displays (see Add and Edit a Design Model (on page 398)). 

3. To highlight the stakeout points that are included in the design data in graphic 
views, click Select in the Stakeout Points group. 

4. To change the stakeout points included in the design data, click . The 
Add/Remove Stakeout Points dialog displays (see Add or Remove Stakeout Points 
(on page 399)). 

5. To highlight the foreground map objects that are included in the design data, click 
Select in the Foreground Map group. 

6. To change the foreground map objects included in the design data, click . 
The Add/Remove Foreground Map Objects dialog displays (see Add or Remove 
Foreground Map Objects (on page 401)). 

Note: Changing a design's data can cause it to become unsynchronized with the 
data synchronization area, creating conflicts. An unsynchronized design is 
indicated by the  icon in the Project Explorer. To resolve conflicts after you edit a 
design, click each Resolve button that is available. 

7. Click Close. The design data is saved to the data synchronization area. 

Related topics 

 Design Options (on page 396) 
 Resolve a Conflict in an SCS Model (see "Resolve a Conflict in Design Models" on 

page 402) 
 Resolve a Conflict in SCS Stakeout Points (see "Resolve a Conflict in Stakeout 

Points" on page 403) 
 Resolve a Conflict in SCS Foreground Maps (see "Resolve a Conflict in Foreground 

Maps" on page 404) 
 

Design Options 

HEAVY CONSTRUCTION  

Use these options to add and edit design data, such as a surface model, stakeout points, 
and a foreground map. In addition, you can change the site controllers to which the 
design is assigned. They are available in the SCS Design Manager. 
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Options 

 Click this to launch the SCS Data Manager (on page 376). 

Info Design name - This shows the name of the current design. 

Model Type - This shows whether the design model is a surface or road 
surface. 

Last update - This displays the date the surface model was added or 
last modified. 

Edit - Click this to display the Edit SCS Design Model dialog, where 
you can add a model to the design, or edit an existing model. 

Resolve - If there is a conflict with the model, click this to display 
the conflict resolution (see "Resolve a Conflict in Design Models" on 
page 402) dialog. The  icon indicates that there is a conflict. 

Stakeout points Select - Click this to highlight the stakeout points currently 
included in the design data. 

 - Click this to display the Add/Remove Stakeout Points 
dialog, in which you can change the stakeout points included in the 
design data. 

Resolve - If there is a conflict with the stakeout points, click this to 
display the conflict resolution (see "Resolve a Conflict in Stakeout 
Points" on page 403) dialog. 

Foreground map Select - Click this to highlight the map objects currently included in 
the design data. 

 - Click this to display the Add/Remove Foreground Map 
Objects dialog, in which you can change the map objects included in 
the design data. 

Resolve - If there is a conflict with the foreground map, click this to 
display the conflict resolution (see "Resolve a Conflict in Foreground 
Maps" on page 404) dialog. 

Controllers Reassign - Click this to display the Reassign Design dialog, in which 
you can change the controllers to which the design is assigned. 

Related topics 

 Edit Design Data (on page 395) 
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 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 
page 427) 

 

Add and Edit a Design Model 

HEAVY CONSTRUCTION  

Add a model to your design to make it available on assigned controllers. Models, which 
can be defined by a surface, a surface and an alignment, or simply an alignment, are 
used by crews in the field to perform grading, checks, and other operations. 

To add or edit a design model: 

1.  If you have just created a design, the SCS Design Manager command pane is 
displayed. Otherwise, do one of the following: 

 Select SCS > SCS Design Manager. 

 Click the  icon on the toolbar. 

The Select Design dialog displays.  

2. Select the design you want to edit, and click OK. If no designs exist, you will need 
to Create a Design (on page 393). The SCS Design Manager command pane displays. 

3. Click Edit in the Model group. The Edit SCS Design Model command pane displays. 

4. Select Surface, Alignment, or Road Surface as the model type, depending on what 
kind of data you have. The pane updates, indicating the types of data you need. 

Note: If the surface used in your design model contains a boundary, all breaklines 
in the surface will appear as unnamed features when the surface is viewed in SCS. 
If the surface in your design model does not contain a boundary, the breakline 
names will appear in SCS. 

5. If you are creating a surface or road surface model, select the surface you want to 
use for the model in the Surface list. 

6. If you only want to use a portion of the surface, select the boundary you want to 
use to clip it in the Surface clipping boundary list. 

7. If you are creating a road surface or alignment model, check the boxes for one or 
more alignments in the Alignments box. 
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Note: The Alignment model can be made from 3D alignments defined by a HAL and 
a VAL, and 2D alignments defined by a HAL alone (if either no VAL exists or more 
than one VAL exists). This will enable field crews to stake the alignments, or others 
generated on-the-fly in relation to them, based on a combination of horizontal 
offset, vertical offset, and cross-slope in SCS. 
Note: If you do not have the surface, boundary, or alignment in your project yet, 
you can create them by selecting New. 
Note: For a road surface model, the alignment and surface you select must be 
coincident. 

8. Click OK. The model is added to your design. If you created a surface model, it is 
saved as a .ttm file in the data synchronization area. If you created a road surface or 
alignment model, it is saved as a .pro file. 

Related topics 

 Resolve a Conflict in an Model (see "Resolve a Conflict in Design Models" on page 
402) 

 Create a Surface (see "Understanding Surfaces" on page 320) 
 Create a Boundary (on page 340) 
 Create an Alignment (on page 288) 

 

Add or Remove Stakeout Points 

HEAVY CONSTRUCTION  

Add stakeout points to your design to make them available on designated controllers. 
Stakeout points are used by crews in the field to stakeout features at the job site. Both 
survey points and CAD points can be selected as stakeout points, but you must convert 
the CAD points to survey points before they can be included. 

To add/remove SCS stakeout points:  

1. Do one of the following: 

 Select SCS > SCS Design Manager. 

 Click the  icon on the toolbar. 

The Select Design dialog displays. 

1. Select the design you want to edit, and click OK. The SCS Design Manager command 
pane displays. 

2. Click  in the Stakeout Points group. The Add/Remove Stakeout Points 
command pane displays. 

3. To add additional points to the file, pick them in a graphic view, or click Options 
for selection options. 
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4. Click Add. If any CAD points are selected, the Convert CAD Points dialog displays 
(see Convert CAD Points (see "Convert CAD Points to Survey Points" on page 
400)). Otherwise, the selected points are added to the stakeout point file. 

5. To remove excess stakeout points, pick them or click Options. 

6. Click Remove. The points are removed from the file. 

7. Click OK. The stakeout points are saved as a .csv file in the data synchronization 
area.  

8. To check the stakeout points included in the design data, click Select in the SCS 
Design Manager. 

Related topics 

 Resolve a Conflict in Stakeout Points (on page 403) 
 Convert CAD Points to Survey Points (on page 400) 

 

Convert CAD Points to Survey Points 

HEAVY CONSTRUCTION  

When you select points to add to your design data as stakeout points, any CAD points 
you have selected must be converted to survey points to be included. 

To convert CAD points to survey points:  

1. Uncheck the Delete CAD points when done box if you want to retain both the CAD 
and survey points at the same location after the conversion. Otherwise, only the 
new survey points will remain. 

Note: Checking this box is recommended to prevent creating duplicate survey 
points at the same location by selecting the CAD points again in the future. 

2. Select a quality for the new survey points in the Point quality list (see Point Options 
(on page 271) for descriptions of the qualities). 

3. Type a feature code for the points if they will be used in feature code processing. 

4. Type a name to use as the base name and starting point for all of the new point IDs. 
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Note: By default, the name of your design is used as the starting point ID. The new 
point IDs will be numbered and increment upwards. If the starting point ID 
includes a number, the new points will increment upwards from that number. 
For example, if the name of your site is "Landfill", and you are converting five CAD 
points, the new survey points will be named Landfill1, Landfill2...Landfill5. If you 
change the starting point ID to "Converted point 210", the five new survey points 
will be Converted point 211, Converted point 212...Converted point 215. If any of the 
incremented names already exists, they will be skipped, and the naming will start 
again at the next available increment. 
Note: Certain characters are invalid in point IDs:  / \ : * ? < > | ; , ~ ' ` " $ [ ] { } ^ ( )    
When points are imported, these characters are replaced by an underscore in the 
point ID. It you type one of these characters in a point ID, it will not be accepted, 
and the program will beep. 

5. Click Yes to convert the points, or click No to ignore the selected CAD points and 
only add the selected survey points as stakeout points. The CAD points are 
converted to survey points and added to your stakeout points. Unlike CAD points, 
the new survey points can now also appear in the Point Spreadsheet. 

Related topics 

 Add or Remove Control Points (on page 386) 
 Add or Remove Stakeout Points (on page 399) 

 

Add or Remove Foreground Map Objects 

HEAVY CONSTRUCTION  

Add a foreground map to your design to make it available on designated controllers. 
Foreground map objects are selectable on site controllers in the field. They are used by 
crews to stake out features, alignments, and surfaces at the job site. 

To add/remove foreground map objects: 

1. Do one of the following: 

 Select SCS > SCS Design Manager. 

 Click the  icon on the toolbar. 

The Select Design dialog displays. 

1. Select the design you want to edit, and click OK. The SCS Design Manager command 
pane displays. 

2. Click  in the Foreground Map group. The Add/Remove Foreground Map Objects 
dialog displays. 
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3. To add additional objects to the map, pick them in a graphic view, or click Options 
for selection options. 

4. Click Add. The selected objects are added to the foreground map. 

5. To remove excess objects, pick them or click Options. 

6. Click Remove. The objects are removed from the foreground map. 

7. Click OK. The foreground map is saved as a .dxf file in the data synchronization 
area. 

8. To check the objects included in the foreground map, click Select in the SCS Design 
Manager. 

Related topics 

 Resolve a Conflict in Foreground Maps (on page 404) 
 

Resolve a Conflict in Design Models 

HEAVY CONSTRUCTION  

Resolve inconsistencies between a surface or road surface model in your design and 
models for the same design on assigned controllers by choosing which model to use for 
all. A conflict is indicated by the active Resolve button with the  icon in the SCS 
Design Manager command pane.  

Causes of a model conflict include differences in model names, dates, or data. 

Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve a model conflict:  

1. Click Resolve in the SCS Design Manager.  

2. Click Yes if asked if you want to resolve conflicts by using the project-based model. 
Otherwise, click No to display the Resolve Model Conflict dialog, showing the model 
in your project and all .ttm files on the controllers to which the design is assigned. 

3. Select either the project-based or a controller-based model in the list. 

Warning: Resolving a conflict by selecting the project-based model overwrites the 
model on assigned controllers when they are synchronized. 

4. Click OK. The conflict is resolved, and the model is updated in your project or the 
data synchronization area, depending on your choice. 
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Related topics 

 Design Options (on page 396) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Resolve a Conflict in Stakeout Points 

HEAVY CONSTRUCTION  

Resolve inconsistencies between stakeout points you have included in your design and 
stakeout point for the same design on assigned controllers by choosing which points to 
use on all. A conflict is indicated by the active Resolve button with the  icon in the 
SCS Design Manager command pane.  

Causes of a stakeout point conflict include differences in coordinates, feature codes, 
point file names or dates, or the points they contain. 

Note: Certain characters are invalid in stakeout point IDs: 
/ \ : * ? < > | ; , ~ ‘ ` “ $ [ ] { } ^ ( ) 
Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve a multiple stakeout point f i le conflict:  

1. Click Resolve in the SCS Design Manager. 

2. Click Yes if asked if you want to resolve conflicts. The Resolve Stakeout Points File 
Conflict dialog displays, showing the files that exist on a single controller. 

3. Select a stakeout point file in the list, and click OK. All other stakeout point files 
are removed, and the conflict is resolved. 

4. If there are multiple stakeout point files on another controller, repeat the process 
and click OK. If you selected a stakeout point file that is in conflict with others on 
assigned controllers, the Resolve Stakeout Points Conflict dialog displays (see the 
next section). Otherwise, the conflict is resolved. 

To resolve a stakeout point confl ict:  

1. Click Resolve in the SCS Design Manager. 

2. Click Yes if asked if you want to resolve conflicts. The Resolve Stakeout Points 
Conflict dialog displays, showing the stakeout points in your project and on assigned 
controllers that are in conflict. 

3. For each point in the list, click the  icon to expand the set. 
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4. Check one box for the stakeout point you want to retain in each set of conflicting 
points. 

5. Click OK. The conflict is resolved, and the stakeout points are updated in the data 
synchronization area. 

Warning: Resolving a conflict by selecting the project-based stakeout points overwrites 
the stakeout points on assigned controllers when they are synchronized. 

Related topics 

 Design Options (on page 396) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Resolve a Conflict in Foreground Maps 

HEAVY CONSTRUCTION  

Resolve inconsistencies between a foreground map you have included in your design 
and foreground maps for the same design on assigned controllers by choosing which 
map to use on all. A conflict is indicated by the active Resolve button with the  icon 
in the SCS Design Manager command pane.  

Causes of a foreground map conflict include differences in foreground map names, 
dates, or the objects they contain. 

Note: The Undo and Redo commands do not affect any of the functions that 
synchronize files. Undo and Redo affect only edits made to database objects within your 
project; this does not include files in the data synchronization area (which SCS uses). If 
you try to undo a conflict resolution, the Resolve button remains disabled because the 
conflict is still resolved. 

To resolve a foreground map conflict:  

1. Click Resolve in the SCS Design Manager. 

2. Click Yes if asked if you want to resolve conflicts by using the project-based map. 
Otherwise, click No. The Resolve Foreground Map Conflict dialog displays, showing 
foreground maps in your project and on assigned controllers that are in conflict. 

3. Select a foreground map file in the list, and click OK. The conflict is resolved, and 
the foreground map file is updated in the data synchronization area. 

Warning: Resolving a conflict by selecting the project-based foreground map 
overwrites the foreground map on assigned controllers when they are 
synchronized. 
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Related topics 

 Design Options (on page 396) 
 Icons in the Project Explorer (see "View Construction Data in Project Explorer" on 

page 427) 
 

Reassign a Design to Controllers 

HEAVY CONSTRUCTION  

Assign your designs to specific controllers so they can be accessed by the designated 
crews in the field. External designs are those that exist in the data synchronization 
area, but not your current project. 

Note: You cannot reassign a design if it has conflicts, or if the site the design is 
associated with has conflicts. Resolve the conflicts first. 

To reassign a design: 

1. Do one of the following: 

 Right-click a design in the Project Explorer, and select SCS Design Manager from 
the context menu. 

 Select SCS > SCS Design Manager. 

 Click the  icon on the toolbar. 

The Select Design dialog displays.  

2. Select the design you want to edit, and click OK. The SCS Design Manager command 
pane displays. 

3. Click Reassign in the Controllers group. The Reassign Design dialog displays.  

4. Check boxes for any controllers on which you want on access the design. To 
remove the design from any controller, uncheck the box. 

5. Click OK. 

To reassign an external design: 

1. Do one of the following: 

 Right-click an external design in the Project Explorer, and select Reassign SCS 
External Design from the context menu. 

 Select SCS > Reassign SCS External Design. 

 Click the  icon on the toolbar. 

2. Select the design in the Select External Design dialog, and click OK. The Reassign 
SCS External Design dialog displays.   
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3. Check the box for the controllers on which you want to access the design. To 
remove the design from any controllers, uncheck the box. 

4. Click OK. 

Related topics 

 Design Options (on page 396) 
 

Manage Work Orders and Results 

HEAVY CONSTRUCTION  

After creating a site and one or more designs, use the Work Order Editor to create work 
orders to send to your field crews, instructing them what tasks are to be performed at 
the job site, as well as specifying the design, tolerances, and other settings to use. 

For additional information, see Understanding Sites, Designs, Work Orders, and 
Synchronization (on page 373). 

Related topics 

 Workflow for Managing Work Orders (on page 406) 
 Create a Work Order (on page 409) 
 Manage a Site and site Data (on page 377) 
 Manage Designs and Design Data (on page 393) 

 

Workflow for Managing Work Orders 

HEAVY CONSTRUCTION  

Prepare instructions for your field crews by creating work orders in which you outline 
the required task, tolerances, and other settings to be use. Here is the general 
workflow: 

1. After you have added a site and design to your project, create a work order and 
assign it to a controller. 

2. Select a related design, if appropriate. 

3. Specify the primary task to be completed, and the tolerances and settings to use. 

4. Graphically review the site and design data associated with the work order. 

5. Save the work order. The work order is written to the data synchronization area so 
it can be transferred to the designated controller when it is synchronized. 

6. If needed, compress and e-mail the work order to colleagues or field crews. 

7. Once the task outlined in the work order has been completed and returned from 
the field, import it and any results into your project. 
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8. Review the completed work order and field measurement data. 

9. Run work order reports. 

10. Copy, update and reuse the work order, or archive it in case you need to retrieve it 
in the future. 



Trimble® Business Center 
Heavy Construction Edition User Guide 408 

 Prepare Data for Site Positioning Systems

Types of work order tasks:  

 General - Use this type to instruct a field crew to perform a miscellaneous task, as 
specified in the Instructions box. 

 Check surface grade - Use this type to instruct a field crew to measure a surface 
while work is in progress, so that the measured surface can be compared to a 
specified design surface. This will help determine how much fill or cut remains to 
be done at each measurement point. The resulting report also shows whether the 
measured surface elevation is within tolerance, and therefore whether the design 
intent has been achieved. The Check surface grade task monitors and documents 
progress towards, and final achievement of, design specifications. Data required for 
this task includes a design containing the design surface data and surface grade 
tolerances, if applicable. 

 Check material thickness - Use this type to instruct a field crew to measure the 
upper surface of a particular material, such as a roadway base. The upper surface 
can then be compared to the previously measured upper surface of the underlying 
material to compute the material thickness. Data required for this task includes a 
design containing the previously measured underlying surface, the specified 
material thickness, and the allowable tolerances, if applicable. 

 Check grade & material thickness - Use this type to instruct a field crew to measure 
the surface of a material in order to compare the achieved surface shape to the 
design surface and, at the same time, to calculate a material thickness. To calculate 
a material thickness, site control software (SCS) compares the measured surface to 
the previously measured upper surface of the underlying material. Data required 
for this task includes a design containing the design surface data, a design 
containing the previously measured underlying surface, the specified material 
thickness, and the surface grade and material thickness tolerances, if applicable. 

 Measure surface & site features - Use this type to instruct a field crew to perform 
either a Topo surface or a Measure site features operation. Select this task if you 
want the crew to measure random points, breaklines, and surface boundaries to 
represent a surface. Also select this task if you want a crew to measure existing 
point-based, line-based, or enclosed boundary site features. The information 
collected for a Topo surface and site features task is typically used to map and 
model existing site features or topography. 

 Stakeout points & alignments - Use this type to instruct a field crew to perform field 
staking of the individual points contained in a specified design, or to perform field 
staking of the points along, or horizontally and/or vertically offset from, a selected 
alignment. The alignment is contained in the foreground map that is included in a 
specified design.  

 Stakeout sideslopes - Use this type to instruct a field crew to stakeout sideslope 
information.  
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 Stakeout surface - Use this type to instruct a field crew to perform field staking of a 
surface that is contained in a specified design. 

 Stakeout roadway - Use this type to instruct a field crew to perform field staking of a 
roadway alignment that is contained in a specified design. 

 Multiple tasks - Use this type to instruct a field crew to perform combinations of the 
above tasks within a single work order, as specified in the Instructions box.  

Note: This task makes all of the possible work order options available. 

Related topics 

 Create a Work Order (on page 409) 
 

Create a Work Order 

HEAVY CONSTRUCTION  

Create work orders to send to your field crews, instructing them what tasks are to be 
performed at a site, as well as specifying the design, tolerances, and other settings to 
use. Multiple work orders can be created for a site.  

To create a work order:  

1. Do one of the following: 

 Select SCS > Create Work Order. 

 Click the  icon on the toolbar. 

The Create Work Order command pane displays. 

2. Type a unique name in the Work order name box. 

Note: Different work orders assigned to different controllers can have the same 
name 

3. Select a single controller on which to access the work order in the Controllers list. 

Note: Each work order can only be assigned to one controller. This is an SCS 
requirement. 

4. Click OK. The Work Order Editor displays. See Edit a Work Order (on page 410). 

To delete a work order:  

1. Right-click the work order in the Project Explorer, and select Delete Work Order from 
the context menu. A confirmation message appears. 

2. Click OK. The work order is removed from the Project Explorer and the data 
synchronization area. 
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Related topics 

 Edit a Work Order (on page 410) 
 Work Order Options (on page 411) 

 

Edit a Work Order 

HEAVY CONSTRUCTION  

To edit  a work order:  

1. If you have just created a work order, the Work Order Editor is already displayed. 
Otherwise, do one of the following: 

 Right-click a work order in the Project Explorer, and select Work Order Editor 
from the context menu. 

 Select SCS > Work Order Editor. 

 Click the  icon on the toolbar. 

The Work Order Editor dialog displays.  

2. Select a work order in the tree and click OK. The Work Order Editor displays. 

3. Select the type of task the field crew needs to perform in the Work order task list. 
The options in the dialog change based on the type of task you select. For 
descriptions of work order tasks, see Workflow for Managing Work Orders (on 
page 406). 

Note: If you change the work order task to one that does not use the values you 
have set, when you save and reopen the work order, those original values will not 
reappear if you change the task back to one that does use them. 

4. Select the design with data related to the work order in the Design list, and specify 
the design surface offset, if applicable. 

Note: If your work order is assigned to a different controller than the design, you 
cannot select the design until any conflicts have been resolved. 

5. Set the current status, priority, and date that the work must be completed in the 
Work order status group. 

6. Describe the tasks that need to be performed in the Instructions box. 

7. Enter data and select settings in the other groups as needed. (See Work Order 
Options (on page 411)). 

8. To see the site and design data that is associated with the work order, click View. 
The Work Order Viewer displays. When you're done reviewing the data, click Close. 

9. Click OK. 
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Related topics 

 Work Order Options (on page 411) 
 View a Work Order's Data Graphically (on page 416) 

 

Work Order Options 

HEAVY CONSTRUCTION  

Use these options to create a work order, instructing field crews what tasks to perform 
at a job site, as well as specifying the design, tolerances, and other settings to use. They 
are available in the Work Order Editor. 

Options with an * in the dialog are optional for one of these reasons: 

 There is a default setting in the site controller software (SCS). Specify a setting to 
override the default, and the field engineer will not be prompted to choose one. 

 The selected task is Multiple tasks, so all options are displayed, but may not be 
needed for the actual task. If you do not specify a required setting, the field 
engineer will be prompted to do so. 

Tip: To set tolerances, continuous measurement settings, and the coverage map grid 
size to a suggested default value, click in the option's box, and click Set to default. 
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Options 

Work order 

Name This displays the name of the selected work order. 

Site name This shows the name of the site with which the work order is 
associated. 

Controller name This shows the controller to which the work order is assigned. 

Work order task See the Types of work order tasks section in Workflow for 
Managing Work Orders (on page 406). 

Note: The option Multiple Tasks shows all of the possible work 
order settings. 
Warning: If you change the work order task to one that does not 
use the values you have set, when you save and reopen the work 
order, those original values will not reappear if you change the 
task back to one that does use them. 

Designs 

Design Design - Select the design that supplies the required data for this 
work order. 

Surface offset Enter the offsets that can be applied to a surface in the design, in 
order to create a different surface. If the field crew, in order to 
create a different surface, must measure a surface that is offset 
from the surface specified in the design (above), enter the offset 
measurement. 

Once you have entered the surface offset, indicate whether the 
offset is applied by raising or lowering the surface by the 
specified amount: 

Above - Select this if the offset surface should be above the 
surface specified in the design.  

Below - Select this if the offset surface should be below that 
surface. 

Offset Type Vertical - Select this if the surface is to be vertically offset from 
the design surface (1 in the graphic below).  

Perpendicular - Select this if the surface is to be offset 
perpendicular to the design surface (2 in the graphic below). 
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Underlying surface 
design 

For a material thickness check, select the design that contains the 
underlying surface. The underlying surface is the upper surface 
of the material on which the material of interest has been placed. 
In most cases, this will be a previously measured surface. 

To compute the material thickness at each measured point, the 
site controller software compares the surface measured by the 
field crew against the underlying surface. 

Work order status 

Status Select the status that reflects the work order's current state of 
completion. 

Priority Select the priority that reflects the relative importance of the 
work order. 

Due date Click the arrow to display the calendar. Select the work order 
completion date. 

You can also enter the date in any valid alphanumeric format. 
The date will automatically be converted to the date format set in 
your Windows® operating system. 

Instructions Enter any instructions you have for the field crew. 

Surface grade tolerances 

 Set these tolerances to check a surface grade against a design 
surface if the selected task requires or allows measurements to be 
taken. An example of this is grade checking. 



Trimble® Business Center 
Heavy Construction Edition User Guide 414 

 Prepare Data for Site Positioning Systems

Above design by 

 

Enter an amount (tolerance) that the finished surface can be 
above the elevation that is established by the design. 

Note: The default setting in most boxes is "?", indicating that no 
tolerance has been specified. If you enter a tolerance outside the 
allowable range, you will need to correct the value. 

Below design by Enter an amount (tolerance) that the finished surface can be 
below the elevation that is established by the design. 

Material thickness and allowable tolerances 

 Set these tolerances if the selected task requires or allows 
measurements to be made in order to check the thickness of a 
material. 



Trimble® Business Center 
Heavy Construction Edition User Guide 415 

 Prepare Data for Site Positioning Systems

Thicker by 

 

Enter an amount (tolerance) that the measured thickness of a 
material can exceed the design thickness. 

Design thickness Enter the intended thickness of a material lying beneath the 
surface that is to be measured. 

Thinner by Enter an amount (tolerance) that the measured thickness of a 
material can be less than the design thickness. 

Measured Vertically - When material has been placed on a previously 
measured surface, select this to compute the material thickness as 
the difference in elevation between the measured surface and the 
new surface. 

Perpendicular - When material has been placed on a previously 
measured surface, select this to compute the material thickness 
using a perpendicular projection from the measured surface to 
the new surface. 

Reference line offset from source line 

Horizontal offset Select Left or Right for the direction of the offset from the source 
line.  
Then enter a horizontal distance in the box. 

Vertical offset Select Above or Below for the direction of the vertical offset from 
the source line.  
Then enter a vertical distance in the box. 

Coverage map 

Grid size Enter the size of the grid cell for the coverage map that is to be 
displayed on the controller. Enter the size in the units used at the 
site. For example, if a project is in meters, a value of "10" equates 
to a cell that is 10 meters square. 

Continuous measurement settings 

 Set these values if the selected task requires or allows continuous 
measurements to be taken, either from a vehicle or when 
walking. These settings determine how often measurements are 
taken when the site controller software is used in Continuous 
measurement mode. 
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Distance interval 

 

Enter a horizontal distance, in the units used at the site where 
the work order will be completed. Every time the receiver (or 
survey rod) detects that this change in distance has taken place, a 
point is recorded. 

Elevation change Enter an elevation change, in the units used at the site where the 
work order will be completed. Every time the receiver (or survey 
rod) detects that this change in elevation has taken place, a point 
is recorded. 

Related topics 

 Create a Work Order (on page 409) 
 Edit a Work Order (on page 410) 

 

View a Work Order's Data Graphically 

HEAVY CONSTRUCTION  

Use the Work Order Viewer to verify that the correct site and design data has been 
provided with the work order; it displays the same graphical view of the data that site 
controller software (SCS) will display in the field. 

To view a work order's data graphically:  

1. If you have just created a work order, the Work Order Editor is already displayed. 
Otherwise, do one of the following: 

 Select a work order in the Project Explorer, right-click and select Work Order 
Editor from the context menu. 

 Select SCS > Work Order Editor. 

 Click the  icon on the toolbar. 

2. The Work Order Editor dialog displays. Select a work order in the tree and click OK. 
The Work Order Editor displays. 

3. Click View. The Work Order Viewer displays. 

4. Review the site and design data in the Map view to confirm that it is complete and 
appropriate for the work order. 

5. Check boxes to show and hide different types of data in the Display options group, 
and use the zoom buttons to scale the view. For coverage map options, see Work 
Order Viewer Options (on page 417). 

6. To control the visibility of layers both in the Work Order Viewer and in the 
foreground map in SCS, click Layer Filter. In the Foreground Map Layer Filter dialog, 
check boxes for the layers you want to show, and uncheck boxes for the layers to 
hide. Click OK to return to the Work Order Viewer. 
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7. Click Close to return to the Work Order Editor. 

Related topics 

 Work Order Viewer Options (on page 417) 
 

Work Order Viewer Options 

HEAVY CONSTRUCTION  

Use these options to graphically check the site and design data associated with your 
work order. They are available in the Work Order Viewer. 
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Options 

Map view This shows the site and design data that is associated with the work 
order you are viewing. 

Zoom buttons Click these to scale the view. 

Display options Check and uncheck the boxes to show and hide different types of data.

If needed, click Select All or Unselect All to quickly change the layers 
that are displayed. 

Coverage map See Using coverage maps at the bottom of this topic. 

Grade cut/fill - Select this to show the coverage map resulting from a 
Check Surface Grade operation. The color codes show whether the 
measured elevation indicates the need for additional cut, additional 
fill, or if the grade is within tolerance. The shade of the red and blue 
colors provides an indication of the magnitude of additional cut or fill 
needed:  

 Reds indicate the need for additional cut to achieve the design 
elevation  

 Blues indicate the need for additional fill to achieve the design 
elevation  

 Green indicates that the measured elevation is within tolerance of 
the design elevation 

Elevation - Select this to show the coverage map resulting from a 
Measure Surface operation. The color codes indicate the relative 
magnitude of the measured elevation as follows:  

 Darker blue suggests higher elevations, based on the elevation 
range formed by the lowest and highest measured elevation, with 
the darkest blue representing the highest measured elevation  

 Lighter blue suggests lower elevations, based on the elevation 
range formed by the lowest and highest measured elevation. 
Within the lightest blue representing the lowest measured 
elevation 

Thickness cut/fill - Select this to show the coverage map resulting from 
a Check Material Thickness operation. The color codes show whether 
the measured elevation indicates the need for additional cut, additional 
fill, or if the material thickness is within tolerance of the design 
thickness. The shade of the red and blue colors provides an indication 
of the magnitude of additional cut or fill needed:  

 Reds indicate the need for additional cut to achieve the design 
thickness  

 Blues indicate the need for additional fill to achieve the design 
thickness  

 Green indicates that the measured elevation demonstrates that the 
computed material thickness is within tolerance of the design 
thickness 
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Layer filter Click this to display the Layer Filter dialog, and check boxes to control 
the visibility of foreground map layers both in the Work Order Viewer 
and in the foreground map in SCS. 

These layer settings are stored with the work order. 
Zooming and panning options 

 Once you have selected the display options, you can zoom and pan. 
The scale bar in the map view updates when you zoom. 

To zoom in or out: 

 Click Zoom In or Zoom Out. Then, you can also roll the mouse 
wheel up and down to zoom.  

To zoom to a window:  

 Click-and-drag to zoom to a window. 

To zoom to the extents of the data: 

 Click Zoom Extents. 

To pan: 

 Click-and-drag using the mouse wheel. 

Using coverage maps: 

Coverage maps show how much of a site's area has been covered in performing specific 
surface measurements, as well as the status of certain earthmoving operations based on 
those measurements. The maps show the area divided into grid squares. The size of the 
squares is set in the Coverage map grid size box in the Work Order Editor. For more 
detailed coverage maps, set the size of the grid squares small enough that only one or 
two measurements occupy each square. The coverage map settings let you display 
coverage for measurements made in performing surface measurements (topo surveys), 
surface grade checks, and material thickness checks. 

For any of the settings, if multiple measurements exist in one square, the worst-case 
measurement (not the average of the measurements) is used. This helps you locate bad 
measurements that might need to be deleted. As you zoom out, and the scale of your 
view gets smaller, each coverage map square might actually represent multiple squares. 
In this case, the same worst-case measurement rule applies. If there are squares that 
have no measurements within them, the squares turn grey, indicating that the area still 
needs to be measured. To determine the area that may need to be measured, zoom in to 
the grey squares to identify the squares without measurements. 

Related topics 

 Edit a Work Order (on page 410) 
 View a Work Order's Data Graphically (on page 416) 
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Reassign or Copy a Work Order 

HEAVY CONSTRUCTION  

Save work by copying work orders that you want to reuse, or changing the controller 
to which a work order was assigned. Each work order can only be assigned to one 
controller at a time. 

To copy a work order:  

1. Do one of the following: 

 Right-click a work order in the Project Explorer, and select Copy Work Order 
from the context menu. 

 Select SCS > Copy Work Order. 

 Click the  icon on the toolbar. 

The Copy Work Order dialog displays. 

2. Select the original work order in the Work order tree.  

3. Type a name for the new work order in the New name box. 

4. Select a controller on which to access the new work order in the New Controller list. 

Note: You can only assign copied work orders to controllers to which the site is 
assigned. 

5. Click OK. The copy of the work order appears in the Project Explorer.  

Note: When you copy a work order, the new work order's state is set to Not started 
and no work order results are copied. 

To reassign a work order to a different controller:  

1. Do one of the following: 

 Right-click a work order in the Project Explorer, and select Reassign Work Order 
from the context menu. 

 Select SCS > Reassign Work Order. 

 Click the  icon on the toolbar. 

The Reassign Work Order dialog displays. 

2. Select the work order in the Work order tree. 

3. Select a different controller on which to access the work order in the New Controller 
list. 

4. Click OK. 
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Compress and E-mail SCS Files 

HEAVY CONSTRUCTION  

Compress your site data, design data, and work orders to archive or e-mail them to 
colleagues or field crews. Files are compressed in a .zip folder. 

To compress and e-mail  site,  design, or work order f i les:  

1. Select a site, design, or work order in the Project Explorer, and do one of the 
following: 

 Right-click and select Compress/E-mail SCS Files from the context menu.  

 Select SCS > Compress/E-mail SCS Files. 

 Click the  icon on the toolbar. 

The Compress /E-mail SCS Files dialog displays. 

2. Select a controller in the Controller box. The files assigned to that controller for the 
selected site, design, or work order appear. 

3. Type a path and name for the output file in the Compressed File Name box. To 
browse for a file path, click . 

4. Check the box for each file to include in the compressed folder in the Files to 
compress list. 

5. To filter the list to include only files that have been created or changed since you 
last synchronized the selected controller, check the Only show files modified since 
last synchronization box. 

6. To send the compressed folder to an e-mail address, check the E-mail file box. 

7. Type an e-mail address to send the file to in the E-mail address box, if applicable. 

8. Click OK. The selected files are saved in the compressed folder and emailed as 
specified. 

Related topics 

 SCS File Compression and Email Options (on page 421) 
 

SCS File Compression and Email Options 

HEAVY CONSTRUCTION  

Use these options to compress and email site, design, and work order files to colleagues 
or field crews. They are available in the Compress /E-mail SCS Files dialog. 
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Options 

Controller Select the controller to which the files you want to 
compress are assigned. 

Compressed file name Type a path and name for the output file. To browse for a 
file path, click . 

The default path saves to a temporary folder. 
Files to compress Check the box for each file to include in the compressed 

folder. Uncheck boxes for files you do not want to include. 

For the assigned controller, all of the files beneath the 
selected site, design, or work order are listed. By default, all 
files are selected for inclusion in the .zip file. 

Only show files modified 
since last synchronization 

Check this to filter the list to include only files that have 
been created or changed since you last synchronized with 
the selected controller. 

E-mail file Check this to send the compressed folder to an email 
address.  

Note: Some Trimble® controllers, such as the TSC2™, can 
have a dedicated e-mail account. When the controller 
connects to a network and accesses the e-mail server, the 
.zip file appears in the e-mail Inbox.  

E-mail address Type the e-mail address for the colleague or controller. 

Note: This feature requires Microsoft® Outlook® to work. 
Other email programs may work, but are not guaranteed. 
Web-based email programs, such as Microsoft Hotmail, 
Yahoo®Mail or Google®Gmail™, will not work. 
Tip: If your email program is not supported, you can still 
create the compressed file, open your email program, attach 
the file to a message, and send it.  

Related topics 

 Compress and E-mail SCS Files (on page 421) 
 

Import Work Order Results 

HEAVY CONSTRUCTION  

When crews return from the field, and synchronize their controllers, new data from 
the field is transferred to the data synchronization area, making it available to your 
project. In addition, any site, design, or work order updates that you have prepared and 
assigned to the controllers are automatically updated on the controllers. When results 
are available for your work orders, the work order icons in the Project Explorer are 
appended with an  icon like this , indicating that the results can be imported.  

These types of files are brought into your project when you import work order results: 
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 <work order name>-Report (.txt) - This file is the work order operations log, the 
historical record of all field operations performed for the work order. 

 <work order name>-Record (.txt) - This file is the measurement record for the 
work order. 

 <work order name>-measure (.dxf) - This file is the CAD output containing 
graphical entities resulting from the field measurements. The field crew may not 
always create one of these. 

To import work order results:  

Select a work order that has an  icon in the Project Explorer, and do one of the 
following: 

 Right-click and select Import Work Order Results from the context menu. 

 Select SCS > Import Work Order Results. 

 Click the  icon on the toolbar. 

The results are imported into your project. 

Related topics 

 Work Order Results Options (see "Edit a View Filter" on page 75) 
 Run a Work Order Report or Summary (on page 423) 

 

Run a Work Order Report or Summary 

HEAVY CONSTRUCTION  

Run reports to check the status of all your work orders and individual work order 
results. The Work Order Summary lists basics on each of the work orders in your project, 
including the assigned controller, task, status, priority, and due date. The Work Order 
Report provides details on base, design, difference, and alignment data from the field, as 
well as tolerances in the original work order. 

To run a summary of work orders:  

1. Do one of the following: 

 Select SCS > Work Orders Summary. 

 Click the  icon on the toolbar. 

 Right-click Work Orders in the Project Explorer, and select Work Orders Summary 
from the context menu. 

The Work Orders Summary displays. 
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2. Review the work orders in your project, clicking any column heading to sort the 
list based on that column.  

Note: "?" indicates that no value was specified. 

3. Click Close. 

To f i lter the Work Orders Summary:  

Click the  icon at the top of a column to select a filter from a list. The icon changes 
color when a filter is active. The options are: 

 All – This displays all items of the column's type and removes any other filter 
applied. 

 Blanks – This displays all rows with a blank in the column. 

 Custom – Use this to create a custom filter, (e.g. to show all work orders due within 
the next 3 days). 

 NonBlanks – This displays all rows that do not have a blank in the column. 

 <specific item> - This displays all rows with the specific name in the column. This 
filter choice allows you to display all rows pertaining to a specific work order, site, 
design, task, etc. 

To run a report on a specif ic work order:  

Select  a work order that has an  icon in the Project Explorer, and do one of the 
following: 

 Right-click and select Work Order Report from the context menu. 

 Select SCS > Work Order Report. 

 Click the  icon on the toolbar. 

The Work Order Report displays in your spreadsheet application. 

Note: If the spreadsheet does not display, the required template is missing or in the 
wrong location. The template is installed during the site controller software (SCS) 
installation. If the report template cannot be found, you can set the path to it by 
selecting Tools > Options. Then click SCS and File locations. 
Note: The Work Order Report does not show work order results. 
Tip: In the report spreadsheet, click the Report tab to view the Report file. For more 
information about these files, see the documentation for SCS. 

Related topics 

 Import Work Order Results (on page 422) 
 Customize and Run a Report (see "Customize a Report" on page 436) 
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Troubleshoot an SCS Site or File Problem 

HEAVY CONSTRUCTION  

Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

The program cannot 
find the SCS900 report 
utility .xls file. 

An error message states 
that it cannot find the 
file or the full file 
extension and if you 
browse to it the file is 
correct. Best to keep on 
the C drive. 

Paths to Microsoft® Excel 
files are limited to 219 
characters. In Trimble® 
Business Center- Heavy 
Construction Edition, 
this means that if the 
path to the SCS report 
utility file (named 
SCS900 Reporting 
Utility.xls or SCS Report 
Utility.xls) exceeds the 
limit, the file will not 
open. In most cases, this 
will only happen if the 
.xls file has been placed in 
the ‘My Documents’ 
directory. 

Move Excel (.xls) files to locations 
with shorter paths (fewer subfolders), 
or rename files with shorter names. 

Unzipping a folder to a location 
within several folders could exceed 
maximum path character limits, 
preventing deeper files from being 
unzipped. There may be a warning 
that the files cannot be unzipped or 
the windows may simply close, 
making it look like they were all 
unzipped. It may be best to unzip 
files directly to the C drive with full 
administrative rights. 

The SCS900 report 
utility .xls file does not 
work.  

An error message says 
that there is a mismatch 
in data when the report 
is opened. 

Note: If the Import 
Record.xls is opened 
directly in Excel, there 
is a no warning until 
you click Import 

Record. 

Note: The number of the 
cause corresponds to the 
number of the solution. 

1. The -Report.txt and  
-Record.txt files are not 
both present or in the 
proper format. 

2. Language settings do 
not match in the 
operating system's 
regional settings, Trimble 
Business Center, 
Microsoft Office, and the 
SCS Report Utility file. 

3. The synchronizer root 
folder is not set to the 
correct folder in the 
Options dialog.  

4. The user does not have 
privileges to the folder. 

5. The Report Utility file 
is a different version from 

1. Ensure that both the -Report.txt 
and  
-Record.txt are present and in the 
proper format in the data 
synchronization area's Output folder. 

2. Ensure that language settings 
match in the operating system's 
regional settings, Trimble Business 
Center, Microsoft Office (apply a 
language pack if necessary), and the 
SCS report utility file. 

3. In this program, select Tools > 
Options. Click SCS and then File 
Locations in the left pane. Click the 

 icon and navigate to the folder in 
which SCS installed the SCS Report 
Utility.xls file. 

4. If the security level is changed in 
Excel, then a new Excel program 
needs to be started for the macro to 
work. To change the security level in 
Excel, open Tools > Options > 
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the one used on the site 
controller. 

Security > Macro Security, and 
set the Security Level to Low (or add 
to the Trusted Publishers list). The 
macro can then be disabled when the 
report utility is opened. 

5. Find and use, or create, a report 
utility file of the same version as the 
one used on the site controller. The 
utility maker is on the SCS 
installation CD. 

The program appears to 
freeze when trying to 
e-mail SCS files. 

If you are running the 
program on a secondary 
monitor, and you attempt 
to e-mail SCS files using 
the Compress/E-mail 
SCS Files command, your 
e-mail program may open 
a dialog confirming the 
operation out of either 
monitor’s visible range. 
The dialog will be located 
off of the primary 
monitor, in the space 
opposite the secondary 
monitor, causing the 
program to appear frozen. 

To reach the dialog and confirm the 
e-mail operation, right-click the 
e-mail application’s name on the 
Windows taskbar and select Move. 
Then, press the appropriate arrow 
key to move the dialog into your 
primary’s monitor’s visible range. 

Label text in the Work 
Order Viewer's 
coverage map is blurry. 

In Windows display 
properties, effects are set 
to Clear Type. 

Smooth the edges of the screen fonts 
in the viewer. Right-click on your 
Windows desktop and select 
Properties from the context menu. In 
the Display Properties dialog, click 
the Appearance tab and click 
Effects. In the Effects dialog, select 
Standard in the second drop-down 
list. 

You receive a message 
that your e-mail 
program is not 
supported when you try 
to e-mail SCS files. 

Note: The number of the 
cause corresponds to the 
number of the solution. 

1.This command requires 
Microsoft® Outlook® to 
work. Other email 
programs may work, but 
are not guaranteed. 
Web-based email 
programs, such as 
Microsoft Hotmail, 
Yahoo®Mail or 

1. If your email program is not 
supported, create the compressed file, 
save it, open your email program, 
attach the file to a message, and send 
it. 

2. Download the Outlook CDO 
(Collaboration Data Objects) file to 
fix the problem: 
http://www.microsoft.com/downloa
ds/details.aspx?FamilyId=2714320D-
C997-4DE1-986F-24F081725D36&di
splaylang=en#QuickInfoContainer 

http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
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Google®Gmail™, will not 
work. 

2. If you do have 
Outlook, it may be 
missing a component file. 

http://www.microsoft.com/downloa
ds/details.aspx?FamilyId=2714320D-
C997-4DE1-986F-24F081725D36&di
splaylang=en#QuickInfoContainer 
For Microsoft Outlook 2003, install 
the CDO file from the original 
program CD. 

 
 

View Construction Data in Project Explorer 
Icons in the Project Explorer show the type of each object in the hierarchy. Many of the 
construction icons also indicate the state of the object. Unsynchronized objects are 
those in conflict with data in the data synchronization area. They are denoted by the 

 icon. 

Icons in the Project Explorer  

 A project 

 A point 

 A coordinate of a point 

 A surface 

 A surface contour 

 An alignment 

 A synchronized site 

 An unsynchronized site 

 A site with an unsynchronized design 

 A design 

 An unsynchronized design 

 An external design 

 An unsynchronized external design 

 An unstarted work order 

 An in-progress work order 

 A work order with field operations complete 

 A completed work order 

 An archived work order 

 A work order (any state) with imported results 

 A boundary 

Related topics 

 Project Explorer (on page 7) 

http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
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 Resolve a Conflict in a Model (see "Resolve a Conflict in Design Models" on page 
402) 

 Resolve a Conflict in Site Calibrations (on page 390) 
 Resolve a Conflict in Background Maps (on page 392) 
 Resolve a Conflict in Control Points (on page 391) 
 Resolve a Conflict in Foreground Maps (on page 404) 
 Resolve a Conflict in Site Settings (on page 388) 
 Resolve a Conflict in Stakeout Points (on page 403) 
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C H A P T E R  1 6  

Run Reports 

Run an Alignment Geometry Report 
Generate an Alignment Geometry Report to see a simple summary or detailed listing of 
the geometry of an alignment in your project. You can choose to report on just the 
horizontal component or both the horizontal and vertical components of alignments. If 
you have specified station equations, they will be reported as well. 

To run an Alignment Geometry Report:  

1. Select Reports > Alignment Geometry Report. The Alignment Geometry Report 
command pane displays. 

2. Select an alignment in the Alignment list. 

3. Click OK. The Alignment Geometry Report displays in your default Web browser. 

To customize the report:   

1. Do one of the following: 

 Click the  icon on the Alignment Geometry Report command pane's toolbar. 

 Select Reports > Report Options.  

The Report Options command pane displays. 

2. Select Alignment Geometry Report in the list. 

3. Expand sections and specify output settings in the Settings group as needed. 

4. Click Apply if you want to customize additional reports, or OK to close the 
command pane. 

Tip: You can also change the abbreviations used for horizontal and vertical 
alignment classifications in the Alignment Geometry Report. Select Project > 
Project Settings, and click Abbreviations in the left pane. Edit any of the 
abbreviations in the right column and click OK. Rerun the report to see your 
changes. 
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Related topics 

 Create an Alignment (see "Understanding Alignments" on page 286) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Run an Earthwork Report 
Use the Earthwork Report to calculate volumes based on a single surface, or the 
comparison of two surfaces. 

To generate a volume report:  

1. Do one of the following: 

 Click the  icon on the toolbar. 

 Select Reports > Earthwork Report.  

The Earthwork Report command pane displays. 

2. Select the option for the type of surface report you want to generate in the Report 
type group. Options in the steps below will vary based on the report type you 
select. 

3. Select the surface you want to report on, or the first surface to compare, in the 
Surface list. The classification for the surface displays below the box. 

4. Select the second surface to compare in the Final list, if applicable. 

5. Pick a point in a graphic view, right-click for options, or type a value in the 
Elevation box, if applicable. 

6. Pick lines to define the perimeter in the Boundary box, or click Options for more 
selection methods. 

7. To account for materials in the calculations, check Use in calculation in the Materials 
group. 

Note: Before using this option, you need to have defined surface materials in the 
Define Materials dialog. 

8. Select the material at the site in the Native list. 

9. Select the material that will be brought to the site in the Borrow list. 

10. Select a type in the Volume Breakdown group, specifying a value by picking in the 
graphics window or typing a value, if necessary. 

11. Click OK. The report displays in your default Internet browser. 

Related topics 

 Define Materials for Earthwork Reports (on page 351) 
 Earthwork Report Options (on page 354) 
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 Understanding Earthwork Volume Calculations (on page 349) 
 

Run an Import Report 
Generate an Import Report to see a project summary, details on imported files, and any 
associated errors or warning messages. 

To run an Import Report:  

 Select Reports > Import Report. 

 Select Reports > Report Options. Select Import Report in the command pane, and 
click OK. 

The Import Report displays in your default Web browser. 

Tip: Click a file name in the report to jump to the creation and import dates and times. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Run a Mean Angle Report 

SURVEY  

Run a Mean Angle Report to view details of how each mean angle was computed. 

To run a Mean Angle Report:  

 Select Reports > Mean Angle Report. 

 Right-click a mean angle node icon  in Project Explorer and select Mean 
Angle Report from the context menu. 

 Click the Report button in the Mean Angle Residuals dialog. 

The Mean Angle Report displays in your default Web browser. 

Note: In the Mean Angle Report, all angles are normalized to the range of 0 to 360 
degrees expressed in project units. All distances are displayed in project units. 

The Mean Angle Report includes a separate table for each mean angle in the project. At 
the top of each table, the point ID, station ID, and backsight ID are displayed. Beneath 
that, the table includes a row of information for each enabled observation used to 
compute the mean angle. Information includes observed readings and residual values 
for the horizontal angle, vertical angle, and slope distance. The last row in the table 
displays the computed horizontal angle, vertical angle, and slope distance for the mean 
angle point. 
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Tip: Click any point in the report to select it in the Project Explorer and graphical and 
spreadsheet views, and display its properties in the Properties pane. 

Related topics 

 Understanding Total Station Data (on page 233) 
 Workflow for Total Station Data (on page 238) 
 View Total Station Data in Project Explorer (on page 240) 
 View and Edit Mean Angle Residuals (on page 248) 

 

Run a Point Derivation Report 
Generate a Point Derivation Report to see details on the survey data used to calculate the 
final coordinates of points in your project. 

To run a Point Derivation Report:  

 Select Reports > Point Derivation Report. 

 Select Reports > Report Options. Select Point Derivation Report in the command 
pane, and click OK. 

The Point Derivation Report displays in your default Web browser. 

Tip: Click a point ID or coordinate in the report to select the point in graphic views and 
the Project Explorer. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Run a Point List Report 
Generate a Point List to see a simple summary of the coordinates for each point in your 
project. 

To run a Point List report:  

 Select Reports > Point List.  

The Point List displays in your default Web browser. 
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To modify the report:   

 Select Reports > Report Options. Select Point List in the command pane, and click 
OK. 

 In the Settings group at the bottom of the command pane, you can specify the type 
of coordinates (grid, local, or global), and the type of data to display.  The data 
options include quality control information such as scale factors and convergence 
angle.  

Tip: Click a point ID in the report to select the point in graphic views and the Project 
Explorer.  

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Run a Project Computation Report 
Generate a computation report to see a summary of the errors and warnings that 
occurred during the last computation of your project data. 

To run a Project Computation Report:  

 Select Reports > Project Computation Report. The Project Computation Report 
displays in your default Web browser. 

To customize the report:   

1. Select Reports > Report Options. The Report Options command pane displays.  

2. Select Project Computation Report in the list.  

3. Expand sections and specify output settings in the Settings group as needed.  

4. Click Apply if you want to customize additional reports, or OK to close the 
command pane. 

Related topics 

 Project Computations (on page 157) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Run a Renamed Point List 
Generate a Renamed Point List to see a simple summary of the original and new names 
of points that you have renamed in your project. 

1. Select Reports > Report Options. The Report Options command pane displays. 

2. Select Renamed Point List in the Reports list. 

3. Edit options in the Settings group as needed. 
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4. Click the  icon on the pane's toolbar. The Renamed Point List displays in your 
default web browser. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Run a Site Calibration Report 
After you calibrate a site, generate a Site Calibration Report to see details on the local site 
settings, horizontal and vertical calibration parameters, and residual differences 
between GNSS and grid points in your project. 

To run a Site Calibration Report:  

 Select Reports > Site Calibration Report. 

The Site Calibration Report displays in your default Web browser. 

To modify the report:   

 Select Reports > Report Options. Select Site Calibration Report in the command 
pane, and click OK. 

In the Settings group at the bottom of the command pane, you can specify the 
header and footer data to display.   

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 

Run a Surface Report 
Run a surface report to see surface measurements and limits, as well as the number of 
triangles, vertices, and other items in a surface in your project. 

To generate a surface report:  

1. Do one of the following: 

 Select Reports > Surface Information Report. 

 Click the  icon. 

 The Surface Information Report command pane displays. 

2. Select the surface you want to generate a report for in the Surface list.  

3. Click OK. The report displays in your default Web browser. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
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Run a Work Order Report or Summary 

HEAVY CONSTRUCTION  

Run reports to check the status of all your work orders and individual work order 
results. The Work Order Summary lists basics on each of the work orders in your project, 
including the assigned controller, task, status, priority, and due date. The Work Order 
Report provides details on base, design, difference, and alignment data from the field, as 
well as tolerances in the original work order. 

To run a summary of work orders:  

1. Do one of the following: 

 Select SCS > Work Orders Summary. 

 Click the  icon on the toolbar. 

 Right-click Work Orders in the Project Explorer, and select Work Orders Summary 
from the context menu. 

The Work Orders Summary displays. 

2. Review the work orders in your project, clicking any column heading to sort the 
list based on that column.  

Note: "?" indicates that no value was specified. 

3. Click Close. 

To f i lter the Work Orders Summary:  

Click the  icon at the top of a column to select a filter from a list. The icon changes 
color when a filter is active. The options are: 
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 All – This displays all items of the column's type and removes any other filter 
applied. 

 Blanks – This displays all rows with a blank in the column. 

 Custom – Use this to create a custom filter, (e.g. to show all work orders due within 
the next 3 days). 

 NonBlanks – This displays all rows that do not have a blank in the column. 

 <specific item> - This displays all rows with the specific name in the column. This 
filter choice allows you to display all rows pertaining to a specific work order, site, 
design, task, etc. 

To run a report on a specif ic work order:  

Select  a work order that has an  icon in the Project Explorer, and do one of the 
following: 

 Right-click and select Work Order Report from the context menu. 

 Select SCS > Work Order Report. 

 Click the  icon on the toolbar. 

The Work Order Report displays in your spreadsheet application. 

Note: If the spreadsheet does not display, the required template is missing or in the 
wrong location. The template is installed during the site controller software (SCS) 
installation. If the report template cannot be found, you can set the path to it by 
selecting Tools > Options. Then click SCS and File locations. 
Note: The Work Order Report does not show work order results. 
Tip: In the report spreadsheet, click the Report tab to view the Report file. For more 
information about these files, see the documentation for SCS. 

Related topics 

 Import Work Order Results (on page 422) 
 Customize and Run a Report (see "Customize a Report" on page 436) 

 

Customize a Report 
Use report options to customize your reports. The settings you specify are saved so that 
output remains consistent each time you run a certain report. The Report Options 
command pane lists all the available reports. For some software modules, the Earthwork 
Report is available from the Reports menu. All reports are displayed in your default 
Web browser. 
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To customize a report:  

You can customize the report layout as desired, selecting what to show in the header, 
footer, report settings and report sections. 

1. Select Reports > Report Options. The Report Options command pane displays.  

2. Select the report in the Reports list. 

3. To view the settings for a report, click the  icons to expand sections in the 
Settings group. Click in boxes, and change options as needed. 

Tip: To access commonly-used reports from the Reports menu, set the Show on 
Reports menu option to Yes. 

4. Click OK. 

To run a report:  

1. Do one of the following: 

 Select Reports > (report name). The report displays in your default Web 
browser. 

 Select Reports > Report Options if you want to review the report settings. 
The Report Options dialog displays. 

2. Select the report in the Reports list. 

3. Click the  icon on the command pane toolbar. The report displays in your 
default Web browser. 

4. Click OK to close the dialog. 

Note: Reports are not saved automatically. To save a report, select File > Save as 
in your Web browser. 

Related topics 

 Report Options (on page 438) 
 Run a Job File Report 

 

Report View 
The Report View displays when you run certain reports. Along with the content of the 
report, the view includes a toolbar located along the top of the tab that allows you to: 
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 Navigate to a specific page in the report 

 View and change the print setup information 

 View the print layout and print the report 

 Export the report to a spreadsheet or PDF document 

 Select a magnification to view the report 

 Search for text in the report 

Related topics 

 Tabbed View Arrangement (on page 34) 
 

Report Options 
Use these common options to customize report output. They are available in the Report 
Options command pane. Specific reports have additional options as well.  For a 
description of any setting, click the name of the setting. The description appears in the 
information box at the bottom of the command pane. 
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Sett ings 

Column display /  

Column selection 

Select which data types to show in the report by setting 
individual columns to Show or Hide. 

Coordinate type Select whether to show global, local, or grid coordinates in 
the report. 

This is for the Point List. 
Footer Select whether to show the date, project name, and 

application name by selecting Show or Hide for each. 
Format options Select from summary or detailed formats. 

Header Select whether to show company, project, user, and 
coordinate system data by selecting Show or Hide for each. 

Report sections /  

Sections 

Select which data types to show in the report by setting 
individual sections to Show or Hide. 

Report setting Set the number of legs in loops, as well as PPM and delta 
criteria for Loop Closure Results. 

Residual plot Separate systems - Select this to combine all satellite 
residual data into a single graph. 

Individual satellites - Select this to plot separate graphs of 
each satellite's residuals. 

This is for the detailed Baseline Processing Report. 
Run-time display Never - Select this to prevent the report from displaying 

when it is generated (for example, during import); display it 
only when selected from the menu or the Report Options 
command pane. 

Show when warnings or errors are present - Select this to 
display the report when it is generated if errors or warnings 
occur (for example, during import). 

Prompt - Select this to display a prompt when the report is 
generated to ask if you want it to display. 

Prompt on warnings or errors - Select this to display a 
prompt if errors or warnings are present when the report is 
generated. 

Always - Select this to always display the report when it is 
generated. 
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Save intermediate data Select whether to include intermediate data in the report. 

Show on Reports menu No - Select this to remove the report from the Reports menu 

Yes - Select this to re-add the report to the menu. 

Related topics 

 Customize and Run a Report (see "Customize a Report" on page 436) 
 Run a Job File Report 
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Export Data 

Export Data 
Export data from your project in a variety of formats. See the individual file format 
topics for details. 

To export data:  

1. Do one of the following: 

 Select File > Export. 

 Click the  icon on the toolbar. 

The Export command pane displays. 

2. Click an export type (Survey, CAD, Custom, or Construction) in the File Format group. 
A list of available exporters displays. 

3. Select an export format in the list. If one with the desired format is not listed, 
create a custom exporter. 

Caution: If you have a field device connected, only file types compatible with the 
device appear. 

4. If needed, use the View Filter (see "Filter a View" on page 76) command to filter 
the selectable data in the plan view. 

5. Select the data to export using one of the Selection Options (see "Selection Methods 
and Options" on page 43). 

6. Select a folder in the File Name list, or click the  icon to browse for a folder.  

When you click the  icon, the Save As dialog displays with the export folder 
specified in Tools > Options > File Location selected. However, you can browse to and 
select a different folder. 

7. Type a new file name in the File Name box if you do not want to overwrite an 
existing file. 
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8. If export settings appear in the Settings group, specify them as needed. 

9. Click OK to export the data. 

Tip: You can select data before you begin the Export command. 
Tip: To customize the format of the exported data, select File > Export Format Editor. 

Related topics 

 Export Format Editor 
 Export Data Formats 

 

Export and Upload Data Formats 

HEAVY CONSTRUCTION  

The Export command and data synchronization functions for sites, designs and work 
orders enable you to send the following types of data out from your project. See 
file-specific topics for details. 

Fi le format Data type 

.csv, .pts ASCII (see "Export ASCII Files" on page 443) point files 

.dc Trimble data collector (see "Export Trimble Data Collector Files 
(.dc)" on page 448) files 

.dxf, .dwg CAD (see "Export CAD Files (.dxf/.dwg)" on page 444) files 

.ini site settings files 

.pro Terramodel project files 

.ttm Trimble terrain model (see "Export Trimble Surface Files (.ttm)" 
on page 448) surface files 

.txt SCS work order report and record files 

.xml LandXML (see "Export LandXML Files (.xml)" on page 445) files 

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 

Export Related Files 
You can specify which additional related files (for example,  geoid files or datum grid 
files) to automatically export with a JOB file when you are exporting to a field device 
either directly (the device is connected) or indirectly (the files will be stored for upload 
at a later date).  
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To specify related f i les to export to a f ield device: 

1. Select View > Command Pane. The Command Pane displays. 

2. In the Command Pane, select Related Files. The Related Files command pane 
displays. 

If there are files that are required for the project (for example, a coordinate system 
file specified in the Project Settings dialog), they are displayed in the File Name list 
with a gray background.  

3. Click in the first empty File Name box, and then either type the path and name of 
the related file or click  to select the file. 

4. Click in the Application box and select the associated device application (or <All> or 
<None>) from the drop-down list.  

5. Repeat steps 3 and 4 for each additional related file and its associated device you 
want to specify. 

6. In the Upload with export list, select to upload all files, just the files required for the 
project, or no files. 

7. Select the Copy files to project folder box if you want to copy the files specified in the 
list to the project folder at the time of export. 

The file referenced in the list is not changed. If the file already exists in the project 
folder, it is overwritten so that the project folder contains the same version that 
was uploaded to the device.  

8. If there is a currently active device, it is displayed in the Active Device box. Click the 
Upload Files Now button to upload the selected related files to the device. 

9. When you are done, click OK. 

The related files you specified will be automatically uploaded with the JOB file 
when you perform an upload to a device. 

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 
 

Export ASCII Files 
Export ASCII files (.asc, .csv, .txt,) that can be used in a variety of other applications 
and field devices, including: 
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 Spectra Precision® Field Surveyor 

 TDS Survey ProTM 

 Nikon NEH 

 Trimble® Survey ManagerTM 

 Trimble® Survey ControllerTM 

 Trimble® Digital FieldbookTM (v2,v3, and v5) 

Click the Custom tab in the Export command pane to access the ASCII exporters. Click 
the Survey tab to export a trajectory as a .csv file. You can set various unit and format 
options for trajectory export in the Settings group. 

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 

Export CAD Files (.dxf/.dwg) 
Select and export some or all of the data in your project to a CAD file. This can be used 
as a background map in field devices. 

Note: You can also upload .bmp, .gif, .jpg, .png, and .tif formats to use as background 
maps in TDS Survey Pro, Trimble Survey Manager, and Spectra Precision® Field 
Surveyor. 

Click the CAD tab in the Export command pane to access the .dxf and .dwg exporters. 
You can set the file version and an explode option in the Settings group. 

Exported CAD files can be used in: 

 Spectra Precision® Field Surveyor 

 Trimble® Survey ControllerTM 

 Trimble® Digital FieldbookTM (v2,v3, and v5) 

 TDS Survey ProTM (as base maps) 

 Trimble® Survey ManagerTM 

Note: By default, a point ID exports as an attribute of the point.  
Note: The .dwg format does not support all alignment information, such as stationing. 
If you export an alignment as a .dwg and then import it into another application as a 
.dxf/.dwg, vertical alignments in the file may not appear either. 

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 
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Export Geodatabase Files (.xml) 
Export feature data contained in your project to a geodatabase XML file from which 
the data can be imported into an Environmental Systems Research Institute, Inc. 
(ESRI) geographic information system (GIS). 

Click the GIS tab in the Export command pane to access the Geodatabase XML exporter.  

Note: The geodatabase XML format represents ESRI's most current open mechanism 
for information interchange between geodatabases and other external systems and is a 
replacement for the earlier shapefile (.shp) spatial data format.  

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 

Export LandXML Files (.xml) 
Export alignments, cross-sections, and surfaces using the LandXML file format. 

To export LandXML data: 

1. Select File > Export. The Export dialog displays. 

2. Click the Construction tab and then select LandXML exporter in the File Format group. 

3. Click in the Selected entities box.  

4. In a graphic view, pick the objects you want to include in the export, or click 
Options and choose a selection option in the list. 

5. If you want to clip a surface that you are exporting, select a boundary in the Surface 
clipping boundary list, or select <New> to create one. 

6. Type a path and file name for the exported file in the File Name box, or click the  
icon to browse for a location and specify a file name. 

7. In the Settings group, set export properties. 

8. Click Export. 

Related topics 

 LandXML Export Options (on page 445) 
 Results of Exporting LandXML Files (on page 446) 

 

LandXML Export Options 

Use these options to specify how to handle surfaces definitions and duplicate points 
when you export LandXML files. They are available in the LandXML Export command 
pane. 
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Options 

Surface 
description 

Optimize for data - Select this to let the program choose the best 
export method (of the two below).  

If the surface you have selected for export contains any internal data 
(surface was imported in a TTM or LandXML file), it will export as 
triangles. 

If the surface only references external data (surface was created 
entirely in this program), it will export as points and breaklines. 

Note: If you are exporting a portion of a surface that is clipped by a 
boundary, all data in the clipped portion is made internal. 

Points and breaklines - Select this to export the surface, as well as the 
points, breaklines, contours, and boundaries used to create the surface.

Triangles - Select this when you only want to export the triangles 
defining the surface. This option also handles holes and islands in the 
data. 

Note: This setting has no effect if the file does not contain surfaces. 

Duplicate point IDs Always ask - Select to automatically check for points with the same 
Point ID. If any are found, you are prompted to import all duplicates, 
ignore all duplicates, or cancel the import. 

Export all - Select to have all points export, including those with 
duplicate Point IDs. 

Ignore all - Select to have only points without duplicate Point IDs 
export. 

Note: This setting has no effect if the file does not contain points. 

Related topics 

 Export LandXML Files (.xml) (on page 445) 
 Results of Exporting LandXML Files (on page 446) 

 

Results of Exporting LandXML Files 

When you export LandXML files, the points, alignments, and surfaces are handled in 
specific ways. 



Trimble® Business Center 
Heavy Construction Edition User Guide 447 

 Export Data

Exported Results 

Points When points are exported: 

 The point name or number is used in the "name" field. 

 Any valid feature codes are used in the "desc" fields. 

 For invalid feature codes, “*” is used. 

 The “LandXML.desc” attribute of the first “LandXML feature” is 
used for the “desc” attribute, and the “LandXML.code” attribute 
of the first “LandXML feature is used for the “code” attribute if 
they exist. Otherwise no “desc” or “code” attributes are written. 

Alignments When alignments are exported: 

 The data defining the alignment is written as an alignment in 
the LandXML file. 

 Both horizontal and vertical components are retained. Multiple 
vertical alignments can be exported with each horizontal. 

Surfaces When surfaces are exported: 

 Either the source data or the definition is used, but not both. 

 Points influencing the surface are saved as points. 

 3D polylines, breaklines, and sloping lines influencing the 
surface are saved as breakline or contour point lists, depending 
whether they are pure 3D or 2D+elevation. 

 Internal breaklines are retained. 

Related topics 

 Export LandXML Files (.xml) (on page 445) 
 LandXML Export Options (on page 445) 
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Export Trimble Data Collector Files (.dc) 
Export points and coordinate system only data as .dc files. Click the Survey tab in the 
Export command pane to access the .dc exporter. You can set the file version, units, and 
output format in the Settings group. 

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 

Export Trimble Surface Files (.ttm) 
Export triangulated terrain models (.ttm) to use in: 

 Trimble® Survey ControllerTM 

 Trimble® Digital FieldbookTM (v2,v3, and v5) 

Click the Construction tab in the Export command pane to access the .ttm exporter. 

Related topics 

 Export Data (on page 441) 
 Export Data in a Custom Format (on page 448) 

 

Export Data in a Custom Format 
Use the Export Format Editor to create a custom converter to export your custom format. 
The converters created with this editor are used within the Export (see "Export Data" 
on page 441) command to export ASCII files with a non-standard format.  

To export a custom format:  

1. Do one of the following: 

 Select File > Export Format Editor. 

 In the Export dialog, click the  icon. 

The Export Format Editor opens and displays the Select Definition (see "Definition 
Options" on page 449) dialog. 

2. Select a custom format in the definition list. 

3. Click Next and select options in the Description and Search Type (see "Description 
and Search Type Options" on page 450) dialog. 

4. Click Next and select options in the General Properties (see "General Properties 
Options" on page 212) dialog. 

5. Click Next and select options in the Fields (see "Fields Options" on page 451) 
dialog. 
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6. Click Finish to create the exporter file. 

You can create a custom converter to export any of the following: 

 Delimited files - data is separated by a specific character. 

 Fixed-width files - data is separated into defined columns. 

 Files where data location is defined by a beginning and/or ending string of text. 

To test a custom format exporter:  

1. Select a custom format in the definition list. 

2. Click Test in any of the four Export Format Editor dialogs. The dialog expands. 

3. Click Read File and select the number of lines you want the exporter to read. If you 
select View File, it will open in a text editor. 

4. Click the  icon and navigate to the type of file you want to export. The exporter 
will read the file and highlight any values that it is unable to convert. 

Note: The file must have the same file extension as the exporter you chose. 

5. Select a different exporter or edit the file to accommodate the reported errors. 

Related commands 

 Definition Options (on page 449) 
 Description and Search Type Options (on page 450) 
 General Properties Options (on page 451) 
 Fields Options (on page 451) 
 Export Data Formats 
 Selection Methods and Options (on page 43) 

 

Definition Options 

Use these options to create new export format definitions. These buttons appear to the 
right of the list of definitions on the first dialog of the Export Format Editor. 
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Options 

New Click this to enter a new definition name in the list. A unique name is 
required; a descriptive name is recommended. Click any other definition 
row to finish.  

Click Next to enter a description and search type (see "Description and 
Search Type Options" on page 450). 

Copy After you click on a description (listing on left), click Copy to enter a 
definition name. A unique name is required; a descriptive name is 
recommended. Click OK to return. 

Click Next to enter a description and search type (see "Description and 
Search Type Options" on page 450). 

Rename Select the name of one of the custom formats you have created, and click 
this to edit the name. 

Delete After you click on a description (listing on left), click this to remove the 
definition from the list. 

Note: To remove a description as an export option, you can click the Enable checkbox 
until no green check appears. These descriptions will not appear as export options. If 
you do not want to display these disabled descriptions on this page, enable Only show 
enabled definitions at the bottom left of the dialog box.  

Related topics 

 Description and Search Type Options (on page 450) 
 General Properties Options (on page 451) 
 Fields Options (on page 451) 
 Export Data in a Custom Format (on page 448) 

 

Description and Search Type Options 

Use these options to define the type of custom exporter you want to create, and add a 
description. They are available in the second dialog of the Export Format Editor. 

Options 

Description Enter a descriptive string to describe this exporter (optional). 

Type Select one of the following options:  

Delimited - this creates a file of data that is separated by a specific 
character. 

Fixed Width - this creates a file of data that is in pre-defined 
columns. 

Search for Text - this creates a file of data that begins and ends 
with a text string. 

Related topics 

 Definition Options (on page 449) 
 General Properties Options (on page 451) 
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 Fields Options (on page 451) 
 Export Data in a Custom Format (on page 448) 

 

General Properties Options 

Use these options to define how you want the file delimited and saved, and the data 
stored. They are available in the third dialog of the Export Format Editor. 

Options 

Delimiter From the drop-down list, select the character that is to 
separate the fields. If you select <other>, you must specify 
the required character.   
This can be one of the following: _ ) ( * & ^ % $ # @ ! ~ `   

Default extension 
(recommended) 

Enter the default extension for the export format.  The 
export analyzer uses this extension to help it decide what 
conversion options to offer the user in the context 
menu.  This field is optional.  If left blank, a default 
extension of ".txt" is assumed. 

Text qualifier (optional) Enter a special character to identify the beginning and 
ending of the string.  

Decimal separator Select a decimal separator if necessary.  USA standard uses 
a point to separate the fractional number from the whole 
number; some areas in Europe use a comma as standard. 

 Related topics 

 Definition Options (on page 449) 
 Description and Search Type Options (on page 450) 
 Fields Options (on page 451) 
 Export Data in a Custom Format (on page 448) 

 

Fields Options 

Use these options to define the fields that you want to export, and their field order, and 
units. The options vary slightly based on the type of converter you are creating. They 
are available in the fourth dialog of the Export Format Editor. 
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Options 

Fields Click Fields to display a drop-down list of data properties.  Select one 
and a tag appears as a field in the row of data.  Continue to select all 
the fields that you want to export. 

Note: If you select the properties out of order, you can click and drag 
them into the proper order. 

Units 
Apply to all 

To select the distance units for all data, select the units and enable 
the Apply to all check box.  You can also disable the Apply to all 
check box, and select a unit for each exported field.   

For Fixed Width 
(only) 

Click on each field, and enter a Start and End value or a Start and 
Width value - the third value will be filled in automatically. 

For Add Text (only) Click on each field, and enter values with which to Start and End 
the field. 

Note: Spaces will not be visible in the Start and End fields, but you 
can see them in the Preview area. 

Test 

Preview 

Click Test to open the testing display area.  If there is selected point 
data, click Preview to see the format that the exporter would create. 
You can continue to modify the format setting and preview the 
results until you are satisfied. 

Note: If you have no data selected, click Finish to exit the Export 
Format Editor command, and save the exporter that you are 
creating.  Then select some points and start the Export Format Editor 
again.  

Related topics 

 Definition Options (on page 449) 
 Description and Search Type Options (on page 450) 
 General Properties Options (on page 451) 
 Export Data in a Custom Format (on page 448) 
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Troubleshoot Issues 

Troubleshoot a Coordinate System Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

You cannot 
create or edit 
coordinate 
systems, or save 
sites. 

You are running as a 
Limited User 
(non-administrator). 
Limited users do not 
have “write” 
permissions for the 
current.csd file, 
which means that you 
cannot create or edit 
coordinate systems, or 
save sites. 

You must be granted “write” permissions for 
the current.csd file by an administrator. The 
location of that file depends on your operating 
system: 

 In Windows® XP or earlier: C:\Documents 
and Settings\All Users\Application 
Data\Trimble\GeoData or C:\Program 
Files\Common Files\Trimble\GeoData. 

 In Windows VistaTM: 
C:\ProgramData\Trimble\GeoData or 
C:\Program Files\Common 
Files\Trimble\GeoData. 

Note: This may be a non-issue if other Trimble 
software has been previously installed, and 
access rights have been resolved. 
Note: If you do not see the Application Data 
folder at the path listed above, it may be 
hidden. To show hidden folders, in Windows® 
Explorer, select Tools > Folder Options. 
Click the View tab and select Show hidden files 
and folders in Advanced Settings. Then click 
OK. 

 
 

Troubleshoot a Data Transfer/Synchronization Problem 
Before calling Support, use any applicable solutions to known issues below. 
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Symptom Possible Cause Solution 

Active Sync 4.5 will not 
run. 

You are running as a 
limited user. Active Sync 
4.5 is not compatible 
with limited user 
accounts. 

Change you permissions to the 
administrator level, or download and 
use Active Sync 4.0. 

Start > Control Panel > User 
Accounts > User Accounts. In 
the User Accounts dialog, select your 
user name in the list and click 
Properties. In the Properties dialog, 
click the Group Membership tab. 
Select Other, and Administrators in 
the list. Click OK twice to close the 
dialogs. 

 
 

Troubleshoot a Layer or View Filter Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

The graphic view 
redraws slowly 
when you make 
changes to view 
filters. 

Your project 
contains a lot of data, 
and your computer's 
graphics memory is 
running at capacity. 

Click the  icon on the View Filter 
Manager's toolbar to open the Advanced View 
Filter Settings dialog. When you make 
changes to view filters in this dialog, the 
graphic view does not automatically redraw. 
You can click Apply at any time to have the 
view redraw. 

or 

Select Project > Project Settings. Click 
View and then View Filters in the left pane, 
and select a default view filter other than All 
so that graphic views refresh more quickly. 

The points on a 
layer are not visible, 
even though you 
have the layer's box 
checked in the View 
Filter Manager to 
make it visible. 

The Point box in the 
Raw Data group is 
not checked. 

Make sure that the boxes for both the points 
and the layer that the points are on are 
checked, making them visible in the view.  

Some of the 
selection sets you 
created do not 
appear in the View 
Filter Manager's 
selection sets list. 

The missing 
selection sets that do 
not contain any 
visible objects. 

None. Selection sets can contain objects that 
have no visible display, such as coordinates. In 
the Selection Explorer, all selection sets are 
available. In the View Filter Manager, 
however, only selection sets that contain at 
least one visible object are available. 
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Related topics 

 Create a View Filter (on page 73) 
 Edit a View Filter (on page 75) 
 Filter a View (on page 76) 
 View Filter Options (see "View Filter Manager Options" on page 79) 
 Advanced View Filter Options (on page 81) 

 

Troubleshoot an Import Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

Duplicate points were 
created for points in an 
imported text file and 
points already in the 
project that have the 
same ID (that is, points 
were not merged as 
expected). 

If you import a text file with 
"Unknown" or “Mapping” 
coordinate quality into a 
project that already contains 
point data, duplicate points 
will be created for points in 
the text file (lightweight 
points (see "Understanding 
Point Types" on page 269)) 
and points already in the 
project (normal points (see 
"Understanding Point Types" 
on page 269)) that have the 
same ID.  

Import the text file into the 
project first to create the 
lightweight points, then import 
the other point data. The 
lightweight points from the text 
file will merge with the normal 
points from the other point data 
to create normal non-duplicated 
points. 

 
 

Troubleshoot a Program Freeze 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

Program freezes 
when selecting 
many objects. 

The Properties pane is open. 
When you select many objects 
with the Properties pane open, it 
looks for the properties common 
to all of the objects, slowing the 
program down and making it 
look frozen. 

Close the program. If you have 
trouble reopening the project, 
check the directory where the 
.vce file is stored. If there is a lock 
(*,lk) file with the same name as 
the project, delete it and reopen 
the project. Close the Properties 
pane before reselecting the 
objects. 
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Program doesn't 
respond in the 
expected way; 
nothing seems to 
work. 

The mouse may be set to a mode 
other than Select. 

Check your mouse mode on the 
Mouse toolbar. If needed, reset it 
to Select. 

The program 
freezes. 

Toolbars are corrupted. Consider contacting Technical 
Support. 

Otherwise, remove the 
application data folder located at 
C:\Documents and 
Settings\<user 
name>\Application 
Data\Trimble\Trimble Business 
Center\<version> 

Note: If you do not see the 
Application Data folder at the 
path listed above, it may be 
hidden. To show hidden folders, 
in Windows® Explorer, select 
Tools > Folder Options. Click 
the View tab and select Show 
hidden files and folders in 
Advanced Settings. Then click 
OK. 

The program 
appears to freeze 
when you float a 
pane or try to open 
a dialog. 

If you are running the program 
on a secondary monitor, and you 
float a pane or use a command 
that launches a dialog, the pane 
or dialog might appear out of 
either monitor’s visible range. It 
will be located off of the primary 
monitor, in the space opposite 
the secondary monitor, causing 
Trimble Business Center to 
appear ‘frozen’. 

To reach the dialog or pane, 
right-click the application’s name 
on the Windows Taskbar and 
select Move. Then, press the 
appropriate arrow key to move 
the dialog into your primary’s 
monitor’s visible range. 

Program appears to 
freeze when you 
are trying to e-mail 
SCS files. 

If you are running the program 
on a secondary monitor, and you 
attempt to e-mail SCS files using 
the Compress/E-mail SCS Files 
command, your e-mail program 
may open a dialog confirming the 
operation out of either monitor’s 
visible range. The dialog will be 
located off of the primary 
monitor, in the space opposite 
the secondary monitor, causing 
the program to appear ‘frozen’. 

To reach the dialog and confirm 
the e-mail operation, right-click 
the e-mail application’s name on 
the Windows Taskbar and select 
Move. Then, press the appropriate 
arrow key to move the dialog into 
your primary’s monitor’s visible 
range. 
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Troubleshoot a Project Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

You cannot reopen a 
.vce project file. 

The project file is locked, possibly due to a 
crash or an improper program shutdown. 

Improper shutdown includes when: 

 A project is open and the power to 
the computer is interrupted. 

 A project is open and the process is 
ended from Windows® Task Manager. 

Delete the lock (project 
name,lk) from the file 
project folder.  
The project will lose all 
changes made since the 
last save. 

 

 
 

Troubleshoot a Toolbar or Menu Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

Toolbars are not in 
the same language as 
the installation. 

The program was run in one 
language, and then reinstalled 
in a different language. 

Reset the toolbars to the reinstalled 
language by loading the default 
layout. 

Select Tools > Customize. In the 
Customize dialog, click Save/Load. 
In Default Layout, select Default 
Layout and click Load. Click OK in 
the New layout dialog. 

Some text in the 
user interface (the 
units on the Status 
bar for instance) is 
in a different 
language. 

This only occurs 
when opening 
project files that 
were created in a 
different language. 

The user interface text is 
being stored in the project 
file. 

There is no solution at this time. 
Newly created projects will not have 
the problem, but it will remain in 
the original project file. 

 
 

Troubleshoot a View or Selection Problem 
Before calling Support, use any applicable solutions to known issues below. 
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Symptom Possible Cause Solution 

The graphic view 
redraws slowly 
when you make 
changes to view 
filters, or when you 
change the size of 
panes. 

Your project contains a 
lot of data, and your 
computer's graphics 
memory is running at 
capacity. 

Click the  icon on the View Filter 
Manager's toolbar to open the Advanced 
Settings dialog. When you make changes 
to view filters in this dialog, the graphic 
view does not automatically redraw. You 
can click Apply at any time to have the 
view redraw. 

or 

Select Project > Project Settings. 
Click View and then View Filters in the left 
pane, and select a default view filter other 
than All so that graphic views refresh more 
quickly. 

The 3D view is 
replaced by a red X 
and this message: 

"The system has run 
out of graphics 
memory. Close any 
unnecessary 
windows and retry." 

The system has run out 
of graphics memory.  
(no screen saver 
interruption) 

 

1. Close any unneeded programs that are 
running,     especially ones that are 
graphics intensive. 

2. Close all 3D views, including those with 
a red X. 

3. Reopen the minimum number of 3D 
views you need. 

Long-term: Consider upgrading your 
graphics card. 

 

The 3D view is 
replaced by a red X 
and this message: 

"The system has run 
out of graphics 
memory. Close any 
unnecessary 
windows and retry." 

The screen saver came 
on and interrupted 
Microsoft® DirectX. 

 Close the 3D view and reopen it. 

 Close and reopen the program and the 
project. 

 Update to the latest version of DirectX. 

Some of the 
selection sets I 
created do not 
appear in the View 
Filter Manager's 
selection sets list. 

The missing selection 
sets that do not contain 
any visible objects. 

None. Selection sets can contain objects 
that have no visible display, such as 
coordinates. In the Selection Explorer, all 
selection sets are available. In the View 
Filter Manager, however, only selection 
sets that contain at least one visible object 
are available. 



Trimble® Business Center 
Heavy Construction Edition User Guide 459 

 Troubleshoot Issues

Your graphic views 
are pixilated or 
contain artifacts 
when you pan or 
rotate them. 

You are not using the 
optimal advanced 
display setting. 

Select Tools > Options. In the Options 
dialog, click Startup and Display in the left 
pane, and then click Advanced. Check the 
Override automatic detection box, and 
select the appropriate option for your 
operating system. 

Your mouse 
movements are 
delayed or track 
intermittently, even 
though you are 
using an advanced 
display setting (see 
above). 

Your graphics card is 
integrated into the 
motherboard, or is not 
sufficient for advanced 
display settings. 

Select Tools > Options. In the Options 
dialog, click Startup and Display in the left 
pane, and then click Advanced. Check the 
Override automatic detection box, and try 
each of these graphics display packages (in 
order, restarting the program between 
each): 

1. DirectX 

2. OpenGL 

3. GDI 

Your system suffers 
from generally poor 
graphics 
performance. 

Two system settings are 
not set to optimize the 
graphics display. 

Try the solution directly above first. If it 
does not improve your graphics 
performance, right-click on your Windows 
desktop, and select Properties from the 
context menu. In the Display Properties 
dialog, click the Settings tab, and select 
Medium (16 bit) in the Color quality list. 
Second, click the Advanced button in the 
same dialog. In the Plug and Play dialog, 
click the Troubleshoot tab, and set 
Hardware acceleration to Full. 

 
 

Troubleshoot an Import Problem 
Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

LandXML data imports 
in the wrong location or 
configuration. 

Project units are not set 
correctly. 

Check the units shown on the 
status bar. If they are not correct, 
undo the import. Then, click the 
units name to open the Project 
Settings dialog. Change to the 
correct type of units, and 
reimport the file. 

A LandXML file will not 
import. The program's 
importer says it is a 
LandXML file, but when 

The file is valid XML, but 
not valid LandXML. 

Open the file in your default Web 
browser. If it is corrupt, you will 
get an error message. If you do not 
get a message, it may be valid 
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you try to import it, a 
message says the file is 
invalid. 

XML, but not valid LandXML, in 
which case the file needs to be 
recreated in a valid LandXML 
format. 

Custom point data (.csv) 
imports at the wrong 
location. 

1. Your project units are not 
set correctly. 

2. The wrong custom 
import definition was 
selected; the northing and 
easting order are reversed. 

1. Make sure that your project 
units are set correctly. 

2. Check the custom import 
definition you used to import the 
points. If you accidentally 
selected the definition with the 
northing and easting reversed, 
undo the import and reimport 
with the correct definition. 

Duplicate points were 
created for points in an 
imported text file and 
points already in the 
project that have the 
same ID (that is, points 
were not merged as 
expected). 

If you import a text file with 
"Unknown" or “Mapping” 
coordinate quality into a 
project that already 
contains point data, 
duplicate points will be 
created for points in the text 
file (lightweight points (see 
"Understanding Point 
Types" on page 269)) and 
points already in the project 
(normal points (see 
"Understanding Point 
Types" on page 269)) that 
have the same ID.  

Import the text file into the 
project first to create the 
lightweight points, then import 
the other point data. The 
lightweight points from the text 
file will merge with the normal 
points from the other point data 
to create normal non-duplicated 
points. 

 
 

Troubleshoot an SCS Site or File Problem 

HEAVY CONSTRUCTION  

Before calling Support, use any applicable solutions to known issues below. 

Symptom Possible Cause Solution 

The program cannot 
find the SCS900 report 
utility .xls file. 

An error message states 
that it cannot find the 
file or the full file 
extension and if you 
browse to it the file is 
correct. Best to keep on 

Paths to Microsoft® Excel 
files are limited to 219 
characters. In Trimble® 
Business Center- Heavy 
Construction Edition, 
this means that if the 
path to the SCS report 
utility file (named 
SCS900 Reporting 

Move Excel (.xls) files to locations 
with shorter paths (fewer subfolders), 
or rename files with shorter names. 

Unzipping a folder to a location 
within several folders could exceed 
maximum path character limits, 
preventing deeper files from being 
unzipped. There may be a warning 
that the files cannot be unzipped or 
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the C drive. Utility.xls or SCS Report 
Utility.xls) exceeds the 
limit, the file will not 
open. In most cases, this 
will only happen if the 
.xls file has been placed in 
the ‘My Documents’ 
directory. 

the windows may simply close, 
making it look like they were all 
unzipped. It may be best to unzip 
files directly to the C drive with full 
administrative rights. 

The SCS900 report 
utility .xls file does not 
work.  

An error message says 
that there is a mismatch 
in data when the report 
is opened. 

Note: If the Import 
Record.xls is opened 
directly in Excel, there 
is a no warning until 
you click Import 

Record. 

Note: The number of the 
cause corresponds to the 
number of the solution. 

1. The -Report.txt and  
-Record.txt files are not 
both present or in the 
proper format. 

2. Language settings do 
not match in the 
operating system's 
regional settings, Trimble 
Business Center, 
Microsoft Office, and the 
SCS Report Utility file. 

3. The synchronizer root 
folder is not set to the 
correct folder in the 
Options dialog.  

4. The user does not have 
privileges to the folder. 

5. The Report Utility file 
is a different version from 
the one used on the site 
controller. 

1. Ensure that both the -Report.txt 
and  
-Record.txt are present and in the 
proper format in the data 
synchronization area's Output folder. 

2. Ensure that language settings 
match in the operating system's 
regional settings, Trimble Business 
Center, Microsoft Office (apply a 
language pack if necessary), and the 
SCS report utility file. 

3. In this program, select Tools > 
Options. Click SCS and then File 
Locations in the left pane. Click the 

 icon and navigate to the folder in 
which SCS installed the SCS Report 
Utility.xls file. 

4. If the security level is changed in 
Excel, then a new Excel program 
needs to be started for the macro to 
work. To change the security level in 
Excel, open Tools > Options > 
Security > Macro Security, and 
set the Security Level to Low (or add 
to the Trusted Publishers list). The 
macro can then be disabled when the 
report utility is opened. 

5. Find and use, or create, a report 
utility file of the same version as the 
one used on the site controller. The 
utility maker is on the SCS 
installation CD. 
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The program appears to 
freeze when trying to 
e-mail SCS files. 

If you are running the 
program on a secondary 
monitor, and you attempt 
to e-mail SCS files using 
the Compress/E-mail 
SCS Files command, your 
e-mail program may open 
a dialog confirming the 
operation out of either 
monitor’s visible range. 
The dialog will be located 
off of the primary 
monitor, in the space 
opposite the secondary 
monitor, causing the 
program to appear frozen. 

To reach the dialog and confirm the 
e-mail operation, right-click the 
e-mail application’s name on the 
Windows taskbar and select Move. 
Then, press the appropriate arrow 
key to move the dialog into your 
primary’s monitor’s visible range. 

Label text in the Work 
Order Viewer's 
coverage map is blurry. 

In Windows display 
properties, effects are set 
to Clear Type. 

Smooth the edges of the screen fonts 
in the viewer. Right-click on your 
Windows desktop and select 
Properties from the context menu. In 
the Display Properties dialog, click 
the Appearance tab and click 
Effects. In the Effects dialog, select 
Standard in the second drop-down 
list. 

You receive a message 
that your e-mail 
program is not 
supported when you try 
to e-mail SCS files. 

Note: The number of the 
cause corresponds to the 
number of the solution. 

1.This command requires 
Microsoft® Outlook® to 
work. Other email 
programs may work, but 
are not guaranteed. 
Web-based email 
programs, such as 
Microsoft Hotmail, 
Yahoo®Mail or 
Google®Gmail™, will not 
work. 

2. If you do have 
Outlook, it may be 
missing a component file. 

1. If your email program is not 
supported, create the compressed file, 
save it, open your email program, 
attach the file to a message, and send 
it. 

2. Download the Outlook CDO 
(Collaboration Data Objects) file to 
fix the problem: 
http://www.microsoft.com/downloa
ds/details.aspx?FamilyId=2714320D-
C997-4DE1-986F-24F081725D36&di
splaylang=en#QuickInfoContainer 
http://www.microsoft.com/downloa
ds/details.aspx?FamilyId=2714320D-
C997-4DE1-986F-24F081725D36&di
splaylang=en#QuickInfoContainer 
For Microsoft Outlook 2003, install 
the CDO file from the original 
program CD. 

 
 

http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320D-C997-4DE1-986F-24F081725D36&displaylang=en#QuickInfoContainer
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C H A P T E R  1 9  

Use Related Utilities 

Coordinate System Manager 
The Coordinate System Manager is a standalone utility that gives you access to your 
coordinate system database (Current.csd). Use the manager to create coordinate 
systems, or to determine which coordinate systems, geoid models, and sites are 
available for use in your project. 

To open the Coordinate System Manager:  

 Select Tools > Coordinate System Manager. 

Note: The Coordinate System Manager has its own help system. Open the utility and 
select Help > Help Topics, or press [F1] within the software. 

Related topics 

 Change the Coordinate System (on page 149) 
 Coordinate Systems (see "Understanding Geodetic Reference Data" on page 170) 
 Define a New Coordinate System (on page 149) 
 Restore the Original Coordinate System File (on page 150) 

 

Feature Definition Manager Utility 
The Feature Definition Manager is a standalone utility that gives you the ability to create 
and manage feature libraries (.fxl files) for feature code processing and GIS attribute 
data collection. A feature library is a collection of features with codes and attributes 
that describe them, as well as line control codes that modify how the features relate. 

The Feature Definition Manager comes with a default library of features with predefined 
attributes. This library provides a good starting point for feature coding. As you create 
new features and edit existing ones, the library will become suited to the specific needs 
of your projects.  

Feature coding in the editor enables you to: 
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 Make detailed data collection in the field more efficient and consistent by 
controlling how features and attributes can be captured. Setting parameters for 
what you can and must enter ensures data integrity and completeness. 

 Add symbols and annotations to feature-coded field data so that the information 
can be presented in a more visual format. 

 Connect points to define line features, such as pavement or building edges, or the 
centerlines of ditches or fences. Line control codes give you the power to add new 
points automatically, and add lines, curves, and arcs between points. 

If you are working with surfaces, coded features also let you: 

 Define the breaklines of a surface. 

 Control how surfaces are formed by specifying which points should be used, and 
which lines should act as breaklines. Surfaces can be modified by moving points to 
specific layers based on their feature codes.  

Note: The Feature Definition Manager has its own help system. While in the Feature 
Definition Manager, select Help > Contents, or press [F1]. 

Related topics 

 Understanding Feature Data (on page 359) 
 Workflow for Feature Data (on page 361) 

 

Planning Utility 
Use the Planning utility to plan and schedule a GPS project based on good and bad 
satellite coverage information. 

To access the uti l ity:  

 Select Tools > Planning. 

Note: The Planning software has its own help system. Open the utility and select Help > 
Index from the Planning menu or press [F1] within the software. 

External Tools Manager 
Use the External Tools Manager to add menu items for external application and utilities 
that you might want to use within this software. For example, if you want to have 
quick access to the Microsoft® Windows® Calculator, you can add it as a menu item. To 
add external tools to the Tools menu, see Customize the Menu (on page 16). 
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SCS Data Manager 

HEAVY CONSTRUCTION  

The SCS Data Manager is a program that lets you create sites, organize site and design 
data, write work orders, and assign the data and work orders to controllers in 
preparation for Trimble® site controller software (SCS). 

SCS enables you to measure material volumes, monitor grades and laid material 
thickness, and perform other site-related tasks, such as roadway point, line, and surface 
stakeout. 

Note: Most of the SCS Data Manager's functions have been embedded in the SCS Site 
Manager in this software.  

To open the SCS Data Manager:  

Do one of the following: 

 Select SCS > SCS Data Manager. 

 Click the  icon on the toolbar. 

Related topics 

 Manage a Site and Site Data (on page 377) 
 Workflow for Creating a Site (on page 377) 
 Workflow for Using an External Site (on page 378) 

 

Trimble Configuration Utility 
Use the Trimble Configuration Utility to update your computer with the latest files for:  

 GPS antennas  

 GPS receivers  

 GPS antenna model files  

After running the utility, your Trimble software will support the latest GPS hardware. 

To access the uti l ity:  

 Select Tools > Configuration Web Page. 
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Trimble Data Transfer Utility 
Use the Trimble Data Transfer Utility to transfer data from a range of devices to your 
computer. You can then import the data into Trimble Geomatics Office™, Trimble 
Total Control™, Terramodel®, Trimble Business Center, GPS Pathfinder® Office, 
Trimble Link™, or the GPS Analyst™ extension for ESRI ArcGIS. 

To access the uti l ity:  

 Select Tools > Data Transfer Web Page. 
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2 
2D View Navigation • 35 

3 
3D View • 28 
3D View Navigation • 37 
3D View Settings • 38 

A 
Abbreviation Settings • 158 
Add a Coordinate to a Point • 272 
Add an External Design • 394 
Add an External Site • 380 
Add and Edit a Design Model • 398 
Add and Edit Points and Coordinates • 270 
Add or Remove Background Map Objects • 387 
Add or Remove Control Points • 386 
Add or Remove Foreground Map Objects • 401 
Add or Remove Stakeout Points • 399 
Add Surface Materials • 349 
Adjust Level Runs • 265 
Advanced Display Options • 141 
Advanced View Filter Options • 81 
Alignment Editor • 30, 299 
Alignment Properties • 296 
Alignment Stationing Options • 295 
Along Line Snap • 128 
Archive a Project • 166 
At Point Snap • 127 

B 
Bearing + Angle Snap • 96 
Bearing Bearing Snap • 99 
Bearing Distance Snap • 100 

Boundary Options • 341 
Break a Line • 314 
Breakline Options • 314, 333 

C 
Calculate and Enter Values • 86 
Calculate the Inverse Between Points • 230, 280 
Calibrate a Site • 181, 184 
Center of Arc Snap • 101 
Center of Gravity Snap • 102 
Change Project Units • 152 
Change the Coordinate System • 149, 171 
Change the Default Template • 164 
Change the Gridline Display • 153 
Change the Template Folder • 144 
Check GNSS Data • 229 
Check Imported Surfaces • 321 
Choose Application Options • 139 
Choose Local Site Settings • 159 
Choose Project Settings • 147 
COGO Expressions, Units, and Entry Formats • 

87 
Command Pane • 13 
Compress and E-mail SCS Files • 421 
Computational Settings • 156 
Contour Options • 347 
Convert CAD Points to Survey Points • 400 
Coordinate Options • 274 
Coordinate System Manager • 173, 463 
Coordinate System Settings • 148 
Coordinates Scroll • 15 
Copyright and Trademarks • ii 
Corporate Office • ii 
Create a Boundary • 340 
Create a Datum Grid File • 174 
Create a Design • 393 
Create a Linestring • 300 
Create a New Project • 161 



Trimble® Business Center 
Heavy Construction Edition User Guide 468 

 Index

Create a Point • 270 
Create a Project Template • 163 
Create a Site • 379 
Create a Surface • 323 
Create a Surface Boundary and Contours • 339 
Create a Surface Contour at an Elevation • 344 
Create a Surface Cut/Fill Grid • 346 
Create a View Filter • 73 
Create a Work Order • 409 
Create an Alignment • 288 
Create an Alignment from a GENIO String • 

297 
Create and Edit a Layer • 68 
Create and Edit a Linestring • 300 
Create and Edit a Simple Breakline • 312, 331 
Create and Edit a Surface • 320 
Create and Edit an Alignment • 286 
Create and Use Selection Sets • 57 
Create and View a Surface Cross-Section • 326 
Create and View a Surface Profile • 325 
Create Surface Contours at Intervals • 343 
Cross-Section View • 26 
Customization Options and Tools • 21 
Customize a Report • 436 
Customize the Keyboard • 20 
Customize the Menu • 16 
Customize the Toolbar • 18 

D 
Data Selection • 42 
Data Synchronization • 223 
Data View Display Formats • 32 
Data Views • 16 
Datum Grid Options • 176 
Define a Geoid Sub-Grid • 177 
Define a New Coordinate System • 149, 171 
Define a Projection • 176 
Define Materials for Earthwork Reports • 351 

Define the Coordinate System • 171 
Definition Options • 210, 449 
Deflection Angle Snap • 92 
Delete a Line Segment • 316 
Delete an Object • 65 
Delta X Delta Y Snap • 103 
Description and Search Type Options • 211, 450 
Design Options • 396 
Device Pane • 11, 219 
Direct Connection • 221 
Distance + Distance Snap (distance) • 121 
Distance + Distance Snap (offset) • 129 
Distance Distance Snap • 103 
Distance Snap • 130 
Download Files (via data synchronization) • 

223 
Download Files (via Direct Connection) • 221 
Drag and Drop to Import • 194 

E 
Earthwork Report Options • 354 
Edit a Linestring's Horizontal Segments • 301 
Edit a Linestring's Vertical Control Points • 309 
Edit a Site's Name and Settings • 383 
Edit a Surface by Adding and Removing 

Members • 328 
Edit a Surface by Changing a Point Coordinate 

• 329 
Edit a Surface by Changing Its Properties • 338 
Edit a Surface by Creating a Breakline • 334 
Edit a Surface by Trimming Edge Triangles • 

336 
Edit a View Filter • 75 
Edit a Work Order • 410 
Edit an Alignment • 290 
Edit an Alignment's Properties • 295 
Edit an Object • 66 
Edit Design Data • 395 
Edit Site Data • 384 



Trimble® Business Center 
Heavy Construction Edition User Guide 469 

 Index

Edit the Point ID for a Station Setup and/or 
Backsight • 278 

End Snap • 104 
Enter a Bearing • 94 
Enter a Coordinate • 97 
Enter a Distance • 120 
Enter a Station • 133 
Enter an Angle • 92 
Enter an Elevation • 125 
Enter an Offset • 128 
Enter, Edit, and Delete Feature Code Strings • 

363 
Explode a Block • 319 
Explore an Object • 318 
Export and Upload Data Formats • 442 
Export ASCII Files • 443 
Export CAD Files (.dxf/.dwg) • 444 
Export Data • 441 
Export Data in a Custom Format • 448 
Export Geodatabase Files (.xml) • 368, 445 
Export LandXML Files (.xml) • 445 
Export Related Files • 442 
Export Trimble Data Collector Files (.dc) • 448 
Export Trimble Surface Files (.ttm) • 448 
External Tools Manager • 464 

F 
Factor of Distance Snap (distance) • 122 
Factor of Distance Snap (offset) • 131 
Factor of Line Snap • 105 
Factor of Segment Snap • 106 
Feature Code Processing Settings • 157, 362 
Feature Definition Manager Utility • 368, 463 
Fields Options • 213, 451 
File Location Options • 142 
Filter a View • 76 
Find Help Topics • 22 
Flags Pane • 14 
Free Snap • 107 

From Surface Snap • 126 

G 
General Information Settings • 147 
General Properties Options • 212, 451 
Geoid Options • 177 
Geoid Sub-Grid Options • 179 
Get Familiar with the Interface • 6 
Get Started • 3 
Graphic Selection Methods • 43 
Graphic Views • 25 

H 
Help Options • 23 
Horizontal Alignment Options • 291 
Horizontal Linestring Segment Options • 305 

I 
Import ASCII Files • 195 
Import CAD Files (.dxf/.dwg) • 196 
Import Data • 193 
Import Data Collector Files (.dc) • 196 
Import Data in a Custom Format • 209 
Import DiNi Digital Level Files (.dat) • 207, 253 
Import GENIO Files • 198 
Import GNSS Job Files (.job) • 199 
Import LandXML Files (.xml) • 200 
Import MicroStation Files (.dgn) • 204 
Import REB Files (.reb) • 206 
Import Trimble Surface Files (.ttm) • 207 
Import Wirth YXZ Files (.yxz) • 207 
Import Work Order Results • 422 
Importable Data Formats • 195 
Include a Site Calibration • 385 
Intersection of Lines Snap • 108 
Intersection of Offset Lines Snap • 109 
Intersection of Offset Segments Snap • 109 
Intersection of Segments Snap • 110 
Inverse Options • 231, 281 



Trimble® Business Center 
Heavy Construction Edition User Guide 470 

 Index

Isolate or Exclude a Layer • 70 

J 
Join Lines • 315 

K 
Keyboard Navigation • 40 

L 
LandXML Conflict Resolution Options • 203 
LandXML Export Options • 445 
Layer Options • 71 
Level Data Errors • 264 
Local Site Setting Options • 160 

M 
Manage a Site and Site Data • 377 
Manage Designs and Design Data • 393 
Manage the Data in Your Views • 67 
Manage Work Orders and Results • 406 
Materials Options • 352 
Measure Angle Options • 138 
Measure Angles • 137 
Measure Options • 136, 283 
Measure Values Between Points • 135, 282 
Merge Duplicate Points • 278 
Merge Level Runs • 266 
Merge Points • 279 
Middle of Point to Point Snap • 111 
Middle of Segment Snap • 112 
Modify Selection Sets • 58 
Mouse Modes • 42 

N 
Nearest to Line Snap • 113 
Note on Level Runs Without Benchmarks • 267 

O 
Office Synchronizer • 219 

Offset at Point Snap • 132 
Offset Line Snap • 113 
Offset Segment Snap • 114 
Open an Existing Project • 164 

P 
Pane and Data View Positioning • 31 
Perpendicular to Line Snap • 115 
Perpendicular to Segment Snap • 115 
Plan View • 25 
Planning Utility • 229, 464 
Point Coordinate Options • 275, 330 
Point of Intersection Snap • 116 
Point Options • 271 
Point Snap • 117 
Point to Point Bearing Snap • 97 
Point to Point Snap (distance) • 123 
Point to Point Snap (offset) • 132 
Points Spreadsheet • 29, 284 
Prepare Data for Site Positioning Systems • 370 
Prepare to Connect a Field Device • 217 
Print a View or Report • 166 
Process Feature Codes • 367 
Profile View • 26 
Project Computations • 157 
Project Explorer • 7 
Properties Pane • 14 

R 
Radius of Arc Snap (distance) • 124 
Radius of Arc Snap (offset) • 133 
Reassign a Design to Controllers • 405 
Reassign a Site to Controllers • 388 
Reassign or Copy a Work Order • 420 
Reference 

Regular Expressions • 214 
Register This Software • 3 
Release Notice • ii 



Trimble® Business Center 
Heavy Construction Edition User Guide 471 

 Index

Rename Points • 276 
Report Options • 438 
Report View • 31, 437 
Resolve a Conflict in Background Maps • 392 
Resolve a Conflict in Control Points • 391 
Resolve a Conflict in Design Models • 402 
Resolve a Conflict in Foreground Maps • 404 
Resolve a Conflict in Site Calibrations • 390 
Resolve a Conflict in Site Settings • 388 
Resolve a Conflict in Stakeout Points • 403 
Resolve LandXML Conflicts • 202 
Restore the Original Coordinate System File • 

150, 172 
Results of Default Folder Locations • 145 
Results of Exporting LandXML Files • 446 
Retaining User Settings When Upgrading • 5 
Rules for Merging Feature Attributes • 365 
Run a Mean Angle Report • 249, 431 
Run a Point Derivation Report • 230, 432 
Run a Point List Report • 229, 432 
Run a Project Computation Report • 157, 433 
Run a Renamed Point List • 277, 433 
Run a Site Calibration Report • 192, 434 
Run a Surface Report • 339, 434 
Run a Work Order Report or Summary • 423, 

435 
Run an Alignment Geometry Report • 298, 429 
Run an Earthwork Report • 353, 430 
Run an Import Report • 215, 431 
Run Reports • 429 
Running Snap Mode Options • 90 

S 
Save a Calibrated Site as a Coordinate System • 

190 
Save a Project • 165 
Scale-Only Projection • 174 
SCS Data Manager • 376, 465 
SCS File Compression and Email Options • 421 

SCS File Location Options • 146 
Select by Elevation Range • 52 
Select By Layer • 53 
Select Duplicate Points • 52 
Select from 2D Views • 44 
Select from Spreadsheet Views • 46 
Select from the 3D View • 45 
Select from the Flags Pane • 48 
Select from the Project Explorer • 48 
Select Points • 49 
Select Using Advanced Criteria • 53 
Selection Explorer • 8, 56 
Selection Explorer and Selection Sets • 54 
Selection Explorer Options • 60 
Selection Methods and Options • 43 
Separate Global and Grid/Local Coordinate 

Points for Site Calibration • 191 
Set a Line Elevation • 317 
Set Default File Locations • 144 
Set Running Snap Modes • 89 
Set the Pick Aperture • 88 
Set Up Geodetic Reference Data • 170 
Set Up Projects • 139 
Shrink 3D Faces • 356 
Site Calibration Options • 187 
Site Options • 381 
Snaps Modes and Commands • 89 
Split Line Features • 365 
Spreadsheets and Other Views • 29 
Startup and Display Options • 139 
Station at Point Snap • 134 
Station from Line Snap • 135 
Status Bar • 10 
Surface Cut/Fill Grid Options • 348 
Surface Options • 324 
Surface Properties • 338 
Surface Slicer View • 27 



Trimble® Business Center 
Heavy Construction Edition User Guide 472 

 Index

T 
Tabbed View Arrangement • 34 
Tangent Snap • 118 
Three Point Snap • 93 
Toggle Line Marking • 155 
Total Station Data Errors • 247 
Total Station Measurement Types • 236 
Total Station Nodes Sequence in Project 

Explorer • 246 
Total Station Setup Types • 234 
Transfer/Synchronize Data • 217 
Trimble Configuration Utility • 465 
Trimble Data Transfer Utility • 466 
Troubleshoot a Coordinate System Problem • 

173, 453 
Troubleshoot a Data Transfer/Synchronization 

Problem • 228, 453 
Troubleshoot a Layer or View Filter Problem • 

83, 454 
Troubleshoot a Program Freeze • 168, 455 
Troubleshoot a Project Problem • 167, 457 
Troubleshoot a Toolbar or Menu Problem • 21, 

457 
Troubleshoot a View or Selection Problem • 84, 

457 
Troubleshoot an Import Problem • 215, 285, 

455, 459 
Troubleshoot an SCS Site or File Problem • 425, 

460 
Troubleshoot Issues • 453 

U 
Undefined Snap • 126 
Understanding Alignments • 286 
Understanding Breaklines • 330 
Understanding COGO Controls • 86 
Understanding Earthwork Volume 

Calculations • 349 
Understanding Feature Data • 359 
Understanding Geodetic Reference Data • 170 

Understanding Layers and View Filters • 67 
Understanding Level Data • 251 
Understanding Point Types • 269 
Understanding Selection Sets • 54 
Understanding Site Calibration • 181 
Understanding Sites, Designs, Work Orders, 

and Synchronization • 373 
Understanding SPS and SCS • 372 
Understanding Surfaces • 320 
Understanding Total Station Data • 233 
Undo or Redo an Action • 67 
Unit Settings • 151 
Upload a Datum Grid File • 227 
Upload a Geoid File • 228 
Upload Files (via data synchronization) • 224 
Upload Files (via Direct Connection) • 221 
Upload Geodetic Reference Data • 227 
Upload Tasks (via data synchronization) • 225 
Upload Tasks (via Direct Connection) • 222 
Use a Datum • 174 
Use a Geoid • 177 
Use a Project Template • 162 
Use Related Utilities • 463 
Use Snap Commands • 91 
Use Terramodel (.pro) Data • 208 
Use Valid Segment Order • 289 
User Guide • i 

V 
Vertical Alignment Options • 293 
Vertical Linestring Options • 310 
View a Slice of a Surface • 327 
View a Work Order's Data Graphically • 416 
View and Edit an Object's Properties • 64 
View and Edit Level Data • 255 
View and Edit Mean Angle Residuals • 248 
View Construction Data in Project Explorer • 

427 
View Filter Manager • 9, 72 



Trimble® Business Center 
Heavy Construction Edition User Guide 473 

 Index

View Filter Manager Options • 79 
View Imported Level Data in Project Explorer • 

261 
View Imported Total Station Data in Project 

Explorer • 241 
View Level Data Associated with a Point in 

Project Explorer • 263 
View Level Data in Project Explorer • 260 
View Settings • 152 
View Total Station Data Associated with a 

Point in Project Explorer • 244 
View Total Station Data in Project Explorer • 

240 
View, Navigate, and Select • 25 

W 
Welcome to Trimble Business Center - Heavy 

Construction Edition • 1 
Work Order Options • 411 
Work Order Viewer Options • 417 
Work with Feature Data • 359 
Work with GNSS Data • 229 
Work with Level Data • 251 
Work with Line Data • 286 
Work with Point Data • 269 
Work with Surface Data • 320 
Work with Total Station Data • 233 
Workflow for Creating a Site • 377 
Workflow for Creating Alignments • 287 
Workflow for Creating Surfaces • 322 
Workflow for Feature Data • 361 
Workflow for Level Data • 252 
Workflow for Managing Work Orders • 406 
Workflow for Total Station Data • 238 
Workflow for Using an External Site • 378 
Workflow for Using Imported Alignments • 

287 
Workflow for Using Imported Surfaces • 321 

X 
XY Snap • 119 

 


	Welcome to Trimble Business Center -  Heavy Construction Edition 
	Get Started 
	Register This Software 
	Retaining User Settings When Upgrading 
	Get Familiar with the Interface 
	Project Explorer 
	Selection Explorer 
	View Filter Manager 
	Status Bar 
	Device Pane 
	Command Pane 
	Properties Pane 
	Flags Pane 
	Coordinates Scroll 
	Data Views 
	Customize the Menu 
	Customize the Toolbar 
	Customize the Keyboard 
	Customization Options and Tools 
	Troubleshoot a Toolbar or Menu Problem 
	Find Help Topics 
	Help Options 
	View, Navigate, and Select 
	Graphic Views 
	Plan View 
	Profile View 
	Cross-Section View 
	Surface Slicer View 
	3D View 

	Spreadsheets and Other Views 
	Points Spreadsheet 
	Alignment Editor 
	Report View 

	Pane and Data View Positioning 
	Data View Display Formats 
	Tabbed View Arrangement 
	2D View Navigation 
	3D View Navigation 
	3D View Settings 
	Keyboard Navigation 
	Mouse Modes 
	Data Selection 
	Selection Methods and Options 
	Graphic Selection Methods 
	Select from 2D Views 
	Select from the 3D View 
	Select from Spreadsheet Views 
	Select from the Flags Pane 
	Select from the Project Explorer 
	Select Points 
	Select Duplicate Points 
	Select by Elevation Range 
	Select By Layer 
	Select Using Advanced Criteria 
	Selection Explorer and Selection Sets 
	Understanding Selection Sets 
	Selection Explorer 
	Create and Use Selection Sets 
	Modify Selection Sets 
	Selection Explorer Options 


	View and Edit an Object's Properties 
	Delete an Object 
	Edit an Object 
	Undo or Redo an Action 
	Manage the Data in Your Views 
	Understanding Layers and View Filters 
	Create and Edit a Layer 
	Isolate or Exclude a Layer 
	Layer Options 
	View Filter Manager 
	Create a View Filter 
	Edit a View Filter 
	Filter a View 
	View Filter Manager Options 
	Advanced View Filter Options 
	Troubleshoot a Layer or View Filter Problem 

	Troubleshoot a View or Selection Problem 

	Calculate and Enter Values 
	Understanding COGO Controls 
	COGO Expressions, Units, and Entry Formats 
	Set the Pick Aperture 
	Snaps Modes and Commands 
	Set Running Snap Modes 
	Running Snap Mode Options 
	Use Snap Commands 

	Enter an Angle 
	Deflection Angle Snap 
	Three Point Snap 

	Enter a Bearing 
	Bearing + Angle Snap 
	Point to Point Bearing Snap 

	Enter a Coordinate 
	Bearing Bearing Snap 
	Bearing Distance Snap 
	Center of Arc Snap 
	Center of Gravity Snap 
	Distance Distance Snap 
	Delta X Delta Y Snap 
	End Snap 
	Factor of Line Snap 
	Factor of Segment Snap 
	Free Snap 
	Intersection of Lines Snap 
	Intersection of Offset Segments Snap 
	Intersection of Offset Lines Snap 
	Intersection of Segments Snap 
	Middle of Point to Point Snap 
	Middle of Segment Snap 
	Nearest to Line Snap 
	Offset Line Snap 
	Offset Segment Snap 
	Perpendicular to Segment Snap 
	Perpendicular to Line Snap 
	Point of Intersection Snap 
	Point Snap 
	Tangent Snap 
	XY Snap 

	Enter a Distance 
	Distance + Distance Snap (distance) 
	Factor of Distance Snap (distance) 
	Point to Point Snap (distance) 
	Radius of Arc Snap (distance) 

	Enter an Elevation 
	Undefined Snap 
	From Surface Snap 
	At Point Snap 
	Along Line Snap 

	Enter an Offset 
	Distance + Distance Snap (offset) 
	Distance Snap 
	Factor of Distance Snap (offset) 
	Offset at Point Snap 
	Point to Point Snap (offset) 
	Radius of Arc Snap (offset) 

	Enter a Station 
	Station at Point Snap 
	Station from Line Snap 

	Measure Values Between Points 
	Measure Options 
	Measure Angles 
	Measure Angle Options 

	Set Up Projects 
	Choose Application Options 
	Startup and Display Options 
	Advanced Display Options 

	File Location Options 
	Change the Template Folder 
	Set Default File Locations 
	Results of Default Folder Locations 

	SCS File Location Options 

	Choose Project Settings 
	General Information Settings 
	Coordinate System Settings 
	Change the Coordinate System 
	Define a New Coordinate System 
	Restore the Original Coordinate System File 

	Unit Settings 
	Change Project Units 

	View Settings 
	Change the Gridline Display 
	Toggle Line Marking 

	Computational Settings 
	Project Computations 
	Run a Project Computation Report 

	Feature Code Processing Settings 
	Abbreviation Settings 

	Choose Local Site Settings 
	Local Site Setting Options 

	Create a New Project 
	Use a Project Template 
	Create a Project Template 
	Change the Default Template 

	Open an Existing Project 
	Save a Project 
	Archive a Project 
	Print a View or Report 
	Troubleshoot a Project Problem 
	Troubleshoot a Program Freeze 

	Set Up Geodetic Reference Data 
	Understanding Geodetic Reference Data 
	Define the Coordinate System 
	Change the Coordinate System 
	Define a New Coordinate System 
	Restore the Original Coordinate System File 
	Troubleshoot a Coordinate System Problem 
	Coordinate System Manager 
	Scale-Only Projection 

	Use a Datum 
	Create a Datum Grid File 
	Datum Grid Options 

	Define a Projection 
	Use a Geoid 
	Geoid Options 
	Define a Geoid Sub-Grid 
	Geoid Sub-Grid Options 

	Calibrate a Site 
	Understanding Site Calibration 

	Using Geoid Models 
	Rules for ensuring a useful calibration 
	Calibrate a Site 
	Site Calibration Options 
	Save a Calibrated Site as a Coordinate System 
	Separate Global and Grid/Local Coordinate Points for Site Calibration 
	Run a Site Calibration Report 


	Import Data 
	Import Data 
	Drag and Drop to Import 
	Importable Data Formats 
	Import ASCII Files 
	Import Data Collector Files (.dc) 
	Import CAD Files (.dxf/.dwg) 
	Import GENIO Files 
	Import GNSS Job Files (.job) 
	Import LandXML Files (.xml) 
	Resolve LandXML Conflicts 
	LandXML Conflict Resolution Options 

	Import MicroStation Files (.dgn) 
	Import REB Files (.reb) 
	Import Trimble Surface Files (.ttm) 
	Import Wirth YXZ Files (.yxz) 
	Import DiNi Digital Level Files (.dat) 
	Use Terramodel (.pro) Data 
	Import Data in a Custom Format 
	Definition Options 
	Description and Search Type Options 
	General Properties Options 
	Fields Options 
	Reference: Regular Expressions 

	Run an Import Report 
	Troubleshoot an Import Problem 

	Transfer/Synchronize Data 
	Prepare to Connect a Field Device 
	Office Synchronizer 
	Device Pane 
	Direct Connection 
	Download Files (via Direct Connection) 
	Upload Files (via Direct Connection) 
	Upload Tasks (via Direct Connection) 

	Data Synchronization 
	Download Files (via data synchronization) 
	Upload Files (via data synchronization) 
	Upload Tasks (via data synchronization) 

	Upload Geodetic Reference Data 
	Upload a Datum Grid File 
	Upload a Geoid File 

	Troubleshoot a Data Transfer/Synchronization Problem 

	Work with GNSS Data 
	Planning Utility 
	Check GNSS Data 
	Run a Point List Report 
	Run a Point Derivation Report 
	Calculate the Inverse Between Points 
	Inverse Options 


	Work with Total Station Data 
	Understanding Total Station Data 
	Total Station Setup Types 
	Total Station Measurement Types 

	Workflow for Total Station Data 
	View Total Station Data in Project Explorer 
	View Imported Total Station Data in Project Explorer 
	View Total Station Data Associated with a Point in Project Explorer 
	Total Station Nodes Sequence in Project Explorer 

	Total Station Data Errors 
	View and Edit Mean Angle Residuals 
	Run a Mean Angle Report 

	Work with Level Data 
	Understanding Level Data 
	Workflow for Level Data 
	Import DiNi Digital Level Files (.dat) 
	View and Edit Level Data 
	View Level Data in Project Explorer 
	View Imported Level Data in Project Explorer 
	View Level Data Associated with a Point in Project Explorer 

	Level Data Errors 
	Adjust Level Runs 
	Merge Level Runs 
	Note on Level Runs Without Benchmarks 

	Work with Point Data 
	Understanding Point Types 
	Add and Edit Points and Coordinates 
	Create a Point 
	Point Options 
	Add a Coordinate to a Point 
	Coordinate Options 
	Point Coordinate Options 
	Rename Points 
	Run a Renamed Point List 
	Edit the Point ID for a Station Setup and/or Backsight 
	Merge Duplicate Points 
	Merge Points 

	Calculate the Inverse Between Points 
	Inverse Options 
	Measure Values Between Points 
	Measure Options 
	Points Spreadsheet 
	Troubleshoot an Import Problem 

	Work with Line Data 
	Create and Edit an Alignment 
	Understanding Alignments 
	Workflow for Using Imported Alignments 
	Workflow for Creating Alignments 
	Create an Alignment 
	Use Valid Segment Order 
	Edit an Alignment 
	Horizontal Alignment Options 
	Vertical Alignment Options 
	Alignment Stationing Options 
	Edit an Alignment's Properties 
	Alignment Properties 
	Create an Alignment from a GENIO String 
	Run an Alignment Geometry Report 
	Alignment Editor 

	Create and Edit a Linestring 
	Create a Linestring 
	Edit a Linestring's Horizontal Segments 
	Horizontal Linestring Segment Options 
	Edit a Linestring's Vertical Control Points 
	Vertical Linestring Options 

	Create and Edit a Simple Breakline 
	Breakline Options 
	Break a Line 
	Join Lines 
	Delete a Line Segment 
	Set a Line Elevation 
	Explore an Object 
	Explode a Block 

	Work with Surface Data 
	Create and Edit a Surface 
	Understanding Surfaces 
	Workflow for Using Imported Surfaces 
	Check Imported Surfaces 
	Workflow for Creating Surfaces 
	Create a Surface 
	Surface Options 
	Create and View a Surface Profile 
	Create and View a Surface Cross-Section 
	View a Slice of a Surface 
	Edit a Surface by Adding and Removing Members 
	Edit a Surface by Changing a Point Coordinate 
	Point Coordinate Options 
	Understanding Breaklines 
	Create and Edit a Simple Breakline 
	Breakline Options 
	Edit a Surface by Creating a Breakline 
	Edit a Surface by Trimming Edge Triangles 
	Edit a Surface by Changing Its Properties 
	Surface Properties 
	Run a Surface Report 

	Create a Surface Boundary and Contours 
	Create a Boundary 
	Boundary Options 
	Create Surface Contours at Intervals 
	Create a Surface Contour at an Elevation 
	Create a Surface Cut/Fill Grid 
	Contour Options 
	Surface Cut/Fill Grid Options 

	Add Surface Materials 
	Understanding Earthwork Volume Calculations 
	Define Materials for Earthwork Reports 
	Materials Options 
	Run an Earthwork Report 
	Earthwork Report Options 

	Shrink 3D Faces 

	Work with Feature Data 
	Understanding Feature Data 
	Workflow for Feature Data 
	Feature Code Processing Settings 
	Enter, Edit, and Delete Feature Code Strings 
	Rules for Merging Feature Attributes 
	Split Line Features 
	Process Feature Codes 
	Export Geodatabase Files (.xml) 
	Feature Definition Manager Utility 

	Prepare Data for Site Positioning Systems 
	Prepare Data for Site Positioning Systems 
	Understanding SPS and SCS 
	Understanding Sites, Designs, Work Orders, and Synchronization 
	SCS Data Manager 
	Manage a Site and Site Data 
	Workflow for Creating a Site 
	Workflow for Using an External Site 
	Create a Site 
	Add an External Site 
	Site Options 
	Edit a Site's Name and Settings 
	Edit Site Data 
	Include a Site Calibration 
	Add or Remove Control Points 
	Add or Remove Background Map Objects 
	Reassign a Site to Controllers 
	Resolve a Conflict in Site Settings 
	Resolve a Conflict in Site Calibrations 
	Resolve a Conflict in Control Points 
	Resolve a Conflict in Background Maps 

	Manage Designs and Design Data 
	Create a Design 
	Add an External Design 
	Edit Design Data 
	Design Options 
	Add and Edit a Design Model 
	Add or Remove Stakeout Points 
	Convert CAD Points to Survey Points 
	Add or Remove Foreground Map Objects 
	Resolve a Conflict in Design Models 
	Resolve a Conflict in Stakeout Points 
	Resolve a Conflict in Foreground Maps 
	Reassign a Design to Controllers 

	Manage Work Orders and Results 
	Workflow for Managing Work Orders 
	Create a Work Order 
	Edit a Work Order 
	Work Order Options 
	View a Work Order's Data Graphically 
	Work Order Viewer Options 
	Reassign or Copy a Work Order 
	Compress and E-mail SCS Files 
	SCS File Compression and Email Options 
	Import Work Order Results 
	Run a Work Order Report or Summary 

	Troubleshoot an SCS Site or File Problem 
	View Construction Data in Project Explorer 

	Run Reports 
	Run an Alignment Geometry Report 
	Run an Earthwork Report 
	Run an Import Report 
	Run a Mean Angle Report 
	Run a Point Derivation Report 
	Run a Point List Report 
	Run a Project Computation Report 
	Run a Renamed Point List 
	Run a Site Calibration Report 
	Run a Surface Report 
	Run a Work Order Report or Summary 
	Customize a Report 
	Report View 
	Report Options 

	Export Data 
	Export Data 
	Export and Upload Data Formats 
	Export Related Files 
	Export ASCII Files 
	Export CAD Files (.dxf/.dwg) 
	Export Geodatabase Files (.xml) 
	Export LandXML Files (.xml) 
	LandXML Export Options 
	Results of Exporting LandXML Files 

	Export Trimble Data Collector Files (.dc) 
	Export Trimble Surface Files (.ttm) 
	Export Data in a Custom Format 
	Definition Options 
	Description and Search Type Options 
	General Properties Options 
	Fields Options 


	Troubleshoot Issues 
	Troubleshoot a Coordinate System Problem 
	Troubleshoot a Data Transfer/Synchronization Problem 
	Troubleshoot a Layer or View Filter Problem 
	Troubleshoot an Import Problem 
	Troubleshoot a Program Freeze 
	Troubleshoot a Project Problem 
	Troubleshoot a Toolbar or Menu Problem 
	Troubleshoot a View or Selection Problem 
	Troubleshoot an Import Problem 
	Troubleshoot an SCS Site or File Problem 

	Use Related Utilities 
	Coordinate System Manager 
	Feature Definition Manager Utility 
	Planning Utility 
	External Tools Manager 
	SCS Data Manager 
	Trimble Configuration Utility 
	Trimble Data Transfer Utility 

	Index 


