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1. About Business Process Modeling Notation (BPMN) 
 

The Business Process Modeling Notation (BPMN) specification provides a graphical notation 

for expressing business processes. This notation has been proposed by the Business Process 

Management Initiative (www.bpmi.org).  

Standard specification can be found here: www.omg.org/docs/dtc/06-02-01.pdf 

 

The objective of BPMN is to support business process management by both technical users 

and business users by providing a notation that is intuitive to business users yet able to 

represent complex process semantics. The main focus of BPMN is on systems that interact 

and interrupt one another, where there are many deeply nested independent, but coordinated, 

interacting threads of execution. 

 

This tutorial is intended to be used for Business Process Analysis, rather than the design 

and orchestration of web services. Please refer to our other documentation if you are 

interested in generating BPEL Code.  
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2. Starting SemTalk BPMN Edition 
 

In order to start SemTalk you can use “Start->Programs->SemTalk->SemTalk 2” or the icon 

on your desktop. The first time you start SemTalk it will come up with the following dialog, 

which gives new users quick access to available modeling methods.  

 

 

Figure 1: SemTalk Welcome Screen 

 

Please select “New” to start SemTalk BPMN Edition. If have already used SemTalk, please 

open a BPMN template with “File->New” and select “bpmn.vst”. File menu options such as 

“Save”, “Save As” etc. are very similar to other MS Office applications especially to Visio. 

Most of the Visio commands used by SemTalk can be found in the “Visio” Menu. 

 

SemTalk shows up as follows. 
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Figure 2: Starting SemTalk BPMN Edition 

 

You can show the SemTalk explorer using the  Button or “Tools->Explorer->Show”. 

In the Explorer you will get a structured access to those objects contained in your model. 

 

For this tutorial please make sure that you are using the Business Process Analysis Mode of 

SemTalk BPMN Edition at Tools->SemTalk Options-> BPMN.  
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Figure 3: BPMN Modes 

 

 

Visio’s Pan & Zoom Window can be shown also:   

 

I  

 

The Stencil Windows and the Pan & Zoom Window can be “docked” to the Borders of the 

Visio pane with or without the Autohide mode. 
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It also can be attached to a border of the Visio document. See Visio’s Help for details. 

 

 



SemTalk BPMN Tutorial  11.1.2007 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2001-2007 

 

 

3. Editing a Process 
 

3.1. Adding Process Elements 

 

Please add now elements to the existing process: Simply drag them from the stencil to your 

diagram (or “Process”). Objects can be renamed by selecting the object and entering the new 

name. 

 

A process is a sequence of process steps (Task). It has well defined interfaces. These are Start 

Event and End Event. Between every two of those elements the can be a Sequence flow.  

 

 

 

A Task is an atomic activity that is included within a Process. A Task 

is used when the work in the Process is not broken down to a finer 

level of Process Model detail. Generally, an end-user and/or an 

application are used to perform the Task when it is executed 

 

An Event is something that “happens” during the course of a business 

process. These Events affect the flow of the Process and usually have 

a cause or an impact. BPMN has restricted the use of events to 

include only those types of events that will affect the sequence or 

timing of activities of a process. Start and most Intermediate Events 

have “Triggers” that define the cause for the event. End Events may 

define a “Result” that is a consequence of a Sequence Flow ending. 

 

Gateways are modeling elements that are used to control how 

Sequence Flow interact as they converge and diverge within a 

Process. It implies that there is a gating mechanism that either allows 

or disallows passage through the Gateway--that is, as Tokens arrive 

at a Gateway, they can be merged together on input and/or split apart 

on output as the Gateway mechanisms are invoked. 

 

 

Data objects do not have any direct affect on the Sequence Flow or 

Message Flow of the process, but they do provide information about 

what the Process does. That is, how documents, data, and other 

objects are used and updated during the Process. While the name 

“Data Object” may imply an electronic document, they can be used 

to represent many different types of objects, both electronic and 

physical. 

 

A Pool is a graphical container for activities within an orchestration.  

We use a Service symbol for IT-Systems (incl. Web Services). 

Human Participants (or roles) will be expressed by Visio Swimlanes 



SemTalk BPMN Tutorial  11.1.2007 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2001-2007 

 

 

 

 

 

Figure 4: The simplified BPMN Meta Model in SemTalk 

 

 

Adding links is quite simple. Drop the “Sequence flow” shape somewhere on the background. 

If you hover its ends over an object’s “connections point” you are notified by a red square that 

you can glue the relation to that object. Select an ending point and glue your relation to the 

objects of your choice. 

 

After adding some elements and connecting them with the “Sequence flow” connector your 

diagram looks like this one: 
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Figure 5: Adding Process Elements 

 

To speed up the creation of diagrams the stamp tool and the connector tool are very useful 

(both from the Visio-Menu). The connector tool is also available from the toolbar .  

 

BPMN does not display human resources graphically as nodes in a process (even it could be 

easily customized to do so).  In order to do that you must use the Edit Dialog and assign a 

resource on the “Performers” tab, which will be explained later on. Let first begin with 

Swimlanes. 

 

3.2. Using Swimlanes 

 

Let us first create a new process page: 
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This will create a new Visio Page of diagram class “Business Process Diagram”. You may 

rename that page directly by renaming the tab or a via a SemTalk dialog (Right Click-> Edit 

on the background or the menu item “Diagram->Edit”.  

 

Swimlanes are well known from Visio’s Flowcharting stencil. They can be used via the 

command buttons  or the Visio Menu of SemTalk. 

 

 
 

 

After dropping functional bands on the drawing you select the title area of the Swimlane and 

go ahead type. Alternatively you can select existing roles or org. units via the right click 

menu. (“Select Resource”). 

 

 

Figure 6: Process with Swimlanes 
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If you move an activity to a Swimlane this is detected by SemTalk and the function will be 

assigned automatically to the role of the Swimlane.  

If you select the head of a swim lane, you can create new roles just by renaming the 

Swimlane. Via the right-click menu on the Swimlane you can select existing roles and edit the 

objects. 

Between tasks on different Swimlanes a special link (“Message flow”) has to be used. You 

may not relate a gateway on one Swimlane with a task on another Swimlane.  

 

Inputs and outputs of task are specified as data objects on the sequence flow.  

A process with data object might look like: 

 

 

Figure 7: Process with Swimlanes and data objects 

 

In BPMN you can attach Events to a task in order to express, that something happened while 

the task was executed.  
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Figure 8: Attaching an Event 

 

Due to a tiny problem with Visio Swimlanes, events must be attached outside of the 

Swimlane. Move “Develop Solution” down, so that it is off the “PD” Swimlane and drop a 

new event shape on the task. Once it is connected, you can move it back on the Swimlane. 

Edit the event and select on the “Measures” tab the option “Process Error” as an Event type: 

 

 

Figure 9: Back on the Swimlane 
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Figure 10: Intermediate Event and Error handling 

 

 

3.3. Object oriented process modeling 

 

If you select the menu „Object->Compose“ or right click compose, you will have the option 

to specify object oriented tasks and events. 

 

 

Figure 11: Composing object oriented tasks 
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Root Class is the base object type: Object, physical resource, media etc. The most used type 

is “Object” for the business objects, but there are also other cases as “open letter” (media) or 

“boot Laptop” (physical resource). Please make sure you have selected “Object” for this 

tutorial. 

 

Class is the object the task is related to. You can reuse existing classes or create new classes 

in a bottom up style. E.g. “Bid” is the class at “make Bid” 

 

The options State and Attribute allow to specify which of these feature will be used to create 

the activity name. For the BPMN methodology only methods are relevant for activities. 

 

In the combo box Method the name of the method (or verb) can be entered newly or be 

selected from the already defined methods of the class 

 

SemTalk creates the class and method in case they do not exist in the database yet. In our 

example a class named “order” with the method “enter” will be created. 

 

The whole idea about compose is, that the name of the task is generated from the name 

of the class and the name of the method. If classes or methods are being renamed, the 

name of the activity is being updated. Note that method (as well as attributes and state) 

can be inherited from super classes.  

 

The order of how the name of the activity will be generated is language specific („Order 

Enter” or “Enter Order”). You can change it as a general setting in the SemTalk options 

dialog. For English you will use “Method Object”. 

 

You can also specify to use “Compose” on any new activity: 
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A newly created Process with some object oriented functions: 

 

 

Figure 12: An object-oriented Process 

 

The objects “Order” and “Customer” are created in the background. A diagram of these (and 

some others) will look like this: 

 

 

Figure 13: Object Model 

 

If you make „Special Offer“ a subclass of „Offer“. “Special Offer” will inherit all methods 

from “Offer”. In the compose dialog those inherited methods will be shown in the method 

combobox. 
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SemTalk ensures the consistency between object models and process models. If you rename a 

class or method all depending functions will be updated. 

 

We recommend object oriented process modeling especially for large projects. It is a good 

idea to define in a first step the most important business objects and build a catalogue of 

methods (verbs). This is the foundation of consistent process models.  

 

If you are going to use the same business objects in multiple projects we recommend to store 

such object libraries in separated files and publish them on intranet or extranet. The SemTalk 

Wizard will ensure that those libraries are used consistently. 

 

3.4. Editing process elements 

 

You can now edit the objects on your diagram: 

 

1. By double clicking or 

2. Right Click “Edit” or 

3. Select & Menu “Object->Edit” or 

4. Find it in the explorer as a child of “Diagrams->Process->Process-6” or 

5. Find it in the explorer as a child of “Objects->”. 

 

In case you just want to rename the object, you can select it and type-in the new name.  

You may also use the Properties Window, which allows reviewing and changing the values 

directly. (Tools->Explorer->Properties) 

 

 

Figure 14: Properties Window 

3.4.1. Task Dialog 

 

The task dialog looks like this: 
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Figure 15: Task Dialog 

  

Links (hyperlinks, attachments, documents), can be added with the right click menu “New” 

(“+” button), changed and removed by the right click menu “Remove” (“-“ button) on the 

background of the links list. Double clicking the link in the listbox opens that document with 

the (for windows) associated application. Activities having at least one link will show up with 

a little marker in the upper left corner. 

 

NOTE: In order to change all occurrences of the task you must edit the class itself using “Edit 

Class”. 
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Figure 16: Edit & Compose a Task Class 

 

  

NOTE: The “General” tab is a generic SemTalk tab and not a BPMN specific one.  

 

3.4.2. Task: “Hum. Resource” Tab 
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Figure 17: Task: Hum. Resource 

 

On the “Hum. Resource”-tab you can assign “Participants” to the task. These are people, roles 

or organizational units which actually execute the task. The left hand listbox shows the 

currently assigned resources and the right hand listbox shows the list of all available human 

resources. 

You may use the arrow buttons to add / remove resources. Double clicking in the listboxes 

will edit the resource. 

 

The right combobox having the selection “Human Resource” allows to filter resources by 

class. 

 The left combobox having the selection “uses hum.resource” allows” to specify certain types 

of execution such as “controlled by” or “supervised by”.
2
  

 

Using the new button you can add new human resources and new human resource classes. 

The new instance will automatically get the class which is selected in the combobox. 

 

                                                
2
 These could be defined as subclasses of the relation “executes” 
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Figure 18: Adding new Human Resources 

 

You can see / edit all existing resources in the explorer as child nodes of “Human Resource” 

 

3.4.3. Task “Measures” Tab 

 

The “Measures” tab allows the processing time, fixed cost, variable cost and probability. 

Some of these attributes are used in reports and at MS Project export. 
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Figure 19: Task: Measures 

 

 

Relevant for simulation, the work plan report, MS-Project etc is especially the “Processing 

Time”. For all others please see the Simulation Tutorial. 

 

3.4.4. Sequence Flow Dialog 

 

Note on BPMN Methodology: 

  
A Sequence Flow is used to show the order that activities will be performed in a Process. 
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The “Data Object Properties” tab allows you to specify which data object, is “flowing” 

between the two connected tasks. Editing the data object itself, will open the Sequence flow 

dialog also. 

 

You can select existing objects from the comboboxes. If you select an existing object or enter 

a new one, you must push the “Add” button in order to add it to the list of objects that flow. 

 

Object composition is done similar to the “Compose” for tasks. 

 
Root Class is the base object type: Object, Physical resource, Media etc. The most used type 

is Object for the business objects. 

 

Class is the object. You can reuse existing classes or create new classes in a bottom up style. 

 

State (and Attribute) is the state of the object which is being send e.g. “Order entered”. 

 

You can remove an object from the list by double clicking it or by using the “Del” Button. 
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Figure 20: Sequence Flow: Measures 

 

The “Measures” tab allows the specification of transportation time, fixed cost, variable cost 

and probability. 

 

 

NOTE: You can glue relations to any point on the object if you select the Visio option “Glue 

to geometry” 
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Figure 21: Visio: Snap& Glue Options 

 

 

 

 

4. Org Charts 
 

Org Charts are used to describe the organizational structure of your company graphically. 

You may add new element using shapes for Org Unit and Position and connect them with 

then “superior of” connector.  

Using Diagram->Insert (Model) you can add the existing Org Units “Sales” and “PD” to the 

org chart. 
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Figure 22: Org Chart 

 

If you edit an Org Unit or Position, you may add Persons to the element. 

 

 

Figure 23: Adding Persons 
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The person can be edited directly by double clicking in the list. Any organizational unit is a 

resource with measures like fixed cost, variable cost and a capacity. 

 

 

Figure 24: Org Chart with Persons 

 

 

5. Class Diagrams 
 

Open a Visio Stencil using File->Open Stencil or search for a Visio shape. Please open the 

Visio Stencil „Enterprise Application“ (ENTAPP_M.VSS, ENTAPP_U.VSS) for additional 

Visio Masters. You will find the stencil for Visio 2007 at „C:\Program Files\Microsoft Office 

\1031“ or for Visio 2003 at  „C:\Program Files\Microsoft Office\VISIO11\1031“.
3
 

 

If you drag an arbitrary Visio master onto your process sheet, SemTalk does not recognize the 

shape in the context of the current modeling method. A Dialog is shown, which allows to 

select the appropriate modeling construct. For example a Server should be uses as an 

alternative symbol for system. “Ignore” just accepts it as a Visio shape and does not add it to 

the SemTalk database. 

 

                                                
3 If you are using Visio Shapes frequently, it makes sense to change file path for stencils (2003) or “My Shapes” 

(2007) using Visio’s options dialog. 
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Figure 25: Adding an arbitrary Visio Shape to a process 

Visio masters, which as used as alternative Visio masters can not be used for new classes 

anymore. 

 

 

Instead of this bottom up approach we can also define new classes of systems on class pages. 

Create a new diagram of type “System Model” and drop some shapes there again. 

 

In the new diagram you can create classes and subclasses with attributes and associations. To 

add a new class, please use the “UML Class” shape. A “subClassOf” (or is a) relation 

between two classes is created with the “subClassOf” connector. Associations are made with 

the “Property” connector.It is a special behavior of class diagrams, that every class is 

automatically a subclass of their root class, which is in this case the class System. 

You can also add new classes by opening a Visio stencil or search for a shape. 

Drop the shapes onto a System Model.  Now you can create further subclasses and 

super classes. 
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Figure 26: Classes of Systems 

 

We have used the Visio shapes for Data store, Server etc
4
. Computer has been created using 

the UML Class master. 

 

The properties of the Visio master are becoming attributes of the class. In the following 

picture you can see the attributes coming from Visio such as “Serial Number” and “Asset 

Number” and the inherited attributes coming from the root class “Participant” marked with a 

“*”. 

 

                                                
4
 These shapes are much easier to use if you turn of “Snap to Member” (Format->Behavior) 
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Figure 27: Attributes imported from Visio Masters 

 

Now let us assume we need a class named CRM-System. We can simple define a subclass of 

data store.  

 

 

Figure 28: CRM System Class 
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Since CRM-System is a subclass of data store, SemTalk will use the data store shape for 

CRM-Systems.   

 

Visio does not contain a specific master for CRM Systems, but we can easily create a new 

master shape in Visio or reuse another Visio master for our purpose. The document stencil 

(Visio-> View->Document Stencil) contains copies of the used Visio masters. Copy the 

component master to the document stencil. Using right click master properties on the master 

you can rename the master to a class name of your choice. Please make a copy of “Data store” 

and rename it to “CRM-System”. 

 

 

Figure 29: Shapes for resources in the Document Stencil 

 

The CRM System master can now be used in the process model. 

 

 

Figure 30: Renamed Visio Master 
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NOTE: A good object oriented model has the definition of attributes on a common super class 

rather than classes created from Visio masters. 

 

6. Systems 
 

Please add a system (e.g. a CRM-System or simply a “Service” in case you skipped to 

preceding chapter) to the process: 

 

 

 

Figure 31: A System with a Visio Shape in a Process 

 

Connect it to “Assign Customer” with a “Message flow” connector. These relations describe 

whether you store information to the system or whether you read information from the 

system. 

  

NOTE: You may insert the same system more than once into a process using right-click insert 

and check “Show Existing”. You may not insert the same task call than once, but you can 

execute the same task multiple times. 

 

A system is a storage device for information or in general for objects. Objects can be stored in 

a system and afterwards be read from that system. Typical systems are the inbox of a mail 

client or a database. A system has a dedicated type. 

 

If you edit the buffer you can specify which type of information is stored in the system. 

The general tab is identical to other dialogs. 
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Figure 32: System: Measures 

 

Fixed Cost is used to assign cost for each information object, which is stored in the system. 

Capacity limits the amount of information objects that can be stored in the system. Flush level 

and flush number are used to specify that the information is send through and outbound 

“Message flow” link if a certain amount or time is exceeded.  

 

For the “Message flow” relation you can select the type of information which is accessed or 

stored. 

 

Note: You can also edit the label of “Message flow” connectors directly to specify the 

information. 

 

7. Refinements (Sub-Process) 
 

Note BPMN Methodology: 

 

Breaking down a task into more detailed tasks is expressed in the BPMN with multiple 

shapes such as “Sub-Process”. In SemTalk a refinement is more dynamic: A (sub-) 

process for the detailed tasks can be attached to any task. For every inbound sequence 

flow link an (internal) entry point is added to the refined process. For outbound 

Sequence flows an (internal) exit point is added.  
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Right Click on “Assign Customer” and select “Refine”. A dialog pops up asking for the name 

of the sub process: 

 

 

Figure 33: Creating a Refinement 

 

A new empty process with entry and exit point is generated: 

 

 

Figure 34: A new Refinement 

 

You can see in the explorer the new process as a child node of “Business Process Diagram-5”. 

In Business Process Diagram-5” “Assign Customer” is now marked with as “+” to inform you 

that is has a refinement. Any time you select “Refine” you open the refinement. The menu 

“SemTalk->Diagram->Go Up” navigates from the refinement to the refined process. 

 

NOTE: If you use the option “External” you can assign of process in a different model as the 

refinement. In this case the refinement works like a hyperlink to the other model. But you can 

not connect entry- and exit points. 

7.1. Attachments and Visio-Hyperlinks 

 

Refinements are used for a unique structured decomposition of processes. Attachments are 

used to assign unstructured information such as documents, hyperlinks or arbitrary Visio 

pages to an object. In order to add an attachment please uses the edit dialog. 
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Figure 35: Editing Hyperlinks 

 

Use Subaddress to attach other Visio pages. Address will be used to attach documents or 

Hyperlinks. Language marks the document for a certain model language. You may attach as 

many documents as you need. Please visit the general tutorial for further information. 

 

Navigation in the document and its HTML representation is realized via Visio-Hyperlinks: 

 

 

Figure 36: Navigation with Hyperlinks 
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8. Customizing Colors 
 

 

Figure 37: Colored Process 

You have the option to change the color of shape for each type separately without touching 

the Visio Master shapes. Select Activity, Gateway or Data Object in the “Objects” part of the 

SemTalk Explorer and select a color of your choice. 

 

 

9. Simulation 
 

Simulation is available for SemTalk BPMN Edition. This allows testing the logical behavior 

of your process in order to find possible deadlocks. 

Using colored Petri-Nets your can investigate your process in a dynamic environment with 

multiple inputs processed in parallel, in order to find out bottlenecks. 

 

Please refer to our Simulation Tutorial for Details. 
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Figure 38: Simulation 

 

 

10. Dialog View 
 

Dialog View allows controlling one Visio document from another. Every time you select a 

process shape in the main Visio document a shape (or “Control”) in the other Visio Document 

will be selected. This is intended to be used for the specification of IT-Systems, Workflows or 

Portals. It might be used in conjunction with the stepping mode of simulation. 

 

Dialog View can be opened from Tools->Dialog View->New/Open. The workspace will be 

split in two areas. You may create or modify user interfaces here. Any Visio document can be 

used. It does not have to be created with SemTalk.  
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Figure 39: Dialog View 

In order to connect a process element with a shape in the drawing please select both shapes 

and choose the option Tools->Dialog View->Capture. Each process element can only be 

assigned to one shape. Each time you select the process the shape will also be selected. This is 

actually what the Simulator does in Single-Step Mode. 
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Abb. 1: Dialog Tab 

 Using the dialog tab you can review and change your settings. Instead of 
connecting the Visio shapes, you may also connect the process element to 
hyperlinks. In order to do that you MUST open the browser via Tools->Dialog 

View->Browser.   

SaveAs Webpage will retain the links to an HTML representation of the 2nd Visio 

document. 

 

11. XPDL Export 
 

The XML Process Definition Language (XPDL) has it origin in the text-based workflow 

exchange format of the Workflow Management Coalition (WfMC Interface 1) 

 

• Allow tools to exchange process models 

• Format to exchange Process Definitions between  

o Components within Workflow/BPM Products 

o Different BPM/Workflow Products 

o Process Modelling/ Simulation tools and BPM/Workflow Products 

 

In SemTalk you’ll find XPDL Export at File->Export/Import->WfMC XPDL Export. 
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Figure 40: XPDL Export 

 

12. Importing from SAP7 
 

12.1. Import data from SAP Solution Composer 

You may use content from SAP Solution Composer in SemTalk EPC Edition and Visio 

(http://www.sap.com/solutions/businessmaps/composer/index.epx) in a pretty simple way. 

 

In order to get the SAP Look & Feel it is recommended to use the template „cview.vst“, 

which has the right colors and shapes. Supported diagram types are Component View and 

Collaborative Business Map. 

 

                                                
7  R/3 and AcceleratedSAP are registered trademarks of SAP AG 
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Copy (Crtl+C) a process at  Solution Composer and paste it at SemTalk (Crtl-V). Do not use 

Insert (Model) but Visio’s Paste command. Please select vertical swim lanes. 

 

 

Figure 41: SAP Solution Composer (1) 

 

 

SAP Content can (in SemTalk) only be used with vertical Swimlanes. Visio does not allow 

horizontal and vertical Swimlanes in one document. To try out the following must open a new 

document based on bpmn.vst. 

If you paste it into a process, the same process looks like this: 
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Figure 42: SAP Solution Composer (2) 

Via simple Copy & Paste you may also add variants and web service definitions of the ESA 

Preview System. 
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