
Using CAD to Construct Geologic Maps 

Introduction 
Computer-Aided Design applications such as AutoCAD and DraftSight can be utilized to construct 

geologic maps and cross-sections. These applications serve as “digital” replacements for traditional map 

drafting tools such as technical pens, protractors, etc. Designing maps with CAD produces significant 

advantages in terms of map accuracy, reproducibility, and efficiency. CAD skills are often sought after by 

prospective employers in the earth sciences. 

Calibrating Base Maps 
Raster base maps are often used as a starting point for the construction of geologic maps with CAD. If 

you want your maps to be usable by others you will need to calibrate it to some type of rectangular 

coordinate system such as UTM or State Plane. To do the calibration you need to have recognizable 

geographic (lat-long) points on the base map raster, such as the corners of a 7.5 minute quadrangle, and 

a utility that will convert geographic to rectangular coordinates like UTM. For this project we will use 

“Corpscon”, a free utility downloadable from the web. For this example we are using the Alexander City 

7.5 quadrangle with southwest corner geographic coordinates of 32 52’ 30’’ N and 86 0’ 0’’ W.  In 

Figure 1 you will see the setup portion of “Corpscon” needed to convert geographic to UTM NAD27 

coordinates. Figure 2 displays the southwest corner point conversion to UTM using the “Convert > 

Manual Conversion” menu selection. Proceed to convert all of the corner points to UTM coordinates and 

record them to a 0.1 meter precision.  

Start DraftSight and set units to 0.0001 precision for linear, and 0.0001 for angular measurements. Make 

the angle base at “90”, and angles direction clockwise. Create the layer “image” and make it the active 

layer. You will need the topographic base map image of the Alexander City quadrangle: 

 http://www.usouthal.edu/geography/allison/GY403/O32085H8.tif 

Use the “Insert > Reference Image” to insert the file “032086H5.tif” into the drawing. Use the settings 

indicated in Figure 3.This is the Alexander City 1:24,000 topographic base map, and by default it inserts 

with the lower left corner of the rater at coordinates (0,0), and with a size of 1.0 x 1.2 units. Use the 

“View > Zoom > Zoom Window” command to zoom in with as much detail as possible to the graphical 

scale at the bottom center portion of the map. Use the “getdistance” command to measure as 

accurately as possible the unit distance between reference marks that indicate a one kilometer distance: 

: getdistance 

Specify start point» {left-click on “0” mark on kilometer scale} 

Specify end point» {left-click on “1” mark on kilometer scale} 
Distance = 0.0747, Angle in XY Plane = 89.4578, Angle from XY Plane = 90.0000 

Delta X = 0.0747, Delta Y = 0.0007, Delta Z = 0.0000 

http://www.usouthal.edu/geography/allison/GY403/O32085H8.tif


Because the map distance represented by 0.0747 units is supposed to represent 1000 meters in real-

world UTM coordinates the initial scaling factor for the image is 1000/0.0747 = 13386.88. Use the scale 

command to scale the image: 

: scale 

Specify entities» {left-click on edge of image} 
1 found 

Specify entities» <Enter> 
Specify base point» 0,0 

Options: Reference or 

Specify scale factor» 13386.88 

Use “View > Zoom > Zoom Bounds” to re-display the extents of the scaled image. Note the change in 

coordinates as you move around the map. Zoom in to the graphical scale and use the “getdistance” 

command to re-measure the distance between the “0” and “1” marks on the kilometer scale. The 

distance should be close to 1000 units (meters).  

The map is scaled properly but is nowhere near the proper location for the UTM system. The “blue” tic 

marks around the map border are the UTM tic marks – you will see the “595” x and “3638” y kilometer 

reference marks near the southwest map corner. These should read “595000” and “3638000” units 

respectively when you align the cursor with the marks. To align the southwest corner with the UTM 

system use “Modify > Move”, however, first insert a “point” at the southwest corner of the map: 

: _POINT 

Active point modes: point mode=0 point size=0.0000 units 

Options: Multiple, Settings or 

Specify position» s  {change size=100 and type= 34} 

Options: Multiple, Settings or 

Specify position» '_ZOOM  

Default: Dynamic 

Options: Bounds, Center, Dynamic, Fit, Left, Previous, SElected, specify a scale factor (nX or 

nXP) or 

Specify first corner» _Window 

Specify first corner» {left-click on window corner near SW map corner} 

Specify opposite corner» {left-click on other window corner} 
Resuming POINT command. 

Options: Multiple, Settings or 

Specify position» {left-click to place point on SW corner} 

You now should have a reference point you can “snap” to accurately placed on the corner point. Now 

“View > Zoom > Fit” so you can see all of the map. Use the move command to move the SW corner to its 

correct absolute UTM position: 

: _MOVE 

Specify entities» {left-click on border of image} 
1 found 



Specify entities» {left-click on point at SW corner of map} 
1 found, 2 total 

Specify entities» <Enter> 
Default: Displacement 

Options: Displacement or 

Specify from point» node  {snap to SW corner point} 

of 

Options: Enter to use from point as displacement or 

Specify destination» 593551.347,3637682.032  {calculated with Corpscon for SW corner} 

The map should now be pretty close to correct position so check the coordinates of the UTM tic marks 

near the SW corner. They should be within a few meters of the correct values. Note that the final 

calibration is not yet complete so as you move away from the SW corner there will be more of a 

difference between the cursor coordinates and the map UTM marks. 

For the final calibration insert a point at the NE corner position calculated by Corpscon. Create a new 

layer for this point and name it “ref_pts”. Make the layer color magenta. Use “View > Zoom > Window” 

to zoom into the NE map corner. Use another point command to insert a point on the visual corner of 

the NE map corner. Now draw a polyline in the “image” layer from the SW and NE corner points in the 

image layer, and then draw a polyline from the SW corner point to the NE calculated point in the 

“ref_pts” layer. Your map should look like Figure 4 when zoomed in to the NE map corner. 

Next, use the “Tools > Inquiry > Distance” selection to measure the length of the “image” corner-to-

corner line. Use the entity snap “node” mode to snap to the line end points. Use the same command to 

measure the “ref_pts” layer line. The new calculated scale factor will be the ratio of the “ref_pts” layer 

line length divided by the “image” layer line length. Also note the “Angle in XY plane” (azimuth) values 

for both lines – the difference will be a rotation correction. In this example the map should be scale by 

18128.5517/18148.1326 = 0.99892. Use the “Modify > Scale” command to do this: 

: _SCALE 

Specify entities» {left-click on image edge to select} 
1 found 

Specify entities» '_ZOOM 

Default: Dynamic 

Options: Bounds, Center, Dynamic, Fit, Left, Previous, SElected, specify a scale factor (nX or 

nXP) or 

Specify first corner» _Window 

Specify first corner» {set a window corner in the NE map corner} 

Specify opposite corner» {set the other NE window corner} 
Resuming SCALE command. 

Specify entities» {Left-click to select  point in “image” layer} 
1 found, 2 total 

Specify entities» {Left-click to select point in “ref_pts” layer} 
1 found, 3 total 

Specify entities» '_ZOOM 



Default: Dynamic 

Options: Bounds, Center, Dynamic, Fit, Left, Previous, SElected, specify a scale factor (nX or 

nXP) or 

Specify first corner» _Fit  {zoom back to view entire map} 

Resuming SCALE command. 

Specify entities» <Enter> 
Specify base point» node  {snap to SE map corner point} 

of 

Options: Reference or 

Specify scale factor» 0.99897 

The map should now be accurately scaled. Now the map will be rotated for the final calibration step – 

use the “Modify > Rotate” command to do this. The rotation factor for this example is 39.5629 – 

39.5564 = 0.0065 degrees. You will rotate the image and the point in the “image” layer around the SW 

map corner point by +0.0065 degrees (clockwise): 

: _ROTATE 

Active positive angle in CCS: DIRECTION=clockwise BASE=90.0000 

Specify entities» {select the image} 
1 found 

Specify entities» '_ZOOM 

Default: Dynamic 

Options: Bounds, Center, Dynamic, Fit, Left, Previous, SElected, specify a scale factor (nX or 

nXP) or 

Specify first corner» _Window   {zoom into the NE map corner area} 

Specify first corner» 

Specify opposite corner» 
Resuming ROTATE command. 

Specify entities» {select the point in the “image” layer} 
1 found, 2 total 

Specify entities» {select the polyline in the “image” layer} 
1 found, 3 total 

Specify entities» '_ZOOM 

Default: Dynamic 

Options: Bounds, Center, Dynamic, Fit, Left, Previous, SElected, specify a scale factor (nX or 

nXP) or 

Specify first corner» _Fit   {zoom out to see entire map} 

Resuming ROTATE command. 

Specify entities» 
Specify pivot point» node  {snap to point in the SW map corner} 

of 

Default: 90.0084 

Options: Reference or 

Specify rotation angle» 0.0084 

 



The two polylines and two points in the NE map corner should now overlay each other. The map is now 

calibrated to the UTM system. As a check on the calibration insert the corner NW and SE points 

calculated by Corpscon into the “ref_pts” layer. The points should not be more than 10 meters from the 

visual corner for this map scale. Move all 4 map corner points to the “ref_pts” layer, and erase the map 

corner polylines. 

Map Border 
You should always draw a map border using calculated coordinates if possible- in this case the map 

corner points calculated by Corpscon will be used. Use the polyline command with an entity snap mode 

of “node” to snap to points. Create the border in a new “border” layer. Your map should appear similar 

to Figure 5. 

Water Boundaries 
Water bodies on geologic maps generally are polygons with a dark blue border and a light blue fill color 

that covers the geology polygons. The Alexander City quadrangle has significant water body boundaries  

that need to be traced. Remember that some of the larger streams and rivers may also define polygons 

that must be accounted for on the final map.  

The strategy for tracing the water body boundary must be well understood – because the map border is 

mathematically defined we will always “snap” to it using “nearest” when beginning a water body 

boundary at the map border. For polygons totally contained within the map area care should be taken 

to make sure that the last polyline vertex snaps to the first vertex at the start of the boundary. At this 

time create a layer named “WaterBodies” and color the layer dark blue. Make it the active layer. Set the 

“ESnap” to “Nearest” only. Zoom “window” to an area that shows a water boundary adjacent to the 

border (see Figure 6). Start the polyline by snapping to the nearest point where the water boundary 

intersects the map border. The Figure 7 graphic displays the vertices of the water boundary to give you 

an idea of the spacing between selected points. Figure 8 shows the map area with the water boundaries 

traced with polylines.  

Water Body Polygon Fills 
To fill in polygon areas you must use the “Draw > Hatch” command to fill in a polygon area with a 

“hatching” pattern – in this case the “solid” pattern. Later the solid color can be made “transparent” 

through the layer control window so that entities below it can be “seen” through the fill. However, to fill 

a polygon with the “hatch” command you must first ensure that all of the polylines that define the 

polygon begin and end on the polygon perimeter. For example, the water body in Figure 7 cannot yet be 

filled because one of the bounding polylines – border – does not begin and end on the polygon 

perimeter. We need to “break” a segment of the border so that that segment begins and ends along the 

polygon perimeter. In fact, inspection of Figure 7 proves that two segments must be broken out of the 

border. Zoom in to the area of Figure 7, then create and make active a new layer named 



“WaterBodyFills” that will receive all of the new “hatch” solid fills. Turn off the “image” layer so that you 

can better see details. Select the “Modify > Split” menu item: 

:split 

Specify entity» 
Options: First point or 

Specify second split point» f  {select first point option} 

Specify first split point» int  {snap to intersection} 

of 

Specify second split point» @0,0   {specify a point exactly on the “first” point} 

In effect the above command “split” out a segment of “zero” length since the first and second points 

where exactly on top of each other. This has the effect of splitting the border polyline at the intersection 

of the water boundary line. Use the same procedure to break the border polyline at the other three 

intersection points. The window dialog settings for the “Draw > Hatch” command is shown in Figure 9. If 

you don’t pre-select the polygon bounding polylines before this command you can click on the “entities” 

button to specify them. Always use the “preview” option to view the result- if everything is OK then you 

can press <Enter>, otherwise use <Esc> to return to the dialog. If the preview shows no fills or incorrect 

fills the polyline perimeter has not been correctly defined.   

When the fill is created it will take on the color assigned to the “WaterBodyFills” layer because the 

default color assignment is “ByLayer”. To override this first select the hatch solid fill by left-clicking on it, 

and then find the color control button in the “Properties” window. Change the color from “Bylayer” to 

“Cyan”. The fill hatch should now take on the cyan color. Note that this technique works with any type 

of entity – you can always override the color assignment from “ByLayer” to a specific color.  

Proceed to finish adding all of the fills to the water bodies. Note that the closed water bodies in the 

interior of the map are very simple to fill with the “hatch” command – just the single polyline boundary 

needs to be selected. The fill will always succeed if the last vertex of the polyline has been “snapped” to 

the first vertex.  If the fill fails you should zoom window to the area that displays the 1st and last vertex 

and then use entity snap to snap the last vertex to the first vertex. 

Entity Creation/Edit Modes 
At this point it is important to understand entity creation modes used by DraftSight. Whenever a new 

entity is created by a drawing command it is assigned a default layer, line type, and line weight (width)  

attribute. You may have noted the “properties” toolbar located in the upper center of the DraftSight 

window that lists “Color ByLayer”, “ByLayer Solid Line”, and “Line weight ByLayer”. These indicate that 

when new entities are created the current layer controls the color, line type, and line weight properties 

because of the “ByLayer” setting. You may recall that the layer window dialog allows you to set these 

and other layer properties. If you change the “ByLayer” settings to a specific color, line type, or line 

weight then when a new entity is created it will have that property no matter what layer the entity is 

assigned to. The user is free to use either the layer or entity control of how properties are assigned, 



however, it is advisable to choose one method and stick with it otherwise you can become very 

confused. 

The “Layer Manger” toolbar is also a very useful feature to be aware of when working in the DraftSight 

map window. By default the toolbar is located at the upper left but like all toolbars may be re-

positioned. You can recognize it because it contains the same color, line type, etc. icons as in the main 

layer window. The currently active layer is listed when no entities are selected along with the current 

entity creation properties. However, if you select an entity with a left-click the toolbar will report the 

layer name and entity properties for the selection. You should realize that if you now click on the layer 

manager toolbar and change to another layer name the selected entities will be “moved” to that layer. 

By the way, the same is true for the entity properties toolbars. This is a very efficient way to move 

selected entities from one layer to another. If multiple entities are selected that are in different layers 

the layer manager toolbar will be blank. 

Another important command to be aware of is the “select” command that is run from the command 

line. Using this command you can use a variety of selection methods to build a “selection set” of 

multiple entities that can be recalled and “fed” into a later command. For example, if you are 

attempting to hatch fill a complex polygon boundary composed of many polylines you can first make a 

selection set with “select” and then use “prev” when prompted to select entities for the hatch 

command. The advantage is that if you accidently left out one or two polylines you can still select them 

and add them to the selection set. 

Another aspect of forming a selection set is the use of selection filters (below is a modified copy of the 

DraftSight help topic on selection methods): 

  

Window (w)   

Specifies all entities that lie completely within a rectangle defined by two 

opposite points. 

 

A rectangular selection Window is defined by two opposite corner points. 

Position the pointer on the first corner of the selection window and click that 

point. Click on the second corner point to specify all entities located entirely 

within the window.  

Crossing (c)   

Specifies entities within a rectangle defined by two opposite points. The 

entities can extend beyond the rectangle. 



 

When specifying entities using the Crossing method, entities whose outlines 

intersect or lie within the window are selected. Position the pointer so that its 

window includes or intersects the desired drawing entities.  

WPolygon (wp) 

Specifies entities that lie completely inside a polygon defined by specified 

points. 

 

Like the Window mode, the Window Polygon mode specifies all drawing 

entities whose contours lie entirely inside the selection window. Unlike the 

Window mode, the Window Polygon mode lets you sketch an irregular 

window with unlimited corner points.  

To use WPolygon, define the corner points for the selection window. Polygon 

lines can intersect themselves and form loops. Press Enter to complete the 

selection window. All entities that lie totally inside of the window are selected. 

 

CPolygon (cp)  

Specifies entities within a polygon defined by specified points. The entities can 

extend beyond the polygon. 

 

The Crossing Polygon selection mode also creates an irregularly formed 

window with unlimited corner points. All entities positioned inside or 

intersected by the selection polygon are specified. 

Define corner points for the selection window. The preview mode shows the 

emerging polygon. Polygon lines can intersect themselves and form loops. 

Press Enter to complete the selection window. All entities within and 

intersecting the crossing polygon are specified for modification. 

Fence (f)  

Specifies all entities that pass through a fence you determine. The Fence 

method is similar to CPolygon except that the fence is not closed. 

 

The Fence mode is an effective variant of a crossing selection mode. The 

entities to specify are not enclosed or crossed by a window, but instead are 

"cut through" by a line, or "fence".  

Define the fence with unlimited points. The fence can intersect itself. Press 

Enter to complete the fence. All entities that intersect the line are added to the 

selection set. 

 



Previous (p)  
Specifies the most recent entity selection set again.  

The Previous option restores the previous selection set.  

Note: As with the Last and All methods, entities on a frozen Layer are not selected, and entities on a locked 

Layer are selected but cannot be handled. 

 

Last (l)  
Specifies the most recently created visible entity. 

The Last option adds the last drawn entity to the selection set. Note: If the last drawn entity is located on a 

frozen Layer, no entity is selected. 

Group (eg)  
Specifies the entities of a specified EntityGroup. 

The EGroup option selects the entities of an EntityGroup specified by the group's name. Create EntityGroups 

using the EntityGroup command. 

Add (a) / Remove (r)  
Toggles between the default Add and Remove mode.  

The Add option is the default mode, letting you specify entities and add them to the selection set at any 

time. The Remove option instead removes previously selected entities from the selection set. Remove 

mode changes the entity selection prompt to Remove Entities. Entities already selected are removed from 

the selection set if they are selected again. 

Undo (u)  
Deselects the most recently selected entities. 

The Undo option reverses the most recent selection. 

All (all)  
Specifies all entities on all Layers. 

The All option selects all entities in the drawing except those located on frozen Layers. 

Single (si) / Multiple (m)  
Toggles between the Single and Multiple selection method. 

With Single mode, you specify one entity, then entity selection completes. With Multiple mode, you select 

entities by specifying multiple points without highlighting the entities. Multiple mode also selects two 

intersecting entities even if the intersection point is chosen twice. 

 

Auto (au)  

Toggles to the Automatic mode where pointing to an entity selects the entity. 

Pointing to an empty location initiates an entity selection box. 

mk:@MSITStore:C:/Program%20Files/Dassault%20Systemes/DraftSight/Help/english/DraftSight.chm::/html/hlpid_group.htm


Auto and All are default modes for entity selection. 

 

Box (box)  

Specifies entities with a pointer method that is a combination of Windows and 

Crossing. If the opposite points of the selection rectangle are specified from 

right to left, Box is equivalent to Crossing. Otherwise, Box is equivalent to 

Window. 

 

Drawing the window from left to right specifies entities within the selection 

window. 

 

Drawing the window from right to left specifies entities within and intersecting 

the selection window. 

  

Adding Geologic Contacts 
The geological contacts normally are derived from field maps that contain pencil or ink lines that are 

traced on the paper map as field work progresses. Approximate contacts are normally indicated by 

dashed lines. Fault contacts and map-scale fold structures often use a heavy weight (0.7mm) line width, 

although this may be difficult to reproduce with a pencil on a field map. The field map should be 

scanned on a high-resolution scanner and then calibrated to the map coordinate system using the same 

technique employed for the base map image. Remember that the field map is likely to have been 

stretched and/or folded so that it will have more calibration “error” attached to it. 

When you trace the contacts with the polyline command follow the below rules: 

1. Always use “nearest” entity snap mode to begin or end a contact exactly on the map border. 

2. Zoom in so you can see the details of the contact. 

3. Use enough vertices when making the polyline so that the contact looks “natural”. It is 

usually counter-productive to try to fit spline or curves through vertices to get a natural 

appearance.  

4. If the contact line type changes along strike (i.e. from regular to approximate) continue to 

digitize a continuous polyline. You can always return back to it to “split” it into 2 segments. 

If the contact is a polygon perimeter (likely) you would have to join the segments anyway so 

wait until all polygon fills are completed. 

5. You can use “pedit” to insert extra vertices if they are needed along the contact. 



A Word about Blocks 
Blocks can behave in bizarre fashion sometimes so CAD users may tend to avoid them, however, they 

are very powerful so if you understand how they work you can work much more efficiently. Blocks are 

nothing more than one or more entities collected together to form a group of entities. When a block is 

defined in a drawing it exists as a memory image. To use the block you have to use one of the 

commands that can insert the block in a drawing such as “insert”, “marklengths”, “pattern”, etc. The 

insert command, for example, can insert a block at any (x,y) coordinate, rotation, and scale.  Blocks may 

contain associated “attributes” that act as a database “field” to contain useful information. For example, 

in some of the below examples the “dip” amount of strike and dip blocks are attributes. When blocks 

are inserted they may originate as a file so it is possible to define useful blocks, such as a north arrow, 

and insert the block directly from a file. When this occurs the file is read into memory as a block 

definition, and that image is then inserted. The memory image of the block is saved with the drawing file 

so if you change the block definition in the block file you will not see the changes in the drawing file 

unless you “re-insert”.  

Block Base Point 
The base point of the block is the coordinate relative to the entities in the block where the block will be 

inserted at the cursor position or coordinate calculated by the inserting command. For many blocks this 

would be the geometric center of the entities but it really depends on the design of the block and its 

intended use. For example, a block designed to be used as the “teeth” on a thrust fault contact would 

not have the base point at the geometric center but rather on the center of its baseline. When a new 

block is defined by itself in a file the base point is (0,0,0). If a block is defined with the “Draw > Block > 

Define” command the base point can be defined within the window dialog.  

Block Re-definition 
The power of blocks comes from the ability to re-define a block definition. For example, let’s assume 

that you have inserted 1000 S1 foliation block markers in a geologic map drawing file. When you 

designed the block you left the “tooth” mark indicating dip direction un-filled but now you want it filled. 

If you had designed the block by itself in a file all that you would need to do to make the change is: 

1. Open the block file and fill in the “tooth” portion with a solid fill and save the file. 

2. Open the geologic map drawing file with the 1000 S1 inserted blocks. 

3. Use the command “Insert > Block” and pick the S1 block using the “Browse” button from the 

file you just updated. 

4. Proceed to insert the block off to the side of the map. You will be asked if you want to 

redefine the S1 block – indicate yes. 

5. Insert the block somewhere were you can easily locate and delete it. All of the other S1 

blocks will be updated. 

Note that if you had not inserted the S1 markers as blocks you would have to edit 1000 markers to add 

the fills! 



Block re-definition does not have to rely on an external file. If you need to re-define a block inside of an 

existing drawing follow the below steps: 

1. Make the “0” layer the current layer. 

2. Insert the block that you want to change with scale of 1.0 in a corner of the drawing away 

from other entities. 

3. Use the “Modify > Explode” command to break apart the blocks into raw entities. 

4. Make changes to the block entities. 

5. Use “ Draw > Block > Define” to re-define the block. Because the block already exists in 

memory you will be asked if you want to “redefine” it – indicate “yes”. 

 

Block Layer Control 
The way that blocks are assigned to layers can get complicated. Remember the following rules: 

1. If the entities in a block were originally in the “0” layer, whatever layer is the current layer 

when the block is inserted will be assigned to that entity.  

2. If the layer property of an entity in the inserted block is a name other than “0” then that 

entity will retain that layer name. If you are inserting from a file and the entity layer does 

not exist in the current drawing it will automatically be created and its properties will be 

inherited. If the layer name exists whatever layer properties it has will be retained. 

3. If a block is exploded any block entities in layer “0” will be deposited in the current active 

layer. Otherwise they will be deposited in the layer of their origin. 

Note that you should be wary of constructing regional geologic maps by inserting multiple quadrangles 

of adjacent map area as blocks. To enable editing of a map you will have to “explode” the block insert to 

be able to access individual entities. When you do this remember that the CAD program keeps a 

memory image of the block in case you want to insert it again. Because individual maps may be very 

large you can pretty quickly bring even the fastest computers to a slow crawl. You can minimize this 

effect by using the “purge” command after each explode to remove any unused block images.  

Adding Geologic Station and Structure Data 
While it is easy to add station position markers and oriented structure data using standard CAD 

commands it can certainly become tedious and time-consuming. Even if each symbol has been defined 

as a block you would still have to specify the coordinates of the insertion point, the scale, and perhaps 

the rotation and dip/plunge text attribute for each “insert” command. Additionally, the text attribute 

will be rotated depending on the trend of the structure data so you will have to use an attribute edit 

command each time to change the rotation back to “0”. This will take a lot of time if you have hundreds 

of data points. A better solution is to design a spreadsheet or database table that contains the observed 

data and use the “MAPPRO” utility program to post the data on the map. The utility map be freely 

downloaded at: 



 http://www.usouthal.edu/geography/allison/mappro/mappro.htm 

 

Below are the steps for (1) posting station location data, and (2) structure data. 

 

Posting Station Data  
In this example we will go through the steps of posting a station marker based on GPS data downloaded 

to a Excel spreadsheet. Figure 10 contains the layout of the first page of data. Note that first 2 columns 

contain the GPS location data in decimal degree format, and the 3rd column contains the station ID. The 

MAPPRO utility converts the geographic coordinates to UTM NAD27 coordinates. At this time use “Insert 

> Block” to insert the block “st” that is the standard station symbol marker in the block folder made 

available on the web site: 

 http://www.usouthal.edu/geography/allison/GY403/struc.zip 

Use the “Browse” button in the Figure 11 dialog window to browse to the folder where the downloaded 

blocks are located. Look for “st.dwg”. Go ahead and insert the block along the margin of the map to add 

it to the diagram, but erase it after adding it – the MAPPRO utility will actually add all of the station 

markers automatically. Note that the insert scale factor of 50 is appropriate for this map scale. 

 

Now it is time to run MAPPRO so start the application. Make the “Edit Window” the active window by 

clicking on it. Now load the spreadsheet that contains your data. Copy the cells containing your data and 

then “paste” into the MAPPRO edit window. You may need to format the latitude and longitude cells to 

7 decimal places to maintain precision before the “copy”.  Follow the below menu selection in MAPPRO: 

1. Select “Settings > UTM” and set the zone to 16 – correct for Alabama. 

2. Select “Settings > Script File Setup” and set to values in Figure 12. 

3. Select “Settings > Results Window Format” and use “standard print out”. 

Note that the destination folder for the script file should point to an existing folder on your device. The 

name of the block (“ST”) must match the name of an existing block in the DraftSight drawing before 

running the script. Now is the time to process the data in MAPPRO – select “Run > Process Edit Window” 

to do this. Note that the output in the results window should show as UTM coordinates that fill within 

the map area. See Figure 13 as an example of the output. During processing of the edit window data 

MAPPRO also produced a script file containing the commands necessary to insert a “ST” block at each 

data point in the edit window. The ID of each point will be the attribute for each block insertion. They 

will be inserting into the layer “stations” with a scale factor of 50.  



Return to DraftSight and select “Tools > Run Script”. Navigate to the location where MAPPRO created 

the script file (.SCR) and select the file – in this example “ac_st.scr”. The station markers should now 

appear on the map. Figure 14 displays a zoom in of an area with several markers.  

Posting Structure Data 
Posting structure data with MAPPRO is very similar to posting station data, however, you must take care 

to format the data correctly in the spreadsheet and match the data type settings in MAPPRO. Figure 15 

contains an example of the input data format for planar quadrant S1 foliation, and the output results. 

The settings were the same as station data above with the addition of “Settings > Map Data Format” set 

to “Data Type = Planar” and “Orientation Format = Quadrant”. Figure 16 contains the settings 

appropriate for S1 data for producing the script file: 

1. Note that the scale is 200. 

2. The angle base is 90.0 – make sure the setting in the CAD file matches this before running 

the script. 

3. The angle direction is clockwise – again you must match this in the CAD file before importing 

the script. 

4. Note that you should match the CAD application that you are using – AutoCAD or DraftSight. 

Run the “script” command to import the S1 data. Figure 17 contains a “zoom in” view of the S1 data. 

Note that the S1 symbols are oriented along strike, and the dip attribute is rotated to be perpendicular 

to the strike line. The angle “base” and angle “direction” are controlled through “Format > Unit System” 

command. 

The difference in the “AutoCAD” versus “DraftSight” format is that with “AutoCAD” selected the dip 

attribute text is automatically edited to have no rotation in terms of text orientation. This is not possible 

with “DraftSight” scripts, although the results of the “DraftSight” format will work in AutoCAD as well – 

the text will be oriented parallel to strike as in Figure 17. In “DraftSight” mode the text rotation can be 

corrected with the “Modify > Entity > Block Attribute > Single”  command: 

:-EDITBLOCKATTRIBUTE 

Default: Yes 

Confirm: Edit block attributes one at a time? 

Specify Yes or No» y  {“yes” to one at a time} 

Default: * 

Options: * to select all blocks or 

Specify block(s)» * {use wildcard} 

Default: * 

Options: * to select all attributes or 

Specify attribute name(s)» * {use wildcard} 

Default: * 

Options: * to select all attribute values or 

Specify attribute value» 28 {match the value of the attribute you want to edit} 

1 found  {Left-click on block or attribute} 

1 block attributes selected.   



Default: Next attribute 

Options: Height, Insertion point, Layer, LInecolor, Next attribute, text Rotation, Textstyle or 

Value 

Specify option» r  {specify text rotation} 

Default: 106.0000 

Specify new text rotation» 90  {correct for angle base at north} 

Default: Next attribute 

Options: Height, Insertion point, Layer, LInecolor, Next attribute, text Rotation, Textstyle or 

Value 

Specify option»<Enter> 

This will “un-rotate” the text attribute. Note that to look normal the text rotation is the same as the 

base angle – in this case 90 (north). 

You may have wondered about the scale factors used in the above examples. Consider that all of the 

structure symbol blocks (st, s1, f1, etc.) that you have downloaded are designed on a 1 x 1 unit grid. Also 

consider that the map scale is 1:24,000, and that translates to 1 plotted inch = 609.6 meters. Therefore, 

if you want the strike line of the S1 block to be approximately a 1/3 inch on the plotted map then a scale 

factor of 200 is needed (200/600 = 1/3). If you want the station markers to be about 0.25 the size of the 

structure symbols then 200 * 0.5 = 50. When using the structure symbol blocks remember to account 

for the scale of your final plot in this manner and you will not have any problems. 

Adding Geological Contacts  
Geological contacts are depositional, intrusive, unconformable, or faulted, and may have a specific line 

type symbology associated with the type of contact (i.e. teeth on the hanging wall of a thrust fault). The 

contacts also form the perimeter of a polygon that will contain a solid or pattern fill that symbolizes the 

lithology exposed in that polygon area. For these reasons care must be made in how the contacts are 

created with the polyline command, and how they are organized into layers. A certain strategy must be 

taken that takes the following constraints into account: 

1. When contact line type and symbols are inserted along a contact polyline the polyline needs 

to be continuous – all segments must be joined together as a single polyline.  

2. When 2 or more polylines intersect along a lithologic polygon perimeter all intersecting 

polylines have to be broken with the “break” command so that the ending vertices of all 

polylines converge at the same point. 

Because of the above constraints I personally like to define the line work first, and then go back and 

create the polygon fills last.  

At this time download the scanned geologic filed map “ac-geo.tif” at: 

 http://www.usouthal.edu/geography/allison/GY403/ac-geo.tif 

 

http://www.usouthal.edu/geography/allison/GY403/ac-geo.tif


Proceed to calibrate it to the UTM system as you did with the DRG base map. Place this image file in the 

layer “ac-geo”. If the image obscures other layers use “Tools > Display” to move it to the “background” 

to other layers display on top of the image. Turn off the “image” layer so it doesn’t interfere with the 

geologic map. Zoom into the NE corner of the map. You should be able to make out geologic contacts in 

“pencil” visible on the scanned map. These are the contacts that will be lithologic polygon boundaries. 

Set the “ESnap” modes to “nearest” only, and then turn on “ESnap”. Make a layer named “contacts” and 

make it the active layer. Start the polyline command and snap to the nearest point on the border and 

continue to trace the contacts by setting vertices with a left-click. When reaching the intersection with 

the fault contact make the last vertex end on the fault contact. Figure 18 displays the completed contact 

with vertices selected so you can get a sense of the spacing between vertices.  Next, trace the full length 

of the fault contact (i.e. stick and ball symbols on the hanging wall) visible in Figure 18.  Put this fault 

contact in the layer “Fault-contact”. Make this the active layer, and assign it a line weight of 0.7mm 

(thick). Note that although the line weight is fairly thick, you will not see the effect until you plot the 

drawing. Remember to use “nearest” snap to terminate the fault contact on the south map border.  

Now let’s add the “ball and stick” symbol line work to the fault contact. The symbol has already been 

ceated as a block in the ZIP archive folder downloadable from: 

 http://www.usouthal.edu/geography/allison/GY403/blocks.zip 

Make the current layer “0” and zoom into the SW corner of the map area. Use “Insert > Block” to insert  

the “downbk.dwg” block with the settings in Figure 19. As indicated the block is scaled by 150, 

therefore, the size of the block will be approximately 150 meters long because the block is designed on a 

1 x 1 unit scale. After the block is inserted make a copy with the copy command and “rotate” it by 180 

degrees. Then use “Modify > Explode” to ungroup the entities in the block. The next step is to make two 

copies of this block at the current scale named “downbk1” and “downbk2”. Now use the “Draw > Block 

> Define” to define the new block as in Figure 20. Note that the base point for both blocks is the end 

opposite the “ball”.  

The “MARKLENGTHS” command can be used to automatically insert block symbols along the length of a 

polyline at a specified interval. Additionally, the command orients the block parallel to the trend of the 

line making it useful for adding line work symbols to a geologic contact. At this time zoom out to the 

map extent so you can see all of the fault contact and then run the “MARKLENGTHS” command at the 

command line: 

: MARKLENGTHS 

Specify entity» {left-click on the fault contact} 

Options: Block or 

Specify length of segment» b  {specify “b” for block} 

Specify block name» downbk1  {block name} 

Default: Yes 

Confirm: Align block with entity? 

Specify Yes or No» y {aligns the block along the trend of the contact} 



Options: Block or 

Specify length of segment» 500  {this is the length between symbols} 

Note that if the symbols are inserted on the wrong side of the contact, simply use the “Edit > Undo” 

command to erase the blocks, and then re-run the “MARKLENGTHS” command but use the “downbk2” 

block instead.  

Adding Lithologic Polygons 
After geological contact line work is completed proceed to construct lithologic polygon fills with the 

“Draw > Hatch/Fill” menu command. Before starting the command make sure that the perimeter of the 

polygon contains polyline segments that terminate at perimeter intersections. As an example zoom into 

the NE corner of the map area. Figure 21 displays the perimeter of the polygon to be filled with the 

color for “weh”. Note that the map border needs to be split at 2 intersections, and the fault contact 

needs to be broken at 1 intersection. Turn off the “ac-geo” image layer so that you can see the polygon 

perimeter clearly. Use the “Modify > Split” command to split the map east border where the fault 

contact intersects. Use the “ESnap” modes “intersect” to make sure that you snap to the exact 

intersection. Make sure that you use the “First” option, and that the 2nd split point is “@0,0”: 

: _SPLIT 

Specify entity» {left-click on border} 

Options: First point or 

Specify second split point» f  {use “first” point option} 

Specify first split point» {snap to intersection} 

Specify second split point» @0,0   {make 2nd point same as 1st point} 

By making the 2nd point the same as the 1st split point you are making a “split” of 0 length. Use the 

“split” command to split the fault contact where it intersects the regular contact. Don’t worry about the 

stream inside the polygon – the water bodies are polygon fills that are in a separate layer above the 

lithologic polygons so you should ignore them when filling the lithologic polygons. The “weh” polygon 

perimeter should now have ending vertices at the intersection points. 

Create a layer named “Lithology_Fills” and make it active. This is the layer that should receive all of the 

lithologic polygon fills. Start the “Draw > Hatch/Fill” command from the menu. The “Hatch” command 

has a lot of options but these are the ones that need to be changed from the default (Figure 22): 

1. Select the “Solid” pattern out of the “Predefined” types. 

2. Select the polygon perimeter polylines with the “Specify Entities” button in the upper right. 

3. Make sure that the “Keep hatch and boundary related” is unchecked. 

When the above are set try the “preview” button to preview the fill. If it appears correct on the preview 

as in Figure 23 press <enter> to accept the fill. If the preview is not correct that means that the polygon 

perimeter geometry is not correct – press <Esc> and then <Cancel> to abort. Find the error before 

attempting to run the “Hatch” command again. 



The color of the fill will match the default color of the layer- if the “weh” should be a specific color select 

it with a left-click. Either from the color control toolbar or the properties window change the color 

“ByLayer” property to the required color. When you change the color or any other property of an entity 

it automatically is elevated “above” all other layers so you will see the water boundaries and the 

perimeter contacts obscured by the fill. While the fill is still selected use “Tools > Display Order > Send to 

back” to send the fill below all the other layers. Turn on the “image” layer at this point. If the image is 

above the new fill, use “Tools > Display Order > Send to Back” to set it below the lithologic fill.  It would 

be nice if the fill were 50% transparent so that the topographic base map could be “seen” through the 

lithologic fill – make this happen with the layer control window “transparency” option for the 

“Lithologic_Fills” layer. Figure 24 displays the effect of the transparency. 

Continue to fill in the lithologic polygons using the above methods. If a polygon perimeter is a single 

polyline remember that the polyline 1st and last vertex must be at the same exact position so if you have 

difficulty filling those polygons zoom window so that you can see the individual vertices when you select 

the polyline. Use the “end” snap mode to snap the last point top the first point. 

If you would like to use patterns rather than solid fills you can certainly make use of a wide range of 

patterns built into CAD (cross-hatch, ruled, crosses, etc.), however, note that these patterns are scale 

dependent and have a default scale factor. If you are in model space and are plotting at 1:24k scale then 

1 plotted inch = 609.6 meters, therefore, a scale of 200 would give several ruled lines per 0.33 inches. If 

the default scale of 0.25 were not changed the ruled lines would be so close together that the hatch 

pattern would appear solid. You may adjust the hatch scaling factor with the “Modify > Properties” 

menu option to get the optimum scale. Hatch patterns do not have a background fill color so they are 

inherently transparent – you can “see” through them.   

Geologic Contacts Revisited 
Geologic contacts may change their line type along strike based on data density. For example, in the NE 

corner of the map example there is not a lot of data coverage so the fault contact will be changed to an 

approximate type (dashed) from just east of the intersection to the east map boundary. Make a new 

layer named “Approx_Fault” and make its line type “dashed” with line weight = 0.7mm. Within the layer 

control window you can select from various different line type styles. 

Now use “split” to break the fault contact just east of the intersection with the regular contact. Then 

select the polyline and change it to the “Approx_Fault” layer. Select the new polyline segment and make 

sure the following are set in the properties window: 

1. LineScale= 200 

2. LineStyleGen = Enabled 

The line type should now appear dashed as in Figure 25. Remember that you should not split contact 

polylines until you are done inserting line work symbols. Otherwise you would have to “re-join” the 

polyline segments to add the line work symbols, but that would merge the contacts into a single line 

type. 



Plotting the Map 
There are several methods for setting up a plot – in this example we will use the “sheet” concept. A 

sheet represents the paper media that will be used to plot the map on by the printer/plotter – in this 

case Architectural E (48 x 36 inches) in landscape mode. When you work on the “sheet” you are working 

in “paper” space in inches. On the paper you have one or more “viewports” that provide a window into 

the map area. You use the “mspace” and “pspace” commands to switch between map (model) and 

paper space. By default when you click on one of the “sheet” tabs you will be in paper space. 

At this time click on the “Sheet1” tab. Select from the main menu “File > Print” to bring up the print 

dialog window in Figure 26. You should select the printer device first- in this example the HP5500 

Plotter. Then select the appropriate paper size, in this case Arch E (48 x 36 inches). In the print scale 

section select 1:1 (1 plotted inch = 1 pspace unit) because we are using the sheet setup. Make sure that 

the units in the scale settings are “inches” if you are using English units. Note that the “Print Range” 

should be set to “sheet”. The geometry orientation should match the way that your sheet is designed – 

in this case landscape. Under additional options you may check the “Print transparency” option if that 

applies to your plot. Press <Esc> to return back to the sheet window. 

In the Figure 27 sheet view note that as you move the cursor around that the coordinate readout is in 

inches relative to the sheet lower left corner. Around the edges of the sheet are dashed black lines 

marking the “hardware” print margins. Any entity outside this boundary will not be plotted. Inside the 

hardware margins are 2 gray rectangles. These are “viewports” that are windows into the “model space” 

of the map. The entities outside the viewports are drawn in “paper space” using paper coordinates so, 

for example, text heights are 0.1 or similar values. You use the same commands to create entities in 

paper space that you do in model space but remember the difference in scale. In this example the 

legend and title have been drawn in paper space. If you left-click on the viewport containing the map its 

properties will appear in the properties window. Note that the “custom scale” is set to 0.00164. This is 

the scale factor to convert the model space units to inches that are being used in paper space. At 

1:24,000 relational fraction 1 plotted inch = 609.6 meters, so 1/609.6 = 0.00164. When the viewport is 

initially created it will have a scaling factor that allows it to use a significant portion of the sheet area but 

it will not match any particular map scale unless you are using a specialized template designed for 

1:24,000 scale (possible but not likely). Normally this is one of the first things to set when working with a 

sheet so that the size of the viewport can be set large enough to show all of the map at the proper scale. 

The other viewport is set to the same scale and is sized to accept a cross-section that has not yet been 

created. You can create any number of viewports with the “viewport” command.  

When a new viewport has been created and scaled the next task is to center the map entities in the 

viewport. To do this you have to enter model space with the “mspace” command. At this time select the 

viewport around the map and type “mspace” at the command prompt. Then run the “View > Pan > 

Dynamic” to see the effect of panning in mspace. Also note the coordinate cursor readout- you will see 

model space coordinates while moving in the viewport window. The pan command can be used to 

center the map in the viewport. If the map is too large then use “pspace” to return to paper space and 



adjust the size of the viewport window. Note that viewports exist in a layer and will plot just like a 

rectangle. If you don’t want an extra border around the map, make the viewport layer non-printable.  

When you have completed adding legend items to the paper space then use “File > Print” to print the 

map. 

Advanced Commands and Concepts 
There are several advanced commands and concepts that can significantly increase the users drawing 

and/or editing efficiency. Below are several that have proved to be very useful: 

1. Select {builds a selection set of entities using standard entity “snaps” } 

2. Filter  {builds a selection set based on a entity database query} 

The select command uses the standard entity selection “snaps” to build a selection set from the 

standard command line. This allows the user to build a complex selection set before actually applying it 

to a drawing command such as “hatch/fill”. Follow these steps: 

1. Run the “select” command from the command prompt and build the selection set. 

Remember that you can use geometry overrides like “wpoly”, “add”, “rem” so add or 

subtract entities from the selection set. Press <Enter> when done. 

2. Run a command that requires entities such as “hatch/fill”. When you get the “select 

entities” prompt respond with “prev” for previous selection set.  

3. You can continue to use geometry overrides like “wpoly” after the “prev”. Press <Enter> 

when all entities are selected. 

The “select” command is most effective during the creation of a geologic map because it is not 

uncommon to have a geologic polygon perimeter made up of 10 or more entities. If you run the 

“hatch/fill” command and accidentally miss one or more of the entities during the hatch command it will 

fail and then you are faced with trying to find the missing polyline segments while in the middle of the 

hatch command. If you build the selection set with “select”, run the hatch command that fails, you can 

simply cancel and then run “select” again. At the prompt specify “prev” again to gather all of the 

previous entities, and then proceed to zoom in and pan to find the missing entities. This is often easier 

than trying the same procedure in the middle of the hatch command. 

The “filter” command becomes very useful when you are dealing with many entities that have 

something in common. For example, in the example geologic map in Figure 27 what if many of the 

lithologic polygon fills are “above” the contacts so that the contacts are obscured. You could run the 

filter command as in Figure 28 to form a selection set of all of the fills. You could then run “Tools > 

Display order” and use “prev” to feed the selection set formed by the filter command to move all fills in 

the “LithologicPolygons” layer to the background.  

 

  



  

 

 

 

 

  

Figure 1: Corpscon setup for geographic > UTM NAD27 coordinates. 



 

  

Figure 2: Using Corpscon to convert from geographic to UTM  coordinates. 



 

  

Figure 3: Inserting base map raster image. 



 

  

Figure 4: Calibration points in NE map corner. 



 

  

Figure 5: Map with border and corner points displayed. 



 

  

Figure 6: Constructing water boundary with polyline. 



 

  

Figure 7: Spacing of vertices on polyline water boundary. 



 

  

Figure 8: Water boundaries traced with polylines. 



 

  

Figure 9: Initial solid fills in water body polygon. 



 

  

Figure 10: Layout of station data in Excel spreadsheet for MAPPRO. 



 

  

Figure 11: Insert block dialog window with "ST" block indicated. 



 

  

Figure 12: Script file settings in MAPPRO for station data. 



 

  

Figure 13: Output results of station data in MAPPRO. 



 

  

Figure 14: Station markers plotted on map with "script" command. 



 

  

Figure 15: Format of planar S1 foliation data in MAPPRO. 



 

  

Figure 16: Script file settings for S1 data. 



 

  

Figure 17: S1 data imported with "script" command. 



 

  

Figure 18: Vertex spacing along a contact on the geologic map. 



 

  

Figure 19: Inserting the "downbk" block from a file. 



 

  

Figure 20: Defining the "downbk1" block. 



 

  

Figure 21: Perimeter polylines of a lithologic polygon. 



 

  

Figure 22: Using the "hatch" command to fill a lithologic polygon. 



 

  

Figure 23: A successful fill of the "weh" polygon with the entity color set to brown. 



 

  

Figure 24: Effect of transparency in the lithologic fills layer. 



 

  

Figure 25: Dashed line type on the fault contact. 



 

  

Figure 26: Print dialog window settings for Arch E media sheet. 



 

  

Figure 27: Arch E sheet layout for the geologic map. 



 

Figure 28: Filter command dialog window. 


