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Abstract: The purpose of this white paper is to provide a method for using the IBM® 
Lotus® Domino® Server.Load utility to evaluate and improve Domino Server performance 
for a given workload. Included are performance considerations for running Lotus Domino 
on Linux®. Also presented is a detailed procedure for running the utility to evaluate the 
performance of Lotus Domino on Red Hat Enterprise Linux, for simulated workloads of 
600 and 1200 users. 
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1  Introduction 
IBM® Lotus® Domino® software provides world-class collaboration capabilities that can be 
deployed as a core e-mail and enterprise scheduling infrastructure, as a business application 
platform, or both. Lotus Domino software and its client software options deliver a reliable, 
security-rich messaging and collaboration environment. This paper introduces concepts that 
will help you get the most out of your environment. For more information, visit the Features and 
benefits of Lotus Domino page. 
 
The goal of  performance tuning is to get the most out of your hardware and your particular 
Domino environment. Since each environment is unique, performance tuning is largely a 
process of  analyzing the systems’ shortcomings and correcting them. This paper outlines 
some general guidelines that apply to tuning Lotus Domino and explains how to use the 
Domino Server.Load utility to find and correct bottlenecks. 
 
For more information on Domino performance tuning, refer to the developerWorks article, 
Introduction to Domino Performance Tuning.  For more comprehensive results on Lotus 
Notes®/Domino 8 server performance and scalability, refer to the article, IBM Lotus Domino v8 
Server with the IBM Lotus Notes V8 client: Performance. 
 
Lotus Server.Load is the IBM Lotus Domino load generation tool that can be used to measure 
and characterize various Domino server capacity and response time metrics. This tool, along 
with the provided workloads, allows you to run consistent, repeatable loads against Lotus 
Domino so that various operating system, hardware, and other configuration changes can be 
assessed for performance.  For more information on getting started with Lotus Domino 
Server.Load V8, refer to the article, Quick start guide to IBM Lotus Domino Server.Load V8. 
 
 
2  Test environment 
Our Domino Server environment under test consists of a single Domino 8.0.1 Server on an 
IBM System x3650 configured with one Dual Core Intel Xeon processor and 4 GB of RAM.  
 
Domino 8.0.1 Server (one) 
• IBM System x3650 
• 4 GB PC2-5300 Memory 
• Four 73.4-GB IBM SAS 15K hard drives 
• Two 146.8-GB IBM SAS 15K hard drives 
• One Intel Xeon Dual-Core 3.0 GHz  
• One ServeRAID 8k-l SAS Controller 
• Two full-duplex Broadcom 5721 Gigabit Ethernet PCI controller 
• 32-bit Windows 2003 Server/32-bit RHEL 5.2 Server 
• 32-bit Domino 8.0.1 for Windows/32-bit Domino 8.0.1 for Linux 
 
We configured three Windows XP Clients with the Domino Administrator Client to run the 
N8Mail Initialization Workload, N8Mail Workload, the Data Collection Script, and The Data 
Rollup Workload included with the Server.Load utility, to simulate a workload of up to 1200 
users.  Two clients running the N8Mail workload and one running the Data Collection Script. 
 
Lotus Notes 8 Administrator Client Systems (three) 
• IBM System x325 
• 4 GB PC2700 ECC DDR SDRAM memory 
• Two 18.2-GB IBM SAS 15K hard drives 
• One 2-GHz AMD Opteron Processor 
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• Integrated dual Gigabit Ethernet ports 
• Windows XP 
• Lotus Notes 8.0.1 Administrator Client 
 
NOTE: Results published in this paper are from benchmarks executed in this limited and 
controlled environment. They do not represent recommendations for a production environment.  
For assistance with Domino Capacity Planning, it is recommended that you consult your 
hardware vendor and the IBM Techline, which handles capacity planning for new hardware. 
 
 
3  Performance considerations for Lotus Domino 
Before tuning your Domino server for performance, ensure that your network components are 
operating efficiently. Next, make sure that your Domino systems are using the network 
efficiently. You can check the network utilization and Total Bytes sent per second, to see how 
much processor time is spent servicing the network. 
 
Plan your Domino server installation so that work will be distributed across hard disks and 
processors as evenly as possible. At a minimum, place the main operating system (OS) files 
and the Domino application files on a separate disk from your Domino data files.  If using 
Transaction Logging, you should put the log files on your fastest drive. The Domino server can 
be very IO intensive, so the manner in which you configure your disk drives can greatly 
enhance server performance. 
 
When installing Domino on Linux it is important to consider which file system is best for your 
environment.  Several options are available, including xfs, ext3, jfs, reiserfs, and ext2. 
Journaled file systems will perform slower than non-journaling file systems; however, they 
recover from errors faster. Domino mail databases, like any mail files, can get quite large, so 
you want to avoid file systems that are optimized for working with small files. 
 
Finally, to reduce unnecessary load on your server, disable or uninstall any OS services and 
features that are not required by your Domino server. You can also optimize Lotus Domino by 
not running Domino server tasks that aren’t required in your Domino environment. 

3.1  Domino Server settings and configuration 
Before running Server.Load against the Server Under Test (SUT), we applied the following 
Domino server optimization settings to it: 
 
• Two Raid 0 Arrays were created. The first was a 73-GB partition to store the OS and 

Domino server binaries. The second consisted of the five remaining disks and was used to 
store the Domino Data directory. 

 
• Ext2 was chosen as the Linux File System,  
 

o To further enhance performance of the ext2 filesystem on Linux, the Domino Data 
partition was  mounted with the noatime option, which turns off ext2 filesystem access 
time tracking. 

 
• In the Configuration Settings document on the Router/SMTP Basics tab, the Number of 

mailboxes field was set to 2. 
 
• The following Notes.ini setting were set on the Domino Server: 
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o SERVER_SHOW_PERFORMANCE=1 



o platform_statistics_enabled=1 
Note: There is a known issue with Domino 7.x/8.x related to enabling platform 
statistics. Before running any performance testing, complete the procedure outlined in 
Technote: 1292478

 
o SCHEDULE_NO_VALIDATE=1 
 
o NSF_buffer_pool_size_MB=512 

Note: 512 is the default value for NSF_buffer_pool_size_MB with 32-bit Domino 8.0.1 
and does not need to be explicitly set. For recommendations for setting 
NSF_BUFFER_POOL_SIZE_MB, refer to Technote: 21286171

 
o Server_Max_Concurrent_trans=100 
 
o server_pool_tasks=80 

 
o Servertasks=Router,Update,AMgr,Adminp,Sched,CalConn,RnRMgr,HTTP,LDAP 

 
Lotus Domino includes a utility called tunekrnl that is used to tune the Linux environment. The 
memory data returned by the Linux operating system is not always accurate, however, so it is 
sometimes necessary tell Lotus Domino the amount of memory it has available. We do this by 
setting additional Notes.ini variables. 
 
For the purpose of this paper, in addition to the Notes.ini variables set above, the following 
Notes.ini variables were also set on the Linux-based Domino Server: 

 
• MEM_AddressableMemSizeMB=2560 
• ConstrainedSHMSizeMB=2048 
• MEM_EnablePreAlloc=1 

 
NOTE: These Notes.ini parameters deal with the allocation of memory for the Domino server. 
These setting should be used with caution. Before setting these variables, you should attempt 
to run Lotus Domino using the default settings. Granting too much or too little memory to Lotus 
Domino can cause performance to degrade, so always test your server performance before 
and after changing these values.  
 
The Notes.ini parameter MEM_AddressableMemSizeMB=2560 tells Lotus Domino that it has 
2560 MB of memory to use. The 32-bit Linux OS reserves 1 GB of memory for kernel process.  
Since the Domino server is the main application running on the OS, we choose to allocate 
most of the remaining memory for Lotus Domino. Of course, some memory must be left for 
other user space applications; usually 500 MB is an ample amount for this purpose. 
 
The next parameter, ConstrainedSHMSizeMB=2048, tells Lotus Domino how much shared 
memory it can use. Because most of the memory Lotus Domino requires is shared memory, 
we give it 2 GB for these tests. 
 
The third parameter, MEM_EnablePreAlloc=1, tells Lotus Domino to pre-allocate the shared 
memory defined in the Notes.ini parameters. This helps prevent Lotus Domino from crashing 
with an insufficient shared memory error. 
 
However, it’s a balancing act because locking down more shared memory than needed is not 
wise. Doing so can cause a shortage of local memory for applications to use and cause 
insufficient memory errors and application failure. 
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4  Domino Server.Load 
Lotus Server.Load is the Lotus Domino load generation tool that can be used to measure and 
characterize various Lotus Domino server capacity and response time metrics. This section 
explains how to install and configure Domino Server.Load to run the N8Mail Workload against 
a Domino SUT. 

4.1  Installing and running Server.Load 
The Server.Load utility and its associated workloads are included as part of the Domino 
Administrator Client. To install Server.Load, you must select this feature during installation.  
Domino Designer is also required to deploy and run the setup agents required by the N8Mail 
Workload. 
 

4.1.1  Install and configure Domino Administrator, Domino Designer, 
and Server.Load 

 
To install the Domino Administrator, change to the client running Microsoft Windows XP and 
follow these steps: 
 
1. Log in as user Administrator. 
 
2. Open Windows Explorer by selecting Start > Programs > Accessories > Windows Explorer. 
 
3. Change to location of the Notes Installer executable and double-click 

notes8basicallclient_w32_prod.exe to start the installation. 
 
4. You are asked where to save files; keep the default path, that is,  

C:\Documents and Settings\Administrator\Local Settings\Temp\Lotus Notes (see figure 1). 
 
Figure 1. Location to Save Files dialog 

 
 
9. Click Next; the files are extracted (see figure 2). Be patient; this may take a few minutes. 
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Figure 2. Extracting Files status screen 

 
 
 
10. When the file extraction is finished, the Install Wizard Welcome screen (see figure 3) will 

display. Click Next. 
 
Figure 3. Welcome screen 

 
 
 
7. In the License Agreement screen (see figure 4), select “I accept the terms in the license 

agreement” and Click Next. 
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Figure 4. License Agreement screen 

 
 
 
8. In the Customer Information screen, provide the information requested and record your 

values in a table such as shown figure 5. Click Next. 
 
Figure 5. Customer Information data 
§ 
 

 
 
 
9. Keep the default values in the Installation Path Selection screen (see figure 6) and Click 

Next. 
 

Field Entry 
User Name:  
Organization:  

Field Entry 
User Name:  
Organization:  
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Figure 6. Installation Path Selection screen 

 
 
 
10. The Custom Setup screen appears (see figure 7). Ensure that you select all features, 

except “Client Single Logon Feature,” by clicking the icon next to the feature. These feature 
will be installed on the local hard drive. Click Next. 

 
Figure 7. Custom Setup screen 

 
 
 
11. The installation wizard now has all required information and is ready to be installed, as 

shown in figure 8. Click the Install button. 
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Figure 8. Start install 

 
 
12. The Lotus Domino Administrator installation begins (see figure 9). This may take a few 

minutes. 
 
Figure 9. Install progress screen 

 
 
 
13. The Install Wizard Completed screen displays (see figure 10). Click Finish. 
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Figure 10. Install Complete screen 

 
 
 
You should see three new icons on the desktop; Lotus Notes 8, Domino Designer 8, and  
Domino Admin 8, as shown below: 
 

 
 

4.1.2  Configuring the Domino Administrator 
In this section we configure the Domino Administrator, following these steps: 
 
1. Double-click the Domino Admin 8 icon on the desktop to start the Lotus Domino 

Administrator. The Welcome screen displays (see figure 11); click Next. 
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Figure 11. Welcome screen 

 
 
 
2. Provide information about the user and the Domino server you’ll be administering (see 

figure 12). This is the server that will be the target of your Server.Load test. In the Your 
name field, enter the name of the Domino Administrator used to Install Domino. Keep “I 
want to connect to a Domino server selected”; click Next. 

 
Figure 12. User Information 

 

Field Entry 
Your name  
Domino server  

 
 
3. The configuration wizard attempts to find your Notes ID file in the Domino Directory. If your 

ID file is not found, a window displays (see figure 13) in which you must provide the 
location: C:\Documents and Settings\Administrator\My Documents\admin.id. Click Next. 
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Figure 13. Cannot find ID file 

 
 
 
4. You are then asked if you want to copy the ID file to the Data directory of Lotus Notes (see 

figure 14). Click Yes. 
 
Figure 14. Copy ID file prompt 

 
 
 
5. The password prompt appears (see figure 15). Type in the password for the Domino user 

admin; click OK. 
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Figure 15. Password prompt 

 
 
 
6. In the Instant Messaging Setup screen (see figure 16), deselect “Setup instant messaging” 

as we do not have a Lotus Sametime server configured. Click Next. 
 
Figure 16. Instant Messaging Setup screen 

 
 
7. In the Additional Services screen (see figure 17), leave everything unselected and click 

Finish. 
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Figure 17. Additional Services screen 

 
 
 
The Setup is completed. Click OK. The Domino Administrator will start (see figure 18). 
 
Figure 18. Startup screen 

 
 
 

4.1.3  Testing the Domino Administrator 
 
To test the installation of the Domino Administrator, we access the server console to see the 
runtime messages generated by the Domino server: 
 
1. If not started, start the Domino Administrator by double-clicking the Domino Admin 8 

desktop icon and then select the Domain tab. 
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2. Within the Domain tab, select the Server tab (see figure 19).  
 
Figure 19. Server tab 

 
 
3. In the left-hand navigation bar, select Server Console (see figure 20) and then click the 

Live button in the upper right-hand corner to connect to the Domino server. 
 
Figure 20. Server Console screen 
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4. Type the command “show server” in the Domino Command field at the bottom of the 

screen and click the Send button (see figure 21). 
 
Figure 21. Show server command 

 
 
5. You should see information about the server scroll by, as shown in figure 22. 
 
Figure 22. Server information  
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You have successfully installed and configured Lotus Domino Administrator! 

4.2  Copying agents required by Server.Load to the SUT 
Nameagent.nsf is provided by the Server.Load feature. It includes the agents required to set up 
the test environment for running the Server.Load workloads, and these agents must be copied 
to and run on the SUT: 
 
1. Launch Domino Designer and from the menu bar select File  > Application > Open; then 

select Server.Load Setup Agents (nameagent.nsf; see figure 23). Click Open. 
 
Figure 23. Open nameagent.nsf 

 
 
2. Open the Domino directory on the SUT. From the menu bar select File > Application > 

Open and click the “Look in” drop-down menu. Select the SUT and then select the SUT's 
directory (Names.nsf). 

 
3. Navigate to the Server.Load Setup Agents > Shared Code > Agents view. Select all the 

agents in the right-hand pane and press CTRL + C to copy these agents. 
 
4. Navigate to the SUT's directory > Shared Code > Agents view, and press CTRL + V to 

paste the agents into the SUT’s Directory (names.nsf). 

4.3  Registering the simulated users on the Domino server 
In the previous section we copied the agents required to run a workload to the Domino SUT. In 
this section we run the Create NotesBench mail Person Document agent on the SUT to create 
1200 mail users: 
 
1. Launch the Lotus Notes Client and open the SUT's Directory and select Actions > Other. 
 
2. In the pop-up, select the “Create notes Bench Mail Person Documents” agent and select 

Run. 
 
3. You are presented with a series of Dialog boxes, with values as recorded in table 1. 
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Table 1. Dialog box values  
 Dialog name 
 

Value 

Starting Values to Create Mail Users: 1 
Number of Users to Create 1200 
Number of Mailn.NSF Files to Use: 1200 
Starting Mailn.NSF File 1 
Location of Mail Databases (relative to Notes 
Data directory, blank = root) 

mail\ 
 

Mail Domain (example: mycompany)  Enter the name of SUT's Domain. 
Number of Mail Servers 1 
Mail Server #1 (example: domino/mycompany) Enter the name of the SUT plus its Domain. 
Internet Host Name #1? Enter the fully qualified  TCP/IP Hostname of 

the SUT. 
Message Storage Format (0=Notes, 1=Keep in 
Sender's Format, 2=MIME) 

0 

Mail System (1=Notes, 6=POP or IMAP) 1 
Percentage of These Users with Local Replicas 
(0 – 100) 

0 

 
4.4  Verify creation of Person documents 

Prior to running the Mail Initialization workload, verify that the necessary Person documents 
have been created on the Domino SUT: 
 
1. Launch the Domino Administrator Client and log in using the ID of the Domino 

Administrator for the SUT. 
 
2. Open the SUT Domain and navigate to the People & Groups tab. 
 
3. Navigate to the Domino Directories > SUT's Directory > People view. 
 
4. Press CTRL + A to select all the document in this view. You should see 1201 documents 

selected; the 1200 Mailn.NSF documents you created plus your administrators Person 
document. 

 
NOTE:  If you don't see these documents, Press F9 to refresh the view. If the documents 
are still not available, an error occurred. Retrace your steps and correct the problem before 
you continue. 

4.5  Run the Mail8 Initialization workload 
The N8 Mail Initialization is used to prepare for the N8 Mail workload and the N7 Mail workload. 
This workload creates and populates the mail databases needed to run both workloads. 
 
As with all workloads, you can collect performance metrics with this one; however, the metrics 
will not be meaningful as this workload is designed only to create the mail databases required 
by the N8 Mail workload. You should not use the metrics gathered with this workload as a 
guideline for tuning Lotus Domino. 
 
NOTE: Before running any workload, ensure that the SUT and the Driver Client systems can 
communicate, are synchronized with respect to date/time, and the admin.id and cert.id are 
correct. 
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1. Set Notes.ini settings on each client driver that will run Mail8 Initialization Workload. For 
example, the setting Domain=mycompany would be “SUT's Domain”. 

 
2. Launch the Server.Load utility, select Start > Run from the menu, and enter C:\Program 

Files\IBM\Lotus\Notes\sload.exe. The Lotus Server.Load graphical user interface opens. 
 
3. In the Test Type section, select Built-In and the Select N8Mail Initialization Workload from 

the drop-down menu. 
 
4. Select the Test Parameters tab and complete the fields show in table 2. 
 
Table 2. Values for Test Parameters tab fields 
 Field Value 
Number of Users/Threads 0 
Script Loop Count 1 
Thread Creation Interval 5 
Starting Thread No. 1 
Test Time Parameter No time limit 
Build Recipient List using Name and Address Book (for 
example: domino/mycompany!!NAMES.NSF) 

sut/domain!!names.nsf 

Storage test output to C:\results\n8initworkload1.txt 

 
5. Select the Script Variables tab and complete the fields in table 3. 
 
Table 3. Script Variables tab values 
 Value Variable Name 
CN=domino/O=mycompany MailServer (example: domino/mycompany) 
mail\ nb_dbdir 
domino\mycompany!!mail8.ntf MailTemplate 
3000 NumMailNotesPerUser 
1 BlockSenderOFF 
0 ColorProfile 
 
6. Select File > Save Setting to save these settings and click Execute to open the 

Server.Load Metrics window. 
 
7. For each metric you want to collect, select it from the Script Metrics or Server Stat Metrics 

pull-down list and click the Add Metric button. To delete a metric, select it and click the 
Delete Selected Metric button. 

 
8. Verify that the Server to receive Console Commands field matches the SUT (for example,  

CN=domino/O=mycompany); if it doesn't, enter the correct value. 
 
9. Enter the location of the file in which to store metrics (for example, 

c:\results\n8initworkload1metrics.csv) 
 
10. Click Start Test, to initiate the workload. Note that the N8Mail Initialization workload may 

take several hours to complete.  
 
11. To verify that databases are being created, log in to the SUT and change to the mail 

directory located in the Domino Data directory on your server. The default location on Linux 
is /local/notesdata/mail.  
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12. Issue the command to list the contents of  this directory. You should see a series of 

mailn.NSFs, where n is a number between 1 and  300.   
 

NOTE: You should not issue this test for more than 300 users at a time; if the script fails for 
any reason, you will have to clean up the databases already created and restart the test. 
 

13. Once the Initialization workload completes, close all open Server.Load windows to exit 
from the program. 

 
14. Repeat Steps 1 – 13, replacing the Starting Thread No in Step 4 with the next mail box 

number (e.g., 301, 601, 901), and then change the output file names accordingly, until you 
have created the desired number of databases. 

4.6  Gather operating systems statistics 
The workloads included with the Server.Load utility simulate user load and query statistics from 
the Domino SUT. To gather additional OS statistics you must run an external performance 
monitoring tool like Microsoft Management Console (perfmon.exe) on Windows-based servers 
or nmon on Linux. 
 
Note that you must set up these tools before running the N8Mail Workload, as they should be 
run concurrently with the N8Mail Workload. 

4.6.1  Gathering OS statistics on Red Hat Enterprise Linux 5 
There are many performance monitoring utilities available for Linux. Here we explain how to 
use nmon to gather Linux OS statistics. 
 
Nmon is a free tool designed for AIX and Linux performance specialists to monitor and analyze 
performance data, including CPU utilization; memory use; disk I/O rates, transfers, and 
read/write ratios; network I/O rates, transfers, and read/write ratios; and much more. For further 
details on nmon, refer to the developerWorks article, “nmon performance: A free tool to 
analyze AIX and Linux performance.” 
 
To use the tool: 
 
1. Download the correct version of  nmon for your platform. 
 
2. Log on a root and extract the nmon executable: 

 
unzip nmon_x86_11f.zip 

 
3. Ensure that the file’s permissions are set to executable: 
 

chmod +x nmon_x86_fedora5 
 
4. Start nmon just before launching the Domino Server.Load Workload and set the 

parameters to gather information so that it completes shortly after your last workload. The 
example below will run for 4 hours and 1 minute, collecting data once per minute: 

 
./nmon_x86_fedora5 -ft -s 60 -c 251 

 
where -f instructs nmon to start in data collection mode. This mode launches the tool  
and background processes, writing the results to a file named  
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hostname_yymmdd_hhmm.nmon 
 
-t = include top output 
 
-s = interval to capture statistics in seconds (60 = once/minute) 
 
-c = number of times to collect data  

 
The file produced by initiating nmon in data collection mode is a CSV file, which can be opened 
with most spreadsheet editors. You many need to rename the file to have a .csv extension. 
 
Alternatively, if you have Microsoft Excel 2002 or later, you can use the nmon analyser tool to 
view the data in spreadsheet form and produce graphs for presentations, based on the nmon 
output. For more information on using nmon analyser see the developerWorks article, “nmon 
analyser -- A free tool to produce AIX performance reports”. 

4.6.2  Gathering OS statistics on Windows 2003 
There are many performance monitoring tools available for Windows, but here we focus on 
how to use the Microsoft Management Console to set up a counter log to gather statistics: 
 
1. Launch the Microsoft Management Console, by selecting Start > Run from the menu, and 

enter C:\perfmon.exe. The Microsoft Management Console opens to the Performance 
window. 

 
2. In the left-hand frame, expand Performance Logs and Alerts, and select Counter Logs. 
 
3. Select Action > New Log Settings from the menu. 
 
4. The New Log Settings pop-up window displays. Enter a name for your log file (for example, 

DominoPerfmonData) and Click OK. The New Perfmon Log Setting window displays with 
the name you just entered. 

 
5. Click Add Objects; the Add Objects window displays. Scroll down and select the objects 

you are interested in, such as PhysicalDisk or LogicalDisk, Memory, Network Interface, 
Paging File, Process, Processor. (To select multiple objects, hold the CTRL key as you 
select each object.) Once you’ve selected all the objects, click Add and then Close. 

 
6. Verify the list of Counters you selected, adding or removing Counters as needed. 
 
7. Take note of the current log file name and location, (for example, 

C:\PerfLogs\DominoPerfmonData_000001.blg). If you wish to change this value, select the 
Log files tab, click configure to change the Filename or Directory to which to save the file, 
and then click OK when complete. 

 
8. Select the Schedule Tab. You will want to configure the Log to start manually and stop 

automatically at a time shortly after the last workload completes. 
 
9. To start the Log, select the name of your log file (DominoPerfmonData) in the panel on the 

right-hand side, and then select Action > Start from the menu. The Database icon will 
change from red to green, indicating that the log is active. 

 
10. Once the workload is complete, stop the Log. Select the name of your log file 

(DominoPerfmonData) in the panel on the right, and then select Action > Stop from the 
menu. The Database icon changes from green to red, indicating the log has stopped. 
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11. Create a filter file (filter.txt) to sift out the statistics that are of interest to you. (This is a text 

file listing the counters to select, one per line.) The sample text below demonstrates the 
format: 

 
\Processor(_Total)\% Privileged Time 
\Processor(_Total)\% User Time 
\Processor(_Total)\% Processor Time 
\PhysicalDisk(_Total)\Disk Reads/sec 
\PhysicalDisk(_Total)\Disk Read Bytes/sec 
\PhysicalDisk(_Total)\Disk Writes/sec 
\PhysicalDisk(_Total)\Disk Write Bytes/sec 
\Network Interface(Broadcom NetXtreme Gigabit Ethernet _3)\Bytes 
Total/sec 

 
12. Open a Command Prompt, click Start > Run, type cmd, and click OK. 
 
13. Change to the location of your log file:  cd c:\PerfLogs 
 
14. Enter the following command to convert the .blg file to a .csv file with the Counters 

specified in the filter file created in step 11: 
 

relog DominoPerfmonData_000001.blg -f csv -o dominoperfmon -cf 
filter.txt 

 
Note: for more information on relog, enter relog -? 

 
15. Finally, open dominoperfmon.csv in your favorite spreadsheet editor. 

4.7  Workload Data Collection script 
The Workload Data Collection custom script, SHSTAT.SCR, allows test data from a group of 
test drivers and an SUT to be combined into a single data file for analysis. While a workload 
runs, the Workload Data Collection custom script collects performance data from the SUT and, 
when the workload is complete, the Workload Data Rollup script rolls up the performance data.    
 
These scripts require a system other than the one that contains the test drivers that put the 
load on the SUT.  

4.7.1  Setting up the Workload Data Collection script 
The Workload Data Collection script should be started just prior to starting the first Workload 
driver, and it should not stop until all the Workload drivers complete their test. To set up the 
client that will run for workload data collection, perform these steps: 
 
1. Create a folder to use as a Results directory and then set sharing privileges on that folder 

to allow the client drivers to write to the Results directory. 
 
2. On each test driver, map a drive to the Results directory on a system that will collect the 

data from all drivers.  
 

3. In the Workload Data Collection driver's Notes.ini, include the following settings: 
 Description 

• ResultsDirectory=Z:\  where Z:\ is mapped to the Results directory created in Step 1. 
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• NB_SaveCMDConsole=1  Tells the script to save results to a file. When we run the 
rollup script, we will change this setting to zero. 

 
4. Launch Domino Designer and open Nameagent.nsf. 
 
5. From the menu bar, select File > Application > Open, select Server.Load Setup Agents 

(nameagent.nsf), and click Open (see figure 24). 
 
Figure 24. Open nameagent.nsf 

 
 
 
6. From the Domino Designer menu, select Help > Using this Application. The Using 

Server.Load Setup Agents page opens. Near the end of this page you will see the section 
labeled “Show Stats script used to collect server data during workload for Workload Data 
Rollup script”. 

 
7. Right-click the showstat.scr attachment located in at the bottom of this page, and select 

Save. The Save Attachment window opens. 
 
8. Navigate to C:\Program Files\IBM\Lotus\Notes and click Save, to save showstat.scr to your 

Notes directory. 
 
9. Launch the Server.Load utility, select Start > Run from the menu, and enter C:\Program 

Files\IBM\Lotus\Notes\sload.exe. The Lotus Server.Load graphical user interface (GUI) 
opens. 

 
10. In the Test Type section, select Custom and then click Browse; the Open window displays. 

Navigate to  C:\Program Files\IBM\Lotus\Notes, select showstat.scr, and click Open. 
 
11. Select the Test Parameters tab and complete the fields as shown in table 4. 
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Table 4. Values for Test Parameters tab fields 
 Field Value 
Number of Users/Threads 1 
Script Loop Count 1 
Thread Creation Interval 1 
Starting Thread No. 1 
Test Time Parameter Specify total test time (in minutes) 
Total Test Time (in minutes) Set to be greater than or equal to 

the total run of the workload 
drivers. 

Build Recipient List using Name and Address Book 
(for example: domino/mycompany!!NAMES.NSF) 

sut/domain!!names.nsf 

Storage test output to Z:\results\datacollection.txt 

 
12. Click Execute to access the Metrics window. 
 
13. Set the "Server to Receive Console Commands" field in the Metrics window to blank. 

Server.Load does not need to authenticate with a server for this script. 
 
14. Before clicking Start Test, finish preparing the workload drivers before continuing. The data 

collection script should be started just prior to starting the first workload driver, and it 
should not be stopped until all workloads are completed. 

4.8  The N8Mail workload 
The N8Mail Workload models an active user on a Notes 8 client, acting on a Domino 8 server 
performing the same set of calendaring and mail operations. To learn more about this 
workload, visit the IBM Lotus Domino 8 information center. 
 
4.8.1  Preparing to run the N8Mail workload 

Prior to running this workload you should have run the N8Mail Initialization workload to create 
the total number of users that you want to simulate and test. Each Client driver can handle 
from 500 to 1500 simulated users. 
 
If you want to test a larger number of users, you must set up additional client driver systems 
before proceeding. Ensure that you’ve synchronized the time on all servers and clients before 
running this workload. 
 
4.8.2  Running the N8Mail workload 

 
1. On the SUT, do the following: 

 
a. Start the Calendar Connector task (Calconn). 

 
b. In the Configuration Settings document on the Router/SMTP Basics tab, set the 

"Number of mailboxes" field to 1 or higher. 
 

NOTE: The server must be restarted for this change to take effect. We used two 
mailboxes, but one mailbox may be enough; it depends upon how many mail users you 
have and how high the mail waiting statistic gets. 
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2. Set the Notes.ini settings (see table 5) on each client driver that will run the N8Mail 
Workload. NOTE:  MailRecipientBeginNumber and Mail RecipientEndNumber should 
correspond to the Starting Thread Number and Number of Users/Threads in step 6 below. 

 
Table 5. Notes.ini settings  
Notes.ini setting Description 
Domain=mycompany SUT's Domain 

NB_PERCENT_ATTACHEMENTS_READ
=25 

What percentage should be read out of all 
attachments encountered. 

NABENTRIES=1 Number of valid users on the server. 

NB_MailRealFromField=1 The Notes ID file. 

MailRecipientBeginNumber=1 Beginning range of users from which to 
choose a random recipient. 

MailRecipientEndNumber=1200 End of the range of users from which to 
choose a random recipient. 

ContextIteration1=24 Iteration interval to add a calendar 
appointment (24 = every 6 hours). 

ContextIteration2=24 Iteration interval to send a meeting 
invitation (24=every 6 hours). 

ContextIteration3=24 Iteration interval to respond to a calendar 
invite (24=every 6 hours). 

RUNTIME=9999 How Long over all the entire test should 
run (9999=forever) 

NB_MAIL_SAVE_MESSAGE=1 When sending a memo, save to the Sent 
folder. 

  
3. Launch the Server.Load utility. Select Start > Run from the menu and enter C:\Program 

Files\IBM\Lotus\Notes\sload.exe. The Server.Load GUI opens. 
 
4. In the Test Type section, select Built-in and the Select N8Mail workload from the drop-

down menu. 
 
5. Select the Test Parameters tab and enter the values shown in table 6. (If you are running 

the test on multiple clients, increment the value of the Starting Thread No. parameter when 
you run the test on each client.) 

 
Table 6. Values for Test Parameters tab fields 
 Field Value 
Number of Users/Threads 600 
Script Loop Count 9999 
Thread Creation Interval 1 
Starting Thread No. 1 
Test Time Parameter Specify total test time (in minutes) 
Total Test Time (in minutes) 240 
Build Recipient List using Name and Address Book 
(for example: domino/mycompany!!NAMES.NSF) 

sut/domain!!names.nsf 

Storage test output to C:\results\n8workloadDrivern.txt 
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6. Select the Script Variables tab and enter the values shown in table 7 for each variable 

listed. 
 
Table 7. Script variables values 
 Value Variable Name 
CN=domino/O=mycompany MailServer (for example: domino/mycompany) 
  
 
mail\ nb_dbdir 
domino\mycompany!!mail8.ntf MailTemplate 
0 NB_N8_NUM_READ_ENTRIES 
0 %NUMCALENTRIES% 
1 N8_ENABLE_V801_TRANS 
2 NB_ReplyNthIteration 
1 NB_Memo1NumRecipients 
1 NB_Memo1NthIteration 
3 NB_Memo2NumRecipients 
2 NB_Memo2NthIteration 
3 NB_InvtNumRecipients 
9999 ScriptIterationLimit 
 
7. Click File > Save Setting, to save these settings. 
 
8. Click Execute to open the Server.Load Metrics window. 
 
9. For each metric you would like to collect, select it from the Script Metrics or Server Stat 

Metrics pull-down list and then click the Add Metric button. To delete a metric, select it and 
then click the Delete Selected Metric button. 

 
NOTE:  Do not select any additional metrics if you are running this workload in conjunction 
with the Workload Data Collection and Workload Data Rollup scripts. 

 
10. Verify that the Server to receive Console Commands field matches the SUT (for example, 

CN=domino/O=mycompany); if it doesn't, enter the correct value. 
 
11. Enter the location of the file in which to store the metrics, that is,  Z:\results\RES1. 
 

NOTE: If you’ll be using the Workload Data Collection and Rollup scripts, these must be 
stored in files with the name RESn, where n is the number of the corresponding workload 
driver.  

 
12. Before clicking Start Test to initiate the workload, you should prepare all your drivers, 

initiate any OS statistics collections using a tool such as perfmon or nmon, and start the 
Workload Data Collection test. 

4.9  Workload Data Rollup feature 
The Server.Load Workload Data Rollup feature is adapted from the NotesBench data rollup 
feature. It allows test data from a group of test drivers and an SUT to be combined into a single 
data file for analysis. 
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While a workload runs, the Workload Data Collection custom script, SHSTAT.SCR, collects 
performance data from the SUT. When the workload is complete, the Workload Data Rollup 
script rolls up the performance data.  
 
1. In the Workload Data Rollup driver's Notes.ini file, include the settings shown in table 8.  
 
Table 8.  Notes.ini settings notes.ini Setting Description 
Notes.ini setting Description 
ResultsDirectory=Z:\ Where Z:\ is mapped to the results directory created prior to 

running the  Workload Data Collection  Script. 

NB_SteadyStateTime=45 Enter the number of minutes that you want to disregard in order to 
ensure you are getting steady state data. If you do not set this 
variable, the default of 30 minutes applies.  

NB_MeasureTime=60 Enter the number of minutes after steady state that the rollup 
should read data (length of the real test). If you do not set this 
variable, the default of 60 minutes is used. If you specify a test 
length value greater than that which is in the data file, Server.Load 
stops at the end of the file.  

NB_SaveCMDConsole=
0  

Set this value to zero (0) prior to running the Workload Data 
Rollup script. Note: If this value is not set then the default value of 
1 is used, and the file will be overwritten during initialization.  

NB_NumOfClients=2 Enter the number of regular drivers in the run. The default is 20  

NB_Rollup=1 Enter 1 to enable the Data Rollup Workload to run.  

  
2. Launch the Server.Load utility. Select Start > Run from the menu and enter C:\Program 

Files\IBM\Lotus\Notes\sload.exe. The Lotus Server.Load GUI opens. 
 
3. In the Test Type section, click Built-in and then select "Workload Data Rollup" from the 

Built-in scripts menu. 
 
4. Select the Test Parameters tab and complete the fields with the values shown in table 9. 
 
Table 9.  Values for Test Parameters tab fields 
 Field Value 
Number of Users/Threads 1 
Script Loop Count 1 
Thread Creation Interval 1 
Starting Thread No. 1 
Test Time Parameter No time limit 
Total Test Time (in minutes) Set to be greater than or equal to the 

total run of the workload drivers. 
Build Recipient List using Name and Address Book 
(for example: domino/mycompany!!NAMES.NSF) 

sut/domain!!names.nsf 

Storage test output to Z:\results\datarollup.txt 

 
5. Click Execute to access the Metrics window. 
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6. Set the "Server to Receive Console Commands" field in the Metrics window to blank. 
Server.Load does not need to authenticate with a server for this script. 

 
7. Click Start Test. The data rollup output resides in the data file NB_Domstat.csv containing 

the averaged client data, along with any relevant SH STAT data. This file is located in the 
ResultsDirectory specified in the Notes.ini setting. 

 
 

5  Graphing and charting the results 
Significant statistics for Domino server performance include CPU utilization, Disk I/O 
operations per second, network utilization, Domino server response time, and Domino server 
Availability Index. In this section, we examine the results of these statistics for a Domino 8.0.1 
server running the N8Mail Workload at loads of 600 and 1200 users, on both Windows 2003 
and Red Hat Enterprise Linux 5.2. 

5.1  Linux results 
The main sources of graphing and charting results from the Red Hat Enterprise Linux (RHEL) 
5.2 Server Load Test are the Domino Server Load Workload Data Rollup file NB_domnstat.csv 
and OS statistics collected by nmon in conjunction with the nmon analyzer tool. 
 
Table 10 shows a sample of the first few lines of NB_domstat.csv. As with the Windows 
testing, each client driver simulated a load of 600 users. The first driver ran for 4 hours, and the 
second driver, which was started 2 hours after the first driver, ran for 2 hours. 
 
Table 10. Sample NB_domstat.csv 

Client Drivers 1 2 
Active Users 600 1200 
Transactions per Minute 59 118 
Response Time 0.20 0.22 
Warnings 0 0 
Errors 0 0 
Failures 0 0 
   
Start Time 9:43 AM 11:44 AM 
End Time 10:43 AM 12:44 PM 
Date 12/1/08 12/1/08 
Workload_Name   

Server_Name lin  

Platform.LogicalDisk.1.AssignedName sda sda 
Platform.LogicalDisk.1.AvgQueLen 0.01 0.02 
Platform.LogicalDisk.1.AvgQueLen.Avg 0.01 0.01 
 
 
The start time of 9:43 above corresponds to the initial steady-state time. We actually started 
the N8Mail workload for the first client driver at 8:58 am, and set NB_SteadyStateTime=45 in 
the Notes.ini file before running the Workload Data Rollup script. 
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Again, these time frames are important because they represent the steady-state time from 
which you should compare results from the OS results, dominoperfmon.csv. 
 
To  graph and chart these results, we used Domino Server Load Workload Data Rollup output 
NB_Domstat.csv and the OS statistics collected by nmon in lin_081201_0850.nmon, in 
conjunction with the nmon analyzer tool. 
 
Table 11 shows sample output from running nmon on the RHEL 5.2-based Domino server.  
(The output file lin_081201_0850.nmon was renamed lin_081201_0850.csv so that the 
spreadsheet editor would recognize it as a CSV file.) 
 
Table 11. lin_081010_0818.csv 
AAA progname nmon_x86_fedora5 
AAA command ./nmon_x86_fedora5 -ft -s 60 -c 280 
AAA version 11f 
AAA disks_per_line 150 
AAA max_disks 256 
AAA disks 10 
AAA host lin 
AAA user root 
AAA OS Linux 
AAA runname lin 
AAA time 08:50:08 AM CST 
AAA date 12/1/08 
AAA interval 60 
AAA snapshots 280 
AAA cpus 2 

Warning - use the UNIX sort command to order this file 
before loading into a spreadsheet AAA note0 

The First Column is simply to get the output sorted in 
the right order AAA note1 

The T0001-T9999 column is a snapshot number. To 
work out the actual time; see the ZZZ section at the endAAA note2 

 
Notice that nmon was started before the first Domino N8Mail Workload driver was started. The 
data that corresponds to steady-state time will correlate to the Start and Stop times in 
NB_domstat.csv above. To process this data we use the nmon analyzer, which sorts and plots 
all the information produced by nmon. 

5.2.1 Linux charts and graphs  
Tables 12 and 13 and figure 25 below show the significant performance statistics for our Linux 
testing. Although it is possible to use any spreadsheet editor that recognizes CSV format, the 
nmon analyser requires Microsoft Excel 2002 or later. 
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Table 12. Server configuration settings (Linux) 
Server Configuration Settings 
Workload_Name N8Mail 
Server_Name lin 
Server.Version.Notes Release 8.0.1 
Server.Time.Start 12/01/2008 08:18:09 CST  

Linux 2.6.18-92.el5PAE #1 SMP Tue 
Apr 29 Server.Version.OS 

Server.CPU.Count 2 
Server.MailBoxes 2 
Database.Database.BufferPool.Maximum.Megabytes 512 
Database.DbCache.MaxEntries 1536 
Database.DBUCache.MaxEntries 2560 
Database.RM.Sys.Logged Disabled 
Platform.Memory.RAM.TotalMBytes 4050.77 
Domino.Config.ActiveThreads.Max 40 
 
Table 13. Results (Linux) 
Results 
Active Users 600 1200 
Transactions per Minute 59 118 
Platform.System.PctCombinedCpuUtil 7.31 15.34 
Response Time (milliseconds) 195.93 220.65 
Platform.System.PctTotalPrivilegedCpuUtil 1.05 2.17 
Platform.System.PctTotalUserCpuUtil 6.26 13.17 
Platform.Network.Total.NetworkBytesPerSec 397761.46 812277.63 
Server.AvailabilityIndex 44 32 
Server.ExpansionFactor 10.331907.31 16.77314211 
Platform.Memory.RAM.AvailMBytes 154.18 157.65 
Platform.System.ContextSwitchesPerSec 1666.81 2676.84 
Mail.Delivered 6558 35759 
Mail.DeliveredSize.100KB_to_1MB 364 2012 
Mail.DeliveredSize.10KB_to_100KB 3212 17448 
Mail.DeliveredSize.1KB_to_10KB 2501 13668 
Mail.DeliveredSize.1MB_to_10MB 16 102 
Database.NSFPool.Used 19564128 25072512 
Database.Database.BufferPool.PerCentReadsInBuffer 98.94 100 
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Figure 25. Transactions rate and CPU utilization 

 
 
The graph in figure 26 was produced by nmon analyser and shows disk utilization statistics for 
the Domino server. The boxes labeled 600 and 1200 represent the corresponding steady-state 
time when the N8Mail Workload is running with 600 and 1200 simulated users, respectively. 
 
Figure 26. Disk usage statistics 

 
 
 
Finally, the two charts in figure 27 present the network statistics pulled from nmon analyser for 
the corresponding steady-state time with 600 and 1200 simulated users. 
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Figure 27. Network statistics 

 
 
6  Conclusions 
Domino Server.Load is a powerful tool for gathering performance data for the Lotus Domino 
server. It should be used in conjunction with OS-specific utilities, such as nmon on Linux and 
Perfmon on Windows, for gathering and charting performance data. 
 
Tuning a Domino server for performance involves multiple variables, including the OS, the file 
system, the network, Domino Notes.ini settings, and Domino server tasks. Discovering what 
settings work best in your particular environment is a matter of identifying your system's 
weaknesses and correcting them. 
 
The results published here should not be used to compare the performance of Lotus Domino 
on Linux to that of Lotus Domino on Windows, as we’ve not exhausted all the tuning options on 
either platform. 
 
NOTE: The results presented in this paper are from benchmarks executed in a limited and 
controlled environment; they do not represent recommendations for a production environment. 
For assistance with Lotus Domino capacity planning, it is recommended that you consult your 
hardware vendor and IBM Techline, which handles capacity planning for new hardware. 
 
7  Resources 

• IBM Lotus Notes and Domino information center 
 

• developerWorks Lotus product page 
 

• Introduction to Domino Performance Tuning 
 

• IBM Lotus Domino v8 Server with the IBM Lotus Notes V8 client: Performance 
 

• Quick start guide to IBM Lotus Domino Server.Load V8 
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