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Copyright Information  

VB Scripting for CATIA V5: How to Model Gears with VBA User Form PREVIEW VERSION 

Revised September 2015. Purchase the complete version here. 

Copyright ©2015 by Alireza Reihani and Emmett Ross  

All rights reserved. No part of this guide may be reproduced or transmitted in any form or by 
any means, electronic or mechanical, including photocopying, recording, or by any information 
storage and retrieval system, without permission in writing by the authors. The only exception 
is by a reviewer, who may quote short excerpts in a review. CATIA is a registered trademark of 
Dassault Systèmes. No affiliation with, or endorsed by anyone associated, or in any way 
connected with Dassault Systèmes, Microsoft Corporation, UNIX, or any of their fantastic 
products. We recognize that some words, model names and designations, for example, 
mentioned herein are the property of the trademark owner. We use them for identification 
purposes only. This is not an official publication.  

Disclaimer 

Although the authors have attempted to exhaustively research all sources to ensure the accuracy 
and completeness of information on the subject matter, the authors assume no responsibility for 
errors, inaccuracies, omissions, or any other inconsistencies herein. The data contained herein is 
for informational purposes only and is not represented to be error free. Information may be 
rendered inaccurate by changes made to the subject of the material, such as the applicable 
software. No consequential damages can be sought against the authors for the use of these 
materials by any third parties or for any direct or indirect result of that use. The purpose of this 
text is to complement and supplement other texts and resources. You are urged to read all the 
available literature, learn as much as you can and adapt the information to your particular needs. 
There may be mistakes within this manual. Therefore, the text should only be used as a general 
and introductory guide and not as the sole source for CATIA macro programming. The 
information contained herein is intended to be of general interest to you and is provided “as is”, 
and it does not address the circumstances of any particular individual or entity. Nothing herein 
constitutes professional advice, nor does it constitute a comprehensive or complete statement of 
the issues discussed thereto. Readers should also be aware that internet websites listed in this 
work may have changed or disappeared between when this work was written and when it is read.  

A prerequisite for this guide is to know the basics of CATIA, programming by Visual Basic, and 
VBScript for CATIA. To start learning programming for CATIA V5 from scratch, please read VB 
SCRIPTING FOR CATIA V5 by Emmett Ross.  

http://www.scripting4v5.com/gear-tutorial
http://www.scripting4v5.com/
http://www.scripting4v5.com/
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Introduction 
 

A good practice to take your CATIA programming skills to the next level is to model a complex 
example like a gear. In this guide, you’ll learn how to develop a CATVBA program to model 
different types of gears in CATIA V5.  

This guide is divided into two main steps: 

1. Drawing gears in CATIA V5 using sketcher 
2. Programming in CATIA V5 step-by-step including VBA user form 

In this case, step one is as important as step two, because there are many ways to model a gear  
but some of them are not good and are inefficient. This is especially evident in Helical Gears 
where sometimes they create errors in CATIA or the file size and/or time of creation is very high. 

Before starting these two steps, let’s briefly review the structure of this program. 

Structure of this VB Program 

This program consists of one Module (Module 1) and one Form (FrmGear). Module 1 has two 
subroutines: CATMain() to show Form and HidePlanes to Hide three main planes (X, Y and Z). 
Subroutine HidePlanes is not necessary to draw gears, it’s just for better viewing of the gears. 
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Fig 1: Project explorer and Program window in design mode 

The UserForm consists of seven subroutine and two functions. At first, Subroutine common 
creates Full Gear Profile, and then, depending on the Gear Type, one of four subroutines that 
draws the desired gear type:  

• Gear 1 Type: Spur 
• Gear 2 Type: Helical 
• Gear 3 Type: Straight Bevel  
• Gear 4 Type: Spiral Bevel 

Two functions Xn and Yp are used to calculate coordinates of intersection of two circles (to draw 
Gear profile). Subroutines HoleKey and Chamfer draw Hole of Shaft and Chamfer. 

 
Fig 2: Subroutines of FrmGear 
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Step 1: Drawing Gear Types in CATIA 
 

Before starting a Sketch of the Tooth Profile (manually or by programming), it’s necessary to have 
equations for drawing a gear tooth profile. 

• Ro = m * Z / 2 where m=module and Z=number of gear teeth 
• Rt = 0.94 * Ro 
• Rd = Ro - 1.25 * m ; Dedendum 
• Ru = Ro + m  ; Addendum 
• Rf = 0.35 * m  ; (fillet; you can get the value from the user) 

    

 

Fig 1-1: Gear profile 
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Note 1: Normally to draw a tooth profile, you must draw circles and lines, then trim them. This 
can be very difficult to do by programming so use intersection points of two circles by these 
equations: 

 

𝑥 =
𝐿 ∗ (𝑋2 − 𝑋1)

𝑑
±
ℎ ∗ (𝑌2 − 𝑌1)

𝑑
+ 𝑋1 

𝑦 =
𝐿 ∗ (𝑌2 − 𝑌1)

𝑑
∓
ℎ ∗ (𝑋2 − 𝑋1)

𝑑
+ 𝑌1 

𝑑 = �(𝑋1 − 𝑋2)2 + (𝑌1 − 𝑌2)2 

𝐿 =
𝑅12 − 𝑅22 + 𝑑2

2 ∗ 𝑑
 

ℎ = �𝑅12 − 𝐿2 

where x,y are coordinates of intersection points,  X1,Y1 are coordinates of center point of first 
circle with radius=R1 and  X2,Y2 are coordinates of center point of second circle with radius=R2. 

The fillets will also be drawn in sketch rather than using the fillet tool because it will be easier to 
do programmatically. 

In this guide, you will draw the Gear Sketch in a plane parallel to XZ plane. As a practice, you can 
develop this program and then draw a gear in each plane.  
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Fig 1-2:  Tooth Profile drawn by finding intersection points 

 

  

Fig 1-3:  First Tooth Profile (Sketch) 
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Note 2: Drawing Full Gear Profile 

For drawing full teeth profile, it doesn’t appear there is a VB function to have Circular Pattern in 

Sketch ( ). Therefore, we will use Circular pattern in GSD ( ). 

  

Fig 1-4:  Full Teeth Profile and Create Pad for Gear Type 1 

In gear types 2,3 and 4, Multi-section Solid creates the volume. 

• Gear 1 Type: Spur = PAD 
• Gear 2 Type: Helical = Multi-section 
• Gear 3 Type: Straight Bevel = Multi-section 
• Gear 4 Type: Spiral Bevel = Multi-section 
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In type 2 (helical gear); after Translating of full teeth profile; it must be rotated (Fig. 1-5). 

 

Fig 1-5: Profile Translated and Rotated 

 

 

Fig 1-6: Profile Translated and Rotated in normal view 
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Fig 1-7: Gear Type 2  

In type 3 (straight bevel); after Translating of full teeth profile; it must be scaled (Fig. 1-8). 

 

Fig 1-8: Profile Translated and Scaled in normal view 
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Fig 1-9: Gear Type 3 (straight bevel) 

In type 4 (spiral bevel); after Translating of full teeth profile; it must be rotated and be scaled. Do 
it two times (Fig. 1-10).  

 

Fig 1-10: Profile Translated, Rotated and Scaled in normal view (two times) 
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Fig 1-11: Gear Type 4 (spiral bevel) 

 

We have just created four different types of gear. Now it’s time to add automation so a user can 
change the size of gears through a user form. 
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Step 2: Programming in CATIA step by step  

2-1) Getting Data and controlling them (sub: common)  

 

2-1-1) Create Form in a new VBA project 

You can get the data needed by using an InputBox but the more user friendly way is to use a 

TextBox, ComboBox, CheckBox combination in a Form like Fig 2-1-1 

 

Fig 2-1-1: Form to get data for creating the gears to the specified size 
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For creating this User Form, we need to create a new program file.  In CATIA, click on the 

Tools>Macro>Visual Basic Editor... or press Alt+F11 (Fig 2-1-2). 

 

Fig 2-1-2: Enter the Visual Basic Editor 
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If there is not a loaded CATVBA file, one message appears (Fig 2-1-3). 

 

Fig 2-1-3: Launch VBA message 

Press Yes to create one VBA project. Now Macro libraries window appears (Fig 2-1-4) 
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Fig 2-1-4) Macro libraries window 

Click on Create new library... button (Library type must be VBA Project Fig 2-1-5). Now 

Create a new VBA project window appears (Fig. 2-1-5). Enter a path and name for your VBA 

project. (This path must be valid, otherwise an error message appears and CATIA doesn’t help 

you to create these Folders.)  
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Fig 2-1-5) Create a new VBA project window 

By clicking on the Ok button you will come back to Macro libraries window and you will see 

your new full path of new VBA project in this window (Fig 2-1-6).  
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Fig 2-1-6: new VBA project in Macro libraries window 

By clicking on Close button you will enter into the VBA environment (Fig 2-1-7) 
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Fig 2-1-7) VBA environment 

To create a Form, Right click on the Project window (left side in Fig 2-1-7) then click on 

Insert>UserForm (Fig 2-1-8) or use menu  Insert>UserForm (Fig 2-1-9). New Form appears 

(Fig 2-1-10).  
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Fig 2-1-8: Add a new Form in your VBA project by right click 

 

Fig 2-1-9: Add a new Form in your VBA project by menu 
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Fig 2-1-10: new Form 

To access to properties of this Form, click on menu View>Properties Window or press F4 or 

click on Properties window icon ( ) or right-click on the form and select properties (Fig 2-

1-11) . Now properties window of  Form appears (Fig 2-1-12). Change the Name property of 

form to FrmGear. 
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Fig 2-1-11: Access to properties of Form by right-click 

 

Fig 2-1-12: properties of Form 
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To access CATIA when the Gear program is running, then set ShowModal property to False 

(Fig 2-1-13). Forms are displayed by the Show method of the form object. This method has an 

optional argument to specify whether the form should be displayed as either modal or 

modeless. A modal form will not let you interact with any other part of the application until 

that form is closed. This means that you cannot interactively use other CATIA commands or 

interact with any other forms that might be displayed at the time. Forms are, by default, modal 

unless otherwise specified. We want to interact with CATIA so set ShowModal property to 

False. 

 

Fig 2-1-13: ShowModal property of Form 

Change the Caption property to 3D Gear (Fig 2-1-14). Finally, change the size of the Form (by 

dragging of corners of  Form or by setting width and Height property). 
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Fig 2-1-14: Caption property of Form 

To classify the controls such as TextBoxes, Labels,... , insert a Frame (Fig 2-1-15) by dragging 

its icon on Toolbox window (Fig 2-1-16) to Form or by clicking on its icon and click a point on 

Form. (If you don’t see this window click on menu: View>Toolbox or click on its icon in 

Standard Toolbars ) 
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2-1-9) Get the Scale of Diameter and check its value 
 

    Dim Sc As Double              'Scale in conic Gear types 

    Sc = Val(TxtScale.Text) 

        If (Op3.Value = True Or Op4.Value = True) And Sc = 0 Then 

            MsgBox "Please Increase Conic Scale.", , "Data Review" 

            FrmGear.Show 

            TxtScale.SetFocus 

            Exit Sub 

        End If 
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2-1-10) Calculate the five Radiuses necessary to draw Gear Tooth 

 

    Dim Rt As Double 

    Dim Ro As Double 

    Dim Rd As Double    'Gear minimum Radius (Dedendum) 

    Dim Ru As Double    'Gear Maximum Radius (Addendum) 

    Dim Rf As Double    'Fillet Radius 

     

    Ro = m * Z / 2# 

    Rt = 0.94 * Ro 

    Rd = Ro - 1.25 * m 

    Ru = Ro + m 

    Rf = 0.35 * m 

     

    If Rd <= 0 Then 

        MsgBox "Please Increase Teeth Qty.", , "Data Review" 

        FrmGear.Show 

        TxtZ.SetFocus 

        Exit Sub 

    End If 
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Video Demo 
 

Watch this program in action. 

https://www.youtube.com/watch?v=Q7pERp0PfvI 
 

 

 

 

 

 

 

https://www.youtube.com/watch?v=Q7pERp0PfvI
http://www.scripting4v5.com/gear-tutorial
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Learn how to create an impressive CATVBA 
project you can use in your next job interview. 

  
Learn how to automatically model four different types of gears in CATIA V5 and create a complex 
user form to create new gears with your desired properties on-the-fly. Along the way of this step-
by-step tutorial you'll also learn how to: 

• Sketch and model different types of gears in CATIA V5 

• Create a detailed userform with command buttons, combo boxes, etc. 

• Break up a complicated project into smaller, more manageable components 

• Use subroutines and functions 

• Anticipate and check for user errors in your program 

After going through the guide you’ll have a fully functional program that you’ll be able to show 
off to potential employers. This tutorial will show you one way you can unlock the full power of 
CATIA V5, a skill that can be translated to countless other tasks and systems. 

What’s Included: 

• 120 page step-by-step guide (PDF) 

• Gear 1 and Gear 4 CATPart Examples 

• CATVBA Code 

• 60-day money back guarantee 

Click here to get started: http://www.scripting4v5.com/gear-tutorial 

 

Questions? Contact us. 

We wish you nothing less than success. Thanks again, good luck, and happy programming!   

- Alireza Reihani and Emmett Ross  

 

Start modeling gears today! 

http://www.scripting4v5.com/gear-tutorial
http://www.scripting4v5.com/gear-tutorial
http://www.scripting4v5.com/gear-tutorial
http://www.scripting4v5.com/gear-tutorial
http://www.scripting4v5.com/contact-us/
http://www.scripting4v5.com/gear-tutorial
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Appendix I: Keyboard Shortcuts  
  
Default CATIA and VBA editor shortcuts:  

  
CATIA V5:  
  
 F1: Open the CATIA V5 online contextual help file  
 Alt+F8: Macro shortcut  
 Alt+F11: Open the macro editor  

  
VBA Editor:  
  
 F1: Visual Basic help  
 F2: Open the Object Browser  
 F4: Properties Window  
 F5: Run macro  
 F7: Code window  F8: Step Into  
 Crtl + Break: Break  
 Crtl + J: List properties and methods  
 Alt+F11: Go back to CATIA  
 End: Quit a running macro  
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Appendix II: Resources 
 

The following is a list of resources used when creating this tutorial and other recommended tools. 

 

HOW TO: Création Roue Dentée Paramétrée CATIA V5 R20 By madriver30 

https://www.youtube.com/watch?v=dvyLuOPvMV8 

 

Helical gear part by Priyam Bajpai 

https://www.youtube.com/watch?v=H989ooFHrxo 

 

Reference for finding intersection points of two circles: 

http://math.stackexchange.com/questions/256100/how-can-i-find-the-points-at-which-two-
circles-intersect 

 

Types of gears: 

http://sdp-si.com/resources/gears/pdf/gear_types_manufacturing.pdf 

 

Confused? Post your question in the forum if you get stuck or have any suggestions for improving 
the tutorial. 

http://www.scripting4v5.com/forums/forum/catia-macro-programming/ 

 

  

  

 

https://www.youtube.com/watch?v=dvyLuOPvMV8
https://www.youtube.com/watch?v=H989ooFHrxo
http://math.stackexchange.com/questions/256100/how-can-i-find-the-points-at-which-two-circles-intersect
http://math.stackexchange.com/questions/256100/how-can-i-find-the-points-at-which-two-circles-intersect
http://sdp-si.com/resources/gears/pdf/gear_types_manufacturing.pdf
http://www.scripting4v5.com/forums/forum/catia-macro-programming/
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