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Images (graphics) in Writer

When you create a text document using LibreOffice Writer, you may want to include some 
illustrations. Illustrations (images or graphics) are added to documents for a variety of reasons: 
from supporting the description provided in the text—as used in this Guide—to providing an 
immediate visual representation of the contents, as is often found in a newspaper.

Images in Writer are of three basic types:

• Image files, such as photos, drawings, and scanned images

• Diagrams created using LibreOffice’s drawing tools

• Charts created using LibreOffice’s Chart facility

This chapter covers images and diagrams.

More detailed descriptions on working with drawing tools can be found in the Draw Guide and 
Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Creating and editing images

You might create images (also called ‘pictures’ in LibreOffice) using a graphics program, scan 
them, or download them from the Internet (make sure you have permission to use them), or use 
photos taken with a digital camera. Writer can import various vector (line drawing) images, and can
rotate and flip such images. Writer also supports raster (bitmap) file formats, the most common of 
which are GIF, JPG, PNG, and BMP. See the Help for a full list.

Writer can import SmartArt images from Microsoft Office files. For example, Writer can open a 
Microsoft Word file that contains SmartArt, and you can use Writer to edit the images.

Some things to consider when choosing or creating pictures include image quality and whether the 
picture will be printed in color or black and white (grayscale).

To edit photos and other bitmap images, use a bitmap editor. To edit line drawings, use a vector 
drawing program. You do not need to buy expensive programs. Open-source (and usually no-cost) 
tools such as Gimp (bitmap editor) and Inkscape (vector drawing program) are excellent. For many
graphics, LibreOffice Draw is sufficient. These and many other programs work on Windows, 
Macintosh OS X, and Linux.

For best results:

• Create images that have the exact dimensions required for the document, or use an 
appropriate graphics package to scale photographs and large drawings to the required 
dimensions. Do not scale images with Writer, even though Writer has tools for doing this, 
because the results might not be as clear as you would like.

• Do any other required image manipulation (brightness and contrast, color balance, 
cropping, conversion to grayscale, and so on) in a graphics package, not in Writer, even 
though Writer has the tools to do a lot of these things too.

• If the document is meant for screen use only, there is no need to use high resolution 
images of 300 or more dpi (dots per inch). Most computer monitors work at between 72 
and 96 dpi; reducing the resolution (and the file size) has no negative impact on what is 
displayed but does make Writer more responsive.
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Preparing images for black-and-white printing
If color images are to be printed in grayscale, check that any adjacent colors have good contrast 
and print dark enough. Test by printing on a black-and-white printer using a grayscale setting. 
Better still: change the “mode” of the image to grayscale, either in a photo editor or in Writer itself 
(see “Graphics mode” on page 11).

For example, the following diagram looks good in color. The circle is dark red and the square is 
dark blue. In grayscale, the difference between the two is not so clear. A third element in the 
diagram is a yellow arrow, which is almost invisible in grayscale.

Original drawing in color Drawing printed in grayscale

Changing the colors of the circle and the arrow improves the contrast and visibility of the resulting 
grayscale image.

Original drawing in color Drawing printed in grayscale

If the document will be available in black-and-white print only, a better result can often be obtained 
by choosing grayscale fills, not color fills—and you don’t have to guess and test to see if you’ve 
made good choices.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file, directly from a 
graphics program or a scanner, from a file stored on your computer, or by copying and pasting from
a source being viewed on your computer.

Inserting an image file
When the image is in a file stored on the computer, you can insert it into a LibreOffice document 
using either of the following methods.

Drag and drop
1) Open a file browser window and locate the image you want to insert.

2) Drag the image into the Writer document and drop it where you want it to appear. A faint 
vertical line marks where the image will be dropped.

This method embeds (saves a copy of) the image file in the Writer document. To link the file 
instead of embedding it, hold down the Control+Shift keys while dragging the image.

6 Working with Images



Insert Image dialog
1) Click in the LibreOffice document where you want the image to appear.

2) Choose Insert > Image > From File from the Menu bar.

3) On the Insert Image dialog, navigate to the file to be inserted, and select it.

At the bottom of the dialog are two options, Preview and Link. Select Preview to view a 
thumbnail of the selected image on the right (as shown in the example), so you can verify 
that you have the correct file. See “Inserting an image file” below for the use of Link.

4) Click Open.

Figure 1: Insert Image dialog

Linking an image file
If the Link option in the Insert picture dialog is selected, LibreOffice creates a link to the file 
containing the image instead of saving a copy of the image in the document. The result is that the 
image is displayed in the document, but when the document is saved, it contains only a reference 
to the image file—not the image itself. The document and the image remain as two separate files, 
and they are merged together only when you open the document again.

Figure 2: Cautionary message box when inserting a linked image

Linking an image has two advantages and one disadvantage:

• Advantage – Linking can reduce the size of the document when it is saved, because the 
image file itself is not included. File size is usually not a problem on a modern computer 
with a reasonable amount of memory, unless the document includes many large images 
files; LibreOffice can handle quite large files.
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• Advantage – You can modify the image file separately without changing the document 
because the link to the file remains valid, and the modified image will appear when you 
next open the document. This can be a big advantage if you (or someone else, perhaps a 
graphic artist) is updating images.

• Disadvantage – If you send the document to someone else, or move it to a different 
computer, you must also send the image files, or the recipient will not be able to see the 
linked images. You need to keep track of the location of the images and make sure the 
recipient knows where to put them on another machine, so the document can find them. 
For example, you might keep images in a subfolder named Images (under the folder 
containing the document); the recipient of the file needs to put the images in a subfolder 
with the same name (under the folder containing the document).

Note
When inserting the same image several times in the document it would appear 
beneficial to create links; however, this is not necessary as LibreOffice embeds in 
the document only one copy of the image file.

Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish. To 
do so:

1) Open the document in LibreOffice and choose Edit > Links.

2) The Edit Links dialog shows all the linked files. In the Source file list, select the files you 
want to change from linked to embedded. Click Update to ensure you have the latest 
image where changes may have taken place.

3) Click the Break Link button.

4) Click Yes in the confirmation message box.

5) Save the document.

Note
Going the other way, from embedded to linked, is not so easy—you must delete 
and reinsert each image, one at a time, selecting the Link option when you do so.

Figure 3: The Edit Links dialog
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Inserting an image from the clipboard
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice 
document and from other programs. To do this:

1) Open both the source document and the target document.

2) In the source document, select the image to be copied.

3) Move the mouse pointer over the selected image and press Control+C (or right-click and 
select Copy from the context menu) to copy the image to the clipboard.

4) Switch to the target document.

5) Click to place the cursor where the image is to be inserted.

6) Press Control+V (or right-click and select Paste from the context menu) to insert the image.

Caution
If the application from which the image was copied is closed before the image is 
pasted into the target, the image stored on the clipboard could be lost.

Inserting an image using a scanner
If a scanner is connected to your computer, LibreOffice can call the scanning application and insert
the scanned item into the LibreOffice document as an image. To start this procedure, click where 
you want the image to be inserted and select Insert > Image > Scan > Select Source.

Select the scan source from the list. This list will contain available devices and, on Windows 
systems the Windows Imaging Acquisition (WIA) platform to these devices. After choosing the 
device, select Insert > Image > Scan > Request. This will open the imaging software to permit 
you to adjust settings for picture quality, size, and other settable attributes. This practice is quick 
and easy, but may not result in a high-quality image of the correct size. You may get better results 
by scanning material into a graphics program and cleaning it up there before inserting the resulting 
image into LibreOffice.

Inserting an image from the Gallery
The Gallery provides a convenient way to group reusable objects such as images and sounds that 
you can insert into your documents. The Gallery is available in all components of LibreOffice. It 
comes with many images, but you can still add your own pictures or find extensions containing 
more images. The Gallery is explained in more detail in Chapter 11, Graphics, the Gallery, and 
Fontwork, in the Getting Started guide. For more about extensions, see Chapter 16, Customizing 
Writer, in this book.

This section explains the basics of inserting a Gallery image into a Writer document.

1) To open the Gallery, click on the Gallery icon ( ) (located in the Standard toolbar and in 
the Drawing toolbar) or choose Tools > Gallery from the Menu bar. The Gallery can also 
be accessed through the Gallery tab on the Sidebar (View > Sidebar > Gallery).

2) Navigate through the Gallery to find the desired picture.

3) To insert the picture, click and drag it from the Gallery into the Writer document. You can 
also right-click on the picture and choose Insert > Copy.

Figure 4 shows an example of an image dragged from the Gallery.

By default, the Gallery is docked above the Writer workspace unless accessed from the Sidebar, in
which case it is docked on the right hand side in a vertical orientation. To expand the Gallery 
opened from other than the Sidebar, position the pointer over the line that divides it from the top of 
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the workspace. When the pointer changes to parallel lines with arrows, click and drag downward. 
The workspace resizes in response.

To expand the Gallery without affecting the workspace, undock it so it floats over the workspace. 
To do so, hold down the Control key and double-click on the upper part of the Gallery next to the 
View icons.  Double-click in the same area while holding down the Control key to dock it again 
(restore it to its position over the workspace).

When the Gallery is docked, to hide it and view the full Writer workspace, click the Hide/Show 
button in the middle of the thin bar separating the Gallery from the workspace (circled in Figure 4).

The vertically oriented Gallery of the Sidebar can be manipulated by similar cursor placements and
control selection.

To close the Gallery, choose Tools > Gallery to toggle the Gallery entry, or click on the Gallery 
icon again. The Sidebar can be closed by deselecting View > Sidebar from the Menu bar.

Figure 4: Inserting an image from the Gallery

Modifying an image

When you insert a new image, you may need to modify it to suit the document. The placement of 
the picture relative to the text is discussed in “Positioning images within the text” on page 18. This 
section describes the use of the Picture toolbar, resizing, cropping, and a workaround to rotate a 
picture.

Writer provides many tools for working with images. These tools are sufficient for most people’s 
everyday requirements. However, for professional results it is generally better to use an image 
manipulation program such as GIMP to modify images (for example, to crop, resize, rotate, and 
change color values) and then insert the result into Writer. GIMP is an open-source graphics 
program that can be downloaded from http://www.gimp.org/downloads/.
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Using the Picture toolbar
When you insert an image or select one already present in the document, the Picture toolbar 
appears. You can set it to always be present (View > Toolbars > Picture). Picture control buttons 
from the Picture toolbar can also be added to the Standard Toolbar. See Chapter 16, Customizing 
Writer, for more information.

This toolbar can be either floating or docked. Figure 5 shows what the Picture toolbar looks like 
when it is floating.

1 Filter 10 Red 19 Remove Noise
2 Graphics mode 11 Green 20 Solarization
3 Color 12 Blue 21 Aging
4 Transparency 13 Brightness 22 Posterize
5 Flip Horizontally 14 Contrast 23 Pop Art
6 Flip Vertically 15 Gamma 24 Charcoal Sketch
7 Rotate 90° Left 16 Invert 25 Relief
8 Rotate 90° Right 17 Smooth 26 Mosaic
9 Frame Properties 18 Sharpen

Figure 5: Picture toolbar plus tear-off Graphic Filter toolbar and floating Color toolbar

Two other toolbars can be opened from this one: the Graphic Filter toolbar, which can be torn off 
and placed elsewhere on the window, and the Color toolbar, which opens as a separate floating 
toolbar.

From these three toolbars, you can apply small corrections to the image or obtain special effects.

Graphics mode
You can change color images to grayscale, to black and white, or to a
watermark by selecting the image and then selecting the relevant menu
item from the Graphics mode list.

Flip vertically, horizontally or in 90° rotations 
To flip an image vertically horizontally or rotate it by ninety degrees, select the image, and then 
click the relevant button.
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Filters
Table 1 provides a short description of the available filters, however the best way to understand 
them is to see them in action. Experiment with the different filters and filter settings, remembering 
that you can undo all the changes by pressing Ctrl+Z or Alt+Backspace or by selecting Edit > 
Undo.

Table 1: Graphic filters and their effects

Icon Name Effect

Invert
Inverts the color values of a color image or the brightness values of 
a grayscale image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

Solarization
Mimics the effects of too much light in a picture. A further dialog 
opens to adjust the parameters.

Aging
Simulates the effects of time on a picture. Can be applied several 
times. A further dialog opens to adjust the aging level.

Posterize
Makes a picture appear like a painting by reducing the number of 
colors used.

Pop Art Modifies the picture dramatically.

Charcoal Displays the image as a charcoal sketch.

Relief
A dialog is displayed to adjust the light source that will create the 
shadow and, hence, the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Color
Use this toolbar to modify the individual RGB color components of the image (red, green, blue) as 
well as the brightness, contrast, and gamma of the image. If the result is not satisfactory, you can 
press Control+Z to restore the default values.

Transparency 
Modify the percentage value in the Transparency box on the Picture toolbar to make the image 
more transparent. This is particularly useful when creating a watermark or when wrapping the 
image in the background.
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Using the Formatting toolbar and Picture dialog
When an image is selected, you can customize some aspects of its appearance using the tools 
available on the OLE-Object toolbar (shown in Figure 11) as well as in the dialog that is shown by 
right-clicking on the image and selecting Picture. You can, for example, create a border around the
image, selecting style and color; or you can (in the Borders page of the Picture dialog) add a 
shadow to the image.

Cropping images
When you are only interested in a section of the image for the purpose of your document, you may 
wish to crop (cut off) parts of it.

Note
If you crop an image in Writer, the image itself is not changed. Writer hides, not 
cuts off, part of the image. If you export the document to HTML, the original image 
is exported, not the cropped image.

To start cropping the image, right-click on it and select Picture from the context menu. In the 
Picture dialog, select the Crop page.

The units of measurement shown on the Crop page are those set in Tools > Options > 
LibreOffice Writer > General.

Two options are available in the crop section for cropping an image.

The first option is the default; Keep scale. You can visualize this as using scissors on a paper 
picture. As you cut parts off, the image gets smaller.

Figure 6: Result on image size of cropping using Keep scale option

The second option is Keep image size. You can visualize this as having a picture frame and the 
image is zoomed in as much as required to fill the fixed-size frame.

You can see in Figure 6 that as the values in Left, Right, Top, and Bottom are altered, the 
boundaries of the image in the preview box alter to show the crop area on the image. This results 
in either an image size change, or a scale change for a fixed image size (Figure 7).

The Width and Height fields under either Scale or Image size change as you enter values in the 
Left, Right, Top, and Bottom fields, depending on which option, Keep scale, or Keep image size, is 
selected.

Modifying an image 13



The original image size is indicated above the Original Size button. The bitmap image density is 
shown alongside this dimension.

Figure 7: Result using Keep image scale option

Resizing an image
To perfectly fit the image into your document, you may have to resize it. There are a number of 
options available in Writer to do this.

A quick and easy way to resize is by dragging the image’s sizing handles:

1) Click the image, if necessary, to show the green sizing handles.

2) Position the pointer over one of the green sizing handles. The pointer changes shape 
giving a graphical representation of the direction of the resizing.

3) Click and drag to resize the image.

4) Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the image simultaneously, while the 
other four handles only resize one dimension at a time.

Tip
To retain the original proportions of the image, Shift+click one of the corner handles,
then drag.

Figure 8 shows three examples of an image inserted into a document and resized.

For more accurate resizing of images, use either the Crop page of the Picture dialog (Figure 6) or, 
the Type page of the Picture dialog.

On the Crop page you can adjust the following settings:

• Scale Width and Height: specify in percentages the scaling of the image. The size of the 
image changes accordingly. For a symmetrical resizing, both values need to be identical.

• Image size: specify the size of the image in your preferred unit of measurement. The 
image enlarges or shrinks accordingly.

• Original size button: when clicked, restores the image to its original size. This will be the 
size resulting after any cropping was carried out.
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Figure 8: Three examples of resized images, plus the original image

On the Type page of the Picture dialog, select the Relative option to toggle between percentage 
and actual dimension. For a symmetrical resizing, select the Keep ratio option. Clicking on the 
Original Size button restores the original image size, the scale dimensions are altered if the image
has been cropped.

Rotating an image
Writer does not provide a tool for rotating an image in other than 90° increments; however, there is 
a simple workaround:

1) Open a new Draw or Impress document (File > New > Drawing or File > New > 
Presentation).

2) Insert the image you want to rotate. You can use any of the mechanisms described in 
“Adding images to a document” on page 6, although there are some slight variations in the 
position of the menu entries and icons.

3) Select the image, then in the Drawing toolbar (shown by default at the bottom of the 

window in Impress and Draw), select the Rotate icon ( ) from the Effects tear-off 

toolbar ( ).

4) Rotate the image as desired. Use the red handles at the corners of the image and move 
the mouse in the direction you wish to rotate. By default the image rotates around its center
(indicated by a black cross-hair), but you can change the pivot point by moving the black 
cross-hair to the desired rotation center.

Tip
To restrict the rotation angle to multiples of 15 degrees keep the Shift key pressed 
while rotating the image.

5) Select the rotated image by pressing Ctrl+A, then copy the image to the clipboard with 
Ctrl+C.
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6) Finish by going back to the location of the Writer document where the image is to be 
inserted and pressing Ctrl+V.

Other settings
The Picture dialog (Figure 6) consists of nine pages. The Crop page was described on page 13, 
while the use of the Type and the Wrap pages is explained in “Positioning images within the text” 
on page 18. The other pages serve the following purposes:

• Options: use this page to give the image a descriptive name (as you want it to appear in 
the Navigator), display alternative text when the mouse hovers over the image in a web 
browser when the image is not available, and protect some of the image settings from 
accidental changes. You can also prevent the image from being printed by deselecting the 
corresponding option.

• Borders: use this page to create borders around the image. The Borders dialog is the 
same as the one used for defining table or paragraph borders. You can also add a shadow 
to the image if so desired.

• Background: use this page to change the background color of the image. This setting 
produces the desired results only for images with a transparent color.

• Hyperlink: use this page to associate a hyperlink to the image. You can also create an 
image map so that only certain areas of the image respond to a mouse click by opening the
associated URI (Uniform Resource Identifier) in the default browser. More information on 
image maps can be found in the Impress Guide.

• Picture: use this page to flip the image as well as to display the original location of the file 
in case the image is linked rather than embedded.

• Macro: allows you to associate a macro to the image. You can choose among the 
predefined macros or write your own.

Deleting an image
To delete an image:

1) Click on the image to show the green resizing handles.

2) Press Delete.

Using Writer’s drawing tools

You can use Writer’s drawing tools to create graphics, such as simple diagrams using rectangles, 
circles, lines, text, and other predefined shapes. You can also group several drawing objects to 
make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in your document, or you can insert them into
a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations 
produced by other programs, but this is not recommended because:

• You cannot include images in a group with drawing objects, so they may get out of 
alignment in your document.

• If you convert a Writer document to another format, such as HTML, the drawing objects and
the images will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended you use LibreOffice Draw, 
which includes many more features such as layers, styles, and so on.
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Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 9), by clicking View > 
Toolbars > Drawing.

If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to 
a convenient place on the window.

1 Select 5 Freeform Line 9 Symbol Shapes 13 Stars
2 Line 6 Text 10 Block arrows 14 Points
3 Rectangle 7 Callouts 11 Flowcharts 15 Fontwork Gallery
4 Ellipse 8 Basic Shapes 12 Callouts 16 From File

17 Extrusion On/Off
Figure 9: The Drawing toolbar

To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change the 
anchor later, if necessary.

2) Select the tool from the Drawing toolbar (Figure 9). The mouse pointer changes to a 

drawing-functions pointer similar to this one for a rectangle shape ( ).

3) Move the cross-hair pointer to the place in the document where you want the image to 
appear and then click-and-drag to create the drawing object. Release the mouse button. 
The selected drawing function remains active, so you can draw another object of the same 
type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the 
arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and weight, anchoring, and others) 
of the drawing object using either the Drawing Object Properties toolbar (Figure 10) or the 
choices and dialog reached by right-clicking on the drawing object.

Set or change properties for drawing objects
To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 9), click the Select tool.

2) On the Drawing Object Properties toolbar (Figure 10), click on the icon for each property 
and select the value you want for that property.

3) For more control, or to define new attributes, you can click on the Area or Line icons on the
toolbar to display detailed dialogs.

The default you set applies to the current document and session. It is not retained when you close 
the document or close Writer, and it does not apply to any other document you open. The defaults 
apply to all the drawing objects except text objects.

To change the properties for an existing drawing object, select the object, then continue as 
described above.
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1 Line 5 Line Color 9 To Foreground 13 Alignment

2 Arrow Style 6 Area 10 To Background 14 Change Anchor

3 Line Style 7 Area Style / Filling 11 Bring to Front 15 Ungroup

4 Line Width 8 Rotate 12 Send to Back 16 Group

Figure 10: Drawing Object Properties toolbar

You can also specify the position and size, rotation, and slant and corner radius properties of the 
drawing object:

1) Right-click on the drawing object and then click Position and Size from the context menu. 
The Position and Size dialog is displayed.

2) Choose any properties, as required.

Resizing a drawing object
The same considerations for resizing an image apply also to resizing an object. Select the object, 
click on one of the eight handles around it and drag it to its new position. For a scaled resizing, 
select one of the corner handles and keep the Shift key pressed while dragging the handle to its 
new position.

For more sophisticated control of the size of the object, select Format > Object > Position and 
Size from the Menu bar. Use the Position and Size dialog to set the width and height 
independently. If the Keep ratio option is selected, then the two dimensions change so that the 
proportion is maintained, allowing for a scaled resizing.

Grouping drawing objects
To group drawing objects:

1) Select one object, then hold down the Shift key and select the others you want to include in
the group. The bounding box expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of the objects and choose 
Format > Group > Group from the Menu bar or right-click and choose Group > Group 
from the context menu.

Note You cannot include an embedded or linked image in a group with drawing objects.

Positioning images within the text

When you add an image to a text document, you need to choose how to position it with respect to 
the text and other images. The positioning of images is often rather time-consuming and may be 
very frustrating for both inexperienced and experienced users. As Writer is a word processor rather
than a desktop publishing program, there are some limitations to the flexibility in positioning images
and it takes time to get things exactly as you would like them.
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Positioning of an image is controlled by four settings:

• Arrangement refers to the placement of an image on an imaginary vertical axis. 
Arrangement controls how images are stacked upon each other or relative to the text.

• Alignment refers to the vertical or horizontal placement of an image in relation to the 
chosen anchor point.

• Anchoring refers to the reference point for the images. This point could be the page, or 
frame where the object is, a paragraph, or even a character. An image always has an 
anchor point.

• Text wrapping refers to the relation of images to the surrounding text, which may wrap 
around the graphic on one or both sides, be overprinted behind or in front of the graphic, or
treat the graphic as a separate paragraph or character.

The settings can be accessed in a number of ways, depending on the nature of the images:

1) From the Format menu, where you can find Alignment, Arrange, Wrap, and Anchor 
(both for images and drawing objects).

2) From the context menu displayed when you right-click on the graphic.

3) From the OLE-Object toolbar (default setting shown in Figure 11).

4) For images, from the Type and Wrapping pages of the Picture dialog. Note that you cannot 
control the arrangement using the dialog. To open the Picture dialog, click on the image to 
select it and then choose Format > Picture or right-click on the graphic and choose 
Picture on the context menu.

5) For drawing objects, from the Position and Size page of the Position and Size dialog. To 
open the Position and Size dialog, click on the drawing object to select it and then choose 
Format > Object > Position and Size or right-click on the graphic and choose Position 
and Size on the context menu. Note that you can only control the alignment and anchoring.

1 Apply Style 6 Base line centered 11 Frame Properties 16 Line Style

2 Align Left 7 Base line at bottom 12 Bring to Front 17 Line Color (of the border)

3 Center 
Horizontal

8 Wrap Off 13 Send to Back

4 Align Right 9 Page Wrap 14 Change Anchor

5 Base line at 
top

10 Wrap Through 15 Borders, add lines; SHIFT
to add and remove

Figure 11: OLE-Object toolbar (graphical control of positioning for images)

Arranging images
Arranging an image means to determine its vertical position relative to other images or text. 
Arranging is only relevant when objects are overlapping. You can choose between four common 
settings, plus a fifth special setting for drawing objects:

Bring to Front
Places the image on top of any other images or text.

Bring Forward
Brings the image one level up in the stack (z-axis). Depending on the number of overlapping 
objects, you may need to apply this option several times to obtain the desired result.
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Send Backward
The opposite of Bring Forward; sends the selected graphic one level down in the object stack.

Send to Back
Sends the selected graphic to the bottom of the stack, so that other images and text cover it.

To Background / To Foreground
Only available for drawing objects; moves the drawing object behind or in front of the text 
respectively.

Anchoring images
You can anchor images as a character or to a page, paragraph, or character. You can also place 
images in a frame and anchor the frame to a page, paragraph, or character. Which method you 
choose depends on what you are trying to achieve.

Here are the ways you can anchor images or drawing objects:

To Page
The graphic keeps the same position in relation to the page margins. It does not move as you 
add or delete text or other images. This method is useful when the graphic does not need to be
visually associated with a particular piece of text. It is often used when producing newsletters 
or other documents that are very layout intensive, or for placing logos in letterheads.

Caution If you plan to use a document within a master document, do not anchor images 
To Page because the images will disappear from the master document. See 
Chapter 13, Working with Master Documents, for more information.

To Paragraph
The graphic is associated with a paragraph and moves with the paragraph. It may be placed in 
the margin or another location. This method is useful as an alternative to a table for placing 
icons beside paragraphs.

To Character
The graphic is associated with a character but is not in the text sequence. It moves with the 
paragraph but may be placed in the margin or another location. This method is similar to 
anchoring to a paragraph but cannot be used with drawing objects.

As Character
The graphic is placed in the document like any other character and, therefore, affects the 
height of the text line and the line break. The graphic moves with the paragraph as you add or 
delete text before the paragraph. This method is useful for keeping screen-shots in sequence 
in a procedure (by anchoring them as a character in a blank paragraph) or for adding a small 
(inline) icon in sequence in a sentence.

To Frame
If the graphic has been placed in a frame, you can anchor the graphic in a fixed position inside 
the frame. The frame can then be anchored to the page, a paragraph, or a character, as 
required.
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Aligning images
Once you have established the anchor point of the graphic, you can decide the position of the 
graphic relative to this anchor: this is called aligning the images. Choose from six options: three for 
aligning the graphic horizontally (left, center, right) and three for aligning the graphic vertically (top, 
center, bottom). Horizontal alignment is not available for images anchored As Character.

For finer control of the alignment, use the Position options on the Type page of the Picture dialog, 
shown in Figure 12.

Figure 12: Fine tuning the alignment

For both the horizontal and vertical position, start by picking the reference point in the right hand 
side drop-down menu, then select in the first drop-down menu among Left, Right or Center. If you 
select the value From left (or From top for the vertical positioning) you can specify the amount in 
your selected unit of measurement. In the example in Figure 12, the upper-left corner of the image 
will be placed at 3 cm from the left margin of the page horizontally and on the top margin vertically.

A visual representation of the area to which the image is anchored is shown in the preview pane to 
the right of the page, indicated by a red bordered area. The graphic position is indicated by a green
bordered area.

Wrapping text around images
The Wrap setting determines the relation between the text and the graphic. Several choices are 
available from the context menu:

No Wrap
With this option the text is placed above and below the image but not to either side of it. This is 
the wrapping type used for most of the figures in this guide.

Page Wrap or Optimal Page Wrap
The text flows around the image. Moving the image around the page causes the text to be 
rearranged to fill the space to the left and right of it. Optimal Page Wrap prevents text from 
being placed to the side of the image if the spacing between the image and the margin is less 
than 2 cm.

Wrap Through
Superimposes the image on the text. That is, the image is in front of the text. This option must 
be used in conjunction with the image-transparency setting in order to make the text under the 
picture visible.

In Background
Similar to Wrap Through, but the image is placed behind the text so there may be no need to 
change the transparency to make the text visible.

Note
The No Wrap option found in the context menu of a picture is equivalent to the 
Wrap Off menu item in the Format > Wrap menu.
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The wrap format is normally selected after the anchoring and the alignment of the picture have 
been decided. To set the position of an image to the desired wrap format, follow these steps:

1) Select an image by clicking on it.

2) Right-click to display the context menu and move the mouse pointer to Wrap to display the 
available wrap formats. Alternatively you can select Format > Wrap from the Menu bar.

3) Select the desired wrap format.

Note
When anchoring an image as character, you can only adjust the distance between 
the image and the text, but no wrapping option is displayed.

To fine-tune the wrapping options, open the Picture dialog and select the Wrap page, shown in
Figure 13.

Figure 13: The advanced wrap format options

For images, you can open this dialog by selecting Format > Picture from the Menu bar or right-
click and select Picture from the context menu. For drawing objects, you can access the Wrap 
page by selecting Format > Wrap > Edit in the Menu bar or right-click and select Wrap > Edit 
from the context menu.

This page is divided into three sections. In the top part you can select from the wrap types 
mentioned above, plus two additional wrap formats that prevent the text from filling the area to the 
left (After) or to the right (Before) of the picture. Use the Spacing section of the page to adjust the 
spacing between the image and the text. The contents of the Options section of the page may 
change depending on the selected wrap format.

First paragraph
Check this box if you want LibreOffice to start a new paragraph after the image even if it could 
still wrap around the image.

In background
This option becomes available if Through Wrap is selected; it moves the image to the 
background.

Contour
Wraps the text around a custom contour rather than around the edge of the picture. This option
is only available for Page or Optimal Page Wrap.
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Outside only
Forces the text to wrap on the outside of the image, even if the contour contains open areas 
within the shape.

Editing the contour
If you select wrapping around a drawing object, LibreOffice automatically creates a contour. The 
Edit Contour option is only available for image wrapping. You can automatically create a contour 
from the context menu after right-clicking the image, by selecting Contour. You can access the 
Contour Editor by selecting Format > Wrap > Edit Contour or from the right-click menu.

The dialog shown in Figure 14 opens with the image loaded in the main window. Use the tools to 
draw the region of the image you do not want to be covered by the text—this area will be shaded.

Figure 14: The Contour Editor in action with AutoContour

There are four tools available to create a contour in the Contour Editor window: Rectangle, 
Ellipse, Polygon, and AutoContour. Some familiarity with drawing tools is required to create 
complex contours; however, in most circumstances there is no need for high accuracy. Figure 14 
shows the actual contour used for “Example 2: Simple contour wrapping in action” when using 
AutoContour, and as you can see the shape of the line around the edge of the apple is quite 
acceptable.

When you are done, click on the Apply button to save the contour. If you are not satisfied with the 
result, you can select the contour line and press the Delete key to restart, or click the Workspace 
icon and then click inside the contour. You can also undo the previous steps or you can select the 
Edit Points button and adjust the contour shape point by point. Be aware that any of the graphic 
outside the contour line is not shown in the document.

For simple images, the AutoContour button does a decent job. If the contour has to be drawn 
around an area with the same or a similar color, you can select this region using the eyedropper. 
Select this tool, then click on a point in the image having the desired color. LibreOffice 
automatically selects all the points which have the same or a similar color. The similarity level can 
be changed by modifying the value in the tolerance box (100% = perfect match).

Note
While all the positioning techniques discussed in this section apply equally to 
frames, contour wrapping is not possible.
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Example 1: Page wrapping
Figure 15 shows an example of page wrapping in action.

Figure 15: Example of image with Page Wrap formatting

To achieve this:

1) Insert the image into the document, then anchor it to the paragraph of your choice. To move
the anchor, select the image or the anchor, and move it until the anchor symbol is at the 
beginning of the chosen paragraph.

2) Align the image so that the left margin of the image is where you want it to be. This can be 
done with the mouse or using the advanced settings. The taskbar shows the location of the 
upper left corner and the image size.

3) Change the wrap to Page Wrap. We now wish to increase the space between the image 
and the text. To do this, access the Wrap page of the Picture dialog and set the gap 
between the image and text to 0.1” in all the boxes.

4) The last touch is to change the position so that the image has our chosen number of lines 
of the paragraph above it. Again, you can use the mouse to drag the image or use the 
advanced settings, which require a bit of trial and error. Moving with the mouse is the 
simplest method.

Example 2: Simple contour wrapping in action
In this example we again apply page wrapping as in Example 1, enabling this time the contour 
option. We will work on an image and on a drawing object as the contour option works slightly 
differently in each case.

The example of Figure 16 was created following the steps below, which you can use to practice.

1) Create some text (a very quick way to do that is to use the dummy text available in 
AutoText. Type DT and then press the F3 key).

2) Insert an image of your choice and anchor it to the first paragraph. Adjust the alignment as 
desired then change the wrap type to Page Wrap.

3) Right-click on the picture to select the option Wrap > Contour, then right-click again and 
select Wrap > Edit Contour from the context menu.

4) Use the technique discussed in “Editing the contour” on page 23 to create a custom 
contour and click Apply. If needed, adjust the spacing between the edge of the image and 
the text using the Wrap page of the Picture dialog.
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Figure 16: Image and drawing objects with contour wrapping

5) Insert an AutoShape of your choice (a triangle in the example) and proceed as in step 2 
above.

6) Enable the contour wrap by selecting Format > Wrap > Contour from the Menu bar. As 
discussed previously, LibreOffice automatically generates the contour. You may need to 
adjust the distance between the drawing object and the text using Format > Wrap > Edit.

Example 3: Wrap Through and In Background
This example shows how to use an image as a watermark by wrapping the text through it and 
adjusting the transparency. This is not the best way to create watermarks and it is presented here 
only for illustration purposes. If you need to create a watermark, it is best to use a Fontworks object
wrapped in the background.

Selecting the Wrap Through option for an inserted image causes the image to overlap the text, 
which as a result will be hidden. To make the text appear, change the transparency of the picture; 
although the words under the image become visible, they may be difficult to read and will appear 
lighter than the rest of the text.

To reproduce the example of Figure 17 create some dummy text, then insert the image of your 
choice. Anchor the image (to the page in the example) and select the wrap through option from the 
Format > Wrap menu or right-clicking on the image and selecting Wrap > Wrap Through from the
context menu. Move the image into the desired position. The Picture toolbar should be displayed 
when the image is selected. Change the transparency to a suitable value (in the example this is 
40%) so that the text can be read.

Figure 17: Transparent image added over the text
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You can obtain a better result if you set an image’s wrap to In Background. With this selection all 
the text will be clearly readable, with all characters having the same intensity, as long as the 
background is not too dark. You may still need to adjust the transparency of the image.

Adding captions to images

You can add captions to images in three ways: automatically, by using the Caption dialog, or 
manually.

Adding captions automatically
You can set up LibreOffice to add captions automatically whenever you insert an image, a table, or 
other objects into a document. You can choose which objects are captioned automatically, what the
sequence name is for each caption (for example, “Table” or “Illustration”), and the position of the 
caption.

To set up automatic captions:

1) Click Tools > Options. On the Options dialog, click on the + sign next to LibreOffice Writer 
to show a list of options.

2) Select AutoCaption. Several choices are available at the right of the dialog for adding 
captions automatically.

3) Choose which objects you want to be automatically captioned and specify the 
characteristics of the captions.

For more information, see “AutoCaption options” in Chapter 2, Setting up Writer.

When you insert an image, if automatic captioning is enabled, the graphic is placed in a frame 
along with a caption containing the default sequence name for images―Illustration. Position the 
cursor in the caption area and type the text for the caption. You can change the sequence name by
selecting one from the drop-down Category list or typing in your own.

Note

You can specify where to place an automatic caption for any object except a 
picture; picture captions can only be automatically placed below the picture. If you 
need a caption above the picture (for example, for data plots in scientific 
publications), you must add the captions manually, as described in “Adding 
captions manually” on page 28.

Tip

A common sequence name—Figure—is not one of the names provided: <None>, 
Drawing, Illustration, Table, and Text. If you want the name “Figure” or any other 
custom name for your images, do the following:

1) Open the Options – LibreOffice Writer – AutoCaption dialog, as described 
above.

2) In the Add captions automatically when inserting section, select LibreOffice 
Writer Picture. This activates the Caption area in the dialog for pictures 
(images).

3) Under the Category drop-down list, enter the name that you want added (say, 
Figure), by overwriting any sequence name in the list. (Overwriting a term 
does not delete it from the drop-down list.) You can also set some options for 
the number style and for a separator between the name and the number, if 
desired. Click OK to save the changes.
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Adding captions using the Caption dialog
To add captions using the Caption dialog:

1) Insert the graphic, then either right-click it and select Caption from the context menu, or 
select it and choose Insert > Caption from the Menu bar.

2) Under Properties on the Caption dialog (Figure 18), make your selections for the Category, 
Numbering, and Separator fields (Illustration, Arabic (1 2 3), and a colon (:), respectively, 
for the example in Figure 18 and type your caption text in the Caption text box at the top. 
Whatever text you enter for the caption appears in the box at the bottom, after the 
sequence name, number, and separator.

Figure 18: Defining the caption for an illustration

3) Click OK. The graphic and its caption are placed in a frame, as shown in Figure 19.

Tip
In the Category box, you can type any name you want, for example Figure. 
LibreOffice will create a numbering sequence using that name.

Illustration 1. An example caption

Figure 19: An example of an image and its caption contained in a frame. The outer box
shows the edge of the frame; this border is normally set to be invisible.

Overriding the default positioning of captions
The default positioning for picture captions is Below, and that position cannot be changed using the
Caption dialog. However, you can override the positioning manually, as follows:

1) Follow the instructions in “Adding captions using the Caption dialog above to create the 
caption.
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2) Right-click on the picture (not the frame surrounding picture and caption) and make sure 
that Anchor > As Character is selected.

3) Left-click on the picture and drag and drop it after the caption.

Tip
You may wish to adjust the spacing above and below the caption text to fine-tune 
the appearance of the picture and its caption.

Adding captions manually
If you need to save as *.doc files or export in other formats, you may find that captions applied as 
described above (either automatically or using the Caption dialog) are lost during the export. 

To avoid export problems, or as another way to put captions above pictures or below them (the 
usual case), you can add a caption manually, in either of two ways:

• Place the graphic and its caption in separate paragraphs.

• Use a table.

Place the graphic and its caption in separate paragraphs
Insert the graphic and anchor it to its paragraph as a character. Press Enter to create a new 
paragraph for the caption.

1) In the caption paragraph, type, for example, Figure and add a space.

2) To insert the figure number automatically, click Insert > Fields > Other (Control + F2) and 
select the Variables tab.

3) Select Number range in the Type list. Select Figure in the Selection list and choose, for 
example, Arabic (1 2 3) in the Format drop-down list. Click the Insert button.

4) A number will appear after the word “Figure” in the caption. Now, type the text of the 
caption.

Tips

If you are manually adding captions to a lot of figures using this method, you might
want to make an AutoText entry containing, for example, Figure and a space, the
figure-number field, and an optional separator and a space after it.

To ensure the picture and its caption stay together on the page, create a new 
paragraph style, for example Figure: if the picture is going above the caption, 
define the text flow of the Figure paragraph style as Keep with next paragraph 
and the next style as Caption. Conversely, if the caption is going above, define the
Caption paragraph style as Keep with next paragraph and the next style as 
Figure.

Use a table
Create a one-column, two-row table. Place the picture in one row and type the caption in the other 
row—or use two or more rows for the caption and other text. This method can be especially useful 
for pictures with numbered legends, such as Figure 11 in this chapter.
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Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other
files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text 
hyperlinks (described in Chapter 12). Clicking on a hotspot causes LibreOffice to open the linked 
page in the appropriate program (for example, the default browser for an HTML page; LibreOffice 
Calc for a ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and 
include several hotspots in the same image.

Figure 20: The dialog to create or edit an image map

To use the image map editor:

1) In your LibreOffice document, select the image where you want to define the hotspots.

2) Choose Edit > ImageMap from the Menu bar. The ImageMap Editor (Figure 20) opens.

3) Use the tools and fields in the dialog (described on the next page) to define the hotspots 
and links necessary.

4) Click the Apply icon ( ) to apply the settings.

5) When done, click the Save icon ( ) to save the image map to a file, then click the X in 
the upper right corner to close the dialog.

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is 
identified by a line indicating its shape.

The toolbar at the top of the dialog contains the following tools:

• Apply button: click this button to apply the changes.

• Open, Save, and Select icons.

• Tools for drawing a hotspot shape: these tools work in exactly the same way as the 
corresponding tools in the Drawing toolbar.

Creating an image map 29



• Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a 
polygon hotspot. Select the Edit Points tool to activate the other tools.

• Active icon: toggles the status of a selected hotspot between active and inactive.

• Macro: associates a macro with the hotspot instead of just associating a hyperlink.

• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:

• Address: the address pointed by the hyperlink. You can also point to an anchor in a 
document; to do this, write the address in this format: 
file:///<path>/document_name#anchor_name

• Text: type the text that you want to be displayed when the mouse pointer is moved over the
hotspot.

• Frame: where the target of the hyperlink will open: pick among _blank (opens in a new 
browser window), _self (opens in the active browser window), _top or _parent.

Tip
The value _self for the target frame will work just fine in the vast majority of 
occasions. It is therefore not recommended to use the other choices unless 
absolutely necessary.

Managing the Gallery

Note In a default installation, only the My themes theme is customizable, although new 
themes can be added as explained in “Adding a new theme to the Gallery” on page
32. The locked themes are easily recognizable by right-clicking on them; the only 
available option in the context menu is Properties. In some installations, or when 
you are running LibreOffice as an Administrator, all themes are customizable.

Adding an image to the Gallery
You may wish to add to the Gallery any images that you use frequently, for example, a company 
logo. You can then very easily insert these images into a document later.

Method 1 (selecting a file)

1) Open the Gallery and select the theme where you want to add images. (You can also 
create a new theme for your images; see page 32.)

2) Right-click on the desired theme and select Properties in the context menu. This displays 
a dialog, into which you add the files from which the selection will be made.

Figure 21: Properties of My Theme in the Gallery
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Either:

a) On the Files page, click the Find Files button. The Select path dialog (not shown) 
opens which allows you to navigate to the folder containing the files of interest.

b) You can enter the path for the folder’s directory in the Path text box, or you can 
navigate to locate the folder’s directory. 

c) Click the Select button to start the search. Subfolders are included in the search. A list
of graphic files is then displayed in the Properties window. You can use the File type 
filter to limit the files displayed.

d) To add all of the files shown in the list, click Add All. Otherwise, select the files to add 
and then click Add. (Hold down either the Shift key or the Control key when you click 
on multiple files.)

Or, to add a single file:

a) Click the Add button to open the Gallery dialog.

b) Use the navigation controls to locate the image to add to the theme. Select it and then
click Open to add it to the theme.

c) Click the OK button of the Properties dialog to close it.

Note
You may need to import some images or create your own on your computer if the 
existing files are insufficient for your needs.

Method 2 (drag and drop)

You can drag and drop an image into the Gallery from a document.

1) Open the document containing an image you want to add to the Gallery, and display the 
Gallery theme to which you want to add it.

2) Position the mouse pointer above the image, without clicking.

3) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this 
case, press the Alt key while you click the image, to select it without activating the link. If 
the mouse pointer does not change to a hand symbol, you can simply click the image to 
select it.

4) Once the image is selected, evident from the colored selection handles around it, release 
the mouse button. Click again on the image, keeping the mouse button pressed for more 
than two seconds before moving the mouse. Without releasing the mouse button, drag the 
image into the Gallery.

5) Release the mouse button.

Deleting images from the Gallery
To delete an image from a theme:

1) Right-click on the name of the image file or its thumbnail in the Gallery.

2) Click Delete on the context menu. A message appears, asking if you want to delete this 
object. Click Yes.

Note
Deleting the name of a file from the list in the Gallery does not delete the file from 
the hard disk or other location. This includes the dragdrop folder in the Gallery.
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Adding a new theme to the Gallery
To add a new theme to the Gallery:

1) Click the New Theme button above the list of themes (see Figure 21).

2) In the Properties of New Theme dialog, click the General tab and type a name for the new 
theme.

3) Click the Files tab and add images to the theme, as described earlier.

Deleting a theme from the Gallery
To delete a theme from the Gallery:

1) Go to Tools > Gallery.

2) Select from the list of themes the theme you wish to delete.

3) Right-click on the theme, then click Delete on the context menu.

Location of the Gallery and the objects in it
Images and other objects shown in the Gallery can be located anywhere on your computer’s hard 
disk, on a network drive, or on a CD-ROM. Listings in the Gallery refer to the location of each 
object. When you add images to the Gallery using method 1, the files are not moved or copied; 
only the location of each new object is added as a reference. When files are added using drag and 
drop, they are copied into a folder (dragdrop) in the Gallery, and allocated a file name.

Figure 22 shows in Detailed View, two files in the My Theme in the Gallery, one is contained in the 
dragdrop folder, and the other is a reference path to its actual location.

Figure 22: Theme showing files inserted with drag-and-drop and by reference

In a workgroup situation, you may have access to a shared Gallery (where you cannot change the 
contents unless authorized to do so) and a user Gallery, where you can add, change, or delete 
objects.

The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can 
change this location, and you can copy your gallery files (SDV) to other computers.

Gallery contents provided with LibreOffice are stored in a different location. You cannot change this
location.

LibreLogo scripting

LibreLogo is an embedded vector graphics language that provides a simple, native, Logo-like 
programming environment with turtle vector graphics for the teaching of computing (programming 
and word processing), desktop publishing (DTP), and graphic design.

Logo toolbar
Display the Logo toolbar by selecting View > Toolbars > Logo from the Menu bar.
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The undocked Logo toolbar

1 Forward (10 pt) 6 Stop
2 Back (10 pt) 7 Home
3 Left (15 degrees) 8 Clear screen
4 Right (15 degrees) 9 Logo command line (press Enter for execution)
5 Start Logo program (text or selected text of 

document)
10 Uppercase commands, also translate them to the 

language of the document

To start using the program, open a new blank document and click the Start button (5) on the 
toolbar. This sets the turtle, Figure 23, to the center of the page. You may find it useful to adjust the
page zoom level so you can view the whole page.

Figure 23: The graphical turtle

The turtle has three attributes:

1) A location

2) An orientation

3) A pen, itself having attributes such as color, width, and up and down.

The turtle moves with commands that are relative to its own position, such as "move forward 10 
spaces" and "turn left 90 degrees". The pen carried by the turtle can also be controlled, by enabling
it, setting its color, or setting its width.

The basics
Click on the buttons 1 – 4 to see the effects of these controls on the turtle. Click the Home button 
(7) to return the turtle to its default settings and position in the center of the page. The Clear 
screen button (8) deletes all drawings from the page.

The command text input box allows you to enter command strings before pressing the Enter key so
that a sequence of commands can be executed at the same time.

For example, entering the sequence circle 10cm fillcolor 'blue' pencolor 'red' 
pensize 2 circle 5cm forward 200 right 89 circle 50 into the command line and 
then pressing Enter results in the following graphic:

Note that the graphic is anchored To Page, and that the turtle attributes follow the setting for the 
line, in this instance fillcolor 'blue'; pencolor 'red'; linesize 2.

You can also write your program on the page instead of entering it into the command line, allowing 
a larger and more complex set of instructions to be built. In this case, clicking the Start Logo 
program button runs the script on the page. The text can be deleted from the page after completing
the program to just leave the graphic.
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Figure 24: Sample graphic from command line

The distance units are typographic points unless expressly defined as standard units such as inch 
or centimeters (72 pt = 1 in = 2.54 cm).

See the Help for comprehensive information about LibreLogo.

LibreLogo examples can be found on http://extensions.libreoffice.org/extension-center/librelogo
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