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Tennis Racket Simulation using Abaqus 
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Introduction 
In this workshop you will become familiar with the process of creating a model 
interactively by using Abaqus/CAE. You will create the tennis racket model shown in 
Figure W–1. 

 
Figure W–1  Tennis racket and ball. 

Preliminaries 
1. Enter the working directory for this workshop: 

cd Workshops/tennis-demo  

2. Start a new session of Abaqus/CAE using the following command: 
abq662se cae  
where abq662se is the command used to run Abaqus Student Edition. 

3. Select Create Model Database from the Start Session dialog box. 
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visible, make sure there is a check mark next to Show Model Tree in the View 
menu. If the Model Tree is still not visible, drag the  cursor from the left side 
of the Abaqus/CAE window to expand the Model Tree. The Model Tree provides 
a visual description of the hierarchy of items in the model database along with 
access to most of the model development functionality available in Abaqus/CAE. 
If you click mouse button 3 on an item in the tree, a menu appears listing 
commands associated with the item. For example, Figure W–2 shows the menu 
for the Models container. In the Models menu, the Create menu item appears in 
bold because it is the default action that will be performed when you double-click 
the Models container.  

 
Figure W–2  Models menu. 

4. In the Model Tree, double-click Models to create a new model in the model 
database.  
The model attributes editor appears. 

5. In the Edit Model Attributes dialog box that appears, enter the name TENNIS-
DEMO and click OK. 
The model TENNIS-DEMO appears in the Model Tree, as shown in Figure W–3. 
The new model is underlined to indicate that it is a current object (i.e., TENNIS-
DEMO is the model you are currently working on). 
Tip:  To reduce clutter in the Model Tree, collapse the container for Model-1 by 
clicking the “−” sign next to the model name or set TENNIS-DEMO as the root. 
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Figure W–3  Model Tree. 

6. To save the model database, select File→Save As from the main menu bar and 
type the file name tennis-demo in the Save Model Database As dialog box. 
Click OK. 
The .cae extension is added to the file name automatically. 

Creating a part 
In this section you will create two three-dimensional parts for frame and ball by first 
sketching the two-dimensional profile and then extruding/ revolving it. 

1. For creating frame we will import already existing sketch. Use File→ Import→ 
Sketch to import frame-sketch.sat and strings-sketch.sat files. 

2. In the Model Tree, double-click Parts to create a new part in the model TENNIS-
DEMO.  
The Create Part dialog box appears.  

3. In the Create Part dialog box, name the part Frame, and specify an approximate 
size of 200. Accept the default settings of a three-dimensional, deformable body. 
Change the base feature to shell, extruded base feature (Figure w-4). Click 
Continue. 
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Figure W–4 Create Part area 

Abaqus/CAE displays text in the prompt area near the bottom of the window to 
guide you through the procedure, as shown in Figure W–5. Click the cancel 
button to cancel the current task; click the backup button to cancel the current step 
in the task and return to the previous step. 

 

 
Figure W–5  Prompt area. 

The Sketcher toolbox appears in the left side of the main window, and the 
Sketcher grid appears in the viewport. 

4. In this case instead of sketching the profile we will import it from already existing 
sketch. To import an already existing sketch choose Add → Sketch and select 
frame-sketch from the Select Sketch window (Figure W-6). The frame sketch 
will appear in the current Viewport. 
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Figure W–6  Add Sketch tool. 

5. Click Done in the prompt area to exit the sketcher (Figure W-7). 

 
Figure W-7 Prompt area 

6. Enter an extrusion depth of 0.5 in the Edit Base Extrusion dialog box, and click 
OK. 
Abaqus/CAE displays an isometric view of the new part, as shown in Figure W-8. 
The Parts icon in the Model Tree changes to indicate that the model contains one 
part, . 
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Figure W–8  Extruded part. 

7. To create strings we will first create partition at the middle of the frame. We will 
use a datum plane for partition. So to create a datum plane first choose Tools→ 
Datum. In the Create Datum window choose Plane with 3 point Method 
(Figure W-9). Click Ok and Select 3 points at the middle of the frame (Figure W-
10). This will create a datum plane at the middle of the frame. 

 

Figure W-9 
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Figure W-10 

8. Choose partitioning tool as shown in Figure W-11 and press Ok. Select the datum 
plane from Viewport to create partition. 

 
Figure W-11 

 
 
 
9. Prompt area will ask to select the faces to partition. To select all the faces of 

frame create a drag box and press Done from the prompt area. Then the prompt 
area will ask to select the datum plane. Click on the datum plane created in step 7 
and select Create Partition from the prompt area. 

10. Create a set using Tools→ Set→ Create. Name the set as frame and then select 
the whole frame by dragging a box. 

11. Create a datum axis along Y-Axis by selecting Tools → Datum → Axis → 
Principal axis as shown in figure W-12, click Ok and then select Y-Axis from the 
prompt area. 
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Figure W-12 

12. Choose Shape→ Wire→ Sketch to create strings. Choose the datum plane and 
datum axis respectively for the ‘plane of wire’ and ‘vertical axis on right’.  

13. In the sketcher select Add→ Sketch and select strings-sketch. Press Done to 
continue. This will result in wires as shown in Figure W-13. Press Done to exit 
out of sketcher. 

 
Figure W-13 
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14. Choose  and remove all the faces (i.e. frame) from the Viewport by 
dragging a box around the whole model and pressing Done from the prompt area. 
Create a set using Tools→ Set→ Create. Name the set as string-elem and 
then select the displayed strings by dragging a box. 

15. Create another set using Tools→ Set→ Create. Name the set as strings. Click 

Show/Hide selection option button . In the 
Options window change Select from: to Vertices and change drag-shape to 
polygon as shown in Figure W-14. 

 
Figure W-14 

16. Then draw a polygon shape in the Viewport to include only the internal nodes as 
shown in Figure W-15. Right click in the Viewport and press Done to create a 
node set which contains only the internal nodes of strings. 

 
Figure W-15 

17. then select the displayed strings by dragging a box 

18. Press Replace All button  to view the complete model. 
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Choose 3D deformable shell with type as revolution. Specify approximate size 
as 20. Press continue to sketch a ball with radius 1.5 using create circle tool. 

 
Enter center as 0, 0 and perimeter as 1.5, 0 in the prompt area to complete the 
definition of this circle. 

20. Add a vertical construction line passing through origin using Add→ 
Construction → Vertical and entering 0, 0 as position in the prompt area. 

21. Select Edit→ Auto-Trim and select the left half of circle for trimming. Press Done 
to exit out or sketcher. At this point you will be prompted to select the 
‘Construction line to act as centerline’. So select the construction line which was 
created in step 17. 

22. In the Edit Revolution window enter angle as 360 degrees and press Ok to obtain 
part shown in Figure W-16. 

 
Figure W-16 

23. Create a datum plane passing through the edge on Ball part using Tools→ Datum 
→ Plane → 3 Points. Partition the ball using this datum plane (Tools→ 
Partition→ Face→ Use Datum Plane). 

24. Create ball set by selecting complete ball geometry (Tools→ Set→ Create).  
25. Create ball-outer surface using Tools→ Surface-Create. Select the whole 

ball geometry and then choose outer surface (Brown) from the prompt area. 
Create ball-inner surface using Tools→ Surface-Create. Select the whole 
ball geometry and then choose inner surface (Purple) from the prompt area. 
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Creating a material definition 
You will now create three materials, one each for frame, strings and ball. 

To define a material: 
1. In the Model Tree, double-click Materials to create a new material in the model 

TENNIS-DEMO. 
Abaqus/CAE switches to the Property module, and the material editor appears.  

2. In the Edit Material dialog box, name the material Frame. Notice the various 
options available in this dialog box. 

 
Figure W–17  Pull–down menu. 

3. From the material editor’s menu bar, select Mechanical→Elasticity→Elastic, as 
shown in Figure W–17. 
Abaqus/CAE displays the Elastic data form. 

4. Enter a value of 1.0E10 for Young’s modulus and a value of 0.0 for Poisson’s 
ratio in the respective fields, as shown in Figure W–18. Use [Tab] to move 
between cells, or use the mouse to select a cell for data entry. 

 

 
Figure W–18  Material editor. 

5. From the material editor’s menu bar, select General→Density and enter 1.0E-3 
as density value. 

6. Press Ok to complete Frame material definition. 
7. Similarly create String material definition with density= 0.000107, Young’s 

Modulus=1.0E6 and Poisson’s Ratio=0.0. 
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Rubber. Select Mechanical→Elasticity→Hyperelastic to enter hyperelastic 
material properties as shown in Figure W-19. Also add density of 0.0001 using 
General→Density. Press Ok to complete the material definition 

 

 
Figure W-19 

Defining and assigning section properties 
Next, you will create three sections. These sections will refer to the materials Frame, 
String, and Rubber that you just created. 

To define shell and truss sections: 
1. In the Model Tree, double-click Sections to create a new section in the model 

TENNIS-DEMO. 
The Create Section dialog box appears. 

2. In the Create Section dialog box: 
a. Name the section FrameSection. 
b. Change the category to Shell and the default type Homogeneous. 
c. Click Continue. 
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3. In the Edit Section dialog box: 
a. Choose Section Integration Before Analysis. 
b. Change the thickness to 0.1. 
c. Select Frame material from the material list. 
d. Click OK. 

4. Create another section with name RubberSection. In the Create Section dialog 
box, change the category to Shell and the default type Homogeneous. Click 
Continue. 

5. In the Edit Section dialog box: Choose Section Integration during Analysis. 
Change the thickness to 0.2. Select Rubber material from the material list. 
Change the Thickness Integration Points to 3 and click OK. 

6. Create a third section with name StringSection. In the Create Section dialog 
box, change the category to Beam and the type to Truss. Click Continue. 

7. In the Edit Section dialog box: Select String material from the material list. 
Specify cross-section area of 0.007854 corresponding to 0.1 in diameter and 
click OK. 

To assign the section definitions: 
1. In the Model Tree, expand the branch for the part Frame (click the “+” symbol to 

expand the Parts container and then click the “+” symbol next to the part Frame). 
2. Double-click Section Assignments to assign a section to the set frame and 

strings. 
Abaqus/CAE displays prompts in the prompt area to guide you through the 
procedure. 

3. From the prompt area select Sets, and select the frame set and press Continue. 
From the Section Assignment Editor use toe drop down list to select 
FrameSection. Press Ok to complete the definition. 

4. Then from the Eligible Sets choose string-elem press Continue. Select 
StringSection from the Edit Section Assignment window and press Ok. 

5.  Expand the branch for part Ball. Double-click Section Assignments to assign 
a section to the set ball. Select ball from the eligible sets and assign section 
RubberSection to it. 

6. Click Cancel to close Eligible Sets window if it is open. 
7. Abaqus/CAE colors the ball green to indicate that the section has been assigned.  
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Assembling the model 
The assembly for this analysis consists of a two instances one each of Frame and Ball 
parts. 

To assemble the model: 
1. In the Model Tree, expand the branch for the Assembly and double-click 

Instances to create a new part instance. 
Abaqus/CAE switches to the Assembly module, and the Create Instance dialog 
box appears. 

2. In the Create Instance dialog box, select Frame and Ball and click OK. 
Abaqus/CAE displays the new part instances in the viewport as shown in Figure 
W-20. 

 
Figure W-20 

3. Translate the Ball instance using Instance→Translate. Select the ball instance 
when prompted and enter the coordinates 0, 0, 0 and 0, 0, 1.8 as start and 
end point of translation vector respectively. 

4. Create a reference point using Tools→Reference Point and enter the coordinates 
as 0.0, 0.0, 0.25. Create another reference point with the following 
coordinates: 0.0, 0.0, 1.8. 

5. Create a set named refnode for RP-1 and refnode-cav for RP-2.  
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Configuring the analysis 
In this simulation we are interested in the dynamic response of the ball and racket when 
ball hits the racket with a velocity. The frame will be modeled as rigid to reduce the 
analysis cost for this simulation. This is a single event, so only a single analysis step is 
needed for the simulation. Consequently, this model will consist of two steps: 

• An initial step, in which you will apply a boundary condition that constrains all 
degrees of freedom of rigid racket frame and initial velocity to the ball.  

• A Dynamic, Explicit analysis step, in which a dynamic response will be 
calculated when ball hits the racket. 

Abaqus/CAE generates the initial step automatically, but you must create the analysis 
step yourself.  

To create a dynamic, explicit analysis step: 
1. In the Model Tree, double-click Steps to create a new step in the model TENNIS-

DEMO.  
Abaqus/CAE switches to the Step module, and the Create Step dialog box 
appears. 

2. In the Create Step dialog box: 
a. Name the step Dynamic. 
b. From the list of available general procedures in the Create Step dialog 

box, select Dynamic, Explicit. 
c. Click Continue. 

The step editor appears. 
3. In the Edit Step dialog box: 

a. In the Description field of the Basic tabbed page, enter Dynamic 
analysis of tennis racket 

b. Change the step time to 0.015 and keep NLGEOM on to include nonlinear 
geometry effects.  

c. Click the Incrementation and Other tab to see its contents; you can 
accept the default values provided for the step. 

d. Click OK to create the step and to exit the step editor. 
4. Create a history output request for CVOL and PCAV: 

a. In the model tree double-click the History Output Requests container. 
Clock Continue in the Create History dialogue box to create a history 
output with name H-Output-2 in step Dynamic. 

b. Enter the values shown in Figure W-21 and click Ok to complete the 
definition. 
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Figure W-21 

5. Modify history output request H-Output-1 by double-clicking it in the model 
tree and changing frequency of output to every 3e-5 units of time (same as H-
Output-2). 
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Applying contact and rigid body constraints in the model 
Next, you will define frame as rigid body and constraint it with refnode. You will also 
define contact between ball and strings. 

To create rigid body constraint: 
1. In the Model Tree, double-click Constraints, select Rigid Body and press 

Continue.  
Abaqus/CAE switches to the Interaction module and prompts the Edit Constraint 
dialog box appears. 

2. In the Edit Constraint dialog box: 
a. Select Region type as Body and press Edit (Figure W-22). 
b. From the prompt area select Sets and select Frame-1.frame from the 

Eligible Sets window, then press Continue. 
c. Press Edit to choose the Reference Point. From the prompt area again 

select Sets, choose refnode and press continue.  
d. Click Ok to complete the rigid body definition. 

 
Figure W-22 

To create contact between ball and strings: 
1. In the Model Tree, double-click Interactions, choose Surface-to-surface 

contact (Explicit) from the Create Interaction window and press Continue.  
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master surface from the eligible surface list and press Continue. 
3. From the prompt area select Node Region (W-23). 

 
Figure W-23 

4. Select Frame-1.strings and press Continue from the Eligible sets dialogue 
box. 

5. In the Edit Interaction dialog box: 
a. Press Create next to Contact interaction property to create friction 

interface (Figure W-24). 
b. Press Continue in the Create Interaction Property window.  
c. Select Mechanical→Tengential Behavior and define friction properties 

as shown in Figure W-25. Then press Ok.  
d. Click Ok to complete the interaction definition. 

 

Figure W-24 
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Figure W-25 

Applying a boundary condition and a load to the model 
Next, you will define the fixed boundary condition at refnode and initial velocity on 
ball. 

To apply boundary conditions to refnode: 
1. In the Model Tree, double-click BCs to create a new boundary condition in the 

model TENNIS-DEMO.  
Abaqus/CAE switches to the Load module, and the Create Boundary Condition 
dialog box appears. 

2. In the Create Boundary Condition dialog box: 
a. Name the boundary condition Fixed. 
b. Select Initial as the step in which the boundary condition will be activated. 
c. In the Category list, accept the default category selection Mechanical. 
d. In the Types for Selected Step list, select 

Symmetry/Antisymmetry/Encastre as the type. 
e. Click Continue. Abaqus/CAE displays prompts in the prompt area to 

guide you through the procedure. Select Sets from prompt area to choose 
refnode set from the Eligible sets. 
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fix all degrees of freedom of refnode  and press Ok.  

To apply a velocity on the ball: 
1. In the Model Tree, double-click Predefined Fields to create a new load in the 

model TENNIS-DEMO. 
The Create Predefined Field dialog box appears. 

2. In the Create Predefined Field dialog box: 
a. Name the load Velocity. 
b. Select Initial as the step. 
c. In the Category list, accept the default category selection Mechanical. 
d. In the Types for Selected Step list, select Velocity. 
e. Click Continue. 
f. Select Sets from prompt area to choose ball set from the Eligible sets. 
g. Specify V1=68.3 and V3=-255 in the Edit Predefined Field dialogue 

box  and press Ok 

Meshing the model 
You use the Mesh module to generate the finite element mesh. You can choose the 
meshing technique that Abaqus/CAE will use to create the mesh, the element shape, and 
the element type. Abaqus/CAE uses a number of different meshing techniques. The 
default meshing technique assigned to the model is indicated by the color of the model 
when you enter the Mesh module; if Abaqus/CAE displays the model in orange, it cannot 
be meshed without assistance from the user. 

To assign the mesh controls: 
1. In the Model Tree, double-click Mesh in the branch for the part Frame.  

Abaqus/CAE switches to the Mesh module and displays the part Frame. 

To assign an Abaqus element type: 
1. From the main menu bar, select Mesh→Element Type. 
2. Select string-elem from the Eligible Sets. 
3. In the Element Type dialog box, make sure that the following is selected: 

• Standard is the default Element Library selection. 
• Linear is the default Geometric Order. 
• Change Family to Truss. 

4. In the lower portion of the dialog box, examine the element shape options. A brief 
description of the default element selection is available at the bottom of each 
tabbed page. 
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Abaqus/CAE will now mesh strings with T3D2 elements. 
5. Click OK to assign the element type and to close the dialog box. 

To mesh the model: 
1. From the main menu bar, select Seed→Part to seed the part. 

The Global Seeds dialog box appears. The default global element size is based 
on the size of the part. 

2. In the Global Seeds dialog box, enter an approximate global size of 1 and click 
OK. 

3. From the main menu bar, select Mesh→Part to mesh the part. 
4. Click Yes in the prompt area or click mouse button 2 in the viewport to confirm 

that you want to mesh the part instance. 
Abaqus/CAE meshes the part instance and displays the resulting mesh, as shown 
in Figure W–26. 

 
Figure W–26  Part instance showing the resulting mesh 

5. To mesh Ball part, switch part to Ball (Figure W-27). Select Mesh→Controls. 
Select the whole ball region. From the Mesh Controls window change the 
Algorithm  to Advancing front and press Ok. 

 
W-27 

6. Assign a global seed of 0.5 using Seed→Part. 
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meshed with S4R elements by default. 
8. Click Yes in the prompt area or click mouse button 2 in the viewport to confirm 

that you want to mesh the part instance. 

Editing keywords to define fluid cavity and initial conditions 
The definition of the model TENNIS-DEMO also contains gas cavity definition for ball 
and initial stress and pressure condition on strings and ball. These definitions are not 
available through GUI interface of CAE so you will add then through keyword editor. 

To edit keywords: 
1. From the main menu bar, select Model→Edit Keywords and select TENNIS-

DEMO model. 
Abaqus/CAE will launch Edit Keywords window. 

2. In the Edit Keywords window, enter the following keywords as shown in Figures 
W-28, W-29 and W-30. After entering all the keywords click Ok. 
Note: Keywords are case-insensitive 

 
 *FLUID BEHAVIOR, NAME=GAS 
 *MOLECULAR WEIGHT 
 0.1367, 
 *CAPACITY, TYPE=TABULAR 
 112.847, 
 

*FLUID CAVITY, NAME=BALL, REF NODE=REFNODE-CAV, SURFACE=BALL-1.BALL-
INNER, BEHAVIOR=BALL-1.GAS, AMBIENT PRESSURE=14.7 
1.0 
 

 *INITIAL CONDITIONS, TYPE=STRESS 
 FRAME-1.STRING-ELEM, 1273. 
 BALL-1.BALL, 22.5, 22.5 
 *INITIAL CONDITIONS, TYPE=FLUID PRESSURE 
 REFNODE-CAV, 6.0 

*PHYSICAL CONSTANTS, ABSOLUTE ZERO=-273.16, UNIVERSAL GAS 
CONSTANT=73.562 
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Figure W-28  Keyword Editor window 

 
Figure W-29  Keyword Editor window 
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Figure W-30  Keyword Editor window 

 

Creating and submitting an analysis job 
The definition of the model TENNIS-DEMO is now complete. Next, you will create and 
submit an analysis job to analyze the model. 

To create and submit an analysis job: 
3. In the Model Tree, double-click Jobs to create a new analysis job. 

Abaqus/CAE switches to the Job module, and the Create Job dialog box appears. 
4. In the Create Job dialog box, name the job Tennis-Analysis and select the 

model TENNIS-DEMO. Click Continue. 
The job editor appears. 

5. In the Description field of the Edit Job dialog box, enter Workshop. 
6. Click the tabs to see the contents of each folder of the job editor and to review the 

default settings. Click OK to accept the default job settings. 
7. In the Model Tree, expand the Jobs container and click mouse button 3 on the 

job Tennis-Analysis. 
The menu for the job Tennis-Analysis appears. 

8. From the job menu, select Submit. 
The icon for the job will change to indicate the status of the job in parenthesis 
after the job name. As the job runs the status Running will be shown in the 
Model Tree. When the job completes successfully, the status will change to 
Completed.  
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You are now ready to view the results of the analysis in the Visualization module. 
1. In the Model Tree, click mouse button 3 on the job Tennis-Analysis and select 

Results from the menu that appears. 
Abaqus/CAE switches to the Visualization module, opens the output database 
created by the job (Tennis-Analysis.odb), and displays the undeformed 
shape of the model, as shown in Figure W–31. 

 
Figure W–31  Undeformed model shape.  

2. In the toolbox, click  (or select Plot→Deformed Shape from the main menu 
bar) to view a deformed model shape plot, as shown in Figure W–32. 

 
Figure W–32  Deformed model shape.  
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You may need to use the Auto-Fit View tool  to rescale the figure in the 
viewport. 

3. In the toolbox, click  (or select Plot→Contours→on Deformed Shape from 
the main menu bar) to view a contour plot of the von Mises stress, as shown in 
Figure W–33. In this figure, the font size for the legend text has been increased to 
10 (Viewport→ Viewport Annotation Options). 

 
Figure W–33  Mises stress contour plot. 

4. In the toolbar, click  (or select File→Save from the main menu bar) to save 
your model in a model database file. Close the Abaqus/CAE session by selecting 
File→Exit from the main menu bar. 
 


