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ABSTRACT 
If you are a SAS programmer who has avoided using SAS Enterprise Guide because you think it's only good for 
point-and-click, then this paper is for you. You may be surprised to learn that SAS Enterprise Guide offers 
programmers many advantages over Display Manager. We'll show you different ways to write and run code, explain 
how SAS Enterprise Guide can help to organize your work, and discuss issues unique to coding in SAS Enterprise 
Guide. 

INTRODUCTION 
Using SAS Enterprise Guide, you can manipulate data and run reports without ever writing a single line of SAS code. 
So it’s not surprising that many SAS programmers believe that SAS Enterprise Guide is only useful to non-
programmers. If you love the SAS language, why would you ever want to use SAS Enterprise Guide?  
 
It turns out that there are several reasons why you might want to do just that. SAS Enterprise Guide offers 
programmers a variety of ways to run code. You can type a program like you do in Display Manager, but you can also 
use the point-and-click features of SAS Enterprise Guide to generate programs  that you can then modify. In addition, 
SAS Enterprise Guide organizes your work into projects making it easy to find your programs, logs, and results; and 
the process flow diagrams show at a glance how everything in your project fits together.  
 
However, writing programs in SAS Enterprise Guide does require learning a new environment with new windows and 
a new system for organizing your work. As with any new skill, there is a learning curve. The goal of this paper is to 
ease that transition by explaining SAS Enterprise Guide from a programmer’s perspective. 
 
In SAS Enterprise Guide there are often three or four (or even more) ways to do the same thing. This paper makes no 
attempt to show all ways, but instead shows the easiest ways. By exploring the menus and function keys, and by 
right-clicking, you can easily find other ways.  
 
This paper was written using SAS Enterprise Guide 6.1, but also applies to versions 4.3 and 5.1 with only slight 
differences.  If you are using SAS Enterprise Guide 4.2, you will find that the windows and menus are similar, but 
some of the more advanced programming features are not available.  

WRITING A NEW PROGRAM 
To open an empty Program window, select Program ► New Program from the menu bar. Then type your program. 
The Program window has a color-coded, syntax-sensitive editor similar to the one in Display Manager.  
 

 

Select  

Program ► New Program  
and type your program 
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Starting with SAS Enterprise Guide 4.3, the editor offers autocompletion. As you type, the editor tries to guess what 
you want. A pop-up list will appear with possible keywords. You can click the list to select the word you want, or press 
the Spacebar, Enter or Tab keys to select the highlighted word, or just ignore it and keep typing. 
 
CUSTOMIZING THE EDITOR 
Most people like the Autocomplete feature, but if you would rather not use it, you can turn it off by selecting Tools ► 
Options ► SAS Programs, and clicking the Editor Options button to open the Enhanced Editor Options window. 
This window has tabs labeled General, Appearance, Autocomplete and Indenter. 
 

 
 
In addition to turning autocompletion on or off, you can customize many other features of the editor such as the font 
size, color scheme, indention, and line numbering. 
 
INTEGRATED SYNTAX HELP 
Integrated syntax help is another feature that was added to the editor starting with SAS Enterprise Guide 4.3. If you 
hover the cursor over a keyword, the editor will display information about the syntax and usage of that keyword along 
with links to relevant documentation. Here, for example, is the syntax help for a WHERE statement: 
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RUNNING YOUR PROGRAM 
When your program is ready to run, click Run at the top of the Program window. To run a part of a program, first 
highlight the part you want to run. Then click the down-arrow next to Run at the top of the Program window, and 
select Run Selection from the drop-down menu.  
 

  
 
If you have more than one SAS server, then you can change the server that SAS Enterprise Guide will use by clicking 
the down-arrow next to Selected Server at the top of the Program window. SAS Enterprise Guide will submit your 
program to SAS on the currently selected server, and display the results.  
 

Click Run or  
select Run Selection 

Hover cursor over 
keyword to display 

syntax 
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REPLACING RESULTS 
Every time you rerun your program, a window will open asking you whether you want to keep the results from your 
previous run, or replace the results. Generally speaking, you will want to click Yes to replace the results. Otherwise, 
your project will quickly fill up with nearly identical results. 

 

VIEWING THE LOG 
By default when you run your program, if there are any errors, then the log will be automatically displayed. If there are 
no errors, the results will be displayed, but you can easily display the log by clicking the Log tab at the top of the 
Program window. 
 

 

Results display 
automatically 

SAS log  

Icon indicating 
program with error 
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If you see a red X on the program icon , this indicates that the program produced errors (either error messages 

or data errors such as invalid dates). A yellow caution sign on your program icon , indicates that your log 

contains warnings (but no errors). You can click the down-arrow  to go to the next error or warning, or the up 

arrow to go to the previous error or warning. If you click  Log Summary, then SAS Enterprise Guide will 
display a list of all the errors, warnings and notes.   
 
HIDING WRAPPER CODE 
Logs in SAS Enterprise Guide are like logs in Display Manager. They show your program along with any error 
messages, warnings, and notes. However, whenever you submit a program in SAS Enterprise Guide, wrapper code is 
added to the beginning and end of your program to take care of housekeeping functions such as closing any 
unwanted ODS destinations. By default, the log will include the wrapper code. If you don't wish to see the wrapper 
code, you can turn it off by selecting Tools ► Options ► Results ► Results General and unchecking Show 
generated wrapper code in SAS log. 

THE PROJECT PARADIGM IN SAS ENTERPRISE GUIDE 
In SAS Enterprise Guide, all your work is organized into projects. Projects help to organize your work by keeping track 
of your code, logs, and results so you don't have to worry about what's where. 
 

  
 
The project is displayed in the Project Tree window in the upper-left corner and in the Process Flow window on the 
right. The space where the Process Flow appears is called the workspace. The Process Flow shares the workspace 
with many other windows including the Program window and results windows. You can switch between these windows 
by double-clicking their names in the Project Tree. The Project Tree displays your project in a hierarchical tree 
diagram while the Process Flow displays your project in a process flow diagram. Icons representing your code and 
results appear in both the Project Tree and Process Flow. 
 
To run your entire project (which can contain multiple process flows), click the down-arrow next to Run at the top of a 
Process Flow window and select Run ► Run Project. To run a single process flow, click the down-arrow next to Run 
at the top of that particular Process Flow window and select Run ► Run Process Flow. 
 
You can have as many projects as you wish, but only one can be open at a time. However, if you want to see more 
than one project at a time, there is a simple work around. Simply open a new SAS Enterprise Guide session to display 
a second project. 
 

Project 
Tree 

Workspace displaying 
Process Flow 
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THE PROJECT LOG 
The project log combines all the logs from each step in a project so that you don't have to open each one separately. 

By default, the Project log is turned off. To turn it on, click Project Log at the top of the Log window, then click 
Turn On at the top of the Project Log window. The Project Log will stay on until you turn it off by clicking Turn Off. 
Turning the log off does not clear it, it just stops new logs from being added to the project log. You can clear the 
project log by clicking Clear Log at the top of the Project Log window.  
 

 

RENAMING CODE AND SAVING A PROJECT 
By default, your program is given the generic name "Program." This is all right, but not terribly informative. It is a good 
idea to give your programs more descriptive names by right-clicking their program icons in the Project Tree or 
Process Flow and selecting Rename from the pop-up menu.  
 
You can save your project by selecting File ► Save Project As and navigating to the location where you want to 
save your project. The next time you open the project, everything will be the way you left it.  
 

  

Select File ► 
Save Project 

As 

Right-click icon 
Select Rename 
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OPENING AND RUNNING AN EXISTING PROGRAM 
As a SAS programmer you are sure to have lots of programs that you have already written. You can open an existing 
SAS program by selecting  Program ► Open Program from the menu bar, and navigating to the location where your 
program is stored. This window shows a program named SplitData that was written in Display Manager and then 
opened in SAS Enterprise Guide.  
  

  
 
Using the Program window, you can edit programs that were written in Display Manager and run them just the same 
as programs that have been written in SAS Enterprise Guide. At this point, this project contains two programs 
(RegionFreq and SplitData) and their results. 
 

 

EMBEDDED PROGRAMS VS. UNEMBEDDED PROGRAMS 

Because SplitData was opened from an external file, its icon includes a little shortcut arrow.  The arrow 
indicates that the project contains a reference to the program, but the program itself is not saved as part of the 

Select File ► Open ► Code 
and navigate to code file 
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project. Because RegionFreq was written in SAS Enterprise Guide, its icon does not include an arrow.  
RegionFreq is saved inside the project, but SplitData is not. 
 
Code that is saved as part of a project is called embedded code; code that is saved outside of a project is 
unembedded. You can change whether or not a file is embedded. To do this, right-click the program icon in the 
Project Tree or Process Flow, and select Properties from the pop-up menu. A Properties window will open for the 
program. In the General page, click the Embed button to embed an external program in your project, or the Save As 
button to save the program in an external file.  
 
 

  
 

Whether it’s better to embed programs in your project or save them as separate files is your choice. One point to 
consider is that programs that are not embedded can be shared by more than one project while embedded programs 
can only be used by the project that contains them. Either way, it’s important that you understand where your 
programs are stored so you don’t accidentally end up with multiple copies of a program when you only want one (or 
vice versa). 

COPYING PROGRAMS GENERATED BY A TASK 
So far this paper has simply shown SAS Enterprise Guide as an environment for writing and running programs, but 
you can also use SAS Enterprise Guide’s point-and-click features to generate programs. 
 
In SAS Enterprise Guide, tasks generate SAS procedure code. Before you can use a task, you must first open your 
data set. To open a data set, select File ► Open ► Data from the menu bar, and navigate to your data set. The data 
set will be displayed in a Data Grid. The following Data Grid shows a data set named World that contains data about 
all the countries in the world.  
 

Click Embed or 
Save As… button
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When you open a task, it will use the active data set. The active data set is the one you have accessed most recently. 
You can change the active data set by viewing it in a Data Grid or by clicking the icon of the data set you want in the 
Project Tree or the Process Flow before you open the task.  
 
This example uses the Summary Tables task, but the process for copying programs is similar for all tasks. The 
Summary Tables task writes PROC TABULATE code. To open Summary Tables, select Tasks ► Describe ► 
Summary Tables from the menu bar (or Describe ► Summary Tables from above a Data Grid). A Summary Tables 
window, like the one pictured below, will open. The first thing you do in any task is assign variables to task roles by 
dragging variable names to the list of task roles. In this window, the variables Region and PopGroup have been 
assigned to serve as classification variables. 
 

 
 
The second thing you do in the Summary Tables task, is arrange your table. To do that, click the Summary Tables 

Data set displayed 
in Data Grid 

First drag variables 
to task roles 

Then Click 
Summary Tables 
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option in the selection pane on the left. 
 
In the Summary Tables page, you drag variables from the list of available variables to the area labeled Preview. To 
find out more about the Summary Tables task, you may want to read the paper, “Introduction to Summary Tables in 
SAS Enterprise Guide,” listed in the reference section at the end of this paper. 
 

 
 
Once you are satisfied with the arrangement of your table, click the Run button. SAS Enterprise Guide will run the 
task and display the results. 
 

 
 
To see the program generated by the task, click the Code tab above the results. You cannot edit the program 
generated by a task, but you can make a copy of the program and edit the copy. The quickest way to do this is to type 
something (anything, including a space or Enter) in the Program window.  
 

Drag variables 
to Preview area 
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A window will open asking if you want to create a copy of the code. Click the Yes button, and SAS Enterprise Guide 
will open a new Program window containing a copy of the code. 
 

 
 
The Process Flow now includes an icon labeled Code for Summary Tables. This is the copy of the code. You can 
edit the copy of the code. You can also use this code in Display Manager by cutting and pasting, or saving this code 
as an unembedded code file and opening it in Display Manager. 
 

 

Type something in 
Program window to 

make a copy 
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INSERTING CUSTOM CODE INTO THE PROGRAM GENERATED BY A TASK 
While you cannot edit the program generated by a task, it is possible to insert code into the program. To do that, 
reopen the task by double-clicking its icon in the Project Tree or the Process Flow. Then click the Preview code 
button in the lower left corner of the task window.  
 

 
 
A Code Preview window will open for that task. Click the Insert Code button.  
 

 
 
A User Code window will open displaying the code written by SAS Enterprise Guide. This window will show all the 
locations in the program where you can insert your own code. Find the place where you want to add code, and 
double-click the words <double-click to insert code>. 

Click  
Preview code 

button 

Click  
Insert code 
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An Enter User Code window will open. Type the code you want to insert and click OK. 
 

 
 
In the task window, click the Run button. SAS Enterprise Guide will run the task using the code you inserted. 
 

 

Double-click  
<double-click to insert code> 
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LINKING ICONS IN THE PROCESS FLOW 
Every program shown in this paper has used the World data set. However, looking at the Process Flow, you can see 
that task icons are automatically connected to the data they use, but program icons are not.  
 

 
 
You can add links to make relationships between data sets and programs more clear. To add a link, right-click the 
icon that you want at the beginning of the link (in this case, the World data set), and select Link item to from the pop-
up menu. 
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A Link window will open showing all the items to which you can link. Select one, and click OK.  
 

 
 
To add more links, repeat the process. Here is the process flow diagram with the World data set linked to each of the 
program icons. Notice that links you add use a dashed line instead of a solid line.  
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There is another reason why you may want to add links to your process flow. When you run a process flow, SAS 
Enterprise Guide executes it from upper-left to lower-right, following the branches of the process flow. You can use 
links to explicitly control the order in which items run. You can also rearrange icons by dragging and dropping them in 
the Process Flow window. 

ADDING NOTES 
As a programmer, you already know that it is important to use comments to document your work. Notes are text files 
that you can use to document your work. To add a note for an entire process flow, click the background of the 
Process Flow window and select File ► New ► Note from the menu bar. To add a note for a particular item in your 
project (such as a program or task), click its icon in the Project Tree or Process Flow window and select File ► New 
► Note from the menu bar. A Note window will open. You can type any text you want in this window.  
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LIBNAMES IN SAS ENTERPRISE GUIDE 
Up to this point, all the examples in this paper have referred to data sets using direct referencing such as  
 

PROC FREQ  DATA  = 'c:\EG Data\World'; 
   WHERE YearInd >= 1990; 
   TABLES Region; 

 
When SAS Enterprise Guide sees a reference like this, it dynamically assigns a libref with a name something like 
ECLIB000. That’s fine if you don’t need to specify any data engines or advanced options. But if your data are more 
complex, you may need more control. There are many ways to define a libref in SAS Enterprise Guide. Some of them 
are discussed below, starting with the most basic, and working to the most complex.  

PUTTING A LIBNAME STATEMENT IN YOUR CODE 
You can always write your own LIBNAME statements to create librefs just as you would in Display Manager. For the 
PROC FREQ example, you could use this: 
 

LIBNAME MyData 'c:\EG Data'; 
PROC FREQ DATA = MyData.World; 
   WHERE YearInd >= 1990; 
   TABLES Region; 

USING OPTIONS TO AUTOMATICALLY EXECUTE CODE 
There are several options that allow you to specify code that will be automatically executed every time you run 
something in SAS Enterprise Guide. If you frequently use the same libref, then this may save you a lot of trouble. 
Open the Options window by selecting Tools ► Options from the menu bar. In the selection pane on the left, click 
the SAS Programs option. In the SAS Programs page, check Insert custom SAS code before submitted code, 
and click the Edit button. 
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In the Edit window, type the code you want to be run automatically. This could be a LIBNAME statement, an 
OPTIONS statement, or any code that you want to be submitted every time you run anything in SAS Enterprise 
Guide. 
 

 

USING AN AUTOEXEC PROCESS FLOW TO AUTOMATICALLY EXECUTE CODE 
You can have only one project open at a time, but you can have multiple process flows in a single project. If you 
create a process flow and name it Autoexec, then SAS Enterprise Guide will automatically run that process flow every 
time you open the project. To create a new process flow, select File ► New ► Process Flow from the menu bar. 
Then right-click the name of that new process flow in the Project Tree and select Rename from the pop-up window.  
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Once you have created a new process flow and named it Autoexec, then you can put anything that you want in it. For 
example, you can open a Program window and type LIBNAME or OPTIONS statements. Then the next time you open 
that project, a window will open asking if you want to run the Autoexec process flow.  
 

 

RULES FOR VARIABLE NAMES 
By default, SAS Enterprise Guide uses the system option VALIDVARNAME = ANY (meaning that names must be 32 
characters or fewer in length, and can contain any character including blanks). In Display Manager the default is 
VALIDVARNAME = V7 which follows the standard rules for SAS names (32 characters or fewer in length, start with a 
letter or underscore, and contain only letters, numerals, or underscores). If you write a program that produces a SAS 
data set (such as PROC TRANSPOSE or PROC IMPORT), then the names of variables in that data set may be 
considerably different than variable names produced by the same exact code in Display Manager. Adding the 
statement 
 

OPTIONS VALIDVARNAME = V7; 
 
to your code will fix this. If you use this option often, you may want to run this statement automatically using an 
Autoexec process flow or the Options window as described above.  

FORMATTING CODE 
If you open a program and find that it is messy and hard to read, SAS Enterprise Guide can help with that. Just right-
click in the Program window and select Format Code from the pop-up window, and your program will be tidied up.  

CONVERTING A PROGRAM TO A PROCESS FLOW 
If you have a complex program, you may want to convert it to a process flow. First open the program. Then select 
Program ► Analyze ► Analyze for Program Flow from the menu bar. In the Analyze SAS Program window click 
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the Begin analysis button. SAS Enterprise Guide will identify each DATA and PROC step and the relationships 
between them. To create a process flow, click the Create process flow button.  

SPLITTING THE WORKSPACE 
By default, you see only one thing at a time in the workspace (one process flow, or one Program window, or one 

result). You can split the workspace to display two items. Click the down-arrow next to the icon of a screen  on 
the menu bar, and select either Stacked or Side By Side from the pull-down menu. Here is a workspace that has 
been split side-by-side with a program and results displayed.  
 

 

CONCLUSIONS 
SAS Enterprise Guide offers programmers a new way to write and run code. If you have never used SAS Enterprise 
Guide, it will take you a while to get used to the new environment. But once you learn how to use it, you may well 
decide to make SAS Enterprise Guide your primary SAS environment. 
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